ISX11.9G CM2380, ISX12 G CM2180/CM2380 EJ

Last Modified: 12 February 2020

Copyright © 2020
Cummins Inc.
All rights reserved


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

FAULT CODE 111

Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 111 PID: S254 SPN: 629 FMI: 12/12 LAMP: Red SRT: | Error internal to the engine control module (ECM) related to memory hardware malfunctions or internal ECM voltage supply circuits. | Engine may not start or may be difficult to start.
Engine Control Module (ECM)

Circuit Description

The ECM has internal diagnostics that continuously run and check the internal memory.

Component Location

The Engine Control Module (ECM) is mounted on the intake manifold side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a read or write error internal to the ECM.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

The engine may not start.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This fault code can only be caused by an internal ECM problem. Repairs are not possible for the ECM.

Refer to Troubleshooting Fault Code 111 .

Last Modified: 18-Jan-2020
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1117

Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1117 PID: S251 SPN: 3597 FMI: 2/2 LAMP: None SRT: | Supply voltage to the ECM fell below a calibrated limit momentarily, or the ECM was not allowed to power down correctly. | None on performance.
Engine Control Module (ECM) Battery Power Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the ECM power supply was removed before power-down parameters could be saved. The fault code will be active when the keyswitch is turned ON following the incomplete power-down event.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Power-down data like trip information, maintenance monitor, and fault information will not get saved to permanent memory when the keyswitch is turned OFF.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine, let it idle for 1 minute, and then shutdown the engine.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter. If unswitched power is coming from the starter, it is possible for the battery voltage to drop low enough during cranking to set this fault active.This fault can also be caused by resistance in the ECM battery supply (+) or (-) circuits. Resistance in these circuits can cause the voltage level at the ECM input to drop low enough to set Fault Code 1117 active. Use of battery disconnect switches to turn off the engine or any device that disconnects battery voltage to the ECM within 10 seconds of turning the keyswitch OFF can cause damage to the aftertreatment system. The vehicle should not be operated with an active Fault Code 1117.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1117 .

Last Modified: 18-Jan-2020


Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

FAULT CODE 115

Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 115 PID: P190 SPN: 612 FMI: 2/2 LAMP: Red SRT: | The ECM has detected the primary and backup speed sensor signals are connected backwards. | The engine will shut down or will not start.
Engine Speed Sensor Circuit

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position and camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankshaft position and camshaft position signal inputs to the ECM are reversed.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Exhaust gas recirculation (EGR) valve operation will be disabled.

  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates the crankshaft position sensor and the camshaft position sensor wiring harness connectors are reversed. As a result, the engine will not start.

Possible causes of this fault code include:

Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness

Damage to the sensor target teeth or tone wheel.

If the fault code is intermittent, inspect the ECM connector, wiring harness, and harness connectors for loose pins and bad connections. Look closely for loose wire connections that can cause an intermittent short to ground or open circuit in the wiring harness or connectors. It may help to wiggle the harness and harness connections and watch for fault code state changes.

Refer to Troubleshooting Fault Code 115 .

Last Modified: 18-Jan-2020


Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 122

Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 122 PID: P102 SPN: 102 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the intake manifold pressure circuit. | Possible reduced engine performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value of the intake manifold pressure reading is used.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.

Exhaust gas recirculation (EGR) valve operation will be disabled.

  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The intake manifold pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 122, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor

Signal wire shorted to sensor supply or battery voltage.

Malfunctioning intake manifold pressure/temperature sensor

Refer to Troubleshooting Fault Code 122 .

Last Modified: 18-Jan-2020


Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 123

Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 123 PID: P102 SPN: 102 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage or open circuit detected at the intake manifold pressure circuit. | Possible reduced engine performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value of the intake manifold pressure reading is used.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The intake manifold pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 123, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.

Malfunctioning intake manifold pressure/temperature sensor

Refer to Troubleshooting Fault Code 123 .

Last Modified: 18-Jan-2020


Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1239

Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1239 PID: S385 SPN: 2623 FMI: 3/3 LAMP: Amber SRT: | High voltage detected at accelerator pedal position number 2 signal circuit. | The system will operate in Limp Home mode.
Accelerator Pedal or Lever Position Sensor 2 Circuit

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the throttle pedal signal voltage was greater than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors should be installed. If troubleshooting an intermittent accelerator problem, the accelerator pedal position sensor 2 signal voltage can be monitored with the recommended Cummins® electronic service tool or equivalent, while flexing the harness to locate the intermittent connection.

Possible causes of this fault code include:

Accelerator pedal position 2 signal circuit shorted to battery or 5-VDC supply

Open accelerator pedal return circuit in the harness or connections

Accelerator supply shorted to battery

Damaged accelerator pedal position sensor.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1239 .

Last Modified: 18-Jan-2020


Intake Manifold 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 124

Intake Manifold 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 124 PID: P102 SPN: 102 FMI: 0/16 LAMP: Amber SRT: | Intake manifold pressure is above the maximum operating limit. | Possible reduced engine performance.
Intake Manifold 1 Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure reading was higher than expected for the engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value of the intake manifold pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The engine intake manifold pressure/temperature sensor monitors pressure in the intake manifold. This fault is set active when the intake manifold pressure is too high for the current engine operating conditions. The current engine operating conditions are calculated, based on input from various engine sensors. A malfunction of one of these inputs can affect the calculated value and cause Fault Code 124 to become active.

Refer to Troubleshooting Fault Code 124 .

Last Modified: 18-Jan-2020


Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1241

Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1241 PID: S385 SPN: 2623 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at accelerator pedal position number 2 signal circuit. | The engine will operate in Limp Home mode.
Accelerator Pedal or Lever Position Sensor 2 Circuit

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the throttle pedal signal voltage was less than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors should be installed. If troubleshooting an intermittent accelerator problem, the accelerator pedal position sensor 2 signal voltage can be monitored with the recommended Cummins® electronic service tool or equivalent, while flexing the harness to locate the intermittent connection.

Possible causes of this fault code include:

Accelerator pedal position signal shorted to engine ground or return wires in the harness or sensor

Damaged accelerator pedal position sensor

Open circuit in the accelerator signal, supply, or return wire in the harness or connectors.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1241 .

Last Modified: 18-Jan-2020


Accelerator Pedal or Lever Position Sensor 1 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1242

Accelerator Pedal or Lever Position Sensor 1 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1242 PID: P91 SPN: 91 FMI: 2/2 LAMP: Red SRT: | Accelerator position sensor number 1 and number 2 are reading different values. | Engine will only idle.
Accelerator Pedal or Lever Position Sensor Circuits

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the values between the accelerator position sensor 1 and accelerator position sensor 2 differ by more than 10 percent

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will have limp-home throttle control only.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors should be installed.This fault code becomes active when the accelerator position sensor number 1 and accelerator position sensor number 2 are not reading the same value.Possible causes of the fault include:

Damaged accelerator pedal position sensor number 1 or damaged accelerator pedal position sensor number 2

Accelerator pedal position sensor number 1 and accelerator pedal position sensor number 2 signal wires are shorted together.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1242 .

Last Modified: 18-Jan-2020


Intake Manifold 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 125

Intake Manifold 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 125 PID: P102 SPN: 102 FMI: 1/18 LAMP: Amber SRT: | Intake manifold pressure is below the minimum operating limit. | Possible reduced engine performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure reading was below the expected level for the engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value of the intake manifold pressure reading is used.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The intake manifold 1 pressure sensor monitors pressure in the intake manifold. This fault is set active when the intake manifold pressure is too low for the present engine operating conditions.

The compressor outlet pressure is also known as the Engine throttle intake pressure

Possible causes of this fault code include:

Leaks in the air intake system between the turbocharger and intake manifold

A damaged intake manifold pressure sensor

Restriction in the charge-air cooler

Refer to Troubleshooting Fault Code 125 .

Last Modified: 18-Jan-2020


Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 131

Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 131 PID: P91 SPN: 91 FMI: 3/3 LAMP: Red SRT: | High voltage detected at accelerator pedal position number 1 circuit. | The engine will operate in Limp Home mode.
Accelerator Pedal or Lever Position Sensor Circuit

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the accelerator pedal signal voltage was out of range high.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If troubleshooting an intermittent accelerator problem:

Accelerator pedal or lever position signal circuit shorted to battery or (+) 5 volt supply

Open accelerator pedal return circuit in the harness or connections

Accelerator supply shorted to battery

Malfunctioning accelerator pedal or lever position sensor.

NOTE: The three wires in the accelerator position sensor circuit must be twisted together.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 131 .

Last Modified: 18-Jan-2020


Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 132

Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 132 PID: P91 SPN: 91 FMI: 4/4 LAMP: Red SRT: | Low voltage detected at accelerator pedal position number 1 signal circuit. | The engine will operate in Limp Home mode.
Accelerator Pedal or Lever Position Sensor Circuit

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the accelerator pedal signal voltage was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors should be installed. If troubleshooting an intermittent accelerator problem, the accelerator pedal position sensor 2 signal voltage can be monitored with the recommended Cummins® electronic service tool or equivalent, while flexing the harness to locate the intermittent connection.

The accelerator pedal or lever position sensor signal voltage can be monitored with the recommended Cummins® electronic service tool or equivalent, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by the recommended Cummins® electronic service tool or equivalent.

Possible causes of this fault code include:

Accelerator pedal or lever position signal shorted to engine ground or return wires in the OEM harness or sensor

Damaged accelerator pedal or lever position sensor

Open circuit in the accelerator signal, supply, or return wire in the harness or connectors.

NOTE: The three wires in the accelerator position sensor circuit must be twisted together.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 132 .

Last Modified: 18-Jan-2020


Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 133

Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 133 PID: P372 SPN: 974 FMI: 3/3 LAMP: Red SRT: | High signal voltage detected at remote accelerator position signal circuit. | Remote accelerator will not operate.
Remote Accelerator Pedal Position Sensor Circuit

Circuit Description

The remote accelerator position sensor is a potentiometer attached to the remote accelerator lever. The remote accelerator position sensor varies the signal voltage to the engine control module (ECM) as the remote accelerator lever is depressed and released. Low signal voltage is received by the ECM when the remote accelerator lever is at 0 percent. A high signal voltage is received by the ECM when the remote accelerator is at 100 percent. The remote accelerator pedal position circuit contains a remote accelerator pedal position 5 volt supply, remote accelerator pedal position return, and remote accelerator pedal position signal.

Component Location

The remote accelerator pedal or lever location varies with each original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the remote accelerator pedal signal voltage was greater than 4.37-VDC for more than 20 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If troubleshooting an intermittent accelerator problem:

The remote accelerator pedal or lever position sensor signal voltage can be monitored with the recommended Cummins® electronic service tool or equivalent, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by the recommended Cummins® electronic service tool or equivalent.

Possible causes of this fault code include:

Remote accelerator pedal or lever position signal circuit shorted to battery or (+) 5 volt supply

Open remote accelerator pedal or lever return circuit in the harness or connections

Remote accelerator supply shorted to battery

Malfunctioned remote accelerator pedal or lever position sensor.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 133 .

Last Modified: 18-Jan-2020


Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 134

Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 134 PID: P372 SPN: 974 FMI: 4/4 LAMP: Red SRT: | Low voltage detected at remote accelerator position signal circuit. | Remote accelerator will not operate.
Remote Accelerator Pedal Position Sensor Circuit

Circuit Description

The remote accelerator position sensor is a potentiometer attached to the remote accelerator lever. The remote accelerator position sensor varies the signal voltage to the engine control module (ECM) as the remote accelerator lever is depressed and released. Low signal voltage is received by the ECM when the remote accelerator lever is at 0 percent. A high signal voltage is received by the ECM when the remote accelerator is at 100 percent. The remote accelerator pedal position circuit contains a remote accelerator pedal position 5 volt supply, remote accelerator pedal position return, and remote accelerator pedal position signal.

Component Location

The remote accelerator pedal or lever location varies with each original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the remote accelerator pedal signal voltage less than 0.132-VDC for more than 20 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If troubleshooting an intermittent accelerator problem:

The remote accelerator pedal or lever position sensor signal voltage can be monitored with the recommended Cummins® electronic service tool or equivalent, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by the recommended Cummins® electronic service tool or equivalent.

Possible causes of this fault code include:

Remote accelerator pedal or lever position signal shorted to engine ground or return wires in the OEM harness or sensor

Damaged remote accelerator pedal or lever position sensor

Open circuit in the remote accelerator signal, supply, or return wire in the harness or connectors.

NOTE: The three wires in the remote accelerator position sensor circuit must be twisted together.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 134 .

Last Modified: 18-Jan-2020


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 135

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: P100 SPN: 100 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the engine oil pressure circuit. | None on performance.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

An engine oil pressure switch or oil pressure sensor is used by the engine control module (ECM) to monitor the lubricating oil pressure. For engines with an oil pressure switch, the switch is normally closed when the engine is not running and open when oil pressure is present. For engines with an oil pressure sensor, the ECM will detect a low signal voltage at operating conditions when the oil pressure is low. The ECM will detect a high signal voltage at operating conditions when the oil pressure is high.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

A default value for the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A pin-to-pin short circuit

  • A signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code 135 .

Last Modified: 18-Jan-2020


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 141

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: P100 SPN: 100 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage or open circuit detected at the engine oil pressure circuit. | None on performance.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

An engine oil pressure switch or oil pressure sensor is used by the engine control module (ECM) to monitor the lubricating oil pressure. For engines with an oil pressure switch, the switch is normally closed when the engine is not running and open when oil pressure is present. For engines with an oil pressure sensor, the ECM will detect a low signal voltage at operating conditions when the oil pressure is low. The ECM will detect a high signal voltage at operating conditions when the oil pressure is high.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

A default value for the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Supply wire open or shorted to ground.

Does the fault occur only in cold weather? If so, allow the oil to warm up and see if the fault goes inactive.

Refer to Troubleshooting Fault Code 141 .

Last Modified: 18-Jan-2020


Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 143

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 143 PID: P100 SPN: 100 FMI: 1/18 LAMP: Amber SRT: | Engine oil pressure signal indicates engine oil pressure is below the engine protection warning limit. | Possible reduced engine performance.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

An engine oil pressure switch or oil pressure sensor is used by the engine control module (ECM) to monitor the lubricating oil pressure. For engines with an oil pressure switch, the switch is normally closed when the engine is not running and open when oil pressure is present. For engines with an oil pressure sensor, the ECM will detect a low signal voltage at operating conditions when the oil pressure is low. The ECM will detect a high signal voltage at operating conditions when the oil pressure is high.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure was less than the engine protection limits for more than 5 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code goes active when the engine oil pressure drops below the engine protection limit. Troubleshoot the engine for low oil pressure.

Possible causes of this fault code include:

Low oil pressure

Incorrect oil level

Damaged oil pressure switch

Engine harness shorted to ground.

Refer to Troubleshooting Fault Code 143 .

Last Modified: 18-Jan-2020


Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 144

Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: P110 SPN: 110 FMI: 3/3 LAMP: Amber SRT: | High signal voltage or open circuit detected at engine coolant temperature circuit. | Fan will stay ON if controlled by the engine control module (ECM).
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value is used for the engine coolant temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The engine coolant temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Before troubleshooting Fault Code 144, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.

Malfunctioning engine coolant temperature sensor

Refer to Troubleshooting Fault Code 144 .

Last Modified: 18-Jan-2020


Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 145

Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: P110 SPN: 110 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at engine coolant temperature circuit. | None on performance. Fan will stay ON if controlled by the engine control module (ECM).
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value is used for the engine coolant temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The engine coolant temperature sensor shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active. Before troubleshooting Fault Code 145, check for multiple fault codes.

Possible causes of this fault code include:

Signal shorted to ground in the harness

Signal shorted to return or ground in the sensor.

Malfunctioning engine coolant temperature sensor

Refer to Troubleshooting Fault Code 145 .

Last Modified: 18-Jan-2020


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 146

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 146 PID: P110 SPN: 110 FMI: 0/16 LAMP: Amber SRT: | Engine coolant temperature is above the engine protection warning limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was greater than a calibrated limit.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limit for high coolant temperature. Refer to Engine Coolant Temperature Above Normal symptom troubleshooting tree in the applicable engine service manual.

Refer to Troubleshooting Fault Code 146 .

Last Modified: 18-Jan-2020


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 151

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 151 PID: P110 SPN: 110 FMI: 0/0 LAMP: Red SRT: | Engine coolant temperature is above the engine protection warning limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was greater than the engine protection limit.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The torque output of the engine will be reduced.

Maximum engine operating speed will be decreased.

The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature.

Refer to Troubleshooting Fault Code 151 .

Last Modified: 18-Jan-2020


Accelerator Pedal Position 1 - Received Network Data in Error

FAULT CODE 1515

Accelerator Pedal Position 1 - Received Network Data in Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1515 PID: P91 SPN: 91 FMI: 2/19 LAMP: Red SRT: | The J1939 multiplexing controller has indicated a malfunction of the multiplexed accelerator pedal. | Engine will only idle.
SAE J1939 Multiplexing Remote Accelerator Pedal or Lever

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The OEM VECU determined that there was a malfunction of the multiplexed accelerator pedal or lever sensor system.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The J1939 multiplexing controller has indicated a malfunction of the multiplexed accelerator pedal.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and data link communication issues with aftertreatment components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing, or intermittent connections.

Refer to Troubleshooting Fault Code 1515 .

Last Modified: 01-Apr-2021


Engine Intake Manifold 1 Temperature - Voltage Above Normal or Shorted to High Source

FAULT CODE 153

Engine Intake Manifold 1 Temperature - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 PID: P105 SPN: 105 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at intake manifold air temperature circuit. | Fan will stay ON if controlled by the engine control module (ECM).
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for the intake manifold temperature reading.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • Engine coolant temperature must read above 0°C [32°F].
  • Turbocharger compressor intake air temperature and intake manifold air temperature are greater than 5Â°C [41Â°F].
  • The engine operating state is run for greater than 120 seconds.

Shop Talk

The intake manifold temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check fault codes with multiple counts first.

Possible causes of this fault code include:

  • Malfunctioning intake manifold pressure/temperature sensor

Signal circuit shorted to return or ground in the sensor

A signal shorted to ground in the harness

  • Open return circuit in the harness, connectors, or sensor
Refer to Troubleshooting Fault Code 153 .

Last Modified: 01-Apr-2021


Engine Intake Manifold 1 Temperature - Voltage Below Normal or Shorted to Low Source

FAULT CODE 154

Engine Intake Manifold 1 Temperature - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 154 PID: P105 SPN: 105 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at intake manifold air temperature circuit. | Possible reduced engine performance. Fan will stay ON if controlled by the engine control module (ECM).
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for the intake manifold temperature reading.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • The engine operating state is run for greater than 120 seconds.
  • Engine coolant temperature must read above 0°C [32°F].
  • Turbocharger compressor intake air temperature and intake manifold air temperature are greater than 5Â°C [41Â°F].

Shop Talk

The intake manifold temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check fault codes with multiple counts first.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor.
  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 154 .

Last Modified: 01-Apr-2021


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 155

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 155 PID: P105 SPN: 105 FMI: 0/0 LAMP: Red SRT: | Intake manifold air temperature signal indicates intake manifold air temperature above engine protection critical limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manfiold air temperature was greater than the engine protection limit.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The torque output of the engine will be reduced.

Maximum engine operating speed will be decreased.

The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The intake manifold air temperature sensor measures the temperature of the charge-air as it passes through the intake manifold.

Possible causes of this fault code include:

Restricted air flow through the charge-air cooler

Undersized charge-air cooler

High turbocharger compressor outlet temperature.

Refer to Troubleshooting Fault Code 155 .

Last Modified: 18-Jan-2020


Engine Misfire Cylinder 1 - Condition Exists

FAULT CODE 1654

Engine Misfire Cylinder 1 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1654 PID: SPN: 1323 FMI: 11/31 LAMP: Amber SRT: | Engine misfire has been detected in cylinder number 1. | Possible reduced engine performance.
Ignition Timing Signal Circuit

Circuit Description

Engine misfire means lack of combustion in the cylinder due to poor fuel metering, poor compression, or any other cause. This diagnostic is designed to detect engine misfires by looking at the exhaust manifold pressure (EMP) signal. The Exhaust Pressure signal is monitored during the combustion state of each cylinder individually. A cylinder with a poor exhaust signal determines a misfire.

Component Location

The ICM is located above the ECM on the intake side of the engine near the fuel control housing.

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a cylinder 1 misfire.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Physical damage to the tip of the spark plug and/or aluminum deposits can indicate a damaged piston.

Causes of cylinder misfire can include:

  • Spark plugs past maintenance intervals
  • Malfunctioning or damaged spark plugs.
  • Malfunctioning or damaged ignition coil.
  • Malfunctioning or damaged ignition wiring harness.
  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged overhead component.
  • Overhead component out of adjustment.
Refer to Troubleshooting Fault Code 1654 .

Last Modified: 02-Aug-2021


Engine Misfire Cylinder 2 - Condition Exists

FAULT CODE 1655

Engine Misfire Cylinder 2 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1655 PID: SPN: 1324 FMI: 11/31 LAMP: Amber SRT: | Engine misfire has been detected in cylinder number 2. | Possible reduced engine performance.
Ignition Timing Signal Circuit

Circuit Description

Engine misfire means lack of combustion in the cylinder due to poor fuel metering, poor compression, or any other cause. This diagnostic is designed to detect engine misfires by looking at the exhaust manifold pressure (EMP) signal. The Exhaust Pressure signal is monitored during the combustion state of each cylinder individually. A cylinder with a poor exhaust signal determines a misfire.

Component Location

Cylinder number 1 is located at the front of the engine where the gear housing is mounted and cylinder number 6 is located at the rear of the engine where the flywheel housing is mounted.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a cylinder 2 misfire.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Physical damage to the tip of the spark plug and/or aluminum deposits can indicate a damaged piston.

Causes of cylinder misfire can include:

  • Spark plugs past maintenance intervals
  • Malfunctioning or damaged spark plugs.
  • Malfunctioning or damaged ignition coil.
  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged overhead component.
  • Overhead component out of adjustment.
Refer to Troubleshooting Fault Code 1655 .

Last Modified: 02-Aug-2021


Engine Misfire Cylinder 3 - Condition Exists

FAULT CODE 1656

Engine Misfire Cylinder 3 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1656 PID: SPN: 1325 FMI: 11/31 LAMP: Amber SRT: | Engine misfire has been detected in cylinder number 3. | Possible reduced engine performance.
Ignition Timing Signal Circuit

Circuit Description

Engine misfire means lack of combustion in the cylinder due to poor fuel metering, poor compression, or any other cause. This diagnostic is designed to detect engine misfires by looking at the exhaust manifold pressure (EMP) signal. The Exhaust Pressure signal is monitored during the combustion state of each cylinder individually. A cylinder with a poor exhaust signal determines a misfire.

Component Location

Cylinder number 1 is located at the front of the engine where the gear housing is mounted and cylinder number 6 is located at the rear of the engine where the flywheel housing is mounted.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a cylinder 3 misfire.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Physical damage to the tip of the spark plug and/or aluminum deposits can indicate a damaged piston.

Causes of cylinder misfire can include:

  • Spark plugs past maintenance intervals
  • Malfunctioning or damaged spark plugs.
  • Malfunctioning or damaged ignition coil.
  • Malfunctioning or damaged ignition wiring harness.
  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged overhead component.
  • Overhead component out of adjustment.
Refer to Troubleshooting Fault Code 1656 .

Last Modified: 02-Aug-2021


Engine Misfire Cylinder 4 - Condition Exists

FAULT CODE 1657

Engine Misfire Cylinder 4 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1657 PID: SPN: 1326 FMI: 11/31 LAMP: Amber SRT: | Engine misfire has been detected in cylinder number 4. | Possible reduced engine performance.
Ignition Timing Signal Circuit

Circuit Description

Engine misfire means lack of combustion in the cylinder due to poor fuel metering, poor compression, or any other cause. This diagnostic is designed to detect engine misfires by looking at the exhaust manifold pressure (EMP) signal. The Exhaust Pressure signal is monitored during the combustion state of each cylinder individually. A cylinder with a poor exhaust signal determines a misfire.

Component Location

Cylinder number 1 is located at the front of the engine where the gear housing is mounted and cylinder number 6 is located at the rear of the engine where the flywheel housing is mounted.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a cylinder 4 misfire.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Physical damage to the tip of the spark plug and/or aluminum deposits can indicate a damaged piston.

Causes of cylinder misfire can include:

  • Spark plugs past maintenance intervals
  • Malfunctioning or damaged spark plugs.
  • Malfunctioning or damaged ignition coil.
  • Malfunctioning or damaged ignition wiring harness.
  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged overhead component.
  • Overhead component out of adjustment.
Refer to Troubleshooting Fault Code 1657 .

Last Modified: 02-Aug-2021


Engine Misfire Cylinder 5 - Condition Exists

FAULT CODE 1658

Engine Misfire Cylinder 5 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1658 PID: SPN: 1327 FMI: 11/31 LAMP: Amber SRT: | Engine misfire has been detected in cylinder number 5. | Possible reduced engine performance.
Ignition Timing Signal Circuit

Circuit Description

Engine misfire means lack of combustion in the cylinder due to poor fuel metering, poor compression, or any other cause. This diagnostic is designed to detect engine misfires by looking at the exhaust manifold pressure (EMP) signal. The Exhaust Pressure signal is monitored during the combustion state of each cylinder individually. A cylinder with a poor exhaust signal determines a misfire.

Component Location

Cylinder number 1 is located at the front of the engine where the gear housing is mounted and cylinder number 6 is located at the rear of the engine where the flywheel housing is mounted.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a cylinder 5 misfire.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Physical damage to the tip of the spark plug and/or aluminum deposits can indicate a damaged piston.

Causes of cylinder misfire can include:

  • Spark plugs past maintenance intervals
  • Malfunctioning or damaged spark plugs.
  • Malfunctioning or damaged ignition coil.
  • Malfunctioning or damaged ignition wiring harness.
  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged overhead component.
  • Overhead component out of adjustment.
Refer to Troubleshooting Fault Code 1658 .

Last Modified: 02-Aug-2021


Engine Misfire Cylinder 6 - Condition Exists

FAULT CODE 1659

Engine Misfire Cylinder 6 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1659 PID: SPN: 1328 FMI: 11/31 LAMP: Amber SRT: | Engine misfire has been detected in cylinder number 6. | Possible reduced engine performance.
Ignition Timing Signal Circuit

Circuit Description

Engine misfire means lack of combustion in the cylinder due to poor fuel metering, poor compression, or any other cause. This diagnostic is designed to detect engine misfires by looking at the exhaust manifold pressure (EMP) signal. The Exhaust Pressure signal is monitored during the combustion state of each cylinder individually. A cylinder with a poor exhaust signal determines a misfire.

Component Location

Cylinder number 1 is located at the front of the engine where the gear housing is mounted and cylinder number 6 is located at the rear of the engine where the flywheel housing is mounted.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a cylinder 6 misfire.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Physical damage to the tip of the spark plug and/or aluminum deposits can indicate a damaged piston.

Causes of cylinder misfire can include:

  • Spark plugs past maintenance intervals
  • Malfunctioning or damaged spark plugs.
  • Malfunctioning or damaged ignition coil.
  • Malfunctioning or damaged ignition wiring harness.
  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged overhead component.
  • Overhead component out of adjustment.
Refer to Troubleshooting Fault Code 1659 .

Last Modified: 02-Aug-2021


Aftertreatment Exhaust Gas Temperature 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1665

Aftertreatment Exhaust Gas Temperature 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1665 PID: S326 SPN: 3241 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Exhaust Gas Temperature 1 Circuit - Voltage Below Normal or Shorted to Low Source | None on performance.
Aftertreatment Exhaust Gas Temperature Sensor Circuit

Circuit Description

The aftertreatment exhaust gas temperature sensor is used by the engine control module (ECM) to monitor the engine exhaust temperature in the aftertreatment system. The aftertreatment exhaust gas temperature sensor is a thermistor and changes resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

Component Location

The aftertreatment exhaust gas temperature sensor is located in the aftertreatment system. It is located at the outlet of the aftertreatment catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continouosly after the engine has been running for 2 minutes.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor circuit was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the exhaust gas temperature reading is used.

Engine torque may be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair:
  • Engine coolant temperature must read above 0°C [32°F].
  • Turbocharger compressor intake air temperature and intake manifold air temperature are greater than 5Â°C [41Â°F].
  • The engine operating state is run for greater than 120 seconds.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A signal shorted to ground in the harness

A signal shorted to return or ground in the sensor.

Malfunctioning sensor

Refer to Troubleshooting Fault Code 1665 .

Last Modified: 18-Jan-2020


Aftertreatment Exhaust Gas Temperature 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1666

Aftertreatment Exhaust Gas Temperature 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1666 PID: S326 SPN: 3241 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Exhaust Gas Temperature 1 Circuit - Voltage Above Normal or Shorted to High Source. | None on performance.
Aftertreatment Exhaust Gas Temperature Sensor Circuit

Circuit Description

The aftertreatment exhaust gas temperature sensor is used by the engine control module (ECM) to monitor the engine exhaust temperature in the aftertreatment system. The aftertreatment exhaust gas temperature sensor is a thermistor and changes resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

Component Location

The aftertreatment exhaust gas temperature sensor is located in the aftertreatment system. It is located at the outlet of the aftertreatment catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously after the engine has been running for 2 minutes.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor circuit was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair:
  • Engine coolant temperature must read above 0°C [32°F].
  • Turbocharger compressor intake air temperature and intake manifold air temperature are greater than 5°C [41°F].
  • The engine operating state is run for greater than 120 seconds.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning sensor
Refer to Troubleshooting Fault Code 1666 .

Last Modified: 31-Oct-2021


Aftertreatment Exhaust Gas Temperature 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1674

Aftertreatment Exhaust Gas Temperature 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1674 PID: S327 SPN: 3249 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the catalyst outlet temperature sensor circuit. | None on performance.
Aftertreatment Exhaust Gas Temperature Sensor Circuit

Circuit Description

The aftertreatment temperature sensors are used by the engine control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or low temperature. When the exhaust gas temperature is hot, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The aftertreatment exhaust gas temperature sensor module is located on the aftertreatment catalyst.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the following conditions are met:

The engine is running.

Coolant temperature is greater than 80°C [176°F].

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment exhaust gas temperature sensor 2 signal voltage is greater than 4.97-VDC for more than 1 second

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • Turn the key switch OFF and allow the ECM to completely powerdown.
  • To Validate the repair, perform a key cycle, start the engine and let it idle for 10 minutes.
  • To validate the repair, it may be necessary to operate the vehicle on a chassis dynamometer or to drive the vehicle in order to get the engine load high enough for the diagnostic to run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Verify that the ECM calibration is correct. Check the calibration revision history found on QuickServeâ„¢ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM.

Possible causes of this fault code include:

Signal shorted to ground in the harness

Signal shorted to return or ground in the sensor

  • The resistance of the sensor varies with temperature. The reading observed should compare to the following table if the sensor is functioning properly.
Refer to Troubleshooting Fault Code 1674 .

Last Modified: 18-Jan-2020


Aftertreatment Exhaust Gas Temperature 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1675

Aftertreatment Exhaust Gas Temperature 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1675 PID: S327 SPN: 3249 FMI: 3/3 LAMP: Amber SRT: | Low signal voltage detected at the catalyst outlet temperature sensor circuit. | None on performance.
Aftertreatment Exhaust Gas Temperature Sensor Circuit

Circuit Description

The aftertreatment temperature sensors are used by the engine control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or a low temperature.When the exhaust gas temperature is high, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore,the ECM senses a low signal voltage, or a high temperature.

Component Location

The aftertreatment exhaust gas temperature sensor module is located on the aftertreatment catalyst.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the following conditions are met:

The engine is running.

Coolant temperature is greater than 80°C [176°F].

Conditions for Setting the Fault Codes

The ECM detects that the aftertreatment exhaust gas temperature sensor 2 signal voltage is greater than 4.97-VDC for more than 1 second

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • Turn the key switch OFF and allow the ECM to completely powerdown.
  • To Validate the repair, perform a key cycle, start the engine and let it idle for 10 minutes.
  • The engine operating state is run for greater than 120 seconds.
  • Engine coolant temperature must read above 0°C [32°F].
  • Turbocharger compressor intake air temperature and intake manifold air temperature are greater than 5Â°C [41Â°F].
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The aftertreatment exhaust gas temperature sensor 2 shares return wires in the original equipment manufacturer (OEM) harness with other sensors. A shorted return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code 1675 .

Last Modified: 18-Jan-2020


Aftertreatment 1 Diesel Oxidation Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 1691

Aftertreatment 1 Diesel Oxidation Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1691 PID: S380 SPN: 5298 FMI: 1/18 LAMP: Amber SRT: | The temperature increase across the aftertreatment diesel oxidation catalyst is lower than expected. | Possible reduced engine performance. Possible frequent need for aftertreatment regeneration.
Engine Throttle Intake Pressure sensor

Circuit Description

The engine control module (ECM) uses these sensors to determine the composition of the exhaust gas so that fueling can be adjusted to maintain desired air/fuel ratio while operating in closed loop. The heater circuit is powered by the ECM to maintain proper temperature at the sensing tip. The ECM also uses these sensors to detect if the aftertreatment catalyst is missing or damaged.

Component Location

The Aftertreatment Intake oxygen sensor is located in the exhaust system, after the turbocharger turbine outlet.

Conditions for Running the Diagnostics

The engine coolant temperature and catalyst temperature must be above a calibrated value. After driving above a calibrated speed, the test will run when the unit comes to a complete stop without touching the accelerator pedal.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detects that the aftertreatment catalyst conversion efficiency is below a threshold.

Action Taken When the Fault Code is Active

For On-Board Diagnostic (OBD) engines, the ECM illuminates the the Malfunction Indicator Lamp (MIL) immediately after three consecutive trips in which the diagnostic runs and fails.

The ECM will illuminate the MAINTENANCE lamp during the key cycle after the diagnostic runs and fails.

  • This fault code may cause possible derate related fault code to become active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.

Shop Talk

The aftertreatment system must be inspected after making the appropriate repair outlined in this fault code troubleshooting tree. Progressive damage to the aftertreatment system may have occurred. Remove the exhaust aftertreatment system from the vehicle to inspect it for potential damage and reuse. Refer to the OEM service manual.

Possible causes of this fault code include:

Engine oil or fuel contamination of the aftertreatment diesel oxidation catalyst

Missing Catalyst

Refer to Troubleshooting Fault Code 1691 .

Last Modified: 18-Jan-2020


Sensor Supply 5 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1695

Sensor Supply 5 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1695 PID: S232 SPN: 3513 FMI: 3/3 LAMP: Amber SRT: | High voltage detected at sensor supply number 5 circuit in the OEM harness. | The engine will operate in Limp Home mode.
Sensor Supply 5 Circuit

Circuit Description

The sensor supply 5 provides a 5 volt supply to the remote accelerator, engine coolant level sensor, and the accelerator position sensor 2. The remote accelerator is an optional original equipment manufacturer (OEM) component.

Component Location

Sensor Supply 5 originates in the OEM connector portion of the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 5 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The engine will have limp-home throttle control only.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

High voltage on the 5-VDC supply wire can be caused by a short circuit to a power supply, a damaged sensor, or a damaged ECM power supply.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1695 .

Last Modified: 18-Jan-2020


Sensor Supply 5 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1696

Sensor Supply 5 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1696 PID: S232 SPN: 3513 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at sensor supply number 5 circuit in the OEM harness. | The engine will operate in Limp Home mode.
Sensor Supply 5 Circuit

Circuit Description

The sensor supply 5 provides a 5 volt supply to the remote accelerator, engine coolant level sensor, and the accelerator position sensor 2. The remote accelerator is an optional original equipment manufacturer (OEM) component.

Component Location

Sensor Supply 5 originates in the OEM connector portion of the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 5 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The engine will have limp-home throttle control only.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Low voltage on the 5 volt supply wire can be caused by a short circuit to ground in a supply wire, a short circuit between a supply wire and a return wire, a damaged sensor, or a damaged ECM power supply.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1696 .

Last Modified: 18-Jan-2020


Engine Misfire for Multiple Cylinders - Condition Exists

FAULT CODE 1718

Engine Misfire for Multiple Cylinders - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1718 PID: SPN: 1322 FMI: 11/31 LAMP: Amber SRT: | Engine misfire has been detected in multiple cylinder numbers. | Possible reduced engine performance.
Ignition System Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

The ICM is located next to the ECM on the intake side of the engine, near the flywheel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a misfire of two or more cylinders.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

WARNING: The ignition system produces high voltage. To reduce the possibility of personal injury from electrical shock, do not touch any ignition wires or components while the engine is operating. Always use suitably insulated tools.

If the ECM does not receive a signal on the secondary return wire after a cylinder has been commanded to fire, the ECM will log this as a misfire. In addition to the three misfire faults for each cylinder, misfire percentages are also calculated over all six cylinders. There are three levels of severity for misfire on multiple cylinders.

Causes of cylinder misfire can include:

Spark plugs past maintenance intervals

Damaged spark plugs

Malfunctioning Engine Ignition Coil

Shorted or open ignition harness

All secondary return wires in the ignition harness are tied together. This way there will be continuity through each secondary return pin of each coil to the main secondary return wire at the ignition harness connector 2. If one of the secondary return wires is found to be open, then the ICM will think that the engine is misfiring when it is not.

Physical damage to the tip of the spark plug and/or aluminum deposits can indicate a damaged piston.

Refer to Troubleshooting Fault Code 1718 .

Last Modified: 18-Jan-2020


Electronic Throttle Control Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 176

Electronic Throttle Control Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 176 PID: SPN: 3464 FMI: 4/4 LAMP: Red SRT: | A short circuit to ground has been detected in the engine intake air throttle actuator signal circuit. | Possible reduced engine performance.
Engine Intake Air Throttle Actuator Circuit

Circuit Description

The electronic control module (ECM) controls the engine throttle actuator, which is both an input and output device. There are two throttle position sensors located inside the engine throttle actuator and they share a common supply and return. The engine throttle actuator receives 5 volt supply voltage from the sensor supply 1. The ECM controls the position of the throttle across the engine throttle actuator (+) line.

Component Location

The engine throttle actuator is located between the air intake adapter and the fuel control housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and during cranking.

Conditions for Setting the Fault Codes

The ECM will log this fault if the sensed throttle position is greater than or less than commanded throttle position by a calibrated value.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Engine intake air throttle actuation will be disabled. The engine intake air throttle will default to the open position.

Possible increase in idle speed

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 5 minutes. After 5 minutes, shut OFF the engine, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Open circuit in the wiring harness

A short circuit to ground in the engine harness

A malfunctioning engine intake air throttle actuator

Refer to Troubleshooting Fault Code 176 .

Last Modified: 18-Jan-2020


Engine Fuel Valve 1 Intake Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1827

Engine Fuel Valve 1 Intake Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1827 PID: SPN: 1390 FMI: 3/3 LAMP: Amber SRT: | The Fuel Inlet Sensor has been shorted to a voltage source. | Possible reduced engine performance.
Fuel Inlet Pressure Sensor

Circuit Description

The electronic control module (ECM) uses the engine fuel regulator outlet pressure/temperature sensor (combination sensor) to measure the pressure and temperature of fuel entering the engine fuel control valve.

Component Location

The engine fuel regulator outlet pressure/temperature sensor is located in the fuel housing near the gas mass flow sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the fuel inlet pressure sensor has been shorted to a voltage source.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

A default value for the fuel delivery pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible cause of this fault code:

malfunctioning fuel regulator outlet pressure/temperature sensor

Damaged wiring harness

Refer to Troubleshooting Fault Code 1827 .

Last Modified: 18-Jan-2020


Engine Fuel Valve 1 Intake Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1828

Engine Fuel Valve 1 Intake Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1828 PID: SPN: 1390 FMI: 4/4 LAMP: Amber SRT: | The fuel inlet pressure sensor has been shorted to ground. | Possible reduced engine performance.
Fuel Inlet Pressure Sensor

Circuit Description

The electronic control module (ECM) uses the engine fuel regulator outlet pressure/temperature sensor (combination sensor) to measure the pressure and temperature of fuel entering the engine fuel control valve.

Component Location

The engine fuel regulator outlet pressure/temperature sensor is located in the fuel housing near the gas mass flow sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the fuel inlet pressure sensor has been shorted to ground.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

A default value for the fuel delivery pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Damaged wiring harness

malfunctioning fuel regulator outlet pressure/temperature sensor

Refer to Troubleshooting Fault Code 1828 .

Last Modified: 18-Jan-2020


Gas Supply (Regulated) Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1839

Gas Supply (Regulated) Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1839 PID: P159 SPN: 159 FMI: 3/3 LAMP: Amber SRT: | The fuel supply pressure sensor has been shorted to a voltage source. | Possible reduced engine performance.
Fuel Supply Pressure Sensor

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine fuel regulator intake pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine fuel regulator intake pressure sensor provides a signal to the ECM on the engine fuel regulator intake pressure sensor circuit. This sensor signal voltage changes, based on the pressure of the fuel entering (low pressure) regulator.

Component Location

The engine fuel regulator intake pressure sensor is located in the fuel housing near the fuel supply fitting.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the fuel supply pressure sensor has been shorted to a voltage source.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

A default value for the fuel delivery pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The engine fuel regulator intake pressure sensor measures the pressure of the fuel entering the engine (low pressure) regulator. The engine fuel regulator intake pressure sensor is an absolute pressure sensor.

Possible cause of this fault code:

Damaged wiring harness

Malfunctioning engine fuel supply pump intake pressure sensor.

Refer to Troubleshooting Fault Code 1839 .

Last Modified: 18-Jan-2020


Gas Supply (Regulated) Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1841

Gas Supply (Regulated) Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1841 PID: P159 SPN: 159 FMI: 4/4 LAMP: Amber SRT: | The fuel supply pressure sensor has been shorted to ground. | Possible reduced engine performance.
Fuel Supply Pressure Sensor

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine fuel regulator intake pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine fuel regulator intake pressure sensor provides a signal to the ECM on the engine fuel regulator intake pressure sensor circuit. This sensor signal voltage changes, based on the pressure of the fuel entering (low pressure) regulator.

Component Location

The engine fuel regulator intake pressure sensor is located in the fuel housing near the fuel supply fitting.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel pressure entering the engine (low pressure) regulator is less than a calibrated value.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

A default value for the fuel delivery pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The engine fuel regulator intake pressure sensor measures the pressure of the fuel entering the engine (low pressure) regulator. The engine fuel regulator intake pressure sensor is an absolute pressure sensor.

Possible cause of this fault code:

Damaged wiring harness

Malfunctioning engine fuel supply pump intake pressure sensor.

Refer to Troubleshooting Fault Code 1841 .

Last Modified: 18-Jan-2020


Crankcase Pressure Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1843

Crankcase Pressure Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1843 PID: P101 SPN: 101 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the crankcase pressure circuit. | None on performance.
Engine Crankcase Pressure Sensor

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located near the crankcase ventilation element.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankcase pressure signal voltage was greater than 4.7-VDC for more than 8 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the crankcase pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The crankcase pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor

Signal wire shorted to sensor supply or battery voltage.

Refer to Troubleshooting Fault Code 1843 .

Last Modified: 18-Jan-2020


Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1844

Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1844 PID: P101 SPN: 101 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the crankcase pressure circuit. | None on performance.
Engine Crankcase Pressure Sensor

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located near the crankcase ventilation element.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankcase pressure signal voltage was Less than 0.25-VDC for more than 8 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the crankcase pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The crankcase pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 1844 .

Last Modified: 18-Jan-2020


EGR Mass Flow - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1855

EGR Mass Flow - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1855 PID: S277 SPN: 2659 FMI: 0/16 LAMP: Amber SRT: | EGR Mass Flow - Data Valid But Above Normal Operating Range - Moderately Severe Level. | Possible reduced engine performance.
EGR Differential Pressure Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) differential pressure sensor has two ports that sense exhaust pressure. The sensor outputs a voltage which represents the pressure difference between the two ports located across an orifice in the EGR tube. The engine control module (ECM) uses this pressure to determine how much exhaust gas is flowing in the EGR connection tube to the intake manifold. This information is used to control the EGR valve for correct emission levels.The ECM provides a 5 volt supply to the EGR differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The EGR differential pressure sensor provides a signal to the ECM on the EGR differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure in the EGR crossover tube.The EGR differential pressure sensor measures the exhaust gas pressure drop across the EGR differential pressure orifice. This pressure drop is used to calculate the amount of EGR flow into the intake manifold.

Component Location

The EGR differential pressure sensor is mounted to the inlet air connection next to the EGR Valve.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating at idle.

Engine Coolant Temperature is less than 50Â°C [122Â°F]

Air flow is greater than a calibrated value.

Catalyst temperature is greater than a calibrated value.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR differential pressure sensor was reading higher than a calibratable value at idle for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Feedback from the EGR differential pressure sensor is not used to control the EGR valve.

  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute. The vehicle may also need to be driven in order to meet EGR flow requirements so that the diagnostic can run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This diagnostic checks the reading of the EGR differential pressure sensor when the engine is idling. At idle, the EGR valve is nearly closed and EGR flow is very low. During this condition the reading of the EGR differential pressure is compared against an expected value, and a fault is logged if measured value exceeds the expected value by more than the allowable tolerance.

Possible causes of this fault code include:

A damaged EGR differential pressure sensor.

A damaged EGR valve

Plugged or restricted EGR differential pressure sensor flow ports.

Exhaust system leaks.

Refer to Troubleshooting Fault Code 1855 .

Last Modified: 18-Jan-2020


EGR Mass Flow - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 1856

EGR Mass Flow - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1856 PID: S277 SPN: 2659 FMI: 1/18 LAMP: Amber SRT: | EGR Mass Flow - Data Valid But Below Normal Operating Range - Moderately Severe Level. | Possible reduced engine performance.
EGR Differential Pressure Sensor Circuit

Circuit Description

The exhaust gas recirculation ( EGR ) differential pressure sensor has two ports that sense exhaust pressure. The sensor outputs a voltage which represents the pressure difference between the two ports. The engine control module (ECM) uses this pressure to determine how much exhaust gas is flowing in the EGR connection tube to the intake manifold. This information is used to control the EGR valve for correct emission levels. The EGR differential pressure sensor measures the exhaust gas pressure drop across the EGR differential pressure orifice. This pressure drop is used to calculate the amount of EGR flow into the intake manifold.

Component Location

The EGR differential pressure sensor is mounted to the inlet air connection next to the EGR Valve.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Engine Coolant Temperature is less than 50Â°C [122Â°F]

Commanded EGR flow is greater than a calibrated value

Catalyst temperature is greater than a calibrated value.

Conditions for Setting the Fault Codes

The ECM detects that the EGR delta pressure is greater than a calibrated value at idle for more than a calibratible time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Feedback from the EGR differential pressure sensor is not used to control the EGR valve.

  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This diagnostic checks the reading of the EGR differential pressure sensor when the engine is idling. At idle, the EGR valve is nearly closed and EGR flow is very low. During this condition the reading of the EGR differential pressure is compared against an expected value, and a fault is logged if measured value exceeds the expected value by more than the allowable tolerance.

Possible causes of this fault code include:

Stuck closed EGR valve

A damaged EGR valve

A damaged EGR differential pressure sensor.

Plugged or restricted EGR differential pressure sensor flow ports.

Refer to Troubleshooting Fault Code 1856 .

Last Modified: 18-Jan-2020


Aftertreatment Intake Oxygen Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1858

Aftertreatment Intake Oxygen Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1858 PID: SPN: 3217 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Intake Oxygen Sensor Circuit - Voltage Above Normal or Shorted to High Source | Possible reduced engine performance.
Engine Turbocharger Outlet Oxygen Sensor

Circuit Description

The engine control module (ECM) uses sensors to determine the composition of the exhaust gas so that fueling can be adjusted to maintain desired air/fuel ratio while operating in closed loop.

Component Location

The engine turbocharger outlet oxygen sensor is located in the exhaust system, after the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected high voltage on the oxygen sensor circuit

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The engine controller uses feedback from the aftertreatment exhaust gas oxygen sensor to correct fuel flow to maintain a stoichiometric air-to-fuel ratio. If the oxygen sensor is unable to maintain a stoichiometric air-to-fuel ratio due to a sustained lean condition, this fault code may become active. Check for aftertreatment gas oxidation catalyst intake oxygen compensation (percent) to be operating at - 100 percent compensation for more than 10 seconds.

Values received from the oxygen sensor are used to adjust fueling. Changes from default fueling are stored in an adaptive learning table in the ECM for future use in place of default values. If the values received from the oxygen sensor are beyond the ECM's maximum level to record, the fault code will light.

Refer to Troubleshooting Fault Code 1858 .

Last Modified: 18-Jan-2020


Aftertreatment Intake Oxygen Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1861

Aftertreatment Intake Oxygen Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1861 PID: SPN: 3217 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment Intake Oxygen Sensor - Data Erratic, Intermittent, or Incorrect | Possible reduced engine performance.
Aftertreatment Exhaust Gas Oxygen Sensor

Circuit Description

The engine control module (ECM) uses this sensor to determine the composition of the exhaust gas so the fueling can be adjusted to maintain desired air/fuel ratio while operating in closed loop. The heater circuit is powered by the ECM to maintain proper temperature at the sensing tip. The heater line is shared between aftertreatment intake and outlet oxygen sensor circuit.

Component Location

The engine turbocharger outlet oxygen sensor is located in the exhaust system, after the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine has been running for more than 1 minute.

Conditions for Setting the Fault Codes

The ECM will set the fault code active when the ECM detects voltage above a calibrated value or below a calibrated value for greater than a calibrated time, or the ECM detects that the oxygen sensor voltage is switching from low to high voltage faster than a calibratable rate.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state type operation, and load. This will simulate normal operating and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The fault code will stay active until the keyswitch is cycled. After the keyswitch has been cycled, the system will again try to operate in closed loop. The fault code will clear as long as the issue does not occur after 5 minutes of closed loop operation. During closed loop operation it is typical to see aftertreatment exhaust gas oxygen 1 concentration toggling between RICH and LEAN.

The aftertreatment exhaust gas oxygen sensor is used to adjust target fueling to maintain desired air/fuel ratio while operating in closed loop.

Closed loop fueling command offsets are stored on power down; therefore, fuel system tables need to be reset whenever the oxygen sensor, fuel control valve, engine fuel regulator (low pressure), or gas mass flow sensor, are replaced.

The engine controller uses feedback from the aftertreatment exhaust gas oxygen sensor to correct fuel flow to maintain a stoichiometric air-to-fuel ratio. If the oxygen sensor is unable to maintain a stoichiometric air-to-fuel ratio due to a sustained lean condition, this fault code may become active. Check for aftertreatment gas oxidation catalyst intake oxygen compensation (percent) to be operating at - 100 percent compensation for more than 10 seconds.

Possible causes of this fault code include:

Low fuel pressure

Restriction due to deposits in the laminar flow screen and oil contamination in the mixer housing and gas flow sensor

A damaged gas mass flow sensor

A cylinder misfire or overfueling.

A damaged turbocharger compressor intake temperature sensor.

A restriction in the fuel system

A damaged fuel control valve

Malfunctioning intake manifold pressure/temperature sensor

Refer to Troubleshooting Fault Code 1861 .

Last Modified: 18-Jan-2020


Aftertreatment Outlet Oxygen Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1862

Aftertreatment Outlet Oxygen Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1862 PID: SPN: 3227 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Outlet Oxygen Sensor Circuit - Voltage Above Normal or Shorted to High Source | Possible reduced engine performance.
Aftertreatment Exhaust Gas Oxygen Sensor

Circuit Description

The engine control module (ECM) uses this sensor to determine the composition of the exhaust gas so the fueling can be adjusted to maintain desired air/fuel ratio while operating in closed loop. The heater circuit is powered by the ECM to maintain proper temperature at the sensing tip. The heater line is shared between aftertreatment intake and outlet oxygen sensor circuit.

Component Location

The engine turbocharger outlet oxygen sensor is located in the exhaust system, after the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating under load and the engine speed is greater than the calibrated threshold.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the High or Low range oxygen signal line voltage is greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The engine controller uses feedback from the aftertreatment exhaust gas oxygen sensor to correct fuel flow to maintain a stoichiometric air-to-fuel ratio. If the oxygen sensor is unable to maintain a stoichiometric air-to-fuel ratio due to a sustained lean condition, this fault code may become active. Check for aftertreatment gas oxidation catalyst intake oxygen compensation (percent) to be operating at - 100 percent compensation for more than 10 seconds.

Closed loop fueling command offsets are stored on power down; therefore, fuel system tables need to be reset whenever the oxygen sensor, fuel control valve, engine fuel regulator (low pressure), or gas mass flow sensor, are replaced.

Possible causes of this fault code include:

Open circuit in the wiring harness

Short to voltage source in the OEM harness

Damaged/drifted oxygen sensor

Refer to Troubleshooting Fault Code 1862 .

Last Modified: 18-Jan-2020


Aftertreatment Outlet Oxygen Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1864

Aftertreatment Outlet Oxygen Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1864 PID: SPN: 3227 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment Outlet Oxygen Sensor - Data Erratic, Intermittent, or Incorrect | Possible reduced engine performance.
Aftertreatment Exhaust Gas Oxygen Sensor

Circuit Description

The engine control module (ECM) uses sensors to determine the composition of the exhaust gas so that fueling can be adjusted to maintain desired air/fuel ratio while operating in closed loop. This diagnostic detects air/fuel ratio cylinder imbalance in one or more cylinders

Component Location

The engine turbocharger outlet oxygen sensor is located in the exhaust system, after the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the High or Low range oxygen signal line voltage is greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and run at high idle for 6 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The engine controller uses feedback from the aftertreatment exhaust gas oxygen sensor to correct fuel flow to maintain a stoichiometric air-to-fuel ratio. If the oxygen sensor is unable to maintain a stoichiometric air-to-fuel ratio due to a sustained lean condition, this fault code may become active. Check for aftertreatment gas oxidation catalyst intake oxygen compensation (percent) to be operating at - 100 percent compensation for more than 10 seconds.

Closed loop fueling command offsets are stored on power down; therefore, fuel system tables need to be reset whenever the oxygen sensor, fuel control valve, engine fuel regulator (low pressure), or gas mass flow sensor, are replaced.

The oxygen sensor compares the oxygen concentration in the exhaust to the oxygen concentration in the reference chamber. If grease has been installed in the oxygen sensor connector, this fault code can become active.

Possible causes of this fault code include:

Short to ground in the wiring harness

Damaged/drifted oxygen sensor

Refer to Troubleshooting Fault Code 1864 .

Last Modified: 18-Jan-2020


Exhaust Gas Recirculation Differential Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1866

Exhaust Gas Recirculation Differential Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1866 PID: P411 SPN: 411 FMI: 2/2 LAMP: Amber SRT: | An error in the EGR delta pressure signal was detected at initial key ON or the sensor failed the autozero test. | Possible reduced engine performance.
EGR Differential Pressure Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) differential pressure sensor has two ports that sense exhaust pressure. The sensor outputs a voltage which represents the pressure difference between the two ports located across an orifice in the EGR tube. The engine control module (ECM) uses this pressure to determine how much exhaust gas is flowing in the EGR connection tube to the intake manifold. This information is used to control the EGR valve for correct emission levels.The ECM provides a 5 volt supply to the EGR differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The EGR differential pressure sensor provides a signal to the ECM on the EGR differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure in the EGR crossover tube.The EGR differential pressure sensor measures the exhaust gas pressure drop across the EGR differential pressure orifice. This pressure drop is used to calculate the amount of EGR flow into the intake manifold.

Component Location

The EGR differential pressure sensor is mounted to the inlet air connection next to the EGR Valve.

Conditions for Running the Diagnostics

This diagnostic runs at key OFF when the following conditions are met:

Engine coolant temperature is 68°C [154°F] or higher.

Intake manifold air temperature is 16Â°C [60Â°F] or higher.

EGR position is less than 2 percent, which occurs during the EGR valve test on powerdown.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR differential pressure sensor was reading higher or lower than a calibratable value when the keyswitch was turned OFF.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Feedback from the EGR differential pressure sensor is not used to control the EGR valve.

  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This check is only performed at keyswitch OFF, during the ECM powerdown. During this diagnostic check, the ECM monitors the value of the EGR differential pressure sensor. If this value is outside of a specified range, Fault Code 1866 is set active.

Possible causes of this fault code include:

A damaged EGR differential pressure sensor.

High resistance in the wiring harness on the signal or return wire.

Plugged or restricted EGR differential pressure sensor flow ports.

Refer to Troubleshooting Fault Code 1866 .

Last Modified: 18-Jan-2020


Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 187

Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 187 PID: S211 SPN: 3510 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at the sensor supply number 2 circuit. | Possible reduced engine performance.
Sensor Supply 2 Circuit

Circuit Description

The sensor supply 2 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 2 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 2 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value is used for all of the sensors on the sensor supply 2 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Low voltage on the +5 volt supply line can be caused by a short circuit to ground in a supply line, a short circuit between a supply line and a return line, a malfunctioning sensor, or a malfunctioning ECM power supply.

Refer to Troubleshooting Fault Code 187 .

Last Modified: 18-Jan-2020


EGR Valve Controller - Out of Calibration

FAULT CODE 1896

EGR Valve Controller - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1896 PID: S146 SPN: 2791 FMI: 13/13 LAMP: Amber SRT: | The EGR valve has failed the automatic calibration procedure at initial key ON. | Possible reduced engine performance.
EGR Valve Circuit

Circuit Description

The exhaust gas recirculation (EGR) valve is opened by a motor located on top of the EGR valve. A motor shaft extends from the motor and contacts the dual-poppet valve to open the EGR valve. The EGR valve motor does not actually retract the EGR valve. The motor current is reduced and the spring pushes the EGR valve closed.

Component Location

The EGR Valve and EGR Differential Pressure Sensor location varies depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON and occasionally during normal engine operation after the EGR valve is commanded closed.

Conditions for Setting the Fault Codes

The EGR valve motor measures the position of the EGR valve at initial key ON. If the valve is detected to be greater than 20 percent open, the fault code is set active.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Exhaust gas recirculation (EGR) valve operation will be disabled.

  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and leave the key in the ON position for 2 minutes. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When the keyswitch is initially turned ON and at various times during engine operation, the closed position of the EGR valve is checked. This diagnostic checks to make sure the EGR valve is not stuck open.

The EGR valve will close when the fault code is active. The fault code will remain active until the next key cycle.

Refer to Troubleshooting Fault Code 1896 .

Last Modified: 18-Jan-2020


Crankcase Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1942

Crankcase Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1942 PID: P101 SPN: 101 FMI: 2/2 LAMP: Amber SRT: | The ECM has detected that the crankcase pressure signal is reading an erratic value at initial key ON or during engine operation. | None on performance.
Engine Crankcase Pressure Sensor Circuit

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located near the crankcase ventilation element.

Conditions for Running the Diagnostics

This diagnostic consists of two parts. The first part of this diagnostic runs at initial key ON and the second part runs when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankcase pressure sensor was reading an erratic value at key ON or the crankcase pressure reading was not changing with engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code can be caused by a crankcase breather hose disconnected between the engine outlet and crankcase filter assembly on engines with an externally mounted crankcase filter option.

Possible causes of this fault code include:

Resistance in the wiring harness

A malfunctioning in-range pressure sensor

Crankcase pressure sensor is not installed correctly in the housing.

Refer to Troubleshooting Fault Code 1942 .

Last Modified: 18-Jan-2020


Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 195

Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 195 PID: P111 SPN: 111 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the engine coolant level circuit. | None on performance.
Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • No engine protection will be available for low coolant level.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor

Signal circuit shorted to sensor supply or battery voltage

Sensor supply circuit shorted to battery voltage.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 195 .

Last Modified: 18-Jan-2020


Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 196

Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 196 PID: P111 SPN: 111 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the engine coolant level circuit. | None on performance.
Engine Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • No engine protection will be available for low coolant level.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Open signal circuit in the engine harness, connectors, or sensor

Signal circuit shorted to ground in the engine harness, connector, or sensor

  • Damaged sensor.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 196 .

Last Modified: 18-Jan-2020


Aftertreatment Exhaust Gas Temperature 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1965

Aftertreatment Exhaust Gas Temperature 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1965 PID: S326 SPN: 3241 FMI: 0/16 LAMP: Amber SRT: | Aftertreatment Exhaust Gas Temperature 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level. | Engine power derate.
Aftertreatment Exhaust Gas Temperature Sensor Circuit

Circuit Description

The aftertreatment exhaust gas temperature sensor is used by the engine control module (ECM) to monitor the engine exhaust temperature in the aftertreatment system. The aftertreatment exhaust gas temperature sensor is a thermistor and changes resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or a low temperature.When the exhaust gas temperature is high, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore,the ECM senses a low signal voltage, or a high temperature.

Component Location

The aftertreatment exhaust gas temperature sensor is located in the aftertreatment system. It is located at the outlet of the aftertreatment catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the exhaust gas temperature reading is used.

Engine torque may be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A cylinder misfire or overfueling.

Excessive engine oil being introduced into the exhaust system from the engine.

Malfunctioning sensor

Refer to Troubleshooting Fault Code 1965 .

Last Modified: 18-Jan-2020


Aftertreatment Exhaust Gas Temperature 1 - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 1966

Aftertreatment Exhaust Gas Temperature 1 - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1966 PID: S326 SPN: 3241 FMI: 0/0 LAMP: Red SRT: | Aftertreatment Exhaust Gas Temperature 1 - Data Valid But Above Normal Operating Range - Most Severe Level | Progressive power derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Aftertreatment Exhaust Gas Temperature Sensor Circuit

Circuit Description

The aftertreatment exhaust gas temperature sensor is used by the engine control module (ECM) to monitor the engine exhaust temperature in the aftertreatment system. The aftertreatment exhaust gas temperature sensor is a thermistor and changes resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or low temperature. When the exhaust gas temperature is hot, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The aftertreatment exhaust gas temperature sensor is located in the aftertreatment system. It is located at the outlet of the aftertreatment catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Engine torque may be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A cylinder misfire or overfueling.

Excessive engine oil being introduced into the exhaust system from the engine.

Malfunctioning sensor

Refer to Troubleshooting Fault Code 1966 .

Last Modified: 18-Jan-2020


Aftertreatment Exhaust Gas Temperature 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1968

Aftertreatment Exhaust Gas Temperature 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1968 PID: S327 SPN: 3249 FMI: 0/16 LAMP: Amber SRT: | Aftertreatment Exhaust Gas Temperature 2 - Data Valid But Below Normal Operating Range - Least Severe Level | Engine power derate.
Aftertreatment Exhaust Gas Temperature Sensor Circuit

Circuit Description

The aftertreatment exhaust gas temperature sensor is used by the engine control module (ECM) to monitor the engine exhaust temperature in the aftertreatment system. The aftertreatment exhaust gas temperature sensor is a thermistor and changes resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or a low temperature.When the exhaust gas temperature is high, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore,the ECM senses a low signal voltage, or a high temperature.

Component Location

The aftertreatment exhaust gas temperature sensor is located in the aftertreatment system. It is located at the outlet of the aftertreatment catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The exhaust gas temperature sensor reading is above engine average by a calibrated amount continuously for a calibrated time.

The Engine Control Module (ECM) detected the exhaust gas temperature sensor circuit was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Engine torque and/or engine speed derate will be active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

A cylinder misfire or overfueling.

Malfunctioning aftertreatment temperature sensors

A damaged catalyst.

Refer to Troubleshooting Fault Code 1968 .

Last Modified: 18-Jan-2020


Aftertreatment Exhaust Gas Temperature 2 - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 1969

Aftertreatment Exhaust Gas Temperature 2 - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE REASON EFFECT
Fault Code: 1969
PID: S327
SPN: 3249
FMI: 0/0
LAMP: Red
SRT:

Exhaust gas temperature is above engine protection.

Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.

If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.

Aftertreatment Exhaust Gas Temperature Sensor Circuit

Circuit Description

The aftertreatment exhaust gas temperature sensor is used by the engine control module (ECM) to monitor the engine exhaust temperature in the aftertreatment system. The aftertreatment exhaust gas temperature sensor is a thermistor and changes resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

When the exhaust temperature is low, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage or a low temperature.When the exhaust gas temperature is high, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore,the ECM senses a low signal voltage, or a high temperature.

Component Location

The aftertreatment exhaust gas temperature sensor is located in the aftertreatment system. It is located at the outlet of the aftertreatment catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The exhaust gas temperature sensor reading is above engine average by a calibrated amount continuously for a calibrated time.

The Engine Control Module (ECM) detected the exhaust gas temperature sensor circuit was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

A cylinder misfire or overfueling.

Malfunctioning aftertreatment temperature sensors

A damaged catalyst.

Refer to Troubleshooting Fault Code 1969 .

Last Modified: 18-Jan-2020


Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 197

Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 197 PID: P111 SPN: 111 FMI: 1/18 LAMP: Amber SRT: | Low engine coolant level detected. | Possible reduced engine performance.
Engine Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level was below normal.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code goes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant.

If this fault code is active and the coolant level is not low, disconnect the coolant level sensor and check the connectors for traces of coolant. If coolant is found at the electrical connectors, the sensor has malfunctioned and must be replaced.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 197 .

Last Modified: 18-Jan-2020


Crankcase Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 1974

Crankcase Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1974 PID: P101 SPN: 101 FMI: 0/15 LAMP: Maintenance SRT: | High crankcase pressure detected. The crankcase breather filter requires maintenance. | None on performance.
Crankcase Pressure Sensor Circuit

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located near the crankcase ventilation element.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected the crankcase pressure in the breather tube was greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • Use the recommended Cummins® electronic service tool or equivalent "Data Monitor/Logger" feature to monitor Crankcase Pressure with the engine running at idle. If the crankcase pressure reading is below 7.0 in H20, the repair has been validated.
  • It is necessary to use the "Reset All Faults" command in the recommended Cummins® electronic service tool or equivalent to clear this fault.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

If this fault code is active, the crankcase breather system may need to be inspected.

Refer to Troubleshooting Fault Code 1974 .

Last Modified: 18-Jan-2020


Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 212

Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 212 PID: P175 SPN: 175 FMI: 3/3 LAMP: Amber SRT: | High signal voltage or an open circuit detected at the engine oil temperature circuit. | None on performance.
Engine Oil Temperature Sensor 1 Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil. The engine control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature.

Component Location

The engine oil temperature sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the engine oil temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The engine oil temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code 212 .

Last Modified: 18-Jan-2020


Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 213

Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 213 PID: P175 SPN: 175 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the engine oil temperature circuit. | None on performance.
Engine Oil Temperature Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil. The engine control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature.

Component Location

The engine oil temperature sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the engine oil temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Signal shorted to ground in the engine harness

Signal shorted to return or ground in the sensor.

Refer to Troubleshooting Fault Code 213 .

Last Modified: 18-Jan-2020


Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 214

Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 214 PID: P175 SPN: 175 FMI: 0/0 LAMP: Red SRT: | Engine oil temperature signal indicates engine oil temperature above engine protection critical limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Engine Oil Temperature Sensor 1 Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil. The engine control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature.

Component Location

The engine oil temperature sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil temperature was greater than the maximum engine protection limit for 5 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The torque output of the engine will be reduced.

Maximum engine operating speed will be decreased.

The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • Start and idle the engine for 1 minute
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates that the engine oil temperature has exceeded the maximum engine protection limit for oil temperature. Troubleshoot the cause of high engine oil temperature.

Refer to Troubleshooting Fault Code 214 .

Last Modified: 18-Jan-2020


Engine Brake Actuator Driver 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2182

Engine Brake Actuator Driver 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2182 PID: S79 SPN: 1072 FMI: 3/3 LAMP: Amber SRT: | High voltage or an open circuit detected at the engine brake solenoid number 1 signal circuit. | Possible reduce engine braking performance.
Engine Brake Actuator Driver 1 Circuit

Circuit Description

The Engine Control Module (ECM) controls engine brakes on cylinders 1, 2, and 3 by sending a signal on the engine brake solenoid number 1 signal circuit. If an engine brake is installed, there will be a jumper harness from this connector to the engine brake pass-through connectors on the rocker lever housing.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake solenoids are controlled through the engine harness by the ECM.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine brake 1 pulse width modulated (PWM) signal was detected to be greater than 0 volts when the PWM signal was turned off by the ECM.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The engine brake 1 circuit will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, drive the vehicle and operate the engine brakes. This will allow the diagnostic to run. If the fault code does not become active again, the repair has been validated.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A short circuit to battery in the engine harness.

An open circuit in the engine harness, brake harness, or engine brake solenoids.

A malfunctioning engine brake solenoid

A malfunctioning engine control module (ECM)

Refer to Troubleshooting Fault Code 2182 .

Last Modified: 18-Jan-2020


Engine Brake Actuator Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2183

Engine Brake Actuator Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2183 PID: S79 SPN: 1072 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at the engine brake solenoid number 1 signal circuit. | Possible reduce engine braking performance.
Engine Brake Actuator Driver 1 Circuit

Circuit Description

The Engine Control Module (ECM) controls engine brakes on cylinders 1, 2, and 3 by sending a signal on the engine brake solenoid number 1 signal circuit. If an engine brake is installed, there will be a jumper harness from this connector to the engine brake pass-through connectors on the rocker lever housing.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake solenoids are controlled through the engine harness by the ECM.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine brake 1 pulse width modulated (PWM) signal was not detected to be system voltage when the PWM signal was turned on.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The engine brake 1 circuit will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, drive the vehicle and operate the engine brakes. This will allow the diagnostic to run. If the fault code does not become active again, the repair has been validated.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The engine brake fault code will only become active once the engine brakes are activated and will remain active until the ECM is powered down. Once the ECM is powered down, the fault code will be inactive until the engine brakes are activated again if the circuit interruption is still present. This tree is designed to troubleshoot an inactive fault code.

Possible causes of this fault code include:

A short circuit to ground in the engine harness

A malfunctioning engine brake solenoid

Refer to Troubleshooting Fault Code 2183 .

Last Modified: 18-Jan-2020


Electronic Fuel Injection Control Valve Circuit - Root Cause Not Known

FAULT CODE 2184

Electronic Fuel Injection Control Valve Circuit - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2184 PID: S18 SPN: 633 FMI: 11/11 LAMP: Amber SRT: | The Fuel Control Valve (FCV) has a position error. | Possible reduced engine performance.
Fuel Control Valve

Circuit Description

The electronic control module (ECM) uses the gas mass flow sensor to measure fuel into the engine and to adjust the fuel control valve based on this measurement.

Component Location

The gas mass flow sensor is located on the fuel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 500 rpm and within the first minute of the engine starting.

Conditions for Setting the Fault Codes

The ECM detects that the actual gas flow is less than or greater than estimated gas flow by more than a calibrated amount for calibratible amount of time when in open loop.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The engine will run in open loop gas flow control

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The engine fuel control valve is a normally closed valve. The ECM will not command the valve open until the ECM detects engine rpm.

Possible causes of this fault code include:

Improper fuel pressure or low fuel.

Restriction due to deposits in the laminar flow screen and oil contamination in the mixer housing and gas flow sensor

A restriction in the fuel system

Damaged Fuel Control Valve (FCV)

A malfunctioning Gas Mass Flow Sensor

A leak in the fuel system

Refer to Troubleshooting Fault Code 2184 .

Last Modified: 18-Jan-2020


Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2185

Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2185 PID: S232 SPN: 3512 FMI: 3/3 LAMP: Amber SRT: | High voltage detected at 5 VDC sensor supply circuit to the accelerator pedal position sensor. | Engine power derate. The engine will operate in Limp Home mode.
Sensor Supply 4 Circuit

Circuit Description

Sensor supply 4 of the engine control module (ECM) provides a 5 VDC supply to the accelerator pedal position sensor.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Sensor Supply 4 originates in the OEM connector portion of the ECM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 4 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The engine speed may be limited to engine idle speed.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code can be caused by a short circuit to a voltage source in the OEM harness or a short circuit to an actuator signal circuit that is greater than 5-VDC.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 2185 .

Last Modified: 17-Feb-2020


Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2186

Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2186 PID: S232 SPN: 3512 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at the 5 VDC sensor supply circuit to the accelerator pedal position sensor. | Engine power derate. The engine will operate in Limp Home mode.
Sensor Supply 4 Circuit

Circuit Description

Sensor supply 4 of the engine control module (ECM) provides a 5 VDC supply to the accelerator pedal position sensor.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Sensor Supply 4 originates in the OEM connector portion of the ECM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 4 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Engine torque and/or engine speed derate will be active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Low voltage on the 5 VDC supply wire can be caused by a short circuit to ground in the supply wire, a short circuit between the supply wire and return circuit, a malfunctioning accelerator, or a malfunctioning ECM power supply.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 2186 .

Last Modified: 18-Jan-2020


Throttle Plate Leaking - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 2189

Throttle Plate Leaking - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2189 PID: S58 SPN: 51 FMI: 7/7 LAMP: Amber SRT: | Throttle Plate Leaking - Mechanical System Not Responding or Out of Adjustment. | None on performance. Possible increase in idle speed.
Throttle Plate Actuator Circuit

Circuit Description

The electronic control module (ECM) controls the engine throttle actuator, which is both an input and output device. There are two throttle position sensors located inside the engine throttle actuator and they share a common supply and return. The engine throttle actuator receives 5 volt supply voltage from the sensor supply 1. The ECM controls the position of the throttle across the engine throttle actuator (+) line.

Component Location

The engine throttle actuator is located between the air intake adapter and the fuel control housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects air leaks in the Engine throttle system.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and use the accelerator pedal to accelerate the engine speed to high idle (100 percent) and hold the engine speed at high idle for at least 20 seconds.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The throttle actuator is pulse-width modulated. Leaks, especially missing pipe and cap plugs, after the throttle actuator can also cause this fault. Excessive backfire can cause a bent throttle plate.

Refer to Troubleshooting Fault Code 2189 .

Last Modified: 18-Jan-2020


Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 227

Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 227 PID: S211 SPN: 3510 FMI: 3/3 LAMP: Amber SRT: | High voltage detected at sensor supply number 2 circuit. | Possible reduced engine performance.
Sensor Supply 2 Circuit

Circuit Description

The sensor supply 2 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 2 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 2 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value is used for all of the sensors on the sensor supply 2 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

High voltage on the (+) 5 volt supply line can be caused by a short to battery voltage in the engine harness or connectors, or a malfunctioning ECM.

Refer to Troubleshooting Fault Code 227 .

Last Modified: 18-Jan-2020


EGR Valve Position Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2272

EGR Valve Position Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2272 PID: P27 SPN: 27 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage has been detected at the EGR valve position sensor circuit. | Possible reduced engine performance.
EGR Valve Position Circuit

Circuit Description

The exhaust gas recirculation (EGR) valve is opened by a motor located on top of the EGR valve. A motor shaft extends from the motor and contacts the dual-poppet valve to open the EGR valve. The EGR valve motor does not actually retract the EGR valve. The motor current is reduced and the spring pushes the EGR valve closed.

Component Location

The EGR valve is located on the air intake connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR valve position sensor signal voltage was less than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The engine will enter an alternative engine protection mode with no desired EGR flow, open loop fueling, and full torque derate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

EGR valve position sensor wiring shorted to ground, open circuit, or shorted to power supply.

Loss of the EGR valve position sensor supply voltage or the ground circuit.

Refer to Troubleshooting Fault Code 2272 .

Last Modified: 18-Jan-2020


Exhaust Gas Recirculation Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2273

Exhaust Gas Recirculation Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2273 PID: P411 SPN: 411 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the EGR differential pressure sensor circuit. | Possible reduced engine performance.
EGR Differential Pressure Sensor Circuit

Circuit Description

The exhaust gas recirculation ( EGR ) differential pressure sensor has two ports that sense exhaust pressure. The sensor outputs a voltage which represents the pressure difference between the two ports. The engine control module (ECM) uses this pressure to determine how much exhaust gas is flowing in the EGR connection tube to the intake manifold. This information is used to control the EGR valve for correct emission levels. The EGR differential pressure sensor measures the exhaust gas pressure drop across the EGR differential pressure orifice. This pressure drop is used to calculate the amount of EGR flow into the intake manifold.

Component Location

The EGR Valve and EGR Differential Pressure Sensor location varies depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR differential pressure signal voltage was greater than 4.8-VDC for more than 8 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Feedback from the EGR differential pressure sensor is not used to control the EGR valve.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor

A signal wire shorted to sensor supply or battery voltage

A damaged EGR differential pressure sensor.

Refer to Troubleshooting Fault Code 2273 .

Last Modified: 18-Jan-2020


Exhaust Gas Recirculation Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2274

Exhaust Gas Recirculation Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2274 PID: P411 SPN: 411 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the EGR differential pressure sensor circuit. | Possible reduced engine performance.
EGR Differential Pressure Sensor Circuit

Circuit Description

The exhaust gas recirculation ( EGR ) differential pressure sensor has two ports that sense exhaust pressure. The sensor outputs a voltage which represents the pressure difference between the two ports. The engine control module (ECM) uses this pressure to determine how much exhaust gas is flowing in the EGR connection tube to the intake manifold. This information is used to control the EGR valve for correct emission levels. The EGR differential pressure sensor measures the exhaust gas pressure drop across the EGR differential pressure orifice. This pressure drop is used to calculate the amount of EGR flow into the intake manifold.

Component Location

The EGR differential pressure sensor is mounted to the inlet air connection next to the EGR cooler.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR differential pressure signal voltage was less than 0.26-VDC for more than 8 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Feedback from the EGR differential pressure sensor is not used to control the EGR valve.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A signal circuit open or shorted to ground in the engine harness or sensor

  • Supply wire open or shorted to ground.

A malfunctioning EGR differential pressure sensor.

Refer to Troubleshooting Fault Code 2274 .

Last Modified: 18-Jan-2020


Engine Multiple Cylinder Spark Voltage Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2286

Engine Multiple Cylinder Spark Voltage Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2286 PID: SPN: 3451 FMI: 3/3 LAMP: Amber SRT: | Ignition Timing Signal Circuit - Voltage Above Normal or Shorted to High Source | Possible reduced engine performance.
Ignition Timing Signal Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

The ICM is located above the ECM on the intake side of the engine near the fuel control housing.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the spark voltage is less than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The ecm will not be capable of logging low cylinder MV or misfire faults if the spark voltage line becomes shorted.

Refer to Troubleshooting Fault Code 2286 .

Last Modified: 18-Jan-2020


Engine Multiple Cylinder Spark Voltage Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2287

Engine Multiple Cylinder Spark Voltage Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2287 PID: SPN: 3451 FMI: 4/4 LAMP: Amber SRT: | Ignition Timing Signal Circuit - Voltage Below Normal or Shorted to Low Source | Possible reduced engine performance.
Ignition Timing Signal Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

The ICM is located above the ECM on the intake side of the engine near the fuel control housing.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the spark voltage is greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The ecm will not be capable of logging low cylinder MV or misfire faults if the spark voltage line becomes shorted.

Refer to Troubleshooting Fault Code 2287 .

Last Modified: 18-Jan-2020


Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2321

Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2321 PID: P190 SPN: 190 FMI: 2/2 LAMP: None SRT: | Crankshaft engine speed sensor intermittent synchronization. | The engine will shut down or will not start.
Engine Crankshaft Speed/Position Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine crankshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The crankshaft speed/position sensor provides a signal to the ECM on the crankshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the crankshaft speed indicator ring passes the sensor. The ECM interprets this signal into an engine speed reading and determines engine position.

Component Location

The crankshaft position sensor is located on the intake side of the engine, near the flywheel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an intermittent or degraded signal from the crankshaft speed/position sensor over an extended period of engine operation.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

For On-Board Diagnostics (OBD) engines, the ECM illuminates the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Exhaust gas recirculation (EGR) valve operation will be disabled.

  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and run it at high idle for 5 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

During engine operation, the ECM monitors the primary speed sensor (crankshaft speed sensor) signal. Fault Code 689 will become active and light the yellow lamp if the signal from the primary speed sensor is not present or degraded for more than 3 continuous seconds. Meanwhile, if the primary engine speed sensor signal is not present or is degraded for a moment (less than 3 seconds), the ECM will interrupt injection events based on the primary engine speed sensor and resume injection events using the backup engine speed sensor. Engine power will be reduced while the injection events are based on the backup speed sensor. If the primary speed sensor signal returns, the ECM will automatically interrupt injection events based on the backup speed sensor and resume injection events based on the primary speed sensor. If over a period of time, the ECM detects several incidents of a loss of the primary speed sensor signal, this fault code will become active.

This fault code becomes active whenever the ECM detects a persistent loss of the primary engine speed sensor signal over a short period of time.

Possible causes of this fault code include:

Intermittent loss of primary speed sensor signal; the most likely cause is an intermittent open or short circuit that can be experienced with speed sensor connector problems.

Sensor air gap that is marginally too small or too large.

Actions to take if this fault is intermittent:

Look for intermittent engine harness connections in the primary engine speed sensor circuit.

Look for loose connections at the ECM connector where the pins can not be locked into the socket.

Look for places where the engine harness has worn into a nearby component, causing an intermittent short circuit.

Look for pin wear at the speed sensor.

Refer to Troubleshooting Fault Code 2321 .

Last Modified: 18-Jan-2020


Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2322

Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2322 PID: S64 SPN: 723 FMI: 2/2 LAMP: None SRT: | Camshaft engine speed sensor intermittent synchronization. | None on performance.
Engine Camshaft Speed/Position Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine camshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The camshaft speed/position sensor provides a signal to the ECM on the camshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the camshaft speed indicator lobe moves past the sensor. The ECM interprets this signal into an engine speed reading and determines engine position. This sensor is used as a backup sensor if the primary engine crankshaft speed/position signal is lost.

Component Location

The engine camshaft speed/position sensor is located on the intake side of the engine above the accessory drive.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an intermittent loss of the camshaft speed/position sensor signal.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and run it at high idle for 5 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

During engine operation, the ECM monitors the secondary speed sensor (camshaft speed sensor) signal. Fault Code 778 will become active and light the yellow lamp if the signal from the secondary speed sensor is not present or degraded for more than 3 continuous seconds. If over a period of time the ECM detects several incidents of a loss of the secondary speed sensor signal, but the signal loss is short in duration, this fault code will become active. Since the secondary engine speed signal is not used for normal engine operation, a vehicle operator should not notice any symptoms related to this problem.

This fault code becomes active whenever the ECM detects a persistent loss of the secondary engine speed sensor signal over a short period of time.

Problems that can cause this fault:

Intermittent loss of primary speed sensor signal; the most likely cause is an intermittent open or short circuit that can be experienced with speed sensor connector problems

Sensor air gap that is marginally too small or too large, or target wheel exhibits excessive runout.

Actions to take if this fault is intermittent:

Look for intermittent engine harness connections in the secondary engine speed sensor circuit

Look for loose connections at the ECM connector where the pins can not be locked into the socket

Look for places where the engine harness has worn into a nearby component, causing an intermittent short circuit

Look for pin wear at the speed sensor

Refer to Troubleshooting Fault Code 2322 .

Last Modified: 18-Jan-2020


Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 234

Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: P190 SPN: 190 FMI: 0/0 LAMP: Red SRT: | Engine speed signal indicates engine speed above engine protection limit. | Possible reduced engine performance.
Engine Crankshaft Position and Camshaft Position Sensor Circuits

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position and camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine speed had exceeded the calibration limit.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Fueling to the engine is stopped until the engine speed drops to normal operating speeds.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

External fuel sources drawn into the intake air passage

Reverse powering (motoring) of the engine

Tampering of the engine speed/position sensors.

Inspect the intake manifold for sources of flammable vapors. Check the turbocharger seals to verify there are no oil leaks. Inspect the engine speed/position sensors for damage or tampering.

Refer to Troubleshooting Fault Code 234 .

Last Modified: 18-Jan-2020


EGR Valve Control Circuit - Current Below Normal or Open Circuit

FAULT CODE 2349

EGR Valve Control Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2349 PID: S146 SPN: 2791 FMI: 5/5 LAMP: Amber SRT: | Motor terminal or motor coil open circuit has been detected by the ECM. | Possible reduced engine performance.
EGR Valve Circuit

Circuit Description

The exhaust gas recirculation (EGR) valve is opened by a motor located on top of the EGR valve. A motor shaft extends from the motor and contacts the dual-poppet valve to open the EGR valve. The EGR valve motor does not actually retract the EGR valve. The motor current is reduced and the spring pushes the EGR valve closed.

Component Location

The EGR valve is located on the air intake connection.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON and occasionally during normal engine operation after the EGR valve is commanded closed.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an open circuit in the engine wiring harness or EGR valve motor coil.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Exhaust gas recirculation (EGR) valve operation will be disabled.

  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and leave the key in the ON position for 2 minutes. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

EGR motor circuit open circuit

Open circuit in the wiring harness

Refer to Troubleshooting Fault Code 2349 .

Last Modified: 18-Jan-2020


Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 235

Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 235 PID: P111 SPN: 111 FMI: 1/1 LAMP: Red SRT: | The engine coolant is severely low. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Engine Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level was below normal.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code goes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant.

The engine protection for coolant level is a customer feature and will only be enabled at the customer's request. This sensor must deactivate or disable the fuel control valve if this feature is utilized by the OEM.

If this fault code is active and the coolant level is not low, disconnect the coolant level sensor and check the connectors for traces of coolant. If coolant is found at the electrical connectors, the sensor has malfunctioned and must be replaced.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Possible causes of this fault code include:

Low coolant level

Refer to Troubleshooting Fault Code 235 .

Last Modified: 18-Jan-2020


EGR Valve Control Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2351

EGR Valve Control Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2351 PID: S146 SPN: 2791 FMI: 4/4 LAMP: Amber SRT: | Motor terminal or motor coil short circuit to ground or power supply has been detected by the engine control module (ECM). | Possible reduced engine performance.
EGR Valve Circuit

Circuit Description

The exhaust gas recirculation (EGR) valve is opened by a motor located on top of the EGR valve. A motor shaft extends from the motor and contacts the dual-poppet valve to open the EGR valve. The EGR valve motor does not actually retract the EGR valve. The motor current is reduced and the spring pushes the EGR valve closed.

Component Location

The EGR Valve and EGR Differential Pressure Sensor location varies depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON and occasionally during normal engine operation after the EGR valve is commanded closed.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a short circuit to ground in the EGR motor supply circuits.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Exhaust gas recirculation (EGR) valve operation will be disabled.

  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and leave the key in the ON position for 2 minutes. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

One of the EGR motor circuits shorted to ground in the EGR valve motor

One of the EGR motor circuits shorted to ground in the harness

Refer to Troubleshooting Fault Code 2351 .

Last Modified: 18-Jan-2020


EGR Valve Control Circuit - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 2357

EGR Valve Control Circuit - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2357 PID: S146 SPN: 2791 FMI: 7/7 LAMP: Amber SRT: | The EGR valve motor has exceeded the duty cycle limit, indicating a stuck open EGR valve. | EGR valve actuation will be disabled.
EGR Valve Circuit

Circuit Description

The exhaust gas recirculation (EGR) valve is opened by a motor located on top of the EGR valve. A motor shaft extends from the motor and contacts the dual-poppet valve to open the EGR valve. The EGR valve motor does not actually retract the EGR valve. The motor current is reduced and the spring pushes the EGR valve closed.

Component Location

The EGR valve is located on the air intake connection.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON and occasionally during normal engine operation after the EGR valve is commanded closed.

Conditions for Setting the Fault Codes

This fault code is set when the duty cycle required to open the turbocharger wastegate is greater than 95 percent for 3 seconds. The fault code is triggered after two failed attempts. The fault code will be inactive at key ON. It will only become active if the turbocharger actuator is commanded open and the wastegate is unable to move to the commanded position.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Exhaust gas recirculation (EGR) valve operation will be disabled.

The engine will enter an alternative engine protection mode with no desired EGR flow, open loop fueling, and full torque derate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and leave the key in the ON position for 2 minutes. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is triggered when the EGR valve motor is unable to move the EGR valve in the open position. This is normally caused by a restriction in the EGR valve not allowing the EGR valve to move to the commanded position.

The fault code will be inactive at key ON. It will only go active if the EGR valve is commanded open and the EGR valve is unable to move to the commanded position.

Refer to Troubleshooting Fault Code 2357 .

Last Modified: 18-Jan-2020


Engine Brake Actuator Driver Output 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2363

Engine Brake Actuator Driver Output 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2363 PID: S80 SPN: 1073 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at the engine brake solenoid number 2 signal circuit. | Possible reduce engine braking performance.
Engine Brake Actuator Driver 2 Circuit

Circuit Description

The engine control module (ECM) controls engine brakes on cylinders 4, 5, and 6 by sending a signal on the engine brake solenoid number 2 signal circuit. If an engine brake is installed, there will be a jumper harness from this connector to the engine brake pass-through connectors on the rocker lever housing.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake solenoids are controlled through the engine harness by the ECM.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine brake 2 pulse width modulated (PWM) signal was not detected to be system voltage when the PWM signal was turned on.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The engine brake 2 circuit will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, drive the vehicle and operate the engine brakes. This will allow the diagnostic to run. If the fault code does not become active again, the repair has been validated.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The engine brake fault code will only become active once the engine brakes are activated and will remain active until the ECM is powered down. Once the ECM is powered down, the fault code will be inactive until the engine brakes are activated again, if the circuit interruption is still present. This tree is designed to troubleshoot an inactive fault code.

Possible causes of this fault code include:

A short circuit to ground in the engine harness

A malfunctioning engine brake solenoid

Refer to Troubleshooting Fault Code 2363 .

Last Modified: 18-Jan-2020


Engine Brake Actuator Driver Output 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2367

Engine Brake Actuator Driver Output 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2367 PID: S80 SPN: 1073 FMI: 3/3 LAMP: Amber SRT: | Open circuit or high voltage detected at the engine brake solenoid Number 2 signal circuit. | Possible reduce engine braking performance.
Engine Brake Actuator Driver 2 Circuit

Circuit Description

The engine control module (ECM) controls engine brakes on cylinders 4, 5, and 6 by sending a signal on the engine brake solenoid number 2 signal circuit. If an engine brake is installed, there will be a jumper harness from this connector to the engine brake pass-through connectors on the rocker lever housing.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake solenoids are controlled through the engine harness by the ECM.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine brake 2 pulse width modulated (PWM) signal was detected to be system voltage when the PWM signal was turned off.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The engine brake 2 circuit will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, drive the vehicle and operate the engine brakes. This will allow the diagnostic to run. If the fault code does not become active again, the repair has been validated.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The engine brake fault code will only become active once the engine brakes are activated and will remain active until the ECM is powered down. Once the ECM is powered down, the fault code will be inactive until the engine brakes are activated again, if the circuit interruption is still present. This tree is designed to troubleshoot an inactive fault code.

Possible causes of this fault code include:

A short circuit to battery in the engine harness.

A malfunctioning engine brake solenoid

A malfunctioning ECM.

Refer to Troubleshooting Fault Code 2367 .

Last Modified: 18-Jan-2020


Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2375

Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2375 PID: P412 SPN: 412 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at EGR temperature circuit. | Possible reduced engine performance.
Exhaust Gas Recirculation Temperature Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) temperature sensor is a variable resistor sensor and is used to measure the temperature of the EGR gas flow after it exits the EGR cooler. The engine control module (ECM) supplies 5 volts to the EGR temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the EGR flow temperature.

The EGR temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The EGR temperature sensor is located on the EGR connection tube between the EGR cooler and the air intake connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR temperature signal voltage was greater than 4.9-VDC for more than 8 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the exhaust gas recirculation temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • Engine coolant temperature must read above 0°C [32°F].
  • Turbocharger compressor intake air temperature and intake manifold air temperature are greater than 5Â°C [41Â°F].
  • The engine operating state is run for greater than 120 seconds.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The EGR temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • An open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code 2375 .

Last Modified: 18-Jan-2020


Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2376

Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2376 PID: P412 SPN: 412 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at EGR temperature circuit. | Possible reduced engine performance.
Exhaust Gas Recirculation Temperature Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) temperature sensor is a variable resistor sensor and is used to measure the temperature of the EGR gas flow after it exits the EGR cooler. The engine control module (ECM) supplies 5 volts to the EGR temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the EGR flow temperature.

The EGR temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The EGR temperature sensor is located on the EGR connection tube between the EGR cooler and the air intake connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR temperature signal voltage was less than 0.05-VDC for more than 8 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the exhaust gas recirculation temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and run it at high idle for 5 minutes.
  • Engine coolant temperature must read above 0°C [32°F].
  • Turbocharger compressor intake air temperature and intake manifold air temperature are greater than 5Â°C [41Â°F].
  • The engine operating state is run for greater than 120 seconds.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The EGR temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

A signal shorted to ground in the harness

A signal shorted to return or ground in the sensor.

A malfunctioning EGR temperature sensor

Refer to Troubleshooting Fault Code 2376 .

Last Modified: 18-Jan-2020


Fan Control Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2377

Fan Control Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2377 PID: S33 SPN: 647 FMI: 3/3 LAMP: Amber SRT: | Open circuit or high voltage detected at the fan control circuit. | None on performance. The fan can stay on continuously or not run at all.
Fan Control Circuit

Circuit Description

The fan control circuit is a device used by the engine to control the fan operation. When the engine control module (ECM) energizes the fan control circuit, the engine fan is engaged.

The fan control circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

There are two types of fans supported by the fan control circuit; variable speed and ON/OFF. The recommended Cummins® electronic service tool or equivalent can be used to determine which fan type is currently set up for use. The fan control circuit varies by original equipment manufacturer (OEM). Certain OEMs can use a solenoid return that is wired to the ECM or can use a return that goes to the engine block or chassis ground.

Component Location

The control solenoid location varies by OEM. Refer to the appropriate OEM service manual to determine the location.

Conditions for Running the Diagnostics

For ON/OFF and variable speed fan types, the diagnostic runs when the fan is turned off and will latch active when the fan PWM signal is 100 percent. For all other fan types, the diagnostic runs when the fan PWM signal is less than 100 percent and will latch active when the fan PWM signal is 100 percent.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fan control circuit pulse width modulated (PWM) signal voltage was greater then 0-VDC when the PWM signal was commanded OFF.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Fan operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If Fault Code 2377 is still active after completing all the steps in this fault code troubleshooting tree, consult the OEM service literature for procedures to check the fan clutch device for an open circuit or short circuit to ground.

Possible causes of this fault code include:

An open circuit in the harness or fan control solenoid.

A short circuit to voltage source in the OEM harness.

A malfunctioning ECM.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 2377 .

Last Modified: 18-Jan-2020


Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 238

Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 238 PID: S232 SPN: 3511 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected on the +5 volt sensor supply circuit to the engine speed sensor. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Sensor Supply 3 Circuit

Circuit Description

The sensor supply 3 circuit provides a 5 volt supply to the primary engine speed/position sensor.

Component Location

Sensor Supply 3 originates in the engine connector portion of the ECM. It provides 5 VDC to the engine crankshaft speed/position sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 3 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The camshaft position sensor will be used by the ECM to determine engine speed and position.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The ECM monitors the voltage level on the engine speed sensor +5 volt supply circuit. If the voltage falls below a calibratible limit, this fault is recorded.

Possible causes of this fault code include:

Short circuit to ground in the engine harness, sensor, or ECM.

Refer to Troubleshooting Fault Code 238 .

Last Modified: 18-Jan-2020


Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 239

Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 239 PID: S232 SPN: 3511 FMI: 3/3 LAMP: Amber SRT: | High voltage detected on the 5 volt sensor supply circuit to the engine speed sensor. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Sensor Supply 3 Circuit

Circuit Description

The sensor supply 3 circuit provides a 5 volt supply to the primary engine speed/position sensor.

Component Location

Sensor Supply 3 originates in the engine connector portion of the ECM. It provides 5 VDC to the engine crankshaft speed/position sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 3 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The camshaft position sensor will be used by the ECM to determine engine speed and position.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

High voltage on the +5 volt supply wire can be caused by a short to battery voltage in the engine harness or connectors, or a damaged ECM.

Refer to Troubleshooting Fault Code 239 .

Last Modified: 18-Jan-2020


Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect

FAULT CODE 241

Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 241 PID: P84 SPN: 84 FMI: 2/2 LAMP: Amber SRT: | The ECM lost the vehicle speed signal or is reading an erratic value. | Engine speed limited to Maximum Engine Speed without VSS parameter value. Cruise Control, Gear-Down Protection, and Road Speed Governor will not work.
Vehicle Speed Sensor Circuit

Circuit Description

The vehicle speed sensor senses the speed of the tailshaft gear on the vehicle's transmission. This speed signal is then transmitted to the engine control module (ECM) and converted into a vehicle speed.

Component Location

The vehicle speed sensor is located in the rear of the vehicle transmission. Refer to the OEM service manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the vehicle is in motion, if the feature is enabled.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of vehicle speed when other engine operating conditions indicated that the vehicle should be in motion. This fault code can also become active if the calculated gear ratio and actual gear ratio do not agree while the vehicle is in motion.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

The engine speed operating range is limited to the adjustable parameter "Maximum Engine Speed without VSS".

ECM powerdown will be delayed for 60 seconds after key OFF.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and move the vehicle so the ECM can read a vehicle speed. The vehicle may need to be driven for up to 15 minutes to get the diagnostic to run and the fault to go inactive.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

There are multiple types of vehicle speed sensors. Various types include magnetic pickup, data link, digital, and tachograph. Contact the OEM for the specific type installed on the vehicle.

This fault is set active when the ECM loses a vehicle speed signal when other engine conditions indicate the vehicle is moving. The fault can also become active if there is a series of clutch, service brake or throttle movements with no vehicle movement. The fault is set inactive when the ECM receives a valid vehicle speed signal.

Since the vehicle speed sensor is an OEM installed component, this troubleshooting procedure will not cover all malfunctions of the circuit due to components not under Cummins® Inc. control. Sensor resistance values, data link speed sensors and tachographs are not fully covered under this procedure. For more information on those components, refer to the OEM service manual.

A damaged vehicle speed sensor or debris on the end of the sensor could cause the fault to become active.

Incorrect Cummins® electronic service tool feature and parameter settings (gear ratio, tire size, rear axle ratio, etc) will also cause the fault to become active. Feature and parameter settings under Transmission Setup and Vehicle Speed source need to be verified with the vehicle components.

NOTE: If the power is removed from the ECM within 60 seconds of key OFF and before the ECM has powered down, Fault Code 1117 may become active.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 241 .

Last Modified: 18-Jan-2020


Wheel-Based Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change

FAULT CODE 242

Wheel-Based Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 242 PID: P84 SPN: 84 FMI: 10/10 LAMP: Amber SRT: | Signal indicates an intermittent connection or VSS tampering. | Engine speed limited to Maximum Engine Speed without VSS parameter value. Cruise Control, Gear-Down Protection, and Road Speed Governor will not work.
Vehicle Speed Sensor Circuit

Circuit Description

The vehicle speed sensor senses the speed of the tailshaft gear on the vehicle's transmission. This speed signal is then transmitted to the engine control module (ECM) and converted into a vehicle speed.

Component Location

The vehicle speed sensor is located in the rear of the vehicle transmission. Refer to the OEM service manual for location.

Conditions for Running the Diagnostics

The adjustable parameter "VSS Anti-Tampering" must be enabled.

This diagnostic runs continuously when the vehicle is in motion, if the feature is enabled.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a tampering event of the vehicle speed signal.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The engine speed operating range is limited to the adjustable parameter "Maximum Engine Speed without VSS".

Cruise Control, Gear-Down Protection, and Road Speed Governor features will be disabled.

Conditions for Clearing the Fault Code

  • The keyswitch must be turned ON, and the vehicle speed and engine speed must be zero for 30 seconds.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Verify that the feature settings for the vehicle speed sensor anti-tampering (Fault Code 242), application type and automatic transmission are set correctly. If any of these are set incorrectly for the specific vehicle and application, Fault Code 242 could occur erroneously.

Driving techniques such as driving for extended periods of time in lower gears can log Fault Code 242. Fault Code 242 can be logged if the driver attempts to defeat the road speed governor by repeatedly cycling the keyswitch.

Once the speed signal has been restored the fault code will go inactive once the keyswitch is ON for 30 seconds and the ECM senses zero vehicle and engine speed.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 242 .

Last Modified: 18-Jan-2020


Engine Cylinder 1 (A1) Knock - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2431

Engine Cylinder 1 (A1) Knock - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2431 PID: S90 SPN: 1352 FMI: 0/15 LAMP: Amber SRT: | Engine Cylinder 1 (A1) Knock - Data Valid but Above Normal Operating Range - Least Severe Level. | Engine power derate.
Knock Sensor Circuit

Circuit Description

The knock sensor is an accelerometer that measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. One sensor can be used for multiple cylinders.

Component Location

Knock sensor 1 is located on the intake side of the cylinder head, next to the number 1 valve cover. Knock sensor 2 is located near the bottom of cylinder block, between the ECM and the oil pressure sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine knock for this cylinder is greater than a calibrated value.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Engine torque and/or engine speed derate will be active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the knock faults occurred.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The knock sensors measure the high frequency vibration of the engine due to combustion knock. Knock may occur if the engine is supplied low quality fuel or if operated at excessive temperatures. Other sources of high frequency vibration may also cause knock faults to be logged. These may include gear-driven accessories such as air compressors or hydraulic pumps, driveline vibration, or a rough running engine due to low fuel pressure.

When the conditions exist, knock faults typically will occur when operated at full power, such as during wide open throttle acceleration. Faults will likely be inactive at idle.

Refer to Troubleshooting Fault Code 2431 .

Last Modified: 18-Jan-2020


Engine Cylinder 2 (B1) Knock - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2432

Engine Cylinder 2 (B1) Knock - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2432 PID: S91 SPN: 1353 FMI: 0/15 LAMP: Amber SRT: | Engine Cylinder 2 (B1) Knock - Data Valid but Above Normal Operating Range - Least Severe Level | Engine power derate.
Knock Sensor Circuit

Circuit Description

The knock sensor is an accelerometer that measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. One sensor can be used for multiple cylinders.

Component Location

Knock sensor 1 is located on the intake side of the cylinder head, next to the number 1 valve cover. Knock sensor 2 is located near the bottom of cylinder block, between the ECM and the oil pressure sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine knock for this cylinder is greater than a calibrated value.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Engine torque and/or engine speed derate will be active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the knock faults occurred.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The knock sensors measure the high frequency vibration of the engine due to combustion knock. Knock may occur if the engine is supplied low quality fuel or if operated at excessive temperatures. Other sources of high frequency vibration may also cause knock faults to be logged. These may include gear-driven accessories such as air compressors or hydraulic pumps, driveline vibration, or a rough running engine due to low fuel pressure.

When the conditions exist, knock faults typically will occur when operated at full power, such as during wide open throttle acceleration. Faults will likely be inactive at idle.

Refer to Troubleshooting Fault Code 2432 .

Last Modified: 18-Jan-2020


Engine Cylinder 3 (A2) Knock - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2433

Engine Cylinder 3 (A2) Knock - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2433 PID: S92 SPN: 1354 FMI: 0/15 LAMP: Amber SRT: | Engine Cylinder 3 (A2) Knock - Data Valid but Above Normal Operating Range - Least Severe Level. | Engine power derate.
Knock Sensor Circuit

Circuit Description

The knock sensor is an accelerometer that measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. One sensor can be used for multiple cylinders.

Component Location

Knock sensor 1 is located on the intake side of the cylinder head, next to the number 1 valve cover. Knock sensor 2 is located near the bottom of cylinder block, between the ECM and the oil pressure sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine knock for this cylinder is greater than a calibrated value.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Engine torque and/or engine speed derate will be active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the knock faults occurred.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The knock sensors measure the high frequency vibration of the engine due to combustion knock. Knock may occur if the engine is supplied low quality fuel or if operated at excessive temperatures. Other sources of high frequency vibration may also cause knock faults to be logged. These may include gear-driven accessories such as air compressors or hydraulic pumps, driveline vibration, or a rough running engine due to low fuel pressure.

When the conditions exist, knock faults typically will occur when operated at full power, such as during wide open throttle acceleration. Faults will likely be inactive at idle.

Refer to Troubleshooting Fault Code 2433 .

Last Modified: 18-Jan-2020


Engine Cylinder 4 (B2) Knock - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2434

Engine Cylinder 4 (B2) Knock - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2434 PID: S93 SPN: 1355 FMI: 0/15 LAMP: Amber SRT: | Engine Cylinder 1 (A1) Knock - Data Valid but Above Normal Operating Range - Least Severe Level. | Engine power derate.
Knock Sensor Circuit

Circuit Description

The knock sensor is an accelerometer that measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. One sensor can be used for multiple cylinders.

Component Location

Knock sensor 1 is located on the intake side of the cylinder head, next to the number 1 valve cover. Knock sensor 2 is located near the bottom of cylinder block, between the ECM and the oil pressure sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine knock for this cylinder is greater than a calibrated value.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Engine torque and/or engine speed derate will be active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the knock faults occurred.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The knock sensors measure the high frequency vibration of the engine due to combustion knock. Knock may occur if the engine is supplied low quality fuel or if operated at excessive temperatures. Other sources of high frequency vibration may also cause knock faults to be logged. These may include gear-driven accessories such as air compressors or hydraulic pumps, driveline vibration, or a rough running engine due to low fuel pressure.

When the conditions exist, knock faults typically will occur when operated at full power, such as during wide open throttle acceleration. Faults will likely be inactive at idle.

Refer to Troubleshooting Fault Code 2434 .

Last Modified: 18-Jan-2020


Engine Cylinder 5 (A3) Knock - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2435

Engine Cylinder 5 (A3) Knock - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2435 PID: S94 SPN: 1356 FMI: 0/15 LAMP: Amber SRT: | Engine Cylinder 5 (A3) Knock - Data Valid but Above Normal Operating Range - Least Severe Level | Engine power derate.
Knock Sensor Circuit

Circuit Description

The knock sensor is an accelerometer that measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. One sensor can be used for multiple cylinders.

Component Location

Knock sensor 1 is located on the intake side of the cylinder head, next to the number 1 valve cover. Knock sensor 2 is located near the bottom of cylinder block, between the ECM and the oil pressure sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine knock for this cylinder is greater than a calibrated value.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Engine torque and/or engine speed derate will be active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the knock faults occurred.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The knock sensors measure the high frequency vibration of the engine due to combustion knock. Knock may occur if the engine is supplied low quality fuel or if operated at excessive temperatures. Other sources of high frequency vibration may also cause knock faults to be logged. These may include gear-driven accessories such as air compressors or hydraulic pumps, driveline vibration, or a rough running engine due to low fuel pressure.

When the conditions exist, knock faults typically will occur when operated at full power, such as during wide open throttle acceleration. Faults will likely be inactive at idle.

Refer to Troubleshooting Fault Code 2435 .

Last Modified: 18-Jan-2020


Engine Cylinder 6 (B3) Knock - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2436

Engine Cylinder 6 (B3) Knock - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2436 PID: S95 SPN: 1357 FMI: 0/15 LAMP: Amber SRT: | Engine Cylinder 6 (B3) Knock - Data Valid but Above Normal Operating Range - Least Severe Level. | Engine power derate.
Knock Sensor Circuit

Circuit Description

The knock sensor is an accelerometer that measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. One sensor can be used for multiple cylinders.

Component Location

Knock sensor 1 is located on the intake side of the cylinder head, next to the number 1 valve cover. Knock sensor 2 is located near the bottom of cylinder block, between the ECM and the oil pressure sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine knock for this cylinder is greater than a calibrated value.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Engine torque and/or engine speed derate will be active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the knock faults occurred.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The knock sensors measure the high frequency vibration of the engine due to combustion knock. Knock may occur if the engine is supplied low quality fuel or if operated at excessive temperatures. Other sources of high frequency vibration may also cause knock faults to be logged. These may include gear-driven accessories such as air compressors or hydraulic pumps, driveline vibration, or a rough running engine due to low fuel pressure.

When the conditions exist, knock faults typically will occur when operated at full power, such as during wide open throttle acceleration. Faults will likely be inactive at idle.

Refer to Troubleshooting Fault Code 2436 .

Last Modified: 18-Jan-2020


Coolant Level - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 2448

Coolant Level - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2448 PID: P111 SPN: 111 FMI: 1/17 LAMP: Maintenance SRT: | Low engine coolant level detected. | None on performance.
Engine Coolant Level Sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine coolant level sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine coolant level sensor provides a signal to the ECM on the engine coolant level sensor signal circuit. This sensor signal voltage changes based on the coolant level in the expansion tank.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level sensor signal voltage is between 1.75 VDC and 3 VDC for more than 30 seconds, indicating low coolant level.

Action Taken When the Fault Code is Active

The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code goes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 2448 .

Last Modified: 18-Jan-2020


Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 245

Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 245 PID: S33 SPN: 647 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the fan control circuit when commanded ON. | The fan can stay on continuously or not run at all.
Fan Clutch Circuit

Circuit Description

The fan control circuit is a device used by the engine to control the fan operation. When the engine control module (ECM) energizes the fan control circuit, the engine fan is engaged.

The fan control circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

There are two types of fans supported by the fan control circuit; variable speed and ON/OFF. The recommended Cummins® electronic service tool or equivalent can be used to determine which fan type is currently set up for use. The fan control circuit varies by original equipment manufacturer (OEM). Certain OEMs can use a solenoid return that is wired to the ECM or can use a return that goes to the engine block or chassis ground.

Component Location

The control solenoid location varies by OEM. Refer to the appropriate OEM service manual to determine the location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fan control circuit pulse width modulated (PWM) signal was not at system voltage when the pulse width modulated (PWM) signal was commanded ON.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Fan operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The fan control logic can be adjusted with the recommended Cummins® electronic service tool or equivalent. There are two choices: 12 or 24 volts ON, or 0 volts ON. For proper fan operation, the fan control logic setup with the recommended Cummins® electronic service tool or equivalent must match the hardware configuration on the vehicle.

This fault code is logged when the ECM commands 12 or 24-VDC to the fan control solenoid, but the voltage on the fan control signal circuit is less than 12 or 24-VDC. The low voltage on the signal circuit usually indicates a short circuit to ground in the harness or solenoid.

If Fault Code 245 is still active after completing the following troubleshooting steps, consult the OEM service manual for procedures to check the fan control circuit for a short circuit to ground.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 245 .

Last Modified: 18-Jan-2020


Turbocharger Turbine Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2451

Turbocharger Turbine Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2451 PID: S384 SPN: 2789 FMI: 0/16 LAMP: None SRT: | Turbocharger turbine intake temperature has exceeded the engine protection limit. | Possible reduced engine performance.
Turbocharger Turbine Inlet Temperature Sensor Circuit

Circuit Description

The engine turbocharger turbine intake temperature sensor is a variable resistor sensor and is used to measure the temperature of the exhaust gas entering the turbine of the turbocharger. The engine control module (ECM) supplies 5 volts to the engine turbocharger turbine intake temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the temperature of the exhaust entering the turbine. The ECM uses the engine turbocharger turbine intake temperature sensor for engine protection purposes.

Component Location

The engine turbocharger turbine intake temperature sensor is located in the turbocharger turbine housing.

Conditions for Running the Diagnostics

This diagnostic runs continouosly after the engine has been running for 2 minutes.

Conditions for Setting the Fault Codes

The ECM detects that the turbine intake temperature is greater than a calibrated value for more than 10 seconds.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Fuel is limited in an attempt to decrease the exhaust gas temperature entering the turbocharger.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Note: This fault code will most likely not be active with no load in the shop. The engine must be loaded to trip this fault code, and to determine if the cause has been found and repaired. Running units on the dynamometer can sometimes cause this fault code to log, due to the stationary nature and high temperatures.

Possible causes of this fault code include:

High intake air temperature

High coolant temperature

A damaged turbocharger or turbocharger wastegate

Combustion Knock

Exhaust leaks in the EGR system.

Refer to Troubleshooting Fault Code 2451 .

Last Modified: 18-Jan-2020


Engine Misfire for Multiple Cylinders - Condition Exists

FAULT CODE 2457

Engine Misfire for Multiple Cylinders - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2457 PID: SPN: 1322 FMI: 11/31 LAMP: Red SRT: | Engine misfire has been detected in multiple cylinder numbers. | Possible reduced engine performance.
Ignition System Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

The ICM is located above the ECM on the intake side of the engine near the fuel control housing.

The coils are located on the lever cover on the intake side of the engine. A high voltage wire is used to complete the connection to the spark plug.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a misfire of two or more cylinders.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the misfire occurred.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If the ECM does not receive a signal on the secondary return wire after a cylinder has been commanded to fire, the ECM will log this as a misfire. In addition to the three misfire faults for each cylinder, misfire percentages are also calculated over all six cylinders. There are three levels of severity for misfire on multiple cylinders.

Causes of cylinder misfire can include:

Damaged spark plugs

Shorted or open ignition harness

Malfunctioning coils

Spark plugs past maintenance intervals

In addition, misfires on multiple cylinders may be caused by low fuel pressure, EGR, voltage supply, fuel system, or oxygen sensor issues. Any fault codes for these systems should be resolved prior to troubleshooting the misfire compliant.

All secondary return wires in the ignition harness are tied together. This way there will be continuity through each secondary return pin of each coil to the main secondary return wire at the ignition harness connector 2. If one of the secondary return wires is found to be open, then the ICM will think that the engine is misfiring when it is not.

Refer to Troubleshooting Fault Code 2457 .

Last Modified: 18-Jan-2020


Engine Turbocharger 1 Boost Pressure Sensor - Voltage Above Normal or Shorted to High Source

FAULT CODE 2517

Engine Turbocharger 1 Boost Pressure Sensor - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2517 PID: S309 SPN: 1127 FMI: 3/3 LAMP: Amber SRT: | The ECM has diagnosed the compressor outlet pressure sensor is shorted to a voltage source. | Possible reduced engine performance.
Throttle Intake Pressure Sensor

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine throttle intake pressure sensor. The ECM also provides a ground on the sensor return circuit. The engine throttle intake pressure sensor provides a signal to the ECM on the engine throttle intake pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure of the air entering the engine throttle. The ECM will detect a low signal voltage when the engine throttle intake pressure is low. The ECM will detect a high signal voltage when the engine throttle intake pressure is high.

Component Location

The ICM is located next to the ECM on the intake side of the engine under the engine throttle actuator.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the engine throttle pressure signal voltage is above 4.95-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If the engine throttle intake pressure sensor is disconnected, the engine can continue operating by using the throttle plate position and the engine intake manifold pressure to estimate the throttle intake pressure. The engine throttle intake pressure sensor has been referred to as the boost pressure sensor and the mixer inlet pressure sensor in previous products.

Possible cause of this fault code:

Damaged wiring harness

Damaged sensor

Refer to Troubleshooting Fault Code 2517 .

Last Modified: 18-Jan-2020


Engine Turbocharger 1 Boost Pressure Sensor - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2518

Engine Turbocharger 1 Boost Pressure Sensor - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2518 PID: S309 SPN: 1127 FMI: 4/4 LAMP: Amber SRT: | The ECM diagnosed the compressor outlet pressure sensor has been shorted to ground. | Possible reduced engine performance.
Throttle Intake Pressure Sensor

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine throttle intake pressure sensor. The ECM also provides a ground on the sensor return circuit. The engine throttle intake pressure sensor provides a signal to the ECM on the engine throttle intake pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure of the air entering the engine throttle. The ECM will detect a low signal voltage when the engine throttle intake pressure is low. The ECM will detect a high signal voltage when the engine throttle intake pressure is high.

Component Location

Throttle Valve Differential Pressure Sensor is located at the Throttle Actuator Assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the engine throttle pressure signal voltage is less than 0.06-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value of the Engine Intake Air Pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If the engine throttle intake pressure sensor is disconnected, the engine can continue operating by using the throttle plate position and the engine intake manifold pressure to estimate the throttle intake pressure. The engine throttle intake pressure sensor has been referred to as the boost pressure sensor and the mixer inlet pressure sensor in previous products.

Possible cause of this fault code:

Damaged wiring harness

Damaged sensor

Refer to Troubleshooting Fault Code 2518 .

Last Modified: 18-Jan-2020


Engine Misfire Cylinder 1 - Condition Exists

FAULT CODE 2533

Engine Misfire Cylinder 1 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2533 PID: SPN: 1323 FMI: 11/31 LAMP: Red SRT: | Engine misfire has been detected in cylinder number 1. | Possible reduced engine performance.
Ignition Timing Signal Circuit

Circuit Description

Engine misfire means lack of combustion in the cylinder due to poor fuel metering, poor compression, or any other cause. This diagnostic is designed to detect engine misfires by looking at the exhaust manifold pressure (EMP) signal. The Exhaust Pressure signal is monitored during the combustion state of each cylinder individually. A cylinder with a poor exhaust signal determines a misfire.

Component Location

Cylinder number 1 is located at the front of the engine where the gear housing is mounted and cylinder number 6 is located at the rear of the engine where the flywheel housing is mounted.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a cylinder 1 misfire.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the misfire occurred.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If the ICM detects an abnormal fire pulse on the cylinder, it will indicate misfire to the ECM via the spark return signal wire.

Causes of cylinder misfire can include:

Damaged spark plug wire

Damaged spark plugs

Shorted or open ignition harness

Damage ICM

Refer to Troubleshooting Fault Code 2533 .

Last Modified: 18-Jan-2020


Engine Misfire Cylinder 2 - Condition Exists

FAULT CODE 2534

Engine Misfire Cylinder 2 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2534 PID: SPN: 1324 FMI: 11/31 LAMP: Red SRT: | Engine misfire has been detected in cylinder number 2. | Possible reduced engine performance.
Combustion control system

Circuit Description

Engine misfire means lack of combustion in the cylinder due to poor fuel metering, poor compression, or any other cause. This diagnostic is designed to detect engine misfires by looking at the exhaust manifold pressure (EMP) signal. The Exhaust Pressure signal is monitored during the combustion state of each cylinder individually. A cylinder with a poor exhaust signal determines a misfire.

Component Location

Cylinder number 1 is located at the front of the engine where the gear housing is mounted and cylinder number 6 is located at the rear of the engine where the flywheel housing is mounted.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a cylinder 2 misfire.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the misfire occurred.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If the ICM detects an abnormal fire pulse on the cylinder, it will indicate misfire to the ECM via the spark return signal wire.

Causes of cylinder misfire can include:

Damaged spark plug wire

Damaged spark plugs

Shorted or open ignition harness

Damage ICM

Refer to Troubleshooting Fault Code 2534 .

Last Modified: 18-Jan-2020


Engine Misfire Cylinder 3 - Condition Exists

FAULT CODE 2535

Engine Misfire Cylinder 3 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2535 PID: SPN: 1325 FMI: 11/31 LAMP: Red SRT: | Engine misfire has been detected in cylinder number 3. | Possible reduced engine performance.
Ignition Timing Signal Circuit

Circuit Description

Engine misfire means lack of combustion in the cylinder due to poor fuel metering, poor compression, or any other cause. This diagnostic is designed to detect engine misfires by looking at the exhaust manifold pressure (EMP) signal. The Exhaust Pressure signal is monitored during the combustion state of each cylinder individually. A cylinder with a poor exhaust signal determines a misfire.

Component Location

Cylinder number 1 is located at the front of the engine where the gear housing is mounted and cylinder number 6 is located at the rear of the engine where the flywheel housing is mounted.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a cylinder 3 misfire.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the misfire occurred.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If the ICM detects an abnormal fire pulse on the cylinder, it will indicate misfire to the ECM via the spark return signal wire.

Causes of cylinder misfire can include:

Damaged spark plug wire

Damaged spark plugs

Shorted or open ignition harness

Damage ICM

Refer to Troubleshooting Fault Code 2535 .

Last Modified: 18-Jan-2020


Engine Misfire Cylinder 4 - Condition Exists

FAULT CODE 2536

Engine Misfire Cylinder 4 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2536 PID: SPN: 1326 FMI: 11/31 LAMP: Red SRT: | Engine misfire has been detected in cylinder number 4. | Possible reduced engine performance.
Ignition Timing Signal Circuit

Circuit Description

Engine misfire means lack of combustion in the cylinder due to poor fuel metering, poor compression, or any other cause. This diagnostic is designed to detect engine misfires by looking at the exhaust manifold pressure (EMP) signal. The Exhaust Pressure signal is monitored during the combustion state of each cylinder individually. A cylinder with a poor exhaust signal determines a misfire.

Component Location

Cylinder number 1 is located at the front of the engine where the gear housing is mounted and cylinder number 6 is located at the rear of the engine where the flywheel housing is mounted.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a cylinder 4 misfire.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the misfire occurred.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If the ICM detects an abnormal fire pulse on the cylinder, it will indicate misfire to the ECM via the spark return signal wire.

Causes of cylinder misfire can include:

Damaged spark plug wire

Damaged spark plugs

Shorted or open ignition harness

Damage ICM

Refer to Troubleshooting Fault Code 2536 .

Last Modified: 18-Jan-2020


Engine Misfire Cylinder 5 - Condition Exists

FAULT CODE 2537

Engine Misfire Cylinder 5 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2537 PID: SPN: 1327 FMI: 11/31 LAMP: Red SRT: | Engine misfire has been detected in cylinder number 5. | Possible reduced engine performance.
Ignition Timing Signal Circuit

Circuit Description

Engine misfire means lack of combustion in the cylinder due to poor fuel metering, poor compression, or any other cause. This diagnostic is designed to detect engine misfires by looking at the exhaust manifold pressure (EMP) signal. The Exhaust Pressure signal is monitored during the combustion state of each cylinder individually. A cylinder with a poor exhaust signal determines a misfire.

Component Location

Cylinder number 1 is located at the front of the engine where the gear housing is mounted and cylinder number 6 is located at the rear of the engine where the flywheel housing is mounted.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a cylinder 5 misfire.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the misfire occurred.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If the ICM detects an abnormal fire pulse on the cylinder, it will indicate misfire to the ECM via the spark return signal wire.

Causes of cylinder misfire can include:

Damaged spark plug wire

Damaged spark plugs

Shorted or open ignition harness

Damage ICM

Refer to Troubleshooting Fault Code 2537 .

Last Modified: 18-Jan-2020


Engine Misfire Cylinder 6 - Condition Exists

FAULT CODE 2538

Engine Misfire Cylinder 6 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2538 PID: SPN: 1328 FMI: 11/31 LAMP: Red SRT: | Engine misfire has been detected in cylinder number 6. | Possible reduced engine performance.
Ignition Timing Signal Circuit

Circuit Description

Engine misfire means lack of combustion in the cylinder due to poor fuel metering, poor compression, or any other cause. This diagnostic is designed to detect engine misfires by looking at the exhaust manifold pressure (EMP) signal. The Exhaust Pressure signal is monitored during the combustion state of each cylinder individually. A cylinder with a poor exhaust signal determines a misfire.

Component Location

Cylinder number 1 is located at the front of the engine where the gear housing is mounted and cylinder number 6 is located at the rear of the engine where the flywheel housing is mounted.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a cylinder 6 misfire.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the misfire occurred.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If the ICM detects an abnormal fire pulse on the cylinder, it will indicate misfire to the ECM via the spark return signal wire.

Causes of cylinder misfire can include:

Damaged spark plug wire

Damaged spark plugs

Shorted or open ignition harness

Damage ICM

Refer to Troubleshooting Fault Code 2538 .

Last Modified: 18-Jan-2020


Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 254

Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 254 PID: S17 SPN: 632 FMI: 4/4 LAMP: Red SRT: | Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at fuel shutoff valve circuit | Engine will shut down.
Fuel Shutoff Valve Circuit

Circuit Description

The fuel shutoff valve is a device used by the engine control module (ECM) to control the engine fuel supply. When the ECM energizes the engine fuel shutoff valve driver circuit, the engine fuel shutoff valve is opened. Zero voltage to the engine fuel shutoff valve will close the engine fuel shutoff valve.

Component Location

The fuel shutoff valve is a serviceable part located on the continuous flow valve.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected no voltage when the engine fuel shutoff valve is commanded open.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine fuel shutoff valve will not open. The engine will not start or run

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A pin-to-pin short circuit

A short circuit to ground in the engine harness

A malfunctioning fuel shutoff valve.

Refer to Troubleshooting Fault Code 254 .

Last Modified: 18-Jan-2020


Engine Fuel Shutoff Valve Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 255

Engine Fuel Shutoff Valve Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 255 PID: S17 SPN: 632 FMI: 3/3 LAMP: Amber SRT: | Open circuit or short to voltage source detected at fuel shutoff valve circuit. | Engine may not start.
Fuel Shutoff Valve Circuit

Circuit Description

The fuel shutoff valve is a device used by the engine control module (ECM) to control the engine fuel supply. When the ECM energizes the engine fuel shutoff valve driver circuit, the engine fuel shutoff valve is opened. Zero voltage to the engine fuel shutoff valve will close the engine fuel shutoff valve.

Component Location

The engine fuel shutoff valve is located on the back of the fuel module, near the fuel pressure regulator end cap.

Conditions for Running the Diagnostics

This diagnostic consists of two parts. The first part of this diagnostic runs at initial key ON and the second part runs when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected voltage when the engine fuel shutoff valve is commanded closed.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The engine fuel shutoff valve will not open. The engine will not start or run

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

A pin-to-pin short circuit

A malfunctioning fuel shutoff valve.

Refer to Troubleshooting Fault Code 255 .

Last Modified: 18-Jan-2020


Gas Supply Pressure (Regulated) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 2568

Gas Supply Pressure (Regulated) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2568 PID: P159 SPN: 159 FMI: 0/0 LAMP: Red SRT: | The ECM has diagnosed that the fuel supply pressure has become too high for safe engine operation. | Engine power derate.
Fuel Supply Pressure Sensor

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine fuel regulator intake pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine fuel regulator intake pressure sensor provides a signal to the ECM on the engine fuel regulator intake pressure sensor circuit. This sensor signal voltage changes, based on the pressure of the fuel entering (low pressure) regulator.

Component Location

The engine fuel regulator intake pressure sensor is located in the fuel housing near the fuel supply fitting.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel pressure entering the engine (low pressure) regulator is greater than a calibrated value.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the fuel delivery pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Two types of fuel systems can be used, compressed natural gas (CNG) or liquefied natural gas (LNG). The fuel system components up to the engine (low pressure) regulator are supplied by the OEM. If the fuel pressure at the intake of the engine (low pressure) regulator is too high, this indicates a problem with the OEM supplied fuel system components or the fuel supply.

Possible cause of this fault code:

Over-pressurized fuel tanks

  • Malfunctioning OEM (high pressure) regulator

Malfunctioning engine fuel regulator pressure sensor.

Refer to Troubleshooting Fault Code 2568 .

Last Modified: 18-Jan-2020


Engine Spark Plug #1 (A1) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2586

Engine Spark Plug #1 (A1) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2586 PID: SPN: 1294 FMI: 0/15 LAMP: None SRT: | Higher than normal spark plug voltage has been detected. | None on performance.
Ignition Timing Signal Circuit

Circuit Description

The ignition system uses a separate ignition control module (ICM) to operate the ignition system. The ICM controls two ignition coil packs. Coil pack 1 generates the voltage to fire cylinders 1 thru 3. coil pack 2 generates the voltage to fire cylinders 4 thru 6. Spark timing is controlled by the ECM. The ECM commands the ICM to energize the ignition coil for the current cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary return lines in the ignition harness. The ICM is capable of measuring spark voltage over the secondary return wire in the ignition harness. The ECM receives this information over the spark voltage signal line.

Component Location

Spark plugs and coils are located on the cylinder head.

The ICM is located next to the ECM on the intake side of the engine, near the flywheel housing.

Conditions for Running the Diagnostics

The diagnostic runs when the intake manifold pressure is greater than a calibrated value.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark plug in cylinder A1 is sparking with high voltage.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and perform a stall test.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the engine is in normal service or misfire complaints. Most probable cause will be a spark plug with too large of a gap, or damaged/failed ignition coil.

Refer to Troubleshooting Fault Code 2586 .

Last Modified: 18-Jan-2020


Engine Spark Plug #2 (B1) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2587

Engine Spark Plug #2 (B1) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2587 PID: SPN: 1295 FMI: 0/15 LAMP: None SRT: | Higher than normal spark plug voltage has been detected. | Engine will misfire or run rough.
Ignition Timing Signal Circuit

Circuit Description

The ignition system uses a separate ignition control module (ICM) to operate the ignition system. The ICM controls two ignition coil packs. Coil pack 1 generates the voltage to fire cylinders 1 thru 3. coil pack 2 generates the voltage to fire cylinders 4 thru 6. Spark timing is controlled by the ECM. The ECM commands the ICM to energize the ignition coil for the current cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary return lines in the ignition harness. The ICM is capable of measuring spark voltage over the secondary return wire in the ignition harness. The ECM receives this information over the spark voltage signal line.

Component Location

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

The diagnostic runs when the intake manifold pressure is greater than a calibrated value.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark plug in cylinder B1 is sparking with high voltage.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and perform a stall test.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the engine is in normal service or misfire complaints. Most probable cause will be a spark plug with too large of a gap, or damaged/failed ignition coil.

Refer to Troubleshooting Fault Code 2587 .

Last Modified: 18-Jan-2020


Engine Spark Plug #3 (A2) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2588

Engine Spark Plug #3 (A2) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2588 PID: SPN: 1296 FMI: 0/15 LAMP: None SRT: | Higher than normal spark plug voltage has been detected. | Engine will misfire or run rough.
Ignition Timing Signal Circuit

Circuit Description

The ignition system uses a separate ignition control module (ICM) to operate the ignition system. The ICM controls two ignition coil packs. Coil pack 1 generates the voltage to fire cylinders 1 thru 3. coil pack 2 generates the voltage to fire cylinders 4 thru 6. Spark timing is controlled by the ECM. The ECM commands the ICM to energize the ignition coil for the current cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary return lines in the ignition harness. The ICM is capable of measuring spark voltage over the secondary return wire in the ignition harness. The ECM receives this information over the spark voltage signal line.

Component Location

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

The diagnostic runs when the intake manifold pressure is greater than a calibrated value.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark plug in cylinder A2 is sparking with high voltage.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and perform a stall test.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the engine is in normal service or misfire complaints. Most probable cause will be a spark plug with too large of a gap, or damaged/failed ignition coil.

Refer to Troubleshooting Fault Code 2588 .

Last Modified: 18-Jan-2020


Engine Spark Plug #4 (B2) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2589

Engine Spark Plug #4 (B2) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2589 PID: SPN: 1297 FMI: 0/15 LAMP: None SRT: | Higher than normal spark plug voltage has been detected. | Engine will misfire or run rough.
Ignition Timing Signal Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

The diagnostic runs when the intake manifold pressure is greater than a calibrated value.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark plug in cylinder B2 is sparking with high voltage.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and perform a stall test.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the engine is in normal service or misfire complaints. Most probable cause will be a spark plug with too large of a gap, or damaged/failed ignition coil.

Refer to Troubleshooting Fault Code 2589 .

Last Modified: 18-Jan-2020


Engine Spark Plug #5 (A3) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2591

Engine Spark Plug #5 (A3) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2591 PID: SPN: 1298 FMI: 0/15 LAMP: None SRT: | Higher than normal spark plug voltage has been detected. | Engine will misfire or run rough.
Ignition Timing Signal Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

The diagnostic runs when the intake manifold pressure is greater than a calibrated value.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark plug in cylinder A3 is sparking with high voltage.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and perform a stall test.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the engine is in normal service or misfire complaints. Most probable cause will be a spark plug with too large of a gap, or damaged/failed ignition coil.

Refer to Troubleshooting Fault Code 2591 .

Last Modified: 18-Jan-2020


Engine Spark Plug #6 (B3) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2592

Engine Spark Plug #6 (B3) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2592 PID: SPN: 1299 FMI: 0/15 LAMP: None SRT: | Higher than normal spark plug voltage has been detected. | Engine will misfire or run rough.
Ignition Timing Signal Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

The diagnostic runs when the intake manifold pressure is greater than a calibrated value.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark plug in cylinder B3 is sparking with high voltage.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and perform a stall test.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the engine is in normal service or misfire complaints. Most probable cause will be a spark plug with too large of a gap, or damaged/failed ignition coil.

Refer to Troubleshooting Fault Code 2592 .

Last Modified: 18-Jan-2020


Engine Spark Plug #1 (A1) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 2593

Engine Spark Plug #1 (A1) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2593 PID: SPN: 1294 FMI: 1/17 LAMP: None SRT: | Lower than normal spark plug voltage has been detected. | Engine will misfire or run rough.
Ignition Timing Signal Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

The diagnostic runs when the intake manifold pressure is greater than a calibrated value.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark plug in cylinder A1 is sparking with low voltage.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and perform a stall test.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the engine is in normal service or misfire complaints. Most probable cause will be a spark plug with too large of a gap, or damaged/failed ignition coil.

Refer to Troubleshooting Fault Code 2593 .

Last Modified: 18-Jan-2020


Engine Spark Plug #2 (B1) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 2594

Engine Spark Plug #2 (B1) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2594 PID: SPN: 1295 FMI: 1/17 LAMP: None SRT: | Lower than normal spark plug voltage has been detected. | Engine will misfire or run rough.
Ignition Timing Signal Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

The diagnostic runs when the intake manifold pressure is greater than a calibrated value.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark plug in cylinder B1 is sparking with low voltage.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and perform a stall test.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the engine is in normal service or misfire complaints. Most probable cause will be a spark plug with too large of a gap, or damaged/failed ignition coil.

Refer to Troubleshooting Fault Code 2594 .

Last Modified: 18-Jan-2020


Engine Spark Plug #3 (A2) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 2595

Engine Spark Plug #3 (A2) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2595 PID: SPN: 1296 FMI: 1/17 LAMP: None SRT: | Lower than normal spark plug voltage has been detected. | Engine will misfire or run rough.
Ignition Timing Signal Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

The diagnostic runs when the intake manifold pressure is greater than a calibrated value.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark plug in cylinder A2 is sparking with low voltage.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and bring it to 100% load for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the engine is in normal service or misfire complaints. Most probable cause will be a spark plug with too large of a gap, or damaged/failed ignition coil.

Refer to Troubleshooting Fault Code 2595 .

Last Modified: 18-Jan-2020


Engine Spark Plug #4 (B2) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 2596

Engine Spark Plug #4 (B2) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2596 PID: SPN: 1297 FMI: 1/17 LAMP: None SRT: | Lower than normal spark plug voltage has been detected. | Engine will misfire or run rough.
Ignition Timing Signal Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

The diagnostic runs when the intake manifold pressure is greater than a calibrated value.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark plug in cylinder B2 is sparking with low voltage.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the engine is in normal service or misfire complaints. Most probable cause will be a spark plug with too large of a gap, or damaged/failed ignition coil.

Refer to Troubleshooting Fault Code 2596 .

Last Modified: 18-Jan-2020


Engine Spark Plug #5 (A3) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 2597

Engine Spark Plug #5 (A3) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2597 PID: SPN: 1298 FMI: 1/17 LAMP: None SRT: | Lower than normal spark plug voltage has been detected. | Engine will misfire or run rough.
Ignition Timing Signal Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

The diagnostic runs when the intake manifold pressure is greater than a calibrated value.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark plug in cylinder A3 is sparking with low voltage.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the engine is in normal service or misfire complaints. Most probable cause will be a spark plug with too large of a gap, or damaged/failed ignition coil.

Refer to Troubleshooting Fault Code 2597 .

Last Modified: 18-Jan-2020


Engine Spark Plug #6 (B3) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 2598

Engine Spark Plug #6 (B3) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2598 PID: SPN: 1299 FMI: 1/17 LAMP: None SRT: | Lower than normal spark plug voltage has been detected. | Engine will misfire or run rough.
Ignition Timing Signal Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

The diagnostic runs when the intake manifold pressure is greater than a calibrated value.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the spark plug in cylinder B3 is sparking with low voltage.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This fault code is for information only and does not light a lamp when it becomes active. The fault is designed to inform the technician that a potential problem with the spark plugs, ignition coils, ignition harness, or ICM exists when the engine is in normal service or misfire complaints. Most probable cause will be a spark plug with too large of a gap, or damaged/failed ignition coil.

Refer to Troubleshooting Fault Code 2598 .

Last Modified: 18-Jan-2020


Engine Misfire Multiple Cylinder Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2616

Engine Misfire Multiple Cylinder Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2616 PID: SPN: 1322 FMI: 3/3 LAMP: Amber SRT: | Engine Misfire Multiple Cylinder Circuit - Voltage Above Normal or Shorted to High Source. | Possible reduced engine performance.
Ignition Timing Signal Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

The ICM is located next to the ECM on the intake side of the engine under the engine throttle actuator.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detects that the voltage on the combustion detection signal line is greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the misfire occurred.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A pin-to-pin short circuit

Refer to Troubleshooting Fault Code 2616 .

Last Modified: 18-Jan-2020


Engine Misfire Multiple Cylinder Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2617

Engine Misfire Multiple Cylinder Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2617 PID: SPN: 1322 FMI: 4/4 LAMP: Amber SRT: | Engine Misfire Multiple Cylinder Circuit - Voltage Below Normal or Shorted to Low Source. | Possible reduced engine performance.
Ignition Timing Signal Circuit

Circuit Description

The ignition system uses a separate ignition control module (ICM) to operate the ignition system. The ICM controls two ignition coil packs. Coil pack 1 generates the voltage to fire cylinders 1 thru 3. coil pack 2 generates the voltage to fire cylinders 4 thru 6. Spark timing is controlled by the ECM. The ECM commands the ICM to energize the ignition coil for the current cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary return lines in the ignition harness. The ICM is capable of measuring spark voltage over the secondary return wire in the ignition harness. The ECM receives this information over the spark voltage signal line.

Component Location

The ICM is located next to the ECM on the intake side of the engine under the engine throttle actuator.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detects that the voltage on the combustion detection signal line is less than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the misfire occurred.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If the ICM detects an abnormal fire pulse on the cylinder, it will indicate misfire to the ECM via the spark return signal wire.

Causes of cylinder misfire can include:

Damaged spark plug wire

Damaged spark plugs

Shorted or open ignition harness

Damage ICM

Refer to Troubleshooting Fault Code 2617 .

Last Modified: 18-Jan-2020


Engine Fuel Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 263

Engine Fuel Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 263 PID: P174 SPN: 174 FMI: 3/3 LAMP: Amber SRT: | High signal voltage or open circuit detected at fuel temperature circuit. | Possible reduced engine performance.
Engine Fuel Regulator Outlet Pressure/Temperature Sensor Circuit

Circuit Description

The engine fuel regulator outlet pressure/temperature sensor is a variable resistor sensor and is used to measure the temperature of the fuel exiting the engine (low pressure) regulator. The electronic control module (ECM) supplies 5 volts to the engine fuel regulator outlet temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the fuel temperature.

Component Location

The engine fuel regulator outlet pressure/temperature sensor is located in the fuel housing near the gas mass flow sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel regulator outlet temperature signal voltage was greater than 4.95-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

A default value for the fuel temperature sensor reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

When the fuel temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage, or low temperature. When the fuel temperature is hot, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Possible causes of this fault code include:

A pin-to-pin short circuit

Open circuit on the signal wire

malfunctioning fuel regulator outlet pressure/temperature sensor

Operation in extremely cold ambient conditions.

Refer to Troubleshooting Fault Code 263 .

Last Modified: 18-Jan-2020


Turbocharger 1 Turbine Intake Temperature - Voltage Above Normal or Shorted to High Source

FAULT CODE 2641

Turbocharger 1 Turbine Intake Temperature - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2641 PID: S384 SPN: 1180 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the turbocharger compressor intake air temperature circuit. | Possible reduced engine performance.
Turbocharger Turbine Inlet Temperature Sensor Circuit

Circuit Description

The engine turbocharger turbine intake temperature sensor is a variable resistor sensor and is used to measure the temperature of the exhaust gas entering the turbine of the turbocharger. The engine control module (ECM) supplies 5 volts to the engine turbocharger turbine intake temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the temperature of the exhaust entering the turbine. The ECM uses the engine turbocharger turbine intake temperature sensor for engine protection purposes.

Component Location

The engine turbocharger turbine intake temperature sensor is located in the turbocharger turbine housing.

Conditions for Running the Diagnostics

This diagnostic runs continouosly after the engine has been running for 2 minutes.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected that the engine turbocharger turbine intake temperature signal voltage is shorted high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the engine turbocharger turbine intake temperature is used.

Engine protection for the turbocharger turbine intake temperature will be disabled

Conditions for Clearing the Fault Code

  • To validate the repair:
  • Engine coolant temperature must read above 0°C [32°F].
  • Turbocharger compressor intake air temperature and intake manifold air temperature are greater than 5Â°C [41Â°F].
  • The engine operating state is run for greater than 120 seconds.

Shop Talk

Possible causes of this fault code include:

Open circuit on the signal wire

Open circuit on the return wire

Refer to Troubleshooting Fault Code 2641 .

Last Modified: 18-Jan-2020


Turbocharger 1 Turbine Intake Temperature - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2642

Turbocharger 1 Turbine Intake Temperature - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2642 PID: S384 SPN: 1180 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the turbocharger compressor intake air temperature circuit. | Possible reduced engine performance.
Turbocharger Turbine Inlet Temperature Sensor Circuit

Circuit Description

The engine turbocharger turbine intake temperature sensor is a variable resistor sensor and is used to measure the temperature of the exhaust gas entering the turbine of the turbocharger. The engine control module (ECM) supplies 5 volts to the engine turbocharger turbine intake temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the temperature of the exhaust entering the turbine. The ECM uses the engine turbocharger turbine intake temperature sensor for engine protection purposes.

Component Location

The engine turbocharger turbine intake temperature sensor is located in the turbocharger turbine housing.

Conditions for Running the Diagnostics

This diagnostic runs continouosly after the engine has been running for 2 minutes.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected that the engine turbocharger turbine intake temperature signal voltage is shorted Low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the engine turbocharger turbine intake temperature is used.

Engine protection for the turbocharger turbine intake temperature will be disabled

Conditions for Clearing the Fault Code

  • To validate the repair:
  • Engine coolant temperature must read above 0°C [32°F].
  • Turbocharger compressor intake air temperature and intake manifold air temperature are greater than 5Â°C [41Â°F].
  • The engine operating state is run for greater than 120 seconds.

Shop Talk

Possible causes of this fault code include:

A signal shorted to ground in the harness

A signal shorted to return or ground in the sensor.

A Malfunctioning engine turbocharger turbine intake temperature sensor.

Refer to Troubleshooting Fault Code 2642 .

Last Modified: 18-Jan-2020


Throttle Position 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2643

Throttle Position 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2643 PID: SPN: 3673 FMI: 3/3 LAMP: Amber SRT: | Throttle Position 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source. | Possible increase in idle speed.
Electronic Throttle Control Actuator Circuit

Circuit Description

The engine turbocharger turbine intake temperature sensor is a variable resistor sensor and is used to measure the temperature of the exhaust gas entering the turbine of the turbocharger. The engine control module (ECM) supplies 5 volts to the engine turbocharger turbine intake temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the temperature of the exhaust entering the turbine. The ECM uses the engine turbocharger turbine intake temperature sensor for engine protection purposes.

Component Location

The engine throttle actuator is located between the air intake adapter and the fuel control housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that throttle position 2 signal voltage is above 4.95-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The engine throttle actuator will move to its default position and the throttle actuator driver circuit will be disabled.

Possible increase in idle speed

Conditions for Clearing the Fault Code

  • To validate the repair, cycle the keyswitch from OFF to ON.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

A damaged engine throttle actuator.

A pin-to-pin short circuit

Refer to Troubleshooting Fault Code 2643 .

Last Modified: 18-Jan-2020


Throttle Position 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2644

Throttle Position 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2644 PID: SPN: 3673 FMI: 4/4 LAMP: Amber SRT: | Throttle Position 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. | Engine will only idle.
Electronic Throttle Control Actuator Circuit

Circuit Description

The electronic control module (ECM) controls the engine throttle actuator, which is both an input and output device. There are two throttle position sensors located inside the engine throttle actuator and they share a common supply and return. The engine throttle actuator receives 5 volt supply voltage from the sensor supply 1. The ECM controls the position of the throttle across the engine throttle actuator (+) line.

Component Location

The engine throttle actuator is located between the air intake adapter and the fuel control housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that throttle position 2 signal voltage is below 0.05-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The engine throttle actuator will move to its default position and the throttle actuator driver circuit will be disabled.

Possible increase in idle speed

Conditions for Clearing the Fault Code

  • To validate the repair, cycle the keyswitch from OFF to ON.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

A damaged engine throttle actuator.

A pin-to-pin short circuit

Refer to Troubleshooting Fault Code 2644 .

Last Modified: 18-Jan-2020


Throttle Plate Position Sensor 1 and 2 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2645

Throttle Plate Position Sensor 1 and 2 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2645 PID: SPN: 3673 FMI: 2/2 LAMP: Red SRT: | Throttle Position Sensor - Data Erratic, Intermittent, or Incorrect. A fault throttle position signal has been detected | Possible increase in idle speed.
Electronic Throttle Control Actuator Circuit

Circuit Description

The electronic control module (ECM) controls the engine throttle actuator, which is both an input and output device. There are two throttle position sensors located inside the engine throttle actuator and they share a common supply and return. The engine throttle actuator receives 5 volt supply voltage from the sensor supply 1. The ECM controls the position of the throttle across the engine throttle actuator (+) line.

Component Location

The engine throttle actuator is located between the air intake adapter and the fuel control housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that throttle position 2 signal voltage is below 0.05-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The engine throttle actuator will move to its default position and the throttle actuator driver circuit will be disabled.

Possible increase in idle speed

Conditions for Clearing the Fault Code

  • To validate the repair, cycle the keyswitch from OFF to ON.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

A damaged engine throttle actuator.

A pin-to-pin short circuit

Refer to Troubleshooting Fault Code 2645 .

Last Modified: 18-Jan-2020


Engine Fuel Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 265

Engine Fuel Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 265 PID: P174 SPN: 174 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the engine fuel temperature sensor circuit. | Possible reduced engine performance.
Engine Fuel Regulator Outlet Pressure/Temperature Sensor Circuit

Circuit Description

The engine fuel regulator outlet pressure/temperature sensor is a variable resistor sensor and is used to measure the temperature of the fuel exiting the engine (low pressure) regulator. The electronic control module (ECM) supplies 5 volts to the engine fuel regulator outlet temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the fuel temperature.

Component Location

The engine fuel regulator outlet pressure/temperature sensor is located in the fuel housing near the gas mass flow sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel regulator outlet temperature signal voltage was less than 0.06-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the fuel temperature sensor reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

When the fuel temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to ground. Therefore, the ECM senses a high signal voltage, or low temperature. When the fuel temperature is hot, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Possible causes of this fault code include:

A signal shorted to ground in the harness

A signal shorted to return or ground in the sensor.

malfunctioning fuel regulator outlet pressure/temperature sensor

Refer to Troubleshooting Fault Code 265 .

Last Modified: 18-Jan-2020


Aftertreatment Intake Gas Sensor Heater - Voltage Above Normal or Shorted to High Source

FAULT CODE 2686

Aftertreatment Intake Gas Sensor Heater - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2686 PID: SPN: 3222 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Intake Oxygen Sensor Heater - Voltage Above Normal or Shorted to High Source. | Possible reduced engine performance.
Engine Turbocharger Outlet Oxygen Sensor

Circuit Description

The engine control module (ECM) uses this sensor to determine the composition of the exhaust gas so the fueling can be adjusted to maintain desired air/fuel ratio while operating in closed loop. The heater circuit is powered by the ECM to maintain proper temperature at the sensing tip. The heater line is shared between aftertreatment intake and outlet oxygen sensor circuit.

Component Location

The Aftertreatment Intake oxygen sensor is located in the exhaust system, after the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects voltage on the Aftertreatment Intake oxygen heater supply circuit when the heater is commanded OFF.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

A pin-to-pin short circuit

Refer to Troubleshooting Fault Code 2686 .

Last Modified: 18-Jan-2020


Aftertreatment Intake Gas Sensor Heater - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2687

Aftertreatment Intake Gas Sensor Heater - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2687 PID: SPN: 3222 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Intake Oxygen Sensor Circuit - Voltage Above Normal or Shorted to High Source | Possible reduced engine performance.
Engine Turbocharger Outlet Oxygen Sensor

Circuit Description

The engine control module (ECM) uses this sensor to determine the composition of the exhaust gas so the fueling can be adjusted to maintain desired air/fuel ratio while operating in closed loop. The heater circuit is powered by the ECM to maintain proper temperature at the sensing tip. The heater line is shared between aftertreatment intake and outlet oxygen sensor circuit.

Component Location

The Aftertreatment Intake oxygen sensor is located in the exhaust system, after the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects the aftertreatment Intake oxygen heater supply voltage is below a calibrated value when the heater is commanded on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Short to ground in the wiring harness

Refer to Troubleshooting Fault Code 2687 .

Last Modified: 18-Jan-2020


Engine Fuel Valve 1 Intake Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2722

Engine Fuel Valve 1 Intake Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2722 PID: SPN: 1390 FMI: 0/16 LAMP: Amber SRT: | Engine Gas Control Valve Intake Pressure - Data Valid but Above Normal Operating Range - Moderately Severe Level. | Possible reduced engine performance.
Engine Fuel Regulator Outlet Pressure/Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the engine fuel regulator outlet pressure/temperature sensor (combination sensor) to measure the pressure and temperature of fuel entering the engine fuel control valve. The electronic control module (ECM) provides a 5 volt supply to the engine fuel regulator outlet pressure/temperature sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine fuel regulator outlet pressure/temperature sensor provides a signal to the ECM on the engine fuel regulator intake pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure of the fuel exiting the engine (low pressure) regulator.

Component Location

The engine fuel regulator outlet pressure/temperature sensor is located in the fuel housing near the gas mass flow sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that pressure of the fuel exiting the engine (low pressure) regulator is greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the fuel delivery pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE light when the fuel pressure is within normal operating range.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Two types of fuel systems can be used, compressed natural gas (CNG) or liquefied natural gas (LNG). The fuel system components up to the engine (low pressure) regulator are supplied by the OEM. If the fuel pressure at the intake of the engine (low pressure) regulator is too high, this indicates a problem with the OEM supplied fuel system components or the fuel supply.

Possible causes of this fault code include:

malfunctioning fuel regulator outlet pressure/temperature sensor

High fuel pressure at the engine (low pressure) regulator.

Refer to Troubleshooting Fault Code 2722 .

Last Modified: 18-Jan-2020


Engine Fuel Valve 1 Intake Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2723

Engine Fuel Valve 1 Intake Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2723 PID: SPN: 1390 FMI: 1/18 LAMP: Amber SRT: | Engine Gas Control Valve Intake Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level. | Possible reduced engine performance.
Engine Fuel Regulator Outlet Pressure/Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the engine fuel regulator outlet pressure/temperature sensor (combination sensor) to measure the pressure and temperature of fuel entering the engine fuel control valve. The electronic control module (ECM) provides a 5 volt supply to the engine fuel regulator outlet pressure/temperature sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine fuel regulator outlet pressure/temperature sensor provides a signal to the ECM on the engine fuel regulator intake pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure of the fuel exiting the engine (low pressure) regulator.

Component Location

The engine fuel regulator outlet pressure/temperature sensor is located in the fuel housing near the gas mass flow sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that pressure of the fuel exiting the engine (low pressure) regulator is less than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the fuel delivery pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE light when the fuel pressure is within normal operating range.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Two types of fuel systems can be used, compressed natural gas (CNG) or liquefied natural gas (LNG). The fuel system components up to the engine (low pressure) regulator are supplied by the OEM. If the fuel pressure at the intake of the engine (low pressure) regulator is too high, this indicates a problem with the OEM supplied fuel system components or the fuel supply.

Possible causes of this fault code include:

malfunctioning fuel regulator outlet pressure/temperature sensor

A malfunctioning fuel shutoff valve.

Low pressure at the engine (low pressure) regulator

Damaged engine fuel regulator boost reference line

Refer to Troubleshooting Fault Code 2723 .

Last Modified: 18-Jan-2020


Gas Supply Pressure (Regulated) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2724

Gas Supply Pressure (Regulated) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2724 PID: P159 SPN: 159 FMI: 0/16 LAMP: Amber SRT: | Gas Supply Pressure (Regulated) - Data Valid but Above Normal operating Range - Moderately Severe Level | Engine power derate.
Engine Fuel Supply Pump Intake Pressure Sensor Circuit.

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine fuel regulator intake pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine fuel regulator intake pressure sensor provides a signal to the ECM on the engine fuel regulator intake pressure sensor circuit. This sensor signal voltage changes, based on the pressure of the fuel entering (low pressure) regulator.

Component Location

The engine fuel regulator intake pressure sensor is located in the fuel housing near the fuel supply fitting.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel pressure entering the engine (low pressure) regulator is greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the fuel delivery pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Two types of fuel systems can be used, compressed natural gas (CNG) or liquefied natural gas (LNG). The fuel system components up to the engine (low pressure) regulator are supplied by the OEM. If the fuel pressure at the intake of the engine (low pressure) regulator is too high, this indicates a problem with the OEM supplied fuel system components or the fuel supply.

Possible cause of this fault code:

Over-pressurized fuel tanks

  • Malfunctioning OEM (high pressure) regulator

Malfunctioning engine fuel regulator pressure sensor.

Refer to Troubleshooting Fault Code 2724 .

Last Modified: 18-Jan-2020


Gas Supply Pressure (Regulated) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2725

Gas Supply Pressure (Regulated) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2725 PID: P159 SPN: 159 FMI: 1/18 LAMP: Amber SRT: | The ECM has diagnosed that the fuel supply pressure has become too low for safe engine operation. | Engine power derate.
Fuel Supply Pressure Sensor

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine fuel regulator intake pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine fuel regulator intake pressure sensor provides a signal to the ECM on the engine fuel regulator intake pressure sensor circuit. This sensor signal voltage changes, based on the pressure of the fuel entering (low pressure) regulator.

Component Location

The engine fuel regulator intake pressure sensor is located in the fuel housing near the fuel supply fitting.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel pressure entering the engine (low pressure) regulator is less than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the fuel delivery pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate it at rated power.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE light when the fuel pressure is within normal operating range.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Two types of fuel systems can be used, compressed natural gas (CNG) or liquefied natural gas (LNG). The fuel system components up to the engine (low pressure) regulator are supplied by the OEM. If the fuel pressure at the intake of the engine (low pressure) regulator is too high, this indicates a problem with the OEM supplied fuel system components or the fuel supply.

Possible cause of this fault code:

Over-pressurized fuel tanks

  • Malfunctioning OEM (high pressure) regulator

Malfunctioning engine fuel regulator pressure sensor.

Refer to Troubleshooting Fault Code 2725 .

Last Modified: 18-Jan-2020


Engine Throttle Control Actuator - Current Above Normal or Grounded Circuit

FAULT CODE 2752

Engine Throttle Control Actuator - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2752 PID: SPN: 3464 FMI: 6/6 LAMP: Red SRT: | An open fault has been detected in Engine Throttle Control Actuator circuit. | Engine will only idle or will shut down.
Engine Throttle Control Circuit

Circuit Description

The electronic control module (ECM) controls the engine throttle actuator, which is both an input and output device. There are two throttle position sensors located inside the engine throttle actuator and they share a common supply and return. The engine throttle actuator receives 5 volt supply voltage from the sensor supply 1. The ECM controls the position of the throttle across the engine throttle actuator (+) line.

Component Location

The engine throttle actuator is located between the air intake adapter and the fuel control housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and the throttle duty cycle is greater than calibrated threshold.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an open circuit in the Engine Throttle Control Actuator circuit

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

The engine throttle actuator will move to its default position and the throttle actuator driver circuit will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A short circuit on the engine throttle actuator (+) or (-) line

An open circuit on the engine throttle actuator (+) or (-) line.

A malfunctioning engine intake air throttle actuator

Refer to Troubleshooting Fault Code 2752 .

Last Modified: 18-Jan-2020


Electronic Throttle Control Actuator - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 2758

Electronic Throttle Control Actuator - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2758 PID: SPN: 3464 FMI: 0/0 LAMP: Red SRT: | Electronic Throttle Control Actuator - Data Valid But Above Normal Operating Range - Most Severe Level | Engine may be shut down.
Engine Throttle Control Circuit

Circuit Description

The electronic control module (ECM) controls the engine throttle actuator, which is both an input and output device. There are two throttle position sensors located inside the engine throttle actuator and they share a common supply and return. The engine throttle actuator receives 5 volt supply voltage from the sensor supply 1. The ECM controls the position of the throttle across the engine throttle actuator (+) line.

Component Location

The engine throttle actuator is located between the air intake adapter and the fuel control housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is ON, the engine speed is above 1000 rpm, the accelerator is depressed, and the engine throttle actuator is commanded closed.

Conditions for Setting the Fault Codes

The ECM will log this fault if the sensed throttle position is greater than commanded throttle position by a calibrated value and sensed mass air flow is greater than a calibrated value.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

The engine will be shut down.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning engine intake air throttle actuator

intake throttle actuator sticking

If this fault code becomes active at startup when ambient conditions are or have been below freezing 0Â°C [32Â°F] in the past 24 hours, check the throttle actuator for signs of moisture or ice. Frozen condensation in the air intake may cause this fault code to become active.

Refer to Troubleshooting Fault Code 2758 .

Last Modified: 18-Jan-2020


Electronic Throttle Control Actuator - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 2759

Electronic Throttle Control Actuator - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2759 PID: SPN: 3464 FMI: 1/1 LAMP: Red SRT: | Electronic Throttle Control Actuator - Data Valid But Above Normal Operating Range - Most Severe Level | Possible increase in idle speed.
Engine Throttle Control Circuit

Circuit Description

The electronic control module (ECM) controls the engine throttle actuator, which is both an input and output device. There are two throttle position sensors located inside the engine throttle actuator and they share a common supply and return. The engine throttle actuator receives 5 volt supply voltage from the sensor supply 1. The ECM controls the position of the throttle across the engine throttle actuator (+) line.

Component Location

The engine throttle actuator is located between the air intake adapter and the fuel control housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is ON, the engine speed is above 1000 rpm, the accelerator is depressed, and the engine throttle actuator is commanded closed.

Conditions for Setting the Fault Codes

The ECM will log this fault if the sensed throttle position is less than commanded throttle position by a calibrated value.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

The engine throttle actuator will move to its default position and the throttle actuator driver circuit will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning engine intake air throttle actuator

If this fault code becomes active at startup when ambient conditions are or have been below freezing 0Â°C [32Â°F] in the past 24 hours, check the throttle actuator for signs of moisture or ice. Frozen condensation in the air intake may cause this fault code to become active.

Refer to Troubleshooting Fault Code 2759 .

Last Modified: 18-Jan-2020


Gas Mass Flow 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2775

Gas Mass Flow 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2775 PID: P149 SPN: 1241 FMI: 0/16 LAMP: Amber SRT: | Gas Mass Flow 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level | Possible reduced engine performance.
Gas Mass Flow Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the gas mass flow sensor to measure fuel into the engine and to adjust the fuel control valve based on this measurement.

Component Location

The gas mass flow sensor is located on the fuel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that actual gas flow is less than desired gass flow by more than a calibrated amount for more than 3 seconds

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The ECM will reset the fuel system tables.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Improper fuel pressure or low fuel.

Restriction due to deposits in the laminar flow screen and oil contamination in the mixer housing and gas flow sensor

A restriction in the fuel system

A damaged gas mass flow sensor

A damaged fuel control valve

Refer to Troubleshooting Fault Code 2775 .

Last Modified: 18-Jan-2020


Gas Mass Flow 1 - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2776

Gas Mass Flow 1 - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2776 PID: P149 SPN: 1241 FMI: 1/18 LAMP: Amber SRT: | Gas Mass Flow 1 Sensor - Data Valid but Below Normal Operating Range - Moderately Severe Level | Possible reduced engine performance.
Gas Mass Flow Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the gas mass flow sensor to measure fuel into the engine and to adjust the fuel control valve based on this measurement.

Component Location

The gas mass flow sensor is located on the fuel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that actual gas flow is less than desired gass flow by more than a calibrated amount for more than 3 seconds

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The ECM will reset the fuel system tables.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Causes of this fault include:

Improper fuel pressure or low fuel.

Restriction due to deposits in the laminar flow screen and oil contamination in the mixer housing and gas flow sensor

A restriction in the fuel system

A damaged gas mass flow sensor

A damaged fuel control valve

A leak in the fuel system

Refer to Troubleshooting Fault Code 2776 .

Last Modified: 18-Jan-2020


Engine Turbocharger 1 Boost Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2782

Engine Turbocharger 1 Boost Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2782 PID: S309 SPN: 1127 FMI: 0/16 LAMP: Amber SRT: | Engine Turbocharger 1 Boost Pressure Sensor - Data Valid But Above Normal Operating Range - Moderately Severe Level. | Possible reduced engine performance.
Engine Throttle Intake Pressure sensor

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine throttle intake pressure sensor. The ECM also provides a ground on the sensor return circuit. The engine throttle intake pressure sensor provides a signal to the ECM on the engine throttle intake pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure of the air entering the engine throttle. The ECM will detect a low signal voltage when the engine throttle intake pressure is low. The ECM will detect a high signal voltage when the engine throttle intake pressure is high.

Component Location

The engine throttle intake pressure sensor is located in the air stream after the charge-air cooler, just before the throttle actuator near the wastegate control valve.

Conditions for Running the Diagnostics

The diagnostic runs continuously when engine speed is greater than 700 rpm.

Conditions for Setting the Fault Codes

The ECM detects the engine throttle intake pressure is greater than a calibrated value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, key OFF for 1 minute, then key ON for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The engine throttle intake pressure sensor has been referred to as the boost pressure sensor and the mixer inlet pressure sensor in previous products.

Possible causes of this fault code include:

A damaged turbocharger compressor intake temperature sensor.

A damaged turbocharger or turbocharger wastegate

Incorrect turbocharger installed.

Refer to Troubleshooting Fault Code 2782 .

Last Modified: 18-Jan-2020


Engine Turbocharger 1 Boost Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2783

Engine Turbocharger 1 Boost Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2783 PID: S309 SPN: 1127 FMI: 1/18 LAMP: Amber SRT: | Engine Turbocharger 1 Boost Pressure - Data Valid but below normal operating range- moderately severe level. | Possible reduced engine performance.
Engine Throttle Intake Pressure sensor

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine throttle intake pressure sensor. The ECM also provides a ground on the sensor return circuit. The engine throttle intake pressure sensor provides a signal to the ECM on the engine throttle intake pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure of the air entering the engine throttle. The ECM will detect a low signal voltage when the engine throttle intake pressure is low. The ECM will detect a high signal voltage when the engine throttle intake pressure is high.

Component Location

The engine throttle intake pressure sensor is located in the air stream after the charge-air cooler, just before the throttle actuator near the wastegate control valve.

Conditions for Running the Diagnostics

The diagnostic runs continuously when engine speed is greater than 700 rpm.

Conditions for Setting the Fault Codes

the ECM detects that the engine throttle intake pressure is less than a calibrated value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, key OFF for 1 minute, then key ON for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If the engine throttle intake pressure sensor is disconnected, the engine can continue operating by using the throttle plate position and the engine intake manifold pressure to estimate the throttle intake pressure. The engine throttle intake pressure sensor has been referred to as the boost pressure sensor and the mixer inlet pressure sensor in previous products.

Possible causes of this fault code include:

A Malfunctioning throttle intake pressure sensor

Malfunctioning turbocharger wastegate

A malfunctioning turbocharger

Refer to Troubleshooting Fault Code 2783 .

Last Modified: 18-Jan-2020


SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

FAULT CODE 285

SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 285 PID: S231 SPN: 639 FMI: 9/9 LAMP: Amber SRT: | The ECM expected information from a multiplexed device but did not receive it soon enough or did not receive it at all. | At least one multiplexed device will not operate properly.
SAE J1939 Data Link Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The Engine Control Module (ECM) is mounted on the intake manifold side of the engine.

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

The Engine Control Module (ECM) detected an open or short circuit condition in the J1939 data link harness.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices can possibly not function as desired.

This fault can occur for the following reasons:

When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the CumminsÂ ECM, or the OEM VECU is not set up to transmit the multiplexed component message.

This fault can also be caused by a bad J1939 data link connection between the OEM VECU and Cummins® ECM, a bad connection between the component and the OEM VECU, bad OEM VECU or bad Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration. It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 285 .

Last Modified: 18-Jan-2020


J1939 Network #1 - Out of Calibration

FAULT CODE 286

J1939 Network #1 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 286 PID: S231 SPN: 639 FMI: 13/13 LAMP: Amber SRT: | The ECM expected information from a multiplexed device but only received a portion of the necessary information. | At least one multiplexed device will not operate properly.
SAE J1939 Data Link Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The Engine Control Module (ECM) is mounted on the intake manifold side of the engine.

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) received an invalid J1939 data link message from a multiplexed device for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault can occur when the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing.

It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 286 .

Last Modified: 01-Jun-2021


SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Position Sensor System - Received Network Data in Error

FAULT CODE 288

SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Position Sensor System - Received Network Data in Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 288 PID: P372 SPN: 974 FMI: 2/19 LAMP: Red SRT: | The original equipment manufacturer (OEM) vehicle electronic control unit (VECU) detected a fault with the remote accelerator. | Engine can ONLY idle or engine will NOT accelerate to full speed. Remote accelerator will not operate.
SAE J1939 Multiplexing Remote Accelerator Pedal or Lever

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) received a message from the OEM VECU via the J1939 data link, indicating the remote throttle signal wire or enable switch was shorted high or shorted low.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault can occur when the OEM VECU detects an error on the remote throttle and or remote throttle enable switch. The ECM has been set up properly (components enabled and OEM VECU source addressed correctly) to receive multiplexed information for the remote throttle enable switch states and remote accelerator position over the J1939 data link from an OEM VECU, and the OEM VECU is transmitting the message for that component. Most OEM VECUs will not have the circuitry to detect a remote throttle switch error.

The two types of errors that can occur for this fault are:

The OEM VECU determines that the remote throttle signal line is shorted high or shorted low. This fault status is transmitted to the Cummins® ECM on the J1939 data link, which causes this fault to occur in the Cummins® ECM.

When the remote throttle enable switch has a shorted high or shorted low error detected by the OEM VECU, this fault status is transmitted to the ECM on the J1939 data link, which causes this fault to occur in the ECM. Most OEM VECUs will not incorporate fault detection on a switch.

It is still possible to get a Fault Code 285 or 286, if there is an incorrect setup in the OEM VECU or Cummins® ECM for other components, or the remote throttle and remote throttle switch, or the data link is damaged. The OEM configurations must multiplex the remote throttle and remote throttle switch inputs together to allow the use of the J1939 multiplexing feature for these components. Use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 288 .

Last Modified: 18-Jan-2020


Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2961

Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2961 PID: P412 SPN: 412 FMI: 0/15 LAMP: None SRT: | EGR temperature has exceeded the engine protection limit. | Possible reduced engine performance.
Exhaust Gas Recirculation Temperature Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) temperature sensor is a variable resistor sensor and is used to measure the temperature of the EGR gas flow after it exits the EGR cooler. The engine control module (ECM) supplies 5 volts to the EGR temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the EGR flow temperature.

The EGR temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The EGR temperature sensor is located on the EGR connection tube between the EGR cooler and the air intake connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR temperature was greater than a threshold for 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate it at rated power.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Plugged or restricted EGR differential pressure sensor ports

A malfunctioning EGR valve

A low reading from the EGR differential pressure sensor

A low reading for the EGR valve position sensor

High exhaust temperatures

Low coolant level

High coolant temperature

An incorrect coolant/water mixture

A fouled EGR cooler.

Note: This fault code will most likely not be active with no load in the shop. The engine must be loaded to trigger this fault code.

Refer to Troubleshooting Fault Code 2961 .

Last Modified: 18-Jan-2020


Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2962

Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2962 PID: P412 SPN: 412 FMI: 0/16 LAMP: Amber SRT: | EGR temperature has exceeded the engine protection limit. | Possible reduced engine performance.
Exhaust Gas Recirculation Temperature Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) temperature sensor is a variable resistor sensor and is used to measure the temperature of the EGR gas flow after it exits the EGR cooler. The engine control module (ECM) supplies 5 volts to the EGR temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the EGR flow temperature.

The EGR temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The EGR temperature sensor is located on the EGR connection tube between the EGR cooler and the air intake connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR temperature was greater than a threshold for 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate it at rated power.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A fouled EGR cooler

Plugged or restricted EGR differential pressure sensor ports

A damaged EGR valve

A low reading from the EGR differential pressure sensor

A low reading for the EGR valve position sensor

High exhaust temperatures

Low coolant level

High coolant temperature

An incorrect coolant/water mixture

Note: This fault code will most likely not be active with no load in the shop. The engine must be loaded to trigger this fault code.

Refer to Troubleshooting Fault Code 2962 .

Last Modified: 18-Jan-2020


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2963

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2963 PID: P110 SPN: 110 FMI: 0/15 LAMP: None SRT: | Engine coolant temperature is above the engine protection warning limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was greater than a calibrated limit.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature. Refer to Engine Coolant Temperature Above Normal symptom troubleshooting tree in the base engine service manual.

Refer to Troubleshooting Fault Code 2963 .

Last Modified: 18-Jan-2020


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2964

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2964 PID: P105 SPN: 105 FMI: 0/15 LAMP: None SRT: | Intake manifold air temperature signal indicates intake manifold air temperature is above engine protection warning limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature was greater than a calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The intake manifold 1 temperature sensor measures the temperature of the charge-air as it passes through the intake manifold.

Possible causes of this fault code include:

Plugged charge-air cooler fins

Restricted airflow through the charge-air cooler

An undersized charge-air cooler

High turbocharger compressor outlet temperature.

Refer to Troubleshooting Fault Code 2964 .

Last Modified: 18-Jan-2020


Intake Manifold 1 Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2973

Intake Manifold 1 Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2973 PID: P102 SPN: 102 FMI: 2/2 LAMP: Amber SRT: | The intake manifold pressure sensor is reading an erratic value. | Possible reduced engine performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure sensor was reading higher or lower than expected at keyoff or during normal engine operation.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value of the intake manifold pressure reading is used.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A damaged intake manifold pressure sensor

Leaks in the air intake system between the turbocharger and intake manifold

Restriction in the charge-air cooler

Refer to Troubleshooting Fault Code 2973 .

Last Modified: 18-Jan-2020


Engine Intake Air Mass Flow - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2988

Engine Intake Air Mass Flow - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2988 PID: P132 SPN: 132 FMI: 0/16 LAMP: Amber SRT: | Engine Intake Air Mass Flow - Data Valid But Above Normal Operating Range - Moderately Severe Level. | Engine power derate.
Components for Mass Air Flow Calculation

Circuit Description

The engine control module (ECM) uses engine coolant temperature, engine throttle position, intake manifold pressure and temperature, humidity, and engine rpm to calculate the air flow into the engine.

Component Location

The ECM is located on the side of the engine, next to the ignition control module (ICM) and flywheel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 1200 RPM.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detects the calculated mass air flow is greater than the desired mass air flow by a calibrated value for a calibrated period of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A damaged turbocharger wastegate actuator.

A damaged turbocharger wastegate valve.

A damaged or disconnected wastegate actuator control line (boost reference line).

A malfunctioning wastegate control valve.

Refer to Troubleshooting Fault Code 2988 .

Last Modified: 18-Jan-2020


Engine Intake Air Mass Flow - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2989

Engine Intake Air Mass Flow - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2989 PID: P132 SPN: 132 FMI: 1/18 LAMP: Amber SRT: | Engine Intake Air Mass Flow - Data Valid But Below Normal Operating Range - Moderately Severe Level. | Engine power derate.
Components for Mass Air Flow Calculation

Circuit Description

The engine control module (ECM) uses engine coolant temperature, engine throttle position, intake manifold pressure and temperature, humidity, and engine rpm to calculate the air flow into the engine.

Component Location

The ECM is located on the side of the engine, next to the ignition control module (ICM) and flywheel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 1200 RPM.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detects the calculated mass air flow is less than the desired mass air flow by a calibrated value for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A damaged turbocharger wastegate actuator.

A damaged turbocharger wastegate valve.

Low Boost Pressure

A malfunctioning wastegate control valve.

Refer to Troubleshooting Fault Code 2989 .

Last Modified: 18-Jan-2020


Engine Fuel Valve 1 Intake Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 2991

Engine Fuel Valve 1 Intake Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2991 PID: SPN: 1390 FMI: 1/1 LAMP: Red SRT: | Engine Gas Control Valve Intake Pressure - Data Valid but Below Normal Operational Range - Most Severe Level. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Engine Fuel Regulator Outlet Pressure/Temperature Sensor Circuit

Circuit Description

The electronic control module (ECM) uses the engine fuel regulator outlet pressure/temperature sensor (combination sensor) to measure the pressure and temperature of fuel entering the engine fuel control valve. The electronic control module (ECM) provides a 5 volt supply to the engine fuel regulator outlet pressure/temperature sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine fuel regulator outlet pressure/temperature sensor provides a signal to the ECM on the engine fuel regulator intake pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure of the fuel exiting the engine (low pressure) regulator.

Component Location

The engine fuel regulator outlet pressure/temperature sensor is located in the fuel housing near the gas mass flow sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that pressure of the fuel exiting the engine (low pressure) regulator is less than a calibrated value.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

An engine speed derate will occur when the fault is registered.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Two types of fuel systems can be used, compressed natural gas (CNG) or liquefied natural gas (LNG). The fuel system components up to the engine (low pressure) regulator are supplied by the OEM. If the fuel pressure at the intake of the engine (low pressure) regulator is too high, this indicates a problem with the OEM supplied fuel system components or the fuel supply.

Possible causes of this fault code include:

malfunctioning fuel regulator outlet pressure/temperature sensor

A damaged engine (low pressure) regulator

Low pressure at the engine (low pressure) regulator

Refer to Troubleshooting Fault Code 2991 .

Last Modified: 18-Jan-2020


Tachograph Output Shaft Speed - Abnormal Update Rate

FAULT CODE 3186

Tachograph Output Shaft Speed - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3186 PID: SPN: 1623 FMI: 9/9 LAMP: Amber SRT: | No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the tachograph output shaft speed sensor. | None on performance.
Tachograph Output Shaft Speed Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices may not function as desired.

This fault can occur for the following reasons:

When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the CumminsÂ ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the CumminsÂ ECM, or the OEM VECU is not set up to transmit the multiplexed component message.

This fault can also be caused by a bad J1939 data link connection between the OEM VECU and Cummins® ECM, a bad connection between the component and the OEM VECU, bad OEM VECU or bad Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration. It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

Refer to Troubleshooting Fault Code 3186 .

Last Modified: 18-Jan-2020


Tachograph Output Shaft Speed - Received Network Data in Error

FAULT CODE 3213

Tachograph Output Shaft Speed - Received Network Data in Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3213 PID: SPN: 1623 FMI: 2/19 LAMP: Amber SRT: | The J1939 multiplexing controller has indicated a malfunction of the tachograph output shaft speed sensor. | None on performance.
SAE J1939 Backbone Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The OEM VECU determined that there was a malfunction of the tachograph output shaft speed sensor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The J1939 multiplexing controller has indicated a malfunction of the tachograph output shaft speed sensor.

Refer to Troubleshooting Fault Code 3213 .

Last Modified: 18-Jan-2020


Accelerator Pedal Position 1 - Abnormal Update Rate

FAULT CODE 3326

Accelerator Pedal Position 1 - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3326 PID: SPN: 91 FMI: 9/9 LAMP: Red SRT: | The ECM expected information from a multiplexed accelerator pedal or lever sensor but did not receive it soon enough or did not receive it at all. | Engine will only idle.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices may not function as desired.

This fault can occur for the following reasons:

The ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the Cummins® ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.

This fault can also be caused by a bad J1939 data link connection between the OEM VECU and Cummins® ECM, a bad connection between the component and the OEM VECU, bad OEM VECU or bad Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration. It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 3326 .

Last Modified: 01-Apr-2021


Transmission Output Shaft Speed - Abnormal Update Rate

FAULT CODE 3328

Transmission Output Shaft Speed - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3328 PID: SPN: 191 FMI: 9/9 LAMP: Amber SRT: | No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the transmission output shaft speed sensor. | None on performance.
Transmission Output Shaft Speed Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices may not function as desired.

This fault can occur for the following reasons:

When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the CumminsÂ ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the CumminsÂ ECM, or the OEM VECU is not set up to transmit the multiplexed component message.

This fault can also be caused by a bad J1939 data link connection between the OEM VECU and Cummins® ECM, a bad connection between the component and the OEM VECU, bad OEM VECU or bad Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration. It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3328 .

Last Modified: 18-Jan-2020


Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3366

Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3366 PID: SPN: 111 FMI: 1/18 LAMP: None SRT: | Low engine coolant level detected. | None on performance.
Engine Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level sensor signal voltage was greater than 3-VDC for more than 30 seconds, indicating severely low coolant level.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

For On-Board Diagnostic (OBD) engines, the ECM illuminates the the Malfunction Indicator Lamp (MIL) immediately after three consecutive trips in which the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code goes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and data link communication issues with aftertreatment components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing, or intermittent connections.

Refer to Troubleshooting Fault Code 3366 .

Last Modified: 18-Jan-2020


Specific Humidity Sensor - Abnormal Update Rate

FAULT CODE 3367

Specific Humidity Sensor - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3367 PID: SPN: 4490 FMI: 9/9 LAMP: Amber SRT: | No communication or an invalid data transfer rate has been detected on the J1939 data link between the engine control module (ECM) and the humidity sensor. | Possible reduced engine performance.
Engine Turbocharger Intake Humidity/Pressure/Temperature Sensor

Circuit Description

The engine turbocharger compressor intake humidity/pressure/temperature sensor is a smart sensor that communicates with the ECM through a private J1939 data link.

Component Location

The humidity sensor is located on the air inlet connection, which is connected to the compressor housing of the turbocharger.

Conditions for Running the Diagnostics

  • The first part of the diagnostic runs continuously while the keyswitch is in the ON position or the engine is running.

Conditions for Setting the Fault Codes

The ECM did not receive a message from the sensor

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible cause of this fault code:

An open or short circuit in the SAE J1939 datalink circuit

  • Supply wire open or shorted to ground.

A damaged Sensor

Refer to Troubleshooting Fault Code 3367 .

Last Modified: 18-Jan-2020


Specific Humidity Sensor - Received Network Data in Error

FAULT CODE 3368

Specific Humidity Sensor - Received Network Data in Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3368 PID: SPN: 4490 FMI: 2/19 LAMP: Amber SRT: | Specific Humidity Sensor - Received Network Data in Error. Smart sensor has detected an invalid reading and broadcasts the error message on the J1939 data link between the engine control module (ECM) and the humidity | Possible reduced engine performance.
Engine turbocharger Compressor Intake Humidity/Pressure/Temperature Sensor

Circuit Description

The engine turbocharger compressor intake humidity/pressure/temperature sensor is a smart sensor that communicates with the ECM through a private J1939 data link.

Component Location

The humidity sensor is located on the air inlet connection, which is connected to the compressor housing of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM did not receive a message from the sensor

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault can occur for the following reasons:

An open or short circuit in the SAE J1939 datalink circuit

Missing or open ground on the compressor intake elbow.

Damaged sensor

Refer to Troubleshooting Fault Code 3368 .

Last Modified: 18-Jan-2020


Roll Over Protection Brake Control Active - Condition Exists

FAULT CODE 3374

Roll Over Protection Brake Control Active - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3374 PID: SPN: 1818 FMI: 11/31 LAMP: None SRT: | The ECM received a message from the anti-lock braking (ABS) controller, inhibiting cruise control operation. | Cruise control could possibly not operate.
SAE J1939 Multiplexing Circuit

Circuit Description

Certain anti-lock braking (ABS) controllers communicate with the engine control module (ECM) through the SAE J1939 data link. Under certain driving conditions, the anti-lock braking (ABS) controller can send a cruise control inhibit message to the ECM and cruise control will temporarily be disabled.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The anti-lock bracking (ABS) controller detected certain driving conditions and inhibited cruise control.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Cruise control has temporarily been inhibited.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, cruise control could possibly not function. This is an information only fault code, indicating that the anti-lock braking (ABS) controller detected certain driving conditions and temporarily inhibited cruise control operation. Refer to the OEM service manual.

Refer to Troubleshooting Fault Code 3374 .

Last Modified: 18-Jan-2020


Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 338

Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 338 PID: S87 SPN: 1267 FMI: 3/3 LAMP: Amber SRT: | Open circuit or short to voltage source detected at the idle shutdown vehicle accessory/ignition bus relay circuit. | Vehicle accessories or ignition bus loads controlled by the idle shutdown relay will not power up.
Idle Shutdown Vehicle Accessories Relay Driver Circuit

Circuit Description

The Engine Control Module (ECM) Idle Shutdown feature has an optional parameter for a shutdown accessory relay. When this parameter is set to "Installed", the ECM sends a signal to energize the relay and turn off vehicle accessories during idle shutdown events. The idle shutdown relay return circuit varies by Original Equipment Manufacturer (OEM). The return circuit can be returned to the ECM through the ECM Return (General) or connected directly to ground. Refer to the OEM service manual to determine grounding configuration.

Component Location

The idle shutdown relay location varies by OEM. Refer to the OEM service manual to determine the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the idle shutdown relay pulse width modulated (PWM) signal was at system voltage when the pulse width modulated (PWM) signal was commanded OFF.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The accessories controlled by the idle shutdown relay will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The ECM monitors the voltage level on this circuit. If it detects a voltage when the signal is commanded off, it records this fault code. This fault code can be caused by:

ECM Idle Shutdown feature set up incorrectly.

Open circuit in the idle shutdown relay, OEM harness, or connectors.

Short circuit to a voltage source in the OEM harness or relay.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 338 .

Last Modified: 18-Jan-2020


Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 339

Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 339 PID: S87 SPN: 1267 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at the idle shutdown vehicle accessory or ignition bus relay circuit when commanded ON. | Vehicle accessories or ignition bus loads controlled by the idle shutdown relay will not power up.
Idle Shutdown Vehicle Accessories Relay Driver Circuit

Circuit Description

The Engine Control Module (ECM) Idle Shutdown feature has an optional parameter for a shutdown accessory relay. When this parameter is set to "Installed", the ECM sends a signal to energize the relay and turn off vehicle accessories during idle shutdown events. The idle shutdown relay return circuit varies by Original Equipment Manufacturer (OEM). The return circuit can be returned to the ECM through the ECM Return (General) or connected directly to ground. Refer to the OEM service manual to determine grounding configuration.

Component Location

The idle shutdown relay location varies by OEM. Refer to the OEM service manual to determine the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the idle shutdown relay pulse width modulated (PWM) signal was NOT at system voltage when the pulse width modulated (PWM) signal was commanded ON.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The accessories controlled by the idle shutdown relay will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The ECM monitors the voltage level on this circuit. This fault code is logged if it detects a low voltage when the relay signal is commanded on. This fault code can be caused by a short circuit to ground in the idle shutdown relay, OEM harness, or connectors.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Possible causes of this fault code include:

A short circuit to ground in the OEM harness

Refer to Troubleshooting Fault Code 339 .

Last Modified: 18-Jan-2020


Transmission Output Shaft Speed - Received Network Data in Error

FAULT CODE 3418

Transmission Output Shaft Speed - Received Network Data in Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3418 PID: SPN: 191 FMI: 2/19 LAMP: Amber SRT: | The J1939 multiplexing controller has indicated a malfunction of the transmission output shaft speed sensor. | None on performance.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The OEM VECU determined there was a malfunction of the transmission output shaft speed sensor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The J1939 multiplexing controller has indicated a malfunction of the transmission output shaft speed sensor.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM

For intermittent power supply and data link communication issues with aftertreatment components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing, or intermittent connections.

Refer to Troubleshooting Fault Code 3418 .

Last Modified: 18-Jan-2020


Aftertreatment Intake Oxygen Sensor - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3436

Aftertreatment Intake Oxygen Sensor - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3436 PID: SPN: 3217 FMI: 0/16 LAMP: Amber SRT: | The engine control module (ECM) has detected a lean condition for a sustained period of time. | Possible reduced engine performance.
Engine Turbocharger Intake Oxygen Sensor

Circuit Description

The engine control module (ECM) uses this sensor to determine the composition of the exhaust gas so the fueling can be adjusted to maintain desired air/fuel ratio while operating in closed loop. The heater circuit is powered by the ECM to maintain proper temperature at the sensing tip. The heater line is shared between aftertreatment intake and outlet oxygen sensor circuit.

Component Location

The Aftertreatment Intake oxygen sensor is located in the exhaust system, after the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The fault code will become active when the ECM detects a lean condition for a calibrated period of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the aftertreatment exhaust gas oxygen sensor reading is used.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, cycle the keyswitch from OFF to ON. Start the engine and let it idle for 12 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The fault code will stay active until the keyswitch is cycled. After the keyswitch has been cycled, the system will again try to operate in closed loop. The fault code will clear as long as the issue does not occur after 5 minutes of closed loop operation. During closed loop operation it is typical to see aftertreatment exhaust gas oxygen 1 concentration toggling between RICH and LEAN.

The oxygen sensor compares the oxygen concentration in the exhaust to the oxygen concentration in the reference chamber. If grease has been installed in the oxygen sensor connector, this fault code can become active.

The engine controller uses feedback from the aftertreatment exhaust gas oxygen sensor to correct fuel flow to maintain a stoichiometric air-to-fuel ratio. If the oxygen sensor is unable to maintain a stoichiometric air-to-fuel ratio due to a sustained lean condition, this fault code may become active. Check for aftertreatment gas oxidation catalyst intake oxygen compensation (percent) to be operating at - 100 percent compensation for more than 10 seconds.

Possible causes of this fault code include:

Damaged/drifted oxygen sensor

Heater line failure

Possible engine misfire

Refer to Troubleshooting Fault Code 3436 .

Last Modified: 18-Jan-2020


Aftertreatment Intake Oxygen Sensor - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3437

Aftertreatment Intake Oxygen Sensor - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3437 PID: SPN: 3217 FMI: 1/18 LAMP: Amber SRT: | The engine control module (ECM) has detected a rich condition for a sustained period of time. | Possible reduced engine performance.
Engine Turbocharger Intake Oxygen Sensor

Circuit Description

The engine control module (ECM) uses sensors to determine the composition of the exhaust gas so that fueling can be adjusted to maintain desired air/fuel ratio while operating in closed loop. This diagnostic detects air/fuel ratio cylinder imbalance in one or more cylinders

Component Location

The Aftertreatment Intake oxygen sensor is located in the exhaust system, after the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The fault code will become active when the ECM detects a rich condition for a calibrated period of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the aftertreatment exhaust gas oxygen sensor reading is used.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, cycle the keyswitch from OFF to ON. Start the engine and let it idle for 12 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The fault code will stay active until the keyswitch is cycled. After the keyswitch has been cycled, the system will again try to operate in closed loop. The fault code will clear as long as the issue does not occur after 5 minutes of closed loop operation. During closed loop operation it is typical to see aftertreatment exhaust gas oxygen 1 concentration toggling between RICH and LEAN.

The engine controller uses feedback from the aftertreatment exhaust gas oxygen sensor to correct fuel flow to maintain a stoichiometric air-to-fuel ratio. If the oxygen sensor is unable to maintain a stoichiometric air-to-fuel ratio due to a sustained lean condition, this fault code may become active. Check for aftertreatment gas oxidation catalyst intake oxygen compensation (percent) to be operating at - 100 percent compensation for more than 10 seconds.

The oxygen sensor compares the oxygen concentration in the exhaust to the oxygen concentration in the reference chamber. If grease has been installed in the oxygen sensor connector, this fault code can become active.

Possible causes of this fault code include:

Damaged/drifted oxygen sensor

Heater line failure

Possible engine misfire

Excessive fuel

Refer to Troubleshooting Fault Code 3437 .

Last Modified: 18-Jan-2020


Anti-Lock Braking (ABS) Controller - Abnormal Update Rate

FAULT CODE 3488

Anti-Lock Braking (ABS) Controller - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3488 PID: SPN: 563 FMI: 9/9 LAMP: Amber SRT: | No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the anti-lock braking (ABS) controller. | None on performance.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices may not function as desired.

Potential causes of this fault code include:

When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the CumminsÂ ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the CumminsÂ ECM, or the OEM VECU is not set up to transmit the multiplexed component message.

This fault can also be caused by a bad J1939 data link connection between the OEM VECU and Cummins® ECM, a bad connection between the component and the OEM VECU, bad OEM VECU or bad Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration. It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3488 .

Last Modified: 18-Jan-2020


Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 352

Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 352 PID: S212 SPN: 3509 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at sensor supply number 1 circuit. | Possible reduced engine performance.
Sensor Supply 1 Circuit

Circuit Description

The sensor supply 1 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 1 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 1 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value is used for all of the sensors on the sensor supply 1 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Low voltage on the +5 volt supply wire can be caused by a short circuit to ground in a supply wire, a short circuit between a supply wire and a return wire, a malfunctioning sensor, or a malfunctioning ECM power supply.

During the fault code response test outlined for each sensor connected to sensor supply number 1, Fault Code 352 must be active before unplugging each sensor. If the fault code is not active, but can be easily duplicated by operating the engine, the following can be performed:

Operate the engine under the conditions that will cause Fault Code 352 to become active, even if it logs for a short period of time. Unplug one sensor at a time until Fault Code 352 stops logging under the test conditions. Each sensor can be unplugged with the engine running. Note: The engine may not start if the camshaft position sensor is unplugged.

Refer to Troubleshooting Fault Code 352 .

Last Modified: 18-Jan-2020


Wheel-Based Vehicle Speed - Abnormal Update Rate

FAULT CODE 3526

Wheel-Based Vehicle Speed - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3526 PID: SPN: 84 FMI: 9/9 LAMP: Amber SRT: | No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the wheel-based vehicle speed sensor. | Engine speed limited to Maximum Engine Speed without VSS parameter value. Cruise Control, Gear-Down Protection, and Road Speed Governor will not work. None on performance.
Wheel-Based Vehicle Speed Sensor Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices may not function as desired.

Possible causes of this fault code include:

When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the CumminsÂ ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the CumminsÂ ECM, or the OEM VECU is not set up to transmit the multiplexed component message.

This fault can also be caused by a bad J1939 data link connection between the OEM VECU and Cummins® ECM, a bad connection between the component and the OEM VECU, bad OEM VECU or bad Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration. It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3526 .

Last Modified: 18-Jan-2020


Accelerator Pedal or Lever Idle Validation Switch - Abnormal Update Rate

FAULT CODE 3528

Accelerator Pedal or Lever Idle Validation Switch - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3528 PID: SPN: 558 FMI: 9/9 LAMP: Red SRT: | No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the accelerator pedal or lever idle validation switch. | Engine will only idle.
Accelerator Pedal or Lever Idle Validation Switch Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices can possibly not function as desired.

This fault can occur for the following reasons:

The ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the CumminsÂ ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the CumminsÂ ECM, or the OEM VECU is not set up to transmit the multiplexed component message.

This fault can also be caused by a bad J1939 data link connection between the OEM VECU and Cummins® ECM, a bad connection between the component and the OEM VECU, bad OEM VECU or bad Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration. It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3528 .

Last Modified: 18-Jan-2020


Ambient Air Temperature - Abnormal Update Rate

FAULT CODE 3531

Ambient Air Temperature - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3531 PID: SPN: 171 FMI: 9/9 LAMP: Amber SRT: | No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the ambient air temperature sensor. | None on performance.
Ambient Temperature Sensor-J1939 Data Link Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) electronic control unit (ECU). Then component values and states from components such as sensors, throttle input, and switches can be transmitted from the OEM ECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Idle Shutdown - Ambient Air Temperature Override feature may not function.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Damaged J1939 data link connection between the OEM ECU and Cummins® ECM.
  • Damaged connection between the component and the OEM ECU.
  • Damaged OEM ECU or damaged Cummins® ECM.
  • A multiplexed component is enabled in the ECM, but the OEM ECU source address of the ECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM ECU is not set up to transmit the multiplexed component message.
Refer to Troubleshooting Fault Code 3531 .

Last Modified: 27-Sep-2020


Ambient Air Temperature - Received Network Data in Error

FAULT CODE 3532

Ambient Air Temperature - Received Network Data in Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3532 PID: SPN: 171 FMI: 2/19 LAMP: Amber SRT: | The J1939 multiplexing controller has indicated a malfunction of the ambient air temperature sensor. | None on performance.
J1939 Multiplexing

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) electronic control unit (ECU). Then component values and states from components such as sensors, throttle input, and switches can be transmitted from the OEM ECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The OEM VECU determined that there was a malfunction of the ambient air temperature sensor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Idle Shutdown - Ambient Air Temperature Override feature may not function.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged ambient air temperature sensor.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3532 .

Last Modified: 27-Sep-2020


Transmission Output Retarder - Abnormal Update Rate

FAULT CODE 3641

Transmission Output Retarder - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3641 PID: SPN: 748 FMI: 9/9 LAMP: Amber SRT: | No communication or an invalid data transfer rate has been detected on the J1939 datalink between the ECM and the transmission output retarder. | None on performance.
Transmission Output Retarder

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices may not function as desired.

This fault can occur for the following reasons:

When the ECM is set up properly (components enabled and OEM Vehicle Control Unit (ECU) source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the CumminsÂ ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.

This fault can also be caused by a bad J1939 data link connection between the OEM VECU and Cummins® ECM, a bad connection between the component and the OEM VECU, bad OEM VECU or bad Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration. It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3641 .

Last Modified: 18-Jan-2020


Estimated Engine Parasitic Losses - Percent Torque - Abnormal Update Rate

FAULT CODE 3838

Estimated Engine Parasitic Losses - Percent Torque - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3838 PID: SPN: 2978 FMI: 9/9 LAMP: Amber SRT: | A loss of communication has been detected. | None on performance.
SAE J1939 Multiplexing Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The OEM VECU determines there is a malfunction of the multiplexed variable speed fan drive.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning SAE J1939 datalink circuit

Incorrect feature and parameter settings

Refer to Troubleshooting Fault Code 3838 .

Last Modified: 18-Jan-2020


Cruise Control Disable Command - Abnormal Update Rate

FAULT CODE 3843

Cruise Control Disable Command - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3843 PID: SPN: 5603 FMI: 9/9 LAMP: None SRT: | No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the cruise control. | None on performance.
The Engine Control Module (ECM)

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices can possibly not function as desired.

This fault can occur for the following reasons:

The ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the CumminsÂ ECM, or the OEM VECU is not set up to transmit the multiplexed component message.

This fault can also be caused by a bad J1939 data link connection between the OEM VECU and Cummins® ECM, a bad connection between the component and the OEM VECU, bad OEM VECU or bad Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration. It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

Refer to Troubleshooting Fault Code 3843 .

Last Modified: 18-Jan-2020


Cruise Control Pause Command - Condition Exists

FAULT CODE 3844

Cruise Control Pause Command - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3844 PID: SPN: 5605 FMI: 11/31 LAMP: None SRT: | The adaptive cruise control has dropped out and must be manually engaged. | Cruise control could possibly not operate.
Engine Control Module (ECM)

Circuit Description

The adaptive cruise control system sends commands to the ECM via the J1939 data link to limit engine speed and maintain a set following distance behind a vehicle travelling more slowly than the current cruise control set speed.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the adaptive cruise control system was paused for more than 30 seconds, or that the vehicle speed dropped by more than 24 kph [15 mph] during the period of time that the cruise control was paused.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This is an information fault code indicating that the adaptive cruise control system was paused for more than 30 seconds, or that the vehicle speed dropped by more than 24 kph [15 mph] during the period of time that the cruise control was paused. Cruise control must be manually engaged when this condition exists.

Refer to Troubleshooting Fault Code 3844 .

Last Modified: 18-Jan-2020


Cruise Control Disable Command - Condition Exists

FAULT CODE 3845

Cruise Control Disable Command - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3845 PID: SPN: 5603 FMI: 11/31 LAMP: None SRT: | The adaptive cruise control has dropped out and must be manually engaged. | Cruise control could possibly not operate.
Engine Control Module (ECM)

Circuit Description

The adaptive cruise control system sends commands to the ECM via the J1939 data link to limit engine speed and maintain a set following distance behind a vehicle travelling more slowly than the current cruise control set speed.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the adaptive cruise control system was disabled for more than 30 seconds.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This is an information fault code indicating that the adaptive cruise control system was disabled. The cruise control must be manually engaged when this condition exists.

Refer to Troubleshooting Fault Code 3845 .

Last Modified: 18-Jan-2020


Engine Fuel Actuator Control - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 3847

Engine Fuel Actuator Control - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3847 PID: SPN: 633 FMI: 1/17 LAMP: Amber SRT: | The Fuel Control Valve (FCV) internal temperature is too low. | Possible reduced engine performance.
Fuel Control Valve

Circuit Description

The ECM controls the Fuel Control Valve to regulate the air/fuel mixture.

Component Location

Located in the Gas supply line before the mixer.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Fuel Control Valve (FCV) has reported to the Engine Control Module (ECM) that its internal temperature is too low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A damaged fuel control valve
  • Plugged or restricted air/fuel mixer passages.
  • Malfunctioning or damaged engine wiring harness.
Refer to Troubleshooting Fault Code 3847 .

Last Modified: 07-Feb-2021


Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 386

Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 386 PID: S212 SPN: 3509 FMI: 3/3 LAMP: Amber SRT: | High voltage detected at sensor supply number 1 circuit. | Possible reduced engine performance.
Sensor Supply 1 Circuit

Circuit Description

The sensor supply 1 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 1 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 1 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value is used for all of the sensors on the sensor supply 1 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

High voltage on the (+) 5 volt supply line can be caused by a short to battery voltage in the engine harness or connectors, or a malfunctioning ECM.

Refer to Troubleshooting Fault Code 386 .

Last Modified: 18-Jan-2020


Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 415

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 415 PID: P100 SPN: 100 FMI: 1/1 LAMP: Red SRT: | The engine oil pressure sensor indicates oil pressure is below the engine protection critical limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

An engine oil pressure switch or oil pressure sensor is used by the engine control module (ECM) to monitor the lubricating oil pressure. For engines with an oil pressure switch, the switch is normally closed when the engine is not running and open when oil pressure is present. For engines with an oil pressure sensor, the ECM will detect a low signal voltage at operating conditions when the oil pressure is low. The ECM will detect a high signal voltage at operating conditions when the oil pressure is high.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure was below minimum operating limits.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The torque output of the engine will be reduced.

The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Low oil pressure

High oil filter restriction.

Incorrect oil level

Malfunctioning engine oil pressure sensor.

Engine harness shorted to ground.

Refer to Troubleshooting Fault Code 415 .

Last Modified: 18-Jan-2020


Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 421

Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 421 PID: P175 SPN: 175 FMI: 0/16 LAMP: Amber SRT: | Engine oil temperature signal indicates engine oil temperature above engine protection warning limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Engine Oil Temperature Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil. The engine control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature.

Component Location

The engine oil temperature sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic consists of two parts. The first part runs when the keyswitch is turned ON and before engine speed is detected. The ECM must not see a key cycle for a period of ten hours before this part of the diagnostic will run. The second part runs when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil temperature was higher or lower than the other temperature sensors on the engine after an extended period of engine off time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, the engine must be shut down with the keyswitch in the OFF position for a period of 10 hours. After the 10 hour cold soak, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates that the engine oil temperature has exceeded the warning engine protection limit for oil temperature. Troubleshoot the cause of high engine oil temperature.

Refer to Troubleshooting Fault Code 421 .

Last Modified: 18-Jan-2020


J1939 Network #1 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 426

J1939 Network #1 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 426 PID: S231 SPN: 639 FMI: 2/2 LAMP: None SRT: | Communication between the engine control module (ECM) and another device on the SAE J1939 data link has been lost. | At least one multiplexed device will not operate properly.
SAE J1939 Datalink 1 Circuit

Circuit Description

Devices such as vehicle engine control module (ECM), automatic slip reduction systems, electronic displays, electronic information systems, electronic service tools, and vehicle electronic control unit(s) can communicate with the ECM over the SAE J1939 data link. Messages sent from the devices are received by the ECM and used for controlling the engine. The ECM also transmits information to these devices over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) received an invalid J1939 data link message from a multiplexed device for more than 1 second.

The Engine Control Module (ECM) detected an open or short circuit condition in the J1939 data link harness.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Shorted or open J1939 data link wiring.

The ECM (or another SAE J1939 device) tying up communications by sending too many consecutive messages

The external OEM controlling device has malfunctioned or can no longer transmit on the data link.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 426 .

Last Modified: 18-Jan-2020


Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 435

Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 435 PID: P100 SPN: 100 FMI: 2/2 LAMP: Amber SRT: | The engine oil pressure sensor is reading an erratic value. | None on performance.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

  • The first part of the diagnostic runs continuously while the keyswitch is in the ON position or the engine is running.

The second part of the diagnostic runs at key OFF.

The diagnostic only runs once per trip.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure reading was higher or lower than the other absolute pressure sensors on the engine after the keyswitch has been turned OFF and the engine has stopped running.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • Cycle the keyswitch to the ON position for 30 seconds, then cycle the keyswitch to the OFF position for 30 seconds. Do not start the engine.
  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning in-range pressure sensor

A malfunctioning engine oil pressure switch

High resistance in the engine harness.

Refer to Troubleshooting Fault Code 435 .

Last Modified: 18-Jan-2020


Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 441

Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 441 PID: P168 SPN: 168 FMI: 1/18 LAMP: Amber SRT: | ECM supply voltage is below the minimum system voltage level. | Possible reduced engine performance. Engine may run rough, may stop running, may not start, or may be difficult to start.
Unswitched Battery Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected low battery supply voltage.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is logged when the ECM battery supply voltage drops below 6-VDC.

Verify that the ECM unswitched power supply is coming from the batteries and not the starter or other device. Check for possible weak batteries.

If the ECM unswitched battery supply is taken from the starter, check for low voltage during cranking. Low voltage during cranking can cause the ECM power supply to drop below specifications and log Fault Code 441.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 441 .

Last Modified: 18-Jan-2020


Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 442

Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 442 PID: P168 SPN: 168 FMI: 0/16 LAMP: Amber SRT: | ECM supply voltage is above the maximum system voltage level. | Possible electrical damage to electrical components.
Unswitched Battery Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected excessive battery supply voltage.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Faulty alternator or regulator that is overcharging the system

Batteries connected in series instead of parallel

Incorrect jump-starting procedure.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 442 .

Last Modified: 18-Jan-2020


Gas Mass Flow 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 453

Gas Mass Flow 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 453 PID: P149 SPN: 1241 FMI: 3/3 LAMP: Amber SRT: | The Gas Mass Flow Sensor has been shorted to a power source. | Possible reduced engine performance.
Gas Mass Flow Sensor

Circuit Description

The electronic control module (ECM) uses the gas mass flow sensor to measure fuel into the engine and to adjust the fuel control valve based on this measurement.

The Engine control module's sensor supply 6 circuit provides a 15 volt supply to the gas mass flow sensor.

Component Location

The gas mass flow sensor is located on the fuel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the gas mass flow sensor has been shorted to a power source.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The gas mass flow to the engine is inferred by measuring a portion of the total flow as it travels through the bypass passage and across the gas mass flow sensor. The bypass flow is regulated by the flow split venturi and screen pack which are located behind the engine fuel shutoff valve.

Possible cause of this fault code:

Damaged sensor

Damaged wiring harness

Refer to Troubleshooting Fault Code 453 .

Last Modified: 18-Jan-2020


Gas Mass Flow 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 454

Gas Mass Flow 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 454 PID: P149 SPN: 1241 FMI: 4/4 LAMP: Amber SRT: | The Gas Mass Flow Sensor has been shorted to ground. | Possible reduced engine performance.
Gas Mass Flow Sensor

Circuit Description

The electronic control module (ECM) uses the gas mass flow sensor to measure fuel into the engine and to adjust the fuel control valve based on this measurement.

The Engine control module's sensor supply 6 circuit provides a 15 volt supply to the gas mass flow sensor.

Component Location

The gas mass flow sensor is located on the fuel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the gas mass flow sensor has been shorted to ground.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The gas mass flow to the engine is inferred by measuring a portion of the total flow as it travels through the bypass passage and across the gas mass flow sensor. The bypass flow is regulated by the flow split venturi and screen pack which are located behind the engine fuel shutoff valve.

Possible cause of this fault code:

A damaged gas mass flow sensor

Damaged wiring harness

An open circuit in the engine harness

A pin-to-pin short circuit

Refer to Troubleshooting Fault Code 454 .

Last Modified: 18-Jan-2020


Electronic Fuel Injection Control Valve Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 455

Electronic Fuel Injection Control Valve Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 455 PID: S18 SPN: 633 FMI: 3/3 LAMP: Red SRT: | Electronic Fuel Injection Control Valve Circuit - Voltage Above Normal or Shorted to High Source. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Electronic Fuel Injection Control Valve Circuit

Circuit Description

The electronic control module (ECM) uses a pulse width modulated valve to meter the fuel into the fuel housing.

Component Location

The engine fuel control valve is located in the fuel housing next to the gas mass flow sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the fan speed is greater than 0 RPM.

Conditions for Setting the Fault Codes

The ECM detects that the engine fuel control valve voltage is greater than a calibrated value.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The engine fuel control valve is a normally closed valve. The ECM will not command the valve open until the ECM detects engine rpm.

Refer to Troubleshooting Fault Code 455 .

Last Modified: 18-Jan-2020


Ignition Timing Signal Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 458

Ignition Timing Signal Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 458 PID: S67 SPN: 726 FMI: 3/3 LAMP: Red SRT: | Ignition Timing Signal Circuit - Voltage Above Normal or Shorted to High Source | The engine will shut down or will not start.
Ignition System Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

The ICM is located above the ECM on the intake side of the engine near the fuel control housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the ignition timing voltage is greater than a calibrated value.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The timing signal must be present at the ICM. If no signal is present, the engine will not start. This fault could become active due to a pin-to-pin short in the timing circuit.

Refer to Troubleshooting Fault Code 458 .

Last Modified: 18-Jan-2020


Ignition Timing Signal Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 459

Ignition Timing Signal Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 459 PID: S67 SPN: 726 FMI: 4/4 LAMP: Red SRT: | The spark timing control line has been shorted to ground. | The engine will shut down or will not start.
Ignition Timing Signal Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

The ICM is located above the ECM on the intake side of the engine near the fuel control housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the ignition timing voltage is less than a calibrated value.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will not start.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

The timing signal must be present at the ICM. If no signal is present, the engine will not start. This fault could become active due to a pin-to-pin short in the timing circuit.

The ICM provides the voltage on the timing and reference lines. If Fault Codes 459 (timing line) and 462 (reference line) shorted low are both present in the ECM image, this may indicate an issue with the power supply to the ICM. The ECM looks for a signal from the ICM right after key ON. Items such as a sticking relay on the switched battery supply causing a delay in the ICM power up can result in Fault Codes 459 and 462 and prevent the vehicle from starting. Both faults will latch active and will not allow the vehicle to start until the next key cycle, even if power has been restored to the ICM.

The ICM is supplied switched battery supply through the OEM harness. Due to the assortment of OEM wiring configurations, this troubleshooting tree will not troubleshoot the OEM side of the circuit. If an issue is suspected on the OEM side, the repair location must refer to the OEM service manual for troubleshooting steps.

Refer to Troubleshooting Fault Code 459 .

Last Modified: 18-Jan-2020


Ignition Control Signal Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 461

Ignition Control Signal Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 461 PID: S66 SPN: 725 FMI: 3/3 LAMP: Red SRT: | Ignition Control Signal Circuit - Voltage Above Normal or Shorted to High Source. | The engine will shut down or will not start.
Ignition Reference Signal Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

The ICM is located above the ECM on the intake side of the engine near the fuel control housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the ICM reference voltage is greater than a calibrated value.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The reference signal must be present at the ICM. If the signal is not present, the engine will not start. This fault could become active due to a short circuit in the reference wire.

Refer to Troubleshooting Fault Code 461 .

Last Modified: 18-Jan-2020


Ignition Control Signal Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 462

Ignition Control Signal Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 462 PID: S66 SPN: 725 FMI: 4/4 LAMP: Red SRT: | The spark refernce control line has been shorted to a power source, shorted to a ground, or open circuit. | The engine will shut down or will not start.
Ignition Reference Signal Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

The ICM is located above the ECM on the intake side of the engine near the fuel control housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the ICM reference voltage is less than a calibrated value.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

The engine may not start.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The reference signal must be present at the ICM. If the signal is not present, the engine will not start. This fault could become active due to a short circuit in the reference wire.

The ICM provides the voltage on the timing and reference lines. If Fault Codes 459 (timing line) and 462 (reference line) shorted low are both present in the ECM image, this may indicate an issue with the power supply to the ICM. The ECM looks for a signal from the ICM right after key ON. Items such as a sticking relay on the switched battery supply causing a delay in the ICM power up can result in Fault Codes 459 and 462 and prevent the vehicle from starting. Both faults will latch active and will not allow the vehicle to start until the next key cycle, even if power has been restored to the ICM.

Refer to Troubleshooting Fault Code 462 .

Last Modified: 18-Jan-2020


Engine Turbocharger 1 Boost Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 4621

Engine Turbocharger 1 Boost Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4621 PID: SPN: 1127 FMI: 2/2 LAMP: Amber SRT: | Compressor outlet pressure sensor is drifiting in range. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Engine Throttle Intake Pressure sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to compressor outlet pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The compressor outlet pressure sensor provides a signal to the ECM on the compressor outlet pressure sensor signal circuit.

Component Location

The engine throttle intake pressure sensor is located in the air stream after the charge-air cooler, just before the throttle actuator near the wastegate control valve.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detects that the throttle intake pressure signal reading is not changing with engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Damaged sensor

Restriction in the charge-air cooler

Leaks in the air intake system between the turbocharger and throttle intake.

Refer to Troubleshooting Fault Code 4621 .

Last Modified: 18-Jan-2020


Turbocharger 1 Wastegate Control Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 465

Turbocharger 1 Wastegate Control Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 465 PID: S32 SPN: 1188 FMI: 3/3 LAMP: Amber SRT: | Turbocharger 1 Wastegate Control Circuit - Voltage Above Normal or Shorted to High Source | Possible reduced engine performance.
Turbocharger Control Valve Circuit

Circuit Description

The electronic control module (ECM) uses the engine turbocharger wastegate control valve to control the pressure in the diaphragm canister of the turbocharger actuator. The turbocharger actuator is connected to the turbocharger wastegate.

Component Location

The engine turbocharger wastegate control valve is located on the intake manifold block just upstream of the throttle and connected by a tube to the turbocharger actuator.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the engine turbocharger wastegate control valve voltage is greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.

Shop Talk

Possible cause of this fault code:

Open circuit in the engine harness, connectors, or actuator.

Signal circuit shorted to voltage source.

Refer to Troubleshooting Fault Code 465 .

Last Modified: 18-Jan-2020


Engine Turbocharger Wastegate Actuator 1 Position Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 466

Engine Turbocharger Wastegate Actuator 1 Position Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 466 PID: S32 SPN: 1188 FMI: 4/4 LAMP: Amber SRT: | Turbocharger 1 Wastegate Control Circuit - Voltage Below Normal or Shorted to Low Source | Possible reduced engine performance.
Turbocharger Control Valve Circuit

Circuit Description

The electronic control module (ECM) uses the engine turbocharger wastegate control valve to control the pressure in the diaphragm canister of the turbocharger actuator. The turbocharger actuator is connected to the turbocharger wastegate.

Component Location

The engine turbocharger wastegate control valve is located on the intake manifold block just upstream of the throttle and connected by a tube to the turbocharger actuator.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the engine turbocharger wastegate control valve voltage is less than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible cause of this fault code:

A short circuit to ground in the engine harness

An open circuit in the engine harness

A malfunctioning wastegate control valve.

Refer to Troubleshooting Fault Code 466 .

Last Modified: 18-Jan-2020


Engine Turbocharger 1 Boost Pressure - Condition Exists

FAULT CODE 4855

Engine Turbocharger 1 Boost Pressure - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4855 PID: SPN: 1127 FMI: 11/31 LAMP: Red SRT: | Engine Turbocharger 1 Boost Pressure - Condition Exists | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Engine throttle intake pressure

Circuit Description

The engine control module (ECM) provides a 5 volt supply to compressor outlet pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The compressor outlet pressure sensor provides a signal to the ECM on the compressor outlet pressure sensor signal circuit.

Component Location

The engine throttle intake pressure sensor is located in the air stream after the charge-air cooler, just before the throttle actuator near the wastegate control valve.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The engine control module (ECM) has one or more active intake manifold pressure sensor fault, AND one or more active engine throttle intake pressure sensor fault, AND one or more active mass air flow sensor fault.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

The engine will shut down 30 seconds after the red STOP lamp starts flashing.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The engine throttle intake pressure sensor has been referred to as the boost pressure sensor and the mixer inlet pressure sensor in previous products.

Logging of this fault code occurs when multiple other faults are active. At least one fault from each of the intake manifold pressure sensor, engine throttle intake pressure sensor, AND mass air flow sensor must be active. When one or more of the sensor specific faults becomes inactive, FC4855 will also go inactive. Troubleshooting steps must be followed for any related active or inactive fault codes.

Refer to Troubleshooting Fault Code 4855 .

Last Modified: 18-Jan-2020


Electronic Fuel Injection Control Valve Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 511

Electronic Fuel Injection Control Valve Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 511 PID: S18 SPN: 633 FMI: 4/4 LAMP: Red SRT: | A malfunctioning fuel rail actuator circuit has been detected. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Fuel Control Valve

Circuit Description

The electronic control module (ECM) uses a pulse width modulated valve to meter the fuel into the fuel housing.

Component Location

The engine fuel control valve is located in the fuel housing next to the gas mass flow sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Engine speed is greater than a calibrated value

Conditions for Setting the Fault Codes

The ECM detects that the engine fuel control valve voltage is less than a calibrated value.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

The engine will not start.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The engine fuel control valve is a normally closed valve. The ECM will not command the valve open until the ECM detects engine rpm.

Possible causes of this fault code include:

Short to ground in the wiring harness

An open circuit in the harness

Damaged Fuel Control Valve (FCV)

Refer to Troubleshooting Fault Code 511 .

Last Modified: 18-Jan-2020


Aftertreatment 1 Three Way Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 5111

Aftertreatment 1 Three Way Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5111 PID: SPN: 6652 FMI: 1/18 LAMP: Amber SRT: | Aftertreatment 1 Three Way Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level. | Engine power derate.
Aftertreatment Oxygen Sensor Circuit

Circuit Description

The engine control module (ECM) uses these sensors to determine the composition of the exhaust gas so that fueling can be adjusted to maintain desired air/fuel ratio while operating in closed loop. The heater circuit is powered by the ECM to maintain proper temperature at the sensing tip. The ECM also uses these sensors to detect if the aftertreatment catalyst is missing or damaged.

Component Location

The Aftertreatment Intake oxygen sensor is located in the exhaust system, after the turbocharger turbine outlet.

The engine turbocharger outlet oxygen sensor is located in the exhaust system, after the turbocharger turbine outlet.

Conditions for Running the Diagnostics

The engine coolant temperature and catalyst temperature must be above a calibrated value. After driving above a calibrated speed, the test will run when the unit comes to a complete stop without touching the accelerator pedal.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detects that the aftertreatment catalyst conversion efficiency is below a threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A damaged catalyst.

Missing Catalyst

Contaminated Catalyst

Refer to Troubleshooting Fault Code 5111 .

Last Modified: 18-Jan-2020


Throttle Position 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 512

Throttle Position 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 512 PID: P51 SPN: 51 FMI: 3/3 LAMP: Amber SRT: | Throttle Position 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. | Possible increase in idle speed.
Electronic Throttle Control Actuator Circuit

Circuit Description

The electronic control module (ECM) controls the engine throttle actuator, which is both an input and output device. There are two throttle position sensors located inside the engine throttle actuator and they share a common supply and return. The engine throttle actuator receives 5 volt supply voltage from the sensor supply 1. The ECM controls the position of the throttle across the engine throttle actuator (+) line.

Component Location

The engine throttle actuator is located between the air intake adapter and the fuel control housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the signal voltage on the engine throttle position 1 signal pin is greater than 4.95-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The engine throttle actuator will move to its default position and the throttle actuator driver circuit will be disabled.

Possible increase in idle speed

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

A damaged engine throttle actuator.

A pin-to-pin short circuit

Refer to Troubleshooting Fault Code 512 .

Last Modified: 18-Jan-2020


Throttle Position 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 513

Throttle Position 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 513 PID: P51 SPN: 51 FMI: 4/4 LAMP: Amber SRT: | Throttle Position 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source | Possible increase in idle speed.
Electronic Throttle Control Actuator Circuit

Circuit Description

The electronic control module (ECM) controls the engine throttle actuator, which is both an input and output device. There are two throttle position sensors located inside the engine throttle actuator and they share a common supply and return. The engine throttle actuator receives 5 volt supply voltage from the sensor supply 1. The ECM controls the position of the throttle across the engine throttle actuator (+) line.

Component Location

The engine throttle actuator is located between the air intake adapter and the fuel control housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the throttle position 1 signal voltage is below 0.05-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The engine throttle actuator will move to its default position and the throttle actuator driver circuit will be disabled.

Possible increase in idle speed

Conditions for Clearing the Fault Code

  • To validate the repair, cycle the keyswitch from OFF to ON.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

A damaged engine throttle actuator.

A signal shorted to ground in the harness

An open circuit in the harness

Refer to Troubleshooting Fault Code 513 .

Last Modified: 18-Jan-2020


Sensor Supply 6 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 515

Sensor Supply 6 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 515 PID: S232 SPN: 3514 FMI: 3/3 LAMP: Amber SRT: | High voltage detected on the +5 volt sensor supply circuit to the fuel rail pressure sensor. | Possible reduced engine performance.
Sensor Supply 6 Circuit

Circuit Description

The Engine control module's sensor supply 6 circuit provides a 15 volt supply to the gas mass flow sensor.

Component Location

The sensor supply 6 circuit is contained in the wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 6 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Sensor supply circuit shorted to battery voltage.

Refer to Troubleshooting Fault Code 515 .

Last Modified: 18-Jan-2020


Sensor Supply 6 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 516

Sensor Supply 6 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 516 PID: S232 SPN: 3514 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 6 Circuit - Voltage Below Normal or Shorted to Low Source | Possible reduced engine performance.
Sensor Supply 6 Circuit

Circuit Description

The Engine control module's sensor supply 6 circuit provides a 15 volt supply to the gas mass flow sensor.

Component Location

The sensor supply 6 circuit is contained in the wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The electronic control module (ECM) detects the sensor supply 6 signal voltage is less than 14.49-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Sensor supply circuit shorted to battery voltage.

  • Supply wire open or shorted to ground.

A malfunctioning Gas Mass Flow Sensor

Refer to Troubleshooting Fault Code 516 .

Last Modified: 18-Jan-2020


Crankcase Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 555

Crankcase Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 555 PID: P101 SPN: 101 FMI: 0/16 LAMP: Amber SRT: | The crankcase breather filter requires maintenance. | Possible reduced engine performance.
Crankcase Pressure Sensor Circuit

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located near the crankcase ventilation element.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Engine speed is greater than a calibrated value

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankcase pressure was greater than a calibrated value.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Crankcase breather filter needs to be replaced

Malfunctioning crankcase pressure sensor.

Plugged or restricted crankcase breather draft tube

Frozen, plugged, or restricted crankcase breather tube.

It is important to check for plugged or restricted hoses, tubes, check valves, oil separator, and breather elements in extreme cold ambient temperatures. If Fault Code 555 becomes active due to a plugged filter before the maintenance interval is reached or the filter plugs frequently, see the Crankcase Gases (Blowby) Excessive troubleshooting symptom tree.

Refer to Troubleshooting Fault Code 555 .

Last Modified: 18-Jan-2020


Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 556

Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 556 PID: P101 SPN: 101 FMI: 0/0 LAMP: Red SRT: | High crankcase pressure detected. The crankcase breather filter requires maintenance. | Possible reduced engine performance.
Crankcase Pressure Sensor Circuit

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located near the crankcase ventilation element.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Engine speed is greater than a calibrated value

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankcase pressure was greater than a calibrated value.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine torque output will be reduced to protect the engine from excessive crankcase pressure.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Crankcase breather filter needs to be replaced

Malfunctioning crankcase pressure sensor.

Plugged or restricted crankcase breather draft tube

It is important to check for plugged or restricted hoses, tubes, check valves, oil separator, and breather elements in extreme cold ambient temperatures. If Fault Code 555 becomes active due to a plugged filter before the maintenance interval is reached or the filter plugs frequently, see the Crankcase Gases (Blowby) Excessive troubleshooting symptom tree.

Refer to Troubleshooting Fault Code 556 .

Last Modified: 18-Jan-2020


Engine Cylinder 1 (A1) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 561

Engine Cylinder 1 (A1) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 561 PID: S90 SPN: 1352 FMI: 0/0 LAMP: Red SRT: | Knock above the critical level has been detected. | Engine power derate.
Engine Knock Sensor Circuit

Circuit Description

The knock sensor is an accelerometer that measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. One sensor can be used for multiple cylinders.

Component Location

Knock sensor 1 is located on the intake side of the cylinder head, next to the number 1 valve cover. Knock sensor 2 is located near the bottom of cylinder block, between the ECM and the oil pressure sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine knock for this cylinder is greater than a calibrated value.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Engine torque and/or engine speed derate will be active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the knock faults occurred.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The knock sensors measure the high frequency vibration of the engine due to combustion knock. Knock may occur if the engine is supplied low quality fuel or if operated at excessive temperatures. Other sources of high frequency vibration may also cause knock faults to be logged. These may include gear-driven accessories such as air compressors or hydraulic pumps, driveline vibration, or a rough running engine due to low fuel pressure.

When the conditions exist, knock faults typically will occur when operated at full power, such as during wide open throttle acceleration. Faults will likely be inactive at idle.

Refer to Troubleshooting Fault Code 561 .

Last Modified: 18-Jan-2020


Engine Cylinder 2 (B1) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 562

Engine Cylinder 2 (B1) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 562 PID: S91 SPN: 1353 FMI: 0/0 LAMP: Red SRT: | Knock above the critical level has been detected. | Engine power derate.
Engine Knock Sensor Circuit

Circuit Description

The knock sensor is an accelerometer that measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. One sensor can be used for multiple cylinders.

Component Location

Knock sensor 1 is located on the intake side of the cylinder head, next to the number 1 valve cover. Knock sensor 2 is located near the bottom of cylinder block, between the ECM and the oil pressure sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine knock for this cylinder is greater than a calibrated value.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Engine torque and/or engine speed derate will be active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the knock faults occurred.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The knock sensors measure the high frequency vibration of the engine due to combustion knock. Knock may occur if the engine is supplied low quality fuel or if operated at excessive temperatures. Other sources of high frequency vibration may also cause knock faults to be logged. These may include gear-driven accessories such as air compressors or hydraulic pumps, driveline vibration, or a rough running engine due to low fuel pressure.

When the conditions exist, knock faults typically will occur when operated at full power, such as during wide open throttle acceleration. Faults will likely be inactive at idle.

Refer to Troubleshooting Fault Code 562 .

Last Modified: 18-Jan-2020


Engine Cylinder 3 (A2) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 563

Engine Cylinder 3 (A2) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 563 PID: S92 SPN: 1354 FMI: 0/0 LAMP: Red SRT: | Knock above the critical level has been detected. | Engine power derate.
Engine Knock Sensor Circuit

Circuit Description

The knock sensor is an accelerometer that measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. One sensor can be used for multiple cylinders.

Component Location

Knock sensor 1 is located on the intake side of the cylinder head, next to the number 1 valve cover. Knock sensor 2 is located near the bottom of cylinder block, between the ECM and the oil pressure sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine knock for this cylinder is greater than a calibrated value.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Engine torque and/or engine speed derate will be active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the knock faults occurred.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The knock sensors measure the high frequency vibration of the engine due to combustion knock. Knock may occur if the engine is supplied low quality fuel or if operated at excessive temperatures. Other sources of high frequency vibration may also cause knock faults to be logged. These may include gear-driven accessories such as air compressors or hydraulic pumps, driveline vibration, or a rough running engine due to low fuel pressure.

When the conditions exist, knock faults typically will occur when operated at full power, such as during wide open throttle acceleration. Faults will likely be inactive at idle.

Refer to Troubleshooting Fault Code 563 .

Last Modified: 18-Jan-2020


Engine Cylinder 4 (B2) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 564

Engine Cylinder 4 (B2) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 564 PID: S93 SPN: 1355 FMI: 0/0 LAMP: Red SRT: | Knock above the critical level has been detected. | Engine power derate.
Engine Knock Sensor Circuit

Circuit Description

The knock sensor is an accelerometer that measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. One sensor can be used for multiple cylinders.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected cylinder knock above the critical level.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Engine torque and/or engine speed derate will be active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the knock faults occurred.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The knock sensors measure the high frequency vibration of the engine due to combustion knock. Knock may occur if the engine is supplied low quality fuel or if operated at excessive temperatures. Other sources of high frequency vibration may also cause knock faults to be logged. These may include gear-driven accessories such as air compressors or hydraulic pumps, driveline vibration, or a rough running engine due to low fuel pressure.

When the conditions exist, knock faults typically will occur when operated at full power, such as during wide open throttle acceleration. Faults will likely be inactive at idle.

Refer to Troubleshooting Fault Code 564 .

Last Modified: 18-Jan-2020


Engine Cylinder 5 (A3) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 565

Engine Cylinder 5 (A3) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 565 PID: S94 SPN: 1356 FMI: 0/0 LAMP: Red SRT: | Knock above the critical level has been detected. | Engine power derate.
Engine Knock Sensor Circuit

Circuit Description

The knock sensor is an accelerometer that measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. One sensor can be used for multiple cylinders.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected cylinder knock above the critical level.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Engine torque and/or engine speed derate will be active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the knock faults occurred.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The knock sensors measure the high frequency vibration of the engine due to combustion knock. Knock may occur if the engine is supplied low quality fuel or if operated at excessive temperatures. Other sources of high frequency vibration may also cause knock faults to be logged. These may include gear-driven accessories such as air compressors or hydraulic pumps, driveline vibration, or a rough running engine due to low fuel pressure.

When the conditions exist, knock faults typically will occur when operated at full power, such as during wide open throttle acceleration. Faults will likely be inactive at idle.

Refer to Troubleshooting Fault Code 565 .

Last Modified: 18-Jan-2020


Engine Cylinder 6 (B3) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 566

Engine Cylinder 6 (B3) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 566 PID: S95 SPN: 1357 FMI: 0/0 LAMP: Red SRT: | Knock above the critical level has been detected. | Engine power derate.
Engine Knock Sensor Circuit

Circuit Description

The knock sensor is an accelerometer that measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. One sensor can be used for multiple cylinders.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected cylinder knock above the critical level.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Engine torque and/or engine speed derate will be active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the knock faults occurred.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The knock sensors measure the high frequency vibration of the engine due to combustion knock. Knock may occur if the engine is supplied low quality fuel or if operated at excessive temperatures. Other sources of high frequency vibration may also cause knock faults to be logged. These may include gear-driven accessories such as air compressors or hydraulic pumps, driveline vibration, or a rough running engine due to low fuel pressure.

When the conditions exist, knock faults typically will occur when operated at full power, such as during wide open throttle acceleration. Faults will likely be inactive at idle.

Refer to Troubleshooting Fault Code 566 .

Last Modified: 18-Jan-2020


Engine Cylinder 2 (B1) Knock - Voltage Below Normal or Shorted to Low Source

FAULT CODE 572

Engine Cylinder 2 (B1) Knock - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 572 PID: S91 SPN: 1353 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the knock sensor circuit. | Engine power derate.
Engine Knock Sensor Circuit

Circuit Description

The knock sensor is an accelerometer that measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. One sensor can be used for multiple cylinders.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the knock sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

A damaged knock sensor 1

Open circuit on the knock sensor 1 (+) line

Open circuit on the knock sensor 1 (-) line

Improper mounting or location of knock sensor 1.

Refer to Troubleshooting Fault Code 572 .

Last Modified: 18-Jan-2020


Engine Cylinder 5 (A3) Knock - Voltage Below Normal or Shorted to Low Source

FAULT CODE 575

Engine Cylinder 5 (A3) Knock - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 575 PID: S94 SPN: 1356 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the knock sensor circuit. | Possible reduced engine performance.
Engine Knock Sensor Circuit

Circuit Description

The knock sensor is an accelerometer that measures high frequency vibrations. The electronic control module (ECM) processes the voltage signals from the knock sensor to check for an elevated signal during the combustion cycle for each cylinder. One sensor can be used for multiple cylinders.

Component Location

The engine knock sensor is located on the cylinder head. Refer to the Engine Diagrams in Section E for detailed component location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the knock sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

A damaged knock sensor 2

Open circuit on the knock sensor 2 (+) line

Open circuit on the knock sensor 2 (-) line

Improper mounting or location of knock sensor 2.

Refer to Troubleshooting Fault Code 575 .

Last Modified: 18-Jan-2020


Engine Starter Motor Relay Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 584

Engine Starter Motor Relay Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 584 PID: S39 SPN: 677 FMI: 3/3 LAMP: Amber SRT: | Open circuit or high voltage detected at starter lockout circuit. | Either the engine will not start or the engine will not have starter lockout protection.
Starter Lockout Relay Circuit

Circuit Description

The starter lockout relay is controlled by the engine control module (ECM) through the starter lockout relay signal circuit. The relay prevents the starter from being engaged when the engine is running. The relay return circuit is dependent on OEM wiring. It can be wired back to the ECM on some vehicles or wired to chassis or block ground on others. Consult the OEM wiring diagram for return circuit details. The starter lockout relay circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

Component Location

The starter lockout relay is installed by the vehicle OEM. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The starter lockout relay circuit signal is detected to be greater than 0-VDC when the signal is turned OFF.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The Starter Lockout feature will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The ECM monitors the voltage level on this circuit. If it detects a voltage when the signal is commanded off, it records this fault code. This fault code can be caused by:

Open circuit in the starter lockout relay, OEM harness, or connectors

Short circuit to a voltage source in the OEM harness or relay.

This fault can also be set active if the over crank protection feature (starter lockout) is enabled, but the engine/ECM is not wired to support it.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 584 .

Last Modified: 18-Jan-2020


Engine Starter Motor Relay Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 585

Engine Starter Motor Relay Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 585 PID: S39 SPN: 677 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at starter lockout circuit. | Either the engine will not start or the engine will not have starter lockout protection.
Starter Lockout Relay Driver Circuit

Circuit Description

The starter lockout relay is controlled by the engine control module (ECM) through the starter lockout relay signal circuit. The relay prevents the starter from being engaged when the engine is running. The relay return circuit is dependent on OEM wiring. It can be wired back to the ECM on some vehicles or wired to chassis or block ground on others. Consult the OEM wiring diagram for return circuit details. The starter lockout relay circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

Component Location

The starter lockout relay is installed by the vehicle OEM. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the starter lockout relay pulse width modulated (PWM) signal was at system voltage when the pulse width modulated (PWM) signal was commanded OFF.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The Starter Lockout feature will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The ECM monitors the voltage level on this circuit. If it detects a low voltage when the signal is commanded ON, it records this fault code. This fault code can be caused by a short circuit to ground in the starter lockout relay, OEM harness, or connectors.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 585 .

Last Modified: 18-Jan-2020


Engine Fuel Actuator Control - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 5948

Engine Fuel Actuator Control - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5948 PID: SPN: 633 FMI: 0/16 LAMP: Red SRT: | The Fuel Control Valve (FCV) internal temperature is too low. | Possible reduced engine performance.
Fuel Control Valve

Circuit Description

The electronic control module (ECM) uses a pulse width modulated valve to meter the fuel into the fuel housing.

Component Location

The engine fuel control valve is located in the fuel housing next to the gas mass flow sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 500 rpm and within the first minute of the engine starting.

Conditions for Setting the Fault Codes

The ECM detects that actual gas flow is greater than desired gass flow by more than a calibrated amount for more than 3 seconds

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

The engine may not start.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The engine fuel control valve is a normally closed valve. The ECM will not command the valve open until the ECM detects engine rpm.

Possible causes of this fault code include:

Damaged Fuel Control Valve (FCV)

Refer to Troubleshooting Fault Code 5948 .

Last Modified: 18-Jan-2020


Electrical Charging System Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 596

Electrical Charging System Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 596 PID: P167 SPN: 167 FMI: 0/16 LAMP: Amber SRT: | High battery voltage detected by the battery voltage monitor feature. | None on performance.
Unswitched Battery Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the battery voltage was greater than a calibratible value.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, cycle the keyswitch from OFF to ON. Start the engine and let it idle for 12 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is part of the Battery Voltage Monitor feature. The ECM can increase idle speed and deactivate idle decrement switch if idle speedup is enabled. Use the recommended Cummins® electronic service tool or equivalent to view the Battery Voltage Monitor feature settings. Disabling the Battery Voltage Monitor feature will also disable this fault code.

Make sure the ECM battery supply (+) is coming directly from the battery and not the starter.

Possible cause of this fault code:

Overcharged batteries caused by a malfunctioning alternator or regulator.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 596 .

Last Modified: 18-Jan-2020


Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 597

Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 597 PID: P167 SPN: 167 FMI: 1/18 LAMP: Amber SRT: | Low battery voltage detected by the battery voltage monitor feature. | None on performance.
Unswitched Battery Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the battery voltage was less than a calibratible value.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, cycle the keyswitch from OFF to ON. Start the engine and let it idle for 12 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is part of the Battery Voltage Monitor feature. The ECM can increase idle speed and deactivate idle decrement switch if idle speedup is enabled. Use the recommended Cummins® electronic service tool or equivalent to view the Battery Voltage Monitor feature settings. Disabling the Battery Voltage Monitor feature will also disable this fault code.

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter.

Possible causes of this fault code include:

Undercharged batteries caused by a malfunctioning alternator or regulator.

High-current devices on the vehicle such as citizens band radio amplifiers, numerous exterior lights, or other accessories.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 597 .

Last Modified: 18-Jan-2020


Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 598

Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 598 PID: P167 SPN: 167 FMI: 1/1 LAMP: Red SRT: | Low battery voltage detected by the battery voltage monitor feature. | None on performance.
ECM Power Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the battery voltage was less than a calibratible value.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is part of the Battery Voltage Monitor feature. The ECM can increase idle speed and deactivate idle decrement switch if idle speedup is enabled. Use the recommended Cummins® electronic service tool or equivalent to view the Battery Voltage Monitor feature settings. Disabling the Battery Voltage Monitor feature will also disable this fault code.

Make sure the ECM battery supply (+) is coming directly from the battery and not the starter.

Possible cause of this fault code:

Undercharged batteries caused by a malfunctioning alternator or regulator.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 598 .

Last Modified: 18-Jan-2020


Engine Throttle Control Actuator - Condition Exists - Condition Exists

FAULT CODE 6388

Engine Throttle Control Actuator - Condition Exists - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6388 PID: SPN: 3464 FMI: 11/31 LAMP: None SRT: | Electronic Throttle Control Actuator - Data Valid But Above Normal Operating Range - Most Severe Level | Possible reduced engine performance.
Engine Throttle Control Circuit

Circuit Description

The electronic control module (ECM) controls the engine throttle actuator, which is both an input and output device. There are two throttle position sensors located inside the engine throttle actuator and they share a common supply and return. The engine throttle actuator receives 5 volt supply voltage from the sensor supply 1. The ECM controls the position of the throttle across the engine throttle actuator (+) line.

Component Location

The engine throttle actuator is located between the air intake adapter and the fuel control housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is ON, the engine speed is above 1000 rpm, the accelerator is depressed, and the engine throttle actuator is commanded closed.

Conditions for Setting the Fault Codes

The ECM will log this fault if the sensed throttle position is greater than or less than commanded throttle position by a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, turn the keyswitch from OFF to ON. Start the engine and let the engine run above 1000 rpm for more than one minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

It is important to check for frozen, plugged, or restricted engine intake air throttle in extreme cold ambient temperatures. Ice may form on the engine intake air throttle causing obstruction / sticking and may not be present at time of troubleshooting.

Possible causes of this fault code include:

A malfunctioning engine intake air throttle actuator

intake throttle actuator sticking

Obstructed engine throttle actuator.

Refer to Troubleshooting Fault Code 6388 .

Last Modified: 18-Jan-2020


Engine Exhaust O₂ Sensor Closed Loop Operation - Data Erratic, Intermittent, or Incorrect

FAULT CODE 6396

Engine Exhaust O₂ Sensor Closed Loop Operation - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6396 PID: SPN: 1696 FMI: 2/2 LAMP: Amber SRT: | The engine control module (ECM) has detected a lean or rich condition for a sustained period of time. | Possible reduced engine performance.
Aftertreatment Exhaust Gas Oxygen Sensor

Circuit Description

The engine control module (ECM) uses this sensor to determine the composition of the exhaust gas so the fueling can be adjusted to maintain desired air/fuel ratio while operating in closed loop. The heater circuit is powered by the ECM to maintain proper temperature at the sensing tip. The heater line is shared between aftertreatment intake and outlet oxygen sensor circuit.

Component Location

The engine turbocharger outlet oxygen sensor is located in the exhaust system, after the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The fault code will become active when the ECM detects a lean or rich condition for a sustained period of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, cycle the keyswitch from OFF to ON. Start the engine and let it idle for 12 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The fault code will stay active until the keyswitch is cycled. After the keyswitch has been cycled, the system will again try to operate in closed loop. The fault code will clear as long as the issue does not occur after 5 minutes of closed loop operation. During closed loop operation it is typical to see aftertreatment exhaust gas oxygen 1 concentration toggling between RICH and LEAN.

The engine controller uses feedback from the aftertreatment exhaust gas oxygen sensor to correct fuel flow to maintain a stoichiometric air-to-fuel ratio. If the oxygen sensor is unable to maintain a stoichiometric air-to-fuel ratio due to a sustained lean condition, this fault code may become active. Check for aftertreatment gas oxidation catalyst intake oxygen compensation (percent) to be operating at - 100 percent compensation for more than 10 seconds.

This fault code could be logged because of failure in multiple components (fuel system, air handling, aftertreatment etc.) This fault logs due to abnormal air/fuel ratio and when it is not possible to isolate the failed component. O₂ sensor voltage is used to detect this failure even though O₂ sensor may not have failed.

Possible causes of this fault code include:

Low fuel pressure

Damaged/drifted oxygen sensor

Heater line failure

A restriction in the fuel system

A malfunctioning turbocharger

A malfunctioning Mass Air Flow Sensor

A damaged fuel control valve

Refer to Troubleshooting Fault Code 6396 .

Last Modified: 18-Jan-2020


Engine Oil Change Interval - Condition Exists

FAULT CODE 649

Engine Oil Change Interval - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 649 PID: S115 SPN: 1378 FMI: 11/31 LAMP: Maintenance SRT: | Change the engine oil and filter. | None on performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) informs the driver of a maintenance event by using the Maintenance Monitor feature's lubrication oil drain limits.

Component Location

For a detailed component location view, refer to the appropriate service manual. Refer to the original equipment manufacturer (OEM) troubleshooting and repair manual for the location of the oil fill port.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil and filter required changing based on the programmable setting in the Maintenance Monitor.

Action Taken When the Fault Code is Active

The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • Use the recommended Cummins® electronic service tool or equivalent to reset the Maintenance Monitor feature.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code will only become active if the Maintenance Monitor is enabled in the recommended Cummins® electronic service tool or equivalent. Make sure the oil and filter are changed before clearing the fault code.

Refer to Troubleshooting Fault Code 649 .

Last Modified: 18-Jan-2020


Engine Ignition Control Module #1 - Abnormal Update Rate

FAULT CODE 6631

Engine Ignition Control Module #1 - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6631 PID: SPN: 1292 FMI: 9/9 LAMP: Amber SRT: | No communication or an invalid data transfer rate has been detected on the J1939 data link between the engine control module (ECM) and ignition control module (ICM). | Possible reduced engine performance.
Ignition Reference Signal Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

The ICM is located above the ECM on the intake side of the engine near the fuel control housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from the Ignition control module.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Depending on engine operating condition, ICM will be commanded by the ECM to operate in three different spark modes.

Single strike mode, ICM provide spark energy to the coil once per firing event

Double strike mode, ICM provide spark energy to the coil twice per firing event

Stop spark mode, ICM can turn off spark energy when demanded.

Possible causes of this fault code include:

An open or short circuit in the SAE J1939 datalink circuit

Damage ICM

ICM connector pin damage.

Refer to Troubleshooting Fault Code 6631 .

Last Modified: 18-Jan-2020


Estimated Engine Parasitic Losses - Percent Torque - Data Erratic, Intermittent, or Incorrect

FAULT CODE 6637

Estimated Engine Parasitic Losses - Percent Torque - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6637 PID: SPN: 2978 FMI: 2/2 LAMP: Amber SRT: | A loss of communication has been detected. | None on performance.
SAE J1939 Multiplexing Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The OEM VECU determines there is a malfunction of the multiplexed variable speed fan drive.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible cause of this fault code:

  • A malfunctioning SAE J1939 datalink circuit

Incorrect feature and parameter settings

For intermittent power supply and data link communication issues with aftertreatment components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing, or intermittent connections.

Refer to Troubleshooting Fault Code 6637 .

Last Modified: 18-Jan-2020


Fuel System Control Module - Data Erratic, Intermittent, or Incorrect

FAULT CODE 6857

Fuel System Control Module - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6857 PID: SPN: 8289 FMI: 2/2 LAMP: None SRT: | Fuel System Control Module - Data Erratic, Intermittent, or Incorrect | Possible reduced engine performance.
SAE J1939 Backbone Circuit

Circuit Description

The fuel system control module monitors and detect failures in the 3rd party fuel delivery system. Fuel system control module sends a fault message to the Cummins® Engine Control Module via J1939 datalink. The Cummins® ECM will log a fault and/or light the check engine lamp.

Component Location

Refer to the OEM service manual for the 3rd party high pressure side fueling components.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The fuel system control module has logged a fault in the 3rd party fuel supply system.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This is an information only fault code for a 3rd party fuel supply system. A fault has logged in the fuel system control module.

Refer to Troubleshooting Fault Code 6857 .

Last Modified: 18-Jan-2020


Fuel System Control Module - Abnormal Update Rate

FAULT CODE 6858

Fuel System Control Module - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6858 PID: SPN: 8289 FMI: 9/9 LAMP: None SRT: | Fuel System Control Module - Abnormal Update Rate | Possible reduced engine performance.
SAE J1939 Backbone Circuit

Circuit Description

The fuel system control module monitors and detect failures in the 3rd party fuel delivery system. Fuel system control module sends a fault message to the Cummins® Engine Control Module via J1939 datalink. The Cummins® ECM will log a fault and/or light the check engine lamp.

Component Location

Refer to the OEM service manual for the 3rd party high pressure side fueling components.

Conditions for Running the Diagnostics

The second part runs continuously while the engine is running.

Conditions for Setting the Fault Codes

The fuel system control module has logged a fault in the 3rd party fuel supply system.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • It is necessary to use the "Reset All Faults" command in the recommended Cummins® electronic service tool or equivalent to clear this fault and extinguish the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL).

Shop Talk

This is an information only fault code for a 3rd party fuel supply system. A fault has logged in the fuel system control module.

Refer to Troubleshooting Fault Code 6858 .

Last Modified: 18-Jan-2020


Engine Ignition Control Module #1 - Voltage Above Normal or Shorted to High Source

FAULT CODE 6883

Engine Ignition Control Module #1 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6883 PID: SPN: 1292 FMI: 3/3 LAMP: Red SRT: | The ICM detects a low voltage on the primary supply circuit during cranking. | None on performance. The engine will not start.
Ignition Timing Signal Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

The ICM is located above the ECM on the intake side of the engine near the fuel control housing.

Conditions for Running the Diagnostics

This diagnostic consists of two parts. The first part runs when the keyswitch is turned ON and before engine speed is detected. The ECM must not see a key cycle for a period of ten hours before this part of the diagnostic will run. The second part runs when the engine is running.

Conditions for Setting the Fault Codes

The ICM detects a low voltage on the primary supply circuit during cranking.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

WARNING: The ignition system produces high voltage. To reduce the possibility of personal injury from electrical shock, do not touch any ignition wires or components while the engine is operating. Always use suitably insulated tools.

All secondary return wires in the ignition harness are tied together. This way there will be continuity through each secondary return pin of each coil to the main secondary return wire at the ignition harness connector 2. If one of the secondary return wires is found to be open, then the ICM will think that the engine is misfiring when it is not.

Possible causes of this fault code include:

  • Loose or unplugged HV voltage connector.

ICM connector pin damage.

Malfunctioning Engine Ignition Coil

Damage ICM

Refer to Troubleshooting Fault Code 6883 .

Last Modified: 18-Jan-2020


Engine Ignition Control Module #1 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 6884

Engine Ignition Control Module #1 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6884 PID: SPN: 1292 FMI: 4/4 LAMP: Red SRT: | Ignition control module charge voltage supply circuit has been shorted to ground. | Engine may not start.
Ignition Timing Signal Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

The ICM is located above the ECM on the intake side of the engine near the fuel control housing.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is initially turned to the ON position.

Conditions for Setting the Fault Codes

The engine control module (ECM) received a message from the ignition control module via J1939 data link that a low voltage has been detected in the charge voltage supply circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will not start.

Conditions for Clearing the Fault Code

  • To validate the repair, cycle the keyswitch from OFF to ON, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged ignition control harness.
  • Malfunctioning or damaged ignition control module.
Refer to Troubleshooting Fault Code 6884 .

Last Modified: 16-May-2021


Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 689

Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 689 PID: P190 SPN: 190 FMI: 2/2 LAMP: Amber SRT: | The ECM has detected an error in the engine speed signal. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Engine Crankshaft Speed/Position Circuit

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position and camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating under load and the engine speed is greater than the calibrated threshold.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of the crankshaft speed/position sensor while the engine was running.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The camshaft position sensor will be used by the ECM to determine engine speed and position.

  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Causes of this fault include:

Open or short circuit of the +5-VDC supply, signal, or return wire in the engine harness

Damaged or malfunctioning engine speed sensor

Damaged tone wheel

Refer to Troubleshooting Fault Code 689 .

Last Modified: 18-Jan-2020


Engine Gaseous Fuel Pressure Regulator Intake Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 6945

Engine Gaseous Fuel Pressure Regulator Intake Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6945 PID: SPN: 7581 FMI: 1/1 LAMP: Amber SRT: | Engine Gaseous Fuel Pressure Regulator Intake Pressure - Data Valid But Below Normal Operating Range - Most Severe Level | Possible reduced engine performance.
SAE J1939 Data Link 1

Circuit Description

The fuel system control module monitors and detect failures in the 3rd party fuel delivery system. Fuel system control module sends a fault message to the Cummins® Engine Control Module via J1939 datalink. The Cummins® ECM will log a fault and/or light the check engine lamp.

Component Location

Refer to the OEM service manual for the 3rd party high pressure side fueling components.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The fuel system control module has logged a fault in the 3rd party fuel supply system.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This is an information only fault code for a 3rd party fuel supply system. A fault has logged in the fuel system control module.

Refer to Troubleshooting Fault Code 6945 .

Last Modified: 18-Jan-2020


Fuel System Control Module - Received Network Data in Error

FAULT CODE 6961

Fuel System Control Module - Received Network Data in Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6961 PID: SPN: 8289 FMI: 2/19 LAMP: None SRT: | The 3rd party fuel system control module has detected a fault in the fuel delivery system. | Engine may run rough, may stop running, may not start, or may be difficult to start.
SAE J1939 Data Link 1

Circuit Description

The fuel system control module monitors and detect failures in the 3rd party fuel delivery system. Fuel system control module sends a fault message to the Cummins® Engine Control Module via J1939 datalink. The Cummins® ECM will log a fault and/or light the check engine lamp.

Component Location

The OEM installed fuel system location will vary depending on application. Refer to the OEM service manual for proper location

Conditions for Running the Diagnostics

The engine is running.

Conditions for Setting the Fault Codes

The fuel system control module has logged a fault in the 3rd party fuel supply system.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The SCM will turn off the amber warning lamp immediately after the diagnostic runs and passes.
  • It is necessary to use the "Reset All Faults" command in the recommended Cummins® electronic service tool or equivalent to clear this fault and extinguish the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL).

Shop Talk

This is an information only fault code for a 3rd party fuel supply system. A fault has logged in the fuel system control module.

Refer to Troubleshooting Fault Code 6961 .

Last Modified: 18-Jan-2020


Engine Ignition Coil #1 - Current Below Normal or Open Circuit

FAULT CODE 6966

Engine Ignition Coil #1 - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6966 PID: SPN: 1268 FMI: 5/5 LAMP: Red SRT: | Engine Ignition Coil #1 - Current Below Normal or Open Circuit | Possible reduced engine performance.
Ignition Timing Signal Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

The ICM is located above the ECM on the intake side of the engine near the fuel control housing.

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ICM detects a coil number 1 open primary circuit while the engine is running.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • It is necessary to use the "Reset All Faults" command in the recommended Cummins® electronic service tool or equivalent to clear this fault.

Shop Talk

WARNING: The ignition system produces high voltage. To reduce the possibility of personal injury from electrical shock, do not touch any ignition wires or components while the engine is operating. Always use suitably insulated tools.

Possible causes of this fault code include:

  • Loose or unplugged HV voltage connector.

Damaged wiring harness

Malfunctioning Engine Ignition Coil

Refer to Troubleshooting Fault Code 6966 .

Last Modified: 18-Jan-2020


Engine Ignition Coil #2 - Current Below Normal or Open Circuit

FAULT CODE 6967

Engine Ignition Coil #2 - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6967 PID: SPN: 1269 FMI: 5/5 LAMP: Red SRT: | An open coil secondary circuit has been detected on coil 2. | Possible reduced engine performance.
Ignition Timing Signal Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

The ICM is located above the ECM on the intake side of the engine near the fuel control housing.

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ICM detects a coil number 2 open primary circuit while the engine is running.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • It is necessary to use the "Reset All Faults" command in the recommended Cummins® electronic service tool or equivalent to clear this fault.

Shop Talk

WARNING: The ignition system produces high voltage. To reduce the possibility of personal injury from electrical shock, do not touch any ignition wires or components while the engine is operating. Always use suitably insulated tools.

Possible causes of this fault code include:

  • Loose or unplugged HV voltage connector.

Damaged wiring harness

Malfunctioning Engine Ignition Coil

Refer to Troubleshooting Fault Code 6967 .

Last Modified: 18-Jan-2020


Engine Ignition Coil #3 - Current Below Normal or Open Circuit

FAULT CODE 6968

Engine Ignition Coil #3 - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6968 PID: SPN: 1270 FMI: 5/5 LAMP: Red SRT: | An open coil secondary circuit has been detected on coil 3. | Possible reduced engine performance.
Ignition Timing Signal Circuit

Circuit Description

The ignition system uses a separate ignition control module (ICM) to operate the ignition system. The ICM controls two ignition coil packs. Coil pack 1 generates the voltage to fire cylinders 1 thru 3. coil pack 2 generates the voltage to fire cylinders 4 thru 6. Spark timing is controlled by the ECM. The ECM commands the ICM to energize the ignition coil for the current cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary return lines in the ignition harness. The ICM is capable of measuring spark voltage over the secondary return wire in the ignition harness. The ECM receives this information over the spark voltage signal line.

Component Location

The ICM is located above the ECM on the intake side of the engine near the fuel control housing.

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ICM detects a coil number 3 open primary circuit while the engine is running.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • It is necessary to use the "Reset All Faults" command in the recommended Cummins® electronic service tool or equivalent to clear this fault.

Shop Talk

WARNING: The ignition system produces high voltage. To reduce the possibility of personal injury from electrical shock, do not touch any ignition wires or components while the engine is operating. Always use suitably insulated tools.

Possible causes of this fault code include:

  • Loose or unplugged HV voltage connector.

Damaged wiring harness

Malfunctioning Engine Ignition Coil

Refer to Troubleshooting Fault Code 6968 .

Last Modified: 18-Jan-2020


Engine Ignition Coil #4 - Current Below Normal or Open Circuit

FAULT CODE 6969

Engine Ignition Coil #4 - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6969 PID: SPN: 1271 FMI: 5/5 LAMP: Red SRT: | Engine Ignition Coil #4 - Current Below Normal or Open Circuit | Possible reduced engine performance.
Ignition Timing Signal Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

The ICM is located above the ECM on the intake side of the engine near the fuel control housing.

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ICM detects a coil number 4 open primary circuit while the engine is running.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • It is necessary to use the "Reset All Faults" command in the recommended Cummins® electronic service tool or equivalent to clear this fault.

Shop Talk

WARNING: The ignition system produces high voltage. To reduce the possibility of personal injury from electrical shock, do not touch any ignition wires or components while the engine is operating. Always use suitably insulated tools.

Possible causes of this fault code include:

  • Loose or unplugged HV voltage connector.

Damaged wiring harness

Malfunctioning Engine Ignition Coil

Refer to Troubleshooting Fault Code 6969 .

Last Modified: 18-Jan-2020


Engine ECU Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 697

Engine ECU Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 697 PID: P21 SPN: 1136 FMI: 3/3 LAMP: Amber SRT: | High signal voltage or open circuit detected at the internal ECM temperature sensor. | None on performance.
ECM

Circuit Description

The engine control module (ECM) has an internal temperature sensor that is used to measure the temperature inside the ECM.

Component Location

The ECM is located on the side of the engine, next to the ignition control module (ICM) and flywheel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the internal temperature sensor circuit was shorted high.

Action Taken When the Fault Code is Active

For On-Board Diagnostics (OBD) engines, the ECM illuminates the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This sensor is located internally to the ECM. No troubleshooting is possible for this fault code. If the fault code is active, the ECM must be replaced.

Refer to Troubleshooting Fault Code 697 .

Last Modified: 18-Jan-2020


Engine Ignition Coil #5 - Current Below Normal or Open Circuit

FAULT CODE 6971

Engine Ignition Coil #5 - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6971 PID: SPN: 1272 FMI: 5/5 LAMP: Red SRT: | Engine Ignition Coil #5 - Current Below Normal or Open Circuit | The engine will not start.
Ignition Timing Signal Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

The ICM is located above the ECM on the intake side of the engine near the fuel control housing.

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ICM detects a coil number 5 open primary circuit while the engine is running.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • It is necessary to use the "Reset All Faults" command in the recommended Cummins® electronic service tool or equivalent to clear this fault.

Shop Talk

WARNING: The ignition system produces high voltage. To reduce the possibility of personal injury from electrical shock, do not touch any ignition wires or components while the engine is operating. Always use suitably insulated tools.

Possible causes of this fault code include:

  • Loose or unplugged HV voltage connector.

Damaged wiring harness

Malfunctioning Engine Ignition Coil

Refer to Troubleshooting Fault Code 6971 .

Last Modified: 18-Jan-2020


Engine Ignition Coil #6 - Current Below Normal or Open Circuit

FAULT CODE 6972

Engine Ignition Coil #6 - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6972 PID: SPN: 1273 FMI: 5/5 LAMP: Red SRT: | Engine Ignition Coil #6 - Current Below Normal or Open Circuit | The engine will not start.
Ignition Timing Signal Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

The ICM is located above the ECM on the intake side of the engine near the fuel control housing.

Spark plugs and coils are located on the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ICM detects a coil number 6 open primary circuit while the engine is running.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • It is necessary to use the "Reset All Faults" command in the recommended Cummins® electronic service tool or equivalent to clear this fault.

Shop Talk

WARNING: The ignition system produces high voltage. To reduce the possibility of personal injury from electrical shock, do not touch any ignition wires or components while the engine is operating. Always use suitably insulated tools.

Possible causes of this fault code include:

  • Loose or unplugged HV voltage connector.

Damaged wiring harness

Malfunctioning Engine Ignition Coil

Refer to Troubleshooting Fault Code 6972 .

Last Modified: 18-Jan-2020


Engine ECU Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 698

Engine ECU Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 698 PID: P21 SPN: 1136 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the internal ECM temperature sensor. | None on performance.
ECM

Circuit Description

The engine control module (ECM) has an internal temperature sensor that is used to measure the temperature inside the ECM.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the internal temperature sensor circuit was shorted to ground.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This sensor is located internally to the ECM. No troubleshooting is possible for this fault code. If the fault code is active, the ECM must be replaced.

Refer to Troubleshooting Fault Code 698 .

Last Modified: 18-Jan-2020


Engine Gaseous Fuel Pressure Regulator Intake Pressure - Abnormal Update Rate

FAULT CODE 6994

Engine Gaseous Fuel Pressure Regulator Intake Pressure - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6994 PID: SPN: 7581 FMI: 9/9 LAMP: None SRT: | Engine Gaseous Fuel Pressure Regulator Intake Pressure - Abnormal Update Rate | Possible reduced engine performance.
SAE J1939 Data Link 1

Circuit Description

The fuel system control module monitors and detect failures in the 3rd party fuel delivery system. Fuel system control module sends a fault message to the Cummins® Engine Control Module via J1939 datalink. The Cummins® ECM will log a fault and/or light the check engine lamp.

Component Location

Refer to the OEM service manual for the 3rd party high pressure side fueling components.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The fuel system control module has logged a fault in the 3rd party fuel supply system.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This is an information only fault code for a 3rd party fuel supply system. A fault has logged in the fuel system control module.

Refer to Troubleshooting Fault Code 6994 .

Last Modified: 18-Jan-2020


Fuel System Control Module - Special Instructions

FAULT CODE 7187

Fuel System Control Module - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 7187 PID: SPN: 8289 FMI: 14/14 LAMP: Amber SRT: | Fuel System Control Module - Special Instructions | Possible reduced engine performance.
SAE J1939 Data Link 1

Circuit Description

The fuel system control module monitors and detect failures in the 3rd party fuel delivery system. Fuel system control module sends a fault message to the Cummins® Engine Control Module via J1939 datalink. The Cummins® ECM will log a fault and/or light the check engine lamp.

Component Location

Refer to the OEM service manual for the 3rd party high pressure side fueling components.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The fuel system control module has logged a fault in the 3rd party fuel supply system.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This is an information only fault code for a 3rd party fuel supply system. A fault has logged in the fuel system control module.

Refer to Troubleshooting Fault Code 7187 .

Last Modified: 18-Jan-2020


Fuel System Control Module - Received Network Data in Error

FAULT CODE 7188

Fuel System Control Module - Received Network Data in Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 7188 PID: SPN: 8289 FMI: 2/19 LAMP: Red SRT: | Fuel System Control Module - Condition Exists | Possible reduced engine performance.
SAE J1939 Data Link 1

Circuit Description

The fuel system control module monitors and detect failures in the 3rd party fuel delivery system. Fuel system control module sends a fault message to the Cummins® Engine Control Module via J1939 datalink. The Cummins® ECM will log a fault and/or light the check engine lamp.

Component Location

Refer to the OEM service manual for the 3rd party high pressure side fueling components.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The fuel system control module has logged a fault in the 3rd party fuel supply system.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This is an information only fault code for a 3rd party fuel supply system. A fault has logged in the fuel system control module.

Refer to Troubleshooting Fault Code 7188 .

Last Modified: 18-Jan-2020


Engine Gaseous Fuel Supply Shutoff Valve 1 Position - Condition Exists

FAULT CODE 7189

Engine Gaseous Fuel Supply Shutoff Valve 1 Position - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 7189 PID: SPN: 7081 FMI: 11/31 LAMP: None SRT: | Engine Gaseous Fuel Supply Pressure - Condition Exists | The engine will shut down or will not start.
SAE J1939 Data Link 1

Circuit Description

The fuel system control module monitors and detect failures in the 3rd party fuel delivery system. Fuel system control module sends a fault message to the Cummins® Engine Control Module via J1939 datalink. The Cummins® ECM will log a fault and/or light the check engine lamp.

Component Location

Refer to the OEM service manual for the 3rd party high pressure side fueling components.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The fuel system control module has logged a fault in the 3rd party fuel supply system.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This is an information only fault code for a 3rd party fuel supply system. A fault has logged in the fuel system control module.

Refer to Troubleshooting Fault Code 7189 .

Last Modified: 18-Jan-2020


Engine Gaseous Fuel Pressure Regulator Intake Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 7191

Engine Gaseous Fuel Pressure Regulator Intake Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 7191 PID: SPN: 7581 FMI: 1/1 LAMP: None SRT: | Engine Gaseous Fuel Pressure Regulator Intake Pressure - Abnormal Update Rate | Possible reduced engine performance.
SAE J1939 Data Link 1

Circuit Description

The fuel system control module monitors and detect failures in the 3rd party fuel delivery system. Fuel system control module sends a fault message to the Cummins® Engine Control Module via J1939 datalink. The Cummins® ECM will log a fault and/or light the check engine lamp.

Component Location

Refer to the OEM service manual for the 3rd party high pressure side fueling components.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The fuel system control module has logged a fault in the 3rd party fuel supply system.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This is an information only fault code for a 3rd party fuel supply system. A fault has logged in the fuel system control module.

Refer to Troubleshooting Fault Code 7191 .

Last Modified: 18-Jan-2020


Engine Ignition Control Module #1 - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 7192

Engine Ignition Control Module #1 - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 7192 PID: SPN: 1292 FMI: 1/18 LAMP: Amber SRT: | Engine Ignition Control Module #1 - Voltage Below Normal or Shorted to Low Source | None on performance.
Ignition Timing Signal Circuit

Circuit Description

The ignition system is a coil-on-plug system that uses a separate ignition control module (ICM) to operate the ignition system. Spark timing is controlled by the engine control module (ECM). The ECM commands the ICM to energize the ignition coil for the present cylinder in the firing sequence over the ICM timing line in the engine harness. The ECM sends a signal to the ICM to prepare to energize the ignition coil for cylinder number 1 over the ICM reference line in the engine harness. The coils are energized by the ICM through the charge voltage and primary RETURN lines in the ignition harness. The ICM is capable of measuring spark voltage and detecting misfire over the secondary RETURN wire in the ignition harness. The ECM receives this information over spark voltage signal and combustion detection (misfire) SIGNAL lines.

Component Location

The ICM is located above the ECM on the intake side of the engine near the fuel control housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ICM detects a low voltage on the primary supply circuit during cranking.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

WARNING: The ignition system produces high voltage. To reduce the possibility of personal injury from electrical shock, do not touch any ignition wires or components while the engine is operating. Always use suitably insulated tools.

Possible causes of this fault code include:

Damaged wiring harness

Malfunctioning Engine Ignition Coil

A damaged ignition module.

Refer to Troubleshooting Fault Code 7192 .

Last Modified: 18-Jan-2020


Fuel System Control Module - Data Erratic, Intermittent, or Incorrect

FAULT CODE 7277

Fuel System Control Module - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 7277 PID: SPN: 8289 FMI: 2/2 LAMP: Amber SRT: | Fuel System Control Module - Data Erratic, Intermittent, or Incorrect | Possible reduced engine performance.
SAE J1939 Data Link 1

Circuit Description

The fuel system control module monitors and detect failures in the 3rd party fuel delivery system. Fuel system control module sends a fault message to the Cummins® Engine Control Module via J1939 datalink. The Cummins® ECM will log a fault and/or light the check engine lamp.

Component Location

Refer to the OEM service manual for the 3rd party high pressure side fueling components.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The fuel system control module has logged a fault in the 3rd party fuel supply system.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This is an information only fault code for a 3rd party fuel supply system. A fault has logged in the fuel system control module.

Refer to Troubleshooting Fault Code 7277 .

Last Modified: 18-Jan-2020


Fuel System Control Module - Abnormal Update Rate

FAULT CODE 7278

Fuel System Control Module - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 7278 PID: SPN: 8289 FMI: 9/9 LAMP: Amber SRT: | Fuel System Control Module - Abnormal Update Rate | Possible reduced engine performance.
SAE J1939 Data Link 1

Circuit Description

The fuel system control module monitors and detect failures in the 3rd party fuel delivery system. Fuel system control module sends a fault message to the Cummins® Engine Control Module via J1939 datalink. The Cummins® ECM will log a fault and/or light the check engine lamp.

Component Location

Refer to the OEM service manual for the 3rd party high pressure side fueling components.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The fuel system control module has logged a fault in the 3rd party fuel supply system.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This is an information only fault code for a 3rd party fuel supply system. A fault has logged in the fuel system control module.

Refer to Troubleshooting Fault Code 7278 .

Last Modified: 18-Jan-2020


Fuel System Control Module - Received Network Data in Error

FAULT CODE 7279

Fuel System Control Module - Received Network Data in Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 7279 PID: SPN: 8289 FMI: 2/19 LAMP: Amber SRT: | The 3rd party fuel system control module has detected a fault in the fuel delivery system. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Engine Control Module (ECM)

Circuit Description

The fuel system control module monitors and detect failures in the 3rd party fuel delivery system. Fuel system control module sends a fault message to the Cummins® Engine Control Module via J1939 datalink. The Cummins® ECM will log a fault and/or light the check engine lamp.

Component Location

The OEM installed fuel system location will vary depending on application. Refer to the OEM service manual for proper location

Conditions for Running the Diagnostics

The engine is running.

Conditions for Setting the Fault Codes

The fuel system control module has logged a fault in the 3rd party fuel supply system.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This is an information only fault code for a 3rd party fuel supply system. A fault has logged in the fuel system control module.

Refer to Troubleshooting Fault Code 7279 .

Last Modified: 18-Jan-2020


Fuel System Control Module - Condition Exists

FAULT CODE 7281

Fuel System Control Module - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 7281 PID: SPN: 8289 FMI: 11/31 LAMP: Amber SRT: | A malfunction has been detected in the OEM fuel system. | Possible reduced engine performance.
SAE J1939 Data Link 1

Circuit Description

The fuel system control module monitors and detect failures in the 3rd party fuel delivery system. Fuel system control module sends a fault message to the Cummins® Engine Control Module via J1939 datalink. The Cummins® ECM will log a fault and/or light the check engine lamp.

Component Location

Refer to the OEM service manual for the 3rd party high pressure side fueling components.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) received a message from the OEM fuel system via the J1939 data link, indicating a malfunction in the OEM fuel system has been detected.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • OEM fuel system component is malfunctioning.
Refer to Troubleshooting Fault Code 7281 .

Last Modified: 27-Mar-2022


Engine Gaseous Fuel Supply Shutoff Valve 1 Position - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 7282

Engine Gaseous Fuel Supply Shutoff Valve 1 Position - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 7282 PID: SPN: 7081 FMI: 1/1 LAMP: Red SRT: | The ECM has detected that the fuel pressure signal is erratic. The ECM has diagnosed that the fuel supply pressure has become too low for safe engine operation. | Possible reduced engine performance.
SAE J1939 Data Link 1

Circuit Description

The fuel system control module monitors and detect failures in the 3rd party fuel delivery system. Fuel system control module sends a fault message to the Cummins® Engine Control Module via J1939 datalink. The Cummins® ECM will log a fault and/or light the check engine lamp.

Component Location

Refer to the OEM service manual for the 3rd party high pressure side fueling components.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The fuel system control module has logged a fault in the 3rd party fuel supply system.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • It is necessary to use the "Reset All Faults" command in the recommended Cummins® electronic service tool or equivalent to clear this fault.

Shop Talk

This is an information only fault code for a 3rd party fuel supply system. A fault has logged in the fuel system control module.

Refer to Troubleshooting Fault Code 7282 .

Last Modified: 18-Jan-2020


Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 731

Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 731 PID: S64 SPN: 723 FMI: 7/7 LAMP: Amber SRT: | Engine position signal from the crankshaft position sensor and camshaft position sensor do not match. | Possible reduced engine performance.
Crankshaft Speed/Position and Camshaft Speed/Postion Sensor Circuits

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position and camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankshaft position does not match the camshaft position signal input to the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The ECM monitors the position of the missing tooth on the crankshaft speed sensor target and the camshaft speed sensor target. If the two positions do not match, the ECM then determines that there is a mechanical misalignment between the two sensors.

Possible causes of this fault code include:

Engine speed sensor rings that are loose or not aligned correctly

Mechanical misalignment.

Refer to Troubleshooting Fault Code 731 .

Last Modified: 18-Jan-2020


Gas Mass Flow 1 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 751

Gas Mass Flow 1 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 751 PID: P149 SPN: 1241 FMI: 2/2 LAMP: Amber SRT: | The Gas Mass Flow sensor has failed in range. | Possible reduced engine performance.
Gas Mass Flow Sensor

Circuit Description

The electronic control module (ECM) uses the gas mass flow sensor to measure fuel into the engine and to adjust the fuel control valve based on this measurement.

Component Location

The gas mass flow sensor is located on the fuel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the gas mass flow sensor has failed in range.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The engine will run in open loop gas flow control

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible cause of this fault code:

Improper fuel pressure or low fuel.

A damaged gas mass flow sensor

Erratic reading due to deposits in the laminar flow screen

Refer to Troubleshooting Fault Code 751 .

Last Modified: 18-Jan-2020


Brake Switch Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 769

Brake Switch Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 769 PID: S246 SPN: 597 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the brake switch circuit. | None on performance.
Brake Switch Circuit

Circuit Description

The brake switch is an original equipment manufacturer (OEM) supplied switch. The switch is supplied 5 volts through the OEM wiring harness. The return is routed to the OEM switch return.

Component Location

The brake switch is an OEM supplied component. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the brake switch circuit was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM

Refer to Troubleshooting Fault Code 769 .

Last Modified: 18-Jan-2020


Brake Switch Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 771

Brake Switch Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 771 PID: S246 SPN: 597 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the brake switch circuit. | None on performance.
Brake Switch Circuit

Circuit Description

The brake switch is an original equipment manufacturer (OEM) supplied switch. The switch is supplied 5 volts through the OEM wiring harness. The return is routed to the OEM switch return.

Component Location

The brake switch is an OEM supplied component. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the brake switch circuit was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 771 .

Last Modified: 18-Jan-2020


Turbocharger 1 Turbine Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 777

Turbocharger 1 Turbine Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 777 PID: S384 SPN: 1180 FMI: 0/16 LAMP: Amber SRT: | Turbocharger turbine intake temperature has exceeded the engine protection limit. | Engine power derate.
Turbocharger Turbine Inlet Temperature Sensor Circuit

Circuit Description

The engine turbocharger turbine intake temperature sensor is a variable resistor sensor and is used to measure the temperature of the exhaust gas entering the turbine of the turbocharger. The engine control module (ECM) supplies 5 volts to the engine turbocharger turbine intake temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the temperature of the exhaust entering the turbine. The ECM uses the engine turbocharger turbine intake temperature sensor for engine protection purposes.

Component Location

The engine turbocharger turbine intake temperature sensor is located in the turbocharger turbine housing.

Conditions for Running the Diagnostics

This diagnostic runs continouosly after the engine has been running for 2 minutes.

Conditions for Setting the Fault Codes

The ECM detects that the turbine intake temperature is greater than a calibrated value for more than 10 seconds.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Engine torque may be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and operate the engine in the condition in which the fault occurred.

Shop Talk

Possible causes of this fault code include:

High intake air temperature

High coolant temperature

Malfunctioning turbocharger wastegate.

EGR system leaks

Combustion Knock

Refer to Troubleshooting Fault Code 777 .

Last Modified: 18-Jan-2020


Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 778

Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 778 PID: S64 SPN: 723 FMI: 2/2 LAMP: Amber SRT: | The ECM has detected a loss of signal from the camshaft position sensor. | Possible reduced engine performance.
Engine Camshaft Speed/Position Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine camshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The camshaft speed/position sensor provides a signal to the ECM on the camshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the camshaft speed indicator lobe moves past the sensor. The ECM interprets this signal into an engine speed reading and determines engine position. This sensor is used as a backup sensor if the primary engine crankshaft speed/position signal is lost.

Component Location

The engine camshaft speed/position sensor is located on the intake side of the engine above the accessory drive.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of the camshaft speed/position sensor while the engine was running.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Causes of this fault include:

Open or short circuit of the 5 volt supply, signal, or return wire in the engine harness.

Damaged or malfunctioning camshaft position sensor.

Damage to the sensor target teeth or tone wheel.

Refer to Troubleshooting Fault Code 778 .

Last Modified: 18-Jan-2020


Adaptive Cruise Control Mode - Data Erratic, Intermittent, or Incorrect

FAULT CODE 784

Adaptive Cruise Control Mode - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 784 PID: S145 SPN: 1590 FMI: 2/2 LAMP: None SRT: | Loss of communication with adaptive cruise control. | Adaptive cruise control will not operate. Standard cruise control may not operate.
SAE J1939 Datalink Circuit

Circuit Description

The adaptive cruise control system sends commands to the ECM via the J1939 data link to limit engine speed and maintain a set following distance behind a vehicle travelling more slowly than the current cruise control set speed.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

The adaptive cruise control will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If Adaptive Cruise Recovery is enabled, the driver can toggle the cruise enable switch from the OFF position to the ON position two times to get regular cruise control to operate and Fault Code 784 will go inactive. At the next key cycle, if the Heartbeat message is still not present, Fault Code 784 will go active.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 784 .

Last Modified: 18-Jan-2020


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 111 | SPN: 629 | FMI: 12
Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Troubleshooting Summary

  1. ECM calibration revision history check
  2. ECM Malfunction

1 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM Malfunction

Solution: S00008831

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 115 | SPN: 612 | FMI: 2
Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Battery or battery cables are malfunctioning
  2. Camshaft position sensor is damaged
  3. Engine crankshaft speed/position sensor check
  4. Camshaft position sensor open circuit check
  5. Camshaft gear is damaged
  6. ECM calibration revision history check

1 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Camshaft position sensor is damaged

Solution: S00001226

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the camshaft position sensor.

Refer to Procedure 019-363

  • Inspect the camshaft position sensor for signs of damage, oil leak, and metal debris on the end of the sensor.

Specification

  • If the camshaft position sensor shows any signs of damage, then a malfunctioning camshaft position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace camshaft position sensor.

Refer to Procedure 019-363

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine crankshaft speed/position sensor check

Solution: S00000684

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the crankshaft position sensor.
  • Inspect the crankshaft position sensor for signs of damage, oil leak, and metal debris on the end of the sensor.
  • Verify the crankshaft position sensor is connected properly.
  • Use the ratchet drive side of the socket tool that was used to removed the sensor from the engine, place it flush on the sensor so that the edge of the socket is on the edge of the sensor.
  • Monitor the crankshaft engine speed sensor state using the recommended Cummins® electronic service tool or equivalent and monitor (Engine Speed Main Sensor State) to check if the sensor state transitions.
  • Slowly slide the socket in a perpendicular direction to the marked line on the sensor or in a perpendicular direction to the mounting bracket of the sensor.

Specification

  • If any damage is found to the sensor, then proceed to the Repair section.
  • If the crankshaft position sensor is not connected properly, then proceed to the Repair section.
  • If the crankshaft position sensor state does NOT transition from high to low or low to high, or the state does NOT show triggered, then a malfunctioning crankshaft engine position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine crankshaft speed/position sensor.

Refer to Procedure 019-365

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Camshaft position sensor open circuit check

Solution: S00004132

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the camshaft position sensor SIGNAL pin at the camshaft position sensor engine wiring harness connector to the camshaft position sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the camshaft position sensor SUPPLY pin at the camshaft position sensor engine wiring harness connector to the camshaft position sensor SUPPLY pin at the engine wiring harness ECM connector.
  • Measure the resistance between the camshaft position sensor RETURN pin at the camshaft position sensor engine wiring harness connector to the camshaft position sensor RETURN pin at the engine wiring harness ECM connector.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Camshaft gear is damaged

Solution: S00003976

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the camshaft tone wheel for defects.

Refer to Procedure 001-013

Specification

  • If any damage or defects to the tone wheel or gear are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the camshaft gear.

Refer to Procedure 001-013

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 122 | SPN: 102 | FMI: 3
Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Intake manifold pressure sensor voltage check
  3. Intake manifold pressure sensor voltage check at the ECM
  4. Intake manifold pressure sensor circuit response
  5. Intake manifold pressure sensor circuit response at the ECM
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000153

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 2: 187, 227

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Intake manifold pressure sensor voltage check

Solution: S00007820

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the intake manifold pressure sensor SUPPLY pin and the intake manifold pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Intake manifold pressure sensor voltage check at the ECM

Refer to S00000758

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Intake manifold pressure sensor voltage check at the ECM

Solution: S00000758

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the intake manifold pressure/temperature sensor SUPPLY pin and the intake manifold pressure/temperature sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Intake manifold pressure sensor circuit response

Solution: S00004894

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning intake manifold pressure sensor 1 has been detected if the following fault code became active with the sensor disconnected: 123

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure/temperature sensor.

Refer to Procedure 019-099

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Intake manifold pressure sensor circuit response at the ECM

Solution: S00000456

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 123
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 123

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 123 | SPN: 102 | FMI: 4
Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Intake manifold pressure sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000153

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 2: 187, 227

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Intake manifold pressure sensor is malfunctioning

Solution: S00008835

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning intake manifold pressure/temperature sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the intake manifold pressure/temperature sensor.

Refer to Procedure 019-099

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 124 | SPN: 102 | FMI: 16
Intake Manifold 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Intake manifold pressure sensor voltage check
  3. Intake manifold pressure sensor voltage check at the ECM
  4. Engine turbocharger compressor intake pressure sensor stuck in-range
  5. Intake manifold pressure sensor stuck in-range
  6. Turbocharger is malfunctioning
  7. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002446

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold: 122, 123, 2973
  • Turbocharger: 687, 4621

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Intake manifold pressure sensor voltage check

Solution: S00007820

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the intake manifold pressure sensor SUPPLY pin and the intake manifold pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Intake manifold pressure sensor voltage check at the ECM

Refer to S00000758

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Intake manifold pressure sensor voltage check at the ECM

Solution: S00000758

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the intake manifold pressure/temperature sensor SUPPLY pin and the intake manifold pressure/temperature sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Engine turbocharger compressor intake pressure sensor stuck in-range

Solution: S00004928

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Install a mechanical gauge on the engine.
  • Compare the sensor reading with the recommended Cummins® electronic service tool or equivalent to a mechanical gauge.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the mechanical gauge must be within: 1.5 in-hg [5 kPa]

Linked Solutions

  • None

Repair

  • Replace the turbocharger compressor intake humidity/pressure/temperature sensor.

Refer to Procedure 019-509

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Intake manifold pressure sensor stuck in-range

Solution: S00004821

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the intake manifold pressure sensor.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the known value must be within: 0 ± 10 kPa [0 ± 3 in Hg]

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure sensor.

Refer to Procedure 019-099

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Turbocharger is malfunctioning

Solution: S00004192

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the intake and exhaust connections from the turbocharger.

Action

  • Check that the turbocharger application identification number in the variable geometry turbocharger actuator matches the turbocharger application identification number in the ECM.
  • Visually inspect the turbocharger exhaust outlet for signs of oil or fuel.

Refer to Procedure 010-033

  • Visually inspect the compressor wheel retaining nut for signs of dust ingestion.

Refer to Procedure 010-033

  • Visually inspect the turbocharger compressor and turbine seals.

Refer to Procedure 010-033

  • Measure the radial and axial clearance of the turbocharger wheel.

Refer to Procedure 010-033

Specification

  • If any deposits, damage, or oil contamination is observed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the turbocharger.

Refer to Procedure 010-033

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 125 | SPN: 102 | FMI: 18
Intake Manifold 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Restricted intake air filter
  3. Engine turbocharger compressor intake pressure sensor stuck in-range
  4. Charge air cooler or exhaust system leak
  5. Intake manifold pressure sensor stuck in-range
  6. Turbocharger wastegate actuator is malfunctioning
  7. Turbocharger is malfunctioning
  8. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002446

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold: 122, 123, 2973
  • Turbocharger: 687, 4621

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Restricted intake air filter

Solution: S00000025

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Specification

  • If the intake air filter is plugged, then a restricted intake air filter has been detected.

Linked Solutions

  • None

Repair

  • Replace the air filter.

Refer to OEM Service Manual

Refer to Procedure 010-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine turbocharger compressor intake pressure sensor stuck in-range

Solution: S00004928

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Install a mechanical gauge on the engine.
  • Compare the sensor reading with the recommended Cummins® electronic service tool or equivalent to a mechanical gauge.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the mechanical gauge must be within: 1.5 in-hg [5 kPa]

Linked Solutions

  • None

Repair

  • Replace the turbocharger compressor intake humidity/pressure/temperature sensor.

Refer to Procedure 019-509

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Charge air cooler or exhaust system leak

Solution: S00006382

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.

Refer to Procedure 010-024

  • Visually inspect the air compressor plumbing for possible air leaks.

Refer to Procedure 010-024

  • Visually inspect the EGR plumbing for possible air leaks.

Refer to Procedure 010-024

  • Visually inspect the exhaust piping for leaks, cracks, and loose connections.

Refer to Procedure 010-024

  • Visually inspect the charge air cooler hoses for possible air leaks.

Refer to Procedure 010-024

  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

Repair or replace the following components if they are found out of specification:

  • Repair or replace the leaking components.

Refer to OEM Service Manual

  • Clean or replace the air compressor air inlet tube.

Refer to Procedure 012-109

  • Repair or replace the EGR cooler connection tube.

Refer to Procedure 011-024

  • Repair or replace the EGR crossover tube.

Refer to Procedure 011-070

  • Replace the exhaust manifold gaskets.

Refer to Procedure 011-007

  • Replace the exhaust manifold.

Refer to Procedure 011-007

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Intake manifold pressure sensor stuck in-range

Solution: S00004821

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the intake manifold pressure sensor.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the known value must be within: 0 ± 10 kPa [0 ± 3 in Hg]

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure sensor.

Refer to Procedure 019-099

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Turbocharger wastegate actuator is malfunctioning

Solution: S00006413

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the turbocharger wastegate actuator for damage.

Refer to Procedure 010-050

  • Visually inspect the turbocharger wastegate valve seat.

Refer to Procedure 010-033

  • Inspect the turbocharger wastegate valve body assembly for damage.

Refer to Procedure 010-055

  • Perform the Turbocharger Wastegate Actuator Test.

Refer to Procedure 010-050

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace turbocharger wastegate.

Refer to Procedure 010-033

  • Replace turbocharger wastegate actuator.

Refer to Procedure 010-050

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Turbocharger is malfunctioning

Solution: S00004192

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the intake and exhaust connections from the turbocharger.

Action

  • Check that the turbocharger application identification number in the variable geometry turbocharger actuator matches the turbocharger application identification number in the ECM.
  • Visually inspect the turbocharger exhaust outlet for signs of oil or fuel.

Refer to Procedure 010-033

  • Visually inspect the compressor wheel retaining nut for signs of dust ingestion.

Refer to Procedure 010-033

  • Visually inspect the turbocharger compressor and turbine seals.

Refer to Procedure 010-033

  • Measure the radial and axial clearance of the turbocharger wheel.

Refer to Procedure 010-033

Specification

  • If any deposits, damage, or oil contamination is observed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the turbocharger.

Refer to Procedure 010-033

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 131 | SPN: 91 | FMI: 3
Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Accelerator pedal voltage check
  3. Accelerator pedal circuit check
  4. Accelerator pedal position sensor circuit response
  5. Accelerator pedal position sensor open circuit check
  6. Accelerator pedal position sensor circuit pin to pin short
  7. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000045

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 4: 2185, 2186

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Accelerator pedal voltage check

Solution: S00006527

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the accelerator pedal position 1 sensor SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Accelerator pedal circuit check

Refer to S00006526

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Accelerator pedal circuit check

Solution: S00006526

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the engine wiring harness connector 2 from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position 1 sensor SIGNAL pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 1 sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor SUPPLY pin at the engine wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 1 sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Accelerator pedal position sensor circuit response

Solution: S00000368

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning accelerator pedal position sensor has been detected if the following fault code became active with the sensor disconnected: 132

Linked Solutions

  • None

Repair

  • Replace the accelerator pedal position sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Accelerator pedal position sensor open circuit check

Solution: S00006528

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the engine wiring harness connector 2 from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position 1 sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor SUPPLY pin at the engine wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 1 sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 1 sensor SIGNAL pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Accelerator pedal position sensor circuit pin to pin short

Solution: S00006529

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the engine wiring harness connector 2 from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 132 | SPN: 91 | FMI: 4
Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Accelerator pedal voltage check
  3. Accelerator pedal circuit check
  4. Accelerator pedal position sensor circuit response
  5. Accelerator pedal position sensor open circuit check
  6. Accelerator pedal position sensor circuit pin to ground short
  7. Accelerator pedal position sensor circuit pin to pin short
  8. Internal ECM Error

1 - Check for primary fault codes

Solution: S00000045

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 4: 2185, 2186

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Accelerator pedal voltage check

Solution: S00006527

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the accelerator pedal position 1 sensor SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Accelerator pedal circuit check

Refer to S00006526

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Accelerator pedal circuit check

Solution: S00006526

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the engine wiring harness connector 2 from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position 1 sensor SIGNAL pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 1 sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor SUPPLY pin at the engine wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 1 sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Accelerator pedal position sensor circuit response

Solution: S00000369

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the accelerator pedal position sensor SUPPLY pin and the accelerator pedal position sensor SIGNAL pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning accelerator pedal position sensor has been detected if the following fault code became active with the jumper wire in place: 131

Linked Solutions

  • None

Repair

  • Replace the accelerator pedal position sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Accelerator pedal position sensor open circuit check

Solution: S00006528

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the engine wiring harness connector 2 from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position 1 sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor SUPPLY pin at the engine wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 1 sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 1 sensor SIGNAL pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Accelerator pedal position sensor circuit pin to ground short

Solution: S00006533

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the engine wiring harness connector 2 from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is less than the following specification: 100K Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Accelerator pedal position sensor circuit pin to pin short

Solution: S00006529

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the engine wiring harness connector 2 from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Internal ECM Error

Solution: S00001230

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 15-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 133 | SPN: 974 | FMI: 3
Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Remote accelerator pedal position sensor voltage check
  3. Remote accelerator pedal position sensor circuit check
  4. Remote accelerator pedal position sensor SIGNAL wire shorted to high source
  5. Remote accelerator pedal position sensor open circuit check
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000047

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1695, 1696

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Remote accelerator pedal position sensor voltage check

Solution: S00000441

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal position sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the accelerator pedal position 1 sensor SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM wiring harness.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Remote accelerator pedal position sensor circuit check

Refer to S00000995

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Remote accelerator pedal position sensor circuit check

Solution: S00000995

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the remote accelerator pedal position sensor SUPPLY pin at the remote accelerator pedal position sensor connector of the OEM wiring harness and the remote accelerator pedal position sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the remote accelerator pedal position sensor RETURN pin at the remote accelerator pedal position sensor connector of the OEM wiring harness and the remote accelerator pedal position sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω
  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Remote accelerator pedal position sensor SIGNAL wire shorted to high source

Solution: S00000452

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the remote accelerator pedal SIGNAL pin in the OEM wiring harness ECM connector 2 and SUPPLY pin in the OEM wiring harness ECM connector 2.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Remote accelerator pedal position sensor open circuit check

Solution: S00000449

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM harness ECM connector RETURN pin and the OEM wiring harness accelerator pedal connector RETURN pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 134 | SPN: 974 | FMI: 4
Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Remote accelerator pedal position sensor voltage check
  3. Remote accelerator pedal position sensor circuit check
  4. Remote accelerator pedal position sensor open circuit check
  5. Remote accelerator pedal position sensor circuit pin to ground short
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000048

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1695, 1696

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Remote accelerator pedal position sensor voltage check

Solution: S00000441

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal position sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the accelerator pedal position 1 sensor SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM wiring harness.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Remote accelerator pedal position sensor circuit check

Refer to S00000995

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Remote accelerator pedal position sensor circuit check

Solution: S00000995

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the remote accelerator pedal position sensor SUPPLY pin at the remote accelerator pedal position sensor connector of the OEM wiring harness and the remote accelerator pedal position sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the remote accelerator pedal position sensor RETURN pin at the remote accelerator pedal position sensor connector of the OEM wiring harness and the remote accelerator pedal position sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω
  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Remote accelerator pedal position sensor open circuit check

Solution: S00000453

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the remote accelerator pedal position sensor SIGNAL pin at the remote accelerator pedal position sensor connector of the OEM wiring harness and the remote accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Remote accelerator pedal position sensor circuit pin to ground short

Solution: S00006521

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the engine wiring harness connector 2 from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the remote accelerator pedal SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the remote accelerator pedal SUPPLY pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the remote accelerator pedal RETURN pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 135 | SPN: 100 | FMI: 3
Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Lubricating oil pressure sensor circuit response
  3. Lubricating oil pressure sensor circuit response at the ECM
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000899

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Lubricating oil pressure sensor circuit response

Solution: S00000376

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lubricating oil pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning lubricating oil pressure sensor has been detected if the following fault code became active with the sensor disconnected: 141

Linked Solutions

  • None

Repair

  • Replace the lubricating oil pressure sensor.

Refer to Procedure 019-066

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Lubricating oil pressure sensor circuit response at the ECM

Solution: S00001231

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 141
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 141

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 141 | SPN: 100 | FMI: 4
Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Lubricating oil pressure sensor circuit response
  3. Lubricating oil pressure sensor circuit response at the ECM
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000899

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Lubricating oil pressure sensor circuit response

Solution: S00000377

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lubricating oil pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the lubricating oil pressure sensor SUPPLY pin and the lubricating oil pressure sensor SIGNAL pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning lubricating oil pressure sensor has been detected if the following fault code became active with the jumper wire in place: 135

Linked Solutions

  • None

Repair

  • Replace the lubricating oil pressure sensor.

Refer to Procedure 019-066

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Lubricating oil pressure sensor circuit response at the ECM

Solution: S00000445

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the lubricating oil pressure sensor SUPPLY pin and the lubricating oil pressure sensor SIGNAL pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 135
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 135

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 143 | SPN: 100 | FMI: 18
Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Basic oil system checks
  3. Lubricating oil pressure sensor stuck in-range
  4. Lubricating oil filter plugged
  5. Lubricating oil pressure relief valve is malfunctioning
  6. Loose or broken lubricating oil suction tube
  7. Main lubricating oil pressure regulator is malfunctioning
  8. Lubricating oil pump is malfunctioning
  9. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000078

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Oil: 135, 141
  • Sensor supply 1: 352, 386

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Basic oil system checks

Solution: S00000474

Verification

Conditions

  • Turn keyswitch OFF.

Action

CAUTION: Do not start an engine that has low oil pressure fault codes/complaints until it has been verified that the oil level is correct and that the oil filter is not plugged. Internal engine damage can result from low or no oil pressure.

  • Interview the operator about the complaint. Ask if the fault occurs when climbing or descending a steep hill to determine if engine angularity is a potential issue.
  • Visually inspect engine for external lubricating oil leaks.
  • Check that the lubricating oil level is correct.

Refer to OEM Service Manual

Specification

  • If an oil leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the component that is the source of the leak.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Lubricating oil pressure sensor stuck in-range

Solution: S00000342

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the sensor for damage.
  • Install a mechanical gauge on the engine.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the sensor reading with the recommended Cummins® electronic service tool or equivalent to a mechanical gauge.
  • If the lubricating oil pressure does not meet the minimum specification, do not perform any engine running tests.

Refer to Procedure 018-017

  • Operate engine at rated rpm.
  • Monitor the lubricating oil pressure sensor.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the mechanical gauge must be within: 17 kPa [2.5 psi]
  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the lubricating oil pressure sensor.

Refer to Procedure 019-066

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Lubricating oil filter plugged

Solution: S00000466

Verification

Conditions

  • Turn keyswitch ON.
  • Engine running.
  • Lubricating oil pressure must be above the minimum specification.

Refer to Procedure 018-017

Action

  • If the lubricating oil pressure does not meet the minimum specification, then skip this solution and do not perform the test to measure oil filter differential pressure.
  • Measure the differential pressure drop across the lubricating oil filter.

Refer to Procedure 007-095

Specification

  • If the lubrication oil filter differential pressure is not within the specification, then a plugged lubrication oil filter has been detected.

Refer to Procedure 007-095

Linked Solutions

  • None

Repair

  • Replace the lubricating oil filter.

Refer to Procedure 007-013

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Lubricating oil pressure relief valve is malfunctioning

Solution: S00000471

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the lubricating oil pressure relief valve.

Refer to Procedure 007-021

Specification

  • If the lubricating oil pressure relief valve does not meet specification, then a malfunctioning lubricating oil pressure relief valve has been detected.

Refer to Procedure 007-021

Linked Solutions

  • None

Repair

  • Replace the lubricating oil pressure relief valve.

Refer to Procedure 007-021

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Loose or broken lubricating oil suction tube

Solution: S00000464

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the lubricating oil pan.

Refer to Procedure 007-025

  • Inspect the lubricating oil suction tube and o-ring for damage.

Refer to Procedure 007-035

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the lubricating oil suction tube o-ring or the damaged lubricating oil suction tube.

Refer to Procedure 007-035

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Main lubricating oil pressure regulator is malfunctioning

Solution: S00000469

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the main lubricating oil pressure regulator assembly.

Refer to Procedure 007-031

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the main lubricating oil pressure regulator assembly.

Refer to Procedure 007-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Lubricating oil pump is malfunctioning

Solution: S00000472

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the lubricating oil pump.

Refer to Procedure 007-031

  • Inspect the lubricating oil pump.

Refer to Procedure 007-031

If the lubricating oil pump was found to be damaged, then inspect the lubricating oil filter for metal.

Specification

  • If damaged, loose or worn gears are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the lubricating oil pump.

Refer to Procedure 007-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 144 | SPN: 110 | FMI: 3
Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Coolant temperature sensor resistance check
  2. Engine coolant temperature sensor circuit response check at the ECM

1 - Coolant temperature sensor resistance check

Solution: S00000127

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and engine coolant temperature sensor RETURN pin at the engine coolant temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the resistance is not within the following specification: 180 - 160k Ω

Linked Solutions

  • None

Repair

  • Replace the coolant temperature sensor.

Refer to Procedure 019-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Engine coolant temperature sensor circuit response check at the ECM

Solution: S00000175

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the engine coolant temperature sensor SIGNAL pin and the engine coolant temperature sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 145
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 145

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 145 | SPN: 110 | FMI: 4
Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Coolant temperature sensor resistance check
  2. Engine coolant temperature sensor circuit response check at the ECM

1 - Coolant temperature sensor resistance check

Solution: S00000127

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and engine coolant temperature sensor RETURN pin at the engine coolant temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the resistance is not within the following specification: 180 - 160k Ω

Linked Solutions

  • None

Repair

  • Replace the coolant temperature sensor.

Refer to Procedure 019-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Engine coolant temperature sensor circuit response check at the ECM

Solution: S00000319

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 144
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 144

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 146 | SPN: 110 | FMI: 16
Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Coolant level check
  3. Cooling fan component inspection
  4. Radiator is externally obstructed
  5. Radiator shutters malfunctioning (if equipped)
  6. Coolant temperature sensor resistance check
  7. Fan clutch operates incorrectly
  8. Thermostat is malfunctioning
  9. Out-of-chassis opening temperature test
  10. Malfunctioning cooling fan drive or cooling fan controls
  11. Combustion gases entering the cooling system
  12. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002207

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Engine coolant temperature: 144, 145

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Coolant level check

Solution: S00003142

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the coolant level.
  • Perform the Coolant System Pressure Test.

Refer to Procedure 008-018

  • Visually inspect for external coolant leaks.

Specification

  • If the coolant level is low and there are signs of external coolant leaks, then reset the search to external coolant leak.
  • If the coolant level is low and there are no signs of external coolant leaks, then reset the search to internal coolant leak.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3 - Cooling fan component inspection

Solution: S00001686

Verification

Conditions

  • Turn keyswitch OFF.

Action

Inspect the following components if applicable:

  • Visually inspect the cooling fan and cooling fan blades.
  • Visually inspect the cooling fan shroud.
  • Visually inspect the recirculation baffles.
  • Inspect the cooling fan belt.

Refer to Procedure 008-002

  • Visually inspect the cooling fan hub assembly.
  • Visually inspect the automatic cooling fan belt tensioner.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Radiator is externally obstructed

Solution: S00000485

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the radiator for damage.
  • Visually inspect the radiator for any type of external obstruction.
  • Check for closed cold weather radiator cover or winterfront.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the restricted radiator.

Refer to OEM Service Manual

  • Remove the obstruction.

Refer to OEM Service Manual

  • Repair or replace cold weather radiator cover or winterfront.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Radiator shutters malfunctioning (if equipped)

Solution: S00000484

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Manually operate the radiator shutters.

Refer to OEM Service Manual

  • Check the shutterstat setting.

Refer to OEM Service Manual

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning radiator shutters or shutterstat.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Coolant temperature sensor resistance check

Solution: S00000127

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and engine coolant temperature sensor RETURN pin at the engine coolant temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the resistance is not within the following specification: 180 - 160k Ω

Linked Solutions

  • None

Repair

  • Replace the coolant temperature sensor.

Refer to Procedure 019-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Fan clutch operates incorrectly

Solution: S00006090

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the adjustable parameters settings.

Ensure the following adjustable parameters are set correctly for the application:

  • Fan Control Logic.
  • Fan Control Switch.
  • Air Conditioner Pressure Switch Input.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Fan Override Test.
  • Verify that the fan operates correctly.
  • Verify the fan is engaging at the correct engine temperature.

Refer to Procedure 008-027

Refer to OEM Service Manual

Specification

  • If the fan does not engage at the correct engine temperature, then a malfunctioning fan clutch has been detected.

Linked Solutions

  • None

Repair

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to Procedure 008-027

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Thermostat is malfunctioning

Solution: S00000785

Verification

Conditions

  • Engine running.

Action

  • Allow the engine to reach operating temperature.
  • Check the thermostat opening temperature with an infrared temperature gun.
  • Check the coolant thermostat for proper operation.

Refer to Procedure 008-013

  • Check for a damaged or leaking thermostat seal.

Refer to Procedure 008-013

  • If a temperature gun is not available or if the temperature gun reading is above the correct thermostat opening temperature, then proceed to Linked Solutions section.

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • Out-of-chassis opening temperature test

Refer to S00001359

Repair

  • Replace the engine coolant thermostat.

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8.1 - Out-of-chassis opening temperature test

Solution: S00001359

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the out-of-chassis opening temperature test.

Refer to Procedure 008-013

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine coolant thermostat.

Refer to Procedure 008-013

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

9 - Malfunctioning cooling fan drive or cooling fan controls

Solution: S00000490

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Monitor the cooling fan operation.

Refer to Procedure 008-027

Specification

  • If the cooling fan operation is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.
  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - Combustion gases entering the cooling system

Solution: S00000470

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check for air or combustion gases in the cooling system.

Refer to Procedure 008-019

Specification

  • If air bubbles are found during the combustion gas test and did not change colors (Blue to Yellow or Green), then a malfunctioning air compressor has been determined.
  • If the combustion gas test changed colors (Blue to Yellow or Green), then a malfunctioning engine cylinder head gasket has been determined.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the air compressor cylinder head.

Refer to Procedure 012-007

  • Replace the cylinder head gasket.

Refer to Procedure 002-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

11 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 151 | SPN: 110 | FMI: 0
Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Coolant level check
  3. Cooling fan component inspection
  4. Radiator is externally obstructed
  5. Radiator shutters malfunctioning (if equipped)
  6. Coolant temperature sensor resistance check
  7. Fan clutch operates incorrectly
  8. Thermostat is malfunctioning
  9. Out-of-chassis opening temperature test
  10. Malfunctioning cooling fan drive or cooling fan controls
  11. Combustion gases entering the cooling system
  12. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002207

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Engine coolant temperature: 144, 145

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Coolant level check

Solution: S00003142

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the coolant level.
  • Perform the Coolant System Pressure Test.

Refer to Procedure 008-018

  • Visually inspect for external coolant leaks.

Specification

  • If the coolant level is low and there are signs of external coolant leaks, then reset the search to external coolant leak.
  • If the coolant level is low and there are no signs of external coolant leaks, then reset the search to internal coolant leak.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3 - Cooling fan component inspection

Solution: S00001686

Verification

Conditions

  • Turn keyswitch OFF.

Action

Inspect the following components if applicable:

  • Visually inspect the cooling fan and cooling fan blades.
  • Visually inspect the cooling fan shroud.
  • Visually inspect the recirculation baffles.
  • Inspect the cooling fan belt.

Refer to Procedure 008-002

  • Visually inspect the cooling fan hub assembly.
  • Visually inspect the automatic cooling fan belt tensioner.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Radiator is externally obstructed

Solution: S00000485

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the radiator for damage.
  • Visually inspect the radiator for any type of external obstruction.
  • Check for closed cold weather radiator cover or winterfront.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the restricted radiator.

Refer to OEM Service Manual

  • Remove the obstruction.

Refer to OEM Service Manual

  • Repair or replace cold weather radiator cover or winterfront.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Radiator shutters malfunctioning (if equipped)

Solution: S00000484

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Manually operate the radiator shutters.

Refer to OEM Service Manual

  • Check the shutterstat setting.

Refer to OEM Service Manual

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning radiator shutters or shutterstat.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Coolant temperature sensor resistance check

Solution: S00000127

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and engine coolant temperature sensor RETURN pin at the engine coolant temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the resistance is not within the following specification: 180 - 160k Ω

Linked Solutions

  • None

Repair

  • Replace the coolant temperature sensor.

Refer to Procedure 019-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Fan clutch operates incorrectly

Solution: S00006090

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the adjustable parameters settings.

Ensure the following adjustable parameters are set correctly for the application:

  • Fan Control Logic.
  • Fan Control Switch.
  • Air Conditioner Pressure Switch Input.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Fan Override Test.
  • Verify that the fan operates correctly.
  • Verify the fan is engaging at the correct engine temperature.

Refer to Procedure 008-027

Refer to OEM Service Manual

Specification

  • If the fan does not engage at the correct engine temperature, then a malfunctioning fan clutch has been detected.

Linked Solutions

  • None

Repair

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to Procedure 008-027

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Thermostat is malfunctioning

Solution: S00000785

Verification

Conditions

  • Engine running.

Action

  • Allow the engine to reach operating temperature.
  • Check the thermostat opening temperature with an infrared temperature gun.
  • Check the coolant thermostat for proper operation.

Refer to Procedure 008-013

  • Check for a damaged or leaking thermostat seal.

Refer to Procedure 008-013

  • If a temperature gun is not available or if the temperature gun reading is above the correct thermostat opening temperature, then proceed to Linked Solutions section.

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • Out-of-chassis opening temperature test

Refer to S00001359

Repair

  • Replace the engine coolant thermostat.

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8.1 - Out-of-chassis opening temperature test

Solution: S00001359

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the out-of-chassis opening temperature test.

Refer to Procedure 008-013

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine coolant thermostat.

Refer to Procedure 008-013

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

9 - Malfunctioning cooling fan drive or cooling fan controls

Solution: S00000490

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Monitor the cooling fan operation.

Refer to Procedure 008-027

Specification

  • If the cooling fan operation is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.
  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - Combustion gases entering the cooling system

Solution: S00000470

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check for air or combustion gases in the cooling system.

Refer to Procedure 008-019

Specification

  • If air bubbles are found during the combustion gas test and did not change colors (Blue to Yellow or Green), then a malfunctioning air compressor has been determined.
  • If the combustion gas test changed colors (Blue to Yellow or Green), then a malfunctioning engine cylinder head gasket has been determined.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the air compressor cylinder head.

Refer to Procedure 012-007

  • Replace the cylinder head gasket.

Refer to Procedure 002-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

11 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 153 | SPN: 105 | FMI: 3
Engine Intake Manifold 1 Temperature - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Intake manifold temperature sensor circuit response
  2. Intake manifold temperature sensor circuit response check at the ECM
  3. Intake manifold temperature sensor stuck in-range
  4. ECM calibration revision history check

1 - Intake manifold temperature sensor circuit response

Solution: S00004339

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the intake manifold temperature sensor SIGNAL pin and the intake manifold temperature sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning intake manifold temperature sensor has been detected if the following fault code became active with the jumper wire in place: 154

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure/temperature sensor.

Refer to Procedure 019-099

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Intake manifold temperature sensor circuit response check at the ECM

Solution: S00000576

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the intake manifold temperature sensor SIGNAL pin and the intake manifold temperature sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 154
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 154

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Intake manifold temperature sensor stuck in-range

Solution: S00004561

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the intake manifold temperature sensor reading to an infrared thermometer or a known value.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the known value must be within: +/- 10C [18F].

Linked Solutions

  • None

Repair

  • Replace the intake manifold temperature sensor.

Refer to Procedure 019-099

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 154 | SPN: 105 | FMI: 4
Engine Intake Manifold 1 Temperature - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Intake manifold temperature sensor circuit response
  2. Intake manifold temperature sensor circuit response check at the ECM
  3. Intake manifold temperature sensor stuck in-range
  4. ECM calibration revision history check

1 - Intake manifold temperature sensor circuit response

Solution: S00004338

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning intake manifold temperature sensor has been detected if the following fault code became active with the sensor disconnected: 153

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure/temperature sensor.

Refer to Procedure 019-099

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Intake manifold temperature sensor circuit response check at the ECM

Solution: S00000479

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 153
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 153

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Intake manifold temperature sensor stuck in-range

Solution: S00004561

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the intake manifold temperature sensor reading to an infrared thermometer or a known value.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the known value must be within: +/- 10C [18F].

Linked Solutions

  • None

Repair

  • Replace the intake manifold temperature sensor.

Refer to Procedure 019-099

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 155 | SPN: 105 | FMI: 0
Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Cooling fan component inspection
  3. High intake manifold temperature basic checks
  4. Radiator is externally obstructed
  5. Fan clutch operates incorrectly
  6. Intake manifold temperature sensor stuck in-range
  7. Thermostat is malfunctioning
  8. Out-of-chassis opening temperature test
  9. Charge air cooler or exhaust system leak
  10. Intake manifold temperature sensor stuck in-range
  11. Malfunctioning cooling fan drive or cooling fan controls
  12. Engine Compression Test
  13. Overhead component damaged or out of adjustment
  14. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000050

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold temperature: 153, 154
  • Fan control circuit: 245, 2377

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Cooling fan component inspection

Solution: S00001686

Verification

Conditions

  • Turn keyswitch OFF.

Action

Inspect the following components if applicable:

  • Visually inspect the cooling fan and cooling fan blades.
  • Visually inspect the cooling fan shroud.
  • Visually inspect the recirculation baffles.
  • Inspect the cooling fan belt.

Refer to Procedure 008-002

  • Visually inspect the cooling fan hub assembly.
  • Visually inspect the automatic cooling fan belt tensioner.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - High intake manifold temperature basic checks

Solution: S00000459

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Refer to Procedure 010-031

  • Visually inspect the charge-air cooler for damage or debris blocking the air flow.

Refer to Procedure 010-027

  • Visually inspect the air conditioner condenser.

Refer to OEM Service Manual

  • Visually inspect the radiator fins for damage or debris blocking the air flow.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Radiator is externally obstructed

Solution: S00000485

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the radiator for damage.
  • Visually inspect the radiator for any type of external obstruction.
  • Check for closed cold weather radiator cover or winterfront.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the restricted radiator.

Refer to OEM Service Manual

  • Remove the obstruction.

Refer to OEM Service Manual

  • Repair or replace cold weather radiator cover or winterfront.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Fan clutch operates incorrectly

Solution: S00006090

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the adjustable parameters settings.

Ensure the following adjustable parameters are set correctly for the application:

  • Fan Control Logic.
  • Fan Control Switch.
  • Air Conditioner Pressure Switch Input.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Fan Override Test.
  • Verify that the fan operates correctly.
  • Verify the fan is engaging at the correct engine temperature.

Refer to Procedure 008-027

Refer to OEM Service Manual

Specification

  • If the fan does not engage at the correct engine temperature, then a malfunctioning fan clutch has been detected.

Linked Solutions

  • None

Repair

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to Procedure 008-027

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Intake manifold temperature sensor stuck in-range

Solution: S00000334

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the intake manifold temperature sensor reading to an infrared thermometer or a known value.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the known value must be within: +/- 10C [18F]

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Thermostat is malfunctioning

Solution: S00000785

Verification

Conditions

  • Engine running.

Action

  • Allow the engine to reach operating temperature.
  • Check the thermostat opening temperature with an infrared temperature gun.
  • Check the coolant thermostat for proper operation.

Refer to Procedure 008-013

  • Check for a damaged or leaking thermostat seal.

Refer to Procedure 008-013

  • If a temperature gun is not available or if the temperature gun reading is above the correct thermostat opening temperature, then proceed to Linked Solutions section.

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • Out-of-chassis opening temperature test

Refer to S00001359

Repair

  • Replace the engine coolant thermostat.

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7.1 - Out-of-chassis opening temperature test

Solution: S00001359

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the out-of-chassis opening temperature test.

Refer to Procedure 008-013

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine coolant thermostat.

Refer to Procedure 008-013

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

8 - Charge air cooler or exhaust system leak

Solution: S00006382

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.

Refer to Procedure 010-024

  • Visually inspect the air compressor plumbing for possible air leaks.

Refer to Procedure 010-024

  • Visually inspect the EGR plumbing for possible air leaks.

Refer to Procedure 010-024

  • Visually inspect the exhaust piping for leaks, cracks, and loose connections.

Refer to Procedure 010-024

  • Visually inspect the charge air cooler hoses for possible air leaks.

Refer to Procedure 010-024

  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

Repair or replace the following components if they are found out of specification:

  • Repair or replace the leaking components.

Refer to OEM Service Manual

  • Clean or replace the air compressor air inlet tube.

Refer to Procedure 012-109

  • Repair or replace the EGR cooler connection tube.

Refer to Procedure 011-024

  • Repair or replace the EGR crossover tube.

Refer to Procedure 011-070

  • Replace the exhaust manifold gaskets.

Refer to Procedure 011-007

  • Replace the exhaust manifold.

Refer to Procedure 011-007

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Intake manifold temperature sensor stuck in-range

Solution: S00004561

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the intake manifold temperature sensor reading to an infrared thermometer or a known value.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the known value must be within: +/- 10C [18F].

Linked Solutions

  • None

Repair

  • Replace the intake manifold temperature sensor.

Refer to Procedure 019-099

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - Malfunctioning cooling fan drive or cooling fan controls

Solution: S00000490

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Monitor the cooling fan operation.

Refer to Procedure 008-027

Specification

  • If the cooling fan operation is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.
  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

11 - Engine Compression Test

Solution: S00006439

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the Engine Compression Test.

Refer to Procedure 014-012

Specification

  • If the Engine Compression Test is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the piston.

Refer to Procedure 001-043

  • Replace the piston ring.

Refer to Procedure 001-047

  • Repair or replace the cylinder liner.

Refer to Procedure 001-028

  • Replace the cylinder head.

Refer to Procedure 002-004

Validation

  • None
Next Solution

12 - Overhead component damaged or out of adjustment

Solution: S00008484

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

  • Adjust the overhead.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

13 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 176 | SPN: 3464 | FMI: 4
Electronic Throttle Control Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Engine intake throttle actuator open circuit check
  2. Engine intake throttle actuator circuit pin to pin short
  3. Engine intake throttle actuator is malfunctioning
  4. Engine intake throttle actuator is malfunctioning

1 - Engine intake throttle actuator open circuit check

Solution: S00004779

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine intake throttle actuator motor SUPPLY pin at the engine intake throttle actuator engine wiring harness connector and the engine intake throttle actuator SUPPLY pin at the engine wiring harness ECM connector.
  • Measure the resistance between the engine intake throttle actuator motor RETURN pin at the engine intake throttle actuator engine wiring harness connector and the engine intake throttle actuator RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Engine intake throttle actuator circuit pin to pin short

Solution: S00004781

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the intake throttle actuator motor SIGNAL pin at the ECM connector of the engine wiring harness and all other pins at that connector.
  • Measure the resistance between the intake throttle actuator motor RETURN pin at the ECM connector of the engine wiring harness and all other pins at that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine intake throttle actuator is malfunctioning

Solution: S00004282

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Gas Throttle Control Test.

Specification

  • If the engine intake throttle actuator does not pass the Gas Throttle Control Test, then a malfunctioning engine intake throttle actuator has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine intake throttle actuator.

Refer to Procedure 005-052

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Engine intake throttle actuator is malfunctioning

Solution: S00004776

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning engine intake throttle actuator assembly has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine intake throttle actuator.

Refer to Procedure 005-052

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 12-Dec-2021


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 187 | SPN: 3510 | FMI: 4
Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. ECM sensor supply 2 voltage below normal

1 - ECM sensor supply 2 voltage below normal

Solution: S00003893

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Perform the following actions one at a time:
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Disconnect the EGR valve from the engine wiring harness.
  • Disconnect the engine intake manifold pressure/temperature sensor from the engine wiring harness.
  • Disconnect the throttle intake pressure sensor from the engine wiring harness.
  • Disconnect the lubricating oil pressure sensor from the engine wiring harness.
  • Disconnect the EGR differential pressure sensor from the engine wiring harness.
  • Disconnect the crankcase pressure sensor from the engine wiring harness.
  • Disconnect the engine wiring harness from the ECM.

Specification

  • If the fault code goes inactive when a component is disconnected, then a malfunctioning sensor supply component has been detected.
  • If the fault code stays active when the engine wiring harness is disconnected, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the EGR valve.

Refer to Procedure 011-022

  • Clean or replace intake manifold pressure/temperature sensor.

Refer to Procedure 019-354

  • Replace the throttle intake pressure sensor.

Refer to Procedure 019-470

  • Replace the lubricating oil pressure sensor.

Refer to Procedure 019-066

  • Replace the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Replace crankcase pressure sensor.

Refer to Procedure 019-445

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 12-Dec-2021


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 195 | SPN: 111 | FMI: 3
Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Coolant level sensor voltage check (3-wire)
  3. Coolant level sensor open circuit check
  4. Coolant level sensor circuit response (2-wire)
  5. Coolant level sensor is malfunctioning
  6. Coolant level sensor circuit response (3-wire)
  7. Coolant level sensor is malfunctioning
  8. Coolant level sensor open circuit check (2-wire)
  9. Coolant level sensor open circuit check (3-wire)
  10. Coolant level sensor circuit pin to pin short (3-wire)
  11. Coolant level sensor circuit pin to pin short (2-wire)

1 - Check for primary fault codes

Solution: S00000051

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1695, 1696

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Coolant level sensor voltage check (3-wire)

Solution: S00006485

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the coolant level sensor SUPPLY pin to the coolant level sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Coolant level sensor open circuit check

Refer to S00006486

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Coolant level sensor open circuit check

Solution: S00006486

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector 2 from the ECM.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SUPPLY pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor SUPPLY pin at the engine wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor SIGNAL pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor RETURN pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Coolant level sensor circuit response (2-wire)

Solution: S00000817

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution if the following fault code did not become active with the sensor disconnected: 195
  • Proceed to the Linked Solutions section if the following fault code became active with the sensor disconnected: 195

Linked Solutions

Click on the link below:

  • Coolant level sensor is malfunctioning

Refer to S00000839

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Coolant level sensor is malfunctioning

Solution: S00000839

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the engine coolant level sensor SIGNAL pin and the engine coolant level sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine coolant level sensor has been detected if the following fault code became active with the jumper wire in place: 196

Linked Solutions

  • None

Repair

  • Replace engine coolant level sensor.

Refer to Procedure 019-017

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Coolant level sensor circuit response (3-wire)

Solution: S00000359

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the engine coolant level sensor SIGNAL pin and the engine coolant level sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution if the following fault code did not become active with the jumper wire in place: 196
  • Proceed to the Linked Solutions section if the following fault code became active with the jumper wire in place: 196

Linked Solutions

  • Coolant level sensor is malfunctioning

Refer to S00001157

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Coolant level sensor is malfunctioning

Solution: S00001157

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the jumper wire between the engine coolant level sensor SIGNAL pin and the engine coolant level sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Place a jumper wire between the engine coolant level sensor SUPPLY pin and the engine coolant level sensor SIGNAL pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine coolant level sensor has been detected if the following fault code became active with the jumper wire in place: 195

Linked Solutions

  • None

Repair

  • Replace engine coolant level sensor.

Refer to Procedure 019-017

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Coolant level sensor open circuit check (2-wire)

Solution: S00006490

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector 2 from the ECM.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor RETURN pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Coolant level sensor open circuit check (3-wire)

Solution: S00006491

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector 2 from the ECM.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SUPPLY pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor SUPPLY pin at the engine wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor SIGNAL pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor RETURN pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Coolant level sensor circuit pin to pin short (3-wire)

Solution: S00006493

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector 2 from the ECM.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins at the engine wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor SUPPLY pin at the engine wiring harness ECM connector and all other pins at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Coolant level sensor circuit pin to pin short (2-wire)

Solution: S00006492

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector 2 from the ECM.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 15-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 196 | SPN: 111 | FMI: 4
Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Coolant level sensor voltage check (3-wire)
  3. Coolant level sensor open circuit check
  4. Coolant level sensor circuit response (2-wire)
  5. Coolant level sensor is malfunctioning
  6. Coolant level sensor circuit response (3-wire)
  7. Coolant level sensor is malfunctioning
  8. Coolant level sensor open circuit check (2-wire)
  9. Coolant level sensor open circuit check (3-wire)
  10. Coolant level sensor circuit pin to ground short
  11. Coolant level sensor circuit pin to pin short (3-wire)
  12. Coolant level sensor circuit pin to pin short (2-wire)

1 - Check for primary fault codes

Solution: S00000054

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1696

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Coolant level sensor voltage check (3-wire)

Solution: S00006485

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the coolant level sensor SUPPLY pin to the coolant level sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Coolant level sensor open circuit check

Refer to S00006486

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Coolant level sensor open circuit check

Solution: S00006486

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector 2 from the ECM.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SUPPLY pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor SUPPLY pin at the engine wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor SIGNAL pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor RETURN pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Coolant level sensor circuit response (2-wire)

Solution: S00000817

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution if the following fault code did not become active with the sensor disconnected: 195
  • Proceed to the Linked Solutions section if the following fault code became active with the sensor disconnected: 195

Linked Solutions

Click on the link below:

  • Coolant level sensor is malfunctioning

Refer to S00000839

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Coolant level sensor is malfunctioning

Solution: S00000839

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the engine coolant level sensor SIGNAL pin and the engine coolant level sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine coolant level sensor has been detected if the following fault code became active with the jumper wire in place: 196

Linked Solutions

  • None

Repair

  • Replace engine coolant level sensor.

Refer to Procedure 019-017

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Coolant level sensor circuit response (3-wire)

Solution: S00000359

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the engine coolant level sensor SIGNAL pin and the engine coolant level sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution if the following fault code did not become active with the jumper wire in place: 196
  • Proceed to the Linked Solutions section if the following fault code became active with the jumper wire in place: 196

Linked Solutions

  • Coolant level sensor is malfunctioning

Refer to S00001157

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Coolant level sensor is malfunctioning

Solution: S00001157

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the jumper wire between the engine coolant level sensor SIGNAL pin and the engine coolant level sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Place a jumper wire between the engine coolant level sensor SUPPLY pin and the engine coolant level sensor SIGNAL pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine coolant level sensor has been detected if the following fault code became active with the jumper wire in place: 195

Linked Solutions

  • None

Repair

  • Replace engine coolant level sensor.

Refer to Procedure 019-017

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Coolant level sensor open circuit check (2-wire)

Solution: S00006490

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector 2 from the ECM.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor RETURN pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Coolant level sensor open circuit check (3-wire)

Solution: S00006491

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector 2 from the ECM.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SUPPLY pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor SUPPLY pin at the engine wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor SIGNAL pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor RETURN pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Coolant level sensor circuit pin to ground short

Solution: S00006562

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the engine wiring harness connector 2 from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Coolant level sensor circuit pin to pin short (3-wire)

Solution: S00006493

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector 2 from the ECM.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins at the engine wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor SUPPLY pin at the engine wiring harness ECM connector and all other pins at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Coolant level sensor circuit pin to pin short (2-wire)

Solution: S00006492

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector 2 from the ECM.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 15-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 197 | SPN: 111 | FMI: 18
Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Coolant level check
  3. Coolant level sensor open circuit check
  4. Coolant level sensor circuit pin to ground short
  5. Coolant level sensor circuit pin to pin short
  6. ECM calibration revision history check
  7. Coolant level sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00010587

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 operating hours from the following list:

  • Coolant level: 195, 196

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Coolant level check

Solution: S00003142

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the coolant level.
  • Perform the Coolant System Pressure Test.

Refer to Procedure 008-018

  • Visually inspect for external coolant leaks.

Specification

  • If the coolant level is low and there are signs of external coolant leaks, then reset the search to external coolant leak.
  • If the coolant level is low and there are no signs of external coolant leaks, then reset the search to internal coolant leak.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3 - Coolant level sensor open circuit check

Solution: S00007920

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Coolant level sensor circuit pin to ground short

Solution: S00007921

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Coolant level sensor circuit pin to pin short

Solution: S00007922

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor SUPPLY pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Coolant level sensor is malfunctioning

Solution: S00007923

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning coolant level sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace engine coolant level sensor.

Refer to Procedure 019-017

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 212 | SPN: 175 | FMI: 3
Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Lubricating oil temperature sensor resistance check

1 - Lubricating oil temperature sensor resistance check

Solution: S00000362

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lubricating oil temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin and the engine oil temperature sensor RETURN pin at the engine oil temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the resistance is not within the following specification: 180 Ω - 160k Ω

Linked Solutions

  • None

Repair

  • Replace the lubricating oil temperature sensor.

Refer to Procedure 019-067

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 213 | SPN: 175 | FMI: 4
Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Lubricating oil temperature sensor resistance check

1 - Lubricating oil temperature sensor resistance check

Solution: S00000362

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lubricating oil temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin and the engine oil temperature sensor RETURN pin at the engine oil temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the resistance is not within the following specification: 180 Ω - 160k Ω

Linked Solutions

  • None

Repair

  • Replace the lubricating oil temperature sensor.

Refer to Procedure 019-067

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 214 | SPN: 175 | FMI: 0
Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Basic oil system checks
  3. Lubricating oil temperature sensor resistance check
  4. Lubricating oil temperature sensor stuck in-range
  5. Lubricating oil thermostat is malfunctioning
  6. Lubricating oil cooler is leaking
  7. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00008424

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Engine coolant temperature: 146, 151, 2113, 2114, 2963, 4629, 4631, 5224

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Basic oil system checks

Solution: S00000474

Verification

Conditions

  • Turn keyswitch OFF.

Action

CAUTION: Do not start an engine that has low oil pressure fault codes/complaints until it has been verified that the oil level is correct and that the oil filter is not plugged. Internal engine damage can result from low or no oil pressure.

  • Interview the operator about the complaint. Ask if the fault occurs when climbing or descending a steep hill to determine if engine angularity is a potential issue.
  • Visually inspect engine for external lubricating oil leaks.
  • Check that the lubricating oil level is correct.

Refer to OEM Service Manual

Specification

  • If an oil leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the component that is the source of the leak.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Lubricating oil temperature sensor resistance check

Solution: S00000362

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lubricating oil temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin and the engine oil temperature sensor RETURN pin at the engine oil temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the resistance is not within the following specification: 180 Ω - 160k Ω

Linked Solutions

  • None

Repair

  • Replace the lubricating oil temperature sensor.

Refer to Procedure 019-067

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Lubricating oil temperature sensor stuck in-range

Solution: S00004643

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the lubricating oil temperature sensor
  • Compare the lubricating oil temperature sensor reading to an infrared thermometer or a known value.

Specification

  • If the temperature reading in the recommended Cummins® electronic service tool or equivalent and infrared thermometer or a known value are not within specification, then a malfunctioning lubricating oil temperature sensor has been detected.
  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the known value must be within: +/- 10C [18F]

Linked Solutions

  • None

Repair

  • Replace the lubricating oil temperature sensor.

Refer to Procedure 019-067

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Lubricating oil thermostat is malfunctioning

Solution: S00000811

Verification

Conditions

  • None

Action

  • Check the lubricating oil thermostat for proper operation.

Refer to Procedure 007-039

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning oil thermostat has been detected.

Linked Solutions

  • None

Repair

  • Replace the lubricating oil thermostat.

Refer to Procedure 007-039

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Lubricating oil cooler is leaking

Solution: S00000810

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Pressure test the lubricating oil cooler.

Refer to Procedure 007-003

Specification

  • If there are any lubricating oil cooler leaks during the pressure test or any damage is observed during inspection, then a malfunctioning lubricating oil cooler or gaskets have been detected.

Linked Solutions

  • None

Repair

  • Replace the lubricating oil cooler.

Refer to Procedure 007-003

  • Replace the lubricating oil cooler element, mounting plate gasket or o-ring.

Refer to Procedure 007-003

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 227 | SPN: 3510 | FMI: 3
Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. ECM sensor supply 2 voltage above normal
  2. ECM calibration revision history check

1 - ECM sensor supply 2 voltage above normal

Solution: S00000992

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine wiring harness has been detected if the following fault code did not become active with the engine wiring harness disconnected: 227
  • A malfunctioning ECM has been detected if the following fault code became active with the engine wiring harness disconnected: 227

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 234 | SPN: 190 | FMI: 0
Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Engine speed sensor is malfunctioning
  3. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002618

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake throttle: 176, 2189, 2645, 2752, 2758, 2759
  • Intake manifold: 2988

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Engine speed sensor is malfunctioning

Solution: S00000483

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Interview the customer and check for the following:
  • Engine has not been motoring downhill
  • Use the recommended Cummins® electronic service tool or equivalent.
  • RPM reading is correct

Specification

  • If all of these conditions are true, then a malfunctioning camshaft position sensor or crankshaft position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace camshaft position sensor.

Refer to Procedure 019-363

  • Replace crankshaft position sensor.

Refer to Procedure 019-365

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 235 | SPN: 111 | FMI: 1
Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Coolant level check
  3. Coolant level sensor open circuit check
  4. Coolant level sensor circuit pin to ground short
  5. Coolant level sensor circuit pin to pin short
  6. ECM calibration revision history check
  7. Coolant level sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00010587

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 operating hours from the following list:

  • Coolant level: 195, 196

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Coolant level check

Solution: S00003142

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the coolant level.
  • Perform the Coolant System Pressure Test.

Refer to Procedure 008-018

  • Visually inspect for external coolant leaks.

Specification

  • If the coolant level is low and there are signs of external coolant leaks, then reset the search to external coolant leak.
  • If the coolant level is low and there are no signs of external coolant leaks, then reset the search to internal coolant leak.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3 - Coolant level sensor open circuit check

Solution: S00007920

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Coolant level sensor circuit pin to ground short

Solution: S00007921

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Coolant level sensor circuit pin to pin short

Solution: S00007922

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor SUPPLY pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Coolant level sensor is malfunctioning

Solution: S00007923

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning coolant level sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace engine coolant level sensor.

Refer to Procedure 019-017

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 238 | SPN: 3511 | FMI: 4
Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. ECM sensor supply 3 voltage below normal
  2. ECM calibration revision history check

1 - ECM sensor supply 3 voltage below normal

Solution: S00001086

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Perform the following actions one at a time:
  • Disconnect the crankshaft position sensor from the engine wiring harness.
  • Disconnect the engine wiring harness from the ECM.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code goes inactive when a component is disconnected, then a malfunctioning sensor supply component has been detected.
  • If the fault code stays active when the engine wiring harness is disconnected, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace crankshaft position sensor.

Refer to Procedure 019-365

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 239 | SPN: 3511 | FMI: 3
Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. ECM sensor supply 3 voltage above normal
  2. ECM calibration revision history check

1 - ECM sensor supply 3 voltage above normal

Solution: S00000819

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code became active with the engine wiring harness disconnected: 239
  • A malfunctioning engine wiring harness has been detected if the following fault code did not become active with the engine wiring harness disconnected: 239

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 241 | SPN: 84 | FMI: 2
Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Vehicle speed sensor resistance check
  2. Vehicle speed sensor tampering
  3. Incorrect vehicle speed sensor configuration
  4. Vehicle speed sensor open circuit check
  5. Vehicle speed sensor circuit pin to ground short
  6. Vehicle speed sensor circuit pin to pin short
  7. Mechanical gear slippage causing erratic wheel speed data
  8. ECM calibration revision history check

1 - Vehicle speed sensor resistance check

Solution: S00003664

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of vehicle speed sensor.

Refer to Procedure 019-090

Refer to Procedure 019-091

Refer to OEM Service Manual

Specification

  • If the resistance is not within specification, then a malfunctioning vehicle speed sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the vehicle speed sensor.

Refer to Procedure 019-090

Refer to Procedure 019-091

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Vehicle speed sensor tampering

Solution: S00000825

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Verify proper installation of the vehicle speed sensor.
  • Verify the vehicle speed sensor for the proper adjustment for magnetic sensor.

Refer to Procedure 019-091

  • Verify the vehicle speed sensor for the proper adjustment for digital sensor.

Refer to Procedure 019-090

  • Verify that no external device is connected in place of the vehicle speed sensor
  • Verify that there is no evidence that tampering with the vehicle speed sensor has taken place.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If signs of tampering or incorrect installation has been found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the digital vehicle speed sensor.

Refer to Procedure 019-090

  • Replace the magnetic vehicle speed sensor.

Refer to Procedure 019-091

  • Repair or remove the tampering device or any external device.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Incorrect vehicle speed sensor configuration

Solution: S00000824

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Verify the parameters match the vehicle configuration.
  • Transmission Setup -Top Gear Transmission Ratio
  • Vehicle Speed Source -Rear Axle Ratio
  • Vehicle Speed Source -Tire Size
  • Vehicle Speed Source - Vehicle Speed Sensor Type
  • For a vehicle speed source that is a mulitplexed input, check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Specification

  • If the settings displayed by the recommended Cummins® electronic service tool or equivalent do not match the vehicle configuration, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Modify the vehicle configuration settings to match the vehicle configuration.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Vehicle speed sensor open circuit check

Solution: S00000826

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (+) wire between the OEM wiring harness ECM connector and the OEM wiring harness magnetic vehicle speed sensor connector.
  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (-) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Vehicle speed sensor circuit pin to ground short

Solution: S00006522

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.
  • Disconnect the engine wiring harness connector 2 from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the magnetic vehicle speed sensor RETURN at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Vehicle speed sensor circuit pin to pin short

Solution: S00000828

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (+) pin at the OEM harness ECM connector and all other pins in that connector.
  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (-) pin at the OEM harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Mechanical gear slippage causing erratic wheel speed data

Solution: S00000829

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the vehicle speed sensor from the transmission.

Refer to OEM Service Manual

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Inspect the gear or tone wheel on the rear of the transmission where the speed sensor picks up the speed signal.

Refer to OEM Service Manual

Specification

  • If any damage or defects to the tone wheel or gear are found, then proceed to the Repair section.
  • If any slippage of the tone wheel or gear relative to the shaft is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the gear or tone wheel.

Refer to OEM Service Manual

  • Replace the vehicle speed sensor.

Refer to Procedure 019-090

Refer to Procedure 019-091

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 242 | SPN: 84 | FMI: 10
Wheel-Based Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change

Troubleshooting Summary

  1. Incorrect vehicle speed signal
  2. Vehicle speed sensor tampering
  3. Incorrect vehicle speed sensor configuration
  4. Vehicle speed sensor open circuit check
  5. Vehicle speed sensor circuit pin to ground short
  6. Vehicle speed sensor circuit pin to pin short
  7. ECM calibration revision history check

1 - Incorrect vehicle speed signal

Solution: S00003601

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the vehicle speed sensor while the vehicle is stationary.
  • Drive vehicle or test on chassis dynamometer.
  • Compare the sensor reading from the recommended Cummins® electronic service tool or equivalent to the reading on the vehicle dash.

Specification

  • If the recommended Cummins® electronic service tool or equivalent and vehicle dash reading do not match, then an incorrect parameter setting has been detected.

Linked Solutions

  • None

Repair

  • Adjust the features and parameters to the correct settings.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Vehicle speed sensor tampering

Solution: S00000825

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Verify proper installation of the vehicle speed sensor.
  • Verify the vehicle speed sensor for the proper adjustment for magnetic sensor.

Refer to Procedure 019-091

  • Verify the vehicle speed sensor for the proper adjustment for digital sensor.

Refer to Procedure 019-090

  • Verify that no external device is connected in place of the vehicle speed sensor
  • Verify that there is no evidence that tampering with the vehicle speed sensor has taken place.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If signs of tampering or incorrect installation has been found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the digital vehicle speed sensor.

Refer to Procedure 019-090

  • Replace the magnetic vehicle speed sensor.

Refer to Procedure 019-091

  • Repair or remove the tampering device or any external device.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Incorrect vehicle speed sensor configuration

Solution: S00000824

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Verify the parameters match the vehicle configuration.
  • Transmission Setup -Top Gear Transmission Ratio
  • Vehicle Speed Source -Rear Axle Ratio
  • Vehicle Speed Source -Tire Size
  • Vehicle Speed Source - Vehicle Speed Sensor Type
  • For a vehicle speed source that is a mulitplexed input, check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Specification

  • If the settings displayed by the recommended Cummins® electronic service tool or equivalent do not match the vehicle configuration, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Modify the vehicle configuration settings to match the vehicle configuration.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Vehicle speed sensor open circuit check

Solution: S00000826

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (+) wire between the OEM wiring harness ECM connector and the OEM wiring harness magnetic vehicle speed sensor connector.
  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (-) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Vehicle speed sensor circuit pin to ground short

Solution: S00006522

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.
  • Disconnect the engine wiring harness connector 2 from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the magnetic vehicle speed sensor RETURN at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Vehicle speed sensor circuit pin to pin short

Solution: S00000828

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (+) pin at the OEM harness ECM connector and all other pins in that connector.
  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (-) pin at the OEM harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 245 | SPN: 647 | FMI: 4
Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Fan control solenoid resistance check
  2. Fan control solenoid circuit pin to ground short
  3. Fan control solenoid circuit pin to pin short
  4. Fan control solenoid is malfunctioning

1 - Fan control solenoid resistance check

Solution: S00001059

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the fan control solenoid.

Refer to OEM Service Manual

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the fan control solenoid resistance does not meet specification, then a malfunctioning fan control solenoid has been detected.

Refer to OEM Service Manual

Linked Solutions

  • None

Repair

  • Replace the fan control solenoid.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Fan control solenoid circuit pin to ground short

Solution: S00006416

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector 2 from the ECM.
  • Disconnect the fan control solenoid from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fan control SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Fan control solenoid circuit pin to pin short

Solution: S00006418

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the fan control connector from the OEM wiring harness connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fan control SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fan control solenoid is malfunctioning

Solution: S00005653

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the fan control solenoid.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 15-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 254 | SPN: 632 | FMI: 4
Engine Fuel Shutoff Valve Driver Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Fuel shutoff valve voltage check
  2. Fuel shutoff valve voltage check at the ECM
  3. ECM calibration revision history check

1 - Fuel shutoff valve voltage check

Solution: S00006302

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the fuel shutoff valve.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage while cranking between the fuel shutoff valve SIGNAL pin and the fuel shutoff valve RETURN pin at the fuel shutoff valve connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • Fuel shutoff valve voltage check at the ECM

Refer to S00004929

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

1.1 - Fuel shutoff valve voltage check at the ECM

Solution: S00004929

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff valve from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the fuel shutoff valve SIGNAL pin and the fuel shutoff valve RETURN pin at the fuel shutoff valve connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the voltage is within the following specification of battery voltage: 1 VDC
  • A malfunctioning ECM has been detected if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • None
Parent Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 255 | SPN: 632 | FMI: 3
Engine Fuel Shutoff Valve Driver Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Fuel shutoff valve voltage check
  2. Fuel shutoff valve voltage check at the ECM
  3. Fuel shutoff valve open circuit check
  4. ECM calibration revision history check

1 - Fuel shutoff valve voltage check

Solution: S00006302

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the fuel shutoff valve.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage while cranking between the fuel shutoff valve SIGNAL pin and the fuel shutoff valve RETURN pin at the fuel shutoff valve connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • Fuel shutoff valve voltage check at the ECM

Refer to S00004929

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

1.1 - Fuel shutoff valve voltage check at the ECM

Solution: S00004929

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel shutoff valve from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the fuel shutoff valve SIGNAL pin and the fuel shutoff valve RETURN pin at the fuel shutoff valve connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the voltage is within the following specification of battery voltage: 1 VDC
  • A malfunctioning ECM has been detected if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • None
Parent Solution

2 - Fuel shutoff valve open circuit check

Solution: S00004588

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the fuel shutoff valve from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel shutoff valve SIGNAL pin at the fuel shutoff valve engine wiring harness connector and the fuel shutoff valve SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the fuel shutoff valve RETURN pin at the fuel shutoff valve engine wiring harness connector and the fuel shutoff valve RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 263 | SPN: 174 | FMI: 3
Engine Fuel Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Fuel temperature sensor circuit response
  3. Fuel temperature sensor circuit response at the ECM
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00006506

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Fuel temperature sensor circuit response

Solution: S00004733

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel outlet pressure/temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the fuel temperature sensor SIGNAL pin and the fuel temperature sensor RETURN pin at the fuel temperature sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning fuel outlet pressure sensor has been detected if the following fault code became active with the jumper wire in place: 265

Linked Solutions

  • None

Repair

  • Replace the fuel outlet pressure/temperature sensor.

Refer to Procedure 019-153

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Fuel temperature sensor circuit response at the ECM

Solution: S00004326

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the fuel temperature sensor SIGNAL pin and the fuel temperature sensor RETURN pin at the fuel temperature sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 265
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 265

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 265 | SPN: 174 | FMI: 4
Engine Fuel Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Fuel temperature sensor circuit response
  3. Fuel temperature sensor circuit response at the ECM
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00006506

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Fuel temperature sensor circuit response

Solution: S00004734

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel outlet pressure/temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning fuel outlet pressure sensor has been detected if the following fault code became active with the sensor disconnected: 263

Linked Solutions

  • None

Repair

  • Replace the fuel outlet pressure/temperature sensor.

Refer to Procedure 019-153

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Fuel temperature sensor circuit response at the ECM

Solution: S00001646

Verification

Conditions

  • Turn keyswitch ON.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 263
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 263

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 285 | SPN: 639 | FMI: 9
SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Troubleshooting Summary

  1. Incorrectly programmed OEM multiplexing unit
  2. ECM calibration revision history check

1 - Incorrectly programmed OEM multiplexing unit

Solution: S00000519

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent SAE J1939 Multiplexed Fault Data, located in Advanced ECM data, to determine which multiplexed component is causing the fault.
  • If the status column indicates "Active" for a multiplexed component, check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses. These components can be found under SAE J1939 Multiplexing in Features and Parameters.

Specification

  • If the recommended Cummins® electronic service tool or equivalent SAE J1939 Multiplexed Fault Data is correct, then the OEM VECU is not transmitting the correct source address due to a malfunctioning OEM component or setup issue.
  • If the J1939 Multiplexed Fault Data is not correct, then an incorrect source address has been entered into he engine ECM for OEM J1939 multiplexed component.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the malfunctioning OEM component.

Refer to OEM Service Manual

  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 286 | SPN: 639 | FMI: 13
J1939 Network #1 - Out of Calibration

Troubleshooting Summary

  1. Incorrectly programmed OEM multiplexing unit
  2. ECM calibration revision history check

1 - Incorrectly programmed OEM multiplexing unit

Solution: S00000519

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent SAE J1939 Multiplexed Fault Data, located in Advanced ECM data, to determine which multiplexed component is causing the fault.
  • If the status column indicates "Active" for a multiplexed component, check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses. These components can be found under SAE J1939 Multiplexing in Features and Parameters.

Specification

  • If the recommended Cummins® electronic service tool or equivalent SAE J1939 Multiplexed Fault Data is correct, then the OEM VECU is not transmitting the correct source address due to a malfunctioning OEM component or setup issue.
  • If the J1939 Multiplexed Fault Data is not correct, then an incorrect source address has been entered into he engine ECM for OEM J1939 multiplexed component.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the malfunctioning OEM component.

Refer to OEM Service Manual

  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 288 | SPN: 974 | FMI: 19
SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Position Sensor System - Received Network Data in Error

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 338 | SPN: 1267 | FMI: 3
Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. Idle shutdown vehicle accessory relay is malfunctioning
  3. Idle shutdown relay open circuit check
  4. Idle shutdown relay circuit pin to pin short
  5. Idle shutdown relay circuit pin to pin short

1 - Incorrect adjustable parameter setting

Solution: S00001166

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Go to Features and Parameters.

Specification

  • If the vehicle has an idle shutdown relay installed, the parameter Shutdown Accessory Relay must be set to "Installed".
  • If the vehicle does not have an idle shutdown relay installed, the parameter Shutdown Accessory Relay must be set to "Not Installed".

Linked Solutions

  • None

Repair

  • Correct the Idle Shutdown feature setup.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Idle shutdown vehicle accessory relay is malfunctioning

Solution: S00000520

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace idle shutdown relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Idle shutdown relay open circuit check

Solution: S00000847

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the idle shutdown relay RETURN pin at the idle shutdown relay connector to ground.
  • Measure the resistance between the engine wiring harness ECM connector idle shutdown relay RETURN pin and the OEM wiring harness idle shutdown relay connector RETURN pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Idle shutdown relay circuit pin to pin short

Solution: S00006508

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the idle shutdown relay SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Idle shutdown relay circuit pin to pin short

Solution: S00000521

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the idle shutdown relay SIGNAL pin in the OEM wiring harness ECM connector and all other pins in the OEM wiring harness ECM connector.
  • Measure the resistance between the idle shutdown relay SIGNAL pin in the OEM wiring harness ECM connector and the ECM battery supply (+) pin of the OEM wiring harness ECM connector.
  • Measure the resistance between the idle shutdown relay SIGNAL pin in the OEM wiring harness ECM connector and the ECM battery supply (-) pin of the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification:

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 339 | SPN: 1267 | FMI: 4
Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. Idle shutdown vehicle accessory relay is malfunctioning
  3. Idle shutdown relay SIGNAL wire short to ground in OEM wiring harness
  4. Idle shutdown relay circuit pin to pin short
  5. Idle shutdown relay circuit pin to pin short

1 - Incorrect adjustable parameter setting

Solution: S00001166

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Go to Features and Parameters.

Specification

  • If the vehicle has an idle shutdown relay installed, the parameter Shutdown Accessory Relay must be set to "Installed".
  • If the vehicle does not have an idle shutdown relay installed, the parameter Shutdown Accessory Relay must be set to "Not Installed".

Linked Solutions

  • None

Repair

  • Correct the Idle Shutdown feature setup.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Idle shutdown vehicle accessory relay is malfunctioning

Solution: S00000520

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace idle shutdown relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Idle shutdown relay SIGNAL wire short to ground in OEM wiring harness

Solution: S00000527

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the idle shutdown relay SIGNAL pin in the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification:

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Idle shutdown relay circuit pin to pin short

Solution: S00006508

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the idle shutdown relay SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Idle shutdown relay circuit pin to pin short

Solution: S00000521

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the idle shutdown relay SIGNAL pin in the OEM wiring harness ECM connector and all other pins in the OEM wiring harness ECM connector.
  • Measure the resistance between the idle shutdown relay SIGNAL pin in the OEM wiring harness ECM connector and the ECM battery supply (+) pin of the OEM wiring harness ECM connector.
  • Measure the resistance between the idle shutdown relay SIGNAL pin in the OEM wiring harness ECM connector and the ECM battery supply (-) pin of the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification:

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 352 | SPN: 3509 | FMI: 4
Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. ECM sensor supply 1 voltage below normal

1 - ECM sensor supply 1 voltage below normal

Solution: S00006463

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Perform the following actions one at a time:
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Refer to Procedure 005-052

  • Disconnect the camshaft position sensor from the engine wiring harness.

Refer to Procedure 019-363

  • Disconnect the fuel inlet pressure sensor from the engine wiring harness.

Refer to Procedure 019-188

  • Disconnect the engine fuel regulator outlet pressure/temperature sensor from the engine wiring harness.

Refer to Procedure 019-153

  • Disconnect the engine wiring harness from the ECM.

Specification

  • If the fault code goes inactive when a component is disconnected, then a malfunctioning sensor supply component has been detected.
  • If the fault code stays active when the engine wiring harness is disconnected, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the engine intake throttle actuator.

Refer to Procedure 005-052

  • Replace camshaft position sensor.

Refer to Procedure 019-363

  • Replace the fuel inlet pressure sensor.

Refer to Procedure 019-188

  • Replace the engine fuel regulator outlet pressure/temperature sensor.

Refer to Procedure 019-153

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable Fault Code
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 25-Jan-2020


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 386 | SPN: 3509 | FMI: 3
Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. ECM sensor supply 1 voltage above normal
  2. ECM calibration revision history check

1 - ECM sensor supply 1 voltage above normal

Solution: S00002196

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine wiring harness has been detected if the following fault code did not become active with the engine wiring harness disconnected: 386
  • A malfunctioning ECM has been detected if the following fault code became active with the engine wiring harness disconnected: 386

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 415 | SPN: 100 | FMI: 1
Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Basic oil system checks
  3. Lubricating oil pressure sensor stuck in-range
  4. Lubricating oil filter plugged
  5. Lubricating oil pressure relief valve is malfunctioning
  6. Loose or broken lubricating oil suction tube
  7. Main lubricating oil pressure regulator is malfunctioning
  8. Lubricating oil pump is malfunctioning
  9. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000078

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Oil: 135, 141
  • Sensor supply 1: 352, 386

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Basic oil system checks

Solution: S00000474

Verification

Conditions

  • Turn keyswitch OFF.

Action

CAUTION: Do not start an engine that has low oil pressure fault codes/complaints until it has been verified that the oil level is correct and that the oil filter is not plugged. Internal engine damage can result from low or no oil pressure.

  • Interview the operator about the complaint. Ask if the fault occurs when climbing or descending a steep hill to determine if engine angularity is a potential issue.
  • Visually inspect engine for external lubricating oil leaks.
  • Check that the lubricating oil level is correct.

Refer to OEM Service Manual

Specification

  • If an oil leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the component that is the source of the leak.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Lubricating oil pressure sensor stuck in-range

Solution: S00000342

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the sensor for damage.
  • Install a mechanical gauge on the engine.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the sensor reading with the recommended Cummins® electronic service tool or equivalent to a mechanical gauge.
  • If the lubricating oil pressure does not meet the minimum specification, do not perform any engine running tests.

Refer to Procedure 018-017

  • Operate engine at rated rpm.
  • Monitor the lubricating oil pressure sensor.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the mechanical gauge must be within: 17 kPa [2.5 psi]
  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the lubricating oil pressure sensor.

Refer to Procedure 019-066

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Lubricating oil filter plugged

Solution: S00000466

Verification

Conditions

  • Turn keyswitch ON.
  • Engine running.
  • Lubricating oil pressure must be above the minimum specification.

Refer to Procedure 018-017

Action

  • If the lubricating oil pressure does not meet the minimum specification, then skip this solution and do not perform the test to measure oil filter differential pressure.
  • Measure the differential pressure drop across the lubricating oil filter.

Refer to Procedure 007-095

Specification

  • If the lubrication oil filter differential pressure is not within the specification, then a plugged lubrication oil filter has been detected.

Refer to Procedure 007-095

Linked Solutions

  • None

Repair

  • Replace the lubricating oil filter.

Refer to Procedure 007-013

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Lubricating oil pressure relief valve is malfunctioning

Solution: S00000471

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the lubricating oil pressure relief valve.

Refer to Procedure 007-021

Specification

  • If the lubricating oil pressure relief valve does not meet specification, then a malfunctioning lubricating oil pressure relief valve has been detected.

Refer to Procedure 007-021

Linked Solutions

  • None

Repair

  • Replace the lubricating oil pressure relief valve.

Refer to Procedure 007-021

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Loose or broken lubricating oil suction tube

Solution: S00000464

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the lubricating oil pan.

Refer to Procedure 007-025

  • Inspect the lubricating oil suction tube and o-ring for damage.

Refer to Procedure 007-035

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the lubricating oil suction tube o-ring or the damaged lubricating oil suction tube.

Refer to Procedure 007-035

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Main lubricating oil pressure regulator is malfunctioning

Solution: S00000469

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the main lubricating oil pressure regulator assembly.

Refer to Procedure 007-031

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the main lubricating oil pressure regulator assembly.

Refer to Procedure 007-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Lubricating oil pump is malfunctioning

Solution: S00000472

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the lubricating oil pump.

Refer to Procedure 007-031

  • Inspect the lubricating oil pump.

Refer to Procedure 007-031

If the lubricating oil pump was found to be damaged, then inspect the lubricating oil filter for metal.

Specification

  • If damaged, loose or worn gears are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the lubricating oil pump.

Refer to Procedure 007-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 421 | SPN: 175 | FMI: 16
Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Basic oil system checks
  3. Lubricating oil temperature sensor resistance check
  4. Lubricating oil temperature sensor stuck in-range
  5. Lubricating oil thermostat is malfunctioning
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00008424

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Engine coolant temperature: 146, 151, 2113, 2114, 2963, 4629, 4631, 5224

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Basic oil system checks

Solution: S00000474

Verification

Conditions

  • Turn keyswitch OFF.

Action

CAUTION: Do not start an engine that has low oil pressure fault codes/complaints until it has been verified that the oil level is correct and that the oil filter is not plugged. Internal engine damage can result from low or no oil pressure.

  • Interview the operator about the complaint. Ask if the fault occurs when climbing or descending a steep hill to determine if engine angularity is a potential issue.
  • Visually inspect engine for external lubricating oil leaks.
  • Check that the lubricating oil level is correct.

Refer to OEM Service Manual

Specification

  • If an oil leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the component that is the source of the leak.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Lubricating oil temperature sensor resistance check

Solution: S00000362

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lubricating oil temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin and the engine oil temperature sensor RETURN pin at the engine oil temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the resistance is not within the following specification: 180 Ω - 160k Ω

Linked Solutions

  • None

Repair

  • Replace the lubricating oil temperature sensor.

Refer to Procedure 019-067

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Lubricating oil temperature sensor stuck in-range

Solution: S00004643

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the lubricating oil temperature sensor
  • Compare the lubricating oil temperature sensor reading to an infrared thermometer or a known value.

Specification

  • If the temperature reading in the recommended Cummins® electronic service tool or equivalent and infrared thermometer or a known value are not within specification, then a malfunctioning lubricating oil temperature sensor has been detected.
  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the known value must be within: +/- 10C [18F]

Linked Solutions

  • None

Repair

  • Replace the lubricating oil temperature sensor.

Refer to Procedure 019-067

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Lubricating oil thermostat is malfunctioning

Solution: S00000811

Verification

Conditions

  • None

Action

  • Check the lubricating oil thermostat for proper operation.

Refer to Procedure 007-039

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning oil thermostat has been detected.

Linked Solutions

  • None

Repair

  • Replace the lubricating oil thermostat.

Refer to Procedure 007-039

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 426 | SPN: 639 | FMI: 2
J1939 Network #1 - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. ECM will not communicate

1 - ECM will not communicate

Solution: S00001512

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Attempt to communicate with the ECM.

Specification

  • If communication between the ECM and the recommended Cummins® electronic service tool or equivalent cannot be established, then reset the search to No Communication with the Cummins® Electronic Service Tool or Equivalent to ECM.

Linked Solutions

  • None

Repair

  • Reset the search to No Communication with the Cummins® Electronic Service Tool or Equivalent to ECM.

Validation

  • None

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 20-Mar-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 435 | SPN: 100 | FMI: 2
Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Lubricating oil pressure sensor stuck in-range
  2. Lubricating oil pressure check
  3. Lubricating oil pressure relief valve is malfunctioning
  4. Main lubricating oil pressure regulator is malfunctioning
  5. ECM calibration revision history check

1 - Lubricating oil pressure sensor stuck in-range

Solution: S00000342

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the sensor for damage.
  • Install a mechanical gauge on the engine.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the sensor reading with the recommended Cummins® electronic service tool or equivalent to a mechanical gauge.
  • If the lubricating oil pressure does not meet the minimum specification, do not perform any engine running tests.

Refer to Procedure 018-017

  • Operate engine at rated rpm.
  • Monitor the lubricating oil pressure sensor.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the mechanical gauge must be within: 17 kPa [2.5 psi]
  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the lubricating oil pressure sensor.

Refer to Procedure 019-066

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Lubricating oil pressure check

Solution: S00003162

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Install a mechanical gauge on the engine.
  • Run the engine at idle.
  • Allow the engine to reach operating temperature.
  • Monitor the lubricating oil pressure.

Specification

  • If the lubricating oil pressure is not within specification, then proceed to the Linked Solutions section.

Refer to Procedure 018-017

Linked Solutions

  • Lubricating oil pressure relief valve is malfunctioning

Refer to S00004717

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Lubricating oil pressure relief valve is malfunctioning

Solution: S00004717

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the lubricating oil pressure relief valve.

Refer to Procedure 007-021

Specification

  • If the lubricating oil pressure relief valve does not meet specification, then a malfunctioning lubricating oil pressure relief valve has been detected.

Refer to Procedure 007-021

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the lubricating oil pressure relief valve.

Refer to Procedure 007-021

Perform following checks for progressive damage.

  • Perform the oil filter analysis.

Refer to Procedure 007-083

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Main lubricating oil pressure regulator is malfunctioning

Solution: S00000469

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the main lubricating oil pressure regulator assembly.

Refer to Procedure 007-031

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the main lubricating oil pressure regulator assembly.

Refer to Procedure 007-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 441 | SPN: 168 | FMI: 18
Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Battery or battery cables are malfunctioning
  2. Charging system alternator is malfunctioning
  3. ECM battery voltage check
  4. Unswitched battery circuit pin to pin short
  5. ECM calibration revision history check

1 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Charging system alternator is malfunctioning

Solution: S00000532

Verification

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the charging system alternator and the battery.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Test the charging system alternator output.

Refer to Procedure 013-001

Specification

  • If the charging system alternator output does not meet specification, then a malfunctioning alternator has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the alternator.

Refer to Procedure 013-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM battery voltage check

Solution: S00002091

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM power supply from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the ECM battery SUPPLY pin at the OEM wiring harness 4 pin connector and engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Unswitched battery circuit pin to pin short

Solution: S00002997

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ECM battery SUPPLY (+) pin of the OEM wiring harness ECM connector to all other pins in that connector.
  • Measure the resistance between the ECM battery SUPPLY (-) pin of the OEM wiring harness ECM connector to all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 442 | SPN: 168 | FMI: 16
Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Battery or battery cables are malfunctioning
  2. Charging system alternator is malfunctioning
  3. ECM calibration revision history check

1 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Charging system alternator is malfunctioning

Solution: S00000532

Verification

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the charging system alternator and the battery.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Test the charging system alternator output.

Refer to Procedure 013-001

Specification

  • If the charging system alternator output does not meet specification, then a malfunctioning alternator has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the alternator.

Refer to Procedure 013-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 453 | SPN: 1241 | FMI: 3
Gas Mass Flow 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Gas mass flow sensor voltage check
  3. Gas mass flow sensor circuit response
  4. Gas mass flow sensor circuit response at the ECM
  5. ECM calibration revision history check
  6. Gas mass flow sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00002694

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 455, 511, 2722
  • Intake manifold: 2988

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Gas mass flow sensor voltage check

Solution: S00004926

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the gas mass flow sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the gas mass flow sensor SUPPLY pin and the gas mass flow sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning gas mass flow sensor has been detected if the voltage is greater than the following specification: 15 VDC

Linked Solutions

  • None

Repair

  • Replace gas mass flow sensor.

Refer to Procedure 019-101

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Gas mass flow sensor circuit response

Solution: S00004668

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the gas mass flow sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning gas mass flow sensor has been detected if the following fault code became active with the sensor disconnected: 454

Linked Solutions

  • None

Repair

  • Replace gas mass flow sensor.

Refer to Procedure 019-101

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Gas mass flow sensor circuit response at the ECM

Solution: S00004674

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 454
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 454

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Gas mass flow sensor is malfunctioning

Solution: S00006282

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning gas mass flow sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace gas mass flow sensor.

Refer to Procedure 019-101

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 454 | SPN: 1241 | FMI: 4
Gas Mass Flow 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Gas mass flow sensor circuit response
  3. Gas mass flow sensor circuit response at the ECM
  4. ECM calibration revision history check
  5. Gas mass flow sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00001755

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 6: 516

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Gas mass flow sensor circuit response

Solution: S00004682

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the gas mass flow sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the gas mass flow sensor SUPPLY pin and the gas mass flow sensor SIGNAL pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning gas mass flow sensor has been detected if the following fault code became active with the jumper wire in place: 453

Linked Solutions

  • None

Repair

  • Replace gas mass flow sensor.

Refer to Procedure 019-101

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Gas mass flow sensor circuit response at the ECM

Solution: S00004683

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the gas mass flow sensor SUPPLY pin and the gas mass flow sensor SIGNAL pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 453
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 453

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Gas mass flow sensor is malfunctioning

Solution: S00006282

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning gas mass flow sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace gas mass flow sensor.

Refer to Procedure 019-101

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 455 | SPN: 633 | FMI: 3
Electronic Fuel Injection Control Valve Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Fuel control valve resistance check
  2. Fuel control valve open circuit check
  3. Engine fuel control valve circuit has pin to pin short
  4. ECM calibration revision history check

1 - Fuel control valve resistance check

Solution: S00004796

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel control valve from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel control valve SIGNAL pin and the fuel control valve RETURN pin at the fuel control valve connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel control valve has been detected if the resistance is not within the following specification: 2 - 5 Ω

Linked Solutions

  • None

Repair

  • Replace the fuel control valve.

Refer to Procedure 019-102

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Fuel control valve open circuit check

Solution: S00004216

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel control valve from the engine wiring harness.

Action

  • Measure the resistance between the fuel control valve SIGNAL pin at the fuel control valve connector of the engine wiring harness and the fuel control valve SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the fuel control valve RETURN pin at the fuel control valve connector of the engine wiring harness and the fuel control valve RETURN pin at the engine wiring harness ECM connector.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine fuel control valve circuit has pin to pin short

Solution: S00003363

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness ECM connector 1 and 2.
  • Disconnect the engine fuel control valve from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine fuel control valve (+) pin in the engine wiring harness ECM connector 1 and all other pins in ECM connector 1.
  • Measure the resistance between the engine fuel control valve (+) pin in the engine wiring harness ECM connector and all other pins in ECM connector 2.
  • Measure the resistance between the engine fuel control valve (-) pin in the engine wiring harness ECM connector 1 and all other pins in ECM connector 1.
  • Measure the resistance between the engine fuel control valve (-) pin in the engine wiring harness ECM connector and all other pins in ECM connector 2.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 458 | SPN: 726 | FMI: 3
Ignition Timing Signal Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Battery or battery cables are malfunctioning
  2. Ignition control module is malfunctioning
  3. Ignition control module open circuit check
  4. Ignition control module circuit pin to pin short
  5. ECM calibration revision history check

1 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Ignition control module is malfunctioning

Solution: S00004201

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the voltage check for the ignition control module.

Refer to Procedure 019-105

  • Perform the ignition coil test.

Refer to Procedure 013-012

  • Visually inspect for a loose connection at the ignition coil connector associated with the fault code.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the voltage is present at the ignition control module and no spark was observed during the coil test, then a malfunctioning ignition control module has been detected.

Linked Solutions

  • None

Repair

  • Replace ignition control module.

Refer to Procedure 019-105

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Ignition control module open circuit check

Solution: S00004840

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the ignition control module C1 connector and the combustion detection SIGNAL pin at the engine wiring harness ECM connector 2.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the ignition control module C1 connector and the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the ignition control module C1 connector and the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module RETURN pin at the ignition control module C1 connector and the ignition control module RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the ignition control module C1 connector and the spark voltage SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Ignition control module circuit pin to pin short

Solution: S00001435

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the gas mass flow sensor from the engine wiring harness.
  • Disconnect the EGR temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 459 | SPN: 726 | FMI: 4
Ignition Timing Signal Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Battery or battery cables are malfunctioning
  2. Ignition control module is malfunctioning
  3. Ignition control module circuit pin to ground short
  4. Ignition control module circuit pin to pin short
  5. ECM calibration revision history check

1 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Ignition control module is malfunctioning

Solution: S00004201

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the voltage check for the ignition control module.

Refer to Procedure 019-105

  • Perform the ignition coil test.

Refer to Procedure 013-012

  • Visually inspect for a loose connection at the ignition coil connector associated with the fault code.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the voltage is present at the ignition control module and no spark was observed during the coil test, then a malfunctioning ignition control module has been detected.

Linked Solutions

  • None

Repair

  • Replace ignition control module.

Refer to Procedure 019-105

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Ignition control module circuit pin to ground short

Solution: S00006519

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Ignition control module circuit pin to pin short

Solution: S00001435

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the gas mass flow sensor from the engine wiring harness.
  • Disconnect the EGR temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 461 | SPN: 725 | FMI: 3
Ignition Control Signal Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Battery or battery cables are malfunctioning
  2. Ignition control module open circuit check
  3. Ignition control module circuit pin to pin short
  4. ECM calibration revision history check

1 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Ignition control module open circuit check

Solution: S00004840

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the ignition control module C1 connector and the combustion detection SIGNAL pin at the engine wiring harness ECM connector 2.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the ignition control module C1 connector and the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the ignition control module C1 connector and the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module RETURN pin at the ignition control module C1 connector and the ignition control module RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the ignition control module C1 connector and the spark voltage SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Ignition control module circuit pin to pin short

Solution: S00001435

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the gas mass flow sensor from the engine wiring harness.
  • Disconnect the EGR temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 462 | SPN: 725 | FMI: 4
Ignition Control Signal Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Switched battery open circuit check
  2. Battery or battery cables are malfunctioning
  3. Ignition control module circuit pin to ground short
  4. Ignition control module circuit pin to pin short
  5. ECM calibration revision history check

1 - Switched battery open circuit check

Solution: S00004955

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine wiring harness from the ignition control module.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the switched battery SUPPLY pins at the engine wiring harness OEM connector and the SUPPLY pin at the engine wiring harness ignition control module connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Troubleshoot the engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Ignition control module circuit pin to ground short

Solution: S00006519

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Ignition control module circuit pin to pin short

Solution: S00001435

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the gas mass flow sensor from the engine wiring harness.
  • Disconnect the EGR temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 465 | SPN: 1188 | FMI: 3
Turbocharger 1 Wastegate Control Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Wastegate control valve resistance check
  2. Wastegate control valve circuit response
  3. Wastegate control valve open circuit check
  4. Wastegate control valve circuit pin to pin short

1 - Wastegate control valve resistance check

Solution: S00006192

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wastegate control valve from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the wastegate control valve.

Refer to Procedure 019-103

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not within specification, then a malfunctioning wastegate control valve has been detected.

Linked Solutions

  • None

Repair

  • Replace the wastegate control valve.

Refer to Procedure 019-103

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Wastegate control valve circuit response

Solution: S00004313

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wastegate control valve from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning wastegate control valve has been detected if the following fault code become active with the wastegate control valve disconnected: 466

Linked Solutions

  • None

Repair

  • Replace the wastegate control valve.

Refer to Procedure 010-109

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Wastegate control valve open circuit check

Solution: S00006230

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wastegate control valve from the engine wiring harness.
  • Disconnect the engine wiring harness connector 1 from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the wastegate control valve SIGNAL pin at the wastegate control valve engine wiring harness connector and the wastegate control valve SIGNAL pin at the engine wiring harness ECM connector.

Refer to Procedure 019-103

  • Measure the resistance between the wastegate control valve RETURN pin at the wastegate control valve engine wiring harness connector and the wastegate control valve RETURN pin at the engine wiring harness ECM connector.

Refer to Procedure 019-103

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Wastegate control valve circuit pin to pin short

Solution: S00006196

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector 1 from the ECM.
  • Disconnect the wastegate control valve from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the wastegate control valve SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the wastegate control valve RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 12-Dec-2021


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 466 | SPN: 1188 | FMI: 4
Engine Turbocharger Wastegate Actuator 1 Position Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Wastegate control valve resistance check
  2. Wastegate control valve circuit response
  3. Wastegate control valve open circuit check
  4. Wastegate control valve circuit pin to pin short

1 - Wastegate control valve resistance check

Solution: S00006192

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wastegate control valve from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the wastegate control valve.

Refer to Procedure 019-103

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not within specification, then a malfunctioning wastegate control valve has been detected.

Linked Solutions

  • None

Repair

  • Replace the wastegate control valve.

Refer to Procedure 019-103

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Wastegate control valve circuit response

Solution: S00004286

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wastegate control valve from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the wastegate control valve SIGNAL pin and the wastegate control valve RETURN pin at the wastegate control valve connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning wastegate control valve has been detected if the following fault code become active with the jumper wire in place: 465

Linked Solutions

  • None

Repair

  • Replace the wastegate control valve.

Refer to Procedure 019-103

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Wastegate control valve open circuit check

Solution: S00006230

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wastegate control valve from the engine wiring harness.
  • Disconnect the engine wiring harness connector 1 from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the wastegate control valve SIGNAL pin at the wastegate control valve engine wiring harness connector and the wastegate control valve SIGNAL pin at the engine wiring harness ECM connector.

Refer to Procedure 019-103

  • Measure the resistance between the wastegate control valve RETURN pin at the wastegate control valve engine wiring harness connector and the wastegate control valve RETURN pin at the engine wiring harness ECM connector.

Refer to Procedure 019-103

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Wastegate control valve circuit pin to pin short

Solution: S00006196

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector 1 from the ECM.
  • Disconnect the wastegate control valve from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the wastegate control valve SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the wastegate control valve RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 12-Dec-2021


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 511 | SPN: 633 | FMI: 4
Electronic Fuel Injection Control Valve Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Fuel control valve resistance check
  3. Engine fuel control valve circuit has pin to pin short
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002660

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Voltage: 1117

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Fuel control valve resistance check

Solution: S00004796

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel control valve from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel control valve SIGNAL pin and the fuel control valve RETURN pin at the fuel control valve connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel control valve has been detected if the resistance is not within the following specification: 2 - 5 Ω

Linked Solutions

  • None

Repair

  • Replace the fuel control valve.

Refer to Procedure 019-102

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine fuel control valve circuit has pin to pin short

Solution: S00003363

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness ECM connector 1 and 2.
  • Disconnect the engine fuel control valve from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine fuel control valve (+) pin in the engine wiring harness ECM connector 1 and all other pins in ECM connector 1.
  • Measure the resistance between the engine fuel control valve (+) pin in the engine wiring harness ECM connector and all other pins in ECM connector 2.
  • Measure the resistance between the engine fuel control valve (-) pin in the engine wiring harness ECM connector 1 and all other pins in ECM connector 1.
  • Measure the resistance between the engine fuel control valve (-) pin in the engine wiring harness ECM connector and all other pins in ECM connector 2.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 512 | SPN: 51 | FMI: 3
Throttle Position 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Electronic throttle control actuator driver malfunctioning
  3. Engine intake throttle actuator circuit response at the ECM
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000899

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Electronic throttle control actuator driver malfunctioning

Solution: S00004278

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine intake throttle actuator has been detected if the following fault code became active with the actuator disconnected: 513

Linked Solutions

  • None

Repair

  • Replace the engine intake throttle actuator.

Refer to Procedure 005-052

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine intake throttle actuator circuit response at the ECM

Solution: S00004906

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 513
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 513

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 513 | SPN: 51 | FMI: 4
Throttle Position 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Engine intake throttle actuator circuit response
  2. Engine intake throttle actuator circuit response at the ECM
  3. ECM calibration revision history check

1 - Engine intake throttle actuator circuit response

Solution: S00004279

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the engine intake throttle actuator sensor SUPPLY 1 pin and the engine intake throttle actuator position 1 SIGNAL pin at the engine intake throttle actuator connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine intake throttle actuator has been detected if the following fault code became active with the jumper wire in place: 512

Linked Solutions

  • None

Repair

  • Replace the engine intake throttle actuator.

Refer to Procedure 005-052

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Engine intake throttle actuator circuit response at the ECM

Solution: S00004907

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the engine intake throttle actuator sensor SUPPLY 1 pin and the engine intake throttle actuator position 1 SIGNAL pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 512
  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 512

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 515 | SPN: 3514 | FMI: 3
Sensor Supply 6 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. ECM sensor supply 6 voltage above normal
  2. ECM calibration revision history check

1 - ECM sensor supply 6 voltage above normal

Solution: S00006455

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector 1 from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine wiring harness has been detected if the following fault code did not become active with the engine wiring harness disconnected: 515
  • A malfunctioning ECM has been detected if the following fault code became active with the engine wiring harness disconnected: 515

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 516 | SPN: 3514 | FMI: 4
Sensor Supply 6 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. ECM sensor supply 6 voltage below normal
  2. ECM calibration revision history check

1 - ECM sensor supply 6 voltage below normal

Solution: S00004362

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Perform the following actions one at a time:
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Disconnect the gas mass flow sensor from the engine wiring harness.
  • Disconnect the engine wiring harness from the ECM.

Specification

  • If the fault code goes inactive when a component is disconnected, then a malfunctioning sensor supply component has been detected.
  • If the fault code stays active when the engine wiring harness is disconnected, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace gas mass flow sensor.

Refer to Procedure 019-101

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 555 | SPN: 101 | FMI: 16
Crankcase Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Lubricating oil level is incorrect
  2. Plugged external crankcase breather tube
  3. Crankcase pressure sensor stuck in-range
  4. Crankcase Blowby Check
  5. Turbocharger leaking air into crankcase
  6. Air compressor leaking air into crankcase
  7. Worn or damaged power cylinder components
  8. Engine Compression Test
  9. ECM calibration revision history check

1 - Lubricating oil level is incorrect

Solution: S00003234

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Make sure the vehicle is on a level surface with the engine off.
  • Check that the lubricating oil level is correct.
  • Determine if the lubrication oil is contaminated with coolant or fuel.

Specification

  • If the oil level is high and coolant contamination has been detected, then reset the search to Coolant in the oil.
  • If the oil level is high and fuel contamination has been detected, then reset the search to Fuel in the oil.
  • If the oil level is high and no coolant or fuel contamination has been detected, then incorrect oil dipstick calibration has been detected.
  • If the oil level is normal, then proceed to the next solution.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Reset search for coolant in the lubricating oil.
  • Search for fuel in oil.
  • Calibrate the lubricating oil dipstick for the proper oil level.

Refer to Procedure 007-009

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Plugged external crankcase breather tube

Solution: S00000626

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the oil drain tubes, check valves, breather tubes, and oil separator for plugging.

Refer to Procedure 003-001

It is important to check for a frozen, plugged, or restricted crankcase breather tubes in extreme cold ambient temperatures. Ice can form in the crankcase breather tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Specification

  • If an obstruction is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the crankcase ventilation oil drain tubes, check valves, breather tube, or separator.

Refer to Procedure 003-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Crankcase pressure sensor stuck in-range

Solution: S00000623

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the crankcase pressure sensor.

Specification

  • A malfunctioning crankcase pressure sensor has been detected if the crankcase pressure sensor is not within the following specification: 0 ± 0.28 kPa - G [0 ± 1.2 in H2O]

Linked Solutions

  • None

Repair

  • Replace crankcase pressure sensor.

Refer to Procedure 019-445

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Crankcase Blowby Check

Solution: S00005143

Verification

Conditions

  • Turn keyswitch ON.
  • Engine running.

Action

  • Check the crankcase breather element type.
  • If the element is not a maintenance free insert, then check the maintenance interval to determine if the maintenance interval has been exceeded.
  • Perform the crankcase blowby measurement test.

Refer to Procedure 014-010

Specification

  • If the crankcase breather element exceeds the maintenance interval, then proceed to the Repair section.
  • If the blowby measurement is not within specification with the element bypassed, then proceed to the Linked Solutions section.

Linked Solutions

Click on the link below:

  • Turbocharger leaking air into crankcase

Refer to S00001203

  • Air compressor leaking air into crankcase

Refer to S00001204

  • Worn or damaged power cylinder components

Refer to S00002975

Repair

  • Replace the crankcase breather element.

Refer to Procedure 003-019

Validation

  • None
Next Solution

4.1 - Turbocharger leaking air into crankcase

Solution: S00001203

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the crankcase blowby measurement test with the turbocharger isolated.

Refer to Procedure 014-010

Specification

  • If the turbocharger blowby contribution is out of specification, then a malfunctioning turbocharger has been detected.

Linked Solutions

  • None

Repair

  • Replace the turbocharger.

Refer to Procedure 010-033

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.2 - Air compressor leaking air into crankcase

Solution: S00001204

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the crankcase blowby measurement test with the air compressor isolated.

Refer to Procedure 014-010

Specification

  • If the air compressor blowby contribution is out of specification, then a malfunctioning air compressor has been detected.

Linked Solutions

  • None

Repair

  • Replace the air compressor.

Refer to Procedure 012-014

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.3 - Worn or damaged power cylinder components

Solution: S00002975

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pistons.

Refer to Procedure 001-043

  • Inspect the piston rings.

Refer to Procedure 001-047

  • Inspect the cylinder liners.

Refer to Procedure 001-028

Specification

  • If damaged or worn power cylinder components are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the piston.

Refer to Procedure 001-043

  • Replace the piston ring.

Refer to Procedure 001-047

  • Repair or replace the cylinder liner.

Refer to Procedure 001-028

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Engine Compression Test

Solution: S00006439

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the Engine Compression Test.

Refer to Procedure 014-012

Specification

  • If the Engine Compression Test is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the piston.

Refer to Procedure 001-043

  • Replace the piston ring.

Refer to Procedure 001-047

  • Repair or replace the cylinder liner.

Refer to Procedure 001-028

  • Replace the cylinder head.

Refer to Procedure 002-004

Validation

  • None
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 556 | SPN: 101 | FMI: 0
Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Lubricating oil level is incorrect
  2. Plugged external crankcase breather tube
  3. Crankcase pressure sensor stuck in-range
  4. Crankcase Blowby Check
  5. Turbocharger leaking air into crankcase
  6. Air compressor leaking air into crankcase
  7. Worn or damaged power cylinder components
  8. Engine Compression Test
  9. ECM calibration revision history check

1 - Lubricating oil level is incorrect

Solution: S00003234

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Make sure the vehicle is on a level surface with the engine off.
  • Check that the lubricating oil level is correct.
  • Determine if the lubrication oil is contaminated with coolant or fuel.

Specification

  • If the oil level is high and coolant contamination has been detected, then reset the search to Coolant in the oil.
  • If the oil level is high and fuel contamination has been detected, then reset the search to Fuel in the oil.
  • If the oil level is high and no coolant or fuel contamination has been detected, then incorrect oil dipstick calibration has been detected.
  • If the oil level is normal, then proceed to the next solution.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Reset search for coolant in the lubricating oil.
  • Search for fuel in oil.
  • Calibrate the lubricating oil dipstick for the proper oil level.

Refer to Procedure 007-009

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Plugged external crankcase breather tube

Solution: S00000626

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the oil drain tubes, check valves, breather tubes, and oil separator for plugging.

Refer to Procedure 003-001

It is important to check for a frozen, plugged, or restricted crankcase breather tubes in extreme cold ambient temperatures. Ice can form in the crankcase breather tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Specification

  • If an obstruction is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the crankcase ventilation oil drain tubes, check valves, breather tube, or separator.

Refer to Procedure 003-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Crankcase pressure sensor stuck in-range

Solution: S00000623

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the crankcase pressure sensor.

Specification

  • A malfunctioning crankcase pressure sensor has been detected if the crankcase pressure sensor is not within the following specification: 0 ± 0.28 kPa - G [0 ± 1.2 in H2O]

Linked Solutions

  • None

Repair

  • Replace crankcase pressure sensor.

Refer to Procedure 019-445

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Crankcase Blowby Check

Solution: S00005143

Verification

Conditions

  • Turn keyswitch ON.
  • Engine running.

Action

  • Check the crankcase breather element type.
  • If the element is not a maintenance free insert, then check the maintenance interval to determine if the maintenance interval has been exceeded.
  • Perform the crankcase blowby measurement test.

Refer to Procedure 014-010

Specification

  • If the crankcase breather element exceeds the maintenance interval, then proceed to the Repair section.
  • If the blowby measurement is not within specification with the element bypassed, then proceed to the Linked Solutions section.

Linked Solutions

Click on the link below:

  • Turbocharger leaking air into crankcase

Refer to S00001203

  • Air compressor leaking air into crankcase

Refer to S00001204

  • Worn or damaged power cylinder components

Refer to S00002975

Repair

  • Replace the crankcase breather element.

Refer to Procedure 003-019

Validation

  • None
Next Solution

4.1 - Turbocharger leaking air into crankcase

Solution: S00001203

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the crankcase blowby measurement test with the turbocharger isolated.

Refer to Procedure 014-010

Specification

  • If the turbocharger blowby contribution is out of specification, then a malfunctioning turbocharger has been detected.

Linked Solutions

  • None

Repair

  • Replace the turbocharger.

Refer to Procedure 010-033

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.2 - Air compressor leaking air into crankcase

Solution: S00001204

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the crankcase blowby measurement test with the air compressor isolated.

Refer to Procedure 014-010

Specification

  • If the air compressor blowby contribution is out of specification, then a malfunctioning air compressor has been detected.

Linked Solutions

  • None

Repair

  • Replace the air compressor.

Refer to Procedure 012-014

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.3 - Worn or damaged power cylinder components

Solution: S00002975

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pistons.

Refer to Procedure 001-043

  • Inspect the piston rings.

Refer to Procedure 001-047

  • Inspect the cylinder liners.

Refer to Procedure 001-028

Specification

  • If damaged or worn power cylinder components are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the piston.

Refer to Procedure 001-043

  • Replace the piston ring.

Refer to Procedure 001-047

  • Repair or replace the cylinder liner.

Refer to Procedure 001-028

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Engine Compression Test

Solution: S00006439

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the Engine Compression Test.

Refer to Procedure 014-012

Specification

  • If the Engine Compression Test is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the piston.

Refer to Procedure 001-043

  • Replace the piston ring.

Refer to Procedure 001-047

  • Repair or replace the cylinder liner.

Refer to Procedure 001-028

  • Replace the cylinder head.

Refer to Procedure 002-004

Validation

  • None
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 561 | SPN: 1352 | FMI: 0
Engine Cylinder 1 (A1) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Knock sensor is malfunctioning
  3. Spark plug is damaged
  4. Ignition Coil Test
  5. Ignition control wiring harness open circuit check
  6. Ignition control wiring harness circuit pin to ground short
  7. Ignition control wiring harness circuit pin to pin short
  8. Ignition control module open circuit check
  9. Ignition control module circuit pin to ground short
  10. Ignition control module circuit pin to pin short
  11. Turbocharger wastegate actuator is malfunctioning
  12. Engine Compression Test
  13. Overhead component damaged or out of adjustment
  14. Cylinder Leak Down Test
  15. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002658

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Knock sensor: 572

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Knock sensor is malfunctioning

Solution: S00004356

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Inspect the appropriate knock sensor.

Refer to Procedure 019-346

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the knock sensor.

Refer to Procedure 019-346

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Spark plug is damaged

Solution: S00003531

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove all of the spark plugs.

Refer to Procedure 013-016

  • Measure the spark plug gap.

Refer to Procedure 013-016

  • Check the spark plugs.

Refer to Service Bulletin 4383578

Specification

  • If the spark plugs do not meet specification, then reset the search to the correct symptom according to the service bulletin.
  • If the spark plug gap is incorrect, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Correct the spark plug gap.

Refer to Procedure 013-016

  • Replace the spark plug.

Refer to Procedure 013-016

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Ignition Coil Test

Solution: S00004217

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect ignition coil body for cracks.

Refer to Procedure 013-012

Refer to Service Bulletin 4383630

  • Perform the ignition coil test.

Refer to Procedure 013-012

Specification

  • If any damage is found, then proceed to the Repair section.
  • If no spark was observed during the coil test, then proceed to the Linked Solutions section.

Linked Solutions

  • Ignition control wiring harness open circuit check

Refer to S00005711

  • Ignition control wiring harness circuit pin to ground short

Refer to S00005713

  • Ignition control wiring harness circuit pin to pin short

Refer to S00005715

  • Ignition control module open circuit check

Refer to S00005712

  • Ignition control module circuit pin to ground short

Refer to S00005714

  • Ignition control module circuit pin to pin short

Refer to S00006731

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil pack.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4.1 - Ignition control wiring harness open circuit check

Solution: S00005711

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.2 - Ignition control wiring harness circuit pin to ground short

Solution: S00005713

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connector C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the charge voltage pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the secondary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the primary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.3 - Ignition control wiring harness circuit pin to pin short

Solution: S00005715

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control wiring harness charge voltage SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness secondary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness primary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.4 - Ignition control module open circuit check

Solution: S00005712

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the ignition control module C1 connector and the combustion detection SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the ignition control module C1 connector and the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the ignition control module C1 connector and the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module RETURN pin at the ignition control module C1 connector and the ignition control module RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the ignition control module C1 connector and the spark voltage SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.5 - Ignition control module circuit pin to ground short

Solution: S00005714

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.6 - Ignition control module circuit pin to pin short

Solution: S00006731

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Turbocharger wastegate actuator is malfunctioning

Solution: S00006413

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the turbocharger wastegate actuator for damage.

Refer to Procedure 010-050

  • Visually inspect the turbocharger wastegate valve seat.

Refer to Procedure 010-033

  • Inspect the turbocharger wastegate valve body assembly for damage.

Refer to Procedure 010-055

  • Perform the Turbocharger Wastegate Actuator Test.

Refer to Procedure 010-050

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace turbocharger wastegate.

Refer to Procedure 010-033

  • Replace turbocharger wastegate actuator.

Refer to Procedure 010-050

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Engine Compression Test

Solution: S00006439

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the Engine Compression Test.

Refer to Procedure 014-012

Specification

  • If the Engine Compression Test is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the piston.

Refer to Procedure 001-043

  • Replace the piston ring.

Refer to Procedure 001-047

  • Repair or replace the cylinder liner.

Refer to Procedure 001-028

  • Replace the cylinder head.

Refer to Procedure 002-004

Validation

  • None
Next Solution

7 - Overhead component damaged or out of adjustment

Solution: S00008484

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

  • Adjust the overhead.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Cylinder Leak Down Test

Solution: S00005891

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the Cylinder Leak Down Test.

Refer to Procedure 014-026

  • Visually inspect the pistons.

Refer to Procedure 001-043

  • Visually inspect the piston rings.

Refer to Procedure 001-047

  • Visually inspect the cylinder liners.

Refer to Procedure 001-028

Specification

  • If the Cylinder Leak Down Test does not meet specification, then a malfunctioning power cylinder component has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the piston.

Refer to Procedure 001-043

  • Replace the piston ring.

Refer to Procedure 001-047

  • Repair or replace the cylinder liner.

Refer to Procedure 001-028

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 562 | SPN: 1353 | FMI: 0
Engine Cylinder 2 (B1) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Knock sensor is malfunctioning
  3. Spark plug is damaged
  4. Ignition Coil Test
  5. Ignition control wiring harness open circuit check
  6. Ignition control wiring harness circuit pin to ground short
  7. Ignition control wiring harness circuit pin to pin short
  8. Ignition control module open circuit check
  9. Ignition control module circuit pin to ground short
  10. Ignition control module circuit pin to pin short
  11. Turbocharger wastegate actuator is malfunctioning
  12. Engine Compression Test
  13. Overhead component damaged or out of adjustment
  14. Cylinder Leak Down Test
  15. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002658

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Knock sensor: 572

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Knock sensor is malfunctioning

Solution: S00004356

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Inspect the appropriate knock sensor.

Refer to Procedure 019-346

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the knock sensor.

Refer to Procedure 019-346

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Spark plug is damaged

Solution: S00003531

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove all of the spark plugs.

Refer to Procedure 013-016

  • Measure the spark plug gap.

Refer to Procedure 013-016

  • Check the spark plugs.

Refer to Service Bulletin 4383578

Specification

  • If the spark plugs do not meet specification, then reset the search to the correct symptom according to the service bulletin.
  • If the spark plug gap is incorrect, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Correct the spark plug gap.

Refer to Procedure 013-016

  • Replace the spark plug.

Refer to Procedure 013-016

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Ignition Coil Test

Solution: S00004217

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect ignition coil body for cracks.

Refer to Procedure 013-012

Refer to Service Bulletin 4383630

  • Perform the ignition coil test.

Refer to Procedure 013-012

Specification

  • If any damage is found, then proceed to the Repair section.
  • If no spark was observed during the coil test, then proceed to the Linked Solutions section.

Linked Solutions

  • Ignition control wiring harness open circuit check

Refer to S00005711

  • Ignition control wiring harness circuit pin to ground short

Refer to S00005713

  • Ignition control wiring harness circuit pin to pin short

Refer to S00005715

  • Ignition control module open circuit check

Refer to S00005712

  • Ignition control module circuit pin to ground short

Refer to S00005714

  • Ignition control module circuit pin to pin short

Refer to S00006731

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil pack.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4.1 - Ignition control wiring harness open circuit check

Solution: S00005711

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.2 - Ignition control wiring harness circuit pin to ground short

Solution: S00005713

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connector C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the charge voltage pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the secondary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the primary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.3 - Ignition control wiring harness circuit pin to pin short

Solution: S00005715

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control wiring harness charge voltage SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness secondary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness primary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.4 - Ignition control module open circuit check

Solution: S00005712

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the ignition control module C1 connector and the combustion detection SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the ignition control module C1 connector and the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the ignition control module C1 connector and the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module RETURN pin at the ignition control module C1 connector and the ignition control module RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the ignition control module C1 connector and the spark voltage SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.5 - Ignition control module circuit pin to ground short

Solution: S00005714

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.6 - Ignition control module circuit pin to pin short

Solution: S00006731

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Turbocharger wastegate actuator is malfunctioning

Solution: S00006413

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the turbocharger wastegate actuator for damage.

Refer to Procedure 010-050

  • Visually inspect the turbocharger wastegate valve seat.

Refer to Procedure 010-033

  • Inspect the turbocharger wastegate valve body assembly for damage.

Refer to Procedure 010-055

  • Perform the Turbocharger Wastegate Actuator Test.

Refer to Procedure 010-050

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace turbocharger wastegate.

Refer to Procedure 010-033

  • Replace turbocharger wastegate actuator.

Refer to Procedure 010-050

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Engine Compression Test

Solution: S00006439

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the Engine Compression Test.

Refer to Procedure 014-012

Specification

  • If the Engine Compression Test is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the piston.

Refer to Procedure 001-043

  • Replace the piston ring.

Refer to Procedure 001-047

  • Repair or replace the cylinder liner.

Refer to Procedure 001-028

  • Replace the cylinder head.

Refer to Procedure 002-004

Validation

  • None
Next Solution

7 - Overhead component damaged or out of adjustment

Solution: S00008484

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

  • Adjust the overhead.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Cylinder Leak Down Test

Solution: S00005891

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the Cylinder Leak Down Test.

Refer to Procedure 014-026

  • Visually inspect the pistons.

Refer to Procedure 001-043

  • Visually inspect the piston rings.

Refer to Procedure 001-047

  • Visually inspect the cylinder liners.

Refer to Procedure 001-028

Specification

  • If the Cylinder Leak Down Test does not meet specification, then a malfunctioning power cylinder component has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the piston.

Refer to Procedure 001-043

  • Replace the piston ring.

Refer to Procedure 001-047

  • Repair or replace the cylinder liner.

Refer to Procedure 001-028

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 563 | SPN: 1354 | FMI: 0
Engine Cylinder 3 (A2) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Check for primary fault codes
  3. Knock sensor is malfunctioning
  4. Spark plug is damaged
  5. Ignition Coil Test
  6. Ignition control wiring harness open circuit check
  7. Ignition control wiring harness circuit pin to ground short
  8. Ignition control wiring harness circuit pin to pin short
  9. Ignition control module open circuit check
  10. Ignition control module circuit pin to ground short
  11. Ignition control module circuit pin to pin short
  12. Turbocharger wastegate actuator is malfunctioning
  13. Engine Compression Test
  14. Overhead component damaged or out of adjustment
  15. Cylinder Leak Down Test
  16. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001543

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Knock sensor: 572

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Check for primary fault codes

Solution: S00002658

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Knock sensor: 572

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

3 - Knock sensor is malfunctioning

Solution: S00004356

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Inspect the appropriate knock sensor.

Refer to Procedure 019-346

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the knock sensor.

Refer to Procedure 019-346

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Spark plug is damaged

Solution: S00003531

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove all of the spark plugs.

Refer to Procedure 013-016

  • Measure the spark plug gap.

Refer to Procedure 013-016

  • Check the spark plugs.

Refer to Service Bulletin 4383578

Specification

  • If the spark plugs do not meet specification, then reset the search to the correct symptom according to the service bulletin.
  • If the spark plug gap is incorrect, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Correct the spark plug gap.

Refer to Procedure 013-016

  • Replace the spark plug.

Refer to Procedure 013-016

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Ignition Coil Test

Solution: S00004217

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect ignition coil body for cracks.

Refer to Procedure 013-012

Refer to Service Bulletin 4383630

  • Perform the ignition coil test.

Refer to Procedure 013-012

Specification

  • If any damage is found, then proceed to the Repair section.
  • If no spark was observed during the coil test, then proceed to the Linked Solutions section.

Linked Solutions

  • Ignition control wiring harness open circuit check

Refer to S00005711

  • Ignition control wiring harness circuit pin to ground short

Refer to S00005713

  • Ignition control wiring harness circuit pin to pin short

Refer to S00005715

  • Ignition control module open circuit check

Refer to S00005712

  • Ignition control module circuit pin to ground short

Refer to S00005714

  • Ignition control module circuit pin to pin short

Refer to S00006731

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil pack.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5.1 - Ignition control wiring harness open circuit check

Solution: S00005711

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.2 - Ignition control wiring harness circuit pin to ground short

Solution: S00005713

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connector C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the charge voltage pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the secondary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the primary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.3 - Ignition control wiring harness circuit pin to pin short

Solution: S00005715

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control wiring harness charge voltage SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness secondary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness primary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.4 - Ignition control module open circuit check

Solution: S00005712

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the ignition control module C1 connector and the combustion detection SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the ignition control module C1 connector and the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the ignition control module C1 connector and the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module RETURN pin at the ignition control module C1 connector and the ignition control module RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the ignition control module C1 connector and the spark voltage SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.5 - Ignition control module circuit pin to ground short

Solution: S00005714

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.6 - Ignition control module circuit pin to pin short

Solution: S00006731

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - Turbocharger wastegate actuator is malfunctioning

Solution: S00006413

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the turbocharger wastegate actuator for damage.

Refer to Procedure 010-050

  • Visually inspect the turbocharger wastegate valve seat.

Refer to Procedure 010-033

  • Inspect the turbocharger wastegate valve body assembly for damage.

Refer to Procedure 010-055

  • Perform the Turbocharger Wastegate Actuator Test.

Refer to Procedure 010-050

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace turbocharger wastegate.

Refer to Procedure 010-033

  • Replace turbocharger wastegate actuator.

Refer to Procedure 010-050

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Engine Compression Test

Solution: S00006439

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the Engine Compression Test.

Refer to Procedure 014-012

Specification

  • If the Engine Compression Test is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the piston.

Refer to Procedure 001-043

  • Replace the piston ring.

Refer to Procedure 001-047

  • Repair or replace the cylinder liner.

Refer to Procedure 001-028

  • Replace the cylinder head.

Refer to Procedure 002-004

Validation

  • None
Next Solution

8 - Overhead component damaged or out of adjustment

Solution: S00008484

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

  • Adjust the overhead.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Cylinder Leak Down Test

Solution: S00005891

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the Cylinder Leak Down Test.

Refer to Procedure 014-026

  • Visually inspect the pistons.

Refer to Procedure 001-043

  • Visually inspect the piston rings.

Refer to Procedure 001-047

  • Visually inspect the cylinder liners.

Refer to Procedure 001-028

Specification

  • If the Cylinder Leak Down Test does not meet specification, then a malfunctioning power cylinder component has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the piston.

Refer to Procedure 001-043

  • Replace the piston ring.

Refer to Procedure 001-047

  • Repair or replace the cylinder liner.

Refer to Procedure 001-028

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 564 | SPN: 1355 | FMI: 0
Engine Cylinder 4 (B2) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Check for primary fault codes
  3. Knock sensor is malfunctioning
  4. Spark plug is damaged
  5. Ignition Coil Test
  6. Ignition control wiring harness open circuit check
  7. Ignition control wiring harness circuit pin to ground short
  8. Ignition control wiring harness circuit pin to pin short
  9. Ignition control module open circuit check
  10. Ignition control module circuit pin to ground short
  11. Ignition control module circuit pin to pin short
  12. Turbocharger wastegate actuator is malfunctioning
  13. Engine Compression Test
  14. Overhead component damaged or out of adjustment
  15. Cylinder Leak Down Test
  16. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001925

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Knock sensor: 575

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Check for primary fault codes

Solution: S00002259

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Knock sensor: 575

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

3 - Knock sensor is malfunctioning

Solution: S00004356

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Inspect the appropriate knock sensor.

Refer to Procedure 019-346

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the knock sensor.

Refer to Procedure 019-346

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Spark plug is damaged

Solution: S00003531

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove all of the spark plugs.

Refer to Procedure 013-016

  • Measure the spark plug gap.

Refer to Procedure 013-016

  • Check the spark plugs.

Refer to Service Bulletin 4383578

Specification

  • If the spark plugs do not meet specification, then reset the search to the correct symptom according to the service bulletin.
  • If the spark plug gap is incorrect, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Correct the spark plug gap.

Refer to Procedure 013-016

  • Replace the spark plug.

Refer to Procedure 013-016

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Ignition Coil Test

Solution: S00004217

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect ignition coil body for cracks.

Refer to Procedure 013-012

Refer to Service Bulletin 4383630

  • Perform the ignition coil test.

Refer to Procedure 013-012

Specification

  • If any damage is found, then proceed to the Repair section.
  • If no spark was observed during the coil test, then proceed to the Linked Solutions section.

Linked Solutions

  • Ignition control wiring harness open circuit check

Refer to S00005711

  • Ignition control wiring harness circuit pin to ground short

Refer to S00005713

  • Ignition control wiring harness circuit pin to pin short

Refer to S00005715

  • Ignition control module open circuit check

Refer to S00005712

  • Ignition control module circuit pin to ground short

Refer to S00005714

  • Ignition control module circuit pin to pin short

Refer to S00006731

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil pack.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5.1 - Ignition control wiring harness open circuit check

Solution: S00005711

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.2 - Ignition control wiring harness circuit pin to ground short

Solution: S00005713

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connector C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the charge voltage pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the secondary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the primary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.3 - Ignition control wiring harness circuit pin to pin short

Solution: S00005715

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control wiring harness charge voltage SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness secondary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness primary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.4 - Ignition control module open circuit check

Solution: S00005712

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the ignition control module C1 connector and the combustion detection SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the ignition control module C1 connector and the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the ignition control module C1 connector and the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module RETURN pin at the ignition control module C1 connector and the ignition control module RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the ignition control module C1 connector and the spark voltage SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.5 - Ignition control module circuit pin to ground short

Solution: S00005714

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.6 - Ignition control module circuit pin to pin short

Solution: S00006731

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - Turbocharger wastegate actuator is malfunctioning

Solution: S00006413

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the turbocharger wastegate actuator for damage.

Refer to Procedure 010-050

  • Visually inspect the turbocharger wastegate valve seat.

Refer to Procedure 010-033

  • Inspect the turbocharger wastegate valve body assembly for damage.

Refer to Procedure 010-055

  • Perform the Turbocharger Wastegate Actuator Test.

Refer to Procedure 010-050

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace turbocharger wastegate.

Refer to Procedure 010-033

  • Replace turbocharger wastegate actuator.

Refer to Procedure 010-050

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Engine Compression Test

Solution: S00006439

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the Engine Compression Test.

Refer to Procedure 014-012

Specification

  • If the Engine Compression Test is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the piston.

Refer to Procedure 001-043

  • Replace the piston ring.

Refer to Procedure 001-047

  • Repair or replace the cylinder liner.

Refer to Procedure 001-028

  • Replace the cylinder head.

Refer to Procedure 002-004

Validation

  • None
Next Solution

8 - Overhead component damaged or out of adjustment

Solution: S00008484

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

  • Adjust the overhead.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Cylinder Leak Down Test

Solution: S00005891

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the Cylinder Leak Down Test.

Refer to Procedure 014-026

  • Visually inspect the pistons.

Refer to Procedure 001-043

  • Visually inspect the piston rings.

Refer to Procedure 001-047

  • Visually inspect the cylinder liners.

Refer to Procedure 001-028

Specification

  • If the Cylinder Leak Down Test does not meet specification, then a malfunctioning power cylinder component has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the piston.

Refer to Procedure 001-043

  • Replace the piston ring.

Refer to Procedure 001-047

  • Repair or replace the cylinder liner.

Refer to Procedure 001-028

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 565 | SPN: 1356 | FMI: 0
Engine Cylinder 5 (A3) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Check for primary fault codes
  3. Knock sensor is malfunctioning
  4. Spark plug is damaged
  5. Ignition Coil Test
  6. Ignition control wiring harness open circuit check
  7. Ignition control wiring harness circuit pin to ground short
  8. Ignition control wiring harness circuit pin to pin short
  9. Ignition control module open circuit check
  10. Ignition control module circuit pin to ground short
  11. Ignition control module circuit pin to pin short
  12. Turbocharger wastegate actuator is malfunctioning
  13. Engine Compression Test
  14. Overhead component damaged or out of adjustment
  15. Cylinder Leak Down Test
  16. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002736

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Knock sensor: 575

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Check for primary fault codes

Solution: S00002259

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Knock sensor: 575

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

3 - Knock sensor is malfunctioning

Solution: S00004356

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Inspect the appropriate knock sensor.

Refer to Procedure 019-346

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the knock sensor.

Refer to Procedure 019-346

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Spark plug is damaged

Solution: S00003531

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove all of the spark plugs.

Refer to Procedure 013-016

  • Measure the spark plug gap.

Refer to Procedure 013-016

  • Check the spark plugs.

Refer to Service Bulletin 4383578

Specification

  • If the spark plugs do not meet specification, then reset the search to the correct symptom according to the service bulletin.
  • If the spark plug gap is incorrect, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Correct the spark plug gap.

Refer to Procedure 013-016

  • Replace the spark plug.

Refer to Procedure 013-016

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Ignition Coil Test

Solution: S00004217

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect ignition coil body for cracks.

Refer to Procedure 013-012

Refer to Service Bulletin 4383630

  • Perform the ignition coil test.

Refer to Procedure 013-012

Specification

  • If any damage is found, then proceed to the Repair section.
  • If no spark was observed during the coil test, then proceed to the Linked Solutions section.

Linked Solutions

  • Ignition control wiring harness open circuit check

Refer to S00005711

  • Ignition control wiring harness circuit pin to ground short

Refer to S00005713

  • Ignition control wiring harness circuit pin to pin short

Refer to S00005715

  • Ignition control module open circuit check

Refer to S00005712

  • Ignition control module circuit pin to ground short

Refer to S00005714

  • Ignition control module circuit pin to pin short

Refer to S00006731

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil pack.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5.1 - Ignition control wiring harness open circuit check

Solution: S00005711

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.2 - Ignition control wiring harness circuit pin to ground short

Solution: S00005713

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connector C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the charge voltage pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the secondary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the primary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.3 - Ignition control wiring harness circuit pin to pin short

Solution: S00005715

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control wiring harness charge voltage SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness secondary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness primary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.4 - Ignition control module open circuit check

Solution: S00005712

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the ignition control module C1 connector and the combustion detection SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the ignition control module C1 connector and the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the ignition control module C1 connector and the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module RETURN pin at the ignition control module C1 connector and the ignition control module RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the ignition control module C1 connector and the spark voltage SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.5 - Ignition control module circuit pin to ground short

Solution: S00005714

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.6 - Ignition control module circuit pin to pin short

Solution: S00006731

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - Turbocharger wastegate actuator is malfunctioning

Solution: S00006413

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the turbocharger wastegate actuator for damage.

Refer to Procedure 010-050

  • Visually inspect the turbocharger wastegate valve seat.

Refer to Procedure 010-033

  • Inspect the turbocharger wastegate valve body assembly for damage.

Refer to Procedure 010-055

  • Perform the Turbocharger Wastegate Actuator Test.

Refer to Procedure 010-050

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace turbocharger wastegate.

Refer to Procedure 010-033

  • Replace turbocharger wastegate actuator.

Refer to Procedure 010-050

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Engine Compression Test

Solution: S00006439

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the Engine Compression Test.

Refer to Procedure 014-012

Specification

  • If the Engine Compression Test is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the piston.

Refer to Procedure 001-043

  • Replace the piston ring.

Refer to Procedure 001-047

  • Repair or replace the cylinder liner.

Refer to Procedure 001-028

  • Replace the cylinder head.

Refer to Procedure 002-004

Validation

  • None
Next Solution

8 - Overhead component damaged or out of adjustment

Solution: S00008484

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

  • Adjust the overhead.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Cylinder Leak Down Test

Solution: S00005891

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the Cylinder Leak Down Test.

Refer to Procedure 014-026

  • Visually inspect the pistons.

Refer to Procedure 001-043

  • Visually inspect the piston rings.

Refer to Procedure 001-047

  • Visually inspect the cylinder liners.

Refer to Procedure 001-028

Specification

  • If the Cylinder Leak Down Test does not meet specification, then a malfunctioning power cylinder component has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the piston.

Refer to Procedure 001-043

  • Replace the piston ring.

Refer to Procedure 001-047

  • Repair or replace the cylinder liner.

Refer to Procedure 001-028

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 566 | SPN: 1357 | FMI: 0
Engine Cylinder 6 (B3) Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Check for primary fault codes
  3. Knock sensor is malfunctioning
  4. Spark plug is damaged
  5. Ignition Coil Test
  6. Ignition control wiring harness open circuit check
  7. Ignition control wiring harness circuit pin to ground short
  8. Ignition control wiring harness circuit pin to pin short
  9. Ignition control module open circuit check
  10. Ignition control module circuit pin to ground short
  11. Ignition control module circuit pin to pin short
  12. Turbocharger wastegate actuator is malfunctioning
  13. Engine Compression Test
  14. Overhead component damaged or out of adjustment
  15. Cylinder Leak Down Test
  16. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002197

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Knock sensor: 575

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Check for primary fault codes

Solution: S00002259

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Knock sensor: 575

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

3 - Knock sensor is malfunctioning

Solution: S00004356

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Inspect the appropriate knock sensor.

Refer to Procedure 019-346

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the knock sensor.

Refer to Procedure 019-346

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Spark plug is damaged

Solution: S00003531

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove all of the spark plugs.

Refer to Procedure 013-016

  • Measure the spark plug gap.

Refer to Procedure 013-016

  • Check the spark plugs.

Refer to Service Bulletin 4383578

Specification

  • If the spark plugs do not meet specification, then reset the search to the correct symptom according to the service bulletin.
  • If the spark plug gap is incorrect, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Correct the spark plug gap.

Refer to Procedure 013-016

  • Replace the spark plug.

Refer to Procedure 013-016

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Ignition Coil Test

Solution: S00004217

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect ignition coil body for cracks.

Refer to Procedure 013-012

Refer to Service Bulletin 4383630

  • Perform the ignition coil test.

Refer to Procedure 013-012

Specification

  • If any damage is found, then proceed to the Repair section.
  • If no spark was observed during the coil test, then proceed to the Linked Solutions section.

Linked Solutions

  • Ignition control wiring harness open circuit check

Refer to S00005711

  • Ignition control wiring harness circuit pin to ground short

Refer to S00005713

  • Ignition control wiring harness circuit pin to pin short

Refer to S00005715

  • Ignition control module open circuit check

Refer to S00005712

  • Ignition control module circuit pin to ground short

Refer to S00005714

  • Ignition control module circuit pin to pin short

Refer to S00006731

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil pack.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5.1 - Ignition control wiring harness open circuit check

Solution: S00005711

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.2 - Ignition control wiring harness circuit pin to ground short

Solution: S00005713

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connector C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the charge voltage pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the secondary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the primary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.3 - Ignition control wiring harness circuit pin to pin short

Solution: S00005715

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control wiring harness charge voltage SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness secondary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness primary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.4 - Ignition control module open circuit check

Solution: S00005712

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the ignition control module C1 connector and the combustion detection SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the ignition control module C1 connector and the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the ignition control module C1 connector and the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module RETURN pin at the ignition control module C1 connector and the ignition control module RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the ignition control module C1 connector and the spark voltage SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.5 - Ignition control module circuit pin to ground short

Solution: S00005714

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.6 - Ignition control module circuit pin to pin short

Solution: S00006731

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - Turbocharger wastegate actuator is malfunctioning

Solution: S00006413

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the turbocharger wastegate actuator for damage.

Refer to Procedure 010-050

  • Visually inspect the turbocharger wastegate valve seat.

Refer to Procedure 010-033

  • Inspect the turbocharger wastegate valve body assembly for damage.

Refer to Procedure 010-055

  • Perform the Turbocharger Wastegate Actuator Test.

Refer to Procedure 010-050

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace turbocharger wastegate.

Refer to Procedure 010-033

  • Replace turbocharger wastegate actuator.

Refer to Procedure 010-050

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Engine Compression Test

Solution: S00006439

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the Engine Compression Test.

Refer to Procedure 014-012

Specification

  • If the Engine Compression Test is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the piston.

Refer to Procedure 001-043

  • Replace the piston ring.

Refer to Procedure 001-047

  • Repair or replace the cylinder liner.

Refer to Procedure 001-028

  • Replace the cylinder head.

Refer to Procedure 002-004

Validation

  • None
Next Solution

8 - Overhead component damaged or out of adjustment

Solution: S00008484

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

  • Adjust the overhead.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Cylinder Leak Down Test

Solution: S00005891

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the Cylinder Leak Down Test.

Refer to Procedure 014-026

  • Visually inspect the pistons.

Refer to Procedure 001-043

  • Visually inspect the piston rings.

Refer to Procedure 001-047

  • Visually inspect the cylinder liners.

Refer to Procedure 001-028

Specification

  • If the Cylinder Leak Down Test does not meet specification, then a malfunctioning power cylinder component has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the piston.

Refer to Procedure 001-043

  • Replace the piston ring.

Refer to Procedure 001-047

  • Repair or replace the cylinder liner.

Refer to Procedure 001-028

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 572 | SPN: 1353 | FMI: 4
Engine Cylinder 2 (B1) Knock - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Knock sensor is malfunctioning
  2. Knock sensor open circuit check
  3. Knock sensor circuit pin to ground short
  4. Knock sensor circuit pin to pin short
  5. ECM calibration revision history check

1 - Knock sensor is malfunctioning

Solution: S00004356

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Inspect the appropriate knock sensor.

Refer to Procedure 019-346

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the knock sensor.

Refer to Procedure 019-346

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Knock sensor open circuit check

Solution: S00003827

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the knock sensor 1 from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the knock sensor 1 SIGNAL pin at the knock sensor 1 engine wiring harness connected and the knock sensor 1 SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Knock sensor circuit pin to ground short

Solution: S00004909

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the knock sensor 1 from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the knock sensor 1 SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the knock sensor 1 RETURN pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Knock sensor circuit pin to pin short

Solution: S00003591

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the knock sensor 1 from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the knock sensor 1 SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the knock sensor 1 RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 575 | SPN: 1356 | FMI: 4
Engine Cylinder 5 (A3) Knock - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Knock sensor is malfunctioning
  2. Knock sensor open circuit check
  3. Knock sensor circuit pin to ground short
  4. Knock sensor circuit pin to pin short
  5. ECM calibration revision history check

1 - Knock sensor is malfunctioning

Solution: S00004356

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Inspect the appropriate knock sensor.

Refer to Procedure 019-346

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the knock sensor.

Refer to Procedure 019-346

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Knock sensor open circuit check

Solution: S00004910

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the knock sensor 2 from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the knock sensor 2 SIGNAL pin at the knock sensor 2 engine wiring harness connected and the knock sensor 2 SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the knock sensor 2 RETURN pin at the knock sensor 2 engine wiring harness connected and the knock sensor 2 RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Knock sensor circuit pin to ground short

Solution: S00003496

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the knock sensor 2 from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the knock sensor 2 SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the knock sensor 2 RETURN pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Knock sensor circuit pin to pin short

Solution: S00004911

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the knock sensor 2 from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the knock sensor 2 SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the knock sensor 2 RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 584 | SPN: 677 | FMI: 3
Engine Starter Motor Relay Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Starter lockout relay is malfunctioning
  2. Starter lockout relay open circuit check
  3. Starter lockout relay circuit pin to pin short

1 - Starter lockout relay is malfunctioning

Solution: S00000637

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the starter lockout relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Starter lockout relay open circuit check

Solution: S00000642

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.
  • Measure the resistance between the starter lockout relay SIGNAL pin at the starter lockout relay connector of the OEM wiring harness and the starter lockout relay SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the starter lockout relay RETURN pin at the starter lockout relay connector of the OEM wiring harness and the starter lockout relay RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Starter lockout relay circuit pin to pin short

Solution: S00000643

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the starter lockout relay SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 585 | SPN: 677 | FMI: 4
Engine Starter Motor Relay Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Starter lockout relay is malfunctioning
  2. Starter lockout relay circuit pin to ground short
  3. Starter lockout relay circuit pin to pin short

1 - Starter lockout relay is malfunctioning

Solution: S00000637

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the starter lockout relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Starter lockout relay circuit pin to ground short

Solution: S00000650

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the starter lockout relay SIGNAL pin in the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Starter lockout relay circuit pin to pin short

Solution: S00000643

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the starter lockout relay SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 596 | SPN: 167 | FMI: 16
Electrical Charging System Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Battery or battery cables are malfunctioning
  2. Charging system alternator is malfunctioning
  3. ECM calibration revision history check

1 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Charging system alternator is malfunctioning

Solution: S00000532

Verification

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the charging system alternator and the battery.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Test the charging system alternator output.

Refer to Procedure 013-001

Specification

  • If the charging system alternator output does not meet specification, then a malfunctioning alternator has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the alternator.

Refer to Procedure 013-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 597 | SPN: 167 | FMI: 18
Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Battery or battery cables are malfunctioning
  2. Charging system alternator is malfunctioning
  3. ECM battery voltage check
  4. Unswitched battery circuit pin to pin short
  5. ECM calibration revision history check

1 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Charging system alternator is malfunctioning

Solution: S00000532

Verification

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the charging system alternator and the battery.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Test the charging system alternator output.

Refer to Procedure 013-001

Specification

  • If the charging system alternator output does not meet specification, then a malfunctioning alternator has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the alternator.

Refer to Procedure 013-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM battery voltage check

Solution: S00002091

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM power supply from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the ECM battery SUPPLY pin at the OEM wiring harness 4 pin connector and engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Unswitched battery circuit pin to pin short

Solution: S00000668

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the battery.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ECM battery SUPPLY (+) pin of the OEM wiring harness ECM connector to all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 598 | SPN: 167 | FMI: 1
Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Intermittent ground connection
  2. Battery or battery cables are malfunctioning
  3. Charging system alternator is malfunctioning
  4. Unswitched battery circuit pin to pin short
  5. ECM calibration revision history check

1 - Intermittent ground connection

Solution: S00000690

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect all of the engine block, starter, alternator, chassis, and battery ground connections.

Refer to OEM Service Manual

  • Verify all of the grounds are present and properly grounded.
  • Inspect all connections for corrosion or loose connections.

Refer to OEM Service Manual

  • Visually inspect the batteries and the battery cable connections for corrosion.

Specification

  • All grounds must be present, properly grounded, free of corrosion, and tight.

Linked Solutions

  • None

Repair

  • Repair or replace damaged connections.

Refer to Procedure 019-008

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Charging system alternator is malfunctioning

Solution: S00000532

Verification

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the charging system alternator and the battery.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Test the charging system alternator output.

Refer to Procedure 013-001

Specification

  • If the charging system alternator output does not meet specification, then a malfunctioning alternator has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the alternator.

Refer to Procedure 013-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Unswitched battery circuit pin to pin short

Solution: S00000668

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the battery.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ECM battery SUPPLY (+) pin of the OEM wiring harness ECM connector to all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 649 | SPN: 1378 | FMI: 31
Engine Oil Change Interval - Condition Exists

Troubleshooting Summary

  1. ECM calibration revision history check
  2. Oil change interval maintenance warning

1 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Oil change interval maintenance warning

Solution: S00000671

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or has more than one inactive count within the last 25 engine operating hours, then the lubricating oil maintenance interval has been exceeded.

Linked Solutions

  • None

Repair

  • Change the lubricating oil.

Refer to Procedure 007-037

  • Change the lubricating oil filter.

Refer to Procedure 007-013

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 689 | SPN: 190 | FMI: 2
Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Crankshaft position sensor voltage check
  3. Crankshaft position sensor voltage check at the ECM
  4. Engine crankshaft speed/position sensor check
  5. Crankshaft position sensor open circuit check
  6. Crankshaft position sensor circuit pin to pin short
  7. ECM calibration revision history check
  8. Engine crankshaft speed/position sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000113

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 3: 238, 239
  • Crankshaft speed/position sensor: 284

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Crankshaft position sensor voltage check

Solution: S00000678

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the crankshaft position sensor SUPPLY pin and the crankshaft position sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Crankshaft position sensor voltage check at the ECM

Refer to S00000679

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Crankshaft position sensor voltage check at the ECM

Solution: S00000679

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the crankshaft positon sensor SUPPLY pin and the crankshaft positon sensor RETURN pin at the ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Engine crankshaft speed/position sensor check

Solution: S00000684

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the crankshaft position sensor.
  • Inspect the crankshaft position sensor for signs of damage, oil leak, and metal debris on the end of the sensor.
  • Verify the crankshaft position sensor is connected properly.
  • Use the ratchet drive side of the socket tool that was used to removed the sensor from the engine, place it flush on the sensor so that the edge of the socket is on the edge of the sensor.
  • Monitor the crankshaft engine speed sensor state using the recommended Cummins® electronic service tool or equivalent and monitor (Engine Speed Main Sensor State) to check if the sensor state transitions.
  • Slowly slide the socket in a perpendicular direction to the marked line on the sensor or in a perpendicular direction to the mounting bracket of the sensor.

Specification

  • If any damage is found to the sensor, then proceed to the Repair section.
  • If the crankshaft position sensor is not connected properly, then proceed to the Repair section.
  • If the crankshaft position sensor state does NOT transition from high to low or low to high, or the state does NOT show triggered, then a malfunctioning crankshaft engine position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine crankshaft speed/position sensor.

Refer to Procedure 019-365

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Crankshaft position sensor open circuit check

Solution: S00000676

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the crankshaft position sensor SIGNAL pin at the crankshaft position sensor engine wiring harness connector to the crankshaft position sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Crankshaft position sensor circuit pin to pin short

Solution: S00000674

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the crankshaft position sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the crankshaft position sensor SIGNAL pin of the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Engine crankshaft speed/position sensor is malfunctioning

Solution: S00000866

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning crankshaft position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace crankshaft position sensor.

Refer to Procedure 019-365

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 697 | SPN: 1136 | FMI: 3
Engine ECU Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. ECM Malfunction

1 - ECM Malfunction

Solution: S00003328

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the Repair section if a fault code from the following list is active or has more than one inactive count within the last 25 engine operating hours: 697, 698, 699

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 09-Jan-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 698 | SPN: 1136 | FMI: 4
Engine ECU Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. ECM Malfunction

1 - ECM Malfunction

Solution: S00003328

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the Repair section if a fault code from the following list is active or has more than one inactive count within the last 25 engine operating hours: 697, 698, 699

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 09-Jan-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 731 | SPN: 723 | FMI: 7
Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment

Troubleshooting Summary

  1. Check for primary fault codes
  2. Intermittent ground connection
  3. Incorrect base engine timing
  4. Camshaft position sensor is damaged
  5. Engine crankshaft speed/position sensor check
  6. Camshaft position sensor open circuit check
  7. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001081

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Crankshaft speed/position sensor: 115, 778, 2321

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Intermittent ground connection

Solution: S00000690

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect all of the engine block, starter, alternator, chassis, and battery ground connections.

Refer to OEM Service Manual

  • Verify all of the grounds are present and properly grounded.
  • Inspect all connections for corrosion or loose connections.

Refer to OEM Service Manual

  • Visually inspect the batteries and the battery cable connections for corrosion.

Specification

  • All grounds must be present, properly grounded, free of corrosion, and tight.

Linked Solutions

  • None

Repair

  • Repair or replace damaged connections.

Refer to Procedure 019-008

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Incorrect base engine timing

Solution: S00000689

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the base engine timing.

Refer to Procedure 001-088

Specification

  • If the camshaft and crankshaft gears are not properly aligned, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Correct the base engine timing.

Refer to Procedure 001-088

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Camshaft position sensor is damaged

Solution: S00001226

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the camshaft position sensor.

Refer to Procedure 019-363

  • Inspect the camshaft position sensor for signs of damage, oil leak, and metal debris on the end of the sensor.

Specification

  • If the camshaft position sensor shows any signs of damage, then a malfunctioning camshaft position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace camshaft position sensor.

Refer to Procedure 019-363

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Engine crankshaft speed/position sensor check

Solution: S00000684

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the crankshaft position sensor.
  • Inspect the crankshaft position sensor for signs of damage, oil leak, and metal debris on the end of the sensor.
  • Verify the crankshaft position sensor is connected properly.
  • Use the ratchet drive side of the socket tool that was used to removed the sensor from the engine, place it flush on the sensor so that the edge of the socket is on the edge of the sensor.
  • Monitor the crankshaft engine speed sensor state using the recommended Cummins® electronic service tool or equivalent and monitor (Engine Speed Main Sensor State) to check if the sensor state transitions.
  • Slowly slide the socket in a perpendicular direction to the marked line on the sensor or in a perpendicular direction to the mounting bracket of the sensor.

Specification

  • If any damage is found to the sensor, then proceed to the Repair section.
  • If the crankshaft position sensor is not connected properly, then proceed to the Repair section.
  • If the crankshaft position sensor state does NOT transition from high to low or low to high, or the state does NOT show triggered, then a malfunctioning crankshaft engine position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine crankshaft speed/position sensor.

Refer to Procedure 019-365

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Camshaft position sensor open circuit check

Solution: S00004132

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the camshaft position sensor SIGNAL pin at the camshaft position sensor engine wiring harness connector to the camshaft position sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the camshaft position sensor SUPPLY pin at the camshaft position sensor engine wiring harness connector to the camshaft position sensor SUPPLY pin at the engine wiring harness ECM connector.
  • Measure the resistance between the camshaft position sensor RETURN pin at the camshaft position sensor engine wiring harness connector to the camshaft position sensor RETURN pin at the engine wiring harness ECM connector.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 751 | SPN: 1241 | FMI: 2
Gas Mass Flow 1 - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. External fuel leak
  2. Fuel pressure check
  3. ECM calibration revision history check
  4. Gas mass flow sensor is malfunctioning

1 - External fuel leak

Solution: S00004765

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Start the engine.
  • Use a combustible gas detector to check for leaks.

Specification

  • If there is any damage or leaks found in the fuel system, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM fuel lines.

Refer to OEM Service Manual

  • Replace fuel filter.

Refer to Procedure 006-015

  • Replace the low pressure regulator.

Refer to Procedure 005-047

  • Replace the high pressure regulator.

Refer to Procedure 005-061

  • Replace gas mass flow sensor.

Refer to Procedure 019-101

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Fuel pressure check

Solution: S00004450

Verification

Conditions

  • Turn keyswitch OFF.
  • Verify all fuel shutoff valves are in the open position.

Action

  • Verify the fuel gauge is working properly.

Refer to OEM Service Manual

  • Verify the fuel tank pressure meets specification.

Refer to OEM Service Manual

  • Verify the fuel regulator intake pressure meets specifications.

Refer to Procedure 005-061

Specification

  • If any of the checks are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Add fuel if needed.

Refer to OEM Service Manual

  • For an OEM issue: Contact the OEM for further repair instructions.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Gas mass flow sensor is malfunctioning

Solution: S00006282

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning gas mass flow sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace gas mass flow sensor.

Refer to Procedure 019-101

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 769 | SPN: 597 | FMI: 3
Brake Switch Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Engine brake switch voltage check
  2. Engine brake switch is malfunctioning
  3. Engine brake switch open circuit check
  4. Engine brake switch circuit pin to pin short

1 - Engine brake switch voltage check

Solution: S00001167

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake switch from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the engine brake switch SIGNAL pin and the engine brake switch RETURN pin at the OEM wiring harness engine brake switch connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is not within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Engine brake switch is malfunctioning

Refer to S00001142

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

1.1 - Engine brake switch is malfunctioning

Solution: S00001142

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine brake switch has been detected if a fault code from the following list is active or has more than one inactive count within the last 25 engine operating hours: 769

Linked Solutions

  • None

Repair

  • Replace brake pedal position switch.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2 - Engine brake switch open circuit check

Solution: S00002208

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake switch from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake switch SIGNAL pin at the engine brake switch OEM wiring harness connector and the engine brake switch SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the engine brake switch RETURN pin at the engine brake switch OEM wiring harness connector and the engine brake switch RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine brake switch circuit pin to pin short

Solution: S00002202

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake switch from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake switch SIGNAL 1 pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Measure the resistance between the engine brake switch SIGNAL 2 pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Measure the resistance between the engine brake switch RETURN 1 pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Measure the resistance between the engine brake switch RETURN 2 pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 771 | SPN: 597 | FMI: 4
Brake Switch Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Engine brake switch voltage check
  2. Engine brake switch is malfunctioning
  3. Engine brake switch circuit pin to pin short

1 - Engine brake switch voltage check

Solution: S00001167

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake switch from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the engine brake switch SIGNAL pin and the engine brake switch RETURN pin at the OEM wiring harness engine brake switch connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is not within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Engine brake switch is malfunctioning

Refer to S00001142

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

1.1 - Engine brake switch is malfunctioning

Solution: S00001142

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine brake switch has been detected if a fault code from the following list is active or has more than one inactive count within the last 25 engine operating hours: 769

Linked Solutions

  • None

Repair

  • Replace brake pedal position switch.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2 - Engine brake switch circuit pin to pin short

Solution: S00002202

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake switch from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake switch SIGNAL 1 pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Measure the resistance between the engine brake switch SIGNAL 2 pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Measure the resistance between the engine brake switch RETURN 1 pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Measure the resistance between the engine brake switch RETURN 2 pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 777 | SPN: 1180 | FMI: 16
Turbocharger 1 Turbine Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Turbocharger turbine intake temperature sensor is stuck in-range
  2. Turbocharger wastegate actuator control line is malfunctioning
  3. Turbocharger wastegate actuator is malfunctioning
  4. ECM calibration revision history check

1 - Turbocharger turbine intake temperature sensor is stuck in-range

Solution: S00004819

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Run the engine at idle.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the turbocharger turbine intake temperature sensor.

Specification

  • A malfunctioning turbocharger turbine intake temperature sensor has been detected if the temperature reading is greater than the following specification: 790°C [1454°F]

Linked Solutions

  • None

Repair

  • Replace the turbocharger turbine intake temperature sensor.

Refer to Procedure 019-473

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Turbocharger wastegate actuator control line is malfunctioning

Solution: S00005874

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the turbocharger wastegate actuator control line for damage.

Refer to Procedure 010-050

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the turbocharger wastegate actuator control line.

Refer to Procedure 010-050

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Turbocharger wastegate actuator is malfunctioning

Solution: S00006413

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the turbocharger wastegate actuator for damage.

Refer to Procedure 010-050

  • Visually inspect the turbocharger wastegate valve seat.

Refer to Procedure 010-033

  • Inspect the turbocharger wastegate valve body assembly for damage.

Refer to Procedure 010-055

  • Perform the Turbocharger Wastegate Actuator Test.

Refer to Procedure 010-050

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace turbocharger wastegate.

Refer to Procedure 010-033

  • Replace turbocharger wastegate actuator.

Refer to Procedure 010-050

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 778 | SPN: 723 | FMI: 2
Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Check for primary fault codes
  3. Camshaft position sensor is damaged
  4. Camshaft position sensor is malfunctioning
  5. Camshaft position sensor voltage check
  6. Camshaft position sensor voltage check at the ECM
  7. Camshaft position sensor open circuit check
  8. Camshaft position sensor open circuit check
  9. Camshaft position sensor circuit pin to pin short
  10. Camshaft gear is damaged
  11. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00006538

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 2: 187, 227

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Check for primary fault codes

Solution: S00001825

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386
  • Voltage: 441, 442

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

3 - Camshaft position sensor is damaged

Solution: S00001226

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the camshaft position sensor.

Refer to Procedure 019-363

  • Inspect the camshaft position sensor for signs of damage, oil leak, and metal debris on the end of the sensor.

Specification

  • If the camshaft position sensor shows any signs of damage, then a malfunctioning camshaft position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace camshaft position sensor.

Refer to Procedure 019-363

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Camshaft position sensor is malfunctioning

Solution: S00003853

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine wiring harness.

Action

  • Disconnect the camshaft position sensor from the engine wiring harness.
  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Inspect the camshaft position sensor for signs of damage, oil leak, and metal debris on the end of the sensor.

Refer to Procedure 019-363

Specification

  • If the camshaft position sensor shows any signs of damage, then a malfunctioning camshaft position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace camshaft position sensor.

Refer to Procedure 019-038

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Camshaft position sensor voltage check

Solution: S00000693

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the camshaft position sensor SUPPLY pin and the camshaft position sensor RETURN pin at the sensor connector of the engine wiring harness.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Camshaft position sensor voltage check at the ECM

Refer to S00000694

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

5.1 - Camshaft position sensor voltage check at the ECM

Solution: S00000694

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the camshaft position sensor SUPPLY pin and the camshaft position sensor RETURN pin at the ECM connector.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - Camshaft position sensor open circuit check

Solution: S00004132

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the camshaft position sensor SIGNAL pin at the camshaft position sensor engine wiring harness connector to the camshaft position sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the camshaft position sensor SUPPLY pin at the camshaft position sensor engine wiring harness connector to the camshaft position sensor SUPPLY pin at the engine wiring harness ECM connector.
  • Measure the resistance between the camshaft position sensor RETURN pin at the camshaft position sensor engine wiring harness connector to the camshaft position sensor RETURN pin at the engine wiring harness ECM connector.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Camshaft position sensor open circuit check

Solution: S00000691

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the camshaft position sensor SIGNAL pin at the camshaft position sensor engine wiring harness connector to the camshaft position sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Camshaft position sensor circuit pin to pin short

Solution: S00000692

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the camshaft position sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the camshaft position sensor SIGNAL pin of the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Camshaft gear is damaged

Solution: S00003976

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the camshaft tone wheel for defects.

Refer to Procedure 001-013

Specification

  • If any damage or defects to the tone wheel or gear are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the camshaft gear.

Refer to Procedure 001-013

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 784 | SPN: 1590 | FMI: 2
Adaptive Cruise Control Mode - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Malfunctioning adaptive cruise control circuit (If equipped)
  3. Malfunctioning adaptive cruise control circuit (If equipped)
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000699

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Anti-Lock Braking: 3488, 4215
  • Transmission: 3328, 3418, 5297, 5298, 6724

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Malfunctioning adaptive cruise control circuit (If equipped)

Solution: S00000701

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the vehicle for installed adaptive cruise control hardware.

Specification

  • If adaptive cruise control hardware is not installed on the vehicle, then use the recommended Cummins® electronic service tool or equivalent to disable the Adaptive Cruise feature.
  • If adaptive cruise control hardware has been installed on the vehicle, then proceed to the Linked Solutions section.

Linked Solutions

Click on the link below:

  • Malfunctioning adaptive cruise control circuit (If equipped)

Refer to S00001082

Repair

  • Adjust the features and parameters to the correct settings.

Refer to Procedure 019-078

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Malfunctioning adaptive cruise control circuit (If equipped)

Solution: S00001082

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Connect the INLINE™ data link adapter to the vehicle SAE J1939 data link diagnostic connector.
  • Attempt to communicate with the ECM.
  • Select INLINE™ J1939 ECM connection.
  • Verify recommended Cummins® electronic service tool or equivalent communication with the ECM.

Specification

  • If communication between the ECM and the recommended Cummins® electronic service tool or equivalent cannot be established, then reset the search to No Communication with the Cummins® Electronic Service Tool or Equivalent to ECM.

Linked Solutions

  • None

Repair

  • For communication error, determine the cause of the loss of communication between the ECM and the adaptive cruise control hardware.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 1117 | SPN: 3597 | FMI: 2
Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Battery power removed by battery disconnect switch
  2. Battery or battery cables are malfunctioning
  3. Battery load test
  4. ECM battery voltage check
  5. Keyswitch open circuit check
  6. Intermittent ground connection
  7. ECM calibration revision history check

1 - Battery power removed by battery disconnect switch

Solution: S00000706

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify that the battery disconnect switches are being used correctly.

The keyswitch must be turned OFF first for 90 seconds before any battery disconnect switches are turned OFF.

Specification

  • If the battery disconnect switches are not being used correctly, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Remind the operator how to correctly use the battery disconnect switches.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Battery load test

Solution: S00000669

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Disconnect the batteries from each other.
  • Connect a load tester separately to each battery.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.

Specification

  • For a 12 volt system, proceed to the Repair section if the battery voltage is below the following specification: 11 VDC
  • For a 24 volt system, proceed to the Repair section if the battery voltage is below the following specification: 22 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Charge or replace the batteries.

Refer to Procedure 013-007

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM battery voltage check

Solution: S00002091

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM power supply from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the ECM battery SUPPLY pin at the OEM wiring harness 4 pin connector and engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Keyswitch open circuit check

Solution: S00000530

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the keyswitch ignition post in the keyswitch assembly to keyswitch input SIGNAL pin of the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Intermittent ground connection

Solution: S00000707

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect all of the engine block, starter, alternator, chassis, and battery ground connections.
  • Visually inspect the ECM ground for damage, corrosion and loose connections.

Specification

  • If the ECM to cylinder block connection resistance is greater than 10 Ω, then a malfunctioning ground connection has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the ECM-to-ground connection.

Refer to Procedure 019-008

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 1239 | SPN: 2623 | FMI: 3
Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Accelerator pedal voltage check
  2. Accelerator pedal circuit check
  3. Accelerator pedal position sensor open circuit check
  4. Accelerator pedal position sensor circuit pin to pin short
  5. ECM calibration revision history check
  6. Accelerator pedal is malfunctioning

1 - Accelerator pedal voltage check

Solution: S00006534

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the accelerator pedal position 1 sensor SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Measure the voltage between the accelerator pedal position 2 sensor SUPPLY pin to the accelerator pedal position 2 sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Accelerator pedal circuit check

Refer to S00006535

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

1.1 - Accelerator pedal circuit check

Solution: S00006535

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the engine wiring harness connector 2 from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position 1 sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor SUPPLY pin at the engine wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 1 sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 1 sensor SIGNAL pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 2 sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 2 sensor SUPPLY pin at the engine wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 2 sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 2 sensor RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 2 sensor SIGNAL pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 2 sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2 - Accelerator pedal position sensor open circuit check

Solution: S00006528

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the engine wiring harness connector 2 from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position 1 sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor SUPPLY pin at the engine wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 1 sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 1 sensor SIGNAL pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Accelerator pedal position sensor circuit pin to pin short

Solution: S00006536

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the engine wiring harness connector 2 from the ECM.
  • Disconnect all components on the wiring circuit being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal 1 SIGNAL pin in the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the accelerator pedal 2 SIGNAL pin in the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Accelerator pedal is malfunctioning

Solution: S00001185

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning accelerator pedal has been detected.

Linked Solutions

  • None

Repair

  • Replace the accelerator pedal.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 1241 | SPN: 2623 | FMI: 4
Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Accelerator pedal voltage check
  2. Accelerator pedal circuit check
  3. Accelerator pedal position sensor open circuit check
  4. Accelerator pedal position sensor circuit pin to ground short
  5. Accelerator pedal position sensor circuit pin to pin short
  6. ECM calibration revision history check
  7. Accelerator pedal is malfunctioning

1 - Accelerator pedal voltage check

Solution: S00006534

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the accelerator pedal position 1 sensor SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Measure the voltage between the accelerator pedal position 2 sensor SUPPLY pin to the accelerator pedal position 2 sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Accelerator pedal circuit check

Refer to S00006535

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

1.1 - Accelerator pedal circuit check

Solution: S00006535

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the engine wiring harness connector 2 from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position 1 sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor SUPPLY pin at the engine wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 1 sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 1 sensor SIGNAL pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 2 sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 2 sensor SUPPLY pin at the engine wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 2 sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 2 sensor RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 2 sensor SIGNAL pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 2 sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2 - Accelerator pedal position sensor open circuit check

Solution: S00006528

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the engine wiring harness connector 2 from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position 1 sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor SUPPLY pin at the engine wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 1 sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 1 sensor SIGNAL pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Accelerator pedal position sensor circuit pin to ground short

Solution: S00006533

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the engine wiring harness connector 2 from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is less than the following specification: 100K Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Accelerator pedal position sensor circuit pin to pin short

Solution: S00006536

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the engine wiring harness connector 2 from the ECM.
  • Disconnect all components on the wiring circuit being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal 1 SIGNAL pin in the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the accelerator pedal 2 SIGNAL pin in the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Accelerator pedal is malfunctioning

Solution: S00001185

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning accelerator pedal has been detected.

Linked Solutions

  • None

Repair

  • Replace the accelerator pedal.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 1242 | SPN: 91 | FMI: 2
Accelerator Pedal or Lever Position Sensor 1 - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Accelerator pedal voltage check
  3. Accelerator pedal circuit check
  4. Accelerator pedal position sensor open circuit check
  5. Accelerator pedal position sensor circuit pin to pin short
  6. ECM calibration revision history check
  7. Accelerator pedal is malfunctioning

1 - Check for primary fault codes

Solution: S00000136

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Accelerator Pedal or Lever Position: 131, 132, 1239, 1241

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Accelerator pedal voltage check

Solution: S00006534

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the accelerator pedal position 1 sensor SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Measure the voltage between the accelerator pedal position 2 sensor SUPPLY pin to the accelerator pedal position 2 sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Accelerator pedal circuit check

Refer to S00006535

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Accelerator pedal circuit check

Solution: S00006535

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the engine wiring harness connector 2 from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position 1 sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor SUPPLY pin at the engine wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 1 sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 1 sensor SIGNAL pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 2 sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 2 sensor SUPPLY pin at the engine wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 2 sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 2 sensor RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 2 sensor SIGNAL pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 2 sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Accelerator pedal position sensor open circuit check

Solution: S00006528

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the engine wiring harness connector 2 from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position 1 sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor SUPPLY pin at the engine wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 1 sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 1 sensor SIGNAL pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Accelerator pedal position sensor circuit pin to pin short

Solution: S00006536

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the engine wiring harness connector 2 from the ECM.
  • Disconnect all components on the wiring circuit being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal 1 SIGNAL pin in the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the accelerator pedal 2 SIGNAL pin in the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Accelerator pedal is malfunctioning

Solution: S00001185

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning accelerator pedal has been detected.

Linked Solutions

  • None

Repair

  • Replace the accelerator pedal.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 1515 | SPN: 91 | FMI: 19
Accelerator Pedal Position 1 - Received Network Data in Error

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 1654 | SPN: 1323 | FMI: 31
Engine Misfire Cylinder 1 - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. Spark plug is damaged
  3. Ignition Coil Test
  4. Ignition control wiring harness open circuit check
  5. Ignition control wiring harness circuit pin to ground short
  6. Ignition control wiring harness circuit pin to pin short
  7. Ignition control module open circuit check
  8. Ignition control module circuit pin to ground short
  9. Ignition control module circuit pin to pin short
  10. Overhead component damaged or out of adjustment
  11. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001452

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Ignition: 6883, 6884, 6966, 6967, 6968, 6969, 6971, 6972, 7192

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Spark plug is damaged

Solution: S00003531

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove all of the spark plugs.

Refer to Procedure 013-016

  • Measure the spark plug gap.

Refer to Procedure 013-016

  • Check the spark plugs.

Refer to Service Bulletin 4383578

Specification

  • If the spark plugs do not meet specification, then reset the search to the correct symptom according to the service bulletin.
  • If the spark plug gap is incorrect, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Correct the spark plug gap.

Refer to Procedure 013-016

  • Replace the spark plug.

Refer to Procedure 013-016

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Ignition Coil Test

Solution: S00004217

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect ignition coil body for cracks.

Refer to Procedure 013-012

Refer to Service Bulletin 4383630

  • Perform the ignition coil test.

Refer to Procedure 013-012

Specification

  • If any damage is found, then proceed to the Repair section.
  • If no spark was observed during the coil test, then proceed to the Linked Solutions section.

Linked Solutions

  • Ignition control wiring harness open circuit check

Refer to S00005711

  • Ignition control wiring harness circuit pin to ground short

Refer to S00005713

  • Ignition control wiring harness circuit pin to pin short

Refer to S00005715

  • Ignition control module open circuit check

Refer to S00005712

  • Ignition control module circuit pin to ground short

Refer to S00005714

  • Ignition control module circuit pin to pin short

Refer to S00006731

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil pack.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3.1 - Ignition control wiring harness open circuit check

Solution: S00005711

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.2 - Ignition control wiring harness circuit pin to ground short

Solution: S00005713

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connector C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the charge voltage pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the secondary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the primary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.3 - Ignition control wiring harness circuit pin to pin short

Solution: S00005715

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control wiring harness charge voltage SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness secondary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness primary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.4 - Ignition control module open circuit check

Solution: S00005712

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the ignition control module C1 connector and the combustion detection SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the ignition control module C1 connector and the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the ignition control module C1 connector and the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module RETURN pin at the ignition control module C1 connector and the ignition control module RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the ignition control module C1 connector and the spark voltage SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.5 - Ignition control module circuit pin to ground short

Solution: S00005714

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.6 - Ignition control module circuit pin to pin short

Solution: S00006731

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Overhead component damaged or out of adjustment

Solution: S00008484

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

  • Adjust the overhead.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 1655 | SPN: 1324 | FMI: 31
Engine Misfire Cylinder 2 - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. Spark plug is damaged
  3. Ignition Coil Test
  4. Ignition control wiring harness open circuit check
  5. Ignition control wiring harness circuit pin to ground short
  6. Ignition control wiring harness circuit pin to pin short
  7. Ignition control module open circuit check
  8. Ignition control module circuit pin to ground short
  9. Ignition control module circuit pin to pin short
  10. Overhead component damaged or out of adjustment
  11. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001452

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Ignition: 6883, 6884, 6966, 6967, 6968, 6969, 6971, 6972, 7192

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Spark plug is damaged

Solution: S00003531

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove all of the spark plugs.

Refer to Procedure 013-016

  • Measure the spark plug gap.

Refer to Procedure 013-016

  • Check the spark plugs.

Refer to Service Bulletin 4383578

Specification

  • If the spark plugs do not meet specification, then reset the search to the correct symptom according to the service bulletin.
  • If the spark plug gap is incorrect, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Correct the spark plug gap.

Refer to Procedure 013-016

  • Replace the spark plug.

Refer to Procedure 013-016

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Ignition Coil Test

Solution: S00004217

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect ignition coil body for cracks.

Refer to Procedure 013-012

Refer to Service Bulletin 4383630

  • Perform the ignition coil test.

Refer to Procedure 013-012

Specification

  • If any damage is found, then proceed to the Repair section.
  • If no spark was observed during the coil test, then proceed to the Linked Solutions section.

Linked Solutions

  • Ignition control wiring harness open circuit check

Refer to S00005711

  • Ignition control wiring harness circuit pin to ground short

Refer to S00005713

  • Ignition control wiring harness circuit pin to pin short

Refer to S00005715

  • Ignition control module open circuit check

Refer to S00005712

  • Ignition control module circuit pin to ground short

Refer to S00005714

  • Ignition control module circuit pin to pin short

Refer to S00006731

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil pack.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3.1 - Ignition control wiring harness open circuit check

Solution: S00005711

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.2 - Ignition control wiring harness circuit pin to ground short

Solution: S00005713

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connector C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the charge voltage pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the secondary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the primary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.3 - Ignition control wiring harness circuit pin to pin short

Solution: S00005715

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control wiring harness charge voltage SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness secondary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness primary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.4 - Ignition control module open circuit check

Solution: S00005712

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the ignition control module C1 connector and the combustion detection SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the ignition control module C1 connector and the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the ignition control module C1 connector and the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module RETURN pin at the ignition control module C1 connector and the ignition control module RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the ignition control module C1 connector and the spark voltage SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.5 - Ignition control module circuit pin to ground short

Solution: S00005714

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.6 - Ignition control module circuit pin to pin short

Solution: S00006731

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Overhead component damaged or out of adjustment

Solution: S00008484

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

  • Adjust the overhead.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 1656 | SPN: 1325 | FMI: 31
Engine Misfire Cylinder 3 - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. Spark plug is damaged
  3. Ignition Coil Test
  4. Ignition control wiring harness open circuit check
  5. Ignition control wiring harness circuit pin to ground short
  6. Ignition control wiring harness circuit pin to pin short
  7. Ignition control module open circuit check
  8. Ignition control module circuit pin to ground short
  9. Ignition control module circuit pin to pin short
  10. Overhead component damaged or out of adjustment
  11. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001452

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Ignition: 6883, 6884, 6966, 6967, 6968, 6969, 6971, 6972, 7192

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Spark plug is damaged

Solution: S00003531

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove all of the spark plugs.

Refer to Procedure 013-016

  • Measure the spark plug gap.

Refer to Procedure 013-016

  • Check the spark plugs.

Refer to Service Bulletin 4383578

Specification

  • If the spark plugs do not meet specification, then reset the search to the correct symptom according to the service bulletin.
  • If the spark plug gap is incorrect, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Correct the spark plug gap.

Refer to Procedure 013-016

  • Replace the spark plug.

Refer to Procedure 013-016

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Ignition Coil Test

Solution: S00004217

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect ignition coil body for cracks.

Refer to Procedure 013-012

Refer to Service Bulletin 4383630

  • Perform the ignition coil test.

Refer to Procedure 013-012

Specification

  • If any damage is found, then proceed to the Repair section.
  • If no spark was observed during the coil test, then proceed to the Linked Solutions section.

Linked Solutions

  • Ignition control wiring harness open circuit check

Refer to S00005711

  • Ignition control wiring harness circuit pin to ground short

Refer to S00005713

  • Ignition control wiring harness circuit pin to pin short

Refer to S00005715

  • Ignition control module open circuit check

Refer to S00005712

  • Ignition control module circuit pin to ground short

Refer to S00005714

  • Ignition control module circuit pin to pin short

Refer to S00006731

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil pack.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3.1 - Ignition control wiring harness open circuit check

Solution: S00005711

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.2 - Ignition control wiring harness circuit pin to ground short

Solution: S00005713

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connector C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the charge voltage pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the secondary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the primary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.3 - Ignition control wiring harness circuit pin to pin short

Solution: S00005715

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control wiring harness charge voltage SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness secondary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness primary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.4 - Ignition control module open circuit check

Solution: S00005712

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the ignition control module C1 connector and the combustion detection SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the ignition control module C1 connector and the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the ignition control module C1 connector and the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module RETURN pin at the ignition control module C1 connector and the ignition control module RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the ignition control module C1 connector and the spark voltage SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.5 - Ignition control module circuit pin to ground short

Solution: S00005714

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.6 - Ignition control module circuit pin to pin short

Solution: S00006731

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Overhead component damaged or out of adjustment

Solution: S00008484

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

  • Adjust the overhead.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 1657 | SPN: 1326 | FMI: 31
Engine Misfire Cylinder 4 - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. Spark plug is damaged
  3. Ignition Coil Test
  4. Ignition control wiring harness open circuit check
  5. Ignition control wiring harness circuit pin to ground short
  6. Ignition control wiring harness circuit pin to pin short
  7. Ignition control module open circuit check
  8. Ignition control module circuit pin to ground short
  9. Ignition control module circuit pin to pin short
  10. Overhead component damaged or out of adjustment
  11. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001452

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Ignition: 6883, 6884, 6966, 6967, 6968, 6969, 6971, 6972, 7192

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Spark plug is damaged

Solution: S00003531

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove all of the spark plugs.

Refer to Procedure 013-016

  • Measure the spark plug gap.

Refer to Procedure 013-016

  • Check the spark plugs.

Refer to Service Bulletin 4383578

Specification

  • If the spark plugs do not meet specification, then reset the search to the correct symptom according to the service bulletin.
  • If the spark plug gap is incorrect, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Correct the spark plug gap.

Refer to Procedure 013-016

  • Replace the spark plug.

Refer to Procedure 013-016

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Ignition Coil Test

Solution: S00004217

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect ignition coil body for cracks.

Refer to Procedure 013-012

Refer to Service Bulletin 4383630

  • Perform the ignition coil test.

Refer to Procedure 013-012

Specification

  • If any damage is found, then proceed to the Repair section.
  • If no spark was observed during the coil test, then proceed to the Linked Solutions section.

Linked Solutions

  • Ignition control wiring harness open circuit check

Refer to S00005711

  • Ignition control wiring harness circuit pin to ground short

Refer to S00005713

  • Ignition control wiring harness circuit pin to pin short

Refer to S00005715

  • Ignition control module open circuit check

Refer to S00005712

  • Ignition control module circuit pin to ground short

Refer to S00005714

  • Ignition control module circuit pin to pin short

Refer to S00006731

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil pack.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3.1 - Ignition control wiring harness open circuit check

Solution: S00005711

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.2 - Ignition control wiring harness circuit pin to ground short

Solution: S00005713

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connector C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the charge voltage pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the secondary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the primary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.3 - Ignition control wiring harness circuit pin to pin short

Solution: S00005715

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control wiring harness charge voltage SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness secondary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness primary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.4 - Ignition control module open circuit check

Solution: S00005712

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the ignition control module C1 connector and the combustion detection SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the ignition control module C1 connector and the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the ignition control module C1 connector and the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module RETURN pin at the ignition control module C1 connector and the ignition control module RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the ignition control module C1 connector and the spark voltage SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.5 - Ignition control module circuit pin to ground short

Solution: S00005714

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.6 - Ignition control module circuit pin to pin short

Solution: S00006731

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Overhead component damaged or out of adjustment

Solution: S00008484

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

  • Adjust the overhead.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 1658 | SPN: 1327 | FMI: 31
Engine Misfire Cylinder 5 - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. Spark plug is damaged
  3. Ignition Coil Test
  4. Ignition control wiring harness open circuit check
  5. Ignition control wiring harness circuit pin to ground short
  6. Ignition control wiring harness circuit pin to pin short
  7. Ignition control module open circuit check
  8. Ignition control module circuit pin to ground short
  9. Ignition control module circuit pin to pin short
  10. Overhead component damaged or out of adjustment
  11. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001452

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Ignition: 6883, 6884, 6966, 6967, 6968, 6969, 6971, 6972, 7192

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Spark plug is damaged

Solution: S00003531

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove all of the spark plugs.

Refer to Procedure 013-016

  • Measure the spark plug gap.

Refer to Procedure 013-016

  • Check the spark plugs.

Refer to Service Bulletin 4383578

Specification

  • If the spark plugs do not meet specification, then reset the search to the correct symptom according to the service bulletin.
  • If the spark plug gap is incorrect, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Correct the spark plug gap.

Refer to Procedure 013-016

  • Replace the spark plug.

Refer to Procedure 013-016

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Ignition Coil Test

Solution: S00004217

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect ignition coil body for cracks.

Refer to Procedure 013-012

Refer to Service Bulletin 4383630

  • Perform the ignition coil test.

Refer to Procedure 013-012

Specification

  • If any damage is found, then proceed to the Repair section.
  • If no spark was observed during the coil test, then proceed to the Linked Solutions section.

Linked Solutions

  • Ignition control wiring harness open circuit check

Refer to S00005711

  • Ignition control wiring harness circuit pin to ground short

Refer to S00005713

  • Ignition control wiring harness circuit pin to pin short

Refer to S00005715

  • Ignition control module open circuit check

Refer to S00005712

  • Ignition control module circuit pin to ground short

Refer to S00005714

  • Ignition control module circuit pin to pin short

Refer to S00006731

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil pack.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3.1 - Ignition control wiring harness open circuit check

Solution: S00005711

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.2 - Ignition control wiring harness circuit pin to ground short

Solution: S00005713

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connector C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the charge voltage pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the secondary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the primary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.3 - Ignition control wiring harness circuit pin to pin short

Solution: S00005715

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control wiring harness charge voltage SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness secondary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness primary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.4 - Ignition control module open circuit check

Solution: S00005712

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the ignition control module C1 connector and the combustion detection SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the ignition control module C1 connector and the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the ignition control module C1 connector and the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module RETURN pin at the ignition control module C1 connector and the ignition control module RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the ignition control module C1 connector and the spark voltage SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.5 - Ignition control module circuit pin to ground short

Solution: S00005714

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.6 - Ignition control module circuit pin to pin short

Solution: S00006731

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Overhead component damaged or out of adjustment

Solution: S00008484

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

  • Adjust the overhead.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 1659 | SPN: 1328 | FMI: 31
Engine Misfire Cylinder 6 - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. Spark plug is damaged
  3. Ignition Coil Test
  4. Ignition control wiring harness open circuit check
  5. Ignition control wiring harness circuit pin to ground short
  6. Ignition control wiring harness circuit pin to pin short
  7. Ignition control module open circuit check
  8. Ignition control module circuit pin to ground short
  9. Ignition control module circuit pin to pin short
  10. Overhead component damaged or out of adjustment
  11. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001452

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Ignition: 6883, 6884, 6966, 6967, 6968, 6969, 6971, 6972, 7192

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Spark plug is damaged

Solution: S00003531

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove all of the spark plugs.

Refer to Procedure 013-016

  • Measure the spark plug gap.

Refer to Procedure 013-016

  • Check the spark plugs.

Refer to Service Bulletin 4383578

Specification

  • If the spark plugs do not meet specification, then reset the search to the correct symptom according to the service bulletin.
  • If the spark plug gap is incorrect, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Correct the spark plug gap.

Refer to Procedure 013-016

  • Replace the spark plug.

Refer to Procedure 013-016

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Ignition Coil Test

Solution: S00004217

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect ignition coil body for cracks.

Refer to Procedure 013-012

Refer to Service Bulletin 4383630

  • Perform the ignition coil test.

Refer to Procedure 013-012

Specification

  • If any damage is found, then proceed to the Repair section.
  • If no spark was observed during the coil test, then proceed to the Linked Solutions section.

Linked Solutions

  • Ignition control wiring harness open circuit check

Refer to S00005711

  • Ignition control wiring harness circuit pin to ground short

Refer to S00005713

  • Ignition control wiring harness circuit pin to pin short

Refer to S00005715

  • Ignition control module open circuit check

Refer to S00005712

  • Ignition control module circuit pin to ground short

Refer to S00005714

  • Ignition control module circuit pin to pin short

Refer to S00006731

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil pack.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3.1 - Ignition control wiring harness open circuit check

Solution: S00005711

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.2 - Ignition control wiring harness circuit pin to ground short

Solution: S00005713

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connector C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the charge voltage pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the secondary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the primary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.3 - Ignition control wiring harness circuit pin to pin short

Solution: S00005715

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control wiring harness charge voltage SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness secondary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness primary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.4 - Ignition control module open circuit check

Solution: S00005712

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the ignition control module C1 connector and the combustion detection SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the ignition control module C1 connector and the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the ignition control module C1 connector and the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module RETURN pin at the ignition control module C1 connector and the ignition control module RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the ignition control module C1 connector and the spark voltage SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.5 - Ignition control module circuit pin to ground short

Solution: S00005714

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.6 - Ignition control module circuit pin to pin short

Solution: S00006731

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Overhead component damaged or out of adjustment

Solution: S00008484

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

  • Adjust the overhead.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 1665 | SPN: 3241 | FMI: 4
Aftertreatment Exhaust Gas Temperature 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Aftertreatment exhaust gas temperature sensor resistance check
  2. Aftertreatment exhaust gas temperature sensor circuit pin to ground short
  3. Aftertreatment exhaust gas temperature sensor circuit pin to pin short
  4. ECM calibration revision history check
  5. Aftertreatment exhaust gas temperature sensor is malfunctioning

1 - Aftertreatment exhaust gas temperature sensor resistance check

Solution: S00004593

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the appropriate aftertreatment exhaust gas temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the aftertreatment exhaust gas temperature sensor.

Refer to Procedure 019-449

Specification

  • If the resistance is not within specification, then a malfunctioning aftertreatment exhaust gas temperature sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment exhaust gas temperature sensor circuit pin to ground short

Solution: S00004343

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the appropriate aftertreatment exhaust gas temperature sensor from the OEM wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the aftertreatment exhaust gas temperature sensor RETURN pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, integrated wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment exhaust gas temperature sensor circuit pin to pin short

Solution: S00004340

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the appropriate aftertreatment exhaust gas temperature sensor from the OEM wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the aftertreatment exhaust gas temperature sensor RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment exhaust gas temperature sensor is malfunctioning

Solution: S00006403

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this symptom have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment exhaust gas temperature sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 1666 | SPN: 3241 | FMI: 3
Aftertreatment Exhaust Gas Temperature 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Aftertreatment exhaust gas temperature sensor resistance check
  2. Aftertreatment exhaust gas temperature sensor open circuit check
  3. Aftertreatment exhaust gas temperature sensor circuit pin to pin short
  4. ECM calibration revision history check
  5. Aftertreatment exhaust gas temperature sensor is malfunctioning

1 - Aftertreatment exhaust gas temperature sensor resistance check

Solution: S00004593

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the appropriate aftertreatment exhaust gas temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the aftertreatment exhaust gas temperature sensor.

Refer to Procedure 019-449

Specification

  • If the resistance is not within specification, then a malfunctioning aftertreatment exhaust gas temperature sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment exhaust gas temperature sensor open circuit check

Solution: S00004342

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the appropriate aftertreatment exhaust gas temperature sensor from the OEM wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment exhaust gas temperature sensor SIGNAL pin at the aftertreatment exhaust gas temperature sensor OEM wiring harness connector and the aftertreatment exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the aftertreatment exhaust gas temperature sensor RETURN pin at the aftertreatment exhaust gas temperature sensor OEM wiring harness connector and the aftertreatment exhaust gas temperature sensor RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment exhaust gas temperature sensor circuit pin to pin short

Solution: S00004340

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the appropriate aftertreatment exhaust gas temperature sensor from the OEM wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the aftertreatment exhaust gas temperature sensor RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment exhaust gas temperature sensor is malfunctioning

Solution: S00006403

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this symptom have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment exhaust gas temperature sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 1674 | SPN: 3249 | FMI: 4
Aftertreatment Exhaust Gas Temperature 2 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Aftertreatment exhaust gas temperature sensor resistance check
  2. Aftertreatment exhaust gas temperature sensor circuit pin to ground short
  3. Aftertreatment exhaust gas temperature sensor circuit pin to pin short
  4. ECM calibration revision history check
  5. Aftertreatment exhaust gas temperature sensor is malfunctioning

1 - Aftertreatment exhaust gas temperature sensor resistance check

Solution: S00004593

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the appropriate aftertreatment exhaust gas temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the aftertreatment exhaust gas temperature sensor.

Refer to Procedure 019-449

Specification

  • If the resistance is not within specification, then a malfunctioning aftertreatment exhaust gas temperature sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment exhaust gas temperature sensor circuit pin to ground short

Solution: S00004343

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the appropriate aftertreatment exhaust gas temperature sensor from the OEM wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the aftertreatment exhaust gas temperature sensor RETURN pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, integrated wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment exhaust gas temperature sensor circuit pin to pin short

Solution: S00004340

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the appropriate aftertreatment exhaust gas temperature sensor from the OEM wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the aftertreatment exhaust gas temperature sensor RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment exhaust gas temperature sensor is malfunctioning

Solution: S00006403

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this symptom have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment exhaust gas temperature sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 1675 | SPN: 3249 | FMI: 3
Aftertreatment Exhaust Gas Temperature 2 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Aftertreatment exhaust gas temperature sensor resistance check
  2. Aftertreatment exhaust gas temperature sensor open circuit check
  3. Aftertreatment exhaust gas temperature sensor circuit pin to pin short
  4. ECM calibration revision history check
  5. Aftertreatment exhaust gas temperature sensor is malfunctioning

1 - Aftertreatment exhaust gas temperature sensor resistance check

Solution: S00004593

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the appropriate aftertreatment exhaust gas temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the aftertreatment exhaust gas temperature sensor.

Refer to Procedure 019-449

Specification

  • If the resistance is not within specification, then a malfunctioning aftertreatment exhaust gas temperature sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment exhaust gas temperature sensor open circuit check

Solution: S00004342

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the appropriate aftertreatment exhaust gas temperature sensor from the OEM wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment exhaust gas temperature sensor SIGNAL pin at the aftertreatment exhaust gas temperature sensor OEM wiring harness connector and the aftertreatment exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the aftertreatment exhaust gas temperature sensor RETURN pin at the aftertreatment exhaust gas temperature sensor OEM wiring harness connector and the aftertreatment exhaust gas temperature sensor RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment exhaust gas temperature sensor circuit pin to pin short

Solution: S00004340

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the appropriate aftertreatment exhaust gas temperature sensor from the OEM wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment exhaust gas temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the aftertreatment exhaust gas temperature sensor RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment exhaust gas temperature sensor is malfunctioning

Solution: S00006403

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this symptom have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment exhaust gas temperature sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 1691 | SPN: 5298 | FMI: 18
Aftertreatment 1 Diesel Oxidation Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Exhaust catalyst is malfunctioning
  2. ECM calibration revision history check

1 - Exhaust catalyst is malfunctioning

Solution: S00004334

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the exhaust catalyst for damage or contamination.

Refer to Procedure 011-078

Specification

  • If the exhaust catalyst does not meet specification, then a malfunctioning exhaust catalyst has been detected.

Linked Solutions

  • None

Repair

  • Locate and correct the source of the oil contamination.
  • Replace the exhaust catalyst.

Refer to Procedure 011-078

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 1695 | SPN: 3513 | FMI: 3
Sensor Supply 5 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. ECM sensor supply 5 circuit pin to pin short
  2. ECM calibration revision history check

1 - ECM sensor supply 5 circuit pin to pin short

Solution: S00004178

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the remote accelerator pedal or lever from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance and check for a short circuit between the 5-VDC SUPPLY pin and all other pins in the OEM wiring harness ECM connector.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification:

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 1696 | SPN: 3513 | FMI: 4
Sensor Supply 5 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. ECM sensor supply 5 voltage below normal
  2. ECM sensor supply 5 circuit pin to pin short
  3. ECM calibration revision history check

1 - ECM sensor supply 5 voltage below normal

Solution: S00004794

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Perform the following actions one at a time:
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the remote throttle from the OEM wiring harness.

Specification

  • If the fault code goes inactive when a component is disconnected, then a malfunctioning sensor supply component has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace engine coolant level sensor.

Refer to OEM Service Manual

  • Replace the accelerator pedal position sensor.

Refer to OEM Service Manual

  • Replace the remote accelerator pedal assembly.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM sensor supply 5 circuit pin to pin short

Solution: S00004178

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the remote accelerator pedal or lever from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance and check for a short circuit between the 5-VDC SUPPLY pin and all other pins in the OEM wiring harness ECM connector.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification:

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 1718 | SPN: 1322 | FMI: 31
Engine Misfire for Multiple Cylinders - Condition Exists

Troubleshooting Summary

  1. Fuel pressure check
  2. Check for primary fault codes
  3. EGR system leak or restriction
  4. EGR cooler is internally leaking
  5. Spark plug is damaged
  6. Ignition Coil Test
  7. Ignition control wiring harness open circuit check
  8. Ignition control wiring harness circuit pin to ground short
  9. Ignition control wiring harness circuit pin to pin short
  10. Ignition control module open circuit check
  11. Ignition control module circuit pin to ground short
  12. Ignition control module circuit pin to pin short
  13. Overhead component damaged or out of adjustment
  14. ECM calibration revision history check

1 - Fuel pressure check

Solution: S00004450

Verification

Conditions

  • Turn keyswitch OFF.
  • Verify all fuel shutoff valves are in the open position.

Action

  • Verify the fuel gauge is working properly.

Refer to OEM Service Manual

  • Verify the fuel tank pressure meets specification.

Refer to OEM Service Manual

  • Verify the fuel regulator intake pressure meets specifications.

Refer to Procedure 005-061

Specification

  • If any of the checks are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Add fuel if needed.

Refer to OEM Service Manual

  • For an OEM issue: Contact the OEM for further repair instructions.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Check for primary fault codes

Solution: S00001452

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Ignition: 6883, 6884, 6966, 6967, 6968, 6969, 6971, 6972, 7192

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

3 - EGR system leak or restriction

Solution: S00005702

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the EGR crossover tube.

Refer to Procedure 011-070

  • Visually inspect the EGR connection tube or crossover tube for traces of coolant.

Specification

  • If leaks or damage are present in the EGR system, then proceed to the Linked Solutions section.

Linked Solutions

  • EGR cooler is internally leaking

Refer to S00005827

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - EGR cooler is internally leaking

Solution: S00005827

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the EGR cooler pressure test.

Refer to Procedure 011-019

Specification

  • If the EGR cooler pressure test does not meet specification, then a malfunctioning EGR cooler has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace damaged components.
  • Replace the EGR cooler.

Refer to Procedure 011-019

  • Replace the spark plugs.

Refer to Procedure 013-016

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Spark plug is damaged

Solution: S00003531

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove all of the spark plugs.

Refer to Procedure 013-016

  • Measure the spark plug gap.

Refer to Procedure 013-016

  • Check the spark plugs.

Refer to Service Bulletin 4383578

Specification

  • If the spark plugs do not meet specification, then reset the search to the correct symptom according to the service bulletin.
  • If the spark plug gap is incorrect, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Correct the spark plug gap.

Refer to Procedure 013-016

  • Replace the spark plug.

Refer to Procedure 013-016

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Ignition Coil Test

Solution: S00004217

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect ignition coil body for cracks.

Refer to Procedure 013-012

Refer to Service Bulletin 4383630

  • Perform the ignition coil test.

Refer to Procedure 013-012

Specification

  • If any damage is found, then proceed to the Repair section.
  • If no spark was observed during the coil test, then proceed to the Linked Solutions section.

Linked Solutions

  • Ignition control wiring harness open circuit check

Refer to S00005711

  • Ignition control wiring harness circuit pin to ground short

Refer to S00005713

  • Ignition control wiring harness circuit pin to pin short

Refer to S00005715

  • Ignition control module open circuit check

Refer to S00005712

  • Ignition control module circuit pin to ground short

Refer to S00005714

  • Ignition control module circuit pin to pin short

Refer to S00006731

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil pack.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5.1 - Ignition control wiring harness open circuit check

Solution: S00005711

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.2 - Ignition control wiring harness circuit pin to ground short

Solution: S00005713

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connector C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the charge voltage pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the secondary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the primary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.3 - Ignition control wiring harness circuit pin to pin short

Solution: S00005715

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control wiring harness charge voltage SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness secondary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness primary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.4 - Ignition control module open circuit check

Solution: S00005712

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the ignition control module C1 connector and the combustion detection SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the ignition control module C1 connector and the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the ignition control module C1 connector and the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module RETURN pin at the ignition control module C1 connector and the ignition control module RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the ignition control module C1 connector and the spark voltage SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.5 - Ignition control module circuit pin to ground short

Solution: S00005714

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.6 - Ignition control module circuit pin to pin short

Solution: S00006731

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - Overhead component damaged or out of adjustment

Solution: S00008484

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

  • Adjust the overhead.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 1827 | SPN: 1390 | FMI: 3
Engine Fuel Valve 1 Intake Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Fuel outlet pressure sensor voltage check
  3. Fuel outlet pressure sensor voltage check at the ECM
  4. Fuel outlet pressure sensor circuit response
  5. Fuel outlet pressure sensor circuit response at the ECM
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002464

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Fuel outlet pressure sensor voltage check

Solution: S00004321

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel outlet pressure/temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the fuel outlet pressure sensor SUPPLY pin and the fuel outlet pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75-5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75-5.25 VDC

Linked Solutions

  • Fuel outlet pressure sensor voltage check at the ECM

Refer to S00004322

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Fuel outlet pressure sensor voltage check at the ECM

Solution: S00004322

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel outlet pressure/temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the fuel outlet pressure sensor SUPPLY pin and the fuel outlet pressure sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75-5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75-5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Fuel outlet pressure sensor circuit response

Solution: S00004696

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel outlet pressure/temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning fuel outlet pressure sensor has been detected if the following fault code became active with the sensor disconnected: 1828

Linked Solutions

  • None

Repair

  • Replace the fuel outlet pressure/temperature sensor.

Refer to Procedure 019-153

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel outlet pressure sensor circuit response at the ECM

Solution: S00003138

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 1828
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 1828

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 1828 | SPN: 1390 | FMI: 4
Engine Fuel Valve 1 Intake Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Check for primary fault codes
  3. Fuel outlet pressure sensor voltage check
  4. Fuel outlet pressure sensor voltage check at the ECM
  5. Fuel outlet pressure sensor circuit response
  6. Fuel outlet pressure sensor circuit response at the ECM
  7. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00006259

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Check for primary fault codes

Solution: S00002464

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

3 - Fuel outlet pressure sensor voltage check

Solution: S00004321

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel outlet pressure/temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the fuel outlet pressure sensor SUPPLY pin and the fuel outlet pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75-5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75-5.25 VDC

Linked Solutions

  • Fuel outlet pressure sensor voltage check at the ECM

Refer to S00004322

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3.1 - Fuel outlet pressure sensor voltage check at the ECM

Solution: S00004322

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel outlet pressure/temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the fuel outlet pressure sensor SUPPLY pin and the fuel outlet pressure sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75-5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75-5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Fuel outlet pressure sensor circuit response

Solution: S00004697

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel outlet pressure/temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the fuel outlet pressure sensor SUPPLY pin and the fuel outlet pressure sensor SIGNAL pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning fuel outlet pressure sensor has been detected if the following fault code became active with the jumper wire in place: 1827

Linked Solutions

  • None

Repair

  • Replace the fuel outlet pressure/temperature sensor.

Refer to Procedure 019-153

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Fuel outlet pressure sensor circuit response at the ECM

Solution: S00004367

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the fuel outlet pressure sensor SUPPLY pin and the fuel outlet pressure sensor SIGNAL pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 1827
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 1827

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 1839 | SPN: 159 | FMI: 3
Gas Supply (Regulated) Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Fuel inlet pressure sensor voltage check
  3. Fuel inlet pressure sensor voltage check at the ECM
  4. Fuel inlet pressure sensor circuit response
  5. Fuel inlet pressure sensor circuit response at the ECM
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00006259

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Fuel inlet pressure sensor voltage check

Solution: S00006273

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel inlet pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the fuel inlet pressure sensor SUPPLY pin and the fuel inlet pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Fuel inlet pressure sensor voltage check at the ECM

Refer to S00006274

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Fuel inlet pressure sensor voltage check at the ECM

Solution: S00006274

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the appropriate ECM.

Action

  • Turn keyswitch ON.
  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the fuel inlet pressure sensor SUPPLY pin and the fuel inlet pressure sensor RETURN pin at the ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-031

  • Replace the ECM.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Fuel inlet pressure sensor circuit response

Solution: S00004303

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel inlet pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning fuel inlet pressure sensor has been detected if the following fault code became active with the sensor disconnected: 1841

Linked Solutions

  • None

Repair

  • Replace the fuel inlet pressure sensor.

Refer to Procedure 019-188

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel inlet pressure sensor circuit response at the ECM

Solution: S00004543

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 1841
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 1841

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 1841 | SPN: 159 | FMI: 4
Gas Supply (Regulated) Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Fuel inlet pressure sensor voltage check
  3. Fuel inlet pressure sensor voltage check at the ECM
  4. Fuel inlet pressure sensor circuit response
  5. Fuel inlet pressure sensor circuit response at the ECM
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00006259

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Fuel inlet pressure sensor voltage check

Solution: S00006273

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel inlet pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the fuel inlet pressure sensor SUPPLY pin and the fuel inlet pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Fuel inlet pressure sensor voltage check at the ECM

Refer to S00006274

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Fuel inlet pressure sensor voltage check at the ECM

Solution: S00006274

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the appropriate ECM.

Action

  • Turn keyswitch ON.
  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the fuel inlet pressure sensor SUPPLY pin and the fuel inlet pressure sensor RETURN pin at the ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-031

  • Replace the ECM.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Fuel inlet pressure sensor circuit response

Solution: S00004304

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel inlet pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the fuel inlet pressure sensor SUPPLY pin and the fuel inlet pressure sensor SIGNAL pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning fuel inlet pressure sensor has been detected if the following fault code became active with the jumper wire in place: 1839

Linked Solutions

  • None

Repair

  • Replace the fuel inlet pressure sensor.

Refer to Procedure 019-188

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel inlet pressure sensor circuit response at the ECM

Solution: S00004544

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the fuel inlet pressure sensor SUPPLY pin and the fuel inlet pressure sensor SIGNAL pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 1839
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 1839

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 1843 | SPN: 101 | FMI: 3
Crankcase Pressure Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Crankcase pressure sensor voltage check
  3. Crankcase pressure sensor voltage check at the ECM
  4. Crankcase pressure sensor circuit response
  5. Crankcase pressure sensor circuit response check at the ECM

1 - Check for primary fault codes

Solution: S00000899

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Crankcase pressure sensor voltage check

Solution: S00000977

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the crankcase pressure sensor SUPPLY pin and the crankcase pressure sensor RETURN pin at the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Crankcase pressure sensor voltage check at the ECM

Refer to S00000978

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Crankcase pressure sensor voltage check at the ECM

Solution: S00000978

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the crankcase pressure sensor SUPPLY pin and the crankcase pressure sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Crankcase pressure sensor circuit response

Solution: S00000409

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning crankcase pressure sensor has been detected if the following fault code became active with the sensor disconnected: 1844

Linked Solutions

  • None

Repair

  • Replace crankcase pressure sensor.

Refer to Procedure 019-445

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Crankcase pressure sensor circuit response check at the ECM

Solution: S00001175

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 1844
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 1844

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 15-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 1844 | SPN: 101 | FMI: 4
Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Crankcase pressure sensor voltage check
  3. Crankcase pressure sensor voltage check at the ECM
  4. Crankcase pressure sensor circuit response
  5. Crankcase pressure sensor circuit response check at the ECM

1 - Check for primary fault codes

Solution: S00000899

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Crankcase pressure sensor voltage check

Solution: S00000977

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the crankcase pressure sensor SUPPLY pin and the crankcase pressure sensor RETURN pin at the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Crankcase pressure sensor voltage check at the ECM

Refer to S00000978

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Crankcase pressure sensor voltage check at the ECM

Solution: S00000978

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the crankcase pressure sensor SUPPLY pin and the crankcase pressure sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Crankcase pressure sensor circuit response

Solution: S00000410

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the crankcase pressure sensor SUPPLY pin and the crankcase pressure sensor SIGNAL pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning crankcase pressure sensor has been detected if the following fault code became active with the jumper wire in place: 1843

Linked Solutions

  • None

Repair

  • Replace crankcase pressure sensor.

Refer to Procedure 019-445

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Crankcase pressure sensor circuit response check at the ECM

Solution: S00001176

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the crankcase pressure sensor SUPPLY pin and the crankcase pressure sensor SIGNAL pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 1843
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 1843

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.
  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 15-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 1855 | SPN: 2659 | FMI: 16
EGR Mass Flow - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. EGR differential pressure sensor stuck in-range
  2. Exhaust leak visual check
  3. ECM calibration revision history check
  4. EGR valve is malfunctioning

1 - EGR differential pressure sensor stuck in-range

Solution: S00004301

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Specification

  • A malfunctioning EGR differential pressure sensor has been detected if the reading is not within the following specification: 0 ± 1 kPa [0 ± 0.30 in Hg]

Linked Solutions

  • None

Repair

  • Replace the EGR differential pressure sensor.

Refer to Procedure 019-370

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Exhaust leak visual check

Solution: S00009448

Verification

Conditions

  • Turn keyswitch ON.
  • Engine running at idle.

Action

  • Visually inspect for leaks from the turbocharger to exhaust manifold.
  • Visually inspect for loose or broken mounting hardware or damaged connection gasket.
  • Visually inspect for leaks in the exhaust manifold to head.
  • Visually inspect for leaks from the EGR components.
  • Visually inspect the exhaust piping for leaks, cracks, and loose connections.

Specification

  • If there is any damage or leaks found in the exhaust system, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the leaking components.

Refer to Procedure 011-007

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - EGR valve is malfunctioning

Solution: S00004389

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

If the EGR valve has been replaced within the last 90 days, follow your technical escalation process PRIOR to performing any of the repair actions listed below:

  • Replace the EGR valve.

Refer to Procedure 011-022

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 1856 | SPN: 2659 | FMI: 18
EGR Mass Flow - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. EGR differential pressure sensor circuit response
  3. Plugged EGR differential pressure sensor supply ports
  4. EGR valve is malfunctioning
  5. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002339

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • EGR differential pressure: 1866

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - EGR differential pressure sensor circuit response

Solution: S00004357

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning EGR differential pressure sensor has been detected if the following fault code is active: 2274

Linked Solutions

  • None

Repair

  • Replace the EGR differential pressure sensor.

Refer to Procedure 019-370

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Plugged EGR differential pressure sensor supply ports

Solution: S00004872

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the EGR differential pressure sensor flow port cross-drillings for blockage.

Refer to Procedure 019-370

  • Visually inspect the exhaust gas entrance ports for blockage.

Specification

  • If debris is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean the EGR differential pressure ports.

Refer to Procedure 005-009

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - EGR valve is malfunctioning

Solution: S00004485

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the EGR valve.
  • Visually inspect the EGR valve.

Refer to Procedure 011-022

Specification

  • If the EGR valve is restricted, then clear the restriction from the EGR valve.
  • If the EGR valve restriction cannot be cleared, then a malfunctioning EGR valve has been detected.

Linked Solutions

  • None

Repair

  • Clean or replace the EGR valve.

Refer to Procedure 011-022

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 1858 | SPN: 3217 | FMI: 3
Aftertreatment Intake Oxygen Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Aftertreatment intake oxygen sensor heater resistance check
  2. Aftertreatment intake oxygen sensor open circuit check
  3. Aftertreatment intake oxygen sensor circuit pin to pin short
  4. ECM calibration revision history check
  5. Aftertreatment intake oxygen sensor is malfunctioning

1 - Aftertreatment intake oxygen sensor heater resistance check

Solution: S00004153

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake oxygen sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the aftertreatment intake oxygen sensor.

Refer to Procedure 019-100

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not within specification, then a malfunctioning aftertreatment intake oxygen sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake oxygen sensor.

Refer to Procedure 019-100

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment intake oxygen sensor open circuit check

Solution: S00004820

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness ECM connector 1 and 2.
  • Disconnect the aftertreatment intake oxygen sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment intake oxygen sensor SIGNAL pin at the aftertreatment intake oxygen sensor engine wiring harness connector and the aftertreatment intake oxygen sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the aftertreatment intake oxygen sensor RETURN pin at the aftertreatment intake oxygen sensor engine wiring harness connector and the aftertreatment intake oxygen sensor RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the aftertreatment intake oxygen sensor heater SUPPLY pin at the aftertreatment intake oxygen sensor connector of the engine wiring harness and the aftertreatment intake oxygen sensor heater SUPPLY pin at the engine wiring harness ECM connector.
  • Measure the resistance between the aftertreatment intake oxygen sensor heater RETURN pin at the aftertreatment intake oxygen sensor connector of the engine wiring harness and the aftertreatment intake oxygen sensor heater RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment intake oxygen sensor circuit pin to pin short

Solution: S00005985

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake oxygen sensor from the engine wiring harness.
  • Disconnect the engine wiring harness ECM connector 1 and 2.
  • Disconnect all components on the wiring circuit being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment intake oxygen sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the aftertreatment intake oxygen sensor RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the aftertreatment intake oxygen sensor heater SUPPLY pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the aftertreatment intake oxygen sensor heater RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment intake oxygen sensor is malfunctioning

Solution: S00004151

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment intake oxygen sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake oxygen sensor.

Refer to Procedure 019-100

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 1861 | SPN: 3217 | FMI: 2
Aftertreatment Intake Oxygen Sensor - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment intake oxygen sensor heater resistance check
  3. Aftertreatment outlet oxygen sensor heater resistance check
  4. Technical Service Bulletin is available
  5. Aftertreatment intake oxygen sensor heater voltage check
  6. Aftertreatment intake oxygen sensor heater circuit pin to ground short
  7. Aftertreatment intake oxygen sensor open circuit check
  8. Aftertreatment intake oxygen sensor circuit pin to ground short
  9. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002341

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment intake oxygen: 2686, 2687, 3436, 3437
  • Aftertreatment outlet oxygen: 1862, 1864, 2688, 2689

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment intake oxygen sensor heater resistance check

Solution: S00004153

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake oxygen sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the aftertreatment intake oxygen sensor.

Refer to Procedure 019-100

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not within specification, then a malfunctioning aftertreatment intake oxygen sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake oxygen sensor.

Refer to Procedure 019-100

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment outlet oxygen sensor heater resistance check

Solution: S00004155

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet oxygen sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the aftertreatment outlet oxygen sensor

Refer to Procedure 019-100

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not within specification, then a malfunctioning outlet oxygen sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment outlet oxygen sensor.

Refer to Procedure 019-100

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Technical Service Bulletin is available

Solution: S00006397

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb101120

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment intake oxygen sensor heater voltage check

Solution: S00004902

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake oxygen sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check that all battery terminal connections are tight and corrosion free.
  • Turn keyswitch ON.
  • Run the engine at idle for the following minutes: 12
  • Measure the voltage between the aftertreatment intake oxygen sensor heater SUPPLY pin and the aftertreatment intake oxygen sensor heater RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • Aftertreatment intake oxygen sensor heater circuit pin to ground short

Refer to S00004964

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

5.1 - Aftertreatment intake oxygen sensor heater circuit pin to ground short

Solution: S00004964

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake oxygen sensor from the engine wiring harness.

Action

  • Start the engine.
  • Measure the voltage between the aftertreatment intake oxygen sensor heater SUPPLY pin at the sensor connector of the engine wiring harness and ground.

Specification

  • A malfunctioning engine wiring harness has been detected if the voltage is within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - Aftertreatment intake oxygen sensor open circuit check

Solution: S00004820

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness ECM connector 1 and 2.
  • Disconnect the aftertreatment intake oxygen sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment intake oxygen sensor SIGNAL pin at the aftertreatment intake oxygen sensor engine wiring harness connector and the aftertreatment intake oxygen sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the aftertreatment intake oxygen sensor RETURN pin at the aftertreatment intake oxygen sensor engine wiring harness connector and the aftertreatment intake oxygen sensor RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the aftertreatment intake oxygen sensor heater SUPPLY pin at the aftertreatment intake oxygen sensor connector of the engine wiring harness and the aftertreatment intake oxygen sensor heater SUPPLY pin at the engine wiring harness ECM connector.
  • Measure the resistance between the aftertreatment intake oxygen sensor heater RETURN pin at the aftertreatment intake oxygen sensor connector of the engine wiring harness and the aftertreatment intake oxygen sensor heater RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Aftertreatment intake oxygen sensor circuit pin to ground short

Solution: S00002829

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the aftertreatment intake oxygen sensor from the engine wiring harness.
  • Disconnect all components on the wiring circuit being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment intake oxygen sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the aftertreatment intake oxygen sensor RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the aftertreatment intake oxygen sensor heater SUPPLY pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the aftertreatment intake oxygen sensor heater RETURN pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 1862 | SPN: 3227 | FMI: 3
Aftertreatment Outlet Oxygen Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Aftertreatment outlet oxygen sensor heater resistance check
  2. Aftertreatment outlet oxygen sensor open circuit check
  3. Aftertreatment outlet oxygen sensor circuit pin to pin short
  4. ECM calibration revision history check
  5. Aftertreatment outlet oxygen sensor is malfunctioning

1 - Aftertreatment outlet oxygen sensor heater resistance check

Solution: S00004155

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet oxygen sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the aftertreatment outlet oxygen sensor

Refer to Procedure 019-100

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not within specification, then a malfunctioning outlet oxygen sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment outlet oxygen sensor.

Refer to Procedure 019-100

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment outlet oxygen sensor open circuit check

Solution: S00005835

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet oxygen sensor from the OEM wiring harness.
  • Disconnect the engine wiring harness connector 1 from the ECM.
  • Disconnect the engine wiring harness connector 2 from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment outlet oxygen sensor SIGNAL pin at the aftertreatment outlet oxygen sensor OEM wiring harness connector and the aftertreatment outlet oxygen sensor SIGNAL pin at the engine wiring harness ECM connector 2.
  • Measure the resistance between the aftertreatment outlet oxygen sensor heater SUPPLY pin at the aftertreatment outlet oxygen sensor OEM wiring harness connector and the aftertreatment outlet oxygen sensor heater SUPPLY pin at the engine wiring harness ECM connector 2.
  • Measure the resistance between the aftertreatment outlet oxygen sensor RETURN pin at the aftertreatment outlet oxygen sensor OEM wiring harness connector and the aftertreatment outlet oxygen sensor RETURN pin at the engine wiring harness ECM connector 2.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment outlet oxygen sensor circuit pin to pin short

Solution: S00005557

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet oxygen sensor from the OEM wiring harness.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment outlet oxygen sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the aftertreatment outlet oxygen sensor RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the aftertreatment outlet oxygen sensor heater SUPPLY pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the aftertreatment outlet oxygen sensor heater RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment outlet oxygen sensor is malfunctioning

Solution: S00008452

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding linked solution verifications have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment outlet oxygen sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment outlet oxygen sensor.

Refer to Procedure 019-100

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 1864 | SPN: 3227 | FMI: 2
Aftertreatment Outlet Oxygen Sensor - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment outlet oxygen sensor heater resistance check
  3. Exhaust leak visual check
  4. Aftertreatment intake oxygen sensor heater voltage check
  5. Aftertreatment intake oxygen sensor heater circuit pin to ground short
  6. Aftertreatment outlet oxygen sensor open circuit check
  7. Aftertreatment outlet oxygen sensor circuit pin to ground short
  8. Aftertreatment outlet oxygen sensor circuit pin to pin short
  9. ECM calibration revision history check
  10. Aftertreatment outlet oxygen sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00002189

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment intake oxygen: 2686, 2687

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment outlet oxygen sensor heater resistance check

Solution: S00004155

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet oxygen sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the aftertreatment outlet oxygen sensor

Refer to Procedure 019-100

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not within specification, then a malfunctioning outlet oxygen sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment outlet oxygen sensor.

Refer to Procedure 019-100

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Exhaust leak visual check

Solution: S00009448

Verification

Conditions

  • Turn keyswitch ON.
  • Engine running at idle.

Action

  • Visually inspect for leaks from the turbocharger to exhaust manifold.
  • Visually inspect for loose or broken mounting hardware or damaged connection gasket.
  • Visually inspect for leaks in the exhaust manifold to head.
  • Visually inspect for leaks from the EGR components.
  • Visually inspect the exhaust piping for leaks, cracks, and loose connections.

Specification

  • If there is any damage or leaks found in the exhaust system, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the leaking components.

Refer to Procedure 011-007

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment intake oxygen sensor heater voltage check

Solution: S00004902

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake oxygen sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check that all battery terminal connections are tight and corrosion free.
  • Turn keyswitch ON.
  • Run the engine at idle for the following minutes: 12
  • Measure the voltage between the aftertreatment intake oxygen sensor heater SUPPLY pin and the aftertreatment intake oxygen sensor heater RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • Aftertreatment intake oxygen sensor heater circuit pin to ground short

Refer to S00004964

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Aftertreatment intake oxygen sensor heater circuit pin to ground short

Solution: S00004964

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake oxygen sensor from the engine wiring harness.

Action

  • Start the engine.
  • Measure the voltage between the aftertreatment intake oxygen sensor heater SUPPLY pin at the sensor connector of the engine wiring harness and ground.

Specification

  • A malfunctioning engine wiring harness has been detected if the voltage is within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Aftertreatment outlet oxygen sensor open circuit check

Solution: S00005835

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet oxygen sensor from the OEM wiring harness.
  • Disconnect the engine wiring harness connector 1 from the ECM.
  • Disconnect the engine wiring harness connector 2 from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment outlet oxygen sensor SIGNAL pin at the aftertreatment outlet oxygen sensor OEM wiring harness connector and the aftertreatment outlet oxygen sensor SIGNAL pin at the engine wiring harness ECM connector 2.
  • Measure the resistance between the aftertreatment outlet oxygen sensor heater SUPPLY pin at the aftertreatment outlet oxygen sensor OEM wiring harness connector and the aftertreatment outlet oxygen sensor heater SUPPLY pin at the engine wiring harness ECM connector 2.
  • Measure the resistance between the aftertreatment outlet oxygen sensor RETURN pin at the aftertreatment outlet oxygen sensor OEM wiring harness connector and the aftertreatment outlet oxygen sensor RETURN pin at the engine wiring harness ECM connector 2.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment outlet oxygen sensor circuit pin to ground short

Solution: S00001588

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the aftertreatment outlet oxygen sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment outlet oxygen sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the aftertreatment outlet oxygen sensor RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the aftertreatment outlet oxygen sensor heater SUPPLY pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the aftertreatment outlet oxygen sensor heater RETURN pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Aftertreatment outlet oxygen sensor circuit pin to pin short

Solution: S00005557

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet oxygen sensor from the OEM wiring harness.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment outlet oxygen sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the aftertreatment outlet oxygen sensor RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the aftertreatment outlet oxygen sensor heater SUPPLY pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the aftertreatment outlet oxygen sensor heater RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Aftertreatment outlet oxygen sensor is malfunctioning

Solution: S00008452

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding linked solution verifications have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment outlet oxygen sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment outlet oxygen sensor.

Refer to Procedure 019-100

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 1866 | SPN: 411 | FMI: 2
Exhaust Gas Recirculation Differential Pressure - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. EGR differential pressure sensor stuck in-range
  3. Plugged EGR differential pressure sensor supply ports
  4. Charge air cooler or exhaust system leak
  5. ECM calibration revision history check
  6. EGR differential pressure sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000154

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • EGR differential pressure: 2273, 2274

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - EGR differential pressure sensor stuck in-range

Solution: S00004301

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Specification

  • A malfunctioning EGR differential pressure sensor has been detected if the reading is not within the following specification: 0 ± 1 kPa [0 ± 0.30 in Hg]

Linked Solutions

  • None

Repair

  • Replace the EGR differential pressure sensor.

Refer to Procedure 019-370

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Plugged EGR differential pressure sensor supply ports

Solution: S00004872

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the EGR differential pressure sensor flow port cross-drillings for blockage.

Refer to Procedure 019-370

  • Visually inspect the exhaust gas entrance ports for blockage.

Specification

  • If debris is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean the EGR differential pressure ports.

Refer to Procedure 005-009

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Charge air cooler or exhaust system leak

Solution: S00006382

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.

Refer to Procedure 010-024

  • Visually inspect the air compressor plumbing for possible air leaks.

Refer to Procedure 010-024

  • Visually inspect the EGR plumbing for possible air leaks.

Refer to Procedure 010-024

  • Visually inspect the exhaust piping for leaks, cracks, and loose connections.

Refer to Procedure 010-024

  • Visually inspect the charge air cooler hoses for possible air leaks.

Refer to Procedure 010-024

  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

Repair or replace the following components if they are found out of specification:

  • Repair or replace the leaking components.

Refer to OEM Service Manual

  • Clean or replace the air compressor air inlet tube.

Refer to Procedure 012-109

  • Repair or replace the EGR cooler connection tube.

Refer to Procedure 011-024

  • Repair or replace the EGR crossover tube.

Refer to Procedure 011-070

  • Replace the exhaust manifold gaskets.

Refer to Procedure 011-007

  • Replace the exhaust manifold.

Refer to Procedure 011-007

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - EGR differential pressure sensor is malfunctioning

Solution: S00003480

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the EGR differential pressure sensor.

Refer to Procedure 019-370

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 1896 | SPN: 2791 | FMI: 13
EGR Valve Controller - Out of Calibration

Troubleshooting Summary

  1. Check for primary fault codes
  2. Charge air cooler or exhaust system leak
  3. EGR valve is malfunctioning
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002228

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • EGR: 2272, 2349, 2351, 2357
  • EGR differential pressure: 1866, 2273, 2274

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Charge air cooler or exhaust system leak

Solution: S00006382

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.

Refer to Procedure 010-024

  • Visually inspect the air compressor plumbing for possible air leaks.

Refer to Procedure 010-024

  • Visually inspect the EGR plumbing for possible air leaks.

Refer to Procedure 010-024

  • Visually inspect the exhaust piping for leaks, cracks, and loose connections.

Refer to Procedure 010-024

  • Visually inspect the charge air cooler hoses for possible air leaks.

Refer to Procedure 010-024

  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

Repair or replace the following components if they are found out of specification:

  • Repair or replace the leaking components.

Refer to OEM Service Manual

  • Clean or replace the air compressor air inlet tube.

Refer to Procedure 012-109

  • Repair or replace the EGR cooler connection tube.

Refer to Procedure 011-024

  • Repair or replace the EGR crossover tube.

Refer to Procedure 011-070

  • Replace the exhaust manifold gaskets.

Refer to Procedure 011-007

  • Replace the exhaust manifold.

Refer to Procedure 011-007

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - EGR valve is malfunctioning

Solution: S00000019

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Turn keyswitch OFF for 10 seconds and then turn the keyswitch ON.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning EGR valve has been detected if a fault code from the following list is active or has more than one inactive count within the last 25 engine operating hours: 1896, 2357

Linked Solutions

  • None

Repair

If the EGR valve has been replaced within the last 90 days, follow your technical escalation process PRIOR to performing any of the repair actions listed below:

  • Clean or replace the EGR valve.

Refer to Procedure 011-022

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 1942 | SPN: 101 | FMI: 2
Crankcase Pressure - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Crankcase pressure sensor stuck in-range
  2. ECM calibration revision history check
  3. Crankcase pressure sensor is malfunctioning

1 - Crankcase pressure sensor stuck in-range

Solution: S00000623

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the crankcase pressure sensor.

Specification

  • A malfunctioning crankcase pressure sensor has been detected if the crankcase pressure sensor is not within the following specification: 0 ± 0.28 kPa - G [0 ± 1.2 in H2O]

Linked Solutions

  • None

Repair

  • Replace crankcase pressure sensor.

Refer to Procedure 019-445

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Crankcase pressure sensor is malfunctioning

Solution: S00006414

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace crankcase pressure sensor.

Refer to Procedure 019-445

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 1965 | SPN: 3241 | FMI: 16
Aftertreatment Exhaust Gas Temperature 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001511

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Engine misfire: 1654, 1655, 1656, 1657, 1658, 1659, 1718
  • Fuel: 2775
  • Intake manifold: 2988, 2989
  • Aftertreatment intake oxygen: 1861
  • Aftertreatment outlet oxygen: 1864

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 1966 | SPN: 3241 | FMI: 0
Aftertreatment Exhaust Gas Temperature 1 - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001511

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Engine misfire: 1654, 1655, 1656, 1657, 1658, 1659, 1718
  • Fuel: 2775
  • Intake manifold: 2988, 2989
  • Aftertreatment intake oxygen: 1861
  • Aftertreatment outlet oxygen: 1864

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 1968 | SPN: 3249 | FMI: 16
Aftertreatment Exhaust Gas Temperature 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001860

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 254, 255, 263, 265, 455, 511, 1827, 1828, 2184, 2722, 2723, 2991, 3847, 5848
  • Intake manifold temperature: 155, 2964
  • Turbocharger: 777, 2451, 2641, 2642,
  • Intake manifold: 2973
  • Aftertreatment intake oxygen: 1858, 1861, 3436
  • Aftertreatment outlet oxygen: 1862, 1864, 3437

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 1969 | SPN: 3249 | FMI: 0
Aftertreatment Exhaust Gas Temperature 2 - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001860

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 254, 255, 263, 265, 455, 511, 1827, 1828, 2184, 2722, 2723, 2991, 3847, 5848
  • Intake manifold temperature: 155, 2964
  • Turbocharger: 777, 2451, 2641, 2642,
  • Intake manifold: 2973
  • Aftertreatment intake oxygen: 1858, 1861, 3436
  • Aftertreatment outlet oxygen: 1862, 1864, 3437

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 1974 | SPN: 101 | FMI: 15
Crankcase Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Lubricating oil level is incorrect
  2. Plugged external crankcase breather tube
  3. Crankcase pressure sensor stuck in-range
  4. Crankcase Blowby Check
  5. Turbocharger leaking air into crankcase
  6. Air compressor leaking air into crankcase
  7. Worn or damaged power cylinder components
  8. ECM calibration revision history check

1 - Lubricating oil level is incorrect

Solution: S00003234

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Make sure the vehicle is on a level surface with the engine off.
  • Check that the lubricating oil level is correct.
  • Determine if the lubrication oil is contaminated with coolant or fuel.

Specification

  • If the oil level is high and coolant contamination has been detected, then reset the search to Coolant in the oil.
  • If the oil level is high and fuel contamination has been detected, then reset the search to Fuel in the oil.
  • If the oil level is high and no coolant or fuel contamination has been detected, then incorrect oil dipstick calibration has been detected.
  • If the oil level is normal, then proceed to the next solution.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Reset search for coolant in the lubricating oil.
  • Search for fuel in oil.
  • Calibrate the lubricating oil dipstick for the proper oil level.

Refer to Procedure 007-009

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Plugged external crankcase breather tube

Solution: S00000626

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the oil drain tubes, check valves, breather tubes, and oil separator for plugging.

Refer to Procedure 003-001

It is important to check for a frozen, plugged, or restricted crankcase breather tubes in extreme cold ambient temperatures. Ice can form in the crankcase breather tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Specification

  • If an obstruction is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the crankcase ventilation oil drain tubes, check valves, breather tube, or separator.

Refer to Procedure 003-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Crankcase pressure sensor stuck in-range

Solution: S00000623

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the crankcase pressure sensor.

Specification

  • A malfunctioning crankcase pressure sensor has been detected if the crankcase pressure sensor is not within the following specification: 0 ± 0.28 kPa - G [0 ± 1.2 in H2O]

Linked Solutions

  • None

Repair

  • Replace crankcase pressure sensor.

Refer to Procedure 019-445

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Crankcase Blowby Check

Solution: S00005143

Verification

Conditions

  • Turn keyswitch ON.
  • Engine running.

Action

  • Check the crankcase breather element type.
  • If the element is not a maintenance free insert, then check the maintenance interval to determine if the maintenance interval has been exceeded.
  • Perform the crankcase blowby measurement test.

Refer to Procedure 014-010

Specification

  • If the crankcase breather element exceeds the maintenance interval, then proceed to the Repair section.
  • If the blowby measurement is not within specification with the element bypassed, then proceed to the Linked Solutions section.

Linked Solutions

Click on the link below:

  • Turbocharger leaking air into crankcase

Refer to S00001203

  • Air compressor leaking air into crankcase

Refer to S00001204

  • Worn or damaged power cylinder components

Refer to S00002975

Repair

  • Replace the crankcase breather element.

Refer to Procedure 003-019

Validation

  • None
Next Solution

4.1 - Turbocharger leaking air into crankcase

Solution: S00001203

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the crankcase blowby measurement test with the turbocharger isolated.

Refer to Procedure 014-010

Specification

  • If the turbocharger blowby contribution is out of specification, then a malfunctioning turbocharger has been detected.

Linked Solutions

  • None

Repair

  • Replace the turbocharger.

Refer to Procedure 010-033

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.2 - Air compressor leaking air into crankcase

Solution: S00001204

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the crankcase blowby measurement test with the air compressor isolated.

Refer to Procedure 014-010

Specification

  • If the air compressor blowby contribution is out of specification, then a malfunctioning air compressor has been detected.

Linked Solutions

  • None

Repair

  • Replace the air compressor.

Refer to Procedure 012-014

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.3 - Worn or damaged power cylinder components

Solution: S00002975

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pistons.

Refer to Procedure 001-043

  • Inspect the piston rings.

Refer to Procedure 001-047

  • Inspect the cylinder liners.

Refer to Procedure 001-028

Specification

  • If damaged or worn power cylinder components are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the piston.

Refer to Procedure 001-043

  • Replace the piston ring.

Refer to Procedure 001-047

  • Repair or replace the cylinder liner.

Refer to Procedure 001-028

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2182 | SPN: 1072 | FMI: 3
Engine Brake Actuator Driver 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Engine brake solenoid valve resistance check
  2. Engine brake solenoid valve open circuit check
  3. Engine brake solenoid circuit pin to pin short

1 - Engine brake solenoid valve resistance check

Solution: S00000539

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover.
  • Disconnect the engine wiring harness from the engine brake connector.
  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the engine brake solenoid valve terminal pin to the body of the solenoid.

Refer to Procedure 020-012

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the engine brake solenoid valve is not within specification, then a malfunctioning engine brake solenoid valve has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine brake solenoid valve.

Refer to Procedure 020-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Engine brake solenoid valve open circuit check

Solution: S00000648

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Measure the resistance between the engine brake solenoid SIGNAL wire at the engine brake solenoid to the engine brake solenoid SIGNAL line at the ECM connector on solenoid being tested.
  • Measure the resistance between the engine brake solenoid RETURN line at the engine brake solenoid to the engine brake solenoid RETURN line at the ECM connector on solenoid being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the engine brake wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine brake solenoid circuit pin to pin short

Solution: S00001027

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2183 | SPN: 1072 | FMI: 4
Engine Brake Actuator Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Engine brake solenoid valve resistance check
  2. Loose or damaged engine brake wiring harness connector
  3. Engine brake solenoid valve open circuit check
  4. Engine brake solenoid circuit pin to pin short

1 - Engine brake solenoid valve resistance check

Solution: S00000539

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover.
  • Disconnect the engine wiring harness from the engine brake connector.
  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the engine brake solenoid valve terminal pin to the body of the solenoid.

Refer to Procedure 020-012

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the engine brake solenoid valve is not within specification, then a malfunctioning engine brake solenoid valve has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine brake solenoid valve.

Refer to Procedure 020-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Loose or damaged engine brake wiring harness connector

Solution: S00003168

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine brake solenoids from the engine brake pass through connector.
  • Visually inspect the engine brake wiring harness for damage or broken connections.

Refer to Procedure 019-361

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the engine brake wiring harness.

Refer to Procedure 020-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine brake solenoid valve open circuit check

Solution: S00000648

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Measure the resistance between the engine brake solenoid SIGNAL wire at the engine brake solenoid to the engine brake solenoid SIGNAL line at the ECM connector on solenoid being tested.
  • Measure the resistance between the engine brake solenoid RETURN line at the engine brake solenoid to the engine brake solenoid RETURN line at the ECM connector on solenoid being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the engine brake wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Engine brake solenoid circuit pin to pin short

Solution: S00001027

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2184 | SPN: 633 | FMI: 11
Electronic Fuel Injection Control Valve Circuit - Root Cause Not Known

Troubleshooting Summary

  1. Check for primary fault codes
  2. Check for primary fault codes
  3. Low pressure regulator is malfunctioning
  4. Fuel control valve resistance check
  5. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001599

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 2775, 2776, 3847, 5948

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Check for primary fault codes

Solution: S00001594

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 1827, 1828, 1839, 1841, 2568, 2722, 2724, 2775, 2776, 3847, 5948
  • Aftertreatment intake oxygen: 1861, 3436, 3437
  • Exhaust gas pressure: 6893

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

3 - Low pressure regulator is malfunctioning

Solution: S00003495

Verification

Conditions

  • Engine running at idle.

Action

  • Perform three throttle sweeps and return to idle.
  • Disconnect the gas mass flow sensor from the engine wiring harness.

Specification

  • If the engine performance improves with the sensor disconnected, then a malfunctioning low pressure regulator has been detected.

Linked Solutions

  • None

Repair

  • Replace the low pressure regulator.

Refer to Procedure 005-047

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel control valve resistance check

Solution: S00004796

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel control valve from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel control valve SIGNAL pin and the fuel control valve RETURN pin at the fuel control valve connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel control valve has been detected if the resistance is not within the following specification: 2 - 5 Ω

Linked Solutions

  • None

Repair

  • Replace the fuel control valve.

Refer to Procedure 019-102

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2185 | SPN: 3512 | FMI: 3
Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. ECM sensor supply 4 voltage above normal
  2. Sensor supply 4 circuit pin to pin short

1 - ECM sensor supply 4 voltage above normal

Solution: S00006678

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector 2 from the ECM.
  • Disconnect the ECM power supply from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SUPPLY pin and all of the ECM battery SUPPLY (+) pins in the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position sensor SUPPLY pin and the ECM keyswitch SIGNAL pin in the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Sensor supply 4 circuit pin to pin short

Solution: S00006675

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the engine wiring harness connector 2 from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SUPPLY pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2186 | SPN: 3512 | FMI: 4
Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Sensor supply 4 circuit pin to pin short

1 - Sensor supply 4 circuit pin to pin short

Solution: S00006675

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the engine wiring harness connector 2 from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SUPPLY pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2189 | SPN: 51 | FMI: 7
Throttle Plate Leaking - Mechanical System Not Responding or Out of Adjustment

Troubleshooting Summary

  1. Engine intake throttle actuator is malfunctioning
  2. ECM calibration revision history check

1 - Engine intake throttle actuator is malfunctioning

Solution: S00004282

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Gas Throttle Control Test.

Specification

  • If the engine intake throttle actuator does not pass the Gas Throttle Control Test, then a malfunctioning engine intake throttle actuator has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine intake throttle actuator.

Refer to Procedure 005-052

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2272 | SPN: 27 | FMI: 4
EGR Valve Position Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. EGR valve position sensor open circuit check
  3. EGR valve position sensor circuit pin to ground short
  4. EGR valve position sensor circuit pin to pin short
  5. EGR valve is malfunctioning

1 - Check for primary fault codes

Solution: S00006719

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 2: 187, 227

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - EGR valve position sensor open circuit check

Solution: S00004531

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the EGR valve from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the EGR valve position sensor SIGNAL A pin at the EGR valve wiring harness connector and the EGR valve position sensor SIGNAL A pin at the engine wiring harness ECM connector.
  • Measure the resistance between the EGR valve position sensor SIGNAL B pin at the EGR valve wiring harness connector and the EGR valve position sensor SIGNAL B pin at the engine wiring harness ECM connector.
  • Measure the resistance between the EGR valve position sensor SIGNAL C pin at the EGR valve wiring harness connector and the EGR valve position sensor SIGNAL C pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - EGR valve position sensor circuit pin to ground short

Solution: S00001063

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve motor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the EGR valve position SIGNAL A pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the EGR valve position SIGNAL B pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the EGR valve position SIGNAL C pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - EGR valve position sensor circuit pin to pin short

Solution: S00000766

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the EGR valve from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the EGR valve position SIGNAL A pin at the engine wiring harness ECM connector and all other pins in the ECM connector.
  • Measure the resistance between the EGR valve position SIGNAL B pin at the engine wiring harness ECM connector and all other pins in the ECM connector.
  • Measure the resistance between the EGR valve position SIGNAL C pin at the engine wiring harness ECM connector and all other pins in the ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - EGR valve is malfunctioning

Solution: S00003101

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Reconnect the engine wiring harness connector from the ECM.
  • Reconnect the EGR valve motor to the engine wiring harness.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait for 60 seconds.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the EGR valve.

Refer to Procedure 011-022

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 15-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2273 | SPN: 411 | FMI: 3
Exhaust Gas Recirculation Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. EGR differential pressure sensor stuck in-range
  3. EGR differential pressure sensor voltage supply check
  4. EGR differential pressure sensor voltage check at the ECM
  5. EGR differential pressure sensor circuit response
  6. EGR differential pressure sensor circuit response at the ECM
  7. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00006719

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 2: 187, 227

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - EGR differential pressure sensor stuck in-range

Solution: S00004301

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Specification

  • A malfunctioning EGR differential pressure sensor has been detected if the reading is not within the following specification: 0 ± 1 kPa [0 ± 0.30 in Hg]

Linked Solutions

  • None

Repair

  • Replace the EGR differential pressure sensor.

Refer to Procedure 019-370

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - EGR differential pressure sensor voltage supply check

Solution: S00000767

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the EGR differential pressure sensor SUPPLY pin and the EGR differential pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • EGR differential pressure sensor voltage check at the ECM.

Refer to S00000768

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3.1 - EGR differential pressure sensor voltage check at the ECM

Solution: S00000768

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the EGR differential pressure sensor SUPPLY pin and the EGR differential pressure sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - EGR differential pressure sensor circuit response

Solution: S00000366

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning EGR differential pressure sensor has been detected if the following fault code became active with the sensor disconnected: 2274

Linked Solutions

  • None

Repair

  • Replace the EGR differential pressure sensor.

Refer to Procedure 019-370

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - EGR differential pressure sensor circuit response at the ECM

Solution: S00001239

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 2274
  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 2274

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2274 | SPN: 411 | FMI: 4
Exhaust Gas Recirculation Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. EGR differential pressure sensor stuck in-range
  3. EGR differential pressure sensor voltage supply check
  4. EGR differential pressure sensor voltage check at the ECM
  5. EGR differential pressure sensor circuit response
  6. EGR differential pressure sensor circuit response at the ECM
  7. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00006719

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 2: 187, 227

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - EGR differential pressure sensor stuck in-range

Solution: S00004301

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Specification

  • A malfunctioning EGR differential pressure sensor has been detected if the reading is not within the following specification: 0 ± 1 kPa [0 ± 0.30 in Hg]

Linked Solutions

  • None

Repair

  • Replace the EGR differential pressure sensor.

Refer to Procedure 019-370

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - EGR differential pressure sensor voltage supply check

Solution: S00000767

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the EGR differential pressure sensor SUPPLY pin and the EGR differential pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • EGR differential pressure sensor voltage check at the ECM.

Refer to S00000768

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3.1 - EGR differential pressure sensor voltage check at the ECM

Solution: S00000768

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the EGR differential pressure sensor SUPPLY pin and the EGR differential pressure sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - EGR differential pressure sensor circuit response

Solution: S00001121

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the EGR differential pressure sensor SUPPLY pin and the EGR differential pressure SIGNAL pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning EGR differential pressure sensor has been detected if the following fault code became active with the jumper wire in place: 2273

Linked Solutions

  • None

Repair

  • Replace the EGR differential pressure sensor.

Refer to Procedure 019-370

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - EGR differential pressure sensor circuit response at the ECM

Solution: S00000592

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the EGR differential pressure sensor SUPPLY pin and the EGR differential pressure sensor SIGNAL pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 2273
  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 2273

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2286 | SPN: 3451 | FMI: 3
Engine Multiple Cylinder Spark Voltage Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Ignition control module is malfunctioning
  2. Ignition control wiring harness open circuit check
  3. Ignition control module circuit pin to pin short
  4. Ignition control wiring harness circuit pin to pin short

1 - Ignition control module is malfunctioning

Solution: S00004201

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the voltage check for the ignition control module.

Refer to Procedure 019-105

  • Perform the ignition coil test.

Refer to Procedure 013-012

  • Visually inspect for a loose connection at the ignition coil connector associated with the fault code.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the voltage is present at the ignition control module and no spark was observed during the coil test, then a malfunctioning ignition control module has been detected.

Linked Solutions

  • None

Repair

  • Replace ignition control module.

Refer to Procedure 019-105

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Ignition control wiring harness open circuit check

Solution: S00004197

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Ignition control module circuit pin to pin short

Solution: S00001435

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the gas mass flow sensor from the engine wiring harness.
  • Disconnect the EGR temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Ignition control wiring harness circuit pin to pin short

Solution: S00004285

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control wiring harness charge voltage SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness secondary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness primary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 12-Dec-2021


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2287 | SPN: 3451 | FMI: 4
Engine Multiple Cylinder Spark Voltage Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Ignition control module is malfunctioning
  2. Ignition control module open circuit check
  3. Ignition control wiring harness open circuit check
  4. Ignition control wiring harness circuit pin to ground short
  5. Ignition control wiring harness circuit pin to ground short
  6. Ignition control module circuit pin to ground short
  7. Ignition control module circuit pin to pin short
  8. Ignition control wiring harness circuit pin to pin short

1 - Ignition control module is malfunctioning

Solution: S00004201

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the voltage check for the ignition control module.

Refer to Procedure 019-105

  • Perform the ignition coil test.

Refer to Procedure 013-012

  • Visually inspect for a loose connection at the ignition coil connector associated with the fault code.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the voltage is present at the ignition control module and no spark was observed during the coil test, then a malfunctioning ignition control module has been detected.

Linked Solutions

  • None

Repair

  • Replace ignition control module.

Refer to Procedure 019-105

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Ignition control module open circuit check

Solution: S00004840

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the ignition control module C1 connector and the combustion detection SIGNAL pin at the engine wiring harness ECM connector 2.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the ignition control module C1 connector and the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the ignition control module C1 connector and the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module RETURN pin at the ignition control module C1 connector and the ignition control module RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the ignition control module C1 connector and the spark voltage SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Ignition control wiring harness open circuit check

Solution: S00004197

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Ignition control wiring harness circuit pin to ground short

Solution: S00004135

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connector C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the charge voltage pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the secondary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the primary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Ignition control wiring harness circuit pin to ground short

Solution: S00004838

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Ignition control module circuit pin to ground short

Solution: S00005822

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery.
  • Disconnect the engine wiring harness from the ignition control module.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module SUPPLY pin at the ignition control module engine wiring harness connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Ignition control module circuit pin to pin short

Solution: S00001435

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the gas mass flow sensor from the engine wiring harness.
  • Disconnect the EGR temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Ignition control wiring harness circuit pin to pin short

Solution: S00004285

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control wiring harness charge voltage SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness secondary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness primary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 12-Dec-2021


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2321 | SPN: 190 | FMI: 2
Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Engine crankshaft speed/position sensor check
  3. Crankshaft position sensor open circuit check
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000185

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Crankshaft speed/position sensor: 689

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Engine crankshaft speed/position sensor check

Solution: S00000684

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the crankshaft position sensor.
  • Inspect the crankshaft position sensor for signs of damage, oil leak, and metal debris on the end of the sensor.
  • Verify the crankshaft position sensor is connected properly.
  • Use the ratchet drive side of the socket tool that was used to removed the sensor from the engine, place it flush on the sensor so that the edge of the socket is on the edge of the sensor.
  • Monitor the crankshaft engine speed sensor state using the recommended Cummins® electronic service tool or equivalent and monitor (Engine Speed Main Sensor State) to check if the sensor state transitions.
  • Slowly slide the socket in a perpendicular direction to the marked line on the sensor or in a perpendicular direction to the mounting bracket of the sensor.

Specification

  • If any damage is found to the sensor, then proceed to the Repair section.
  • If the crankshaft position sensor is not connected properly, then proceed to the Repair section.
  • If the crankshaft position sensor state does NOT transition from high to low or low to high, or the state does NOT show triggered, then a malfunctioning crankshaft engine position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine crankshaft speed/position sensor.

Refer to Procedure 019-365

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Crankshaft position sensor open circuit check

Solution: S00000676

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the crankshaft position sensor SIGNAL pin at the crankshaft position sensor engine wiring harness connector to the crankshaft position sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2322 | SPN: 723 | FMI: 2
Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Camshaft position sensor is damaged
  3. Camshaft position sensor voltage check
  4. Camshaft position sensor voltage check at the ECM
  5. Camshaft position sensor open circuit check
  6. Camshaft position sensor circuit pin to pin short
  7. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000186

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Camshaft speed/position sensor: 778

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Camshaft position sensor is damaged

Solution: S00001226

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the camshaft position sensor.

Refer to Procedure 019-363

  • Inspect the camshaft position sensor for signs of damage, oil leak, and metal debris on the end of the sensor.

Specification

  • If the camshaft position sensor shows any signs of damage, then a malfunctioning camshaft position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace camshaft position sensor.

Refer to Procedure 019-363

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Camshaft position sensor voltage check

Solution: S00000693

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the camshaft position sensor SUPPLY pin and the camshaft position sensor RETURN pin at the sensor connector of the engine wiring harness.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Camshaft position sensor voltage check at the ECM

Refer to S00000694

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Camshaft position sensor voltage check at the ECM

Solution: S00000694

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the camshaft position sensor SUPPLY pin and the camshaft position sensor RETURN pin at the ECM connector.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Camshaft position sensor open circuit check

Solution: S00000691

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the camshaft position sensor SIGNAL pin at the camshaft position sensor engine wiring harness connector to the camshaft position sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Camshaft position sensor circuit pin to pin short

Solution: S00000692

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the camshaft position sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the camshaft position sensor SIGNAL pin of the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2349 | SPN: 2791 | FMI: 5
EGR Valve Control Circuit - Current Below Normal or Open Circuit

Troubleshooting Summary

  1. EGR valve motor resistance check
  2. EGR valve motor open circuit check
  3. EGR valve motor circuit pin to pin short
  4. EGR valve is malfunctioning

1 - EGR valve motor resistance check

Solution: S00000773

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve motor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the EGR valve motor wire A pin, to the EGR valve motor wire B pin in the EGR valve motor connector.
  • Measure the resistance between the EGR valve motor wire A pin, to the EGR valve motor wire C pin in the EGR valve motor connector.
  • Measure the resistance between the EGR valve motor wire C pin, to the EGR valve motor wire B pin in the EGR valve motor connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning EGR valve motor has been detected if the resistance is greater than the following specification: 5 Ω

Linked Solutions

  • None

Repair

  • Replace the EGR valve.

Refer to Procedure 011-022

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - EGR valve motor open circuit check

Solution: S00001075

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the EGR valve from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the EGR valve motor A SIGNAL pin at the EGR valve engine wiring harness connector and the EGR valve motor A SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the EGR valve motor B SIGNAL pin at the EGR valve engine wiring harness connector and the EGR valve motor B SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the EGR valve motor C SIGNAL pin at the EGR valve engine wiring harness connector and the EGR valve motor C SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the EGR valve motor RETURN pin at the EGR valve engine wiring harness connector and the EGR valve motor RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - EGR valve motor circuit pin to pin short

Solution: S00006730

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the EGR valve from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the EGR valve motor SIGNAL A pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the EGR valve motor SIGNAL B pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the EGR valve motor SIGNAL C pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - EGR valve is malfunctioning

Solution: S00004389

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

If the EGR valve has been replaced within the last 90 days, follow your technical escalation process PRIOR to performing any of the repair actions listed below:

  • Replace the EGR valve.

Refer to Procedure 011-022

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 15-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2351 | SPN: 2791 | FMI: 4
EGR Valve Control Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. EGR valve motor circuit pin to ground short
  3. EGR valve motor circuit pin to pin short

1 - Check for primary fault codes

Solution: S00002210

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 2: 187, 227

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - EGR valve motor circuit pin to ground short

Solution: S00001181

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the EGR valve motor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the EGR valve motor SIGNAL A pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the EGR valve motor SIGNAL B pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the EGR valve motor SIGNAL C pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - EGR valve motor circuit pin to pin short

Solution: S00006730

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the EGR valve from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the EGR valve motor SIGNAL A pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the EGR valve motor SIGNAL B pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the EGR valve motor SIGNAL C pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 15-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2357 | SPN: 2791 | FMI: 7
EGR Valve Control Circuit - Mechanical System Not Responding or Out of Adjustment

Troubleshooting Summary

  1. EGR valve position sensor open circuit check
  2. EGR valve motor open circuit check
  3. EGR valve position sensor circuit pin to ground short
  4. EGR valve motor circuit pin to ground short
  5. EGR valve position sensor circuit pin to pin short
  6. EGR valve motor circuit pin to pin short
  7. EGR valve is malfunctioning

1 - EGR valve position sensor open circuit check

Solution: S00004531

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the EGR valve from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the EGR valve position sensor SIGNAL A pin at the EGR valve wiring harness connector and the EGR valve position sensor SIGNAL A pin at the engine wiring harness ECM connector.
  • Measure the resistance between the EGR valve position sensor SIGNAL B pin at the EGR valve wiring harness connector and the EGR valve position sensor SIGNAL B pin at the engine wiring harness ECM connector.
  • Measure the resistance between the EGR valve position sensor SIGNAL C pin at the EGR valve wiring harness connector and the EGR valve position sensor SIGNAL C pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - EGR valve motor open circuit check

Solution: S00001075

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the EGR valve from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the EGR valve motor A SIGNAL pin at the EGR valve engine wiring harness connector and the EGR valve motor A SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the EGR valve motor B SIGNAL pin at the EGR valve engine wiring harness connector and the EGR valve motor B SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the EGR valve motor C SIGNAL pin at the EGR valve engine wiring harness connector and the EGR valve motor C SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the EGR valve motor RETURN pin at the EGR valve engine wiring harness connector and the EGR valve motor RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - EGR valve position sensor circuit pin to ground short

Solution: S00001063

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve motor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the EGR valve position SIGNAL A pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the EGR valve position SIGNAL B pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the EGR valve position SIGNAL C pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - EGR valve motor circuit pin to ground short

Solution: S00001181

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the EGR valve motor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the EGR valve motor SIGNAL A pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the EGR valve motor SIGNAL B pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the EGR valve motor SIGNAL C pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - EGR valve position sensor circuit pin to pin short

Solution: S00000766

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the EGR valve from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the EGR valve position SIGNAL A pin at the engine wiring harness ECM connector and all other pins in the ECM connector.
  • Measure the resistance between the EGR valve position SIGNAL B pin at the engine wiring harness ECM connector and all other pins in the ECM connector.
  • Measure the resistance between the EGR valve position SIGNAL C pin at the engine wiring harness ECM connector and all other pins in the ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - EGR valve motor circuit pin to pin short

Solution: S00006730

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the EGR valve from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the EGR valve motor SIGNAL A pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the EGR valve motor SIGNAL B pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the EGR valve motor SIGNAL C pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - EGR valve is malfunctioning

Solution: S00000019

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Turn keyswitch OFF for 10 seconds and then turn the keyswitch ON.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning EGR valve has been detected if a fault code from the following list is active or has more than one inactive count within the last 25 engine operating hours: 1896, 2357

Linked Solutions

  • None

Repair

If the EGR valve has been replaced within the last 90 days, follow your technical escalation process PRIOR to performing any of the repair actions listed below:

  • Clean or replace the EGR valve.

Refer to Procedure 011-022

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 15-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2363 | SPN: 1073 | FMI: 4
Engine Brake Actuator Driver Output 2 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Engine brake solenoid valve resistance check
  2. Engine brake solenoid valve resistance check
  3. Loose or damaged engine brake wiring harness connector
  4. Engine brake solenoid 2 harness pin to ground short
  5. Engine brake solenoid circuit pin to pin short
  6. Engine wiring harness has a pin to pin short

1 - Engine brake solenoid valve resistance check

Solution: S00000539

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover.
  • Disconnect the engine wiring harness from the engine brake connector.
  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the engine brake solenoid valve terminal pin to the body of the solenoid.

Refer to Procedure 020-012

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the engine brake solenoid valve is not within specification, then a malfunctioning engine brake solenoid valve has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine brake solenoid valve.

Refer to Procedure 020-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Engine brake solenoid valve resistance check

Solution: S00001031

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.
  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid valve SIGNAL pin and engine brake solenoid RETURN at the engine brake solenoid valve.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the engine brake solenoid valve is not within specification, then a malfunctioning engine brake solenoid valve has been detected.

Refer to Procedure 020-012

Linked Solutions

  • None

Repair

  • Replace the engine brake solenoid valve.

Refer to Procedure 020-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Loose or damaged engine brake wiring harness connector

Solution: S00003168

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine brake solenoids from the engine brake pass through connector.
  • Visually inspect the engine brake wiring harness for damage or broken connections.

Refer to Procedure 019-361

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the engine brake wiring harness.

Refer to Procedure 020-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Engine brake solenoid 2 harness pin to ground short

Solution: S00001030

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake solenoid number 2 from the engine brake pass through connector.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid number 2 SIGNAL pin in the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness, internal actuator wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the internal actuator wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Engine brake solenoid circuit pin to pin short

Solution: S00001027

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Engine wiring harness has a pin to pin short

Solution: S00000774

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake solenoid number 2 from the engine brake pass through connector.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid number 2 SIGNAL pin in the engine wiring harness ECM connector and all other pins in the ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness, internal actuator wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the internal actuator wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2367 | SPN: 1073 | FMI: 3
Engine Brake Actuator Driver Output 2 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Engine brake solenoid valve resistance check
  2. Loose or damaged engine brake wiring harness connector
  3. Engine brake solenoid valve open circuit check
  4. Engine brake solenoid circuit pin to pin short
  5. Engine brake solenoid circuit pin to pin short

1 - Engine brake solenoid valve resistance check

Solution: S00001031

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.
  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid valve SIGNAL pin and engine brake solenoid RETURN at the engine brake solenoid valve.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the engine brake solenoid valve is not within specification, then a malfunctioning engine brake solenoid valve has been detected.

Refer to Procedure 020-012

Linked Solutions

  • None

Repair

  • Replace the engine brake solenoid valve.

Refer to Procedure 020-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Loose or damaged engine brake wiring harness connector

Solution: S00003168

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine brake solenoids from the engine brake pass through connector.
  • Visually inspect the engine brake wiring harness for damage or broken connections.

Refer to Procedure 019-361

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the engine brake wiring harness.

Refer to Procedure 020-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine brake solenoid valve open circuit check

Solution: S00000648

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Measure the resistance between the engine brake solenoid SIGNAL wire at the engine brake solenoid to the engine brake solenoid SIGNAL line at the ECM connector on solenoid being tested.
  • Measure the resistance between the engine brake solenoid RETURN line at the engine brake solenoid to the engine brake solenoid RETURN line at the ECM connector on solenoid being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the engine brake wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Engine brake solenoid circuit pin to pin short

Solution: S00001027

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Engine brake solenoid circuit pin to pin short

Solution: S00001028

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine wiring harness from the engine brake connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid number 1 SIGNAL pin in the engine wiring harness ECM connector and all other pins in the ECM connector.
  • Measure the resistance between the engine brake solenoid number 2 SIGNAL pin in the engine wiring harness ECM connector and all other pins in the ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2375 | SPN: 412 | FMI: 3
Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. EGR temperature sensor circuit response
  2. EGR temperature sensor circuit response at the ECM
  3. ECM calibration revision history check

1 - EGR temperature sensor circuit response

Solution: S00000391

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the EGR temperature sensor SIGNAL pin and the EGR temperature sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning EGR temperature sensor has been detected if the following fault code became active with the jumper wire in place: 2376

Linked Solutions

  • None

Repair

  • Replace EGR temperature sensor.

Refer to Procedure 019-378

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - EGR temperature sensor circuit response at the ECM

Solution: S00000575

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the EGR temperature sensor SIGNAL pin and the EGR temperature sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 2376
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 2376

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2376 | SPN: 412 | FMI: 4
Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. EGR temperature sensor circuit response
  2. EGR temperature sensor circuit response at the ECM
  3. ECM calibration revision history check

1 - EGR temperature sensor circuit response

Solution: S00000769

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning EGR temperature sensor has been detected if the following fault code became active with the sensor disconnected: 2375

Linked Solutions

  • None

Repair

  • Replace EGR temperature sensor.

Refer to Procedure 019-378

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - EGR temperature sensor circuit response at the ECM

Solution: S00001089

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 2375
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 2375

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2377 | SPN: 647 | FMI: 3
Fan Control Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Fan control solenoid open circuit check
  2. Fan control solenoid circuit pin to pin short
  3. Fan control solenoid is malfunctioning

1 - Fan control solenoid open circuit check

Solution: S00006512

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector 2 from the ECM.
  • Disconnect the fan control connector from the OEM wiring harness connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fan control solenoid SIGNAL pin at the fan control solenoid OEM wiring harness connector and the fan control solenoid SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the fan control solenoid RETURN pin at the fan control solenoid OEM wiring harness connector and the fan control solenoid RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Fan control solenoid circuit pin to pin short

Solution: S00006418

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the fan control connector from the OEM wiring harness connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fan control SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Fan control solenoid is malfunctioning

Solution: S00005653

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the fan control solenoid.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 15-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2431 | SPN: 1352 | FMI: 15
Engine Cylinder 1 (A1) Knock - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Turbocharger wastegate actuator is malfunctioning
  3. Knock sensor is malfunctioning
  4. Spark plug is damaged
  5. Ignition Coil Test
  6. Ignition control wiring harness open circuit check
  7. Ignition control wiring harness circuit pin to ground short
  8. Ignition control wiring harness circuit pin to pin short
  9. Ignition control module open circuit check
  10. Ignition control module circuit pin to ground short
  11. Ignition control module circuit pin to pin short
  12. Engine Compression Test
  13. Overhead component damaged or out of adjustment
  14. Cylinder Leak Down Test
  15. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002658

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Knock sensor: 572

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Turbocharger wastegate actuator is malfunctioning

Solution: S00003427

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the turbocharger wastegate actuator control line for damage.

Refer to Procedure 010-050

  • Measure the turbocharger wastegate actuator rod travel.

Refer to Procedure 010-050

Specification

  • If incorrect travel or damage is found on the turbocharger wastegate actuator control line, or rod, then a malfunctioning turbocharger wastegate actuator control line or rod has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the turbocharger wastegate actuator control line.

Refer to Procedure 010-050

  • Replace the wastegate actuator rod.

Refer to Procedure 010-050

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Knock sensor is malfunctioning

Solution: S00004356

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Inspect the appropriate knock sensor.

Refer to Procedure 019-346

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the knock sensor.

Refer to Procedure 019-346

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Spark plug is damaged

Solution: S00003531

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove all of the spark plugs.

Refer to Procedure 013-016

  • Measure the spark plug gap.

Refer to Procedure 013-016

  • Check the spark plugs.

Refer to Service Bulletin 4383578

Specification

  • If the spark plugs do not meet specification, then reset the search to the correct symptom according to the service bulletin.
  • If the spark plug gap is incorrect, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Correct the spark plug gap.

Refer to Procedure 013-016

  • Replace the spark plug.

Refer to Procedure 013-016

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Ignition Coil Test

Solution: S00004217

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect ignition coil body for cracks.

Refer to Procedure 013-012

Refer to Service Bulletin 4383630

  • Perform the ignition coil test.

Refer to Procedure 013-012

Specification

  • If any damage is found, then proceed to the Repair section.
  • If no spark was observed during the coil test, then proceed to the Linked Solutions section.

Linked Solutions

  • Ignition control wiring harness open circuit check

Refer to S00005711

  • Ignition control wiring harness circuit pin to ground short

Refer to S00005713

  • Ignition control wiring harness circuit pin to pin short

Refer to S00005715

  • Ignition control module open circuit check

Refer to S00005712

  • Ignition control module circuit pin to ground short

Refer to S00005714

  • Ignition control module circuit pin to pin short

Refer to S00006731

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil pack.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5.1 - Ignition control wiring harness open circuit check

Solution: S00005711

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.2 - Ignition control wiring harness circuit pin to ground short

Solution: S00005713

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connector C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the charge voltage pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the secondary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the primary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.3 - Ignition control wiring harness circuit pin to pin short

Solution: S00005715

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control wiring harness charge voltage SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness secondary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness primary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.4 - Ignition control module open circuit check

Solution: S00005712

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the ignition control module C1 connector and the combustion detection SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the ignition control module C1 connector and the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the ignition control module C1 connector and the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module RETURN pin at the ignition control module C1 connector and the ignition control module RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the ignition control module C1 connector and the spark voltage SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.5 - Ignition control module circuit pin to ground short

Solution: S00005714

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.6 - Ignition control module circuit pin to pin short

Solution: S00006731

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - Engine Compression Test

Solution: S00006439

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the Engine Compression Test.

Refer to Procedure 014-012

Specification

  • If the Engine Compression Test is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the piston.

Refer to Procedure 001-043

  • Replace the piston ring.

Refer to Procedure 001-047

  • Repair or replace the cylinder liner.

Refer to Procedure 001-028

  • Replace the cylinder head.

Refer to Procedure 002-004

Validation

  • None
Next Solution

7 - Overhead component damaged or out of adjustment

Solution: S00008484

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

  • Adjust the overhead.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Cylinder Leak Down Test

Solution: S00005891

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the Cylinder Leak Down Test.

Refer to Procedure 014-026

  • Visually inspect the pistons.

Refer to Procedure 001-043

  • Visually inspect the piston rings.

Refer to Procedure 001-047

  • Visually inspect the cylinder liners.

Refer to Procedure 001-028

Specification

  • If the Cylinder Leak Down Test does not meet specification, then a malfunctioning power cylinder component has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the piston.

Refer to Procedure 001-043

  • Replace the piston ring.

Refer to Procedure 001-047

  • Repair or replace the cylinder liner.

Refer to Procedure 001-028

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2432 | SPN: 1353 | FMI: 15
Engine Cylinder 2 (B1) Knock - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Turbocharger wastegate actuator is malfunctioning
  3. Knock sensor is malfunctioning
  4. Spark plug is damaged
  5. Ignition Coil Test
  6. Ignition control wiring harness open circuit check
  7. Ignition control wiring harness circuit pin to ground short
  8. Ignition control wiring harness circuit pin to pin short
  9. Ignition control module open circuit check
  10. Ignition control module circuit pin to ground short
  11. Ignition control module circuit pin to pin short
  12. Engine Compression Test
  13. Overhead component damaged or out of adjustment
  14. Cylinder Leak Down Test
  15. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002658

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Knock sensor: 572

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Turbocharger wastegate actuator is malfunctioning

Solution: S00003427

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the turbocharger wastegate actuator control line for damage.

Refer to Procedure 010-050

  • Measure the turbocharger wastegate actuator rod travel.

Refer to Procedure 010-050

Specification

  • If incorrect travel or damage is found on the turbocharger wastegate actuator control line, or rod, then a malfunctioning turbocharger wastegate actuator control line or rod has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the turbocharger wastegate actuator control line.

Refer to Procedure 010-050

  • Replace the wastegate actuator rod.

Refer to Procedure 010-050

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Knock sensor is malfunctioning

Solution: S00004356

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Inspect the appropriate knock sensor.

Refer to Procedure 019-346

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the knock sensor.

Refer to Procedure 019-346

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Spark plug is damaged

Solution: S00003531

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove all of the spark plugs.

Refer to Procedure 013-016

  • Measure the spark plug gap.

Refer to Procedure 013-016

  • Check the spark plugs.

Refer to Service Bulletin 4383578

Specification

  • If the spark plugs do not meet specification, then reset the search to the correct symptom according to the service bulletin.
  • If the spark plug gap is incorrect, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Correct the spark plug gap.

Refer to Procedure 013-016

  • Replace the spark plug.

Refer to Procedure 013-016

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Ignition Coil Test

Solution: S00004217

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect ignition coil body for cracks.

Refer to Procedure 013-012

Refer to Service Bulletin 4383630

  • Perform the ignition coil test.

Refer to Procedure 013-012

Specification

  • If any damage is found, then proceed to the Repair section.
  • If no spark was observed during the coil test, then proceed to the Linked Solutions section.

Linked Solutions

  • Ignition control wiring harness open circuit check

Refer to S00005711

  • Ignition control wiring harness circuit pin to ground short

Refer to S00005713

  • Ignition control wiring harness circuit pin to pin short

Refer to S00005715

  • Ignition control module open circuit check

Refer to S00005712

  • Ignition control module circuit pin to ground short

Refer to S00005714

  • Ignition control module circuit pin to pin short

Refer to S00006731

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil pack.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5.1 - Ignition control wiring harness open circuit check

Solution: S00005711

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.2 - Ignition control wiring harness circuit pin to ground short

Solution: S00005713

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connector C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the charge voltage pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the secondary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the primary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.3 - Ignition control wiring harness circuit pin to pin short

Solution: S00005715

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control wiring harness charge voltage SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness secondary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness primary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.4 - Ignition control module open circuit check

Solution: S00005712

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the ignition control module C1 connector and the combustion detection SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the ignition control module C1 connector and the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the ignition control module C1 connector and the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module RETURN pin at the ignition control module C1 connector and the ignition control module RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the ignition control module C1 connector and the spark voltage SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.5 - Ignition control module circuit pin to ground short

Solution: S00005714

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.6 - Ignition control module circuit pin to pin short

Solution: S00006731

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - Engine Compression Test

Solution: S00006439

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the Engine Compression Test.

Refer to Procedure 014-012

Specification

  • If the Engine Compression Test is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the piston.

Refer to Procedure 001-043

  • Replace the piston ring.

Refer to Procedure 001-047

  • Repair or replace the cylinder liner.

Refer to Procedure 001-028

  • Replace the cylinder head.

Refer to Procedure 002-004

Validation

  • None
Next Solution

7 - Overhead component damaged or out of adjustment

Solution: S00008484

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

  • Adjust the overhead.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Cylinder Leak Down Test

Solution: S00005891

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the Cylinder Leak Down Test.

Refer to Procedure 014-026

  • Visually inspect the pistons.

Refer to Procedure 001-043

  • Visually inspect the piston rings.

Refer to Procedure 001-047

  • Visually inspect the cylinder liners.

Refer to Procedure 001-028

Specification

  • If the Cylinder Leak Down Test does not meet specification, then a malfunctioning power cylinder component has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the piston.

Refer to Procedure 001-043

  • Replace the piston ring.

Refer to Procedure 001-047

  • Repair or replace the cylinder liner.

Refer to Procedure 001-028

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2433 | SPN: 1354 | FMI: 15
Engine Cylinder 3 (A2) Knock - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Turbocharger wastegate actuator is malfunctioning
  3. Knock sensor is malfunctioning
  4. Spark plug is damaged
  5. Ignition Coil Test
  6. Ignition control wiring harness open circuit check
  7. Ignition control wiring harness circuit pin to ground short
  8. Ignition control wiring harness circuit pin to pin short
  9. Ignition control module open circuit check
  10. Ignition control module circuit pin to ground short
  11. Ignition control module circuit pin to pin short
  12. Engine Compression Test
  13. Overhead component damaged or out of adjustment
  14. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002658

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Knock sensor: 572

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Turbocharger wastegate actuator is malfunctioning

Solution: S00003427

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the turbocharger wastegate actuator control line for damage.

Refer to Procedure 010-050

  • Measure the turbocharger wastegate actuator rod travel.

Refer to Procedure 010-050

Specification

  • If incorrect travel or damage is found on the turbocharger wastegate actuator control line, or rod, then a malfunctioning turbocharger wastegate actuator control line or rod has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the turbocharger wastegate actuator control line.

Refer to Procedure 010-050

  • Replace the wastegate actuator rod.

Refer to Procedure 010-050

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Knock sensor is malfunctioning

Solution: S00004356

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Inspect the appropriate knock sensor.

Refer to Procedure 019-346

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the knock sensor.

Refer to Procedure 019-346

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Spark plug is damaged

Solution: S00003531

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove all of the spark plugs.

Refer to Procedure 013-016

  • Measure the spark plug gap.

Refer to Procedure 013-016

  • Check the spark plugs.

Refer to Service Bulletin 4383578

Specification

  • If the spark plugs do not meet specification, then reset the search to the correct symptom according to the service bulletin.
  • If the spark plug gap is incorrect, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Correct the spark plug gap.

Refer to Procedure 013-016

  • Replace the spark plug.

Refer to Procedure 013-016

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Ignition Coil Test

Solution: S00004217

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect ignition coil body for cracks.

Refer to Procedure 013-012

Refer to Service Bulletin 4383630

  • Perform the ignition coil test.

Refer to Procedure 013-012

Specification

  • If any damage is found, then proceed to the Repair section.
  • If no spark was observed during the coil test, then proceed to the Linked Solutions section.

Linked Solutions

  • Ignition control wiring harness open circuit check

Refer to S00005711

  • Ignition control wiring harness circuit pin to ground short

Refer to S00005713

  • Ignition control wiring harness circuit pin to pin short

Refer to S00005715

  • Ignition control module open circuit check

Refer to S00005712

  • Ignition control module circuit pin to ground short

Refer to S00005714

  • Ignition control module circuit pin to pin short

Refer to S00006731

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil pack.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5.1 - Ignition control wiring harness open circuit check

Solution: S00005711

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.2 - Ignition control wiring harness circuit pin to ground short

Solution: S00005713

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connector C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the charge voltage pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the secondary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the primary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.3 - Ignition control wiring harness circuit pin to pin short

Solution: S00005715

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control wiring harness charge voltage SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness secondary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness primary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.4 - Ignition control module open circuit check

Solution: S00005712

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the ignition control module C1 connector and the combustion detection SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the ignition control module C1 connector and the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the ignition control module C1 connector and the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module RETURN pin at the ignition control module C1 connector and the ignition control module RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the ignition control module C1 connector and the spark voltage SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.5 - Ignition control module circuit pin to ground short

Solution: S00005714

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.6 - Ignition control module circuit pin to pin short

Solution: S00006731

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - Engine Compression Test

Solution: S00006439

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the Engine Compression Test.

Refer to Procedure 014-012

Specification

  • If the Engine Compression Test is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the piston.

Refer to Procedure 001-043

  • Replace the piston ring.

Refer to Procedure 001-047

  • Repair or replace the cylinder liner.

Refer to Procedure 001-028

  • Replace the cylinder head.

Refer to Procedure 002-004

Validation

  • None
Next Solution

7 - Overhead component damaged or out of adjustment

Solution: S00008484

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

  • Adjust the overhead.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2434 | SPN: 1355 | FMI: 15
Engine Cylinder 4 (B2) Knock - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Turbocharger wastegate actuator is malfunctioning
  3. Knock sensor is malfunctioning
  4. Spark plug is damaged
  5. Ignition Coil Test
  6. Ignition control wiring harness open circuit check
  7. Ignition control wiring harness circuit pin to ground short
  8. Ignition control wiring harness circuit pin to pin short
  9. Ignition control module open circuit check
  10. Ignition control module circuit pin to ground short
  11. Ignition control module circuit pin to pin short
  12. Engine Compression Test
  13. Overhead component damaged or out of adjustment
  14. Cylinder Leak Down Test
  15. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002259

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Knock sensor: 575

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Turbocharger wastegate actuator is malfunctioning

Solution: S00003427

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the turbocharger wastegate actuator control line for damage.

Refer to Procedure 010-050

  • Measure the turbocharger wastegate actuator rod travel.

Refer to Procedure 010-050

Specification

  • If incorrect travel or damage is found on the turbocharger wastegate actuator control line, or rod, then a malfunctioning turbocharger wastegate actuator control line or rod has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the turbocharger wastegate actuator control line.

Refer to Procedure 010-050

  • Replace the wastegate actuator rod.

Refer to Procedure 010-050

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Knock sensor is malfunctioning

Solution: S00004356

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Inspect the appropriate knock sensor.

Refer to Procedure 019-346

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the knock sensor.

Refer to Procedure 019-346

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Spark plug is damaged

Solution: S00003531

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove all of the spark plugs.

Refer to Procedure 013-016

  • Measure the spark plug gap.

Refer to Procedure 013-016

  • Check the spark plugs.

Refer to Service Bulletin 4383578

Specification

  • If the spark plugs do not meet specification, then reset the search to the correct symptom according to the service bulletin.
  • If the spark plug gap is incorrect, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Correct the spark plug gap.

Refer to Procedure 013-016

  • Replace the spark plug.

Refer to Procedure 013-016

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Ignition Coil Test

Solution: S00004217

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect ignition coil body for cracks.

Refer to Procedure 013-012

Refer to Service Bulletin 4383630

  • Perform the ignition coil test.

Refer to Procedure 013-012

Specification

  • If any damage is found, then proceed to the Repair section.
  • If no spark was observed during the coil test, then proceed to the Linked Solutions section.

Linked Solutions

  • Ignition control wiring harness open circuit check

Refer to S00005711

  • Ignition control wiring harness circuit pin to ground short

Refer to S00005713

  • Ignition control wiring harness circuit pin to pin short

Refer to S00005715

  • Ignition control module open circuit check

Refer to S00005712

  • Ignition control module circuit pin to ground short

Refer to S00005714

  • Ignition control module circuit pin to pin short

Refer to S00006731

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil pack.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5.1 - Ignition control wiring harness open circuit check

Solution: S00005711

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.2 - Ignition control wiring harness circuit pin to ground short

Solution: S00005713

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connector C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the charge voltage pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the secondary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the primary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.3 - Ignition control wiring harness circuit pin to pin short

Solution: S00005715

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control wiring harness charge voltage SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness secondary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness primary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.4 - Ignition control module open circuit check

Solution: S00005712

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the ignition control module C1 connector and the combustion detection SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the ignition control module C1 connector and the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the ignition control module C1 connector and the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module RETURN pin at the ignition control module C1 connector and the ignition control module RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the ignition control module C1 connector and the spark voltage SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.5 - Ignition control module circuit pin to ground short

Solution: S00005714

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.6 - Ignition control module circuit pin to pin short

Solution: S00006731

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - Engine Compression Test

Solution: S00006439

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the Engine Compression Test.

Refer to Procedure 014-012

Specification

  • If the Engine Compression Test is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the piston.

Refer to Procedure 001-043

  • Replace the piston ring.

Refer to Procedure 001-047

  • Repair or replace the cylinder liner.

Refer to Procedure 001-028

  • Replace the cylinder head.

Refer to Procedure 002-004

Validation

  • None
Next Solution

7 - Overhead component damaged or out of adjustment

Solution: S00008484

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

  • Adjust the overhead.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Cylinder Leak Down Test

Solution: S00005891

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the Cylinder Leak Down Test.

Refer to Procedure 014-026

  • Visually inspect the pistons.

Refer to Procedure 001-043

  • Visually inspect the piston rings.

Refer to Procedure 001-047

  • Visually inspect the cylinder liners.

Refer to Procedure 001-028

Specification

  • If the Cylinder Leak Down Test does not meet specification, then a malfunctioning power cylinder component has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the piston.

Refer to Procedure 001-043

  • Replace the piston ring.

Refer to Procedure 001-047

  • Repair or replace the cylinder liner.

Refer to Procedure 001-028

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2435 | SPN: 1356 | FMI: 15
Engine Cylinder 5 (A3) Knock - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Turbocharger wastegate actuator is malfunctioning
  3. Knock sensor is malfunctioning
  4. Spark plug is damaged
  5. Ignition Coil Test
  6. Ignition control wiring harness open circuit check
  7. Ignition control wiring harness circuit pin to ground short
  8. Ignition control wiring harness circuit pin to pin short
  9. Ignition control module open circuit check
  10. Ignition control module circuit pin to ground short
  11. Ignition control module circuit pin to pin short
  12. Engine Compression Test
  13. Overhead component damaged or out of adjustment
  14. Cylinder Leak Down Test
  15. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002259

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Knock sensor: 575

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Turbocharger wastegate actuator is malfunctioning

Solution: S00003427

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the turbocharger wastegate actuator control line for damage.

Refer to Procedure 010-050

  • Measure the turbocharger wastegate actuator rod travel.

Refer to Procedure 010-050

Specification

  • If incorrect travel or damage is found on the turbocharger wastegate actuator control line, or rod, then a malfunctioning turbocharger wastegate actuator control line or rod has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the turbocharger wastegate actuator control line.

Refer to Procedure 010-050

  • Replace the wastegate actuator rod.

Refer to Procedure 010-050

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Knock sensor is malfunctioning

Solution: S00004356

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Inspect the appropriate knock sensor.

Refer to Procedure 019-346

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the knock sensor.

Refer to Procedure 019-346

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Spark plug is damaged

Solution: S00003531

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove all of the spark plugs.

Refer to Procedure 013-016

  • Measure the spark plug gap.

Refer to Procedure 013-016

  • Check the spark plugs.

Refer to Service Bulletin 4383578

Specification

  • If the spark plugs do not meet specification, then reset the search to the correct symptom according to the service bulletin.
  • If the spark plug gap is incorrect, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Correct the spark plug gap.

Refer to Procedure 013-016

  • Replace the spark plug.

Refer to Procedure 013-016

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Ignition Coil Test

Solution: S00004217

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect ignition coil body for cracks.

Refer to Procedure 013-012

Refer to Service Bulletin 4383630

  • Perform the ignition coil test.

Refer to Procedure 013-012

Specification

  • If any damage is found, then proceed to the Repair section.
  • If no spark was observed during the coil test, then proceed to the Linked Solutions section.

Linked Solutions

  • Ignition control wiring harness open circuit check

Refer to S00005711

  • Ignition control wiring harness circuit pin to ground short

Refer to S00005713

  • Ignition control wiring harness circuit pin to pin short

Refer to S00005715

  • Ignition control module open circuit check

Refer to S00005712

  • Ignition control module circuit pin to ground short

Refer to S00005714

  • Ignition control module circuit pin to pin short

Refer to S00006731

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil pack.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5.1 - Ignition control wiring harness open circuit check

Solution: S00005711

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.2 - Ignition control wiring harness circuit pin to ground short

Solution: S00005713

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connector C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the charge voltage pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the secondary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the primary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.3 - Ignition control wiring harness circuit pin to pin short

Solution: S00005715

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control wiring harness charge voltage SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness secondary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness primary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.4 - Ignition control module open circuit check

Solution: S00005712

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the ignition control module C1 connector and the combustion detection SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the ignition control module C1 connector and the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the ignition control module C1 connector and the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module RETURN pin at the ignition control module C1 connector and the ignition control module RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the ignition control module C1 connector and the spark voltage SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.5 - Ignition control module circuit pin to ground short

Solution: S00005714

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.6 - Ignition control module circuit pin to pin short

Solution: S00006731

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - Engine Compression Test

Solution: S00006439

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the Engine Compression Test.

Refer to Procedure 014-012

Specification

  • If the Engine Compression Test is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the piston.

Refer to Procedure 001-043

  • Replace the piston ring.

Refer to Procedure 001-047

  • Repair or replace the cylinder liner.

Refer to Procedure 001-028

  • Replace the cylinder head.

Refer to Procedure 002-004

Validation

  • None
Next Solution

7 - Overhead component damaged or out of adjustment

Solution: S00008484

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

  • Adjust the overhead.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Cylinder Leak Down Test

Solution: S00005891

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the Cylinder Leak Down Test.

Refer to Procedure 014-026

  • Visually inspect the pistons.

Refer to Procedure 001-043

  • Visually inspect the piston rings.

Refer to Procedure 001-047

  • Visually inspect the cylinder liners.

Refer to Procedure 001-028

Specification

  • If the Cylinder Leak Down Test does not meet specification, then a malfunctioning power cylinder component has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the piston.

Refer to Procedure 001-043

  • Replace the piston ring.

Refer to Procedure 001-047

  • Repair or replace the cylinder liner.

Refer to Procedure 001-028

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2436 | SPN: 1357 | FMI: 15
Engine Cylinder 6 (B3) Knock - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Turbocharger wastegate actuator is malfunctioning
  3. Knock sensor is malfunctioning
  4. Spark plug is damaged
  5. Ignition Coil Test
  6. Ignition control wiring harness open circuit check
  7. Ignition control wiring harness circuit pin to ground short
  8. Ignition control wiring harness circuit pin to pin short
  9. Ignition control module open circuit check
  10. Ignition control module circuit pin to ground short
  11. Ignition control module circuit pin to pin short
  12. Engine Compression Test
  13. Overhead component damaged or out of adjustment
  14. Cylinder Leak Down Test
  15. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002259

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Knock sensor: 575

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Turbocharger wastegate actuator is malfunctioning

Solution: S00003427

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the turbocharger wastegate actuator control line for damage.

Refer to Procedure 010-050

  • Measure the turbocharger wastegate actuator rod travel.

Refer to Procedure 010-050

Specification

  • If incorrect travel or damage is found on the turbocharger wastegate actuator control line, or rod, then a malfunctioning turbocharger wastegate actuator control line or rod has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the turbocharger wastegate actuator control line.

Refer to Procedure 010-050

  • Replace the wastegate actuator rod.

Refer to Procedure 010-050

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Knock sensor is malfunctioning

Solution: S00004356

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Inspect the appropriate knock sensor.

Refer to Procedure 019-346

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the knock sensor.

Refer to Procedure 019-346

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Spark plug is damaged

Solution: S00003531

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove all of the spark plugs.

Refer to Procedure 013-016

  • Measure the spark plug gap.

Refer to Procedure 013-016

  • Check the spark plugs.

Refer to Service Bulletin 4383578

Specification

  • If the spark plugs do not meet specification, then reset the search to the correct symptom according to the service bulletin.
  • If the spark plug gap is incorrect, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Correct the spark plug gap.

Refer to Procedure 013-016

  • Replace the spark plug.

Refer to Procedure 013-016

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Ignition Coil Test

Solution: S00004217

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect ignition coil body for cracks.

Refer to Procedure 013-012

Refer to Service Bulletin 4383630

  • Perform the ignition coil test.

Refer to Procedure 013-012

Specification

  • If any damage is found, then proceed to the Repair section.
  • If no spark was observed during the coil test, then proceed to the Linked Solutions section.

Linked Solutions

  • Ignition control wiring harness open circuit check

Refer to S00005711

  • Ignition control wiring harness circuit pin to ground short

Refer to S00005713

  • Ignition control wiring harness circuit pin to pin short

Refer to S00005715

  • Ignition control module open circuit check

Refer to S00005712

  • Ignition control module circuit pin to ground short

Refer to S00005714

  • Ignition control module circuit pin to pin short

Refer to S00006731

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil pack.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5.1 - Ignition control wiring harness open circuit check

Solution: S00005711

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.2 - Ignition control wiring harness circuit pin to ground short

Solution: S00005713

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connector C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the charge voltage pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the secondary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the primary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.3 - Ignition control wiring harness circuit pin to pin short

Solution: S00005715

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control wiring harness charge voltage SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness secondary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness primary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.4 - Ignition control module open circuit check

Solution: S00005712

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the ignition control module C1 connector and the combustion detection SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the ignition control module C1 connector and the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the ignition control module C1 connector and the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module RETURN pin at the ignition control module C1 connector and the ignition control module RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the ignition control module C1 connector and the spark voltage SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.5 - Ignition control module circuit pin to ground short

Solution: S00005714

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.6 - Ignition control module circuit pin to pin short

Solution: S00006731

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - Engine Compression Test

Solution: S00006439

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the Engine Compression Test.

Refer to Procedure 014-012

Specification

  • If the Engine Compression Test is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the piston.

Refer to Procedure 001-043

  • Replace the piston ring.

Refer to Procedure 001-047

  • Repair or replace the cylinder liner.

Refer to Procedure 001-028

  • Replace the cylinder head.

Refer to Procedure 002-004

Validation

  • None
Next Solution

7 - Overhead component damaged or out of adjustment

Solution: S00008484

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

  • Adjust the overhead.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Cylinder Leak Down Test

Solution: S00005891

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the Cylinder Leak Down Test.

Refer to Procedure 014-026

  • Visually inspect the pistons.

Refer to Procedure 001-043

  • Visually inspect the piston rings.

Refer to Procedure 001-047

  • Visually inspect the cylinder liners.

Refer to Procedure 001-028

Specification

  • If the Cylinder Leak Down Test does not meet specification, then a malfunctioning power cylinder component has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the piston.

Refer to Procedure 001-043

  • Replace the piston ring.

Refer to Procedure 001-047

  • Repair or replace the cylinder liner.

Refer to Procedure 001-028

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2448 | SPN: 111 | FMI: 17
Coolant Level - Data Valid But Below Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Coolant level check
  3. Coolant level sensor open circuit check
  4. Coolant level sensor circuit pin to ground short
  5. Coolant level sensor circuit pin to pin short
  6. ECM calibration revision history check
  7. Coolant level sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00010587

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 operating hours from the following list:

  • Coolant level: 195, 196

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Coolant level check

Solution: S00003142

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the coolant level.
  • Perform the Coolant System Pressure Test.

Refer to Procedure 008-018

  • Visually inspect for external coolant leaks.

Specification

  • If the coolant level is low and there are signs of external coolant leaks, then reset the search to external coolant leak.
  • If the coolant level is low and there are no signs of external coolant leaks, then reset the search to internal coolant leak.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3 - Coolant level sensor open circuit check

Solution: S00007920

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Coolant level sensor circuit pin to ground short

Solution: S00007921

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Coolant level sensor circuit pin to pin short

Solution: S00007922

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor SUPPLY pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Coolant level sensor is malfunctioning

Solution: S00007923

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning coolant level sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace engine coolant level sensor.

Refer to Procedure 019-017

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2451 | SPN: 2789 | FMI: 16
Turbocharger Turbine Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Restricted intake air filter
  2. Turbocharger turbine intake temperature sensor is stuck in-range
  3. Turbocharger wastegate actuator is malfunctioning
  4. ECM calibration revision history check

1 - Restricted intake air filter

Solution: S00000025

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Specification

  • If the intake air filter is plugged, then a restricted intake air filter has been detected.

Linked Solutions

  • None

Repair

  • Replace the air filter.

Refer to OEM Service Manual

Refer to Procedure 010-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Turbocharger turbine intake temperature sensor is stuck in-range

Solution: S00004819

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Run the engine at idle.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the turbocharger turbine intake temperature sensor.

Specification

  • A malfunctioning turbocharger turbine intake temperature sensor has been detected if the temperature reading is greater than the following specification: 790°C [1454°F]

Linked Solutions

  • None

Repair

  • Replace the turbocharger turbine intake temperature sensor.

Refer to Procedure 019-473

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Turbocharger wastegate actuator is malfunctioning

Solution: S00006413

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the turbocharger wastegate actuator for damage.

Refer to Procedure 010-050

  • Visually inspect the turbocharger wastegate valve seat.

Refer to Procedure 010-033

  • Inspect the turbocharger wastegate valve body assembly for damage.

Refer to Procedure 010-055

  • Perform the Turbocharger Wastegate Actuator Test.

Refer to Procedure 010-050

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace turbocharger wastegate.

Refer to Procedure 010-033

  • Replace turbocharger wastegate actuator.

Refer to Procedure 010-050

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2457 | SPN: 1322 | FMI: 31
Engine Misfire for Multiple Cylinders - Condition Exists

Troubleshooting Summary

  1. Fuel pressure check
  2. Check for primary fault codes
  3. EGR system leak or restriction
  4. EGR cooler is internally leaking
  5. Spark plug is damaged
  6. Ignition Coil Test
  7. Ignition control wiring harness open circuit check
  8. Ignition control wiring harness circuit pin to ground short
  9. Ignition control wiring harness circuit pin to pin short
  10. Ignition control module open circuit check
  11. Ignition control module circuit pin to ground short
  12. Ignition control module circuit pin to pin short
  13. Overhead component damaged or out of adjustment
  14. ECM calibration revision history check

1 - Fuel pressure check

Solution: S00004450

Verification

Conditions

  • Turn keyswitch OFF.
  • Verify all fuel shutoff valves are in the open position.

Action

  • Verify the fuel gauge is working properly.

Refer to OEM Service Manual

  • Verify the fuel tank pressure meets specification.

Refer to OEM Service Manual

  • Verify the fuel regulator intake pressure meets specifications.

Refer to Procedure 005-061

Specification

  • If any of the checks are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Add fuel if needed.

Refer to OEM Service Manual

  • For an OEM issue: Contact the OEM for further repair instructions.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Check for primary fault codes

Solution: S00001452

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Ignition: 6883, 6884, 6966, 6967, 6968, 6969, 6971, 6972, 7192

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

3 - EGR system leak or restriction

Solution: S00005702

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the EGR crossover tube.

Refer to Procedure 011-070

  • Visually inspect the EGR connection tube or crossover tube for traces of coolant.

Specification

  • If leaks or damage are present in the EGR system, then proceed to the Linked Solutions section.

Linked Solutions

  • EGR cooler is internally leaking

Refer to S00005827

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - EGR cooler is internally leaking

Solution: S00005827

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the EGR cooler pressure test.

Refer to Procedure 011-019

Specification

  • If the EGR cooler pressure test does not meet specification, then a malfunctioning EGR cooler has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace damaged components.
  • Replace the EGR cooler.

Refer to Procedure 011-019

  • Replace the spark plugs.

Refer to Procedure 013-016

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Spark plug is damaged

Solution: S00003531

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove all of the spark plugs.

Refer to Procedure 013-016

  • Measure the spark plug gap.

Refer to Procedure 013-016

  • Check the spark plugs.

Refer to Service Bulletin 4383578

Specification

  • If the spark plugs do not meet specification, then reset the search to the correct symptom according to the service bulletin.
  • If the spark plug gap is incorrect, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Correct the spark plug gap.

Refer to Procedure 013-016

  • Replace the spark plug.

Refer to Procedure 013-016

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Ignition Coil Test

Solution: S00004217

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect ignition coil body for cracks.

Refer to Procedure 013-012

Refer to Service Bulletin 4383630

  • Perform the ignition coil test.

Refer to Procedure 013-012

Specification

  • If any damage is found, then proceed to the Repair section.
  • If no spark was observed during the coil test, then proceed to the Linked Solutions section.

Linked Solutions

  • Ignition control wiring harness open circuit check

Refer to S00005711

  • Ignition control wiring harness circuit pin to ground short

Refer to S00005713

  • Ignition control wiring harness circuit pin to pin short

Refer to S00005715

  • Ignition control module open circuit check

Refer to S00005712

  • Ignition control module circuit pin to ground short

Refer to S00005714

  • Ignition control module circuit pin to pin short

Refer to S00006731

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil pack.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5.1 - Ignition control wiring harness open circuit check

Solution: S00005711

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.2 - Ignition control wiring harness circuit pin to ground short

Solution: S00005713

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connector C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the charge voltage pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the secondary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the primary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.3 - Ignition control wiring harness circuit pin to pin short

Solution: S00005715

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control wiring harness charge voltage SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness secondary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness primary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.4 - Ignition control module open circuit check

Solution: S00005712

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the ignition control module C1 connector and the combustion detection SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the ignition control module C1 connector and the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the ignition control module C1 connector and the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module RETURN pin at the ignition control module C1 connector and the ignition control module RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the ignition control module C1 connector and the spark voltage SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.5 - Ignition control module circuit pin to ground short

Solution: S00005714

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.6 - Ignition control module circuit pin to pin short

Solution: S00006731

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - Overhead component damaged or out of adjustment

Solution: S00008484

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

  • Adjust the overhead.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2517 | SPN: 1127 | FMI: 3
Engine Turbocharger 1 Boost Pressure Sensor - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Turbocharger compressor intake pressure sensor circuit response at the ECM
  3. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002469

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 2: 187, 227

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Turbocharger compressor intake pressure sensor circuit response at the ECM

Solution: S00003544

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 2518
  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 2518

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2518 | SPN: 1127 | FMI: 4
Engine Turbocharger 1 Boost Pressure Sensor - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001645

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 2: 187

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2533 | SPN: 1323 | FMI: 31
Engine Misfire Cylinder 1 - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. Spark plug is damaged
  3. Ignition Coil Test
  4. Ignition control wiring harness open circuit check
  5. Ignition control wiring harness circuit pin to ground short
  6. Ignition control wiring harness circuit pin to pin short
  7. Ignition control module open circuit check
  8. Ignition control module circuit pin to ground short
  9. Ignition control module circuit pin to pin short
  10. Overhead component damaged or out of adjustment
  11. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001452

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Ignition: 6883, 6884, 6966, 6967, 6968, 6969, 6971, 6972, 7192

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Spark plug is damaged

Solution: S00003531

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove all of the spark plugs.

Refer to Procedure 013-016

  • Measure the spark plug gap.

Refer to Procedure 013-016

  • Check the spark plugs.

Refer to Service Bulletin 4383578

Specification

  • If the spark plugs do not meet specification, then reset the search to the correct symptom according to the service bulletin.
  • If the spark plug gap is incorrect, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Correct the spark plug gap.

Refer to Procedure 013-016

  • Replace the spark plug.

Refer to Procedure 013-016

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Ignition Coil Test

Solution: S00004217

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect ignition coil body for cracks.

Refer to Procedure 013-012

Refer to Service Bulletin 4383630

  • Perform the ignition coil test.

Refer to Procedure 013-012

Specification

  • If any damage is found, then proceed to the Repair section.
  • If no spark was observed during the coil test, then proceed to the Linked Solutions section.

Linked Solutions

  • Ignition control wiring harness open circuit check

Refer to S00005711

  • Ignition control wiring harness circuit pin to ground short

Refer to S00005713

  • Ignition control wiring harness circuit pin to pin short

Refer to S00005715

  • Ignition control module open circuit check

Refer to S00005712

  • Ignition control module circuit pin to ground short

Refer to S00005714

  • Ignition control module circuit pin to pin short

Refer to S00006731

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil pack.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3.1 - Ignition control wiring harness open circuit check

Solution: S00005711

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.2 - Ignition control wiring harness circuit pin to ground short

Solution: S00005713

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connector C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the charge voltage pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the secondary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the primary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.3 - Ignition control wiring harness circuit pin to pin short

Solution: S00005715

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control wiring harness charge voltage SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness secondary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness primary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.4 - Ignition control module open circuit check

Solution: S00005712

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the ignition control module C1 connector and the combustion detection SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the ignition control module C1 connector and the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the ignition control module C1 connector and the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module RETURN pin at the ignition control module C1 connector and the ignition control module RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the ignition control module C1 connector and the spark voltage SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.5 - Ignition control module circuit pin to ground short

Solution: S00005714

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.6 - Ignition control module circuit pin to pin short

Solution: S00006731

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Overhead component damaged or out of adjustment

Solution: S00008484

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

  • Adjust the overhead.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2534 | SPN: 1324 | FMI: 31
Engine Misfire Cylinder 2 - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. Spark plug is damaged
  3. Ignition Coil Test
  4. Ignition control wiring harness open circuit check
  5. Ignition control wiring harness circuit pin to ground short
  6. Ignition control wiring harness circuit pin to pin short
  7. Ignition control module open circuit check
  8. Ignition control module circuit pin to ground short
  9. Ignition control module circuit pin to pin short
  10. Overhead component damaged or out of adjustment
  11. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001452

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Ignition: 6883, 6884, 6966, 6967, 6968, 6969, 6971, 6972, 7192

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Spark plug is damaged

Solution: S00003531

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove all of the spark plugs.

Refer to Procedure 013-016

  • Measure the spark plug gap.

Refer to Procedure 013-016

  • Check the spark plugs.

Refer to Service Bulletin 4383578

Specification

  • If the spark plugs do not meet specification, then reset the search to the correct symptom according to the service bulletin.
  • If the spark plug gap is incorrect, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Correct the spark plug gap.

Refer to Procedure 013-016

  • Replace the spark plug.

Refer to Procedure 013-016

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Ignition Coil Test

Solution: S00004217

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect ignition coil body for cracks.

Refer to Procedure 013-012

Refer to Service Bulletin 4383630

  • Perform the ignition coil test.

Refer to Procedure 013-012

Specification

  • If any damage is found, then proceed to the Repair section.
  • If no spark was observed during the coil test, then proceed to the Linked Solutions section.

Linked Solutions

  • Ignition control wiring harness open circuit check

Refer to S00005711

  • Ignition control wiring harness circuit pin to ground short

Refer to S00005713

  • Ignition control wiring harness circuit pin to pin short

Refer to S00005715

  • Ignition control module open circuit check

Refer to S00005712

  • Ignition control module circuit pin to ground short

Refer to S00005714

  • Ignition control module circuit pin to pin short

Refer to S00006731

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil pack.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3.1 - Ignition control wiring harness open circuit check

Solution: S00005711

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.2 - Ignition control wiring harness circuit pin to ground short

Solution: S00005713

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connector C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the charge voltage pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the secondary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the primary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.3 - Ignition control wiring harness circuit pin to pin short

Solution: S00005715

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control wiring harness charge voltage SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness secondary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness primary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.4 - Ignition control module open circuit check

Solution: S00005712

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the ignition control module C1 connector and the combustion detection SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the ignition control module C1 connector and the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the ignition control module C1 connector and the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module RETURN pin at the ignition control module C1 connector and the ignition control module RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the ignition control module C1 connector and the spark voltage SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.5 - Ignition control module circuit pin to ground short

Solution: S00005714

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.6 - Ignition control module circuit pin to pin short

Solution: S00006731

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Overhead component damaged or out of adjustment

Solution: S00008484

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

  • Adjust the overhead.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2535 | SPN: 1325 | FMI: 31
Engine Misfire Cylinder 3 - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. Spark plug is damaged
  3. Ignition Coil Test
  4. Ignition control wiring harness open circuit check
  5. Ignition control wiring harness circuit pin to ground short
  6. Ignition control wiring harness circuit pin to pin short
  7. Ignition control module open circuit check
  8. Ignition control module circuit pin to ground short
  9. Ignition control module circuit pin to pin short
  10. Overhead component damaged or out of adjustment
  11. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001452

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Ignition: 6883, 6884, 6966, 6967, 6968, 6969, 6971, 6972, 7192

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Spark plug is damaged

Solution: S00003531

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove all of the spark plugs.

Refer to Procedure 013-016

  • Measure the spark plug gap.

Refer to Procedure 013-016

  • Check the spark plugs.

Refer to Service Bulletin 4383578

Specification

  • If the spark plugs do not meet specification, then reset the search to the correct symptom according to the service bulletin.
  • If the spark plug gap is incorrect, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Correct the spark plug gap.

Refer to Procedure 013-016

  • Replace the spark plug.

Refer to Procedure 013-016

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Ignition Coil Test

Solution: S00004217

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect ignition coil body for cracks.

Refer to Procedure 013-012

Refer to Service Bulletin 4383630

  • Perform the ignition coil test.

Refer to Procedure 013-012

Specification

  • If any damage is found, then proceed to the Repair section.
  • If no spark was observed during the coil test, then proceed to the Linked Solutions section.

Linked Solutions

  • Ignition control wiring harness open circuit check

Refer to S00005711

  • Ignition control wiring harness circuit pin to ground short

Refer to S00005713

  • Ignition control wiring harness circuit pin to pin short

Refer to S00005715

  • Ignition control module open circuit check

Refer to S00005712

  • Ignition control module circuit pin to ground short

Refer to S00005714

  • Ignition control module circuit pin to pin short

Refer to S00006731

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil pack.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3.1 - Ignition control wiring harness open circuit check

Solution: S00005711

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.2 - Ignition control wiring harness circuit pin to ground short

Solution: S00005713

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connector C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the charge voltage pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the secondary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the primary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.3 - Ignition control wiring harness circuit pin to pin short

Solution: S00005715

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control wiring harness charge voltage SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness secondary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness primary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.4 - Ignition control module open circuit check

Solution: S00005712

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the ignition control module C1 connector and the combustion detection SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the ignition control module C1 connector and the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the ignition control module C1 connector and the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module RETURN pin at the ignition control module C1 connector and the ignition control module RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the ignition control module C1 connector and the spark voltage SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.5 - Ignition control module circuit pin to ground short

Solution: S00005714

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.6 - Ignition control module circuit pin to pin short

Solution: S00006731

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Overhead component damaged or out of adjustment

Solution: S00008484

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

  • Adjust the overhead.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2536 | SPN: 1326 | FMI: 31
Engine Misfire Cylinder 4 - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. Spark plug is damaged
  3. Ignition Coil Test
  4. Ignition control wiring harness open circuit check
  5. Ignition control wiring harness circuit pin to ground short
  6. Ignition control wiring harness circuit pin to pin short
  7. Ignition control module open circuit check
  8. Ignition control module circuit pin to ground short
  9. Ignition control module circuit pin to pin short
  10. Overhead component damaged or out of adjustment
  11. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001452

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Ignition: 6883, 6884, 6966, 6967, 6968, 6969, 6971, 6972, 7192

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Spark plug is damaged

Solution: S00003531

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove all of the spark plugs.

Refer to Procedure 013-016

  • Measure the spark plug gap.

Refer to Procedure 013-016

  • Check the spark plugs.

Refer to Service Bulletin 4383578

Specification

  • If the spark plugs do not meet specification, then reset the search to the correct symptom according to the service bulletin.
  • If the spark plug gap is incorrect, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Correct the spark plug gap.

Refer to Procedure 013-016

  • Replace the spark plug.

Refer to Procedure 013-016

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Ignition Coil Test

Solution: S00004217

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect ignition coil body for cracks.

Refer to Procedure 013-012

Refer to Service Bulletin 4383630

  • Perform the ignition coil test.

Refer to Procedure 013-012

Specification

  • If any damage is found, then proceed to the Repair section.
  • If no spark was observed during the coil test, then proceed to the Linked Solutions section.

Linked Solutions

  • Ignition control wiring harness open circuit check

Refer to S00005711

  • Ignition control wiring harness circuit pin to ground short

Refer to S00005713

  • Ignition control wiring harness circuit pin to pin short

Refer to S00005715

  • Ignition control module open circuit check

Refer to S00005712

  • Ignition control module circuit pin to ground short

Refer to S00005714

  • Ignition control module circuit pin to pin short

Refer to S00006731

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil pack.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3.1 - Ignition control wiring harness open circuit check

Solution: S00005711

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.2 - Ignition control wiring harness circuit pin to ground short

Solution: S00005713

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connector C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the charge voltage pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the secondary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the primary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.3 - Ignition control wiring harness circuit pin to pin short

Solution: S00005715

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control wiring harness charge voltage SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness secondary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness primary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.4 - Ignition control module open circuit check

Solution: S00005712

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the ignition control module C1 connector and the combustion detection SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the ignition control module C1 connector and the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the ignition control module C1 connector and the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module RETURN pin at the ignition control module C1 connector and the ignition control module RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the ignition control module C1 connector and the spark voltage SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.5 - Ignition control module circuit pin to ground short

Solution: S00005714

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.6 - Ignition control module circuit pin to pin short

Solution: S00006731

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Overhead component damaged or out of adjustment

Solution: S00008484

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

  • Adjust the overhead.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2537 | SPN: 1327 | FMI: 31
Engine Misfire Cylinder 5 - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. Spark plug is damaged
  3. Ignition Coil Test
  4. Ignition control wiring harness open circuit check
  5. Ignition control wiring harness circuit pin to ground short
  6. Ignition control wiring harness circuit pin to pin short
  7. Ignition control module open circuit check
  8. Ignition control module circuit pin to ground short
  9. Ignition control module circuit pin to pin short
  10. Overhead component damaged or out of adjustment
  11. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001452

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Ignition: 6883, 6884, 6966, 6967, 6968, 6969, 6971, 6972, 7192

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Spark plug is damaged

Solution: S00003531

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove all of the spark plugs.

Refer to Procedure 013-016

  • Measure the spark plug gap.

Refer to Procedure 013-016

  • Check the spark plugs.

Refer to Service Bulletin 4383578

Specification

  • If the spark plugs do not meet specification, then reset the search to the correct symptom according to the service bulletin.
  • If the spark plug gap is incorrect, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Correct the spark plug gap.

Refer to Procedure 013-016

  • Replace the spark plug.

Refer to Procedure 013-016

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Ignition Coil Test

Solution: S00004217

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect ignition coil body for cracks.

Refer to Procedure 013-012

Refer to Service Bulletin 4383630

  • Perform the ignition coil test.

Refer to Procedure 013-012

Specification

  • If any damage is found, then proceed to the Repair section.
  • If no spark was observed during the coil test, then proceed to the Linked Solutions section.

Linked Solutions

  • Ignition control wiring harness open circuit check

Refer to S00005711

  • Ignition control wiring harness circuit pin to ground short

Refer to S00005713

  • Ignition control wiring harness circuit pin to pin short

Refer to S00005715

  • Ignition control module open circuit check

Refer to S00005712

  • Ignition control module circuit pin to ground short

Refer to S00005714

  • Ignition control module circuit pin to pin short

Refer to S00006731

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil pack.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3.1 - Ignition control wiring harness open circuit check

Solution: S00005711

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.2 - Ignition control wiring harness circuit pin to ground short

Solution: S00005713

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connector C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the charge voltage pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the secondary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the primary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.3 - Ignition control wiring harness circuit pin to pin short

Solution: S00005715

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control wiring harness charge voltage SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness secondary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness primary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.4 - Ignition control module open circuit check

Solution: S00005712

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the ignition control module C1 connector and the combustion detection SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the ignition control module C1 connector and the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the ignition control module C1 connector and the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module RETURN pin at the ignition control module C1 connector and the ignition control module RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the ignition control module C1 connector and the spark voltage SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.5 - Ignition control module circuit pin to ground short

Solution: S00005714

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.6 - Ignition control module circuit pin to pin short

Solution: S00006731

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Overhead component damaged or out of adjustment

Solution: S00008484

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

  • Adjust the overhead.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2538 | SPN: 1328 | FMI: 31
Engine Misfire Cylinder 6 - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. Spark plug is damaged
  3. Ignition Coil Test
  4. Ignition control wiring harness open circuit check
  5. Ignition control wiring harness circuit pin to ground short
  6. Ignition control wiring harness circuit pin to pin short
  7. Ignition control module open circuit check
  8. Ignition control module circuit pin to ground short
  9. Ignition control module circuit pin to pin short
  10. Overhead component damaged or out of adjustment
  11. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001452

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Ignition: 6883, 6884, 6966, 6967, 6968, 6969, 6971, 6972, 7192

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Spark plug is damaged

Solution: S00003531

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove all of the spark plugs.

Refer to Procedure 013-016

  • Measure the spark plug gap.

Refer to Procedure 013-016

  • Check the spark plugs.

Refer to Service Bulletin 4383578

Specification

  • If the spark plugs do not meet specification, then reset the search to the correct symptom according to the service bulletin.
  • If the spark plug gap is incorrect, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Correct the spark plug gap.

Refer to Procedure 013-016

  • Replace the spark plug.

Refer to Procedure 013-016

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Ignition Coil Test

Solution: S00004217

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect ignition coil body for cracks.

Refer to Procedure 013-012

Refer to Service Bulletin 4383630

  • Perform the ignition coil test.

Refer to Procedure 013-012

Specification

  • If any damage is found, then proceed to the Repair section.
  • If no spark was observed during the coil test, then proceed to the Linked Solutions section.

Linked Solutions

  • Ignition control wiring harness open circuit check

Refer to S00005711

  • Ignition control wiring harness circuit pin to ground short

Refer to S00005713

  • Ignition control wiring harness circuit pin to pin short

Refer to S00005715

  • Ignition control module open circuit check

Refer to S00005712

  • Ignition control module circuit pin to ground short

Refer to S00005714

  • Ignition control module circuit pin to pin short

Refer to S00006731

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil pack.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3.1 - Ignition control wiring harness open circuit check

Solution: S00005711

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.2 - Ignition control wiring harness circuit pin to ground short

Solution: S00005713

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connector C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the charge voltage pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the secondary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the primary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.3 - Ignition control wiring harness circuit pin to pin short

Solution: S00005715

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control wiring harness charge voltage SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness secondary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness primary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.4 - Ignition control module open circuit check

Solution: S00005712

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the ignition control module C1 connector and the combustion detection SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the ignition control module C1 connector and the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the ignition control module C1 connector and the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module RETURN pin at the ignition control module C1 connector and the ignition control module RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the ignition control module C1 connector and the spark voltage SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.5 - Ignition control module circuit pin to ground short

Solution: S00005714

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.6 - Ignition control module circuit pin to pin short

Solution: S00006731

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Overhead component damaged or out of adjustment

Solution: S00008484

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

  • Adjust the overhead.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2568 | SPN: 159 | FMI: 0
Gas Supply Pressure (Regulated) - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Fuel inlet pressure sensor stuck in-range
  3. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002121

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 1839, 1841

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Fuel inlet pressure sensor stuck in-range

Solution: S00004738

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Install a mechanical gauge on the engine.

Refer to Procedure 005-061

  • Start the engine.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the fuel regulator intake pressure.

Refer to Procedure 005-061

  • Compare the sensor reading with the recommended Cummins® electronic service tool or equivalent to a mechanical gauge.

Specification

  • A malfunctioning OEM fuel delivery system has been detected if the readings are within the following specification of each other: 5%
  • A malfunctioning fuel inlet pressure sensor has been detected if the readings are not within the following specification of each other: 5%

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM fuel system component.

Refer to OEM Service Manual

  • Replace the fuel inlet pressure sensor.

Refer to Procedure 019-188

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2586 | SPN: 1294 | FMI: 15
Engine Spark Plug #1 (A1) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Ignition Coil Test
  2. Ignition control wiring harness open circuit check
  3. Ignition control wiring harness circuit pin to ground short
  4. Ignition control wiring harness circuit pin to pin short
  5. Ignition control module open circuit check
  6. Ignition control module circuit pin to ground short
  7. Ignition control module circuit pin to pin short

1 - Ignition Coil Test

Solution: S00004217

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect ignition coil body for cracks.

Refer to Procedure 013-012

Refer to Service Bulletin 4383630

  • Perform the ignition coil test.

Refer to Procedure 013-012

Specification

  • If any damage is found, then proceed to the Repair section.
  • If no spark was observed during the coil test, then proceed to the Linked Solutions section.

Linked Solutions

  • Ignition control wiring harness open circuit check

Refer to S00005711

  • Ignition control wiring harness circuit pin to ground short

Refer to S00005713

  • Ignition control wiring harness circuit pin to pin short

Refer to S00005715

  • Ignition control module open circuit check

Refer to S00005712

  • Ignition control module circuit pin to ground short

Refer to S00005714

  • Ignition control module circuit pin to pin short

Refer to S00006731

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil pack.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

1.1 - Ignition control wiring harness open circuit check

Solution: S00005711

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.2 - Ignition control wiring harness circuit pin to ground short

Solution: S00005713

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connector C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the charge voltage pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the secondary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the primary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.3 - Ignition control wiring harness circuit pin to pin short

Solution: S00005715

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control wiring harness charge voltage SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness secondary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness primary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.4 - Ignition control module open circuit check

Solution: S00005712

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the ignition control module C1 connector and the combustion detection SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the ignition control module C1 connector and the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the ignition control module C1 connector and the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module RETURN pin at the ignition control module C1 connector and the ignition control module RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the ignition control module C1 connector and the spark voltage SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.5 - Ignition control module circuit pin to ground short

Solution: S00005714

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.6 - Ignition control module circuit pin to pin short

Solution: S00006731

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

Last Modified: 12-Dec-2021


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2587 | SPN: 1295 | FMI: 15
Engine Spark Plug #2 (B1) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Ignition Coil Test
  2. Ignition control wiring harness open circuit check
  3. Ignition control wiring harness circuit pin to ground short
  4. Ignition control wiring harness circuit pin to pin short
  5. Ignition control module open circuit check
  6. Ignition control module circuit pin to ground short
  7. Ignition control module circuit pin to pin short

1 - Ignition Coil Test

Solution: S00004217

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect ignition coil body for cracks.

Refer to Procedure 013-012

Refer to Service Bulletin 4383630

  • Perform the ignition coil test.

Refer to Procedure 013-012

Specification

  • If any damage is found, then proceed to the Repair section.
  • If no spark was observed during the coil test, then proceed to the Linked Solutions section.

Linked Solutions

  • Ignition control wiring harness open circuit check

Refer to S00005711

  • Ignition control wiring harness circuit pin to ground short

Refer to S00005713

  • Ignition control wiring harness circuit pin to pin short

Refer to S00005715

  • Ignition control module open circuit check

Refer to S00005712

  • Ignition control module circuit pin to ground short

Refer to S00005714

  • Ignition control module circuit pin to pin short

Refer to S00006731

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil pack.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

1.1 - Ignition control wiring harness open circuit check

Solution: S00005711

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.2 - Ignition control wiring harness circuit pin to ground short

Solution: S00005713

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connector C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the charge voltage pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the secondary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the primary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.3 - Ignition control wiring harness circuit pin to pin short

Solution: S00005715

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control wiring harness charge voltage SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness secondary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness primary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.4 - Ignition control module open circuit check

Solution: S00005712

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the ignition control module C1 connector and the combustion detection SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the ignition control module C1 connector and the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the ignition control module C1 connector and the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module RETURN pin at the ignition control module C1 connector and the ignition control module RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the ignition control module C1 connector and the spark voltage SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.5 - Ignition control module circuit pin to ground short

Solution: S00005714

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.6 - Ignition control module circuit pin to pin short

Solution: S00006731

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

Last Modified: 12-Dec-2021


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2588 | SPN: 1296 | FMI: 15
Engine Spark Plug #3 (A2) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Ignition Coil Test
  2. Ignition control wiring harness open circuit check
  3. Ignition control wiring harness circuit pin to ground short
  4. Ignition control wiring harness circuit pin to pin short
  5. Ignition control module open circuit check
  6. Ignition control module circuit pin to ground short
  7. Ignition control module circuit pin to pin short

1 - Ignition Coil Test

Solution: S00004217

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect ignition coil body for cracks.

Refer to Procedure 013-012

Refer to Service Bulletin 4383630

  • Perform the ignition coil test.

Refer to Procedure 013-012

Specification

  • If any damage is found, then proceed to the Repair section.
  • If no spark was observed during the coil test, then proceed to the Linked Solutions section.

Linked Solutions

  • Ignition control wiring harness open circuit check

Refer to S00005711

  • Ignition control wiring harness circuit pin to ground short

Refer to S00005713

  • Ignition control wiring harness circuit pin to pin short

Refer to S00005715

  • Ignition control module open circuit check

Refer to S00005712

  • Ignition control module circuit pin to ground short

Refer to S00005714

  • Ignition control module circuit pin to pin short

Refer to S00006731

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil pack.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

1.1 - Ignition control wiring harness open circuit check

Solution: S00005711

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.2 - Ignition control wiring harness circuit pin to ground short

Solution: S00005713

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connector C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the charge voltage pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the secondary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the primary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.3 - Ignition control wiring harness circuit pin to pin short

Solution: S00005715

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control wiring harness charge voltage SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness secondary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness primary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.4 - Ignition control module open circuit check

Solution: S00005712

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the ignition control module C1 connector and the combustion detection SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the ignition control module C1 connector and the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the ignition control module C1 connector and the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module RETURN pin at the ignition control module C1 connector and the ignition control module RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the ignition control module C1 connector and the spark voltage SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.5 - Ignition control module circuit pin to ground short

Solution: S00005714

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.6 - Ignition control module circuit pin to pin short

Solution: S00006731

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

Last Modified: 12-Dec-2021


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2589 | SPN: 1297 | FMI: 15
Engine Spark Plug #4 (B2) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Ignition Coil Test
  2. Ignition control wiring harness open circuit check
  3. Ignition control wiring harness circuit pin to ground short
  4. Ignition control wiring harness circuit pin to pin short
  5. Ignition control module open circuit check
  6. Ignition control module circuit pin to ground short
  7. Ignition control module circuit pin to pin short

1 - Ignition Coil Test

Solution: S00004217

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect ignition coil body for cracks.

Refer to Procedure 013-012

Refer to Service Bulletin 4383630

  • Perform the ignition coil test.

Refer to Procedure 013-012

Specification

  • If any damage is found, then proceed to the Repair section.
  • If no spark was observed during the coil test, then proceed to the Linked Solutions section.

Linked Solutions

  • Ignition control wiring harness open circuit check

Refer to S00005711

  • Ignition control wiring harness circuit pin to ground short

Refer to S00005713

  • Ignition control wiring harness circuit pin to pin short

Refer to S00005715

  • Ignition control module open circuit check

Refer to S00005712

  • Ignition control module circuit pin to ground short

Refer to S00005714

  • Ignition control module circuit pin to pin short

Refer to S00006731

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil pack.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

1.1 - Ignition control wiring harness open circuit check

Solution: S00005711

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.2 - Ignition control wiring harness circuit pin to ground short

Solution: S00005713

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connector C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the charge voltage pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the secondary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the primary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.3 - Ignition control wiring harness circuit pin to pin short

Solution: S00005715

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control wiring harness charge voltage SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness secondary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness primary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.4 - Ignition control module open circuit check

Solution: S00005712

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the ignition control module C1 connector and the combustion detection SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the ignition control module C1 connector and the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the ignition control module C1 connector and the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module RETURN pin at the ignition control module C1 connector and the ignition control module RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the ignition control module C1 connector and the spark voltage SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.5 - Ignition control module circuit pin to ground short

Solution: S00005714

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.6 - Ignition control module circuit pin to pin short

Solution: S00006731

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

Last Modified: 12-Dec-2021


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2591 | SPN: 1298 | FMI: 15
Engine Spark Plug #5 (A3) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Ignition Coil Test
  2. Ignition control wiring harness open circuit check
  3. Ignition control wiring harness circuit pin to ground short
  4. Ignition control wiring harness circuit pin to pin short
  5. Ignition control module open circuit check
  6. Ignition control module circuit pin to ground short
  7. Ignition control module circuit pin to pin short

1 - Ignition Coil Test

Solution: S00004217

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect ignition coil body for cracks.

Refer to Procedure 013-012

Refer to Service Bulletin 4383630

  • Perform the ignition coil test.

Refer to Procedure 013-012

Specification

  • If any damage is found, then proceed to the Repair section.
  • If no spark was observed during the coil test, then proceed to the Linked Solutions section.

Linked Solutions

  • Ignition control wiring harness open circuit check

Refer to S00005711

  • Ignition control wiring harness circuit pin to ground short

Refer to S00005713

  • Ignition control wiring harness circuit pin to pin short

Refer to S00005715

  • Ignition control module open circuit check

Refer to S00005712

  • Ignition control module circuit pin to ground short

Refer to S00005714

  • Ignition control module circuit pin to pin short

Refer to S00006731

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil pack.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

1.1 - Ignition control wiring harness open circuit check

Solution: S00005711

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.2 - Ignition control wiring harness circuit pin to ground short

Solution: S00005713

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connector C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the charge voltage pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the secondary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the primary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.3 - Ignition control wiring harness circuit pin to pin short

Solution: S00005715

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control wiring harness charge voltage SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness secondary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness primary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.4 - Ignition control module open circuit check

Solution: S00005712

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the ignition control module C1 connector and the combustion detection SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the ignition control module C1 connector and the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the ignition control module C1 connector and the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module RETURN pin at the ignition control module C1 connector and the ignition control module RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the ignition control module C1 connector and the spark voltage SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.5 - Ignition control module circuit pin to ground short

Solution: S00005714

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.6 - Ignition control module circuit pin to pin short

Solution: S00006731

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

Last Modified: 12-Dec-2021


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2592 | SPN: 1299 | FMI: 15
Engine Spark Plug #6 (B3) Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Ignition Coil Test
  2. Ignition control wiring harness open circuit check
  3. Ignition control wiring harness circuit pin to ground short
  4. Ignition control wiring harness circuit pin to pin short
  5. Ignition control module open circuit check
  6. Ignition control module circuit pin to ground short
  7. Ignition control module circuit pin to pin short

1 - Ignition Coil Test

Solution: S00004217

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect ignition coil body for cracks.

Refer to Procedure 013-012

Refer to Service Bulletin 4383630

  • Perform the ignition coil test.

Refer to Procedure 013-012

Specification

  • If any damage is found, then proceed to the Repair section.
  • If no spark was observed during the coil test, then proceed to the Linked Solutions section.

Linked Solutions

  • Ignition control wiring harness open circuit check

Refer to S00005711

  • Ignition control wiring harness circuit pin to ground short

Refer to S00005713

  • Ignition control wiring harness circuit pin to pin short

Refer to S00005715

  • Ignition control module open circuit check

Refer to S00005712

  • Ignition control module circuit pin to ground short

Refer to S00005714

  • Ignition control module circuit pin to pin short

Refer to S00006731

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil pack.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

1.1 - Ignition control wiring harness open circuit check

Solution: S00005711

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.2 - Ignition control wiring harness circuit pin to ground short

Solution: S00005713

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connector C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the charge voltage pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the secondary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the primary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.3 - Ignition control wiring harness circuit pin to pin short

Solution: S00005715

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control wiring harness charge voltage SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness secondary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness primary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.4 - Ignition control module open circuit check

Solution: S00005712

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the ignition control module C1 connector and the combustion detection SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the ignition control module C1 connector and the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the ignition control module C1 connector and the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module RETURN pin at the ignition control module C1 connector and the ignition control module RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the ignition control module C1 connector and the spark voltage SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.5 - Ignition control module circuit pin to ground short

Solution: S00005714

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.6 - Ignition control module circuit pin to pin short

Solution: S00006731

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

Last Modified: 12-Dec-2021


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2593 | SPN: 1294 | FMI: 17
Engine Spark Plug #1 (A1) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Ignition Coil Test
  2. Ignition control wiring harness open circuit check
  3. Ignition control wiring harness circuit pin to ground short
  4. Ignition control wiring harness circuit pin to pin short
  5. Ignition control module open circuit check
  6. Ignition control module circuit pin to ground short
  7. Ignition control module circuit pin to pin short

1 - Ignition Coil Test

Solution: S00004217

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect ignition coil body for cracks.

Refer to Procedure 013-012

Refer to Service Bulletin 4383630

  • Perform the ignition coil test.

Refer to Procedure 013-012

Specification

  • If any damage is found, then proceed to the Repair section.
  • If no spark was observed during the coil test, then proceed to the Linked Solutions section.

Linked Solutions

  • Ignition control wiring harness open circuit check

Refer to S00005711

  • Ignition control wiring harness circuit pin to ground short

Refer to S00005713

  • Ignition control wiring harness circuit pin to pin short

Refer to S00005715

  • Ignition control module open circuit check

Refer to S00005712

  • Ignition control module circuit pin to ground short

Refer to S00005714

  • Ignition control module circuit pin to pin short

Refer to S00006731

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil pack.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

1.1 - Ignition control wiring harness open circuit check

Solution: S00005711

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.2 - Ignition control wiring harness circuit pin to ground short

Solution: S00005713

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connector C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the charge voltage pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the secondary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the primary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.3 - Ignition control wiring harness circuit pin to pin short

Solution: S00005715

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control wiring harness charge voltage SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness secondary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness primary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.4 - Ignition control module open circuit check

Solution: S00005712

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the ignition control module C1 connector and the combustion detection SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the ignition control module C1 connector and the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the ignition control module C1 connector and the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module RETURN pin at the ignition control module C1 connector and the ignition control module RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the ignition control module C1 connector and the spark voltage SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.5 - Ignition control module circuit pin to ground short

Solution: S00005714

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.6 - Ignition control module circuit pin to pin short

Solution: S00006731

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

Last Modified: 12-Dec-2021


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2594 | SPN: 1295 | FMI: 17
Engine Spark Plug #2 (B1) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Ignition Coil Test
  2. Ignition control wiring harness open circuit check
  3. Ignition control wiring harness circuit pin to ground short
  4. Ignition control wiring harness circuit pin to pin short
  5. Ignition control module open circuit check
  6. Ignition control module circuit pin to ground short
  7. Ignition control module circuit pin to pin short

1 - Ignition Coil Test

Solution: S00004217

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect ignition coil body for cracks.

Refer to Procedure 013-012

Refer to Service Bulletin 4383630

  • Perform the ignition coil test.

Refer to Procedure 013-012

Specification

  • If any damage is found, then proceed to the Repair section.
  • If no spark was observed during the coil test, then proceed to the Linked Solutions section.

Linked Solutions

  • Ignition control wiring harness open circuit check

Refer to S00005711

  • Ignition control wiring harness circuit pin to ground short

Refer to S00005713

  • Ignition control wiring harness circuit pin to pin short

Refer to S00005715

  • Ignition control module open circuit check

Refer to S00005712

  • Ignition control module circuit pin to ground short

Refer to S00005714

  • Ignition control module circuit pin to pin short

Refer to S00006731

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil pack.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

1.1 - Ignition control wiring harness open circuit check

Solution: S00005711

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.2 - Ignition control wiring harness circuit pin to ground short

Solution: S00005713

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connector C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the charge voltage pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the secondary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the primary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.3 - Ignition control wiring harness circuit pin to pin short

Solution: S00005715

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control wiring harness charge voltage SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness secondary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness primary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.4 - Ignition control module open circuit check

Solution: S00005712

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the ignition control module C1 connector and the combustion detection SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the ignition control module C1 connector and the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the ignition control module C1 connector and the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module RETURN pin at the ignition control module C1 connector and the ignition control module RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the ignition control module C1 connector and the spark voltage SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.5 - Ignition control module circuit pin to ground short

Solution: S00005714

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.6 - Ignition control module circuit pin to pin short

Solution: S00006731

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

Last Modified: 12-Dec-2021


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2595 | SPN: 1296 | FMI: 17
Engine Spark Plug #3 (A2) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Ignition Coil Test
  2. Ignition control wiring harness open circuit check
  3. Ignition control wiring harness circuit pin to ground short
  4. Ignition control wiring harness circuit pin to pin short
  5. Ignition control module open circuit check
  6. Ignition control module circuit pin to ground short
  7. Ignition control module circuit pin to pin short

1 - Ignition Coil Test

Solution: S00004217

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect ignition coil body for cracks.

Refer to Procedure 013-012

Refer to Service Bulletin 4383630

  • Perform the ignition coil test.

Refer to Procedure 013-012

Specification

  • If any damage is found, then proceed to the Repair section.
  • If no spark was observed during the coil test, then proceed to the Linked Solutions section.

Linked Solutions

  • Ignition control wiring harness open circuit check

Refer to S00005711

  • Ignition control wiring harness circuit pin to ground short

Refer to S00005713

  • Ignition control wiring harness circuit pin to pin short

Refer to S00005715

  • Ignition control module open circuit check

Refer to S00005712

  • Ignition control module circuit pin to ground short

Refer to S00005714

  • Ignition control module circuit pin to pin short

Refer to S00006731

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil pack.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

1.1 - Ignition control wiring harness open circuit check

Solution: S00005711

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.2 - Ignition control wiring harness circuit pin to ground short

Solution: S00005713

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connector C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the charge voltage pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the secondary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the primary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.3 - Ignition control wiring harness circuit pin to pin short

Solution: S00005715

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control wiring harness charge voltage SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness secondary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness primary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.4 - Ignition control module open circuit check

Solution: S00005712

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the ignition control module C1 connector and the combustion detection SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the ignition control module C1 connector and the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the ignition control module C1 connector and the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module RETURN pin at the ignition control module C1 connector and the ignition control module RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the ignition control module C1 connector and the spark voltage SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.5 - Ignition control module circuit pin to ground short

Solution: S00005714

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.6 - Ignition control module circuit pin to pin short

Solution: S00006731

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

Last Modified: 12-Dec-2021


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2596 | SPN: 1297 | FMI: 17
Engine Spark Plug #4 (B2) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Ignition Coil Test
  2. Ignition control wiring harness open circuit check
  3. Ignition control wiring harness circuit pin to ground short
  4. Ignition control wiring harness circuit pin to pin short
  5. Ignition control module open circuit check
  6. Ignition control module circuit pin to ground short
  7. Ignition control module circuit pin to pin short

1 - Ignition Coil Test

Solution: S00004217

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect ignition coil body for cracks.

Refer to Procedure 013-012

Refer to Service Bulletin 4383630

  • Perform the ignition coil test.

Refer to Procedure 013-012

Specification

  • If any damage is found, then proceed to the Repair section.
  • If no spark was observed during the coil test, then proceed to the Linked Solutions section.

Linked Solutions

  • Ignition control wiring harness open circuit check

Refer to S00005711

  • Ignition control wiring harness circuit pin to ground short

Refer to S00005713

  • Ignition control wiring harness circuit pin to pin short

Refer to S00005715

  • Ignition control module open circuit check

Refer to S00005712

  • Ignition control module circuit pin to ground short

Refer to S00005714

  • Ignition control module circuit pin to pin short

Refer to S00006731

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil pack.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

1.1 - Ignition control wiring harness open circuit check

Solution: S00005711

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.2 - Ignition control wiring harness circuit pin to ground short

Solution: S00005713

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connector C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the charge voltage pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the secondary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the primary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.3 - Ignition control wiring harness circuit pin to pin short

Solution: S00005715

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control wiring harness charge voltage SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness secondary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness primary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.4 - Ignition control module open circuit check

Solution: S00005712

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the ignition control module C1 connector and the combustion detection SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the ignition control module C1 connector and the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the ignition control module C1 connector and the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module RETURN pin at the ignition control module C1 connector and the ignition control module RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the ignition control module C1 connector and the spark voltage SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.5 - Ignition control module circuit pin to ground short

Solution: S00005714

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.6 - Ignition control module circuit pin to pin short

Solution: S00006731

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

Last Modified: 12-Dec-2021


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2597 | SPN: 1298 | FMI: 17
Engine Spark Plug #5 (A3) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Ignition Coil Test
  2. Ignition control wiring harness open circuit check
  3. Ignition control wiring harness circuit pin to ground short
  4. Ignition control wiring harness circuit pin to pin short
  5. Ignition control module open circuit check
  6. Ignition control module circuit pin to ground short
  7. Ignition control module circuit pin to pin short

1 - Ignition Coil Test

Solution: S00004217

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect ignition coil body for cracks.

Refer to Procedure 013-012

Refer to Service Bulletin 4383630

  • Perform the ignition coil test.

Refer to Procedure 013-012

Specification

  • If any damage is found, then proceed to the Repair section.
  • If no spark was observed during the coil test, then proceed to the Linked Solutions section.

Linked Solutions

  • Ignition control wiring harness open circuit check

Refer to S00005711

  • Ignition control wiring harness circuit pin to ground short

Refer to S00005713

  • Ignition control wiring harness circuit pin to pin short

Refer to S00005715

  • Ignition control module open circuit check

Refer to S00005712

  • Ignition control module circuit pin to ground short

Refer to S00005714

  • Ignition control module circuit pin to pin short

Refer to S00006731

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil pack.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

1.1 - Ignition control wiring harness open circuit check

Solution: S00005711

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.2 - Ignition control wiring harness circuit pin to ground short

Solution: S00005713

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connector C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the charge voltage pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the secondary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the primary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.3 - Ignition control wiring harness circuit pin to pin short

Solution: S00005715

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control wiring harness charge voltage SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness secondary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness primary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.4 - Ignition control module open circuit check

Solution: S00005712

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the ignition control module C1 connector and the combustion detection SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the ignition control module C1 connector and the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the ignition control module C1 connector and the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module RETURN pin at the ignition control module C1 connector and the ignition control module RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the ignition control module C1 connector and the spark voltage SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.5 - Ignition control module circuit pin to ground short

Solution: S00005714

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.6 - Ignition control module circuit pin to pin short

Solution: S00006731

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

Last Modified: 12-Dec-2021


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2598 | SPN: 1299 | FMI: 17
Engine Spark Plug #6 (B3) Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Ignition Coil Test
  2. Ignition control wiring harness open circuit check
  3. Ignition control wiring harness circuit pin to ground short
  4. Ignition control wiring harness circuit pin to pin short
  5. Ignition control module open circuit check
  6. Ignition control module circuit pin to ground short
  7. Ignition control module circuit pin to pin short

1 - Ignition Coil Test

Solution: S00004217

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect ignition coil body for cracks.

Refer to Procedure 013-012

Refer to Service Bulletin 4383630

  • Perform the ignition coil test.

Refer to Procedure 013-012

Specification

  • If any damage is found, then proceed to the Repair section.
  • If no spark was observed during the coil test, then proceed to the Linked Solutions section.

Linked Solutions

  • Ignition control wiring harness open circuit check

Refer to S00005711

  • Ignition control wiring harness circuit pin to ground short

Refer to S00005713

  • Ignition control wiring harness circuit pin to pin short

Refer to S00005715

  • Ignition control module open circuit check

Refer to S00005712

  • Ignition control module circuit pin to ground short

Refer to S00005714

  • Ignition control module circuit pin to pin short

Refer to S00006731

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil pack.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

1.1 - Ignition control wiring harness open circuit check

Solution: S00005711

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.2 - Ignition control wiring harness circuit pin to ground short

Solution: S00005713

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connector C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the charge voltage pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the secondary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the primary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.3 - Ignition control wiring harness circuit pin to pin short

Solution: S00005715

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control wiring harness charge voltage SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness secondary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness primary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.4 - Ignition control module open circuit check

Solution: S00005712

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the ignition control module C1 connector and the combustion detection SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the ignition control module C1 connector and the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the ignition control module C1 connector and the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module RETURN pin at the ignition control module C1 connector and the ignition control module RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the ignition control module C1 connector and the spark voltage SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.5 - Ignition control module circuit pin to ground short

Solution: S00005714

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

1.6 - Ignition control module circuit pin to pin short

Solution: S00006731

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

Last Modified: 12-Dec-2021


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2616 | SPN: 1322 | FMI: 3
Engine Misfire Multiple Cylinder Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Ignition control module open circuit check
  2. Ignition control wiring harness open circuit check
  3. Ignition control module circuit pin to pin short

1 - Ignition control module open circuit check

Solution: S00004840

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the ignition control module C1 connector and the combustion detection SIGNAL pin at the engine wiring harness ECM connector 2.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the ignition control module C1 connector and the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the ignition control module C1 connector and the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module RETURN pin at the ignition control module C1 connector and the ignition control module RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the ignition control module C1 connector and the spark voltage SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Ignition control wiring harness open circuit check

Solution: S00004197

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Ignition control module circuit pin to pin short

Solution: S00001435

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the gas mass flow sensor from the engine wiring harness.
  • Disconnect the EGR temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 12-Dec-2021


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2617 | SPN: 1322 | FMI: 4
Engine Misfire Multiple Cylinder Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Ignition control module open circuit check
  2. Ignition control wiring harness open circuit check
  3. Ignition control wiring harness circuit pin to ground short
  4. Ignition control module circuit pin to ground short
  5. Ignition control module circuit pin to pin short

1 - Ignition control module open circuit check

Solution: S00004840

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the ignition control module C1 connector and the combustion detection SIGNAL pin at the engine wiring harness ECM connector 2.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the ignition control module C1 connector and the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the ignition control module C1 connector and the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module RETURN pin at the ignition control module C1 connector and the ignition control module RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the ignition control module C1 connector and the spark voltage SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Ignition control wiring harness open circuit check

Solution: S00004197

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Ignition control wiring harness circuit pin to ground short

Solution: S00004838

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Ignition control module circuit pin to ground short

Solution: S00005822

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery.
  • Disconnect the engine wiring harness from the ignition control module.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module SUPPLY pin at the ignition control module engine wiring harness connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Ignition control module circuit pin to pin short

Solution: S00001435

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the gas mass flow sensor from the engine wiring harness.
  • Disconnect the EGR temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 08-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2641 | SPN: 1180 | FMI: 3
Turbocharger 1 Turbine Intake Temperature - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Turbocharger turbine intake temperature sensor circuit response
  2. Turbocharger turbine intake temperature sensor circuit response at the ECM
  3. ECM calibration revision history check

1 - Turbocharger turbine intake temperature sensor circuit response

Solution: S00004784

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger turbine intake temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the turbocharger turbine intake temperature sensor SIGNAL pin and the turbocharger turbine intake temperature sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait for 120 seconds.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning turbocharger turbine intake temperature sensor has been detected if the following fault code became active with the jumper wire in place: 2642

Linked Solutions

  • None

Repair

  • Replace the turbocharger turbine intake temperature sensor.

Refer to Procedure 019-473

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Turbocharger turbine intake temperature sensor circuit response at the ECM

Solution: S00004785

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the turbocharger turbine intake temperature sensor SIGNAL pin and the turbocharger turbine intake temperature sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait for 120 seconds.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 2642
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 2642

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2642 | SPN: 1180 | FMI: 4
Turbocharger 1 Turbine Intake Temperature - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Turbocharger turbine intake temperature sensor circuit response
  2. Turbocharger turbine intake temperature sensor circuit response at the ECM
  3. ECM calibration revision history check

1 - Turbocharger turbine intake temperature sensor circuit response

Solution: S00004786

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger turbine intake temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning turbocharger turbine intake temperature sensor has been detected if the following fault code became active with the sensor disconnected: 2641

Linked Solutions

  • None

Repair

  • Replace the turbocharger turbine intake temperature sensor.

Refer to Procedure 019-473

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Turbocharger turbine intake temperature sensor circuit response at the ECM

Solution: S00004787

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 2641
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 2641

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2643 | SPN: 3673 | FMI: 3
Throttle Position 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Engine intake throttle actuator circuit response
  3. Engine intake throttle actuator circuit response at the ECM
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002464

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Engine intake throttle actuator circuit response

Solution: S00004966

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine intake throttle actuator has been detected if the following fault code became active with the actuator disconnected: 2644

Linked Solutions

  • None

Repair

  • Replace the engine intake throttle actuator.

Refer to Procedure 005-052

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine intake throttle actuator circuit response at the ECM

Solution: S00004949

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 2644
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 2644

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2644 | SPN: 3673 | FMI: 4
Throttle Position 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Engine intake throttle actuator circuit response
  3. Engine intake throttle actuator circuit response at the ECM
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00006259

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Engine intake throttle actuator circuit response

Solution: S00004594

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the engine intake throttle actuator position sensor SUPPLY 1 pin and the engine intake throttle actuator position sensor SIGNAL 2 pin at the engine intake throttle actuator connector of the engine wiring harness.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine intake throttle actuator has been detected if the following fault code became active with the jumper wire in place: 2643

Linked Solutions

  • None

Repair

  • Replace the engine intake throttle actuator.

Refer to Procedure 005-052

Validation

  • None
Next Solution

3 - Engine intake throttle actuator circuit response at the ECM

Solution: S00004950

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the engine intake throttle actuator position sensor SUPPLY 1 pin and the engine intake throttle actuator position sensor SIGNAL 2 pin at the ECM.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 2643
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 2643

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2645 | SPN: 3673 | FMI: 2
Throttle Plate Position Sensor 1 and 2 - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Engine intake throttle actuator circuit pin to pin short
  2. Engine intake throttle actuator is malfunctioning
  3. ECM calibration revision history check
  4. Electronic throttle control actuator driver malfunctioning

1 - Engine intake throttle actuator circuit pin to pin short

Solution: S00004921

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the throttle position 1 SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the throttle position 1 SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 2.
  • Measure the resistance between the throttle position 2 SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 1.
  • Measure the resistance between the throttle position 2 SIGNAL pin in the ECM connector 1 and all other pins in the ECM connector 2.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Engine intake throttle actuator is malfunctioning

Solution: S00004282

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Gas Throttle Control Test.

Specification

  • If the engine intake throttle actuator does not pass the Gas Throttle Control Test, then a malfunctioning engine intake throttle actuator has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine intake throttle actuator.

Refer to Procedure 005-052

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Electronic throttle control actuator driver malfunctioning

Solution: S00004265

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning engine intake throttle actuator assembly has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine intake throttle actuator.

Refer to Procedure 005-052

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2686 | SPN: 3222 | FMI: 3
Aftertreatment Intake Gas Sensor Heater - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Aftertreatment intake oxygen sensor heater resistance check
  2. Aftertreatment intake oxygen sensor heater voltage check
  3. Aftertreatment intake oxygen sensor heater circuit pin to ground short
  4. Aftertreatment intake oxygen sensor circuit pin to pin short
  5. ECM calibration revision history check
  6. Aftertreatment intake oxygen sensor is malfunctioning

1 - Aftertreatment intake oxygen sensor heater resistance check

Solution: S00004153

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake oxygen sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the aftertreatment intake oxygen sensor.

Refer to Procedure 019-100

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not within specification, then a malfunctioning aftertreatment intake oxygen sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake oxygen sensor.

Refer to Procedure 019-100

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment intake oxygen sensor heater voltage check

Solution: S00004902

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake oxygen sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check that all battery terminal connections are tight and corrosion free.
  • Turn keyswitch ON.
  • Run the engine at idle for the following minutes: 12
  • Measure the voltage between the aftertreatment intake oxygen sensor heater SUPPLY pin and the aftertreatment intake oxygen sensor heater RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • Aftertreatment intake oxygen sensor heater circuit pin to ground short

Refer to S00004964

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Aftertreatment intake oxygen sensor heater circuit pin to ground short

Solution: S00004964

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake oxygen sensor from the engine wiring harness.

Action

  • Start the engine.
  • Measure the voltage between the aftertreatment intake oxygen sensor heater SUPPLY pin at the sensor connector of the engine wiring harness and ground.

Specification

  • A malfunctioning engine wiring harness has been detected if the voltage is within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Aftertreatment intake oxygen sensor circuit pin to pin short

Solution: S00004198

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake oxygen sensor from the engine wiring harness.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment intake oxygen sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the aftertreatment intake oxygen sensor RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the aftertreatment intake oxygen sensor heater SUPPLY pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the aftertreatment intake oxygen sensor heater RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment intake oxygen sensor is malfunctioning

Solution: S00004151

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment intake oxygen sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake oxygen sensor.

Refer to Procedure 019-100

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2687 | SPN: 3222 | FMI: 4
Aftertreatment Intake Gas Sensor Heater - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Aftertreatment intake oxygen sensor heater resistance check
  2. Aftertreatment intake oxygen sensor open circuit check
  3. Aftertreatment intake oxygen sensor circuit pin to ground short
  4. Aftertreatment intake oxygen sensor circuit pin to pin short
  5. ECM calibration revision history check
  6. Aftertreatment intake oxygen sensor is malfunctioning

1 - Aftertreatment intake oxygen sensor heater resistance check

Solution: S00004153

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake oxygen sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the aftertreatment intake oxygen sensor.

Refer to Procedure 019-100

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not within specification, then a malfunctioning aftertreatment intake oxygen sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake oxygen sensor.

Refer to Procedure 019-100

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment intake oxygen sensor open circuit check

Solution: S00004820

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness ECM connector 1 and 2.
  • Disconnect the aftertreatment intake oxygen sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment intake oxygen sensor SIGNAL pin at the aftertreatment intake oxygen sensor engine wiring harness connector and the aftertreatment intake oxygen sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the aftertreatment intake oxygen sensor RETURN pin at the aftertreatment intake oxygen sensor engine wiring harness connector and the aftertreatment intake oxygen sensor RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the aftertreatment intake oxygen sensor heater SUPPLY pin at the aftertreatment intake oxygen sensor connector of the engine wiring harness and the aftertreatment intake oxygen sensor heater SUPPLY pin at the engine wiring harness ECM connector.
  • Measure the resistance between the aftertreatment intake oxygen sensor heater RETURN pin at the aftertreatment intake oxygen sensor connector of the engine wiring harness and the aftertreatment intake oxygen sensor heater RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment intake oxygen sensor circuit pin to ground short

Solution: S00002829

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the aftertreatment intake oxygen sensor from the engine wiring harness.
  • Disconnect all components on the wiring circuit being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment intake oxygen sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the aftertreatment intake oxygen sensor RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the aftertreatment intake oxygen sensor heater SUPPLY pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the aftertreatment intake oxygen sensor heater RETURN pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment intake oxygen sensor circuit pin to pin short

Solution: S00004198

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake oxygen sensor from the engine wiring harness.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment intake oxygen sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the aftertreatment intake oxygen sensor RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the aftertreatment intake oxygen sensor heater SUPPLY pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the aftertreatment intake oxygen sensor heater RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment intake oxygen sensor is malfunctioning

Solution: S00004151

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment intake oxygen sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake oxygen sensor.

Refer to Procedure 019-100

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2722 | SPN: 1390 | FMI: 16
Engine Fuel Valve 1 Intake Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Technical Service Bulletin is available
  3. Fuel outlet pressure sensor stuck in-range
  4. Low pressure regulator is malfunctioning
  5. Fuel inlet pressure sensor stuck in-range
  6. ECM calibration revision history check
  7. OEM fuel system is malfunctioning

1 - Check for primary fault codes

Solution: S00002640

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 1839, 1841, 2568, 2724, 2725
  • Turbocharger: 2517, 2518

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Technical Service Bulletin is available

Solution: S00009792

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb150180

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Fuel outlet pressure sensor stuck in-range

Solution: S00003459

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Install a mechanical gauge on the engine.

Refer to Procedure 005-047

  • Start the engine.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the fuel regulator outlet pressure.

Refer to Procedure 005-047

  • Compare the sensor reading with the recommended Cummins® electronic service tool or equivalent to a mechanical gauge.

Specification

  • A malfunctioning fuel outlet pressure sensor has been detected if the readings are not within the following specification of each other: 5%

Linked Solutions

  • None

Repair

  • Replace the fuel outlet pressure/temperature sensor.

Refer to Procedure 019-153

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Low pressure regulator is malfunctioning

Solution: S00005020

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Install a mechanical gauge on the engine.
  • Turn keyswitch ON.
  • Perform the Fuel Pressure Test.

Refer to Procedure 005-047

Specification

  • If the Fuel Pressure Test does not meet specification, then a malfunctioning low pressure regulator has been detected.

Linked Solutions

  • None

Repair

  • Replace the low pressure regulator.

Refer to Procedure 005-047

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Fuel inlet pressure sensor stuck in-range

Solution: S00004738

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Install a mechanical gauge on the engine.

Refer to Procedure 005-061

  • Start the engine.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the fuel regulator intake pressure.

Refer to Procedure 005-061

  • Compare the sensor reading with the recommended Cummins® electronic service tool or equivalent to a mechanical gauge.

Specification

  • A malfunctioning OEM fuel delivery system has been detected if the readings are within the following specification of each other: 5%
  • A malfunctioning fuel inlet pressure sensor has been detected if the readings are not within the following specification of each other: 5%

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM fuel system component.

Refer to OEM Service Manual

  • Replace the fuel inlet pressure sensor.

Refer to Procedure 019-188

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - OEM fuel system is malfunctioning

Solution: S00004100

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning OEM fuel system has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM fuel system component.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2723 | SPN: 1390 | FMI: 18
Engine Fuel Valve 1 Intake Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. External fuel leak
  2. Fuel pressure check
  3. Check for primary fault codes
  4. Technical Service Bulletin is available
  5. Fuel outlet pressure sensor stuck in-range
  6. Low pressure regulator is malfunctioning
  7. Fuel inlet pressure sensor stuck in-range
  8. Boost reference line damaged
  9. Low pressure regulator o-rings are damaged
  10. Fuel system is contaminated
  11. ECM calibration revision history check

1 - External fuel leak

Solution: S00004765

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Start the engine.
  • Use a combustible gas detector to check for leaks.

Specification

  • If there is any damage or leaks found in the fuel system, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM fuel lines.

Refer to OEM Service Manual

  • Replace fuel filter.

Refer to Procedure 006-015

  • Replace the low pressure regulator.

Refer to Procedure 005-047

  • Replace the high pressure regulator.

Refer to Procedure 005-061

  • Replace gas mass flow sensor.

Refer to Procedure 019-101

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Fuel pressure check

Solution: S00004450

Verification

Conditions

  • Turn keyswitch OFF.
  • Verify all fuel shutoff valves are in the open position.

Action

  • Verify the fuel gauge is working properly.

Refer to OEM Service Manual

  • Verify the fuel tank pressure meets specification.

Refer to OEM Service Manual

  • Verify the fuel regulator intake pressure meets specifications.

Refer to Procedure 005-061

Specification

  • If any of the checks are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Add fuel if needed.

Refer to OEM Service Manual

  • For an OEM issue: Contact the OEM for further repair instructions.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Check for primary fault codes

Solution: S00002357

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 453, 454, 1827, 1828, 1839, 1841, 2568, 2722, 2724, 2725, 2775, 2776, 2783, 2991

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

4 - Technical Service Bulletin is available

Solution: S00009792

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb150180

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Fuel outlet pressure sensor stuck in-range

Solution: S00003459

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Install a mechanical gauge on the engine.

Refer to Procedure 005-047

  • Start the engine.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the fuel regulator outlet pressure.

Refer to Procedure 005-047

  • Compare the sensor reading with the recommended Cummins® electronic service tool or equivalent to a mechanical gauge.

Specification

  • A malfunctioning fuel outlet pressure sensor has been detected if the readings are not within the following specification of each other: 5%

Linked Solutions

  • None

Repair

  • Replace the fuel outlet pressure/temperature sensor.

Refer to Procedure 019-153

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Low pressure regulator is malfunctioning

Solution: S00005020

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Install a mechanical gauge on the engine.
  • Turn keyswitch ON.
  • Perform the Fuel Pressure Test.

Refer to Procedure 005-047

Specification

  • If the Fuel Pressure Test does not meet specification, then a malfunctioning low pressure regulator has been detected.

Linked Solutions

  • None

Repair

  • Replace the low pressure regulator.

Refer to Procedure 005-047

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Fuel inlet pressure sensor stuck in-range

Solution: S00004738

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Install a mechanical gauge on the engine.

Refer to Procedure 005-061

  • Start the engine.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the fuel regulator intake pressure.

Refer to Procedure 005-061

  • Compare the sensor reading with the recommended Cummins® electronic service tool or equivalent to a mechanical gauge.

Specification

  • A malfunctioning OEM fuel delivery system has been detected if the readings are within the following specification of each other: 5%
  • A malfunctioning fuel inlet pressure sensor has been detected if the readings are not within the following specification of each other: 5%

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM fuel system component.

Refer to OEM Service Manual

  • Replace the fuel inlet pressure sensor.

Refer to Procedure 019-188

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Boost reference line damaged

Solution: S00003800

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Visually inspect the low pressure regulator boost reference line for damage.

Refer to Procedure 010-050

Specification

  • If any damage or if the low pressure regulator boost reference line is found leaking, then a malfunctioning low pressure regulator boost reference line has been detected.
  • If fuel is detected inside the boost reference line, then a leaking low pressure regulator or fuel shutoff valve has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the low pressure regulator boost reference line.

Refer to Procedure 010-050

  • Replace the low pressure regulator.

Refer to Procedure 005-047

  • Replace the fuel shutoff valve.

Refer to Procedure 019-050

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Low pressure regulator o-rings are damaged

Solution: S00006223

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the low pressure regulator.

Refer to Procedure 005-047

  • Inspect the low pressure regulator.

Refer to Procedure 005-047

  • Inspect the low pressure regulator o-rings.

Refer to Procedure 005-047

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the low pressure regulator.

Refer to Procedure 005-047

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - Fuel system is contaminated

Solution: S00004667

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the fuel filter.

Refer to Procedure 006-015

  • Disconnect the gas mass flow sensor from the engine wiring harness.

Refer to Procedure 019-101

  • Inspect the air/fuel mixer.

Refer to Procedure 005-003

Specification

  • If excess oil is found in the fuel system, then proceed to the repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel control valve.

Refer to Procedure 019-102

  • Replace gas mass flow sensor.

Refer to Procedure 019-101

  • Clean the fuel control housing.

Refer to Procedure 005-009

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

11 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2724 | SPN: 159 | FMI: 16
Gas Supply Pressure (Regulated) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Technical Service Bulletin is available
  2. Fuel inlet pressure sensor stuck in-range
  3. ECM calibration revision history check
  4. OEM fuel system is malfunctioning

1 - Technical Service Bulletin is available

Solution: S00009806

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb150200

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Fuel inlet pressure sensor stuck in-range

Solution: S00004738

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Install a mechanical gauge on the engine.

Refer to Procedure 005-061

  • Start the engine.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the fuel regulator intake pressure.

Refer to Procedure 005-061

  • Compare the sensor reading with the recommended Cummins® electronic service tool or equivalent to a mechanical gauge.

Specification

  • A malfunctioning OEM fuel delivery system has been detected if the readings are within the following specification of each other: 5%
  • A malfunctioning fuel inlet pressure sensor has been detected if the readings are not within the following specification of each other: 5%

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM fuel system component.

Refer to OEM Service Manual

  • Replace the fuel inlet pressure sensor.

Refer to Procedure 019-188

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - OEM fuel system is malfunctioning

Solution: S00004100

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning OEM fuel system has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM fuel system component.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2725 | SPN: 159 | FMI: 18
Gas Supply Pressure (Regulated) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Fuel pressure check
  2. Technical Service Bulletin is available

1 - Fuel pressure check

Solution: S00004450

Verification

Conditions

  • Turn keyswitch OFF.
  • Verify all fuel shutoff valves are in the open position.

Action

  • Verify the fuel gauge is working properly.

Refer to OEM Service Manual

  • Verify the fuel tank pressure meets specification.

Refer to OEM Service Manual

  • Verify the fuel regulator intake pressure meets specifications.

Refer to Procedure 005-061

Specification

  • If any of the checks are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Add fuel if needed.

Refer to OEM Service Manual

  • For an OEM issue: Contact the OEM for further repair instructions.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Technical Service Bulletin is available

Solution: S00009806

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb150200

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 17-Apr-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2752 | SPN: 3464 | FMI: 6
Engine Throttle Control Actuator - Current Above Normal or Grounded Circuit

Troubleshooting Summary

  1. Check for primary fault codes
  2. Engine intake throttle actuator circuit pin to pin short
  3. Engine intake throttle actuator is malfunctioning

1 - Check for primary fault codes

Solution: S00007285

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Engine intake throttle actuator circuit pin to pin short

Solution: S00004887

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the intake throttle actuator motor SIGNAL pin at the ECM connector of the engine wiring harness and all other pins at that connector.
  • Measure the resistance between the intake throttle actuator motor RETURN pin at the ECM connector of the engine wiring harness and all other pins at that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine intake throttle actuator is malfunctioning

Solution: S00004282

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Gas Throttle Control Test.

Specification

  • If the engine intake throttle actuator does not pass the Gas Throttle Control Test, then a malfunctioning engine intake throttle actuator has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine intake throttle actuator.

Refer to Procedure 005-052

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 12-Dec-2021


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2758 | SPN: 3464 | FMI: 0
Electronic Throttle Control Actuator - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Engine intake throttle actuator is malfunctioning
  3. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00006259

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Engine intake throttle actuator is malfunctioning

Solution: S00004282

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Gas Throttle Control Test.

Specification

  • If the engine intake throttle actuator does not pass the Gas Throttle Control Test, then a malfunctioning engine intake throttle actuator has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine intake throttle actuator.

Refer to Procedure 005-052

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2759 | SPN: 3464 | FMI: 1
Electronic Throttle Control Actuator - Data Valid But Below Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Engine intake throttle actuator is malfunctioning
  3. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00006259

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Engine intake throttle actuator is malfunctioning

Solution: S00004282

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Gas Throttle Control Test.

Specification

  • If the engine intake throttle actuator does not pass the Gas Throttle Control Test, then a malfunctioning engine intake throttle actuator has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine intake throttle actuator.

Refer to Procedure 005-052

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2775 | SPN: 1241 | FMI: 16
Gas Mass Flow 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. External fuel leak
  2. Fuel pressure check
  3. Check for primary fault codes
  4. Low pressure regulator is malfunctioning
  5. ECM calibration revision history check

1 - External fuel leak

Solution: S00004765

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Start the engine.
  • Use a combustible gas detector to check for leaks.

Specification

  • If there is any damage or leaks found in the fuel system, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM fuel lines.

Refer to OEM Service Manual

  • Replace fuel filter.

Refer to Procedure 006-015

  • Replace the low pressure regulator.

Refer to Procedure 005-047

  • Replace the high pressure regulator.

Refer to Procedure 005-061

  • Replace gas mass flow sensor.

Refer to Procedure 019-101

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Fuel pressure check

Solution: S00004450

Verification

Conditions

  • Turn keyswitch OFF.
  • Verify all fuel shutoff valves are in the open position.

Action

  • Verify the fuel gauge is working properly.

Refer to OEM Service Manual

  • Verify the fuel tank pressure meets specification.

Refer to OEM Service Manual

  • Verify the fuel regulator intake pressure meets specifications.

Refer to Procedure 005-061

Specification

  • If any of the checks are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Add fuel if needed.

Refer to OEM Service Manual

  • For an OEM issue: Contact the OEM for further repair instructions.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Check for primary fault codes

Solution: S00002456

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 453, 454, 1827, 1828, 1839, 1841, 2184, 2568, 2722, 2724, 3847
  • Maintenance lamp: 5984

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

4 - Low pressure regulator is malfunctioning

Solution: S00003495

Verification

Conditions

  • Engine running at idle.

Action

  • Perform three throttle sweeps and return to idle.
  • Disconnect the gas mass flow sensor from the engine wiring harness.

Specification

  • If the engine performance improves with the sensor disconnected, then a malfunctioning low pressure regulator has been detected.

Linked Solutions

  • None

Repair

  • Replace the low pressure regulator.

Refer to Procedure 005-047

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2776 | SPN: 1241 | FMI: 18
Gas Mass Flow 1 - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. External fuel leak
  2. Fuel pressure check
  3. Check for primary fault codes
  4. Air/fuel mixer is malfunctioning
  5. Low pressure regulator is malfunctioning
  6. Technical Service Bulletin is available
  7. Turbocharger wastegate actuator control line is malfunctioning
  8. Fuel system is contaminated
  9. ECM calibration revision history check

1 - External fuel leak

Solution: S00004765

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Start the engine.
  • Use a combustible gas detector to check for leaks.

Specification

  • If there is any damage or leaks found in the fuel system, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM fuel lines.

Refer to OEM Service Manual

  • Replace fuel filter.

Refer to Procedure 006-015

  • Replace the low pressure regulator.

Refer to Procedure 005-047

  • Replace the high pressure regulator.

Refer to Procedure 005-061

  • Replace gas mass flow sensor.

Refer to Procedure 019-101

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Fuel pressure check

Solution: S00004450

Verification

Conditions

  • Turn keyswitch OFF.
  • Verify all fuel shutoff valves are in the open position.

Action

  • Verify the fuel gauge is working properly.

Refer to OEM Service Manual

  • Verify the fuel tank pressure meets specification.

Refer to OEM Service Manual

  • Verify the fuel regulator intake pressure meets specifications.

Refer to Procedure 005-061

Specification

  • If any of the checks are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Add fuel if needed.

Refer to OEM Service Manual

  • For an OEM issue: Contact the OEM for further repair instructions.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Check for primary fault codes

Solution: S00002284

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Ignition: 458
  • Mass air flow: 2988
  • Fuel: 453, 454, 511, 751, 2184, 2723, 2725, 2991, 3847, 5948

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

4 - Air/fuel mixer is malfunctioning

Solution: S00004158

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the air/fuel mixer.

Refer to Procedure 005-003

  • Inspect the air/fuel mixer.

Refer to Procedure 005-003

Specification

  • If any damage or restriction is found, then a malfunctioning air/fuel mixer has been detected.

Linked Solutions

  • None

Repair

  • Clean or replace the air/fuel mixer.

Refer to Procedure 005-003

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Low pressure regulator is malfunctioning

Solution: S00003495

Verification

Conditions

  • Engine running at idle.

Action

  • Perform three throttle sweeps and return to idle.
  • Disconnect the gas mass flow sensor from the engine wiring harness.

Specification

  • If the engine performance improves with the sensor disconnected, then a malfunctioning low pressure regulator has been detected.

Linked Solutions

  • None

Repair

  • Replace the low pressure regulator.

Refer to Procedure 005-047

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Technical Service Bulletin is available

Solution: S00006397

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb101120

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Turbocharger wastegate actuator control line is malfunctioning

Solution: S00005874

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the turbocharger wastegate actuator control line for damage.

Refer to Procedure 010-050

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the turbocharger wastegate actuator control line.

Refer to Procedure 010-050

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Fuel system is contaminated

Solution: S00004667

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the fuel filter.

Refer to Procedure 006-015

  • Disconnect the gas mass flow sensor from the engine wiring harness.

Refer to Procedure 019-101

  • Inspect the air/fuel mixer.

Refer to Procedure 005-003

Specification

  • If excess oil is found in the fuel system, then proceed to the repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel control valve.

Refer to Procedure 019-102

  • Replace gas mass flow sensor.

Refer to Procedure 019-101

  • Clean the fuel control housing.

Refer to Procedure 005-009

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2782 | SPN: 1127 | FMI: 16
Engine Turbocharger 1 Boost Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Restricted intake air filter
  3. Intake manifold pressure sensor stuck in-range
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002077

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold: 122, 123
  • Intake manifold temperature: 153, 154
  • Engine coolant temperature: 144, ,145
  • Intake throttle: 176, 512, 513, 2643, 2644, 2645
  • Crankshaft speed/position sensor: 689, 2321
  • Ambient air temperature: 1128, 1919

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Restricted intake air filter

Solution: S00000025

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Specification

  • If the intake air filter is plugged, then a restricted intake air filter has been detected.

Linked Solutions

  • None

Repair

  • Replace the air filter.

Refer to OEM Service Manual

Refer to Procedure 010-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Intake manifold pressure sensor stuck in-range

Solution: S00004821

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the intake manifold pressure sensor.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the known value must be within: 0 ± 10 kPa [0 ± 3 in Hg]

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure sensor.

Refer to Procedure 019-099

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2783 | SPN: 1127 | FMI: 18
Engine Turbocharger 1 Boost Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Restricted intake air filter
  2. Air intake or exhaust system leaks
  3. Intake manifold pressure sensor stuck in-range
  4. Turbocharger wastegate actuator is malfunctioning
  5. Throttle intake pressure sensor is malfunctioning

1 - Restricted intake air filter

Solution: S00000025

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Specification

  • If the intake air filter is plugged, then a restricted intake air filter has been detected.

Linked Solutions

  • None

Repair

  • Replace the air filter.

Refer to OEM Service Manual

Refer to Procedure 010-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Air intake or exhaust system leaks

Solution: S00000080

Verification

Conditions

  • Engine running at idle.

Action

  • Visually inspect the intake plumbing for possible air leaks.

Refer to Procedure 010-024

  • Visually inspect the EGR plumbing for possible air leaks.

Refer to Procedure 010-024

  • Verify all connections are free of corrosion and tight.

Refer to Procedure 010-024

  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction.

Refer to Procedure 010-024

Specification

  • If a leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to Procedure 010-024

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Intake manifold pressure sensor stuck in-range

Solution: S00004821

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the intake manifold pressure sensor.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the known value must be within: 0 ± 10 kPa [0 ± 3 in Hg]

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure sensor.

Refer to Procedure 019-099

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Turbocharger wastegate actuator is malfunctioning

Solution: S00006413

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the turbocharger wastegate actuator for damage.

Refer to Procedure 010-050

  • Visually inspect the turbocharger wastegate valve seat.

Refer to Procedure 010-033

  • Inspect the turbocharger wastegate valve body assembly for damage.

Refer to Procedure 010-055

  • Perform the Turbocharger Wastegate Actuator Test.

Refer to Procedure 010-050

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace turbocharger wastegate.

Refer to Procedure 010-033

  • Replace turbocharger wastegate actuator.

Refer to Procedure 010-050

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Throttle intake pressure sensor is malfunctioning

Solution: S00005264

Verification

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Turn keyswitch ON.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the throttle intake pressure sensor reading to the barometric pressure.

Specification

  • A malfunctioning throttle intake pressure sensor has been detected if the pressure sensor is not within the following specification of local ambient air pressure: 5 in-Hg [2.5 psi]

Linked Solutions

  • None

Repair

  • Replace the throttle intake pressure sensor.

Refer to Procedure 019-470

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2961 | SPN: 412 | FMI: 15
Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. EGR temperature sensor stuck in-range
  3. ECM calibration revision history check
  4. EGR cooler plugged or restricted

1 - Check for primary fault codes

Solution: S00006330

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Engine coolant temperature: 144, 146, 151
  • Engine coolant level: 196
  • EGR: 2375, 2376

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - EGR temperature sensor stuck in-range

Solution: S00010126

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the EGR temperature sensor.

Refer to Procedure 019-378

Specification

  • If the sensor reading is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace EGR temperature sensor.

Refer to Procedure 019-378

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - EGR cooler plugged or restricted

Solution: S00009965

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean or replace the EGR cooler.

Refer to Procedure 011-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2962 | SPN: 412 | FMI: 16
Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. EGR temperature sensor stuck in-range
  3. Charge air cooler or exhaust system leak
  4. ECM calibration revision history check
  5. EGR cooler plugged or restricted

1 - Check for primary fault codes

Solution: S00006330

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Engine coolant temperature: 144, 146, 151
  • Engine coolant level: 196
  • EGR: 2375, 2376

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - EGR temperature sensor stuck in-range

Solution: S00010126

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the EGR temperature sensor.

Refer to Procedure 019-378

Specification

  • If the sensor reading is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace EGR temperature sensor.

Refer to Procedure 019-378

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Charge air cooler or exhaust system leak

Solution: S00006382

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.

Refer to Procedure 010-024

  • Visually inspect the air compressor plumbing for possible air leaks.

Refer to Procedure 010-024

  • Visually inspect the EGR plumbing for possible air leaks.

Refer to Procedure 010-024

  • Visually inspect the exhaust piping for leaks, cracks, and loose connections.

Refer to Procedure 010-024

  • Visually inspect the charge air cooler hoses for possible air leaks.

Refer to Procedure 010-024

  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

Repair or replace the following components if they are found out of specification:

  • Repair or replace the leaking components.

Refer to OEM Service Manual

  • Clean or replace the air compressor air inlet tube.

Refer to Procedure 012-109

  • Repair or replace the EGR cooler connection tube.

Refer to Procedure 011-024

  • Repair or replace the EGR crossover tube.

Refer to Procedure 011-070

  • Replace the exhaust manifold gaskets.

Refer to Procedure 011-007

  • Replace the exhaust manifold.

Refer to Procedure 011-007

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - EGR cooler plugged or restricted

Solution: S00009965

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean or replace the EGR cooler.

Refer to Procedure 011-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2963 | SPN: 110 | FMI: 15
Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Coolant level check
  3. Cooling fan component inspection
  4. Radiator is externally obstructed
  5. Radiator shutters malfunctioning (if equipped)
  6. Coolant temperature sensor resistance check
  7. Fan clutch operates incorrectly
  8. Thermostat is malfunctioning
  9. Out-of-chassis opening temperature test
  10. Combustion gases entering the cooling system
  11. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002207

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Engine coolant temperature: 144, 145

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Coolant level check

Solution: S00003142

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the coolant level.
  • Perform the Coolant System Pressure Test.

Refer to Procedure 008-018

  • Visually inspect for external coolant leaks.

Specification

  • If the coolant level is low and there are signs of external coolant leaks, then reset the search to external coolant leak.
  • If the coolant level is low and there are no signs of external coolant leaks, then reset the search to internal coolant leak.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3 - Cooling fan component inspection

Solution: S00001686

Verification

Conditions

  • Turn keyswitch OFF.

Action

Inspect the following components if applicable:

  • Visually inspect the cooling fan and cooling fan blades.
  • Visually inspect the cooling fan shroud.
  • Visually inspect the recirculation baffles.
  • Inspect the cooling fan belt.

Refer to Procedure 008-002

  • Visually inspect the cooling fan hub assembly.
  • Visually inspect the automatic cooling fan belt tensioner.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Radiator is externally obstructed

Solution: S00000485

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the radiator for damage.
  • Visually inspect the radiator for any type of external obstruction.
  • Check for closed cold weather radiator cover or winterfront.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the restricted radiator.

Refer to OEM Service Manual

  • Remove the obstruction.

Refer to OEM Service Manual

  • Repair or replace cold weather radiator cover or winterfront.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Radiator shutters malfunctioning (if equipped)

Solution: S00000484

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Manually operate the radiator shutters.

Refer to OEM Service Manual

  • Check the shutterstat setting.

Refer to OEM Service Manual

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning radiator shutters or shutterstat.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Coolant temperature sensor resistance check

Solution: S00000127

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and engine coolant temperature sensor RETURN pin at the engine coolant temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the resistance is not within the following specification: 180 - 160k Ω

Linked Solutions

  • None

Repair

  • Replace the coolant temperature sensor.

Refer to Procedure 019-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Fan clutch operates incorrectly

Solution: S00006090

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the adjustable parameters settings.

Ensure the following adjustable parameters are set correctly for the application:

  • Fan Control Logic.
  • Fan Control Switch.
  • Air Conditioner Pressure Switch Input.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Fan Override Test.
  • Verify that the fan operates correctly.
  • Verify the fan is engaging at the correct engine temperature.

Refer to Procedure 008-027

Refer to OEM Service Manual

Specification

  • If the fan does not engage at the correct engine temperature, then a malfunctioning fan clutch has been detected.

Linked Solutions

  • None

Repair

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to Procedure 008-027

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Thermostat is malfunctioning

Solution: S00000785

Verification

Conditions

  • Engine running.

Action

  • Allow the engine to reach operating temperature.
  • Check the thermostat opening temperature with an infrared temperature gun.
  • Check the coolant thermostat for proper operation.

Refer to Procedure 008-013

  • Check for a damaged or leaking thermostat seal.

Refer to Procedure 008-013

  • If a temperature gun is not available or if the temperature gun reading is above the correct thermostat opening temperature, then proceed to Linked Solutions section.

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • Out-of-chassis opening temperature test

Refer to S00001359

Repair

  • Replace the engine coolant thermostat.

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8.1 - Out-of-chassis opening temperature test

Solution: S00001359

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the out-of-chassis opening temperature test.

Refer to Procedure 008-013

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine coolant thermostat.

Refer to Procedure 008-013

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

9 - Combustion gases entering the cooling system

Solution: S00000470

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check for air or combustion gases in the cooling system.

Refer to Procedure 008-019

Specification

  • If air bubbles are found during the combustion gas test and did not change colors (Blue to Yellow or Green), then a malfunctioning air compressor has been determined.
  • If the combustion gas test changed colors (Blue to Yellow or Green), then a malfunctioning engine cylinder head gasket has been determined.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the air compressor cylinder head.

Refer to Procedure 012-007

  • Replace the cylinder head gasket.

Refer to Procedure 002-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2964 | SPN: 105 | FMI: 15
Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. High intake manifold temperature basic checks
  2. Fan clutch operates incorrectly
  3. Intake manifold temperature sensor stuck in-range
  4. Intake manifold temperature sensor stuck in-range
  5. Malfunctioning cooling fan drive or cooling fan controls
  6. Overhead component damaged or out of adjustment

1 - High intake manifold temperature basic checks

Solution: S00000459

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Refer to Procedure 010-031

  • Visually inspect the charge-air cooler for damage or debris blocking the air flow.

Refer to Procedure 010-027

  • Visually inspect the air conditioner condenser.

Refer to OEM Service Manual

  • Visually inspect the radiator fins for damage or debris blocking the air flow.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Fan clutch operates incorrectly

Solution: S00006090

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the adjustable parameters settings.

Ensure the following adjustable parameters are set correctly for the application:

  • Fan Control Logic.
  • Fan Control Switch.
  • Air Conditioner Pressure Switch Input.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Fan Override Test.
  • Verify that the fan operates correctly.
  • Verify the fan is engaging at the correct engine temperature.

Refer to Procedure 008-027

Refer to OEM Service Manual

Specification

  • If the fan does not engage at the correct engine temperature, then a malfunctioning fan clutch has been detected.

Linked Solutions

  • None

Repair

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to Procedure 008-027

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Intake manifold temperature sensor stuck in-range

Solution: S00000334

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the intake manifold temperature sensor reading to an infrared thermometer or a known value.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the known value must be within: +/- 10C [18F]

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Intake manifold temperature sensor stuck in-range

Solution: S00004561

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the intake manifold temperature sensor reading to an infrared thermometer or a known value.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the known value must be within: +/- 10C [18F].

Linked Solutions

  • None

Repair

  • Replace the intake manifold temperature sensor.

Refer to Procedure 019-099

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Malfunctioning cooling fan drive or cooling fan controls

Solution: S00000490

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Monitor the cooling fan operation.

Refer to Procedure 008-027

Specification

  • If the cooling fan operation is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.
  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Overhead component damaged or out of adjustment

Solution: S00008484

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

  • Adjust the overhead.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 08-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2973 | SPN: 102 | FMI: 2
Intake Manifold 1 Pressure - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Restricted intake air filter
  3. Charge air cooler or exhaust system leak
  4. Intake manifold pressure sensor stuck in-range
  5. Turbocharger wastegate actuator is malfunctioning
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001392

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold: 122, 123

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Restricted intake air filter

Solution: S00000025

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Specification

  • If the intake air filter is plugged, then a restricted intake air filter has been detected.

Linked Solutions

  • None

Repair

  • Replace the air filter.

Refer to OEM Service Manual

Refer to Procedure 010-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Charge air cooler or exhaust system leak

Solution: S00006382

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.

Refer to Procedure 010-024

  • Visually inspect the air compressor plumbing for possible air leaks.

Refer to Procedure 010-024

  • Visually inspect the EGR plumbing for possible air leaks.

Refer to Procedure 010-024

  • Visually inspect the exhaust piping for leaks, cracks, and loose connections.

Refer to Procedure 010-024

  • Visually inspect the charge air cooler hoses for possible air leaks.

Refer to Procedure 010-024

  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

Repair or replace the following components if they are found out of specification:

  • Repair or replace the leaking components.

Refer to OEM Service Manual

  • Clean or replace the air compressor air inlet tube.

Refer to Procedure 012-109

  • Repair or replace the EGR cooler connection tube.

Refer to Procedure 011-024

  • Repair or replace the EGR crossover tube.

Refer to Procedure 011-070

  • Replace the exhaust manifold gaskets.

Refer to Procedure 011-007

  • Replace the exhaust manifold.

Refer to Procedure 011-007

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Intake manifold pressure sensor stuck in-range

Solution: S00004821

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the intake manifold pressure sensor.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the known value must be within: 0 ± 10 kPa [0 ± 3 in Hg]

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure sensor.

Refer to Procedure 019-099

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Turbocharger wastegate actuator is malfunctioning

Solution: S00006413

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the turbocharger wastegate actuator for damage.

Refer to Procedure 010-050

  • Visually inspect the turbocharger wastegate valve seat.

Refer to Procedure 010-033

  • Inspect the turbocharger wastegate valve body assembly for damage.

Refer to Procedure 010-055

  • Perform the Turbocharger Wastegate Actuator Test.

Refer to Procedure 010-050

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace turbocharger wastegate.

Refer to Procedure 010-033

  • Replace turbocharger wastegate actuator.

Refer to Procedure 010-050

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2988 | SPN: 132 | FMI: 16
Engine Intake Air Mass Flow - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Wastegate control valve resistance check
  3. Charge air cooler or exhaust system leak
  4. Turbocharger wastegate control valve is malfunctioning
  5. Turbocharger wastegate actuator control line is malfunctioning
  6. Turbocharger wastegate actuator is malfunctioning
  7. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002077

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold: 122, 123
  • Intake manifold temperature: 153, 154
  • Engine coolant temperature: 144, ,145
  • Intake throttle: 176, 512, 513, 2643, 2644, 2645
  • Crankshaft speed/position sensor: 689, 2321
  • Ambient air temperature: 1128, 1919

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Wastegate control valve resistance check

Solution: S00006192

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wastegate control valve from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the wastegate control valve.

Refer to Procedure 019-103

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not within specification, then a malfunctioning wastegate control valve has been detected.

Linked Solutions

  • None

Repair

  • Replace the wastegate control valve.

Refer to Procedure 019-103

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Charge air cooler or exhaust system leak

Solution: S00006382

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.

Refer to Procedure 010-024

  • Visually inspect the air compressor plumbing for possible air leaks.

Refer to Procedure 010-024

  • Visually inspect the EGR plumbing for possible air leaks.

Refer to Procedure 010-024

  • Visually inspect the exhaust piping for leaks, cracks, and loose connections.

Refer to Procedure 010-024

  • Visually inspect the charge air cooler hoses for possible air leaks.

Refer to Procedure 010-024

  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

Repair or replace the following components if they are found out of specification:

  • Repair or replace the leaking components.

Refer to OEM Service Manual

  • Clean or replace the air compressor air inlet tube.

Refer to Procedure 012-109

  • Repair or replace the EGR cooler connection tube.

Refer to Procedure 011-024

  • Repair or replace the EGR crossover tube.

Refer to Procedure 011-070

  • Replace the exhaust manifold gaskets.

Refer to Procedure 011-007

  • Replace the exhaust manifold.

Refer to Procedure 011-007

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Turbocharger wastegate control valve is malfunctioning

Solution: S00004858

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wastegate control valve from the engine wiring harness.

Action

  • Perform the turbocharger wastegate control valve pressure test.

Refer to Procedure 019-103

Specification

  • If the turbocharger wastegate control valve does not pass the turbocharger wastegate control valve pressure test, then a malfunctioning turbocharger wastegate control valve has been detected.

Linked Solutions

  • None

Repair

  • Replace the wastegate control valve.

Refer to Procedure 019-103

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Turbocharger wastegate actuator control line is malfunctioning

Solution: S00005874

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the turbocharger wastegate actuator control line for damage.

Refer to Procedure 010-050

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the turbocharger wastegate actuator control line.

Refer to Procedure 010-050

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Turbocharger wastegate actuator is malfunctioning

Solution: S00006413

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the turbocharger wastegate actuator for damage.

Refer to Procedure 010-050

  • Visually inspect the turbocharger wastegate valve seat.

Refer to Procedure 010-033

  • Inspect the turbocharger wastegate valve body assembly for damage.

Refer to Procedure 010-055

  • Perform the Turbocharger Wastegate Actuator Test.

Refer to Procedure 010-050

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace turbocharger wastegate.

Refer to Procedure 010-033

  • Replace turbocharger wastegate actuator.

Refer to Procedure 010-050

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2989 | SPN: 132 | FMI: 18
Engine Intake Air Mass Flow - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Restricted intake air filter
  3. High exhaust restriction
  4. Wastegate control valve resistance check
  5. Charge air cooler or exhaust system leak
  6. Turbocharger wastegate control valve is malfunctioning
  7. Turbocharger wastegate actuator is malfunctioning
  8. Turbocharger is malfunctioning
  9. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002335

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold: 122, 123, 124
  • Engine coolant temperature: 144, 145
  • Intake manifold temperature: 153, 154
  • Intake throttle: 176, 512, 513, 2643, 2644, 2645
  • Turbocharger: 629
  • Fuel: 1128, 1919
  • Crankshaft speed/position sensor: 689, 2321

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Restricted intake air filter

Solution: S00000025

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Specification

  • If the intake air filter is plugged, then a restricted intake air filter has been detected.

Linked Solutions

  • None

Repair

  • Replace the air filter.

Refer to OEM Service Manual

Refer to Procedure 010-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - High exhaust restriction

Solution: S00004657

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Check the exhaust restriction.

Refer to Procedure 011-009

Specification

  • If the exhaust restriction is not within specification, then a restriction in the exhaust has been detected.

Linked Solutions

  • None

Repair

  • Repair the source of the exhaust restriction.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Wastegate control valve resistance check

Solution: S00006192

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wastegate control valve from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the wastegate control valve.

Refer to Procedure 019-103

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not within specification, then a malfunctioning wastegate control valve has been detected.

Linked Solutions

  • None

Repair

  • Replace the wastegate control valve.

Refer to Procedure 019-103

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Charge air cooler or exhaust system leak

Solution: S00006382

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.

Refer to Procedure 010-024

  • Visually inspect the air compressor plumbing for possible air leaks.

Refer to Procedure 010-024

  • Visually inspect the EGR plumbing for possible air leaks.

Refer to Procedure 010-024

  • Visually inspect the exhaust piping for leaks, cracks, and loose connections.

Refer to Procedure 010-024

  • Visually inspect the charge air cooler hoses for possible air leaks.

Refer to Procedure 010-024

  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

Repair or replace the following components if they are found out of specification:

  • Repair or replace the leaking components.

Refer to OEM Service Manual

  • Clean or replace the air compressor air inlet tube.

Refer to Procedure 012-109

  • Repair or replace the EGR cooler connection tube.

Refer to Procedure 011-024

  • Repair or replace the EGR crossover tube.

Refer to Procedure 011-070

  • Replace the exhaust manifold gaskets.

Refer to Procedure 011-007

  • Replace the exhaust manifold.

Refer to Procedure 011-007

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Turbocharger wastegate control valve is malfunctioning

Solution: S00004858

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wastegate control valve from the engine wiring harness.

Action

  • Perform the turbocharger wastegate control valve pressure test.

Refer to Procedure 019-103

Specification

  • If the turbocharger wastegate control valve does not pass the turbocharger wastegate control valve pressure test, then a malfunctioning turbocharger wastegate control valve has been detected.

Linked Solutions

  • None

Repair

  • Replace the wastegate control valve.

Refer to Procedure 019-103

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Turbocharger wastegate actuator is malfunctioning

Solution: S00006413

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the turbocharger wastegate actuator for damage.

Refer to Procedure 010-050

  • Visually inspect the turbocharger wastegate valve seat.

Refer to Procedure 010-033

  • Inspect the turbocharger wastegate valve body assembly for damage.

Refer to Procedure 010-055

  • Perform the Turbocharger Wastegate Actuator Test.

Refer to Procedure 010-050

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace turbocharger wastegate.

Refer to Procedure 010-033

  • Replace turbocharger wastegate actuator.

Refer to Procedure 010-050

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Turbocharger is malfunctioning

Solution: S00004192

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the intake and exhaust connections from the turbocharger.

Action

  • Check that the turbocharger application identification number in the variable geometry turbocharger actuator matches the turbocharger application identification number in the ECM.
  • Visually inspect the turbocharger exhaust outlet for signs of oil or fuel.

Refer to Procedure 010-033

  • Visually inspect the compressor wheel retaining nut for signs of dust ingestion.

Refer to Procedure 010-033

  • Visually inspect the turbocharger compressor and turbine seals.

Refer to Procedure 010-033

  • Measure the radial and axial clearance of the turbocharger wheel.

Refer to Procedure 010-033

Specification

  • If any deposits, damage, or oil contamination is observed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the turbocharger.

Refer to Procedure 010-033

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 2991 | SPN: 1390 | FMI: 1
Engine Fuel Valve 1 Intake Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. External fuel leak
  2. Fuel pressure check
  3. Technical Service Bulletin is available
  4. Fuel outlet pressure sensor stuck in-range
  5. Low pressure regulator is malfunctioning
  6. Fuel inlet pressure sensor stuck in-range
  7. Boost reference line damaged
  8. Low pressure regulator o-rings are damaged
  9. Laminar flow screen is restricted
  10. Fuel system is contaminated
  11. ECM calibration revision history check

1 - External fuel leak

Solution: S00004765

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Start the engine.
  • Use a combustible gas detector to check for leaks.

Specification

  • If there is any damage or leaks found in the fuel system, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM fuel lines.

Refer to OEM Service Manual

  • Replace fuel filter.

Refer to Procedure 006-015

  • Replace the low pressure regulator.

Refer to Procedure 005-047

  • Replace the high pressure regulator.

Refer to Procedure 005-061

  • Replace gas mass flow sensor.

Refer to Procedure 019-101

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Fuel pressure check

Solution: S00004450

Verification

Conditions

  • Turn keyswitch OFF.
  • Verify all fuel shutoff valves are in the open position.

Action

  • Verify the fuel gauge is working properly.

Refer to OEM Service Manual

  • Verify the fuel tank pressure meets specification.

Refer to OEM Service Manual

  • Verify the fuel regulator intake pressure meets specifications.

Refer to Procedure 005-061

Specification

  • If any of the checks are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Add fuel if needed.

Refer to OEM Service Manual

  • For an OEM issue: Contact the OEM for further repair instructions.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Technical Service Bulletin is available

Solution: S00009792

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb150180

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel outlet pressure sensor stuck in-range

Solution: S00003459

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Install a mechanical gauge on the engine.

Refer to Procedure 005-047

  • Start the engine.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the fuel regulator outlet pressure.

Refer to Procedure 005-047

  • Compare the sensor reading with the recommended Cummins® electronic service tool or equivalent to a mechanical gauge.

Specification

  • A malfunctioning fuel outlet pressure sensor has been detected if the readings are not within the following specification of each other: 5%

Linked Solutions

  • None

Repair

  • Replace the fuel outlet pressure/temperature sensor.

Refer to Procedure 019-153

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Low pressure regulator is malfunctioning

Solution: S00005020

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Install a mechanical gauge on the engine.
  • Turn keyswitch ON.
  • Perform the Fuel Pressure Test.

Refer to Procedure 005-047

Specification

  • If the Fuel Pressure Test does not meet specification, then a malfunctioning low pressure regulator has been detected.

Linked Solutions

  • None

Repair

  • Replace the low pressure regulator.

Refer to Procedure 005-047

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Fuel inlet pressure sensor stuck in-range

Solution: S00004738

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Install a mechanical gauge on the engine.

Refer to Procedure 005-061

  • Start the engine.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the fuel regulator intake pressure.

Refer to Procedure 005-061

  • Compare the sensor reading with the recommended Cummins® electronic service tool or equivalent to a mechanical gauge.

Specification

  • A malfunctioning OEM fuel delivery system has been detected if the readings are within the following specification of each other: 5%
  • A malfunctioning fuel inlet pressure sensor has been detected if the readings are not within the following specification of each other: 5%

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM fuel system component.

Refer to OEM Service Manual

  • Replace the fuel inlet pressure sensor.

Refer to Procedure 019-188

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Boost reference line damaged

Solution: S00003800

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Visually inspect the low pressure regulator boost reference line for damage.

Refer to Procedure 010-050

Specification

  • If any damage or if the low pressure regulator boost reference line is found leaking, then a malfunctioning low pressure regulator boost reference line has been detected.
  • If fuel is detected inside the boost reference line, then a leaking low pressure regulator or fuel shutoff valve has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the low pressure regulator boost reference line.

Refer to Procedure 010-050

  • Replace the low pressure regulator.

Refer to Procedure 005-047

  • Replace the fuel shutoff valve.

Refer to Procedure 019-050

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Low pressure regulator o-rings are damaged

Solution: S00006223

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the low pressure regulator.

Refer to Procedure 005-047

  • Inspect the low pressure regulator.

Refer to Procedure 005-047

  • Inspect the low pressure regulator o-rings.

Refer to Procedure 005-047

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the low pressure regulator.

Refer to Procedure 005-047

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Laminar flow screen is restricted

Solution: S00001653

Verification

Conditions

  • Turn keyswitch OFF.
  • Follow the gas engine shutdown procedure.

Refer to Procedure 005-009

Action

  • Remove the fuel transfer tube from the fuel control housing.

Refer to Procedure 005-009

  • Inspect the laminar flow screen for deposits, damage, or oil contamination.

Refer to Procedure 005-009

Specification

  • If any deposits, damage, or oil contamination is observed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Remove and do not replace the laminar flow screen.

Refer to Procedure 005-009

  • Locate and correct the source of the oil contamination.
  • Clean the fuel system of any oil deposits.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - Fuel system is contaminated

Solution: S00004667

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the fuel filter.

Refer to Procedure 006-015

  • Disconnect the gas mass flow sensor from the engine wiring harness.

Refer to Procedure 019-101

  • Inspect the air/fuel mixer.

Refer to Procedure 005-003

Specification

  • If excess oil is found in the fuel system, then proceed to the repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel control valve.

Refer to Procedure 019-102

  • Replace gas mass flow sensor.

Refer to Procedure 019-101

  • Clean the fuel control housing.

Refer to Procedure 005-009

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

11 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 3186 | SPN: 1623 | FMI: 9
Tachograph Output Shaft Speed - Abnormal Update Rate

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 3213 | SPN: 1623 | FMI: 19
Tachograph Output Shaft Speed - Received Network Data in Error

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 3326 | SPN: 91 | FMI: 9
Accelerator Pedal Position 1 - Abnormal Update Rate

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 3328 | SPN: 191 | FMI: 9
Transmission Output Shaft Speed - Abnormal Update Rate

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 3366 | SPN: 111 | FMI: 18
Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Coolant level check
  3. Coolant level sensor open circuit check
  4. Coolant level sensor circuit pin to ground short
  5. Coolant level sensor circuit pin to pin short
  6. Coolant level sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00010587

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 operating hours from the following list:

  • Coolant level: 195, 196

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Coolant level check

Solution: S00003142

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the coolant level.
  • Perform the Coolant System Pressure Test.

Refer to Procedure 008-018

  • Visually inspect for external coolant leaks.

Specification

  • If the coolant level is low and there are signs of external coolant leaks, then reset the search to external coolant leak.
  • If the coolant level is low and there are no signs of external coolant leaks, then reset the search to internal coolant leak.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3 - Coolant level sensor open circuit check

Solution: S00007920

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Coolant level sensor circuit pin to ground short

Solution: S00007921

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Coolant level sensor circuit pin to pin short

Solution: S00007922

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor SUPPLY pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Coolant level sensor is malfunctioning

Solution: S00007923

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning coolant level sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace engine coolant level sensor.

Refer to Procedure 019-017

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 15-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 3367 | SPN: 4490 | FMI: 9
Specific Humidity Sensor - Abnormal Update Rate

Troubleshooting Summary

  1. Check for primary fault codes
  2. Battery or battery cables are malfunctioning
  3. Specific humidity sensor stuck in-range
  4. Humidity sensor voltage check
  5. Humidity sensor voltage check at the ECM
  6. J1939 data link terminating resistance is incorrect
  7. Engine data link terminating resistor resistance check
  8. Ignition control module data link terminating resistor resistance check
  9. J1939 data link harness open circuit check
  10. Specific humidity intake sensor not grounded
  11. ECM calibration revision history check
  12. Specific humidity intake sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00002072

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Ignition: 459, 462

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Specific humidity sensor stuck in-range

Solution: S00004915

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.

Monitor the following parameters:

  • Monitor the compressor intake temperature sensor
  • Monitor the engine turbocharger compressor intake pressure sensor

Specification

  • A malfunctioning temperature sensor has been detected if the temperature sensor is not within the following specification of local ambient air temperature: +/- 5° C [9° F]
  • A malfunctioning pressure sensor has been detected if the pressure sensor is not within the following specification of local ambient air pressure: +/- 5 kPa [1.5 in-Hg]

Linked Solutions

  • None

Repair

  • Replace the turbocharger compressor intake humidity/pressure/temperature sensor.

Refer to Procedure 019-509

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Humidity sensor voltage check

Solution: S00004920

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake humidity/pressure/temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the turbocharger compressor intake humidity/pressure/temperature sensor SUPPLY pin and the turbocharger compressor intake humidity/pressure/temperature sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • Humidity sensor voltage check at the ECM

Refer to S00004943

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4.1 - Humidity sensor voltage check at the ECM

Solution: S00004943

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the turbocharger compressor intake humidity/pressure /temperature sensor SUPPLY pin and the turbocharger compressor intake humidity/pressure/temperature sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if the voltage is not within the following specification of battery voltage: 1 VDC
  • A malfunctioning engine wiring harness has been detected if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • None
Parent Solution

5 - J1939 data link terminating resistance is incorrect

Solution: S00005757

Verification

Conditions

  • Turn keyswitch OFF.
  • Wait for 90 seconds.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3-pin service data link connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the resistance is not within the following specification: 54 - 66 Ω

Linked Solutions

  • Engine data link terminating resistor resistance check

Refer to S00005758

  • Ignition control module data link terminating resistor resistance check

Refer to S00005699

  • J1939 data link harness open circuit check

Refer to S00005759

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

5.1 - Engine data link terminating resistor resistance check

Solution: S00005758

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the terminating resistor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the terminating resistor.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning terminating resistor has been detected if the resistance is not within the following specification: 108-132 Ω

Linked Solutions

  • None

Repair

  • Replace the terminating resistor.

Refer to Procedure 019-417

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.2 - Ignition control module data link terminating resistor resistance check

Solution: S00005699

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the ignition control module C1 connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning terminating resistor has been detected if the resistance is not within the following specification: 108 - 132 Ω

Linked Solutions

  • None

Repair

  • Replace ignition control module.

Refer to Procedure 019-105

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.3 - J1939 data link harness open circuit check

Solution: S00005759

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the appropriate data link component from the data link wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the J1939 (+) pin at the appropriate component data link wiring harness connector and the appropriate data link component J1939 (+) pin at the data link wiring harness ECM connector.
  • Measure the resistance between the J1939 (-) pin at the appropriate component data link wiring harness connector and the appropriate data link component J1939 (-) pin at the data link wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning J1939 data link wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - Specific humidity intake sensor not grounded

Solution: S00005039

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake humidity/pressure/temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Verify the grounding wire is present and properly grounded.
  • Measure the resistance between the turbocharger compressor intake humidity/pressure/temperature sensor RETURN pin at the turbocharger compressor intake humidity/pressure/temperature sensor engine wiring harness connector and the turbocharger compressor intake humidity/pressure/temperature sensor grounding wire connector.

Refer to Procedure 019-510

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Specific humidity intake sensor is malfunctioning

Solution: S00004098

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning specific humidity intake sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace humidity sensor.

Refer to Procedure 019-509

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 3368 | SPN: 4490 | FMI: 19
Specific Humidity Sensor - Received Network Data in Error

Troubleshooting Summary

  1. Specific humidity sensor stuck in-range
  2. Specific humidity intake sensor not grounded
  3. ECM calibration revision history check
  4. Specific humidity intake sensor is malfunctioning

1 - Specific humidity sensor stuck in-range

Solution: S00004915

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.

Monitor the following parameters:

  • Monitor the compressor intake temperature sensor
  • Monitor the engine turbocharger compressor intake pressure sensor

Specification

  • A malfunctioning temperature sensor has been detected if the temperature sensor is not within the following specification of local ambient air temperature: +/- 5° C [9° F]
  • A malfunctioning pressure sensor has been detected if the pressure sensor is not within the following specification of local ambient air pressure: +/- 5 kPa [1.5 in-Hg]

Linked Solutions

  • None

Repair

  • Replace the turbocharger compressor intake humidity/pressure/temperature sensor.

Refer to Procedure 019-509

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Specific humidity intake sensor not grounded

Solution: S00005039

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake humidity/pressure/temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Verify the grounding wire is present and properly grounded.
  • Measure the resistance between the turbocharger compressor intake humidity/pressure/temperature sensor RETURN pin at the turbocharger compressor intake humidity/pressure/temperature sensor engine wiring harness connector and the turbocharger compressor intake humidity/pressure/temperature sensor grounding wire connector.

Refer to Procedure 019-510

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Specific humidity intake sensor is malfunctioning

Solution: S00004098

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning specific humidity intake sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace humidity sensor.

Refer to Procedure 019-509

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 3374 | SPN: 1818 | FMI: 31
Roll Over Protection Brake Control Active - Condition Exists

Troubleshooting Summary

  1. ECM calibration revision history check

1 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 3418 | SPN: 191 | FMI: 19
Transmission Output Shaft Speed - Received Network Data in Error

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 3436 | SPN: 3217 | FMI: 16
Aftertreatment Intake Oxygen Sensor - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment intake oxygen sensor heater resistance check
  3. Low pressure regulator is malfunctioning
  4. Exhaust leak visual check
  5. Aftertreatment intake oxygen sensor heater voltage check
  6. Aftertreatment intake oxygen sensor heater circuit pin to ground short
  7. Aftertreatment intake oxygen sensor open circuit check
  8. Aftertreatment intake oxygen sensor circuit pin to ground short
  9. Aftertreatment intake oxygen sensor circuit pin to pin short
  10. ECM calibration revision history check
  11. Aftertreatment intake oxygen sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00001950

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment outlet oxygen: 2686, 2687

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment intake oxygen sensor heater resistance check

Solution: S00004153

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake oxygen sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the aftertreatment intake oxygen sensor.

Refer to Procedure 019-100

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not within specification, then a malfunctioning aftertreatment intake oxygen sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake oxygen sensor.

Refer to Procedure 019-100

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Low pressure regulator is malfunctioning

Solution: S00003495

Verification

Conditions

  • Engine running at idle.

Action

  • Perform three throttle sweeps and return to idle.
  • Disconnect the gas mass flow sensor from the engine wiring harness.

Specification

  • If the engine performance improves with the sensor disconnected, then a malfunctioning low pressure regulator has been detected.

Linked Solutions

  • None

Repair

  • Replace the low pressure regulator.

Refer to Procedure 005-047

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Exhaust leak visual check

Solution: S00009448

Verification

Conditions

  • Turn keyswitch ON.
  • Engine running at idle.

Action

  • Visually inspect for leaks from the turbocharger to exhaust manifold.
  • Visually inspect for loose or broken mounting hardware or damaged connection gasket.
  • Visually inspect for leaks in the exhaust manifold to head.
  • Visually inspect for leaks from the EGR components.
  • Visually inspect the exhaust piping for leaks, cracks, and loose connections.

Specification

  • If there is any damage or leaks found in the exhaust system, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the leaking components.

Refer to Procedure 011-007

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment intake oxygen sensor heater voltage check

Solution: S00004902

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake oxygen sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check that all battery terminal connections are tight and corrosion free.
  • Turn keyswitch ON.
  • Run the engine at idle for the following minutes: 12
  • Measure the voltage between the aftertreatment intake oxygen sensor heater SUPPLY pin and the aftertreatment intake oxygen sensor heater RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • Aftertreatment intake oxygen sensor heater circuit pin to ground short

Refer to S00004964

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

5.1 - Aftertreatment intake oxygen sensor heater circuit pin to ground short

Solution: S00004964

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake oxygen sensor from the engine wiring harness.

Action

  • Start the engine.
  • Measure the voltage between the aftertreatment intake oxygen sensor heater SUPPLY pin at the sensor connector of the engine wiring harness and ground.

Specification

  • A malfunctioning engine wiring harness has been detected if the voltage is within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - Aftertreatment intake oxygen sensor open circuit check

Solution: S00004820

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness ECM connector 1 and 2.
  • Disconnect the aftertreatment intake oxygen sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment intake oxygen sensor SIGNAL pin at the aftertreatment intake oxygen sensor engine wiring harness connector and the aftertreatment intake oxygen sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the aftertreatment intake oxygen sensor RETURN pin at the aftertreatment intake oxygen sensor engine wiring harness connector and the aftertreatment intake oxygen sensor RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the aftertreatment intake oxygen sensor heater SUPPLY pin at the aftertreatment intake oxygen sensor connector of the engine wiring harness and the aftertreatment intake oxygen sensor heater SUPPLY pin at the engine wiring harness ECM connector.
  • Measure the resistance between the aftertreatment intake oxygen sensor heater RETURN pin at the aftertreatment intake oxygen sensor connector of the engine wiring harness and the aftertreatment intake oxygen sensor heater RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Aftertreatment intake oxygen sensor circuit pin to ground short

Solution: S00002829

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the aftertreatment intake oxygen sensor from the engine wiring harness.
  • Disconnect all components on the wiring circuit being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment intake oxygen sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the aftertreatment intake oxygen sensor RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the aftertreatment intake oxygen sensor heater SUPPLY pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the aftertreatment intake oxygen sensor heater RETURN pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Aftertreatment intake oxygen sensor circuit pin to pin short

Solution: S00005985

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake oxygen sensor from the engine wiring harness.
  • Disconnect the engine wiring harness ECM connector 1 and 2.
  • Disconnect all components on the wiring circuit being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment intake oxygen sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the aftertreatment intake oxygen sensor RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the aftertreatment intake oxygen sensor heater SUPPLY pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the aftertreatment intake oxygen sensor heater RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - Aftertreatment intake oxygen sensor is malfunctioning

Solution: S00004151

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment intake oxygen sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake oxygen sensor.

Refer to Procedure 019-100

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 3437 | SPN: 3217 | FMI: 18
Aftertreatment Intake Oxygen Sensor - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment intake oxygen sensor heater resistance check
  3. Low pressure regulator is malfunctioning
  4. Exhaust leak visual check
  5. Aftertreatment intake oxygen sensor heater voltage check
  6. Aftertreatment intake oxygen sensor heater circuit pin to ground short
  7. Aftertreatment intake oxygen sensor open circuit check
  8. Aftertreatment intake oxygen sensor circuit pin to pin short
  9. ECM calibration revision history check
  10. Aftertreatment intake oxygen sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00002362

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment intake oxygen: 2686, 2687, 3436
  • Aftertreatment NOx: 1887
  • Engine coolant temperature: 2963
  • Aftertreatment diesel exhaust fluid system: 3258, 3651
  • Crankcase pressure: 3734

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment intake oxygen sensor heater resistance check

Solution: S00004153

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake oxygen sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the aftertreatment intake oxygen sensor.

Refer to Procedure 019-100

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not within specification, then a malfunctioning aftertreatment intake oxygen sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake oxygen sensor.

Refer to Procedure 019-100

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Low pressure regulator is malfunctioning

Solution: S00003495

Verification

Conditions

  • Engine running at idle.

Action

  • Perform three throttle sweeps and return to idle.
  • Disconnect the gas mass flow sensor from the engine wiring harness.

Specification

  • If the engine performance improves with the sensor disconnected, then a malfunctioning low pressure regulator has been detected.

Linked Solutions

  • None

Repair

  • Replace the low pressure regulator.

Refer to Procedure 005-047

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Exhaust leak visual check

Solution: S00009448

Verification

Conditions

  • Turn keyswitch ON.
  • Engine running at idle.

Action

  • Visually inspect for leaks from the turbocharger to exhaust manifold.
  • Visually inspect for loose or broken mounting hardware or damaged connection gasket.
  • Visually inspect for leaks in the exhaust manifold to head.
  • Visually inspect for leaks from the EGR components.
  • Visually inspect the exhaust piping for leaks, cracks, and loose connections.

Specification

  • If there is any damage or leaks found in the exhaust system, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the leaking components.

Refer to Procedure 011-007

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment intake oxygen sensor heater voltage check

Solution: S00004902

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake oxygen sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check that all battery terminal connections are tight and corrosion free.
  • Turn keyswitch ON.
  • Run the engine at idle for the following minutes: 12
  • Measure the voltage between the aftertreatment intake oxygen sensor heater SUPPLY pin and the aftertreatment intake oxygen sensor heater RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • Aftertreatment intake oxygen sensor heater circuit pin to ground short

Refer to S00004964

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

5.1 - Aftertreatment intake oxygen sensor heater circuit pin to ground short

Solution: S00004964

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake oxygen sensor from the engine wiring harness.

Action

  • Start the engine.
  • Measure the voltage between the aftertreatment intake oxygen sensor heater SUPPLY pin at the sensor connector of the engine wiring harness and ground.

Specification

  • A malfunctioning engine wiring harness has been detected if the voltage is within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - Aftertreatment intake oxygen sensor open circuit check

Solution: S00004820

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness ECM connector 1 and 2.
  • Disconnect the aftertreatment intake oxygen sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment intake oxygen sensor SIGNAL pin at the aftertreatment intake oxygen sensor engine wiring harness connector and the aftertreatment intake oxygen sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the aftertreatment intake oxygen sensor RETURN pin at the aftertreatment intake oxygen sensor engine wiring harness connector and the aftertreatment intake oxygen sensor RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the aftertreatment intake oxygen sensor heater SUPPLY pin at the aftertreatment intake oxygen sensor connector of the engine wiring harness and the aftertreatment intake oxygen sensor heater SUPPLY pin at the engine wiring harness ECM connector.
  • Measure the resistance between the aftertreatment intake oxygen sensor heater RETURN pin at the aftertreatment intake oxygen sensor connector of the engine wiring harness and the aftertreatment intake oxygen sensor heater RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Aftertreatment intake oxygen sensor circuit pin to pin short

Solution: S00005985

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake oxygen sensor from the engine wiring harness.
  • Disconnect the engine wiring harness ECM connector 1 and 2.
  • Disconnect all components on the wiring circuit being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment intake oxygen sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the aftertreatment intake oxygen sensor RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the aftertreatment intake oxygen sensor heater SUPPLY pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the aftertreatment intake oxygen sensor heater RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Aftertreatment intake oxygen sensor is malfunctioning

Solution: S00004151

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment intake oxygen sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake oxygen sensor.

Refer to Procedure 019-100

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 3488 | SPN: 563 | FMI: 9
Anti-Lock Braking (ABS) Controller - Abnormal Update Rate

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 3526 | SPN: 84 | FMI: 9
Wheel-Based Vehicle Speed - Abnormal Update Rate

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 3528 | SPN: 558 | FMI: 9
Accelerator Pedal or Lever Idle Validation Switch - Abnormal Update Rate

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 3531 | SPN: 171 | FMI: 9
Ambient Air Temperature - Abnormal Update Rate

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 3532 | SPN: 171 | FMI: 19
Ambient Air Temperature - Received Network Data in Error

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 3641 | SPN: 748 | FMI: 9
Transmission Output Retarder - Abnormal Update Rate

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 3838 | SPN: 2978 | FMI: 9
Estimated Engine Parasitic Losses - Percent Torque - Abnormal Update Rate

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 3843 | SPN: 5603 | FMI: 9
Cruise Control Disable Command - Abnormal Update Rate

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 3844 | SPN: 5605 | FMI: 31
Cruise Control Pause Command - Condition Exists

Troubleshooting Summary

  1. Fault code is for information only
  2. ECM calibration revision history check

1 - Fault code is for information only

Solution: S00004413

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • This solution is for information only stating that the adaptive cruise control has paused.

Specification

  • This solution is information only.

Linked Solutions

  • None

Repair

  • This fault code is for information only.
  • No repair is necessary.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 3845 | SPN: 5603 | FMI: 31
Cruise Control Disable Command - Condition Exists

Troubleshooting Summary

  1. Fault code is for information only
  2. ECM calibration revision history check

1 - Fault code is for information only

Solution: S00003669

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • This solution is for information only stating that the adaptive cruise control has been disabled.

Specification

  • This solution is information only.

Linked Solutions

  • None

Repair

  • This fault code is for information only.
  • No repair is necessary.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 3847 | SPN: 633 | FMI: 17
Engine Fuel Actuator Control - Data Valid But Below Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. External fuel leak
  2. Fuel pressure check
  3. Check for primary fault codes
  4. Air/fuel mixer is malfunctioning
  5. Fuel control valve resistance check
  6. Technical Service Bulletin is available
  7. Laminar flow screen is restricted
  8. Engine fuel control valve circuit has pin to pin short
  9. ECM calibration revision history check

1 - External fuel leak

Solution: S00004765

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Start the engine.
  • Use a combustible gas detector to check for leaks.

Specification

  • If there is any damage or leaks found in the fuel system, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM fuel lines.

Refer to OEM Service Manual

  • Replace fuel filter.

Refer to Procedure 006-015

  • Replace the low pressure regulator.

Refer to Procedure 005-047

  • Replace the high pressure regulator.

Refer to Procedure 005-061

  • Replace gas mass flow sensor.

Refer to Procedure 019-101

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Fuel pressure check

Solution: S00004450

Verification

Conditions

  • Turn keyswitch OFF.
  • Verify all fuel shutoff valves are in the open position.

Action

  • Verify the fuel gauge is working properly.

Refer to OEM Service Manual

  • Verify the fuel tank pressure meets specification.

Refer to OEM Service Manual

  • Verify the fuel regulator intake pressure meets specifications.

Refer to Procedure 005-061

Specification

  • If any of the checks are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Add fuel if needed.

Refer to OEM Service Manual

  • For an OEM issue: Contact the OEM for further repair instructions.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Check for primary fault codes

Solution: S00002439

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 1827, 1828, 1839, 1841, 2568, 2722, 2723, 2724, 2725

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

4 - Air/fuel mixer is malfunctioning

Solution: S00004158

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the air/fuel mixer.

Refer to Procedure 005-003

  • Inspect the air/fuel mixer.

Refer to Procedure 005-003

Specification

  • If any damage or restriction is found, then a malfunctioning air/fuel mixer has been detected.

Linked Solutions

  • None

Repair

  • Clean or replace the air/fuel mixer.

Refer to Procedure 005-003

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Fuel control valve resistance check

Solution: S00004796

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel control valve from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel control valve SIGNAL pin and the fuel control valve RETURN pin at the fuel control valve connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel control valve has been detected if the resistance is not within the following specification: 2 - 5 Ω

Linked Solutions

  • None

Repair

  • Replace the fuel control valve.

Refer to Procedure 019-102

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Technical Service Bulletin is available

Solution: S00006397

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb101120

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Laminar flow screen is restricted

Solution: S00001653

Verification

Conditions

  • Turn keyswitch OFF.
  • Follow the gas engine shutdown procedure.

Refer to Procedure 005-009

Action

  • Remove the fuel transfer tube from the fuel control housing.

Refer to Procedure 005-009

  • Inspect the laminar flow screen for deposits, damage, or oil contamination.

Refer to Procedure 005-009

Specification

  • If any deposits, damage, or oil contamination is observed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Remove and do not replace the laminar flow screen.

Refer to Procedure 005-009

  • Locate and correct the source of the oil contamination.
  • Clean the fuel system of any oil deposits.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Engine fuel control valve circuit has pin to pin short

Solution: S00003363

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness ECM connector 1 and 2.
  • Disconnect the engine fuel control valve from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine fuel control valve (+) pin in the engine wiring harness ECM connector 1 and all other pins in ECM connector 1.
  • Measure the resistance between the engine fuel control valve (+) pin in the engine wiring harness ECM connector and all other pins in ECM connector 2.
  • Measure the resistance between the engine fuel control valve (-) pin in the engine wiring harness ECM connector 1 and all other pins in ECM connector 1.
  • Measure the resistance between the engine fuel control valve (-) pin in the engine wiring harness ECM connector and all other pins in ECM connector 2.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 4621 | SPN: 1127 | FMI: 2
Engine Turbocharger 1 Boost Pressure - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Air intake or exhaust system leaks
  3. Throttle intake pressure sensor is malfunctioning
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002322

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold: 2973
  • Intake throttle: 2517, 2518

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Air intake or exhaust system leaks

Solution: S00000080

Verification

Conditions

  • Engine running at idle.

Action

  • Visually inspect the intake plumbing for possible air leaks.

Refer to Procedure 010-024

  • Visually inspect the EGR plumbing for possible air leaks.

Refer to Procedure 010-024

  • Verify all connections are free of corrosion and tight.

Refer to Procedure 010-024

  • Visually inspect the air intake piping between the air filter housing and turbocharger intake for damage or restriction.

Refer to Procedure 010-024

Specification

  • If a leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to Procedure 010-024

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Throttle intake pressure sensor is malfunctioning

Solution: S00005264

Verification

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Turn keyswitch ON.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the throttle intake pressure sensor reading to the barometric pressure.

Specification

  • A malfunctioning throttle intake pressure sensor has been detected if the pressure sensor is not within the following specification of local ambient air pressure: 5 in-Hg [2.5 psi]

Linked Solutions

  • None

Repair

  • Replace the throttle intake pressure sensor.

Refer to Procedure 019-470

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 4855 | SPN: 1127 | FMI: 31
Engine Turbocharger 1 Boost Pressure - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002294

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold: 122, 123, 124, 125, 2973
  • Mass air flow: 358, 2633
  • Turbocharger: 2517, 2518, 2782, 2783, 4621

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 5111 | SPN: 6652 | FMI: 18
Aftertreatment 1 Three Way Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Fault Code 5111 requires that ALL solutions be performed
  2. Exhaust catalyst is malfunctioning
  3. ECM calibration revision history check

1 - Fault Code 5111 requires that ALL solutions be performed

Solution: S00007279

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • This solution is information only.
  • ALL solutions displayed for this fault code must be performed.
  • Continue to perform the verifications of ALL solution steps listed for this fault code regardless if a given solution is within specification or out of specification.

Specification

  • This solution is information only.

Linked Solutions

  • None

Repair

  • If a resolution is found in any solution for this fault code, continue performing ALL solutions listed for this fault code.

Validation

  • None
Next Solution

2 - Exhaust catalyst is malfunctioning

Solution: S00004334

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the exhaust catalyst for damage or contamination.

Refer to Procedure 011-078

Specification

  • If the exhaust catalyst does not meet specification, then a malfunctioning exhaust catalyst has been detected.

Linked Solutions

  • None

Repair

  • Locate and correct the source of the oil contamination.
  • Replace the exhaust catalyst.

Refer to Procedure 011-078

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 5948 | SPN: 633 | FMI: 16
Engine Fuel Actuator Control - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. External fuel leak
  2. Fuel pressure check
  3. Check for primary fault codes
  4. Air/fuel mixer is malfunctioning
  5. Fuel control valve resistance check
  6. Fuel control valve open circuit check
  7. Engine fuel control valve circuit has pin to pin short
  8. ECM calibration revision history check

1 - External fuel leak

Solution: S00004765

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Start the engine.
  • Use a combustible gas detector to check for leaks.

Specification

  • If there is any damage or leaks found in the fuel system, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM fuel lines.

Refer to OEM Service Manual

  • Replace fuel filter.

Refer to Procedure 006-015

  • Replace the low pressure regulator.

Refer to Procedure 005-047

  • Replace the high pressure regulator.

Refer to Procedure 005-061

  • Replace gas mass flow sensor.

Refer to Procedure 019-101

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Fuel pressure check

Solution: S00004450

Verification

Conditions

  • Turn keyswitch OFF.
  • Verify all fuel shutoff valves are in the open position.

Action

  • Verify the fuel gauge is working properly.

Refer to OEM Service Manual

  • Verify the fuel tank pressure meets specification.

Refer to OEM Service Manual

  • Verify the fuel regulator intake pressure meets specifications.

Refer to Procedure 005-061

Specification

  • If any of the checks are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Add fuel if needed.

Refer to OEM Service Manual

  • For an OEM issue: Contact the OEM for further repair instructions.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Check for primary fault codes

Solution: S00002373

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 1827, 1828, 1839, 1841, 2568, 2722, 2723, 2724, 2725

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

4 - Air/fuel mixer is malfunctioning

Solution: S00004158

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the air/fuel mixer.

Refer to Procedure 005-003

  • Inspect the air/fuel mixer.

Refer to Procedure 005-003

Specification

  • If any damage or restriction is found, then a malfunctioning air/fuel mixer has been detected.

Linked Solutions

  • None

Repair

  • Clean or replace the air/fuel mixer.

Refer to Procedure 005-003

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Fuel control valve resistance check

Solution: S00004796

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel control valve from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel control valve SIGNAL pin and the fuel control valve RETURN pin at the fuel control valve connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel control valve has been detected if the resistance is not within the following specification: 2 - 5 Ω

Linked Solutions

  • None

Repair

  • Replace the fuel control valve.

Refer to Procedure 019-102

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Fuel control valve open circuit check

Solution: S00004216

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel control valve from the engine wiring harness.

Action

  • Measure the resistance between the fuel control valve SIGNAL pin at the fuel control valve connector of the engine wiring harness and the fuel control valve SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the fuel control valve RETURN pin at the fuel control valve connector of the engine wiring harness and the fuel control valve RETURN pin at the engine wiring harness ECM connector.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Engine fuel control valve circuit has pin to pin short

Solution: S00003363

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness ECM connector 1 and 2.
  • Disconnect the engine fuel control valve from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine fuel control valve (+) pin in the engine wiring harness ECM connector 1 and all other pins in ECM connector 1.
  • Measure the resistance between the engine fuel control valve (+) pin in the engine wiring harness ECM connector and all other pins in ECM connector 2.
  • Measure the resistance between the engine fuel control valve (-) pin in the engine wiring harness ECM connector 1 and all other pins in ECM connector 1.
  • Measure the resistance between the engine fuel control valve (-) pin in the engine wiring harness ECM connector and all other pins in ECM connector 2.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 6388 | SPN: 3464 | FMI: 31
Engine Throttle Control Actuator - Condition Exists - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. Engine intake throttle actuator is malfunctioning

1 - Check for primary fault codes

Solution: S00002384

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake throttle: 2758, 2759

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Engine intake throttle actuator is malfunctioning

Solution: S00004282

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Gas Throttle Control Test.

Specification

  • If the engine intake throttle actuator does not pass the Gas Throttle Control Test, then a malfunctioning engine intake throttle actuator has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine intake throttle actuator.

Refer to Procedure 005-052

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 12-Dec-2021


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 6396 | SPN: 1696 | FMI: 2
Engine Exhaust O₂ Sensor Closed Loop Operation - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment intake oxygen sensor heater resistance check
  3. Low pressure regulator is malfunctioning
  4. Aftertreatment intake oxygen sensor heater voltage check
  5. Aftertreatment intake oxygen sensor heater circuit pin to ground short
  6. Aftertreatment intake oxygen sensor open circuit check
  7. Aftertreatment intake oxygen sensor circuit pin to pin short
  8. ECM calibration revision history check
  9. Aftertreatment intake oxygen sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00002101

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment outlet oxygen: 2686, 2687

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment intake oxygen sensor heater resistance check

Solution: S00004153

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake oxygen sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the aftertreatment intake oxygen sensor.

Refer to Procedure 019-100

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not within specification, then a malfunctioning aftertreatment intake oxygen sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake oxygen sensor.

Refer to Procedure 019-100

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Low pressure regulator is malfunctioning

Solution: S00003495

Verification

Conditions

  • Engine running at idle.

Action

  • Perform three throttle sweeps and return to idle.
  • Disconnect the gas mass flow sensor from the engine wiring harness.

Specification

  • If the engine performance improves with the sensor disconnected, then a malfunctioning low pressure regulator has been detected.

Linked Solutions

  • None

Repair

  • Replace the low pressure regulator.

Refer to Procedure 005-047

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment intake oxygen sensor heater voltage check

Solution: S00004902

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake oxygen sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check that all battery terminal connections are tight and corrosion free.
  • Turn keyswitch ON.
  • Run the engine at idle for the following minutes: 12
  • Measure the voltage between the aftertreatment intake oxygen sensor heater SUPPLY pin and the aftertreatment intake oxygen sensor heater RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • Aftertreatment intake oxygen sensor heater circuit pin to ground short

Refer to S00004964

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Aftertreatment intake oxygen sensor heater circuit pin to ground short

Solution: S00004964

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake oxygen sensor from the engine wiring harness.

Action

  • Start the engine.
  • Measure the voltage between the aftertreatment intake oxygen sensor heater SUPPLY pin at the sensor connector of the engine wiring harness and ground.

Specification

  • A malfunctioning engine wiring harness has been detected if the voltage is within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Aftertreatment intake oxygen sensor open circuit check

Solution: S00004820

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness ECM connector 1 and 2.
  • Disconnect the aftertreatment intake oxygen sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment intake oxygen sensor SIGNAL pin at the aftertreatment intake oxygen sensor engine wiring harness connector and the aftertreatment intake oxygen sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the aftertreatment intake oxygen sensor RETURN pin at the aftertreatment intake oxygen sensor engine wiring harness connector and the aftertreatment intake oxygen sensor RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the aftertreatment intake oxygen sensor heater SUPPLY pin at the aftertreatment intake oxygen sensor connector of the engine wiring harness and the aftertreatment intake oxygen sensor heater SUPPLY pin at the engine wiring harness ECM connector.
  • Measure the resistance between the aftertreatment intake oxygen sensor heater RETURN pin at the aftertreatment intake oxygen sensor connector of the engine wiring harness and the aftertreatment intake oxygen sensor heater RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment intake oxygen sensor circuit pin to pin short

Solution: S00004198

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake oxygen sensor from the engine wiring harness.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment intake oxygen sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the aftertreatment intake oxygen sensor RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the aftertreatment intake oxygen sensor heater SUPPLY pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the aftertreatment intake oxygen sensor heater RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Aftertreatment intake oxygen sensor is malfunctioning

Solution: S00004151

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment intake oxygen sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake oxygen sensor.

Refer to Procedure 019-100

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 6631 | SPN: 1292 | FMI: 9
Engine Ignition Control Module #1 - Abnormal Update Rate

Troubleshooting Summary

  1. Battery or battery cables are malfunctioning
  2. J1939 data link terminating resistance is incorrect
  3. Engine data link terminating resistor resistance check
  4. Ignition control module data link terminating resistor resistance check
  5. J1939 data link harness open circuit check
  6. Ignition control module open circuit check
  7. Ignition control module open circuit check
  8. Ignition control module circuit pin to ground short
  9. Ignition control module circuit pin to pin short
  10. ECM calibration revision history check

1 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - J1939 data link terminating resistance is incorrect

Solution: S00005757

Verification

Conditions

  • Turn keyswitch OFF.
  • Wait for 90 seconds.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3-pin service data link connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the resistance is not within the following specification: 54 - 66 Ω

Linked Solutions

  • Engine data link terminating resistor resistance check

Refer to S00005758

  • Ignition control module data link terminating resistor resistance check

Refer to S00005699

  • J1939 data link harness open circuit check

Refer to S00005759

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Engine data link terminating resistor resistance check

Solution: S00005758

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the terminating resistor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the terminating resistor.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning terminating resistor has been detected if the resistance is not within the following specification: 108-132 Ω

Linked Solutions

  • None

Repair

  • Replace the terminating resistor.

Refer to Procedure 019-417

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Ignition control module data link terminating resistor resistance check

Solution: S00005699

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the ignition control module C1 connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning terminating resistor has been detected if the resistance is not within the following specification: 108 - 132 Ω

Linked Solutions

  • None

Repair

  • Replace ignition control module.

Refer to Procedure 019-105

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.3 - J1939 data link harness open circuit check

Solution: S00005759

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the appropriate data link component from the data link wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the J1939 (+) pin at the appropriate component data link wiring harness connector and the appropriate data link component J1939 (+) pin at the data link wiring harness ECM connector.
  • Measure the resistance between the J1939 (-) pin at the appropriate component data link wiring harness connector and the appropriate data link component J1939 (-) pin at the data link wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning J1939 data link wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Ignition control module open circuit check

Solution: S00002985

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the battery SUPPLY pin at the OEM wiring harness service connector and the battery SUPPLY pin at the engine wiring harness ignition control module connector.
  • Measure the resistance between the battery RETURN pin at the OEM wiring harness service connector and the battery RETURN pin at the engine wiring harness ignition control module connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Ignition control module open circuit check

Solution: S00004840

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the combustion detection SIGNAL pin at the ignition control module C1 connector and the combustion detection SIGNAL pin at the engine wiring harness ECM connector 2.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the ignition control module C1 connector and the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module timing SIGNAL pin at the ignition control module C1 connector and the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the ignition control module RETURN pin at the ignition control module C1 connector and the ignition control module RETURN pin at the engine wiring harness ECM connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the ignition control module C1 connector and the spark voltage SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Ignition control module circuit pin to ground short

Solution: S00006519

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Ignition control module circuit pin to pin short

Solution: S00001435

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the gas mass flow sensor from the engine wiring harness.
  • Disconnect the EGR temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness from the ignition control module.
  • Disconnect the engine wiring harness ECM connector 1 and 2.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control module timing SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module reference SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the ignition control module RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the spark voltage SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the combustion detection SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 6637 | SPN: 2978 | FMI: 2
Estimated Engine Parasitic Losses - Percent Torque - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 6857 | SPN: 8289 | FMI: 2
Fuel System Control Module - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. OEM fuel system is malfunctioning
  2. ECM calibration revision history check

1 - OEM fuel system is malfunctioning

Solution: S00005306

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning OEM fuel system has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the OEM fuel system.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 6858 | SPN: 8289 | FMI: 9
Fuel System Control Module - Abnormal Update Rate

Troubleshooting Summary

  1. OEM fuel system is malfunctioning
  2. ECM calibration revision history check

1 - OEM fuel system is malfunctioning

Solution: S00005306

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning OEM fuel system has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the OEM fuel system.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 6883 | SPN: 1292 | FMI: 3
Engine Ignition Control Module #1 - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Ignition coil resistance check
  2. Ignition control module is malfunctioning

1 - Ignition coil resistance check

Solution: S00004762

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the resistance check on the appropriate ignition coil.

Refer to Procedure 013-012

Specification

  • If the resistance is not within specification, then a malfunctioning ignition coil has been detected.

Refer to Procedure 013-012

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Ignition control module is malfunctioning

Solution: S00004918

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning ignition control module has been detected.

Linked Solutions

  • None

Repair

  • Replace ignition control module.

Refer to Procedure 019-105

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 6884 | SPN: 1292 | FMI: 4
Engine Ignition Control Module #1 - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Ignition control wiring harness circuit pin to ground short
  2. Ignition control wiring harness circuit pin to pin short
  3. Ignition control module is malfunctioning

1 - Ignition control wiring harness circuit pin to ground short

Solution: S00004135

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connector C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the charge voltage pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the secondary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the primary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Ignition control wiring harness circuit pin to pin short

Solution: S00004285

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control wiring harness charge voltage SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness secondary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness primary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Ignition control module is malfunctioning

Solution: S00004918

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning ignition control module has been detected.

Linked Solutions

  • None

Repair

  • Replace ignition control module.

Refer to Procedure 019-105

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 6945 | SPN: 7581 | FMI: 1
Engine Gaseous Fuel Pressure Regulator Intake Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. OEM fuel system is malfunctioning
  2. ECM calibration revision history check

1 - OEM fuel system is malfunctioning

Solution: S00005306

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning OEM fuel system has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the OEM fuel system.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 6961 | SPN: 8289 | FMI: 19
Fuel System Control Module - Received Network Data in Error

Troubleshooting Summary

  1. OEM fuel system is malfunctioning
  2. ECM calibration revision history check

1 - OEM fuel system is malfunctioning

Solution: S00005306

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning OEM fuel system has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the OEM fuel system.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 6966 | SPN: 1268 | FMI: 5
Engine Ignition Coil #1 - Current Below Normal or Open Circuit

Troubleshooting Summary

  1. Ignition control module and coil connection loose
  2. Ignition coil resistance check
  3. Ignition control wiring harness open circuit check
  4. Ignition control module is malfunctioning

1 - Ignition control module and coil connection loose

Solution: S00002902

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect for a loose connection at the ignition coil connector associated with the fault code.
  • Visually inspect for a loose connection at the ignition control module C2 connector.

Specification

  • If there is a loose connection at either the ignition coil or the ignition control module, then proceed to the Repair tab.

Linked Solutions

  • None

Repair

  • Properly connect the ignition control module C2 and ignition coil connectors.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Ignition coil resistance check

Solution: S00004762

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the resistance check on the appropriate ignition coil.

Refer to Procedure 013-012

Specification

  • If the resistance is not within specification, then a malfunctioning ignition coil has been detected.

Refer to Procedure 013-012

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Ignition control wiring harness open circuit check

Solution: S00004197

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Ignition control module is malfunctioning

Solution: S00004918

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning ignition control module has been detected.

Linked Solutions

  • None

Repair

  • Replace ignition control module.

Refer to Procedure 019-105

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 6967 | SPN: 1269 | FMI: 5
Engine Ignition Coil #2 - Current Below Normal or Open Circuit

Troubleshooting Summary

  1. Ignition control module and coil connection loose
  2. Ignition coil resistance check
  3. Ignition control wiring harness open circuit check
  4. Ignition control module is malfunctioning

1 - Ignition control module and coil connection loose

Solution: S00002902

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect for a loose connection at the ignition coil connector associated with the fault code.
  • Visually inspect for a loose connection at the ignition control module C2 connector.

Specification

  • If there is a loose connection at either the ignition coil or the ignition control module, then proceed to the Repair tab.

Linked Solutions

  • None

Repair

  • Properly connect the ignition control module C2 and ignition coil connectors.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Ignition coil resistance check

Solution: S00004762

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the resistance check on the appropriate ignition coil.

Refer to Procedure 013-012

Specification

  • If the resistance is not within specification, then a malfunctioning ignition coil has been detected.

Refer to Procedure 013-012

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Ignition control wiring harness open circuit check

Solution: S00004197

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Ignition control module is malfunctioning

Solution: S00004918

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning ignition control module has been detected.

Linked Solutions

  • None

Repair

  • Replace ignition control module.

Refer to Procedure 019-105

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 6968 | SPN: 1270 | FMI: 5
Engine Ignition Coil #3 - Current Below Normal or Open Circuit

Troubleshooting Summary

  1. Ignition control module and coil connection loose
  2. Ignition coil resistance check
  3. Ignition control wiring harness open circuit check
  4. Ignition control module is malfunctioning

1 - Ignition control module and coil connection loose

Solution: S00002902

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect for a loose connection at the ignition coil connector associated with the fault code.
  • Visually inspect for a loose connection at the ignition control module C2 connector.

Specification

  • If there is a loose connection at either the ignition coil or the ignition control module, then proceed to the Repair tab.

Linked Solutions

  • None

Repair

  • Properly connect the ignition control module C2 and ignition coil connectors.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Ignition coil resistance check

Solution: S00004762

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the resistance check on the appropriate ignition coil.

Refer to Procedure 013-012

Specification

  • If the resistance is not within specification, then a malfunctioning ignition coil has been detected.

Refer to Procedure 013-012

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Ignition control wiring harness open circuit check

Solution: S00004197

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Ignition control module is malfunctioning

Solution: S00004918

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning ignition control module has been detected.

Linked Solutions

  • None

Repair

  • Replace ignition control module.

Refer to Procedure 019-105

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 6969 | SPN: 1271 | FMI: 5
Engine Ignition Coil #4 - Current Below Normal or Open Circuit

Troubleshooting Summary

  1. Ignition control module and coil connection loose
  2. Ignition coil resistance check
  3. Ignition control wiring harness open circuit check
  4. Ignition control module is malfunctioning

1 - Ignition control module and coil connection loose

Solution: S00002902

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect for a loose connection at the ignition coil connector associated with the fault code.
  • Visually inspect for a loose connection at the ignition control module C2 connector.

Specification

  • If there is a loose connection at either the ignition coil or the ignition control module, then proceed to the Repair tab.

Linked Solutions

  • None

Repair

  • Properly connect the ignition control module C2 and ignition coil connectors.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Ignition coil resistance check

Solution: S00004762

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the resistance check on the appropriate ignition coil.

Refer to Procedure 013-012

Specification

  • If the resistance is not within specification, then a malfunctioning ignition coil has been detected.

Refer to Procedure 013-012

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Ignition control wiring harness open circuit check

Solution: S00004197

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Ignition control module is malfunctioning

Solution: S00004918

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning ignition control module has been detected.

Linked Solutions

  • None

Repair

  • Replace ignition control module.

Refer to Procedure 019-105

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 6971 | SPN: 1272 | FMI: 5
Engine Ignition Coil #5 - Current Below Normal or Open Circuit

Troubleshooting Summary

  1. Ignition control module and coil connection loose
  2. Ignition coil resistance check
  3. Ignition control wiring harness open circuit check
  4. Ignition control module is malfunctioning

1 - Ignition control module and coil connection loose

Solution: S00002902

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect for a loose connection at the ignition coil connector associated with the fault code.
  • Visually inspect for a loose connection at the ignition control module C2 connector.

Specification

  • If there is a loose connection at either the ignition coil or the ignition control module, then proceed to the Repair tab.

Linked Solutions

  • None

Repair

  • Properly connect the ignition control module C2 and ignition coil connectors.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Ignition coil resistance check

Solution: S00004762

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the resistance check on the appropriate ignition coil.

Refer to Procedure 013-012

Specification

  • If the resistance is not within specification, then a malfunctioning ignition coil has been detected.

Refer to Procedure 013-012

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Ignition control wiring harness open circuit check

Solution: S00004197

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Ignition control module is malfunctioning

Solution: S00004918

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning ignition control module has been detected.

Linked Solutions

  • None

Repair

  • Replace ignition control module.

Refer to Procedure 019-105

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 6972 | SPN: 1273 | FMI: 5
Engine Ignition Coil #6 - Current Below Normal or Open Circuit

Troubleshooting Summary

  1. Ignition control module and coil connection loose
  2. Ignition coil resistance check
  3. Ignition control wiring harness open circuit check
  4. Ignition control module is malfunctioning

1 - Ignition control module and coil connection loose

Solution: S00002902

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect for a loose connection at the ignition coil connector associated with the fault code.
  • Visually inspect for a loose connection at the ignition control module C2 connector.

Specification

  • If there is a loose connection at either the ignition coil or the ignition control module, then proceed to the Repair tab.

Linked Solutions

  • None

Repair

  • Properly connect the ignition control module C2 and ignition coil connectors.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Ignition coil resistance check

Solution: S00004762

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the resistance check on the appropriate ignition coil.

Refer to Procedure 013-012

Specification

  • If the resistance is not within specification, then a malfunctioning ignition coil has been detected.

Refer to Procedure 013-012

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Ignition control wiring harness open circuit check

Solution: S00004197

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the primary RETURN pin at the ignition control wiring harness connector C2 and the primary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the secondary RETURN pin at the ignition control wiring harness connector C2 and the secondary RETURN pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Measure the resistance between the charge voltage pin at the ignition control wiring harness connector C2 and the charge voltage pin at the ignition coil connector of the ignition control wiring harness for each ignition coil.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Ignition control module is malfunctioning

Solution: S00004918

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning ignition control module has been detected.

Linked Solutions

  • None

Repair

  • Replace ignition control module.

Refer to Procedure 019-105

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 6994 | SPN: 7581 | FMI: 9
Engine Gaseous Fuel Pressure Regulator Intake Pressure - Abnormal Update Rate

Troubleshooting Summary

  1. OEM fuel system is malfunctioning
  2. ECM calibration revision history check

1 - OEM fuel system is malfunctioning

Solution: S00005306

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning OEM fuel system has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the OEM fuel system.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 7187 | SPN: 8289 | FMI: 14
Fuel System Control Module - Special Instructions

Troubleshooting Summary

  1. OEM fuel system is malfunctioning
  2. ECM calibration revision history check

1 - OEM fuel system is malfunctioning

Solution: S00005306

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning OEM fuel system has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the OEM fuel system.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 7188 | SPN: 8289 | FMI: 19
Fuel System Control Module - Received Network Data in Error

Troubleshooting Summary

  1. OEM fuel system is malfunctioning
  2. ECM calibration revision history check

1 - OEM fuel system is malfunctioning

Solution: S00005306

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning OEM fuel system has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the OEM fuel system.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 7189 | SPN: 7081 | FMI: 31
Engine Gaseous Fuel Supply Shutoff Valve 1 Position - Condition Exists

Troubleshooting Summary

  1. OEM fuel system is malfunctioning
  2. ECM calibration revision history check

1 - OEM fuel system is malfunctioning

Solution: S00005306

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning OEM fuel system has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the OEM fuel system.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 7191 | SPN: 7581 | FMI: 1
Engine Gaseous Fuel Pressure Regulator Intake Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. OEM fuel system is malfunctioning
  2. ECM calibration revision history check

1 - OEM fuel system is malfunctioning

Solution: S00005306

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning OEM fuel system has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the OEM fuel system.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 7192 | SPN: 1292 | FMI: 18
Engine Ignition Control Module #1 - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Ignition coil resistance check
  2. Ignition control wiring harness circuit pin to ground short
  3. Ignition control wiring harness circuit pin to pin short
  4. Ignition control module is malfunctioning

1 - Ignition coil resistance check

Solution: S00004762

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the resistance check on the appropriate ignition coil.

Refer to Procedure 013-012

Specification

  • If the resistance is not within specification, then a malfunctioning ignition coil has been detected.

Refer to Procedure 013-012

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ignition coil.

Refer to Procedure 013-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Ignition control wiring harness circuit pin to ground short

Solution: S00004135

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connector C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the charge voltage pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the secondary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Measure the resistance between the primary RETURN pin and ground at each ignition coil connector of the ignition control wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Ignition control wiring harness circuit pin to pin short

Solution: S00004285

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ignition control wiring harness connect C2 from the ignition control module.
  • Disconnect the ignition control wiring harness from all ignition coils.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ignition control wiring harness charge voltage SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness secondary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Measure the resistance between the ignition control wiring harness primary return SIGNAL pin at the ignition control wiring harness connector C2 and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ignition control wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the ignition control wiring harness.

Refer to Procedure 013-037

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Ignition control module is malfunctioning

Solution: S00004918

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning ignition control module has been detected.

Linked Solutions

  • None

Repair

  • Replace ignition control module.

Refer to Procedure 019-105

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 7277 | SPN: 8289 | FMI: 2
Fuel System Control Module - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. OEM fuel system is malfunctioning
  2. ECM calibration revision history check

1 - OEM fuel system is malfunctioning

Solution: S00005306

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning OEM fuel system has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the OEM fuel system.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 7278 | SPN: 8289 | FMI: 9
Fuel System Control Module - Abnormal Update Rate

Troubleshooting Summary

  1. OEM fuel system is malfunctioning
  2. ECM calibration revision history check

1 - OEM fuel system is malfunctioning

Solution: S00005306

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning OEM fuel system has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the OEM fuel system.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 7279 | SPN: 8289 | FMI: 19
Fuel System Control Module - Received Network Data in Error

Troubleshooting Summary

  1. OEM fuel system is malfunctioning
  2. ECM calibration revision history check

1 - OEM fuel system is malfunctioning

Solution: S00005306

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning OEM fuel system has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the OEM fuel system.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 7281 | SPN: 8289 | FMI: 31
Fuel System Control Module - Condition Exists

Troubleshooting Summary

  1. OEM fuel system is malfunctioning
  2. ECM calibration revision history check

1 - OEM fuel system is malfunctioning

Solution: S00005306

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning OEM fuel system has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the OEM fuel system.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX12 G CM2180 EJ

Fault Code: 7282 | SPN: 7081 | FMI: 1
Engine Gaseous Fuel Supply Shutoff Valve 1 Position - Data Valid But Below Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. OEM fuel system is malfunctioning
  2. ECM calibration revision history check

1 - OEM fuel system is malfunctioning

Solution: S00005306

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning OEM fuel system has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the OEM fuel system.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


INDEX
182-fc111.htm

182-t06-111.htm

182-fc115.htm

182-t06-115.htm

182-fc122.htm

182-t06-122.htm

182-fc123.htm

182-t06-123.htm

182-fc124.htm

182-t06-124.htm

182-fc125.htm

182-t06-125.htm

182-fc131.htm

182-t06-131.htm

182-fc132.htm

182-t06-132.htm

182-fc133.htm

182-t06-133.htm

182-fc134.htm

182-t06-134.htm

182-fc135.htm

182-t06-135.htm

182-fc141.htm

182-t06-141.htm

182-fc143.htm

182-t06-143.htm

182-fc144.htm

182-t06-144.htm

182-fc145.htm

182-t06-145.htm

182-fc146.htm

182-t06-146.htm

182-fc151.htm

182-t06-151.htm

182-fc153.htm

182-t06-153.htm

182-fc154.htm

182-t06-154.htm

182-fc155.htm

182-t06-155.htm

182-fc176.htm

182-t06-176.htm

182-fc187.htm

182-t06-187.htm

182-fc195.htm

182-t06-195.htm

182-fc196.htm

182-t06-196.htm

182-fc197.htm

182-t06-197.htm

182-fc212.htm

182-t06-212.htm

182-fc213.htm

182-t06-213.htm

182-fc214.htm

182-t06-214.htm

182-fc227.htm

182-t06-227.htm

182-fc234.htm

182-t06-234.htm

182-fc235.htm

182-t06-235.htm

182-fc238.htm

182-t06-238.htm

182-fc239.htm

182-t06-239.htm

182-fc241.htm

182-t06-241.htm

182-fc242.htm

182-t06-242.htm

182-fc245.htm

182-t06-245.htm

182-fc254.htm

182-t06-254.htm

182-fc255.htm

182-t06-255.htm

182-fc263.htm

182-t06-263.htm

182-fc265.htm

182-t06-265.htm

182-fc285.htm

182-t06-285.htm

182-fc286.htm

182-t06-286.htm

182-fc288.htm

182-t06-288.htm

182-fc338.htm

182-t06-338.htm

182-fc339.htm

182-t06-339.htm

182-fc352.htm

182-t06-352.htm

182-fc386.htm

182-t06-386.htm

182-fc415.htm

182-t06-415.htm

182-fc421.htm

182-t06-421.htm

182-fc426.htm

182-t06-426.htm

182-fc435.htm

182-t06-435.htm

182-fc441.htm

182-t06-441.htm

182-fc442.htm

182-t06-442.htm

182-fc453.htm

182-t06-453.htm

182-fc454.htm

182-t06-454.htm

182-fc455.htm

182-t06-455.htm

182-fc458.htm

182-t06-458.htm

182-fc459.htm

182-t06-459.htm

182-fc461.htm

182-t06-461.htm

182-fc462.htm

182-t06-462.htm

182-fc465.htm

182-t06-465.htm

182-fc466.htm

182-t06-466.htm

182-fc511.htm

182-t06-511.htm

182-fc512.htm

182-t06-512.htm

182-fc513.htm

182-t06-513.htm

182-fc515.htm

182-t06-515.htm

182-fc516.htm

182-t06-516.htm

182-fc555.htm

182-t06-555.htm

182-fc556.htm

182-t06-556.htm

182-fc561.htm

182-t06-561.htm

182-fc562.htm

182-t06-562.htm

182-fc563.htm

182-t06-563.htm

182-fc564.htm

182-t06-564.htm

182-fc565.htm

182-t06-565.htm

182-fc566.htm

182-t06-566.htm

182-fc572.htm

182-t06-572.htm

182-fc575.htm

182-t06-575.htm

182-fc584.htm

182-t06-584.htm

182-fc585.htm

182-t06-585.htm

182-fc596.htm

182-t06-596.htm

182-fc597.htm

182-t06-597.htm

182-fc598.htm

182-t06-598.htm

182-fc649.htm

182-t06-649.htm

182-fc689.htm

182-t06-689.htm

182-fc697.htm

182-t06-697.htm

182-fc698.htm

182-t06-698.htm

182-fc731.htm

182-t06-731.htm

182-fc751.htm

182-t06-751.htm

182-fc769.htm

182-t06-769.htm

182-fc771.htm

182-t06-771.htm

182-fc777.htm

182-t06-777.htm

182-fc778.htm

182-t06-778.htm

182-fc784.htm

182-t06-784.htm

182-fc1117.htm

182-t06-1117.htm

182-fc1239.htm

182-t06-1239.htm

182-fc1241.htm

182-t06-1241.htm

182-fc1242.htm

182-t06-1242.htm

182-fc1515.htm

182-t06-1515.htm

182-fc1654.htm

182-t06-1654.htm

182-fc1655.htm

182-t06-1655.htm

182-fc1656.htm

182-t06-1656.htm

182-fc1657.htm

182-t06-1657.htm

182-fc1658.htm

182-t06-1658.htm

182-fc1659.htm

182-t06-1659.htm

182-fc1665.htm

182-t06-1665.htm

182-fc1666.htm

182-t06-1666.htm

182-fc1674.htm

182-t06-1674.htm

182-fc1675.htm

182-t06-1675.htm

182-fc1691.htm

182-t06-1691.htm

182-fc1695.htm

182-t06-1695.htm

182-fc1696.htm

182-t06-1696.htm

182-fc1718.htm

182-t06-1718.htm

182-fc1827.htm

182-t06-1827.htm

182-fc1828.htm

182-t06-1828.htm

182-fc1839.htm

182-t06-1839.htm

182-fc1841.htm

182-t06-1841.htm

182-fc1843.htm

182-t06-1843.htm

182-fc1844.htm

182-t06-1844.htm

182-fc1855.htm

182-t06-1855.htm

182-fc1856.htm

182-t06-1856.htm

182-fc1858.htm

182-t06-1858.htm

182-fc1861.htm

182-t06-1861.htm

182-fc1862.htm

182-t06-1862.htm

182-fc1864.htm

182-t06-1864.htm

182-fc1866.htm

182-t06-1866.htm

182-fc1896.htm

182-t06-1896.htm

182-fc1942.htm

182-t06-1942.htm

182-fc1965.htm

182-t06-1965.htm

182-fc1966.htm

182-t06-1966.htm

182-fc1968.htm

182-t06-1968.htm

182-fc1969.htm

182-t06-1969.htm

182-fc1974.htm

182-t06-1974.htm

182-fc2182.htm

182-t06-2182.htm

182-fc2183.htm

182-t06-2183.htm

182-fc2184.htm

182-t06-2184.htm

182-fc2185.htm

182-t06-2185.htm

182-fc2186.htm

182-t06-2186.htm

182-fc2189.htm

182-t06-2189.htm

182-fc2272.htm

182-t06-2272.htm

182-fc2273.htm

182-t06-2273.htm

182-fc2274.htm

182-t06-2274.htm

182-fc2286.htm

182-t06-2286.htm

182-fc2287.htm

182-t06-2287.htm

182-fc2321.htm

182-t06-2321.htm

182-fc2322.htm

182-t06-2322.htm

182-fc2349.htm

182-t06-2349.htm

182-fc2351.htm

182-t06-2351.htm

182-fc2357.htm

182-t06-2357.htm

182-fc2363.htm

182-t06-2363.htm

182-fc2367.htm

182-t06-2367.htm

182-fc2375.htm

182-t06-2375.htm

182-fc2376.htm

182-t06-2376.htm

182-fc2377.htm

182-t06-2377.htm

182-fc2431.htm

182-t06-2431.htm

182-fc2432.htm

182-t06-2432.htm

182-fc2433.htm

182-t06-2433.htm

182-fc2434.htm

182-t06-2434.htm

182-fc2435.htm

182-t06-2435.htm

182-fc2436.htm

182-t06-2436.htm

182-fc2448.htm

182-t06-2448.htm

182-fc2451.htm

182-t06-2451.htm

182-fc2457.htm

182-t06-2457.htm

182-fc2517.htm

182-t06-2517.htm

182-fc2518.htm

182-t06-2518.htm

182-fc2533.htm

182-t06-2533.htm

182-fc2534.htm

182-t06-2534.htm

182-fc2535.htm

182-t06-2535.htm

182-fc2536.htm

182-t06-2536.htm

182-fc2537.htm

182-t06-2537.htm

182-fc2538.htm

182-t06-2538.htm

182-fc2568.htm

182-t06-2568.htm

182-fc2586.htm

182-t06-2586.htm

182-fc2587.htm

182-t06-2587.htm

182-fc2588.htm

182-t06-2588.htm

182-fc2589.htm

182-t06-2589.htm

182-fc2591.htm

182-t06-2591.htm

182-fc2592.htm

182-t06-2592.htm

182-fc2593.htm

182-t06-2593.htm

182-fc2594.htm

182-t06-2594.htm

182-fc2595.htm

182-t06-2595.htm

182-fc2596.htm

182-t06-2596.htm

182-fc2597.htm

182-t06-2597.htm

182-fc2598.htm

182-t06-2598.htm

182-fc2616.htm

182-t06-2616.htm

182-fc2617.htm

182-t06-2617.htm

182-fc2641.htm

182-t06-2641.htm

182-fc2642.htm

182-t06-2642.htm

182-fc2643.htm

182-t06-2643.htm

182-fc2644.htm

182-t06-2644.htm

182-fc2645.htm

182-t06-2645.htm

182-fc2686.htm

182-t06-2686.htm

182-fc2687.htm

182-t06-2687.htm

182-fc2722.htm

182-t06-2722.htm

182-fc2723.htm

182-t06-2723.htm

182-fc2724.htm

182-t06-2724.htm

182-fc2725.htm

182-t06-2725.htm

182-fc2752.htm

182-t06-2752.htm

182-fc2758.htm

182-t06-2758.htm

182-fc2759.htm

182-t06-2759.htm

182-fc2775.htm

182-t06-2775.htm

182-fc2776.htm

182-t06-2776.htm

182-fc2782.htm

182-t06-2782.htm

182-fc2783.htm

182-t06-2783.htm

182-fc2961.htm

182-t06-2961.htm

182-fc2962.htm

182-t06-2962.htm

182-fc2963.htm

182-t06-2963.htm

182-fc2964.htm

182-t06-2964.htm

182-fc2973.htm

182-t06-2973.htm

182-fc2988.htm

182-t06-2988.htm

182-fc2989.htm

182-t06-2989.htm

182-fc2991.htm

182-t06-2991.htm

182-fc3186.htm

182-t06-3186.htm

182-fc3213.htm

182-t06-3213.htm

182-fc3326.htm

182-t06-3326.htm

182-fc3328.htm

182-t06-3328.htm

182-fc3366.htm

182-t06-3366.htm

182-fc3367.htm

182-t06-3367.htm

182-fc3368.htm

182-t06-3368.htm

182-fc3374.htm

182-t06-3374.htm

182-fc3418.htm

182-t06-3418.htm

182-fc3436.htm

182-t06-3436.htm

182-fc3437.htm

182-t06-3437.htm

182-fc3488.htm

182-t06-3488.htm

182-fc3526.htm

182-t06-3526.htm

182-fc3528.htm

182-t06-3528.htm

182-fc3531.htm

182-t06-3531.htm

182-fc3532.htm

182-t06-3532.htm

182-fc3641.htm

182-t06-3641.htm

182-fc3838.htm

182-t06-3838.htm

182-fc3843.htm

182-t06-3843.htm

182-fc3844.htm

182-t06-3844.htm

182-fc3845.htm

182-t06-3845.htm

182-fc3847.htm

182-t06-3847.htm

182-fc4621.htm

182-t06-4621.htm

182-fc4855.htm

182-t06-4855.htm

182-fc5111.htm

182-t06-5111.htm

182-fc5948.htm

182-t06-5948.htm

182-fc6388.htm

182-t06-6388.htm

182-fc6396.htm

182-t06-6396.htm

182-fc6631.htm

182-t06-6631.htm

182-fc6637.htm

182-t06-6637.htm

182-fc6857.htm

182-t06-6857.htm

182-fc6858.htm

182-t06-6858.htm

182-fc6883.htm

182-t06-6883.htm

182-fc6884.htm

182-t06-6884.htm

182-fc6945.htm

182-t06-6945.htm

182-fc6961.htm

182-t06-6961.htm

182-fc6966.htm

182-t06-6966.htm

182-fc6967.htm

182-t06-6967.htm

182-fc6968.htm

182-t06-6968.htm

182-fc6969.htm

182-t06-6969.htm

182-fc6971.htm

182-t06-6971.htm

182-fc6972.htm

182-t06-6972.htm

182-fc6994.htm

182-t06-6994.htm

182-fc7187.htm

182-t06-7187.htm

182-fc7188.htm

182-t06-7188.htm

182-fc7189.htm

182-t06-7189.htm

182-fc7191.htm

182-t06-7191.htm

182-fc7192.htm

182-t06-7192.htm

182-fc7277.htm

182-t06-7277.htm

182-fc7278.htm

182-t06-7278.htm

182-fc7279.htm

182-t06-7279.htm

182-fc7281.htm

182-t06-7281.htm

182-fc7282.htm

182-t06-7282.htm