ISX15 CM2350 X101/X104/X109

Last Modified: 12 February 2020

Copyright © 2020
Cummins Inc.
All rights reserved


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

FAULT CODE 111

Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 111 PID: S254 SPN: 629 FMI: 12/12 LAMP: Red SRT: | Error internal to the engine control module (ECM) related to memory hardware malfunctions or internal ECM voltage supply circuits. | Engine may not start or may be difficult to start.
Engine Control Module (ECM)

Circuit Description

The ECM has internal diagnostics that continuously run and check the internal memory.

Component Location

The Engine Control Module (ECM) is mounted on the intake manifold side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a read or write error internal to the ECM.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

The engine may not start.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code can only be caused by an internal ECM problem. Repairs are not possible for the ECM.

Refer to Troubleshooting Fault Code 111.

Last Modified: 25-May-2019
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1117

Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1117 PID: S251 SPN: 3597 FMI: 2/2 LAMP: None SRT: | Supply voltage to the ECM fell below a calibrated limit momentarily, or the ECM was not allowed to power down correctly. | Possible reduced engine performance.
Engine Control Module (ECM) Battery Power Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the primary ECM power supply dropped below a calibratible value while the keyswitch was in the ON position.

The power down sequence was interrupted by a premature ECM shutdown.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Power-down data like trip information, maintenance monitor, and fault information will not get saved to permanent memory when the keyswitch is turned OFF.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine, let it idle for 1 minute, and then shutdown the engine.
  • Turn the key switch OFF and allow the ECM to completely powerdown.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code are:

Battery voltage below 6.2 VDC during cranking.

High resistance in the ECM supply or return circuit.

Use of a battery disconnect switch or any device that disconnects battery voltage to the ECM to turn the engine off or before the ECM is completely powered down.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1117.

Last Modified: 25-May-2019


Injector Solenoid Driver Cylinder 1 - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 1139

Injector Solenoid Driver Cylinder 1 - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1139 PID: S1 SPN: 651 FMI: 7/7 LAMP: Amber SRT: | The ECM has detected an error with the injection timing or quantity. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to verify injector operation. During selected conditions, each injector is fired. The fueling quantity and timing are then compared to a specified threshold.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs periodically during engine operation.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a fueling timing or quantity error for the specified injector.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • It is necessary to use the "Reset All Faults" command in the recommended Cummins electronic service tool or equivalent to clear this fault and extinguish the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL).

Shop Talk

This fault code is intended to identify fueling quantity and timing issues.

Refer to Troubleshooting Fault Code 1139.

Last Modified: 25-May-2019


Injector Solenoid Driver Cylinder 2 - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 1141

Injector Solenoid Driver Cylinder 2 - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1141 PID: S2 SPN: 652 FMI: 7/7 LAMP: Amber SRT: | The ECM has detected an error with the injection timing or quantity. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to verify injector operation. During selected conditions, each injector is fired. The fueling quantity and timing are then compared to a specified threshold.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs periodically during engine operation.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a fueling timing or quantity error for the specified injector.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • It is necessary to use the "Reset All Faults" command in the recommended Cummins electronic service tool or equivalent to clear this fault and extinguish the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL).

Shop Talk

This fault code is intended to identify fueling quantity and timing issues.

Refer to Troubleshooting Fault Code 1141.

Last Modified: 25-May-2019


Injector Solenoid Driver Cylinder 3 - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 1142

Injector Solenoid Driver Cylinder 3 - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1142 PID: S3 SPN: 653 FMI: 7/7 LAMP: Amber SRT: | The ECM has detected an error with the injection timing or quantity. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to verify injector operation. During selected conditions, each injector is fired. The fueling quantity and timing are then compared to a specified threshold.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs periodically during engine operation.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a fueling timing or quantity error for the specified injector.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • It is necessary to use the "Reset All Faults" command in the recommended Cummins electronic service tool or equivalent to clear this fault and extinguish the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL).

Shop Talk

This fault code is intended to identify fueling quantity and timing issues.

Refer to Troubleshooting Fault Code 1142.

Last Modified: 25-May-2019


Injector Solenoid Driver Cylinder 4 - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 1143

Injector Solenoid Driver Cylinder 4 - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1143 PID: S4 SPN: 654 FMI: 7/7 LAMP: Amber SRT: | The ECM has detected an error with the injection timing or quantity. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to verify injector operation. During selected conditions, each injector is fired. The fueling quantity and timing are then compared to a specified threshold.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs periodically during engine operation.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a fueling timing or quantity error for the specified injector.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • It is necessary to use the "Reset All Faults" command in the recommended Cummins electronic service tool or equivalent to clear this fault and extinguish the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL).

Shop Talk

This fault code is intended to identify fueling quantity and timing issues.

Refer to Troubleshooting Fault Code 1143.

Last Modified: 25-May-2019


Injector Solenoid Driver Cylinder 5 - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 1144

Injector Solenoid Driver Cylinder 5 - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1144 PID: S5 SPN: 655 FMI: 7/7 LAMP: Amber SRT: | The ECM has detected an error with the injection timing or quantity. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to verify injector operation. During selected conditions, each injector is fired. The fueling quantity and timing are then compared to a specified threshold.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs periodically during engine operation.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a fueling timing or quantity error for the specified injector.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • It is necessary to use the "Reset All Faults" command in the recommended Cummins electronic service tool or equivalent to clear this fault and extinguish the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL).

Shop Talk

This fault code is intended to identify fueling quantity and timing issues.

Refer to Troubleshooting Fault Code 1144.

Last Modified: 25-May-2019


Injector Solenoid Driver Cylinder 6 - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 1145

Injector Solenoid Driver Cylinder 6 - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1145 PID: S6 SPN: 656 FMI: 7/7 LAMP: Amber SRT: | The ECM has detected an error with the injection timing or quantity. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to verify injector operation. During selected conditions, each injector is fired. The fueling quantity and timing are then compared to a specified threshold.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs periodically during engine operation.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a fueling timing or quantity error for the specified injector.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • It is necessary to use the "Reset All Faults" command in the recommended Cummins electronic service tool or equivalent to clear this fault and extinguish the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL).

Shop Talk

This fault code is intended to identify fueling quantity and timing issues.

Refer to Troubleshooting Fault Code 1145.

Last Modified: 25-May-2019


Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

FAULT CODE 115

Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 115 PID: P190 SPN: 612 FMI: 2/2 LAMP: Red SRT: | The ECM has detected the primary and backup speed sensor signals are connected backwards. | The engine will shut down or will not start.
Engine Crankshaft Speed/Postion and Camshaft Speed/Postion Sensor Circuits

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position and camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankshaft position and camshaft position signal inputs to the ECM are reversed.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates the crankshaft position sensor and the camshaft position sensor wiring harness connectors are reversed. As a result, the engine will not start.

Refer to Troubleshooting Fault Code 115.

Last Modified: 25-May-2019


Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 122

Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 122 PID: P102 SPN: 102 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the intake manifold pressure circuit. | Possible reduced engine performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value of the intake manifold pressure reading is used.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The intake manifold pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 122, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor

Signal wire shorted to sensor supply or battery voltage.

Malfunctioning intake manifold pressure/temperature sensor

Refer to Troubleshooting Fault Code 122.

Last Modified: 25-May-2019


EGR Valve Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1228

EGR Valve Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1228 PID: P27 SPN: 27 FMI: 2/2 LAMP: Amber SRT: | The EGR valve is unable to meet commanded position. | Possible reduced engine performance.
EGR Valve Position Circuit

Circuit Description

The exhaust gas recirculation (EGR) valve is controlled by a brushless motor located on top of the EGR valve. The EGR valve motor uses three different motor legs to move the valve through its range of motion. The ECM uses the EGR motor A, B, and C wires to command the EGR valve to the appropriate position in order to meet EGR flow targets.The EGR valve motor contains three position sensors that detect the location of the EGR valve. These sensors report the position of the valve back to the ECM over the EGR valve position A, B, and C wires.

Component Location

The EGR valve position sensor is internal to the EGR valve assembly and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR valve was unable to reach the commanded position.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Intermittent open or short in the wiring harness

Malfunctioning EGR valve position sensor

Malfunctioning ECM

Refer to Troubleshooting Fault Code 1228.

Last Modified: 25-May-2019


Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 123

Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 123 PID: P102 SPN: 102 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage or open circuit detected at the intake manifold pressure circuit. | Possible reduced engine performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

A default value of the intake manifold pressure reading is used.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The intake manifold pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 123, check for multiple faults.

Possible causes of this fault code include:

Signal circuit open or shorted to ground in the engine harness or sensor

  • Supply wire open or shorted to ground.

Malfunctioning intake manifold pressure/temperature sensor

Refer to Troubleshooting Fault Code 123.

Last Modified: 25-May-2019


Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1239

Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1239 PID: S385 SPN: 2623 FMI: 3/3 LAMP: Amber SRT: | High voltage detected at accelerator pedal position number 2 signal circuit. | The engine will operate in Limp Home mode.
Accelerator Pedal or Lever Position Sensor 2 Circuit

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the throttle pedal signal voltage was greater than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors should be installed. If troubleshooting an intermittent accelerator problem, the accelerator pedal position sensor 2 signal voltage can be monitored with the recommended Cummins electronic service tool or equivalent, while flexing the harness to locate the intermittent connection.

Possible causes of this fault code include:

Accelerator pedal position 2 signal circuit shorted to battery or 5-VDC supply

Open accelerator pedal return circuit in the harness or connections

Accelerator supply shorted to battery

Damaged accelerator pedal position sensor.

The three wires in the accelerator position sensor circuit must be twisted together.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1239.

Last Modified: 25-May-2019


Intake Manifold 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 124

Intake Manifold 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 124 PID: P102 SPN: 102 FMI: 0/16 LAMP: Amber SRT: | Intake manifold pressure is above the maximum operating limit. | Possible reduced engine performance.
Intake Manifold Pressure/Temperature Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure reading was higher than expected for the engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning variable geometry turbocharger (VGT)

High exhaust restriction.

Malfunctioning intake manifold pressure/temperature sensor

Refer to Troubleshooting Fault Code 124.

Last Modified: 25-May-2019


Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1241

Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1241 PID: S385 SPN: 2623 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at accelerator pedal position number 2 signal circuit. | The engine will operate in Limp Home mode.
Accelerator Pedal or Lever Position Sensor 2 Circuit

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the throttle pedal signal voltage was less than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors should be installed. If troubleshooting an intermittent accelerator problem, the accelerator pedal position sensor 2 signal voltage can be monitored with the recommended Cummins electronic service tool or equivalent, while flexing the harness to locate the intermittent connection.

Possible causes of this fault code include:

Accelerator pedal position signal shorted to engine ground or return wires in the harness or sensor

Damaged accelerator pedal position sensor

Open circuit in the accelerator signal, supply, or return wire in the harness or connectors.

The three wires in the accelerator position sensor circuit must be twisted together.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1241.

Last Modified: 25-May-2019


Accelerator Pedal or Lever Position Sensor 1 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1242

Accelerator Pedal or Lever Position Sensor 1 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1242 PID: P91 SPN: 91 FMI: 2/2 LAMP: Red SRT: | Accelerator position sensor number 1 and number 2 are reading different values. | Engine will only idle.
Accelerator Pedal or Lever Position Sensor Circuits

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the readings between the accelerator position sensor 1 and accelerator position sensor 2 differ by more than 2 percent.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will have limp-home throttle control only.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors should be installed.This fault code becomes active when the accelerator position sensor number 1 and accelerator position sensor number 2 are not reading the same value.Possible causes of the fault include:

Damaged accelerator pedal position sensor number 1 or damaged accelerator pedal position sensor number 2

Accelerator pedal position sensor number 1 and accelerator pedal position sensor number 2 signal wires are shorted together.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1242.

Last Modified: 25-May-2019


Intake Manifold 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 125

Intake Manifold 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 125 PID: P102 SPN: 102 FMI: 1/18 LAMP: Amber SRT: | Intake manifold pressure is below the minimum operating limit. | Possible reduced engine performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure reading was below the expected level for the engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The intake manifold 1 pressure sensor monitors pressure in the intake manifold. This fault is set active when the intake manifold pressure is too low for the present engine operating conditions. The ECM commands a charge flow command and the VGT and EGR valve move to meet this command. If the engine is unable to achieve the desired oxygen level necessary for complete combustion, this fault code is logged.

Possible causes of this fault are:

Leaks in the air intake system between the turbocharger and intake manifold

A damaged intake manifold pressure sensor

A damaged barometric pressure sensor

Restriction in the charge-air cooler

Leaks or restrictions in the EGR system plumbing

Fuel inlet restriction too high (normally caused by a restricted fuel filter).

Refer to Troubleshooting Fault Code 125.

Last Modified: 25-May-2019


Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 131

Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 131 PID: P91 SPN: 91 FMI: 3/3 LAMP: Red SRT: | High voltage detected at accelerator pedal position number 1 circuit. | The engine will operate in Limp Home mode.
Accelerator Pedal or Lever Position Sensor Circuit

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the accelerator pedal signal voltage was out of range high.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position, and Fault Code 132 goes inactive, and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors must be installed.

If troubleshooting an intermittent accelerator problem:

The accelerator pedal or lever position sensor signal voltage can be monitored with the recommended Cummins electronic service tool or equivalent, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by the recommended Cummins electronic service tool or equivalent.

Possible causes of this fault code include:

Accelerator pedal or lever position signal circuit shorted to battery or (+) 5 volt supply

Open accelerator pedal return circuit in the harness or connections

Accelerator supply shorted to battery

Malfunctioning accelerator pedal or lever position sensor.

NOTE: The three wires in the accelerator position sensor circuit must be twisted together.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 131.

Last Modified: 25-May-2019


Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 132

Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 132 PID: P91 SPN: 91 FMI: 4/4 LAMP: Red SRT: | Low voltage detected at accelerator pedal position number 1 signal circuit. | The engine will operate in Limp Home mode.
Accelerator Pedal or Lever Position Sensor Circuit

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the accelerator pedal signal voltage was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors should be installed. If troubleshooting an intermittent accelerator problem, the accelerator pedal position sensor 2 signal voltage can be monitored with the recommended Cummins electronic service tool or equivalent, while flexing the harness to locate the intermittent connection.

The accelerator pedal or lever position sensor signal voltage can be monitored with the recommended Cummins electronic service tool or equivalent, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by the recommended Cummins electronic service tool or equivalent.

Possible causes of this fault code include:

Accelerator pedal or lever position signal shorted to engine ground or return wires in the OEM harness or sensor

Damaged accelerator pedal or lever position sensor

Open circuit in the accelerator signal, supply, or return wire in the harness or connectors.

NOTE: The three wires in the accelerator position sensor circuit must be twisted together.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 132.

Last Modified: 25-May-2019


Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 133

Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 133 PID: P372 SPN: 974 FMI: 3/3 LAMP: Red SRT: | High signal voltage detected at remote accelerator position signal circuit. | Remote accelerator will not operate.
Remote Accelerator Pedal Position Sensor Circuit

Circuit Description

The remote accelerator position sensor is a potentiometer attached to the remote accelerator lever. The remote accelerator position sensor varies the signal voltage to the engine control module (ECM) as the remote accelerator lever is depressed and released. Low signal voltage is received by the ECM when the remote accelerator lever is at 0 percent. A high signal voltage is received by the ECM when the remote accelerator is at 100 percent. The remote accelerator pedal position circuit contains a remote accelerator pedal position 5 volt supply, remote accelerator pedal position return, and remote accelerator pedal position signal.

Component Location

The remote accelerator pedal or lever location varies with each original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the remote accelerator pedal signal voltage was greater than 4.37-VDC for more than 20 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If troubleshooting an intermittent accelerator problem:

The remote accelerator pedal or lever position sensor signal voltage can be monitored with the recommended Cummins electronic service tool or equivalent, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by the recommended Cummins electronic service tool or equivalent.

Possible causes of this fault code include:

Remote accelerator pedal or lever position signal circuit shorted to battery or (+) 5 volt supply

Open remote accelerator pedal or lever return circuit in the harness or connections

Remote accelerator supply shorted to battery

Malfunctioned remote accelerator pedal or lever position sensor.

NOTE: The three wires in the remote accelerator position sensor circuit must be twisted together.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 133.

Last Modified: 25-May-2019


Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 134

Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 134 PID: P372 SPN: 974 FMI: 4/4 LAMP: Red SRT: | Low voltage detected at remote accelerator position signal circuit. | Remote accelerator will not operate.
Remote Accelerator Pedal Position Sensor Circuit

Circuit Description

The remote accelerator position sensor is a potentiometer attached to the remote accelerator lever. The remote accelerator position sensor varies the signal voltage to the engine control module (ECM) as the remote accelerator lever is depressed and released. Low signal voltage is received by the ECM when the remote accelerator lever is at 0 percent. A high signal voltage is received by the ECM when the remote accelerator is at 100 percent. The remote accelerator pedal position circuit contains a remote accelerator pedal position 5 volt supply, remote accelerator pedal position return, and remote accelerator pedal position signal.

Component Location

The remote accelerator pedal or lever location varies with each original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the remote accelerator pedal signal voltage less than 0.132-VDC for more than 20 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If troubleshooting an intermittent accelerator problem:

The remote accelerator pedal or lever position sensor signal voltage can be monitored with the recommended Cummins electronic service tool or equivalent, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by the recommended Cummins electronic service tool or equivalent.

Possible causes of this fault code include:

Remote accelerator pedal or lever position signal shorted to engine ground or return wires in the OEM harness or sensor

Damaged remote accelerator pedal or lever position sensor

Open circuit in the remote accelerator signal, supply, or return wire in the harness or connectors.

NOTE: The three wires in the remote accelerator position sensor circuit must be twisted together.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 134.

Last Modified: 25-May-2019


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 135

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: P100 SPN: 100 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the engine oil pressure circuit. | None on performance.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

An engine oil pressure switch or oil pressure sensor is used by the engine control module (ECM) to monitor the lubricating oil pressure. For engines with an oil pressure switch, the switch is normally closed when the engine is not running and open when oil pressure is present. For engines with an oil pressure sensor, the ECM will detect a low signal voltage at operating conditions when the oil pressure is low. The ECM will detect a high signal voltage at operating conditions when the oil pressure is high.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

A default value for the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The oil pressure sensor shares supply and return wires in the engine harness with other sensors, opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 135, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor

A signal circuit shorted to sensor supply or battery voltage.

Refer to Troubleshooting Fault Code 135.

Last Modified: 25-May-2019


Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1361

Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1361 PID: P372 SPN: 974 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at remote accelerator position signal circuit. | Remote accelerator will not operate.
Remote Accelerator Pedal Position Sensor Circuit

Circuit Description

The remote accelerator position sensor is a potentiometer attached to the remote accelerator lever. The remote accelerator position sensor varies the signal voltage to the engine control module (ECM) as the remote accelerator lever is depressed and released. Low signal voltage is received by the ECM when the remote accelerator lever is at 0 percent. A high signal voltage is received by the ECM when the remote accelerator is at 100 percent. The remote accelerator pedal position circuit contains a remote accelerator pedal position 5 volt supply, remote accelerator pedal position return, and remote accelerator pedal position signal.

Component Location

The remote accelerator pedal or lever location varies with each original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the remote accelerator pedal signal voltage less than 0.132-VDC for more than 20 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If troubleshooting an intermittent accelerator problem:

The remote accelerator pedal or lever position sensor signal voltage can be monitored with the recommended Cummins electronic service tool or equivalent, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by the recommended Cummins electronic service tool or equivalent.

Possible causes of this fault code include:

Remote accelerator pedal or lever position signal shorted to engine ground or return wires in the OEM harness or sensor

Damaged remote accelerator pedal or lever position sensor

Open circuit in the remote accelerator signal, supply, or return wire in the harness or connectors.

NOTE: The three wires in the remote accelerator position sensor circuit must be twisted together.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1361.

Last Modified: 25-May-2019


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 141

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: P100 SPN: 100 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage or open circuit detected at the engine oil pressure circuit. | None on performance.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

An engine oil pressure switch or oil pressure sensor is used by the engine control module (ECM) to monitor the lubricating oil pressure. For engines with an oil pressure switch, the switch is normally closed when the engine is not running and open when oil pressure is present. For engines with an oil pressure sensor, the ECM will detect a low signal voltage at operating conditions when the oil pressure is low. The ECM will detect a high signal voltage at operating conditions when the oil pressure is high.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

A default value for the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The oil pressure sensor shares supply and return wires in the engine harness with other sensors, opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 141, check for multiple faults.

Possible causes of this fault code include:

Signal circuit open or shorted to ground in the engine harness or sensor

  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 141.

Last Modified: 25-May-2019


Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 143

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 143 PID: P100 SPN: 100 FMI: 1/18 LAMP: Amber SRT: | Engine oil pressure signal indicates engine oil pressure is below the engine protection warning limit. | Possible reduced engine performance.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

An engine oil pressure switch or oil pressure sensor is used by the engine control module (ECM) to monitor the lubricating oil pressure. For engines with an oil pressure switch, the switch is normally closed when the engine is not running and open when oil pressure is present. For engines with an oil pressure sensor, the ECM will detect a low signal voltage at operating conditions when the oil pressure is low. The ECM will detect a high signal voltage at operating conditions when the oil pressure is high.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure was less than the engine protection limits for more than 5 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code goes active when the engine oil pressure drops below the engine protection limit. Troubleshoot the engine for low oil pressure.

Refer to Troubleshooting Fault Code 143.

Last Modified: 25-May-2019


Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 144

Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: P110 SPN: 110 FMI: 3/3 LAMP: Amber SRT: | High signal voltage or open circuit detected at engine coolant temperature circuit. | Fan will stay ON if controlled by the engine control module (ECM).
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value is used for the engine coolant temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The engine coolant temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Before troubleshooting Fault Code 144, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor

Open signal circuit or shorted to a voltage source.

Malfunctioning engine coolant temperature sensor

Refer to Troubleshooting Fault Code 144.

Last Modified: 25-May-2019


Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 145

Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: P110 SPN: 110 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at engine coolant temperature circuit. | Fan will stay ON if controlled by the engine control module (ECM).
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value is used for the engine coolant temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The engine coolant temperature sensor shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active. Before troubleshooting Fault Code 145, check for multiple fault codes.

Possible causes of this fault code include:

Signal shorted to ground in the harness

Signal shorted to return or ground in the sensor.

Malfunctioning engine coolant temperature sensor

Refer to Troubleshooting Fault Code 145.

Last Modified: 25-May-2019


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 146

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 146 PID: P110 SPN: 110 FMI: 0/16 LAMP: Amber SRT: | Engine coolant temperature is above the engine protection warning limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was greater than 108°C [226°F] for more than 5 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limit for high coolant temperature. Refer to Engine Coolant Temperature Above Normal symptom troubleshooting tree in the applicable engine service manual.

Refer to Troubleshooting Fault Code 146.

Last Modified: 25-May-2019


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 151

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 151 PID: P110 SPN: 110 FMI: 0/0 LAMP: Red SRT: | Engine coolant temperature is above the engine protection warning limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was greater than 117°C [ 242°F] for more than 5 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The torque output of the engine will be reduced.

Maximum engine operating speed will be decreased.

The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature.

Refer to Troubleshooting Fault Code 151.

Last Modified: 25-May-2019


Accelerator Pedal Position 1 - Received Network Data in Error

FAULT CODE 1515

Accelerator Pedal Position 1 - Received Network Data in Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1515 PID: P91 SPN: 91 FMI: 2/19 LAMP: Red SRT: | The J1939 multiplexing controller has indicated a malfunction of the multiplexed accelerator pedal. | Engine will only idle.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The OEM VECU determined that there was a malfunction of the multiplexed accelerator pedal or lever sensor system.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The J1939 multiplexing controller has indicated a malfunction of the multiplexed accelerator pedal.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 1515 .

Last Modified: 13-Oct-2021


Engine Intake Manifold 1 Temperature - Voltage Above Normal or Shorted to High Source

FAULT CODE 153

Engine Intake Manifold 1 Temperature - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 PID: P105 SPN: 105 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at intake manifold air temperature circuit. | Fan will stay ON if controlled by the engine control module (ECM).
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for the intake manifold temperature reading.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Exhaust gas recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The intake manifold air temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check active fault codes with multiple counts first.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to voltage source.
  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 153 .

Last Modified: 13-Oct-2021


Engine Intake Manifold 1 Temperature - Voltage Below Normal or Shorted to Low Source

FAULT CODE 154

Engine Intake Manifold 1 Temperature - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 154 PID: P105 SPN: 105 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at intake manifold air temperature circuit. | Fan will stay ON if controlled by the engine control module (ECM).
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for the intake manifold temperature reading.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Exhaust gas recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The intake manifold temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check fault codes with multiple counts first.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor.
  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 154 .

Last Modified: 13-Oct-2021


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 155

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 155 PID: P105 SPN: 105 FMI: 0/0 LAMP: Red SRT: | Intake manifold air temperature signal indicates intake manifold air temperature above engine protection critical limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold air temperature was greater than 132°C [270°F] for 5 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The torque output of the engine will be reduced.

Maximum engine operating speed will be decreased.

The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The intake manifold air temperature sensor measures the temperature of the charge-air as it passes through the intake manifold.

Possible causes of this fault code include:

Restricted air flow through the charge-air cooler

Undersized charge-air cooler

High turbocharger compressor outlet temperature.

Refer to Troubleshooting Fault Code 155.

Last Modified: 25-May-2019


Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1595

Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1595 PID: P372 SPN: 974 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at remote accelerator position signal circuit. | Remote accelerator will not operate.
Remote Accelerator Pedal Position Sensor Circuit

Circuit Description

The remote accelerator position sensor is a potentiometer attached to the remote accelerator lever. The remote accelerator position sensor varies the signal voltage to the engine control module (ECM) as the remote accelerator lever is depressed and released. Low signal voltage is received by the ECM when the remote accelerator lever is at 0 percent. A high signal voltage is received by the ECM when the remote accelerator is at 100 percent. The remote accelerator pedal position circuit contains a remote accelerator pedal position 5 volt supply, remote accelerator pedal position return, and remote accelerator pedal position signal.

Component Location

The remote accelerator pedal or lever location varies with each original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the remote accelerator pedal signal voltage was greater than 4.37-VDC for more than 20 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If troubleshooting an intermittent accelerator problem:

The remote accelerator pedal or lever position sensor signal voltage can be monitored with the recommended Cummins electronic service tool or equivalent, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by the recommended Cummins electronic service tool or equivalent.

Possible causes of this fault code include:

Remote accelerator pedal or lever position signal circuit shorted to battery or (+) 5 volt supply

Open remote accelerator pedal or lever return circuit in the harness or connections

Remote accelerator supply shorted to battery

Malfunctioned remote accelerator pedal or lever position sensor.

NOTE: The three wires in the remote accelerator position sensor circuit must be twisted together.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1595.

Last Modified: 25-May-2019


Engine Misfire Cylinder 1 - Condition Exists

FAULT CODE 1654

Engine Misfire Cylinder 1 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1654 PID: SPN: 1323 FMI: 11/31 LAMP: Amber SRT: | Engine misfire has been detected in cylinder number 1. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

An algorithm in the ECM calibration monitors engine speed as each injector fires. If a cylinder(s) has high or low contribution to engine speed, the fault will become active. The intention of the fault is to assist in troubleshooting performance complaints such as engine misfire and low power.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a cylinder 1 misfire.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If Fault Code 1654 is inactive in the ECM memory and there is no complaint such as "low power" or "engine misfire", it is possible that an intermittent event, such as air entering the fuel system following a filter change, caused the fault. Inactive counts of Fault Code 1654 should be disregarded unless other performance symptoms are present. The engine coolant temperature must be greater than 71°C [160°F] before this diagnostic will run.

Causes of cylinder misfire can include:

Valve lash out of specification (compare actual valve lash to reset limits)

Cylinder malfunction (check for high blowby when the engine is loaded)

Valve train malfunction or valve held open (listen for intake valve "chirping" noise in the intake)

Extra, missing, or damaged sealing washer under an injector

Injector malfunctions (swap injectors to see if the problem follows the indicated injector).

Refer to Troubleshooting Fault Code 1654.

Last Modified: 25-May-2019


Engine Misfire Cylinder 2 - Condition Exists

FAULT CODE 1655

Engine Misfire Cylinder 2 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1655 PID: SPN: 1324 FMI: 11/31 LAMP: Amber SRT: | Engine misfire has been detected in cylinder number 2. | Possible reduced engine performance.
Engine Control Module

Circuit Description

An algorithm in the ECM calibration monitors engine speed as each injector fires. If a cylinder(s) has high or low contribution to engine speed, the fault will become active. The intention of the fault is to assist in troubleshooting performance complaints such as engine misfire and low power.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a cylinder 2 misfire.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If Fault Code 1655 is inactive in the ECM memory and there is no complaint such as "low power" or "engine misfire", it is possible that an intermittent event such as air entering the fuel system following a filter change caused the fault. Inactive counts of Fault Code 1655 should be disregarded unless other performance symptoms are present. The engine coolant temperature must be greater than 71°C [160°F]before this diagnostic will run.

Causes of cylinder misfire can include:

Valve lash out of specification (compare actual valve lash to reset limits)

Cylinder malfunction (check for high blowby when the engine is loaded)

Valve train malfunction or valve held open (listen for intake valve "chirping" noise in the intake)

Extra, missing, or damaged sealing washer under an injector

Injector malfunctions (swap injectors to see if the problem follows the indicated injector).

Refer to Troubleshooting Fault Code 1655.

Last Modified: 25-May-2019


Engine Misfire Cylinder 3 - Condition Exists

FAULT CODE 1656

Engine Misfire Cylinder 3 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1656 PID: SPN: 1325 FMI: 11/31 LAMP: Amber SRT: | Engine misfire has been detected in cylinder number 3. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

An algorithm in the ECM calibration monitors engine speed as each injector fires. If a cylinder(s) has high or low contribution to engine speed, the fault will become active. The intention of the fault is to assist in troubleshooting performance complaints such as engine misfire and low power.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a cylinder 3 misfire.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If Fault Code 1656 is inactive in the ECM memory and there is no complaint such as "low power" or "engine misfire", it is possible that an intermittent event, such as air entering the fuel system following a filter change caused the fault. Inactive counts of Fault Code 1656 should be disregarded unless other performance symptoms are present. The coolant temperature must be greater than 71°C [160°F] before this diagnostic will run.

Causes of cylinder misfire can include:

Valve lash out of specification (compare actual valve lash to reset limits)

Cylinder malfunction (check for high blowby when the engine is loaded)

Valve train malfunction or valve held open (listen for intake valve "chirping" noise in the intake)

Extra, missing, or damaged sealing washer under an injector

Injector malfunctions (swap injectors to see if the problem follows the indicated injector).

Refer to Troubleshooting Fault Code 1656.

Last Modified: 25-May-2019


Engine Misfire Cylinder 4 - Condition Exists

FAULT CODE 1657

Engine Misfire Cylinder 4 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1657 PID: SPN: 1326 FMI: 11/31 LAMP: Amber SRT: | Engine misfire has been detected in cylinder number 4. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

An algorithm in the ECM calibration monitors engine speed as each injector fires. If a cylinder(s) has high or low contribution to engine speed, the fault will become active. The intention of the fault is to assist in troubleshooting performance complaints such as engine misfire and low power.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a cylinder 4 misfire.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If Fault Code 1657 is inactive in the ECM memory and there is no complaint such as "low power" or "engine misfire", it is possible that an intermittent event such as air entering the fuel system following a filter change caused the fault. Inactive counts of Fault Code 1657 should be disregarded unless other performance symptoms are present. The engine coolant temperature must be greater than 71°C [160°F] before this diagnostic will run.

Causes of cylinder misfire can include:

Valve lash out of specification (compare actual valve lash to reset limits)

Cylinder malfunction (check for high blowby when the engine is loaded)

Valve train malfunction or valve held open (listen for intake valve "chirping" noise in the intake)

Extra, missing, or damaged sealing washer under an injector

Injector malfunctions (swap injectors to see if the problem follows the indicated injector).

Refer to Troubleshooting Fault Code 1657.

Last Modified: 25-May-2019


Engine Misfire Cylinder 5 - Condition Exists

FAULT CODE 1658

Engine Misfire Cylinder 5 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1658 PID: SPN: 1327 FMI: 11/31 LAMP: Amber SRT: | Engine misfire has been detected in cylinder number 5. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

An algorithm in the ECM calibration monitors engine speed as each injector fires. If a cylinder(s) has high or low contribution to engine speed, the fault will become active. The intention of the fault is to assist in troubleshooting performance complaints such as engine misfire and low power.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a cylinder 5 misfire.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If Fault Code 1658 is inactive in the ECM memory and there is no complaint such as "low power" or "engine misfire", it is possible that an intermittent event such as air entering the fuel system following a filter change caused the fault. Inactive counts of Fault Code 1658 should be disregarded unless other performance symptoms are present. The engine coolant temperature must be greater than 71°C [160°F] before this diagnostic will run.

Causes of cylinder misfire can include:

Valve lash out of specification (compare actual valve lash to reset limits)

Cylinder malfunction (check for high blowby when the engine is loaded)

Valve train malfunction or valve held open (listen for intake valve "chirping" noise in the intake)

Extra, missing, or damaged sealing washer under an injector

Injector malfunctions (swap injectors to see if the problem follows the indicated injector).

Refer to Troubleshooting Fault Code 1658.

Last Modified: 25-May-2019


Engine Misfire Cylinder 6 - Condition Exists

FAULT CODE 1659

Engine Misfire Cylinder 6 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1659 PID: SPN: 1328 FMI: 11/31 LAMP: Amber SRT: | Engine misfire has been detected in cylinder number 6. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

An algorithm in the ECM calibration monitors engine speed as each injector fires. If a cylinder(s) has high or low contribution to engine speed, the fault will become active. The intention of the fault is to assist in troubleshooting performance complaints such as engine misfire and low power.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a cylinder 6 misfire.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If Fault Code 1659 is inactive in the ECM memory and there is no complaint such as "low power" or "engine misfire", it is possible that an intermittent event, such as air entering the fuel system, following a filter change caused the fault. Inactive counts of Fault Code 1659 should be disregarded unless other performance symptoms are present. The engine coolant temperature must be greater than 71°C [160°F] before this diagnostic will run.

Causes of cylinder misfire can include:

Valve lash out of specification (compare actual valve lash to reset limits)

Cylinder malfunction (check for high blowby when the engine is loaded)

Valve train malfunction or valve held open (listen for intake valve "chirping" noise in the intake)

Extra, missing, or damaged sealing washer under an injector

Injector malfunctions (swap injectors to see if the problem follows the indicated injector).

Refer to Troubleshooting Fault Code 1659.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Oxidation Catalyst Missing - Condition Exists

FAULT CODE 1664

Aftertreatment 1 Diesel Oxidation Catalyst Missing - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1664 PID: S380 SPN: 4796 FMI: 11/31 LAMP: Amber SRT: | The aftertreatment diesel oxidation catalyst is not present in the exhaust system. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel oxidation catalyst is located in the exhaust system. The location of the catalyst can vary, depending on the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs during active regeneration of the aftertreatment diesel particulate filter.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the difference between the aftertreatment diesel oxidation catalyst intake temperature sensor signal and the aftertreatment diesel particulate filter intake temperature sensor signal during an active regeneration of the aftertreatment system was too small indicating a missing diesel oxidation catalyst.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and perform the recommended Cummins electronic service tool or equivalent Aftertreatment Diesel Particulate Filter Regeneration Test.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code becomes active when the aftertreatment diesel oxidation catalyst intake and aftertreatment diesel particulate filter intake temperature sensors do not detect the presence of a catalyst in the aftertreatment system.

Possible causes of this fault code include:

Tampering with the catalyst system

Removing the catalyst system from the vehicle

A damaged catalyst.

Refer to Troubleshooting Fault Code 1664.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1668

Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1668 PID: SPN: 1761 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the aftertreatment diesel exhaust fluid tank level sensor circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor - 3 Wire Sensor
Aftertreatment Diesel Exhaust Fluid Tank Level/Temperature/Quality Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank level sensor is used to monitor the aftertreatment diesel exhaust fluid level inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank level sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Signal circuit open or shorted to ground in the engine harness or sensor

  • Supply wire open or shorted to ground.

A malfunctioning aftertreatment diesel exhaust fluid tank level sensor

The type of diesel exhaust fluid tank temperature and level sensor used can vary depending on the vehicle OEM. As a result, the physical and/or electrical sensor configuration may vary slightly from what is shown in the troubleshooting and wiring diagram information.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1668.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1669

Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1669 PID: SPN: 1761 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the catalyst tank level sensor circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit
Aftertreatment Diesel Exhaust Fluid Tank Level/Temperature/Quality Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank level sensor is used to monitor the aftertreatment diesel exhaust fluid level inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank level sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Engine torque will be severely reduced.

Vehicle speed will be limited to 8 km [5 mi] per hour after extended engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor

Signal circuit shorted to sensor supply or battery voltage.

A malfunctioning aftertreatment diesel exhaust fluid tank level sensor

The type of diesel exhaust fluid tank temperature and level sensor used can vary depending on the vehicle OEM. As a result, the physical and/or electrical sensor configuration may vary slightly from what is shown in the troubleshooting and wiring diagram information.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1669.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 1673

Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1673 PID: SPN: 1761 FMI: 1/1 LAMP: Amber SRT: | The aftertreatment diesel exhaust fluid tank level has fallen below the critical warning level. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid level sensor is used to monitor the diesel exhaust fluid level inside the diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the following conditions are met:

Keyswitch is in the ON position or when the engine is running.

Ambient temperature is above -20Â°C [-4Â°F].

Vehicle altitude change is less than 305 m [1000 ft] in 1 hour.

Conditions for Setting the Fault Codes

The diesel exhaust fluid tank was critically low.

Action Taken When the Fault Code is Active

The diesel exhaust fluid lamp will be flashing.

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Engine torque will be severely reduced.

Vehicle speed will be limited to 8 km [5 mi] per hour after the engine has been shutdown, 1 hour of engine idle time, or the fuel tank has been refilled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates that the Diesel Exhaust Fluid (DEF) level is critically low and there will be a power loss. Engine power will be reduced automatically.This can be corrected by refilling the DEF tank. Normal engine power will be restored after refilling the DEF tank.

Refer to Troubleshooting Fault Code 1673.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1677

Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1677 PID: SPN: 3031 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the diesel exhaust fluid tank temperature sensor circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor Circuit
SAE J1939 Datalink

Circuit Description

The aftertreatment diesel exhaust fluid tank temperature sensor is used to monitor the temperature of the aftertreatment diesel exhaust fluid inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor

Signal shorted to ground in the harness

Signal shorted to return or ground in the sensor.

The type of diesel exhaust fluid tank temperature and level sensor used can vary depending on the vehicle OEM. As a result, the physical and/or electrical sensor configuration may vary slightly from what is shown in the troubleshooting and wiring diagram information.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1677.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Above Normal or Shorted to High Source

FAULT CODE 1678

Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1678 PID: SPN: 3031 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at the diesel exhaust fluid tank temperature sensor circuit | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor Circuit
SAE J1939 Datalink

Circuit Description

The aftertreatment diesel exhaust fluid tank temperature sensor is used to monitor the temperature of the aftertreatment diesel exhaust fluid inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Engine torque will be severely reduced.

Vehicle speed will be limited to 8 km [5 mi] per hour after extended engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor

  • Open return circuit in the harness, connectors, or sensor

Open signal circuit or shorted to a voltage source.

The type of diesel exhaust fluid tank temperature and level sensor used can vary depending on the vehicle OEM. As a result, the physical and/or electrical sensor configuration may vary slightly from what is shown in the troubleshooting and wiring diagram information.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1678.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1679

Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1679 PID: SPN: 3031 FMI: 2/2 LAMP: Amber SRT: | The diesel exhaust fluid tank temperature sensor has indicated a tank temperature too high or too low for the ambient conditions. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor Circuit
SAE J1939 Datalink

Circuit Description

The aftertreatment diesel exhaust fluid tank temperature sensor is used to monitor the temperature of the aftertreatment diesel exhaust fluid inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

The engine must be turned OFF for period of 8 hours before this diagnostic will run. This diagnostic runs when the keyswitch is turned to the ON position after an 8 hour cold soak.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank temperature sensor reading was higher or lower than the other temperature sensors on the engine.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, the engine must be shut down with the keyswitch in the OFF position for 8 hours. After the 8 hour cold soak, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

In-range failure of the diesel exhaust fluid tank temperature sensor

Damaged wiring harness

The type of diesel exhaust fluid tank temperature and level sensor used can vary depending on the vehicle OEM. As a result, the physical and/or electrical sensor configuration may vary slightly from what is shown in the troubleshooting and wiring diagram information.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1679.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Input Lines - Condition Exists

FAULT CODE 1682

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Input Lines - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1682 PID: SPN: 3362 FMI: 11/31 LAMP: Amber SRT: | The aftertreatment diesel exhaust fluid dosing unit is unable to prime. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The diesel exhaust fluid dosing unit lines are responsible for transporting diesel exhaust fluid between the dosing unit, dosing valve, and diesel exhaust fluid tank.

Component Location

There are three diesel exhaust fluid lines. One line is between the dosing unit and dosing valve, and the other two lines are between the dosing unit and the diesel exhaust fluid tank. These lines can be partially hidden from view by the SCR system and other vehicle components. Line routing will vary, based on the aftertreatment architecture and the OEM.

Conditions for Running the Diagnostics

This diagnostic runs when the SCR system is trying to prime.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid dosing unit was unable to successfully prime after multiple attempts.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Engine torque will be severely reduced.

Vehicle speed will be limited to 8 km [5 mi] per hour after extended engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid System Leak Test" found under "ECM Diagnostic Tests" in the recommended Cummins electronic service tool or equivalent.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Low aftertreatment diesel exhaust fluid level in the diesel exhaust fluid tank

The line heaters are not successfully thawing the frozen diesel exhaust fluid

The diesel exhaust fluid pressure line between the dosing unit and dosing valve is kinked, broken, or disconnected

The diesel exhaust fluid suction line between the diesel exhaust fluid tank and the dosing unit is kinked, broken, or disconnected

Malfunctioning diesel exhaust fluid dosing unit

The diesel exhaust fluid suction and return lines between the dosing unit and diesel exhaust fluid tank are reversed

Debris from the diesel exhaust fluid tank. If debris is found in the diesel exhaust fluid tank, clean the diesel exhaust fluid tank thoroughly and fill with certified diesel exhaust fluid.

Refer to Troubleshooting Fault Code 1682.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Voltage Above Normal or Shorted to High Source

FAULT CODE 1683

Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1683 PID: SPN: 3363 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the aftertreatment diesel exhaust fluid tank heater circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank heater keeps the diesel exhaust fluid from freezing in the diesel exhaust fluid tank. The tank heater consists of an electrically powered tank heater control valve which controls the flow of engine coolant to a heating coil inside the diesel exhaust fluid tank. The tank heater control valve opens to allow coolant to flow to the heating coil when heating is commanded, and closes when heating is no longer required.

Component Location

The diesel exhaust fluid tank heater control valve is located near the diesel exhaust fluid tank. Specific location will vary depending on the OEM. The tank heating coil is internal to the diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when diesel exhaust fluid tank heating is being commanded.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank heater circuit is shorted to battery or open circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Diesel exhaust fluid tank heating will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Vehicle speed will be limited to 8 km [5 mi] per hour after extended engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use the recommended Cummins electronic service tool or equivalent to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Diesel exhaust fluid tank heater signal wire and return wire shorted together

Malfunctioning diesel exhaust fluid tank heater control valve

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1683.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1684

Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1684 PID: SPN: 3363 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the aftertreatment diesel exhaust fluid tank heater circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank heater keeps the diesel exhaust fluid from freezing in the diesel exhaust fluid tank. The tank heater consists of an electrically powered tank heater control valve which controls the flow of engine coolant to a heating coil inside the diesel exhaust fluid tank. The tank heater control valve opens to allow coolant to flow to the heating coil when heating is commanded, and closes when heating is no longer required.

Component Location

The diesel exhaust fluid tank heater control valve is located near the diesel exhaust fluid tank. Specific location will vary depending on the OEM. The tank heating coil is internal to the diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when diesel exhaust fluid tank heating is being commanded.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected low signal voltage or a short to ground at the diesel exhaust fluid tank heater circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Diesel exhaust fluid tank heating will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use the recommended Cummins electronic service tool or equivalent to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning diesel exhaust fluid tank heater control valve

A short circuit to ground

Refer to Troubleshooting Fault Code 1684.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Quality Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1685

Aftertreatment 1 Diesel Exhaust Fluid Quality Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1685 PID: SPN: 3364 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit - Voltage below normal, or shorted to low source | Possible reduced engine performance.
SAE J1939 Datalink

Circuit Description

The aftertreatment diesel exhaust fluid quality sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor is used to measure the concentration of the aftertreatment diesel exhaust fluid in the tank.

Component Location

The aftertreatment diesel exhaust fluid quality sensor is located in the aftertreatment diesel exhaust fluid tank. It may be a combination sensor with the aftertreatement diesel exhaust fluid tank level and tank temperature sensors. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Aftertreatment DEF quality sensor reported an out of range low condition.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning Aftertreatment DEF Quality Sensor.
Refer to Troubleshooting Fault Code 1685 .

Last Modified: 13-Oct-2021


Aftertreatment 1 Diesel Exhaust Fluid Quality Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1686

Aftertreatment 1 Diesel Exhaust Fluid Quality Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1686 PID: SPN: 3364 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit - Voltage above normal, or shorted to high source | Possible reduced engine performance.
SAE J1939 Datalink

Circuit Description

The aftertreatment diesel exhaust fluid quality sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor is used to measure the concentration of the aftertreatment diesel exhaust fluid in the tank.

Component Location

The aftertreatment diesel exhaust fluid quality sensor is located in the aftertreatment diesel exhaust fluid tank. It may be a combination sensor with the aftertreatement diesel exhaust fluid tank level and tank temperature sensors. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Aftertreatment DEF quality sensor reported an out of range high condition.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning Aftertreatment DEF Quality Sensor.
Refer to Troubleshooting Fault Code 1686 .

Last Modified: 13-Oct-2021


Aftertreatment 1 Diesel Oxidation Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 1691

Aftertreatment 1 Diesel Oxidation Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1691 PID: S380 SPN: 5298 FMI: 1/18 LAMP: Amber SRT: | The temperature increase across the aftertreatment diesel oxidation catalyst is lower than expected. | Possible frequent need for aftertreatment regeneration.
Engine Control Module (ECM)

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel oxidation catalyst is located in the exhaust system. The location of the catalyst can vary, depending on the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active regeneration of the aftertreatment diesel particulate filter is occurring.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) calculated the DOC efficiency was less than required to successfully complete a regeneration.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and perform the recommended Cummins electronic service tool or equivalent Aftertreatment Diesel Particulate Filter Regeneration Test.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning diesel oxidation catalyst

A malfunctioning aftertreatment fuel injector

Refer to Troubleshooting Fault Code 1691.

Last Modified: 25-May-2019


Aftertreatment 1 Outlet NOx Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1694

Aftertreatment 1 Outlet NOx Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1694 PID: SPN: 3226 FMI: 2/2 LAMP: Amber SRT: | An incorrect NOx sensor reading has been detected by the aftertreatment outlet NOx sensor. | Possible reduced engine performance.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic has to meet specific engine and aftertreatment conditions to run and complete.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment outlet NOx sensor reading was not changing with engine conditions or is stuck.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Diesel exhaust fluid crystallization or deposits

Incorrectly installed aftertreatment outlet NOx sensor

Malfunctioning aftertreatment outlet NOx sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM

This diagnostic will NOT run during a regeneration.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1694.

Last Modified: 25-May-2019


Sensor Supply 5 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1695

Sensor Supply 5 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1695 PID: S232 SPN: 3513 FMI: 3/3 LAMP: Amber SRT: | High voltage detected at sensor supply number 5 circuit in the OEM harness. | The engine will operate in Limp Home mode.
Sensor Supply 5 Circuit

Circuit Description

The sensor supply 5 circuit of the engine control module (ECM) provides a 5 volt supply for various aftertreatment and OEM sensors.

Component Location

Sensor Supply 5 originates in the OEM connector portion of the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 5 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The engine will have limp-home throttle control only.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

High voltage on the 5-VDC supply wire can be caused by a short circuit to a power supply, a damaged sensor, or a damaged ECM power supply.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1695.

Last Modified: 25-May-2019


Sensor Supply 5 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1696

Sensor Supply 5 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1696 PID: S232 SPN: 3513 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at sensor supply number 5 circuit in the OEM harness. | The engine will operate in Limp Home mode.
Sensor Supply 5 Circuit

Circuit Description

The sensor supply 5 circuit of the engine control module (ECM) provides a 5 volt supply for various aftertreatment and OEM sensors.

Component Location

Sensor Supply 5 originates in the OEM connector portion of the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 5 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The engine will have limp-home throttle control only.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Low voltage on the 5 volt supply wire can be caused by a short circuit to ground in a supply wire, a short circuit between a supply wire and a return wire, a damaged sensor, or a damaged ECM power supply.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1696.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 1712

Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1712 PID: SPN: 3363 FMI: 1/18 LAMP: Amber SRT: | The aftertreatment diesel exhaust fluid tank heater is unable to thaw the frozen diesel exhaust fluid. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank heater keeps the diesel exhaust fluid from freezing in the diesel exhaust fluid tank. The tank heater consists of an electrically powered tank heater control valve which controls the flow of engine coolant to a heating coil inside the diesel exhaust fluid tank. The tank heater control valve opens to allow coolant to flow to the heating coil when heating is commanded, and closes when heating is no longer required.

Component Location

The diesel exhaust fluid tank heater control valve is located near the diesel exhaust fluid tank. Specific location will vary depending on the OEM. The tank heating coil is internal to the diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs a calibrated amount of time after diesel exhaust fluid tank heating is first commanded.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank temperature failed to thaw after the aftertreatment diesel exhaust fluid tank heater control valve was commanded open for a calibrated time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • The fault code status in the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the system is able to adequately heat and the diagnostic runs and passes. If heating can not be completed, use the "Diesel Exhaust Fluid Doser System Heater Test" found under "ECM Diagnostic Test" in the recommended Cummins electronic service tool or equivalent to command heating to the tank heater and all line heaters.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Aftertreatment diesel exhaust fluid tank heater control valve stuck closed

Blockage or restrictons in the coolant plumbing to the diesel exhaust fluid tank heater

Engine coolant level low

Malfunctioning aftertreatment diesel exhaust fluid tank heater control valve

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1712.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1713

Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1713 PID: SPN: 3363 FMI: 0/16 LAMP: Amber SRT: | The diesel exhaust fluid tank heater is continuously in the ON position. | Engine torque output will be reduced.
Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank heater keeps the diesel exhaust fluid from freezing in the diesel exhaust fluid tank. The tank heater consists of an electrically powered tank heater control valve which controls the flow of engine coolant to a heating coil inside the diesel exhaust fluid tank. The tank heater control valve opens to allow coolant to flow to the heating coil when heating is commanded, and closes when heating is no longer required.

Component Location

The diesel exhaust fluid tank heater control valve is located near the diesel exhaust fluid tank. Specific location will vary depending on the OEM. The tank heating coil is internal to the diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when diesel exhaust fluid tank heating is NOT being commanded.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the DEF tank temperature was greater than a calibrated temperature, indicating the aftertreatment diesel exhaust fluid tank heater control valve was in the ON position when the ECM was commanding the valve to be in the OFF position.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Before troubleshooting this fault code, make sure the equipment is not equipped with an auxiliary heating device for the diesel exhaust fluid tank. Such a device can result in overheating the diesel exhaust fluid in the tank.

This fault code may be inactive when the vehicle is brought in for service. Even if inactive, follow the troubleshooting tree completely.

Possible causes of this fault code include:

Aftertreatment diesel exhaust fluid tank heater control valve installed incorrectly, reversed relative to coolant flow direction.

Malfunctioning aftertreatment diesel exhaust fluid tank heater control valve stuck open or leakage past the valve seat.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1713.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Quality - Out of Calibration

FAULT CODE 1714

Aftertreatment 1 Diesel Exhaust Fluid Quality - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1714 PID: SPN: 3364 FMI: 13/13 LAMP: Amber SRT: | The received datalink message was not valid. | None on performance.
SAE J1939 Backbone

Circuit Description

The aftertreatment diesel exhaust fluid quality sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor is used to measure the concentration of the aftertreatment diesel exhaust fluid in the tank.

Component Location

The aftertreatment diesel exhaust fluid quality sensor is located in the aftertreatment diesel exhaust fluid tank. It may be a combination sensor with the aftertreatement diesel exhaust fluid tank level and tank temperature sensors. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The DEF quality sensor has detected a read or write error internal to the quality sensor sensing module.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be severely reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This fault code sets when the ECM detects an internal reset of the sensor. This internal reset is caused by an intermittent battery voltage supply. This fault code indicates that an intermittent wiring problem has been detected. All wiring and connectors should be closely inspected for intermittent connections.

Refer to Troubleshooting Fault Code 1714 .

Last Modified: 13-Oct-2021


Aftertreatment 1 Diesel Exhaust Fluid Quality - Root Cause Not Known

FAULT CODE 1715

Aftertreatment 1 Diesel Exhaust Fluid Quality - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1715 PID: SPN: 3364 FMI: 11/11 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Quality - Root Cause Not Known | None on performance.
SAE J1939 Datalink

Circuit Description

The aftertreatment diesel exhaust fluid quality sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor is used to measure the concentration of the aftertreatment diesel exhaust fluid in the tank.

Component Location

The aftertreatment diesel exhaust fluid quality sensor is located in the aftertreatment diesel exhaust fluid tank. It may be a combination sensor with the aftertreatement diesel exhaust fluid tank level and tank temperature sensors. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The DEF quality sensor has reported an internal error.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning Aftertreatment DEF Quality Sensor.
Refer to Troubleshooting Fault Code 1715 .

Last Modified: 13-Oct-2021


Engine Misfire for Multiple Cylinders - Condition Exists

FAULT CODE 1718

Engine Misfire for Multiple Cylinders - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1718 PID: SPN: 1322 FMI: 11/31 LAMP: Amber SRT: | Engine misfire has been detected in multiple cylinder numbers. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

An algorithm in the ECM calibration monitors engine speed as each injector fires. If a cylinder(s) has high or low contribution to engine speed, the fault will become active. The intention of the fault is to assist in troubleshooting performance complaints such as engine misfire and low power.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a misfire of two or more cylinders.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If Fault Code 1718 is inactive in the ECM memory and there is no complaint such as "low power" or "engine misfire", it is possible that an intermittent event such as air entering the fuel system following a filter change caused the fault. Inactive counts of Fault Code 1718 should be disregarded unless other performance symptoms are present. The engine coolant temperature must be greater than 71°C [160°F] before this diagnostic will run.

Causes of cylinder misfire can include:

Valve lash out of specification (compare actual valve lash to reset limits)

Cylinder damaged (check for high blowby when the engine is loaded)

Valve damaged or valve held open (listen for intake valve "chirping" noise in the intake).

Injector malfunction (swap injectors to see if the problem follows the indicated injector).

Refer to Troubleshooting Fault Code 1718.

Last Modified: 25-May-2019


Electronic Throttle Control Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 175

Electronic Throttle Control Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 175 PID: SPN: 3464 FMI: 3/3 LAMP: Red SRT: | A short circuit to battery or open circuit has been detected in the engine intake air throttle actuator signal circuit. | Possible reduced engine performance.
Engine Intake Air Throttle Actuator Circuit

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine intake air throttle actuator signal is shorted to voltage when the actuator is commanded OFF.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Engine intake air throttle actuation will be disabled. The engine intake air throttle will default to the open position.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Active and stationary regeneration of the diesel particulate filter will be disabled.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

An open or short circuit to battery in the engine harness.

A malfunctioning engine intake air throttle actuator

Refer to Troubleshooting Fault Code 175.

Last Modified: 25-May-2019


Electronic Throttle Control Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 176

Electronic Throttle Control Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 176 PID: SPN: 3464 FMI: 4/4 LAMP: Red SRT: | A short circuit to ground has been detected in the engine intake air throttle actuator signal circuit. | Possible reduced engine performance.
Engine Intake Air Throttle Actuator Circuit

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs when the engine intake air throttle actuator is being commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine intake air throttle actuator signal is shorted to ground when the actuator is commanded ON.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Engine intake air throttle actuation will be disabled. The engine intake air throttle will default to the open position.

Exhaust gas recirculation (EGR) valve operation will be disabled.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 5 minutes. After 5 minutes, shut OFF the engine, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A short circuit to ground in the engine harness

A malfunctioning engine intake air throttle actuator

Refer to Troubleshooting Fault Code 176.

Last Modified: 25-May-2019


Electronic Throttle Control Actuator - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 177

Electronic Throttle Control Actuator - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 177 PID: SPN: 3464 FMI: 7/7 LAMP: Red SRT: | The engine intake air throttle actuator has failed the auto zero span check. | Possible reduced engine performance.
Engine Intake Air Throttle Actuator Circuit

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

One part runs when the keyswitch is initially turned ON before the engine is started

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine intake air throttle actuator failed the autozero span check.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Engine intake air throttle actuation will be disabled. The engine intake air throttle will default to the open position.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • Start and idle the engine for 1 minute
  • Turn the key switch OFF and allow the ECM to completely powerdown.
  • Turn the key switch ON.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning engine intake air throttle actuator

Refer to Troubleshooting Fault Code 177.

Last Modified: 25-May-2019


Crankcase Pressure Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1843

Crankcase Pressure Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1843 PID: P101 SPN: 101 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the crankcase pressure circuit. | None on performance.
Engine Crankcase Pressure Sensor

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located near the crankcase ventilation element.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankcase pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the crankcase pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The crankcase pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor

Signal wire shorted to sensor supply or battery voltage.

Refer to Troubleshooting Fault Code 1843.

Last Modified: 25-May-2019


Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1844

Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1844 PID: P101 SPN: 101 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the crankcase pressure circuit. | None on performance.
Engine Crankcase Pressure Sensor

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located near the crankcase ventilation element.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankcase pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the crankcase pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The crankcase pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting, check for multiple fault codes.

Possible causes of this fault code include:

Signal circuit open or shorted to ground in the engine harness or sensor

  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 1844.

Last Modified: 25-May-2019


Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1845

Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1845 PID: P97 SPN: 97 FMI: 3/3 LAMP: Maintenance SRT: | High voltage detected at the water-in-fuel circuit. | None on performance.
Water-in-Fuel Indicator Sensor Circuit

Circuit Description

The water-in-fuel sensor is in the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage down, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the water in fuel sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Open RETURN or SIGNAL circuit in the harness, connectors, or sensor

Signal wire shorted to sensor supply or battery voltage.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1845.

Last Modified: 25-May-2019


Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1846

Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1846 PID: P97 SPN: 97 FMI: 4/4 LAMP: Maintenance SRT: | Low voltage detected at the water-in-fuel circuit. | None on performance.
Water-in-Fuel Indicator Sensor Circuit

Circuit Description

The water-in-fuel sensor is in the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage down, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the water in fuel sensor signal voltage was less than 0.05-VDC for 1 second.

Action Taken When the Fault Code is Active

The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Signal circuit shorted to ground in the harness, sensor, or connector.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1846.

Last Modified: 25-May-2019


Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1852

Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1852 PID: P97 SPN: 97 FMI: 0/16 LAMP: Amber SRT: | The Water in Fuel Indicator indicates that the water level is above warning level. | None on performance.
Water-in-Fuel Indicator Sensor Circuit

Circuit Description

The water-in-fuel sensor is in the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage down, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected water in fuel for an extended period of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Water in the fuel can do extensive damage to the fuel system, due to the tight tolerances of the fuel system components.

The fuel filter must be drained immediately.

If this fault code is active and there is no water in the fuel filter then a malfunctioning Water-In-Fuel sensor or water in the sensor connector could be causing the fault.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1852.

Last Modified: 25-May-2019


Exhaust Gas Recirculation Differential Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1866

Exhaust Gas Recirculation Differential Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1866 PID: P411 SPN: 411 FMI: 2/2 LAMP: Amber SRT: | An error in the EGR delta pressure signal was detected at initial key ON or the sensor failed the autozero test. | Possible reduced engine performance.
EGR Differential Pressure Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) differential pressure sensor has two ports that sense exhaust pressure. The sensor outputs a voltage which represents the pressure difference between the two ports located across an orifice in the EGR tube. The engine control module (ECM) uses this pressure to determine how much exhaust gas is flowing in the EGR connection tube to the intake manifold. This information is used to control the EGR valve for correct emission levels.The ECM provides a 5 volt supply to the EGR differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The EGR differential pressure sensor provides a signal to the ECM on the EGR differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure in the EGR crossover tube.The EGR differential pressure sensor measures the exhaust gas pressure drop across the EGR differential pressure orifice. This pressure drop is used to calculate the amount of EGR flow into the intake manifold.

Component Location

The EGR differential pressure sensor is mounted on the EGR mass measurement assembly.

Conditions for Running the Diagnostics

This diagnostic runs at key OFF when the following conditions are met:

Engine coolant temperature is 68Â°C [154Â°F] or higher.

Intake manifold air temperature is 7Â°C [44Â°F] or higher.

Keyswitch transitions from ON to OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR differential pressure sensor was reading higher or lower than a calibratable value when the keyswitch was turned OFF.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, first ensure the engine coolant temperature is above 70 °C or 158 °F. Operate the engine if necessary.
  • The keyswitch must be completely turned OFF for more than 30 seconds before this diagnostic will run at initial key ON.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.

Shop Talk

This check is only performed at keyswitch OFF, during the ECM powerdown. During this diagnostic check, the ECM monitors the value of the EGR differential pressure sensor. If this value is outside of a specified range, Fault Code 1866 is set active.

Possible causes of this fault code include:

A damaged EGR differential pressure sensor.

High resistance in the wiring harness on the signal or return wire.

Plugged or restricted EGR differential pressure sensor flow ports.

Refer to Troubleshooting Fault Code 1866.

Last Modified: 25-May-2019


Exhaust Gas Recirculation Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1867

Exhaust Gas Recirculation Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1867 PID: P412 SPN: 412 FMI: 2/2 LAMP: Amber SRT: | The EGR temperature sensor is reading an erratic value at initial key ON or while the engine is running. | Possible reduced engine performance.
EGR Temperature Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) temperature sensor is a variable resistor sensor and is used to measure the temperature of the EGR gas flow after it exits the EGR cooler. The engine control module (ECM) supplies 5 volts to the EGR temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the EGR flow temperature.

The EGR temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The EGR temperature sensor is located on the EGR connection tube between the EGR cooler and the air intake connection.

Conditions for Running the Diagnostics

This diagnostic consists of two parts. The first part runs when the keyswitch is turned to the ON position after a 8 hour cold soak, during which the keyswitch has been turned OFF. The second part runs continuously while the engine is running and EGR flow is above a calibratible value.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR temperature reading was too high or tool low for the operating conditions, or the EGR temperature reading was not changing with the operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Exhaust gas recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • If the fault code does not go inactive, it may be necessary to perform a 8 hour cold soak with the key OFF, then turn the keyswitch to the ON position so that the key ON portion of the diagnostic will run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Stuck in-range EGR temperature sensor

High resistance in the EGR temperature sensor signal or return wires.

Refer to Troubleshooting Fault Code 1867 .

Last Modified: 19-Jul-2020


Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 187

Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 187 PID: S211 SPN: 3510 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at the sensor supply number 2 circuit. | Possible reduced engine performance.
Sensor Supply 2 Circuit

Circuit Description

The sensor supply 2 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 2 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 2 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value is used for all of the sensors on the sensor supply 2 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Low voltage on the +5 volt supply line can be caused by a short circuit to ground in a supply line, a short circuit between a supply line and a return line, a malfunctioning sensor, or a malfunctioning ECM power supply.

Refer to Troubleshooting Fault Code 187.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Particulate Filter Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1879

Aftertreatment 1 Diesel Particulate Filter Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1879 PID: S324 SPN: 3251 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the aftertreatment differential pressure sensor circuit. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the aftertreatment diesel particulate filter differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The aftertreatment diesel particulate filter differential pressure sensor provides a signal to the ECM on the aftertreatment diesel particulate filter differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure across the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter differential pressure sensor is mounted on the diesel particulate filter. It is a combination sensor that detects both diesel particulate filter differential pressure and outlet pressure. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel particulate filter differential pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the aftertreatment diesel particulate filter differential pressure is used.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Exhaust gas recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.
  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 1879 .

Last Modified: 13-Oct-2021


Aftertreatment 1 Diesel Particulate Filter Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1881

Aftertreatment 1 Diesel Particulate Filter Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1881 PID: S324 SPN: 3251 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage or open circuit detected at the aftertreatment differential pressure sensor circuit. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the aftertreatment diesel particulate filter differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The aftertreatment diesel particulate filter differential pressure sensor provides a signal to the ECM on the aftertreatment diesel particulate filter differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure across the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter differential pressure sensor is mounted on the diesel particulate filter. It is a combination sensor that detects both diesel particulate filter differential pressure and outlet pressure. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel particulate filter differential pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the aftertreatment diesel particulate filter differential pressure is used.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Exhaust gas recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.
  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 1881 .

Last Modified: 13-Oct-2021


Aftertreatment 1 Diesel Particulate Filter Differential Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1883

Aftertreatment 1 Diesel Particulate Filter Differential Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1883 PID: S324 SPN: 3251 FMI: 2/2 LAMP: Amber SRT: | The aftertreatment diesel particulate filter differential pressure sensor is reading an erratic value. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the aftertreatment diesel particulate filter differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The aftertreatment diesel particulate filter differential pressure sensor provides a signal to the ECM on the aftertreatment diesel particulate filter differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure across the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter differential pressure sensor is mounted on the diesel particulate filter. It is a combination sensor that detects both diesel particulate filter differential pressure and outlet pressure. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic consists of two parts:

One part runs when the keyswitch is initially turned ON before the engine is started

The second part runs continuously while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel particulate filter differential pressure was greater than 1.5 kpa [0.44 in HG] at initial key ON, or is not changing with engine conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.
  • A default value for the aftertreatment diesel particulate filter differential pressure is used.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Exhaust gas recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • Turn the key switch OFF and allow the ECM to completely powerdown.
  • To validate the repair, perform a key cycle and leave the key in the ON position for 2 minutes. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Stuck in-range aftertreatment diesel particulate filter differential pressure sensor reading
  • High resistance in the aftertreatment diesel particulate filter differential pressure sensor signal or return wires
  • Disconnected or damaged aftertreatment diesel particulate filter differential pressure sensor tubes
  • Plugged aftertreatment differential pressure sensor ports could cause this fault code if pressure is held in the port after the engine is turned off.
  • Frozen, plugged, or restricted aftertreatment DPF differential pressure sensor tubes.
  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 1883 .

Last Modified: 13-Oct-2021


Aftertreatment 1 Intake NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1885

Aftertreatment 1 Intake NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1885 PID: SPN: 3216 FMI: 4/4 LAMP: Amber SRT: | An internal circuit error has been detected by the aftertreatment intake NOx sensor. | Possible reduced engine performance.
Aftertreatment Intake NOx Sensor Circuit

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the NOx emissions at the intake of the aftertreatment system.

Component Location

The aftertreatment intake NOx sensor is mounted on the engine near the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment diesel oxidation catalyst intake temperature sensor has been above 150°C [302°F] for 5 minutes while the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment intake NOx sensor assembly.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be severely reduced.

Vehicle speed will be limited to 8 km [5 mi] per hour after extended engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using the recommended Cummins electronic service tool or equivalent.
  • The aftertreatment diesel oxidation catalyst intake temperature must be above 150°C [302°F] for 5 minutes before the aftertreatment intake NOx sensor can run its internal diagnostics.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

The aftertreatment intake NOx sensor has malfunctioned or is damaged

The aftertreatment intake NOx sensor internal heater has malfunctioned

The NOx sensor part number is incorrect.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1885.

Last Modified: 25-May-2019


Aftertreatment 1 Outlet NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1887

Aftertreatment 1 Outlet NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1887 PID: SPN: 3226 FMI: 4/4 LAMP: Amber SRT: | An internal circuit error has been detected by the aftertreatment outlet NOx sensor. | Possible reduced engine performance.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR outlet temperature has been above 200°C [392° F] for a calibratible period of time while the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment outlet NOx sensor assembly.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using the recommended Cummins electronic service tool or equivalent.
  • The aftertreatment SCR outlet temperature must be above 200Â° C [392Â° F] for 60 seconds before the aftertreatment outlet NOx sensor can run its internal diagnostics.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

The aftertreatment outlet NOx sensor has malfunctioned or is damaged

The aftertreatment outlet NOx sensor internal heater has malfunctioned

The NOx sensor part number is incorrect.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1887.

Last Modified: 25-May-2019


VGT Actuator Driver Circuit - Abnormal Update Rate

FAULT CODE 1894

VGT Actuator Driver Circuit - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1894 PID: S27 SPN: 641 FMI: 9/9 LAMP: Amber SRT: | No communications on the J1939 data link between the engine ECM and the smart VGT controller. | Possible reduced engine performance.
VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports malfunctions back to the primary engine ECM, using the J1939 data link. The ECM then decodes the error message and converts it to a fault code.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a valid J1939 data link message from the Variable Geometry Turbocharger (VGT) actuator for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

VGT actuation will be disabled.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

The VGT actuator is not receiving power from the ECM. This can be caused by an open circuit in the power supply wire or low voltage supplied by the primary engine ECM.

  • Rapid cycling of the keyswitch

An open return circuit on the VGT actuator circuit

An open or short circuit on the J1939 data link circuit between the ECM and VGT actuator

Intermittent communications between the VGT actuator and the primary engine ECM on the J1939 data link

A damaged termination resistor in the engine data link harness

Refer to Troubleshooting Fault Code 1894.

Last Modified: 25-May-2019


EGR Valve Controller - Out of Calibration

FAULT CODE 1896

EGR Valve Controller - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1896 PID: S146 SPN: 2791 FMI: 13/13 LAMP: Amber SRT: | The EGR valve has failed the automatic calibration procedure at initial key ON. | Possible reduced engine performance.
EGR Valve Circuit

Circuit Description

The exhaust gas recirculation (EGR) valve is controlled by a brushless motor located on top of the EGR valve. The EGR valve motor uses three different motor legs to move the valve through its range of motion. The ECM uses the EGR motor A, B, and C wires to command the EGR valve to the appropriate position in order to meet EGR flow targets.The EGR valve motor contains three position sensors that detect the location of the EGR valve. These sensors report the position of the valve back to the ECM over the EGR valve position A, B, and C wires.

Component Location

The EGR Valve and EGR Differential Pressure Sensor location varies depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs at key OFF with coolant temperature above 85°C [185° F].

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR valve failed the autozero span check.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • Turn the key switch OFF and allow the ECM to completely powerdown.
  • Start and idle the engine for 1 minute
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will turn off the MIL after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When the keyswitch is initially turned ON and at various times during engine operation, the closed position of the EGR valve is checked. This diagnostic checks to make sure the EGR valve is not stuck open.

The EGR valve will close when the fault code is active. The fault code will remain active until the next key cycle.

The aftertreatment system must be inspected after making the appropriate repair outlined in this fault code troubleshooting tree. Progressive damage to the aftertreatment system may have occurred. Perform the Snap-Acceleration Test to check for a malfunctioning diesel particulate filter.

Refer to Troubleshooting Fault Code 1896.

Last Modified: 25-May-2019


VGT Actuator Controller - Bad Intelligent Device or Component

FAULT CODE 1897

VGT Actuator Controller - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1897 PID: S27 SPN: 641 FMI: 12/12 LAMP: Amber SRT: | An internal error has been detected by the smart VGT controller. | Possible reduced engine performance.
VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports malfunctions back to the primary engine ECM, using the J1939 data link. The ECM then decodes the error message and converts it to a fault code.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Variable Geometry Turbocharger (VGT) detected an internal error in the VGT smart device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

VGT actuation will be disabled.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is logged when the VGT smart actuator detected an internal error within the VGT actuator. The VGT actuator will stop controlling the turbocharger when this fault code is active.

Fault Code 1897 will become active if the VGT actuator is removed from the turbocharger and then the keyswitch is turned to the ON position; or it may be possible for it to become active if the actuator fails the install/calibrate procedure. If this occurs, disconnect the VGT actuator from the engine harness with the keyswitch ON, and connect the VGT actuator to the engine harness. Fault Code 1897 should go inactive. Follow the VGT actuator installation procedure to install the VGT actuator.

Refer to Troubleshooting Fault Code 1897.

Last Modified: 25-May-2019


VGT Actuator Controller - Out of Calibration

FAULT CODE 1898

VGT Actuator Controller - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1898 PID: S27 SPN: 641 FMI: 13/13 LAMP: Amber SRT: | The VGT has failed the automatic calibration procedure at initial key ON. | Possible reduced engine performance.
VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports malfunctions back to the primary engine ECM, using the J1939 data link. The ECM then decodes the error message and converts it to a fault code.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs 5 minutes after engine start up if coolant temperature is greater than 71Â°C [160Â°F].

Conditions for Setting the Fault Codes

The internal position reference was not detected during the Engine Control Module (ECM) commanded span check due to mechanical system binding or internal condition. The actual VGT actuator position was not known.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

VGT actuation will be disabled.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is logged when one of the following error conditions exists.

The gear alignment between the actuator and the turbocharger housing is misaligned.

Foreign material in the VGT turbocharger can prevent the sliding nozzle from moving to the desired position.

Refer to Troubleshooting Fault Code 1898.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1921

Aftertreatment 1 Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1921 PID: S324 SPN: 3251 FMI: 0/16 LAMP: Amber SRT: | The soot load of the aftertreatment diesel particulate filter has exceeded the recommended limits. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit

Circuit Description

The engine aftertreatment system monitors the soot load in the aftertreatment diesel particulate filter. Under normal operating conditions, the aftertreatment diesel particulate filter is self-cleaning, where soot is converted to carbon dioxide, nitrogen, and water. Under light load operating conditions, it can be necessary to perform a stationary regeneration of the aftertreatment diesel particulate filter. The soot load in the aftertreatment diesel particulate filter is estimated, using the aftertreatment differential pressure sensor and the calculated soot output of the engine.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the soot load of the aftertreatment diesel particulate filter was moderately severe. The aftertreatment system needs to be regenerated to remove the soot.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The ECM will flash the aftertreatment lamp immediately after the diagnostic fails.

  • Torque output of the engine will be reduced as the soot load in the aftertreatment diesel particulate filter increases.

Mobile regeneration of the diesel particulate filter will be disabled.

  • Exhaust gas recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • After completing a stationary regeneration (as instructed in this fault code troubleshooting tree) and no additional faults become active, the repair has been validated.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Note: Repeated occurrences of this fault code may indicate the engine requires frequent regeneration. Refer to symptom tree t147 (Aftertreatment Diesel Particulate Filter-Excessive Automatic and/or Stationary Regeneration) to identify the cause of frequent regeneration.

Possible causes of this fault code include:

  • The engine has been operating in a light load condition that prevents exhaust temperatures from being high enough to actively regenerate the aftertreatment diesel particulate filter.

Possible engine damage that causes excessive black soot to be generated.

  • Excessive ash in the DPF

If Fault Code 2777 is active along with Fault Code 1921, this indicates that a regeneration inhibit message has been received by the engine ECM and that active regeneration of the aftertreatment diesel particulate filter was not permitted. Confirm that OEM settings for the aftertreatment permit switch are configured correctly. A stationary regeneration of the aftertreatment diesel particulate filter can be performed. Use the recommended Cummins® electronic service tool or equivalent.

Refer to Troubleshooting Fault Code 1921 .

Last Modified: 13-Oct-2021


Aftertreatment 1 Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 1922

Aftertreatment 1 Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1922 PID: S324 SPN: 3251 FMI: 0/0 LAMP: Red SRT: | The soot load of the aftertreatment diesel particulate filter has exceeded the recommended limits. Engine protection derate is enabled. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit

Circuit Description

The engine aftertreatment system monitors the soot load in the aftertreatment diesel particulate filter. Under normal operating conditions, the aftertreatment diesel particulate filter is self-cleaning, where soot is converted to carbon dioxide, nitrogen, and water. Under light load operating conditions, it can be necessary to perform a stationary regeneration of the aftertreatment diesel particulate filter. The soot load in the aftertreatment diesel particulate filter is estimated, using the aftertreatment differential pressure sensor and the calculated soot output of the engine.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the soot load of the aftertreatment diesel particulate filter had exceeded the maximum operating limits.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Torque output of the engine will be reduced as the soot load in the aftertreatment diesel particulate filter increases.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Exhaust gas recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Note: Repeated occurrences of this fault code may indicate the engine requires frequent regeneration. Refer to symptom tree t147 (Aftertreatment Diesel Particulate Filter-Excessive Automatic and/or Stationary Regeneration) to identify the cause of frequent regeneration.

Possible causes of this fault code include:

  • The aftertreatment wiring harness or the aftertreatment temperature sensor connector pin installation may be incorrect.
  • The engine has been operating in a light load condition that prevents exhaust temperatures from being high enough to actively regenerate the aftertreatment diesel particulate filter.
  • A possible base engine malfunction that causes excessive black soot to be generated.
  • Excessive ash in the DPF

If both Fault Code 1921 and 2777 are inactive with an active Fault Code 1922, this indicates that a regeneration inhibit message has been received by the engine ECM and that active regeneration of the aftertreatment diesel particulate filter was not allowed. Use the OEM manuals to confirm that the OEM settings for the aftertreatment permit switch are configured correctly.

Refer to Troubleshooting Fault Code 1922 .

Last Modified: 13-Oct-2021


Aftertreatment Fuel Shutoff Valve Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1923

Aftertreatment Fuel Shutoff Valve Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1923 PID: S334 SPN: 3482 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the aftertreatment fuel shutoff valve circuit. | Possible reduced engine performance.
Aftertreatment Fuel Shutoff Valve Circuit

Circuit Description

The aftertreatment fuel shutoff valve is used to disable the fuel supply to the aftertreatment system.

Component Location

The aftertreatment fuel injector is installed in the exhaust system in the turbocharger adapter pipe. The aftertreatment fuel pressure sensor and aftertreatment fuel shutoff valve are installed in the shutoff valve manifold. The aftertreatment purge air actuator is located above the shutoff valve manifold.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment fuel shutoff valve is commanded on.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment fuel shutoff valve pulse width modulated (PWM) signal was at system voltage when the pulse width modulated (PWM) signal was commanded OFF.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Active regeneration of the aftertreatment diesel particulate filter will be disabled unitl the next key cycle.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and perform the recommended Cummins electronic service tool or equivalent Aftertreatment Diesel Particulate Filter Regeneration Test.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Fuel shutoff valve signal wire shorted to a voltage source in the harness

A damaged aftertreatment fuel shutoff valve.

Refer to Troubleshooting Fault Code 1923.

Last Modified: 25-May-2019


Aftertreatment Fuel Shutoff Valve Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1924

Aftertreatment Fuel Shutoff Valve Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1924 PID: S334 SPN: 3482 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the aftertreatment fuel shutoff valve circuit. | Possible reduced engine performance.
Aftertreatment Fuel Shutoff Valve Circuit

Circuit Description

The aftertreatment fuel shutoff valve is used to disable the fuel supply to the aftertreatment system.

Component Location

The aftertreatment fuel injector is installed in the exhaust system in the turbocharger adapter pipe. The aftertreatment fuel pressure sensor and aftertreatment fuel shutoff valve are installed in the shutoff valve manifold. The aftertreatment purge air actuator is located above the shutoff valve manifold.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment fuel shutoff valve is commanded off.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment fuel shutoff valve pulse width modulated (PWM) signal was NOT at system voltage when the pulse width modulated (PWM) signal was commanded ON.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Active regeneration of the aftertreatment diesel particulate filter will be disabled unitl the next key cycle.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Open return circuit in the engine harness, connectors, or shutoff valve.

A short circuit to ground in the engine harness, connectors, or shutoff valve.

A shorted aftertreatment fuel shutoff valve.

Refer to Troubleshooting Fault Code 1924.

Last Modified: 25-May-2019


Aftertreatment Fuel Shutoff Valve - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1925

Aftertreatment Fuel Shutoff Valve - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1925 PID: S334 SPN: 3482 FMI: 2/2 LAMP: Amber SRT: | An error has been detected in the aftertreatment fuel shutoff valve or the aftertreatment fuel injector system. | Possible reduced engine performance.
Aftertreatment Fuel Injection System

Circuit Description

Before active regeneration of the aftertreatment diesel particulate filter, a diagnostic test on the system is performed. The aftertreatment fuel injector opens and relieves fuel pressure in the line. The aftertreatment fuel pressure sensor must be reading atmospheric pressure at this point in the test. The aftertreatment fuel injector closes and the aftertreatment purge air actuator opens. This pressurizes the aftertreatment fuel system to vehicle air pressure. The diagnostic then checks to make sure the aftertreatment fuel pressure sensor is reading vehicle air pressure. The aftertreatment fuel shutoff valve then opens and allows pressurized fuel to enter the system. The aftertreatment fuel injector then opens and primes the system by purging the air from the line. The aftertreatment fuel shutoff valve and aftertreatment fuel injector then close and trap the fuel between the aftertreatment fuel shutoff valve and the aftertreatment fuel injector. The diagnostic checks to make sure the system maintains fuel pressure.

Component Location

The aftertreatment fuel injector is installed in the exhaust system in the turbocharger adapter pipe. The aftertreatment fuel pressure sensor and aftertreatment fuel shutoff valve are installed in the shutoff valve manifold. The aftertreatment purge air actuator is located above the shutoff valve manifold.

Conditions for Running the Diagnostics

This diagnostic runs during active regeneration of the aftertreatment diesel particulate filter.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an internally leaking aftertreatment fuel shutoff valve, aftertreatment purge air actuator, or a stuck closed aftertreatment fuel injector.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Active regeneration of the aftertreatment diesel particulate filter will be disabled unitl the next key cycle.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and perform the recommended Cummins electronic service tool or equivalent Aftertreatment Diesel Particulate Filter Regeneration Test.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Internal leak of the aftertreatment fuel shutoff valve allowing fuel pressure to leak past the shutoff valve

Internal leak of the aftertreatment purge air actuator

Stuck closed, plugged, or clogged aftertreatment fuel injector.

Refer to Troubleshooting Fault Code 1925.

Last Modified: 25-May-2019


Aftertreatment Fuel Pressure Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1926

Aftertreatment Fuel Pressure Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1926 PID: S332 SPN: 3480 FMI: 2/2 LAMP: Amber SRT: | The ECM has detected that the aftertreatment fuel pressure signal is not changing with engine operating conditions. | Possible reduced engine performance.
Aftertreatment Fuel Pressure Sensor Circuit

Circuit Description

The aftertreatment fuel pressure sensor is used to monitor the fuel pressure into the aftertreatment system. The engine control module (ECM) supplies the aftertreatment fuel pressure sensor a 5 volt reference voltage. When the fuel pressure is low, the sensor signal voltage is low. When the fuel pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the aftertreatment fuel pressure signal circuit voltage to calculate the pressure of the fuel within the aftertreatment system.

Component Location

The aftertreatment fuel injector is installed in the exhaust system in the turbocharger adapter pipe. The aftertreatment fuel pressure sensor and aftertreatment fuel shutoff valve are installed in the shutoff valve manifold. The aftertreatment purge air actuator is located above the shutoff valve manifold.

Conditions for Running the Diagnostics

This diagnostic runs during active regeneration of the aftertreatment diesel particulate filter.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment fuel pressure sensor was reading an erratic value, or the aftertreatment fuel pressure reading was not changing with the engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the aftertreatment fuel pressure sensor reading is used.

Active regeneration of the aftertreatment diesel particulate filter will be disabled unitl the next key cycle.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and perform the recommended Cummins electronic service tool or equivalent Aftertreatment Diesel Particulate Filter Regeneration Test.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning in-range aftertreatment fuel pressure sensor

A plugged fuel filter

A malfunctioning fuel pump gear pump.

Refer to Troubleshooting Fault Code 1926.

Last Modified: 25-May-2019


Aftertreatment Fuel Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1927

Aftertreatment Fuel Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1927 PID: S332 SPN: 3480 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the aftertreatment fuel pressure sensor circuit. | Possible reduced engine performance.
Aftertreatment Fuel Pressure Sensor Circuit

Circuit Description

The aftertreatment fuel pressure sensor is used to monitor the fuel pressure into the aftertreatment system. The engine control module (ECM) supplies the aftertreatment fuel pressure sensor a 5 volt reference voltage. When the fuel pressure is low, the sensor signal voltage is low. When the fuel pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the aftertreatment fuel pressure signal circuit voltage to calculate the pressure of the fuel within the aftertreatment system.

Component Location

The aftertreatment fuel injector is installed in the exhaust system in the turbocharger adapter pipe. The aftertreatment fuel pressure sensor and aftertreatment fuel shutoff valve are installed in the shutoff valve manifold. The aftertreatment purge air actuator is located above the shutoff valve manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment fuel pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Active regeneration of the aftertreatment diesel particulate filter will be disabled unitl the next key cycle.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Open return circuit in the engine harness, connector, sensor

Signal wire shorted to sensor supply or battery voltage

A shorted sensor.

Refer to Troubleshooting Fault Code 1927.

Last Modified: 25-May-2019


Aftertreatment Fuel Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1928

Aftertreatment Fuel Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1928 PID: S332 SPN: 3480 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the aftertreatment fuel pressure sensor circuit. | Possible reduced engine performance.
Aftertreatment Fuel Pressure Sensor Circuit

Circuit Description

The aftertreatment fuel pressure sensor is used to monitor the fuel pressure into the aftertreatment system. The engine control module (ECM) supplies the aftertreatment fuel pressure sensor a 5 volt reference voltage. When the fuel pressure is low, the sensor signal voltage is low. When the fuel pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the aftertreatment fuel pressure signal circuit voltage to calculate the pressure of the fuel within the aftertreatment system.

Component Location

The aftertreatment fuel injector is installed in the exhaust system in the turbocharger adapter pipe. The aftertreatment fuel pressure sensor and aftertreatment fuel shutoff valve are installed in the shutoff valve manifold. The aftertreatment purge air actuator is located above the shutoff valve manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment fuel pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Active regeneration of the aftertreatment diesel particulate filter will be disabled unitl the next key cycle.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Open signal circuit in the engine harness, connector, sensor

Signal wire shorted to ground

A shorted sensor.

Refer to Troubleshooting Fault Code 1928.

Last Modified: 25-May-2019


Aftertreatment Doser - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1932

Aftertreatment Doser - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1932 PID: S382 SPN: 3556 FMI: 2/2 LAMP: Amber SRT: | An internal or external fuel leak has been detected in the aftertreatment fuel system. | Possible reduced engine performance.
Aftertreatment Fuel Injection System

Circuit Description

Before active regeneration of the aftertreatment diesel particulate filter, a diagnostic test on the system is performed. The aftertreatment fuel injector opens and relieves fuel pressure in the line. The aftertreatment fuel pressure sensor must be reading atmospheric pressure at this point in the test. The aftertreatment fuel injector closes and the aftertreatment purge air actuator opens. This pressurizes the aftertreatment fuel system to vehicle air pressure. The diagnostic then checks to make sure the aftertreatment fuel pressure sensor is reading vehicle air pressure. The aftertreatment fuel shutoff valve then opens and allows pressurized fuel to enter the system. The aftertreatment fuel injector then opens and primes the system by purging the air from the line. The aftertreatment fuel shutoff valve and aftertreatment fuel injector then close and trap the fuel between the aftertreatment fuel shutoff valve and the aftertreatment fuel injector. The diagnostic checks to make sure the system maintains fuel pressure.

Component Location

The aftertreatment fuel injector is installed in the exhaust system in the turbocharger adapter pipe. The aftertreatment fuel pressure sensor and aftertreatment fuel shutoff valve are installed in the shutoff valve manifold. The aftertreatment purge air actuator is located above the shutoff valve manifold.

Conditions for Running the Diagnostics

This diagnostic runs during active regeneration of the aftertreatment diesel particulate filter.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a leaking aftertreatment fuel injector or an external leak.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Active regeneration of the aftertreatment diesel particulate filter will be disabled unitl the next key cycle.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and perform the recommended Cummins electronic service tool or equivalent Aftertreatment Diesel Particulate Filter Regeneration Test.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A stuck open or leaking aftertreatment fuel injector

An external leak in the aftertreatment fuel injector system.

A leaking aftertreatment fuel shutoff manifold

Refer to Troubleshooting Fault Code 1932.

Last Modified: 25-May-2019


ECU Power Output Supply Voltage 1 - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 1938

ECU Power Output Supply Voltage 1 - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1938 PID: S212 SPN: 3597 FMI: 1/18 LAMP: Amber SRT: | Low battery voltage detected by the VGT actuator. | Possible reduced engine performance.
VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports malfunctions back to the primary engine ECM, using the J1939 data link. The ECM then decodes the error message and converts it to a fault code.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

Voltage supplied to the Variable Geometry Turbocharger (VGT) actuator dropped below 10-VDC for 10 seconds and the engine speed was at zero rpm or greater than 575 rpm.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is logged when the voltage to the VGT actuator drops below 10-VDC. The VGT will still continue to respond to commands from the primary engine ECM.

Refer to Troubleshooting Fault Code 1938.

Last Modified: 25-May-2019


Crankcase Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1942

Crankcase Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1942 PID: P101 SPN: 101 FMI: 2/2 LAMP: Amber SRT: | The ECM has detected that the crankcase pressure signal is reading an erratic value at initial key ON or during engine operation. | None on performance.
Engine Crankcase Pressure Sensor Circuit

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located near the crankcase ventilation element.

Conditions for Running the Diagnostics

This diagnostic consists of two parts. The first part of this diagnostic runs at initial key ON and the second part runs when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankcase pressure sensor was reading an erratic value at key ON or the crankcase pressure reading was not changing with engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code can be caused by a crankcase breather hose disconnected between the engine outlet and crankcase filter assembly on engines with an externally mounted crankcase filter option.

Possible causes of this fault code include:

Resistance in the wiring harness

A malfunctioning in-range pressure sensor

Crankcase pressure sensor is not installed correctly in the housing.

Refer to Troubleshooting Fault Code 1942.

Last Modified: 25-May-2019


Ambient Air Density - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 1943

Ambient Air Density - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1943 PID: S372 SPN: 3555 FMI: 1/17 LAMP: None SRT: | Engine torque has been reduced because the vehicle was operating at a high altitude condition. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) monitors the ambient air pressure using either an ambient air pressure sensor or a combination turbocharger compressor intake pressure/temperature sensor. These sensors respond to pressure changes in the atmosphere, which occur based on the elevation where the engine is currently operating. This pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit. The ambient air or compressor intake pressure sensor provides a signal to the ECM on the pressure sensor signal circuit. This sensor signal voltage changes based on the pressure of the atmosphere. The ECM will detect a low signal voltage when the vehicle is operating at high altitudes. The ECM will detect a high signal voltage when the vehicle is operating at sea level altitudes.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness near the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the barometric air pressure reading was less than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Engine torque output will be limited due to the engine operating at high altitude conditions.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When the engine has been operated in a high altitude location, this fault code is logged. This fault code is for information only and no repairs are necessary. The engine can possibly be derated when operating in the high altitude location to protect the turbocharger and engine from excessively high exhaust temperatures. The derate limits the torque output of the engine to keep the temperatures below the maximum temperature limits.

Note: This fault code will most likely not be active with no load in the shop. The engine must be under the same operating condition (altitude and temperature) at the time that it had originally logged.

Refer to Troubleshooting Fault Code 1943.

Last Modified: 25-May-2019


Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 195

Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 195 PID: P111 SPN: 111 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the engine coolant level circuit. | None on performance.
Engine Coolant Level Sensor Circuit - 3 Wire Sensor
Engine Coolant Level Sensor Circuit - 2 Wire Sensor

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

No engine protection will be available for low coolant level.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A short circuit to battery in the OEM harness

An open circuit in the OEM harness

A malfunctioning engine coolant level sensor

Refer to Troubleshooting Fault Code 195.

Last Modified: 25-May-2019


Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 196

Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 196 PID: P111 SPN: 111 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the engine coolant level circuit. | None on performance.
Engine Coolant Level Sensor Circuit - 3 Wire Sensor
Engine Coolant Level Sensor Circuit - 2 Wire Sensor

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

No engine protection will be available for low coolant level.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A short circuit to ground in the OEM harness

An open circuit in the OEM harness

A malfunctioning engine coolant level sensor

Refer to Troubleshooting Fault Code 196.

Last Modified: 25-May-2019


EGR Valve Control Circuit Over Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 1961

EGR Valve Control Circuit Over Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1961 PID: S146 SPN: 2791 FMI: 0/15 LAMP: Amber SRT: | High EGR valve driver temperature has been detected. | Possible reduced engine performance.
EGR Valve Circuit

Circuit Description

The exhaust gas recirculation (EGR) valve is controlled by a brushless motor located on top of the EGR valve. The EGR valve motor uses three different motor legs to move the valve through its range of motion. The ECM uses the EGR motor A, B, and C wires to command the EGR valve to the appropriate position in order to meet EGR flow targets.The EGR valve motor contains three position sensors that detect the location of the EGR valve. These sensors report the position of the valve back to the ECM over the EGR valve position A, B, and C wires.

The EGR valve motor contains three position sensors that detect the location of the EGR valve. These sensors report the position of the valve back to the ECM over the EGR valve position A, B, and C wires.

Component Location

The EGR valve device driver is internal to the ECM and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the temperature of the EGR valve driver internal to the ECM was greater than 150Â°C [302Â°F].

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code may be inactive when the vehicle is in the shop because the EGR valve driver temperature has cooled down. Therefore, troubleshoot multiple inactive counts of this fault code as an active fault code.

Possible causes of this fault code include:

Malfunctioning ECM.

Refer to Troubleshooting Fault Code 1961.

Last Modified: 25-May-2019


VGT Actuator Driver Over Temperature (Calculated) - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 1962

VGT Actuator Driver Over Temperature (Calculated) - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1962 PID: S27 SPN: 641 FMI: 0/15 LAMP: Amber SRT: | High internal VGT actuator temperature has been detected. | None on performance.
VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports malfunctions back to the primary engine ECM, using the J1939 data link. The ECM then decodes the error message and converts it to a fault code.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The internal temperature of the Variable Geometry Turbocharger (VGT) actuator exceeded 125Â°C [257Â°F] continuously for 30 minutes.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code will be inactive when the vehicle is in the shop because the VGT actuator temperature has cooled down. Troubleshoot multiple inactive counts of this fault code as an active fault code.

Also check for exhaust leaks blowing on the VGT actuator. Repair any external leaks.

Refer to Troubleshooting Fault Code 1962.

Last Modified: 25-May-2019


Aftertreatment Fuel Shutoff Valve - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 1963

Aftertreatment Fuel Shutoff Valve - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1963 PID: S332 SPN: 3482 FMI: 7/7 LAMP: Amber SRT: | The aftertreatment fuel shutoff valve has been detected to be stuck closed. | Possible reduced engine performance.
Aftertreatment Fuel Injection System

Circuit Description

Before active regeneration of the aftertreatment diesel particulate filter, a diagnostic test on the system is performed. The aftertreatment fuel injector opens and relieves fuel pressure in the line. The aftertreatment fuel pressure sensor must be reading atmospheric pressure at this point in the test. The aftertreatment fuel injector closes and the aftertreatment purge air actuator opens. This pressurizes the aftertreatment fuel system to vehicle air pressure. The diagnostic then checks to make sure the aftertreatment fuel pressure sensor is reading vehicle air pressure. The aftertreatment fuel shutoff valve then opens and allows pressurized fuel to enter the system. The aftertreatment fuel injector then opens and primes the system by purging the air from the line. The aftertreatment fuel shutoff valve and aftertreatment fuel injector then close and trap the fuel between the aftertreatment fuel shutoff valve and the aftertreatment fuel injector. The diagnostic checks to make sure the system maintains fuel pressure.

Component Location

The aftertreatment fuel injector is installed in the exhaust system in the turbocharger adapter pipe. The aftertreatment fuel pressure sensor and aftertreatment fuel shutoff valve are installed in the shutoff valve manifold. The aftertreatment purge air actuator is located above the shutoff valve manifold.

Conditions for Running the Diagnostics

This diagnostic runs during active regeneration of the aftertreatment diesel particulate filter.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment fuel pressure sensor was reading lower than a calibratible threshold when the aftertreatment fuel shutoff valve was commanded open.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Active regeneration of the aftertreatment diesel particulate filter will be disabled unitl the next key cycle.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and perform the recommended Cummins electronic service tool or equivalent Aftertreatment Diesel Particulate Filter Regeneration Test.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Stuck closed aftertreatment fuel shutoff valve

A missing or leaking fuel supply line to the aftertreatment fuel shutoff manifold

A plugged fuel filter

A malfunctioning fuel pump gear pump.

Refer to Troubleshooting Fault Code 1963.

Last Modified: 25-May-2019


Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 197

Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 197 PID: P111 SPN: 111 FMI: 1/18 LAMP: Amber SRT: | Low engine coolant level detected. | Possible reduced engine performance.
Engine Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level sensor signal voltage was higher than 3-VDC for more than 30 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The torque output of the engine will be reduced.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code goes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant.

If this fault code is active and the coolant level is not low, disconnect the coolant level sensor and check the connectors for traces of coolant. If coolant is found at the electrical connectors, the sensor has malfunctioned and must be replaced.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 197.

Last Modified: 25-May-2019


Crankcase Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 1974

Crankcase Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1974 PID: P101 SPN: 101 FMI: 0/15 LAMP: Maintenance SRT: | The crankcase breather filter requires maintenance. | None on performance.
Crankcase Pressure Sensor Circuit

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located near the crankcase ventilation element.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected the crankcase pressure in the breather tube was greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • Use the recommended Cummins electronic service tool or equivalent "Data Monitor/Logger" feature to monitor Crankcase Pressure with the engine running at idle. If the crankcase pressure reading is below 7.0 in H20, the repair has been validated.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

If this fault code is active, the crankcase breather system may need to be inspected.

Refer to Troubleshooting Fault Code 1974.

Last Modified: 25-May-2019


VGT Actuator Driver Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 1976

VGT Actuator Driver Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1976 PID: S27 SPN: 641 FMI: 0/15 LAMP: None SRT: | High internal VGT actuator temperature has been detected. | None on performance.
VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports malfunctions back to the primary engine ECM, using the J1939 data link. The ECM then decodes the error message and converts it to a fault code.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The internal temperature of the Variable Geometry Turbocharger (VGT) actuator exceeded 125Â°C [257Â°F] continuously for 30 minutes.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code will be inactive when the vehicle is in the shop because the VGT actuator temperature has cooled down. Troubleshoot multiple inactive counts of this fault code as an active fault code.

Also check for exhaust leaks blowing on the VGT actuator. Repair any external leaks.

Refer to Troubleshooting Fault Code 1976.

Last Modified: 25-May-2019


Aftertreatment Doser Circuit - Current Below Normal or Open Circuit

FAULT CODE 1977

Aftertreatment Doser Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1977 PID: S382 SPN: 3556 FMI: 5/5 LAMP: Amber SRT: | High resistance, short circuit, or open circuit detected on the aftertreatment fuel injector circuit. | Possible reduced engine performance.
Aftertreatment Fuel Injector Circuit

Circuit Description

The aftertreatment fuel injector is electronically controlled by the engine electronic control module (ECM) through a pulse width modulated (PWM) signal. The amount of fuel injected is determined by how long the PWM signal to the injector is on.

Component Location

The aftertreatment fuel injector is installed in the exhaust system in the turbocharger adapter pipe. The aftertreatment fuel pressure sensor and aftertreatment fuel shutoff valve are installed in the shutoff valve manifold. The aftertreatment purge air actuator is located above the shutoff valve manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error within the aftertreatment fuel injector circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Active regeneration of the aftertreatment diesel particulate filter will be disabled unitl the next key cycle.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and perform the recommended Cummins electronic service tool or equivalent Aftertreatment Diesel Particulate Filter Regeneration Test.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

An open circuit in the supply or return wire in the engine harness

An open circuit in the aftertreatment fuel injector solenoid

A short circuit to ground in the engine harness

A short circuit to voltage source in the engine harness

High resistance in the aftertreatment fuel injector solenoid

An extremely low resistance in the aftertreatment fuel injector solenoid

A damaged ECM.

Refer to Troubleshooting Fault Code 1977.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Particulate Filter System - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 1981

Aftertreatment 1 Diesel Particulate Filter System - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1981 PID: SPN: 3936 FMI: 0/15 LAMP: Amber SRT: | The aftertreatment differential pressure has exceeded the maximum operating limits or the diesel particulate filter is plugged. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit

Circuit Description

The engine aftertreatment system monitors the soot load in the aftertreatment diesel particulate filter. Under normal operating conditions, the aftertreatment diesel particulate filter is self-cleaning, where soot is converted to carbon dioxide, nitrogen, and water. Under light load operating conditions, it can be necessary to perform a stationary regeneration of the aftertreatment diesel particulate filter. The soot load in the aftertreatment diesel particulate filter is estimated, using the aftertreatment differential pressure sensor and the calculated soot output of the engine.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the diesel particulate filter is plugged or that the differential pressure across the diesel particulate filter was greater than the maximum limits.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and run at high idle for 6 minutes.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

The aftertreatment diesel particulate filter can be plugged with ash.

The engine has been operating in light load conditions that prevent exhaust gas temperatures from being high enough to actively regenerate the aftertreatment particulate trap.

An engine malfunction that is elevating the engine smoke output.

Excessive ash in the DPF

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1981.

Last Modified: 25-May-2019


Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 212

Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 212 PID: P175 SPN: 175 FMI: 3/3 LAMP: Amber SRT: | High signal voltage or an open circuit detected at the engine oil temperature circuit. | None on performance.
Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil. The engine control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature.

Component Location

The engine oil temperature sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the engine oil temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The engine oil temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor

Open signal circuit or shorted to a voltage source.

Refer to Troubleshooting Fault Code 212.

Last Modified: 25-May-2019


Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 213

Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 213 PID: P175 SPN: 175 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the engine oil temperature circuit. | None on performance.
Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil. The engine control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature.

Component Location

The engine oil temperature sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the engine oil temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Signal shorted to ground in the engine harness

Signal shorted to return or ground in the sensor.

Refer to Troubleshooting Fault Code 213.

Last Modified: 25-May-2019


Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 214

Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 214 PID: P175 SPN: 175 FMI: 0/0 LAMP: Red SRT: | Engine oil temperature signal indicates engine oil temperature above engine protection critical limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil. The engine control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature.

Component Location

The engine oil temperature sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil temperature was greater than the maximum engine protection limit for 5 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The torque output of the engine will be reduced.

Maximum engine operating speed will be decreased.

The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates that the engine oil temperature has exceeded the maximum engine protection limit for oil temperature. Troubleshoot the cause of high engine oil temperature.

Refer to Troubleshooting Fault Code 214.

Last Modified: 25-May-2019


Engine Brake Actuator Driver 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2182

Engine Brake Actuator Driver 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2182 PID: S79 SPN: 1072 FMI: 3/3 LAMP: Amber SRT: | High voltage or an open circuit detected at the engine brake solenoid number 1 signal circuit. | Possible reduce engine braking performance.
Engine Brake Actuator Dirver 1 Circuit

Circuit Description

The Engine Control Module (ECM) controls engine brakes on cylinders 1, 2, and 3 by sending a signal on the engine brake solenoid number 1 signal circuit. If an engine brake is installed, there will be a jumper harness from this connector to the engine brake pass-through connectors on the rocker lever housing.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake solenoids are controlled through the engine harness by the ECM.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine brake 1 pulse width modulated (PWM) signal was detected to be greater than 0 volts when the PWM signal was turned off by the ECM.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The engine brake 1 circuit will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, drive the vehicle and operate the engine brakes. This will allow the diagnostic to run. If the fault code does not become active again, the repair has been validated.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A short circuit to battery in the engine harness.

A malfunctioning engine brake solenoid

Refer to Troubleshooting Fault Code 2182.

Last Modified: 25-May-2019


Engine Brake Actuator Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2183

Engine Brake Actuator Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2183 PID: S79 SPN: 1072 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at the engine brake solenoid number 1 signal circuit. | Possible reduce engine braking performance.
Engine Brake Actuator Driver 1 Circuit

Circuit Description

The Engine Control Module (ECM) controls engine brakes on cylinders 1, 2, and 3 by sending a signal on the engine brake solenoid number 1 signal circuit. If an engine brake is installed, there will be a jumper harness from this connector to the engine brake pass-through connectors on the rocker lever housing.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake solenoids are controlled through the engine harness by the ECM.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine brake 1 pulse width modulated (PWM) signal was not detected to be system voltage when the PWM signal was turned on.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The engine brake 1 circuit will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, drive the vehicle and operate the engine brakes. This will allow the diagnostic to run. If the fault code does not become active again, the repair has been validated.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A short circuit to ground in the engine harness

A malfunctioning engine brake solenoid

Refer to Troubleshooting Fault Code 2183.

Last Modified: 25-May-2019


Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2185

Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2185 PID: S232 SPN: 3512 FMI: 3/3 LAMP: Amber SRT: | High voltage detected at 5 VDC sensor supply circuit to the accelerator pedal position sensor. | Engine will only idle.
Sensor Supply 4 Circuit

Circuit Description

Sensor supply 4 of the engine control module (ECM) provides a 5 VDC supply to the accelerator pedal position sensor.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 4 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The engine will only idle.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code can be caused by a short circuit to a voltage source in the OEM harness or a short circuit to an actuator signal circuit that is greater than 5-VDC.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 2185.

Last Modified: 25-May-2019


Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2186

Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2186 PID: S232 SPN: 3512 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at the 5 VDC sensor supply circuit to the accelerator pedal position sensor. | Engine will only idle.
Sensor Supply 4 Circuit

Circuit Description

Sensor supply 4 of the engine control module (ECM) provides a 5 VDC supply to the accelerator pedal position sensor.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 4 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The engine will only idle.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Low voltage on the 5 VDC supply wire can be caused by a short circuit to ground in the supply wire, a short circuit between the supply wire and return circuit, a malfunctioning accelerator, or a malfunctioning ECM power supply.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 2186.

Last Modified: 25-May-2019


Intake Manifold 1 Pressure Sensor - Condition Exists

FAULT CODE 2191

Intake Manifold 1 Pressure Sensor - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2191 PID: P102 SPN: 102 FMI: 11/31 LAMP: Amber SRT: | The intake manifold pressure sensor is reading an erratic value. | Possible reduced engine performance.
Engine Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic consists of two parts:

One part runs immediately after the keyswitch is turned OFF, and the engine coolant temperature is above 70Â°C or 158Â°F.

The second part occurs when the engine is operating.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure sensor was reading higher or lower than expected at keyoff or during normal engine operation.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value of the intake manifold pressure reading is used.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, first ensure the engine coolant temperature is above 70 °C or 158 °F. Operate the engine if necessary.
  • Cycle the keyswitch to the ON position for 30 seconds, then cycle the keyswitch to the OFF position for 30 seconds. Start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This diagnostic consists of two parts. At key OFF, the sensor readings for intake manifold pressure, barometric air pressure, oil pressure (if available), and exhaust gas pressure are compared to each other. This fault code occurs if the intake manifold pressure sensor reading is different from the other sensor readings. This check is only done once after the keyswitch is turned OFF. This fault can also be set active when the intake manifold pressure is too high or low for the current engine operating conditions when the engine is running. The ECM compares the intake manifold pressure reading to turbocharger speed to determine if the pressure reading is valid.

Possible causes of this fault are:

A damaged intake manifold pressure sensor

Refer to Troubleshooting Fault Code 2191.

Last Modified: 25-May-2019


VGT Actuator Driver Circuit - Root Cause Not Known

FAULT CODE 2198

VGT Actuator Driver Circuit - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2198 PID: S27 SPN: 641 FMI: 11/11 LAMP: Amber SRT: | Intermittent communication between the smart VGT controller and the ECM has been detected. The VGT controller is not interpreting the J1939 message from the ECM correctly. | Possible reduced engine performance.
VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports malfunctions back to the primary engine ECM, using the J1939 data link. The ECM then decodes the error message and converts it to a fault code.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Variable Geometry Turbocharger (VGT) actuator did not receive a valid J1939 data link message from the Engine Control Module (ECM) for 4 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

VGT actuation will be disabled.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Intermittent J1939 data link connections or interference on the J1939 network are possible causes of this fault code. Also check for intermittent power supply and ground connections to the VGT actuator.

Refer to Troubleshooting Fault Code 2198.

Last Modified: 25-May-2019


Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 221

Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 221 PID: P108 SPN: 108 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at barometric pressure circuit. | Possible reduced engine performance.
Barometric Pressure Sensor Circuit

Circuit Description

The barometric pressure sensor responds to pressure changes in the atmospheric pressure. The pressure changes occur based on the elevation where the engine is presently operating. The barometric pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness near the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the barometric air pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the barometric pressure reading is used.

Exhaust gas recirculation (EGR) valve operation will be disabled.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A short circuit to battery in the engine harness.

An open return circuit in the engine harness

A malfunctioning barometric air pressure sensor

A malfunctioning engine control module (ECM)

Refer to Troubleshooting Fault Code 221.

Last Modified: 25-May-2019


Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 222

Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 222 PID: P108 SPN: 108 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at barometric pressure circuit. | Possible reduced engine performance.
Barometric Pressure Sensor Circuit

Circuit Description

The barometric pressure sensor responds to pressure changes in the atmospheric pressure. The pressure changes occur based on the elevation where the engine is presently operating. The barometric pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness near the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the barometric air pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the barometric pressure reading is used.

Exhaust gas recirculation (EGR) valve operation will be disabled.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A short circuit to ground in the engine harness

An open circuit in the engine harness

A malfunctioning barometric air pressure sensor

A malfunctioning engine control module (ECM)

Refer to Troubleshooting Fault Code 222.

Last Modified: 25-May-2019


Fuel Level (Main Tank) Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2222

Fuel Level (Main Tank) Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2222 PID: P96 SPN: 96 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the fuel level sensor circuit. | None on performance.
Engine Control Module

Circuit Description

The fuel level sensor is used to monitor the amount of diesel fuel in the vehicle's fuel tank(s).

Component Location

The fuel level sensor is an OEM component. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel level sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A short circuit to voltage source in the OEM harness

An open circuit in the OEM harness

A malfunctioning fuel level sensor

Refer to Troubleshooting Fault Code 2222.

Last Modified: 25-May-2019


Fuel Level (Main Tank) Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2223

Fuel Level (Main Tank) Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2223 PID: P96 SPN: 96 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the fuel level sensor circuit. | None on performance.
Engine Control Module

Circuit Description

The fuel level sensor is used to monitor the amount of diesel fuel in the vehicle's fuel tank(s).

Component Location

The fuel level sensor is an OEM component. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel level sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

An open circuit in the OEM harness

A short circuit to ground in the OEM harness

A malfunctioning fuel level sensor

Many vehicles are equipped with a multiplexed fuel level sensor. Be sure to check the features and parameter settings are correct for the vehicle configuration.

Refer to Troubleshooting Fault Code 2223.

Last Modified: 25-May-2019


Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2265

Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2265 PID: S126 SPN: 1075 FMI: 3/3 LAMP: Amber SRT: | High voltage or open circuit detected at the fuel lift pump signal circuit. | Engine may not start or may be difficult to start.
Engine Fuel Lift Pump Supply Circuit

Circuit Description

The fuel lift pump circuit is a discrete output in the engine control module (ECM) that controls the electric fuel lift pump. The lift pump is grounded in the ECM.

Component Location

The fuel lift pump is mounted on the intake side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and the lift pump timer has expired 1 minute after initial key ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel lift pump signal circuit was detected to be greater than 0-VDC when the signal was turned off by the engine control module (ECM).

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • Perform a key cycle, and leave the key switch in the ON position for at least 2 minutes.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

An open circuit in the engine harness

A short circuit to battery in the engine harness.

A malfunctioning fuel lift pump

Refer to Troubleshooting Fault Code 2265.

Last Modified: 25-May-2019


Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2266

Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2266 PID: S126 SPN: 1075 FMI: 4/4 LAMP: Amber SRT: | High voltage or open circuit detected at the fuel lift pump signal circuit. | Engine may not start or may be difficult to start.
Engine Lift Pump Supply Circuit

Circuit Description

The fuel lift pump circuit is a discrete output in the engine control module (ECM) that controls the electric fuel lift pump. The lift pump is grounded in the ECM.

Component Location

The fuel lift pump is mounted on the intake side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is initially turned to the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel lift pump signal circuit was detected to be 0-VDC when the signal is turned ON by the engine control module (ECM).

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A short circuit to ground in the engine harness

A malfunctioning fuel lift pump

Refer to Troubleshooting Fault Code 2266.

Last Modified: 25-May-2019


Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 227

Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 227 PID: S211 SPN: 3510 FMI: 3/3 LAMP: Amber SRT: | High voltage detected at sensor supply number 2 circuit. | Possible reduced engine performance.
Sensor Supply 2 Circuit

Circuit Description

The sensor supply 2 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 2 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 2 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value is used for all of the sensors on the sensor supply 2 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

High voltage on the (+) 5 volt supply line can be caused by a short to battery voltage in the engine harness or connectors, or a malfunctioning ECM.

Refer to Troubleshooting Fault Code 227.

Last Modified: 25-May-2019


EGR Valve Position Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2272

EGR Valve Position Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2272 PID: P27 SPN: 27 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage has been detected at the EGR valve position sensor circuit. | Possible reduced engine performance.
EGR Valve Position Circuit

Circuit Description

The exhaust gas recirculation (EGR) valve is controlled by a brushless motor located on top of the EGR valve. The EGR valve motor uses three different motor legs to move the valve through its range of motion. The ECM uses the EGR motor A, B, and C wires to command the EGR valve to the appropriate position in order to meet EGR flow targets.The EGR valve motor contains three position sensors that detect the location of the EGR valve. These sensors report the position of the valve back to the ECM over the EGR valve position A, B, and C wires.

The EGR valve motor contains three position sensors that detect the location of the EGR valve. These sensors report the position of the valve back to the ECM over the EGR valve position A, B, and C wires.

Component Location

The EGR valve position sensor is internal to the EGR valve assembly and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR valve position sensor signal voltage was less than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

EGR valve position sensor wiring shorted to ground, open circuit, or shorted to power supply.

Loss of the EGR valve position sensor supply voltage or the ground circuit.

Refer to Troubleshooting Fault Code 2272.

Last Modified: 25-May-2019


Exhaust Gas Recirculation Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2273

Exhaust Gas Recirculation Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2273 PID: P411 SPN: 411 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the EGR differential pressure sensor circuit. | Possible reduced engine performance.
EGR Differential Pressure Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) differential pressure sensor has two ports that sense exhaust pressure. The sensor outputs a voltage which represents the pressure difference between the two ports located across an orifice in the EGR tube. The engine control module (ECM) uses this pressure to determine how much exhaust gas is flowing in the EGR connection tube to the intake manifold. This information is used to control the EGR valve for correct emission levels.The ECM provides a 5 volt supply to the EGR differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The EGR differential pressure sensor provides a signal to the ECM on the EGR differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure in the EGR crossover tube.The EGR differential pressure sensor measures the exhaust gas pressure drop across the EGR differential pressure orifice. This pressure drop is used to calculate the amount of EGR flow into the intake manifold.

Component Location

The EGR differential pressure sensor is mounted on the EGR mass measurement assembly.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR differential pressure signal voltage was greater than 4.8-VDC for more than 8 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the EGR differential pressure sensor is used.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor

A signal wire shorted to sensor supply or battery voltage

A damaged EGR differential pressure sensor.

Refer to Troubleshooting Fault Code 2273.

Last Modified: 25-May-2019


Exhaust Gas Recirculation Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2274

Exhaust Gas Recirculation Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2274 PID: P411 SPN: 411 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the EGR differential pressure sensor circuit. | Possible reduced engine performance.
EGR Differential Pressure Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) differential pressure sensor has two ports that sense exhaust pressure. The sensor outputs a voltage which represents the pressure difference between the two ports located across an orifice in the EGR tube. The engine control module (ECM) uses this pressure to determine how much exhaust gas is flowing in the EGR connection tube to the intake manifold. This information is used to control the EGR valve for correct emission levels.The ECM provides a 5 volt supply to the EGR differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The EGR differential pressure sensor provides a signal to the ECM on the EGR differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure in the EGR crossover tube.The EGR differential pressure sensor measures the exhaust gas pressure drop across the EGR differential pressure orifice. This pressure drop is used to calculate the amount of EGR flow into the intake manifold.

Component Location

The EGR Valve and EGR Differential Pressure Sensor location varies depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR differential pressure signal voltage was less than 0.26-VDC for more than 8 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the EGR differential pressure sensor is used.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A signal circuit open or shorted to ground in the engine harness or sensor

  • Supply wire open or shorted to ground.

A malfunctioning EGR differential pressure sensor.

Refer to Troubleshooting Fault Code 2274.

Last Modified: 25-May-2019


Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2288

Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2288 PID: P103 SPN: 103 FMI: 0/15 LAMP: None SRT: | High turbocharger speed has been detected by the ECM. | Possible reduced engine performance.
Turbocharger Speed Sensor Circuit

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. The target on the turbocharger shaft is a ground flat in the center of the shaft. As the flat on the turbocharger shaft spins past the speed sensor, a signal is generated. The Engine Control Module (ECM) interprets this signal and converts it to a turbocharger speed reading.

Component Location

The turbocharger speed sensor is mounted in the center housing of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the turbocharger speed was above the maximum calibratible limits.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

The ECM will reduce the torque output of the engine to reduce turbocharger speeds.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When the engine has taken the necessary action to reduce the turbocharger speed, this fault code is logged. This fault code is for information only and no repairs are necessary. The engine can possibly be derated when operating near the maximum turbocharger speed limits.

Refer to Troubleshooting Fault Code 2288.

Last Modified: 25-May-2019


Electronic Fuel Injection Control Valve Circuit - Condition Exists

FAULT CODE 2311

Electronic Fuel Injection Control Valve Circuit - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2311 PID: S18 SPN: 633 FMI: 11/31 LAMP: Amber SRT: | The fuel pump actuator circuit resistance is too high or too low, or an intermittent connection has been detected. | Possible reduced engine performance.
Fuel Pump Actuator Circuit

Circuit Description

The circuit is a pulse-width modulation (PWM) driver in the engine control module (ECM) that controls the fuel pump actuator. The actuator is grounded in the ECM. The actuator is normally open. The PWM duty cycle to the fuel pump actuator depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The fuel pump actuator circuit had an intermittent circuit concern, or the fuel pump actuator resistance was too high or too low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Sensed fuel rail pressure will not follow the commanded rail pressure.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If this fault code occurs during a road test, verify that all connectors are clean and free of corrosion before replacing components.

This fault code can become active for any of the following reasons:

Fuel pump actuator high resistance

Engine harness high resistance

Loose, worn, or corroded connectors or pins at the fuel pump actuator or ECM connectors

Fuel pump actuator with low internal resistance

Fuel pump actuator or engine harness that has shorted to ground

Intermittent circuit malfunctions that cause the fuel pressure to exceed the fuel rail pressure relief valve opening pressure.

If an intermittent electrical circuit problem of the fuel pump actuator circuit exists, it is possible for the fault code to become active then inactive during normal engine operation. For example, if a poor connection causes an intermittent open or short circuit, the normally open valve will open in a fraction of a second while the circuit is malfunctioning, causing the fuel rail pressure relief valve to open. Following the event that caused the fuel rail pressure relief valve to open, the ECM will attempt to reset the fuel rail pressure relief valve, provided the fuel pump actuator circuit is not still malfunctioning.

Refer to Troubleshooting Fault Code 2311.

Last Modified: 25-May-2019


Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2321

Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2321 PID: P190 SPN: 190 FMI: 2/2 LAMP: None SRT: | Crankshaft engine speed sensor intermittent synchronization. | Possible reduced engine performance.
Engine Crankshaft Speed/Position Sensor Circuit

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position and camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 1200 RPM.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an intermittent or degraded signal from the crankshaft speed/position sensor over an extended period of engine operation.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

For On-Board Diagnostics (OBD) engines, the ECM illuminates the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and run it at high idle for 5 minutes.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

During engine operation, the ECM monitors the primary speed sensor (crankshaft speed sensor) signal. Fault Code 689 will become active and light the yellow lamp if the signal from the primary speed sensor is not present or degraded for more than 3 continuous seconds. Meanwhile, if the primary engine speed sensor signal is not present or is degraded for a moment (less than 3 seconds), the ECM will interrupt injection events based on the primary engine speed sensor and resume injection events using the backup engine speed sensor. Engine power will be reduced while the injection events are based on the backup speed sensor. If the primary speed sensor signal returns, the ECM will automatically interrupt injection events based on the backup speed sensor and resume injection events based on the primary speed sensor. If over a period of time, the ECM detects several incidents of a loss of the primary speed sensor signal, this fault code will become active.

A vehicle operator can notice an intermittent "misfire" if the injection events are interrupted while the ECM switches from control based on the primary and secondary speed sensors. Also, a vehicle operator can notice intermittent "low power" if a "glitch" in the primary speed sensor signal causes the engine to intermittently use the backup speed sensor for injection control.

This fault code becomes active whenever the ECM detects a persistent loss of the primary engine speed sensor signal over a short period of time.

This fault becomes inactive if the ECM does not detect a loss of the primary engine speed sensor signal for at least 20 minutes.

Possible causes of this fault code include:

Intermittent loss of primary speed sensor signal; the most likely cause is an intermittent open or short circuit that can be experienced with speed sensor connector problems.

Sensor air gap that is marginally too small or too large.

Actions to take if this fault is intermittent:

Look for intermittent engine harness connections in the primary engine speed sensor circuit.

Look for loose connections at the ECM connector where the pins can not be locked into the socket.

Look for places where the engine harness has worn into a nearby component, causing an intermittent short circuit.

Look for pin wear at the speed sensor.

Inspect the target wheel for damage.

Refer to Troubleshooting Fault Code 2321.

Last Modified: 25-May-2019


Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2322

Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2322 PID: S64 SPN: 723 FMI: 2/2 LAMP: None SRT: | Camshaft engine speed sensor intermittent synchronization. | None on performance.
Engine Camshaft Speed/Position Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine camshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The camshaft speed/position sensor provides a signal to the ECM on the camshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the camshaft speed indicator lobe moves past the sensor. The ECM interprets this signal into an engine speed reading and determines engine position. This sensor is used as a backup sensor if the primary engine crankshaft speed/position signal is lost.

Component Location

The camshaft position sensor is located in the top of the gear housing on the exhaust side. .

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine speed is greater than 1200 RPM.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an intermittent loss of the camshaft speed/position sensor signal.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

For On-Board Diagnostics (OBD) engines, the ECM illuminates the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and run it at high idle for 5 minutes.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

During engine operation, the ECM monitors the secondary speed sensor (camshaft speed sensor) signal. Fault Code 778 will become active and light the yellow lamp if the signal from the secondary speed sensor is not present or degraded for more than 3 continuous seconds. If over a period of time the ECM detects several incidents of a loss of the secondary speed sensor signal, but the signal loss is short in duration, this fault code will become active. Since the secondary engine speed signal is not used for normal engine operation, a vehicle operator should not notice any symptoms related to this problem.

This fault code becomes active whenever the ECM detects a persistent loss of the secondary engine speed sensor signal over a short period of time.

This fault becomes inactive if the ECM does not detect a loss of the secondary engine speed sensor signal for at least 20 minutes.

Problems that can cause this fault:

Intermittent loss of primary speed sensor signal; the most likely cause is an intermittent open or short circuit that can be experienced with speed sensor connector problems

Sensor air gap that is marginally too small or too large, or target wheel exhibits excessive runout.

Actions to take if this fault is intermittent:

Look for intermittent engine harness connections in the secondary engine speed sensor circuit

Look for loose connections at the ECM connector where the pins can not be locked into the socket

Look for places where the engine harness has worn into a nearby component, causing an intermittent short circuit

Look for pin wear at the speed sensor

Inspect the target wheel for damage.

Refer to Troubleshooting Fault Code 2322.

Last Modified: 25-May-2019


Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 234

Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: P190 SPN: 190 FMI: 0/0 LAMP: Red SRT: | Engine speed signal indicates engine speed above engine protection limit. | Possible reduced engine performance.
Engine Crankshaft Speed/Position and Camshaft Speed/Position Sensor Circuits

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position and camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine speed had exceeded the calibration limit.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Fueling to the engine is stopped until the engine speed drops to normal operating speeds.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

External fuel sources drawn into the intake air passage

Reverse powering (motoring) of the engine

Tampering of the engine speed/position sensors.

Inspect the intake manifold for sources of flammable vapors. Check the turbocharger seals to verify there are no oil leaks. Inspect the engine speed/position sensors for damage or tampering.

If Fault Code 234 becomes active only during engine braking, and the engine brakes fail to engage, check for a short circuit to ground in the engine brake wiring harness. The rocker lever cover must be removed to perform this inspection. Repair or replace the engine brake wiring harness as necessary.

Refer to Troubleshooting Fault Code 234.

Last Modified: 25-May-2019


Fuel Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2343

Fuel Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2343 PID: P95 SPN: 95 FMI: 0/15 LAMP: Maintenance SRT: | Fuel filter restriction has exceeded a pre-set threshold. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) monitors engine operating conditions, including the reading of fuel rail pressure, and changes the flow command to either increase (OPEN the fuel pump actuator) or decrease (CLOSE the fuel pump actuator) the fuel supply to the high-pressure pump.

Component Location

There are two fuel filters and several original equipment manufacturer (OEM) supplied components that can impact this fault code. The pressure-side fuel filter is typically mounted directly to the engine, but can also be remote mounted. The suction-side fuel filters and other OEM supplied components are OEM specific. The OEM is required to supply a suction-side filter, and the exact filter location is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

Fuel pressure was less than a calibratible value during high fuel flow conditions indicating a fuel inlet restriction.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Low fuel pressure at rated speed/load indicates a fuel inlet restriction or a plugged pressure-side fuel filter. Possible causes of this fault code include:

A plugged pressure or suction side fuel filter

Collapsed fuel inlet lines

An obstructed suction tube in the fuel tank

Plugged fuel tank vents.

Note: The mounting location of the suction side fuel filter will vary by OEM, and can possibly not be in an obvious location.

Refer to Troubleshooting Fault Code 2343.

Last Modified: 25-May-2019


Turbocharger Turbine Intake Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2346

Turbocharger Turbine Intake Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2346 PID: S384 SPN: 2789 FMI: 0/15 LAMP: None SRT: | Turbocharger turbine intake temperature has exceeded the engine protection limit. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The exhaust gas temperature is calculated by the engine control module (ECM). The exhaust gas temperature is derived by the ECM, based on engine operating conditions such as intake manifold air temperature, engine speed, injection timing, intake manifold pressure, and fuel flow.

Component Location

There is not a physical exhaust gas temperature sensor in the system. The exhaust gas temperature is a calculation of exhaust gas temperature before the turbocharger, and is also known as turbine intake temperature.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) calculated the turbine intake temperature was greater than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Fuel is limited in an attempt to decrease the temperature of the exhaust gas entering the turbocharger.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is an information fault code, indicating that the engine has been derated for high turbine intake temperature (exhaust temperature). No troubleshooting is necessary for this fault code. It is only an indicator that the engine power was derated to limit the exhaust temperature.

If the condition continues to exist, Fault Code 2451 will become active.

Refer to Troubleshooting Fault Code 2346.

Last Modified: 25-May-2019


Turbocharger Compressor Outlet Temperature (Calculated) - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2347

Turbocharger Compressor Outlet Temperature (Calculated) - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2347 PID: P404 SPN: 2629 FMI: 0/15 LAMP: None SRT: | High turbocharger compressor outlet air temperature has been calculated by the engine control module (ECM). | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The exhaust gas temperature is calculated by the engine control module (ECM). The exhaust gas temperature is derived by the ECM, based on engine operating conditions such as intake manifold air temperature, engine speed, injection timing, intake manifold pressure, and fuel flow.

Component Location

There is not a physical turbocharger compressor outlet temperature sensor in the system. The turbocharger compressor outlet air temperature is a calculation of temperature of the air after it is compressed by the turbocharger compressor, but before exhaust gas recirculation (EGR) is mixed into the system, and before it enters the charge-air cooler.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) calculated the turbocharger compressor outlet temperature was greater than 250Â°C [482Â°F].

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Fuel is limited in an attempt to decrease the calculated compressor outlet temperature.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Air intake leaks allowing hot under-hood air to enter the intake system

Faulty intake manifold pressure readings

High turbocharger speed readings

Faulty barometric pressure readings

Stuck variable geometry turbocharger.

Note: Unless the issue is a malfunctioning barometric pressure sensor or intake manifold pressure sensor, this fault code will most likely not be active with no load in the shop. The engine will most likely need to be loaded to trip this fault code, and to determine if the malfunction has been found and repaired.

Refer to Troubleshooting Fault Code 2347.

Last Modified: 25-May-2019


EGR Valve Control Circuit - Current Below Normal or Open Circuit

FAULT CODE 2349

EGR Valve Control Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2349 PID: S146 SPN: 2791 FMI: 5/5 LAMP: Amber SRT: | Motor terminal or motor coil open circuit has been detected by the ECM. | Possible reduced engine performance.
EGR Valve Circuit

Circuit Description

The exhaust gas recirculation (EGR) valve is controlled by a brushless motor located on top of the EGR valve. The EGR valve motor uses three different motor legs to move the valve through its range of motion. The ECM uses the EGR motor A, B, and C wires to command the EGR valve to the appropriate position in order to meet EGR flow targets.The EGR valve motor contains three position sensors that detect the location of the EGR valve. These sensors report the position of the valve back to the ECM over the EGR valve position A, B, and C wires.

The EGR valve motor contains three position sensors that detect the location of the EGR valve. These sensors report the position of the valve back to the ECM over the EGR valve position A, B, and C wires.

Component Location

The EGR Valve and EGR Differential Pressure Sensor location varies depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an open circuit in the engine wiring harness or EGR valve motor coil.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

EGR motor circuit open circuit

Open circuit in the wiring harness

Malfunctioning ECM.

Refer to Troubleshooting Fault Code 2349.

Last Modified: 25-May-2019


Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 235

Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 235 PID: P111 SPN: 111 FMI: 1/1 LAMP: Red SRT: | The engine coolant is severely low. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Engine Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level sensor signal voltage was greater than 3-VDC for more than 30 seconds, indicating severely low coolant level.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Low coolant level

Refer to Troubleshooting Fault Code 235.

Last Modified: 25-May-2019


EGR Valve Control Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 2353

EGR Valve Control Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2353 PID: S146 SPN: 2791 FMI: 6/6 LAMP: Amber SRT: | A short circuit to ground has been detected in the EGR valve motor circuit. | Possible reduced engine performance.
EGR Valve Circuit

Circuit Description

The exhaust gas recirculation (EGR) valve is controlled by a brushless motor located on top of the EGR valve. The EGR valve motor uses three different motor legs to move the valve through its range of motion. The ECM uses the EGR motor A, B, and C wires to command the EGR valve to the appropriate position in order to meet EGR flow targets.The EGR valve motor contains three position sensors that detect the location of the EGR valve. These sensors report the position of the valve back to the ECM over the EGR valve position A, B, and C wires.

The EGR valve motor contains three position sensors that detect the location of the EGR valve. These sensors report the position of the valve back to the ECM over the EGR valve position A, B, and C wires.

Component Location

The EGR Valve and EGR Differential Pressure Sensor location varies depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a short circuit to ground in the EGR motor supply circuits.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

One of the EGR motor circuits shorted to ground in the EGR valve motor

One of the EGR motor circuits shorted to ground in the harness

Malfunctioning ECM.

Refer to Troubleshooting Fault Code 2353.

Last Modified: 25-May-2019


Engine Brake Actuator Driver Output 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2363

Engine Brake Actuator Driver Output 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2363 PID: S80 SPN: 1073 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at the engine brake solenoid number 2 signal circuit. | Possible reduce engine braking performance.
Engine Brake Actuator Driver 2 Circuit

Circuit Description

The engine control module (ECM) controls engine brakes on cylinders 4, 5, and 6 by sending a signal on the engine brake solenoid number 2 signal circuit. If an engine brake is installed, there will be a jumper harness from this connector to the engine brake pass-through connectors on the rocker lever housing.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake solenoids are controlled through the engine harness by the ECM.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine brake 2 pulse width modulated (PWM) signal was not detected to be system voltage when the PWM signal was turned on.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The engine brake 2 circuit will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, drive the vehicle and operate the engine brakes. This will allow the diagnostic to run. If the fault code does not become active again, the repair has been validated.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A short circuit to ground in the engine harness

A malfunctioning engine brake solenoid

Refer to Troubleshooting Fault Code 2363.

Last Modified: 25-May-2019


Engine Brake Actuator Driver Output 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2367

Engine Brake Actuator Driver Output 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2367 PID: S80 SPN: 1073 FMI: 3/3 LAMP: Amber SRT: | Open circuit or high voltage detected at the engine brake solenoid Number 2 signal circuit. | Possible reduce engine braking performance.
Engine Brake Actuator Driver 2 Circuit

Circuit Description

The engine control module (ECM) controls engine brakes on cylinders 4, 5, and 6 by sending a signal on the engine brake solenoid number 2 signal circuit. If an engine brake is installed, there will be a jumper harness from this connector to the engine brake pass-through connectors on the rocker lever housing.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake solenoids are controlled through the engine harness by the ECM.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine brake 2 pulse width modulated (PWM) signal was detected to be system voltage when the PWM signal was turned off.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The engine brake 2 circuit will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, drive the vehicle and operate the engine brakes. This will allow the diagnostic to run. If the fault code does not become active again, the repair has been validated.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A short circuit to battery in the engine harness.

A malfunctioning engine brake solenoid

Refer to Troubleshooting Fault Code 2367.

Last Modified: 25-May-2019


Fuel Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2372

Fuel Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2372 PID: P95 SPN: 95 FMI: 0/16 LAMP: Amber SRT: | Excessive fuel flow restriction to the high pressure fuel pump has been detected. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) monitors engine operating conditions, including the reading of fuel rail pressure, and changes the flow command to either increase (OPEN the fuel pump actuator) or decrease (CLOSE the fuel pump actuator) the fuel supply to the high-pressure pump.

Component Location

There are two fuel filters and several original equipment manufacturer (OEM) supplied components that can impact this fault code. The pressure-side fuel filter is typically mounted directly to the engine, but can also be remote mounted. The suction-side fuel filters and other OEM supplied components are OEM specific. The OEM is required to supply a suction-side filter, and the exact filter location is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

Fuel pressure was less than a calibratible value during high fuel flow conditions indicating a fuel inlet restriction.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Low fuel pressure at rated speed/load indicates a fuel inlet restriction or a plugged pressure-side fuel filter. Possible causes of this fault code include:

A plugged pressure or suction side fuel filter

Collapsed fuel inlet lines

An obstructed suction tube in the fuel tank

Plugged fuel tank vents.

Malfunctioning high-pressure fuel system

Note: The mounting location of the suction side fuel filter will vary by OEM, and can possibly not be in an obvious location.

Refer to Troubleshooting Fault Code 2372.

Last Modified: 25-May-2019


Exhaust Gas Bank 1 Pressure Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2373

Exhaust Gas Bank 1 Pressure Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2373 PID: P131 SPN: 1209 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the exhaust gas pressure circuit. | Possible reduced engine performance.
Exhaust Gas Pressure Sensor Circuit

Circuit Description

The exhaust gas pressure sensor is used to measure exhaust gas pressure in the exhaust manifold. This information is used by the engine control module (ECM) to control emissions and exhaust gas recirculation (EGR) valve operation. The ECM provides a 5 volt supply to the exhaust gas pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The exhaust gas pressure sensor provides a signal to the ECM on the exhaust gas pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the exhaust manifold.

Component Location

The exhaust gas pressure sensor is located above the front section of the exhaust manifold and is plumbed into the exhaust manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas pressure signal voltage was greater than 4.75-VDC for more than 8 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value is used for the exhaust gas pressure sensor reading.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The exhaust gas pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor

A signal wire shorted to sensor supply or battery voltage.

Refer to Troubleshooting Fault Code 2373.

Last Modified: 25-May-2019


Exhaust Gas Bank 1 Pressure Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2374

Exhaust Gas Bank 1 Pressure Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2374 PID: P131 SPN: 1209 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the exhaust gas pressure circuit. | Possible reduced engine performance.
Exhaust Gas Pressure Sensor Circuit

Circuit Description

The exhaust gas pressure sensor is used to measure exhaust gas pressure in the exhaust manifold. This information is used by the engine control module (ECM) to control emissions and exhaust gas recirculation (EGR) valve operation. The ECM provides a 5 volt supply to the exhaust gas pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The exhaust gas pressure sensor provides a signal to the ECM on the exhaust gas pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the exhaust manifold.

Component Location

The exhaust gas pressure sensor is located above the front section of the exhaust manifold and is plumbed into the exhaust manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas pressure signal voltage was less than 0.25-VDC for more than 8 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value is used for the exhaust gas pressure sensor reading.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The exhaust gas pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active.

Possible causes of this fault code include:

A signal circuit open or shorted to ground in the engine harness or sensor

  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 2374.

Last Modified: 25-May-2019


Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2375

Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2375 PID: P412 SPN: 412 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at EGR temperature circuit. | Possible reduced engine performance.
Exhaust Gas Recirculation Temperature Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) temperature sensor is a variable resistor sensor and is used to measure the temperature of the EGR gas flow after it exits the EGR cooler. The engine control module (ECM) supplies 5 volts to the EGR temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the EGR flow temperature.

The EGR temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The EGR temperature sensor is located on the EGR connection tube between the EGR cooler and the air intake connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR temperature signal voltage was greater than 4.9-VDC for more than 8 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the exhaust gas recirculation temperature reading is used.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The EGR temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor

An open signal circuit or shorted to a voltage source.

Refer to Troubleshooting Fault Code 2375.

Last Modified: 25-May-2019


Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2376

Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2376 PID: P412 SPN: 412 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at EGR temperature circuit. | Possible reduced engine performance.
Exhaust Gas Recirculation Temperature Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) temperature sensor is a variable resistor sensor and is used to measure the temperature of the EGR gas flow after it exits the EGR cooler. The engine control module (ECM) supplies 5 volts to the EGR temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the EGR flow temperature.

The EGR temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The EGR temperature sensor is located on the EGR connection tube between the EGR cooler and the air intake connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR temperature signal voltage was less than 0.05-VDC for more than 8 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the exhaust gas recirculation temperature reading is used.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The EGR temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

A signal shorted to ground in the harness

A signal shorted to return or ground in the sensor.

Refer to Troubleshooting Fault Code 2376.

Last Modified: 25-May-2019


Fan Control Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2377

Fan Control Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2377 PID: S33 SPN: 647 FMI: 3/3 LAMP: Amber SRT: | Open circuit or high voltage detected at the fan control circuit. | The fan can stay on continuously or not run at all.
Fan Control Circuit

Circuit Description

The fan control circuit is a device used by the engine to control the fan operation. When the engine control module (ECM) energizes the fan control circuit, the engine fan is engaged.

The fan control circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

There are two types of fans supported by the fan control circuit; variable speed and ON/OFF. The recommended Cummins electronic service tool or equivalent can be used to determine which fan type is currently set up for use. The fan control circuit varies by original equipment manufacturer (OEM). Certain OEMs can use a solenoid return that is wired to the ECM or can use a return that goes to the engine block or chassis ground.

Component Location

The control solenoid location varies by OEM. Refer to the appropriate OEM service manual to determine the location.

Conditions for Running the Diagnostics

For ON/OFF and variable speed fan types, the diagnostic runs when the fan is turned off and will latch active when the fan PWM signal is 100 percent. For all other fan types, the diagnostic runs when the fan PWM signal is less than 100 percent and will latch active when the fan PWM signal is 100 percent.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fan control circuit pulse width modulated (PWM) signal voltage was greater then 0-VDC when the PWM signal was commanded OFF.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Fan operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If Fault Code 2377 is still active after completing all the steps in this fault code troubleshooting tree, consult the OEM service literature for procedures to check the fan clutch device for an open circuit or short circuit to ground.

Possible causes of this fault code include:

An open circuit in the harness or fan control solenoid.

A short circuit to voltage source in the OEM harness.

A malfunctioning ECM.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 2377.

Last Modified: 25-May-2019


Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 238

Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 238 PID: S232 SPN: 3511 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected on the +5 volt sensor supply circuit to the engine speed sensor. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Sensor Supply 3 Circuit

Circuit Description

The sensor supply 3 circuit provides a 5 volt supply to the primary engine speed/position sensor.

Component Location

Sensor Supply 3 originates in the engine connector portion of the ECM. It provides 5 VDC to the engine crankshaft speed/position sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 3 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The backup engine speed sensor will be used by the ECM for the engine speed signal.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The ECM monitors the voltage level on the engine speed sensor +5 volt supply circuit. If the voltage falls below a calibratible limit, this fault is recorded.

Possible causes of this fault code include:

Short circuit to ground in the engine harness, sensor, or ECM.

Refer to Troubleshooting Fault Code 238.

Last Modified: 25-May-2019


VGT Actuator Driver Circuit (Motor) - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 2387

VGT Actuator Driver Circuit (Motor) - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2387 PID: S27 SPN: 641 FMI: 7/7 LAMP: Amber SRT: | The smart VGT controller has detected incorrect stop limits, or the VGT is unable to move to the closed position. | Possible reduced engine performance.
VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports malfunctions back to the primary engine ECM, using the J1939 data link. The ECM then decodes the error message and converts it to a fault code.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic has to meet specific engine and aftertreatment conditions to run and complete.

Conditions for Setting the Fault Codes

The Variable Geometry Turbocharger (VGT) actuator position could not meet the commanded position for greater than 10 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

The VGT actuator will continue to attempt to meet commanded position, even when the CHECK ENGINE lamp is on.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Exhaust gas recirculation (EGR) valve operation will be disabled.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning turbocharger

A malfunctioning turbocharger actuator

The aftertreatment system must be inspected for potential damage after making the appropriate repair outlined in this fault code troubleshooting tree. Progressive damage to the aftertreatment system can possibly have occurred.

Refer to Troubleshooting Fault Code 2387.

Last Modified: 25-May-2019


Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 239

Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 239 PID: S232 SPN: 3511 FMI: 3/3 LAMP: Amber SRT: | High voltage detected on the 5 volt sensor supply circuit to the engine speed sensor. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Sensor Supply 3 Circuit

Circuit Description

The sensor supply 3 circuit provides a 5 volt supply to the primary engine speed/position sensor.

Component Location

Sensor Supply 3 originates in the engine connector portion of the ECM. It provides 5 VDC to the engine crankshaft speed/position sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 3 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The backup engine speed sensor will be used by the ECM for the engine speed signal.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

High voltage on the +5 volt supply wire can be caused by a short to battery voltage in the engine harness or connectors, or a damaged ECM.

Refer to Troubleshooting Fault Code 239.

Last Modified: 25-May-2019


Ambient Air Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2398

Ambient Air Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2398 PID: P171 SPN: 171 FMI: 2/2 LAMP: Amber SRT: | The ambient air temperature sensor is reading an erratic value. | Possible reduced engine performance.
Ambient Air Temperature Sensor Circuit

Circuit Description

The ambient air temperature sensor is a variable resistor sensor and is used to measure the temperature of the ambient air. The engine control module (ECM) uses this temperature reading to optimize engine performance, and determine if heating of the SCR system is required. The engine control module (ECM) supplies 5 volts to the ambient air temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the ambient air temperature.

Component Location

The mounting location for the ambient air temperature sensor is OEM dependent. Refer to the appropriate OEM service manual.

Conditions for Running the Diagnostics

This diagnostic consists of two parts.The first part runs when the keyswitch is turned ON and before engine speed is detected.The ECM must not see a key cycle for a period of 8 hours before this part of the diagnostic will run.

The second part runs continuously while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the ambient air temperature reading was higher or lower than the other temperature sensors on the engine after an extended period of engine off time, or the ambient air temperature was reading was too high or too low for the engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the ambient air temperature reading is used.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • If the fault code does not go inactive, it may be necessary to perform a 8 hour cold soak with the key OFF, then turn the keyswitch to the ON position so that the key ON portion of the diagnostic will run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Stuck in-range ambient air temperature sensor

High resistance in the ambient air temperature sensor signal or return lines

ECM malfunction.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 2398.

Last Modified: 25-May-2019


Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect

FAULT CODE 241

Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 241 PID: P84 SPN: 84 FMI: 2/2 LAMP: Amber SRT: | The ECM lost the vehicle speed signal or is reading an erratic value. | Engine speed limited to Maximum Engine Speed without VSS parameter value. Cruise Control, Gear-Down Protection, and Road Speed Governor will not work.
Vehicle Speed Sensor Circuit

Circuit Description

The vehicle speed sensor senses the speed of the tailshaft gear on the vehicle's transmission. This speed signal is then transmitted to the engine control module (ECM) and converted into a vehicle speed.

Component Location

The vehicle speed sensor is located in the rear of the vehicle transmission. Refer to the OEM service manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the vehicle is in motion, if the feature is enabled.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of vehicle speed when other engine operating conditions indicated that the vehicle should be in motion. This fault code can also become active if the calculated gear ratio and actual gear ratio do not agree while the vehicle is in motion.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The engine speed operating range is limited to the adjustable parameter "Maximum Engine Speed without VSS".

ECM powerdown will be delayed for 60 seconds after key OFF.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

There are multiple types of vehicle speed sensors. Various types include magnetic pickup, data link, digital, and tachograph. Contact the OEM for the specific type installed on the vehicle.

This fault is set active when the ECM loses a vehicle speed signal when other engine conditions indicate the vehicle is moving. The fault can also become active if there is a series of clutch, service brake or throttle movements with no vehicle movement. The fault is set inactive when the ECM receives a valid vehicle speed signal.

Since the vehicle speed sensor is an OEM installed component, this troubleshooting procedure will not cover all malfunctions of the circuit due to components not under Cummins Inc. control. Sensor resistance values, data link speed sensors and tachographs are not fully covered under this procedure. For more information on those components, refer to the OEM service manual.

A damaged vehicle speed sensor or debris on the end of the sensor could cause the fault to become active.

Incorrect Cummins electronic service tool feature and parameter settings (gear ratio, tire size, rear axle ratio, etc) will also cause the fault to become active. Feature and parameter settings under Transmission Setup and Vehicle Speed source need to be verified with the vehicle components.

NOTE: If the power is removed from the ECM within 60 seconds of key OFF and before the ECM has powered down, Fault Code 1117 may become active.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 241.

Last Modified: 25-May-2019


Engine Control Module Calibration Memory Checksum - Out of Calibration

FAULT CODE 2416

Engine Control Module Calibration Memory Checksum - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2416 PID: S253 SPN: 1634 FMI: 13/13 LAMP: Amber SRT: | The ECM has detected a calibration mismatch error. | None on performance.
Engine Control Module (ECM)

Circuit Description

The Engine Control Module (ECM) calculates a calibration memory checksum based on the values of certain parameters in the ECM. This checksum is compared to an expected value in the ECM to detect tampering.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the calibration memory checksum did not match the expected value or it did not complete before ECM shutdown.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • In order for this fault code to go inactive, a calibration download is necessary.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

Malfunctioning ECM software

Tampering of the ECM software

Refer to Troubleshooting Fault Code 2416.

Last Modified: 25-May-2019


Wheel-Based Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change

FAULT CODE 242

Wheel-Based Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 242 PID: P84 SPN: 84 FMI: 10/10 LAMP: Amber SRT: | Signal indicates an intermittent connection or VSS tampering. | Engine speed limited to Maximum Engine Speed without VSS parameter value. Cruise Control, Gear-Down Protection, and Road Speed Governor will not work.
Vehicle Speed Sensor Circuit

Circuit Description

The vehicle speed sensor senses the speed of the tailshaft gear on the vehicle's transmission. This speed signal is then transmitted to the engine control module (ECM) and converted into a vehicle speed.

Component Location

The vehicle speed sensor is located in the rear of the vehicle transmission. Refer to the OEM service manual for location.

Conditions for Running the Diagnostics

The adjustable parameter "VSS Anti-Tampering" must be enabled.

This diagnostic runs continuously when the vehicle is in motion, if the feature is enabled.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a tampering event of the vehicle speed signal.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The engine speed operating range is limited to the adjustable parameter "Maximum Engine Speed without VSS".

Cruise Control, Gear-Down Protection, and Road Speed Governor features will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Verify that the feature settings for the vehicle speed sensor anti-tampering (Fault Code 242), application type and automatic transmission are set correctly. If any of these are set incorrectly for the specific vehicle and application, Fault Code 242 could occur erroneously.

Driving techniques such as driving for extended periods of time in lower gears can log Fault Code 242. Fault Code 242 can be logged if the driver attempts to defeat the road speed governor by repeatedly cycling the keyswitch.

Once the speed signal has been restored the fault code will go inactive once the keyswitch is ON for 30 seconds and the ECM senses zero vehicle and engine speed.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 242.

Last Modified: 25-May-2019


Coolant Level - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 2448

Coolant Level - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2448 PID: P111 SPN: 111 FMI: 1/17 LAMP: Maintenance SRT: | Low engine coolant level detected. | None on performance.
Engine Coolant Level Sensor

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level signal voltage was less than a calibratible value for a period of time.

Action Taken When the Fault Code is Active

The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code goes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 2448.

Last Modified: 25-May-2019


VGT Actuator Controller - Out of Calibration

FAULT CODE 2449

VGT Actuator Controller - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2449 PID: S27 SPN: 641 FMI: 13/13 LAMP: Red SRT: | The VGT actuator has been installed incorrectly. | Possible reduced engine performance.
VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports malfunctions back to the primary engine ECM, using the J1939 data link. The ECM then decodes the error message and converts it to a fault code.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is initially turned to the ON position.

The keyswitch must be turned OFF for more than 30 seconds before this diagnostic will run at initial key ON.

Conditions for Setting the Fault Codes

The Variable Geometry Turbocharger (VGT) actuator position was not known during initial power ON.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

VGT actuation will be disabled.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the keyswitch in the ON position for 1 minute. Note that the keyswitch must be completely turned OFF for more than 30 seconds before this diagnostic will run at initial key ON.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code can only be logged after the VGT actuator has been removed or replaced, and then not installed correctly. The gear alignment between the actuator and the turbocharger housing is misaligned. The correct installation procedure must be followed when replacing the VGT actuator.

Refer to Troubleshooting Fault Code 2449.

Last Modified: 25-May-2019


Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 245

Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 245 PID: S33 SPN: 647 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the fan control circuit when commanded ON. | The fan can stay on continuously or not run at all.
Fan Control Circuit

Circuit Description

The fan control circuit is a device used by the engine to control the fan operation. When the engine control module (ECM) energizes the fan control circuit, the engine fan is engaged.

The fan control circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

There are two types of fans supported by the fan control circuit; variable speed and ON/OFF. The recommended Cummins electronic service tool or equivalent can be used to determine which fan type is currently set up for use. The fan control circuit varies by original equipment manufacturer (OEM). Certain OEMs can use a solenoid return that is wired to the ECM or can use a return that goes to the engine block or chassis ground.

Component Location

The control solenoid location varies by OEM. Refer to the appropriate OEM service manual to determine the location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fan control circuit pulse width modulated (PWM) signal was not at system voltage when the pulse width modulated (PWM) signal was commanded ON.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Fan operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The fan control logic can be adjusted with the recommended Cummins electronic service tool or equivalent. There are two choices: 12 or 24 volts ON, or 0 volts ON. For proper fan operation, the fan control logic setup with the recommended Cummins electronic service tool or equivalent must match the hardware configuration on the vehicle.

This fault code is logged when the ECM commands 12 or 24-VDC to the fan control solenoid, but the voltage on the fan control signal circuit is less than 12 or 24-VDC. The low voltage on the signal circuit usually indicates a short circuit to ground in the harness or solenoid.

If Fault Code 245 is still active after completing the following troubleshooting steps, consult the OEM service manual for procedures to check the fan control circuit for a short circuit to ground.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 245.

Last Modified: 25-May-2019


Turbocharger Turbine Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2451

Turbocharger Turbine Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2451 PID: S384 SPN: 2789 FMI: 0/16 LAMP: None SRT: | Turbocharger turbine intake temperature has exceeded the engine protection limit. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The exhaust gas temperature is calculated by the engine control module (ECM). The exhaust gas temperature is derived by the ECM, based on engine operating conditions such as intake manifold air temperature, engine speed, injection timing, intake manifold pressure, and fuel flow.

Component Location

There is not a physical exhaust gas temperature sensor in the system. The exhaust gas temperature is a calculation of exhaust gas temperature before the turbocharger, and is also known as turbine intake temperature.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) calculated turbine inlet temperature was greater than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Fuel is limited in an attempt to decrease the exhaust gas temperature entering the turbocharger.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The most common cause of this fault code is low boost pressure. Low boost pressure can be caused by several factors: leaking charge-air cooler, damaged charge-air cooler piping or hose, loose charge-air cooler clamps, damaged intake manifold pressure sensor, damaged variable geometry turbocharger, damaged turbocharger control valve, or damaged turbocharger control shutoff valve.

This fault code can also be caused by a turbocharger fuel control derate, which can be viewed with the recommended Cummins electronic service tool or equivalent, under the Engine Operating State. Turbocharger fuel control derates can be caused by several factors: high exhaust temperatures, turbocharger compressor inlet temperatures, and turbocharger compressor outlet temperatures.

Exhaust gas recirculation (EGR) system leaks can also cause this fault code. Inspect the EGR bellows and EGR connections for signs of leaks.

Note: This fault code will most likely not be active with no load in the shop. The engine must be loaded to trip this fault code, and to determine if the cause has been found and repaired. Running units on the dynamometer can sometimes cause this fault code to log, due to the stationary nature and high temperatures.

Refer to Troubleshooting Fault Code 2451.

Last Modified: 25-May-2019


Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2468

Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2468 PID: P190 SPN: 190 FMI: 0/16 LAMP: Amber SRT: | The engine speed has exceeded a critical limit. | Engine will shut down.
Engine Control Module (ECM)

Circuit Description

The air shutoff valve is an optional component used to shutdown the engine in the event of an engine overspeed condition. It can be closed via a manual shutdown switch or via an ECM command.

Component Location

The engine air shutoff valve location can vary depending on the OEM. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine speed was greater than 2500 RPM for 0.25 seconds, or the operator manually tripped the engine air shutoff valve.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The air shutoff valve closes

The engine will be shut down.

Conditions for Clearing the Fault Code

  • The air shutoff valve must be reset to the open position.
  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates that the engine has been shut down via the engine air shutoff valve. This can occur automatically (engine overspeed condition) or manually (activating the engine air shutoff valve switch in the cab). In either case, this fault code will become active until the valve de-activated.

Refer to Troubleshooting Fault Code 2468.

Last Modified: 25-May-2019


Ambient Air Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 249

Ambient Air Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 249 PID: P171 SPN: 171 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at ambient air temperature circuit. | Possible reduced engine performance.
Ambient Air Temperature Sensor Circuit

Circuit Description

The ambient air temperature sensor is a variable resistor sensor and is used to measure the temperature of the ambient air. The engine control module (ECM) uses this temperature reading to optimize engine performance, and determine if heating of the SCR system is required. The engine control module (ECM) supplies 5 volts to the ambient air temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the ambient air temperature.

Component Location

The mounting location for the ambient air temperature sensor is OEM dependent. Refer to the appropriate OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the ambient air temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

  • A default value for the ambient air temperature reading is used.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor

Open signal circuit or shorted to a voltage source.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 249.

Last Modified: 25-May-2019


Exhaust Gas Pressure 1 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2554

Exhaust Gas Pressure 1 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2554 PID: P131 SPN: 1209 FMI: 2/2 LAMP: Amber SRT: | The exhaust gas pressure sensor is reading an erratic value. | Possible reduced engine performance.
Exhaust Gas Pressure Sensor Circuit

Circuit Description

The exhaust gas pressure sensor is used to measure exhaust gas pressure in the exhaust manifold. This information is used by the engine control module (ECM) to control emissions and exhaust gas recirculation (EGR) valve operation. The ECM provides a 5 volt supply to the exhaust gas pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The exhaust gas pressure sensor provides a signal to the ECM on the exhaust gas pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the exhaust manifold.

Component Location

The exhaust gas pressure sensor is located above the front section of the exhaust manifold and is plumbed into the exhaust manifold.

Conditions for Running the Diagnostics

This diagnostic consists of two parts:

One part runs immediately after the keyswitch is turned OFF, and the engine coolant temperature is above 70Â°C or 158Â°F.

The second part runs continuously while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust pressure reading was higher or lower than the other absolute pressure sensors when the keyswitch is OFF and the engine is not running.

The Engine Control Module (ECM) detected the exhaust pressure was higher or lower than expected during normal engine operation.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value is used for the exhaust gas pressure sensor reading.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, first ensure the engine coolant temperature is above 70 °C or 158 °F. Operate the engine if necessary.
  • Cycle the keyswitch to the ON position for 30 seconds, then cycle the keyswitch to the OFF position for 30 seconds. Start the engine and run it at high idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Stuck in-range exhaust gas pressure sensor reading

High resistance in the exhaust gas pressure sensor signal or return lines

Plugging or restriction in the exhaust gas pressure sensor tube

Leaks in the exhaust system

Refer to Troubleshooting Fault Code 2554.

Last Modified: 25-May-2019


Ambient Air Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 256

Ambient Air Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 256 PID: P171 SPN: 171 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at ambient air temperature circuit. | Possible reduced engine performance.
Ambient Air Temperature Sensor Circuit

Circuit Description

The ambient air temperature sensor is a variable resistor sensor and is used to measure the temperature of the ambient air. The engine control module (ECM) uses this temperature reading to optimize engine performance, and determine if heating of the SCR system is required. The engine control module (ECM) supplies 5 volts to the ambient air temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the ambient air temperature.

Component Location

The mounting location for the ambient air temperature sensor is OEM dependent. Refer to the appropriate OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the ambient air temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

  • A default value for the ambient air temperature reading is used.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The ambient air temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check fault codes with multiple counts first.

Possible causes of this fault code include:

Signal shorted to ground in the harness

Signal shorted to return or ground in the sensor.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 256.

Last Modified: 25-May-2019


VGT Actuator Controller - Bad Intelligent Device or Component

FAULT CODE 2634

VGT Actuator Controller - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2634 PID: S27 SPN: 641 FMI: 12/12 LAMP: Red SRT: | An internal error has been detected by the smart VGT controller. | Possible reduced engine performance.
VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports malfunctions back to the primary engine ECM, using the J1939 data link. The ECM then decodes the error message and converts it to a fault code.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Variable Geometry Turbocharger (VGT) detected an internal error in the VGT smart device.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

VGT actuation will be disabled.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is logged when the VGT smart actuator detected an internal error within the VGT actuator. The VGT actuator will stop controlling the turbocharger when this fault code is active.

Fault Code 2634 will become active if the VGT actuator is removed from the turbocharger and then the keyswitch is turned to the ON position; or it may be possible for it to become active if the actuator fails the install/calibrate procedure. If this occurs, disconnect the VGT actuator from the engine harness with the keyswitch ON, and connect the VGT actuator to the engine harness. Fault Code 2634 should go inactive. Follow the VGT actuator installation procedure to install the VGT actuator.

Refer to Troubleshooting Fault Code 2634.

Last Modified: 25-May-2019


VGT Actuator Driver Circuit - Abnormal Update Rate

FAULT CODE 2636

VGT Actuator Driver Circuit - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2636 PID: S27 SPN: 641 FMI: 9/9 LAMP: Red SRT: | No communications on the J1939 data link between the engine ECM and the smart VGT controller. | Possible reduced engine performance.
VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports malfunctions back to the primary engine ECM, using the J1939 data link. The ECM then decodes the error message and converts it to a fault code.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a valid J1939 data link message from the Variable Geometry Turbocharger (VGT) actuator for more than 1 second.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

VGT actuation will be disabled.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

The VGT actuator is not receiving power from the ECM. This can be caused by an open circuit in the power supply wire or low voltage supplied by the primary engine ECM.

  • Rapid cycling of the keyswitch

An open return circuit on the VGT actuator circuit

An open or short circuit on the J1939 data link circuit between the ECM and VGT actuator

Intermittent communications between the VGT actuator and the primary engine ECM on the J1939 data link

A damaged termination resistor in the engine data link harness

Refer to Troubleshooting Fault Code 2636.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Oxidation Catalyst Face Plugged - Root Cause Not Known

FAULT CODE 2637

Aftertreatment 1 Diesel Oxidation Catalyst Face Plugged - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2637 PID: S380 SPN: 5018 FMI: 11/11 LAMP: None SRT: | The front face of the aftertreatment diesel oxidation catalyst has been detected to be plugged with soot. | Possible reduced engine performance.
ISX15 CM2350 X101 - Aftertreatment Diesel Oxidation Catalyst

Circuit Description

The aftertreatment temperature sensors are used by the engine control module (ECM) to monitor the engine exhaust temperatures in the aftertreatment system. The aftertreatment temperature sensors are thermistors and change resistance based on the temperature being measured. The ECM provides a 5 volt reference voltage to the sensor. The ECM monitors the change in signal voltage and converts this to a temperature value.

Component Location

The aftertreatment diesel oxidation catalyst is located in the exhaust system. The location of the catalyst can vary, depending on the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active regeneration of the aftertreatment diesel particulate filter is occurring.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake face of the diesel oxidation catalyst was plugged with soot.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • Perform the recommended Cummins electronic service tool or equivalent Diesel Oxidation Catalyst Maintenance Reset procedure found under the Aftertreatment Maintenance section of Advanced ECM Data.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is set when the inlet face of the diesel oxidation catalyst is detected to be plugged with soot.

Possible causes of this fault code include:

Engine oil or fuel plugging the front face of the aftertreatment diesel oxidation catalyst.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and data link communication issues with aftertreatment components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing, or intermittent connections.

NOTE: This fault code is only used to assist in troubleshooting Fault Codes 3151, 3543, and/or 3582.

Refer to Troubleshooting Fault Code 2637.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Oxidation Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 2638

Aftertreatment 1 Diesel Oxidation Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2638 PID: S380 SPN: 5298 FMI: 1/17 LAMP: None SRT: | The temperature increase across the aftertreatment diesel oxidation catalyst is lower than expected. | Possible frequent need for aftertreatment regeneration.
Engine Control Module (ECM)

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel oxidation catalyst is located in the exhaust system. The location of the catalyst can vary, depending on the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active regeneration of the aftertreatment diesel particulate filter is occurring.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) calculated the DOC efficiency was less than required to successfully complete a regeneration.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and perform the recommended Cummins® electronic service tool or equivalent Aftertreatment Diesel Particulate Filter Regeneration Test.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning diesel oxidation catalyst

A malfunctioning aftertreatment fuel injector

Refer to Troubleshooting Fault Code 2638 .

Last Modified: 13-Oct-2021


Aftertreatment 1 Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2639

Aftertreatment 1 Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2639 PID: S324 SPN: 3251 FMI: 0/15 LAMP: None SRT: | The soot load of the aftertreatment diesel particulate filter has exceeded the recommended limits. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit

Circuit Description

The engine aftertreatment system monitors the soot load in the aftertreatment diesel particulate filter. Under normal operating conditions, the aftertreatment diesel particulate filter is self-cleaning, where soot is converted to carbon dioxide, nitrogen, and water. Under light load operating conditions, it can be necessary to perform a stationary regeneration of the aftertreatment diesel particulate filter. The soot load in the aftertreatment diesel particulate filter is estimated, using the aftertreatment differential pressure sensor and the calculated soot output of the engine.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the soot load of the aftertreatment diesel particulate filter had reached the first stage of plugging.

Action Taken When the Fault Code is Active

The ECM will illuminate the aftertreatment diesel particulate filter lamp immediately after the diagnostic is set.

The ECM will flash the aftertreatment dash lamp as the severity of the soot load increases.

  • Torque output of the engine will be reduced as the soot load in the aftertreatment diesel particulate filter increases.

Conditions for Clearing the Fault Code

  • After completing a stationary regeneration (as instructed in this fault code troubleshooting tree) and no additional faults become active, the repair has been validated.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the aftertreatment diesel particulate filter lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Note: Repeated occurrences of this fault code may indicate the engine requires frequent regeneration. Refer to symptom tree t147 (Aftertreatment Diesel Particulate Filter-Excessive Automatic and/or Stationary Regeneration) to identify the cause of frequent regeneration.

Possible causes of this fault code include:

The engine has been operating in light load operating conditions that prevent exhaust temperatures from being high enough to regenerate the aftertreatment diesel particulate filter

Possible engine damage that causes excessive black smoke to be generated.

  • Excessive ash in the DPF
Refer to Troubleshooting Fault Code 2639 .

Last Modified: 13-Oct-2021


Engine Coolant Temperature - Condition Exists

FAULT CODE 2646

Engine Coolant Temperature - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2646 PID: P110 SPN: 110 FMI: 11/31 LAMP: Amber SRT: | The EGR valve was closed to reduce engine coolant temperature. | Possible reduced engine performance.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was above a threshold and closed the EGR valve to reduce the engine coolant temperature.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When the engine coolant temperature nears the engine protection limits, the EGR valve will be closed to reduce the coolant temperature. This fault code is used as an information fault code, only indicating that the EGR valve has closed. No malfunction has occurred to cause this fault code. Other engine protection fault codes will be active if the engine coolant temperature has exceeded the engine protection limits.

Refer to Troubleshooting Fault Code 2646.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Particulate Filter System - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2692

Aftertreatment 1 Diesel Particulate Filter System - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2692 PID: SPN: 3936 FMI: 2/2 LAMP: Amber SRT: | The aftertreatment particulate matter sensor has detected a problem with the diesel particulate filter system. | Possible reduced engine performance.
Aftertreatment Particulate Sensor Circuit

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR outlet temperature has been above 200°C [392° F] for a calibratable period of time while the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment particulate matter sensor detected soot emissions higher than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

The aftertreatment diesel particulate filter is cracked or broken

  • An engine malfunction resulting in high engine out smoke

Malfunctioning aftertreatment particulate matter sensor

Refer to Troubleshooting Fault Code 2692 .

Last Modified: 05-Dec-2021


Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 271

Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 271 PID: S126 SPN: 1347 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage is detected at the fuel pump actuator circuit. | Possible reduced engine performance.
Fuel Pump Actuator Circuit

Circuit Description

The circuit is a pulse-width modulation (PWM) driver in the engine control module (ECM) that controls the fuel pump actuator. The actuator is grounded in the ECM. The actuator is normally open. The PWM duty cycle to the fuel pump actuator depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a short circuit to ground in the fuel pump actuator signal or return circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Sensed fuel rail pressure will not follow the commanded rail pressure.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault becomes active when the ECM detects a short circuit in the electronic fuel pump actuator circuit. Causes for this fault code are short circuit to ground or low resistance (fuel pump actuator coil is shorted internally) in the circuit for the fuel pump actuator. When excessive current or a short circuit is detected, the ECM driver to the fuel pump actuator is turned off to protect the circuit. It is necessary to cycle the keyswitch OFF and then back ON before the ECM will test again for the cause of the fault code. The ECM driver is enabled at key ON; if the cause is no longer present, the fault code will become inactive and can be cleared. If the fault code is intermittent, look for causes of an intermittent short to ground in the wiring harness or connectors.

Fault Code 2311 can have high counts if the short circuit condition is or was intermittent.

Refer to Troubleshooting Fault Code 271.

Last Modified: 25-May-2019


Brake Switch and Accelerator Pedal Position Incompatible - Condition Exists

FAULT CODE 2718

Brake Switch and Accelerator Pedal Position Incompatible - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2718 PID: SPN: 6304 FMI: 11/31 LAMP: None SRT: | The ECM has detected the brake pedal and accelerator pedal were depressed simultaneously. | The engine will operate in Limp Home mode.
Engine Control Module (ECM)

Circuit Description

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

The brake pedal position switch is mounted to the brake pedal. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the vehicle is in motion, if the feature is enabled.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the accelerator pedal and brake pedal were depressed simultaneously.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The engine will have limp-home throttle control only.

Conditions for Clearing the Fault Code

  • To validate the repair, it may be necessary to operate the vehicle on a chassis dynamometer or to drive the vehicle.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is intended to detect conditions where both the accelerator pedal and brake pedal were depressed at the same time. When this condition occurs, the accelerator pedal position is defaults to idle. If the fault occurs when both pedals are NOT depressed, this may indicate that either the accelerator pedal position or brake pedal position are NOT returning to 0 percent.

Refer to Troubleshooting Fault Code 2718.

Last Modified: 25-May-2019


Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 272

Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 272 PID: S126 SPN: 1347 FMI: 3/3 LAMP: Amber SRT: | High signal voltage or open circuit is detected at the fuel pump actuator circuit. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Fuel Pump Actuator Circuit

Circuit Description

The circuit is a pulse-width modulation (PWM) driver in the engine control module (ECM) that controls the fuel pump actuator. The actuator is grounded in the ECM. The actuator is normally open. The PWM duty cycle to the fuel pump actuator depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a short to battery, short pin-to-pin, or open circuit in the fuel pump actuator circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Sensed fuel rail pressure will not follow the commanded rail pressure.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault becomes active when the ECM detects an open or short circuit in the fuel pump actuator circuit. Causes of this fault code include a short circuit to a positive voltage, open circuit, short circuit to ground, or low resistance (fuel pump actuator is shorted internally) in the fuel pump actuator circuit. If there is high harness resistance or an intermittent open circuit, Fault Code 2311 can have high inactive counts. When excessive current or a short circuit is detected, the ECM driver to the fuel pump actuator is turned off to protect the circuit. It is necessary to cycle the keyswitch OFF and then back ON before the ECM will run this diagnostic again. The ECM driver is enabled at key ON, so if the cause is no longer present, the fault code will become inactive and can be cleared.

If the fault code is intermittent, inspect the ECM connector, wiring harness, and harness connectors for loose pins and bad connections. Look closely for loose wire connections that can cause an intermittent short to ground or open circuit in the wiring harness or connectors. It may help to wiggle the harness and harness connections and watch for fault code state changes.

Refer to Troubleshooting Fault Code 272.

Last Modified: 25-May-2019


Engine Start Enable Device 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2738

Engine Start Enable Device 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2738 PID: S237 SPN: 626 FMI: 3/3 LAMP: Amber SRT: | High signal voltage or open circuit detected at the ether start solenoid circuit. | Ether start functionality will be disabled.
Ether Injection Start Circuit

Circuit Description

The ether injection circuit is a device used by the engine to control the ether injection operation. The ether injection circuit utilizes a Pulse Width Modulated (PWM) signal. A PWM signal is pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

Component Location

The control solenoid location varies by OEM. Refer to the appropriate OEM service manual to determine the location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The ether injection circuit pulse width modulated (PWM) signal voltage was greater than 0-VDC when the PWM signal was turned off by the ECM.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The ether injection operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

An open circuit in the engine harness or ether injection solenoid

A short circuit to voltage source in the OEM harness

A malfunctioning ECM.

Refer to Troubleshooting Fault Code 2738.

Last Modified: 25-May-2019


Engine Start Enable Device 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2739

Engine Start Enable Device 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2739 PID: S237 SPN: 626 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the ether start solenoid circuit. | Ether start functionality will be disabled.
Ether Injection Start Circuit

Circuit Description

The ether injection circuit is a device used by the engine to control the ether injection operation. The ether injection circuit utilizes a Pulse Width Modulated (PWM) signal. A PWM signal is pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

Component Location

The control solenoid location varies by OEM. Refer to the appropriate OEM service manual to determine the location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The ether injection circuit pulse width modulated (PWM) signal was not at system voltage when the PWM signal was turned ON.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The ether injection operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is logged when the ECM commands 12-VDC to the ether injection solenoid, but the voltage on the ether injection signal circuit is less than 12-VDC. The low voltage on the signal circuit usually indicates a short circuit to ground in the harness or solenoid.

Refer to Troubleshooting Fault Code 2739.

Last Modified: 25-May-2019


Engine Diesel Particulate Filter Intake Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2754

Engine Diesel Particulate Filter Intake Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2754 PID: P81 SPN: 81 FMI: 0/16 LAMP: Amber SRT: | Excessive black smoke has been detected exiting the engine and entering the aftertreatment diesel particulate filter. | None on performance.
Engine Diesel Particulate Filter

Circuit Description

The engine aftertreatment system monitors the soot load in the aftertreatment diesel particulate filter. Under normal operating conditions, the aftertreatment diesel particulate filter is self-cleaning, where soot is converted to carbon dioxide, nitrogen, and water. Under light load operating conditions, it can be necessary to perform a stationary regeneration of the aftertreatment diesel particulate filter. The soot load in the aftertreatment diesel particulate filter is estimated, using the aftertreatment differential pressure sensor and the calculated soot output of the engine.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

Soot accumulation within the diesel particulate filter occurred at a higher rate than under normal operating conditions.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

Boost leaks in the charge-air cooler plumbing

A malfunction of the variable geometry turbocharger (VGT)

A malfunction of the exhaust gas recirculation (EGR) valve

A malfunctioning in-range EGR differential pressure sensor

A malfunctioning in-range boost pressure sensor

A malfunctioning in-range barometric pressure sensor

A cylinder misfire or overfueling.

Excessive ash in the DPF

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 2754.

Last Modified: 25-May-2019


Exhaust Gas Pressure 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2764

Exhaust Gas Pressure 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2764 PID: P131 SPN: 1209 FMI: 0/16 LAMP: Amber SRT: | High exhaust gas pressure has been detected by the exhaust gas pressure sensor. | Possible reduced engine performance.
Exhaust Gas Pressure Sensor Circuit

Circuit Description

The exhaust gas pressure sensor is used to measure exhaust gas pressure in the exhaust manifold. This information is used by the engine control module (ECM) to control emissions and exhaust gas recirculation (EGR) valve operation. The ECM provides a 5 volt supply to the exhaust gas pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The exhaust gas pressure sensor provides a signal to the ECM on the exhaust gas pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the exhaust manifold.

Component Location

The exhaust gas pressure sensor is located above the front section of the exhaust manifold and is plumbed into the exhaust manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

Exhaust gas pressure sensor reading was greater than the engine protection limits.

Action Taken When the Fault Code is Active

An engine derate will be activated to bring exhaust gas pressure below the maximum operating limits.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning variable geometry turbocharger

A damaged in-range exhaust gas pressure sensor

A plugged or restricted aftertreatment diesel particulate filter

A plugged or restricted EGR cooler.

Refer to Troubleshooting Fault Code 2764.

Last Modified: 25-May-2019


Aftertreatment 1 Outlet NOx Sensor - Abnormal Update Rate

FAULT CODE 2771

Aftertreatment 1 Outlet NOx Sensor - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2771 PID: SPN: 3226 FMI: 9/9 LAMP: Amber SRT: | No communication or an invalid data transfer rate detected on the J1939 data link between the ECM and the aftertreatment outlet NOx sensor. | Possible reduced engine performance.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) lost communication with the aftertreatment outlet NOx sensor via the J1939 data link.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Engine torque will be severely reduced.

Vehicle speed will be limited to 8 km [5 mi] per hour after extended engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

The Aftertreatment Outlet NOx Sensor is not receiving power from the battery supply circuit in the OEM harness. This can be caused by an open circuit in the power supply wire, blown NOx sensor fuse, or low voltage supplied by the battery.

Open return circuit on the aftertreatment outlet NOx sensor battery return.

Open or short circuit on the J1939 data link circuit between the engine ECM and aftertreatment outlet NOx sensor.

Intermittent communications between the aftertreatment outlet NOx sensor and the ECM on the J1939 data link.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 2771.

Last Modified: 25-May-2019


Aftertreatment Regeneration Inhibited Due to Inhibit Switch - Condition Exists

FAULT CODE 2777

Aftertreatment Regeneration Inhibited Due to Inhibit Switch - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2777 PID: S390 SPN: 3703 FMI: 11/31 LAMP: Maintenance SRT: | Regeneration of the diesel particulate filter has been prevented due to the permit switch being disabled. | Possible frequent need for aftertreatment regeneration.
Engine Control Module (ECM)

Circuit Description

The OEM truck manufacturer can install a permit switch in the dash or send an inhibit message via the J1939 data link to the engine ECM. The function of the inhibit message is to prevent the aftertreatment system from performing mobile regenerations.

Component Location

The aftertreatment regeneration permit switch can be an actual switch in the vehicle dash or it can be a J1939 message sent via the J1939 data link. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel particulate filter regeneration permit switch was disabling regeneration while the ECM was requesting active regeneration of the aftertreatment diesel particulate filter.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If this fault code is active and there has been damage to the aftertreatment system, the permit switch can possibly have prevented the aftertreatment system from performing a mobile (active) regeneration.

Consult with the OEM if the aftertreatment system has malfunctioned due to the permit switch.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 2777.

Last Modified: 25-May-2019


Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2789

Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2789 PID: P110 SPN: 110 FMI: 1/18 LAMP: Amber SRT: | Engine coolant temperature is below normal operating temperature limits. | None on performance.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

Engine coolant temperature was less than 60Â°C [140Â°F] for over 1 hour during a period of extended idle.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If this fault indicates that coolant temperature is below a calibratible limit set in the ECM.

Refer to Engine Coolant Temperature Below Normal troubleshooting symptom tree tree in the base engine service manual.

Refer to Troubleshooting Fault Code 2789.

Last Modified: 25-May-2019


SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

FAULT CODE 285

SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 285 PID: S231 SPN: 639 FMI: 9/9 LAMP: Amber SRT: | The ECM expected information from a multiplexed device but did not receive it soon enough or did not receive it at all. | At least one multiplexed device will not operate properly.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins ECM and used for controlling the engine. The Cummins ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

The Engine Control Module (ECM) detected an open or short circuit condition in the J1939 data link harness.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices can possibly not function as desired.

This fault can occur for the following reasons:

When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the CumminsÂ ECM, or the OEM VECU is not set up to transmit the multiplexed component message.

This fault can also be caused by a bad J1939 data link connection between the OEM VECU and Cummins ECM, a bad connection between the component and the OEM VECU, bad OEM VECU or bad Cummins ECM. It may be necessary to contact the OEM for proper multiplexing configuration. It is possible to use the recommended Cummins electronic service tool or equivalent to monitor multiplexed components.

It is possible to use the recommended Cummins electronic service tool or equivalent to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 285.

Last Modified: 25-May-2019


J1939 Network #1 - Out of Calibration

FAULT CODE 286

J1939 Network #1 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 286 PID: S231 SPN: 639 FMI: 13/13 LAMP: Amber SRT: | The ECM expected information from a multiplexed device but only received a portion of the necessary information. | At least one multiplexed device will not operate properly.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) received an invalid J1939 data link message from a multiplexed device for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault can occur when the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing.

It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 286 .

Last Modified: 13-Oct-2021


SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Position Sensor System - Received Network Data in Error

FAULT CODE 288

SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Position Sensor System - Received Network Data in Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 288 PID: P372 SPN: 974 FMI: 2/19 LAMP: Red SRT: | The OEM vehicle electronic control unit (VECU) detected a fault with the remote accelerator. | Remote accelerator will not operate.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins ECM and used for controlling the engine. The Cummins ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) received a message from the OEM VECU via the J1939 data link, indicating the remote throttle signal wire or enable switch was shorted high or shorted low.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault can occur when the OEM VECU detects an error on the remote throttle and or remote throttle enable switch. The ECM has been set up properly (components enabled and OEM VECU source addressed correctly) to receive multiplexed information for the remote throttle enable switch states and remote accelerator position over the J1939 data link from an OEM VECU, and the OEM VECU is transmitting the message for that component. Most OEM VECUs will not have the circuitry to detect a remote throttle switch error.

The two types of errors that can occur for this fault are:

The OEM VECU determines that the remote throttle signal line is shorted high or shorted low. This fault status is transmitted to the Cummins ECM on the J1939 data link, which causes this fault to occur in the Cummins ECM.

When the remote throttle enable switch has a shorted high or shorted low error detected by the OEM VECU, this fault status is transmitted to the ECM on the J1939 data link, which causes this fault to occur in the ECM. Most OEM VECUs will not incorporate fault detection on a switch.

It is still possible to get a Fault Code 285 or 286, if there is an incorrect setup in the OEM VECU or Cummins ECM for other components, or the remote throttle and remote throttle switch, or the data link is damaged. The OEM configurations must multiplex the remote throttle and remote throttle switch inputs together to allow the use of the J1939 multiplexing feature for these components. Use the recommended Cummins electronic service tool or equivalent to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 288.

Last Modified: 25-May-2019


Aftertreatment Fuel Pressure Sensor - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 2881

Aftertreatment Fuel Pressure Sensor - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2881 PID: S332 SPN: 3480 FMI: 1/17 LAMP: Amber SRT: | Low fuel pressure has been detected in the aftertreatment fuel system. | None on performance.
Aftertreatment Fuel Pressure Sensor Circuit

Circuit Description

The aftertreatment fuel pressure sensor is used to monitor the fuel pressure into the aftertreatment system. The engine control module (ECM) supplies the aftertreatment fuel pressure sensor a 5 volt reference voltage. When the fuel pressure is low, the sensor signal voltage is low. When the fuel pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the aftertreatment fuel pressure signal circuit voltage to calculate the pressure of the fuel within the aftertreatment system.

Component Location

The aftertreatment fuel injector is installed in the exhaust system in the turbocharger adapter pipe. The aftertreatment fuel pressure sensor and aftertreatment fuel shutoff valve are installed in the shutoff valve manifold. The aftertreatment purge air actuator is located above the shutoff valve manifold.

Conditions for Running the Diagnostics

This diagnostic runs during active regeneration of the aftertreatment diesel particulate filter.

Conditions for Setting the Fault Codes

The aftertreatment fuel pressure was less than 300 kPa [43.5 psi] for more than 15 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Active regeneration of the aftertreatment diesel particulate filter will be disabled unitl the next key cycle.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and perform the recommended Cummins electronic service tool or equivalent Aftertreatment Diesel Particulate Filter Regeneration Test.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Plugged or restricted aftertreatment fuel supply line

Plugged or restricted aftertreatment fuel shutoff manifold

Plugged or restricted pressure side fuel filter

Malfunctioning fuel pump gear pump.

Refer to Troubleshooting Fault Code 2881.

Last Modified: 25-May-2019


Barometric Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 295

Barometric Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 295 PID: P108 SPN: 108 FMI: 2/2 LAMP: Amber SRT: | An error in the barometric pressure sensor signal was detected by the ECM. | Possible reduced engine performance.
Barometric Air Pressure Sensor Circuit

Circuit Description

The barometric pressure sensor responds to pressure changes in the atmospheric pressure. The pressure changes occur based on the elevation where the engine is presently operating. The barometric pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness near the ECM.

Conditions for Running the Diagnostics

  • The first part of the diagnostic runs continuously while the keyswitch is in the ON position or the engine is running.

The second part of the diagnostic runs at key OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the barometric pressure reading was higher or lower than the other absolute pressure sensors on the engine, or an in-range malfunction of the sensor was detected.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the barometric pressure reading is used.

Exhaust gas recirculation (EGR) valve operation will be disabled.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine, let it idle for 1 minute, and then shutdown the engine.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning barometric air pressure sensor

Refer to Troubleshooting Fault Code 295.

Last Modified: 25-May-2019


Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2961

Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2961 PID: P412 SPN: 412 FMI: 0/15 LAMP: None SRT: | EGR temperature has exceeded the engine protection limit. | Possible reduced engine performance.
Exhaust Gas Recirculation Temperature Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) temperature sensor is a variable resistor sensor and is used to measure the temperature of the EGR gas flow after it exits the EGR cooler. The engine control module (ECM) supplies 5 volts to the EGR temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the EGR flow temperature.

The EGR temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The EGR temperature sensor is located on the EGR connection tube between the EGR cooler and the air intake connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR temperature was greater than 210Â°C [410Â°F] for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Plugged or restricted EGR differential pressure sensor ports

Damaged EGR differential pressure tubes

A malfunctioning EGR valve

A low reading from the EGR differential pressure sensor

A low reading for the EGR valve position sensor

High exhaust temperatures

Low coolant level

High coolant temperature

An incorrect coolant/water mixture

A stuck closed variable geometry turbocharger

A fouled EGR cooler.

Note: This fault code will most likely not be active with no load in the shop. The engine must be loaded to trigger this fault code.

Refer to Troubleshooting Fault Code 2961.

Last Modified: 25-May-2019


Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2962

Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2962 PID: P412 SPN: 412 FMI: 0/16 LAMP: Amber SRT: | EGR temperature has exceeded the engine protection limit. | Possible reduced engine performance.
Exhaust Gas Recirculation Temperature Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) temperature sensor is a variable resistor sensor and is used to measure the temperature of the EGR gas flow after it exits the EGR cooler. The engine control module (ECM) supplies 5 volts to the EGR temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the EGR flow temperature.

The EGR temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The EGR temperature sensor is located on the EGR connection tube between the EGR cooler and the air intake connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR temperature was greater than 250Â°C [482Â°F] for more than 5 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A fouled EGR cooler

Plugged or restricted EGR differential pressure sensor ports

A damaged EGR valve

A low reading from the EGR differential pressure sensor

A low reading for the EGR valve position sensor

High exhaust temperatures

Low coolant level

High coolant temperature

An incorrect coolant/water mixture

A stuck closed variable geometry turbocharger.

Note: This fault code will most likely not be active with no load in the shop. The engine must be loaded to trigger this fault code.

Refer to Troubleshooting Fault Code 2962.

Last Modified: 25-May-2019


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2963

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2963 PID: P110 SPN: 110 FMI: 0/15 LAMP: None SRT: | Engine coolant temperature is above the engine protection warning limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was greater than 107Â°C [225Â°F].

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature. Refer to Engine Coolant Temperature Above Normal symptom troubleshooting tree in the base engine service manual.

Refer to Troubleshooting Fault Code 2963.

Last Modified: 25-May-2019


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2964

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2964 PID: P105 SPN: 105 FMI: 0/15 LAMP: None SRT: | Intake manifold air temperature signal indicates intake manifold air temperature is above engine protection warning limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature was greater than 120C [248F].

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The intake manifold 1 temperature sensor measures the temperature of the charge-air as it passes through the intake manifold.

Possible causes of this fault code include:

Plugged charge-air cooler fins

Restricted airflow through the charge-air cooler

An undersized charge-air cooler

High turbocharger compressor outlet temperature.

Refer to Troubleshooting Fault Code 2964.

Last Modified: 25-May-2019


Intake Manifold 1 Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2973

Intake Manifold 1 Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2973 PID: P102 SPN: 102 FMI: 2/2 LAMP: Amber SRT: | The intake manifold pressure sensor is reading an erratic value. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic consists of two parts:

One part runs immediately after the keyswitch is turned OFF, and the engine coolant temperature is above 70Â°C or 158Â°F.

The second part occurs when the engine is operating.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure sensor was reading higher or lower than expected at keyoff or during normal engine operation.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value of the intake manifold pressure reading is used.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, first ensure the engine coolant temperature is above 70 °C or 158 °F. Operate the engine if necessary.
  • Cycle the keyswitch to the ON position for 30 seconds, then cycle the keyswitch to the OFF position for 30 seconds. Start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This diagnostic consists of two parts. At key OFF, the sensor readings for intake manifold pressure, barometric air pressure, oil pressure (if available), and exhaust gas pressure are compared to each other. This fault code occurs if the intake manifold pressure sensor reading is different from the other sensor readings. This check is only done once after the keyswitch is turned OFF. This fault can also be set active when the intake manifold pressure is too high or low for the current engine operating conditions when the engine is running. The ECM compares the intake manifold pressure reading to turbocharger speed to determine if the pressure reading is valid.

Possible causes of this fault are:

A damaged turbocharger speed sensor

A damaged barometric pressure sensor

Leaks in the air intake system between the turbocharger and intake manifold

Restriction in the charge-air cooler

A damaged intake manifold pressure sensor

A damaged turbocharger compressor intake temperature sensor.

Refer to Troubleshooting Fault Code 2973.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2976

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2976 PID: SPN: 3361 FMI: 2/2 LAMP: Amber SRT: | An internal error has been detected in the aftertreatment diesel exhaust fluid dosing unit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit precisely measures the amount of aftertreatment diesel exhaust fluid to be injected into the aftertreatment system. The aftertreatment diesel exhaust fluid dosing unit has three primary cycles. A priming cycle makes sure that aftertreatment diesel exhaust fluid is available at the aftertreatment diesel exhaust fluid dosing unit. During the dosing cycle, aftertreatment diesel exhaust fluid is being delivered to the aftertreatment dosing valve. A purge cycle occurs when the engine is turned OFF. The purge cycle makes sure that all the aftertreatment diesel exhaust fluid is removed from the diesel exhaust fluid lines and dosing valve.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs immediately after the keyswitch is turned to the ON position, and continues until the diesel exhaust fluid dosing unit attempts to prime.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing unit internal temperature was not communicated to the ECM by the diesel exhaust dosing unit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Vehicle speed will be limited to 8 km [5 mi] per hour after extended engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • Start the engine and let it idle. If, after the engine idles for 10 minutes, the fault code is still not active, the repair has been validated.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning dosing unit

Short circuit to ground in the aftertreatment diesel exhaust fluid dosing unit signal/dosing unit temperature wire.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 2976.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Particulate Filter Outlet Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3133

Aftertreatment 1 Diesel Particulate Filter Outlet Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3133 PID: SPN: 3610 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the aftertreatment diesel particulate filter outlet pressure sensor circuit. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Outlet Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the aftertreatment diesel particulate filter outlet pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The aftertreatment diesel particulate filter outlet pressure sensor provides a signal to the ECM on the aftertreatment diesel particulate filter outlet pressure sensor signal circuit. This sensor signal voltage changes based on the pressure at the outlet of the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter differential pressure sensor is mounted on the diesel particulate filter. It is a combination sensor that detects both diesel particulate filter differential pressure and outlet pressure. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel particulate filter outlet pressure signal voltage was out range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor

Signal circuit shorted to sensor supply or battery voltage.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3133.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Particulate Filter Outlet Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3134

Aftertreatment 1 Diesel Particulate Filter Outlet Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3134 PID: SPN: 3610 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the aftertreatment diesel particulate filter outlet pressure sensor circuit. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Outlet Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the aftertreatment diesel particulate filter outlet pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The aftertreatment diesel particulate filter outlet pressure sensor provides a signal to the ECM on the aftertreatment diesel particulate filter outlet pressure sensor signal circuit. This sensor signal voltage changes based on the pressure at the outlet of the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter differential pressure sensor is mounted on the diesel particulate filter. It is a combination sensor that detects both diesel particulate filter differential pressure and outlet pressure. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel particulate filter outlet pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Signal circuit open or shorted to ground in the engine harness or sensor

  • Supply wire open or shorted to ground.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3134.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Particulate Filter Outlet Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3135

Aftertreatment 1 Diesel Particulate Filter Outlet Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3135 PID: SPN: 3610 FMI: 2/2 LAMP: Amber SRT: | The aftertreatment diesel particulate filter outlet pressure sensor is reading an erratic value. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Outlet Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the aftertreatment diesel particulate filter outlet pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The aftertreatment diesel particulate filter outlet pressure sensor provides a signal to the ECM on the aftertreatment diesel particulate filter outlet pressure sensor signal circuit. This sensor signal voltage changes based on the pressure at the outlet of the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter differential pressure sensor is mounted on the diesel particulate filter. It is a combination sensor that detects both diesel particulate filter differential pressure and outlet pressure. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic consists of two parts:

  • One part runs continuously while the engine is running.
  • The second part runs when keyswitch is OFF engine OFF for 60 seconds and DPF outlet temperature was greater than 200°C [392°F] before the keyswitch was turned OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel particulate filter outlet pressure was greater than 1.5 kpa [0.22 psi] or less than -1.5 kpa [0.22 psi] at key OFF, or was higher than expected during engine operation.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • Turn the key switch OFF and allow the ECM to completely powerdown.
  • To validate the repair, perform a key cycle and leave the key in the ON position for 2 minutes. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Stuck in-range aftertreatment diesel particulate filter outlet pressure sensor reading

High resistance in the aftertreatment diesel particulate filter outlet pressure sensor signal or return wires

Higher than expected diesel particulate filter outlet pressure

Excessive diesel exhaust fluid (DEF) deposits in the aftertreatment decomposition tube

Plugged aftertreatment outlet pressure sensor ports could cause this fault code if pressure is held in the port after the engine is turned OFF.

Frozen, plugged, or restricted aftertreatment DPF differential pressure sensor tubes.

Note: It is possible to set this fault in a shop environment by performing a key cycle with the tailpipe connected to an exhaust ventilation system.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3135.

Last Modified: 25-May-2019


Engine Exhaust Gas Recirculation Outlet Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3136

Engine Exhaust Gas Recirculation Outlet Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3136 PID: SPN: 5019 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the EGR orifice pressure sensor. | Possible reduced engine performance.
Exhaust Gas Recirculation Orifice Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the EGR orifice pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The EGR orifice pressure sensor provides a signal to the ECM on the EGR orifice pressure sensor signal circuit. This sensor signal voltage changes based on the pressure at the EGR orifice pressure sensor.

Component Location

The EGR orifice pressure sensor is mounted on the EGR mass measurement assembly near the EGR differential pressure sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR orifice pressure sensor signal voltage was greater than 4.75-volts for 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor

Signal circuit shorted to sensor supply or battery voltage.

Refer to Troubleshooting Fault Code 3136.

Last Modified: 25-May-2019


Engine Exhaust Gas Recirculation Outlet Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3137

Engine Exhaust Gas Recirculation Outlet Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3137 PID: SPN: 5019 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the EGR orifice pressure sensor. | Possible reduced engine performance.
Exhaust Gas Recirculation Orifice Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the EGR orifice pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The EGR orifice pressure sensor provides a signal to the ECM on the EGR orifice pressure sensor signal circuit. This sensor signal voltage changes based on the pressure at the EGR orifice pressure sensor.

Component Location

The EGR orifice pressure sensor is mounted on the EGR mass measurement assembly near the EGR differential pressure sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR orifice pressure sensor signal voltage was less than 0.25 volts for 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Signal circuit open or shorted to ground in the engine harness or sensor

  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 3137.

Last Modified: 25-May-2019


Engine Exhaust Gas Recirculation Outlet Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3138

Engine Exhaust Gas Recirculation Outlet Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3138 PID: SPN: 5019 FMI: 2/2 LAMP: Amber SRT: | The EGR orifice pressure sensor is reading an erratic value at initial key ON or while the engine is running. | Possible reduced engine performance.
ISX11.9 CM2250/ISX15 CM2250 - Engine Exhaust Gas Recirculation Orifice Pressure Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the EGR orifice pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The EGR orifice pressure sensor provides a signal to the ECM on the EGR orifice pressure sensor signal circuit. This sensor signal voltage changes based on the pressure at the EGR orifice pressure sensor.

Component Location

The EGR orifice pressure sensor is mounted on the EGR mass measurement assembly near the EGR differential pressure sensor.

Conditions for Running the Diagnostics

This is a two part diagnostic.

One part runs immediately after the keyswitch is turned OFF, and the engine coolant temperature is above 70Â°C or 158Â°F.

The second part runs continuously while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR orifice pressure sensor was not changing with engine conditions or was incorrect at key OFF.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 5 minutes. After 5 minutes, shut OFF the engine, perform a key cycle, and leave the key in the ON position for 1 minute.
  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A damaged EGR orifice pressure sensor

High resistance in the wiring harness on the signal or return wire

Plugged or restricted EGR differential pressure sensor flow ports.

Refer to Troubleshooting Fault Code 3138.

Last Modified: 25-May-2019


Engine Air Shutoff Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3139

Engine Air Shutoff Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3139 PID: SPN: 3667 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the air shutoff circuit. | The engine air shutoff valve will be disabled.
ISX15 CM2350 X101 - Engine Air Shutoff Circuit

Circuit Description

The air shutoff valve is an OEM installed component that shuts off the flow of air into the intake of the engine in order to prevent an engine overspeed condition. When activated, the ECM supplies 12-VDC to the air shutoff solenoid. This solenoid then supplies air to the air shutoff valve and activates the valve, closing a plate over the intake.

Component Location

The air shutoff valve is either an OEM or CumminsÂ installed component, and is usually located on the air intake connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine air shutoff driver was shorted to voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Open engine air shutoff circuit

Short circuit to voltage in the engine air shutoff circuit

Malfunctioning ECM.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3139.

Last Modified: 25-May-2019


Engine Air Shutoff Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3141

Engine Air Shutoff Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3141 PID: SPN: 3667 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the engine air shutoff circuit. | The engine air shutoff valve will be disabled.
ISX15 CM2350 X101 - Engine Air Shutoff Sensor Circuit

Circuit Description

The air shutoff valve is either an original equipment manufacturer (OEM) or CumminsÂ installed component that shuts off the flow of air into the intake of the engine in order to prevent an engine overspeed condition. When activated, the engine control module (ECM) supplies 12-VDC to the air shutoff solenoid. This solenoid then activates the valve, closing a plate over the intake.

Component Location

The air shutoff valve is either an OEM or CumminsÂ installed component, and is usually located on the air intake connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine air shut off driver was shorted to ground.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Short circuit to ground in the engine air shutoff circuit

Malfunctioning ECM.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3141.

Last Modified: 25-May-2019


Aftertreatment 1 SCR Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3142

Aftertreatment 1 SCR Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3142 PID: SPN: 4360 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the selective catalytic reduction (SCR) intake temperature sensor circuit. | Possible reduced engine performance.
Aftertreatment SCR Intake Temperature Sensor Circuit

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intake temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The SCR intake temperature sensor is located in the aftertreatment system. It is located between the diesel particulate filter and the SCR catalyst in the exhaust system.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the SCR intake temperature sensor signal voltage was greater than 4.4-VDC for more than 2 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Engine torque will be severely reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The SCR intake temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor

Open signal circuit or shorted to a voltage source

Malfunctioning aftertreatment SCR catalyst temperature sensor interface module.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3142.

Last Modified: 25-May-2019


Aftertreatment 1 SCR Outlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3146

Aftertreatment 1 SCR Outlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3146 PID: SPN: 4363 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the SCR outlet temperature sensor circuit. | Possible reduced engine performance.
Aftertreatment SCR Catalyst Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intermediate temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported the aftertreatment SCR outlet temperature signal was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment SCR outlet temperature sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3146.

Last Modified: 25-May-2019


Aftertreatment 1 SCR Outlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3147

Aftertreatment 1 SCR Outlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3147 PID: SPN: 4363 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the SCR outlet temperature sensor circuit. | Possible reduced engine performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intermediate temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported the aftertreatment SCR outlet temperature signal was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment SCR outlet temperature sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3147.

Last Modified: 25-May-2019


Aftertreatment 1 SCR Outlet Temperature Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3148

Aftertreatment 1 SCR Outlet Temperature Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3148 PID: SPN: 4363 FMI: 2/2 LAMP: Amber SRT: | The selective catalytic reduction (SCR) outlet temperature sensor is not changing with engine operating conditions. | Possible reduced engine performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intermediate temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the exhaust gas temperature sensors are compared to other engine temperatures during engine operation. The engine coolant temperature must be above 60Â°C [140Â°F] before the diagnostic will run.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment SCR outlet temperature sensor signal was irrational for more than 5 minutes.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

A default value for the SCR catalyst outlet temperature is used.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment SCR outlet temperature sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3148.

Last Modified: 25-May-2019


Aftertreatment 1 SCR Catalyst System Missing - Condition Exists

FAULT CODE 3151

Aftertreatment 1 SCR Catalyst System Missing - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3151 PID: SPN: 4794 FMI: 11/31 LAMP: Amber SRT: | The aftertreatment SCR catalyst in the exhaust system is not present. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) monitors the NOx concentration in the engine's exhaust gases using an aftertreatment intake NOx sensor and an aftertreatment outlet NOx sensor. By comparing these two values, the ECM is able to determine the conversion efficiency of the SCR catalyst and dosing system.

Component Location

The SCR catalyst is located in the vehicle's exhaust system, after the diesel particulate filter and decomposition tube.

Conditions for Running the Diagnostics

This diagnostic has to meet specific engine and aftertreatment conditions to run and complete.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the NOx conversion efficiency of the SCR catalyst was critically low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Engine torque will be severely reduced.

Vehicle speed will be limited to 8 km [5 mi] per hour after extended engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • It is necessary to use the "Reset All Faults" command in the recommended Cummins electronic service tool or equivalent to clear this fault and extinguish the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL).

Shop Talk

Troubleshoot all other active NOx sensor and SCR dosing system related fault codes before this fault.

Possible causes of this fault code include:

Tampering with SCR catalyst system, removal of SCR catalyst from vehicle, or malfunctioning SCR catalyst

Malfunctioning aftertreatment diesel exhaust fluid dosing system.

Exhaust system leaks

Degraded, diluted, or incorrect diesel exhaust fluid

Diesel exhaust fluid deposits in the decomposition tube.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3151.

Last Modified: 25-May-2019


Aftertreatment 1 SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 3165

Aftertreatment 1 SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3165 PID: SPN: 4363 FMI: 0/0 LAMP: Red SRT: | The selective catalytic reduction (SCR) outlet temperature sensor reading has exceeded the maximum temperature limit. | Possible reduced engine performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intermediate temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the temperature at the SCR catalyst outlet temperature sensor was greater than 800Â°C [1472Â°F] for more than 20 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down if the Engine Protection Shutdown feature is enabled.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault will go inactive immediately after the SCR outlet temperature drops below the warning limit, and will likely be inactive at the time of diagnosis. For these reasons this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault code include:

Malfunctioning SCR catalyst

Degraded, diluted, or incorrect diesel exhaust fluid

Malfunctioning in-range SCR outlet temperature sensor.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3165.

Last Modified: 25-May-2019


Aftertreatment Doser - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3167

Aftertreatment Doser - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3167 PID: S382 SPN: 3556 FMI: 1/18 LAMP: Amber SRT: | The ECM detects that the aftertreatment fuel injector has used up all compensation. | Possible frequent need for aftertreatment regeneration.
Aftertreatment Fuel Injector Circuit

Circuit Description

The aftertreatment fuel injector is electronically controlled by the engine electronic control module (ECM) through a pulse width modulated (PWM) signal. The amount of fuel injected is determined by how long the PWM signal to the injector is on.

Component Location

The aftertreatment fuel injector is installed in the exhaust system in the turbocharger adapter pipe. The aftertreatment fuel pressure sensor and aftertreatment fuel shutoff valve are installed in the shutoff valve manifold. The aftertreatment purge air actuator is located above the shutoff valve manifold.

Conditions for Running the Diagnostics

This diagnostic runs during active regeneration of the aftertreatment diesel particulate filter.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment fuel injector could not inject enough fuel for active regeneration of the aftertreatment diesel particulate filter.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and perform the recommended Cummins electronic service tool or equivalent Aftertreatment Diesel Particulate Filter Regeneration Test.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A dirty or damaged aftertreatment fuel injector.

Refer to Troubleshooting Fault Code 3167.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Particulate Filter System - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3168

Aftertreatment 1 Diesel Particulate Filter System - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3168 PID: SPN: 3936 FMI: 0/16 LAMP: Amber SRT: | The system has detected a malfunction in the filtering capability of the aftertreatment diesel particulate filter. | None on performance.
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit

Circuit Description

The ECM calculates an aftertreatment diesel particulate filter flow resistance, using the aftertreatment diesel particulate filter differential pressure and calculated exhaust flow rate.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic only runs after successful completion of an active regeneration of the aftertreatment diesel particulate filter.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) calculated the aftertreatment diesel particulate filter flow resistance was too low after successful regeneration of the aftertreatment diesel particulate filter.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • It is necessary to use the "Reset All Faults" command in the recommended Cummins electronic service tool or equivalent to clear this fault and extinguish the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL).

Shop Talk

Possible causes of this fault code include:

A damaged aftertreatment diesel particulate filter differential pressure sensor

Missing or malfunctioning aftertreatment diesel particulate filter differential pressure sensor tubes

Malfunction aftertreatment diesel particulate filter.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3168.

Last Modified: 25-May-2019


Injector Solenoid Driver 1 Circuit - Current Below Normal or Open Circuit

FAULT CODE 322

Injector Solenoid Driver 1 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 322 PID: S1 SPN: 651 FMI: 5/5 LAMP: Amber SRT: | Malfunction detected at injector 1 circuit. | Possible reduced engine performance.
Injector Solenoid Driver Cylinder 1 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.
  • Exhaust gas recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If a fault condition is intermittent, and especially if more than one injector fault code is occurring, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid.When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation, making sure there are no shorts to a rocker lever.An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

  • Open circuit in the engine harness(es) or injector solenoid.
  • High resistance in a single injector or injector solenoid.
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground).
  • Malfunctioning or damaged ECM.

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

Bank 1 - Front Bank: Fault Codes 322, 324, 331

Bank 2 - Rear Bank: Fault Codes 323, 325, 332.

Refer to Troubleshooting Fault Code 322 .

Last Modified: 13-Oct-2021


Aftertreatment Purge Air Actuator Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3223

Aftertreatment Purge Air Actuator Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3223 PID: SPN: 3490 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the aftertreatment purge air actuator circuit. | Possible reduced engine performance.
Aftertreatment Purge Air Actuator Circuit

Circuit Description

The aftertreatment purge air actuator is used to purge the aftertreatment fuel injector system of fuel after active regeneration of the aftertreatment diesel particulate filter.

Component Location

The aftertreatment fuel injector is installed in the exhaust system in the turbocharger adapter pipe. The aftertreatment fuel pressure sensor and aftertreatment fuel shutoff valve are installed in the shutoff valve manifold. The aftertreatment purge air actuator is located above the shutoff valve manifold.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment purge air actuator is commanded OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an open circuit or short to ground in the aftertreatment purge air actuator circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Active regeneration of the aftertreatment diesel particulate filter will be disabled unitl the next key cycle.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and perform the recommended Cummins electronic service tool or equivalent Aftertreatment Diesel Particulate Filter Regeneration Test.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

An open circuit in the engine harness, connectors, or aftertreatment purge air actuator

A short circuit in the engine harness, connectors, or aftertreatment purge air actuator

A damaged aftertreatment purge air actuator.

Refer to Troubleshooting Fault Code 3223.

Last Modified: 25-May-2019


Aftertreatment Purge Air Actuator Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3224

Aftertreatment Purge Air Actuator Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3224 PID: SPN: 3490 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the aftertreatment purge air actuator circuit. | Possible reduced engine performance.
Aftertreatment Purge Air Actuator Circuit

Circuit Description

The aftertreatment purge air actuator is used to purge the aftertreatment fuel injector system of fuel after active regeneration of the aftertreatment diesel particulate filter.

Component Location

The aftertreatment fuel injector is installed in the exhaust system in the turbocharger adapter pipe. The aftertreatment fuel pressure sensor and aftertreatment fuel shutoff valve are installed in the shutoff valve manifold. The aftertreatment purge air actuator is located above the shutoff valve manifold.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment purge air actuator is commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a short circuit to battery in the aftertreatment purge air actuator circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Active regeneration of the aftertreatment diesel particulate filter will be disabled unitl the next key cycle.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and perform the recommended Cummins electronic service tool or equivalent Aftertreatment Diesel Particulate Filter Regeneration Test.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A short to battery in the aftertreatment purge air actuator circuit

A damaged aftertreatment purge air actuator.

Refer to Troubleshooting Fault Code 3224.

Last Modified: 25-May-2019


Aftertreatment Purge Air Actuator - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 3225

Aftertreatment Purge Air Actuator - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3225 PID: SPN: 3490 FMI: 7/7 LAMP: Amber SRT: | Aftertreatment Purge Air Actuator - Mechanical System Not Responding or Out of Adjustment.A stuck closed aftertreatment purge air actuator has been detected | Possible reduced engine performance.
Aftertreatment Purge Air Actuator Circuit

Circuit Description

The aftertreatment purge air actuator is used to purge the aftertreatment fuel injector system of fuel after active regeneration of the aftertreatment diesel particulate filter.

Component Location

The aftertreatment fuel injector is installed in the exhaust system in the turbocharger adapter pipe. The aftertreatment fuel pressure sensor and aftertreatment fuel shutoff valve are installed in the shutoff valve manifold. The aftertreatment purge air actuator is located above the shutoff valve manifold.

Conditions for Running the Diagnostics

This diagnostic runs during active regeneration of the aftertreatment diesel particulate filter.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment fuel pressure was less than a threshold when the aftertreatment purge air actuator was commanded on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Active regeneration of the aftertreatment diesel particulate filter will be disabled unitl the next key cycle.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and perform the recommended Cummins electronic service tool or equivalent Aftertreatment Diesel Particulate Filter Regeneration Test.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A stuck closed aftertreatment purge air actuator

Missing or leaking air supply line to the aftertreatment purge air actuator

Missing or leaking air supply line from the aftertreatment purge air actuator to the shutoff valve manifold.

Refer to Troubleshooting Fault Code 3225.

Last Modified: 25-May-2019


Aftertreatment 1 Intake NOx Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3228

Aftertreatment 1 Intake NOx Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3228 PID: SPN: 3216 FMI: 2/2 LAMP: Amber SRT: | An incorrect NOx sensor reading has been detected by the aftertreatment intake NOx sensor. | Possible reduced engine performance.
Aftertreatment Intake NOx Sensor Circuit

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the NOx emissions at the intake of the aftertreatment system.

Component Location

The aftertreatment intake NOx sensor is mounted on the engine near the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment diesel oxidation catalyst intake temperature sensor has been above 150°C [302°F] for 5 minutes while the engine is running.

This diagnostic has to meet specific engine and aftertreatment conditions to run and complete. Sensor data is gathered over varying engine speeds and loads. When enough data has been gathered, the diagnostic will run, make a pass/fail decision, and begin to gather data again.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment intake NOx reading was higher or lower than the calculated aftertreatment intake NOx value for the engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, it may be necessary to operate the vehicle on a chassis dynamometer or to drive the vehicle in order to get the engine load high enough for the diagnostic to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

EGR system leaks

Exhaust system leaks

An incorrectly installed aftertreatment intake NOx sensor

An aftertreatment intake NOx sensor that has carbon buildup on the tip of the sensor

A malfunctioning EGR differential pressure sensor.

A malfunctioning EGR valve

  • Excessive oil consumption

Possible engine misfire

The NOx sensor part number is incorrect.

Refer to Troubleshooting Fault Code 3228.

Last Modified: 25-May-2019


Injector Solenoid Driver 5 Circuit - Current Below Normal or Open Circuit

FAULT CODE 323

Injector Solenoid Driver 5 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 323 PID: S5 SPN: 655 FMI: 5/5 LAMP: Amber SRT: | Malfunction detected at injector 5 circuit. | Possible reduced engine performance.
Injector Solenoid Driver Cylinder 5 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.
  • Exhaust gas recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If a fault condition is intermittent, and especially if more than one injector fault code is occurring, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid.When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation, making sure there are no shorts to a rocker lever.An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

  • Open circuit in the engine harness(es) or injector solenoid.
  • High resistance in a single injector or injector solenoid.
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground).
  • Malfunctioning or damaged ECM.

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

Bank 1 - Front Bank: Fault Codes 322, 324, 331

Bank 2 - Rear Bank: Fault Codes 323, 325, 332.

Refer to Troubleshooting Fault Code 323 .

Last Modified: 13-Oct-2021


Aftertreatment 1 Intake NOx Sensor - Abnormal Update Rate

FAULT CODE 3232

Aftertreatment 1 Intake NOx Sensor - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3232 PID: SPN: 3216 FMI: 9/9 LAMP: Amber SRT: | No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the aftertreatment intake NOx sensor. | Possible reduced engine performance.
Aftertreatment Intake NOx Sensor Circuit

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the NOx emissions at the intake of the aftertreatment system.

Component Location

The aftertreatment intake NOx sensor is mounted on the engine near the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

This fault code is triggered when the ECM loses J1939 data link communications with the aftertreatment intake NOx sensor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be severely reduced.

Vehicle speed will be limited to 8 km [5 mi] per hour after extended engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

The aftertreatment intake NOx sensor is not receiving power from the battery supply circuit in the OEM harness. This can be caused by an open circuit in the power supply wire, malfunctioned NOx sensor fuse, or low voltage supplied by the battery.

Open return circuit on the aftertreatment intake NOx sensor circuit between the battery circuit aftertreatment intake NOx sensor.

Open or short circuit on the J1939 data link circuit between the engine ECM and aftertreatment intake NOx sensor.

Intermittent communications between the aftertreatment intake NOx sensor and the ECM on the J1939 data link

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3232.

Last Modified: 25-May-2019


Aftertreatment 1 SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3235

Aftertreatment 1 SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3235 PID: SPN: 4363 FMI: 0/16 LAMP: Red SRT: | The SCR outlet temperature sensor reading has exceeded the maximum temperature limit. | Possible reduced engine performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intermediate temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active regeneration of the aftertreatment diesel particulate filter is not occurring.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the temperature at the SCR catalyst outlet temperature sensor was greater than 650Â°C [1202Â°F] for more than 60 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault will go inactive immediately after the SCR outlet temperature drops below the warning limit, and will likely be inactive at the time of diagnosis. For these reasons this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault code include:

Malfunctioning SCR catalyst

Degraded, diluted, or incorrect diesel exhaust fluid

Malfunctioning in-range SCR outlet temperature sensor.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3235.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Line Heater 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3237

Aftertreatment 1 Diesel Exhaust Fluid Line Heater 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3237 PID: SPN: 4340 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the diesel exhaust fluid line heater 1 circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Line Heater 1 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heaters are used to defrost and/or prevent freezing of the diesel exhaust fluid lines.

Component Location

The aftertreatment diesel exhaust fluid line heater 1 is located on the supply line between the diesel exhaust fluid dosing unit and the diesel exhaust fluid dosing valve.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and line heating is commanded OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the line heater voltage was above a calibratible value and the line heater current was above a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The line heater will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use the recommended Cummins electronic service tool or equivalent to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning line heater

A short circuit to battery in the OEM harness

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3237.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Line Heater 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3238

Aftertreatment 1 Diesel Exhaust Fluid Line Heater 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3238 PID: SPN: 4340 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the diesel exhaust fluid line heater 1 circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaustl Fluid Line Heater 1 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heaters are used to defrost and/or prevent freezing of the diesel exhaust fluid lines.

Component Location

The aftertreatment diesel exhaust fluid line heater 1 is located on the supply line between the diesel exhaust fluid dosing unit and the diesel exhaust fluid dosing valve.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and line heating is commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the line heater voltage was below a calibratible value and the line heater current was below a calibratable valure.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The line heater will be disabled.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use the recommended Cummins electronic service tool or equivalent to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A short circuit to ground in the OEM harness

A malfunctioning line heater

Refer to Troubleshooting Fault Code 3238.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Line Heater 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3239

Aftertreatment 1 Diesel Exhaust Fluid Line Heater 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3239 PID: SPN: 4342 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the diesel exhaust fluid line heater 2 circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Line Heater 2 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heaters are used to defrost and/or prevent freezing of the diesel exhaust fluid lines.

Component Location

The aftertreatment diesel exhaust fluid line heater 2 is located on the return line between the diesel exhaust fluid dosing unit and diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and line heating is commanded OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the line heater voltage was above a calibratible value and the line heater current was above a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The line heater will be disabled.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use the recommended Cummins electronic service tool or equivalent to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning line heater

A short circuit to battery in the OEM harness

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3239.

Last Modified: 25-May-2019


Injector Solenoid Driver 3 Circuit - Current Below Normal or Open Circuit

FAULT CODE 324

Injector Solenoid Driver 3 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 324 PID: S3 SPN: 653 FMI: 5/5 LAMP: Amber SRT: | Malfunction detected at injector 3 circuit. | Possible reduced engine performance.
Injector Solenoid Driver Cylinder 3 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.
  • Exhaust gas recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If a fault condition is intermittent, and especially if more than one injector fault code is occurring, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid.When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation, making sure there are no shorts to a rocker lever.An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

  • Open circuit in the engine harness(es) or injector solenoid.
  • High resistance in a single injector or injector solenoid.
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground).
  • Malfunctioning or damaged ECM.

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

Bank 1 - Front Bank: Fault Codes 322, 324, 331

Bank 2 - Rear Bank: Fault Codes 323, 325, 332.

Refer to Troubleshooting Fault Code 324 .

Last Modified: 13-Oct-2021


Aftertreatment 1 Diesel Exhaust Fluid Line Heater 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3241

Aftertreatment 1 Diesel Exhaust Fluid Line Heater 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3241 PID: SPN: 4342 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the diesel exhaust fluid line heater 2 circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Line Heater 2 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heaters are used to defrost and/or prevent freezing of the diesel exhaust fluid lines.

Component Location

The aftertreatment diesel exhaust fluid line heater 2 is located on the return line between the diesel exhaust fluid dosing unit and diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and line heating is commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the line heater voltage was below a calibratible value and the line heater current was below a calibratable valure.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The line heater will be disabled.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use the recommended Cummins electronic service tool or equivalent to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A short circuit to ground in the OEM harness

A malfunctioning line heater

Refer to Troubleshooting Fault Code 3241.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 3242

Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3242 PID: SPN: 3363 FMI: 7/7 LAMP: Amber SRT: | The aftertreatment diesel exhaust fluid temperature did not increase when the aftertreatment diesel exhaust fluid tank heater was commanded ON. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank heater keeps the diesel exhaust fluid from freezing in the diesel exhaust fluid tank. The tank heater consists of an electrically powered tank heater control valve which controls the flow of engine coolant to a heating coil inside the diesel exhaust fluid tank. The tank heater control valve opens to allow coolant to flow to the heating coil when heating is commanded, and closes when heating is no longer required.

Component Location

The diesel exhaust fluid tank heater control valve is located near the diesel exhaust fluid tank. Specific location will vary depending on the OEM. The tank heating coil is internal to the diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs a calibrated amount of time after diesel exhaust fluid tank heating is first commanded.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid tank heater was commanded on by the engine engine control module (ECM), but no corresponding temperature increase in the aftertreatment diesel exhaust fluid tank temperature was recorded by the tank temperature sensor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • The fault code status in the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the system is able to adequately heat and the diagnostic runs and passes. If heating can not be completed, use the "Diesel Exhaust Fluid Doser System Heater Test" found under "ECM Diagnostic Test" in the recommended Cummins electronic service tool or equivalent to command heating to the tank heater and all line heaters.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Aftertreatment diesel exhaust fluid tank heater control valve stuck closed

Blockage or restrictions in the coolant plumbing to the diesel exhaust fluid tank heater

Engine coolant level low

Malfunctioning aftertreatment diesel exhaust fluid tank heater control valve

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3242.

Last Modified: 25-May-2019


Engine Cooling System Monitor - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3243

Engine Cooling System Monitor - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3243 PID: SPN: 3060 FMI: 1/18 LAMP: Amber SRT: | The engine is not warming up as expected. | None on performance.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running if the coolant temperature was less than 52Â°C [126Â°F] when the engine was started.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature did not reach 72Â°C [162Â°F] in a specified amount of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Low coolant level, or air in the cooling system

Malfunctioning coolant temperature sensor

Malfunctioning engine coolant thermostat.

Refer to Troubleshooting Fault Code 3243.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Particulate Filter System - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 3245

Aftertreatment 1 Diesel Particulate Filter System - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3245 PID: SPN: 3936 FMI: 7/7 LAMP: Amber SRT: | The aftertreatment diesel particulate filter has been damaged. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter outlet temperature sensor reading was greater than 950Â°C [1742Â°F] for 30 seconds, or the difference between the diesel particulate filter intake temperature and the diesel particulate filter outlet temperature was greater than 1050Â°C [1922Â°F] for 30 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Excessive engine oil or diesel fuel being introduced into the exhaust system from the engine

A malfunctioning engine fuel injector causing unburned diesel fuel to enter the exhaust system

A face plugged aftertreatment diesel oxidation catalyst

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3245.

Last Modified: 25-May-2019


Injector Solenoid Driver 6 Circuit - Current Below Normal or Open Circuit

FAULT CODE 325

Injector Solenoid Driver 6 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 325 PID: S6 SPN: 656 FMI: 5/5 LAMP: Amber SRT: | Malfunction detected at injector 6 circuit. | Possible reduced engine performance.
Injector Solenoid Driver Cylinder 6 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.
  • Exhaust gas recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If a fault condition is intermittent, and especially if more than one injector fault code is occurring, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid.When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation, making sure there are no shorts to a rocker lever.An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

Bank 1 - Front Bank: Fault Codes 322, 324, 331

Bank 2 - Rear Bank: Fault Codes 323, 325, 332.

Refer to Troubleshooting Fault Code 325 .

Last Modified: 13-Oct-2021


Aftertreatment 1 Diesel Oxidation Catalyst Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3251

Aftertreatment 1 Diesel Oxidation Catalyst Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3251 PID: S326 SPN: 4765 FMI: 0/16 LAMP: Red SRT: | The diesel oxidation catalyst intake temperature sensor reading has exceeded the maximum temperature limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Aftertreatment Diesel Particulate Filter Temperature Sensor Module

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel oxidation catalyst intake temperature sensor is located in the aftertreatment system. It is located at the intake of the aftertreatment catalyst. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active regeneration of the aftertreatment diesel particulate filter is not occurring.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the temperature at the diesel oxidation catalyst intake was greater than 687Â°C [1269Â°F] for 60 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

A default value for the aftertreatment diesel oxidation catalyst intake temperature sensor reading is used.

Active and stationary regeneration of the diesel particulate filter will be disabled.

The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is logged when the ECM has detected a high temperature condition in the aftertreatment system and active regeneration of the aftertreatment diesel particulate filter is not occurring. The fault code indicates that a secondary fuel source is entering the aftertreatment system and is creating a temperature increase across the aftertreatment diesel oxidation catalyst and/or aftertreatment diesel particulate filter.

Possible causes of this fault code include:

Excessive engine oil or diesel fuel being introduced into the exhaust system from the engine

A damaged engine fuel injector causing unburned diesel fuel to enter the exhaust system

The aftertreatment system must be inspected after making the appropriate repair outlined in this fault code troubleshooting tree. Progressive damage to the aftertreatment system may have occurred. Remove the exhaust aftertreatment system from the vehicle to inspect it for potential damage and reuse. Refer to the OEM service manual.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3251.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Particulate Filter Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3253

Aftertreatment 1 Diesel Particulate Filter Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3253 PID: SPN: 3242 FMI: 0/16 LAMP: Red SRT: | The aftertreatment diesel particulate filter intake temperature sensor reading has exceeded the maximum engine protection temperature limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Aftertreatment Diesel Particulate Filter Temperature Sensor Module

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter intake temperature sensor is located in the aftertreatment system. It is located at the outlet of the diesel oxidation catalyst and before the diesel particulate filter. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active regeneration of the aftertreatment diesel particulate filter is not occurring.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter intake temperature sensor reading was greater than 650Â°C [1202Â°F] for 85 seconds, or the difference between the diesel oxidation catalyst intake temperature and the diesel particulate filter intake temperature was greater than 365Â°C [689Â°F] for 50 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Exhaust gas recirculation (EGR) valve operation will be disabled.

The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is logged when the ECM has detected a high temperature condition in the aftertreatment system and active regeneration of the aftertreatment diesel particulate filter is not occurring. The fault code indicates that a secondary fuel source is entering the aftertreatment system and is creating a temperature increase across the aftertreatment diesel particulate filter. This fault will go inactive immediately after the aftertreatment temperatures drop below the warning limit, and will likely be inactive when the vehicle is in the shop. For these reasons, this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault code include:

Excessive engine oil or diesel fuel being introduced into the exhaust system from the engine

A damaged engine fuel injector causing unburned diesel fuel to enter the exhaust system

A face plugged aftertreatment diesel oxidation catalyst

The aftertreatment system must be inspected after making the appropriate repair outlined in this fault code troubleshooting tree. Progressive damage to the aftertreatment system may have occurred. Remove the exhaust aftertreatment system from the vehicle to inspect it for potential damaged and reuse. Refer to the OEM service manual.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3253.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Particulate Filter Intake Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 3254

Aftertreatment 1 Diesel Particulate Filter Intake Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3254 PID: SPN: 3242 FMI: 0/15 LAMP: Amber SRT: | The aftertreatment diesel particulate filter intake temperature sensor reading has exceeded the maximum engine protection temperature limit. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Temperature Sensor Module

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter intake temperature sensor is located in the aftertreatment system. It is located at the outlet of the diesel oxidation catalyst and before the diesel particulate filter. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter intake temperature sensor reading was greater than 675°C [1247°F] for 5 seconds on five separate occasions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • To validate the repair, start the engine and perform the recommended Cummins® electronic service tool or equivalent Aftertreatment Diesel Particulate Filter Regeneration Test.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Excessive engine oil or diesel fuel being introduced into the exhaust system from the engine

A face plugged aftertreatment diesel oxidation catalyst

Refer to Troubleshooting Fault Code 3254 .

Last Modified: 16-May-2021


Aftertreatment 1 Diesel Particulate Filter Outlet Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3255

Aftertreatment 1 Diesel Particulate Filter Outlet Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3255 PID: SPN: 3246 FMI: 0/16 LAMP: Red SRT: | The aftertreatment diesel particulate filter outlet temperature sensor reading has exceeded the maximum engine protection temperature limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Aftertreatment Diesel Particulate Filter Temperature Sensor Module

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter outlet temperature sensor is located in the aftertreatment system. It is located at the outlet of the aftertreatment diesel particulate filter. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active regeneration of the aftertreatment diesel particulate filter is not occurring.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter intake temperature sensor reading was greater than 687Â°C [1269Â°F] for 90 seconds, or the difference between the diesel particulate filter intake temperature and the diesel particulate filter outlet temperature was greater than 300Â°C [572Â°F] for 90 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault will go inactive immediately after the aftertreatment temperatures drop below the warning limit, and will likely be inactive at the time of diagnosis. For these reasons, this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault code include:

Excessive engine oil or diesel fuel being introduced into the exhaust system from the engine

A damaged engine fuel injector causing unburned diesel fuel to enter the exhaust system

A face plugged aftertreatment diesel oxidation catalyst

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3255.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Particulate Filter Outlet Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 3256

Aftertreatment 1 Diesel Particulate Filter Outlet Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3256 PID: SPN: 3246 FMI: 0/15 LAMP: Amber SRT: | The aftertreatment diesel particulate filter outlet temperature sensor reading has exceeded the maximum engine protection temperature limit. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Temperature Sensor Module

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter outlet temperature sensor is located in the aftertreatment system. It is located at the outlet of the aftertreatment diesel particulate filter. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter outlet temperature sensor was greater than 675Â°C [1247Â°F] for 10 seconds on five separate occasions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • To validate the repair, start the engine and perform the recommended Cummins electronic service tool or equivalent Aftertreatment Diesel Particulate Filter Regeneration Test.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault will go inactive immediately after the aftertreatment temperatures drop below the warning limit, and will likely be inactive at the time of diagnosis. For these reasons, this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault code include:

Excessive engine oil or diesel fuel being introduced into the exhaust system from the engine

A damaged engine fuel injector causing unburned diesel fuel to enter the exhaust system

A face plugged aftertreatment diesel oxidation catalyst

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3256.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Line Heater 1 Circuit - Current Below Normal or Open Circuit

FAULT CODE 3258

Aftertreatment 1 Diesel Exhaust Fluid Line Heater 1 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3258 PID: SPN: 4340 FMI: 5/5 LAMP: Amber SRT: | Open circuit detected in the diesel exhaust fluid line heater 1. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Line Heater 1 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heaters are used to defrost and/or prevent freezing of the diesel exhaust fluid lines.

Component Location

The aftertreatment diesel exhaust fluid line heater 1 is located on the supply line between the diesel exhaust fluid dosing unit and the diesel exhaust fluid dosing valve.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and line heating is commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an open in the line heater circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Engine torque will be severely reduced.

Vehicle speed will be limited to 8 km [5 mi] per hour after extended engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use the recommended Cummins electronic service tool or equivalent to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning line heater relay

Malfunctioning line heater

An open circuit in the OEM harness

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3258.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Line Heater 2 Circuit - Current Below Normal or Open Circuit

FAULT CODE 3261

Aftertreatment 1 Diesel Exhaust Fluid Line Heater 2 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3261 PID: SPN: 4342 FMI: 5/5 LAMP: Amber SRT: | Open circuit detected in the diesel exhaust fluid line heater 2. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Line Heater 2 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heaters are used to defrost and/or prevent freezing of the diesel exhaust fluid lines.

Component Location

The aftertreatment diesel exhaust fluid line heater 2 is located on the return line between the diesel exhaust fluid dosing unit and diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and line heating is commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an open in the line heater circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Engine torque will be severely reduced.

Vehicle speed will be limited to 8 km [5 mi] per hour after extended engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use the recommended Cummins electronic service tool or equivalent to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning line heater relay

Malfunctioning line heater

An open circuit in the OEM harness

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3261.

Last Modified: 25-May-2019


Injector Solenoid Driver 2 Circuit - Current Below Normal or Open Circuit

FAULT CODE 331

Injector Solenoid Driver 2 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 331 PID: S2 SPN: 652 FMI: 5/5 LAMP: Amber SRT: | Malfunction detected at injector 2 circuit. | Possible reduced engine performance.
Injector Solenoid Driver Cylinder 2 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.
  • Exhaust gas recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If a fault condition is intermittent, and especially if more than one injector fault code is occurring, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid.When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation, making sure there are no shorts to a rocker lever.An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same bank exhibit misfires, look for a short circuit anywhere in the bank of cylinders.

Possible causes of a single injector fault include:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

Bank 1 - Front Bank: Fault Codes 322, 324, 331

Bank 2 - Rear Bank: Fault Codes 323, 325, 332.

Refer to Troubleshooting Fault Code 331 .

Last Modified: 13-Oct-2021


Aftertreatment 1 Diesel Particulate Filter Intake Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 3311

Aftertreatment 1 Diesel Particulate Filter Intake Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3311 PID: SPN: 3242 FMI: 0/0 LAMP: Red SRT: | The aftertreatment diesel particulate filter intake temperature sensor reading has exceeded the maximum engine protection temperature limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Aftertreatment Diesel Particulate Filter Temperature Sensor Module

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter intake temperature sensor is located in the aftertreatment system. It is located at the outlet of the diesel oxidation catalyst and before the diesel particulate filter. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active regeneration of the aftertreatment diesel particulate filter is occurring.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel particulate filter intake temperature reading was greater than 800Â°C [1472Â°F] for more than 20 seconds, or the temperature differential across the diesel oxidation catalyst was greater than 500Â°C [932Â°F] for more than 120 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Exhaust gas recirculation (EGR) valve operation will be disabled.

The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault will go inactive immediately after the aftertreatment temperatures drop below the warning limit, and will likely be inactive at the time of diagnosis. For these reasons this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault code include:

A malfunctioning fuel injector causing unburned fuel to enter the exhaust system

Excessive engine oil being introduced into the exhaust system from the engine.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3311.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Particulate Filter Outlet Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 3312

Aftertreatment 1 Diesel Particulate Filter Outlet Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3312 PID: SPN: 3246 FMI: 0/0 LAMP: Red SRT: | The aftertreatment diesel particulate filter outlet temperature sensor reading has exceeded the maximum engine protection temperature limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Aftertreatment Diesel Particulate Filter Temperature Sensor Module

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter outlet temperature sensor is located in the aftertreatment system. It is located at the outlet of the aftertreatment diesel particulate filter. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel particulate filter outlet temperature reading was greater than 800Â°C [1472Â°F] for 20 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Exhaust gas recirculation (EGR) valve operation will be disabled.

The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault will go inactive after the aftertreatment temperatures drop below the warning limit and a key cycle has occurred, and will likely be inactive at the time of diagnosis. For these reasons this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault code include:

A malfunctioning fuel injector causing unburned fuel to enter the exhaust system

Excessive engine oil being introduced into the exhaust system from the engine.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3312.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Oxidation Catalyst Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3313

Aftertreatment 1 Diesel Oxidation Catalyst Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3313 PID: SPN: 4765 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the catalyst intake temperature sensor circuit. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Temperature Sensor Module

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel oxidation catalyst intake temperature sensor is located in the aftertreatment system. It is located at the intake of the aftertreatment catalyst. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter temperature sensor module reported the aftertreatment diesel oxidation catalyst intake temperature signal was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the aftertreatment diesel oxidation catalyst intake temperature sensor reading is used.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel oxidation catalyst intake temperature sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3313.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Oxidation Catalyst Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3314

Aftertreatment 1 Diesel Oxidation Catalyst Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3314 PID: SPN: 4765 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the catalyst intake temperature sensor circuit. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Temperature Sensor Module

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel oxidation catalyst intake temperature sensor is located in the aftertreatment system. It is located at the intake of the aftertreatment catalyst. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter temperature sensor module reported the aftertreatment diesel oxidation catalyst intake temperature signal was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the aftertreatment diesel oxidation catalyst intake temperature sensor reading is used.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel oxidation catalyst intake temperature sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3314.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Oxidation Catalyst Intake Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3315

Aftertreatment 1 Diesel Oxidation Catalyst Intake Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3315 PID: SPN: 4765 FMI: 2/2 LAMP: Amber SRT: | The aftertreatment diesel oxidation catalyst intake temperature sensor is not changing with engine operating conditions. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Temperature Sensor Module

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel oxidation catalyst intake temperature sensor is located in the aftertreatment system. It is located at the intake of the aftertreatment catalyst. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the difference between the aftertreatment diesel oxidation catalyst intake temperature sensor data and diesel particulate filter intake temperature sensor data did not match the expected value for the present engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

A default value for the aftertreatment diesel oxidation catalyst intake temperature sensor reading is used.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel particulate filter intake temperature sensor

A malfunctioning aftertreatment diesel oxidation catalyst intake temperature sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3315.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Particulate Filter Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3316

Aftertreatment 1 Diesel Particulate Filter Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3316 PID: SPN: 3242 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the aftertreatment diesel particulate filter intake temperature sensor circuit. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Temperature Sensor Module

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter intake temperature sensor is located in the aftertreatment system. It is located at the outlet of the diesel oxidation catalyst and before the diesel particulate filter. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter temperature sensor module reported the aftertreatment particulate filter intake temperature signal was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the aftertreatment diesel particulate filter intake temperature reading is used.

Active and stationary regeneration of the diesel particulate filter will be disabled.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel particulate filter intake temperature sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3316.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Particulate Filter Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3317

Aftertreatment 1 Diesel Particulate Filter Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3317 PID: SPN: 3242 FMI: 3/3 LAMP: Amber SRT: | High signal voltage or open circuit detected at the aftertreatment diesel particulate filter intake temperature sensor circuit. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Temperature Sensor Module

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter intake temperature sensor is located in the aftertreatment system. It is located at the outlet of the diesel oxidation catalyst and before the diesel particulate filter. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter temperature sensor module reported the aftertreatment diesel particulate filter intake temperature signal was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the aftertreatment diesel particulate filter intake temperature reading is used.

Active and stationary regeneration of the diesel particulate filter will be disabled.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel particulate filter intake temperature sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3317.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Particulate Filter Intake Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3318

Aftertreatment 1 Diesel Particulate Filter Intake Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3318 PID: SPN: 3242 FMI: 2/2 LAMP: Amber SRT: | The aftertreatment diesel particulate filter intake temperature is not changing with engine operating conditions. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Temperature Sensor Module

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter intake temperature sensor is located in the aftertreatment system. It is located at the outlet of the diesel oxidation catalyst and before the diesel particulate filter. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the difference between the aftertreatment diesel particulate filter intake temperature sensor data and diesel particulate filter outlet temperature sensor data did not match the expected value for the present engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

A default value for the aftertreatment diesel particulate filter intake temperature reading is used.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel particulate filter intake temperature sensor

A malfunctioning aftertreatment diesel particulate filter outlet temperature sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3318.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Particulate Filter Outlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3319

Aftertreatment 1 Diesel Particulate Filter Outlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3319 PID: SPN: 3246 FMI: 3/3 LAMP: Amber SRT: | High signal voltage or open circuit detected at the aftertreatment diesel particulate filter outlet temperature sensor circuit. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Temperature Sensor Module

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter outlet temperature sensor is located in the aftertreatment system. It is located at the outlet of the aftertreatment diesel particulate filter. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter temperature sensor module reported the aftertreatment diesel particulate filter outlet temperature signal was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the aftertreatment diesel particulate filter outlet temperature sensor reading is used.

Active and stationary regeneration of the diesel particulate filter will be disabled.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel particulate filter outlet temperature sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3319.

Last Modified: 25-May-2019


Injector Solenoid Driver 4 Circuit - Current Below Normal or Open Circuit

FAULT CODE 332

Injector Solenoid Driver 4 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 332 PID: S4 SPN: 654 FMI: 5/5 LAMP: Amber SRT: | Malfunction detected at injector 4 circuit. | Possible reduced engine performance.
Injector Solenoid Driver Cylinder 4 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.
  • Exhaust gas recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If a fault condition is intermittent, and especially if more than one injector fault code is occurring, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid.When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation, making sure there are no shorts to a rocker lever.An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same bank exhibit misfires, look for a short circuit anywhere in the bank of cylinders.

Possible causes of a single injector fault include:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

Bank 1 - Front Bank: Fault Codes 322, 324, 331

Bank 2 - Rear Bank: Fault Codes 323, 325, 332.

Refer to Troubleshooting Fault Code 332 .

Last Modified: 13-Oct-2021


Aftertreatment 1 Diesel Particulate Filter Outlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3321

Aftertreatment 1 Diesel Particulate Filter Outlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3321 PID: SPN: 3246 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the aftertreatment diesel particulate filter outlet temperature sensor circuit. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Temperature Sensor Module

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter outlet temperature sensor is located in the aftertreatment system. It is located at the outlet of the aftertreatment diesel particulate filter. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter temperature sensor module reported the aftertreatment diesel particulate filter outlet temperature signal was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the aftertreatment diesel particulate filter outlet temperature sensor reading is used.

Active and stationary regeneration of the diesel particulate filter will be disabled.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel particulate filter outlet temperature sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3321.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Particulate Filter Outlet Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3322

Aftertreatment 1 Diesel Particulate Filter Outlet Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3322 PID: SPN: 3246 FMI: 2/2 LAMP: Amber SRT: | The aftertreatment diesel particulate filter outlet temperature is not changing with engine operating conditions. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Temperature Sensor Module

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter outlet temperature sensor is located in the aftertreatment system. It is located at the outlet of the aftertreatment diesel particulate filter. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel particulate filter outlet temperature sensor reading did not change with engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

A default value for the aftertreatment diesel particulate filter outlet temperature sensor reading is used.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel particulate filter intake temperature sensor

A malfunctioning aftertreatment diesel particulate filter outlet temperature sensor

Build up or plugging on the inlet face of the Diesel Particulate Filter.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3322.

Last Modified: 25-May-2019


Accelerator Pedal Position 1 - Abnormal Update Rate

FAULT CODE 3326

Accelerator Pedal Position 1 - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3326 PID: SPN: 91 FMI: 9/9 LAMP: Red SRT: | The ECM expected information from a multiplexed accelerator pedal or lever sensor but did not receive it soon enough or did not receive it at all. | Engine will only idle.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices may not function as desired.

This fault can occur for the following reasons:

The ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the Cummins® ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.

This fault can also be caused by a bad J1939 data link connection between the OEM VECU and Cummins® ECM, a bad connection between the component and the OEM VECU, bad OEM VECU or bad Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration. It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 3326 .

Last Modified: 13-Oct-2021


Transmission Output Shaft Speed - Abnormal Update Rate

FAULT CODE 3328

Transmission Output Shaft Speed - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3328 PID: SPN: 191 FMI: 9/9 LAMP: Amber SRT: | No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the transmission output shaft speed sensor. | None on performance.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins ECM and used for controlling the engine. The Cummins ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices may not function as desired.

This fault can occur for the following reasons:

When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the CumminsÂ ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the CumminsÂ ECM, or the OEM VECU is not set up to transmit the multiplexed component message.

This fault can also be caused by a bad J1939 data link connection between the OEM VECU and Cummins ECM, a bad connection between the component and the OEM VECU, bad OEM VECU or bad Cummins ECM. It may be necessary to contact the OEM for proper multiplexing configuration. It is possible to use the recommended Cummins electronic service tool or equivalent to monitor multiplexed components.

It is possible to use the recommended Cummins electronic service tool or equivalent to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3328.

Last Modified: 25-May-2019


Engine Idle Fuel Quantity - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3338

Engine Idle Fuel Quantity - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3338 PID: SPN: 5395 FMI: 1/18 LAMP: Amber SRT: | The fueling quantity at idle is lower than expected. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to verify injector operation. During selected conditions, each injector is fired. The fueling quantity and timing are then compared to a specified threshold.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating at idle and PTO is not active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the idle fuel quantity was lower than expected.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning fuel injectors

Refer to Troubleshooting Fault Code 3338.

Last Modified: 25-May-2019


Engine Coolant Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 334

Engine Coolant Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 334 PID: P110 SPN: 110 FMI: 2/2 LAMP: Amber SRT: | The engine coolant temperature sensor is reading an erratic value. | None on performance.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

The engine must be turned OFF for period of 8 hours before this diagnostic will run. This diagnostic runs when the keyswitch is turned to the ON position after an 8 hour cold soak.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was greater than other engine temperature sensors by a calibratable value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

A default value is used for the engine coolant temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • Monitor Engine Coolant Temperature Using the recommended Cummins electronic service tool or equivalent during the Diagnostic Road Test or Dynamometer run. Coolant temperature should remain in the normal operating range.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning engine coolant thermostat.

In-range malfunction of the engine coolant temperature sensor

High resistance in the engine coolant temperature sensor signal or return lines.

Refer to Troubleshooting Fault Code 334.

Last Modified: 25-May-2019


Engine Exhaust Gas Recirculation Cooler Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3342

Engine Exhaust Gas Recirculation Cooler Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3342 PID: SPN: 4752 FMI: 1/18 LAMP: Amber SRT: | The EGR cooler is not cooling the recirculated exhaust gas sufficiently. | None on performance.
Engine Exhaust Gas Recirculation Temperature Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) temperature sensor is a variable resistor sensor and is used to measure the temperature of the EGR gas flow after it exits the EGR cooler. The engine control module (ECM) supplies 5 volts to the EGR temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the EGR flow temperature.

The EGR temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The EGR temperature sensor is located on the EGR connection tube between the EGR cooler and the air intake connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR temperature was greater than a threshold for 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning EGR temperature sensor

A malfunctioning EGR cooler.

Refer to Troubleshooting Fault Code 3342.

Last Modified: 25-May-2019


Engine Charge Air Cooler Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3343

Engine Charge Air Cooler Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3343 PID: SPN: 5285 FMI: 1/18 LAMP: Amber SRT: | The engine charge air cooler is not cooling the intake air flow sufficiently. | None on performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature was greater than 105C [221F] for 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning intake manifold temperature sensor

A malfunctioning charge-air cooler.

Refer to Troubleshooting Fault Code 3343.

Last Modified: 25-May-2019


Turbocharger 1 Compressor Intake Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 3348

Turbocharger 1 Compressor Intake Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3348 PID: SPN: 1176 FMI: 1/1 LAMP: Red SRT: | The estimated differential pressure across the turbocharger is above the critical level. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Engine Control Module (ECM)

Circuit Description

The ECM calculates a differential pressure across the turbocharger using the intake manifold pressure sensor and the crankcase pressure sensor.

Component Location

The intake manifold pressure sensor is located in the air intake horn. The crankcase pressure sensor is mounted to the crankcase breather filter housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the calculated differential pressure across the turbocharger was greater than a threshold.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

An engine speed derate will occur when the fault is registered.

If the problem persists for 5 minutes, an engine shutdown procedure will begin.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Crankcase filter needs to be changed.

If the crankcase filter is being replaced frequently for this fault code, reference the Crankcase Coalescing Filter - Frequent Replacement troubleshooting symptom tree.

Air intake filter needs to be changed.

A plugged or restricted crankcase ventilation system.

Check the tube between the engine and the coalescing filter.

Check the draft tube going from the coalescing filter to the atmosphere or intake manifold.

Consider the working environment. Ice, snow, or mud can temporarily block the tube and then fall away.

Complete the entire troubleshooting tree whether Fault Code 3348 is active or inactive.

If a problem is found in the early steps, the troubleshooting tree should still be completed.

Refer to Troubleshooting Fault Code 3348.

Last Modified: 25-May-2019


Intake Manifold 1 Pressure - Abnormal Rate of Change

FAULT CODE 3361

Intake Manifold 1 Pressure - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3361 PID: SPN: 102 FMI: 10/10 LAMP: Amber SRT: | The VGT position reading is stuck. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports malfunctions back to the primary engine ECM, using the J1939 data link. The ECM then decodes the error message and converts it to a fault code.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic has to meet specific engine and aftertreatment conditions to run and complete.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the Variable Geometry Turbocharger (VGT) actuator was slow to meet the commanded position.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning variable geometry turbocharger (VGT)

High exhaust restriction.

Refer to Troubleshooting Fault Code 3361.

Last Modified: 25-May-2019


Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3366

Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3366 PID: SPN: 111 FMI: 1/18 LAMP: None SRT: | Low engine coolant level detected. | None on performance.
Engine Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level sensor signal voltage was greater than 3-VDC for more than 30 seconds and engine coolant temperature was greater than 107Â°C [225Â°F].

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

For On-Board Diagnostics (OBD) engines, the ECM illuminates the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code goes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3366.

Last Modified: 25-May-2019


Roll Over Protection Brake Control Active - Condition Exists

FAULT CODE 3374

Roll Over Protection Brake Control Active - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3374 PID: SPN: 1818 FMI: 11/31 LAMP: None SRT: | The ECM received a message from the anti-lock braking (ABS) controller, inhibiting cruise control operation. | Cruise control could possibly not operate.
Engine Control Module (ECM)

Circuit Description

Certain anti-lock braking (ABS) controllers communicate with the engine control module (ECM) through the SAE J1939 data link. Under certain driving conditions, the anti-lock braking (ABS) controller can send a cruise control inhibit message to the ECM and cruise control will temporarily be disabled.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The anti-lock bracking (ABS) controller detected certain driving conditions and inhibited cruise control.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Cruise control has temporarily been inhibited.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, cruise control could possibly not function. This is an information only fault code, indicating that the anti-lock braking (ABS) controller detected certain driving conditions and temporarily inhibited cruise control operation. Refer to the OEM service manual.

Refer to Troubleshooting Fault Code 3374.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Particulate Filter Regeneration too Frequent - Condition Exists

FAULT CODE 3375

Aftertreatment 1 Diesel Particulate Filter Regeneration too Frequent - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3375 PID: SPN: 5397 FMI: 11/31 LAMP: Amber SRT: | The system has detected the need for an active regeneration has occurred too soon following the last active regeneration. | None on performance.
Engine Control Module (ECM)

Circuit Description

The ECM records the time from the completion of an active regeneration of the aftertreatment diesel particulate filter until the ECM request another active regeneration of the diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic only runs after successful completion of an active regeneration of the aftertreatment diesel particulate filter.

Conditions for Setting the Fault Codes

The time between the completion of a successful active regeneration and the requests for another active regeneration was less than a threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • This diagnostic can not be run in the shop environment.
  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • It is necessary to use the "Reset All Faults" command in the recommended Cummins® electronic service tool or equivalent to clear this fault and extinguish the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL).

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment fuel injector

  • A face plugged aftertreatment diesel oxidation catalyst

A malfunctioning aftertreatment diesel particulate filter differential pressure sensor

  • An engine malfunction resulting in high engine out soot.
  • Excessive ash in the DPF
Refer to Troubleshooting Fault Code 3375 .

Last Modified: 13-Oct-2021


Aftertreatment 1 Diesel Particulate Filter Incomplete Regeneration - Condition Exists

FAULT CODE 3376

Aftertreatment 1 Diesel Particulate Filter Incomplete Regeneration - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3376 PID: SPN: 5319 FMI: 11/31 LAMP: Amber SRT: | The system has detected that the aftertreatment diesel particulate filter differential pressure is too high following an active regeneration. | Possible frequent need for aftertreatment regeneration.
Engine Control Module (ECM)

Circuit Description

The engine aftertreatment system monitors the soot load in the aftertreatment diesel particulate filter. Under normal operating conditions, the aftertreatment diesel particulate filter is self-cleaning, where soot is converted to carbon dioxide, nitrogen, and water. Under light load operating conditions, it can be necessary to perform a stationary regeneration of the aftertreatment diesel particulate filter. The soot load in the aftertreatment diesel particulate filter is estimated, using the aftertreatment differential pressure sensor and the calculated soot output of the engine.

Component Location

The aftertreatment diesel particulate filter differential pressure sensor is mounted on the diesel particulate filter. It is a combination sensor that detects both diesel particulate filter differential pressure and outlet pressure. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic only runs after successful completion of an active regeneration of the aftertreatment diesel particulate filter.

Conditions for Setting the Fault Codes

The estimated soot load in the aftertreatment diesel particulate filter was higher than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment fuel injector

  • Malfunctioning aftertreatment temperature sensors

A malfunctioning aftertreatment diesel oxidation catalyst

  • A malfunctioning or stuck in-range aftertreatment diesel particulate filter differential pressure sensor
  • An engine malfunction resulting in high engine out smoke
  • Excessive ash in the DPF

A damaged or malfunctioning OEM wiring harness to the differential pressure sensor.

Refer to Troubleshooting Fault Code 3376 .

Last Modified: 13-Oct-2021


Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 338

Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 338 PID: S87 SPN: 1267 FMI: 3/3 LAMP: Amber SRT: | Open circuit or short to voltage source detected at the idle shutdown vehicle accessory/ignition bus relay circuit. | Vehicle accessories or ignition bus loads controlled by the idle shutdown relay will not power up.
Idle Shutdown Vehicle Accessories Relay Driver Circuit

Circuit Description

The Engine Control Module (ECM) Idle Shutdown feature has an optional parameter for a shutdown accessory relay. When this parameter is set to "Installed", the ECM sends a signal to energize the relay and turn off vehicle accessories during idle shutdown events. The idle shutdown relay return circuit varies by Original Equipment Manufacturer (OEM). The return circuit can be returned to the ECM through the ECM Return (General) or connected directly to ground. Refer to the OEM service manual to determine grounding configuration.

Component Location

The idle shutdown relay location varies by OEM. Refer to the OEM service manual to determine the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the idle shutdown relay pulse width modulated (PWM) signal was at system voltage when the pulse width modulated (PWM) signal was commanded OFF.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The accessories controlled by the idle shutdown relay will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The ECM monitors the voltage level on this circuit. If it detects a voltage when the signal is commanded off, it records this fault code. This fault code can be caused by:

ECM Idle Shutdown feature set up incorrectly.

Open circuit in the idle shutdown relay, OEM harness, or connectors.

Short circuit to a voltage source in the OEM harness or relay.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 338.

Last Modified: 25-May-2019


Engine Exhaust Gas Recirculation (EGR) System - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3382

Engine Exhaust Gas Recirculation (EGR) System - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3382 PID: SPN: 3058 FMI: 1/18 LAMP: Amber SRT: | Measured EGR flow is lower than commanded. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The exhaust gas recirculation (EGR) differential pressure sensor has two ports that sense exhaust pressure. The sensor outputs a voltage which represents the pressure difference between the two ports located across an orifice in the EGR tube. The engine control module (ECM) uses this pressure to determine how much exhaust gas is flowing in the EGR connection tube to the intake manifold. This information is used to control the EGR valve for correct emission levels.The ECM provides a 5 volt supply to the EGR differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The EGR differential pressure sensor provides a signal to the ECM on the EGR differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure in the EGR crossover tube.The EGR differential pressure sensor measures the exhaust gas pressure drop across the EGR differential pressure orifice. This pressure drop is used to calculate the amount of EGR flow into the intake manifold.

Component Location

The EGR Valve and EGR Differential Pressure Sensor location varies depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the actual EGR flow was less than what was being commanded based on the current engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code are:

Leaks or restrictions in the EGR flow plumbing

Internally leaking EGR valve

Stuck closed EGR valve

Malfunctioning EGR differential pressure sensor.

Refer to Troubleshooting Fault Code 3382.

Last Modified: 25-May-2019


Engine Exhaust Gas Recirculation (EGR) System - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3383

Engine Exhaust Gas Recirculation (EGR) System - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3383 PID: SPN: 3058 FMI: 0/16 LAMP: Amber SRT: | Measured EGR flow is higher than commanded. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The exhaust gas recirculation (EGR) differential pressure sensor has two ports that sense exhaust pressure. The sensor outputs a voltage which represents the pressure difference between the two ports located across an orifice in the EGR tube. The engine control module (ECM) uses this pressure to determine how much exhaust gas is flowing in the EGR connection tube to the intake manifold. This information is used to control the EGR valve for correct emission levels.The ECM provides a 5 volt supply to the EGR differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The EGR differential pressure sensor provides a signal to the ECM on the EGR differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure in the EGR crossover tube.The EGR differential pressure sensor measures the exhaust gas pressure drop across the EGR differential pressure orifice. This pressure drop is used to calculate the amount of EGR flow into the intake manifold.

Component Location

The EGR Valve and EGR Differential Pressure Sensor location varies depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the measured EGR flow was greater than what was being commanded based on the present engine.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault are:

Blockage, restrictions, or leaks in the EGR differential pressure sensor ports

Leaking EGR valve

Stuck open EGR valve

Malfunctioning EGR differential pressure sesnor.

Refer to Troubleshooting Fault Code 3383.

Last Modified: 25-May-2019


Intake Manifold 1 Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3385

Intake Manifold 1 Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3385 PID: P105 SPN: 105 FMI: 1/18 LAMP: Amber SRT: | Intake Manifold 1 Temperature - Data Valid But Below Normal Operational Range - Moderately Severe Level. The intake manifold temperature is below a critical threshold | None on performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating at idle.

Conditions for Setting the Fault Codes

The intake manifold temperature was less than 20Â°C [68Â°F] while the engine was idleing for an extended period of time.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The EGR valve was closed because the engine was idling with cold intake manifold temperatures for an extended period of time.

Refer to Troubleshooting Fault Code 3385.

Last Modified: 25-May-2019


Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 339

Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 339 PID: S87 SPN: 1267 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at the idle shutdown vehicle accessory or ignition bus relay circuit when commanded ON. | Vehicle accessories or ignition bus loads controlled by the idle shutdown relay will not power up.
Idle Shutdown Vehicle Accessories Relay Driver Circuit

Circuit Description

The Engine Control Module (ECM) Idle Shutdown feature has an optional parameter for a shutdown accessory relay. When this parameter is set to "Installed", the ECM sends a signal to energize the relay and turn off vehicle accessories during idle shutdown events. The idle shutdown relay return circuit varies by Original Equipment Manufacturer (OEM). The return circuit can be returned to the ECM through the ECM Return (General) or connected directly to ground. Refer to the OEM service manual to determine grounding configuration.

Component Location

The idle shutdown relay location varies by OEM. Refer to the OEM service manual to determine the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the idle shutdown relay pulse width modulated (PWM) signal was NOT at system voltage when the pulse width modulated (PWM) signal was commanded ON.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The accessories controlled by the idle shutdown relay will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The ECM monitors the voltage level on this circuit. This fault code is logged if it detects a low voltage when the relay signal is commanded on. This fault code can be caused by a short circuit to ground in the idle shutdown relay, OEM harness, or connectors.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 339.

Last Modified: 25-May-2019


Aftertreatment Diesel Particulate Filter 1 Conditions Not Met for Active Regeneration - Condition Exists

FAULT CODE 3396

Aftertreatment Diesel Particulate Filter 1 Conditions Not Met for Active Regeneration - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3396 PID: SPN: 3750 FMI: 11/31 LAMP: Amber SRT: | The aftertreatment temperatures are not warm enough for aftertreatment injection. | Possible frequent need for aftertreatment regeneration.
Engine Control Module (ECM)

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and the ECM is requesting active regeneration of the aftertreatment diesel particulate filter.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel oxidation catalyst temperature was too low for active regeneration of the diesel particulate filter.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and perform the recommended Cummins electronic service tool or equivalent Aftertreatment Diesel Particulate Filter Regeneration Test.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates that the aftertreatment diesel oxidation catalyst temperatures were NOT warm enough to inject fuel for active regeneration of the diesel particulate filter.

Refer to Troubleshooting Fault Code 3396.

Last Modified: 25-May-2019


Transmission Output Shaft Speed - Received Network Data in Error

FAULT CODE 3418

Transmission Output Shaft Speed - Received Network Data in Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3418 PID: SPN: 191 FMI: 2/19 LAMP: Amber SRT: | The J1939 multiplexing controller has indicated a malfunction of the transmission output shaft speed sensor. | None on performance.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins ECM and used for controlling the engine. The Cummins ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The OEM VECU determined there was a malfunction of the transmission output shaft speed sensor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The J1939 multiplexing controller has indicated a malfunction of the transmission output shaft speed sensor.

Refer to Troubleshooting Fault Code 3418.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Line Heater 3 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3422

Aftertreatment 1 Diesel Exhaust Fluid Line Heater 3 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3422 PID: SPN: 4344 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the diesel exhaust fluid line heater 3 circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Line Heater 3 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heaters are used to defrost and/or prevent freezing of the diesel exhaust fluid lines.

Component Location

The aftertreatment diesel exhaust fluid line heater 3 is located on the suction line between the diesel exhaust fluid tank and diesel exhaust fluid dosing unit.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and line heating is commanded OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the line heater voltage was above a calibratible value and the line heater current was above a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The line heater will be disabled.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use the recommended Cummins electronic service tool or equivalent to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning line heater

Malfunctioning aftertreatment diesel exhaust fluid contoller.

A short circuit to battery in the OEM harness

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3422.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Line Heater 3 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3423

Aftertreatment 1 Diesel Exhaust Fluid Line Heater 3 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3423 PID: SPN: 4344 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the diesel exhaust fluid line heater 3 circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Line Heater 3 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heaters are used to defrost and/or prevent freezing of the diesel exhaust fluid lines.

Component Location

The aftertreatment diesel exhaust fluid line heater 3 is located on the suction line between the diesel exhaust fluid tank and diesel exhaust fluid dosing unit.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and line heating is commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the line heater voltage was below a calibratible value and the line heater current was below a calibratable valure.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The line heater will be disabled.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use the recommended Cummins electronic service tool or equivalent to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning line heater

A short circuit to ground in the OEM harness

Refer to Troubleshooting Fault Code 3423.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Line Heater 3 Circuit - Current Below Normal or Open Circuit

FAULT CODE 3425

Aftertreatment 1 Diesel Exhaust Fluid Line Heater 3 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3425 PID: SPN: 4344 FMI: 5/5 LAMP: Amber SRT: | Open circuit detected in the diesel exhaust fluid line heater 3. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Line Heater 3 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heaters are used to defrost and/or prevent freezing of the diesel exhaust fluid lines.

Component Location

The aftertreatment diesel exhaust fluid line heater 3 is located on the suction line between the diesel exhaust fluid tank and diesel exhaust fluid dosing unit.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and line heating is commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an open in the line heater circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Engine torque will be severely reduced.

Vehicle speed will be limited to 8 km [5 mi] per hour after extended engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use the recommended Cummins electronic service tool or equivalent to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning line heater relay

Malfunctioning line heater

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3425.

Last Modified: 25-May-2019


Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

FAULT CODE 343

Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 343 PID: S254 SPN: 629 FMI: 12/12 LAMP: Amber SRT: | ECM power supply errors have been detected. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a read or write error internal to the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter. If unswitched power is coming from the starter, it is possible for the battery voltage to drop low enough during cranking to set this fault active.

This fault can also be caused by resistance in the ECM battery supply (+) or (-) circuits. Resistance in these circuits can cause the voltage level at the ECM input to drop low enough to set Fault Code 343 active.

Refer to Troubleshooting Fault Code 343.

Last Modified: 25-May-2019


Aftertreatment Intake Gas Sensor Heater - Current Below Normal or Open Circuit

FAULT CODE 3446

Aftertreatment Intake Gas Sensor Heater - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3446 PID: SPN: 3222 FMI: 5/5 LAMP: Amber SRT: | An internal circuit error has been detected by the aftertreatment intake NOx sensor. | Possible reduced engine performance.
Aftertreatment Intake NOx Sensor Circuit

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the NOx emissions at the intake of the aftertreatment system.

Component Location

The aftertreatment intake NOx sensor is mounted on the engine near the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment diesel oxidation catalyst intake temperature sensor has been above 150°C [302°F] for 5 minutes while the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment intake NOx sensor assembly.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be severely reduced.

Vehicle speed will be limited to 8 km [5 mi] per hour after extended engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using the recommended Cummins electronic service tool or equivalent.
  • The aftertreatment diesel oxidation catalyst intake temperature must be above 150°C [302°F] for 5 minutes before the aftertreatment intake NOx sensor can run its internal diagnostics.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

The aftertreatment intake NOx sensor has malfunctioned or is damaged

The aftertreatment intake NOx sensor internal heater has malfunctioned

The NOx sensor part number is incorrect.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3446.

Last Modified: 25-May-2019


Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component

FAULT CODE 346

Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 346 PID: S253 SPN: 630 FMI: 12/12 LAMP: Amber SRT: | Invalid switch configuration adjustable parameter setting have been detected by the Engine Control Module (ECM). | Various optional switch inputs to the ECM may not operate correctly.
Engine Control Module (ECM)

Circuit Description

The Original Equipment Manufacturer (OEM) wiring harness connects multiple outputs or switched inputs to the ECM which can be enabled or disabled using recommended Cummins electronic service tool or equivalent, such as such as the accelerator interlock/engine torque limit switch or the clutch/engine protection override switch. Many of the outputs and switched inputs share a common wire on the OEM wiring harness. Refer to the engine wiring diagram to determine which features share common wires in the OEM harness.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected features which share a common input or output to the ECM were simultaneously enabled..

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Many of the outputs and switched inputs share a common wire on the OEM wiring harness. If two features that share a common OEM wire are enabled simultaneously in the ECM, this fault code will be logged. To disable the fault code, disable one of the features on the shared OEM wire. For example, if the accelerator interlock switch and powertrain protection torque limit switch are both enabled in the ECM, either disable one of the features with the recommended Cummins electronic service tool or equivalent or configure one of the features to be multiplexed using the SAE J1939 multiplexing feature.

Refer to Troubleshooting Fault Code 346.

Last Modified: 25-May-2019


Anti-Lock Braking (ABS) Controller - Abnormal Update Rate

FAULT CODE 3488

Anti-Lock Braking (ABS) Controller - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3488 PID: SPN: 563 FMI: 9/9 LAMP: Amber SRT: | No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the anti-lock braking (ABS) controller. | None on performance.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins ECM and used for controlling the engine. The Cummins ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices may not function as desired.

Potential causes of this fault code include:

When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the CumminsÂ ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the CumminsÂ ECM, or the OEM VECU is not set up to transmit the multiplexed component message.

This fault can also be caused by a bad J1939 data link connection between the OEM VECU and Cummins ECM, a bad connection between the component and the OEM VECU, bad OEM VECU or bad Cummins ECM. It may be necessary to contact the OEM for proper multiplexing configuration. It is possible to use the recommended Cummins electronic service tool or equivalent to monitor multiplexed components.

It is possible to use the recommended Cummins electronic service tool or equivalent to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3488.

Last Modified: 25-May-2019


Real Time Clock - Abnormal Rate of Change

FAULT CODE 3492

Real Time Clock - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3492 PID: SPN: 251 FMI: 10/10 LAMP: Amber SRT: | The real time clock indicates a stuck engine off timer. | None on performance.
Engine Control Module (ECM)

Circuit Description

The real-time clock consists of a timing chip internal to the engine control module (ECM) which monitors engine off time, i.e. how long the engine has been shut down.

Component Location

The real time clock is a timing chip internal to the ECM and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

The engine off timer was not counting correctly and does not match other timers in the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

The ECM will not be able to monitor engine off time accurately.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Monitoring the engine off time is necessary in to make sure that all other engine sensors and actuators are performing correctly. If the ECM is recalibrated or replaced during the repair and the fault code is no longer present, the instructions in the "Conditions for Clearing" section must be followed in order for the diagnostic to run again and validate the repair.

Potential causes of this fault code include:

Malfunctioning real time clock chip internal to the ECM

Engine calibration issue.

Refer to Troubleshooting Fault Code 3492.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 3497

Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3497 PID: SPN: 1761 FMI: 1/17 LAMP: Maintenance SRT: | The aftertreatment diesel exhaust fluid tank level is low. | None on performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid level sensor is used to monitor the diesel exhaust fluid level inside the diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the following conditions are met:

Keyswitch is in the ON position or when the engine is running.

Ambient temperature is above -20Â°C [-4Â°F].

Vehicle altitude change is less than 305 m [1000 ft] in 1 hour.

Conditions for Setting the Fault Codes

The diesel exhaust fluid tank level was low.

Action Taken When the Fault Code is Active

The Diesel Exhaust Fluid Lamp will be illuminated.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the diesel exhaust fluid lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates that the diesel exhaust fluid level is low, and the tank must be refilled at the operator's earliest convenience.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3497.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3498

Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3498 PID: SPN: 1761 FMI: 1/18 LAMP: Maintenance SRT: | The aftertreatment diesel exhaust fluid tank level is very low. | None on performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid level sensor is used to monitor the diesel exhaust fluid level inside the diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the following conditions are met:

Keyswitch is in the ON position or when the engine is running.

Ambient temperature is above -20Â°C [-4Â°F].

Vehicle altitude change is less than 305 m [1000 ft] in 1 hour.

Conditions for Setting the Fault Codes

The diesel exhaust fluid tank level was very low.

Action Taken When the Fault Code is Active

The diesel exhaust fluid lamp will be flashing.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the diesel exhaust fluid lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates that the diesel exhaust fluid level is very low. The diesel exhaust fluid tank must be refilled.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3498.

Last Modified: 25-May-2019


Injector Power Supply - Bad Intelligent Device or Component

FAULT CODE 351

Injector Power Supply - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 351 PID: S251 SPN: 3597 FMI: 12/12 LAMP: Amber SRT: | The ECM measured injector boost voltage is low. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

Between each injection event, the Engine Control Module (ECM) attempts to recharge the injector power supply. The injector power supply consists of a bank of capacitors. This power supply is maintained at high voltage. Recharging is accomplished by recovering energy stored in the injector solenoids. For the injector power supply to remain fully charged, there must be good ECM battery power and ground, a good engine speed/position sensor, and good injector circuits.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the measured injector power supply voltage was less than the commanded injector power supply voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code will become active after key ON if the battery charge is above a minimum threshold, and, at the same time, the measured injector power supply voltage is lower than the commanded injector power supply voltage.

Refer to Troubleshooting Fault Code 351.

Last Modified: 25-May-2019


Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 352

Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 352 PID: S212 SPN: 3509 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at sensor supply number 1 circuit. | Possible reduced engine performance.
Sensor Supply 1 Circuit

Circuit Description

The sensor supply 1 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 1 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 1 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value is used for all of the sensors on the sensor supply 1 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Low voltage on the +5 volt supply wire can be caused by a short circuit to ground in a supply wire, a short circuit between a supply wire and a return wire, a malfunctioning sensor, or a malfunctioning ECM power supply.

During the fault code response test outlined for each sensor connected to sensor supply number 1, Fault Code 352 must be active before unplugging each sensor. If the fault code is not active, but can be easily duplicated by operating the engine, the following can be performed:

Operate the engine under the conditions that will cause Fault Code 352 to become active, even if it logs for a short period of time. Unplug one sensor at a time until Fault Code 352 stops logging under the test conditions. Each sensor can be unplugged with the engine running. Note: The engine may not start if the camshaft position sensor is unplugged.

Refer to Troubleshooting Fault Code 352.

Last Modified: 25-May-2019


Wheel-Based Vehicle Speed - Received Network Data in Error

FAULT CODE 3525

Wheel-Based Vehicle Speed - Received Network Data in Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3525 PID: SPN: 84 FMI: 2/19 LAMP: Amber SRT: | The J1939 multiplexing controller has indicated a malfunction of the wheel-based vehicle speed sensor. | Engine speed limited to Maximum Engine Speed without VSS parameter value. Cruise Control, Gear-Down Protection, and Road Speed Governor will not work.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins ECM and used for controlling the engine. The Cummins ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The OEM VECU determined that there was a malfunction of the wheel-based vehicle speed sensor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The J1939 multiplexing controller has indicated a malfunction of the wheel-based vehicle speed sensor.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3525.

Last Modified: 25-May-2019


Wheel-Based Vehicle Speed - Abnormal Update Rate

FAULT CODE 3526

Wheel-Based Vehicle Speed - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3526 PID: SPN: 84 FMI: 9/9 LAMP: Amber SRT: | No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the wheel-based vehicle speed sensor. | Engine speed limited to Maximum Engine Speed without VSS parameter value. Cruise Control, Gear-Down Protection, and Road Speed Governor will not work.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins ECM and used for controlling the engine. The Cummins ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices may not function as desired.

Possible causes of this fault code include:

When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the CumminsÂ ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the CumminsÂ ECM, or the OEM VECU is not set up to transmit the multiplexed component message.

This fault can also be caused by a bad J1939 data link connection between the OEM VECU and Cummins ECM, a bad connection between the component and the OEM VECU, bad OEM VECU or bad Cummins ECM. It may be necessary to contact the OEM for proper multiplexing configuration. It is possible to use the recommended Cummins electronic service tool or equivalent to monitor multiplexed components.

It is possible to use the recommended Cummins electronic service tool or equivalent to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3526.

Last Modified: 25-May-2019


Accelerator Pedal or Lever Idle Validation Switch - Received Network Data in Error

FAULT CODE 3527

Accelerator Pedal or Lever Idle Validation Switch - Received Network Data in Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3527 PID: SPN: 558 FMI: 2/19 LAMP: Red SRT: | The J1939 multiplexing controller has indicated a malfunction of the accelerator pedal or lever idle validation switch. | Engine will only idle.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins ECM and used for controlling the engine. The Cummins ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The OEM VECU determined that there was a malfunction of the accelerator pedal or lever idle validation switch.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The J1939 multiplexing controller has indicated a malfunction of the accelerator pedal or lever idle validation switch.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3527.

Last Modified: 25-May-2019


Accelerator Pedal or Lever Idle Validation Switch - Abnormal Update Rate

FAULT CODE 3528

Accelerator Pedal or Lever Idle Validation Switch - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3528 PID: SPN: 558 FMI: 9/9 LAMP: Red SRT: | No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the accelerator pedal or lever idle validation switch. | Engine will only idle.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins ECM and used for controlling the engine. The Cummins ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices can possibly not function as desired.

This fault can occur for the following reasons:

The ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the CumminsÂ ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the CumminsÂ ECM, or the OEM VECU is not set up to transmit the multiplexed component message.

This fault can also be caused by a bad J1939 data link connection between the OEM VECU and Cummins ECM, a bad connection between the component and the OEM VECU, bad OEM VECU or bad Cummins ECM. It may be necessary to contact the OEM for proper multiplexing configuration. It is possible to use the recommended Cummins electronic service tool or equivalent to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3528.

Last Modified: 25-May-2019


Engine Intake Throttle Actuator Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3539

Engine Intake Throttle Actuator Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3539 PID: SPN: 51 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the engine intake air throttle position sensor circuit. | Possible reduced engine performance.
Engine Intake Air Throttle Position Sensor Circuit

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine intake air throttle position sensor circuit voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Engine intake air throttle actuation will be disabled. The engine intake air throttle will default to the open position.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning engine intake air throttle position sensor

A short circuit to battery in the engine harness.

An open circuit in the engine harness

Refer to Troubleshooting Fault Code 3539.

Last Modified: 25-May-2019


Engine Intake Throttle Actuator Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3541

Engine Intake Throttle Actuator Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3541 PID: SPN: 51 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the engine intake air throttle position sensor circuit. | Possible reduced engine performance.
Engine Intake Air Throttle Position Sensor Circuit

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine intake air throttle position sensor circuit voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Engine intake air throttle actuation will be disabled. The engine intake air throttle will default to the open position.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning engine intake air throttle position sensor

A short circuit to ground in the engine harness

An open circuit in the engine harness

Refer to Troubleshooting Fault Code 3541.

Last Modified: 25-May-2019


Engine Intake Throttle Actuator Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3542

Engine Intake Throttle Actuator Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3542 PID: SPN: 51 FMI: 2/2 LAMP: Amber SRT: | The engine intake air throttle posistion feedback is erratic or incorrect. | Possible reduced engine performance.
Engine Intake Air Throttle Position Sensor Circuit

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine intake air throttle position sensor signal is incorrect.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Engine intake air throttle actuation will be disabled. The engine intake air throttle will default to the open position.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning engine intake air throttle position sensor

Refer to Troubleshooting Fault Code 3542.

Last Modified: 25-May-2019


NOx Limits Exceeded Due to Insufficient Reagent Quality - Condition Exists

FAULT CODE 3543

NOx Limits Exceeded Due to Insufficient Reagent Quality - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3543 PID: SPN: 4094 FMI: 11/31 LAMP: Amber SRT: | The diesel exhaust fluid quality is not sufficient enough to provide adequate NOx reduction. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) monitors the NOx concentration in the engine's exhaust gases using an aftertreatment intake NOx sensor and an aftertreatment outlet NOx sensor. By comparing these two values, the ECM is able to determine the conversion efficiency of the SCR catalyst and dosing system.

Component Location

The SCR catalyst is located in the vehicle's exhaust system, after the diesel particulate filter and decomposition tube.

Conditions for Running the Diagnostics

This diagnostic has to meet specific engine and aftertreatment conditions to run and complete.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the NOx conversion across the SCR catalyst was less than expected, and the diesel exhaust fluid tank has recently been refilled.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Engine torque will be severely reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • It is necessary to use the "Reset All Faults" command in the recommended Cummins electronic service tool or equivalent to clear this fault and extinguish the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL).

Shop Talk

Troubleshoot all other active NOx sensor and SCR dosing system related fault codes before this fault.

Possible causes of this fault code include:

Malfunctioning aftertreatment diesel exhaust fluid dosing system.

Exhaust system leaks

Malfunctioning SCR catalyst

Degraded, diluted, or incorrect diesel exhaust fluid

Diesel exhaust fluid deposits in the decomposition tube.

Refer to Troubleshooting Fault Code 3543.

Last Modified: 25-May-2019


Aftertreatment 1 Outlet NOx Sensor - Abnormal Rate of Change

FAULT CODE 3545

Aftertreatment 1 Outlet NOx Sensor - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3545 PID: SPN: 3226 FMI: 10/10 LAMP: Amber SRT: | The aftertreatment outlet NOx sensor reading is not valid. | None on performance.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR outlet temperature has been above 200°C [392° F] for a calibratible period of time while the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment outlet NOx sensor reading was not valid.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using the recommended Cummins electronic service tool or equivalent.
  • The aftertreatment SCR outlet temperature must be above 200Â° C [392Â° F] for 60 seconds before the aftertreatment outlet NOx sensor can run its internal diagnostics.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code sets when the aftertreatment outlet NOx sensor indicates to the ECM that it is not providing valid data.

Troubleshoot the aftertreatment outlet NOx sensor for Fault Codes 1887, 2771, or 3682 before troubleshooting this fault code.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3545.

Last Modified: 25-May-2019


Aftertreatment Diesel Exhaust Fluid Tank Empty - Condition Exists

FAULT CODE 3547

Aftertreatment Diesel Exhaust Fluid Tank Empty - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3547 PID: SPN: 4096 FMI: 11/31 LAMP: Amber SRT: | The diesel exhaust fluid tank is empty. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid level sensor is used to monitor the diesel exhaust fluid level inside the diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the following conditions are met:

Keyswitch is in the ON position or when the engine is running.

Ambient temperature is above -20Â°C [-4Â°F].

Vehicle altitude change is less than 305 m [1000 ft] in 1 hour.

Conditions for Setting the Fault Codes

The diesel exhaust fluid tank was empty and the dosing unit was unable to prime.

Action Taken When the Fault Code is Active

There are two levels of action taken by the ECM when this fault code is active:

Level 1: Action taken when the diesel exhaust fluid tank is empty:

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Level 2: Action taken when the diesel exhaust fluid tank is empty and engine shutdown or extended idle.

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The diesel exhaust fluid lamp will be flashing.

Engine torque will be severely reduced.

Vehicle speed will be limited to 8 km [5 mi] per hour.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the diesel exhaust fluid lamp immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates that the aftertreatment diesel exhaust fluid tank is empty and needs refilled immediately.

Refer to Troubleshooting Fault Code 3547.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3558

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3558 PID: SPN: 3361 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the aftertreatment diesel exhaust fluid dosing unit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit performs many functions, one of which is to generate adequate diesel exhaust fluid pressure in the lines, using a pump, to allow for dosing. The ECM provides a battery voltage supply and a ground to the diesel exhaust fluid dosing unit. The ECM also supplies a signal to the dosing unit to control the diesel exhaust fluid output. This signal changes, based on the diesel exhaust fluid pressure being commanded.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing unit is in the priming or dosing state.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing unit signal voltage was greater than a calibratible value or the diesel exhaust fluid dosing unit supply was shorted to battery or open circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid System Leak Test" found under "ECM Diagnostic Tests" in the recommended Cummins electronic service tool or equivalent.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Short to battery voltage in the diesel exhaust fluid dosing unit

A short circuit to battery in the OEM harness

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3558.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3559

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3559 PID: SPN: 3361 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the aftertreatment diesel exhaust fluid dosing unit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit performs many functions, one of which is to generate adequate diesel exhaust fluid pressure in the lines, using a pump, to allow for dosing. The ECM provides a battery voltage supply and a ground to the diesel exhaust fluid dosing unit. The ECM also supplies a signal to the dosing unit to control the diesel exhaust fluid output. This signal changes, based on the diesel exhaust fluid pressure being commanded.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing unit is in the priming or dosing state.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing unit signal voltage or the aftertreatment diesel exhaust fluid dosing unit supply voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid System Leak Test" found under "ECM Diagnostic Tests" in the recommended Cummins® electronic service tool or equivalent.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Short to ground in the diesel exhaust fluid dosing unit

A short circuit to ground in the OEM harness

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3559 .

Last Modified: 31-Aug-2019


Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Voltage Above Normal or Shorted to High Source

FAULT CODE 3562

Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3562 PID: SPN: 5491 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the diesel exhaust fluid line heater relay. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Line Heater Relay Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heater relay is used to provide power to the aftertreatment diesel exhaust fluid line heaters.

Component Location

The aftertreatment diesel exhaust fluidline heater relay location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and line heating is commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid line heater relay driver signal was shorted to high source.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use the recommended Cummins electronic service tool or equivalent to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Short to battery voltage in the diesel exhaust fluid line heater relay circuit

A short circuit to battery in the OEM harness

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3562.

Last Modified: 25-May-2019


Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3563

Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3563 PID: SPN: 5491 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the diesel exhaust fluid line heater relay. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Line Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heater relay is used to provide power to the aftertreatment diesel exhaust fluid line heaters.

Component Location

The aftertreatment diesel exhaust fluidline heater relay location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid line heater relay control signal was out or range low or open circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Short to ground in the aftertreatment diesel exhaust fluid line heater relay circuit

A short circuit to ground in the OEM harness

An open circuit in the OEM harness

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3563.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 1 Circuit - Current Below Normal or Open Circuit

FAULT CODE 3567

Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 1 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3567 PID: SPN: 5394 FMI: 5/5 LAMP: Amber SRT: | A circuit error has been detected in the aftertreatment diesel exhaust fluid dosing valve circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Valve Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing valve is controlled by the ECM. When the engine control module (ECM) commands DEF dosing, the ECM sends a pulse width modulated (PWM) signal to the dosing valve, which opens the dosing valve and allows DEF to be sprayed into the exhaust stream.

Component Location

The aftertreatment diesel exhaust fluid dosing valve is installed in the exhaust system. It is mounted directly to the aftertreatment decomposition tube, before the selective catalytic reduction (SCR) catalyst. Installation position will vary, based on the aftertreatment architecture and the original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing valve is being commanded on.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing valve circuit was shorted high, shorted low, or open.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Engine torque will be severely reduced.

Vehicle speed will be limited to 8 km [5 mi] per hour after extended engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair:
  • Perform a key cycle.
  • Start and idle the engine.
  • Monitor the Aftertreatment Diesel Exhaust Fluid Dosing Unit State in the recommended Cummins electronic service tool or equivalent.
  • The Aftertreatment Diesel Exhaust Fluid Dosing Unit State in the recommended Cummins electronic service tool or equivalent must transition to Dosing, indicating the system has primed.
  • Turn the key switch OFF and allow the ECM to completely powerdown.
  • Turn the key switch ON.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Open circuit in the diesel exhaust fluid dosing valve

A short circuit to battery in the OEM harness

A short circuit to ground in the OEM harness

An open circuit in the OEM harness

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3567.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 1 - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 3568

Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 1 - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3568 PID: SPN: 5394 FMI: 7/7 LAMP: Amber SRT: | A mechanical malfunction has been detected in the DEF dosing valve. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Valve Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing valve is controlled by the ECM. When the engine control module (ECM) commands DEF dosing, the ECM sends a pulse width modulated (PWM) signal to the dosing valve, which opens the dosing valve and allows DEF to be sprayed into the exhaust stream.

Component Location

The aftertreatment diesel exhaust fluid dosing valve is installed in the exhaust system. It is mounted directly to the aftertreatment decomposition tube, before the selective catalytic reduction (SCR) catalyst. Installation position will vary, based on the aftertreatment architecture and the original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing valve is being commanded on.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure was greater than a threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the recommended Cummins electronic service tool or equivalent.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel exhaust fluid dosing valve

Contamination of the DEF can be a possible cause for this fault code.

Refer to Troubleshooting Fault Code 3568.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3571

Aftertreatment 1 Diesel Exhaust Fluid Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3571 PID: SPN: 4334 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the aftertreatment diesel exhaust fluid pressure sensor circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Signal wire shorted to sensor supply or battery voltage

A malfunctioning aftertreatment diesel exhaust fluid pressure sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3571.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3572

Aftertreatment 1 Diesel Exhaust Fluid Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3572 PID: SPN: 4334 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the diesel exhaust fluid pressure sensor circuit. | Possible reduced engine performance.
19r00207

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Signal wire shorted to ground

A malfunctioning aftertreatment diesel exhaust fluid pressure sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3572.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3574

Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3574 PID: SPN: 4334 FMI: 1/18 LAMP: Amber SRT: | Low diesel exhaust fluid pressure has been detected in the dosing unit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing unit is in the priming or dosing state.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure was less than a threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Engine torque will be severely reduced.

Vehicle speed will be limited to 8 km [5 mi] per hour after extended engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the recommended Cummins electronic service tool or equivalent.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Troubleshoot other active SCR related faults before this fault.

Possible causes of this fault code include:

Low diesel exhaust fluid tank level

Blocked, restricted, or frozen diesel exhaust fluid dosing unit supply line

Blocked or restricted diesel exhaust fluid tank filter

Blocked or restricted diesel exhaust fluid dosing unit filter

Blocked or restricted diesel exhaust fluid dosing unit supply line fitting

Malfunctioning diesel exhaust fluid dosing unit

Contaminated diesel exhaust fluid

Debris from the diesel exhaust fluid tank. If debris is found in the diesel exhaust fluid tank, clean the diesel exhaust fluid tank thoroughly and fill with certified diesel exhaust fluid.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3574.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3575

Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3575 PID: SPN: 4334 FMI: 0/16 LAMP: Amber SRT: | The diesel exhaust fluid dosing unit has detected a blockage in the diesel exhaust fluid return flow. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure was greater than 1100 kpa [159 psi] for more than 20 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Engine torque will be severely reduced.

Vehicle speed will be limited to 8 km [5 mi] per hour after extended engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the recommended Cummins electronic service tool or equivalent.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Troubleshoot other active SCR related faults before this fault.

Possible causes of this fault code include:

Blocked, restricted, or frozen diesel exhaust fluid dosing unit return line or return line fitting

Malfunctioning diesel exhaust fluid dosing unit.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3575.

Last Modified: 25-May-2019


Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Above Normal or Shorted to High Source

FAULT CODE 3577

Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3577 PID: SPN: 4376 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the aftertreatment diesel exhaust fluid return valve. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit

Circuit Description

The aftertreatment diesel exhaust fluid return valve is controlled by the Engine Control Module (ECM). The return valve position determines where diesel exhaust fluid will flow as it exits the dosing unit. When the return valve is activated, the dosing system will purge and return the diesel exhaust fluid in the lines to the tank.

Component Location

The aftertreatment diesel exhaust fluid return valve is internal to the aftertreatment diesel exhaust fluid dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid return valve circuit was out of range high or open.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If this fault is active, the dosing system may not be able to purge, which means there will be aftertreatment diesel exhaust fluid left in the lines. Care must be taken when removing connections.Also, lines can freeze and the SCR system can become damaged in cold weather if the system is not properly purged.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3577.

Last Modified: 25-May-2019


Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3578

Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3578 PID: SPN: 4376 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the diesel exhaust fluid return valve. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit

Circuit Description

The aftertreatment diesel exhaust fluid return valve is controlled by the Engine Control Module (ECM). The return valve position determines where diesel exhaust fluid will flow as it exits the dosing unit. When the return valve is activated, the dosing system will purge and return the diesel exhaust fluid in the lines to the tank.

Component Location

The aftertreatment diesel exhaust fluid return valve is internal to the aftertreatment diesel exhaust fluid dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic only runs when the aftertreatment diesel exhaust fluid dosing system is purging.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid return valve voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If this fault is active, the dosing system may not be able to purge, which means there will be diesel exhaust fluid left in the lines. Care must be taken when removing connections. Also, lines could freeze and become damaged in cold weather if the system is not properly purged.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3578.

Last Modified: 25-May-2019


Aftertreatment SCR Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3582

Aftertreatment SCR Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3582 PID: SPN: 4364 FMI: 1/18 LAMP: Amber SRT: | NOx conversion across the SCR catalyst is too low. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) monitors the NOx concentration in the engine's exhaust gases using an aftertreatment intake NOx sensor and an aftertreatment outlet NOx sensor. By comparing these two values, the ECM is able to determine the conversion efficiency of the SCR catalyst and dosing system.

Component Location

The SCR catalyst is located in the vehicle's exhaust system, after the diesel particulate filter and decomposition tube.

Conditions for Running the Diagnostics

This diagnostic has to meet specific engine and aftertreatment conditions to run and complete.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the NOx conversion across the SCR catalyst was less than expected.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • It is necessary to use the "Reset All Faults" command in the recommended Cummins electronic service tool or equivalent to clear this fault and extinguish the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL).

Shop Talk

Troubleshoot all other active NOx sensor and SCR dosing system related fault codes before this fault.

Possible causes of this fault code include:

Malfunctioning aftertreatment diesel exhaust fluid dosing system.

Exhaust system leaks

Malfunctioning SCR catalyst

Degraded, diluted, or incorrect diesel exhaust fluid

Diesel exhaust fluid deposits in the decomposition tube.

For unit that has come back into with repeat failures consider the possibility that customer is not using Ultra-low sulfur Diesel fuel

Refer to Troubleshooting Fault Code 3582.

Last Modified: 25-May-2019


Aftertreatment 1 Outlet NOx Sensor Heater - Abnormal Rate of Change

FAULT CODE 3583

Aftertreatment 1 Outlet NOx Sensor Heater - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3583 PID: SPN: 5031 FMI: 10/10 LAMP: Amber SRT: | The aftertreatment outlet NOx sensor heater is unable to maintain its normal operating temperature. | None on performance.
Aftertreatment Outlet NOx Sensor Heater Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR outlet temperature has been above 200°C [392° F] for a calibratible period of time while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the NOx sensor heater was unable to maintain its normal operating temperature.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using the recommended Cummins electronic service tool or equivalent.
  • The aftertreatment SCR outlet temperature must be above 200Â° C [392Â° F] for 60 seconds before the aftertreatment outlet NOx sensor can run its internal diagnostics.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The NOx sensor heater is internal to the NOx sensor assembly, and can not be serviced separately.

Possible causes of this fault code include:

A damaged aftertreatment outlet NOx sensor

Intermittent power connection to the aftertreatment outlet NOx sensor.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3583.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3596

Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3596 PID: SPN: 4334 FMI: 2/2 LAMP: Amber SRT: | The diesel exhaust fluid pressure sensor has reported a reading too high or low for the operating conditions. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Pressure Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs when diesel exhaust fluid dosing unit is fully primed, and is actively maintaining diesel exhaust fluid pressure in the dosing system.

Conditions for Setting the Fault Codes

The diesel exhaust fluid dosing unit was unable to maintain the commanded diesel exhaust fluid pressure.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the recommended Cummins electronic service tool or equivalent.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Leaking diesel exhaust fluid lines

Malfunctioning diesel exhaust fluid dosing unit

Blocked or restricted diesel exhaust fluid dosing unit supply line fitting

Blocked or restricted diesel exhaust fluid filters

Malfunctioning diesel exhaust fluid pressure sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3596.

Last Modified: 25-May-2019


Aftertreatment 1 Intake NOx Sensor Heater - Abnormal Rate of Change

FAULT CODE 3649

Aftertreatment 1 Intake NOx Sensor Heater - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3649 PID: SPN: 5024 FMI: 10/10 LAMP: Amber SRT: | The aftertreatment intake NOx sensor heater is unable to maintain its normal operating temperature. | None on performance.
Aftertreatment Intake NOx Sensor Circuit

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the NOx emissions at the intake of the aftertreatment system.

Component Location

The aftertreatment intake NOx sensor is mounted on the engine near the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment diesel oxidation catalyst intake temperature sensor has been above 150°C [302°F] for 5 minutes while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the NOx sensor heater was unable to maintain its normal operating temperature.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using the recommended Cummins electronic service tool or equivalent.
  • The aftertreatment diesel oxidation catalyst intake temperature must be above 150°C [302°F] for 5 minutes before the aftertreatment intake NOx sensor can run its internal diagnostics.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The NOx sensor heater is internal to the NOx sensor assembly, and can not be serviced separately.

Possible causes of this fault code include:

Damaged aftertreatment intake NOx sensor

Intermittent power connection to the aftertreatment intake NOx sensor.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3649.

Last Modified: 25-May-2019


Aftertreatment 1 Outlet NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3681

Aftertreatment 1 Outlet NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3681 PID: SPN: 3228 FMI: 2/2 LAMP: Amber SRT: | The aftertreatment outlet NOx sensor indicates that the power supply to the sensor is incorrect. | None on performance.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR outlet temperature has been above 200°C [392° F] for a calibratible period of time while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the power supply to the outlet NOx sensor was above or below a calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using the recommended Cummins electronic service tool or equivalent.
  • The aftertreatment SCR outlet temperature must be above 200Â° C [392Â° F] for 60 seconds before the aftertreatment outlet NOx sensor can run its internal diagnostics.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Short to battery or ground in the OEM harness

Open NOx sensor power supply circuit in the OEM harness

  • Incorrect system voltage set-up in the recommended Cummins electronic service tool or equivalent.

Internal malfunction of the outlet NOx sensor

The NOx sensor part number is incorrect.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3681.

Last Modified: 25-May-2019


Aftertreatment 1 Intake NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3682

Aftertreatment 1 Intake NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3682 PID: SPN: 3218 FMI: 2/2 LAMP: Amber SRT: | The aftertreatment intake NOx sensor indicates that the power supply to the sensor is incorrect. | None on performance.
Aftertreatment Intake NOx Sensor Circuit

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the NOx emissions at the intake of the aftertreatment system.

Component Location

The aftertreatment intake NOx sensor is mounted on the engine near the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment diesel oxidation catalyst intake temperature sensor has been above 150°C [302°F] for 5 minutes while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the power supply to the intake NOx sensor was above or below a calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using the recommended Cummins electronic service tool or equivalent.
  • The aftertreatment diesel oxidation catalyst intake temperature must be above 150°C [302°F] for 5 minutes before the aftertreatment intake NOx sensor can run its internal diagnostics.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Short to battery or ground in the OEM harness

Open NOx sensor power supply circuit in the OEM harness

  • Incorrect system voltage set-up in the recommended Cummins electronic service tool or equivalent.

Internal malfunction of the intake NOx sensor

The NOx sensor part number is incorrect.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3682.

Last Modified: 25-May-2019


Engine Control Module Calibration Memory - Bad Intelligent Device or Component

FAULT CODE 3697

Engine Control Module Calibration Memory - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3697 PID: S253 SPN: 630 FMI: 12/12 LAMP: Red SRT: | Error internal to the ECM related to engine software failures. | Engine may not start or may be difficult to start.
Engine Control Module (ECM)

Circuit Description

The ECM has internal diagnostics that continuously run and check the internal memory.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a software or calibration error.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

The engine may not start.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunction of the ECM software.

Refer to Troubleshooting Fault Code 3697.

Last Modified: 25-May-2019


Aftertreatment SCR Operator Inducement - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 3712

Aftertreatment SCR Operator Inducement - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3712 PID: SPN: 5246 FMI: 0/0 LAMP: Red SRT: | Critical SCR related fault codes have been active for an extended period of time and require immediate attention. | Vehicle speed will be limited to 8 km [5 miles] per hour.
Engine Control Module (ECM)

Circuit Description

The ECM continuously monitors the engine's fault code status to determine if any fault codes critical to successful engine operation are active.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine has been operated for an extended amount of time with critical SCR faults active, and no repair action has been taken. This amount of time will vary, depending on which SCR faults are active.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Engine torque will be reduced.

Vehicle speed will be limited to 8 km [5 mi] per hour.

Conditions for Clearing the Fault Code

  • This fault code will go inactive once all other active fault codes have been addressed. Refer to the appropriate fault code troubleshooting tree.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only, and indicates that an engine power derate and vehicle speed limit have been implemented in order to make sure that the critical SCR related fault codes that are presently active in the ECM are addressed as quickly as possible.

Refer to Troubleshooting Fault Code 3712.

Last Modified: 25-May-2019


Engine Protection Torque Derate - Condition Exists

FAULT CODE 3714

Engine Protection Torque Derate - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3714 PID: SPN: 1569 FMI: 11/31 LAMP: Amber SRT: | Critical fault codes related to engine operation are active. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM continuously monitors the engine's fault code status to determine if any fault codes critical to successful engine operation are active.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected certain critical fault codes related to engine operation were active and the engine continued to operate.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • This fault code will go inactive once all other active fault codes have been addressed. Refer to the appropriate fault code troubleshooting tree.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only, and indicates that an engine power derate has been implemented in order to make sure that the critical fault codes that are presently active in the ECM are addressed as quickly as possible.

Refer to Troubleshooting Fault Code 3714.

Last Modified: 25-May-2019


Engine Speed At Idle - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3715

Engine Speed At Idle - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3715 PID: SPN: 188 FMI: 0/16 LAMP: Amber SRT: | The engine speed at idle has exceeded the governed idle speed. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The Engine Control Module (ECM) continuously monitors the engine speed at idle and adjusts fueling to maintain governed idle speed.

Component Location

The engine speed is monitored by the crankshaft and/or camshaft position sensors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating at idle and PTO is not active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine speed was 50 rpm above governed idle speed for 30 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Fuel system malfunction

Crankshaft position sensor malfunction

Camshaft position sensor malfunction

Alternate fuel source entering intake system

Refer to Troubleshooting Fault Code 3715.

Last Modified: 25-May-2019


Engine Speed At Idle - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3716

Engine Speed At Idle - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3716 PID: SPN: 188 FMI: 1/18 LAMP: Amber SRT: | Engine is not maintaining the governed idle speed. | None on performance.
Engine Control Module (ECM)

Circuit Description

The Engine Control Module (ECM) continuously monitors the engine speed at idle and adjusts fueling to maintain governed idle speed.

Component Location

The engine speed is monitored by the crankshaft and/or camshaft position sensors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating at idle and PTO is not active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine speed was 50 rpm below governed idle speed for 30 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Fuel system malfunction

Crankshaft position sensor malfunction

Camshaft position sensor malfunction

Increased engine accessory load

Refer to Troubleshooting Fault Code 3716.

Last Modified: 25-May-2019


Engine Exhaust Gas Recirculation 1 Valve 1 Control 1 - Condition Exists

FAULT CODE 3724

Engine Exhaust Gas Recirculation 1 Valve 1 Control 1 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3724 PID: P168 SPN: 2791 FMI: 11/31 LAMP: Amber SRT: | Low voltage to the EGR valve device driver has been detected. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The EGR valve device driver in the ECM provides power to the EGR valve motor. The EGR valve motor is used to move the EGR valve to the correct position, as commanded by the ECM.

Component Location

The EGR valve device driver is internal to the ECM and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected low power at the EGR valve device driver. The ECM was no longer able to control the EGR valve.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Exhaust gas recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates an internal failure in the ECM.

Refer to Troubleshooting Fault Code 3724 .

Last Modified: 13-Oct-2021


Aftertreatment 1 Intake NOx Sensor - Abnormal Rate of Change

FAULT CODE 3725

Aftertreatment 1 Intake NOx Sensor - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3725 PID: SPN: 3216 FMI: 10/10 LAMP: Amber SRT: | The aftertreatment intake NOx sensor reading is not valid. | None on performance.
Aftertreatment Intake NOx Sensor Circuit

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the NOx emissions at the intake of the aftertreatment system.

Component Location

The aftertreatment intake NOx sensor is mounted on the engine near the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment diesel oxidation catalyst intake temperature sensor has been above 150°C [302°F] for 5 minutes while the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment intake Nox sensor reading was not valid.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using the recommended Cummins electronic service tool or equivalent.
  • The aftertreatment diesel oxidation catalyst intake temperature must be above 150°C [302°F] for 5 minutes before the aftertreatment intake NOx sensor can run its internal diagnostics.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code sets when the aftertreatment intake NOx sensor indicates to the ECM that it is not providing valid data.

Troubleshoot the aftertreatment outlet NOx sensor for Fault Codes 1885, 3232, or 3681 before troubleshooting this fault code.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3725.

Last Modified: 25-May-2019


High Pressure Common Rail Fuel Pressure Relief Valve - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 3727

High Pressure Common Rail Fuel Pressure Relief Valve - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3727 PID: SPN: 5571 FMI: 7/7 LAMP: None SRT: | The fuel rail high-pressure relief valve has opened at a lower than expected pressure. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The high-pressure relief valve is a mechanical device that opens when the fuel pressure in the fuel rail exceeds a critical limit.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel pressure relief valve had opened at a pressure lower than expected.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code will become inactive at each key OFF event, and will not become active again until the fault condition reoccurs. Troubleshoot inactive or active occurences of this fault code the same.

An occurence of this fault indicates that the high-pressure relief valve is being tripped at a pressure lower than what is expected. If this has happened multiple times, there will be many occurences of this fault. Troubleshoot Fault Code 3727 before Fault Code 1911, if both fault codes are present in the ECM.

This fault code may also be triggered by a sudden and significant loss of fuel pressure in the fuel system.

Refer to Troubleshooting Fault Code 3727.

Last Modified: 25-May-2019


Crankcase Breather Filter Heater Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3733

Crankcase Breather Filter Heater Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3733 PID: SPN: 862 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the crankcase breather heater circuit. | None on performance.
Crankcase Breather Filter Heater Circuit

Circuit Description

The crankcase breather heater is used to keep the crankcase breather filter housing from freezing. The ECM supplies battery voltage to the breather heater when heating is commanded.

Component Location

The crankcase breather heater is mounted to the crankcase breather filter housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankcase breather heater signal voltage was out of range high for more than 10 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The crankcase breather heater will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Short circuit to voltage in the crankcase breather heater circuit

Malfunctioning ECM.

Refer to Troubleshooting Fault Code 3733.

Last Modified: 25-May-2019


Crankcase Breather Filter Heater Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3734

Crankcase Breather Filter Heater Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3734 PID: SPN: 862 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the crankcase breather heater circuit. | None on performance.
Crankcase Breather Filter Heater Circuit

Circuit Description

The crankcase breather heater is used to keep the crankcase breather filter housing from freezing. The ECM supplies battery voltage to the breather heater when heating is commanded.

Component Location

The crankcase breather heater is mounted to the crankcase breather filter housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankcase breather heater signal circuit was shorted to ground.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The crankcase breather heater will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Open crankcase breather heater circuit

Short circuit to ground in the crankcase breather heater circuit

Malfunctioning ECM.

Refer to Troubleshooting Fault Code 3734.

Last Modified: 25-May-2019


Engine Starter Mode Overcrank Protection - Condition Exists

FAULT CODE 3737

Engine Starter Mode Overcrank Protection - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3737 PID: SPN: 1675 FMI: 11/31 LAMP: None SRT: | The starter motor has been temporarily disabled in order to prevent starter damage. | Starter operation is prohibited until the starter motor has adequately cooled.
Engine Control Module (ECM)

Circuit Description

The overcrank protection feature (or starter lockout) is designed to prevent damage to the starter motor during hard start conditions. Excessive cranking of the engine can cause the starter motor to overheat, resulting in permanent damage. When excessive engine cranking is detected, the overcrank protection feature locks out the starter until the starter motor has adequately cooled, and is safe to operate again.

Component Location

The overcrank protection feature is controlled by the ECM, and can not be modified.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is being started.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the starter motor was engaged for a long enough period of time that continued cranking can cause starter damage. This cumulative time includes continuous cranking and/or a series of shorter cranking attempts within a certain time window.

Action Taken When the Fault Code is Active

The starter is locked out and the engine can not be cranked over until the starter motor has adequately cooled.

Conditions for Clearing the Fault Code

  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This is an information only fault code, and does not indicate an issue with the starter.

Refer to Troubleshooting Fault Code 3737.

Last Modified: 25-May-2019


High Pressure Common Rail Fuel Pressure Relief Valve - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 3741

High Pressure Common Rail Fuel Pressure Relief Valve - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3741 PID: SPN: 5571 FMI: 0/0 LAMP: Amber SRT: | The fuel rail pressure relief valve has opened due to high fuel rail pressure. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Fuel Rail Pressure Sensor Circuit

Circuit Description

The high-pressure relief valve is a mechanical device that opens when the fuel pressure in the fuel rail exceeds a critical limit.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel rail pressure had exceeded the fuel pressure relief valve opening pressure, and the fuel pressure relief valve opened.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and run it at high idle for 5 minutes.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

High fuel drain line restriction

A leaking or sticky fuel pump actuator

Air in the fuel

A plugged fuel pump actuator mounting adapter

This fault indicates that the fuel rail pressure was high enough to open the fuel rail pressure relief valve.

Refer to Troubleshooting Fault Code 3741.

Last Modified: 25-May-2019


Aftertreatment 1 Intake NOx Sensor - Data Not Rational - Drifted High

FAULT CODE 3748

Aftertreatment 1 Intake NOx Sensor - Data Not Rational - Drifted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3748 PID: SPN: 3216 FMI: 2/20 LAMP: Amber SRT: | An offset in the intake NOx sensor reading has been detected. | None on performance.
Aftertreatment Intake NOx Sensor Circuit

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the NOx emissions at the intake of the aftertreatment system.

Component Location

The aftertreatment intake NOx sensor is mounted on the engine near the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment diesel oxidation catalyst intake temperature is above 150°C [302°F], and the engine is in a motoring condition.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment intake NOx sensor was not reading zero while in a motoring (non-fueling) condition.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Engine torque will be severely reduced.

Vehicle speed will be limited to 8 km [5 mi] per hour after extended engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by performing a road test.
  • The aftertreatment diesel oxidation catalyst intake temperature must be above 150Â° C [302Â° F] for 5 seconds, and the engine must be in a motoring condition before the aftertreatment intake NOx sensor can run its internal diagnostics.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning aftertreatment Intake NOx sensor

Improperly installed aftertreatment intake NOx sensor.

Refer to Troubleshooting Fault Code 3748.

Last Modified: 25-May-2019


Aftertreatment 1 Outlet NOx Sensor - Data Not Rational - Drifted High

FAULT CODE 3749

Aftertreatment 1 Outlet NOx Sensor - Data Not Rational - Drifted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3749 PID: SPN: 3226 FMI: 2/20 LAMP: Amber SRT: | An offset in the outlet NOx sensor reading has been detected. | None on performance.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR outlet temperature is above 200°C [392°F], and the engine is in a motoring condition.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment outlet NOx sensor was not reading zero while in a motoring (non-fueling) condition.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using the recommended Cummins electronic service tool or equivalent.
  • The aftertreatment SCR outlet temperature must be above 200Â° C [392Â° F] for 60 seconds before the aftertreatment outlet NOx sensor can run its internal diagnostics.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning aftertreatment outlet NOx sensor

Diesel exhaust fluid crystallization or deposits

Improperly installed aftertreatment outlet NOx sensor.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3749.

Last Modified: 25-May-2019


Cruise Control Disable Command - Abnormal Update Rate

FAULT CODE 3843

Cruise Control Disable Command - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3843 PID: SPN: 5603 FMI: 9/9 LAMP: None SRT: | No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the cruise control. | None on performance.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins ECM and used for controlling the engine. The Cummins ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices can possibly not function as desired.

This fault can occur for the following reasons:

The ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the CumminsÂ ECM, or the OEM VECU is not set up to transmit the multiplexed component message.

This fault can also be caused by a bad J1939 data link connection between the OEM VECU and Cummins ECM, a bad connection between the component and the OEM VECU, bad OEM VECU or bad Cummins ECM. It may be necessary to contact the OEM for proper multiplexing configuration. It is possible to use the recommended Cummins electronic service tool or equivalent to monitor multiplexed components.

It is possible to use the recommended Cummins electronic service tool or equivalent to monitor multiplexed components.

Refer to Troubleshooting Fault Code 3843.

Last Modified: 25-May-2019


Cruise Control Pause Command - Condition Exists

FAULT CODE 3844

Cruise Control Pause Command - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3844 PID: SPN: 5605 FMI: 11/31 LAMP: None SRT: | The adaptive cruise control has dropped out and must be manually engaged. | Cruise control could possibly not operate.
Engine Control Module (ECM)

Circuit Description

The adaptive cruise control system sends commands to the ECM via the J1939 data link to limit engine speed and maintain a set following distance behind a vehicle travelling more slowly than the current cruise control set speed.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the adaptive cruise control system was paused for more than 30 seconds, or that the vehicle speed dropped by more than 24 kph [15 mph] during the period of time that the cruise control was paused.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This is an information fault code indicating that the adaptive cruise control system was paused for more than 30 seconds, or that the vehicle speed dropped by more than 24 kph [15 mph] during the period of time that the cruise control was paused. Cruise control must be manually engaged when this condition exists.

Refer to Troubleshooting Fault Code 3844.

Last Modified: 25-May-2019


Cruise Control Disable Command - Condition Exists

FAULT CODE 3845

Cruise Control Disable Command - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3845 PID: SPN: 5603 FMI: 11/31 LAMP: None SRT: | The adaptive cruise control has dropped out and must be manually engaged. | Cruise control could possibly not operate.
Engine Control Module (ECM)

Circuit Description

The adaptive cruise control system sends commands to the ECM via the J1939 data link to limit engine speed and maintain a set following distance behind a vehicle travelling more slowly than the current cruise control set speed.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the adaptive cruise control system was disabled for more than 30 seconds.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This is an information fault code indicating that the adaptive cruise control system was disabled. The cruise control must be manually engaged when this condition exists.

Refer to Troubleshooting Fault Code 3845.

Last Modified: 25-May-2019


Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 386

Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 386 PID: S212 SPN: 3509 FMI: 3/3 LAMP: Amber SRT: | High voltage detected at sensor supply number 1 circuit. | Possible reduced engine performance.
Sensor Supply 1 Circuit

Circuit Description

The sensor supply 1 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 1 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 1 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value is used for all of the sensors on the sensor supply 1 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

High voltage on the (+) 5 volt supply line can be caused by a short to battery voltage in the engine harness or connectors, or a malfunctioning ECM.

Refer to Troubleshooting Fault Code 386.

Last Modified: 25-May-2019


Aftertreatment Diesel Exhaust Fluid Quality - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3867

Aftertreatment Diesel Exhaust Fluid Quality - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3867 PID: SPN: 3364 FMI: 1/18 LAMP: Amber SRT: | The diesel exhaust fluid (DEF) quality has been detected to be below a critical threshold. | Possible reduced engine performance.
SAE J1939 Datalink

Circuit Description

The aftertreatment diesel exhaust fluid quality sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor is used to measure the concentration of the aftertreatment diesel exhaust fluid in the tank.

Component Location

The aftertreatment diesel exhaust fluid quality sensor is located in the aftertreatment diesel exhaust fluid tank. It may be a combination sensor with the aftertreatement diesel exhaust fluid tank level and tank temperature sensors. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the following conditions are met:

Keyswitch is in the ON position or when the engine is running.

Ambient temperature is above -20Â°C [-4Â°F].

Vehicle altitude change is less than 305 m [1000 ft] in 1 hour.

Conditions for Setting the Fault Codes

The DEF quality sensor has detected that the DEF concentration has fallen below a critical threshold.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • Start and idle the engine for 15 minutes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Degraded, diluted, or incorrect diesel exhaust fluid

Malfunctioning Aftertreatment DEF Quality Sensor.

Refer to Troubleshooting Fault Code 3867.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Quality - Abnormal Update Rate

FAULT CODE 3868

Aftertreatment 1 Diesel Exhaust Fluid Quality - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3868 PID: SPN: 3364 FMI: 9/9 LAMP: Amber SRT: | The Urea Quality Sensor has been unable to generate a concentration value for a period of time. | Engine power derate.
SAE J1939 Datalink

Circuit Description

The DEF quality sensor is a smart device and communicates with the engine electronic control module (ECM) via the J1939 data link. The DEF quality sensor receives power and ground directly from the battery. The sensor performs its own internal diagnostics and reports malfunctions back to the primary engine ECM via the J1939 data link. The DEF quality sensor is used to measure the concentration of the DEF in the tank.

Component Location

The DEF quality sensor is typically mounted in the DEF tank or in-line with the DEF dosing unit supply line. Reference the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) lost communication with the aftertreatment DEF quality sensor via the J1939 data link.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with the recommended Cummins® electronic service tool or equivalent.
  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

  • Open or short circuit on J1939 data link.
Refer to Troubleshooting Fault Code 3868 .

Last Modified: 13-Oct-2021


Aftertreatment 1 Diesel Exhaust Fluid Quality - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3878

Aftertreatment 1 Diesel Exhaust Fluid Quality - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3878 PID: SPN: 3364 FMI: 2/2 LAMP: Amber SRT: | The diesel exhaust fluid quality sensor has reported a reading too high or low for the operating conditions. | Engine power derate.
SAE J1939 Datalink

Circuit Description

The DEF quality sensor is a smart device and communicates with the engine electronic control module (ECM) via the J1939 data link. The DEF quality sensor receives power and ground directly from the battery. The sensor performs its own internal diagnostics and reports malfunctions back to the primary engine ECM via the J1939 data link. The DEF quality sensor is used to measure the concentration of the DEF in the tank.

Component Location

The DEF quality sensor is typically mounted in the DEF tank or in-line with the DEF dosing unit supply line. Reference the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

This fault code is triggered when the DEF quality sensor detects that the internal temperature has exceeded 125Â°C.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning Aftertreatment DEF Quality Sensor.
Refer to Troubleshooting Fault Code 3878 .

Last Modified: 13-Oct-2021


Aftertreatment 1 SCR Intermediate NH3 Sensor - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3899

Aftertreatment 1 SCR Intermediate NH3 Sensor - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3899 PID: SPN: 5848 FMI: 4/4 LAMP: Amber SRT: | A circuit error has been detected in the NH3 sensor. | None on performance.
Aftertreatment SCR Intermediate NH3 Sensor Circuit

Circuit Description

The aftertreatment SCR intermediate NH3 (ammonia) sensor is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment intermediate NH3 sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module using the J1939 data link. The aftertreatment intermediate NH3 sensor is used to measure the ammonia in the aftertreatment system.

Component Location

The aftertreatment SCR intermediate NH3 sensor is located in the middle of the aftetreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR intermediate temperature has been above 170 C [338 F] for a calibratible period of time while the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment SCR intermediate NH3 sensor reported a circuit malfunctioning.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using the recommended Cummins electronic service tool or equivalent.
  • The aftertreatment SCR intermediate temperature must be above 170 C [338 F] for 5 seconds before the aftertreatment SCR intermediate NH3 sensor can run its internal diagnostics.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment SCR intermediate NH3 sensor probe

A malfunctioning aftertreatment SCR intermediate NH3 sensor module

Refer to Troubleshooting Fault Code 3899.

Last Modified: 25-May-2019


Aftertreatment 1 SCR Intermediate NH3 Sensor - Abnormal Update Rate

FAULT CODE 3911

Aftertreatment 1 SCR Intermediate NH3 Sensor - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3911 PID: SPN: 5848 FMI: 9/9 LAMP: Amber SRT: | Loss of communication with the aftertreatment SCR intermediate NH3 sensor. | Possible reduced engine performance.
Aftertreatment SCR Intermediate NH3 Sensor Circuit

Circuit Description

The aftertreatment SCR intermediate NH3 (ammonia) sensor is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment intermediate NH3 sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module using the J1939 data link. The aftertreatment intermediate NH3 sensor is used to measure the ammonia in the aftertreatment system.

Component Location

The aftertreatment SCR intermediate NH3 sensor is located in the middle of the aftetreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of communication with the aftertreatment SCR intermediate NH3 sensor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be severely reduced.

Vehicle speed will be limited to 8 km [5 mi] per hour after extended engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using the recommended Cummins electronic service tool or equivalent.
  • The aftertreatment SCR intermediate temperature must be above 170 C [338 F] for 5 seconds before the aftertreatment SCR intermediate NH3 sensor can run its internal diagnostics.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Low battery voltage supply to the aftertreatment SCR intermediate NH3 sensor

Incorrect terminating resistance of the SAE J1939 datalink circuit

  • A malfunctioning SAE J1939 datalink circuit

Intermittent communication from the aftertreatment SCR intermediate NH3 sensor

Refer to Troubleshooting Fault Code 3911.

Last Modified: 25-May-2019


Aftertreatment 1 Outlet NH3 Gas Sensor Heater - Abnormal Rate of Change

FAULT CODE 3912

Aftertreatment 1 Outlet NH3 Gas Sensor Heater - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3912 PID: SPN: 5853 FMI: 10/10 LAMP: Amber SRT: | A malfunction of the aftertreatment SCR intermediate NH3 sensor heater has been detected. | Possible reduced engine performance.
Aftertreatment SCR Intermediate NH3 Sensor Circuit

Circuit Description

The aftertreatment SCR intermediate NH3 (ammonia) sensor is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment intermediate NH3 sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module using the J1939 data link. The aftertreatment intermediate NH3 sensor is used to measure the ammonia in the aftertreatment system.

Component Location

The aftertreatment SCR intermediate NH3 sensor is located in the middle of the aftetreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR intermediate temperature has been above 170 C [338 F] for a calibratible period of time while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment SCR intermediate NH3 sensor heater is unable to maintain its normal operating temperature.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using the recommended Cummins electronic service tool or equivalent.
  • The aftertreatment SCR intermediate temperature must be above 170 C [338 F] for 5 seconds before the aftertreatment SCR intermediate NH3 sensor can run its internal diagnostics.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment SCR intermediate NH3 sensor probe

Refer to Troubleshooting Fault Code 3912.

Last Modified: 25-May-2019


Aftertreatment 1 SCR Intermediate NH3 Gas Sensor Power Supply - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3932

Aftertreatment 1 SCR Intermediate NH3 Gas Sensor Power Supply - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3932 PID: SPN: 5851 FMI: 0/16 LAMP: Amber SRT: | High battery voltage supply detected at the aftertreatment SCR intermediate NH3 sensor. | Possible reduced engine performance.
Aftertreatment SCR Intermediate NH3 Sensor Circuit

Circuit Description

The aftertreatment SCR intermediate NH3 (ammonia) sensor is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment intermediate NH3 sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module using the J1939 data link. The aftertreatment intermediate NH3 sensor is used to measure the ammonia in the aftertreatment system.

Component Location

The aftertreatment SCR intermediate NH3 sensor is located in the middle of the aftetreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR intermediate temperature has been above 170 C [338 F] for a calibratible period of time while the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment SCR intermediate NH3 sensor reported the battery voltage supply was greater than 32 VDC.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using the recommended Cummins electronic service tool or equivalent.
  • The aftertreatment SCR intermediate temperature must be above 170 C [338 F] for 5 seconds before the aftertreatment SCR intermediate NH3 sensor can run its internal diagnostics.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

High battery voltage supply

Incorrect sensor for the application (12 VDC versus 24 VDC)

  • Incorrect battery voltage setting in the recommended Cummins electronic service tool or equivalent.
Refer to Troubleshooting Fault Code 3932.

Last Modified: 25-May-2019


Aftertreatment 1 SCR Intermediate NH3 Gas Sensor Power Supply - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3933

Aftertreatment 1 SCR Intermediate NH3 Gas Sensor Power Supply - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3933 PID: SPN: 5851 FMI: 1/18 LAMP: Amber SRT: | Low battery voltage supply detected at the aftertreatment SCR intermediate NH3 sensor. | Possible reduced engine performance.
Aftertreatment SCR Intermediate NH3 Sensor Circuit

Circuit Description

The aftertreatment SCR intermediate NH3 (ammonia) sensor is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment intermediate NH3 sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module using the J1939 data link. The aftertreatment intermediate NH3 sensor is used to measure the ammonia in the aftertreatment system.

Component Location

The aftertreatment SCR intermediate NH3 sensor is located in the middle of the aftetreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR intermediate temperature has been above 170 C [338 F] for a calibratible period of time while the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment SCR intermediate NH3 sensor reported the battery voltage supply was less than 10 VDC.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using the recommended Cummins electronic service tool or equivalent.
  • The aftertreatment SCR intermediate temperature must be above 170 C [338 F] for 5 seconds before the aftertreatment SCR intermediate NH3 sensor can run its internal diagnostics.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Low battery voltage supply

Incorrect sensor for the application (12 VDC versus 24 VDC)

  • Incorrect battery voltage setting in the recommended Cummins electronic service tool or equivalent.
Refer to Troubleshooting Fault Code 3933.

Last Modified: 25-May-2019


Aftertreatment 1 SCR Intermediate NH3 Gas Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3934

Aftertreatment 1 SCR Intermediate NH3 Gas Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3934 PID: SPN: 5851 FMI: 2/2 LAMP: Amber SRT: | Intermittent battery voltage supply detected at the aftertreatment SCR intermediate NH3 sensor. | Possible reduced engine performance.
Aftertreatment SCR Intermediate NH3 Sensor Circuit

Circuit Description

The aftertreatment SCR intermediate NH3 (ammonia) sensor is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment intermediate NH3 sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module using the J1939 data link. The aftertreatment intermediate NH3 sensor is used to measure the ammonia in the aftertreatment system.

Component Location

The aftertreatment SCR intermediate NH3 sensor is located in the middle of the aftetreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR intermediate temperature has been above 170 C [338 F] for a calibratible period of time while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an intermittent battery voltage supply to the aftertreatment SCR intermediate NH3 sensor resulting in an internal reset of the sensor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using the recommended Cummins electronic service tool or equivalent.
  • The aftertreatment SCR intermediate temperature must be above 170 C [338 F] for 5 seconds before the aftertreatment SCR intermediate NH3 sensor can run its internal diagnostics.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code sets when the ECM detects an internal reset of the sensor. This internal reset is caused by an intermittent battery voltage supply. This fault code indicates that an intermittent wiring problem has been detected. All wiring and connectors should be closely inspected for intermittent connections.

Refer to Troubleshooting Fault Code 3934.

Last Modified: 25-May-2019


Aftertreatment 1 SCR Intermediate NH3 Sensor - Out of Calibration

FAULT CODE 3935

Aftertreatment 1 SCR Intermediate NH3 Sensor - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3935 PID: SPN: 5848 FMI: 13/13 LAMP: Amber SRT: | Incorrect trim resistance has been detected in the aftertreatment SCR intermediate NH3 sensor. | Possible reduced engine performance.
Aftertreatment SCR Intermediate NH3 Sensor Circuit

Circuit Description

The aftertreatment SCR intermediate NH3 (ammonia) sensor is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment intermediate NH3 sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module using the J1939 data link. The aftertreatment intermediate NH3 sensor is used to measure the ammonia in the aftertreatment system.

Component Location

The aftertreatment SCR intermediate NH3 sensor is located in the middle of the aftetreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR intermediate temperature has been above 170 C [338 F] for a calibratible period of time while the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment SCR intermediate NH3 sensor reported the resistance of the trim resistor is out of range.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using the recommended Cummins electronic service tool or equivalent.
  • The aftertreatment SCR intermediate temperature must be above 170 C [338 F] for 5 seconds before the aftertreatment SCR intermediate NH3 sensor can run its internal diagnostics.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment SCR intermediate NH3 sensor probe

A malfunctioning aftertreatment SCR intermediate NH3 sensor module

Refer to Troubleshooting Fault Code 3935.

Last Modified: 25-May-2019


Aftertreatment 1 SCR Intermediate NH3 Sensor - Bad Intelligent Device or Component

FAULT CODE 3936

Aftertreatment 1 SCR Intermediate NH3 Sensor - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3936 PID: SPN: 5848 FMI: 12/12 LAMP: Amber SRT: | An internal error of the aftertreatment SCR intermediate NH3 sensor has been detected. | Possible reduced engine performance.
Aftertreatment SCR Intermediate NH3 Sensor Circuit

Circuit Description

The aftertreatment SCR intermediate NH3 (ammonia) sensor is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment intermediate NH3 sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module using the J1939 data link. The aftertreatment intermediate NH3 sensor is used to measure the ammonia in the aftertreatment system.

Component Location

The aftertreatment SCR intermediate NH3 sensor is located in the middle of the aftetreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment SCR intermediate NH3 sensor reported an internal circuitry error of the aftertreatment SCR intermediate NH3 sensor module.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment SCR intermediate NH3 sensor module

Refer to Troubleshooting Fault Code 3936.

Last Modified: 25-May-2019


Aftertreatment 1 SCR Intermediate NH3 Sensor - Abnormal Rate of Change

FAULT CODE 3937

Aftertreatment 1 SCR Intermediate NH3 Sensor - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3937 PID: SPN: 5848 FMI: 10/10 LAMP: Amber SRT: | The aftertreatment SCR intermediate NH3 sensor reading is NOT valid. | Possible reduced engine performance.
Aftertreatment SCR Intermediate NH3 Sensor Circuit

Circuit Description

The aftertreatment SCR intermediate NH3 (ammonia) sensor is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment intermediate NH3 sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module using the J1939 data link. The aftertreatment intermediate NH3 sensor is used to measure the ammonia in the aftertreatment system.

Component Location

The aftertreatment SCR intermediate NH3 sensor is located in the middle of the aftetreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR intermediate temperature has been above 170 C [338 F] for a calibratible period of time while the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment SCR intermediate NH3 Sensor reading was not valid.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using the recommended Cummins electronic service tool or equivalent.
  • The aftertreatment SCR intermediate temperature must be above 170 C [338 F] for 5 seconds before the aftertreatment SCR intermediate NH3 sensor can run its internal diagnostics.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment SCR intermediate NH3 sensor probe

A malfunctioning aftertreatment SCR intermediate NH3 sensor module

Refer to Troubleshooting Fault Code 3937.

Last Modified: 25-May-2019


Aftertreatment 1 Particulate Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 4143

Aftertreatment 1 Particulate Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4143 PID: SPN: 5835 FMI: 3/3 LAMP: Amber SRT: | An internal circuit error has been detected by the aftertreatment particulate matter sensor. | Possible reduced engine performance.
Aftertreatment Particulate Sensor Circuit

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment particulate sensor assembly

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning aftertreatment particulate matter sensor

Refer to Troubleshooting Fault Code 4143 .

Last Modified: 05-Dec-2021


Aftertreatment 1 Particulate Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4144

Aftertreatment 1 Particulate Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4144 PID: SPN: 5835 FMI: 4/4 LAMP: Amber SRT: | An internal circuit error has been detected by the aftertreatment particulate matter sensor. | Possible reduced engine performance.
Aftertreatment Particulate Sensor Circuit

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment particulate sensor assembly

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning aftertreatment particulate matter sensor

Refer to Troubleshooting Fault Code 4144 .

Last Modified: 05-Dec-2021


Accelerator Pedal or Lever Position Sensor 2 Circuit Frequency - Abnormal Frequency or Pulse Width or Period

FAULT CODE 4149

Accelerator Pedal or Lever Position Sensor 2 Circuit Frequency - Abnormal Frequency or Pulse Width or Period

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4149 PID: SPN: 2623 FMI: 8/8 LAMP: Amber SRT: | The accelerator pedal position sensor reading is out of range. | The engine will operate in Limp Home mode.
Accelerator Pedal Position Sensor 2 Circuit

Circuit Description

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the accelerator pedal position sensor reading was out of range.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The engine will have limp-home throttle control only.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning accelerator pedal position sensor.

A short circuit to battery in the OEM harness

A short circuit to ground in the OEM harness

An open circuit in the OEM harness

Refer to Troubleshooting Fault Code 4149.

Last Modified: 25-May-2019


Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 415

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 415 PID: P100 SPN: 100 FMI: 1/1 LAMP: Red SRT: | The engine oil pressure sensor indicates oil pressure is below the engine protection critical limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

An engine oil pressure switch or oil pressure sensor is used by the engine control module (ECM) to monitor the lubricating oil pressure. For engines with an oil pressure switch, the switch is normally closed when the engine is not running and open when oil pressure is present. For engines with an oil pressure sensor, the ECM will detect a low signal voltage at operating conditions when the oil pressure is low. The ECM will detect a high signal voltage at operating conditions when the oil pressure is high.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure was below minimum operating limits.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The torque output of the engine will be reduced.

The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Low oil pressure

Incorrect oil level

Damaged oil pressure switch

Engine harness shorted to ground.

Refer to Troubleshooting Fault Code 415.

Last Modified: 25-May-2019


Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Abnormal Update Rate

FAULT CODE 4151

Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4151 PID: SPN: 5742 FMI: 9/9 LAMP: Amber SRT: | No communications on the J1939 data link between the ECM and the aftertreatment diesel particulate filter temperature sensor module. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Temperature Sensor Module

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter temperature sensor module is mounted on the aftertreatment diesel particulate filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of communication with the aftertreatment diesel particulate filter temperature sensor module.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Active and stationary regeneration of the diesel particulate filter will be disabled.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Low battery voltage supply

Incorrect terminating resistance of the SAE J1939 datalink circuit

  • Incorrect battery voltage setting in the recommended Cummins electronic service tool or equivalent.

Incorrect sensor for the application (12 VDC versus 24 VDC)

Refer to Troubleshooting Fault Code 4151.

Last Modified: 25-May-2019


Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Abnormal Update Rate

FAULT CODE 4152

Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4152 PID: SPN: 5743 FMI: 9/9 LAMP: Amber SRT: | No communication on the J1939 data link between the ECM and the aftertreatment SCR temperature sensor module. | Possible reduced engine performance.
Aftertreatment SCR Temperature Sensor Module Circuit

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intermediate temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of communication with the aftertreatment SCR temperature sensor module.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Low battery voltage supply

Incorrect terminating resistance of the SAE J1939 datalink circuit

Incorrect sensor for the application (12 VDC versus 24 VDC)

  • Incorrect battery voltage setting in the recommended Cummins electronic service tool or equivalent.
Refer to Troubleshooting Fault Code 4152.

Last Modified: 25-May-2019


Aftertreatment 1 Particulate Sensor Heater High Side Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 4153

Aftertreatment 1 Particulate Sensor Heater High Side Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4153 PID: SPN: 7321 FMI: 3/3 LAMP: Amber SRT: | An internal circuit error has been detected by the aftertreatment particulate matter sensor. | Possible reduced engine performance.
Aftertreatment Particulate Sensor Circuit

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment particulate sensor assembly

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning aftertreatment particulate matter sensor

Refer to Troubleshooting Fault Code 4153 .

Last Modified: 05-Dec-2021


Aftertreatment 1 Particulate Sensor Heater Low Side Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4154

Aftertreatment 1 Particulate Sensor Heater Low Side Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4154 PID: SPN: 7323 FMI: 4/4 LAMP: Amber SRT: | An internal circuit error has been detected by the aftertreatment particulate matter sensor. | Possible reduced engine performance.
Aftertreatment Particulate Sensor Circuit

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment particulate sensor assembly

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning aftertreatment particulate matter sensor

Refer to Troubleshooting Fault Code 4154 .

Last Modified: 05-Dec-2021


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Heater Relay Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 4155

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Heater Relay Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4155 PID: SPN: 5746 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the aftertreatment diesel exhaust fluid dosing unit heater relay circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit heater relay is used to provide power to the aftertreatment diesel exhaust fluid dosing unit heater.

The aftertreatment diesel exhaust fluid dosing unit heater is used to defrost and/or prevent freezing of the diesel exhaust fluid dosing unit.

Component Location

The aftertreatment diesel exhaust fluid dosing unit heater relay is an OEM component. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment diesel exhaust fluid dosing unit heater is commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing unit heater relay signal was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use the recommended Cummins electronic service tool or equivalent to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel exhaust fluid dosing unit heater relay

A short circuit to battery in the OEM harness

Refer to Troubleshooting Fault Code 4155.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Heater Relay Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4156

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Heater Relay Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4156 PID: SPN: 5746 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the aftertreatment diesel exhaust fluid dosing unit heater relay circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit heater relay is used to provide power to the aftertreatment diesel exhaust fluid dosing unit heater.

The aftertreatment diesel exhaust fluid dosing unit heater is used to defrost and/or prevent freezing of the diesel exhaust fluid dosing unit.

Component Location

The aftertreatment diesel exhaust fluid dosing unit heater relay is an OEM component. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment diesel exhaust fluid dosing unit heater is commanded OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing unit heater relay signal was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be severely reduced.

Vehicle speed will be limited to 8 km [5 mi] per hour after extended engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel exhaust fluid dosing unit heater relay

A short circuit to ground in the OEM harness

An open circuit in the OEM harness

Refer to Troubleshooting Fault Code 4156.

Last Modified: 25-May-2019


Aftertreatment Diesel Exhaust Fluid Return Valve - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 4157

Aftertreatment Diesel Exhaust Fluid Return Valve - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4157 PID: SPN: 4376 FMI: 7/7 LAMP: Amber SRT: | A stuck aftertreatment diesel exhaust fluid return valve has been detected. | None on performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit

Circuit Description

The aftertreatment diesel exhaust fluid return valve is used to purge the aftertreatment diesel exhaust fluid dosing system. When the return valve is energized, the dosing system will purge and return the aftertreatment diesel exhaust fluid to the tank.

Component Location

The aftertreatment diesel exhaust fluid return valve is internal to the aftertreatment diesel exhaust fluid dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic only runs when the aftertreatment diesel exhaust fluid dosing system is purging.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure did not drop when the aftertreatment diesel exhaust fluid return valve was commanded on.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid System Leak Test" found under "ECM Diagnostic Tests" in the recommended Cummins electronic service tool or equivalent.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel exhaust fluid return valve

Refer to Troubleshooting Fault Code 4157.

Last Modified: 25-May-2019


Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Bad Intelligent Device or Component

FAULT CODE 4158

Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4158 PID: SPN: 5742 FMI: 12/12 LAMP: Amber SRT: | An internal error has been detected in the aftertreatment diesel particulate filter temperature sensor module. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Temperature Sensor Module Circuit

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter temperature sensor module is mounted on the aftertreatment diesel particulate filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter temperature sensor module reported an internal error.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Active and stationary regeneration of the diesel particulate filter will be disabled.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel particulate filter temperature sensor module

Refer to Troubleshooting Fault Code 4158.

Last Modified: 25-May-2019


Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Bad Intelligent Device or Component

FAULT CODE 4159

Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4159 PID: SPN: 5743 FMI: 12/12 LAMP: Amber SRT: | An internal error has been detected in the aftertreatment SCR temperature sensor module. | Possible reduced engine performance.
Aftertreatment SCR Temperature Sensor Module Circuit

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intermediate temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported an internal error.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment SCR temperature sensor module

Refer to Troubleshooting Fault Code 4159.

Last Modified: 25-May-2019


Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Voltage Above Normal or Shorted to High Source

FAULT CODE 4161

Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4161 PID: SPN: 5742 FMI: 3/3 LAMP: Amber SRT: | High battery supply voltage detected at the aftertreatment diesel particulate filter temperature sensor module. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Temperature Sensor Module Circuit

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter temperature sensor module is mounted on the aftertreatment diesel particulate filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter temperature sensor module reported high battery supply voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Incorrect battery voltage setting in the recommended Cummins electronic service tool or equivalent.

Incorrect sensor for the application (12 VDC versus 24 VDC)

High battery voltage supply

Refer to Troubleshooting Fault Code 4161.

Last Modified: 25-May-2019


Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4162

Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4162 PID: SPN: 5742 FMI: 4/4 LAMP: Amber SRT: | Low battery supply voltage detected at the aftertreatment diesel particulate filter temperature sensor module. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Temperature Sensor Module

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter temperature sensor module is mounted on the aftertreatment diesel particulate filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter temperature sensor module reported low battery supply voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Incorrect battery voltage setting in the recommended Cummins electronic service tool or equivalent.

Incorrect sensor for the application (12 VDC versus 24 VDC)

Low battery voltage supply

Refer to Troubleshooting Fault Code 4162.

Last Modified: 25-May-2019


Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 4163

Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4163 PID: SPN: 5742 FMI: 0/16 LAMP: Amber SRT: | High internal temperature detected in the aftertreatment diesel particulate filter temperature sensor module. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Temperature Sensor Module

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter temperature sensor module is mounted on the aftertreatment diesel particulate filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter temperature sensor module reported the internal circuit board temperature was too high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates the internal temperature of the aftertreatment diesel particulate filter temperature sensor module was too high. Troubleshoot the exhaust system for leaks, missing heat shields, or dirt and debris that could lead to over heating of the aftertreatment diesel particulate filter temperature sensor module.

Refer to Troubleshooting Fault Code 4163.

Last Modified: 25-May-2019


Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Voltage Above Normal or Shorted to High Source

FAULT CODE 4164

Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4164 PID: SPN: 5743 FMI: 3/3 LAMP: Amber SRT: | High battery supply voltage detected at the aftertreatment SCR temperature sensor module. | Possible reduced engine performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intermediate temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported high battery supply voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Incorrect battery voltage setting in the recommended Cummins electronic service tool or equivalent.

Incorrect sensor for the application (12 VDC versus 24 VDC)

High battery voltage supply

Refer to Troubleshooting Fault Code 4164.

Last Modified: 25-May-2019


Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4165

Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4165 PID: SPN: 5743 FMI: 4/4 LAMP: Amber SRT: | Low battery supply voltage detected at the aftertreatment SCR temperature sensor module. | Possible reduced engine performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intermediate temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported low battery supply voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Incorrect battery voltage setting in the recommended Cummins electronic service tool or equivalent.

Incorrect sensor for the application (12 VDC versus 24 VDC)

Low battery voltage supply

Refer to Troubleshooting Fault Code 4165.

Last Modified: 25-May-2019


Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 4166

Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4166 PID: SPN: 5743 FMI: 0/16 LAMP: Amber SRT: | High internal temperature detected in the aftertreatment SCR temperature sensor module. | Possible reduced engine performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intermediate temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported the internal circuit board temperature was too high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates the internal temperature of the aftertreatment SCR temperature sensor module was too high. Troubleshoot the exhaust system for leaks, missing heat shields, or dirt and debris that could lead to overheating of the aftertreatment SCR temperature sensor module.

Refer to Troubleshooting Fault Code 4166.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 1 Heater Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 4168

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 1 Heater Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4168 PID: SPN: 5745 FMI: 3/3 LAMP: Amber SRT: | The aftertreatment diesel exhasut fluid dosing unit heater is detected to be stuck on. | None on performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit heater is used to defrost and/or prevent freezing of the diesel exhaust fluid dosing unit.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment diesel exhaust fluid dosing unit heater is commanded OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing unit heater temperature was rising when the aftertreatment diesel exhaust fluid dosing unit heater was commanded OFF.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel exhaust fluid dosing unit heater relay

A short circuit to battery in the OEM harness

Refer to Troubleshooting Fault Code 4168.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 1 Heater Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4169

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 1 Heater Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4169 PID: SPN: 5745 FMI: 4/4 LAMP: Amber SRT: | The aftertreatment diesel exhasut fluid dosing unit heater is detected to be stuck off. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit heater is used to defrost and/or prevent freezing of the diesel exhaust fluid dosing unit.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment diesel exhaust fluid dosing unit heater is commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing unit heater temperature was not rising when the aftertreatment diesel exhaust fluid dosing unit heater was commanded ON.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be severely reduced.

Vehicle speed will be limited to 8 km [5 mi] per hour after extended engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use the recommended Cummins electronic service tool or equivalent to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel exhaust fluid dosing unit heater relay

A short circuit to ground in the OEM harness

Refer to Troubleshooting Fault Code 4169.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 1 Heater - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 4171

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 1 Heater - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4171 PID: SPN: 5745 FMI: 1/18 LAMP: Amber SRT: | The aftertreatment diesel exhaust fluid dosing unit failed to thaw. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit heater is used to defrost and/or prevent freezing of the diesel exhaust fluid dosing unit.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment diesel exhaust fluid dosing unit heater is commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing unit failed to reach a target temperature after heating for a calibratable amount of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use the recommended Cummins electronic service tool or equivalent to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel exhaust fluid dosing unit heater

Refer to Troubleshooting Fault Code 4171.

Last Modified: 25-May-2019


Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 418

Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 418 PID: P97 SPN: 97 FMI: 0/15 LAMP: Maintenance SRT: | The Water in Fuel Indicator indicates that the water level is above warning level. | None on performance.
Water-in-Fuel Indicator Circuit

Circuit Description

The water-in-fuel sensor is in the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage down, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected water in the fuel filter was above the sensor level.

Action Taken When the Fault Code is Active

The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates that water has been detected in the water separation fuel filter. Drain the water from the fuel filter.

If this fault code is active and there is no water in the fuel filter then a malfunctioning Water-In-Fuel sensor or water in the sensor connector could be causing the fault.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 418.

Last Modified: 25-May-2019


Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 421

Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 421 PID: P175 SPN: 175 FMI: 0/16 LAMP: Amber SRT: | Engine oil temperature signal indicates engine oil temperature above engine protection warning limit. | Possible reduced engine performance.
Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil. The engine control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature.

Component Location

The engine oil temperature sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil temperature was greater than the warning engine protection limit for 5 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates that the engine oil temperature has exceeded the warning engine protection limit for oil temperature. Troubleshoot the cause of high engine oil temperature.

Refer to Troubleshooting Fault Code 421.

Last Modified: 25-May-2019


Aftertreatment Regeneration Inhibit Switch - Data Erratic, Intermittent, or Incorrect

FAULT CODE 4213

Aftertreatment Regeneration Inhibit Switch - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4213 PID: SPN: 3695 FMI: 2/2 LAMP: Amber SRT: | The aftertreatment regeneration permit switch is stuck in the OFF or INHIBIT position. | Possible frequent need for aftertreatment regeneration.
Engine Control Module (ECM)

Circuit Description

The OEM truck manufacturer can install a permit switch in the dash or send an inhibit message via the J1939 data link to the engine ECM. The function of the inhibit message is to prevent the aftertreatment system from performing mobile regenerations.

Component Location

The aftertreatment regeneration permit switch can be an actual switch in the vehicle dash or it can be a J1939 message sent via the J1939 data link. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment regeneration permit switch is stuck in the OFF or INHIBIT position and the ECM is requesting active regeneration.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and perform the recommended Cummins electronic service tool or equivalent Aftertreatment Diesel Particulate Filter Regeneration Test.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment regeneration permit switch circuit.

Incorrect feature and parameter settings

Refer to Troubleshooting Fault Code 4213.

Last Modified: 25-May-2019


Anti-Lock Braking (ABS) Active - Condition Exists

FAULT CODE 4215

Anti-Lock Braking (ABS) Active - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4215 PID: SPN: 563 FMI: 11/31 LAMP: None SRT: | Cruise control was paused due to an anti-wheel slip message from the ABS controller. | Adaptive cruise control will not operate. Standard cruise control may not operate.
Engine Control Module (ECM)

Circuit Description

Certain anti-lock braking (ABS) controllers communicate with the engine control module (ECM) through the SAE J1939 data link. Under certain driving conditions, the anti-lock braking (ABS) controller can send a cruise control inhibit message to the ECM and cruise control will temporarily be disabled.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) disabled cruise control due to an anti-wheel slip message from the anti-lock braking (ABS) controller.

Action Taken When the Fault Code is Active

Cruise control has temporarily been inhibited.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This is an information only fault code to indicate that cruise control was interrupted due to a message from the ABS controller. No troubleshooting is necessary.

Refer to Troubleshooting Fault Code 4215.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 4233

Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4233 PID: SPN: 3515 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Temperature Sensor - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at the diesel exhaust fluid temperature sensor circuit | Possible reduced engine performance.
SAE J1939 Datalink

Circuit Description

The aftertreatment diesel exhaust fluid (DEF) sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment DEF sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment DEF sensor monitors the tank level, temperature and quality of the DEF fluid.

Component Location

The aftertreatment diesel exhaust fluid (DEF) sensor is located in the aftertreatment DEF tank. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning Aftertreatment DEF Quality Sensor.

Refer to Troubleshooting Fault Code 4233.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4234

Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4234 PID: SPN: 3515 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Temperature Sensor - Voltage Below Normal or Shorted to Low Source. Low signal voltage or short circuit detected at the diesel exhaust fluid temperature sensor circuit | Possible reduced engine performance.
SAE J1939 Datalink

Circuit Description

The aftertreatment diesel exhaust fluid (DEF) sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment DEF sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment DEF sensor monitors the tank level, temperature and quality of the DEF fluid.

Component Location

The aftertreatment diesel exhaust fluid (DEF) sensor is located in the aftertreatment DEF tank. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing temperature sensor signal circuit was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning Aftertreatment DEF Quality Sensor.

Refer to Troubleshooting Fault Code 4234.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 - Abnormal Rate of Change

FAULT CODE 4243

Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4243 PID: SPN: 3515 FMI: 10/10 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 - Abnormal Rate of Change | Possible reduced engine performance.
ECM

Circuit Description

The aftertreatment diesel exhaust fluid quality sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor is used to measure the concentration of the aftertreatment diesel exhaust fluid in the tank.

Component Location

The DEF quality sensor is typically mounted in the DEF tank or in-line with the DEF dosing unit supply line. Reference the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

The engine must be turned OFF for period of 8 hours before this diagnostic will run. This diagnostic runs when the keyswitch is turned to the ON position after an 8 hour cold soak.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank temperature sensor reading was higher or lower than the other temperature sensors on the engine.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, the engine must be shut down with the keyswitch in the OFF position for 8 hours. After the 8 hour cold soak, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

Malfunctioning Aftertreatment DEF Quality Sensor.

Refer to Troubleshooting Fault Code 4243.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Dosing Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 4244

Aftertreatment 1 Diesel Exhaust Fluid Dosing Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4244 PID: SPN: 4337 FMI: 2/2 LAMP: Amber SRT: | The aftertreatment diesel exhaust fluid dosing temperature is irrational. | None on performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit heater is used to defrost and/or prevent freezing of the diesel exhaust fluid dosing unit.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

The engine must be turned OFF for period of 8 hours before this diagnostic will run. This diagnostic runs when the keyswitch is turned to the ON position after an 8 hour cold soak.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing unit temperature was higher or lower than the other temperature sensors on the engine after an extended period of engine OFF time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • If the fault code does not go inactive, it may be necessary to perform a 8 hour cold soak with the key OFF, then turn the keyswitch to the ON position so that the key ON portion of the diagnostic will run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel exhaust fluid dosing unit temperature sensor

Refer to Troubleshooting Fault Code 4244.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Heater Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 4245

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Heater Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4245 PID: SPN: 5798 FMI: 2/2 LAMP: Amber SRT: | The aftertreatment diesel exhaust fluid dosing unit heater temperature is irrational. | None on performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit heater is used to defrost and/or prevent freezing of the diesel exhaust fluid dosing unit.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

The engine must be turned OFF for period of 8 hours before this diagnostic will run. This diagnostic runs when the keyswitch is turned to the ON position after an 8 hour cold soak.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing unit heater temperature reading was higher or lower than the other temperature sensors on the engine after an extended period of engine OFF time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • If the fault code does not go inactive, it may be necessary to perform a 8 hour cold soak with the key OFF, then turn the keyswitch to the ON position so that the key ON portion of the diagnostic will run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel exhaust fluid dosing unit heater temperature sensor

Refer to Troubleshooting Fault Code 4245.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Dosing Temperature - Abnormal Rate of Change

FAULT CODE 4249

Aftertreatment 1 Diesel Exhaust Fluid Dosing Temperature - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4249 PID: SPN: 4337 FMI: 10/10 LAMP: Amber SRT: | The aftertreatment diesel exhaust fluid dosing unit temperature is stuck. | None on performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit heater is used to defrost and/or prevent freezing of the diesel exhaust fluid dosing unit.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment diesel exhaust fluid dosing unit heater is commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing unit temperature is not changing when the heater is commanded ON.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use the recommended Cummins electronic service tool or equivalent to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel exhaust fluid dosing unit heater

A malfunctioning aftertreatment diesel exhaust fluid dosing unit temperature sensor

Refer to Troubleshooting Fault Code 4249.

Last Modified: 25-May-2019


Engine Oil Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 425

Engine Oil Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 425 PID: P175 SPN: 175 FMI: 2/2 LAMP: Amber SRT: | The engine oil temperature is erratic. | None on performance.
Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil. The engine control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature.

Component Location

The engine oil temperature sensor is located in the oil rifle.

Conditions for Running the Diagnostics

This diagnostic consists of two parts:

The first part runs when the keyswitch is turned ON and before engine speed is detected.

The engine must be turned OFF for period of 8 hours before this diagnostic will run. This diagnostic runs when the keyswitch is turned to the ON position after an 8 hour cold soak.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil temperature was higher or lower than the other temperature sensors on the engine after an extended period of engine off time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning oil temperature sensor.

Resistance in the signal line

Refer to Troubleshooting Fault Code 425.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Heater Temperature - Abnormal Rate of Change

FAULT CODE 4251

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Heater Temperature - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4251 PID: SPN: 5798 FMI: 10/10 LAMP: Amber SRT: | The aftertreatment diesel exhaust fluid dosing unit heater temperature sensor reading is stuck. | None on performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit heater is used to defrost and/or prevent freezing of the diesel exhaust fluid dosing unit.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment diesel exhaust fluid dosing unit heater is commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing unit heater temperature sensor reading was not changing when the heater was commanded ON.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use the recommended Cummins electronic service tool or equivalent to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel exhaust fluid dosing unit heater

A malfunctioning aftertreatment diesel exhaust fluid dosing unit heater temperature sensor

Refer to Troubleshooting Fault Code 4251.

Last Modified: 25-May-2019


Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Root Cause Not Known

FAULT CODE 4259

Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4259 PID: SPN: 5742 FMI: 11/11 LAMP: Amber SRT: | Intermittent battery voltage supply detected at the aftertreatment diesel particulate filter temperature sensor module. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Temperature Sensor Module

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter temperature sensor module is mounted on the aftertreatment diesel particulate filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an intermittent battery voltage supply to the aftertreatment diesel particulate filter temperature sensor module resulting in an internal reset of the module.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code sets when the ECM detects an internal reset of the sensor. This internal reset is caused by an intermittent battery voltage supply. This fault code indicates that an intermittent wiring problem has been detected. All wiring and connectors should be closely inspected for intermittent connections.

Refer to Troubleshooting Fault Code 4259.

Last Modified: 25-May-2019


Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Root Cause Not Known

FAULT CODE 4261

Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4261 PID: SPN: 5743 FMI: 11/11 LAMP: Amber SRT: | Intermittent battery voltage supply detected at the aftertreatment SCR temperature sensor module. | Possible reduced engine performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intermediate temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an intermittent battery voltage supply to the aftertreatment SCR temperature sensor module resulting in an internal reset of the module.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code sets when the ECM detects an internal reset of the sensor. This internal reset is caused by an intermittent battery voltage supply. This fault code indicates that an intermittent wiring problem has been detected. All wiring and connectors should be closely inspected for intermittent connections.

Refer to Troubleshooting Fault Code 4261.

Last Modified: 25-May-2019


J1939 Network #1 - Abnormal Update Rate

FAULT CODE 427

J1939 Network #1 - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 427 PID: S231 SPN: 639 FMI: 9/9 LAMP: None SRT: | Communication between the engine control module (ECM) and another device on the SAE J1939 data link has been lost. | Engine will only idle.
SAE J1939 Data Link Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Electrical problems with the SAE J1939 data link wiring such as grounded, shorted, or open circuits

The ECM (or another SAE J1939 device) tying up communications by sending too many consecutive messages

The external OEM controlling device has malfunctioned or can no longer transmit on the data link.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 427 .

Last Modified: 13-Oct-2021


Aftertreatment 1 Diesel Exhaust Fluid Quality - Abnormal Rate of Change

FAULT CODE 4277

Aftertreatment 1 Diesel Exhaust Fluid Quality - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4277 PID: SPN: 3364 FMI: /10 LAMP: Amber SRT: | The Urea Quality Sensor has been unable to generate a concentration value for a period of time. | Engine power derate.
SAE J1939 Datalink

Circuit Description

The DEF quality sensor is a smart device and communicates with the engine electronic control module (ECM) via the J1939 data link. The DEF quality sensor receives power and ground directly from the battery. The sensor performs its own internal diagnostics and reports malfunctions back to the primary engine ECM via the J1939 data link. The DEF quality sensor is used to measure the concentration of the DEF in the tank.

Component Location

The aftertreatment diesel exhaust fluid quality sensor is located in the aftertreatment diesel exhaust fluid tank. It may be a combination sensor with the aftertreatement diesel exhaust fluid tank level and tank temperature sensors. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the following conditions are met:

Keyswitch is in the ON position or when the engine is running.

Ambient temperature is above -20Â°C [-4Â°F].

Vehicle altitude change is less than 305 m [1000 ft] in 1 hour.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) lost communication with the aftertreatment DEF quality sensor via the J1939 data link.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Low aftertreatment diesel exhaust fluid level in the diesel exhaust fluid tank
  • Shorted or open J1939 data link wiring.
  • Malfunctioning Aftertreatment DEF Quality Sensor.
  • Inactive counts can be caused by elevation changes or tank sloshing while driving.
Refer to Troubleshooting Fault Code 4277 .

Last Modified: 13-Oct-2021


Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 428

Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 428 PID: P97 SPN: 97 FMI: 3/3 LAMP: Amber SRT: | High voltage detected at the water-in-fuel circuit. | None on performance.
Water-in-Fuel Indicator Sensor Circuit

Circuit Description

The water-in-fuel sensor is in the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage down, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the water in fuel sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Open RETURN or SIGNAL circuit in the harness, connectors, or sensor

Signal wire shorted to sensor supply or battery voltage.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 428.

Last Modified: 25-May-2019


Aftertreatment 1 SCR Intermediate NH3 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 4281

Aftertreatment 1 SCR Intermediate NH3 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4281 PID: SPN: 5848 FMI: 2/2 LAMP: Amber SRT: | The aftertreatment SCR intermediate NH3 sensor reading is stuck. | None on performance.
Aftertreatment SCR Intermediate NH3 Sensor Circuit

Circuit Description

The aftertreatment SCR intermediate NH3 (ammonia) sensor is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment intermediate NH3 sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module using the J1939 data link. The aftertreatment intermediate NH3 sensor is used to measure the ammonia in the aftertreatment system.

Component Location

The aftertreatment SCR intermediate NH3 sensor is located in the middle of the aftetreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic has to meet specific engine and aftertreatment conditions to run and complete.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment SCR intermediate NH3 sensor reading is not changing.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • It is necessary to use the "Reset All Faults" command in the recommended Cummins electronic service tool or equivalent to clear this fault and extinguish the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL).

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment SCR intermediate NH3 sensor probe

Refer to Troubleshooting Fault Code 4281.

Last Modified: 25-May-2019


Accelerator Pedal or Lever Position Sensor 1 Circuit Frequency - Abnormal Frequency or Pulse Width or Period

FAULT CODE 4289

Accelerator Pedal or Lever Position Sensor 1 Circuit Frequency - Abnormal Frequency or Pulse Width or Period

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4289 PID: SPN: 91 FMI: 8/8 LAMP: Red SRT: | The accelerator pedal position sensor reading is out of range. | The engine will operate in Limp Home mode.
Accelerator Pedal Position Sensor Circuit

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the accelerator pedal position sensor reading was out of range.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

The engine will have limp-home throttle control only.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning accelerator pedal position sensor.

A short circuit to ground in the OEM harness

An open circuit in the OEM harness

A short circuit to battery in the OEM harness

Refer to Troubleshooting Fault Code 4289.

Last Modified: 25-May-2019


Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 429

Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 429 PID: P97 SPN: 97 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at the water-in-fuel circuit. | None on performance.
Water-in-Fuel Indicator Sensor Circuit

Circuit Description

The water-in-fuel sensor is in the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage down, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the water in fuel sensor signal voltage was less than 0.05-VDC for 1 second.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Signal circuit shorted to ground in the harness, sensor, or connector.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 429.

Last Modified: 25-May-2019


Engine Brake Active Lamp - Voltage Above Normal or Shorted to High Source

FAULT CODE 4293

Engine Brake Active Lamp - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4293 PID: SPN: 5097 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the brake lamp relay driver circuit. | None on performance.
Brake Lamp Relay Circuit

Circuit Description

The brake lamp relay is an OEM optional component used to illuminate the vehicle's brake lamps under conditions when the engine is braking.

Component Location

The brake lamp relay is an OEM component. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the brake lamp relay driver circuit was shorted to high source or open circuit.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Incorrect feature and parameter settings

An open circuit in the OEM harness

A short circuit to battery in the OEM harness

Refer to Troubleshooting Fault Code 4293.

Last Modified: 25-May-2019


Engine Brake Active Lamp - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4294

Engine Brake Active Lamp - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4294 PID: SPN: 5097 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the brake lamp relay driver circuit. | None on performance.
Brake Lamp Relay Circuit

Circuit Description

The brake lamp relay is an OEM optional component used to illuminate the vehicle's brake lamps under conditions when the engine is braking.

Component Location

The brake lamp relay is an OEM component. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the brake lamp relay driver circuit was shorted to low source.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Incorrect feature and parameter settings

A short circuit to ground in the OEM harness

Refer to Troubleshooting Fault Code 4294.

Last Modified: 25-May-2019


Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 435

Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 435 PID: P100 SPN: 100 FMI: 2/2 LAMP: Amber SRT: | The engine oil pressure sensor is reading an erratic value. | None on performance.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

An engine oil pressure switch or oil pressure sensor is used by the engine control module (ECM) to monitor the lubricating oil pressure. For engines with an oil pressure switch, the switch is normally closed when the engine is not running and open when oil pressure is present. For engines with an oil pressure sensor, the ECM will detect a low signal voltage at operating conditions when the oil pressure is low. The ECM will detect a high signal voltage at operating conditions when the oil pressure is high.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

  • The first part of the diagnostic runs continuously while the keyswitch is in the ON position or the engine is running.

The second part of the diagnostic runs at key OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure reading was higher or lower than the other absolute pressure sensors on the engine after the keyswitch has been turned OFF and the engine has stopped running.

The ECM detected the engine oil pressure reading was higher than calibrated limit.

The Engine Control Module (ECM) detected that the engine oil pressure reading was not changing with engine RPM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

A default value for the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

High resistance in the engine harness.

Malfunctioning engine oil pressure sensor.

  • A malfunctioning oil pressure relief valve.

Malfunctioning oil pump.

Refer to Troubleshooting Fault Code 435.

Last Modified: 25-May-2019


Intake Manifold 1 Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 436

Intake Manifold 1 Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 436 PID: P105 SPN: 105 FMI: 2/2 LAMP: Amber SRT: | The intake manifold pressure sensor is reading an erratic value. | Possible reduced engine performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic consists of two parts.The first part runs when the keyswitch is turned ON and before engine speed is detected.The ECM must not see a key cycle for a period of 8 hours before this part of the diagnostic will run.

The second part runs continuously while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine intake manifold temperature sensor reading was higher or lower than the other temperature sensors on the engine after an extended period of engine OFF time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value is used for the intake manifold temperature reading.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

In-range malfunction of the engine intake manifold temperature sensor

High resistance in the engine intake manifold temperature sensor signal or return lines.

Refer to Troubleshooting Fault Code 436.

Last Modified: 25-May-2019


Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 441

Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 441 PID: P168 SPN: 168 FMI: 1/18 LAMP: Amber SRT: | ECM supply voltage is below the minimum system voltage level. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Unswitched Battery Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected low battery supply voltage.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Verify that the ECM unswitched power supply is coming from the batteries and not the starter or other device. Check for possible weak batteries.

If the ECM unswitched battery supply is taken from the starter, check for low voltage during cranking. Low voltage during cranking can cause the ECM power supply to drop below specifications and log Fault Code 441.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 441.

Last Modified: 25-May-2019


Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 442

Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 442 PID: P168 SPN: 168 FMI: 0/16 LAMP: Amber SRT: | ECM supply voltage is above the maximum system voltage level. | None on performance.
Unswitched Battery Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected excessive battery supply voltage.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Faulty alternator or regulator that is overcharging the system

Batteries connected in series instead of parallel

Incorrect jump-starting procedure.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 442.

Last Modified: 25-May-2019


Aftertreatment 1 Particulate Sensor Regeneration Status - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 4449

Aftertreatment 1 Particulate Sensor Regeneration Status - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4449 PID: SPN: 6773 FMI: 0/16 LAMP: Amber SRT: | The aftertreatment particulate matter sensor has detected in-range high sensor values. | Possible reduced engine performance.
Aftertreatment Particulate Sensor Circuit

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The residual current flow through the sensor after a sensor regeneration was higher than a threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning aftertreatment particulate matter sensor

  • Internal engine damage.
Refer to Troubleshooting Fault Code 4449 .

Last Modified: 05-Dec-2021


Aftertreatment 1 SCR Intermediate NH3 - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 4453

Aftertreatment 1 SCR Intermediate NH3 - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4453 PID: SPN: 5848 FMI: 7/7 LAMP: Amber SRT: | The maximum dosing adjustment has been reached. | None on performance.
Engine Control Module (ECM)

Circuit Description

The aftertreatment SCR intermediate NH3 (ammonia) sensor is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment intermediate NH3 sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module using the J1939 data link. The aftertreatment intermediate NH3 sensor is used to measure the ammonia in the aftertreatment system.

Component Location

The aftertreatment SCR intermediate NH3 sensor is located in the middle of the aftetreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic has to meet specific engine and aftertreatment conditions to run and complete.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the adjusted aftertreatment diesel exhaust fluid dosing command based on the aftertreatment SCR intermediate NH3 sensor has reached a maximum limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • It is necessary to use the "Reset All Faults" command in the recommended Cummins electronic service tool or equivalent to clear this fault and extinguish the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL).

Shop Talk

Troubleshoot any aftertreatment intermediate NH3 sensor, aftertreatment diesel exhaust fluid dosing system, or any aftertreatment SCR temperature sensor fault codes prior to this fault code.

Refer to Troubleshooting Fault Code 4453.

Last Modified: 25-May-2019


Engine Air Shutoff - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 4484

Engine Air Shutoff - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4484 PID: SPN: 3667 FMI: 7/7 LAMP: Red SRT: | Engine air shutoff failed to close during test mode. | The engine air shutoff valve will be disabled.
ISX15 CM2350 X101 - Engine Air Shutoff Sensor Circuit

Circuit Description

The air shutoff valve is either an original equipment manufacturer (OEM) or CumminsÂ installed component that shuts off the flow of air into the intake of the engine in order to prevent an engine overspeed condition. When activated, the engine control module (ECM) supplies 12-VDC to the air shutoff solenoid. This solenoid then activates the valve, closing a plate over the intake.

Component Location

The air shutoff valve is either an OEM or CumminsÂ installed component, and is usually located on the air intake connection.

Conditions for Running the Diagnostics

This diagnostic only runs during an Air Shutoff Valve Test.

Conditions for Setting the Fault Codes

The ECM detects that the air shutoff valve has not closed.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • Use the recommended Cummins electronic service tool or equivalent to calibrate the ECM.
  • NOTE: The engine must be calibrated again to clear the fault code. This is done because of the hazardous operating environment and safety considerations.
  • To validate the repair, the Air Shutoff Valve Test must be performed again and successfully passed.

Shop Talk

Possible causes of this fault code include:

Malfunctioning air shutoff valve.

Broken or disconnected air shutoff position switch SIGNAL wire.

Broken or disconnected air shutoff position switch RETURN wire.

Refer to Troubleshooting Fault Code 4484.

Last Modified: 25-May-2019


Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 451

Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 451 PID: P157 SPN: 157 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the fuel rail pressure sensor circuit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Injector Metering Rail 1 Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the fuel rail pressure sensor using a dedicated sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel rail pressure sensor provides a primary fuel pressure signal to the ECM on the fuel rail pressure sensor signal 1 circuit. The sensor also provides a secondary fuel pressure sensor signal on the fuel rail pressure signal 2 circuit. This sensor signal voltage changes based on the pressure in the fuel rail. The ECM will detect a high signal voltage at high rail pressure conditions. The ECM will detect a low signal voltage during low rail pressure conditions.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel rail pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the fuel rail pressure reading is used.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Causes for this fault code include:

Voltage (+5-VDC or higher shorted to the signal wire)

Open circuit on the signal wire

Open circuit on the 5 Volt supply wire

Open circuit on the return wire

Malfunctioning sensor

Malfunctioning ECM.

Refer to Troubleshooting Fault Code 451.

Last Modified: 25-May-2019


Vehicle Identification Number - Out of Calibration

FAULT CODE 4517

Vehicle Identification Number - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4517 PID: SPN: 237 FMI: 13/13 LAMP: Amber SRT: | The vehicle identification number has not been programmed into the ECM. | None on performance.
Engine Control Module (ECM)

Circuit Description

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins ECM and used for controlling the engine. The Cummins ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The Engine Control Module (ECM) is mounted on the intake manifold side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the vehicle identification number (VIN) was not programmed in the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Incorrect feature and parameter settings

Refer to Troubleshooting Fault Code 4517.

Last Modified: 25-May-2019


Aftertreatment 1 SCR Intermediate Gas Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 4518

Aftertreatment 1 SCR Intermediate Gas Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4518 PID: SPN: 5862 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the aftreatment SCR intermediate temperature sensor circuit. | Possible reduced engine performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intermediate temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported the aftertreatment SCR intermediate temperature signal was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment SCR intermediate temperature sensor

Refer to Troubleshooting Fault Code 4518.

Last Modified: 25-May-2019


Aftertreatment 1 SCR Intermediate Gas Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4519

Aftertreatment 1 SCR Intermediate Gas Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4519 PID: SPN: 5862 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the aftertreatment SCR intermediate temperature sensor circuit. | Possible reduced engine performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intermediate temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported the aftertreatment SCR intermediate temperature signal was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment SCR intermediate temperature sensor

Refer to Troubleshooting Fault Code 4519.

Last Modified: 25-May-2019


Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 452

Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 452 PID: P157 SPN: 157 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the fuel rail pressure sensor circuit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Injector Metering Rail 1 Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the fuel rail pressure sensor using a dedicated sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel rail pressure sensor provides a primary fuel pressure signal to the ECM on the fuel rail pressure sensor signal 1 circuit. The sensor also provides a secondary fuel pressure sensor signal on the fuel rail pressure signal 2 circuit. This sensor signal voltage changes based on the pressure in the fuel rail. The ECM will detect a high signal voltage at high rail pressure conditions. The ECM will detect a low signal voltage during low rail pressure conditions.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel rail pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the fuel rail pressure reading is used.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Causes for this fault code include:

Supply or signal wire is shorted to ground.

Damaged sensor

Damaged ECM.

Refer to Troubleshooting Fault Code 452.

Last Modified: 25-May-2019


Aftertreatment 1 SCR Intermediate Gas Temperature Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 4521

Aftertreatment 1 SCR Intermediate Gas Temperature Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4521 PID: SPN: 5862 FMI: 2/2 LAMP: Amber SRT: | The aftertreatment SCR intermediate temperature sensor reading is irrational. | Possible reduced engine performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intermediate temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and exhaust flow is above a minimum level.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment SCR intermediate temperature sensor signal was irrational for more than 5 minutes.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, it may be necessary to operate the vehicle on a chassis dynamometer or to drive the vehicle in order to get the engine load high enough for the diagnostic to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment SCR intermediate temperature sensor

A malfunctioning aftertreatment SCR outlet temperature sensor

Refer to Troubleshooting Fault Code 4521.

Last Modified: 25-May-2019


Aftertreatment 1 SCR Intermediate Gas Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 4524

Aftertreatment 1 SCR Intermediate Gas Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4524 PID: SPN: 5862 FMI: 0/0 LAMP: Red SRT: | The aftertreatment SCR intermediate temperature sensor reading is above the engine protection limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intermediate temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment SCR intermediate temperature was above 800 C [1472] for 20 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning fuel injectors

A malfunctioning aftertreatment fuel injector

A malfunctioning aftertreatment SCR intermediate temperature sensor

Contaminated diesel exhaust fluid

Refer to Troubleshooting Fault Code 4524.

Last Modified: 25-May-2019


Aftertreatment 1 SCR Intermediate Gas Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 4525

Aftertreatment 1 SCR Intermediate Gas Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4525 PID: SPN: 5862 FMI: 0/16 LAMP: Red SRT: | High SCR Intermediate temperature detected. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intermediate temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active regeneration of the aftertreatment diesel particulate filter is not occurring.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment SCR intermediate temperature was above 650 C [1202 F] for 60 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning fuel injectors

A malfunctioning aftertreatment fuel injector

A malfunctioning aftertreatment SCR intermediate temperature sensor

Contaminated diesel exhaust fluid

Refer to Troubleshooting Fault Code 4525.

Last Modified: 25-May-2019


Brake Pedal Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 4526

Brake Pedal Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4526 PID: SPN: 521 FMI: 2/2 LAMP: Amber SRT: | The values of the 2 brake switch signals do not match. | None on performance.
Engine Control Module (ECM)

Circuit Description

The Engine Control Module (ECM) monitors the brake pedal position using two brake pedal position switches.

Component Location

The brake pedal position switch is mounted to the brake pedal. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the two brake switch signals do not match.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning brake pedal position switch

A short circuit to ground in the OEM harness

An open circuit in the OEM harness

Refer to Troubleshooting Fault Code 4526.

Last Modified: 25-May-2019


Aftertreatment Fuel Shutoff Valve - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 4568

Aftertreatment Fuel Shutoff Valve - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4568 PID: SPN: 3482 FMI: 0/16 LAMP: Amber SRT: | A plugged aftertreatment fuel shutoff valve orifice has been detected. | Possible frequent need for aftertreatment regeneration.
Engine Control Module (ECM)

Circuit Description

The aftertreatment fuel shutoff valve is used to disable the fuel supply to the aftertreatment system.

Component Location

The aftertreatment fuel injector is installed in the exhaust system in the turbocharger adapter pipe. The aftertreatment fuel pressure sensor and aftertreatment fuel shutoff valve are installed in the shutoff valve manifold. The aftertreatment purge air actuator is located above the shutoff valve manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active regeneration of the aftertreatment diesel particulate filter is occurring.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment fuel shutoff valve orifice is plugged.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and perform the recommended Cummins electronic service tool or equivalent Aftertreatment Diesel Particulate Filter Regeneration Test.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment fuel injector

A malfunctioning aftertreatment fuel shutoff valve.

Refer to Troubleshooting Fault Code 4568.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Abnormal Update Rate

FAULT CODE 4572

Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4572 PID: SPN: 3031 FMI: 9/9 LAMP: Amber SRT: | The ECM lost communication with the aftertreatment diesel exhaust fluid tank temperature sensor. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank temperature sensor is used to monitor the temperature of the aftertreatment diesel exhaust fluid inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of communication with the aftertreatment diesel exhaust fluid tank temperature sensor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Incorrect terminating resistance of the SAE J1939 datalink circuit

Intermittent communication from the aftertreatment diesel exhaust fluid tank temperature sensor

An open or short circuit in the SAE J1939 datalink circuit

Refer to Troubleshooting Fault Code 4572.

Last Modified: 25-May-2019


Aftertreatment Diesel Particulate Filter System - Special Instructions

FAULT CODE 4584

Aftertreatment Diesel Particulate Filter System - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4584 PID: SPN: 3936 FMI: 14/14 LAMP: Red SRT: | Aftertreatment Diesel Particulate Filter System - Special Instructions. the incorrect aftertreatment diesel particulate filter system has been installed with the engine | Engine will shut down.
Engine Control Module (ECM)

Circuit Description

Because engines and aftertreatment components are manufactured in different locations, they are shipped to OEM customers for final vehicle assembly. The process involves both hardware and software elements in detecting the correct match of aftertreatment system to engine model during initial engine to machine integration.

Component Location

The aftertreatment diesel particulate filter temperature sensor module is mounted on the aftertreatment diesel particulate filter.

Conditions for Running the Diagnostics

This diagnostic runs at key ON in the first 50 hours of engine run time.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine has been manufactured with the incorrect Diesel Particulate Filter System

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The purpose of this fault code is to indicate when the wrong aftertreatment system has been mated to the engine during the equipment assembly process. If this fault code is active, the aftertreatment part numbers should be verified.

Refer to Troubleshooting Fault Code 4584.

Last Modified: 25-May-2019


Aftertreatment 1 SCR Catalyst System - Special Instructions

FAULT CODE 4585

Aftertreatment 1 SCR Catalyst System - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4585 PID: SPN: 4792 FMI: 14/14 LAMP: Red SRT: | An incorrect SCR system has been installed. | Engine will shut down.
Engine Control Module (ECM)

Circuit Description

Because engines and aftertreatment components are manufactured in different locations, they are shipped to OEM customers for final vehicle assembly. The process involves both hardware and software elements in detecting the correct match of aftertreatment system to engine model during initial engine to machine integration.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs at key ON in the first 50 hours of engine run time.

Conditions for Setting the Fault Codes

The engine control module detects that the engine has been manufactured with the incorrect SCR

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The purpose of this fault code is to indicate when the wrong aftertreatment system has been mated to the engine during the equipment assembly process. If this fault code is active, the aftertreatment part numbers should be verified.

Refer to Troubleshooting Fault Code 4585.

Last Modified: 25-May-2019


Engine Intake Manifold Pressure System Monitor - Condition Exists

FAULT CODE 4612

Engine Intake Manifold Pressure System Monitor - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4612 PID: SPN: 5321 FMI: 11/31 LAMP: Amber SRT: | The engine is unable to meet the air handling system commands. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports malfunctions back to the primary engine ECM, using the J1939 data link. The ECM then decodes the error message and converts it to a fault code.

The exhaust gas recirculation (EGR) valve is controlled by a brushless motor located on top of the EGR valve. The EGR valve motor uses three different motor legs to move the valve through its range of motion. The ECM uses the EGR motor A, B, and C wires to command the EGR valve to the appropriate position in order to meet EGR flow targets.The EGR valve motor contains three position sensors that detect the location of the EGR valve. These sensors report the position of the valve back to the ECM over the EGR valve position A, B, and C wires.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

The EGR Valve and EGR Differential Pressure Sensor location varies depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR flow, intake manifold pressure, or exhaust pressure was unable to meet the command.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, it may be necessary to operate the vehicle on a chassis dynamometer or to drive the vehicle in order to get the engine load high enough for the diagnostic to run.

Shop Talk

Troubleshoot any fault codes related to the intake manifold pressure/temperature, EGR differential pressure, barometric pressure, exhaust gas pressure, VGT, EGR, or engine intake air throttle prior to troubleshooting 4612.

Refer to Troubleshooting Fault Code 4612.

Last Modified: 25-May-2019


Intake Manifold 1 Pressure - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 4616

Intake Manifold 1 Pressure - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4616 PID: SPN: 102 FMI: 1/17 LAMP: Amber SRT: | Low intake manifold pressure detected. | Possible reduced engine performance.

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the following conditions are met:

The engine is running.

Ambient temperature is greater than -8°C [18°F].

NO Exhaust Gas Recirculation (EGR), Intake Air Throttle (IAT), or Variable Geometry Turbocharger (VGT) related fault codes.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure reading was below the expected level for the engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, it may be necessary to operate the vehicle on a chassis dynamometer or to drive the vehicle in order to get the engine load high enough for the diagnostic to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after one trip where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A damaged turbocharger speed sensor

A malfunctioning barometric air pressure sensor

Leaks in the charge air system plumbing

A malfunctioning variable geometry turbocharger

Refer to Troubleshooting Fault Code 4616 .

Last Modified: 20-Jul-2019


Aftertreatment 1 Diesel Exhaust Fluid Actual Dosing Quantity - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 4658

Aftertreatment 1 Diesel Exhaust Fluid Actual Dosing Quantity - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4658 PID: SPN: 4331 FMI: 1/18 LAMP: Amber SRT: | Low aftertreatment diesel exhaust fluid flow detected. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit precisely measures the amount of aftertreatment diesel exhaust fluid to be injected into the aftertreatment system. The aftertreatment diesel exhaust fluid dosing unit has three primary cycles. A priming cycle makes sure that aftertreatment diesel exhaust fluid is available at the aftertreatment diesel exhaust fluid dosing unit. During the dosing cycle, aftertreatment diesel exhaust fluid is being delivered to the aftertreatment dosing valve. A purge cycle occurs when the engine is turned OFF. The purge cycle makes sure that all the aftertreatment diesel exhaust fluid is removed from the diesel exhaust fluid lines and dosing valve.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

The aftertreatment diesel exhaust fluid dosing valve is installed in the exhaust system. It is mounted directly to the aftertreatment decomposition tube, before the selective catalytic reduction (SCR) catalyst. Installation position will vary, based on the aftertreatment architecture and the original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing valve is being commanded on.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing performance is low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the recommended Cummins electronic service tool or equivalent.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel exhaust fluid dosing unit

A malfunctioning aftertreatment diesel exhaust fluid dosing valve

Refer to Troubleshooting Fault Code 4658.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Abnormal Update Rate

FAULT CODE 4677

Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4677 PID: SPN: 1761 FMI: 9/9 LAMP: Amber SRT: | The ECM lost communication with the aftertreatment diesel exhaust fluid tank level sensor. | At least one multiplexed device will not operate properly.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins ECM and used for controlling the engine. The Cummins ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

The Engine Control Module (ECM) detected an open or short circuit condition in the J1939 data link harness.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices can possibly not function as desired.

This fault can occur for the following reasons:

When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the CumminsÂ ECM, or the OEM VECU is not set up to transmit the multiplexed component message.

This fault can also be caused by a bad J1939 data link connection between the OEM VECU and Cummins ECM, a bad connection between the component and the OEM VECU, bad OEM VECU or bad Cummins ECM. It may be necessary to contact the OEM for proper multiplexing configuration. It is possible to use the recommended Cummins electronic service tool or equivalent to monitor multiplexed components.

It is possible to use the recommended Cummins electronic service tool or equivalent to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 4677.

Last Modified: 25-May-2019


Engine Injector Metering Rail 1 Cranking Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 4691

Engine Injector Metering Rail 1 Cranking Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4691 PID: SPN: 5585 FMI: 1/18 LAMP: Amber SRT: | The fuel rail pressure during cranking is too low for the engine to start. | Engine may not start or may be difficult to start.
Engine Fuel Rail Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the fuel rail pressure sensor using a dedicated sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel rail pressure sensor provides a primary fuel pressure signal to the ECM on the fuel rail pressure sensor signal 1 circuit. The sensor also provides a secondary fuel pressure sensor signal on the fuel rail pressure signal 2 circuit. This sensor signal voltage changes based on the pressure in the fuel rail. The ECM will detect a high signal voltage at high rail pressure conditions. The ECM will detect a low signal voltage during low rail pressure conditions.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is being started.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel rail pressure during cranking was too low for the engine to start.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The engine may not start.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning fuel lift pump

Low fuel gear pump output pressure

Malfunctioning high-pressure fuel pump

Leaking fuel rail pressure relief valve

Leaking fuel injectors and or fuel injector connectors

Refer to Troubleshooting Fault Code 4691.

Last Modified: 25-May-2019


Engine Fuel Leakage - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 4726

Engine Fuel Leakage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4726 PID: SPN: 1239 FMI: 0/16 LAMP: Amber SRT: | Fuel rail pressure decay has been detected. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the fuel rail pressure sensor using a dedicated sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel rail pressure sensor provides a primary fuel pressure signal to the ECM on the fuel rail pressure sensor signal 1 circuit. The sensor also provides a secondary fuel pressure sensor signal on the fuel rail pressure signal 2 circuit. This sensor signal voltage changes based on the pressure in the fuel rail. The ECM will detect a high signal voltage at high rail pressure conditions. The ECM will detect a low signal voltage during low rail pressure conditions.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs periodically during engine operation.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine fuel rail pressure decayed more than expected during a motoring (non-fueling) condition.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • It is necessary to use the "Reset All Faults" command in the recommended Cummins electronic service tool or equivalent to clear this fault and extinguish the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL).

Shop Talk

Possible causes of this fault code include:

Leaking fuel injectors and or fuel injector connectors

Leaking fuel rail pressure relief valve

Refer to Troubleshooting Fault Code 4726.

Last Modified: 25-May-2019


Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 4727

Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4727 PID: SPN: 157 FMI: 0/15 LAMP: Amber SRT: | A self pumping condition has been detected in the fuel system. | Possible reduced engine performance.
Engine Fuel Rail Pressure Sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the fuel rail pressure sensor using a dedicated sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel rail pressure sensor provides a primary fuel pressure signal to the ECM on the fuel rail pressure sensor signal 1 circuit. The sensor also provides a secondary fuel pressure sensor signal on the fuel rail pressure signal 2 circuit. This sensor signal voltage changes based on the pressure in the fuel rail. The ECM will detect a high signal voltage at high rail pressure conditions. The ECM will detect a low signal voltage during low rail pressure conditions.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs periodically during engine operation.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel rail pressure was increasing during motoring (non-fueling) conditions where the pressure should have been stable.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • It is necessary to use the "Reset All Faults" command in the recommended Cummins® electronic service tool or equivalent to clear this fault and extinguish the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL).

Shop Talk

Possible causes of this fault code include:

High fuel drain line restriction

Refer to Troubleshooting Fault Code 4727 .

Last Modified: 02-Nov-2019


Exhaust Gas Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 4728

Exhaust Gas Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4728 PID: SPN: 1209 FMI: 1/18 LAMP: Amber SRT: | The commanded VGT position and exhaust pressure were not met. | None on performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

The exhaust gas pressure sensor is used to measure exhaust gas pressure in the exhaust manifold. This information is used by the engine control module (ECM) to control emissions and exhaust gas recirculation (EGR) valve operation. The ECM provides a 5 volt supply to the exhaust gas pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The exhaust gas pressure sensor provides a signal to the ECM on the exhaust gas pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the exhaust manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

The exhaust gas pressure sensor is located above the front section of the exhaust manifold and is plumbed into the exhaust manifold.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating in SCR warm-up mode.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected both the VGT position and the difference of the exhaust pressure and intake manifold pressure are lower than commanded.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning intake manifold pressure sensor

A malfunctioning exhaust gas pressure sensor

A malfunctioning turbocharger

Refer to Troubleshooting Fault Code 4728.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Out of Calibration

FAULT CODE 4731

Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4731 PID: SPN: 3031 FMI: 13/13 LAMP: Amber SRT: | The received datalink message was not valid. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor

Circuit Description

The aftertreatment diesel exhaust fluid tank temperature sensor is used to monitor the temperature of the aftertreatment diesel exhaust fluid inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the SAE J1939 datalink message received from the aftertreatment diesel exhaust fluid tank temperature sensor was NOT valid.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor

Refer to Troubleshooting Fault Code 4731.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Out of Calibration

FAULT CODE 4732

Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4732 PID: SPN: 1761 FMI: 13/13 LAMP: Amber SRT: | The received datalink message was not valid. | None on performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor

Circuit Description

The aftertreatment diesel exhaust fluid tank level sensor is used to monitor the aftertreatment diesel exhaust fluid level inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the SAE J1939 datalink message received from the aftertreatment diesel exhaust fluid tank level sensor was NOT valid.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel exhaust fluid tank level sensor

Refer to Troubleshooting Fault Code 4732.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Root Cause Not Known

FAULT CODE 4739

Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4739 PID: SPN: 1761 FMI: 11/11 LAMP: Amber SRT: | An unknown error has been detected with the aftertreatment diesel exhaust fluid tank level sensor. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank level sensor is used to monitor the aftertreatment diesel exhaust fluid level inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid tank level sensor reported an unknown error.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel exhaust fluid tank level sensor

Refer to Troubleshooting Fault Code 4739.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 - Root Cause Not Known

FAULT CODE 4745

Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4745 PID: SPN: 3515 FMI: 11/11 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 - Root Cause Not Known | Possible reduced engine performance.
SAE J1939 Datalink

Circuit Description

The DEF quality sensor is a smart device and communicates with the engine electronic control module (ECM) via the J1939 data link. The DEF quality sensor receives power and ground directly from the battery. The sensor performs its own internal diagnostics and reports malfunctions back to the primary engine ECM via the J1939 data link. The DEF quality sensor is used to measure the concentration of the DEF in the tank.

Component Location

The aftertreatment diesel exhaust fluid quality sensor is located in the aftertreatment diesel exhaust fluid tank. It may be a combination sensor with the aftertreatement diesel exhaust fluid tank level and tank temperature sensors. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

This fault code is triggered when the DEF quality sensor detects that the internal temperature has exceeded 125Â°C.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • This fault code can not be cleared with the recommended Cummins electronic service tool or equivalent.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor

Refer to Troubleshooting Fault Code 4745.

Last Modified: 25-May-2019


Aftertreatment 1 Intake Oxygen Sensor - Data Not Rational - Drifted High

FAULT CODE 4747

Aftertreatment 1 Intake Oxygen Sensor - Data Not Rational - Drifted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4747 PID: SPN: 3217 FMI: 2/20 LAMP: Amber SRT: | An in-range high failure has been detected. | None on performance.
Aftertreatment Intake NOx Sensor Circuit

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the NOx emissions at the intake of the aftertreatment system.

Component Location

The aftertreatment intake NOx sensor is mounted on the engine near the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR outlet temperature has been above 200°C [392° F] for a calibratible period of time while the engine is running.

Conditions for Setting the Fault Codes

The ECM detected that the absolute difference between the inlet and outlet NOx sensors was greater than a calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using the recommended Cummins® electronic service tool or equivalent.
  • The aftertreatment SCR outlet temperature must be above 200Â° C [392Â° F] for 60 seconds before the aftertreatment outlet NOx sensor can run its internal diagnostics.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning aftertreatment Intake NOx sensor
  • Diesel exhaust fluid crystallization or deposits
  • Improperly installed aftertreatment intake NOx sensor.
  • Exhaust system leaks.

Exhaust gas recirculation (EGR) system leaks can also cause this fault code. Inspect the EGR bellows and EGR connections for signs of leaks.

  • Leaks in the air intake system between the turbocharger and intake manifold
  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 4747 .

Last Modified: 13-Oct-2021


Aftertreatment 1 Intake Oxygen Sensor - Data Not Rational - Drifted Low

FAULT CODE 4748

Aftertreatment 1 Intake Oxygen Sensor - Data Not Rational - Drifted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4748 PID: SPN: 3217 FMI: 2/21 LAMP: Amber SRT: | An in-range low failure has been detected. | None on performance.
Aftertreatment Intake NOx Sensor Circuit

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the NOx emissions at the intake of the aftertreatment system.

Component Location

The aftertreatment intake NOx sensor is mounted on the engine near the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR outlet temperature has been above 200°C [392° F] for a calibratible period of time while the engine is running.

Conditions for Setting the Fault Codes

The ECM detected that the absolute difference between the inlet and outlet NOx sensors was greater than a calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using the recommended Cummins® electronic service tool or equivalent.
  • The aftertreatment SCR outlet temperature must be above 200Â° C [392Â° F] for 60 seconds before the aftertreatment outlet NOx sensor can run its internal diagnostics.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning aftertreatment Intake NOx sensor
  • Diesel exhaust fluid crystallization or deposits
  • Improperly installed aftertreatment intake NOx sensor.
  • Exhaust system leaks.

Exhaust gas recirculation (EGR) system leaks can also cause this fault code. Inspect the EGR bellows and EGR connections for signs of leaks.

  • Leaks in the air intake system between the turbocharger and intake manifold
  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 4748 .

Last Modified: 13-Oct-2021


Aftertreatment 1 Outlet Oxygen - Data Not Rational - Drifted High

FAULT CODE 4749

Aftertreatment 1 Outlet Oxygen - Data Not Rational - Drifted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4749 PID: SPN: 3227 FMI: 2/20 LAMP: Amber SRT: | An in-range high failure has been detected. | None on performance.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR outlet temperature is above 200°C [392°F], and the engine is in a motoring condition.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment outlet NOx sensor was not reading zero while in a motoring (non-fueling) condition.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using the recommended Cummins® electronic service tool or equivalent.
  • The aftertreatment SCR outlet temperature must be above 200Â° C [392Â° F] for 60 seconds before the aftertreatment outlet NOx sensor can run its internal diagnostics.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning aftertreatment outlet NOx sensor
  • Diesel exhaust fluid crystallization or deposits
  • Improperly installed aftertreatment outlet NOx sensor.
  • Exhaust system leaks.

Exhaust gas recirculation (EGR) system leaks can also cause this fault code. Inspect the EGR bellows and EGR connections for signs of leaks.

  • Leaks in the air intake system between the turbocharger and intake manifold
  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 4749 .

Last Modified: 13-Oct-2021


Aftertreatment 1 Outlet Oxygen - Data Not Rational - Drifted Low

FAULT CODE 4751

Aftertreatment 1 Outlet Oxygen - Data Not Rational - Drifted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4751 PID: SPN: 3227 FMI: 2/21 LAMP: Amber SRT: | An in-range low failure has been detected. | None on performance.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR outlet temperature is above 200°C [392°F], and the engine is in a motoring condition.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment outlet NOx sensor was not reading zero while in a motoring (non-fueling) condition.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using the recommended Cummins® electronic service tool or equivalent.
  • The aftertreatment SCR outlet temperature must be above 200Â° C [392Â° F] for 60 seconds before the aftertreatment outlet NOx sensor can run its internal diagnostics.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning aftertreatment outlet NOx sensor
  • Diesel exhaust fluid crystallization or deposits
  • Improperly installed aftertreatment outlet NOx sensor.
  • Exhaust system leaks.

Exhaust gas recirculation (EGR) system leaks can also cause this fault code. Inspect the EGR bellows and EGR connections for signs of leaks.

  • Leaks in the air intake system between the turbocharger and intake manifold
  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 4751 .

Last Modified: 13-Oct-2021


Aftertreatment 1 Diesel Exhaust Fluid Property - Root Cause Not Known

FAULT CODE 4768

Aftertreatment 1 Diesel Exhaust Fluid Property - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4768 PID: SPN: 3521 FMI: 11/11 LAMP: Amber SRT: | Unknown fluid inside DEF tank. | Engine power derate.
SAE J1939 Datalink

Circuit Description

The DEF quality sensor is a smart device and communicates with the engine electronic control module (ECM) via the J1939 data link. The DEF quality sensor receives power and ground directly from the battery. The sensor performs its own internal diagnostics and reports malfunctions back to the primary engine ECM via the J1939 data link. The DEF quality sensor is used to measure the concentration of the DEF in the tank.

Component Location

The aftertreatment diesel exhaust fluid quality sensor is located in the aftertreatment diesel exhaust fluid tank. It may be a combination sensor with the aftertreatement diesel exhaust fluid tank level and tank temperature sensors. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the following conditions are met:

Keyswitch is in the ON position or when the engine is running.

Ambient temperature is above -20Â°C [-4Â°F].

Vehicle altitude change is less than 305 m [1000 ft] in 1 hour.

Conditions for Setting the Fault Codes

The DEF quality sensor has detected that the DEF concentration has fallen below a critical threshold.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • Start and idle the engine for 15 minutes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Degraded, diluted, or incorrect diesel exhaust fluid

Malfunctioning Aftertreatment DEF Quality Sensor.

Refer to Troubleshooting Fault Code 4768.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Abnormal Rate of Change

FAULT CODE 4769

Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4769 PID: SPN: 1761 FMI: 10/10 LAMP: Amber SRT: | A valid diesel exhaust fluid tank level reading has NOT been received. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank level sensor is used to monitor the aftertreatment diesel exhaust fluid level inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the following conditions are met:

Keyswitch is in the ON position or when the engine is running.

Ambient temperature is above -20Â°C [-4Â°F].

Vehicle altitude change is less than 305 m [1000 ft] in 1 hour.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank level sensor reading was invalid for an extended period of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

To validate the repair, perform a key cycle, and leave the key in the ON position for 2 hours.

  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment diesel exhaust fluid tank level sensor

Tampering of the aftertreatment diesel exhaust fluid tank level sensor

Refer to Troubleshooting Fault Code 4769.

Last Modified: 25-May-2019


Injector Metering Rail 2 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 483

Injector Metering Rail 2 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 483 PID: P129 SPN: 1349 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the fuel rail pressure sensor circuit. | Possible reduced engine performance.
Injector Metering Rail 2 Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the fuel rail pressure sensor using a dedicated sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel rail pressure sensor provides a primary fuel pressure signal to the ECM on the fuel rail pressure sensor signal 1 circuit. The sensor also provides a secondary fuel pressure sensor signal on the fuel rail pressure signal 2 circuit. This sensor signal voltage changes based on the pressure in the fuel rail. The ECM will detect a high signal voltage at high rail pressure conditions. The ECM will detect a low signal voltage during low rail pressure conditions.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel rail pressure 2 signal voltage was greater than 4.75-VDC for more than 3 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning fuel rail pressure sensor

A short circuit to battery in the engine harness.

An open return circuit in the engine harness

An open circuit in the engine harness

Refer to Troubleshooting Fault Code 483.

Last Modified: 25-May-2019


Engine Air Shutoff - Condition Exists

FAULT CODE 4839

Engine Air Shutoff - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4839 PID: SPN: 3667 FMI: 11/31 LAMP: Amber SRT: | One or more electronic throttle valve fault codes active when configured as an air shut off valve. | Possible reduced engine performance.
Electronic Throttle Control Circuit

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected active Engine Intake Air Throttle faults.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This is an information only fault that sets when there are one or more active Engine Intake Air Throttle faults when the Engine Intake Air Throttle has been configured as an Air Shutoff.

Refer to Troubleshooting Fault Code 4839.

Last Modified: 25-May-2019


Injector Metering Rail 2 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 484

Injector Metering Rail 2 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 484 PID: P129 SPN: 1349 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the fuel rail pressure sensor circuit. | Possible reduced engine performance.
Injector Metering Rail 2 Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the fuel rail pressure sensor using a dedicated sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel rail pressure sensor provides a primary fuel pressure signal to the ECM on the fuel rail pressure sensor signal 1 circuit. The sensor also provides a secondary fuel pressure sensor signal on the fuel rail pressure signal 2 circuit. This sensor signal voltage changes based on the pressure in the fuel rail. The ECM will detect a high signal voltage at high rail pressure conditions. The ECM will detect a low signal voltage during low rail pressure conditions.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel rail pressure 2 signal voltage was less than 0.25-VDC for more than 3 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning fuel rail pressure sensor

A short circuit to ground in the engine harness

Refer to Troubleshooting Fault Code 484.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Quality - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 4842

Aftertreatment 1 Diesel Exhaust Fluid Quality - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4842 PID: SPN: 3364 FMI: 0/15 LAMP: None SRT: | The aftertreatment diesel exhaust fluid quality sensor has detected an in-range high condition. | Possible reduced engine performance.
SAE J1939 Datalink

Circuit Description

The aftertreatment diesel exhaust fluid quality sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor is used to measure the concentration of the aftertreatment diesel exhaust fluid in the tank.

Component Location

The aftertreatment diesel exhaust fluid quality sensor is located in the aftertreatment diesel exhaust fluid tank. It may be a combination sensor with the aftertreatement diesel exhaust fluid tank level and tank temperature sensors. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the following conditions are met:

Keyswitch is in the ON position or when the engine is running.

Ambient temperature is above -20Â°C [-4Â°F].

Vehicle altitude change is less than 305 m [1000 ft] in 1 hour.

Conditions for Setting the Fault Codes

The DEF quality sensor has detected that the DEF concentration has risen above a critical threshold.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • Start and idle the engine for 15 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Degraded, diluted, or incorrect diesel exhaust fluid
  • Malfunctioning Aftertreatment DEF Quality Sensor.
Refer to Troubleshooting Fault Code 4842 .

Last Modified: 13-Oct-2021


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 488

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 488 PID: P105 SPN: 105 FMI: 0/16 LAMP: Amber SRT: | Intake manifold air temperature signal indicates intake manifold air temperature is above engine protection warning limit. | Progressive power derate increasing in severity from time of alert.
Intake Manifold Pressure/Temperature Sensor

Circuit Description

The intake manifold air temperature sensor monitors intake manifold air temperature and passes information to the electronic control. The intake manifold 1 temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the intake manifold of the engine. The electronic control module (ECM) supplies 5 volts to the intake manifold temperature SIGNAL circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature.

When the intake air is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature. This fault code indicates that the intake manifold temperature has exceeded the maximum engine protection limit.

Component Location

The intake manifold temperature sensor 1 is located in intake manifold 1.

Conditions for Running the Diagnostics

  • The first part of the diagnostic runs continuously while the keyswitch is in the ON position or the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature was greater than a calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to inactive and the torque derate will be removed immediately after the intake manifold temperature falls below a calibratible limit set in the ECM and the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The intake manifold 1 temperature sensor measures the temperature of the charge-air as it passes through the intake manifold. Possible causes of this fault code include.

Plugged charge-air cooler fins

Restricted airflow through the charge-air cooler

Undersized charge-air cooler

High turbocharger compressor outlet temperature.

Refer to Troubleshooting Fault Code 488.

Last Modified: 25-May-2019


Maintain ECU Power Lamp Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 4951

Maintain ECU Power Lamp Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4951 PID: SPN: 6655 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the battery power required lamp circuit. | None on performance.
Engine Control Module

Circuit Description

The Engine Control Module (ECM) requires battery power when the keyswitch is ON and for a period of time after the keyswitch is turned OFF. The battery power required lamp is an optional lamp that can be installed to indicate when it is acceptable to remove battery power from the ECM. The lamp will be illuminated when the ECM requires battery power and will extinguish once it is acceptable to remove battery power.

Component Location

The battery power required lamp is an OEM installed component. Refer to the OEM for component location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the battery power required lamp signal circuit was out of range high.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A pin-to-pin short circuit

An open circuit in the OEM harness

A malfunctioning battery power required lamp

Refer to Troubleshooting Fault Code 4951.

Last Modified: 25-May-2019


Maintain ECU Power Lamp Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4952

Maintain ECU Power Lamp Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4952 PID: SPN: 6655 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the battery power required lamp circuit. | None on performance.
Engine Control Module

Circuit Description

The Engine Control Module (ECM) requires battery power when the keyswitch is ON and for a period of time after the keyswitch is turned OFF. The battery power required lamp is an optional lamp that can be installed to indicate when it is acceptable to remove battery power from the ECM. The lamp will be illuminated when the ECM requires battery power and will extinguish once it is acceptable to remove battery power.

Component Location

The battery power required lamp is an OEM installed component. Refer to the OEM for component location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the battery power required lamp signal circuit was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A short circuit to ground in the OEM harness

A pin-to-pin short circuit

A malfunctioning battery power required lamp

Refer to Troubleshooting Fault Code 4952.

Last Modified: 25-May-2019


Sensor Supply 6 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 515

Sensor Supply 6 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 515 PID: S232 SPN: 3514 FMI: 3/3 LAMP: Amber SRT: | High voltage detected on the +5 volt sensor supply circuit to the fuel rail pressure sensor. | Possible reduced engine performance.
Sensor Supply 6 Circuit

Circuit Description

The sensor supply 6 circuit of the engine control module (ECM) is a dedicated (+) 5-VDC supply for the fuel rail pressure sensor.

Component Location

Sensor Supply 6 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 6 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

High voltage on the (+) 5 volt supply line can be caused by a short to battery voltage in the engine harness or connectors, or a malfunctioning ECM.

Refer to Troubleshooting Fault Code 515.

Last Modified: 25-May-2019


Sensor Supply 6 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 516

Sensor Supply 6 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 516 PID: S232 SPN: 3514 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected on the +5 volt sensor supply circuit to the fuel rail pressure sensor. | Possible reduced engine performance.
Sensor Supply 6 Circuit

Circuit Description

The sensor supply 6 circuit of the engine control module (ECM) is a dedicated (+) 5-VDC supply for the fuel rail pressure sensor.

Component Location

Sensor Supply 6 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 6 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Low voltage on the 5 volt supply line can be caused by a short circuit to ground in the supply line, a short circuit between the supply line and a return line, a failed sensor, or a damaged ECM power supply.

Refer to Troubleshooting Fault Code 516.

Last Modified: 25-May-2019


Engine Air Shutoff Status - Special Instructions

FAULT CODE 5259

Engine Air Shutoff Status - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5259 PID: SPN: 3667 FMI: 14/14 LAMP: Red SRT: | Active Engine Air Shutoff fault initiated an engine derate. | Engine power derate.
Electronic Throttle Control Circuit

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected active Engine Intake Air Throttle faults.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This is an information only fault that sets when there are one or more active Engine Intake Air Throttle faults when the Engine Intake Air Throttle has been configured as an Air Shutoff.

Refer to Troubleshooting Fault Code 5259.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Exhaust Fluid Dosing System Frozen - Condition Exists

FAULT CODE 5278

Aftertreatment 1 Diesel Exhaust Fluid Dosing System Frozen - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5278 PID: SPN: 6802 FMI: 11/31 LAMP: Amber SRT: | The ECM has detected conditions which indicate the Diesel Exhaust Fluid Dosing System is frozen. | Engine power derate.
Aftertreatment DEF Tank Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank heater keeps the diesel exhaust fluid from freezing in the diesel exhaust fluid tank. The tank heater consists of an electrically powered tank heater control valve which controls the flow of engine coolant to a heating coil inside the diesel exhaust fluid tank. The tank heater control valve opens to allow coolant to flow to the heating coil when heating is commanded, and closes when heating is no longer required.

Component Location

The diesel exhaust fluid tank heater control valve is located near the diesel exhaust fluid tank. Specific location will vary depending on the OEM. The tank heating coil is internal to the diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the diesel exhaust fluid dosing system was unable to prime when the ambient air temperature was low (non-heated diesel exhaust fluid dosing systems).

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use the recommended Cummins electronic service tool or equivalent to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the recommended Cummins electronic service tool or equivalent.
  • This fault code can not be cleared with the recommended Cummins electronic service tool or equivalent.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only, and indicates that an engine power derate has been implemented in order to make sure that the critical fault codes that are presently active in the ECM are addressed as quickly as possible.

Refer to Troubleshooting Fault Code 5278.

Last Modified: 25-May-2019


Engine/Transmission Match - Out of Calibration

FAULT CODE 5297

Engine/Transmission Match - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5297 PID: SPN: 747 FMI: 13/13 LAMP: None SRT: | The ECM Calibration is not correct for the transmission. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins ECM and used for controlling the engine. The Cummins ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The Engine Control Module (ECM) is mounted on the intake manifold side of the engine.

The Transmission ECU location varies by application, Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM Calibration and the Transmission ECU software are mismatched. The ECM calibration has SmartAdvantage or Advanced Dynamic Efficient Powertrain (ADEPT) features enabled, but the transmission ECU software is not compatible.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Incorrect or incomplete transmission up fit installation.

Missed or timed out J1939 messages.

ECM Calibration is not compatible for the transmission ECU software.

ECM updated include SmartAdvantage or Advanced Dynamic Efficient Powertrain (ADEPT) feature and the transmission ECU has an older version of software.

Refer to Troubleshooting Fault Code 5297.

Last Modified: 25-May-2019


Engine/Transmission Match - Received Network Data in Error

FAULT CODE 5298

Engine/Transmission Match - Received Network Data in Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5298 PID: SPN: 747 FMI: 2/19 LAMP: None SRT: | The ECM Calibration is not correct for the transmission. | None on performance.
Engine Control Module (ECM)

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins ECM and used for controlling the engine. The Cummins ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The Engine Control Module (ECM) is mounted on the intake manifold side of the engine.

The Transmission Control Module (TCM) location varies by application, Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM Calibration and the Transmission are mismatched. A SmartAdvantage transmission is installed but the ECM calibration does not support that transmission.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

ECM Calibration is not compatible for the transmission ECU software.

Refer to Troubleshooting Fault Code 5298.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Particulate Filter Ash Load Percent - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 5383

Aftertreatment 1 Diesel Particulate Filter Ash Load Percent - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5383 PID: SPN: 3720 FMI: 0/15 LAMP: Maintenance SRT: | The ash load of the aftertreatment diesel particulate filter has exceeded the recommended limits. | None on performance.
Engine Control Module (ECM)

Circuit Description

The engine aftertreatment system monitors the aftertreatment DPF restriction. The diagnostic alerts the operator of the excessive ash in the aftertreatment DPF.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating and exhaust flow is above a minimum level.

Conditions for Setting the Fault Codes

This diagnostic monitors the aftertreatment DPF differential pressure sensor. When the aftertreatment DPF differential pressure is above a maximum value at the end of an aftertreatment regeneration the fault code is set.

Action Taken When the Fault Code is Active

The ECM will illuminate the MAINTENANCE lamp during the key cycle after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • In order to clear the fault code, the aftertreatment DPF must be exchanged or properly cleaned and the recommended Cummins® electronic service tool or equivalent must be used to perform an Aftertreatment Diesel Particulate Filter Installation.

Shop Talk

Possible causes of this fault code include:

The aftertreatment diesel particulate filter differential tubes are installed incorrectly, broken, loose, or have been tampered with

The aftertreatment diesel particulate filter intake temperature sensor malfunctioned in-range

Build up or plugging on the inlet face of the Diesel Particulate Filter.

  • Excessive ash in the DPF
Refer to Troubleshooting Fault Code 5383 .

Last Modified: 27-Mar-2022


Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 553

Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 553 PID: P157 SPN: 157 FMI: 0/16 LAMP: Amber SRT: | The engine control module (ECM) has detected that fuel pressure is higher than the commanded pressure. | Possible reduced engine performance.
Injector Metering Rail 1 Pressure Circuit

Circuit Description

The engine control module (ECM) monitors engine operating conditions, including the reading of fuel rail pressure, and changes the flow command to either increase (OPEN the fuel pump actuator) or decrease (CLOSE the fuel pump actuator) the fuel supply to the high-pressure pump.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel rail pressure reading was greater than the commanded fuel rail pressure.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

A fuel pump actuator with excessive leakage or a damaged inboard o-ring will result in high fuel rail pressures at idle or light load.

Refer to Troubleshooting Fault Code 553.

Last Modified: 25-May-2019


Crankcase Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 555

Crankcase Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 555 PID: P101 SPN: 101 FMI: 0/16 LAMP: Amber SRT: | The crankcase breather filter requires maintenance. | None on performance.
Crankcase Pressure Sensor Circuit

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located near the crankcase ventilation element.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankcase pressure was greater than a calibrated value.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Crankcase breather element may be plugged

Malfunctioning crankcase pressure sensor.

Plugged or restricted crankcase breather oil separator

Plugged or restricted crankcase breather oil drain tube or check valve

Plugged or restricted crankcase breather draft tube

Frozen, plugged, or restricted crankcase breather tube.

It is important to check for plugged or restricted hoses, tubes, check valves, oil separator, and breather elements in extreme cold ambient temperatures. If Fault Code 555 becomes active due to a plugged filter before the maintenance interval is reached or the filter plugs frequently, see the Crankcase Gases (Blowby) Excessive troubleshooting symptom tree.

Refer to Troubleshooting Fault Code 555.

Last Modified: 25-May-2019


Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 556

Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 556 PID: P101 SPN: 101 FMI: 0/0 LAMP: Red SRT: | High crankcase pressure detected. | Possible reduced engine performance.
Crankcase Pressure Sensor Circuit

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located near the crankcase ventilation element.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankcase pressure was greater than a calibrated value.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The engine torque output will be reduced to protect the engine from excessive crankcase pressure.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Crankcase breather element may be plugged

Malfunctioning crankcase pressure sensor.

Plugged or restricted crankcase breather oil separator

Plugged or restricted crankcase breather oil drain tube or check valve

Plugged or restricted crankcase breather draft tube

Frozen, plugged, or restricted crankcase breather tube.

It is important to check for plugged or restricted hoses, tubes, check valves, oil separator, and breather elements in extreme cold ambient temperatures. If Fault Code 555 becomes active due to a plugged filter before the maintenance interval is reached or the filter plugs frequently, see the Crankcase Gases (Blowby) Excessive troubleshooting symptom tree.

Refer to Troubleshooting Fault Code 556.

Last Modified: 25-May-2019


Aftertreatment 1 Particulate Sensor Power Supply - Voltage Above Normal or Shorted to High Source

FAULT CODE 5577

Aftertreatment 1 Particulate Sensor Power Supply - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5577 PID: SPN: 6778 FMI: 3/3 LAMP: Amber SRT: | An internal circuit error has been detected by the aftertreatment particulate matter sensor. | Possible reduced engine performance.
Aftertreatment Particulate Sensor Circuit

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment particulate sensor assembly

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning aftertreatment particulate matter sensor

Refer to Troubleshooting Fault Code 5577 .

Last Modified: 05-Dec-2021


Aftertreatment 1 Particulate Sensor Power Supply - Voltage Below Normal or Shorted to Low Source

FAULT CODE 5578

Aftertreatment 1 Particulate Sensor Power Supply - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5578 PID: SPN: 6778 FMI: 4/4 LAMP: Amber SRT: | An internal circuit error has been detected by the aftertreatment particulate matter sensor. | Possible reduced engine performance.
Aftertreatment Particulate Sensor Circuit

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment particulate sensor assembly

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning aftertreatment particulate matter sensor

Refer to Troubleshooting Fault Code 5578 .

Last Modified: 05-Dec-2021


Aftertreatment 1 Particulate Sensor Power Supply - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 5579

Aftertreatment 1 Particulate Sensor Power Supply - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5579 PID: SPN: 6778 FMI: 0/16 LAMP: Amber SRT: | An internal circuit error has been detected by the aftertreatment particulate matter sensor. | Possible reduced engine performance.
Aftertreatment Particulate Sensor Circuit

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment particulate sensor assembly

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning aftertreatment particulate matter sensor

Refer to Troubleshooting Fault Code 5579 .

Last Modified: 05-Dec-2021


Aftertreatment 1 Particulate Sensor Heater Power Supply - Data Erratic, Intermittent, or Incorrect

FAULT CODE 5581

Aftertreatment 1 Particulate Sensor Heater Power Supply - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5581 PID: SPN: 7329 FMI: 2/2 LAMP: Amber SRT: | An internal circuit error has been detected by the aftertreatment particulate matter sensor. | Possible reduced engine performance.
Aftertreatment Particulate Sensor Circuit

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment particulate sensor assembly

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning aftertreatment particulate matter sensor

Refer to Troubleshooting Fault Code 5581 .

Last Modified: 05-Dec-2021


Aftertreatment 1 Particulate Sensor Module Battery Voltage Supply - Data Erratic, Intermittent, or Incorrect

FAULT CODE 5582

Aftertreatment 1 Particulate Sensor Module Battery Voltage Supply - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5582 PID: SPN: 7854 FMI: 2/2 LAMP: Amber SRT: | The aftertreatment particulate sensor detected intermittent supply voltage to the control module. | Possible reduced engine performance.
Aftertreatment Particulate Sensor Circuit

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The power supply to the aftertreatment particulate sensor has been intermittently interrupted.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning aftertreatment particulate matter sensor

Refer to Troubleshooting Fault Code 5582 .

Last Modified: 05-Dec-2021


Aftertreatment 1 Particulate Sensor Detection Status - Abnormal Rate of Change

FAULT CODE 5583

Aftertreatment 1 Particulate Sensor Detection Status - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5583 PID: SPN: 6777 FMI: 10/10 LAMP: Amber SRT: | The aftertreatment particulate sensor reading is not valid. | Possible reduced engine performance.
Aftertreatment Particulate Sensor Circuit

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment particulate matter sensor reading was not valid.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning aftertreatment particulate matter sensor

For intermittent power supply and data link communication issues with aftertreatment components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing, or intermittent connections.

Refer to Troubleshooting Fault Code 5583 .

Last Modified: 05-Dec-2021


Aftertreatment 1 Particulate Sensor Regeneration Status - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 5584

Aftertreatment 1 Particulate Sensor Regeneration Status - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5584 PID: SPN: 6773 FMI: 7/7 LAMP: Amber SRT: | The aftertreatment particulate sensor was unable to enter measurement mode. | Possible reduced engine performance.
Aftertreatment Particulate Sensor Circuit

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment particulate matter sensor heater was unable to maintain sensor regeneration temperature for a calibrated period of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning aftertreatment particulate matter sensor

Refer to Troubleshooting Fault Code 5584 .

Last Modified: 05-Dec-2021


Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 559

Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 559 PID: P157 SPN: 157 FMI: 1/18 LAMP: Amber SRT: | The ECM has detected that fuel pressure is lower than commanded pressure. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Injector Metering Rail Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the fuel rail pressure sensor using a dedicated sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel rail pressure sensor provides a primary fuel pressure signal to the ECM on the fuel rail pressure sensor signal 1 circuit. The sensor also provides a secondary fuel pressure sensor signal on the fuel rail pressure signal 2 circuit. This sensor signal voltage changes based on the pressure in the fuel rail. The ECM will detect a high signal voltage at high rail pressure conditions. The ECM will detect a low signal voltage during low rail pressure conditions.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

The second part runs continuously while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the measured fuel rail pressure was less than the commanded fuel rail pressure by at least 250 bar [3625 psi] for 7 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

High fuel inlet restriction

Low fuel gear pump output pressure

Air in the fuel

Leaking fuel rail pressure relief valve

Malfunctioning high-pressure fuel pump

Leaking fuel injectors and or fuel injector connectors

Refer to Troubleshooting Fault Code 559.

Last Modified: 25-May-2019


Aftertreatment 1 SCR Conversion Efficiency - Condition Exists

FAULT CODE 5655

Aftertreatment 1 SCR Conversion Efficiency - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5655 PID: SPN: 4364 FMI: 11/31 LAMP: Amber SRT: | NOx conversion across the SCR catalyst is too low. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) monitors the NOx concentration in the engine's exhaust gases using an aftertreatment intake NOx sensor and an aftertreatment outlet NOx sensor. By comparing these two values, the ECM is able to determine the conversion efficiency of the SCR catalyst and dosing system.

Component Location

The SCR catalyst is located in the vehicle's exhaust system, after the diesel particulate filter and decomposition tube.

Conditions for Running the Diagnostics

This diagnostic has to meet specific engine and aftertreatment conditions to run and complete.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the NOx conversion across the SCR catalyst was less than expected.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • It is necessary to use the "Reset All Faults" command in the recommended Cummins electronic service tool or equivalent to clear this fault and extinguish the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL).

Shop Talk

Troubleshoot all other active NOx sensor and SCR dosing system related fault codes before this fault.

Possible causes of this fault code include:

Malfunctioning aftertreatment diesel exhaust fluid dosing system.

Exhaust system leaks

Malfunctioning SCR catalyst

Degraded, diluted, or incorrect diesel exhaust fluid

Diesel exhaust fluid deposits in the decomposition tube.

For unit that has come back into with repeat failures consider the possibility that customer is not using Ultra-low sulfur Diesel fuel

Refer to Troubleshooting Fault Code 5655.

Last Modified: 25-May-2019


Aftertreatment 1 Outlet NOx Sensor - Root Cause Not Known

FAULT CODE 5689

Aftertreatment 1 Outlet NOx Sensor - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5689 PID: SPN: 3226 FMI: 11/11 LAMP: Amber SRT: | Signal indicates wrong reading or sensor tampering. | None on performance.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR outlet temperature has been above 200°C [392° F] for a calibratible period of time while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the power supply to the outlet NOx sensor was above or below a calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using the recommended Cummins electronic service tool or equivalent.
  • The aftertreatment SCR outlet temperature must be above 200Â° C [392Â° F] for 60 seconds before the aftertreatment outlet NOx sensor can run its internal diagnostics.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Short to battery or ground in the OEM harness

Open NOx sensor power supply circuit in the OEM harness

  • Incorrect system voltage set-up in the recommended Cummins electronic service tool or equivalent.

Internal malfunction of the outlet NOx sensor

The NOx sensor part number is incorrect.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 5689.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Particulate Filter Differential Pressure - Abnormal Rate of Change

FAULT CODE 5715

Aftertreatment 1 Diesel Particulate Filter Differential Pressure - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5715 PID: SPN: 3251 FMI: 10/10 LAMP: Amber SRT: | The aftertreatment diesel particulate filter differential pressure sensor is reading an erratic value. | Active and stationary regeneration of the diesel particulate filter will be disabled.
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the aftertreatment diesel particulate filter differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The aftertreatment diesel particulate filter differential pressure sensor provides a signal to the ECM on the aftertreatment diesel particulate filter differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure across the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter differential pressure sensor is mounted on the diesel particulate filter. It is a combination sensor that detects both diesel particulate filter differential pressure and outlet pressure. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic consists of two parts:

One part runs when the keyswitch is initially turned ON before the engine is started

The second part runs continuously while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel particulate filter differential pressure was greater than 1.5 kpa [0.44 in HG] at initial key ON, or is not changing with engine conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.
  • A default value for the aftertreatment diesel particulate filter differential pressure is used.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Stuck in-range aftertreatment diesel particulate filter differential pressure sensor reading

High resistance in the aftertreatment diesel particulate filter differential pressure sensor signal or return wires

Disconnected or damaged aftertreatment diesel particulate filter differential pressure sensor tubes

Plugged aftertreatment differential pressure sensor ports could cause this fault code if pressure is held in the port after the engine is turned off.

Frozen, plugged, or restricted aftertreatment DPF differential pressure sensor tubes.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM

For intermittent power supply and data link communication issues with aftertreatment components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing, or intermittent connections.

Refer to Troubleshooting Fault Code 5715.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Particulate Filter Outlet Pressure - Abnormal Rate of Change

FAULT CODE 5716

Aftertreatment 1 Diesel Particulate Filter Outlet Pressure - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5716 PID: SPN: 3610 FMI: 10/10 LAMP: Amber SRT: | The aftertreatment diesel particulate filter outlet pressure sensor is reading an erratic value. | Active and stationary regeneration of the diesel particulate filter will be disabled.
Aftertreatment Diesel Particulate Filter Outlet Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the aftertreatment diesel particulate filter outlet pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The aftertreatment diesel particulate filter outlet pressure sensor provides a signal to the ECM on the aftertreatment diesel particulate filter outlet pressure sensor signal circuit. This sensor signal voltage changes based on the pressure at the outlet of the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter differential pressure sensor is mounted on the diesel particulate filter. It is a combination sensor that detects both diesel particulate filter differential pressure and outlet pressure. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic consists of two parts:

One part runs when the keyswitch is initially turned ON before the engine is started

The second part runs continuously while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel particulate filter outlet pressure was greater than 1.5 kpa [0.22 psi] or less than -1.5 kpa [0.22 psi] at initial key ON, or was not changing with engine conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Stuck in-range aftertreatment diesel particulate filter outlet pressure sensor reading

High resistance in the aftertreatment diesel particulate filter outlet pressure sensor signal or return wires

Higher than expected diesel particulate filter outlet pressure

Excessive diesel exhaust fluid (DEF) deposits in the aftertreatment decomposition tube

Plugged aftertreatment outlet pressure sensor ports could cause this fault code if pressure is held in the port after the engine is turned OFF.

Frozen, plugged, or restricted aftertreatment DPF differential pressure sensor tubes.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM

For intermittent power supply and data link communication issues with aftertreatment components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing, or intermittent connections.

Refer to Troubleshooting Fault Code 5716.

Last Modified: 25-May-2019


Aftertreatment 1 Particulate Sensor Heater High Side Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 5792

Aftertreatment 1 Particulate Sensor Heater High Side Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5792 PID: SPN: 7321 FMI: 4/4 LAMP: Amber SRT: | An internal circuit error has been detected by the aftertreatment particulate matter sensor. | Possible reduced engine performance.
Aftertreatment Particulate Sensor Circuit

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment particulate sensor assembly

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning aftertreatment particulate matter sensor

Refer to Troubleshooting Fault Code 5792 .

Last Modified: 05-Dec-2021


Aftertreatment 1 Particulate Sensor Heater Low Side Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 5793

Aftertreatment 1 Particulate Sensor Heater Low Side Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5793 PID: SPN: 7323 FMI: 3/3 LAMP: Amber SRT: | An internal circuit error has been detected by the aftertreatment particulate matter sensor. | Possible reduced engine performance.
Aftertreatment Particulate Sensor Circuit

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment particulate sensor assembly

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning aftertreatment particulate matter sensor

Refer to Troubleshooting Fault Code 5793 .

Last Modified: 05-Dec-2021


Aftertreatment 1 Particulate Sensor - Data Not Rational - Drifted Low

FAULT CODE 5837

Aftertreatment 1 Particulate Sensor - Data Not Rational - Drifted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5837 PID: SPN: 5835 FMI: 2/21 LAMP: Amber SRT: | An in-range low failure has been detected. | Possible reduced engine performance.
Aftertreatment Particulate Sensor Circuit

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatement particulate matter sensor has detected the probe temperature value is not changing with conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning aftertreatment particulate matter sensor

Refer to Troubleshooting Fault Code 5837 .

Last Modified: 05-Dec-2021


Engine Starter Motor Relay Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 584

Engine Starter Motor Relay Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 584 PID: S39 SPN: 677 FMI: 3/3 LAMP: Amber SRT: | Open circuit or high voltage detected at starter lockout circuit. | Either the engine will not start or the engine will not have starter lockout protection.
Starter Lockout Relay Circuit

Circuit Description

The starter lockout relay is controlled by the engine control module (ECM) through the starter lockout relay signal circuit. The relay prevents the starter from being engaged when the engine is running. The relay return circuit is dependent on OEM wiring. It can be wired back to the ECM on some vehicles or wired to chassis or block ground on others. Consult the OEM wiring diagram for return circuit details. The starter lockout relay circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

Component Location

The starter lockout relay is installed by the vehicle OEM. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the starter lockout relay pulse width modulated (PWM) signal was NOT at system voltage when the pulse width modulated (PWM) signal was commanded ON.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The Starter Lockout feature will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The ECM monitors the voltage level on this circuit. If it detects a voltage when the signal is commanded off, it records this fault code. This fault code can be caused by:

Open circuit in the starter lockout relay, OEM harness, or connectors

Short circuit to a voltage source in the OEM harness or relay.

This fault can also be set active if the over crank protection feature (starter lockout) is enabled, but the engine/ECM is not wired to support it.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 584.

Last Modified: 25-May-2019


Engine Starter Motor Relay Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 585

Engine Starter Motor Relay Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 585 PID: S39 SPN: 677 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at starter lockout circuit. | Either the engine will not start or the engine will not have starter lockout protection.
Starter Lockout Relay Driver Circuit

Circuit Description

The starter lockout relay is controlled by the engine control module (ECM) through the starter lockout relay signal circuit. The relay prevents the starter from being engaged when the engine is running. The relay return circuit is dependent on OEM wiring. It can be wired back to the ECM on some vehicles or wired to chassis or block ground on others. Consult the OEM wiring diagram for return circuit details. The starter lockout relay circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

Component Location

The starter lockout relay is installed by the vehicle OEM. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the starter lockout relay pulse width modulated (PWM) signal was at system voltage when the pulse width modulated (PWM) signal was commanded OFF.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The Starter Lockout feature will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The ECM monitors the voltage level on this circuit. If it detects a low voltage when the signal is commanded ON, it records this fault code. This fault code can be caused by a short circuit to ground in the starter lockout relay, OEM harness, or connectors.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 585.

Last Modified: 25-May-2019


Aftertreatment 1 SCR Feedback Control Status - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 5868

Aftertreatment 1 SCR Feedback Control Status - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5868 PID: SPN: 4339 FMI: 7/7 LAMP: Amber SRT: | The maximum dosing adjustment has been reached. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the NOx emissions at the intake of the aftertreatment system.

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment intake NOx sensor is mounted on the engine near the turbocharger turbine outlet.

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic has to meet specific engine and aftertreatment conditions to run and complete.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the adjusted aftertreatment diesel exhaust fluid dosing command has reached a maximum limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • It is necessary to use the "Reset All Faults" command in the recommended Cummins electronic service tool or equivalent to clear this fault and extinguish the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL).

Shop Talk

Troubleshoot other active SCR related faults before this fault.

Refer to Troubleshooting Fault Code 5868.

Last Modified: 25-May-2019


Electronic Throttle Control Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 5879

Electronic Throttle Control Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5879 PID: SPN: 3464 FMI: 3/3 LAMP: Amber SRT: | A short circuit to battery or open circuit has been detected in the engine intake air throttle actuator signal circuit. | Possible reduced engine performance.
Engine Intake Air Throttle Actuator Circuit

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine intake air throttle actuator signal is shorted to voltage when the actuator is commanded OFF.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Engine intake air throttle actuation will be disabled. The engine intake air throttle will default to the open position.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Active and stationary regeneration of the diesel particulate filter will be disabled.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

An open or short circuit to battery in the engine harness.

A malfunctioning engine intake air throttle actuator

Refer to Troubleshooting Fault Code 5879.

Last Modified: 25-May-2019


Electronic Throttle Control Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 5881

Electronic Throttle Control Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5881 PID: SPN: 3464 FMI: 4/4 LAMP: Amber SRT: | A short circuit to ground has been detected in the engine intake air throttle actuator signal circuit. | Possible reduced engine performance.
Engine Intake Air Throttle Actuator Circuit

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs when the engine intake air throttle actuator is being commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine intake air throttle actuator signal is shorted to ground when the actuator is commanded ON.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Engine intake air throttle actuation will be disabled. The engine intake air throttle will default to the open position.

Exhaust gas recirculation (EGR) valve operation will be disabled.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 5 minutes. After 5 minutes, shut OFF the engine, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A short circuit to ground in the engine harness

A malfunctioning engine intake air throttle actuator

Refer to Troubleshooting Fault Code 5881.

Last Modified: 25-May-2019


Electronic Throttle Control Actuator - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 5882

Electronic Throttle Control Actuator - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5882 PID: SPN: 3464 FMI: 7/7 LAMP: Amber SRT: | The engine intake air throttle actuator has failed the auto zero span check. | Possible reduced engine performance.
Engine Intake Air Throttle Actuator Circuit

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

One part runs when the keyswitch is initially turned ON before the engine is started

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine intake air throttle actuator failed the autozero span check.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Engine intake air throttle actuation will be disabled. The engine intake air throttle will default to the open position.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • Start and idle the engine for 1 minute
  • Turn the key switch OFF and allow the ECM to completely powerdown.
  • Turn the key switch ON.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning engine intake air throttle actuator

Refer to Troubleshooting Fault Code 5882.

Last Modified: 25-May-2019


Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 595

Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 595 PID: P103 SPN: 103 FMI: 0/16 LAMP: Amber SRT: | High turbocharger speed has been detected by the ECM. | Possible reduced engine performance.
Turbocharger Speed Sensor Circuit

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. The target on the turbocharger shaft is a ground flat in the center of the shaft. As the flat on the turbocharger shaft spins past the speed sensor, a signal is generated. The Engine Control Module (ECM) interprets this signal and converts it to a turbocharger speed reading.

Component Location

The turbocharger speed sensor is mounted in the center housing of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the turbocharger speed was greater than 150,000 rpm for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The ECM will estimate the turbocharger speed.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Damaged turbocharger speed sensor

Damaged engine harness

Damaged ECM.

If the fault occurs intermittently, look for causes of intermittent open or short circuits in the turbocharger speed sensor circuit (including the speed sensor pigtail connector).

Refer to Troubleshooting Fault Code 595.

Last Modified: 25-May-2019


Electrical Charging System Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 596

Electrical Charging System Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 596 PID: P167 SPN: 167 FMI: 0/16 LAMP: Amber SRT: | High battery voltage detected by the battery voltage monitor feature. | None on performance.
Unswitched Battery Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the battery voltage was greater than a calibratible value.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is part of the Battery Voltage Monitor feature. The ECM can increase idle speed and deactivate idle decrement switch if idle speedup is enabled. Use the recommended Cummins electronic service tool or equivalent to view the Battery Voltage Monitor feature settings. Disabling the Battery Voltage Monitor feature will also disable this fault code.

Make sure the ECM battery supply (+) is coming directly from the battery and not the starter.

Possible cause of this fault code:

Overcharged batteries caused by a malfunctioning alternator or regulator.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 596.

Last Modified: 25-May-2019


Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 597

Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 597 PID: P167 SPN: 167 FMI: 1/18 LAMP: Amber SRT: | Low battery voltage detected by the battery voltage monitor feature. | None on performance.
Unswitched Battery Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the battery voltage was less than a calibratible value.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is part of the Battery Voltage Monitor feature. The ECM can increase idle speed and deactivate idle decrement switch if idle speedup is enabled. Use the recommended Cummins electronic service tool or equivalent to view the Battery Voltage Monitor feature settings. Disabling the Battery Voltage Monitor feature will also disable this fault code.

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter.

Possible causes of this fault code include:

Undercharged batteries caused by a malfunctioning alternator or regulator.

High-current devices on the vehicle such as citizens band radio amplifiers, numerous exterior lights, or other accessories.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 597.

Last Modified: 25-May-2019


SCR Thermal Management - Condition Exists

FAULT CODE 6244

SCR Thermal Management - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6244 PID: SPN: 5400 FMI: 11/31 LAMP: Amber SRT: | Indicates that the low engine-out NOx control strategy is not working as intended. | None on performance.
Engine Control Module

Circuit Description

This diagnostic monitors the fueling condition of the engine when the SCR system is warming up to ensure that proper air handling commands are being provided.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR intermediate temperature sensor reads below 190Â°C [374Â°F] while the engine is running.

Conditions for Setting the Fault Codes

The fueling condition of the engine does not match the proper air handling commands during the SCR system warm up.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.

Shop Talk

This fault code sets when a calibration mismatch is detected in the ECM.

Refer to Troubleshooting Fault Code 6244.

Last Modified: 25-May-2019


Aftertreatment SCR Operator Inducement Severity - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 6254

Aftertreatment SCR Operator Inducement Severity - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6254 PID: SPN: 5246 FMI: 0/16 LAMP: Amber SRT: | Aftertreatment SCR Operator Inducement Severity - Data Valid But Above Normal Operating Range - Moderately Severe Level Critical fault codes related to engine operation are active. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM continuously monitors the engine's fault code status to determine if any fault codes critical to successful engine operation are active.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected certain critical fault codes related to engine operation were active and the engine continued to operate.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • This fault code will go inactive once all other active fault codes have been addressed. Refer to the appropriate fault code troubleshooting tree.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only, and indicates that an engine power derate has been implemented in order to make sure that the critical fault codes that are presently active in the ECM are addressed as quickly as possible.

Refer to Troubleshooting Fault Code 6254.

Last Modified: 25-May-2019


Engine Protection Torque Derate - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 6255

Engine Protection Torque Derate - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6255 PID: SPN: 1569 FMI: 0/15 LAMP: None SRT: | Critical fault codes related to engine operation are active. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM continuously monitors the engine's fault code status to determine if any fault codes critical to successful engine operation are active.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected certain critical fault codes related to engine operation were active and the engine continued to operate.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • This fault code will go inactive once all other active fault codes have been addressed. Refer to the appropriate fault code troubleshooting tree.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only, and indicates that an engine power derate has been implemented in order to make sure that the critical fault codes that are presently active in the ECM are addressed as quickly as possible.

Refer to Troubleshooting Fault Code 6255.

Last Modified: 25-May-2019


Battery 1 Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 6256

Battery 1 Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6256 PID: SPN: 168 FMI: 0/15 LAMP: None SRT: | ECM supply voltage is above the maximum system voltage level. | None on performance.
Unswitched Battery Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected excessive battery supply voltage.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Faulty alternator or regulator that is overcharging the system

Batteries connected in series instead of parallel

Incorrect jump-starting procedure.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 6256.

Last Modified: 25-May-2019


Battery 1 Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 6257

Battery 1 Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6257 PID: SPN: 168 FMI: 1/17 LAMP: None SRT: | ECM supply voltage is above the maximum system voltage level. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Unswitched Battery Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected low battery supply voltage.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Verify that the ECM unswitched power supply is coming from the batteries and not the starter or other device. Check for possible weak batteries.

If the ECM unswitched battery supply is taken from the starter, check for low voltage during cranking. Low voltage during cranking can cause the ECM power supply to drop below specifications and log Fault Code 441.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 6257.

Last Modified: 25-May-2019


Electric Lift Pump for Engine Fuel Supply - Voltage Above Normal or Shorted to High Source

FAULT CODE 6258

Electric Lift Pump for Engine Fuel Supply - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6258 PID: SPN: 1075 FMI: 3/3 LAMP: None SRT: | High voltage or open circuit detected at the fuel lift pump signal circuit. | Engine may not start or may be difficult to start.
Engine Fuel Lift Pump Supply Circuit

Circuit Description

The fuel lift pump circuit is a discrete output in the engine control module (ECM) that controls the electric fuel lift pump. The lift pump is grounded in the ECM.

Component Location

The fuel lift pump is mounted on the intake side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and the lift pump timer has expired 1 minute after initial key ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel lift pump signal circuit was detected to be greater than 0-VDC when the signal was turned off by the engine control module (ECM).

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • Perform a key cycle, and leave the key switch in the ON position for at least 2 minutes.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

An open circuit in the engine harness

A short circuit to battery in the engine harness.

A malfunctioning fuel lift pump

Refer to Troubleshooting Fault Code 6258.

Last Modified: 25-May-2019


Electric Lift Pump for Engine Fuel Supply - Voltage Below Normal or Shorted to Low Source

FAULT CODE 6259

Electric Lift Pump for Engine Fuel Supply - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6259 PID: SPN: 1075 FMI: 4/4 LAMP: None SRT: | Low signal voltage detected at the fuel lift pump circuit. | Engine may not start or may be difficult to start.
Engine Lift Pump Supply Circuit

Circuit Description

The fuel lift pump circuit is a discrete output in the engine control module (ECM) that controls the electric fuel lift pump. The lift pump is grounded in the ECM.

Component Location

The fuel lift pump is mounted on the intake side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is initially turned to the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel lift pump signal circuit was detected to be 0-VDC when the signal is turned ON by the engine control module (ECM).

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A short circuit to ground in the engine harness

A malfunctioning fuel lift pump

Refer to Troubleshooting Fault Code 6259.

Last Modified: 25-May-2019


Engine Starter Motor Relay Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 6261

Engine Starter Motor Relay Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6261 PID: SPN: 677 FMI: 3/3 LAMP: None SRT: | Open circuit or high voltage detected at starter lockout circuit. | Either the engine will not start or the engine will not have starter lockout protection.
Starter Lockout Relay Circuit

Circuit Description

The starter lockout relay is controlled by the engine control module (ECM) through the starter lockout relay signal circuit. The relay prevents the starter from being engaged when the engine is running. The relay return circuit is dependent on OEM wiring. It can be wired back to the ECM on some vehicles or wired to chassis or block ground on others. Consult the OEM wiring diagram for return circuit details. The starter lockout relay circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

Component Location

The starter lockout relay is installed by the vehicle OEM. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the starter lockout relay pulse width modulated (PWM) signal was NOT at system voltage when the pulse width modulated (PWM) signal was commanded ON.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

The Starter Lockout feature will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The ECM monitors the voltage level on this circuit. If it detects a voltage when the signal is commanded off, it records this fault code. This fault code can be caused by:

Open circuit in the starter lockout relay, OEM harness, or connectors

Short circuit to a voltage source in the OEM harness or relay.

This fault can also be set active if the over crank protection feature (starter lockout) is enabled, but the engine/ECM is not wired to support it.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 6261.

Last Modified: 25-May-2019


Engine Starter Motor Relay Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 6262

Engine Starter Motor Relay Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6262 PID: SPN: 677 FMI: 4/4 LAMP: None SRT: | Low voltage detected at starter lockout circuit. | Either the engine will not start or the engine will not have starter lockout protection.
Starter Lockout Relay Driver Circuit

Circuit Description

The starter lockout relay is controlled by the engine control module (ECM) through the starter lockout relay signal circuit. The relay prevents the starter from being engaged when the engine is running. The relay return circuit is dependent on OEM wiring. It can be wired back to the ECM on some vehicles or wired to chassis or block ground on others. Consult the OEM wiring diagram for return circuit details. The starter lockout relay circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

Component Location

The starter lockout relay is installed by the vehicle OEM. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the starter lockout relay pulse width modulated (PWM) signal was at system voltage when the pulse width modulated (PWM) signal was commanded OFF.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

The Starter Lockout feature will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The ECM monitors the voltage level on this circuit. If it detects a low voltage when the signal is commanded ON, it records this fault code. This fault code can be caused by a short circuit to ground in the starter lockout relay, OEM harness, or connectors.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 6262.

Last Modified: 25-May-2019


Fan Control Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 6263

Fan Control Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6263 PID: SPN: 647 FMI: 3/3 LAMP: None SRT: | Open circuit or high voltage detected at the fan control circuit. | The fan can stay on continuously or not run at all.
Fan Control Circuit

Circuit Description

The fan control circuit is a device used by the engine to control the fan operation. When the engine control module (ECM) energizes the fan control circuit, the engine fan is engaged.

The fan control circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

There are two types of fans supported by the fan control circuit; variable speed and ON/OFF. The recommended Cummins electronic service tool or equivalent can be used to determine which fan type is currently set up for use. The fan control circuit varies by original equipment manufacturer (OEM). Certain OEMs can use a solenoid return that is wired to the ECM or can use a return that goes to the engine block or chassis ground.

Component Location

The control solenoid location varies by OEM. Refer to the appropriate OEM service manual to determine the location.

Conditions for Running the Diagnostics

For ON/OFF and variable speed fan types, the diagnostic runs when the fan is turned off and will latch active when the fan PWM signal is 100 percent. For all other fan types, the diagnostic runs when the fan PWM signal is less than 100 percent and will latch active when the fan PWM signal is 100 percent.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fan control circuit pulse width modulated (PWM) signal voltage was greater then 0-VDC when the PWM signal was commanded OFF.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Fan operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If Fault Code 6263 is still active after completing all the steps in this fault code troubleshooting tree, consult the OEM service literature for procedures to check the fan clutch device for an open circuit or short circuit to ground.

Possible causes of this fault code include:

An open circuit in the harness or fan control solenoid.

A short circuit to voltage source in the OEM harness.

A malfunctioning ECM.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 6263.

Last Modified: 25-May-2019


Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 6264

Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6264 PID: SPN: 647 FMI: 4/4 LAMP: None SRT: | Low signal voltage detected at the fan control circuit when commanded ON. | The fan can stay on continuously or not run at all.
Fan Control Circuit

Circuit Description

The fan control circuit is a device used by the engine to control the fan operation. When the engine control module (ECM) energizes the fan control circuit, the engine fan is engaged.

The fan control circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

There are two types of fans supported by the fan control circuit; variable speed and ON/OFF. The recommended Cummins electronic service tool or equivalent can be used to determine which fan type is currently set up for use. The fan control circuit varies by original equipment manufacturer (OEM). Certain OEMs can use a solenoid return that is wired to the ECM or can use a return that goes to the engine block or chassis ground.

Component Location

The control solenoid location varies by OEM. Refer to the appropriate OEM service manual to determine the location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fan control circuit pulse width modulated (PWM) signal was not at system voltage when the pulse width modulated (PWM) signal was commanded ON.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Fan operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The fan control logic can be adjusted with the recommended Cummins electronic service tool or equivalent. There are two choices: 12 or 24 volts ON, or 0 volts ON. For proper fan operation, the fan control logic setup with the recommended Cummins electronic service tool or equivalent must match the hardware configuration on the vehicle.

This fault code is logged when the ECM commands 12 or 24-VDC to the fan control solenoid, but the voltage on the fan control signal circuit is less than 12 or 24-VDC. The low voltage on the signal circuit usually indicates a short circuit to ground in the harness or solenoid.

If Fault Code 6264 is still active after completing the following troubleshooting steps, consult the OEM service manual for procedures to check the fan control circuit for a short circuit to ground.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 6264.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Particulate Filter System - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 6265

Aftertreatment 1 Diesel Particulate Filter System - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6265 PID: SPN: 3936 FMI: 7/7 LAMP: None SRT: | The aftertreatment diesel particulate filter has been damaged. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter outlet temperature sensor reading was greater than 950Â°C [1742Â°F] for 30 seconds, or the difference between the diesel particulate filter intake temperature and the diesel particulate filter outlet temperature was greater than 1050Â°C [1922Â°F] for 30 seconds.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Excessive engine oil or diesel fuel being introduced into the exhaust system from the engine

A malfunctioning engine fuel injector causing unburned diesel fuel to enter the exhaust system

A face plugged aftertreatment diesel oxidation catalyst

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 6265.

Last Modified: 25-May-2019


Aftertreatment 1 SCR Intermediate Gas Temperature - Special Instructions

FAULT CODE 6266

Aftertreatment 1 SCR Intermediate Gas Temperature - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6266 PID: SPN: 5862 FMI: 14/14 LAMP: Amber SRT: | The aftertreatment SCR intermediate temperature sensor reading is irrational. | Possible reduced engine performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intermediate temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and exhaust flow is above a minimum level.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment SCR intermediate temperature sensor signal was irrational for more than 5 minutes.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, it may be necessary to operate the vehicle on a chassis dynamometer or to drive the vehicle in order to get the engine load high enough for the diagnostic to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment SCR intermediate temperature sensor

A malfunctioning aftertreatment SCR outlet temperature sensor

Refer to Troubleshooting Fault Code 6266.

Last Modified: 25-May-2019


Aftertreatment 1 SCR Intake Temperature - Special Instructions

FAULT CODE 6267

Aftertreatment 1 SCR Intake Temperature - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6267 PID: SPN: 4360 FMI: 14/14 LAMP: Amber SRT: | The aftertreatment SCR intermediate temperature sensor reading is irrational. | Possible reduced engine performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intermediate temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and exhaust flow is above a minimum level.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment SCR intermediate temperature sensor signal was irrational for more than 5 minutes.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, it may be necessary to operate the vehicle on a chassis dynamometer or to drive the vehicle in order to get the engine load high enough for the diagnostic to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment SCR intermediate temperature sensor

A malfunctioning aftertreatment SCR outlet temperature sensor

Refer to Troubleshooting Fault Code 6267.

Last Modified: 25-May-2019


Aftertreatment 1 SCR Outlet Temperature Sensor - Bad Intelligent Device or Component

FAULT CODE 6268

Aftertreatment 1 SCR Outlet Temperature Sensor - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6268 PID: SPN: 4363 FMI: 12/12 LAMP: Amber SRT: | High signal voltage detected at the SCR outlet temperature sensor circuit. | Possible reduced engine performance.
Aftertreatment SCR Catalyst Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intermediate temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported the aftertreatment SCR outlet temperature signal was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment SCR outlet temperature sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 6268.

Last Modified: 25-May-2019


Turbocharger 1 Compressor Intake Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 629

Turbocharger 1 Compressor Intake Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 629 PID: S314 SPN: 1176 FMI: 1/18 LAMP: Amber SRT: | The estimated differential pressure across the turbocharger is above the critical level. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM calculates a differential pressure across the turbocharger using the intake manifold pressure sensor and the crankcase pressure sensor.

Component Location

The intake manifold pressure sensor is located in the air intake horn. The crankcase pressure sensor is mounted to the crankcase breather filter housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the calculated differential pressure across the turbocharger was greater than a threshold.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Plugged or restricted air filter plugged

Restricted crankcase breather filter plugged

Restricted crankcase breather plumbing.

Refer to Troubleshooting Fault Code 629.

Last Modified: 25-May-2019


Crankcase Breather Filter Heater Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 6336

Crankcase Breather Filter Heater Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6336 PID: SPN: 862 FMI: 3/3 LAMP: None SRT: | High signal voltage detected at the crankcase breather heater circuit. | None on performance.
Crankcase Breather Filter Heater Circuit

Circuit Description

The crankcase breather heater is used to keep the crankcase breather filter housing from freezing. The ECM supplies battery voltage to the breather heater when heating is commanded.

Component Location

The crankcase breather heater is mounted to the crankcase breather filter housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankcase breather heater signal voltage was out of range high for more than 10 seconds.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

The crankcase breather heater will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Short circuit to voltage in the crankcase breather heater circuit

Malfunctioning ECM.

Refer to Troubleshooting Fault Code 6336.

Last Modified: 25-May-2019


Crankcase Breather Filter Heater Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 6337

Crankcase Breather Filter Heater Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6337 PID: SPN: 862 FMI: 4/4 LAMP: None SRT: | Low signal voltage detected at the crankcase breather heater circuit. | None on performance.
Crankcase Breather Filter Heater Circuit

Circuit Description

The crankcase breather heater is used to keep the crankcase breather filter housing from freezing. The ECM supplies battery voltage to the breather heater when heating is commanded.

Component Location

The crankcase breather heater is mounted to the crankcase breather filter housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankcase breather heater signal circuit was shorted to ground.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

The crankcase breather heater will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Open crankcase breather heater circuit

Short circuit to ground in the crankcase breather heater circuit

Malfunctioning ECM.

Refer to Troubleshooting Fault Code 6337.

Last Modified: 25-May-2019


Fuel Level 1 - Abnormal Update Rate

FAULT CODE 6339

Fuel Level 1 - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6339 PID: SPN: 96 FMI: 9/9 LAMP: Amber SRT: | The ECM expected information from a multiplexed device but did not receive it soon enough or did not receive it at all. | At least one multiplexed device will not operate properly.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins ECM and used for controlling the engine. The Cummins ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

The Engine Control Module (ECM) detected an open or short circuit condition in the J1939 data link harness.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices can possibly not function as desired.

This fault can occur for the following reasons:

When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the CumminsÂ ECM, or the OEM VECU is not set up to transmit the multiplexed component message.

This fault can also be caused by a bad J1939 data link connection between the OEM VECU and Cummins ECM, a bad connection between the component and the OEM VECU, bad OEM VECU or bad Cummins ECM. It may be necessary to contact the OEM for proper multiplexing configuration. It is possible to use the recommended Cummins electronic service tool or equivalent to monitor multiplexed components.

It is possible to use the recommended Cummins electronic service tool or equivalent to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 6339.

Last Modified: 25-May-2019


Fuel Level 1 - Out of Calibration

FAULT CODE 6341

Fuel Level 1 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6341 PID: SPN: 96 FMI: 13/13 LAMP: Amber SRT: | The ECM expected information from a multiplexed device but only received a portion of the necessary information. | At least one multiplexed device will not operate properly.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins ECM and used for controlling the engine. The Cummins ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) received an invalid J1939 data link message from a multiplexed device for more than 1 second.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault can occur when the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing.

It is possible to use the recommended Cummins electronic service tool or equivalent to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 6341.

Last Modified: 25-May-2019


Fuel Level 2 - Abnormal Update Rate

FAULT CODE 6342

Fuel Level 2 - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6342 PID: SPN: 38 FMI: 9/9 LAMP: Amber SRT: | The ECM expected information from a multiplexed device but did not receive it soon enough or did not receive it at all. | At least one multiplexed device will not operate properly.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins ECM and used for controlling the engine. The Cummins ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

The Engine Control Module (ECM) detected an open or short circuit condition in the J1939 data link harness.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices can possibly not function as desired.

This fault can occur for the following reasons:

When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the CumminsÂ ECM, or the OEM VECU is not set up to transmit the multiplexed component message.

This fault can also be caused by a bad J1939 data link connection between the OEM VECU and Cummins ECM, a bad connection between the component and the OEM VECU, bad OEM VECU or bad Cummins ECM. It may be necessary to contact the OEM for proper multiplexing configuration. It is possible to use the recommended Cummins electronic service tool or equivalent to monitor multiplexed components.

It is possible to use the recommended Cummins electronic service tool or equivalent to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 6342.

Last Modified: 25-May-2019


Fuel Level 2 - Out of Calibration

FAULT CODE 6343

Fuel Level 2 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6343 PID: SPN: 38 FMI: 13/13 LAMP: Amber SRT: | The ECM expected information from a multiplexed device but only received a portion of the necessary information. | At least one multiplexed device will not operate properly.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins ECM and used for controlling the engine. The Cummins ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) received an invalid J1939 data link message from a multiplexed device for more than 1 second.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault can occur when the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing.

It is possible to use the recommended Cummins electronic service tool or equivalent to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 6343.

Last Modified: 25-May-2019


Aftertreatment Regeneration Inhibited Due to Inhibit Switch - Condition Exists

FAULT CODE 6416

Aftertreatment Regeneration Inhibited Due to Inhibit Switch - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6416 PID: SPN: 3703 FMI: 11/31 LAMP: None SRT: | Regeneration of the diesel particulate filter has been prevented due to the permit switch being disabled. | Possible frequent need for aftertreatment regeneration.
Engine Control Module (ECM)

Circuit Description

The OEM truck manufacturer can install a permit switch in the dash or send an inhibit message via the J1939 data link to the engine ECM. The function of the inhibit message is to prevent the aftertreatment system from performing mobile regenerations.

Component Location

The aftertreatment regeneration permit switch can be an actual switch in the vehicle dash or it can be a J1939 message sent via the J1939 data link. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel particulate filter regeneration permit switch was disabling regeneration while the ECM was requesting active regeneration of the aftertreatment diesel particulate filter.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If this fault code is active and there has been damage to the aftertreatment system, the permit switch can possibly have prevented the aftertreatment system from performing a mobile (active) regeneration.

Consult with the OEM if the aftertreatment system has malfunctioned due to the permit switch.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 6416.

Last Modified: 25-May-2019


SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Sensor System - Received Network Data in Error

FAULT CODE 6417

SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Sensor System - Received Network Data in Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6417 PID: SPN: 974 FMI: 2/19 LAMP: Amber SRT: | The OEM vehicle electronic control unit (VECU) detected a fault with the remote accelerator. | Remote accelerator will not operate.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins ECM and used for controlling the engine. The Cummins ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) received a message from the OEM VECU via the J1939 data link, indicating the remote throttle signal wire or enable switch was shorted high or shorted low.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault can occur when the OEM VECU detects an error on the remote throttle and or remote throttle enable switch. The ECM has been set up properly (components enabled and OEM VECU source addressed correctly) to receive multiplexed information for the remote throttle enable switch states and remote accelerator position over the J1939 data link from an OEM VECU, and the OEM VECU is transmitting the message for that component. Most OEM VECUs will not have the circuitry to detect a remote throttle switch error.

The two types of errors that can occur for this fault are:

The OEM VECU determines that the remote throttle signal line is shorted high or shorted low. This fault status is transmitted to the Cummins ECM on the J1939 data link, which causes this fault to occur in the Cummins ECM.

When the remote throttle enable switch has a shorted high or shorted low error detected by the OEM VECU, this fault status is transmitted to the ECM on the J1939 data link, which causes this fault to occur in the ECM. Most OEM VECUs will not incorporate fault detection on a switch.

It is still possible to get a Fault Code 285 or 286, if there is an incorrect setup in the OEM VECU or Cummins ECM for other components, or the remote throttle and remote throttle switch, or the data link is damaged. The OEM configurations must multiplex the remote throttle and remote throttle switch inputs together to allow the use of the J1939 multiplexing feature for these components. Use the recommended Cummins electronic service tool or equivalent to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 6417.

Last Modified: 25-May-2019


Engine Brake Actuator Driver 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 6418

Engine Brake Actuator Driver 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6418 PID: SPN: 1072 FMI: 3/3 LAMP: None SRT: | High voltage or an open circuit detected at the engine brake solenoid number 1 signal circuit. | Possible reduce engine braking performance.
Engine Brake Actuator Dirver 1 Circuit

Circuit Description

The Engine Control Module (ECM) controls engine brakes on cylinders 1, 2, and 3 by sending a signal on the engine brake solenoid number 1 signal circuit. If an engine brake is installed, there will be a jumper harness from this connector to the engine brake pass-through connectors on the rocker lever housing.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake solenoids are controlled through the engine harness by the ECM.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine brake 1 pulse width modulated (PWM) signal was detected to be greater than 0 volts when the PWM signal was turned off by the ECM.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

The engine brake 1 circuit will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, drive the vehicle and operate the engine brakes. This will allow the diagnostic to run. If the fault code does not become active again, the repair has been validated.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A short circuit to battery in the engine harness.

A malfunctioning engine brake solenoid

Refer to Troubleshooting Fault Code 6418.

Last Modified: 25-May-2019


Engine Brake Actuator Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 6419

Engine Brake Actuator Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6419 PID: SPN: 1072 FMI: 4/4 LAMP: None SRT: | Low voltage detected at the engine brake solenoid number 1 signal circuit. | Possible reduce engine braking performance.
Engine Brake Actuator Driver 1 Circuit

Circuit Description

The Engine Control Module (ECM) controls engine brakes on cylinders 1, 2, and 3 by sending a signal on the engine brake solenoid number 1 signal circuit. If an engine brake is installed, there will be a jumper harness from this connector to the engine brake pass-through connectors on the rocker lever housing.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake solenoids are controlled through the engine harness by the ECM.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine brake 1 pulse width modulated (PWM) signal was not detected to be system voltage when the PWM signal was turned on.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

The engine brake 1 circuit will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, drive the vehicle and operate the engine brakes. This will allow the diagnostic to run. If the fault code does not become active again, the repair has been validated.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A short circuit to ground in the engine harness

A malfunctioning engine brake solenoid

Refer to Troubleshooting Fault Code 6419.

Last Modified: 25-May-2019


Engine Brake Actuator Driver Output 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 6421

Engine Brake Actuator Driver Output 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6421 PID: SPN: 1073 FMI: 3/3 LAMP: None SRT: | Open circuit or high voltage detected at the engine brake solenoid Number 2 signal circuit. | Possible reduce engine braking performance.
Engine Brake Actuator Driver 2 Circuit

Circuit Description

The engine control module (ECM) controls engine brakes on cylinders 4, 5, and 6 by sending a signal on the engine brake solenoid number 2 signal circuit. If an engine brake is installed, there will be a jumper harness from this connector to the engine brake pass-through connectors on the rocker lever housing.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake solenoids are controlled through the engine harness by the ECM.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine brake 2 pulse width modulated (PWM) signal was detected to be system voltage when the PWM signal was turned off.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

The engine brake 2 circuit will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, drive the vehicle and operate the engine brakes. This will allow the diagnostic to run. If the fault code does not become active again, the repair has been validated.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A short circuit to battery in the engine harness.

A malfunctioning engine brake solenoid

Refer to Troubleshooting Fault Code 6421.

Last Modified: 25-May-2019


Engine Brake Actuator Driver Output 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 6422

Engine Brake Actuator Driver Output 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6422 PID: SPN: 1073 FMI: 4/4 LAMP: None SRT: | Low voltage detected at the engine brake solenoid number 2 signal circuit. | Possible reduce engine braking performance.
Engine Brake Actuator Driver 2 Circuit

Circuit Description

The engine control module (ECM) controls engine brakes on cylinders 4, 5, and 6 by sending a signal on the engine brake solenoid number 2 signal circuit. If an engine brake is installed, there will be a jumper harness from this connector to the engine brake pass-through connectors on the rocker lever housing.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake solenoids are controlled through the engine harness by the ECM.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine brake 2 pulse width modulated (PWM) signal was not detected to be system voltage when the PWM signal was turned on.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

The engine brake 2 circuit will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, drive the vehicle and operate the engine brakes. This will allow the diagnostic to run. If the fault code does not become active again, the repair has been validated.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A short circuit to ground in the engine harness

A malfunctioning engine brake solenoid

Refer to Troubleshooting Fault Code 6422.

Last Modified: 25-May-2019


VGT Actuator Controller - Special Instructions

FAULT CODE 6432

VGT Actuator Controller - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6432 PID: SPN: 641 FMI: 14/14 LAMP: Amber SRT: | The VGT actuator has been installed incorrectly. | Possible reduced engine performance.
VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports malfunctions back to the primary engine ECM, using the J1939 data link. The ECM then decodes the error message and converts it to a fault code.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is initially turned to the ON position.

The keyswitch must be turned OFF for more than 30 seconds before this diagnostic will run at initial key ON.

Conditions for Setting the Fault Codes

The Variable Geometry Turbocharger (VGT) actuator position was not known during initial power ON.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

VGT actuation will be disabled.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the keyswitch in the ON position for 1 minute. Note that the keyswitch must be completely turned OFF for more than 30 seconds before this diagnostic will run at initial key ON.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code can only be logged after the VGT actuator has been removed or replaced, and then not installed correctly. The gear alignment between the actuator and the turbocharger housing is misaligned. The correct installation procedure must be followed when replacing the VGT actuator.

Refer to Troubleshooting Fault Code 6432.

Last Modified: 25-May-2019


Engine Oil Change Interval - Condition Exists

FAULT CODE 649

Engine Oil Change Interval - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 649 PID: S115 SPN: 1378 FMI: 11/31 LAMP: Maintenance SRT: | Change the engine oil and filter. | None on performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) informs the driver of a maintenance event by using the Maintenance Monitor feature's lubrication oil drain limits.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil and filter required changing based on the programmable setting in the Maintenance Monitor.

Action Taken When the Fault Code is Active

The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • Use the recommended Cummins electronic service tool or equivalent to reset the Maintenance Monitor feature.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code will only become active if the Maintenance Monitor is enabled in the recommended Cummins electronic service tool or equivalent. Make sure the oil and filter are changed before clearing the fault code.

Refer to Troubleshooting Fault Code 649.

Last Modified: 25-May-2019


Predictive Cruise Control State - Abnormal Update Rate

FAULT CODE 6575

Predictive Cruise Control State - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6575 PID: SPN: 7317 FMI: 9/9 LAMP: None SRT: | Loss of communication with predictive cruise control. | Predictive cruise control will not operate. Standard cruise control may not operate.
SAE J1939 Datalink Circuit

Circuit Description

The predictive cruise control system sends commands to the ECM via the vehicle J1939 network. Predictive Cruise Control dynamically adjust the vehicle speed profile while the vehicle is operating in cruise control. The vehicle speed profile is optimized for fuel economy based on the upcoming road grade.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

The predictive cruise control will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 2 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

For troubleshooting information on this fault code refer to the OEM service manual.

Refer to Troubleshooting Fault Code 6575.

Last Modified: 25-May-2019


Engine Speed - Root Cause Not Known

FAULT CODE 6595

Engine Speed - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6595 PID: SPN: 190 FMI: 11/11 LAMP: None SRT: | The engine control module has detected the primary and backup speed sensor signals have lost synchronization or are connected backwards. | Engine may be shut down.
Engine Crankshaft Speed/Postion and Camshaft Speed/Postion Sensor Circuits

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position and camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and during cranking.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of both engine speed/position signals.

Action Taken When the Fault Code is Active

For On-Board Diagnostics (OBD) engines, the ECM illuminates the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

The engine may not start.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates the crankshaft position sensor and the camshaft position sensor have lost synchronization or the wiring harness connectors are reversed.

Refer to Troubleshooting Fault Code 6595.

Last Modified: 25-May-2019


SCR Monitoring System Malfunction - Special Instructions

FAULT CODE 6613

SCR Monitoring System Malfunction - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6613 PID: SPN: 5842 FMI: 14/14 LAMP: Amber SRT: | Critical SCR related fault codes have been active and require immediate attention. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM continuously monitors the engine's fault code status to determine if any fault codes critical to successful engine operation are active.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected certain critical fault codes related to engine operation were active and the engine continued to operate.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • This fault code will go inactive once all other active fault codes have been addressed. Refer to the appropriate fault code troubleshooting tree.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only, and indicates that an engine power derate has been implemented in order to make sure that the critical fault codes that are presently active in the ECM are addressed as quickly as possible.

Refer to Troubleshooting Fault Code 6613.

Last Modified: 25-May-2019


Estimated Engine Parasitic Losses - Percent Torque - Data Erratic, Intermittent, or Incorrect

FAULT CODE 6637

Estimated Engine Parasitic Losses - Percent Torque - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6637 PID: SPN: 2978 FMI: 2/2 LAMP: Amber SRT: | A loss of communication has been detected. | None on performance.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins ECM and used for controlling the engine. The Cummins ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The OEM VECU determines there is a malfunction of the multiplexed variable speed fan drive.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible cause of this fault code:

  • A malfunctioning SAE J1939 datalink circuit

Incorrect feature and parameter settings

For intermittent power supply and data link communication issues with aftertreatment components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing, or intermittent connections.

Refer to Troubleshooting Fault Code 6637.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Particulate Filter 1 Soot Sensor ECU Internal Temperature 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 6642

Aftertreatment 1 Diesel Particulate Filter 1 Soot Sensor ECU Internal Temperature 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6642 PID: SPN: 5569 FMI: 4/4 LAMP: Amber SRT: | An internal circuit error has been detected by the aftertreatment particulate matter sensor. | Possible reduced engine performance.
Aftertreatment Particulate Sensor Circuit

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment particulate sensor assembly

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning aftertreatment particulate matter sensor

Refer to Troubleshooting Fault Code 6642 .

Last Modified: 05-Dec-2021


Aftertreatment 1 Diesel Particulate Filter 1 Soot Sensor ECU Internal Temperature 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 6643

Aftertreatment 1 Diesel Particulate Filter 1 Soot Sensor ECU Internal Temperature 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6643 PID: SPN: 5569 FMI: 3/3 LAMP: Amber SRT: | An internal circuit error has been detected by the aftertreatment particulate matter sensor. | Possible reduced engine performance.
Aftertreatment Particulate Sensor Circuit

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment particulate sensor assembly

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning aftertreatment particulate matter sensor

Refer to Troubleshooting Fault Code 6643 .

Last Modified: 05-Dec-2021


Aftertreatment 1 Diesel Particulate Filter 1 Soot Sensor ECU Internal Temperature 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 6644

Aftertreatment 1 Diesel Particulate Filter 1 Soot Sensor ECU Internal Temperature 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6644 PID: SPN: 5569 FMI: 4/4 LAMP: Amber SRT: | An internal circuit error has been detected by the aftertreatment particulate matter sensor. | Possible reduced engine performance.
Aftertreatment Particulate Sensor Circuit

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment particulate sensor assembly

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning aftertreatment particulate matter sensor

Refer to Troubleshooting Fault Code 6644 .

Last Modified: 05-Dec-2021


Aftertreatment 1 Diesel Particulate Filter 1 Soot Sensor ECU Internal Temperature 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 6645

Aftertreatment 1 Diesel Particulate Filter 1 Soot Sensor ECU Internal Temperature 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6645 PID: SPN: 5569 FMI: 3/3 LAMP: Amber SRT: | An internal circuit error has been detected by the aftertreatment particulate matter sensor. | Possible reduced engine performance.
Aftertreatment Particulate Sensor Circuit

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment particulate sensor assembly

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning aftertreatment particulate matter sensor

Refer to Troubleshooting Fault Code 6645 .

Last Modified: 05-Dec-2021


Aftertreatment 1 Diesel Particulate Filter 1 Soot Sensor ECU Internal Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 6646

Aftertreatment 1 Diesel Particulate Filter 1 Soot Sensor ECU Internal Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6646 PID: SPN: 5569 FMI: 2/2 LAMP: Amber SRT: | Erratic internal temperatures have been detected by the aftertreatment particulate sensor. | Possible reduced engine performance.
Aftertreatment Particulate Sensor Circuit

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment particulate matter sensor has detected a mismatch between the internal ECU temperature probes.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning aftertreatment particulate matter sensor

Refer to Troubleshooting Fault Code 6646 .

Last Modified: 05-Dec-2021


Aftertreatment 1 Diesel Particulate Filter Soot Temperature Sensor - Voltage Above Normal or Shorted to High Source

FAULT CODE 6647

Aftertreatment 1 Diesel Particulate Filter Soot Temperature Sensor - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6647 PID: SPN: 6780 FMI: 3/3 LAMP: Amber SRT: | An internal circuit error has been detected by the aftertreatment particulate matter sensor. | Possible reduced engine performance.
Aftertreatment Particulate Sensor Circuit

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment particulate sensor assembly

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning aftertreatment particulate matter sensor

Refer to Troubleshooting Fault Code 6647 .

Last Modified: 05-Dec-2021


Aftertreatment 1 Diesel Particulate Filter Soot Temperature Sensor - Voltage Below Normal or Shorted to Low Source

FAULT CODE 6648

Aftertreatment 1 Diesel Particulate Filter Soot Temperature Sensor - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6648 PID: SPN: 6780 FMI: 4/4 LAMP: Amber SRT: | An internal circuit error has been detected by the aftertreatment particulate matter sensor. | Possible reduced engine performance.
Aftertreatment Particulate Sensor Circuit

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment particulate sensor assembly

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning aftertreatment particulate matter sensor

Refer to Troubleshooting Fault Code 6648 .

Last Modified: 05-Dec-2021


Aftertreatment 1 Diesel Particulate Filter Soot Temperature Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 6649

Aftertreatment 1 Diesel Particulate Filter Soot Temperature Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6649 PID: SPN: 6780 FMI: 2/2 LAMP: Amber SRT: | The aftertreatment particulate matter sensor has detected a temperature that is incorrect for the conditions. | Possible reduced engine performance.
Aftertreatment Particulate Sensor Circuit

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

The engine must be turned OFF for period of 8 hours before this diagnostic will run. This diagnostic runs when the keyswitch is turned to the ON position after an 8 hour cold soak.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment particulate sensor assembly

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, the engine must be shut down with the keyswitch in the OFF position for 8 hours. After the 8 hour cold soak, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning aftertreatment particulate matter sensor

  • Malfunctioning aftertreatment temperature sensors
Refer to Troubleshooting Fault Code 6649 .

Last Modified: 05-Dec-2021


Aftertreatment 1 Diesel Particulate Filter Soot Sensor Module - Voltage Above Normal or Shorted to High Source

FAULT CODE 6651

Aftertreatment 1 Diesel Particulate Filter Soot Sensor Module - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6651 PID: SPN: 7854 FMI: 3/3 LAMP: Amber SRT: | The aftertreatment particulate sensor has detected high supply voltage. | Possible reduced engine performance.
Aftertreatment Particulate Sensor Circuit

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The voltage to the aftertreatment particulate matter sensor is above a calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning aftertreatment particulate matter sensor

  • A damaged alternator causing high voltage
Refer to Troubleshooting Fault Code 6651 .

Last Modified: 05-Dec-2021


Aftertreatment 1 Diesel Particulate Filter Soot Sensor Module - Voltage Below Normal or Shorted to Low Source

FAULT CODE 6652

Aftertreatment 1 Diesel Particulate Filter Soot Sensor Module - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6652 PID: SPN: 7854 FMI: 4/4 LAMP: Amber SRT: | The aftertreatment particulate sensor has detected low supply voltage. | Possible reduced engine performance.
Aftertreatment Particulate Sensor Circuit

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The voltage to the aftertreatment particulate matter sensor is below a calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning aftertreatment particulate matter sensor

Short or open circuit in the aftertreatment wiring harness

Refer to Troubleshooting Fault Code 6652 .

Last Modified: 05-Dec-2021


Aftertreatment 1 Diesel Particulate Filter Soot Sensor Module - Current Above Normal or Grounded Circuit

FAULT CODE 6653

Aftertreatment 1 Diesel Particulate Filter Soot Sensor Module - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6653 PID: SPN: 7854 FMI: 6/6 LAMP: Amber SRT: | The aftertreatment particulate sensor has detected high supply current. | Possible reduced engine performance.
Aftertreatment Particulate Sensor Circuit

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment particulate matter sensor has detected low resistance in its power supply.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning aftertreatment particulate matter sensor

Refer to Troubleshooting Fault Code 6653 .

Last Modified: 05-Dec-2021


SCR Monitoring System Malfunction - Special Instructions

FAULT CODE 6656

SCR Monitoring System Malfunction - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6656 PID: SPN: 5842 FMI: 14/14 LAMP: None SRT: | Critical SCR related fault codes have been active and require immediate attention. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM continuously monitors the engine's fault code status to determine if any fault codes critical to successful engine operation are active.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected certain critical fault codes related to engine operation were active and the engine continued to operate.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • This fault code will go inactive once all other active fault codes have been addressed. Refer to the appropriate fault code troubleshooting tree.

Shop Talk

This fault code is for information only, make sure that the critical SCR tampering related fault codes that are presently active in the ECM are addressed as quickly as possible.

Refer to Troubleshooting Fault Code 6656.

Last Modified: 25-May-2019


Aftertreatment 1 Particulate Sensor - Abnormal Update Rate

FAULT CODE 6688

Aftertreatment 1 Particulate Sensor - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6688 PID: SPN: 5835 FMI: 9/9 LAMP: Amber SRT: | No communication or an invalid data transfer rate detected on the J1939 data link between the ECM and the aftertreatment particulate matter sensor. | Possible reduced engine performance.
Aftertreatment Particulate Sensor Circuit

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) lost communication with the aftertreatment particulate matter sensor via the J1939 data link.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Supply wire open or shorted to ground.
  • Sensor return wire open.
  • An open or short circuit in the SAE J1939 datalink circuit

Malfunctioning aftertreatment particulate matter sensor

For intermittent power supply and data link communication issues with aftertreatment components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing, or intermittent connections.

Refer to Troubleshooting Fault Code 6688 .

Last Modified: 05-Dec-2021


Intake Manifold 1 Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 6725

Intake Manifold 1 Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6725 PID: SPN: 102 FMI: 0/15 LAMP: Amber SRT: | The intake manifold boost pressure reading is higher than expected for the engine operating conditions. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure reading was higher than expected for the engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value of the intake manifold pressure reading is used.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, first ensure the engine coolant temperature is above 70 °C or 158 °F. Operate the engine if necessary.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault are:

A damaged turbocharger speed sensor

A damaged barometric pressure sensor

A damaged turbocharger compressor intake temperature sensor.

Refer to Troubleshooting Fault Code 6725.

Last Modified: 25-May-2019


Aftertreatment 1 Diesel Particulate Filter 1 Soot Sensor ECU Internal Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 6735

Aftertreatment 1 Diesel Particulate Filter 1 Soot Sensor ECU Internal Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6735 PID: SPN: 5569 FMI: 0/16 LAMP: None SRT: | High internal temperature detected in the aftertreatment diesel particulate filter soot sensor module. | None on performance.
Aftertreatment Particulate Sensor Circuit

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter soot sensor module reported the internal circuit board temperature was too high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates the internal temperature of the aftertreatment diesel particulate filter soot sensor module was too high. Troubleshoot the exhaust system for leaks, missing heat shields, or dirt and debris that could lead to overheating of the aftertreatment diesel particulate filter soot sensor module.

Refer to Troubleshooting Fault Code 6735 .

Last Modified: 05-Dec-2021


Navigation Control Module - Abnormal Update Rate

FAULT CODE 6753

Navigation Control Module - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6753 PID: SPN: 7936 FMI: 9/9 LAMP: None SRT: | Loss of communication with the Route Parameter Manager Module or OEM Predictive Cruise Control module. | Predictive cruise control will not operate. Standard cruise control may not operate.
SAE J1939 Datalink

Circuit Description

The Route Parameter Manager is an electronic module that communicates the Look-Ahead route data to the ECM. The ECM utilizes the Look-Ahead route data to calculate the necessary information to support the Advanced Dynamic Efficient Powertrain Technology (ADEPT™) electronic features. This occurs automatically when the module is properly installed on the J1939 vehicle network. When a Route Parameter Manager is detected, Cummins® Predictive Cruise Control is selected. Cummins® Predictive Cruise Control can also be enabled by approved OEM predictive cruise control module.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

The predictive cruise control will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 2 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • The Route Parameter Manager Module or the OEM predictive cruise control module is not receiving power.
  • Certain ADEPT™ parameters enabled without a Route Parameter Manager Module or OEM predictive cruise control module installed
  • Open circuit in the power supply wire.
  • Rapid cycling of the keyswitch
  • An open or short circuit on the J1939 data link circuit between the ECM and the Route Parameter Manager Module or between the ECM and the OEM predictive cruise control module.
  • Intermittent communications between the ECM and the Route Parameter Manager Module or between the ECM and the OEM predictive cruise control module.
  • A damaged termination resistor in the J1939 data link.
Refer to Troubleshooting Fault Code 6753 .

Last Modified: 19-Apr-2020


Intake Manifold 1 Pressure - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 6864

Intake Manifold 1 Pressure - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6864 PID: SPN: 102 FMI: 1/17 LAMP: None SRT: | Low intake manifold pressure detected. | Possible reduced engine performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure reading was below the expected level for the engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, it may be necessary to operate the vehicle on a chassis dynamometer or to drive the vehicle in order to get the engine load high enough for the diagnostic to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A damaged turbocharger speed sensor

A malfunctioning barometric air pressure sensor

Leaks in the charge air system plumbing

A malfunctioning variable geometry turbocharger

Refer to Troubleshooting Fault Code 6864.

Last Modified: 25-May-2019


Turbocharger 1 Speed - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 687

Turbocharger 1 Speed - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 687 PID: P103 SPN: 103 FMI: 1/18 LAMP: Amber SRT: | Low turbocharger speed detected by the ECM. | Possible reduced engine performance.
Turbocharger Speed Sensor Circuit

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. The target on the turbocharger shaft is a ground flat in the center of the shaft. As the flat on the turbocharger shaft spins past the speed sensor, a signal is generated. The Engine Control Module (ECM) interprets this signal and converts it to a turbocharger speed reading.

Component Location

The turbocharger speed sensor is mounted in the center housing of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the turbocharger speed was less than 600 rpm for more than 1 second when the engine speed was greater than 1200 rpm.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The ECM will estimate the turbocharger speed.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Items that can cause this fault code include:

Damaged turbocharger speed sensor

Damaged engine harness

Damaged ECM.

Operating the engine at idle or high idle while stationary will not create enough load to maintain boost pressure at 1.19 times ambient pressure for 30 consecutive seconds. .

Although it is possible for a damaged ECM to be the root cause of this fault code, it is highly unlikely. ECM replacement should only be considered as a last resort, if no other repairs are successful in clearing the fault code.

In very rare cases, it has been shown that the turbocharger can cause this fault code to come active and turbocharger replacement may be the only way to clear the fault code.

Refer to Troubleshooting Fault Code 687.

Last Modified: 25-May-2019


Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 689

Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 689 PID: P190 SPN: 190 FMI: 2/2 LAMP: Amber SRT: | The ECM has detected an error in the engine speed signal. | Possible reduced engine performance.
Engine Crankshaft Speed/Position Circuit

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position sensor is located at the front of the engine and is bolted to the front cover.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of the crankshaft speed/position sensor while the engine was running.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

The backup engine speed sensor will be used by the ECM for the engine speed signal.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Causes of this fault include:

Open or short circuit of the +5-VDC supply, signal, or return wire in the engine harness

Damaged or malfunctioning engine speed sensor

Damaged tone wheel

Sensor air gap that is too small or too large.

Refer to Troubleshooting Fault Code 689.

Last Modified: 25-May-2019


Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 691

Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 691 PID: P351 SPN: 1172 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the turbocharger compressor intake air temperature circuit. | Possible reduced engine performance.
Turbocharger Compressor Intake Temperature Sensor Circuit

Circuit Description

The compressor intake air temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the compressor intake of the turbocharger. The engine control module (ECM) supplies 5-VDC to the compressor intake temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the air temperature.

Component Location

The turbocharger compressor intake temperature sensor is located in the compressor inlet of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the compressor intake temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the compressor intake temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The turbocharger compressor intake air temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active. Before troubleshooting Fault Code 691, check for multiple fault codes. An extension harness between the main engine harness and the turbocharger compressor intake temperature sensor can be used depending on the turbocharger arrangement.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor

Open signal circuit or short circuit to a voltage source

Damaged sensor.

Refer to Troubleshooting Fault Code 691.

Last Modified: 25-May-2019


Accelerator Pedal Position 1 - Out of Calibration

FAULT CODE 6919

Accelerator Pedal Position 1 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6919 PID: SPN: 91 FMI: 13/13 LAMP: Amber SRT: | The ECM expected information from a multiplexed device but only received a portion of the necessary information. | At least one multiplexed device will not operate properly.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) received an invalid J1939 data link message from a multiplexed device for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault can occur when the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing.

It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 6919 .

Last Modified: 13-Oct-2021


Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 692

Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 692 PID: P351 SPN: 1172 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the turbocharger compressor intake air temperature circuit. | Possible reduced engine performance.
Turbocharger 1 Compressor Intake Temperature Sensor Circuit

Circuit Description

The turbocharger compressor intake temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the compressor intake of the turbocharger. The engine control module (ECM) supplies 5-VDC to the compressor intake temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the air temperature.

Component Location

The turbocharger compressor intake temperature sensor is located in the compressor inlet of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the compressor intake temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the compressor intake temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The turbocharger compressor intake air temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active. Before troubleshooting Fault Code 692, check for multiple fault codes. An extension harness between the main engine harness and the turbocharger compressor intake temperature sensor can be used depending on the turbocharger arrangement.

Possible causes of this fault code include:

Signal circuit shorted to ground in the harness

Signal circuit shorted to return or ground in the sensor

Damaged sensor.

Refer to Troubleshooting Fault Code 692.

Last Modified: 25-May-2019


Turbocharger 1 Compressor Intake Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 693

Turbocharger 1 Compressor Intake Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 693 PID: P351 SPN: 1172 FMI: 2/2 LAMP: Amber SRT: | A temperature too high or low for the operating conditions has been detected by the turbocharger compressor intake temperature sensor. | Possible reduced engine performance.
Turbocharger 1 Compressor Intake Temperature Sensor Circuit

Circuit Description

The turbocharger compressor intake temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the compressor intake of the turbocharger. The engine control module (ECM) supplies 5-VDC to the compressor intake temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the air temperature.

Component Location

The turbocharger compressor intake temperature sensor is located in the compressor inlet of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic consists of two parts:

The first part runs when the keyswitch is turned to the ON position after a 8 hour cold soak, during which the keyswitch has been turned OFF.

The second part runs continuously while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the compressor intake temperature reading was too high or too low for the engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

A default value for the compressor intake temperature reading is used.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • If the fault code does not go inactive, it may be necessary to perform a 8 hour cold soak with the key OFF, then turn the keyswitch to the ON position so that the key ON portion of the diagnostic will run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Stuck in-range compressor intake temperature sensor

High resistance in the compressor intake temperature sensor signal or return lines

ECM malfunction.

Refer to Troubleshooting Fault Code 693.

Last Modified: 25-May-2019


Source Address of Active or Pending Transmission Requested Gear - Abnormal Update Rate

FAULT CODE 7286

Source Address of Active or Pending Transmission Requested Gear - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 7286 PID: SPN: 8613 FMI: 9/9 LAMP: None SRT: | The ECM expected information from a multiplexed device but did not receive it soon enough or did not receive it at all. | At least one multiplexed device will not operate properly.
SAE J1939 Data Link Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins ECM and used for controlling the engine. The Cummins ECM and OEM VECUs must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

The Engine Control Module (ECM) detected an open or short circuit condition in the J1939 data link harness.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices can possibly not function as desired.

This fault can occur for the following reasons:

  • When the ECM is set up properly (components enabled and OEM VECU or transmission ECU source addressed correctly) to receive information from an OEM VECU or transmission ECU, but the OEM VECU or transmission ECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the ECM, but the OEM VECU or transmission ECU source address of the VECU or transmission ECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU or transmission ECU is not set up to transmit the multiplexed component message.
  • This fault can also be caused by a damaged J1939 data link connection between the OEM VECU or transmission ECU and Cummins ECM, a damaged connection between the component and the OEM VECU or transmission ECU, damaged OEM VECU, transmission ECU, or damaged Cummins ECM. It can become necessary to contact the OEM or Transmission supplier for proper multiplexing configuration.

It is possible to use the recommended Cummins electronic service tool or equivalent to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 7286.

Last Modified: 25-May-2019


Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 731

Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 731 PID: S64 SPN: 723 FMI: 7/7 LAMP: Amber SRT: | Engine position signal from the crankshaft position sensor and camshaft position sensor do not match. | Possible reduced engine performance.
Crankshaft Speed/Position and Camshaft Speed/Postion Sensor Circuits

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position and camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankshaft position does not match the camshaft position signal input to the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Active and stationary regeneration of the diesel particulate filter will be disabled.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The ECM monitors the position of the missing tooth on the crankshaft speed sensor target and the camshaft speed sensor target. If the two positions do not match, the ECM then determines that there is a mechanical misalignment between the two sensors.

Possible causes of this fault code include:

Engine speed sensor rings that are loose or not aligned correctly

Mechanical misalignment.

Refer to Troubleshooting Fault Code 731.

Last Modified: 25-May-2019


Injector Metering Rail 1 Pressure - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 755

Injector Metering Rail 1 Pressure - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 755 PID: P157 SPN: 157 FMI: 7/7 LAMP: Amber SRT: | The ECM has detected a difference in the 2 fuel rail pressure signals. | Possible reduced engine performance.
Injector Metering Rail Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the fuel rail pressure sensor using a dedicated sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel rail pressure sensor provides a primary fuel pressure signal to the ECM on the fuel rail pressure sensor signal 1 circuit. The sensor also provides a secondary fuel pressure sensor signal on the fuel rail pressure signal 2 circuit. This sensor signal voltage changes based on the pressure in the fuel rail. The ECM will detect a high signal voltage at high rail pressure conditions. The ECM will detect a low signal voltage during low rail pressure conditions.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel pump actuator is mounted on the fuel pump. The fuel pressure sensor is mounted in the high pressure fuel rail. The fuel pressure relief valve is mounted on the high pressure fuel rail.

Conditions for Running the Diagnostics

The second part runs continuously while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the difference between the fuel rail 1 pressure signal and the fuel rail 2 pressure signal was greater than a threshold for 2 consecutive trips.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) after the diagnostic fails on two consecutive trips.

A default value for the fuel rail pressure reading is used.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning fuel rail pressure sensor

Refer to Troubleshooting Fault Code 755.

Last Modified: 25-May-2019


Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 778

Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 778 PID: S64 SPN: 723 FMI: 2/2 LAMP: Amber SRT: | The ECM has detected a loss of signal from the camshaft position sensor. | Possible reduced engine performance.
Engine Camshaft Speed/Position Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine camshaft speed/position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The camshaft speed/position sensor provides a signal to the ECM on the camshaft speed/position sensor signal circuit. This sensor generates a signal to the ECM as the camshaft speed indicator lobe moves past the sensor. The ECM interprets this signal into an engine speed reading and determines engine position. This sensor is used as a backup sensor if the primary engine crankshaft speed/position signal is lost.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of the camshaft speed/position sensor while the engine was running.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Exhaust gas recirculation (EGR) valve operation will be disabled.

Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Causes of this fault include:

Open or short circuit of the 5 volt supply, signal, or return wire in the engine harness.

Damaged or malfunctioning camshaft position sensor.

Damaged speed indicator lobe.

Sensor air gap that is too large or small.

Refer to Troubleshooting Fault Code 778.

Last Modified: 25-May-2019


Auxiliary Equipment Sensor Input 3 - Root Cause Not Known

FAULT CODE 779

Auxiliary Equipment Sensor Input 3 - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 779 PID: S51 SPN: 703 FMI: 11/11 LAMP: Amber SRT: | Auxiliary Equipment Sensor Input 3 - Root Cause Not Known | Possible reduced engine performance.

Circuit Description

The original equipment manufacturer (OEM) has the option of wiring a pressure or temperature sensor input to the Cummins engine control module (ECM). A specific calibration is then created to recognize this pressure or temperature sensor input. This fault code is activated when the pressure or temperature input from the OEM sensor exceeds the engine protection limit defined by the OEM. Depending on OEM requirements, an Engine Protection derate can be associated with this fault code.

Component Location

The OEM pressure sensor input and location will vary. Refer to the OEM service manual for sensor location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine protection limit for the OEM input device was exceeded.

Action Taken When the Fault Code is Active

The regulated derate conditions may vary depending on the OEM and local regulations.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This fault code is activated when the pressure or temperature input from the OEM sensor exceeds the engine protection limit defined by the OEM. An engine power derate is possible, depending on the OEM application.

Refer to Troubleshooting Fault Code 779 .

Last Modified: 20-Jul-2019


Adaptive Cruise Control Mode - Data Erratic, Intermittent, or Incorrect

FAULT CODE 784

Adaptive Cruise Control Mode - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 784 PID: S145 SPN: 1590 FMI: 2/2 LAMP: None SRT: | Loss of communication with adaptive cruise control. | Adaptive cruise control will not operate. Standard cruise control may not operate.
SAE J1939 Datalink Circuit

Circuit Description

The adaptive cruise control system sends commands to the ECM via the J1939 data link to limit engine speed and maintain a set following distance behind a vehicle travelling more slowly than the current cruise control set speed.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive an expected message from the Adaptive Cruise Control module.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

The adaptive cruise control will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If Adaptive Cruise Recovery is enabled, the driver can toggle the cruise enable switch from the OFF position to the ON position two times to get regular cruise control to operate and Fault Code 784 will go inactive. At the next key cycle, if the Heartbeat message is still not present, Fault Code 784 will go active.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 784.

Last Modified: 25-May-2019


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


NO TITLE

ISX15 CM2350 X101

Fault Code: 111 | SPN: 629 | FMI: 12
Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Troubleshooting Summary

  1. ECM calibration revision history check
  2. ECM Malfunction

1 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM Malfunction

Solution: S00008831

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 115 | SPN: 612 | FMI: 2
Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Battery or battery cables are malfunctioning
  2. Camshaft position sensor is damaged
  3. Reversed engine position sensors
  4. Engine crankshaft speed/position sensor check
  5. ECM calibration revision history check

1 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Camshaft position sensor is damaged

Solution: S00001226

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the camshaft position sensor.

Refer to Procedure 019-363

  • Inspect the camshaft position sensor for signs of damage, oil leak, and metal debris on the end of the sensor.

Specification

  • If the camshaft position sensor shows any signs of damage, then a malfunctioning camshaft position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace camshaft position sensor.

Refer to Procedure 019-363

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Reversed engine position sensors

Solution: S00000318

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine wiring harness.
  • Disconnect the crankshaft position sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually verify the camshaft engine position and crankshaft engine position sensor are connected properly.

Specification

  • If the sensors are not properly connected, then proceed to the repair section.

Linked Solutions

  • None

Repair

  • Connect the camshaft and crankshaft position sensors in the correct position.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Engine crankshaft speed/position sensor check

Solution: S00000684

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the crankshaft position sensor.
  • Inspect the crankshaft position sensor for signs of damage, oil leak, and metal debris on the end of the sensor.
  • Verify the crankshaft position sensor is connected properly.
  • Use the ratchet drive side of the socket tool that was used to removed the sensor from the engine, place it flush on the sensor so that the edge of the socket is on the edge of the sensor.
  • Monitor the crankshaft engine speed sensor state using the recommended Cummins® electronic service tool or equivalent and monitor (Engine Speed Main Sensor State) to check if the sensor state transitions.
  • Slowly slide the socket in a perpendicular direction to the marked line on the sensor or in a perpendicular direction to the mounting bracket of the sensor.

Specification

  • If any damage is found to the sensor, then proceed to the Repair section.
  • If the crankshaft position sensor is not connected properly, then proceed to the Repair section.
  • If the crankshaft position sensor state does NOT transition from high to low or low to high, or the state does NOT show triggered, then a malfunctioning crankshaft engine position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine crankshaft speed/position sensor.

Refer to Procedure 019-365

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 122 | SPN: 102 | FMI: 3
Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Intake manifold pressure sensor voltage check
  3. Intake manifold pressure sensor voltage check at the ECM
  4. Intake manifold pressure sensor circuit response
  5. Intake manifold pressure sensor circuit response at the ECM
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00006545

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Intake manifold pressure sensor voltage check

Solution: S00007820

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the intake manifold pressure sensor SUPPLY pin and the intake manifold pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Intake manifold pressure sensor voltage check at the ECM

Refer to S00000758

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Intake manifold pressure sensor voltage check at the ECM

Solution: S00000758

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the intake manifold pressure/temperature sensor SUPPLY pin and the intake manifold pressure/temperature sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Intake manifold pressure sensor circuit response

Solution: S00000411

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning intake manifold pressure sensor 1 has been detected if the following fault code became active with the sensor disconnected: 123

Linked Solutions

  • None

Repair

  • Replace the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Intake manifold pressure sensor circuit response at the ECM

Solution: S00000456

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 123
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 123

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 123 | SPN: 102 | FMI: 4
Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Intake manifold pressure sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00006545

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Intake manifold pressure sensor is malfunctioning

Solution: S00007822

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning intake manifold pressure/temperature sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 124 | SPN: 102 | FMI: 16
Intake Manifold 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Intake manifold pressure sensor voltage check
  3. Intake manifold pressure sensor voltage check at the ECM
  4. Intake manifold pressure sensor has carbon buildup
  5. Intake manifold pressure sensor stuck in-range
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000043

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold: 122, 123, 125
  • Barometric pressure: 221, 222, 295
  • Voltage: 1938
  • Turbocharger: 595, 687, 691, 692, 693, 1894, 1897, 1898, 1962, 1976, 2198, 2288, 2346, 2347, 2387, 2449, 2451, 2634, 2635, 2636, 3348, 6432
  • EGR: 1228, 1866, 1867, 1896, 1961, 2272, 2273, 2274, 2349, 2353, 2375, 2376, 2961, 2962, 3136, 3137, 3138, 3342, 3382
  • Fuel: 271, 272, 322, 323, 324, 325, 331, 332, 351, 451, 452, 483, 484, 553, 559, 775, 1139, 1141, 1142, 1143, 1144, 1145, 2222, 2223, 2265, 2266, 2311, 2372, 4691, 4726, 4727, 6258, 6259, 6339, 6341, 6342, 6343

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Intake manifold pressure sensor voltage check

Solution: S00007820

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the intake manifold pressure sensor SUPPLY pin and the intake manifold pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Intake manifold pressure sensor voltage check at the ECM

Refer to S00000758

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Intake manifold pressure sensor voltage check at the ECM

Solution: S00000758

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the intake manifold pressure/temperature sensor SUPPLY pin and the intake manifold pressure/temperature sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Intake manifold pressure sensor has carbon buildup

Solution: S00006329

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

  • Visually inspect the intake manifold pressure/temperature sensor tip for soot or carbon buildup.
  • Visually inspect the intake manifold pressure sensor for damage.
  • Visually inspect the intake manifold pressure sensor o-rings for damage.

Specification

  • If any carbon buildup is found, then proceed to the Repair section.
  • If nicks or cuts in or on the o-ring are identified, then a damaged intake manifold pressure/temperature sensor o-ring has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

  • Replace the intake manifold pressure/temperature sensor o-ring.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Intake manifold pressure sensor stuck in-range

Solution: S00002814

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the intake manifold pressure sensor.

Specification

  • A malfunctioning intake manifold air pressure sensor has been detected if the intake manifold air pressure is not reading within the following specification: 0 ± 6.8 Kpa [0 ± 1 psi], 0 ± 51 mm-Hg [0 ± 2 in- Hg]

Linked Solutions

  • None

Repair

  • Replace the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 125 | SPN: 102 | FMI: 18
Intake Manifold 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Restricted intake air filter
  3. Barometric air pressure sensor stuck in-range
  4. Intake manifold pressure sensor has carbon buildup
  5. Intake manifold pressure sensor stuck in-range
  6. Leaks in the intake air system
  7. Charge air cooler system leak
  8. High exhaust restriction
  9. Turbocharger is malfunctioning
  10. ECM calibration revision history check
  11. Intake manifold pressure sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000794

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold: 122, 123, 2973
  • Barometric pressure: 221, 222, 295
  • Turbocharger: 629, 687, 2387, 2449, 2634, 2635, 2636, 3348, 3616
  • EGR: 1228, 1896, 1898, 2198, 2272, 2349, 2353, 2357

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Restricted intake air filter

Solution: S00000025

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Specification

  • If the intake air filter is plugged, then a restricted intake air filter has been detected.

Linked Solutions

  • None

Repair

  • Replace the air filter.

Refer to OEM Service Manual

Refer to Procedure 010-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Barometric air pressure sensor stuck in-range

Solution: S00005632

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the barometric air pressure sensor

Specification

  • A malfunctioning barometric air pressure sensor has been detected if the barometric air pressure sensor is not within the following specification of local ambient air pressure: 51 mm HG [2 in HG]

Linked Solutions

  • None

Repair

  • Replace barometric air pressure sensor.

Refer to Procedure 019-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Intake manifold pressure sensor has carbon buildup

Solution: S00006329

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

  • Visually inspect the intake manifold pressure/temperature sensor tip for soot or carbon buildup.
  • Visually inspect the intake manifold pressure sensor for damage.
  • Visually inspect the intake manifold pressure sensor o-rings for damage.

Specification

  • If any carbon buildup is found, then proceed to the Repair section.
  • If nicks or cuts in or on the o-ring are identified, then a damaged intake manifold pressure/temperature sensor o-ring has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

  • Replace the intake manifold pressure/temperature sensor o-ring.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Intake manifold pressure sensor stuck in-range

Solution: S00002814

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the intake manifold pressure sensor.

Specification

  • A malfunctioning intake manifold air pressure sensor has been detected if the intake manifold air pressure is not reading within the following specification: 0 ± 6.8 Kpa [0 ± 1 psi], 0 ± 51 mm-Hg [0 ± 2 in- Hg]

Linked Solutions

  • None

Repair

  • Replace the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Leaks in the intake air system

Solution: S00008386

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.
  • Visually inspect the intake plumbing for possible air leaks.

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Charge air cooler system leak

Solution: S00008815

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the charge air cooler hoses for possible air leaks.
  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If a leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the charge air cooler.

Refer to Procedure 010-027

  • Repair or replace the charge air cooler hoses.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - High exhaust restriction

Solution: S00000324

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the exhaust restriction.

Refer to Procedure 011-009

Specification

  • If the exhaust restriction is not within specification, then a restriction in the exhaust has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Check the face of the aftertreatment diesel oxidation catalyst for plugging.

Refer to Procedure 011-049

  • Check the face of the aftertreatment diesel particulate filter for plugging.

Refer to Procedure 011-041

  • Check for deposits in the decomposition tube.

Refer to Procedure 011-062

  • Check the face of the aftertreatment SCR catalyst for plugging.

Refer to Procedure 011-036

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Turbocharger is malfunctioning

Solution: S00005253

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the intake and exhaust connections from the turbocharger.

Action

  • Inspect the turbocharger compressor and turbine blades for damage or wear.

Refer to Procedure 010-033

Specification

  • If any of the checks are not within specification, then a malfunctioning turbocharger has been detected.

Linked Solutions

  • None

Repair

  • Replace the turbocharger.

Refer to Procedure 010-033

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

11 - Intake manifold pressure sensor is malfunctioning

Solution: S00001048

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning intake manifold pressure/temperature sensor has been detected.

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 131 | SPN: 91 | FMI: 3
Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Accelerator pedal voltage check
  3. Accelerator pedal circuit check
  4. Accelerator pedal position sensor circuit response
  5. Accelerator pedal position sensor open circuit check
  6. Accelerator pedal position sensor circuit pin to pin short
  7. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000045

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 4: 2185, 2186

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Accelerator pedal voltage check

Solution: S00000444

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the accelerator pedal position 1 sensor SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Accelerator pedal circuit check

Refer to S00000549

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Accelerator pedal circuit check

Solution: S00000549

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Accelerator pedal position sensor circuit response

Solution: S00000368

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning accelerator pedal position sensor has been detected if the following fault code became active with the sensor disconnected: 132

Linked Solutions

  • None

Repair

  • Replace the accelerator pedal position sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Accelerator pedal position sensor open circuit check

Solution: S00000467

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Accelerator pedal position sensor circuit pin to pin short

Solution: S00000468

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 132 | SPN: 91 | FMI: 4
Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Accelerator pedal voltage check
  3. Accelerator pedal circuit check
  4. Accelerator pedal position sensor circuit response
  5. Accelerator pedal position sensor open circuit check
  6. Accelerator pedal position sensor circuit pin to ground short
  7. Accelerator pedal position sensor circuit pin to pin short
  8. Internal ECM Error

1 - Check for primary fault codes

Solution: S00000045

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 4: 2185, 2186

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Accelerator pedal voltage check

Solution: S00000444

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the accelerator pedal position 1 sensor SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Accelerator pedal circuit check

Refer to S00000549

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Accelerator pedal circuit check

Solution: S00000549

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Accelerator pedal position sensor circuit response

Solution: S00000369

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the accelerator pedal position sensor SUPPLY pin and the accelerator pedal position sensor SIGNAL pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning accelerator pedal position sensor has been detected if the following fault code became active with the jumper wire in place: 131

Linked Solutions

  • None

Repair

  • Replace the accelerator pedal position sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Accelerator pedal position sensor open circuit check

Solution: S00000467

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Accelerator pedal position sensor circuit pin to ground short

Solution: S00000448

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100K Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Accelerator pedal position sensor circuit pin to pin short

Solution: S00000468

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Internal ECM Error

Solution: S00001230

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 15-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 133 | SPN: 974 | FMI: 3
Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Remote accelerator pedal position sensor voltage check
  3. Remote accelerator pedal position sensor circuit check
  4. Remote accelerator pedal position sensor circuit response
  5. Remote accelerator pedal position sensor SIGNAL wire shorted to high source
  6. Remote accelerator pedal position sensor open circuit check
  7. Remote accelerator pedal position sensor circuit pin to pin short
  8. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000047

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1695, 1696

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Remote accelerator pedal position sensor voltage check

Solution: S00000441

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal position sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the accelerator pedal position 1 sensor SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM wiring harness.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Remote accelerator pedal position sensor circuit check

Refer to S00000995

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Remote accelerator pedal position sensor circuit check

Solution: S00000995

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the remote accelerator pedal position sensor SUPPLY pin at the remote accelerator pedal position sensor connector of the OEM wiring harness and the remote accelerator pedal position sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the remote accelerator pedal position sensor RETURN pin at the remote accelerator pedal position sensor connector of the OEM wiring harness and the remote accelerator pedal position sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω
  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Remote accelerator pedal position sensor circuit response

Solution: S00000353

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning remote accelerator pedal position sensor has been detected if the following fault code become active with the remote accelerator pedal position sensor disconnected: 134

Linked Solutions

  • None

Repair

  • Replace the remote accelerator pedal assembly.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Remote accelerator pedal position sensor SIGNAL wire shorted to high source

Solution: S00000452

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the remote accelerator pedal SIGNAL pin in the OEM wiring harness ECM connector 2 and SUPPLY pin in the OEM wiring harness ECM connector 2.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Remote accelerator pedal position sensor open circuit check

Solution: S00000449

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM harness ECM connector RETURN pin and the OEM wiring harness accelerator pedal connector RETURN pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Remote accelerator pedal position sensor circuit pin to pin short

Solution: S00000450

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the remote accelerator pedal SIGNAL pin in the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 134 | SPN: 974 | FMI: 4
Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Remote accelerator pedal position sensor voltage check
  3. Remote accelerator pedal position sensor circuit check
  4. Remote accelerator pedal position sensor circuit response
  5. Remote accelerator pedal position sensor open circuit check
  6. Remote accelerator pedal position sensor circuit pin to ground short
  7. Remote accelerator pedal position sensor circuit pin to pin short
  8. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000048

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1695, 1696

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Remote accelerator pedal position sensor voltage check

Solution: S00000441

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal position sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the accelerator pedal position 1 sensor SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM wiring harness.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Remote accelerator pedal position sensor circuit check

Refer to S00000995

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Remote accelerator pedal position sensor circuit check

Solution: S00000995

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the remote accelerator pedal position sensor SUPPLY pin at the remote accelerator pedal position sensor connector of the OEM wiring harness and the remote accelerator pedal position sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the remote accelerator pedal position sensor RETURN pin at the remote accelerator pedal position sensor connector of the OEM wiring harness and the remote accelerator pedal position sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω
  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Remote accelerator pedal position sensor circuit response

Solution: S00000370

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the remote accelerator pedal position sensor SUPPLY pin and the remote accelerator pedal position sensor SIGNAL pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning remote accelerator pedal position sensor has been detected if the following fault code became active with the jumper wire in place: 133

Linked Solutions

  • None

Repair

  • Replace the remote accelerator pedal assembly.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Remote accelerator pedal position sensor open circuit check

Solution: S00000453

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the remote accelerator pedal position sensor SIGNAL pin at the remote accelerator pedal position sensor connector of the OEM wiring harness and the remote accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Remote accelerator pedal position sensor circuit pin to ground short

Solution: S00000454

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the remote accelerator pedal SUPPLY pin in the OEM wiring harness ECM connector and ground.
  • Measure the resistance between the remote accelerator pedal SIGNAL pin in the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Remote accelerator pedal position sensor circuit pin to pin short

Solution: S00000450

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the remote accelerator pedal SIGNAL pin in the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 135 | SPN: 100 | FMI: 3
Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Lubricating oil pressure sensor voltage check
  3. Lubricating oil pressure sensor voltage check at the ECM
  4. Lubricating oil pressure sensor circuit response
  5. Lubricating oil pressure sensor circuit response at the ECM
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000899

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Lubricating oil pressure sensor voltage check

Solution: S00000455

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lubricating oil pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage from the lubricating oil pressure SUPPLY pin to the lubricating oil pressure RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Lubricating oil pressure sensor voltage check at the ECM

Refer to S00000745

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Lubricating oil pressure sensor voltage check at the ECM

Solution: S00000745

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage from the oil pressure SUPPLY pin to the oil pressure RETURN pin at the ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Lubricating oil pressure sensor circuit response

Solution: S00000376

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lubricating oil pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning lubricating oil pressure sensor has been detected if the following fault code became active with the sensor disconnected: 141

Linked Solutions

  • None

Repair

  • Replace the lubricating oil pressure sensor.

Refer to Procedure 019-066

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Lubricating oil pressure sensor circuit response at the ECM

Solution: S00001231

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 141
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 141

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 141 | SPN: 100 | FMI: 4
Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Lubricating oil pressure sensor voltage check
  3. Lubricating oil pressure sensor voltage check at the ECM
  4. Lubricating oil pressure sensor circuit response
  5. Lubricating oil pressure sensor circuit response at the ECM
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000899

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Lubricating oil pressure sensor voltage check

Solution: S00000455

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lubricating oil pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage from the lubricating oil pressure SUPPLY pin to the lubricating oil pressure RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Lubricating oil pressure sensor voltage check at the ECM

Refer to S00000745

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Lubricating oil pressure sensor voltage check at the ECM

Solution: S00000745

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage from the oil pressure SUPPLY pin to the oil pressure RETURN pin at the ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Lubricating oil pressure sensor circuit response

Solution: S00000377

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lubricating oil pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the lubricating oil pressure sensor SUPPLY pin and the lubricating oil pressure sensor SIGNAL pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning lubricating oil pressure sensor has been detected if the following fault code became active with the jumper wire in place: 135

Linked Solutions

  • None

Repair

  • Replace the lubricating oil pressure sensor.

Refer to Procedure 019-066

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Lubricating oil pressure sensor circuit response at the ECM

Solution: S00000445

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the lubricating oil pressure sensor SUPPLY pin and the lubricating oil pressure sensor SIGNAL pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 135
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 135

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 143 | SPN: 100 | FMI: 18
Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Technical Service Bulletin is available
  3. Basic oil system checks
  4. Contaminated lubricating oil
  5. Lubricating oil pressure sensor stuck in-range
  6. Lubricating oil filter plugged
  7. Lubricating oil pressure relief valve is malfunctioning
  8. Loose or broken lubricating oil suction tube
  9. Main lubricating oil pressure regulator is malfunctioning
  10. Lubricating oil pump is malfunctioning
  11. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000078

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Oil: 135, 141
  • Sensor supply 1: 352, 386

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Technical Service Bulletin is available

Solution: S00009809

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb160024

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Basic oil system checks

Solution: S00000474

Verification

Conditions

  • Turn keyswitch OFF.

Action

CAUTION: Do not start an engine that has low oil pressure fault codes/complaints until it has been verified that the oil level is correct and that the oil filter is not plugged. Internal engine damage can result from low or no oil pressure.

  • Interview the operator about the complaint. Ask if the fault occurs when climbing or descending a steep hill to determine if engine angularity is a potential issue.
  • Visually inspect engine for external lubricating oil leaks.
  • Check that the lubricating oil level is correct.

Refer to OEM Service Manual

Specification

  • If an oil leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the component that is the source of the leak.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Contaminated lubricating oil

Solution: S00000462

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Determine if the lubrication oil is contaminated with coolant or fuel.

Specification

  • If the oil level is high and coolant contamination has been detected, then reset the search to Coolant in the oil.
  • If the oil level is high and fuel contamination has been detected, then reset the search to Fuel in the oil.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Lubricating oil pressure sensor stuck in-range

Solution: S00000342

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the sensor for damage.
  • Install a mechanical gauge on the engine.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the sensor reading with the recommended Cummins® electronic service tool or equivalent to a mechanical gauge.
  • If the lubricating oil pressure does not meet the minimum specification, do not perform any engine running tests.

Refer to Procedure 018-017

  • Operate engine at rated rpm.
  • Monitor the lubricating oil pressure sensor.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the mechanical gauge must be within: 17 kPa [2.5 psi]
  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the lubricating oil pressure sensor.

Refer to Procedure 019-066

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Lubricating oil filter plugged

Solution: S00000466

Verification

Conditions

  • Turn keyswitch ON.
  • Engine running.
  • Lubricating oil pressure must be above the minimum specification.

Refer to Procedure 018-017

Action

  • If the lubricating oil pressure does not meet the minimum specification, then skip this solution and do not perform the test to measure oil filter differential pressure.
  • Measure the differential pressure drop across the lubricating oil filter.

Refer to Procedure 007-095

Specification

  • If the lubrication oil filter differential pressure is not within the specification, then a plugged lubrication oil filter has been detected.

Refer to Procedure 007-095

Linked Solutions

  • None

Repair

  • Replace the lubricating oil filter.

Refer to Procedure 007-013

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Lubricating oil pressure relief valve is malfunctioning

Solution: S00000471

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the lubricating oil pressure relief valve.

Refer to Procedure 007-021

Specification

  • If the lubricating oil pressure relief valve does not meet specification, then a malfunctioning lubricating oil pressure relief valve has been detected.

Refer to Procedure 007-021

Linked Solutions

  • None

Repair

  • Replace the lubricating oil pressure relief valve.

Refer to Procedure 007-021

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Loose or broken lubricating oil suction tube

Solution: S00000464

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the lubricating oil pan.

Refer to Procedure 007-025

  • Inspect the lubricating oil suction tube and o-ring for damage.

Refer to Procedure 007-035

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the lubricating oil suction tube o-ring or the damaged lubricating oil suction tube.

Refer to Procedure 007-035

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Main lubricating oil pressure regulator is malfunctioning

Solution: S00000469

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the main lubricating oil pressure regulator assembly.

Refer to Procedure 007-031

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the main lubricating oil pressure regulator assembly.

Refer to Procedure 007-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - Lubricating oil pump is malfunctioning

Solution: S00000472

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the lubricating oil pump.

Refer to Procedure 007-031

  • Inspect the lubricating oil pump.

Refer to Procedure 007-031

If the lubricating oil pump was found to be damaged, then inspect the lubricating oil filter for metal.

Specification

  • If damaged, loose or worn gears are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the lubricating oil pump.

Refer to Procedure 007-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

11 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 144 | SPN: 110 | FMI: 3
Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Coolant temperature sensor resistance check
  2. Coolant temperature sensor circuit response
  3. Engine coolant temperature sensor circuit response check at the ECM

1 - Coolant temperature sensor resistance check

Solution: S00000127

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and engine coolant temperature sensor RETURN pin at the engine coolant temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the resistance is not within the following specification: 180 - 160k Ω

Linked Solutions

  • None

Repair

  • Replace the coolant temperature sensor.

Refer to Procedure 019-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Coolant temperature sensor circuit response

Solution: S00000128

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the engine coolant temperature sensor SIGNAL pin and the engine coolant temperature sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine coolant temperature sensor has been detected if the following fault code become active with the jumper wire in place: 145

Linked Solutions

  • None

Repair

  • Replace the engine coolant temperature sensor.

Refer to Procedure 019-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine coolant temperature sensor circuit response check at the ECM

Solution: S00000175

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the engine coolant temperature sensor SIGNAL pin and the engine coolant temperature sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 145
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 145

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 145 | SPN: 110 | FMI: 4
Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Coolant temperature sensor resistance check
  2. Coolant temperature sensor circuit response
  3. Engine coolant temperature sensor circuit response check at the ECM

1 - Coolant temperature sensor resistance check

Solution: S00000127

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and engine coolant temperature sensor RETURN pin at the engine coolant temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the resistance is not within the following specification: 180 - 160k Ω

Linked Solutions

  • None

Repair

  • Replace the coolant temperature sensor.

Refer to Procedure 019-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Coolant temperature sensor circuit response

Solution: S00000313

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine coolant temperature sensor has been detected if the following fault code became active with the sensor disconnected: 144

Linked Solutions

  • None

Repair

  • Replace the engine coolant temperature sensor.

Refer to Procedure 019-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine coolant temperature sensor circuit response check at the ECM

Solution: S00000319

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 144
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 144

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 146 | SPN: 110 | FMI: 16
Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Coolant level check
  2. Cooling fan component inspection
  3. Radiator is externally obstructed
  4. Radiator shutters malfunctioning (if equipped)
  5. Coolant temperature sensor resistance check
  6. Fan clutch operates incorrectly
  7. Thermostat is malfunctioning
  8. Out-of-chassis opening temperature test
  9. Malfunctioning cooling fan drive or cooling fan controls
  10. Combustion gases entering the cooling system
  11. ECM calibration revision history check

1 - Coolant level check

Solution: S00003142

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the coolant level.
  • Perform the Coolant System Pressure Test.

Refer to Procedure 008-018

  • Visually inspect for external coolant leaks.

Specification

  • If the coolant level is low and there are signs of external coolant leaks, then reset the search to external coolant leak.
  • If the coolant level is low and there are no signs of external coolant leaks, then reset the search to internal coolant leak.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2 - Cooling fan component inspection

Solution: S00001686

Verification

Conditions

  • Turn keyswitch OFF.

Action

Inspect the following components if applicable:

  • Visually inspect the cooling fan and cooling fan blades.
  • Visually inspect the cooling fan shroud.
  • Visually inspect the recirculation baffles.
  • Inspect the cooling fan belt.

Refer to Procedure 008-002

  • Visually inspect the cooling fan hub assembly.
  • Visually inspect the automatic cooling fan belt tensioner.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Radiator is externally obstructed

Solution: S00000485

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the radiator for damage.
  • Visually inspect the radiator for any type of external obstruction.
  • Check for closed cold weather radiator cover or winterfront.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the restricted radiator.

Refer to OEM Service Manual

  • Remove the obstruction.

Refer to OEM Service Manual

  • Repair or replace cold weather radiator cover or winterfront.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Radiator shutters malfunctioning (if equipped)

Solution: S00000484

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Manually operate the radiator shutters.

Refer to OEM Service Manual

  • Check the shutterstat setting.

Refer to OEM Service Manual

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning radiator shutters or shutterstat.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Coolant temperature sensor resistance check

Solution: S00000127

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and engine coolant temperature sensor RETURN pin at the engine coolant temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the resistance is not within the following specification: 180 - 160k Ω

Linked Solutions

  • None

Repair

  • Replace the coolant temperature sensor.

Refer to Procedure 019-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Fan clutch operates incorrectly

Solution: S00006090

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the adjustable parameters settings.

Ensure the following adjustable parameters are set correctly for the application:

  • Fan Control Logic.
  • Fan Control Switch.
  • Air Conditioner Pressure Switch Input.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Fan Override Test.
  • Verify that the fan operates correctly.
  • Verify the fan is engaging at the correct engine temperature.

Refer to Procedure 008-027

Refer to OEM Service Manual

Specification

  • If the fan does not engage at the correct engine temperature, then a malfunctioning fan clutch has been detected.

Linked Solutions

  • None

Repair

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to Procedure 008-027

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Thermostat is malfunctioning

Solution: S00000785

Verification

Conditions

  • Engine running.

Action

  • Allow the engine to reach operating temperature.
  • Check the thermostat opening temperature with an infrared temperature gun.
  • Check the coolant thermostat for proper operation.

Refer to Procedure 008-013

  • Check for a damaged or leaking thermostat seal.

Refer to Procedure 008-013

  • If a temperature gun is not available or if the temperature gun reading is above the correct thermostat opening temperature, then proceed to Linked Solutions section.

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • Out-of-chassis opening temperature test

Refer to S00001359

Repair

  • Replace the engine coolant thermostat.

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7.1 - Out-of-chassis opening temperature test

Solution: S00001359

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the out-of-chassis opening temperature test.

Refer to Procedure 008-013

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine coolant thermostat.

Refer to Procedure 008-013

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

8 - Malfunctioning cooling fan drive or cooling fan controls

Solution: S00000490

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Monitor the cooling fan operation.

Refer to Procedure 008-027

Specification

  • If the cooling fan operation is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.
  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Combustion gases entering the cooling system

Solution: S00000470

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check for air or combustion gases in the cooling system.

Refer to Procedure 008-019

Specification

  • If air bubbles are found during the combustion gas test and did not change colors (Blue to Yellow or Green), then a malfunctioning air compressor has been determined.
  • If the combustion gas test changed colors (Blue to Yellow or Green), then a malfunctioning engine cylinder head gasket has been determined.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the air compressor cylinder head.

Refer to Procedure 012-007

  • Replace the cylinder head gasket.

Refer to Procedure 002-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 151 | SPN: 110 | FMI: 0
Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Coolant level check
  2. Cooling fan component inspection
  3. Radiator is externally obstructed
  4. Radiator shutters malfunctioning (if equipped)
  5. Coolant temperature sensor resistance check
  6. Fan clutch operates incorrectly
  7. Thermostat is malfunctioning
  8. Out-of-chassis opening temperature test
  9. Malfunctioning cooling fan drive or cooling fan controls
  10. Combustion gases entering the cooling system
  11. ECM calibration revision history check

1 - Coolant level check

Solution: S00003142

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the coolant level.
  • Perform the Coolant System Pressure Test.

Refer to Procedure 008-018

  • Visually inspect for external coolant leaks.

Specification

  • If the coolant level is low and there are signs of external coolant leaks, then reset the search to external coolant leak.
  • If the coolant level is low and there are no signs of external coolant leaks, then reset the search to internal coolant leak.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2 - Cooling fan component inspection

Solution: S00001686

Verification

Conditions

  • Turn keyswitch OFF.

Action

Inspect the following components if applicable:

  • Visually inspect the cooling fan and cooling fan blades.
  • Visually inspect the cooling fan shroud.
  • Visually inspect the recirculation baffles.
  • Inspect the cooling fan belt.

Refer to Procedure 008-002

  • Visually inspect the cooling fan hub assembly.
  • Visually inspect the automatic cooling fan belt tensioner.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Radiator is externally obstructed

Solution: S00000485

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the radiator for damage.
  • Visually inspect the radiator for any type of external obstruction.
  • Check for closed cold weather radiator cover or winterfront.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the restricted radiator.

Refer to OEM Service Manual

  • Remove the obstruction.

Refer to OEM Service Manual

  • Repair or replace cold weather radiator cover or winterfront.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Radiator shutters malfunctioning (if equipped)

Solution: S00000484

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Manually operate the radiator shutters.

Refer to OEM Service Manual

  • Check the shutterstat setting.

Refer to OEM Service Manual

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning radiator shutters or shutterstat.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Coolant temperature sensor resistance check

Solution: S00000127

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and engine coolant temperature sensor RETURN pin at the engine coolant temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the resistance is not within the following specification: 180 - 160k Ω

Linked Solutions

  • None

Repair

  • Replace the coolant temperature sensor.

Refer to Procedure 019-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Fan clutch operates incorrectly

Solution: S00006090

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the adjustable parameters settings.

Ensure the following adjustable parameters are set correctly for the application:

  • Fan Control Logic.
  • Fan Control Switch.
  • Air Conditioner Pressure Switch Input.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Fan Override Test.
  • Verify that the fan operates correctly.
  • Verify the fan is engaging at the correct engine temperature.

Refer to Procedure 008-027

Refer to OEM Service Manual

Specification

  • If the fan does not engage at the correct engine temperature, then a malfunctioning fan clutch has been detected.

Linked Solutions

  • None

Repair

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to Procedure 008-027

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Thermostat is malfunctioning

Solution: S00000785

Verification

Conditions

  • Engine running.

Action

  • Allow the engine to reach operating temperature.
  • Check the thermostat opening temperature with an infrared temperature gun.
  • Check the coolant thermostat for proper operation.

Refer to Procedure 008-013

  • Check for a damaged or leaking thermostat seal.

Refer to Procedure 008-013

  • If a temperature gun is not available or if the temperature gun reading is above the correct thermostat opening temperature, then proceed to Linked Solutions section.

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • Out-of-chassis opening temperature test

Refer to S00001359

Repair

  • Replace the engine coolant thermostat.

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7.1 - Out-of-chassis opening temperature test

Solution: S00001359

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the out-of-chassis opening temperature test.

Refer to Procedure 008-013

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine coolant thermostat.

Refer to Procedure 008-013

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

8 - Malfunctioning cooling fan drive or cooling fan controls

Solution: S00000490

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Monitor the cooling fan operation.

Refer to Procedure 008-027

Specification

  • If the cooling fan operation is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.
  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Combustion gases entering the cooling system

Solution: S00000470

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check for air or combustion gases in the cooling system.

Refer to Procedure 008-019

Specification

  • If air bubbles are found during the combustion gas test and did not change colors (Blue to Yellow or Green), then a malfunctioning air compressor has been determined.
  • If the combustion gas test changed colors (Blue to Yellow or Green), then a malfunctioning engine cylinder head gasket has been determined.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the air compressor cylinder head.

Refer to Procedure 012-007

  • Replace the cylinder head gasket.

Refer to Procedure 002-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 153 | SPN: 105 | FMI: 3
Engine Intake Manifold 1 Temperature - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Intake manifold temperature sensor circuit response
  2. Intake manifold temperature sensor circuit response check at the ECM
  3. ECM calibration revision history check

1 - Intake manifold temperature sensor circuit response

Solution: S00000354

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the intake manifold temperature sensor SIGNAL pin and the intake manifold temperature sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning intake manifold temperature sensor has been detected if the following fault code became active with the jumper wire in place: 154

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Intake manifold temperature sensor circuit response check at the ECM

Solution: S00000576

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the intake manifold temperature sensor SIGNAL pin and the intake manifold temperature sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 154
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 154

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 154 | SPN: 105 | FMI: 4
Engine Intake Manifold 1 Temperature - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Intake manifold temperature sensor circuit response
  2. Intake manifold temperature sensor circuit response check at the ECM
  3. ECM calibration revision history check

1 - Intake manifold temperature sensor circuit response

Solution: S00001234

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning intake manifold temperature sensor has been detected if the following fault code became active with the sensor disconnected: 153

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Intake manifold temperature sensor circuit response check at the ECM

Solution: S00000479

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 153
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 153

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 155 | SPN: 105 | FMI: 0
Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Cooling fan component inspection
  3. High intake manifold temperature basic checks
  4. Radiator is externally obstructed
  5. Fan clutch operates incorrectly
  6. Intake manifold temperature sensor stuck in-range
  7. Thermostat is malfunctioning
  8. Out-of-chassis opening temperature test
  9. Leaks in the intake air system
  10. Charge air cooler system leak
  11. Malfunctioning cooling fan drive or cooling fan controls
  12. Overhead component damaged or out of adjustment
  13. Turbocharger is malfunctioning
  14. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000050

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold temperature: 153, 154
  • Fan control circuit: 245, 2377

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Cooling fan component inspection

Solution: S00001686

Verification

Conditions

  • Turn keyswitch OFF.

Action

Inspect the following components if applicable:

  • Visually inspect the cooling fan and cooling fan blades.
  • Visually inspect the cooling fan shroud.
  • Visually inspect the recirculation baffles.
  • Inspect the cooling fan belt.

Refer to Procedure 008-002

  • Visually inspect the cooling fan hub assembly.
  • Visually inspect the automatic cooling fan belt tensioner.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - High intake manifold temperature basic checks

Solution: S00000459

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Refer to Procedure 010-031

  • Visually inspect the charge-air cooler for damage or debris blocking the air flow.

Refer to Procedure 010-027

  • Visually inspect the air conditioner condenser.

Refer to OEM Service Manual

  • Visually inspect the radiator fins for damage or debris blocking the air flow.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Radiator is externally obstructed

Solution: S00000485

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the radiator for damage.
  • Visually inspect the radiator for any type of external obstruction.
  • Check for closed cold weather radiator cover or winterfront.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the restricted radiator.

Refer to OEM Service Manual

  • Remove the obstruction.

Refer to OEM Service Manual

  • Repair or replace cold weather radiator cover or winterfront.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Fan clutch operates incorrectly

Solution: S00006090

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the adjustable parameters settings.

Ensure the following adjustable parameters are set correctly for the application:

  • Fan Control Logic.
  • Fan Control Switch.
  • Air Conditioner Pressure Switch Input.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Fan Override Test.
  • Verify that the fan operates correctly.
  • Verify the fan is engaging at the correct engine temperature.

Refer to Procedure 008-027

Refer to OEM Service Manual

Specification

  • If the fan does not engage at the correct engine temperature, then a malfunctioning fan clutch has been detected.

Linked Solutions

  • None

Repair

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to Procedure 008-027

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Intake manifold temperature sensor stuck in-range

Solution: S00000334

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the intake manifold temperature sensor reading to an infrared thermometer or a known value.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the known value must be within: +/- 10C [18F]

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Thermostat is malfunctioning

Solution: S00000785

Verification

Conditions

  • Engine running.

Action

  • Allow the engine to reach operating temperature.
  • Check the thermostat opening temperature with an infrared temperature gun.
  • Check the coolant thermostat for proper operation.

Refer to Procedure 008-013

  • Check for a damaged or leaking thermostat seal.

Refer to Procedure 008-013

  • If a temperature gun is not available or if the temperature gun reading is above the correct thermostat opening temperature, then proceed to Linked Solutions section.

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • Out-of-chassis opening temperature test

Refer to S00001359

Repair

  • Replace the engine coolant thermostat.

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7.1 - Out-of-chassis opening temperature test

Solution: S00001359

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the out-of-chassis opening temperature test.

Refer to Procedure 008-013

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine coolant thermostat.

Refer to Procedure 008-013

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

8 - Leaks in the intake air system

Solution: S00008386

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.
  • Visually inspect the intake plumbing for possible air leaks.

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Charge air cooler system leak

Solution: S00008815

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the charge air cooler hoses for possible air leaks.
  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If a leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the charge air cooler.

Refer to Procedure 010-027

  • Repair or replace the charge air cooler hoses.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - Malfunctioning cooling fan drive or cooling fan controls

Solution: S00000490

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Monitor the cooling fan operation.

Refer to Procedure 008-027

Specification

  • If the cooling fan operation is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.
  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

11 - Overhead component damaged or out of adjustment

Solution: S00005074

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.
  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Adjust the overhead.

Refer to Procedure 003-004

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

12 - Turbocharger is malfunctioning

Solution: S00005253

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the intake and exhaust connections from the turbocharger.

Action

  • Inspect the turbocharger compressor and turbine blades for damage or wear.

Refer to Procedure 010-033

Specification

  • If any of the checks are not within specification, then a malfunctioning turbocharger has been detected.

Linked Solutions

  • None

Repair

  • Replace the turbocharger.

Refer to Procedure 010-033

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

13 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 175 | SPN: 3464 | FMI: 3
Electronic Throttle Control Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Technical Service Bulletin is available
  2. Open circuit in the engine intake throttle actuator motor
  3. Engine intake throttle actuator motor resistance check
  4. Engine intake throttle actuator motor open circuit check
  5. Intake throttle control actuator motor circuit pin to pin short

1 - Technical Service Bulletin is available

Solution: S00008863

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb190003

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Open circuit in the engine intake throttle actuator motor

Solution: S00000804

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine intake throttle actuator motor SIGNAL pin and the engine intake throttle actuator motor connector RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the resistance is greater than the following specification: 15 Ω

Linked Solutions

Click on the link below:

  • Engine intake throttle actuator motor resistance check

Refer to S00000805

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Engine intake throttle actuator motor resistance check

Solution: S00000805

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine intake throttle actuator motor SIGNAL pin and the engine intake throttle actuator motor RETURN pin at the engine intake throttle actuator motor connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine intake throttle actuator motor has been detected if the resistance is greater than the following specification: 15 Ω
  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 15 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the engine intake throttle actuator.

Refer to Procedure 010-140

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Engine intake throttle actuator motor open circuit check

Solution: S00000494

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine intake throttle actuator motor SUPPLY pin at the engine intake throttle actuator engine wiring harness connector and the engine intake throttle actuator SUPPLY pin at the engine wiring harness ECM connector.
  • Measure the resistance between the engine intake throttle actuator motor SIGNAL pin at the engine intake throttle actuator engine wiring harness connector and the engine intake throttle actuator SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the engine intake throttle actuator motor RETURN pin at the engine intake throttle actuator engine wiring harness connector and the engine intake throttle actuator RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Intake throttle control actuator motor circuit pin to pin short

Solution: S00000800

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the intake throttle actuator motor SIGNAL pin at the ECM connector of the engine wiring harness and all other pins at that connector.
  • Measure the resistance between the intake throttle actuator motor RETURN pin at the ECM connector of the engine wiring harness and all other pins at that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 17-Apr-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 176 | SPN: 3464 | FMI: 4
Electronic Throttle Control Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Technical Service Bulletin is available
  2. Engine intake throttle actuator motor shorted to ground
  3. Engine intake throttle actuator circuit pin to ground short
  4. Intake throttle control actuator motor circuit pin to pin short

1 - Technical Service Bulletin is available

Solution: S00008863

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb190003

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Engine intake throttle actuator motor shorted to ground

Solution: S00000493

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine intake throttle actuator motor SIGNAL pin and ground.
  • Measure the resistance between the engine intake throttle actuator motor RETURN pin and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine intake throttle actuator motor has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Replace the engine intake throttle actuator.

Refer to Procedure 010-140

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine intake throttle actuator circuit pin to ground short

Solution: S00000492

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine intake throttle actuator motor SUPPLY pin at the ECM connector of the engine wiring harness and engine block ground.
  • Measure the resistance between the engine intake throttle actuator motor RETURN pin at the ECM connector of the engine wiring harness and engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Intake throttle control actuator motor circuit pin to pin short

Solution: S00000800

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the intake throttle actuator motor SIGNAL pin at the ECM connector of the engine wiring harness and all other pins at that connector.
  • Measure the resistance between the intake throttle actuator motor RETURN pin at the ECM connector of the engine wiring harness and all other pins at that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 17-Apr-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 177 | SPN: 3464 | FMI: 7
Electronic Throttle Control Actuator - Mechanical System Not Responding or Out of Adjustment

Troubleshooting Summary

  1. Restricted engine intake throttle
  2. Engine intake throttle actuator motor open circuit check
  3. ECM calibration revision history check
  4. Engine intake throttle actuator not responding or out of adjustment

1 - Restricted engine intake throttle

Solution: S00000495

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the engine intake throttle for restriction, stuck or debris blocking the throttle plate.

Refer to Procedure 010-140

Specification

  • If the throttle plate does not operate freely with no restriction, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Remove the obstruction.

Refer to Procedure 010-140

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Engine intake throttle actuator motor open circuit check

Solution: S00000494

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine intake throttle actuator motor SUPPLY pin at the engine intake throttle actuator engine wiring harness connector and the engine intake throttle actuator SUPPLY pin at the engine wiring harness ECM connector.
  • Measure the resistance between the engine intake throttle actuator motor SIGNAL pin at the engine intake throttle actuator engine wiring harness connector and the engine intake throttle actuator SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the engine intake throttle actuator motor RETURN pin at the engine intake throttle actuator engine wiring harness connector and the engine intake throttle actuator RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Engine intake throttle actuator not responding or out of adjustment

Solution: S00001034

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning engine intake throttle actuator assembly has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine intake throttle actuator.

Refer to Procedure 010-140

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 187 | SPN: 3510 | FMI: 4
Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. ECM sensor supply 2 voltage below normal

1 - ECM sensor supply 2 voltage below normal

Solution: S00002970

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Perform the following actions one at a time:
  • Disconnect the aftertreatment fuel pressure sensor from the engine wiring harness.
  • Disconnect the EGR differential pressure sensor from the engine wiring harness.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.
  • Disconnect the EGR valve from the engine wiring harness.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.
  • Disconnect the EGR orifice pressure sensor from the engine wiring harness.
  • Disconnect the engine wiring harness from the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code goes inactive when a component is disconnected, then a malfunctioning sensor supply component has been detected.
  • If the fault code stays active when the engine wiring harness is disconnected, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace aftertreatment fuel pressure sensor.

Refer to Procedure 019-444

  • Replace the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Replace the Exhaust gas pressure sensor.

Refer to Procedure 019-376

  • Replace the EGR valve.

Refer to Procedure 011-022

  • Replace the engine intake throttle actuator.

Refer to Procedure 010-140

  • Replace EGR orifice pressure sensor.

Refer to Procedure 019-461

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable Fault Code
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 25-Jan-2020


NO TITLE

ISX15 CM2350 X101

Fault Code: 195 | SPN: 111 | FMI: 3
Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Coolant level sensor circuit response (2-wire)
  3. Coolant level sensor is malfunctioning
  4. Coolant level sensor circuit response (3-wire)
  5. Coolant level sensor is malfunctioning
  6. Coolant level sensor open circuit check (3-wire)
  7. Coolant level sensor open circuit check (2-wire)
  8. Coolant level sensor circuit pin to pin short (3-wire)
  9. Coolant level sensor circuit pin to pin short (2-wire)

1 - Check for primary fault codes

Solution: S00000051

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1695, 1696

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Coolant level sensor circuit response (2-wire)

Solution: S00000817

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution if the following fault code did not become active with the sensor disconnected: 195
  • Proceed to the Linked Solutions section if the following fault code became active with the sensor disconnected: 195

Linked Solutions

Click on the link below:

  • Coolant level sensor is malfunctioning

Refer to S00000839

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Coolant level sensor is malfunctioning

Solution: S00000839

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the engine coolant level sensor SIGNAL pin and the engine coolant level sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine coolant level sensor has been detected if the following fault code became active with the jumper wire in place: 196

Linked Solutions

  • None

Repair

  • Replace engine coolant level sensor.

Refer to Procedure 019-017

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Coolant level sensor circuit response (3-wire)

Solution: S00000359

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the engine coolant level sensor SIGNAL pin and the engine coolant level sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution if the following fault code did not become active with the jumper wire in place: 196
  • Proceed to the Linked Solutions section if the following fault code became active with the jumper wire in place: 196

Linked Solutions

  • Coolant level sensor is malfunctioning

Refer to S00001157

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Coolant level sensor is malfunctioning

Solution: S00001157

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the jumper wire between the engine coolant level sensor SIGNAL pin and the engine coolant level sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Place a jumper wire between the engine coolant level sensor SUPPLY pin and the engine coolant level sensor SIGNAL pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine coolant level sensor has been detected if the following fault code became active with the jumper wire in place: 195

Linked Solutions

  • None

Repair

  • Replace engine coolant level sensor.

Refer to Procedure 019-017

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Coolant level sensor open circuit check (3-wire)

Solution: S00000498

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SUPPLY pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor SIGNAL pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor RETURN pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Coolant level sensor open circuit check (2-wire)

Solution: S00004695

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor RETURN pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Coolant level sensor circuit pin to pin short (3-wire)

Solution: S00000497

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor SUPPLY pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Coolant level sensor circuit pin to pin short (2-wire)

Solution: S00004789

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 196 | SPN: 111 | FMI: 4
Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Coolant level sensor voltage check
  3. Coolant level sensor circuit check
  4. Coolant level sensor circuit response (2-wire)
  5. Coolant level sensor is malfunctioning
  6. Coolant level sensor circuit response (3-wire)
  7. Coolant level sensor is malfunctioning
  8. Coolant level sensor open circuit check (3-wire)
  9. Coolant level sensor open circuit check (2-wire)
  10. Coolant level sensor circuit pin to ground short
  11. Coolant level sensor circuit pin to pin short (3-wire)
  12. Coolant level sensor circuit pin to pin short (2-wire)

1 - Check for primary fault codes

Solution: S00000054

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1696

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Coolant level sensor voltage check

Solution: S00000727

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the coolant level sensor SUPPLY pin to the coolant level sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Coolant level sensor circuit check

Refer to S00000815

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Coolant level sensor circuit check

Solution: S00000815

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SUPPLY pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor RETURN pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Coolant level sensor circuit response (2-wire)

Solution: S00000817

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution if the following fault code did not become active with the sensor disconnected: 195
  • Proceed to the Linked Solutions section if the following fault code became active with the sensor disconnected: 195

Linked Solutions

Click on the link below:

  • Coolant level sensor is malfunctioning

Refer to S00000839

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Coolant level sensor is malfunctioning

Solution: S00000839

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the engine coolant level sensor SIGNAL pin and the engine coolant level sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine coolant level sensor has been detected if the following fault code became active with the jumper wire in place: 196

Linked Solutions

  • None

Repair

  • Replace engine coolant level sensor.

Refer to Procedure 019-017

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Coolant level sensor circuit response (3-wire)

Solution: S00000359

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the engine coolant level sensor SIGNAL pin and the engine coolant level sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution if the following fault code did not become active with the jumper wire in place: 196
  • Proceed to the Linked Solutions section if the following fault code became active with the jumper wire in place: 196

Linked Solutions

  • Coolant level sensor is malfunctioning

Refer to S00001157

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Coolant level sensor is malfunctioning

Solution: S00001157

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the jumper wire between the engine coolant level sensor SIGNAL pin and the engine coolant level sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Place a jumper wire between the engine coolant level sensor SUPPLY pin and the engine coolant level sensor SIGNAL pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine coolant level sensor has been detected if the following fault code became active with the jumper wire in place: 195

Linked Solutions

  • None

Repair

  • Replace engine coolant level sensor.

Refer to Procedure 019-017

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Coolant level sensor open circuit check (3-wire)

Solution: S00000498

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SUPPLY pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor SIGNAL pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor RETURN pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Coolant level sensor open circuit check (2-wire)

Solution: S00004695

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor RETURN pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Coolant level sensor circuit pin to ground short

Solution: S00000499

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Coolant level sensor circuit pin to pin short (3-wire)

Solution: S00000497

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor SUPPLY pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Coolant level sensor circuit pin to pin short (2-wire)

Solution: S00004789

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 197 | SPN: 111 | FMI: 18
Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Coolant level check
  3. Coolant level sensor open circuit check
  4. Coolant level sensor circuit pin to ground short
  5. Coolant level sensor circuit pin to pin short
  6. ECM calibration revision history check
  7. Coolant level sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00010587

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 operating hours from the following list:

  • Coolant level: 195, 196

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Coolant level check

Solution: S00003142

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the coolant level.
  • Perform the Coolant System Pressure Test.

Refer to Procedure 008-018

  • Visually inspect for external coolant leaks.

Specification

  • If the coolant level is low and there are signs of external coolant leaks, then reset the search to external coolant leak.
  • If the coolant level is low and there are no signs of external coolant leaks, then reset the search to internal coolant leak.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3 - Coolant level sensor open circuit check

Solution: S00007920

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Coolant level sensor circuit pin to ground short

Solution: S00007921

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Coolant level sensor circuit pin to pin short

Solution: S00007922

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor SUPPLY pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Coolant level sensor is malfunctioning

Solution: S00007923

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning coolant level sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace engine coolant level sensor.

Refer to Procedure 019-017

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 212 | SPN: 175 | FMI: 3
Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Lubricating oil temperature sensor resistance check
  2. Lubricating oil temperature sensor circuit response
  3. Lubricating oil temperature sensor circuit response at the ECM

1 - Lubricating oil temperature sensor resistance check

Solution: S00000362

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lubricating oil temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin and the engine oil temperature sensor RETURN pin at the engine oil temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the resistance is not within the following specification: 180 Ω - 160k Ω

Linked Solutions

  • None

Repair

  • Replace the lubricating oil temperature sensor.

Refer to Procedure 019-067

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Lubricating oil temperature sensor circuit response

Solution: S00003662

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lubricating oil temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the engine oil temperature sensor SIGNAL pin and the engine oil temperature sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine oil temperature sensor has been detected if the following fault code became active with the jumper wire in place: 213

Linked Solutions

  • None

Repair

  • Replace the lubricating oil temperature sensor.

Refer to Procedure 019-067

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Lubricating oil temperature sensor circuit response at the ECM

Solution: S00000586

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the engine oil temperature sensor SIGNAL pin and the engine oil temperature sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 213
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 213

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 213 | SPN: 175 | FMI: 4
Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Lubricating oil temperature sensor resistance check
  2. Lubricating oil temperature sensor circuit response
  3. Lubricating oil temperature sensor circuit response at the ECM

1 - Lubricating oil temperature sensor resistance check

Solution: S00000362

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lubricating oil temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin and the engine oil temperature sensor RETURN pin at the engine oil temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the resistance is not within the following specification: 180 Ω - 160k Ω

Linked Solutions

  • None

Repair

  • Replace the lubricating oil temperature sensor.

Refer to Procedure 019-067

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Lubricating oil temperature sensor circuit response

Solution: S00000371

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lubricating oil temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine oil temperature sensor has been detected if the following fault code became active with the sensor disconnected: 212

Linked Solutions

  • None

Repair

  • Replace the lubricating oil temperature sensor.

Refer to Procedure 019-067

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Lubricating oil temperature sensor circuit response at the ECM

Solution: S00000585

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 212
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 212

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 214 | SPN: 175 | FMI: 0
Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Basic oil system checks
  3. Lubricating oil temperature sensor resistance check
  4. Lubricating oil temperature sensor stuck in-range
  5. Lubricating oil thermostat is malfunctioning
  6. Lubricating oil cooler is malfunctioning or restricted
  7. Lubricating oil cooler is leaking
  8. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00008424

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Engine coolant temperature: 146, 151, 2113, 2114, 2963, 4629, 4631, 5224

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Basic oil system checks

Solution: S00000474

Verification

Conditions

  • Turn keyswitch OFF.

Action

CAUTION: Do not start an engine that has low oil pressure fault codes/complaints until it has been verified that the oil level is correct and that the oil filter is not plugged. Internal engine damage can result from low or no oil pressure.

  • Interview the operator about the complaint. Ask if the fault occurs when climbing or descending a steep hill to determine if engine angularity is a potential issue.
  • Visually inspect engine for external lubricating oil leaks.
  • Check that the lubricating oil level is correct.

Refer to OEM Service Manual

Specification

  • If an oil leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the component that is the source of the leak.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Lubricating oil temperature sensor resistance check

Solution: S00000362

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lubricating oil temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin and the engine oil temperature sensor RETURN pin at the engine oil temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the resistance is not within the following specification: 180 Ω - 160k Ω

Linked Solutions

  • None

Repair

  • Replace the lubricating oil temperature sensor.

Refer to Procedure 019-067

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Lubricating oil temperature sensor stuck in-range

Solution: S00004643

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the lubricating oil temperature sensor
  • Compare the lubricating oil temperature sensor reading to an infrared thermometer or a known value.

Specification

  • If the temperature reading in the recommended Cummins® electronic service tool or equivalent and infrared thermometer or a known value are not within specification, then a malfunctioning lubricating oil temperature sensor has been detected.
  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the known value must be within: +/- 10C [18F]

Linked Solutions

  • None

Repair

  • Replace the lubricating oil temperature sensor.

Refer to Procedure 019-067

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Lubricating oil thermostat is malfunctioning

Solution: S00000811

Verification

Conditions

  • None

Action

  • Check the lubricating oil thermostat for proper operation.

Refer to Procedure 007-039

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning oil thermostat has been detected.

Linked Solutions

  • None

Repair

  • Replace the lubricating oil thermostat.

Refer to Procedure 007-039

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Lubricating oil cooler is malfunctioning or restricted

Solution: S00000543

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the lubricating oil cooler for debris.

Refer to Procedure 007-003

Specification

  • If debris is found in the lubricating oil cooler, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the lubricating oil cooler.

Refer to Procedure 007-003

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Lubricating oil cooler is leaking

Solution: S00000810

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Pressure test the lubricating oil cooler.

Refer to Procedure 007-003

Specification

  • If there are any lubricating oil cooler leaks during the pressure test or any damage is observed during inspection, then a malfunctioning lubricating oil cooler or gaskets have been detected.

Linked Solutions

  • None

Repair

  • Replace the lubricating oil cooler.

Refer to Procedure 007-003

  • Replace the lubricating oil cooler element, mounting plate gasket or o-ring.

Refer to Procedure 007-003

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 221 | SPN: 108 | FMI: 3
Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Barometric pressure sensor voltage check
  3. Barometric pressure sensor voltage check at the ECM
  4. Barometric pressure sensor circuit response
  5. Barometric sensor circuit response at the ECM

1 - Check for primary fault codes

Solution: S00000060

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 386
  • Sensor supply 2: 227

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Barometric pressure sensor voltage check

Solution: S00001076

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the barometric pressure sensor SUPPLY pin and the barometric pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Barometric pressure sensor voltage check at the ECM

Refer to S00001077

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Barometric pressure sensor voltage check at the ECM

Solution: S00001077

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the barometric pressure sensor SUPPLY pin and the barometric pressure sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Barometric pressure sensor circuit response

Solution: S00000372

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning barometric pressure sensor has been detected if the following fault code became active with the sensor disconnected: 222

Linked Solutions

  • None

Repair

  • Replace barometric air pressure sensor.

Refer to Procedure 019-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Barometric sensor circuit response at the ECM

Solution: S00000579

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 222
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 222

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 222 | SPN: 108 | FMI: 4
Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Barometric pressure sensor voltage check
  3. Barometric pressure sensor voltage check at the ECM
  4. Barometric pressure sensor circuit response
  5. Barometric sensor circuit response at the ECM

1 - Check for primary fault codes

Solution: S00000062

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352
  • Sensor supply 2: 187

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Barometric pressure sensor voltage check

Solution: S00001076

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the barometric pressure sensor SUPPLY pin and the barometric pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Barometric pressure sensor voltage check at the ECM

Refer to S00001077

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Barometric pressure sensor voltage check at the ECM

Solution: S00001077

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the barometric pressure sensor SUPPLY pin and the barometric pressure sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Barometric pressure sensor circuit response

Solution: S00000373

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the barometric pressure sensor SUPPLY pin and the barometric pressure sensor SIGNAL pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning barometric pressure sensor has been detected if the following fault code became active with the jumper wire in place: 221

Linked Solutions

  • None

Repair

  • Replace barometric air pressure sensor.

Refer to Procedure 019-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Barometric sensor circuit response at the ECM

Solution: S00000581

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the barometric pressure sensor SUPPLY pin and the barometric pressure sensor SIGNAL pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 221
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 221

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 15-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 227 | SPN: 3510 | FMI: 3
Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. ECM sensor supply 2 voltage above normal
  2. ECM calibration revision history check

1 - ECM sensor supply 2 voltage above normal

Solution: S00000992

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine wiring harness has been detected if the following fault code did not become active with the engine wiring harness disconnected: 227
  • A malfunctioning ECM has been detected if the following fault code became active with the engine wiring harness disconnected: 227

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 234 | SPN: 190 | FMI: 0
Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Engine speed sensor is malfunctioning
  3. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000067

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Crankshaft speed/position sensor: 689
  • Camshaft speed/position sensor: 778

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Engine speed sensor is malfunctioning

Solution: S00000483

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Interview the customer and check for the following:
  • Engine has not been motoring downhill
  • Use the recommended Cummins® electronic service tool or equivalent.
  • RPM reading is correct

Specification

  • If all of these conditions are true, then a malfunctioning camshaft position sensor or crankshaft position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace camshaft position sensor.

Refer to Procedure 019-363

  • Replace crankshaft position sensor.

Refer to Procedure 019-365

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 235 | SPN: 111 | FMI: 1
Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Coolant level check
  3. Coolant level sensor open circuit check
  4. Coolant level sensor circuit pin to ground short
  5. Coolant level sensor circuit pin to pin short
  6. ECM calibration revision history check
  7. Coolant level sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00010587

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 operating hours from the following list:

  • Coolant level: 195, 196

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Coolant level check

Solution: S00003142

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the coolant level.
  • Perform the Coolant System Pressure Test.

Refer to Procedure 008-018

  • Visually inspect for external coolant leaks.

Specification

  • If the coolant level is low and there are signs of external coolant leaks, then reset the search to external coolant leak.
  • If the coolant level is low and there are no signs of external coolant leaks, then reset the search to internal coolant leak.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3 - Coolant level sensor open circuit check

Solution: S00007920

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Coolant level sensor circuit pin to ground short

Solution: S00007921

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Coolant level sensor circuit pin to pin short

Solution: S00007922

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor SUPPLY pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Coolant level sensor is malfunctioning

Solution: S00007923

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning coolant level sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace engine coolant level sensor.

Refer to Procedure 019-017

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 238 | SPN: 3511 | FMI: 4
Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. ECM sensor supply 3 voltage below normal
  2. ECM calibration revision history check

1 - ECM sensor supply 3 voltage below normal

Solution: S00001086

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Perform the following actions one at a time:
  • Disconnect the crankshaft position sensor from the engine wiring harness.
  • Disconnect the engine wiring harness from the ECM.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code goes inactive when a component is disconnected, then a malfunctioning sensor supply component has been detected.
  • If the fault code stays active when the engine wiring harness is disconnected, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace crankshaft position sensor.

Refer to Procedure 019-365

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 239 | SPN: 3511 | FMI: 3
Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. ECM sensor supply 3 voltage above normal
  2. ECM calibration revision history check

1 - ECM sensor supply 3 voltage above normal

Solution: S00000819

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code became active with the engine wiring harness disconnected: 239
  • A malfunctioning engine wiring harness has been detected if the following fault code did not become active with the engine wiring harness disconnected: 239

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 241 | SPN: 84 | FMI: 2
Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Vehicle speed sensor tampering
  2. Incorrect vehicle speed sensor configuration
  3. Vehicle speed sensor open circuit check
  4. Vehicle speed sensor circuit pin to ground short
  5. Vehicle speed sensor circuit pin to pin short
  6. Mechanical gear slippage causing erratic wheel speed data
  7. ECM calibration revision history check

1 - Vehicle speed sensor tampering

Solution: S00000825

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Verify proper installation of the vehicle speed sensor.
  • Verify the vehicle speed sensor for the proper adjustment for magnetic sensor.

Refer to Procedure 019-091

  • Verify the vehicle speed sensor for the proper adjustment for digital sensor.

Refer to Procedure 019-090

  • Verify that no external device is connected in place of the vehicle speed sensor
  • Verify that there is no evidence that tampering with the vehicle speed sensor has taken place.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If signs of tampering or incorrect installation has been found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the digital vehicle speed sensor.

Refer to Procedure 019-090

  • Replace the magnetic vehicle speed sensor.

Refer to Procedure 019-091

  • Repair or remove the tampering device or any external device.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Incorrect vehicle speed sensor configuration

Solution: S00000824

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Verify the parameters match the vehicle configuration.
  • Transmission Setup -Top Gear Transmission Ratio
  • Vehicle Speed Source -Rear Axle Ratio
  • Vehicle Speed Source -Tire Size
  • Vehicle Speed Source - Vehicle Speed Sensor Type
  • For a vehicle speed source that is a mulitplexed input, check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Specification

  • If the settings displayed by the recommended Cummins® electronic service tool or equivalent do not match the vehicle configuration, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Modify the vehicle configuration settings to match the vehicle configuration.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Vehicle speed sensor open circuit check

Solution: S00000826

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (+) wire between the OEM wiring harness ECM connector and the OEM wiring harness magnetic vehicle speed sensor connector.
  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (-) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Vehicle speed sensor circuit pin to ground short

Solution: S00000827

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (+) at the OEM wiring harness ECM connector and ground.
  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (-) at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Vehicle speed sensor circuit pin to pin short

Solution: S00000828

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (+) pin at the OEM harness ECM connector and all other pins in that connector.
  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (-) pin at the OEM harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Mechanical gear slippage causing erratic wheel speed data

Solution: S00000829

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the vehicle speed sensor from the transmission.

Refer to OEM Service Manual

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Inspect the gear or tone wheel on the rear of the transmission where the speed sensor picks up the speed signal.

Refer to OEM Service Manual

Specification

  • If any damage or defects to the tone wheel or gear are found, then proceed to the Repair section.
  • If any slippage of the tone wheel or gear relative to the shaft is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the gear or tone wheel.

Refer to OEM Service Manual

  • Replace the vehicle speed sensor.

Refer to Procedure 019-090

Refer to Procedure 019-091

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 242 | SPN: 84 | FMI: 10
Wheel-Based Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change

Troubleshooting Summary

  1. Incorrect vehicle speed signal
  2. Vehicle speed sensor tampering
  3. Incorrect vehicle speed sensor configuration
  4. Vehicle speed sensor open circuit check
  5. Vehicle speed sensor circuit pin to ground short
  6. Vehicle speed sensor circuit pin to pin short
  7. ECM calibration revision history check

1 - Incorrect vehicle speed signal

Solution: S00003601

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the vehicle speed sensor while the vehicle is stationary.
  • Drive vehicle or test on chassis dynamometer.
  • Compare the sensor reading from the recommended Cummins® electronic service tool or equivalent to the reading on the vehicle dash.

Specification

  • If the recommended Cummins® electronic service tool or equivalent and vehicle dash reading do not match, then an incorrect parameter setting has been detected.

Linked Solutions

  • None

Repair

  • Adjust the features and parameters to the correct settings.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Vehicle speed sensor tampering

Solution: S00000825

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Verify proper installation of the vehicle speed sensor.
  • Verify the vehicle speed sensor for the proper adjustment for magnetic sensor.

Refer to Procedure 019-091

  • Verify the vehicle speed sensor for the proper adjustment for digital sensor.

Refer to Procedure 019-090

  • Verify that no external device is connected in place of the vehicle speed sensor
  • Verify that there is no evidence that tampering with the vehicle speed sensor has taken place.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If signs of tampering or incorrect installation has been found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the digital vehicle speed sensor.

Refer to Procedure 019-090

  • Replace the magnetic vehicle speed sensor.

Refer to Procedure 019-091

  • Repair or remove the tampering device or any external device.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Incorrect vehicle speed sensor configuration

Solution: S00000824

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Verify the parameters match the vehicle configuration.
  • Transmission Setup -Top Gear Transmission Ratio
  • Vehicle Speed Source -Rear Axle Ratio
  • Vehicle Speed Source -Tire Size
  • Vehicle Speed Source - Vehicle Speed Sensor Type
  • For a vehicle speed source that is a mulitplexed input, check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Specification

  • If the settings displayed by the recommended Cummins® electronic service tool or equivalent do not match the vehicle configuration, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Modify the vehicle configuration settings to match the vehicle configuration.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Vehicle speed sensor open circuit check

Solution: S00000826

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (+) wire between the OEM wiring harness ECM connector and the OEM wiring harness magnetic vehicle speed sensor connector.
  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (-) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Vehicle speed sensor circuit pin to ground short

Solution: S00000827

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (+) at the OEM wiring harness ECM connector and ground.
  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (-) at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Vehicle speed sensor circuit pin to pin short

Solution: S00000828

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (+) pin at the OEM harness ECM connector and all other pins in that connector.
  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (-) pin at the OEM harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 245 | SPN: 647 | FMI: 4
Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Fan control solenoid resistance check
  2. Fan control solenoid circuit pin to ground short
  3. Fan control solenoid circuit pin to pin short
  4. Fan control solenoid is malfunctioning

1 - Fan control solenoid resistance check

Solution: S00001059

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the fan control solenoid.

Refer to OEM Service Manual

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the fan control solenoid resistance does not meet specification, then a malfunctioning fan control solenoid has been detected.

Refer to OEM Service Manual

Linked Solutions

  • None

Repair

  • Replace the fan control solenoid.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Fan control solenoid circuit pin to ground short

Solution: S00001060

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the fan control solenoid from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fan control SIGNAL pin of the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

3 - Fan control solenoid circuit pin to pin short

Solution: S00004897

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the fan control connector from the OEM wiring harness connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fan control SIGNAL pin of the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fan control solenoid is malfunctioning

Solution: S00005653

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the fan control solenoid.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 15-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 249 | SPN: 171 | FMI: 3
Ambient Air Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Ambient air temperature sensor circuit response
  2. Ambient air temperature sensor open circuit check
  3. Ambient air temperature sensor circuit pin to pin short
  4. ECM calibration revision history check

1 - Ambient air temperature sensor circuit response

Solution: S00000374

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the ambient air temperature sensor SIGNAL pin and the ambient air temperature sensor RETURN pin at the sensor connector of the OEM wiring harness
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ambient air temperature sensor has been detected if the following fault code became active with the jumper wire in place: 256

Linked Solutions

  • None

Repair

  • Replace the ambient air temperature sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Ambient air temperature sensor open circuit check

Solution: S00000833

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the ambient air temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM wiring harness ECM connector ambient air temperature sensor RETURN pin and OEM wiring harness ambient air temperature sensor connector RETURN pin
  • Measure the resistance between the OEM wiring harness ECM connector ambient air temperature sensor SIGNAL pin and OEM wiring harness ambient air temperature sensor connector SIGNAL pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Ambient air temperature sensor circuit pin to pin short

Solution: S00001091

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ambient air temperature sensor SIGNAL pin in the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 256 | SPN: 171 | FMI: 4
Ambient Air Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Ambient air temperature sensor circuit response
  2. Ambient air temperature sensor circuit pin to ground short
  3. Ambient air temperature sensor circuit pin to pin short
  4. ECM calibration revision history check

1 - Ambient air temperature sensor circuit response

Solution: S00000375

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ambient air temperature sensor has been detected if the following fault code became active with the sensor disconnected: 249

Linked Solutions

  • None

Repair

  • Replace the ambient air temperature sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Ambient air temperature sensor circuit pin to ground short

Solution: S00003624

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ambient air temperature sensor SIGNAL pin of the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Ambient air temperature sensor circuit pin to pin short

Solution: S00001091

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ambient air temperature sensor SIGNAL pin in the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 271 | SPN: 1347 | FMI: 4
Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Fuel pump actuator resistance check
  2. Fuel pump actuator circuit pin to ground short
  3. Fuel pump actuator circuit pin to pin short
  4. ECM calibration revision history check

1 - Fuel pump actuator resistance check

Solution: S00002009

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the fuel pump actuator resistance.

Refer to Procedure 019-117

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not within specification, then a malfunctioning fuel pump actuator has been detected.

Linked Solutions

  • None

Repair

  • Replace the fuel pump actuator.

Refer to Procedure 019-117

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Fuel pump actuator circuit pin to ground short

Solution: S00000507

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel pump actuator SIGNAL pin of the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Fuel pump actuator circuit pin to pin short

Solution: S00000500

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel pump actuator SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 272 | SPN: 1347 | FMI: 3
Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Fuel pump actuator resistance check
  2. Fuel pump actuator open circuit check
  3. Fuel pump actuator circuit pin to ground short
  4. Fuel pump actuator circuit pin to pin short
  5. ECM calibration revision history check
  6. Fuel pump actuator is malfunctioning

1 - Fuel pump actuator resistance check

Solution: S00002009

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the fuel pump actuator resistance.

Refer to Procedure 019-117

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not within specification, then a malfunctioning fuel pump actuator has been detected.

Linked Solutions

  • None

Repair

  • Replace the fuel pump actuator.

Refer to Procedure 019-117

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Fuel pump actuator open circuit check

Solution: S00000508

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine wiring harness fuel pump actuator RETURN pin at the ECM connector of the engine wiring harness and the fuel pump actuator RETURN pin at the fuel pump actuator connector.
  • Measure the resistance between the engine wiring harness fuel pump actuator SIGNAL pin at the ECM connector of the engine wiring harness and the fuel pump actuator SIGNAL pin at the fuel pump actuator connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Fuel pump actuator circuit pin to ground short

Solution: S00000507

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel pump actuator SIGNAL pin of the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel pump actuator circuit pin to pin short

Solution: S00000500

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel pump actuator SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Fuel pump actuator is malfunctioning

Solution: S00000980

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning fuel pump actuator have been detected.

Linked Solutions

  • None

Repair

  • Replace the fuel pump actuator.

Refer to Procedure 019-117

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 285 | SPN: 639 | FMI: 9
SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Troubleshooting Summary

  1. Incorrectly programmed OEM multiplexing unit
  2. ECM calibration revision history check

1 - Incorrectly programmed OEM multiplexing unit

Solution: S00000519

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent SAE J1939 Multiplexed Fault Data, located in Advanced ECM data, to determine which multiplexed component is causing the fault.
  • If the status column indicates "Active" for a multiplexed component, check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses. These components can be found under SAE J1939 Multiplexing in Features and Parameters.

Specification

  • If the recommended Cummins® electronic service tool or equivalent SAE J1939 Multiplexed Fault Data is correct, then the OEM VECU is not transmitting the correct source address due to a malfunctioning OEM component or setup issue.
  • If the J1939 Multiplexed Fault Data is not correct, then an incorrect source address has been entered into he engine ECM for OEM J1939 multiplexed component.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the malfunctioning OEM component.

Refer to OEM Service Manual

  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 286 | SPN: 639 | FMI: 13
J1939 Network #1 - Out of Calibration

Troubleshooting Summary

  1. Incorrectly programmed OEM multiplexing unit
  2. ECM calibration revision history check

1 - Incorrectly programmed OEM multiplexing unit

Solution: S00000519

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent SAE J1939 Multiplexed Fault Data, located in Advanced ECM data, to determine which multiplexed component is causing the fault.
  • If the status column indicates "Active" for a multiplexed component, check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses. These components can be found under SAE J1939 Multiplexing in Features and Parameters.

Specification

  • If the recommended Cummins® electronic service tool or equivalent SAE J1939 Multiplexed Fault Data is correct, then the OEM VECU is not transmitting the correct source address due to a malfunctioning OEM component or setup issue.
  • If the J1939 Multiplexed Fault Data is not correct, then an incorrect source address has been entered into he engine ECM for OEM J1939 multiplexed component.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the malfunctioning OEM component.

Refer to OEM Service Manual

  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 288 | SPN: 974 | FMI: 19
SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Position Sensor System - Received Network Data in Error

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 295 | SPN: 108 | FMI: 2
Barometric Pressure - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Barometric pressure sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000070

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Barometric pressure: 221, 222

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Barometric pressure sensor is malfunctioning

Solution: S00004225

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace barometric air pressure sensor.

Refer to Procedure 019-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 322 | SPN: 651 | FMI: 5
Injector Solenoid Driver 1 Circuit - Current Below Normal or Open Circuit

Troubleshooting Summary

  1. Technical Service Bulletin is available
  2. Injector solenoid driver cylinder 1 current below normal or open circuit
  3. Injector solenoid circuit check at pass through connector
  4. Fuel injector solenoid has an open circuit
  5. Fuel injector solenoid shorted by debris
  6. Fuel injector driver solenoid circuit pin to ground short
  7. Fuel injector solenoid to engine block ground resistance check
  8. Injector driver solenoid circuit pin to pin short
  9. Fuel injector isolation test
  10. Fuel injector solenoid isolation test
  11. ECM fuel injector solenoid driver is malfunctioning

1 - Technical Service Bulletin is available

Solution: S00009814

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb150187

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Injector solenoid driver cylinder 1 current below normal or open circuit

Solution: S00000513

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to clear the fault codes.
  • Idle the engine for 1 minute.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution, if all fault codes are active or have more than one inactive count within the last 25 engine operating hours from the following list: 322, 324, 331
  • Proceed to the Linked Solutions section if a fault code from the following list is active or has more than one inactive count within the last 25 engine operating hours: 322

Linked Solutions

Click on the link below:

  • Injector solenoid circuit check at pass through connector

Refer to S00000963

  • Fuel injector solenoid has an open circuit

Refer to S00001385

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Injector solenoid circuit check at pass through connector

Solution: S00000963

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector pass through wiring harness at the pass through connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel injector solenoid SIGNAL and the injector solenoid RETURN at the fuel injector pass through connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next Linked Solution if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Fuel injector solenoid has an open circuit

Solution: S00001385

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance between the fuel injector solenoid SIGNAL post and the injector solenoid RETURN post on the fuel injector solenoid for the fuel injector being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Fuel injector solenoid shorted by debris

Solution: S00002802

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Inspect the fuel injector solenoid terminals for debris.

Refer to tsb150187

Specification

  • If debris is found on the fuel injector solenoid terminals, then a shorted fuel injector solenoid has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Remove the debris from the fuel injector solenoid terminals.

Refer to Procedure 006-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel injector driver solenoid circuit pin to ground short

Solution: S00000505

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin of the appropriate cylinder driver at the ECM connector of the engine wiring harness to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Cylinders 1, 2, and 3 (Cylinders 1 and 4 for 4-cylinder engines) are on the same fuel injector ECM driver.

Cylinders 4, 5, and 6 (Cylinders 2 and 3 for 4-cylinder engines) are on the same fuel injector ECM driver.

Specification

  • Proceed to the Linked Solutions section if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • Fuel injector solenoid to engine block ground resistance check

Refer to S00000976

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Fuel injector solenoid to engine block ground resistance check

Solution: S00000976

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance from the appropriate fuel injector SIGNAL pin at the fuel injector solenoid to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector solenoid has been detected if the resistance is less than the following specification: 100k Ω
  • A malfunctioning engine wiring harness or injector pass through wiring harness has been detected if the resistance is greater than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Injector driver solenoid circuit pin to pin short

Solution: S00000501

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine wiring harness from the injectors being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin for the appropriate cylinder and all the other pins in that connector.
  • Measure the resistance from the RETURN pin for the appropriate cylinder and all the other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Repeat for all injectors on the same bank.

Specification

  • A malfunctioning engine wiring harness, fuel injector pass through wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.
  • Replace the pass through connector

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Fuel injector isolation test

Solution: S00004511

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Turn keyswitch OFF.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.

Specification

  • If the rocker levers are contacting the fuel injector wiring harness, then proceed to the Repair section.
  • If multiple fault codes from the same bank are active, then proceed to the Linked Solutions section.

Linked Solutions

  • Fuel injector isolation test

Refer to S00004111

Repair

  • Repair or replace the fuel injector pass through wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6.1 - Fuel injector solenoid isolation test

Solution: S00004111

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Place electrical tape on the ends of the fuel injector wiring harness ends so they do not come into contact with each other or engine block ground.
  • Place the rocker lever cover back on the engine.
  • Idle the engine for 1 minute.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If only the fault code associated with the disconnected fuel injector is active, then a malfunction of that fuel fuel injector has been detected.
  • If multiple fault codes from the same bank are active, then reconnect the disconnected fuel injector and repeat the previous steps for the next fuel injector in the bank.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

7 - ECM fuel injector solenoid driver is malfunctioning

Solution: S00000533

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect previously disconnected components.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to clear the fault codes.
  • Run the engine at idle for the following minutes: 1
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Check for multiple fuel injector faults in the same fuel injector driver bank.

Specification

  • If there are multiple fuel injector faults in the same fuel injector driver bank and all of the previous solutions have been completed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 323 | SPN: 655 | FMI: 5
Injector Solenoid Driver 5 Circuit - Current Below Normal or Open Circuit

Troubleshooting Summary

  1. Technical Service Bulletin is available
  2. Injector solenoid driver cylinder 5 current below normal or open circuit
  3. Injector solenoid circuit check at pass through connector
  4. Fuel injector solenoid has an open circuit
  5. Fuel injector solenoid shorted by debris
  6. Fuel injector driver solenoid circuit pin to ground short
  7. Fuel injector solenoid to engine block ground resistance check
  8. Injector driver solenoid circuit pin to pin short
  9. Fuel injector isolation test
  10. Fuel injector solenoid isolation test
  11. ECM fuel injector solenoid driver is malfunctioning

1 - Technical Service Bulletin is available

Solution: S00009814

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb150187

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Injector solenoid driver cylinder 5 current below normal or open circuit

Solution: S00000506

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to clear the fault codes.
  • Idle the engine for 1 minute.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution, if all fault codes are active or have more than one inactive count within the last 25 engine operating hours from the following list: 323, 325, 332
  • Proceed to the Linked Solutions section if a fault code from the following list is active or has more than one inactive count within the last 25 engine operating hours: 323

Linked Solutions

Click on the link below:

  • Injector solenoid circuit check at pass through connector

Refer to S00000963

  • Fuel injector solenoid has an open circuit

Refer to S00001385

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Injector solenoid circuit check at pass through connector

Solution: S00000963

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector pass through wiring harness at the pass through connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel injector solenoid SIGNAL and the injector solenoid RETURN at the fuel injector pass through connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next Linked Solution if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Fuel injector solenoid has an open circuit

Solution: S00001385

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance between the fuel injector solenoid SIGNAL post and the injector solenoid RETURN post on the fuel injector solenoid for the fuel injector being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Fuel injector solenoid shorted by debris

Solution: S00002802

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Inspect the fuel injector solenoid terminals for debris.

Refer to tsb150187

Specification

  • If debris is found on the fuel injector solenoid terminals, then a shorted fuel injector solenoid has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Remove the debris from the fuel injector solenoid terminals.

Refer to Procedure 006-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel injector driver solenoid circuit pin to ground short

Solution: S00000505

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin of the appropriate cylinder driver at the ECM connector of the engine wiring harness to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Cylinders 1, 2, and 3 (Cylinders 1 and 4 for 4-cylinder engines) are on the same fuel injector ECM driver.

Cylinders 4, 5, and 6 (Cylinders 2 and 3 for 4-cylinder engines) are on the same fuel injector ECM driver.

Specification

  • Proceed to the Linked Solutions section if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • Fuel injector solenoid to engine block ground resistance check

Refer to S00000976

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Fuel injector solenoid to engine block ground resistance check

Solution: S00000976

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance from the appropriate fuel injector SIGNAL pin at the fuel injector solenoid to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector solenoid has been detected if the resistance is less than the following specification: 100k Ω
  • A malfunctioning engine wiring harness or injector pass through wiring harness has been detected if the resistance is greater than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Injector driver solenoid circuit pin to pin short

Solution: S00000501

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine wiring harness from the injectors being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin for the appropriate cylinder and all the other pins in that connector.
  • Measure the resistance from the RETURN pin for the appropriate cylinder and all the other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Repeat for all injectors on the same bank.

Specification

  • A malfunctioning engine wiring harness, fuel injector pass through wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.
  • Replace the pass through connector

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Fuel injector isolation test

Solution: S00004511

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Turn keyswitch OFF.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.

Specification

  • If the rocker levers are contacting the fuel injector wiring harness, then proceed to the Repair section.
  • If multiple fault codes from the same bank are active, then proceed to the Linked Solutions section.

Linked Solutions

  • Fuel injector isolation test

Refer to S00004111

Repair

  • Repair or replace the fuel injector pass through wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6.1 - Fuel injector solenoid isolation test

Solution: S00004111

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Place electrical tape on the ends of the fuel injector wiring harness ends so they do not come into contact with each other or engine block ground.
  • Place the rocker lever cover back on the engine.
  • Idle the engine for 1 minute.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If only the fault code associated with the disconnected fuel injector is active, then a malfunction of that fuel fuel injector has been detected.
  • If multiple fault codes from the same bank are active, then reconnect the disconnected fuel injector and repeat the previous steps for the next fuel injector in the bank.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

7 - ECM fuel injector solenoid driver is malfunctioning

Solution: S00000533

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect previously disconnected components.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to clear the fault codes.
  • Run the engine at idle for the following minutes: 1
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Check for multiple fuel injector faults in the same fuel injector driver bank.

Specification

  • If there are multiple fuel injector faults in the same fuel injector driver bank and all of the previous solutions have been completed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 324 | SPN: 653 | FMI: 5
Injector Solenoid Driver 3 Circuit - Current Below Normal or Open Circuit

Troubleshooting Summary

  1. Technical Service Bulletin is available
  2. Injector solenoid driver cylinder 3 current below normal or open circuit
  3. Injector solenoid circuit check at pass through connector
  4. Fuel injector solenoid has an open circuit
  5. Fuel injector solenoid shorted by debris
  6. Fuel injector driver solenoid circuit pin to ground short
  7. Fuel injector solenoid to engine block ground resistance check
  8. Injector driver solenoid circuit pin to pin short
  9. Fuel injector isolation test
  10. Fuel injector solenoid isolation test
  11. ECM fuel injector solenoid driver is malfunctioning

1 - Technical Service Bulletin is available

Solution: S00009814

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb150187

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Injector solenoid driver cylinder 3 current below normal or open circuit

Solution: S00000509

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to clear the fault codes.
  • Idle the engine for 1 minute.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution, if all fault codes are active or have more than one inactive count within the last 25 engine operating hours from the following list: 322, 324, 331
  • Proceed to the Linked Solutions section if a fault code from the following list is active or has more than one inactive count within the last 25 engine operating hours: 324

Linked Solutions

Click on the link below:

  • Injector solenoid circuit check at pass through connector

Refer to S00000963

  • Fuel injector solenoid has an open circuit

Refer to S00001385

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Injector solenoid circuit check at pass through connector

Solution: S00000963

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector pass through wiring harness at the pass through connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel injector solenoid SIGNAL and the injector solenoid RETURN at the fuel injector pass through connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next Linked Solution if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Fuel injector solenoid has an open circuit

Solution: S00001385

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance between the fuel injector solenoid SIGNAL post and the injector solenoid RETURN post on the fuel injector solenoid for the fuel injector being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Fuel injector solenoid shorted by debris

Solution: S00002802

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Inspect the fuel injector solenoid terminals for debris.

Refer to tsb150187

Specification

  • If debris is found on the fuel injector solenoid terminals, then a shorted fuel injector solenoid has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Remove the debris from the fuel injector solenoid terminals.

Refer to Procedure 006-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel injector driver solenoid circuit pin to ground short

Solution: S00000505

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin of the appropriate cylinder driver at the ECM connector of the engine wiring harness to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Cylinders 1, 2, and 3 (Cylinders 1 and 4 for 4-cylinder engines) are on the same fuel injector ECM driver.

Cylinders 4, 5, and 6 (Cylinders 2 and 3 for 4-cylinder engines) are on the same fuel injector ECM driver.

Specification

  • Proceed to the Linked Solutions section if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • Fuel injector solenoid to engine block ground resistance check

Refer to S00000976

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Fuel injector solenoid to engine block ground resistance check

Solution: S00000976

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance from the appropriate fuel injector SIGNAL pin at the fuel injector solenoid to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector solenoid has been detected if the resistance is less than the following specification: 100k Ω
  • A malfunctioning engine wiring harness or injector pass through wiring harness has been detected if the resistance is greater than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Injector driver solenoid circuit pin to pin short

Solution: S00000501

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine wiring harness from the injectors being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin for the appropriate cylinder and all the other pins in that connector.
  • Measure the resistance from the RETURN pin for the appropriate cylinder and all the other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Repeat for all injectors on the same bank.

Specification

  • A malfunctioning engine wiring harness, fuel injector pass through wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.
  • Replace the pass through connector

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Fuel injector isolation test

Solution: S00004511

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Turn keyswitch OFF.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.

Specification

  • If the rocker levers are contacting the fuel injector wiring harness, then proceed to the Repair section.
  • If multiple fault codes from the same bank are active, then proceed to the Linked Solutions section.

Linked Solutions

  • Fuel injector isolation test

Refer to S00004111

Repair

  • Repair or replace the fuel injector pass through wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6.1 - Fuel injector solenoid isolation test

Solution: S00004111

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Place electrical tape on the ends of the fuel injector wiring harness ends so they do not come into contact with each other or engine block ground.
  • Place the rocker lever cover back on the engine.
  • Idle the engine for 1 minute.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If only the fault code associated with the disconnected fuel injector is active, then a malfunction of that fuel fuel injector has been detected.
  • If multiple fault codes from the same bank are active, then reconnect the disconnected fuel injector and repeat the previous steps for the next fuel injector in the bank.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

7 - ECM fuel injector solenoid driver is malfunctioning

Solution: S00000533

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect previously disconnected components.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to clear the fault codes.
  • Run the engine at idle for the following minutes: 1
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Check for multiple fuel injector faults in the same fuel injector driver bank.

Specification

  • If there are multiple fuel injector faults in the same fuel injector driver bank and all of the previous solutions have been completed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 325 | SPN: 656 | FMI: 5
Injector Solenoid Driver 6 Circuit - Current Below Normal or Open Circuit

Troubleshooting Summary

  1. Technical Service Bulletin is available
  2. Injector solenoid driver cylinder 6 current below normal or open circuit
  3. Injector solenoid circuit check at pass through connector
  4. Fuel injector solenoid has an open circuit
  5. Fuel injector solenoid shorted by debris
  6. Fuel injector driver solenoid circuit pin to ground short
  7. Fuel injector solenoid to engine block ground resistance check
  8. Injector driver solenoid circuit pin to pin short
  9. Fuel injector isolation test
  10. Fuel injector solenoid isolation test
  11. ECM fuel injector solenoid driver is malfunctioning

1 - Technical Service Bulletin is available

Solution: S00009814

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb150187

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Injector solenoid driver cylinder 6 current below normal or open circuit

Solution: S00000510

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to clear the fault codes.
  • Idle the engine for 1 minute.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution, if all fault codes are active or have more than one inactive count within the last 25 engine operating hours from the following list: 323, 325, 332
  • Proceed to the Linked Solutions section if a fault code from the following list is active or has more than one inactive count within the last 25 engine operating hours: 325

Linked Solutions

Click on the link below:

  • Injector solenoid circuit check at pass through connector

Refer to S00000963

  • Fuel injector solenoid has an open circuit

Refer to S00001385

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Injector solenoid circuit check at pass through connector

Solution: S00000963

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector pass through wiring harness at the pass through connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel injector solenoid SIGNAL and the injector solenoid RETURN at the fuel injector pass through connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next Linked Solution if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Fuel injector solenoid has an open circuit

Solution: S00001385

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance between the fuel injector solenoid SIGNAL post and the injector solenoid RETURN post on the fuel injector solenoid for the fuel injector being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Fuel injector solenoid shorted by debris

Solution: S00002802

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Inspect the fuel injector solenoid terminals for debris.

Refer to tsb150187

Specification

  • If debris is found on the fuel injector solenoid terminals, then a shorted fuel injector solenoid has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Remove the debris from the fuel injector solenoid terminals.

Refer to Procedure 006-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel injector driver solenoid circuit pin to ground short

Solution: S00000505

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin of the appropriate cylinder driver at the ECM connector of the engine wiring harness to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Cylinders 1, 2, and 3 (Cylinders 1 and 4 for 4-cylinder engines) are on the same fuel injector ECM driver.

Cylinders 4, 5, and 6 (Cylinders 2 and 3 for 4-cylinder engines) are on the same fuel injector ECM driver.

Specification

  • Proceed to the Linked Solutions section if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • Fuel injector solenoid to engine block ground resistance check

Refer to S00000976

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Fuel injector solenoid to engine block ground resistance check

Solution: S00000976

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance from the appropriate fuel injector SIGNAL pin at the fuel injector solenoid to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector solenoid has been detected if the resistance is less than the following specification: 100k Ω
  • A malfunctioning engine wiring harness or injector pass through wiring harness has been detected if the resistance is greater than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Injector driver solenoid circuit pin to pin short

Solution: S00000501

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine wiring harness from the injectors being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin for the appropriate cylinder and all the other pins in that connector.
  • Measure the resistance from the RETURN pin for the appropriate cylinder and all the other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Repeat for all injectors on the same bank.

Specification

  • A malfunctioning engine wiring harness, fuel injector pass through wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.
  • Replace the pass through connector

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Fuel injector isolation test

Solution: S00004511

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Turn keyswitch OFF.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.

Specification

  • If the rocker levers are contacting the fuel injector wiring harness, then proceed to the Repair section.
  • If multiple fault codes from the same bank are active, then proceed to the Linked Solutions section.

Linked Solutions

  • Fuel injector isolation test

Refer to S00004111

Repair

  • Repair or replace the fuel injector pass through wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6.1 - Fuel injector solenoid isolation test

Solution: S00004111

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Place electrical tape on the ends of the fuel injector wiring harness ends so they do not come into contact with each other or engine block ground.
  • Place the rocker lever cover back on the engine.
  • Idle the engine for 1 minute.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If only the fault code associated with the disconnected fuel injector is active, then a malfunction of that fuel fuel injector has been detected.
  • If multiple fault codes from the same bank are active, then reconnect the disconnected fuel injector and repeat the previous steps for the next fuel injector in the bank.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

7 - ECM fuel injector solenoid driver is malfunctioning

Solution: S00000533

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect previously disconnected components.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to clear the fault codes.
  • Run the engine at idle for the following minutes: 1
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Check for multiple fuel injector faults in the same fuel injector driver bank.

Specification

  • If there are multiple fuel injector faults in the same fuel injector driver bank and all of the previous solutions have been completed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 331 | SPN: 652 | FMI: 5
Injector Solenoid Driver 2 Circuit - Current Below Normal or Open Circuit

Troubleshooting Summary

  1. Technical Service Bulletin is available
  2. Injector solenoid driver cylinder 2 current below normal or open circuit
  3. Injector solenoid circuit check at pass through connector
  4. Fuel injector solenoid has an open circuit
  5. Fuel injector solenoid shorted by debris
  6. Fuel injector driver solenoid circuit pin to ground short
  7. Fuel injector solenoid to engine block ground resistance check
  8. Injector driver solenoid circuit pin to pin short
  9. Fuel injector isolation test
  10. Fuel injector solenoid isolation test
  11. ECM fuel injector solenoid driver is malfunctioning

1 - Technical Service Bulletin is available

Solution: S00009814

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb150187

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Injector solenoid driver cylinder 2 current below normal or open circuit

Solution: S00000512

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to clear the fault codes.
  • Idle the engine for 1 minute.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution, if all fault codes are active or have more than one inactive count within the last 25 engine operating hours from the following list: 322, 324, 331
  • Proceed to the Linked Solutions section if a fault code from the following list is active or has more than one inactive count within the last 25 engine operating hours: 331

Linked Solutions

Click on the link below:

  • Injector solenoid circuit check at pass through connector

Refer to S00000963

  • Fuel injector solenoid has an open circuit

Refer to S00001385

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Injector solenoid circuit check at pass through connector

Solution: S00000963

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector pass through wiring harness at the pass through connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel injector solenoid SIGNAL and the injector solenoid RETURN at the fuel injector pass through connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next Linked Solution if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Fuel injector solenoid has an open circuit

Solution: S00001385

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance between the fuel injector solenoid SIGNAL post and the injector solenoid RETURN post on the fuel injector solenoid for the fuel injector being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Fuel injector solenoid shorted by debris

Solution: S00002802

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Inspect the fuel injector solenoid terminals for debris.

Refer to tsb150187

Specification

  • If debris is found on the fuel injector solenoid terminals, then a shorted fuel injector solenoid has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Remove the debris from the fuel injector solenoid terminals.

Refer to Procedure 006-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel injector driver solenoid circuit pin to ground short

Solution: S00000505

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin of the appropriate cylinder driver at the ECM connector of the engine wiring harness to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Cylinders 1, 2, and 3 (Cylinders 1 and 4 for 4-cylinder engines) are on the same fuel injector ECM driver.

Cylinders 4, 5, and 6 (Cylinders 2 and 3 for 4-cylinder engines) are on the same fuel injector ECM driver.

Specification

  • Proceed to the Linked Solutions section if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • Fuel injector solenoid to engine block ground resistance check

Refer to S00000976

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Fuel injector solenoid to engine block ground resistance check

Solution: S00000976

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance from the appropriate fuel injector SIGNAL pin at the fuel injector solenoid to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector solenoid has been detected if the resistance is less than the following specification: 100k Ω
  • A malfunctioning engine wiring harness or injector pass through wiring harness has been detected if the resistance is greater than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Injector driver solenoid circuit pin to pin short

Solution: S00000501

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine wiring harness from the injectors being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin for the appropriate cylinder and all the other pins in that connector.
  • Measure the resistance from the RETURN pin for the appropriate cylinder and all the other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Repeat for all injectors on the same bank.

Specification

  • A malfunctioning engine wiring harness, fuel injector pass through wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.
  • Replace the pass through connector

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Fuel injector isolation test

Solution: S00004511

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Turn keyswitch OFF.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.

Specification

  • If the rocker levers are contacting the fuel injector wiring harness, then proceed to the Repair section.
  • If multiple fault codes from the same bank are active, then proceed to the Linked Solutions section.

Linked Solutions

  • Fuel injector isolation test

Refer to S00004111

Repair

  • Repair or replace the fuel injector pass through wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6.1 - Fuel injector solenoid isolation test

Solution: S00004111

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Place electrical tape on the ends of the fuel injector wiring harness ends so they do not come into contact with each other or engine block ground.
  • Place the rocker lever cover back on the engine.
  • Idle the engine for 1 minute.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If only the fault code associated with the disconnected fuel injector is active, then a malfunction of that fuel fuel injector has been detected.
  • If multiple fault codes from the same bank are active, then reconnect the disconnected fuel injector and repeat the previous steps for the next fuel injector in the bank.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

7 - ECM fuel injector solenoid driver is malfunctioning

Solution: S00000533

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect previously disconnected components.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to clear the fault codes.
  • Run the engine at idle for the following minutes: 1
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Check for multiple fuel injector faults in the same fuel injector driver bank.

Specification

  • If there are multiple fuel injector faults in the same fuel injector driver bank and all of the previous solutions have been completed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 332 | SPN: 654 | FMI: 5
Injector Solenoid Driver 4 Circuit - Current Below Normal or Open Circuit

Troubleshooting Summary

  1. Technical Service Bulletin is available
  2. Injector solenoid driver cylinder 4 current below normal or open circuit
  3. Injector solenoid circuit check at pass through connector
  4. Fuel injector solenoid has an open circuit
  5. Fuel injector solenoid shorted by debris
  6. Fuel injector driver solenoid circuit pin to ground short
  7. Fuel injector solenoid to engine block ground resistance check
  8. Injector driver solenoid circuit pin to pin short
  9. Fuel injector isolation test
  10. Fuel injector solenoid isolation test
  11. ECM fuel injector solenoid driver is malfunctioning

1 - Technical Service Bulletin is available

Solution: S00009814

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb150187

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Injector solenoid driver cylinder 4 current below normal or open circuit

Solution: S00000511

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to clear the fault codes.
  • Idle the engine for 1 minute.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution, if all fault codes are active or have more than one inactive count within the last 25 engine operating hours from the following list: 323, 325, 332
  • Proceed to the Linked Solutions section if a fault code from the following list is active or has more than one inactive count within the last 25 engine operating hours: 332

Linked Solutions

Click on the link below:

  • Injector solenoid circuit check at pass through connector

Refer to S00000963

  • Fuel injector solenoid has an open circuit

Refer to S00001385

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Injector solenoid circuit check at pass through connector

Solution: S00000963

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the fuel injector pass through wiring harness at the pass through connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel injector solenoid SIGNAL and the injector solenoid RETURN at the fuel injector pass through connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next Linked Solution if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Fuel injector solenoid has an open circuit

Solution: S00001385

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance between the fuel injector solenoid SIGNAL post and the injector solenoid RETURN post on the fuel injector solenoid for the fuel injector being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Fuel injector solenoid shorted by debris

Solution: S00002802

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Inspect the fuel injector solenoid terminals for debris.

Refer to tsb150187

Specification

  • If debris is found on the fuel injector solenoid terminals, then a shorted fuel injector solenoid has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Remove the debris from the fuel injector solenoid terminals.

Refer to Procedure 006-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel injector driver solenoid circuit pin to ground short

Solution: S00000505

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin of the appropriate cylinder driver at the ECM connector of the engine wiring harness to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Cylinders 1, 2, and 3 (Cylinders 1 and 4 for 4-cylinder engines) are on the same fuel injector ECM driver.

Cylinders 4, 5, and 6 (Cylinders 2 and 3 for 4-cylinder engines) are on the same fuel injector ECM driver.

Specification

  • Proceed to the Linked Solutions section if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • Fuel injector solenoid to engine block ground resistance check

Refer to S00000976

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Fuel injector solenoid to engine block ground resistance check

Solution: S00000976

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.
  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Measure the resistance from the appropriate fuel injector SIGNAL pin at the fuel injector solenoid to ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel injector solenoid has been detected if the resistance is less than the following specification: 100k Ω
  • A malfunctioning engine wiring harness or injector pass through wiring harness has been detected if the resistance is greater than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Injector driver solenoid circuit pin to pin short

Solution: S00000501

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine wiring harness from the injectors being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the SIGNAL pin for the appropriate cylinder and all the other pins in that connector.
  • Measure the resistance from the RETURN pin for the appropriate cylinder and all the other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Repeat for all injectors on the same bank.

Specification

  • A malfunctioning engine wiring harness, fuel injector pass through wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the fuel injector pass through wiring harness.
  • Replace the pass through connector

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Fuel injector isolation test

Solution: S00004511

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Turn keyswitch OFF.
  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Verify that the rocker levers are not contacting the fuel injector wiring harness.

Specification

  • If the rocker levers are contacting the fuel injector wiring harness, then proceed to the Repair section.
  • If multiple fault codes from the same bank are active, then proceed to the Linked Solutions section.

Linked Solutions

  • Fuel injector isolation test

Refer to S00004111

Repair

  • Repair or replace the fuel injector pass through wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6.1 - Fuel injector solenoid isolation test

Solution: S00004111

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the fuel injector wiring harness from the fuel injector solenoid associated with the fault code.
  • Place electrical tape on the ends of the fuel injector wiring harness ends so they do not come into contact with each other or engine block ground.
  • Place the rocker lever cover back on the engine.
  • Idle the engine for 1 minute.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If only the fault code associated with the disconnected fuel injector is active, then a malfunction of that fuel fuel injector has been detected.
  • If multiple fault codes from the same bank are active, then reconnect the disconnected fuel injector and repeat the previous steps for the next fuel injector in the bank.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

7 - ECM fuel injector solenoid driver is malfunctioning

Solution: S00000533

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect previously disconnected components.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to clear the fault codes.
  • Run the engine at idle for the following minutes: 1
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Check for multiple fuel injector faults in the same fuel injector driver bank.

Specification

  • If there are multiple fuel injector faults in the same fuel injector driver bank and all of the previous solutions have been completed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 334 | SPN: 110 | FMI: 2
Engine Coolant Temperature - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Thermostat is malfunctioning
  3. Out-of-chassis opening temperature test
  4. ECM calibration revision history check
  5. Coolant temperature sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000074

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Engine coolant temperature: 144, 145

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Thermostat is malfunctioning

Solution: S00000785

Verification

Conditions

  • Engine running.

Action

  • Allow the engine to reach operating temperature.
  • Check the thermostat opening temperature with an infrared temperature gun.
  • Check the coolant thermostat for proper operation.

Refer to Procedure 008-013

  • Check for a damaged or leaking thermostat seal.

Refer to Procedure 008-013

  • If a temperature gun is not available or if the temperature gun reading is above the correct thermostat opening temperature, then proceed to Linked Solutions section.

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • Out-of-chassis opening temperature test

Refer to S00001359

Repair

  • Replace the engine coolant thermostat.

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Out-of-chassis opening temperature test

Solution: S00001359

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the out-of-chassis opening temperature test.

Refer to Procedure 008-013

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine coolant thermostat.

Refer to Procedure 008-013

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Coolant temperature sensor is malfunctioning

Solution: S00001238

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the engine coolant temperature sensor.

Refer to Procedure 019-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 338 | SPN: 1267 | FMI: 3
Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. Idle shutdown vehicle accessory relay is malfunctioning
  3. Idle shutdown relay open circuit check
  4. Idle shutdown relay SIGNAL pin short in the OEM power wiring harness
  5. Idle shutdown relay circuit pin to pin short

1 - Incorrect adjustable parameter setting

Solution: S00001166

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Go to Features and Parameters.

Specification

  • If the vehicle has an idle shutdown relay installed, the parameter Shutdown Accessory Relay must be set to "Installed".
  • If the vehicle does not have an idle shutdown relay installed, the parameter Shutdown Accessory Relay must be set to "Not Installed".

Linked Solutions

  • None

Repair

  • Correct the Idle Shutdown feature setup.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Idle shutdown vehicle accessory relay is malfunctioning

Solution: S00000520

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace idle shutdown relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Idle shutdown relay open circuit check

Solution: S00000847

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the idle shutdown relay RETURN pin at the idle shutdown relay connector to ground.
  • Measure the resistance between the engine wiring harness ECM connector idle shutdown relay RETURN pin and the OEM wiring harness idle shutdown relay connector RETURN pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Idle shutdown relay SIGNAL pin short in the OEM power wiring harness

Solution: S00001165

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the idle shutdown relay from the OEM wiring harness.
  • Disconnect the OEM power supply wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the idle shutdown relay SIGNAL pin in the OEM wiring harness ECM connector and the ECM battery supply (+) pin of the OEM wiring harness ECM connector.
  • Measure the resistance between the idle shutdown relay SIGNAL pin in the OEM wiring harness ECM connector and the ECM battery supply (-) pin of the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification:

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Idle shutdown relay circuit pin to pin short

Solution: S00000521

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the idle shutdown relay SIGNAL pin in the OEM wiring harness ECM connector and all other pins in the OEM wiring harness ECM connector.
  • Measure the resistance between the idle shutdown relay SIGNAL pin in the OEM wiring harness ECM connector and the ECM battery supply (+) pin of the OEM wiring harness ECM connector.
  • Measure the resistance between the idle shutdown relay SIGNAL pin in the OEM wiring harness ECM connector and the ECM battery supply (-) pin of the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification:

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 339 | SPN: 1267 | FMI: 4
Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. Idle shutdown vehicle accessory relay is malfunctioning
  3. Idle shutdown relay voltage check
  4. Idle shutdown relay SIGNAL and RETURN wires resistance check
  5. Idle shutdown relay SIGNAL wire short to ground in OEM wiring harness
  6. Idle shutdown relay SIGNAL pin short in the OEM power wiring harness
  7. Idle shutdown relay circuit pin to pin short

1 - Incorrect adjustable parameter setting

Solution: S00001166

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Go to Features and Parameters.

Specification

  • If the vehicle has an idle shutdown relay installed, the parameter Shutdown Accessory Relay must be set to "Installed".
  • If the vehicle does not have an idle shutdown relay installed, the parameter Shutdown Accessory Relay must be set to "Not Installed".

Linked Solutions

  • None

Repair

  • Correct the Idle Shutdown feature setup.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Idle shutdown vehicle accessory relay is malfunctioning

Solution: S00000520

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace idle shutdown relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Idle shutdown relay voltage check

Solution: S00000528

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the idle shutdown relay SIGNAL pin and the idle shutdown relay RETURN pin at the idle shutdown relay connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Idle shutdown relay SIGNAL and RETURN wires resistance check

Refer to S00000529

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Idle shutdown relay SIGNAL and RETURN wires resistance check

Solution: S00000529

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the idle shutdown relay SIGNAL pin at the idle shutdown relay connector of the OEM wiring harness and the idle shutdown relay SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the idle shutdown relay RETURN pin at the idle shutdown relay connector of the OEM wiring harness and the idle shutdown relay RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Idle shutdown relay SIGNAL wire short to ground in OEM wiring harness

Solution: S00000527

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the idle shutdown relay SIGNAL pin in the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification:

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Idle shutdown relay SIGNAL pin short in the OEM power wiring harness

Solution: S00001165

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the idle shutdown relay from the OEM wiring harness.
  • Disconnect the OEM power supply wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the idle shutdown relay SIGNAL pin in the OEM wiring harness ECM connector and the ECM battery supply (+) pin of the OEM wiring harness ECM connector.
  • Measure the resistance between the idle shutdown relay SIGNAL pin in the OEM wiring harness ECM connector and the ECM battery supply (-) pin of the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification:

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Idle shutdown relay circuit pin to pin short

Solution: S00000521

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the idle shutdown relay SIGNAL pin in the OEM wiring harness ECM connector and all other pins in the OEM wiring harness ECM connector.
  • Measure the resistance between the idle shutdown relay SIGNAL pin in the OEM wiring harness ECM connector and the ECM battery supply (+) pin of the OEM wiring harness ECM connector.
  • Measure the resistance between the idle shutdown relay SIGNAL pin in the OEM wiring harness ECM connector and the ECM battery supply (-) pin of the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification:

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 343 | SPN: 629 | FMI: 12
Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Troubleshooting Summary

  1. Intermittent ground connection
  2. Battery or battery cables are malfunctioning
  3. Charging system alternator is malfunctioning
  4. Keyswitch open circuit check
  5. ECM calibration revision history check
  6. ECM Malfunction

1 - Intermittent ground connection

Solution: S00000690

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect all of the engine block, starter, alternator, chassis, and battery ground connections.

Refer to OEM Service Manual

  • Verify all of the grounds are present and properly grounded.
  • Inspect all connections for corrosion or loose connections.

Refer to OEM Service Manual

  • Visually inspect the batteries and the battery cable connections for corrosion.

Specification

  • All grounds must be present, properly grounded, free of corrosion, and tight.

Linked Solutions

  • None

Repair

  • Repair or replace damaged connections.

Refer to Procedure 019-008

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Charging system alternator is malfunctioning

Solution: S00000532

Verification

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the charging system alternator and the battery.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Test the charging system alternator output.

Refer to Procedure 013-001

Specification

  • If the charging system alternator output does not meet specification, then a malfunctioning alternator has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the alternator.

Refer to Procedure 013-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Keyswitch open circuit check

Solution: S00000530

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the keyswitch ignition post in the keyswitch assembly to keyswitch input SIGNAL pin of the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM Malfunction

Solution: S00001622

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 346 | SPN: 630 | FMI: 12
Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00003835

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the adjustable parameters settings.

Refer to Procedure 019-078

Verify only one parameter is enabled for the following combinations:

  • Accelerator interlock switch or powertrain protection torque limit switch.
  • Air shutoff valve or idle shutdown.
  • Switched maximum engine operating speed, switched maximum vehicle speed or governor type switch.
  • Vehicle brake lamp or battery power required lamp.
  • Remote PTO or station PTO.
  • Vehicle speed source - rear axle ratio or accelerator brake override.

Specification

  • If more than one parameter is enabled in the combinations, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Adjust the features and parameters to the correct settings.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 351 | SPN: 3597 | FMI: 12
Injector Power Supply - Bad Intelligent Device or Component

Troubleshooting Summary

  1. Check for primary fault codes
  2. Battery or battery cables are malfunctioning
  3. ECM power supply open circuit check
  4. Engine control module power supply circuit pin to ground short
  5. ECM calibration revision history check
  6. Internal ECM Error

1 - Check for primary fault codes

Solution: S00000077

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Voltage: 441

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM power supply open circuit check

Solution: S00001889

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ECM battery SUPPLY (+) pins at the OEM wiring harness connector and the battery positive (+) pins at the battery positive (+) connection.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Repair section if the resistance is greater than the following specification: 0.5 Ω
  • Proceed to the Linked Solutions section if the resistance is less than the following specification: 0.5 Ω

Linked Solutions

Click on the link below:

  • Engine control module power supply circuit pin to ground short

Refer to S00002882

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the fuse.

Refer to OEM Service Manual

  • For a loose or corroded ground connection tighten and clean the ground connection.

Refer to OEM Service Manual

Validation

  • None
Next Solution

3.1 - Engine control module power supply circuit pin to ground short

Solution: S00002882

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the battery negative (-) pins at the OEM wiring harness connector to engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Repair section if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuse.

Refer to OEM Service Manual

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Refer to OEM Service Manual

  • For a loose or corroded ground connection tighten and clean the ground connection.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Internal ECM Error

Solution: S00001230

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 352 | SPN: 3509 | FMI: 4
Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. ECM sensor supply 1 voltage below normal

1 - ECM sensor supply 1 voltage below normal

Solution: S00000535

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Perform the following actions one at a time:
  • Disconnect the engine turbocharger compressor intake pressure/temperature sensor from the engine wiring harness.
  • Disconnect the camshaft position sensor from the engine wiring harness.
  • Disconnect the engine intake manifold pressure/temperature sensor from the engine wiring harness.
  • Disconnect the crankcase pressure sensor from the engine wiring harness.
  • Disconnect the engine barometric pressure sensor from the engine wiring harness.
  • Disconnect the lubricating oil pressure sensor from the engine wiring harness.
  • Disconnect the engine wiring harness from the ECM.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code goes inactive when a component is disconnected, then a malfunctioning sensor supply component has been detected.
  • If the fault code stays active when the engine wiring harness is disconnected, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace turbocharger compressor intake pressure sensor.

Refer to Procedure 019-395

  • Replace camshaft position sensor.

Refer to Procedure 019-363

  • Clean or replace intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

  • Replace crankcase pressure sensor.

Refer to Procedure 019-445

  • Replace barometric air pressure sensor.

Refer to Procedure 019-004

  • Replace the lubricating oil pressure sensor.

Refer to Procedure 019-066

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 386 | SPN: 3509 | FMI: 3
Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. ECM sensor supply 1 voltage above normal
  2. ECM calibration revision history check

1 - ECM sensor supply 1 voltage above normal

Solution: S00002196

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine wiring harness has been detected if the following fault code did not become active with the engine wiring harness disconnected: 386
  • A malfunctioning ECM has been detected if the following fault code became active with the engine wiring harness disconnected: 386

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 415 | SPN: 100 | FMI: 1
Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Technical Service Bulletin is available
  2. Check for primary fault codes
  3. Basic oil system checks
  4. Contaminated lubricating oil
  5. Lubricating oil pressure sensor stuck in-range
  6. Lubricating oil filter plugged
  7. Lubricating oil pressure relief valve is malfunctioning
  8. Loose or broken lubricating oil suction tube
  9. Main lubricating oil pressure regulator is malfunctioning
  10. Lubricating oil pump is malfunctioning
  11. ECM calibration revision history check

1 - Technical Service Bulletin is available

Solution: S00008863

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb190003

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Check for primary fault codes

Solution: S00000078

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Oil: 135, 141
  • Sensor supply 1: 352, 386

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

3 - Basic oil system checks

Solution: S00000474

Verification

Conditions

  • Turn keyswitch OFF.

Action

CAUTION: Do not start an engine that has low oil pressure fault codes/complaints until it has been verified that the oil level is correct and that the oil filter is not plugged. Internal engine damage can result from low or no oil pressure.

  • Interview the operator about the complaint. Ask if the fault occurs when climbing or descending a steep hill to determine if engine angularity is a potential issue.
  • Visually inspect engine for external lubricating oil leaks.
  • Check that the lubricating oil level is correct.

Refer to OEM Service Manual

Specification

  • If an oil leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the component that is the source of the leak.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Contaminated lubricating oil

Solution: S00000462

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Determine if the lubrication oil is contaminated with coolant or fuel.

Specification

  • If the oil level is high and coolant contamination has been detected, then reset the search to Coolant in the oil.
  • If the oil level is high and fuel contamination has been detected, then reset the search to Fuel in the oil.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Lubricating oil pressure sensor stuck in-range

Solution: S00000342

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the sensor for damage.
  • Install a mechanical gauge on the engine.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the sensor reading with the recommended Cummins® electronic service tool or equivalent to a mechanical gauge.
  • If the lubricating oil pressure does not meet the minimum specification, do not perform any engine running tests.

Refer to Procedure 018-017

  • Operate engine at rated rpm.
  • Monitor the lubricating oil pressure sensor.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the mechanical gauge must be within: 17 kPa [2.5 psi]
  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the lubricating oil pressure sensor.

Refer to Procedure 019-066

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Lubricating oil filter plugged

Solution: S00000466

Verification

Conditions

  • Turn keyswitch ON.
  • Engine running.
  • Lubricating oil pressure must be above the minimum specification.

Refer to Procedure 018-017

Action

  • If the lubricating oil pressure does not meet the minimum specification, then skip this solution and do not perform the test to measure oil filter differential pressure.
  • Measure the differential pressure drop across the lubricating oil filter.

Refer to Procedure 007-095

Specification

  • If the lubrication oil filter differential pressure is not within the specification, then a plugged lubrication oil filter has been detected.

Refer to Procedure 007-095

Linked Solutions

  • None

Repair

  • Replace the lubricating oil filter.

Refer to Procedure 007-013

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Lubricating oil pressure relief valve is malfunctioning

Solution: S00000471

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the lubricating oil pressure relief valve.

Refer to Procedure 007-021

Specification

  • If the lubricating oil pressure relief valve does not meet specification, then a malfunctioning lubricating oil pressure relief valve has been detected.

Refer to Procedure 007-021

Linked Solutions

  • None

Repair

  • Replace the lubricating oil pressure relief valve.

Refer to Procedure 007-021

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Loose or broken lubricating oil suction tube

Solution: S00000464

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the lubricating oil pan.

Refer to Procedure 007-025

  • Inspect the lubricating oil suction tube and o-ring for damage.

Refer to Procedure 007-035

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the lubricating oil suction tube o-ring or the damaged lubricating oil suction tube.

Refer to Procedure 007-035

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Main lubricating oil pressure regulator is malfunctioning

Solution: S00000469

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the main lubricating oil pressure regulator assembly.

Refer to Procedure 007-031

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the main lubricating oil pressure regulator assembly.

Refer to Procedure 007-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - Lubricating oil pump is malfunctioning

Solution: S00000472

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the lubricating oil pump.

Refer to Procedure 007-031

  • Inspect the lubricating oil pump.

Refer to Procedure 007-031

If the lubricating oil pump was found to be damaged, then inspect the lubricating oil filter for metal.

Specification

  • If damaged, loose or worn gears are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the lubricating oil pump.

Refer to Procedure 007-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

11 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 418 | SPN: 97 | FMI: 15
Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Water accumulation in the fuel filter
  3. OEM wiring harness has a pin to pin short
  4. ECM calibration revision history check
  5. Water in fuel sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000079

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 428, 429

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Water accumulation in the fuel filter

Solution: S00000545

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Water has been detected in the fuel filter if a fault code from the following list is active, or has more than one inactive count within the last 25 engine operating hours: 418, 1852, 4642

Linked Solutions

  • None

Repair

  • Open the water drain from the bottom of the fuel filter to remove the water from the fuel filter.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - OEM wiring harness has a pin to pin short

Solution: S00000590

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the water-in-fuel sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Water in fuel sensor is malfunctioning

Solution: S00000548

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning water in fuel sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace water in fuel sensor.

Refer to Procedure 019-127

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 421 | SPN: 175 | FMI: 16
Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Basic oil system checks
  3. Lubricating oil temperature sensor resistance check
  4. Lubricating oil temperature sensor stuck in-range
  5. Lubricating oil thermostat is malfunctioning
  6. Lubricating oil cooler is malfunctioning or restricted
  7. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00008424

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Engine coolant temperature: 146, 151, 2113, 2114, 2963, 4629, 4631, 5224

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Basic oil system checks

Solution: S00000474

Verification

Conditions

  • Turn keyswitch OFF.

Action

CAUTION: Do not start an engine that has low oil pressure fault codes/complaints until it has been verified that the oil level is correct and that the oil filter is not plugged. Internal engine damage can result from low or no oil pressure.

  • Interview the operator about the complaint. Ask if the fault occurs when climbing or descending a steep hill to determine if engine angularity is a potential issue.
  • Visually inspect engine for external lubricating oil leaks.
  • Check that the lubricating oil level is correct.

Refer to OEM Service Manual

Specification

  • If an oil leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the component that is the source of the leak.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Lubricating oil temperature sensor resistance check

Solution: S00000362

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lubricating oil temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin and the engine oil temperature sensor RETURN pin at the engine oil temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the resistance is not within the following specification: 180 Ω - 160k Ω

Linked Solutions

  • None

Repair

  • Replace the lubricating oil temperature sensor.

Refer to Procedure 019-067

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Lubricating oil temperature sensor stuck in-range

Solution: S00004643

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the lubricating oil temperature sensor
  • Compare the lubricating oil temperature sensor reading to an infrared thermometer or a known value.

Specification

  • If the temperature reading in the recommended Cummins® electronic service tool or equivalent and infrared thermometer or a known value are not within specification, then a malfunctioning lubricating oil temperature sensor has been detected.
  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the known value must be within: +/- 10C [18F]

Linked Solutions

  • None

Repair

  • Replace the lubricating oil temperature sensor.

Refer to Procedure 019-067

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Lubricating oil thermostat is malfunctioning

Solution: S00000811

Verification

Conditions

  • None

Action

  • Check the lubricating oil thermostat for proper operation.

Refer to Procedure 007-039

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning oil thermostat has been detected.

Linked Solutions

  • None

Repair

  • Replace the lubricating oil thermostat.

Refer to Procedure 007-039

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Lubricating oil cooler is malfunctioning or restricted

Solution: S00000543

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the lubricating oil cooler for debris.

Refer to Procedure 007-003

Specification

  • If debris is found in the lubricating oil cooler, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the lubricating oil cooler.

Refer to Procedure 007-003

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 425 | SPN: 175 | FMI: 2
Engine Oil Temperature - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Lubricating oil temperature sensor resistance check
  3. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000086

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Oil: 212, 213

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Lubricating oil temperature sensor resistance check

Solution: S00000362

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lubricating oil temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin and the engine oil temperature sensor RETURN pin at the engine oil temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the resistance is not within the following specification: 180 Ω - 160k Ω

Linked Solutions

  • None

Repair

  • Replace the lubricating oil temperature sensor.

Refer to Procedure 019-067

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 427 | SPN: 639 | FMI: 9
J1939 Network #1 - Abnormal Update Rate

Troubleshooting Summary

  1. ECM data link malfunction
  2. Incorrectly programmed OEM multiplexing unit
  3. ECM calibration revision history check

1 - ECM data link malfunction

Solution: S00003428

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify the J1939 communications between the recommended Cummins® electronic service tool or equivalent and the ECM.

Specification

  • If communication between the ECM and the recommended Cummins® electronic service tool or equivalent can be established, then a malfunctioning OEM SAE J1939 data link circuit has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace OEM side of SAE J1939 data link circuit.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Incorrectly programmed OEM multiplexing unit

Solution: S00000519

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent SAE J1939 Multiplexed Fault Data, located in Advanced ECM data, to determine which multiplexed component is causing the fault.
  • If the status column indicates "Active" for a multiplexed component, check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses. These components can be found under SAE J1939 Multiplexing in Features and Parameters.

Specification

  • If the recommended Cummins® electronic service tool or equivalent SAE J1939 Multiplexed Fault Data is correct, then the OEM VECU is not transmitting the correct source address due to a malfunctioning OEM component or setup issue.
  • If the J1939 Multiplexed Fault Data is not correct, then an incorrect source address has been entered into he engine ECM for OEM J1939 multiplexed component.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the malfunctioning OEM component.

Refer to OEM Service Manual

  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 428 | SPN: 97 | FMI: 3
Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Incorrect water-in-fuel sensor installed
  2. Water in fuel sensor open circuit check
  3. OEM wiring harness has a pin to pin short
  4. Water in fuel sensor is malfunctioning

1 - Incorrect water-in-fuel sensor installed

Solution: S00000588

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the correct water-in-fuel sensor is being used for the engine application.

Specification

  • If the water in fuel sensor is not the correct sensor part number for the engine configuration, then the incorrect sensor has been installed.

Linked Solutions

  • None

Repair

  • Install the correct water in fuel sensor for the engine configuration.

Refer to Procedure 019-127

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Water in fuel sensor open circuit check

Solution: S00000589

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the water in fuel sensor SIGNAL pin at the water in fuel sensor OEM wiring harness connector and the water in fuel sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the water in fuel sensor RETURN pin at the water in fuel sensor OEM wiring harness connector and the water in fuel sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - OEM wiring harness has a pin to pin short

Solution: S00000590

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the water-in-fuel sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Water in fuel sensor is malfunctioning

Solution: S00000548

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning water in fuel sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace water in fuel sensor.

Refer to Procedure 019-127

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 429 | SPN: 97 | FMI: 4
Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. OEM wiring harness has a pin to pin short
  2. Water in fuel sensor is malfunctioning

1 - OEM wiring harness has a pin to pin short

Solution: S00000590

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the water-in-fuel sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Water in fuel sensor is malfunctioning

Solution: S00000548

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning water in fuel sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace water in fuel sensor.

Refer to Procedure 019-127

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 435 | SPN: 100 | FMI: 2
Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Lubricating oil pressure sensor stuck in-range
  3. Lubricating oil pressure check
  4. Lubricating oil pressure relief valve is malfunctioning
  5. Main lubricating oil pressure regulator is malfunctioning
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000087

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Oil: 135, 141

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Lubricating oil pressure sensor stuck in-range

Solution: S00000342

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the sensor for damage.
  • Install a mechanical gauge on the engine.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the sensor reading with the recommended Cummins® electronic service tool or equivalent to a mechanical gauge.
  • If the lubricating oil pressure does not meet the minimum specification, do not perform any engine running tests.

Refer to Procedure 018-017

  • Operate engine at rated rpm.
  • Monitor the lubricating oil pressure sensor.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the mechanical gauge must be within: 17 kPa [2.5 psi]
  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the lubricating oil pressure sensor.

Refer to Procedure 019-066

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Lubricating oil pressure check

Solution: S00003162

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Install a mechanical gauge on the engine.
  • Run the engine at idle.
  • Allow the engine to reach operating temperature.
  • Monitor the lubricating oil pressure.

Specification

  • If the lubricating oil pressure is not within specification, then proceed to the Linked Solutions section.

Refer to Procedure 018-017

Linked Solutions

  • Lubricating oil pressure relief valve is malfunctioning

Refer to S00004717

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Lubricating oil pressure relief valve is malfunctioning

Solution: S00004717

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the lubricating oil pressure relief valve.

Refer to Procedure 007-021

Specification

  • If the lubricating oil pressure relief valve does not meet specification, then a malfunctioning lubricating oil pressure relief valve has been detected.

Refer to Procedure 007-021

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the lubricating oil pressure relief valve.

Refer to Procedure 007-021

Perform following checks for progressive damage.

  • Perform the oil filter analysis.

Refer to Procedure 007-083

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Main lubricating oil pressure regulator is malfunctioning

Solution: S00000469

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the main lubricating oil pressure regulator assembly.

Refer to Procedure 007-031

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the main lubricating oil pressure regulator assembly.

Refer to Procedure 007-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 436 | SPN: 105 | FMI: 2
Intake Manifold 1 Temperature - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Intake manifold temperature sensor stuck in-range
  3. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000088

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold temperature: 153, 154, 2398

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Intake manifold temperature sensor stuck in-range

Solution: S00000334

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the intake manifold temperature sensor reading to an infrared thermometer or a known value.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the known value must be within: +/- 10C [18F]

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 441 | SPN: 168 | FMI: 18
Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Battery or battery cables are malfunctioning
  2. Charging system alternator is malfunctioning
  3. Unswitched battery open circuit check
  4. Unswitched battery circuit pin to pin short
  5. ECM calibration revision history check

1 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Charging system alternator is malfunctioning

Solution: S00000532

Verification

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the charging system alternator and the battery.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Test the charging system alternator output.

Refer to Procedure 013-001

Specification

  • If the charging system alternator output does not meet specification, then a malfunctioning alternator has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the alternator.

Refer to Procedure 013-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Unswitched battery open circuit check

Solution: S00005285

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the ECM battery SUPPLY (+) circuit between the OEM wiring harness ECM connector and the positive (+) terminal of the battery.
  • Measure the resistance of the ECM battery SUPPLY (-) circuit between the OEM wiring harness ECM connector and the positive (-) terminal of the battery.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Unswitched battery circuit pin to pin short

Solution: S00002997

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ECM battery SUPPLY (+) pin of the OEM wiring harness ECM connector to all other pins in that connector.
  • Measure the resistance between the ECM battery SUPPLY (-) pin of the OEM wiring harness ECM connector to all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 442 | SPN: 168 | FMI: 16
Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Battery or battery cables are malfunctioning
  2. Charging system alternator is malfunctioning
  3. ECM calibration revision history check

1 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Charging system alternator is malfunctioning

Solution: S00000532

Verification

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the charging system alternator and the battery.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Test the charging system alternator output.

Refer to Procedure 013-001

Specification

  • If the charging system alternator output does not meet specification, then a malfunctioning alternator has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the alternator.

Refer to Procedure 013-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 451 | SPN: 157 | FMI: 3
Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Fuel rail pressure sensor voltage check
  3. Fuel rail pressure sensor voltage check at the ECM
  4. Fuel rail pressure sensor circuit response
  5. Fuel rail pressure sensor circuit response at the ECM

1 - Check for primary fault codes

Solution: S00006184

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 6: 515, 516

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Fuel rail pressure sensor voltage check

Solution: S00000616

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the fuel rail pressure sensor SUPPLY pin and the fuel rail pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Fuel rail pressure sensor voltage check at the ECM

Refer to S00000617

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Fuel rail pressure sensor voltage check at the ECM

Solution: S00000617

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the fuel rail pressure sensor SUPPLY pin and the fuel rail pressure sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Fuel rail pressure sensor circuit response

Solution: S00000378

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the fuel rail pressure sensor SIGNAL 1 pin and the fuel rail pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel rail pressure sensor has been detected if the following fault code became active with the jumper wire in place: 452

Linked Solutions

  • None

Repair

  • Replace fuel rail pressure sensor.

Refer to Procedure 019-115

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel rail pressure sensor circuit response at the ECM

Solution: S00000604

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the fuel rail pressure sensor SIGNAL 1 pin and the fuel rail pressure sensor RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 452
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 452

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 452 | SPN: 157 | FMI: 4
Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Fuel rail pressure sensor voltage check
  3. Fuel rail pressure sensor voltage check at the ECM
  4. Fuel rail pressure sensor circuit response
  5. Fuel rail pressure sensor circuit response at the ECM

1 - Check for primary fault codes

Solution: S00006184

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 6: 515, 516

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Fuel rail pressure sensor voltage check

Solution: S00000616

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the fuel rail pressure sensor SUPPLY pin and the fuel rail pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Fuel rail pressure sensor voltage check at the ECM

Refer to S00000617

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Fuel rail pressure sensor voltage check at the ECM

Solution: S00000617

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the fuel rail pressure sensor SUPPLY pin and the fuel rail pressure sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Fuel rail pressure sensor circuit response

Solution: S00000379

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuel rail pressure sensor has been detected if the following fault code became active with the sensor disconnected: 451

Linked Solutions

  • None

Repair

  • Replace fuel rail pressure sensor.

Refer to Procedure 019-115

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel rail pressure sensor circuit response at the ECM

Solution: S00000605

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 451
  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 451

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 483 | SPN: 1349 | FMI: 3
Injector Metering Rail 2 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Fuel rail pressure sensor voltage check
  3. Fuel rail pressure sensor voltage check at the ECM
  4. Fuel rail 2 pressure sensor circuit response
  5. Fuel rail pressure sensor circuit response at the ECM

1 - Check for primary fault codes

Solution: S00000094

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 386
  • Sensor supply 6: 515

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Fuel rail pressure sensor voltage check

Solution: S00000616

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the fuel rail pressure sensor SUPPLY pin and the fuel rail pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Fuel rail pressure sensor voltage check at the ECM

Refer to S00000617

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Fuel rail pressure sensor voltage check at the ECM

Solution: S00000617

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the fuel rail pressure sensor SUPPLY pin and the fuel rail pressure sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Fuel rail 2 pressure sensor circuit response

Solution: S00000380

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail 2 pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the fuel rail pressure sensor SIGNAL 2 pin and the fuel rail pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning fuel rail 2 pressure sensor has been detected if the following fault code became active with the jumper wire in place: 484

Linked Solutions

  • None

Repair

  • Replace the fuel rail 2 pressure sensor.

Refer to Procedure 019-115

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel rail pressure sensor circuit response at the ECM

Solution: S00000878

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the fuel rail pressure sensor SIGNAL 2 pin and the fuel rail pressure sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 484
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 484

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 484 | SPN: 1349 | FMI: 4
Injector Metering Rail 2 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Fuel rail pressure sensor voltage check
  3. Fuel rail pressure sensor voltage check at the ECM
  4. Fuel rail 2 pressure sensor circuit response
  5. Fuel rail pressure sensor circuit response at the ECM
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000095

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 6: 516

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Fuel rail pressure sensor voltage check

Solution: S00000616

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the fuel rail pressure sensor SUPPLY pin and the fuel rail pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Fuel rail pressure sensor voltage check at the ECM

Refer to S00000617

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Fuel rail pressure sensor voltage check at the ECM

Solution: S00000617

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the fuel rail pressure sensor SUPPLY pin and the fuel rail pressure sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Fuel rail 2 pressure sensor circuit response

Solution: S00000381

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail 2 pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning fuel rail 2 pressure sensor has been detected if the following fault code became active with the sensor disconnected: 483

Linked Solutions

  • None

Repair

  • Replace fuel rail pressure sensor.

Refer to Procedure 019-115

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel rail pressure sensor circuit response at the ECM

Solution: S00000879

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 483
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 483

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 488 | SPN: 105 | FMI: 16
Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Cooling fan component inspection
  3. High intake manifold temperature basic checks
  4. Radiator is externally obstructed
  5. Intake manifold temperature sensor stuck in-range
  6. Thermostat is malfunctioning
  7. Out-of-chassis opening temperature test
  8. Malfunctioning cooling fan drive or cooling fan controls
  9. Overhead component damaged or out of adjustment
  10. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000106

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold temperature: 153, 154
  • Fan control circuit: 245, 2377

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Cooling fan component inspection

Solution: S00001686

Verification

Conditions

  • Turn keyswitch OFF.

Action

Inspect the following components if applicable:

  • Visually inspect the cooling fan and cooling fan blades.
  • Visually inspect the cooling fan shroud.
  • Visually inspect the recirculation baffles.
  • Inspect the cooling fan belt.

Refer to Procedure 008-002

  • Visually inspect the cooling fan hub assembly.
  • Visually inspect the automatic cooling fan belt tensioner.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - High intake manifold temperature basic checks

Solution: S00000459

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Refer to Procedure 010-031

  • Visually inspect the charge-air cooler for damage or debris blocking the air flow.

Refer to Procedure 010-027

  • Visually inspect the air conditioner condenser.

Refer to OEM Service Manual

  • Visually inspect the radiator fins for damage or debris blocking the air flow.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Radiator is externally obstructed

Solution: S00000485

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the radiator for damage.
  • Visually inspect the radiator for any type of external obstruction.
  • Check for closed cold weather radiator cover or winterfront.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the restricted radiator.

Refer to OEM Service Manual

  • Remove the obstruction.

Refer to OEM Service Manual

  • Repair or replace cold weather radiator cover or winterfront.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Intake manifold temperature sensor stuck in-range

Solution: S00000334

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the intake manifold temperature sensor reading to an infrared thermometer or a known value.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the known value must be within: +/- 10C [18F]

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Thermostat is malfunctioning

Solution: S00000785

Verification

Conditions

  • Engine running.

Action

  • Allow the engine to reach operating temperature.
  • Check the thermostat opening temperature with an infrared temperature gun.
  • Check the coolant thermostat for proper operation.

Refer to Procedure 008-013

  • Check for a damaged or leaking thermostat seal.

Refer to Procedure 008-013

  • If a temperature gun is not available or if the temperature gun reading is above the correct thermostat opening temperature, then proceed to Linked Solutions section.

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • Out-of-chassis opening temperature test

Refer to S00001359

Repair

  • Replace the engine coolant thermostat.

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6.1 - Out-of-chassis opening temperature test

Solution: S00001359

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the out-of-chassis opening temperature test.

Refer to Procedure 008-013

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine coolant thermostat.

Refer to Procedure 008-013

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

7 - Malfunctioning cooling fan drive or cooling fan controls

Solution: S00000490

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Monitor the cooling fan operation.

Refer to Procedure 008-027

Specification

  • If the cooling fan operation is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.
  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Overhead component damaged or out of adjustment

Solution: S00005074

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.
  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Adjust the overhead.

Refer to Procedure 003-004

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 515 | SPN: 3514 | FMI: 3
Sensor Supply 6 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. ECM sensor supply 6 voltage above normal
  2. ECM calibration revision history check

1 - ECM sensor supply 6 voltage above normal

Solution: S00000026

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine wiring harness has been detected if the following fault code did not become active with the engine wiring harness disconnected: 515
  • A malfunctioning ECM has been detected if the following fault code became active with the engine wiring harness disconnected: 515

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 516 | SPN: 3514 | FMI: 4
Sensor Supply 6 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. ECM sensor supply 6 voltage below normal
  2. ECM calibration revision history check

1 - ECM sensor supply 6 voltage below normal

Solution: S00000934

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Perform the following actions one at a time:
  • Disconnect the fuel rail pressure sensor from the engine wiring harness.
  • Disconnect the engine wiring harness from the ECM.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code goes inactive when a component is disconnected, then a malfunctioning sensor supply component has been detected.
  • If the fault code stays active when the engine wiring harness is disconnected, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace fuel rail pressure sensor.

Refer to Procedure 019-115

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 553 | SPN: 157 | FMI: 16
Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Air in fuel check
  3. High fuel drain line restriction
  4. Fuel pump actuator has high resistance
  5. Fuel pump actuator o-ring is malfunctioning
  6. ECM calibration revision history check
  7. Fuel pump actuator is malfunctioning

1 - Check for primary fault codes

Solution: S00000108

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 271, 272, 449, 2311

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Air in fuel check

Solution: S00004548

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify adequate fuel level in the tank.

Refer to OEM Service Manual

  • Inspect for air being ingested into the fuel.

Refer to Procedure 006-003

Specification

  • If air is present in the fuel flow, then a damaged fuel supply line, loose or damaged fuel filter, or a loose connection has been detected.

Linked Solutions

  • None

Repair

Repair or replace the following components if they are found out of specification:

  • Tighten the loose fitting or replace the damaged component that allows air to enter the fuel system.

Refer to Procedure 006-003

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - High fuel drain line restriction

Solution: S00000537

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect fuel drain line for signs of kinks or damage.
  • Measure the fuel drain line restriction.

Refer to Procedure 006-012

Specification

  • If the fuel drain line restriction is not within the specification, then high fuel drain line restriction has been detected.

Linked Solutions

  • None

Repair

  • Replace fuel drain line.

Refer to Procedure 006-013

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel pump actuator has high resistance

Solution: S00000859

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the fuel pump actuator resistance.

Refer to Procedure 019-117

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the fuel pump actuator.

Refer to Procedure 019-117

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Fuel pump actuator o-ring is malfunctioning

Solution: S00000620

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the fuel pump actuator.

Action

  • Visually inspect fuel pump actuator for a cut or damaged o-ring.
  • Visually inspect the wiring or body of the actuator for damage.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the o-ring.

Refer to Procedure 019-117

  • Replace the fuel pump actuator.

Refer to Procedure 019-117

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Fuel pump actuator is malfunctioning

Solution: S00000980

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning fuel pump actuator have been detected.

Linked Solutions

  • None

Repair

  • Replace the fuel pump actuator.

Refer to Procedure 019-117

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 555 | SPN: 101 | FMI: 16
Crankcase Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Lubricating oil level is incorrect
  3. Plugged external crankcase breather tube
  4. Crankcase pressure sensor stuck in-range
  5. Crankcase Blowby Check
  6. Plugged external crankcase breather tube
  7. Turbocharger leaking air into crankcase
  8. Air compressor leaking air into crankcase
  9. Worn or damaged power cylinder components
  10. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001079

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Crankcase pressure: 1843, 1844, 3733, 3734

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Lubricating oil level is incorrect

Solution: S00003234

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Make sure the vehicle is on a level surface with the engine off.
  • Check that the lubricating oil level is correct.
  • Determine if the lubrication oil is contaminated with coolant or fuel.

Specification

  • If the oil level is high and coolant contamination has been detected, then reset the search to Coolant in the oil.
  • If the oil level is high and fuel contamination has been detected, then reset the search to Fuel in the oil.
  • If the oil level is high and no coolant or fuel contamination has been detected, then incorrect oil dipstick calibration has been detected.
  • If the oil level is normal, then proceed to the next solution.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Reset search for coolant in the lubricating oil.
  • Search for fuel in oil.
  • Calibrate the lubricating oil dipstick for the proper oil level.

Refer to Procedure 007-009

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Plugged external crankcase breather tube

Solution: S00000626

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the oil drain tubes, check valves, breather tubes, and oil separator for plugging.

Refer to Procedure 003-001

It is important to check for a frozen, plugged, or restricted crankcase breather tubes in extreme cold ambient temperatures. Ice can form in the crankcase breather tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Specification

  • If an obstruction is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the crankcase ventilation oil drain tubes, check valves, breather tube, or separator.

Refer to Procedure 003-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Crankcase pressure sensor stuck in-range

Solution: S00000623

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the crankcase pressure sensor.

Specification

  • A malfunctioning crankcase pressure sensor has been detected if the crankcase pressure sensor is not within the following specification: 0 ± 0.28 kPa - G [0 ± 1.2 in H2O]

Linked Solutions

  • None

Repair

  • Replace crankcase pressure sensor.

Refer to Procedure 019-445

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Crankcase Blowby Check

Solution: S00000621

Verification

Conditions

  • Turn keyswitch OFF.

Action

It is important to check for a frozen, plugged, or restricted crankcase breather tubes in extreme cold ambient temperatures. Ice can form in the crankcase breather tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

  • Check the crankcase breather element type.
  • If the element is not a maintenance free insert, then check the maintenance interval to determine if the maintenance interval has been exceeded.
  • Start the engine.
  • Perform the crankcase blowby measurement test.

Refer to Procedure 014-010

Specification

  • If the crankcase breather element exceeds the maintenance interval, then proceed to the Repair section.
  • If the blowby measurement is not within specification with the element bypassed, then proceed to the Linked Solutions section.

Linked Solutions

Click on the link below:

  • Plugged external crankcase breather tube

Refer to S00001375

  • Turbocharger leaking air into crankcase

Refer to S00001203

  • Air compressor leaking air into crankcase

Refer to S00001204

  • Worn or damaged power cylinder components

Refer to S00001381

Repair

  • Replace the crankcase breather element.

Refer to Procedure 003-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5.1 - Plugged external crankcase breather tube

Solution: S00001375

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the oil drain tubes, check valves, breather tubes, and oil separator for plugging.

Refer to Procedure 003-018

It is important to check for a frozen, plugged, or restricted crankcase breather tubes in extreme cold ambient temperatures. Ice can form in the crankcase breather tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Specification

  • If the crankcase breather element is incorrectly installed or the crankcase breather inlet hose is restricted or damaged, then a malfunction of the crankcase breather element or restricted crankcase breather inlet hose has been detected.

Linked Solutions

  • None

Repair

  • Clean or replace the crankcase ventilation oil drain tubes, check valves, breather tube, or separator.

Refer to Procedure 003-018

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.2 - Turbocharger leaking air into crankcase

Solution: S00001203

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the crankcase blowby measurement test with the turbocharger isolated.

Refer to Procedure 014-010

Specification

  • If the turbocharger blowby contribution is out of specification, then a malfunctioning turbocharger has been detected.

Linked Solutions

  • None

Repair

  • Replace the turbocharger.

Refer to Procedure 010-033

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.3 - Air compressor leaking air into crankcase

Solution: S00001204

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the crankcase blowby measurement test with the air compressor isolated.

Refer to Procedure 014-010

Specification

  • If the air compressor blowby contribution is out of specification, then a malfunctioning air compressor has been detected.

Linked Solutions

  • None

Repair

  • Replace the air compressor.

Refer to Procedure 012-014

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.4 - Worn or damaged power cylinder components

Solution: S00001381

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pistons.

Refer to Procedure 001-043

  • Inspect the piston rings.

Refer to Procedure 001-047

Refer to tsb150069

  • Inspect the cylinder liners.

Refer to Procedure 001-028

Refer to tsb140030

Specification

  • If damaged or worn power cylinder components are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the piston.

Refer to Procedure 001-043

  • Replace the piston ring.

Refer to Procedure 001-047

  • Repair or replace the cylinder liner.

Refer to Procedure 001-028

Validation

  • None
Parent Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 556 | SPN: 101 | FMI: 0
Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Lubricating oil level is incorrect
  3. Plugged external crankcase breather tube
  4. Crankcase pressure sensor stuck in-range
  5. Crankcase Blowby Check
  6. Plugged external crankcase breather tube
  7. Turbocharger leaking air into crankcase
  8. Air compressor leaking air into crankcase
  9. Worn or damaged power cylinder components
  10. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001080

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Crankcase pressure: 1843, 1844, 3733, 3734

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Lubricating oil level is incorrect

Solution: S00003234

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Make sure the vehicle is on a level surface with the engine off.
  • Check that the lubricating oil level is correct.
  • Determine if the lubrication oil is contaminated with coolant or fuel.

Specification

  • If the oil level is high and coolant contamination has been detected, then reset the search to Coolant in the oil.
  • If the oil level is high and fuel contamination has been detected, then reset the search to Fuel in the oil.
  • If the oil level is high and no coolant or fuel contamination has been detected, then incorrect oil dipstick calibration has been detected.
  • If the oil level is normal, then proceed to the next solution.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Reset search for coolant in the lubricating oil.
  • Search for fuel in oil.
  • Calibrate the lubricating oil dipstick for the proper oil level.

Refer to Procedure 007-009

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Plugged external crankcase breather tube

Solution: S00000626

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the oil drain tubes, check valves, breather tubes, and oil separator for plugging.

Refer to Procedure 003-001

It is important to check for a frozen, plugged, or restricted crankcase breather tubes in extreme cold ambient temperatures. Ice can form in the crankcase breather tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Specification

  • If an obstruction is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the crankcase ventilation oil drain tubes, check valves, breather tube, or separator.

Refer to Procedure 003-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Crankcase pressure sensor stuck in-range

Solution: S00000623

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the crankcase pressure sensor.

Specification

  • A malfunctioning crankcase pressure sensor has been detected if the crankcase pressure sensor is not within the following specification: 0 ± 0.28 kPa - G [0 ± 1.2 in H2O]

Linked Solutions

  • None

Repair

  • Replace crankcase pressure sensor.

Refer to Procedure 019-445

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Crankcase Blowby Check

Solution: S00000621

Verification

Conditions

  • Turn keyswitch OFF.

Action

It is important to check for a frozen, plugged, or restricted crankcase breather tubes in extreme cold ambient temperatures. Ice can form in the crankcase breather tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

  • Check the crankcase breather element type.
  • If the element is not a maintenance free insert, then check the maintenance interval to determine if the maintenance interval has been exceeded.
  • Start the engine.
  • Perform the crankcase blowby measurement test.

Refer to Procedure 014-010

Specification

  • If the crankcase breather element exceeds the maintenance interval, then proceed to the Repair section.
  • If the blowby measurement is not within specification with the element bypassed, then proceed to the Linked Solutions section.

Linked Solutions

Click on the link below:

  • Plugged external crankcase breather tube

Refer to S00001375

  • Turbocharger leaking air into crankcase

Refer to S00001203

  • Air compressor leaking air into crankcase

Refer to S00001204

  • Worn or damaged power cylinder components

Refer to S00001381

Repair

  • Replace the crankcase breather element.

Refer to Procedure 003-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5.1 - Plugged external crankcase breather tube

Solution: S00001375

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the oil drain tubes, check valves, breather tubes, and oil separator for plugging.

Refer to Procedure 003-018

It is important to check for a frozen, plugged, or restricted crankcase breather tubes in extreme cold ambient temperatures. Ice can form in the crankcase breather tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Specification

  • If the crankcase breather element is incorrectly installed or the crankcase breather inlet hose is restricted or damaged, then a malfunction of the crankcase breather element or restricted crankcase breather inlet hose has been detected.

Linked Solutions

  • None

Repair

  • Clean or replace the crankcase ventilation oil drain tubes, check valves, breather tube, or separator.

Refer to Procedure 003-018

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.2 - Turbocharger leaking air into crankcase

Solution: S00001203

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the crankcase blowby measurement test with the turbocharger isolated.

Refer to Procedure 014-010

Specification

  • If the turbocharger blowby contribution is out of specification, then a malfunctioning turbocharger has been detected.

Linked Solutions

  • None

Repair

  • Replace the turbocharger.

Refer to Procedure 010-033

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.3 - Air compressor leaking air into crankcase

Solution: S00001204

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the crankcase blowby measurement test with the air compressor isolated.

Refer to Procedure 014-010

Specification

  • If the air compressor blowby contribution is out of specification, then a malfunctioning air compressor has been detected.

Linked Solutions

  • None

Repair

  • Replace the air compressor.

Refer to Procedure 012-014

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.4 - Worn or damaged power cylinder components

Solution: S00001381

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pistons.

Refer to Procedure 001-043

  • Inspect the piston rings.

Refer to Procedure 001-047

Refer to tsb150069

  • Inspect the cylinder liners.

Refer to Procedure 001-028

Refer to tsb140030

Specification

  • If damaged or worn power cylinder components are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the piston.

Refer to Procedure 001-043

  • Replace the piston ring.

Refer to Procedure 001-047

  • Repair or replace the cylinder liner.

Refer to Procedure 001-028

Validation

  • None
Parent Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 559 | SPN: 157 | FMI: 18
Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Engine will not start
  3. Low pressure fuel system component is malfunctioning
  4. Fuel Inlet Restriction check
  5. Air in fuel check
  6. Fuel filter differential and gear pump pressure check
  7. Fuel injector return flow check
  8. Fuel injector isolation test
  9. Fuel pressure relief valve return flow excessive
  10. Air in fuel check
  11. High-Pressure Fuel Pump Performance Test
  12. Fuel pump actuator is malfunctioning
  13. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000109

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 271, 272, 281, 449, 451, 452, 484, 553, 1911, 2311, 2343, 2372, 3727, 4691, 4726, 5585
  • Fuel injector: 322, 323, 324, 325, 331, 332
  • Voltage: 1117
  • Sensor supply 6: 515, 516

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Engine will not start

Solution: S00000629

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Attempt to start the engine.

Specification

  • If the engine starts, then proceed to the next Solution.
  • If the engine will not start, then reset the search to crank no start.

Linked Solutions

  • None

Repair

  • Reset the search to crank no start.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Low pressure fuel system component is malfunctioning

Solution: S00005122

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually check fuel tank for adequate fuel supply.

Refer to OEM Service Manual

  • Visually inspect the engine fuel supply lines for signs of kinks, damage or fuel leaks.

Refer to Procedure 006-024

Specification

  • If no damage or leaks are observed, then proceed to the Linked Solutions section.
  • If there is any damage or leaks found in the OEM fuel system, then proceed to the Repair section.

Linked Solutions

  • Fuel Inlet Restriction check

Refer to S00001206

  • Air in fuel check

Refer to S00001205

  • Fuel filter differential and gear pump pressure check

Refer to S00005034

Repair

  • Repair or replace the OEM fuel lines.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3.1 - Fuel Inlet Restriction check

Solution: S00001206

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Measure the fuel inlet restriction.

Refer to Procedure 006-020

Specification

  • If the engine will not start, then proceed to the next solution.

If the inlet restriction is excessive, look for the root cause:

Inspect the following components if applicable:

  • Suction side fuel filters plugged.
  • Fuel heater restricted.

Refer to OEM Service Manual

  • OEM fuel lines restricted.

Refer to OEM Service Manual

  • ECM cooling plate plugged.

Refer to Procedure 006-006

  • ECM cooling plate check valve restricted.

Refer to Procedure 006-006

  • Fuel tank stand pipes restricted.

Refer to OEM Service Manual

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace fuel filter.

Refer to OEM Service Manual

  • Repair or replace the fuel heater.

Refer to OEM Service Manual

  • Repair or replace the OEM fuel lines.

Refer to OEM Service Manual

  • Repair or replace the ECM cooling plate.

Refer to Procedure 006-006

  • Repair or replace the ECM cooling plate check valve.

Refer to Procedure 006-006

  • Repair or replace the fuel tank stand pipe.

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.2 - Air in fuel check

Solution: S00001205

Verification

Conditions

  • Turn keyswitch ON.
  • Verify adequate fuel level in the tank

Action

  • Allow the engine to reach operating temperature.
  • If engine will not start, then perform the check during cranking.
  • Inspect for air being ingested into the fuel.

Refer to Procedure 006-003

Specification

  • If air is present in the fuel flow, then a damaged fuel supply line, loose or damaged fuel filter, or a loose connection has been detected.

Linked Solutions

  • None

Repair

  • Tighten the loose fitting or replace the damaged component that allows air to enter the fuel system.

Refer to Procedure 006-003

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.3 - Fuel filter differential and gear pump pressure check

Solution: S00005034

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Perform the Fuel Filter Restriction Test.

Refer to Procedure 005-236

Specification

  • If the pressure is not within specification at the fuel pressure filter inlet, then a malfunction of the fuel pump gear pump has been detected.
  • If pressure from the fuel pump gear pump is within specification and the differential pressure does not meet specification a plugged or blocked fuel filter has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace fuel filter.

Refer to Procedure 006-065

  • Replace the fuel pump gear pump.

Refer to Procedure 005-025

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Fuel injector return flow check

Solution: S00000631

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the High-Pressure Injector Return Flow Test.

Refer to Procedure 005-236

Specification

  • If the High-Pressure Injector Return Flow Test is out of specification, then tighten the fuel injector connector nuts and perform the High-Pressure Injector Return Flow Test again.
  • If the High-Pressure Injector Return Flow Test is still out of specification, then proceed to the Linked Solutions section.

Linked Solutions

  • Fuel injector isolation test

Refer to S00001280

Repair

  • Check the torque on the fuel connector retaining nuts and tighten if necessary.

Refer to Procedure 006-052

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4.1 - Fuel injector isolation test

Solution: S00001280

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the High-Pressure Injector Return Flow Isolation Test.

Refer to Procedure 005-236

Specification

  • If the Fuel Injector Return Flow Isolation Test identifies a fuel injector that does not meet specification, then a malfunctioning fuel injector has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Fuel pressure relief valve return flow excessive

Solution: S00000632

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the Fuel Pressure Relief Valve Return Flow Test.

Refer to Procedure 005-236

Specification

  • If the fuel rail return flow does not meet the specification at the fuel rail pressure relief valve, then a malfunctioning fuel rail relief valve has been detected.

Linked Solutions

  • None

Repair

  • Replace the fuel pressure relief valve.

Refer to Procedure 006-061

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Air in fuel check

Solution: S00004548

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify adequate fuel level in the tank.

Refer to OEM Service Manual

  • Inspect for air being ingested into the fuel.

Refer to Procedure 006-003

Specification

  • If air is present in the fuel flow, then a damaged fuel supply line, loose or damaged fuel filter, or a loose connection has been detected.

Linked Solutions

  • None

Repair

Repair or replace the following components if they are found out of specification:

  • Tighten the loose fitting or replace the damaged component that allows air to enter the fuel system.

Refer to Procedure 006-003

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - High-Pressure Fuel Pump Performance Test

Solution: S00005120

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the High-Pressure Fuel Pump Performance Test.

Refer to Procedure 005-236

Specification

  • If the measured fuel flow from the high-pressure fuel pump service tool at the recorded engine speed is in the upper region of the graph, the fuel pump is functioning properly.

Refer to Procedure 005-236

  • If the measured fuel flow from the high-pressure fuel pump service tool at the recorded engine speed is in the lower region of the graph, then a malfunctioning fuel pump has been detected.

Refer to Procedure 005-236

  • If the test readings are in the gray area, the fuel pump head must be removed and the fuel pump camshaft and fuel pump camshaft tappet rollers must be inspected.

Refer to Procedure 005-236

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace fuel pump head.

Refer to Procedure 005-227

  • Replace high pressure fuel pump.

Refer to Procedure 005-227

Refer to tsb140019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Fuel pump actuator is malfunctioning

Solution: S00001170

Verification

Conditions

  • Engine running at idle.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor Commanded Fuel Rail Pressure.
  • Monitor Measured Fuel Rail Pressure.

Specification

  • Proceed to the Repair section if the Measured Fuel Rail Pressure deviates from the Commanded Fuel Rail Pressure by more than following: 100 bar [1450 psi]
  • Proceed to the next solution if the Measured Fuel Rail Pressure does not deviate from the Commanded Fuel Rail Pressure by more than the following: 100 bar [1450 psi]

Linked Solutions

  • None

Repair

  • Replace the fuel pump actuator.

Refer to Procedure 019-117

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 584 | SPN: 677 | FMI: 3
Engine Starter Motor Relay Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Starter lockout relay is malfunctioning
  2. Starter lockout relay not enabled
  3. Starter lockout relay voltage circuit check
  4. Starter lockout relay circuit check at the ECM
  5. Starter lockout relay open circuit check
  6. Starter lockout relay circuit pin to pin short

1 - Starter lockout relay is malfunctioning

Solution: S00000637

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the starter lockout relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Starter lockout relay not enabled

Solution: S00000639

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify a starter lockout relay is installed.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Verify the starter lockout relay parameter is set correctly for the application.

Specification

  • If a starter lockout relay is installed and the parameter is not set to "Enable", then the incorrect adjustable parameter is configured.
  • If a starter lockout relay is not installed and the parameter is not set to "Disable", then the incorrect adjustable parameter is configured.

Linked Solutions

  • None

Repair

  • Adjust the features and parameters to the correct settings.

Refer to Procedure 019-078

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Starter lockout relay voltage circuit check

Solution: S00000644

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the starter lockout relay SIGNAL pin and the starter lockout relay RETURN pin at the starter lockout relay connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Starter lockout relay circuit check at the ECM

Refer to S00000646

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Starter lockout relay circuit check at the ECM

Solution: S00000646

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the starter lockout relay SIGNAL pin at the starter lockout relay connector and the starter lockout relay SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the starter lockout relay RETURN pin at the starter lockout relay connector and the starter lockout relay RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω
  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Starter lockout relay open circuit check

Solution: S00000642

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.
  • Measure the resistance between the starter lockout relay SIGNAL pin at the starter lockout relay connector of the OEM wiring harness and the starter lockout relay SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the starter lockout relay RETURN pin at the starter lockout relay connector of the OEM wiring harness and the starter lockout relay RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Starter lockout relay circuit pin to pin short

Solution: S00000643

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the starter lockout relay SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 585 | SPN: 677 | FMI: 4
Engine Starter Motor Relay Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Starter lockout relay is malfunctioning
  2. Starter lockout relay not enabled
  3. Starter lockout relay voltage circuit check
  4. Starter lockout relay circuit check at the ECM
  5. Starter lockout relay circuit pin to ground short
  6. Starter lockout relay circuit pin to pin short

1 - Starter lockout relay is malfunctioning

Solution: S00000637

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the starter lockout relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Starter lockout relay not enabled

Solution: S00000639

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify a starter lockout relay is installed.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Verify the starter lockout relay parameter is set correctly for the application.

Specification

  • If a starter lockout relay is installed and the parameter is not set to "Enable", then the incorrect adjustable parameter is configured.
  • If a starter lockout relay is not installed and the parameter is not set to "Disable", then the incorrect adjustable parameter is configured.

Linked Solutions

  • None

Repair

  • Adjust the features and parameters to the correct settings.

Refer to Procedure 019-078

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Starter lockout relay voltage circuit check

Solution: S00000644

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the starter lockout relay SIGNAL pin and the starter lockout relay RETURN pin at the starter lockout relay connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Starter lockout relay circuit check at the ECM

Refer to S00000646

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Starter lockout relay circuit check at the ECM

Solution: S00000646

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the starter lockout relay SIGNAL pin at the starter lockout relay connector and the starter lockout relay SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the starter lockout relay RETURN pin at the starter lockout relay connector and the starter lockout relay RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω
  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Starter lockout relay circuit pin to ground short

Solution: S00000650

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the starter lockout relay SIGNAL pin in the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Starter lockout relay circuit pin to pin short

Solution: S00000643

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the starter lockout relay SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 595 | SPN: 103 | FMI: 16
Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Intake manifold pressure sensor has carbon buildup
  3. Turbocharger speed sensor is malfunctioning
  4. Intake manifold pressure sensor stuck in-range
  5. Barometric air pressure sensor stuck in-range
  6. Turbocharger speed sensor resistance check
  7. Turbocharger speed sensor open circuit check
  8. Turbocharger speed sensor circuit pin to ground short
  9. Turbocharger speed sensor circuit pin to pin short
  10. ECM calibration revision history check
  11. Turbocharger speed sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000110

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold: 122, 123
  • Barometric pressure: 221, 222

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Intake manifold pressure sensor has carbon buildup

Solution: S00006329

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

  • Visually inspect the intake manifold pressure/temperature sensor tip for soot or carbon buildup.
  • Visually inspect the intake manifold pressure sensor for damage.
  • Visually inspect the intake manifold pressure sensor o-rings for damage.

Specification

  • If any carbon buildup is found, then proceed to the Repair section.
  • If nicks or cuts in or on the o-ring are identified, then a damaged intake manifold pressure/temperature sensor o-ring has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

  • Replace the intake manifold pressure/temperature sensor o-ring.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Turbocharger speed sensor is malfunctioning

Solution: S00002831

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the turbocharger speed sensor from the turbocharger housing.

Refer to Procedure 019-390

  • Visually inspect the turbocharger speed sensor tip for damage.

Refer to Procedure 019-390

Specification

  • If the turbocharger speed sensor tip is damaged, then a malfunctioning turbocharger speed sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace turbocharger speed sensor.

Refer to Procedure 019-390

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Intake manifold pressure sensor stuck in-range

Solution: S00002814

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the intake manifold pressure sensor.

Specification

  • A malfunctioning intake manifold air pressure sensor has been detected if the intake manifold air pressure is not reading within the following specification: 0 ± 6.8 Kpa [0 ± 1 psi], 0 ± 51 mm-Hg [0 ± 2 in- Hg]

Linked Solutions

  • None

Repair

  • Replace the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Barometric air pressure sensor stuck in-range

Solution: S00000340

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the barometric air pressure sensor
  • Compare to the local ambient air pressure.

Refer to Procedure 019-004

Specification

  • A malfunctioning barometric air pressure sensor has been detected if the barometric air pressure sensor is not within the following specification of local ambient air pressure: 51 mm HG [2 in HG]

Linked Solutions

  • None

Repair

  • Replace barometric air pressure sensor.

Refer to Procedure 019-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Turbocharger speed sensor resistance check

Solution: S00002828

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the turbocharger speed sensor SUPPLY pin and the turbocharger speed sensor RETURN pin at the sensor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Repair section if the resistance is not within the following specification: 600 - 1600 Ω

Linked Solutions

  • None

Repair

  • Replace turbocharger speed sensor.

Refer to Procedure 019-390

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Turbocharger speed sensor open circuit check

Solution: S00000653

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the turbocharger speed sensor SIGNAL pin at the turbocharger speed sensor wiring harness connector and the turbocharger speed sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the turbocharger speed sensor RETURN pin at the turbocharger speed sensor wiring harness connector and the turbocharger speed sensor RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Turbocharger speed sensor circuit pin to ground short

Solution: S00000673

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the turbocharger speed SIGNAL pin at the engine wiring harness ECM connector to engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Turbocharger speed sensor circuit pin to pin short

Solution: S00000652

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the turbocharger speed sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the turbocharger speed sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

11 - Turbocharger speed sensor is malfunctioning

Solution: S00000651

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace turbocharger speed sensor.

Refer to Procedure 019-390

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 596 | SPN: 167 | FMI: 16
Electrical Charging System Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Battery or battery cables are malfunctioning
  2. Charging system alternator is malfunctioning
  3. ECM calibration revision history check

1 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Charging system alternator is malfunctioning

Solution: S00000532

Verification

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the charging system alternator and the battery.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Test the charging system alternator output.

Refer to Procedure 013-001

Specification

  • If the charging system alternator output does not meet specification, then a malfunctioning alternator has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the alternator.

Refer to Procedure 013-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 597 | SPN: 167 | FMI: 18
Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Battery or battery cables are malfunctioning
  2. Loose alternator belt
  3. Charging system alternator is malfunctioning
  4. Unswitched battery open circuit check
  5. Unswitched battery circuit pin to pin short
  6. Loose charging system alternator pulley
  7. ECM calibration revision history check

1 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Loose alternator belt

Solution: S00000665

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the alternator belt tension.

Refer to Procedure 013-005

  • Inspect the automatic charging system alternator belt tensioner for correct operation.

Refer to Procedure 013-021

Specification

  • If the belt tension does not meet specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Adjust the alternator belt to the proper belt tension.

Refer to Procedure 013-005

  • Replace the alternator belt.

Refer to Procedure 013-005

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Charging system alternator is malfunctioning

Solution: S00000532

Verification

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the charging system alternator and the battery.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Test the charging system alternator output.

Refer to Procedure 013-001

Specification

  • If the charging system alternator output does not meet specification, then a malfunctioning alternator has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the alternator.

Refer to Procedure 013-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Unswitched battery open circuit check

Solution: S00005285

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the ECM battery SUPPLY (+) circuit between the OEM wiring harness ECM connector and the positive (+) terminal of the battery.
  • Measure the resistance of the ECM battery SUPPLY (-) circuit between the OEM wiring harness ECM connector and the positive (-) terminal of the battery.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Unswitched battery circuit pin to pin short

Solution: S00000668

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the battery.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ECM battery SUPPLY (+) pin of the OEM wiring harness ECM connector to all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Loose charging system alternator pulley

Solution: S00000666

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the alternator pulley for damage.

Refer to Procedure 013-006

  • Check the charging system alternator pulley nut torque.

Refer to Procedure 013-006

Specification

  • If damage has been observed or if alternator pulley nut torque is out of specification, the proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace or adjust the charging system alternator pulley so that it is tight on the shaft.

Refer to Procedure 013-006

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 629 | SPN: 1176 | FMI: 18
Turbocharger 1 Compressor Intake Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Restricted intake air filter
  3. Plugged external crankcase breather tube
  4. Intake manifold pressure sensor has carbon buildup
  5. Intake manifold pressure sensor stuck in-range
  6. Leaks in the intake air system
  7. Charge air cooler system leak
  8. Turbocharger is malfunctioning
  9. Oil discharge from turbocharger compressor
  10. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000111

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold: 125
  • Crankcase pressure: 555, 556

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Restricted intake air filter

Solution: S00000025

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Specification

  • If the intake air filter is plugged, then a restricted intake air filter has been detected.

Linked Solutions

  • None

Repair

  • Replace the air filter.

Refer to OEM Service Manual

Refer to Procedure 010-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Plugged external crankcase breather tube

Solution: S00000626

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the oil drain tubes, check valves, breather tubes, and oil separator for plugging.

Refer to Procedure 003-001

It is important to check for a frozen, plugged, or restricted crankcase breather tubes in extreme cold ambient temperatures. Ice can form in the crankcase breather tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Specification

  • If an obstruction is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the crankcase ventilation oil drain tubes, check valves, breather tube, or separator.

Refer to Procedure 003-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Intake manifold pressure sensor has carbon buildup

Solution: S00006329

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

  • Visually inspect the intake manifold pressure/temperature sensor tip for soot or carbon buildup.
  • Visually inspect the intake manifold pressure sensor for damage.
  • Visually inspect the intake manifold pressure sensor o-rings for damage.

Specification

  • If any carbon buildup is found, then proceed to the Repair section.
  • If nicks or cuts in or on the o-ring are identified, then a damaged intake manifold pressure/temperature sensor o-ring has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

  • Replace the intake manifold pressure/temperature sensor o-ring.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Intake manifold pressure sensor stuck in-range

Solution: S00002814

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the intake manifold pressure sensor.

Specification

  • A malfunctioning intake manifold air pressure sensor has been detected if the intake manifold air pressure is not reading within the following specification: 0 ± 6.8 Kpa [0 ± 1 psi], 0 ± 51 mm-Hg [0 ± 2 in- Hg]

Linked Solutions

  • None

Repair

  • Replace the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Leaks in the intake air system

Solution: S00008386

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.
  • Visually inspect the intake plumbing for possible air leaks.

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Charge air cooler system leak

Solution: S00008815

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the charge air cooler hoses for possible air leaks.
  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If a leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the charge air cooler.

Refer to Procedure 010-027

  • Repair or replace the charge air cooler hoses.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Turbocharger is malfunctioning

Solution: S00005253

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the intake and exhaust connections from the turbocharger.

Action

  • Inspect the turbocharger compressor and turbine blades for damage or wear.

Refer to Procedure 010-033

Specification

  • If any of the checks are not within specification, then a malfunctioning turbocharger has been detected.

Linked Solutions

  • None

Repair

  • Replace the turbocharger.

Refer to Procedure 010-033

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Oil discharge from turbocharger compressor

Solution: S00000670

Verification

Conditions

  • Connect all components.

Action

  • Run the engine for 5 minutes at 1000 rpm.
  • Remove the discharge pipe from the turbocharger compressor.
  • Inspect the discharge line for oil.

Specification

  • If oil residue is found in the discharge pipe, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean the turbocharger compressor outlet and discharge pipe.
  • Assemble the discharge pipe and repeat the Verification procedure up to 5 times.
  • After 5 cleaning cycles, if oil is in the discharge pipe, replace the turbocharger.

Refer to Procedure 010-033

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 649 | SPN: 1378 | FMI: 31
Engine Oil Change Interval - Condition Exists

Troubleshooting Summary

  1. ECM calibration revision history check
  2. Oil change interval maintenance warning

1 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Oil change interval maintenance warning

Solution: S00000671

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or has more than one inactive count within the last 25 engine operating hours, then the lubricating oil maintenance interval has been exceeded.

Linked Solutions

  • None

Repair

  • Change the lubricating oil.

Refer to Procedure 007-037

  • Change the lubricating oil filter.

Refer to Procedure 007-013

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 687 | SPN: 103 | FMI: 18
Turbocharger 1 Speed - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Intake manifold pressure sensor has carbon buildup
  3. Turbocharger speed sensor is malfunctioning
  4. Intake manifold pressure sensor stuck in-range
  5. Turbocharger speed sensor resistance check
  6. Turbocharger speed sensor open circuit check
  7. Turbocharger speed sensor circuit pin to ground short
  8. Turbocharger speed sensor circuit pin to pin short
  9. ECM calibration revision history check
  10. Turbocharger speed sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000112

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold: 122, 123
  • Barometric pressure: 221, 222

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Intake manifold pressure sensor has carbon buildup

Solution: S00006329

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

  • Visually inspect the intake manifold pressure/temperature sensor tip for soot or carbon buildup.
  • Visually inspect the intake manifold pressure sensor for damage.
  • Visually inspect the intake manifold pressure sensor o-rings for damage.

Specification

  • If any carbon buildup is found, then proceed to the Repair section.
  • If nicks or cuts in or on the o-ring are identified, then a damaged intake manifold pressure/temperature sensor o-ring has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

  • Replace the intake manifold pressure/temperature sensor o-ring.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Turbocharger speed sensor is malfunctioning

Solution: S00002831

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the turbocharger speed sensor from the turbocharger housing.

Refer to Procedure 019-390

  • Visually inspect the turbocharger speed sensor tip for damage.

Refer to Procedure 019-390

Specification

  • If the turbocharger speed sensor tip is damaged, then a malfunctioning turbocharger speed sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace turbocharger speed sensor.

Refer to Procedure 019-390

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Intake manifold pressure sensor stuck in-range

Solution: S00002814

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the intake manifold pressure sensor.

Specification

  • A malfunctioning intake manifold air pressure sensor has been detected if the intake manifold air pressure is not reading within the following specification: 0 ± 6.8 Kpa [0 ± 1 psi], 0 ± 51 mm-Hg [0 ± 2 in- Hg]

Linked Solutions

  • None

Repair

  • Replace the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Turbocharger speed sensor resistance check

Solution: S00002828

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the turbocharger speed sensor SUPPLY pin and the turbocharger speed sensor RETURN pin at the sensor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Repair section if the resistance is not within the following specification: 600 - 1600 Ω

Linked Solutions

  • None

Repair

  • Replace turbocharger speed sensor.

Refer to Procedure 019-390

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Turbocharger speed sensor open circuit check

Solution: S00000653

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the turbocharger speed sensor SIGNAL pin at the turbocharger speed sensor wiring harness connector and the turbocharger speed sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the turbocharger speed sensor RETURN pin at the turbocharger speed sensor wiring harness connector and the turbocharger speed sensor RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Turbocharger speed sensor circuit pin to ground short

Solution: S00000673

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the turbocharger speed SIGNAL pin at the engine wiring harness ECM connector to engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Turbocharger speed sensor circuit pin to pin short

Solution: S00000652

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the turbocharger speed sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the turbocharger speed sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - Turbocharger speed sensor is malfunctioning

Solution: S00000651

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace turbocharger speed sensor.

Refer to Procedure 019-390

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 689 | SPN: 190 | FMI: 2
Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Crankshaft tone wheel is damaged
  3. Crankshaft position sensor voltage check
  4. Crankshaft position sensor voltage check at the ECM
  5. Engine crankshaft speed/position sensor check
  6. Crankshaft position sensor open circuit check
  7. Crankshaft position sensor circuit pin to pin short
  8. ECM calibration revision history check
  9. Engine crankshaft speed/position sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000113

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 3: 238, 239
  • Crankshaft speed/position sensor: 284

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Crankshaft tone wheel is damaged

Solution: S00000683

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the crankshaft position sensor.

Refer to Procedure 019-365

  • Visually inspect the crankshaft tone wheel for defects.

Specification

  • If any damage or defects to the tone wheel or gear are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the crankshaft tone wheel.

Refer to Procedure 001-069

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Crankshaft position sensor voltage check

Solution: S00000678

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the crankshaft position sensor SUPPLY pin and the crankshaft position sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Crankshaft position sensor voltage check at the ECM

Refer to S00000679

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Crankshaft position sensor voltage check at the ECM

Solution: S00000679

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the crankshaft positon sensor SUPPLY pin and the crankshaft positon sensor RETURN pin at the ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Engine crankshaft speed/position sensor check

Solution: S00000684

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the crankshaft position sensor.
  • Inspect the crankshaft position sensor for signs of damage, oil leak, and metal debris on the end of the sensor.
  • Verify the crankshaft position sensor is connected properly.
  • Use the ratchet drive side of the socket tool that was used to removed the sensor from the engine, place it flush on the sensor so that the edge of the socket is on the edge of the sensor.
  • Monitor the crankshaft engine speed sensor state using the recommended Cummins® electronic service tool or equivalent and monitor (Engine Speed Main Sensor State) to check if the sensor state transitions.
  • Slowly slide the socket in a perpendicular direction to the marked line on the sensor or in a perpendicular direction to the mounting bracket of the sensor.

Specification

  • If any damage is found to the sensor, then proceed to the Repair section.
  • If the crankshaft position sensor is not connected properly, then proceed to the Repair section.
  • If the crankshaft position sensor state does NOT transition from high to low or low to high, or the state does NOT show triggered, then a malfunctioning crankshaft engine position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine crankshaft speed/position sensor.

Refer to Procedure 019-365

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Crankshaft position sensor open circuit check

Solution: S00000676

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the crankshaft position sensor SIGNAL pin at the crankshaft position sensor engine wiring harness connector to the crankshaft position sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Crankshaft position sensor circuit pin to pin short

Solution: S00000674

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the crankshaft position sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the crankshaft position sensor SIGNAL pin of the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Engine crankshaft speed/position sensor is malfunctioning

Solution: S00000866

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning crankshaft position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace crankshaft position sensor.

Refer to Procedure 019-365

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 691 | SPN: 1172 | FMI: 3
Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Turbocharger compressor intake temperature sensor resistance check
  2. Turbocharger compressor intake temperature sensor circuit response
  3. Turbocharger compressor intake temperature sensor circuit response at the ECM

1 - Turbocharger compressor intake temperature sensor resistance check

Solution: S00003441

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the turbocharger compressor intake temperature sensor SIGNAL pin and the turbocharger compressor intake temperature sensor RETURN pin at the sensor connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning turbocharger compressor intake temperature sensor has been detected if the resistance is not within the following specification: 640 Ω to 62k Ω

Linked Solutions

  • None

Repair

  • Replace turbocharger compressor intake temperature sensor.

Refer to Procedure 019-395

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Turbocharger compressor intake temperature sensor circuit response

Solution: S00000382

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the turbocharger compressor intake temperature sensor SIGNAL pin and the turbocharger compressor intake temperature sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning turbocharger compressor intake temperature sensor has been detected if the following fault code became active with the jumper wire in place: 692

Linked Solutions

  • None

Repair

  • Replace turbocharger compressor intake temperature sensor.

Refer to Procedure 019-395

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Turbocharger compressor intake temperature sensor circuit response at the ECM

Solution: S00000686

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the turbocharger 1 compressor intake temperature sensor SIGNAL pin and the turbocharger 1 compressor intake temperature sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 692
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 692

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 692 | SPN: 1172 | FMI: 4
Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Turbocharger compressor intake temperature sensor circuit response
  2. Turbocharger compressor intake temperature sensor circuit response at the ECM

1 - Turbocharger compressor intake temperature sensor circuit response

Solution: S00000383

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning turbocharger compressor intake temperature sensor has been detected if the following fault code became active with the sensor disconnected: 691

Linked Solutions

  • None

Repair

  • Replace turbocharger compressor intake temperature sensor.

Refer to Procedure 019-395

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Turbocharger compressor intake temperature sensor circuit response at the ECM

Solution: S00000685

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 691
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 691

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 693 | SPN: 1172 | FMI: 2
Turbocharger 1 Compressor Intake Temperature - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Compressor intake temperature sensor stuck in-range
  3. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000116

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Turbocharger: 691, 692

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Compressor intake temperature sensor stuck in-range

Solution: S00004923

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the turbocharger compressor intake pressure/temperature sensor.

Specification

  • A malfunctioning turbocharger compressor intake pressure/temperature sensor has been detected if the turbocharger compressor intake pressure/temperature sensor is not within the following specification of local ambient air temperature: 5.5C [10F]

Linked Solutions

  • None

Repair

  • Replace the turbocharger compressor intake pressure/temperature sensor.

Refer to Procedure 019-466

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 731 | SPN: 723 | FMI: 7
Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment

Troubleshooting Summary

  1. Check for primary fault codes
  2. Intermittent ground connection
  3. Incorrect base engine timing
  4. Camshaft position sensor is damaged
  5. Engine crankshaft speed/position sensor check
  6. Crankshaft/camshaft tone wheel
  7. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001081

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Crankshaft speed/position sensor: 115, 778, 2321

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Intermittent ground connection

Solution: S00000690

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect all of the engine block, starter, alternator, chassis, and battery ground connections.

Refer to OEM Service Manual

  • Verify all of the grounds are present and properly grounded.
  • Inspect all connections for corrosion or loose connections.

Refer to OEM Service Manual

  • Visually inspect the batteries and the battery cable connections for corrosion.

Specification

  • All grounds must be present, properly grounded, free of corrosion, and tight.

Linked Solutions

  • None

Repair

  • Repair or replace damaged connections.

Refer to Procedure 019-008

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Incorrect base engine timing

Solution: S00000689

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the base engine timing.

Refer to Procedure 001-088

Specification

  • If the camshaft and crankshaft gears are not properly aligned, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Correct the base engine timing.

Refer to Procedure 001-088

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Camshaft position sensor is damaged

Solution: S00001226

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the camshaft position sensor.

Refer to Procedure 019-363

  • Inspect the camshaft position sensor for signs of damage, oil leak, and metal debris on the end of the sensor.

Specification

  • If the camshaft position sensor shows any signs of damage, then a malfunctioning camshaft position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace camshaft position sensor.

Refer to Procedure 019-363

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Engine crankshaft speed/position sensor check

Solution: S00000684

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the crankshaft position sensor.
  • Inspect the crankshaft position sensor for signs of damage, oil leak, and metal debris on the end of the sensor.
  • Verify the crankshaft position sensor is connected properly.
  • Use the ratchet drive side of the socket tool that was used to removed the sensor from the engine, place it flush on the sensor so that the edge of the socket is on the edge of the sensor.
  • Monitor the crankshaft engine speed sensor state using the recommended Cummins® electronic service tool or equivalent and monitor (Engine Speed Main Sensor State) to check if the sensor state transitions.
  • Slowly slide the socket in a perpendicular direction to the marked line on the sensor or in a perpendicular direction to the mounting bracket of the sensor.

Specification

  • If any damage is found to the sensor, then proceed to the Repair section.
  • If the crankshaft position sensor is not connected properly, then proceed to the Repair section.
  • If the crankshaft position sensor state does NOT transition from high to low or low to high, or the state does NOT show triggered, then a malfunctioning crankshaft engine position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine crankshaft speed/position sensor.

Refer to Procedure 019-365

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Crankshaft/camshaft tone wheel

Solution: S00003847

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the camshaft position sensor.

Refer to Procedure 019-363

  • Remove the crankshaft position sensor.

Refer to Procedure 019-365

  • Visually inspect the indicator ring and tone wheel while barring the engine over and looking through the camshaft engine position sensor or crankshaft engine position sensor hole.
  • Visually inspect the camshaft tone wheel for defects.
  • Visually inspect the crankshaft tone wheel for defects.

Specification

  • If any damage or defects to the tone wheel or gear are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the camshaft tone wheel.

Refer to Procedure 001-112

  • Replace the crankshaft tone wheel.

Refer to Procedure 001-069

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 755 | SPN: 157 | FMI: 7
Injector Metering Rail 1 Pressure - Mechanical System Not Responding or Out of Adjustment

Troubleshooting Summary

  1. Check for primary fault codes
  2. Fuel rail pressure sensor voltage check
  3. Fuel rail pressure sensor voltage check at the ECM
  4. Fuel rail pressure sensor circuit pin to ground short
  5. Fuel rail pressure sensor circuit pin to pin short
  6. ECM calibration revision history check
  7. Fuel rail pressure sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000117

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 451, 452, 483, 484

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Fuel rail pressure sensor voltage check

Solution: S00000616

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the fuel rail pressure sensor SUPPLY pin and the fuel rail pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Fuel rail pressure sensor voltage check at the ECM

Refer to S00000617

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Fuel rail pressure sensor voltage check at the ECM

Solution: S00000617

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the fuel rail pressure sensor SUPPLY pin and the fuel rail pressure sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Fuel rail pressure sensor circuit pin to ground short

Solution: S00005779

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel rail pressure sensor SUPPLY pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the fuel rail pressure sensor SIGNAL 1 pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the fuel rail pressure sensor SIGNAL 2 pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the fuel rail pressure sensor RETURN pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel rail pressure sensor circuit pin to pin short

Solution: S00005780

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel rail pressure sensor SUPPLY pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the fuel rail pressure sensor SIGNAL 1 pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the fuel rail pressure sensor SIGNAL 2 pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the fuel rail pressure sensor RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Fuel rail pressure sensor is malfunctioning

Solution: S00005870

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning fuel rail pressure sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace fuel rail pressure sensor.

Refer to Procedure 019-115

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 778 | SPN: 723 | FMI: 2
Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Camshaft position sensor is damaged
  3. Camshaft position sensor voltage check
  4. Camshaft position sensor voltage check at the ECM
  5. Camshaft position sensor open circuit check
  6. Camshaft position sensor circuit pin to pin short
  7. Crankshaft/camshaft tone wheel
  8. ECM calibration revision history check
  9. Camshaft position sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00001825

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386
  • Voltage: 441, 442

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Camshaft position sensor is damaged

Solution: S00001226

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the camshaft position sensor.

Refer to Procedure 019-363

  • Inspect the camshaft position sensor for signs of damage, oil leak, and metal debris on the end of the sensor.

Specification

  • If the camshaft position sensor shows any signs of damage, then a malfunctioning camshaft position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace camshaft position sensor.

Refer to Procedure 019-363

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Camshaft position sensor voltage check

Solution: S00000693

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the camshaft position sensor SUPPLY pin and the camshaft position sensor RETURN pin at the sensor connector of the engine wiring harness.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Camshaft position sensor voltage check at the ECM

Refer to S00000694

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Camshaft position sensor voltage check at the ECM

Solution: S00000694

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the camshaft position sensor SUPPLY pin and the camshaft position sensor RETURN pin at the ECM connector.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Camshaft position sensor open circuit check

Solution: S00000691

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the camshaft position sensor SIGNAL pin at the camshaft position sensor engine wiring harness connector to the camshaft position sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Camshaft position sensor circuit pin to pin short

Solution: S00000692

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the camshaft position sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the camshaft position sensor SIGNAL pin of the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Crankshaft/camshaft tone wheel

Solution: S00003847

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the camshaft position sensor.

Refer to Procedure 019-363

  • Remove the crankshaft position sensor.

Refer to Procedure 019-365

  • Visually inspect the indicator ring and tone wheel while barring the engine over and looking through the camshaft engine position sensor or crankshaft engine position sensor hole.
  • Visually inspect the camshaft tone wheel for defects.
  • Visually inspect the crankshaft tone wheel for defects.

Specification

  • If any damage or defects to the tone wheel or gear are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the camshaft tone wheel.

Refer to Procedure 001-112

  • Replace the crankshaft tone wheel.

Refer to Procedure 001-069

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Camshaft position sensor is malfunctioning

Solution: S00000364

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning camshaft position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace camshaft position sensor.

Refer to Procedure 019-363

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 779 | SPN: 703 | FMI: 11
Auxiliary Equipment Sensor Input 3 - Root Cause Not Known

Troubleshooting Summary

  1. OEM protection limits exceeded

1 - OEM protection limits exceeded

Solution: S00003355

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Inspect OEM device for proper operation.

Refer to OEM Service Manual

Specification

  • If the OEM sensor reading does not meet specification, then a malfunctioning OEM sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the OEM auxiliary sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 21-Mar-2021


NO TITLE

ISX15 CM2350 X101

Fault Code: 784 | SPN: 1590 | FMI: 2
Adaptive Cruise Control Mode - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Malfunctioning adaptive cruise control circuit (If equipped)
  3. Malfunctioning adaptive cruise control circuit (If equipped)
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000699

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Anti-Lock Braking: 3488, 4215
  • Transmission: 3328, 3418, 5297, 5298, 6724

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Malfunctioning adaptive cruise control circuit (If equipped)

Solution: S00000701

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the vehicle for installed adaptive cruise control hardware.

Specification

  • If adaptive cruise control hardware is not installed on the vehicle, then use the recommended Cummins® electronic service tool or equivalent to disable the Adaptive Cruise feature.
  • If adaptive cruise control hardware has been installed on the vehicle, then proceed to the Linked Solutions section.

Linked Solutions

Click on the link below:

  • Malfunctioning adaptive cruise control circuit (If equipped)

Refer to S00001082

Repair

  • Adjust the features and parameters to the correct settings.

Refer to Procedure 019-078

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Malfunctioning adaptive cruise control circuit (If equipped)

Solution: S00001082

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Connect the INLINE™ data link adapter to the vehicle SAE J1939 data link diagnostic connector.
  • Attempt to communicate with the ECM.
  • Select INLINE™ J1939 ECM connection.
  • Verify recommended Cummins® electronic service tool or equivalent communication with the ECM.

Specification

  • If communication between the ECM and the recommended Cummins® electronic service tool or equivalent cannot be established, then reset the search to No Communication with the Cummins® Electronic Service Tool or Equivalent to ECM.

Linked Solutions

  • None

Repair

  • For communication error, determine the cause of the loss of communication between the ECM and the adaptive cruise control hardware.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1117 | SPN: 3597 | FMI: 2
Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Battery power removed by battery disconnect switch
  2. Battery or battery cables are malfunctioning
  3. Battery load test
  4. Unswitched battery open circuit check
  5. Keyswitch open circuit check
  6. Intermittent ground connection
  7. ECM calibration revision history check

1 - Battery power removed by battery disconnect switch

Solution: S00000706

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify that the battery disconnect switches are being used correctly.

The keyswitch must be turned OFF first for 90 seconds before any battery disconnect switches are turned OFF.

Specification

  • If the battery disconnect switches are not being used correctly, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Remind the operator how to correctly use the battery disconnect switches.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Battery load test

Solution: S00000669

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Disconnect the batteries from each other.
  • Connect a load tester separately to each battery.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.

Specification

  • For a 12 volt system, proceed to the Repair section if the battery voltage is below the following specification: 11 VDC
  • For a 24 volt system, proceed to the Repair section if the battery voltage is below the following specification: 22 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Charge or replace the batteries.

Refer to Procedure 013-007

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Unswitched battery open circuit check

Solution: S00005285

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the ECM battery SUPPLY (+) circuit between the OEM wiring harness ECM connector and the positive (+) terminal of the battery.
  • Measure the resistance of the ECM battery SUPPLY (-) circuit between the OEM wiring harness ECM connector and the positive (-) terminal of the battery.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Keyswitch open circuit check

Solution: S00000530

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the keyswitch ignition post in the keyswitch assembly to keyswitch input SIGNAL pin of the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Intermittent ground connection

Solution: S00000707

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect all of the engine block, starter, alternator, chassis, and battery ground connections.
  • Visually inspect the ECM ground for damage, corrosion and loose connections.

Specification

  • If the ECM to cylinder block connection resistance is greater than 10 Ω, then a malfunctioning ground connection has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the ECM-to-ground connection.

Refer to Procedure 019-008

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1139 | SPN: 651 | FMI: 7
Injector Solenoid Driver Cylinder 1 - Mechanical System Not Responding or Out of Adjustment

Troubleshooting Summary

  1. Check for primary fault codes
  2. Check for multiple fuel injector fault codes
  3. High fuel drain line restriction
  4. ECM calibration revision history check
  5. Fuel injector is malfunctioning

1 - Check for primary fault codes

Solution: S00000118

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 271, 272, 322, 323, 324, 325, 331, 332, 451, 452, 483, 484, 3332, 4726

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Check for multiple fuel injector fault codes

Solution: S00008019

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the Linked Solutions section if multiple fault codes from the following list is active or has more than one inactive count within the last 25 engine operating hours:
  • Fuel injector: 1139, 1141, 1142, 1143, 1144, 1145

Linked Solutions

  • High fuel drain line restriction

Refer to S00002037

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - High fuel drain line restriction

Solution: S00002037

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Measure the fuel drain line restriction.

Refer to Procedure 006-012

Specification

  • If the fuel drain line restriction is not within the specification, then high fuel drain line restriction has been detected.

Linked Solutions

  • None

Repair

  • Replace fuel drain line.

Refer to Procedure 006-013

Validation

  • None
Parent Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel injector is malfunctioning

Solution: S00007909

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1141 | SPN: 652 | FMI: 7
Injector Solenoid Driver Cylinder 2 - Mechanical System Not Responding or Out of Adjustment

Troubleshooting Summary

  1. Check for primary fault codes
  2. Check for multiple fuel injector fault codes
  3. High fuel drain line restriction
  4. ECM calibration revision history check
  5. Fuel injector is malfunctioning

1 - Check for primary fault codes

Solution: S00000118

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 271, 272, 322, 323, 324, 325, 331, 332, 451, 452, 483, 484, 3332, 4726

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Check for multiple fuel injector fault codes

Solution: S00008019

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the Linked Solutions section if multiple fault codes from the following list is active or has more than one inactive count within the last 25 engine operating hours:
  • Fuel injector: 1139, 1141, 1142, 1143, 1144, 1145

Linked Solutions

  • High fuel drain line restriction

Refer to S00002037

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - High fuel drain line restriction

Solution: S00002037

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Measure the fuel drain line restriction.

Refer to Procedure 006-012

Specification

  • If the fuel drain line restriction is not within the specification, then high fuel drain line restriction has been detected.

Linked Solutions

  • None

Repair

  • Replace fuel drain line.

Refer to Procedure 006-013

Validation

  • None
Parent Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel injector is malfunctioning

Solution: S00007909

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1142 | SPN: 653 | FMI: 7
Injector Solenoid Driver Cylinder 3 - Mechanical System Not Responding or Out of Adjustment

Troubleshooting Summary

  1. Check for primary fault codes
  2. Check for multiple fuel injector fault codes
  3. High fuel drain line restriction
  4. ECM calibration revision history check
  5. Fuel injector is malfunctioning

1 - Check for primary fault codes

Solution: S00000118

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 271, 272, 322, 323, 324, 325, 331, 332, 451, 452, 483, 484, 3332, 4726

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Check for multiple fuel injector fault codes

Solution: S00008019

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the Linked Solutions section if multiple fault codes from the following list is active or has more than one inactive count within the last 25 engine operating hours:
  • Fuel injector: 1139, 1141, 1142, 1143, 1144, 1145

Linked Solutions

  • High fuel drain line restriction

Refer to S00002037

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - High fuel drain line restriction

Solution: S00002037

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Measure the fuel drain line restriction.

Refer to Procedure 006-012

Specification

  • If the fuel drain line restriction is not within the specification, then high fuel drain line restriction has been detected.

Linked Solutions

  • None

Repair

  • Replace fuel drain line.

Refer to Procedure 006-013

Validation

  • None
Parent Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel injector is malfunctioning

Solution: S00007909

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1143 | SPN: 654 | FMI: 7
Injector Solenoid Driver Cylinder 4 - Mechanical System Not Responding or Out of Adjustment

Troubleshooting Summary

  1. Check for primary fault codes
  2. Check for multiple fuel injector fault codes
  3. High fuel drain line restriction
  4. ECM calibration revision history check
  5. Fuel injector is malfunctioning

1 - Check for primary fault codes

Solution: S00000118

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 271, 272, 322, 323, 324, 325, 331, 332, 451, 452, 483, 484, 3332, 4726

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Check for multiple fuel injector fault codes

Solution: S00008019

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the Linked Solutions section if multiple fault codes from the following list is active or has more than one inactive count within the last 25 engine operating hours:
  • Fuel injector: 1139, 1141, 1142, 1143, 1144, 1145

Linked Solutions

  • High fuel drain line restriction

Refer to S00002037

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - High fuel drain line restriction

Solution: S00002037

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Measure the fuel drain line restriction.

Refer to Procedure 006-012

Specification

  • If the fuel drain line restriction is not within the specification, then high fuel drain line restriction has been detected.

Linked Solutions

  • None

Repair

  • Replace fuel drain line.

Refer to Procedure 006-013

Validation

  • None
Parent Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel injector is malfunctioning

Solution: S00007909

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1144 | SPN: 655 | FMI: 7
Injector Solenoid Driver Cylinder 5 - Mechanical System Not Responding or Out of Adjustment

Troubleshooting Summary

  1. Check for primary fault codes
  2. Check for multiple fuel injector fault codes
  3. High fuel drain line restriction
  4. ECM calibration revision history check
  5. Fuel injector is malfunctioning

1 - Check for primary fault codes

Solution: S00000118

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 271, 272, 322, 323, 324, 325, 331, 332, 451, 452, 483, 484, 3332, 4726

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Check for multiple fuel injector fault codes

Solution: S00008019

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the Linked Solutions section if multiple fault codes from the following list is active or has more than one inactive count within the last 25 engine operating hours:
  • Fuel injector: 1139, 1141, 1142, 1143, 1144, 1145

Linked Solutions

  • High fuel drain line restriction

Refer to S00002037

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - High fuel drain line restriction

Solution: S00002037

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Measure the fuel drain line restriction.

Refer to Procedure 006-012

Specification

  • If the fuel drain line restriction is not within the specification, then high fuel drain line restriction has been detected.

Linked Solutions

  • None

Repair

  • Replace fuel drain line.

Refer to Procedure 006-013

Validation

  • None
Parent Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel injector is malfunctioning

Solution: S00007909

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1145 | SPN: 656 | FMI: 7
Injector Solenoid Driver Cylinder 6 - Mechanical System Not Responding or Out of Adjustment

Troubleshooting Summary

  1. Check for primary fault codes
  2. Check for multiple fuel injector fault codes
  3. High fuel drain line restriction
  4. ECM calibration revision history check
  5. Fuel injector is malfunctioning

1 - Check for primary fault codes

Solution: S00000118

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 271, 272, 322, 323, 324, 325, 331, 332, 451, 452, 483, 484, 3332, 4726

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Check for multiple fuel injector fault codes

Solution: S00008019

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the Linked Solutions section if multiple fault codes from the following list is active or has more than one inactive count within the last 25 engine operating hours:
  • Fuel injector: 1139, 1141, 1142, 1143, 1144, 1145

Linked Solutions

  • High fuel drain line restriction

Refer to S00002037

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - High fuel drain line restriction

Solution: S00002037

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Measure the fuel drain line restriction.

Refer to Procedure 006-012

Specification

  • If the fuel drain line restriction is not within the specification, then high fuel drain line restriction has been detected.

Linked Solutions

  • None

Repair

  • Replace fuel drain line.

Refer to Procedure 006-013

Validation

  • None
Parent Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel injector is malfunctioning

Solution: S00007909

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1228 | SPN: 27 | FMI: 2
EGR Valve Position - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Ice buildup in the air system components
  3. EGR valve plugged or restricted with ice
  4. Incorrect air compressor discharge line routing
  5. Air compressor discharge line plugged or restricted with ice
  6. EGR valve position sensor voltage check
  7. EGR valve position sensor voltage check at the ECM
  8. EGR valve restricted
  9. ECM calibration revision history check
  10. EGR valve is malfunctioning

1 - Check for primary fault codes

Solution: S00000133

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • EGR: 2272, 2349, 2353

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Ice buildup in the air system components

Solution: S00006422

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the engine was operating in temperatures at or below: 5° C [41° F]

Ice can form causing obstruction/sticking and may not be present at the time of troubleshooting.

Specification

  • Proceed to the Linked Solutions section if the engine was operating in temperatures at or below the following specification: 5° C [41° F]

Linked Solutions

  • EGR valve plugged or restricted with ice

Refer to S00007344

  • Incorrect air compressor discharge line routing

Refer to S00001254

  • Air compressor discharge line plugged or restricted with ice

Refer to S00001255

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - EGR valve plugged or restricted with ice

Solution: S00007344

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the EGR valve.
  • Visually inspect the EGR valve for ice plugging.

Refer to Procedure 011-022

Specification

  • If the EGR valve is plugged with ice, then an EGR valve restriction has been detected.

Linked Solutions

  • None

Repair

  • Clean or replace the EGR valve.

Refer to Procedure 011-022

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Incorrect air compressor discharge line routing

Solution: S00001254

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually verify the air compressor discharge line maintains a constant downward slope from the air compressor to the air dryer inlet fitting.

Refer to OEM Service Manual

Specification

  • If the air compressor discharge line does not have a continuous downward slope from the air compressor to the air dryer inlet fitting, then an incorrect air compressor discharge line routing has been detected.

Linked Solutions

  • None

Repair

  • Route the air compressor discharge line so it maintains a constant downward slope.

Refer to OEM Service Manual

Validation

  • None
Parent Solution

2.3 - Air compressor discharge line plugged or restricted with ice

Solution: S00001255

Verification

Conditions

  • Turn keyswitch OFF.
  • Air compressor discharge line removed.

Action

  • Visually inspect the air discharge line for ice plugging.
  • Visually inspect the air discharge line at the air dryer connection for moisture that could freeze and plug the air discharge line or fittings.

Specification

  • If the air compressor discharge line is plugged with ice, then an air compressor discharge line restriction has been detected.
  • If the air compressor discharge line has a lot of moisture in it, then excessive moisture has been detected in the air compressor discharge line.

Linked Solutions

  • None

Repair

  • Clear the moisture or ice from the air compressor discharge line.

Refer to OEM Service Manual

Validation

  • None
Parent Solution

3 - EGR valve position sensor voltage check

Solution: S00000719

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the EGR valve SUPPLY pin and the EGR valve RETURN pin at the EGR valve connector of the engine wiring harness.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • EGR valve position sensor voltage check at the ECM

Refer to S00000720

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3.1 - EGR valve position sensor voltage check at the ECM

Solution: S00000720

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the EGR valve SUPPLY pin and the EGR valve RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - EGR valve restricted

Solution: S00000681

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the EGR valve.

Refer to Procedure 011-022

  • Visually inspect the EGR valve.

Refer to Procedure 011-022

Specification

  • If debris is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean the EGR valve.

Refer to Procedure 011-022

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - EGR valve is malfunctioning

Solution: S00004389

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

If the EGR valve has been replaced within the last 90 days, follow your technical escalation process PRIOR to performing any of the repair actions listed below:

  • Replace the EGR valve.

Refer to Procedure 011-022

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1239 | SPN: 2623 | FMI: 3
Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Accelerator pedal voltage check
  3. Accelerator pedal circuit check
  4. Accelerator pedal position sensor open circuit check
  5. Accelerator pedal position sensor circuit pin to pin short
  6. ECM calibration revision history check
  7. Accelerator pedal is malfunctioning

1 - Check for primary fault codes

Solution: S00000134

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1695

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Accelerator pedal voltage check

Solution: S00000948

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the accelerator pedal position 1 sensor SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Measure the voltage between the accelerator pedal position 2 sensor SUPPLY pin to the accelerator pedal position 2 sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Accelerator pedal circuit check

Refer to S00000949

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Accelerator pedal circuit check

Solution: S00000949

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position 1 sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 1 sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor RETURN pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 2 sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 2 sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 2 sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 2 sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Accelerator pedal position sensor open circuit check

Solution: S00000467

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Accelerator pedal position sensor circuit pin to pin short

Solution: S00000721

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect all components on the wiring circuit being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal 1 SIGNAL pin in the OEM wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the accelerator pedal 2 SIGNAL pin in the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Accelerator pedal is malfunctioning

Solution: S00001185

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning accelerator pedal has been detected.

Linked Solutions

  • None

Repair

  • Replace the accelerator pedal.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1241 | SPN: 2623 | FMI: 4
Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Accelerator pedal voltage check
  3. Accelerator pedal circuit check
  4. Accelerator pedal position sensor open circuit check
  5. Accelerator pedal position sensor circuit pin to ground short
  6. Accelerator pedal position sensor circuit pin to pin short
  7. ECM calibration revision history check
  8. Accelerator pedal is malfunctioning

1 - Check for primary fault codes

Solution: S00000135

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1696

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Accelerator pedal voltage check

Solution: S00000948

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the accelerator pedal position 1 sensor SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Measure the voltage between the accelerator pedal position 2 sensor SUPPLY pin to the accelerator pedal position 2 sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Accelerator pedal circuit check

Refer to S00000949

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Accelerator pedal circuit check

Solution: S00000949

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position 1 sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 1 sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor RETURN pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 2 sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 2 sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 2 sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 2 sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Accelerator pedal position sensor open circuit check

Solution: S00000467

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Accelerator pedal position sensor circuit pin to ground short

Solution: S00000448

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100K Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Accelerator pedal position sensor circuit pin to pin short

Solution: S00000721

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect all components on the wiring circuit being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal 1 SIGNAL pin in the OEM wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the accelerator pedal 2 SIGNAL pin in the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Accelerator pedal is malfunctioning

Solution: S00001185

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning accelerator pedal has been detected.

Linked Solutions

  • None

Repair

  • Replace the accelerator pedal.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1242 | SPN: 91 | FMI: 2
Accelerator Pedal or Lever Position Sensor 1 - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Accelerator pedal voltage check
  3. Accelerator pedal circuit check
  4. Accelerator pedal position sensor open circuit check
  5. Accelerator pedal position sensor circuit pin to pin short
  6. ECM calibration revision history check
  7. Accelerator pedal is malfunctioning

1 - Check for primary fault codes

Solution: S00000136

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Accelerator Pedal or Lever Position: 131, 132, 1239, 1241

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Accelerator pedal voltage check

Solution: S00000948

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the accelerator pedal position 1 sensor SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Measure the voltage between the accelerator pedal position 2 sensor SUPPLY pin to the accelerator pedal position 2 sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Accelerator pedal circuit check

Refer to S00000949

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Accelerator pedal circuit check

Solution: S00000949

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position 1 sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 1 sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor RETURN pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 2 sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 2 sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 2 sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 2 sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Accelerator pedal position sensor open circuit check

Solution: S00000467

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Accelerator pedal position sensor circuit pin to pin short

Solution: S00000721

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect all components on the wiring circuit being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal 1 SIGNAL pin in the OEM wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the accelerator pedal 2 SIGNAL pin in the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Accelerator pedal is malfunctioning

Solution: S00001185

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning accelerator pedal has been detected.

Linked Solutions

  • None

Repair

  • Replace the accelerator pedal.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1361 | SPN: 974 | FMI: 4
Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Check for primary fault codes
  3. Remote accelerator pedal position sensor voltage check
  4. Remote accelerator pedal position sensor circuit check
  5. Remote accelerator pedal position sensor open circuit check
  6. Remote accelerator pedal position sensor circuit pin to ground short
  7. Remote accelerator pedal position sensor circuit pin to pin short
  8. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000137

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1695, 1696

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Check for primary fault codes

Solution: S00000047

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1695, 1696

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

3 - Remote accelerator pedal position sensor voltage check

Solution: S00000441

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal position sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the accelerator pedal position 1 sensor SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM wiring harness.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Remote accelerator pedal position sensor circuit check

Refer to S00000995

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Remote accelerator pedal position sensor circuit check

Solution: S00000995

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the remote accelerator pedal position sensor SUPPLY pin at the remote accelerator pedal position sensor connector of the OEM wiring harness and the remote accelerator pedal position sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the remote accelerator pedal position sensor RETURN pin at the remote accelerator pedal position sensor connector of the OEM wiring harness and the remote accelerator pedal position sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω
  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Remote accelerator pedal position sensor open circuit check

Solution: S00000453

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the remote accelerator pedal position sensor SIGNAL pin at the remote accelerator pedal position sensor connector of the OEM wiring harness and the remote accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Remote accelerator pedal position sensor circuit pin to ground short

Solution: S00000454

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the remote accelerator pedal SUPPLY pin in the OEM wiring harness ECM connector and ground.
  • Measure the resistance between the remote accelerator pedal SIGNAL pin in the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Remote accelerator pedal position sensor circuit pin to pin short

Solution: S00000450

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the remote accelerator pedal SIGNAL pin in the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1515 | SPN: 91 | FMI: 19
Accelerator Pedal Position 1 - Received Network Data in Error

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1595 | SPN: 974 | FMI: 3
Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Check for primary fault codes
  3. Remote accelerator pedal position sensor voltage check
  4. Remote accelerator pedal position sensor circuit check
  5. Remote accelerator pedal position sensor SIGNAL wire shorted to high source
  6. Remote accelerator pedal position sensor open circuit check
  7. Remote accelerator pedal position sensor circuit pin to pin short
  8. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000138

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1695, 1696

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Check for primary fault codes

Solution: S00000047

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1695, 1696

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

3 - Remote accelerator pedal position sensor voltage check

Solution: S00000441

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal position sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the accelerator pedal position 1 sensor SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM wiring harness.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Remote accelerator pedal position sensor circuit check

Refer to S00000995

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Remote accelerator pedal position sensor circuit check

Solution: S00000995

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the remote accelerator pedal position sensor SUPPLY pin at the remote accelerator pedal position sensor connector of the OEM wiring harness and the remote accelerator pedal position sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the remote accelerator pedal position sensor RETURN pin at the remote accelerator pedal position sensor connector of the OEM wiring harness and the remote accelerator pedal position sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω
  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Remote accelerator pedal position sensor SIGNAL wire shorted to high source

Solution: S00000452

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the remote accelerator pedal SIGNAL pin in the OEM wiring harness ECM connector 2 and SUPPLY pin in the OEM wiring harness ECM connector 2.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Remote accelerator pedal position sensor open circuit check

Solution: S00000449

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM harness ECM connector RETURN pin and the OEM wiring harness accelerator pedal connector RETURN pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Remote accelerator pedal position sensor circuit pin to pin short

Solution: S00000450

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the remote accelerator pedal SIGNAL pin in the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1654 | SPN: 1323 | FMI: 31
Engine Misfire Cylinder 1 - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. Fuel Injector Performance Test
  3. Overhead component damaged or out of adjustment
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000935

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 271, 272, 451, 452, 483, 484, 553, 559, 755, 1139, 1141, 1142, 1143, 1144, 1145, 2265, 2266, 2311, 2372, 3338, 3741, 4726, 4727, 6258, 6259
  • Camshaft speed/position sensor: 115, 731, 778, 2322, 6596
  • Crankshaft speed/position sensor: 234, 689, 2321, 2468

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Fuel Injector Performance Test

Solution: S00000708

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Start the engine.
  • Allow the engine to reach operating temperature.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Injector Performance Test.

Refer to Procedure 014-014

If the Fuel Injector Performance Test will not activate, then troubleshoot Fuel Injector Performance Test Will not Activate.

If the Fuel Injector Performance Test will not complete, then troubleshoot Fuel Injector Performance Test Will not Complete.

Specification

  • If a Failed indication is displayed by the recommended Cummins® electronic service tool or equivalent for any injector, then that injector is malfunctioning.

Linked Solutions

  • None

Repair

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Perform the Snap Acceleration - Aftertreatment Connected Test.

Refer to Procedure 014-017

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Overhead component damaged or out of adjustment

Solution: S00005074

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.
  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Adjust the overhead.

Refer to Procedure 003-004

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1655 | SPN: 1324 | FMI: 31
Engine Misfire Cylinder 2 - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. Fuel Injector Performance Test
  3. Overhead component damaged or out of adjustment
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000936

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 271, 272, 451, 452, 483, 484, 553, 559, 755, 1139, 1141, 1142, 1143, 1144, 1145, 2265, 2266, 2311, 2372, 3338, 3727, 3741, 4691, 4726, 4747, 6258, 6259
  • Camshaft speed/position sensor: 115, 731, 778, 2322, 6596
  • Crankshaft speed/position sensor: 234, 689, 2321, 2468

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Fuel Injector Performance Test

Solution: S00000708

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Start the engine.
  • Allow the engine to reach operating temperature.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Injector Performance Test.

Refer to Procedure 014-014

If the Fuel Injector Performance Test will not activate, then troubleshoot Fuel Injector Performance Test Will not Activate.

If the Fuel Injector Performance Test will not complete, then troubleshoot Fuel Injector Performance Test Will not Complete.

Specification

  • If a Failed indication is displayed by the recommended Cummins® electronic service tool or equivalent for any injector, then that injector is malfunctioning.

Linked Solutions

  • None

Repair

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Perform the Snap Acceleration - Aftertreatment Connected Test.

Refer to Procedure 014-017

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Overhead component damaged or out of adjustment

Solution: S00005074

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.
  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Adjust the overhead.

Refer to Procedure 003-004

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1656 | SPN: 1325 | FMI: 31
Engine Misfire Cylinder 3 - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. Fuel Injector Performance Test
  3. Overhead component damaged or out of adjustment
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000937

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 271, 272, 451, 452, 483, 553, 559, 755, 1139, 1141, 1142, 1143, 1144, 1145, 2222, 2223, 2311, 2343, 2372, 3338, 3727, 4284, 4616, 4691, 4727, 6258, 6259, 6339, 6341, 6342, 6343
  • Camshaft speed/position sensor: 115, 731, 778, 2322, 6596
  • Crankshaft speed/position sensor: 234, 689, 2321, 2468

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Fuel Injector Performance Test

Solution: S00000708

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Start the engine.
  • Allow the engine to reach operating temperature.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Injector Performance Test.

Refer to Procedure 014-014

If the Fuel Injector Performance Test will not activate, then troubleshoot Fuel Injector Performance Test Will not Activate.

If the Fuel Injector Performance Test will not complete, then troubleshoot Fuel Injector Performance Test Will not Complete.

Specification

  • If a Failed indication is displayed by the recommended Cummins® electronic service tool or equivalent for any injector, then that injector is malfunctioning.

Linked Solutions

  • None

Repair

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Perform the Snap Acceleration - Aftertreatment Connected Test.

Refer to Procedure 014-017

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Overhead component damaged or out of adjustment

Solution: S00005074

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.
  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Adjust the overhead.

Refer to Procedure 003-004

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1657 | SPN: 1326 | FMI: 31
Engine Misfire Cylinder 4 - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. Fuel Injector Performance Test
  3. Overhead component damaged or out of adjustment
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000938

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 271, 272, 451, 452, 483, 484, 553, 559, 755, 1139, 1141, 1142, 1143, 1144, 1145, 2265, 2266, 2311, 2343, 2372, 3338, 3727, 3741, 4691, 4726, 4727, 6258, 6259
  • Camshaft speed/position sensor: 115, 731, 778, 2322, 6596
  • Crankshaft speed/position sensor: 234, 689, 2321, 2468

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Fuel Injector Performance Test

Solution: S00000708

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Start the engine.
  • Allow the engine to reach operating temperature.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Injector Performance Test.

Refer to Procedure 014-014

If the Fuel Injector Performance Test will not activate, then troubleshoot Fuel Injector Performance Test Will not Activate.

If the Fuel Injector Performance Test will not complete, then troubleshoot Fuel Injector Performance Test Will not Complete.

Specification

  • If a Failed indication is displayed by the recommended Cummins® electronic service tool or equivalent for any injector, then that injector is malfunctioning.

Linked Solutions

  • None

Repair

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Perform the Snap Acceleration - Aftertreatment Connected Test.

Refer to Procedure 014-017

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Overhead component damaged or out of adjustment

Solution: S00005074

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.
  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Adjust the overhead.

Refer to Procedure 003-004

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1658 | SPN: 1327 | FMI: 31
Engine Misfire Cylinder 5 - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. Fuel Injector Performance Test
  3. Overhead component damaged or out of adjustment
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000939

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 271, 272, 451, 452, 483, 484, 553, 559, 755, 1139, 1141, 1142, 1143, 1144, 1145, 2265, 2266, 2311, 2372, 3338, 3727, 3741, 4691, 4726, 4727, 6258, 6259
  • Camshaft speed/position sensor: 115, 731, 2322, 6596
  • Crankshaft speed/position sensor: 234, 689, 2321, 2468

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Fuel Injector Performance Test

Solution: S00000708

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Start the engine.
  • Allow the engine to reach operating temperature.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Injector Performance Test.

Refer to Procedure 014-014

If the Fuel Injector Performance Test will not activate, then troubleshoot Fuel Injector Performance Test Will not Activate.

If the Fuel Injector Performance Test will not complete, then troubleshoot Fuel Injector Performance Test Will not Complete.

Specification

  • If a Failed indication is displayed by the recommended Cummins® electronic service tool or equivalent for any injector, then that injector is malfunctioning.

Linked Solutions

  • None

Repair

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Perform the Snap Acceleration - Aftertreatment Connected Test.

Refer to Procedure 014-017

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Overhead component damaged or out of adjustment

Solution: S00005074

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.
  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Adjust the overhead.

Refer to Procedure 003-004

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1659 | SPN: 1328 | FMI: 31
Engine Misfire Cylinder 6 - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. Fuel Injector Performance Test
  3. Overhead component damaged or out of adjustment
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000940

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 271, 272, 451, 452, 483, 484, 553, 559, 755, 1139, 1141, 1142, 1143, 1144, 1145, 2265, 2266, 2311, 2343, 2372, 3338, 3727, 3741, 4691, 4726, 4727, 6258, 6259
  • Camshaft speed/position sensor: 115, 731, 778, 2322, 6596
  • Crankshaft speed/position sensor: 234, 689, 2321, 2468

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Fuel Injector Performance Test

Solution: S00000708

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Start the engine.
  • Allow the engine to reach operating temperature.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Injector Performance Test.

Refer to Procedure 014-014

If the Fuel Injector Performance Test will not activate, then troubleshoot Fuel Injector Performance Test Will not Activate.

If the Fuel Injector Performance Test will not complete, then troubleshoot Fuel Injector Performance Test Will not Complete.

Specification

  • If a Failed indication is displayed by the recommended Cummins® electronic service tool or equivalent for any injector, then that injector is malfunctioning.

Linked Solutions

  • None

Repair

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Perform the Snap Acceleration - Aftertreatment Connected Test.

Refer to Procedure 014-017

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Overhead component damaged or out of adjustment

Solution: S00005074

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.
  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Adjust the overhead.

Refer to Procedure 003-004

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1664 | SPN: 4796 | FMI: 31
Aftertreatment 1 Diesel Oxidation Catalyst Missing - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment exhaust system leaks
  3. Aftertreatment fuel injector flow test
  4. Aftertreatment DOC is malfunctioning
  5. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000139

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment DOC: 3313, 3314, 3315
  • Aftertreatment DPF: 3316, 3317, 3318

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment exhaust system leaks

Solution: S00001008

Verification

Conditions

  • Engine running.

Action

  • Visually inspect for leaks in the exhaust manifold to head.

Refer to Procedure 010-024

  • Visually inspect for leaks from the turbocharger to exhaust manifold.

Refer to Procedure 010-024

  • Visually inspect for leaks in the exhaust plumbing between the turbocharger outlet and the Aftertreatment DOC intake connection.

Refer to Procedure 010-024

  • Visually inspect the exhaust piping for leaks, cracks, and loose connections.

Refer to Procedure 010-024

  • Inspect for leaks at the aftertreatment DOC housing, sensor ports and connection points.

Refer to Procedure 010-024

  • Visually inspect the aftertreatment and SCR components for exhaust leaks.

Refer to Procedure 010-024

Specification

  • If there is any damage or leaks found in the exhaust system, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the exhaust manifold.

Refer to Procedure 011-007

  • Repair or replace the exhaust plumbing.

Refer to Procedure 011-007

Refer to OEM Service Manual

  • Replace aftertreatment DOC.

Refer to Procedure 011-049

  • Replace the aftertreatment diesel particulate filter.

Refer to Procedure 011-041

  • Replace the aftertreatment SCR Catalyst.

Refer to Procedure 011-036

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment fuel injector flow test

Solution: S00002774

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the Aftertreatment Fuel Injector Flow Test.

Refer to Procedure 011-054

Specification

  • If the Aftertreatment Fuel Injector Flow Test does not meet specification, then a malfunctioning aftertreatment fuel injector has been detected.

Linked Solutions

  • None

Repair

  • Clean or replace the aftertreatment fuel injector.

Refer to Procedure 011-042

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment DOC is malfunctioning

Solution: S00005082

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect for the presence of the aftertreatment DOC.

Refer to Procedure 011-049

  • Inspect the inlet face of the aftertreatment DOC for reuse.

Refer to Procedure 011-049

Refer to Service Bulletin 4021600

  • Inspect for cracks in the aftertreatment DOC cell walls.

Refer to Service Bulletin 4021600

  • Inspect for soot or oil plugging the front face of the catalyst

Refer to Service Bulletin 4021600

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • If the face of the aftertreatment DOC is plugged, then clean the aftertreatment DOC.

Refer to Procedure 011-049

  • If the face of the aftertreatment DOC is cracked or damaged, then replace the aftertreatment DOC.

Refer to Procedure 011-049

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1668 | SPN: 1761 | FMI: 4
Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid tank level sensor is malfunctioning
  3. Aftertreatment diesel exhaust fluid tank level sensor voltage check
  4. Aftertreatment diesel exhaust fluid tank level sensor open circuit check
  5. Aftertreatment diesel exhaust fluid tank level sensor circuit response
  6. Aftertreatment diesel exhaust fluid tank level sensor open circuit check
  7. Aftertreatment diesel exhaust fluid tank level sensor circuit pin to ground short
  8. Aftertreatment diesel exhaust fluid tank level sensor circuit pin to pin short
  9. ECM calibration revision history check
  10. Aftertreatment diesel exhaust fluid tank level sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000140

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 1669

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid tank level sensor is malfunctioning

Solution: S00001232

Verification

Conditions

  • None

Action

  • Verify if the aftertreatment diesel exhaust fluid level sensor is a multiplexed sensor for this application.

Specification

  • If the aftertreatment diesel exhaust fluid level sensor is a multiplexed sensor and the fault code is active or inactive with more than 1 count within the last 25 engine operating hours, then a malfunctioning aftertreatment diesel exhaust fluid level sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid tank level sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid tank level sensor voltage check

Solution: S00001177

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment diesel exhaust fluid tank level sensor voltage SUPPLY pin and the aftertreatment diesel exhaust fluid tank level sensor voltage RETURN pin at the OEM wiring harness connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Aftertreatment diesel exhaust fluid tank level sensor open circuit

Refer to S00001237

Repair

  • No additional action is required for this solution.

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3.1 - Aftertreatment diesel exhaust fluid tank level sensor open circuit check

Solution: S00001237

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank level/temperature sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.
  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment diesel exhaust fluid tank level sensor RETURN pin and the OEM wiring harness aftertreatment diesel exhaust fluid tank level sensor connector RETURN pin.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Aftertreatment diesel exhaust fluid tank level sensor circuit response

Solution: S00000393

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning aftertreatment diesel exhaust fluid tank level sensor has been detected if the following fault code became active with the sensor disconnected: 1669

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid tank level sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment diesel exhaust fluid tank level sensor open circuit check

Solution: S00000942

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment diesel exhaust fluid tank level sensor SIGNAL pin and the OEM wiring harness aftertreatment diesel exhaust fluid tank level sensor connector SIGNAL pin.
  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment diesel exhaust fluid tank level sensor RETURN pin and the OEM wiring harness aftertreatment diesel exhaust fluid tank level sensor connector RETURN pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment diesel exhaust fluid tank level sensor circuit pin to ground short

Solution: S00000696

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid tank level sensor SIGNAL pin at the OEM wiring harness ECM connector and engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Aftertreatment diesel exhaust fluid tank level sensor circuit pin to pin short

Solution: S00000697

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid tank level sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins in the connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Aftertreatment diesel exhaust fluid tank level sensor is malfunctioning

Solution: S00000695

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Engine running at idle.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active and no other fault codes have been logged, then a malfunctioning aftertreatment diesel exhaust fluid tank level, temperature, quality sensor has been detected.

Linked Solutions

  • None

Repair

If an aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit has been replaced within the last 90 days, follow your technical escalation process PRIOR to performing any of the repair actions listed below:

The aftertreatment diesel exhaust fluid tank level sensor is a integrated part of the aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit and is not a servicable part.

  • Replace the aftertreatment diesel exhaust fluid tank level sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1669 | SPN: 1761 | FMI: 3
Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Incorrect adjustable parameter setting
  3. Aftertreatment diesel exhaust fluid tank level sensor is malfunctioning
  4. Aftertreatment diesel exhaust fluid tank level sensor voltage check
  5. Aftertreatment diesel exhaust fluid tank level sensor open circuit check
  6. Aftertreatment diesel exhaust fluid tank level sensor circuit response
  7. Aftertreatment diesel exhaust fluid tank level sensor open circuit check
  8. Aftertreatment diesel exhaust fluid tank level sensor circuit pin to pin short
  9. ECM calibration revision history check
  10. Aftertreatment diesel exhaust fluid tank level sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000047

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1695, 1696

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Incorrect adjustable parameter setting

Solution: S00001174

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Check the adjustable parameters settings.

Specification

  • Adjustable parameter settings must be enabled/disable to match whether or not the aftertreatment diesel exhaust fluid tank level/temperature is used on the application.

Linked Solutions

  • None

Repair

  • Adjust the features and parameters to the correct settings.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid tank level sensor is malfunctioning

Solution: S00001232

Verification

Conditions

  • None

Action

  • Verify if the aftertreatment diesel exhaust fluid level sensor is a multiplexed sensor for this application.

Specification

  • If the aftertreatment diesel exhaust fluid level sensor is a multiplexed sensor and the fault code is active or inactive with more than 1 count within the last 25 engine operating hours, then a malfunctioning aftertreatment diesel exhaust fluid level sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid tank level sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid tank level sensor voltage check

Solution: S00001177

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment diesel exhaust fluid tank level sensor voltage SUPPLY pin and the aftertreatment diesel exhaust fluid tank level sensor voltage RETURN pin at the OEM wiring harness connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Aftertreatment diesel exhaust fluid tank level sensor open circuit

Refer to S00001237

Repair

  • No additional action is required for this solution.

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4.1 - Aftertreatment diesel exhaust fluid tank level sensor open circuit check

Solution: S00001237

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank level/temperature sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.
  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment diesel exhaust fluid tank level sensor RETURN pin and the OEM wiring harness aftertreatment diesel exhaust fluid tank level sensor connector RETURN pin.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Aftertreatment diesel exhaust fluid tank level sensor circuit response

Solution: S00000392

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the aftertreatment diesel exhaust fluid tank level sensor SIGNAL pin and the aftertreatment diesel exhaust fluid tank level sensor RETURN pin at the aftertreatment diesel exhaust fluid tank level sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning aftertreatment diesel exhaust fluid tank level sensor has been detected if the following fault code became active with the jumper wire in place: 1668

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid tank level sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment diesel exhaust fluid tank level sensor open circuit check

Solution: S00000942

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment diesel exhaust fluid tank level sensor SIGNAL pin and the OEM wiring harness aftertreatment diesel exhaust fluid tank level sensor connector SIGNAL pin.
  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment diesel exhaust fluid tank level sensor RETURN pin and the OEM wiring harness aftertreatment diesel exhaust fluid tank level sensor connector RETURN pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Aftertreatment diesel exhaust fluid tank level sensor circuit pin to pin short

Solution: S00000697

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid tank level sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins in the connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Aftertreatment diesel exhaust fluid tank level sensor is malfunctioning

Solution: S00000695

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Engine running at idle.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active and no other fault codes have been logged, then a malfunctioning aftertreatment diesel exhaust fluid tank level, temperature, quality sensor has been detected.

Linked Solutions

  • None

Repair

If an aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit has been replaced within the last 90 days, follow your technical escalation process PRIOR to performing any of the repair actions listed below:

The aftertreatment diesel exhaust fluid tank level sensor is a integrated part of the aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit and is not a servicable part.

  • Replace the aftertreatment diesel exhaust fluid tank level sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1673 | SPN: 1761 | FMI: 1
Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid level is low
  2. Aftertreatment diesel exhaust fluid tank level sensor circuit is malfunctioning
  3. ECM calibration revision history check

1 - Aftertreatment diesel exhaust fluid level is low

Solution: S00000798

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Fill the aftertreatment diesel exhaust fluid tank.

Refer to OEM Service Manual

Specification

  • If the fault code goes inactive, proceed to Repair section.

Linked Solutions

  • None

Repair

  • Fill the aftertreatment diesel exhaust fluid tank completely full.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid tank level sensor circuit is malfunctioning

Solution: S00000546

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually check the level of the aftertreatment diesel exhaust fluid in the aftertreatment diesel exhaust fluid tank.
  • Monitor the position of the aftertreatment diesel exhaust fluid level with the recommended Cummins® electronic service tool or equivalent.
  • Compare the reading from the recommended Cummins® electronic service tool or equivalent to the actual level of the aftertreatment diesel exhaust fluid.

Specification

  • If the actual aftertreatment diesel exhaust fluid level is within specification and the recommended Cummins® electronic service tool or equivalent reading is not the same as the actual level, then a malfunctioning aftertreatment diesel exhaust fluid level sensor have been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid tank level sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1677 | SPN: 3031 | FMI: 4
Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid tank temperature sensor circuit response (Hardwired)
  2. Aftertreatment diesel exhaust fluid tank temperature sensor circuit pin to ground short
  3. Aftertreatment diesel exhaust fluid tank temperature sensor circuit pin shorted to another pin
  4. ECM calibration revision history check
  5. Aftertreatment diesel exhaust fluid tank temperature sensor is malfunctioning

1 - Aftertreatment diesel exhaust fluid tank temperature sensor circuit response (Hardwired)

Solution: S00000947

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor has been detected if the following fault code became active with the sensor disconnected: 1678

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid tank temperature sensor .

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid tank temperature sensor circuit pin to ground short

Solution: S00000757

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid tank temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid tank temperature sensor SIGNAL pin of the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid tank temperature sensor circuit pin shorted to another pin

Solution: S00000680

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid tank temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid tank temperature sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins in the connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment diesel exhaust fluid tank temperature sensor is malfunctioning

Solution: S00004854

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor has been detected.

Linked Solutions

  • None

Repair

If an aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit has been replaced within the last 90 days, follow your technical escalation process PRIOR to performing any of the repair actions listed below:

The aftertreatment diesel exhaust fluid tank level sensor is a integrated part of the aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit and is not a servicable part.

  • Replace the aftertreatment diesel exhaust fluid tank temperature sensor .

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1678 | SPN: 3031 | FMI: 3
Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid tank temperature sensor circuit response (Hardwired)
  2. Aftertreatment diesel exhaust fluid tank temperature sensor open circuit check
  3. Aftertreatment diesel exhaust fluid tank temperature sensor circuit pin shorted to another pin
  4. ECM calibration revision history check
  5. Aftertreatment diesel exhaust fluid tank temperature sensor is malfunctioning

1 - Aftertreatment diesel exhaust fluid tank temperature sensor circuit response (Hardwired)

Solution: S00000397

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the aftertreatment diesel exhaust fluid tank temperature sensor SIGNAL pin and the aftertreatment diesel exhaust fluid tank temperature sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor has been detected if the following fault code became active with the jumper wire in place: 1677

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid tank temperature sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid tank temperature sensor open circuit check

Solution: S00000729

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment diesel exhaust fluid tank temperature sensor RETURN pin and the OEM wiring harness aftertreatment diesel exhaust fluid tank temperature sensor connector RETURN pin.
  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment diesel exhaust fluid tank temperature sensor SIGNAL pin and the OEM wiring harness aftertreatment diesel exhaust fluid tank temperature sensor connector SIGNAL pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid tank temperature sensor circuit pin shorted to another pin

Solution: S00000680

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid tank temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid tank temperature sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins in the connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment diesel exhaust fluid tank temperature sensor is malfunctioning

Solution: S00004854

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor has been detected.

Linked Solutions

  • None

Repair

If an aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit has been replaced within the last 90 days, follow your technical escalation process PRIOR to performing any of the repair actions listed below:

The aftertreatment diesel exhaust fluid tank level sensor is a integrated part of the aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit and is not a servicable part.

  • Replace the aftertreatment diesel exhaust fluid tank temperature sensor .

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1679 | SPN: 3031 | FMI: 2
Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. OEM ambient air temperature sensor stuck in-range
  3. Aftertreatment diesel exhaust fluid tank temperature sensor is malfunctioning
  4. Aftertreatment diesel exhaust fluid tank temperature sensor open circuit check
  5. Aftertreatment diesel exhaust fluid tank temperature sensor circuit pin shorted to another pin
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000142

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 1677, 1678
  • Intake manifold temperature: 436
  • Engine coolant temperature: 334, 197, 3366

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - OEM ambient air temperature sensor stuck in-range

Solution: S00000339

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the OEM ambient air temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the temperature sensor is not within the following specification of local ambient air temperature: 5°F [2.8°C]

Linked Solutions

  • None

Repair

  • Replace the ambient air temperature sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid tank temperature sensor is malfunctioning

Solution: S00003127

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the reading from the recommended Cummins® electronic service tool or equivalent for the aftertreatment diesel exhaust fluid tank temperature sensor to the infrared thermometer reading.

Specification

  • A malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor has been detected if the reading is not within the following specification: 10 C [18 F]

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid tank temperature sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid tank temperature sensor open circuit check

Solution: S00000729

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment diesel exhaust fluid tank temperature sensor RETURN pin and the OEM wiring harness aftertreatment diesel exhaust fluid tank temperature sensor connector RETURN pin.
  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment diesel exhaust fluid tank temperature sensor SIGNAL pin and the OEM wiring harness aftertreatment diesel exhaust fluid tank temperature sensor connector SIGNAL pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment diesel exhaust fluid tank temperature sensor circuit pin shorted to another pin

Solution: S00000680

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid tank temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid tank temperature sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins in the connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1682 | SPN: 3362 | FMI: 31
Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Input Lines - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid dosing unit connector is malfunctioning
  3. Aftertreatment diesel exhaust fluid dosing unit line or fittings are cracked, plugged or restricted
  4. Aftertreatment diesel exhaust fluid is contaminated
  5. Aftertreatment diesel exhaust fluid blocked backflow fitting
  6. Leaks in the aftertreatment diesel exhaust fluid dosing system
  7. Aftertreatment diesel exhaust fluid dosing unit suction test
  8. Aftertreatment diesel exhaust fluid dosing unit is malfunctioning
  9. Aftertreatment diesel exhaust fluid dosing unit intake restriction
  10. Air in the aftertreatment diesel exhaust fluid
  11. Aftertreatment diesel exhaust fluid tank filter is restricted
  12. Aftertreatment Diesel Exhaust Fluid Doser Pump Override test
  13. Aftertreatment diesel exhaust fluid dosing valve is malfunctioning
  14. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001387

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 1671, 1673, 1683, 1684, 1712, 1713, 3237, 3239, 3242, 3422, 3497, 3498, 3562, 3563, 3567, 3568, 3571, 3572, 3575, 3596, 5278, 5867, 5935
  • Aftertreatment diesel exhaust fluid dosing unit: 3558, 3559

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid dosing unit connector is malfunctioning

Solution: S00003209

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.
  • Inspect all connections for corrosion or loose connections.

Specification

  • If the aftertreatment diesel exhaust fluid dosing unit connector or the aftertreatment diesel exhaust fluid dosing unit wiring harness connector show signs of diesel exhaust fluid, then a malfunctioning aftertreatment diesel exhaust fluid dosing unit connector has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

  • Repair or replace the OEM wiring harness.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid dosing unit line or fittings are cracked, plugged or restricted

Solution: S00000664

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the lines are not swapped at the dosing unit, dosing valve or diesel exhaust fluid tank connections.

Refer to Procedure 011-058

  • Visually inspect the aftertreatment diesel exhaust fluid tank connections for cracks or pitting.
  • Visually inspect the aftertreatment diesel exhaust fluid tank vent line for restrictions.
  • Visually inspect the aftertreatment diesel exhaust fluid line for damage.
  • Visually inspect both dosing unit connections and fittings for loose, leaking, or damaged connections.
  • Disconnect the suction line and pressure line dosing unit connectors and look for signs of build-up or blockage.

Refer to Procedure 011-058

  • Visually inspect the suction line for signs of leakage or openings which will allow the dosing unit to suck in air with the diesel exhaust fluid.
  • Visually inspect the pressure line for signs of leakage or rupture.
  • Verify proper sealing at all connection points, including diesel exhaust fluid tank, dosing unit, and dosing valve.

Refer to Procedure 011-058

Specification

  • If there are aftertreament diesel exhaust fluid lines reversed, damaged, leaking or restricted connections found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace damaged components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid is contaminated

Solution: S00000563

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Use a diesel exhaust fluid refractometer to measure the concentration of the diesel exhaust fluid in the tank.

Refer to Service Bulletin 4021566

Specification

  • If there are signs of contaminates in the aftertreatment diesel exhaust fluid, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to Procedure 011-056

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment diesel exhaust fluid blocked backflow fitting

Solution: S00002819

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-080

  • Monitor the aftertreatment diesel exhaust fluid pressure.

Specification

  • A blocked backflow fitting has been detected if the dosing unit shut off and the diesel exhaust fluid pressure was greater than the following for more than 3 seconds: 1000 kPa [145 psi]

Linked Solutions

  • None

Repair

  • Replace the backflow fitting.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Leaks in the aftertreatment diesel exhaust fluid dosing system

Solution: S00002840

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-080

  • While the test is running, inspect the diesel exhaust fluid tank connectors, diesel exhaust fluid dosing unit and dosing unit connectors, diesel exhaust fluid lines, and diesel exhaust fluid dosing valve for signs of external leaks.

Specification

  • If a line, fitting, connection, or dosing unit is leaking, then a malfunction has been detected in the aftertreatment diesel exhaust fluid system or dosing unit.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Repair or replace the leaking diesel exhaust fluid line, connector or fitting.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Aftertreatment diesel exhaust fluid dosing unit suction test

Solution: S00000360

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the Aftertreatment Diesel Exhaust Fluid Dosing Unit Suction Test.

Refer to Procedure 011-121

Specification

  • If the vacuum in diagnostic line does not meet specification, then proceed to the Linked Solutions section.

Linked Solutions

Click on the link below:

  • Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

Refer to S00000522

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7.1 - Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

Solution: S00000522

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the Aftertreatment Diesel Exhaust Fluid Dosing Unit Non Air Flush.

Refer to Procedure 011-058

  • Perform the Aftertreatment Diesel Exhaust Fluid Dosing Unit Suction Test.

Refer to Procedure 011-121

Specification

  • A malfunctioning aftertreatment diesel exhaust fluid dosing unit has been detected if vacuum is less than the following specification: -216 mm-hg [-8.0 in-hg]
  • Excessive blockage or buildup has been detected in the aftertreatment diesel exhaust fluid dosing system and the aftertreatment diesel exhaust fluid dosing unit can be reused if the vacuum is greater than the following specification: -216 mm-hg [-8.0 in-hg]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Cleaning of the aftertreatment diesel exhaust fluid dosing system resolved the issue.
  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

8 - Aftertreatment diesel exhaust fluid dosing unit intake restriction

Solution: S00000732

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the aftertreatment diesel exhaust fluid dosing unit intake restriction.

Refer to Procedure 011-086

Specification

  • If the vacuum in diagnostic line is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the diesel exhaust fluid tank filter.

Refer to OEM Service Manual

  • Clean or replace the aftertreatment diesel exhaust fluid intake line.

Refer to OEM Service Manual

  • Clean or replace the aftertreatment diesel exhaust fluid tank header.

Refer to OEM Service Manual

  • Clean or replace the aftertreatment diesel exhaust fluid tank vent.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Air in the aftertreatment diesel exhaust fluid

Solution: S00000730

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Check for air in the diesel exhaust fluid.

Refer to Procedure 011-075

Specification

  • If a line, fitting, connection, or dosing unit is leaking, then a malfunction has been detected in the aftertreatment diesel exhaust fluid system or dosing unit.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to Procedure 011-075

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - Aftertreatment diesel exhaust fluid tank filter is restricted

Solution: S00002874

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the sending unit from the diesel exhaust fluid tank.

Action

  • Visually verify that the aftertreatment diesel exhaust fluid level in the tank agrees with the diesel exhaust fluid level gauge reading.
  • Visually inspect the aftertreatment diesel exhaust fluid tank filter for signs of blockage or buildup.

Refer to OEM Service Manual

  • Visually inspect the aftertreatment diesel exhaust fluid suction tube for damage.

Refer to OEM Service Manual

Specification

  • If the aftertreatment diesel exhaust fluid tank filter is blocked or restricted, then proceed to the Repair section.
  • if the aftertreatment diesel exhaust fluid suction tube is damaged, then proceed to the Repair section.
  • If the actual aftertreatment diesel exhaust fluid level is within specification and the recommended Cummins® electronic service tool or equivalent reading is not the same as the actual level, then a malfunctioning aftertreatment diesel exhaust fluid level sensor have been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the diesel exhaust fluid tank filter.

Refer to OEM Service Manual

  • Drain, clean, and refill the diesel exhaust fluid dosing system.

Refer to Procedure 011-056

  • Replace the aftertreatment diesel exhaust fluid tank level sensor.

Refer to OEM Service Manual

  • Replace the aftertreatment diesel exhaust fluid suction tube.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

11 - Aftertreatment Diesel Exhaust Fluid Doser Pump Override test

Solution: S00002761

Verification

Conditions

  • Reconnect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank if they have been previously disconnected during troubleshooting.

Action

  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.

Refer to Procedure 011-059

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

The Aftertreatment Diesel Exhaust Fluid Doser Pump Override test can only be ran twice before a key cycle needs to be performed.

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test meets the specification, then proceed to the next solution.
  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test does not meet the specification, then proceed to the Linked Solutions section.

Linked Solutions

Click on the link below:

  • Aftertreatment diesel exhaust fluid dosing valve is malfunctioning

Refer to S00002764

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

11.1 - Aftertreatment diesel exhaust fluid dosing valve is malfunctioning

Solution: S00002764

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Clean the aftertreatment diesel exhaust fluid dosing valve.
  • Turn keyswitch ON.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

12 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1683 | SPN: 3363 | FMI: 3
Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid tank heater control valve circuit response
  2. Aftertreatment diesel exhaust fluid tank heater control valve open circuit check
  3. Aftertreatment diesel exhaust fluid tank heater control valve circuit pin to pin short

1 - Aftertreatment diesel exhaust fluid tank heater control valve circuit response

Solution: S00000401

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank heater control valve from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the aftertreatment diesel exhaust fluid tank heater control valve SIGNAL pin and the aftertreatment diesel exhaust fluid tank heater control valve RETURN pin at the aftertreatment diesel exhaust fluid tank heater control valve connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Run the engine at idle.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning aftertreatment diesel exhaust fluid tank heater control valve has been detected if the following fault code became active with the jumper wire in place: 1684

Linked Solutions

  • None

Repair

  • Repair or replace the aftertreatment diesel exhaust fluid tank heater control valve.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid tank heater control valve open circuit check

Solution: S00005496

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid tank heater control valve from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid tank heater control valve SIGNAL pin at the aftertreatment diesel exhaust fluid tank heater control valve OEM wiring harness connector and the aftertreatment diesel exhaust fluid tank heater control valve SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid tank heater control valve RETURN pin at the aftertreatment diesel exhaust fluid tank heater control valve wiring harness connector and the aftertreatment diesel exhaust fluid tank heater control valve RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid tank heater control valve circuit pin to pin short

Solution: S00000659

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid tank heater control valve from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid tank heater control valve SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid tank heater control valve SUPPLY pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1684 | SPN: 3363 | FMI: 4
Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid tank heater control valve circuit response
  2. Aftertreatment diesel exhaust fluid tank heater control valve circuit short to ground
  3. Aftertreatment diesel exhaust fluid tank heater control valve circuit pin to pin short

1 - Aftertreatment diesel exhaust fluid tank heater control valve circuit response

Solution: S00002870

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank heater control valve from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Run the engine at idle.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning aftertreatment diesel exhaust fluid tank heater control valve has been detected if the following fault code became active with the valve disconnected: 1683

Linked Solutions

  • None

Repair

  • Repair or replace the aftertreatment diesel exhaust fluid tank heater control valve.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid tank heater control valve circuit short to ground

Solution: S00000661

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid tank heater control valve from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid tank heater control valve SIGNAL pin at the OEM wiring harness ECM connector and engine block ground.
  • Measure the resistance between the aftertreatment diesel exhaust fluid tank heater control valve SUPPLY pin at the OEM wiring harness ECM connector and engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100K Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid tank heater control valve circuit pin to pin short

Solution: S00000659

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid tank heater control valve from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid tank heater control valve SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid tank heater control valve SUPPLY pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1685 | SPN: 3364 | FMI: 4
Aftertreatment 1 Diesel Exhaust Fluid Quality Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid quality sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000144

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 3868

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid quality sensor is malfunctioning

Solution: S00000933

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than once count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid quality sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid quality sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1686 | SPN: 3364 | FMI: 3
Aftertreatment 1 Diesel Exhaust Fluid Quality Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid quality sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000145

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 3868

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid quality sensor is malfunctioning

Solution: S00000933

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than once count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid quality sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid quality sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1691 | SPN: 5298 | FMI: 18
Aftertreatment 1 Diesel Oxidation Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Technical Service Bulletin is available
  3. Aftertreatment exhaust system leaks
  4. Aftertreatment temperature sensor stuck in-range
  5. Turbocharger exhaust is leaking oil into the aftertreatment system
  6. Aftertreatment fuel injector is malfunctioning
  7. Aftertreatment DOC is malfunctioning
  8. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000760

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment DOC: 3313, 3314, 3315, 3251,
  • Aftertreatment DPF: 3311 3312, 3316, 3317, 3318, 3319, 3321, 3322, 3253, 3254, 3255, 3256, 4151, 4158, 4161, 4162, 4163, 4259
  • Turbocharger: 595, 687, 691, 692, 693, 1894, 1897, 1898, 1962, 1976, 2198, 2288, 2387, 2449, 2634, 2635, 2636, 6432
  • EGR: 1228, 1866, 1867, 1896, 1961, 2272, 2273, 2274, 2349, 2353, 2375, 2376, 2861, 2962, 3342, 3382, 3383
  • Fuel: 271, 272, 449, 451, 452, 483, 484, 755, 2265, 2266, 2311, 2343, 2372, 3727, 3741, 4284, 4691, 4713, 4726, 4727, 4841, 6258, 6259

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Technical Service Bulletin is available

Solution: S00009715

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb130159

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment exhaust system leaks

Solution: S00001008

Verification

Conditions

  • Engine running.

Action

  • Visually inspect for leaks in the exhaust manifold to head.

Refer to Procedure 010-024

  • Visually inspect for leaks from the turbocharger to exhaust manifold.

Refer to Procedure 010-024

  • Visually inspect for leaks in the exhaust plumbing between the turbocharger outlet and the Aftertreatment DOC intake connection.

Refer to Procedure 010-024

  • Visually inspect the exhaust piping for leaks, cracks, and loose connections.

Refer to Procedure 010-024

  • Inspect for leaks at the aftertreatment DOC housing, sensor ports and connection points.

Refer to Procedure 010-024

  • Visually inspect the aftertreatment and SCR components for exhaust leaks.

Refer to Procedure 010-024

Specification

  • If there is any damage or leaks found in the exhaust system, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the exhaust manifold.

Refer to Procedure 011-007

  • Repair or replace the exhaust plumbing.

Refer to Procedure 011-007

Refer to OEM Service Manual

  • Replace aftertreatment DOC.

Refer to Procedure 011-049

  • Replace the aftertreatment diesel particulate filter.

Refer to Procedure 011-041

  • Replace the aftertreatment SCR Catalyst.

Refer to Procedure 011-036

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment temperature sensor stuck in-range

Solution: S00000338

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Start the engine.

Action

  • Run the engine at high idle for the following minutes: 10
  • Use the recommended Cummins® electronic service tool or equivalent.

Monitor the following parameters:

  • Aftertreatment diesel oxidation catalyst intake temperature
  • Aftertreatment diesel particulate filter intake temperature
  • Aftertreatment diesel particulate filter outlet temperature

Specification

  • A malfunctioning aftertreatment exhaust gas temperature sensor has been detected if each sensor is not within the following specification of the others: 24 C [43 F]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Turbocharger exhaust is leaking oil into the aftertreatment system

Solution: S00000655

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the exhaust piping from the turbocharger outlet.

Action

  • Inspect for any fluids.
  • Visually inspect the turbocharger exhaust outlet for signs of oil or fuel.
  • Perform the Snap Acceleration Test - Aftertreatment Disconnected.

Refer to Procedure 014-017

Specification

  • If lubricating engine oil contamination is found in the turbocharger exhaust outlet, then reset the search to oil consumption internal.
  • If excessive black smoke is detected, then reset the search to black smoke.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

6 - Aftertreatment fuel injector is malfunctioning

Solution: S00003043

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the Aftertreatment Maintenance Reset All procedure found under the Aftertreatment Maintenance Section of Advanced ECM Data.

Performing the Aftertreatment Maintenance Reset All may cause the fault code to go inactive. This does not mean that the issue was resolved, only that the efficiencies were reset. Troubleshooting must be continued.

  • Visually inspect for a missing poppet in the aftertreatment fuel injector.

Refer to TSB130159

  • Perform the Aftertreatment Fuel Injector Flow Test.

Refer to Procedure 011-054

Specification

  • If the Aftertreatment Fuel Injector Flow Test does not meet specification, then a malfunctioning aftertreatment fuel injector has been detected.

Linked Solutions

  • None

Repair

  • Replace the fuel injector.

Refer to Procedure 011-042

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Aftertreatment DOC is malfunctioning

Solution: S00005082

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect for the presence of the aftertreatment DOC.

Refer to Procedure 011-049

  • Inspect the inlet face of the aftertreatment DOC for reuse.

Refer to Procedure 011-049

Refer to Service Bulletin 4021600

  • Inspect for cracks in the aftertreatment DOC cell walls.

Refer to Service Bulletin 4021600

  • Inspect for soot or oil plugging the front face of the catalyst

Refer to Service Bulletin 4021600

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • If the face of the aftertreatment DOC is plugged, then clean the aftertreatment DOC.

Refer to Procedure 011-049

  • If the face of the aftertreatment DOC is cracked or damaged, then replace the aftertreatment DOC.

Refer to Procedure 011-049

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1694 | SPN: 3226 | FMI: 2
Aftertreatment 1 Outlet NOx Sensor - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment exhaust system leaks
  3. Aftertreatment outlet NOx sensor has carbon buildup
  4. Deposits in the SCR decomposition tube
  5. Leaks in the aftertreatment diesel exhaust fluid dosing system
  6. Aftertreatment Diesel Exhaust Fluid Doser Pump Override test
  7. Aftertreatment diesel exhaust fluid dosing valve is malfunctioning
  8. Aftertreatment SCR System Test
  9. Aftertreatment diesel exhaust fluid dosing system test failed
  10. Aftertreatment intake NOx sensor failed
  11. Aftertreatment outlet NOx sensor - Inspection
  12. Inspect both aftertreatment NOx sensors
  13. Aftertreatment SCR Catalyst Test Failed
  14. Aftertreatment outlet NOx sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000146

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment NOx: 1885, 1887, 2771, 3228, 3232, 3545, 3583, 3649, 3681, 3682, 3725, 3748, 3749

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment exhaust system leaks

Solution: S00001008

Verification

Conditions

  • Engine running.

Action

  • Visually inspect for leaks in the exhaust manifold to head.

Refer to Procedure 010-024

  • Visually inspect for leaks from the turbocharger to exhaust manifold.

Refer to Procedure 010-024

  • Visually inspect for leaks in the exhaust plumbing between the turbocharger outlet and the Aftertreatment DOC intake connection.

Refer to Procedure 010-024

  • Visually inspect the exhaust piping for leaks, cracks, and loose connections.

Refer to Procedure 010-024

  • Inspect for leaks at the aftertreatment DOC housing, sensor ports and connection points.

Refer to Procedure 010-024

  • Visually inspect the aftertreatment and SCR components for exhaust leaks.

Refer to Procedure 010-024

Specification

  • If there is any damage or leaks found in the exhaust system, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the exhaust manifold.

Refer to Procedure 011-007

  • Repair or replace the exhaust plumbing.

Refer to Procedure 011-007

Refer to OEM Service Manual

  • Replace aftertreatment DOC.

Refer to Procedure 011-049

  • Replace the aftertreatment diesel particulate filter.

Refer to Procedure 011-041

  • Replace the aftertreatment SCR Catalyst.

Refer to Procedure 011-036

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment outlet NOx sensor has carbon buildup

Solution: S00000540

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the correct aftertreatment outlet NOx sensor is installed for engine configuration (12 or 24 volt).
  • Remove the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Inspect the sensor tip for damage or carbon buildup.

Refer to Procedure 019-451

Specification

  • If the aftertreatment outlet NOx sensor is damaged or has carbon buildup, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Deposits in the SCR decomposition tube

Solution: S00000564

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the aftertreatment decomposition tube from the vehicle.

Refer to Procedure 011-062

  • Visually inspect the decomposition tube for deposits.

Refer to Procedure 011-062

Specification

  • If any excessive aftertreatment diesel exhaust fluid deposits were found inside the decomposition tube, then a plugged or restricted aftertreatment decomposition tube has been detected.
  • Proceed to Linked Solutions section for additional checks.

Linked Solutions

  • Leaks in the aftertreatment diesel exhaust fluid dosing system

Refer to S00000735

Repair

  • Clean and install the decomposition tube.

Refer to Procedure 011-062

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4.1 - Leaks in the aftertreatment diesel exhaust fluid dosing system

Solution: S00000735

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank if they have been previously disconnected during troubleshooting.

Action

  • Remove the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-080

Specification

  • If a line, fitting, connection, or dosing unit is leaking, then a malfunction has been detected in the aftertreatment diesel exhaust fluid system or dosing unit.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to Procedure 011-059

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Aftertreatment Diesel Exhaust Fluid Doser Pump Override test

Solution: S00002761

Verification

Conditions

  • Reconnect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank if they have been previously disconnected during troubleshooting.

Action

  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.

Refer to Procedure 011-059

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

The Aftertreatment Diesel Exhaust Fluid Doser Pump Override test can only be ran twice before a key cycle needs to be performed.

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test meets the specification, then proceed to the next solution.
  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test does not meet the specification, then proceed to the Linked Solutions section.

Linked Solutions

Click on the link below:

  • Aftertreatment diesel exhaust fluid dosing valve is malfunctioning

Refer to S00002764

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5.1 - Aftertreatment diesel exhaust fluid dosing valve is malfunctioning

Solution: S00002764

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Clean the aftertreatment diesel exhaust fluid dosing valve.
  • Turn keyswitch ON.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - Aftertreatment SCR System Test

Solution: S00000541

Verification

Conditions

  • Connect all components.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment SCR System Test.

Refer to Procedure 014-025

If the Aftertreatment SCR System Test is not available on the recommended Cummins® electronic service tool or equivalent, update to the latest ECM Calibration Revision and then perform the Aftertreatment SCR System Test.

Specification

  • If the Aftertreatment SCR System Test does not pass, then proceed to the Linked Solutions section.

If the Aftertreatment SCR System Test does not activate, then reset the Search to Aftertreatment SCR System Test does not activate.

If the Aftertreatment SCR System Test does not complete, then reset the Search to Aftertreatment SCR System Test does not complete.

If the Aftertreatment SCR System Test displays "Deposit Burn Failed", the test should keep running and no repair action is required unless a Aftertreatment Intake or Outlet NOx sensor failure is detected.

Linked Solutions

  • Aftertreatment diesel exhaust fluid dosing system test failed

Refer to S00000552

  • Aftertreatment intake NOx sensor failed

Refer to S00000867

  • Aftertreatment outlet NOx sensor - Inspection

Refer to S00000567

  • Inspect both aftertreatment NOx sensors

Refer to S00000566

  • Aftertreatment SCR catalyst test failed

Refer to S00000565

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

6.1 - Aftertreatment diesel exhaust fluid dosing system test failed

Solution: S00000552

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If there are signs of contaminates in the diesel exhaust fluid, then proceed to the Repair section.
  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump override test displays FAILED, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to OEM Service Manual

  • For a Aftertreatment Diesel Exhaust Fluid Doser Pump override test displaying FAILED, then follow the repair instructions in the procedure.

Refer to Procedure 011-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6.2 - Aftertreatment intake NOx sensor failed

Solution: S00000867

Verification

Conditions

  • None

Action

  • Verify that the aftertreatment intake NOx sensor is displayed as FAILED.

Specification

  • If the SCR System test displays that the intake NOx sensor has FAILED, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6.3 - Aftertreatment outlet NOx sensor - Inspection

Solution: S00000567

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the decomposition tube for deposits.

Refer to Procedure 011-062

  • Visually inspect the aftertreatment diesel exhaust fluid tank connections for cracks or pitting.

Refer to OEM Service Manual

  • Connect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank.
  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-080

  • While the test is running, inspect the diesel exhaust fluid tank connectors, diesel exhaust fluid dosing unit and dosing unit connectors, diesel exhaust fluid lines, and diesel exhaust fluid dosing valve for signs of external leaks.

Specification

  • If the aftertreatment diesel exhaust fluid dosing valve is not leaking and there are no deposits in the decomposition tube, then a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Clean and install the decomposition tube.

Refer to Procedure 011-062

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6.4 - Inspect both aftertreatment NOx sensors

Solution: S00000566

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the decomposition tube for deposits.

Refer to Procedure 011-062

  • Visually inspect the aftertreatment diesel exhaust fluid tank connections for cracks or pitting.

Refer to OEM Service Manual

  • Connect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank.
  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-080

  • Verify proper sealing at all connection points, including diesel exhaust fluid tank, dosing unit, and dosing valve.

Specification

  • If the aftertreatment diesel exhaust fluid dosing valve is not leaking and there are no deposits in the decomposition tube, then a malfunctioning aftertreatment intake NOx sensor and a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Clean and install the decomposition tube.

Refer to Procedure 011-062

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6.5 - Aftertreatment SCR Catalyst Test Failed

Solution: S00000565

Verification

Conditions

  • Reconnect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank if they have been previously disconnected during troubleshooting.

Action

The aftertreatment diesel exhaust fluid dosing valve must be removed and placed in a measuring container greater then 1.5 liter [50 oz] capacity to perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override test.

The Aftertreatment Diesel Exhaust Fluid Doser Pump Override test can only be ran twice before a key cycle needs to be performed.

  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is not within specification, then proceed to the Repair section.
  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is within specification, then a malfunctioning aftertreatment SCR Catalyst has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Replace the aftertreatment SCR Catalyst.

Refer to Procedure 011-036

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

7 - Aftertreatment outlet NOx sensor is malfunctioning

Solution: S00000994

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1695 | SPN: 3513 | FMI: 3
Sensor Supply 5 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. OEM wiring harness has a short to battery
  2. ECM calibration revision history check

1 - OEM wiring harness has a short to battery

Solution: S00000970

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the remote accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the fan speed sensor from the OEM wiring harness.
  • Disconnect the OEM pressure sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM +5 volt SUPPLY pin at the OEM wiring harness ECM connector to the ECM battery (+) pins at the OEM wiring harness connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω
  • A malfunctioning ECM has been detected if the resistance is greater than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1696 | SPN: 3513 | FMI: 4
Sensor Supply 5 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid dosing unit connector is malfunctioning
  2. ECM sensor supply 5 voltage below normal
  3. OEM wiring harness has a short to ground
  4. ECM sensor supply 5 circuit pin to pin short
  5. ECM calibration revision history check

1 - Aftertreatment diesel exhaust fluid dosing unit connector is malfunctioning

Solution: S00003209

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.
  • Inspect all connections for corrosion or loose connections.

Specification

  • If the aftertreatment diesel exhaust fluid dosing unit connector or the aftertreatment diesel exhaust fluid dosing unit wiring harness connector show signs of diesel exhaust fluid, then a malfunctioning aftertreatment diesel exhaust fluid dosing unit connector has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

  • Repair or replace the OEM wiring harness.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM sensor supply 5 voltage below normal

Solution: S00000544

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Perform the following actions one at a time:
  • Disconnect the OEM pressure sensor from the OEM wiring harness.
  • Disconnect the spare OEM pressure sensor from the OEM wiring harness.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the ambient air temperature sensor from the OEM wiring harness.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve from the OEM wiring harness.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the remote accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the fan speed sensor from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the fuel level sensor from the OEM wiring harness.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code goes inactive when a component is disconnected, then a malfunctioning sensor supply component has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the OEM pressure sensor.

Refer to OEM Service Manual

  • Replace the spare OEM pressure sensor.

Refer to OEM Service Manual

  • Replace accelerator pedal or lever position sensor.

Refer to OEM Service Manual

  • Replace the ambient air temperature sensor.

Refer to OEM Service Manual

  • Replace aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Replace engine coolant level sensor.

Refer to Procedure 019-017

  • Replace the remote accelerator pedal assembly.

Refer to OEM Service Manual

  • Replace the fan speed sensor.

Refer to OEM Service Manual

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

  • Replace the fuel level sensor.

Refer to OEM Service Manual

  • Replace the vehicle speed sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - OEM wiring harness has a short to ground

Solution: S00001229

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the OEM pressure sensor from the OEM wiring harness.
  • Disconnect the ambient air temperature sensor from the OEM wiring harness.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the fan speed sensor from the OEM wiring harness.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the remote accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid pressure sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance and check for a short circuit between the 5-VDC SUPPLY pin and engine block ground.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM sensor supply 5 circuit pin to pin short

Solution: S00000542

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the OEM pressure sensor from the OEM wiring harness.
  • Disconnect the ambient air temperature sensor from the OEM wiring harness.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the fan speed sensor from the OEM wiring harness.
  • Disconnect the vehicle speed sensor from the OEM wiring harness.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the remote accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid pressure sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance and check for a short circuit between the 5-VDC SUPPLY pin and all other pins in the OEM wiring harness ECM connector.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1712 | SPN: 3363 | FMI: 18
Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. No coolant flow through diesel exhaust fluid tank heater line
  3. Restricted or leaking aftertreatment diesel exhaust fluid tank heater control valve coolant lines
  4. Aftertreatment diesel exhaust fluid tank heater control valve is installed incorrectly
  5. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000147

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 1677, 1678, 1679, 1683, 1684, 3242, 3576

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - No coolant flow through diesel exhaust fluid tank heater line

Solution: S00001102

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the coolant level.

Specification

  • If the coolant level is low, then proceed to Repair section.

Linked Solutions

  • None

Repair

  • For low coolant level, add coolant and visually inspect the engine components for traces of a coolant leak.

Refer to Procedure 008-018

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Restricted or leaking aftertreatment diesel exhaust fluid tank heater control valve coolant lines

Solution: S00000784

Verification

Conditions

  • Turn keyswitch OFF.
  • Verify that the engine coolant level is within normal operating range.

Action

  • Visually inspect the aftertreatment diesel exhaust fluid tank heater coolant lines for signs of damage, leaking lines, leaking gaskets, leaking seals, or loose connections.

Refer to OEM Service Manual

  • Visually inspect the aftertreatment diesel exhaust fluid tank heater coolant lines for kinks, or restrictions including the OEM in-line shutoff valve.

Refer to OEM Service Manual

Specification

  • If there are any leaks or restrictions in the aftertreatment diesel exhaust fluid tank heater coolant lines, then a malfunctioning aftertreatment diesel exhaust fluid tank heater coolant line or connection has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid tank heater control valve is installed incorrectly

Solution: S00000547

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the aftertreatment diesel exhaust fluid tank heater control valve is installed correctly, and not reversed.

Specification

  • If the aftertreatment diesel exhaust fluid tank heater control valve is reversed, then the incorrect installation of the aftertreatment diesel exhaust fluid tank heater control valve has been detected.
  • If the aftertreatment diesel exhaust fluid tank heater control valve is not reversed, then a malfunctioning aftertreatment diesel exhaust fluid tank heater control valve has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the aftertreatment diesel exhaust fluid tank heater control valve.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1713 | SPN: 3363 | FMI: 16
Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid tank temperature sensor is malfunctioning
  3. Aftertreatment diesel exhaust fluid tank heater control valve is installed incorrectly
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000148

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 1677, 1678, 1679, 1683, 1684, 3576, 4737

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid tank temperature sensor is malfunctioning

Solution: S00000574

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the reading from the recommended Cummins® electronic service tool or equivalent for the aftertreatment diesel exhaust fluid tank temperature sensor to the infrared thermometer reading.

Specification

  • A malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor has been detected if the reading is not within the following specification: 10 C [18 F]

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid tank temperature sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid tank heater control valve is installed incorrectly

Solution: S00000547

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the aftertreatment diesel exhaust fluid tank heater control valve is installed correctly, and not reversed.

Specification

  • If the aftertreatment diesel exhaust fluid tank heater control valve is reversed, then the incorrect installation of the aftertreatment diesel exhaust fluid tank heater control valve has been detected.
  • If the aftertreatment diesel exhaust fluid tank heater control valve is not reversed, then a malfunctioning aftertreatment diesel exhaust fluid tank heater control valve has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the aftertreatment diesel exhaust fluid tank heater control valve.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1714 | SPN: 3364 | FMI: 13
Aftertreatment 1 Diesel Exhaust Fluid Quality - Out of Calibration

Troubleshooting Summary

  1. ECM calibration revision history check
  2. Aftertreatment diesel exhaust fluid quality sensor is malfunctioning

1 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid quality sensor is malfunctioning

Solution: S00008137

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than once count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid quality sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid quality sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1715 | SPN: 3364 | FMI: 11
Aftertreatment 1 Diesel Exhaust Fluid Quality - Root Cause Not Known

Troubleshooting Summary

  1. Check for primary fault codes
  2. Multiple Technical Service Bulletins are available
  3. ECM calibration revision history check
  4. Aftertreatment diesel exhaust fluid quality sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000149

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 3868

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Multiple Technical Service Bulletins are available

Solution: S00005092

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb170054

  • If this engine is not in a Navistar application, then proceed to the next solution.
  • Technical Service Bulletin is available.

Refer to tsb160031

  • If this engine is not in a PACCAR™ application, then proceed to the next solution.
  • Technical Service Bulletin is available.

Refer to tsb200189

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid quality sensor is malfunctioning

Solution: S00000933

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than once count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid quality sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid quality sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1718 | SPN: 1322 | FMI: 31
Engine Misfire for Multiple Cylinders - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. Plugged or damaged exhaust gas pressure sensor tube
  3. Fuel Injector Performance Test
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000150

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 271, 272, 281, 322, 323, 324, 325, 331, 332, 449, 451, 452, 559, 1911, 2311, 2372
  • Sensor supply 6: 515, 516

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Plugged or damaged exhaust gas pressure sensor tube

Solution: S00000703

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

  • Inspect the exhaust gas pressure sensor tube for cracks and thread damage.

Refer to Procedure 011-027

  • Inspect the inside of the tube and sensor adapter for debris or soot buildup.

Refer to Procedure 011-027

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Fuel Injector Performance Test

Solution: S00000708

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Start the engine.
  • Allow the engine to reach operating temperature.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Injector Performance Test.

Refer to Procedure 014-014

If the Fuel Injector Performance Test will not activate, then troubleshoot Fuel Injector Performance Test Will not Activate.

If the Fuel Injector Performance Test will not complete, then troubleshoot Fuel Injector Performance Test Will not Complete.

Specification

  • If a Failed indication is displayed by the recommended Cummins® electronic service tool or equivalent for any injector, then that injector is malfunctioning.

Linked Solutions

  • None

Repair

  • Replace the fuel injector.

Refer to Procedure 006-026

  • Perform the Snap Acceleration - Aftertreatment Connected Test.

Refer to Procedure 014-017

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1843 | SPN: 101 | FMI: 3
Crankcase Pressure Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Crankcase pressure sensor voltage check
  3. Crankcase pressure sensor voltage check at the ECM
  4. Crankcase pressure sensor circuit response
  5. Crankcase pressure sensor circuit response check at the ECM

1 - Check for primary fault codes

Solution: S00000899

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Crankcase pressure sensor voltage check

Solution: S00000977

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the crankcase pressure sensor SUPPLY pin and the crankcase pressure sensor RETURN pin at the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Crankcase pressure sensor voltage check at the ECM

Refer to S00000978

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Crankcase pressure sensor voltage check at the ECM

Solution: S00000978

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the crankcase pressure sensor SUPPLY pin and the crankcase pressure sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Crankcase pressure sensor circuit response

Solution: S00000409

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning crankcase pressure sensor has been detected if the following fault code became active with the sensor disconnected: 1844

Linked Solutions

  • None

Repair

  • Replace crankcase pressure sensor.

Refer to Procedure 019-445

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Crankcase pressure sensor circuit response check at the ECM

Solution: S00001175

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 1844
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 1844

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 15-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1844 | SPN: 101 | FMI: 4
Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Crankcase pressure sensor voltage check
  3. Crankcase pressure sensor voltage check at the ECM
  4. Crankcase pressure sensor circuit response
  5. Crankcase pressure sensor circuit response check at the ECM

1 - Check for primary fault codes

Solution: S00000899

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Crankcase pressure sensor voltage check

Solution: S00000977

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the crankcase pressure sensor SUPPLY pin and the crankcase pressure sensor RETURN pin at the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Crankcase pressure sensor voltage check at the ECM

Refer to S00000978

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Crankcase pressure sensor voltage check at the ECM

Solution: S00000978

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the crankcase pressure sensor SUPPLY pin and the crankcase pressure sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Crankcase pressure sensor circuit response

Solution: S00000410

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the crankcase pressure sensor SUPPLY pin and the crankcase pressure sensor SIGNAL pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning crankcase pressure sensor has been detected if the following fault code became active with the jumper wire in place: 1843

Linked Solutions

  • None

Repair

  • Replace crankcase pressure sensor.

Refer to Procedure 019-445

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Crankcase pressure sensor circuit response check at the ECM

Solution: S00001176

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the crankcase pressure sensor SUPPLY pin and the crankcase pressure sensor SIGNAL pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 1843
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 1843

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.
  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 15-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1845 | SPN: 97 | FMI: 3
Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Incorrect water-in-fuel sensor installed
  2. Water in fuel sensor open circuit check
  3. OEM wiring harness has a pin to pin short
  4. Water in fuel sensor is malfunctioning

1 - Incorrect water-in-fuel sensor installed

Solution: S00000588

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the correct water-in-fuel sensor is being used for the engine application.

Specification

  • If the water in fuel sensor is not the correct sensor part number for the engine configuration, then the incorrect sensor has been installed.

Linked Solutions

  • None

Repair

  • Install the correct water in fuel sensor for the engine configuration.

Refer to Procedure 019-127

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Water in fuel sensor open circuit check

Solution: S00000589

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the water in fuel sensor SIGNAL pin at the water in fuel sensor OEM wiring harness connector and the water in fuel sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the water in fuel sensor RETURN pin at the water in fuel sensor OEM wiring harness connector and the water in fuel sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - OEM wiring harness has a pin to pin short

Solution: S00000590

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the water-in-fuel sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Water in fuel sensor is malfunctioning

Solution: S00000548

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning water in fuel sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace water in fuel sensor.

Refer to Procedure 019-127

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1846 | SPN: 97 | FMI: 4
Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. OEM wiring harness has a pin to pin short
  2. Water in fuel sensor is malfunctioning

1 - OEM wiring harness has a pin to pin short

Solution: S00000590

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the water-in-fuel sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Water in fuel sensor is malfunctioning

Solution: S00000548

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning water in fuel sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace water in fuel sensor.

Refer to Procedure 019-127

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1852 | SPN: 97 | FMI: 16
Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Water accumulation in the fuel filter
  2. ECM calibration revision history check
  3. Water in fuel sensor is malfunctioning

1 - Water accumulation in the fuel filter

Solution: S00000545

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Water has been detected in the fuel filter if a fault code from the following list is active, or has more than one inactive count within the last 25 engine operating hours: 418, 1852, 4642

Linked Solutions

  • None

Repair

  • Open the water drain from the bottom of the fuel filter to remove the water from the fuel filter.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Water in fuel sensor is malfunctioning

Solution: S00000548

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning water in fuel sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace water in fuel sensor.

Refer to Procedure 019-127

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1866 | SPN: 411 | FMI: 2
Exhaust Gas Recirculation Differential Pressure - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Technical Service Bulletin is available
  2. Check for primary fault codes
  3. Plugged EGR differential pressure sensor supply ports
  4. Leaks in the intake air system
  5. Charge air cooler system leak
  6. ECM calibration revision history check
  7. EGR differential pressure sensor is malfunctioning

1 - Technical Service Bulletin is available

Solution: S00008721

Verification

Conditions

  • Turn keyswitch OFF.
  • Verify OEM is Kenworth™.

Action

  • If this engine is not in a Kenworth™ application, then proceed to the next solution.
  • Technical Service Bulletin is available.

Refer to tsb160065

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Check for primary fault codes

Solution: S00000154

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • EGR differential pressure: 2273, 2274

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

3 - Plugged EGR differential pressure sensor supply ports

Solution: S00005073

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the EGR differential pressure sensor flow port cross-drillings for soot blockage.

Refer to Procedure 011-066

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Remove and clean the EGR mass measurement flow assembly.

Refer to Procedure 011-066

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Leaks in the intake air system

Solution: S00008386

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.
  • Visually inspect the intake plumbing for possible air leaks.

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Charge air cooler system leak

Solution: S00008815

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the charge air cooler hoses for possible air leaks.
  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If a leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the charge air cooler.

Refer to Procedure 010-027

  • Repair or replace the charge air cooler hoses.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - EGR differential pressure sensor is malfunctioning

Solution: S00003480

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the EGR differential pressure sensor.

Refer to Procedure 019-370

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1867 | SPN: 412 | FMI: 2
Exhaust Gas Recirculation Temperature - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. EGR temperature sensor stuck in-range
  3. EGR temperature sensor open circuit check
  4. EGR temperature sensor circuit pin to ground short
  5. EGR temperature sensor circuit pin to pin short
  6. ECM calibration revision history check
  7. EGR temperature sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000155

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Exhaust gas temperature: 2375, 2376

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - EGR temperature sensor stuck in-range

Solution: S00003137

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Monitor the intake manifold temperature
  • Monitor the EGR temperature sensor.

Specification

  • A malfunctioning EGR temperature sensor has been detected if the reading is not within the following specification of the intake manifold temperature sensor reading: +/- 5.5C [10F]

Linked Solutions

  • None

Repair

  • Replace EGR temperature sensor.

Refer to Procedure 019-378

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - EGR temperature sensor open circuit check

Solution: S00005089

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the EGR temperature sensor SIGNAL pin at the EGR temperature sensor engine wiring harness connector and the EGR temperature sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the EGR temperature sensor RETURN pin at the EGR temperature sensor engine wiring harness connector and the EGR temperature sensor RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - EGR temperature sensor circuit pin to ground short

Solution: S00005090

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the EGR temperature sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - EGR temperature sensor circuit pin to pin short

Solution: S00005079

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the EGR temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the EGR temperature sensor RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - EGR temperature sensor is malfunctioning

Solution: S00005254

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace EGR temperature sensor.

Refer to Procedure 019-378

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1879 | SPN: 3251 | FMI: 3
Aftertreatment 1 Diesel Particulate Filter Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment DPF differential pressure sensor voltage check
  3. Aftertreatment DPF differential pressure sensor circuit check
  4. Aftertreatment DPF differential pressure sensor circuit response
  5. Aftertreatment DPF differential pressure sensor open circuit check
  6. Aftertreatment DPF differential pressure sensor wire pin to pin short circuit check

1 - Check for primary fault codes

Solution: S00000047

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1695, 1696

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment DPF differential pressure sensor voltage check

Solution: S00001246

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment DPF differential/outlet pressure sensor SUPPLY pin and the aftertreatment DPF differential/outlet pressure sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section and perform the open circuit check if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Aftertreatment DPF differential pressure sensor circuit check

Refer to S00001247

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Aftertreatment DPF differential pressure sensor circuit check

Solution: S00001247

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment DPF differential pressure sensor SUPPLY pin and the OEM wiring harness aftertreatment DPF differential pressure sensor connector SUPPLY pin.
  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment DPF differential pressure sensor RETURN pin and the OEM wiring harness aftertreatment DPF differential pressure sensor connector RETURN pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Aftertreatment DPF differential pressure sensor circuit response

Solution: S00000582

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning aftertreatment DPF differential pressure sensor has been detected if the following fault code became active with the sensor disconnected: 1881

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF differential/outlet pressure sensor.

Refer to Procedure 019-443

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment DPF differential pressure sensor open circuit check

Solution: S00000984

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment DPF differential pressure sensor RETURN pin and the OEM wiring harness aftertreatment DPF differential pressure sensor connector RETURN pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment DPF differential pressure sensor wire pin to pin short circuit check

Solution: S00007439

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the remote accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the fuel level sensor from the OEM wiring harness.
  • Disconnect the fan speed sensor from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM wiring harness.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SIGNAL pin in the OEM wiring harness ECM connector and all other pins in the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment DPF differential pressure sensor SUPPLY pin in the OEM wiring harness ECM connector and all other pins in the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 15-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1881 | SPN: 3251 | FMI: 4
Aftertreatment 1 Diesel Particulate Filter Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment DPF differential pressure sensor voltage check
  3. Aftertreatment DPF differential pressure sensor circuit check
  4. Aftertreatment DPF differential pressure sensor circuit response
  5. Aftertreatment DPF differential pressure sensor open circuit check
  6. Aftertreatment DPF differential pressure sensor circuit pin to ground short
  7. Aftertreatment DPF differential pressure sensor wire pin to pin short circuit check

1 - Check for primary fault codes

Solution: S00000157

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1696

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment DPF differential pressure sensor voltage check

Solution: S00001246

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment DPF differential/outlet pressure sensor SUPPLY pin and the aftertreatment DPF differential/outlet pressure sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section and perform the open circuit check if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Aftertreatment DPF differential pressure sensor circuit check

Refer to S00001247

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Aftertreatment DPF differential pressure sensor circuit check

Solution: S00001247

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment DPF differential pressure sensor SUPPLY pin and the OEM wiring harness aftertreatment DPF differential pressure sensor connector SUPPLY pin.
  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment DPF differential pressure sensor RETURN pin and the OEM wiring harness aftertreatment DPF differential pressure sensor connector RETURN pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Aftertreatment DPF differential pressure sensor circuit response

Solution: S00000580

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the aftertreatment DPF differential pressure sensor SUPPLY pin and the aftertreatment DPF differential pressure sensor SIGNAL pin at the sensor connector of the OEM wiring harness.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning aftertreatment DPF differential pressure sensor has been detected if the following fault code became active with the jumper wire in place: 1879

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment DPF differential pressure sensor open circuit check

Solution: S00000996

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment diesel particulate filter differential pressure sensor SIGNAL pin and the OEM wiring harness aftertreatment diesel particulate filter differential pressure sensor connector SIGNAL pin.
  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment diesel particulate filter differential pressure sensor SUPPLY pin and the OEM wiring harness aftertreatment diesel particulate filter differential pressure sensor connector SUPPLY pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment DPF differential pressure sensor circuit pin to ground short

Solution: S00001539

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF outlet pressure sensor SIGNAL pin in the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment DPF differential pressure sensor wire pin to pin short circuit check

Solution: S00007439

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the remote accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the fuel level sensor from the OEM wiring harness.
  • Disconnect the fan speed sensor from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM wiring harness.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SIGNAL pin in the OEM wiring harness ECM connector and all other pins in the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment DPF differential pressure sensor SUPPLY pin in the OEM wiring harness ECM connector and all other pins in the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1883 | SPN: 3251 | FMI: 2
Aftertreatment 1 Diesel Particulate Filter Differential Pressure - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Damaged or missing aftertreatment DPF differential pressure sensor tubes
  3. Aftertreatment DPF differential pressure sensor voltage check
  4. Aftertreatment DPF differential pressure sensor circuit check
  5. Aftertreatment DPF differential pressure sensor stuck in-range
  6. Aftertreatment DPF differential pressure sensor open circuit check
  7. Aftertreatment DPF differential pressure sensor circuit pin to ground short
  8. Aftertreatment DPF differential pressure sensor wire pin to pin short circuit check
  9. ECM calibration revision history check
  10. Aftertreatment DPF differential pressure sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000158

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment DPF: 1879, 1881

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Damaged or missing aftertreatment DPF differential pressure sensor tubes

Solution: S00001010

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the aftertreatment differential pressure tubes for proper installation.
  • Inspect the aftertreatment DPF differential pressure sensor tubes for signs of damage, plugging, kinks, leakage or loose connections.

Refer to Procedure 011-047

In extreme cold ambient temperatures it is important to check for a frozen, plugged, or restricted aftertreatment DPF differential pressure sensor tubes. Ice can form in the aftertreatment DPF differential pressure sensor tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Specification

  • If damage, kinks or blockages are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace DPF differential pressure sensor tubes.

Refer to Procedure 011-047

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

3 - Aftertreatment DPF differential pressure sensor voltage check

Solution: S00001246

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment DPF differential/outlet pressure sensor SUPPLY pin and the aftertreatment DPF differential/outlet pressure sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section and perform the open circuit check if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Aftertreatment DPF differential pressure sensor circuit check

Refer to S00001247

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Aftertreatment DPF differential pressure sensor circuit check

Solution: S00001247

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment DPF differential pressure sensor SUPPLY pin and the OEM wiring harness aftertreatment DPF differential pressure sensor connector SUPPLY pin.
  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment DPF differential pressure sensor RETURN pin and the OEM wiring harness aftertreatment DPF differential pressure sensor connector RETURN pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Aftertreatment DPF differential pressure sensor stuck in-range

Solution: S00000793

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the aftertreatment DPF differential pressure sensor voltage.

Refer to Procedure 019-443

Specification

  • If the aftertreatment DPF differential pressure sensor voltage readings are not within specification, then a malfunctioning aftertreatment DPF differential pressure sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment DPF differential pressure sensor open circuit check

Solution: S00000996

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment diesel particulate filter differential pressure sensor SIGNAL pin and the OEM wiring harness aftertreatment diesel particulate filter differential pressure sensor connector SIGNAL pin.
  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment diesel particulate filter differential pressure sensor SUPPLY pin and the OEM wiring harness aftertreatment diesel particulate filter differential pressure sensor connector SUPPLY pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment DPF differential pressure sensor circuit pin to ground short

Solution: S00001539

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF outlet pressure sensor SIGNAL pin in the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Aftertreatment DPF differential pressure sensor wire pin to pin short circuit check

Solution: S00007439

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the remote accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the fuel level sensor from the OEM wiring harness.
  • Disconnect the fan speed sensor from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM wiring harness.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SIGNAL pin in the OEM wiring harness ECM connector and all other pins in the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment DPF differential pressure sensor SUPPLY pin in the OEM wiring harness ECM connector and all other pins in the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Aftertreatment DPF differential pressure sensor is malfunctioning

Solution: S00002710

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all preceding solution verifications have been performed, then a malfunctioning aftertreatment DPF differential pressure sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1885 | SPN: 3216 | FMI: 4
Aftertreatment 1 Intake NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Aftertreatment intake NOx sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000017

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment NOx: 3232, 3682

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment intake NOx sensor is malfunctioning

Solution: S00007913

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment intake NOx sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1887 | SPN: 3226 | FMI: 4
Aftertreatment 1 Outlet NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Aftertreatment outlet NOx sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000160

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment NOx: 2771, 3681

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment outlet NOx sensor is malfunctioning

Solution: S00000587

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is active or inactive with more than one count within the last 25 engine hours, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1894 | SPN: 641 | FMI: 9
VGT Actuator Driver Circuit - Abnormal Update Rate

Troubleshooting Summary

  1. Check for primary fault codes
  2. Low battery voltage
  3. Battery load test
  4. Ground inspection
  5. Variable geometry turbocharger actuator voltage check
  6. Wiring harness load test
  7. Variable geometry turbocharger actuator voltage check at the ECM
  8. Fault Code 1894 triggered by a malfunction in the J1939 data link with multiple OEM fault codes
  9. Variable geometry turbocharger actuator has incorrect J1939 terminating resistance
  10. J1939 data link engine wiring harness voltage check 3 pin service connector
  11. OEM sensor voltage check
  12. J1939 data link harness pin to ground short circuit
  13. J1939 data link terminating resistance is incorrect
  14. Variable geometry turbocharger actuator has incorrect J1939 terminating resistance
  15. Engine wiring harness has incorrect J1939 terminating resistance
  16. OEM wiring harness has incorrect J1939 terminating resistance
  17. OEM terminating resistor Ω check for the J1939 data link
  18. Incorrect terminating resistance in the J1939 data link by a J1939 data linked component
  19. J1939 wire resistance check at the crossover connector for each component
  20. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000161

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Turbocharger: 1897,1962,1976
  • Voltage: 1941

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Low battery voltage

Solution: S00001110

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.
  • If this vehicle has been repaired within the last 30 days for the same fault code, then proceed to the Linked Solutions section.

Specification

  • If the battery voltage is at least 10.8 VDC (12 volt systems) or 21.6 VDC (24 volt systems), then proceed to the Linked Solutions section.
  • If the battery or battery cables show signs of corrosion or damage, then proceed to the Repair Section.

Linked Solutions

  • Battery load test

Refer to S00001379

  • Ground inspection

Refer to S00000754

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean corrosion or tighten battery cable connections.

Refer to OEM Service Manual

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Battery load test

Solution: S00001379

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Disconnect the batteries from each other.
  • Connect a load tester separately to each battery.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.

Specification

  • For a 12 volt system, proceed to the Repair section if the battery voltage is below the following specification: 11 VDC
  • For a 24 volt system, proceed to the Repair section if the battery voltage is below the following specification: 22 VDC

Linked Solutions

  • None

Repair

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Ground inspection

Solution: S00000754

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the ECM ground for damage, corrosion and loose connections.
  • Visually inspect the aftertreatment interface wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the OEM wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the grounds for proper routing.

Specification

  • If damage, corrosion or incorrect routing of grounds are found, then proceed to the Repair section

Linked Solutions

  • None

Repair

  • Clean or replace connections.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Variable geometry turbocharger actuator voltage check

Solution: S00000597

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the variable geometry turbocharger actuator from the engine wiring harness.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the variable geometry turbocharger actuator battery SUPPLY pin and the variable geometry turbocharger actuator battery RETURN pin at the variable geometry turbocharger actuator engine wiring harness connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section and perform the Wiring Harness Load Test if the voltage is within the following specification of battery voltage: 1 VDC
  • Proceed to the Linked Solutions section and perform the voltage check at the ECM if voltage is not within the following specification: 1 VDC

Linked Solutions

  • Wiring harness load test

Refer to S00000877

  • Variable geometry turbocharger actuator voltage check at the ECM

Refer to S00001244

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Wiring harness load test

Solution: S00000877

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect all components on the wiring circuit being tested.

Action

This test is NOT for checking the J1939 data link (+) and (-) pins since it may cause damage to the J1939 smart devices or sensors.

  • Perform the wiring harness load test for the circuit being tested.

Refer to Procedure 019-359

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the voltage drop is not within specification, then a malfunctioning wiring harness has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.2 - Variable geometry turbocharger actuator voltage check at the ECM

Solution: S00001244

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the variable geometry turbocharger actuator battery SUPPLY pin and the variable geometry turbocharger actuator battery RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the voltage is within the following specification of battery voltage: 1 VDC
  • A malfunctioning ECM has been detected if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Fault Code 1894 triggered by a malfunction in the J1939 data link with multiple OEM fault codes

Solution: S00001109

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution, if any fault code is active or has more than one inactive count within the last 25 engine operating hours from the following list: 2771, 3232, 3868, 3911, 4151, 4152, 4572, 4677, 6688
  • Proceed to the Linked Solutions section if a fault code from the following list is not active or does not have more than one inactive count within the last 25 engine operating hours: 2771, 3232, 3868, 3911, 4151, 4152, 4572, 4677, 6688

Linked Solutions

  • Variable geometry turbocharger actuator has incorrect J1939 terminating resistance

Refer to S00001242

  • If the above checks are all within specification, then a malfunctioning variable geometry turbocharger actuator has been detected

Repair

  • Replace the variable geometry turbocharger actuator.

Refer to Procedure 010-134

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4.1 - Variable geometry turbocharger actuator has incorrect J1939 terminating resistance

Solution: S00001242

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the variable geometry turbocharger actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the variable geometry turbocharger actuator SAE J1939 data link (+) pin and the variable geometry turbocharger actuator SAE J1939 data link (-) pin at the variable geometry turbocharger actuator.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning variable geometry turbocharger actuator has been detected if the resistance is not within the following specification: 108 Ω - 132 Ω

Linked Solutions

  • None

Repair

  • Replace the variable geometry turbocharger actuator.

Refer to Procedure 010-134

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - J1939 data link engine wiring harness voltage check 3 pin service connector

Solution: S00000594

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect all SAE J1939 components.
  • Turn keyswitch ON.

Action

The service tool datalink adapter can NOT be connected to the 3-pin J1939 datalink connector during this check.

  • Measure the J1939 voltage of the J1939 (+) pin to ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

  • Measure the J1939 voltage of the J1939 (-) pin to ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

Specification

  • A malfunctioning wiring harness has been detected due to the J1939 data link circuit being shorted to a voltage source if the voltage is greater than the following specification: 4.5 VDC
  • Proceed to the Linked Solutions section if the voltage is less than the following specification: 1 VDC
  • Proceed to the next solution if the voltage is within the following specification for both the SAE J1939 data link (+) and SAE J1939 data link (-) circuit: 1 - 4.5 VDC

Linked Solutions

  • OEM J1939 data link component isolation

Refer to S00003176

  • Engine or OEM wiring harness shorted to ground

Refer to S00003331

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5.1 - OEM sensor voltage check

Solution: S00003176

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Reconnect the crossover connector.

Inspect the following components if applicable:

  • Turn keyswitch ON.
  • Measure the J1939 voltage of the SAE J1939 data link (+) and SAE data link J1939 (-) pins at the variable geometry turbocharger actuator engine wiring harness connector to battery ground while each component is disconnected one at a time.
  • Disconnect the aftertreatment outlet NOx sensor
  • Disconnect the aftertreatment DPF temperature sensor module.
  • Disconnect the aftertreatment SCR temperature sensor module.
  • Disconnect the aftertreatment intermediate NH3 sensor.
  • Disconnect the aftertreatment particulate sensor
  • Disconnect the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.
  • Disconnect the aftertreatment exhaust gas temperature sensor.
  • Disconnect the aftertreatment intake NOx sensor.

Specification

  • A malfunctioning SAE J1939 data link component has been detected if the voltage is within the following specification after the component has been disconnected: 1 - 4.5 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.

Refer to OEM Service Manual

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

  • Replace aftertreatment DPF temperature sensor module.

Refer to Procedure 019-449

  • Replace the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-449

  • Replace aftertreatment intermediate NH3 sensor.

Refer to Procedure 019-479

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.2 - J1939 data link harness pin to ground short circuit

Solution: S00003331

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Turn keyswitch ON.

Action

The service tool datalink adapter can NOT be connected to the 3-pin J1939 datalink connector during this check.

  • Measure the J1939 voltage of the J1939 (+) pin to battery ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

  • Measure the J1939 voltage of the J1939 (-) pin to battery ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

Specification

  • A malfunctioning OEM wiring harness has been detected if voltage is within the following specification with the crossover connector disconnected: 1 - 4.5 VDC
  • A malfunctioning engine wiring harness has been detected if voltage is not within the following specification with the crossover connector disconnected: 1 - 4.5 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - J1939 data link terminating resistance is incorrect

Solution: S00000593

Verification

Conditions

  • Turn keyswitch OFF.
  • Wait for 90 seconds.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.
  • Reconnect the variable geometry turbocharger actuator if it has been previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3-pin service data link connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Follow your technical escalation process if the resistance is within the following specification: 54 - 66 Ω
  • Proceed to the Linked Solutions section if the resistance is not within the following specification: 54 - 66 Ω

Linked Solutions

  • Variable geometry turbocharger actuator has incorrect J1939 terminating resistance

Refer to S00001242

  • Engine wiring harness has incorrect J1939 terminating resistance

Refer to S00000972

  • OEM wiring harness has incorrect J1939 terminating resistance

Refer to S00000971

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

6.1 - Variable geometry turbocharger actuator has incorrect J1939 terminating resistance

Solution: S00001242

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the variable geometry turbocharger actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the variable geometry turbocharger actuator SAE J1939 data link (+) pin and the variable geometry turbocharger actuator SAE J1939 data link (-) pin at the variable geometry turbocharger actuator.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning variable geometry turbocharger actuator has been detected if the resistance is not within the following specification: 108 Ω - 132 Ω

Linked Solutions

  • None

Repair

  • Replace the variable geometry turbocharger actuator.

Refer to Procedure 010-134

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6.2 - Engine wiring harness has incorrect J1939 terminating resistance

Solution: S00000972

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect previously disconnected components.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.
  • Disconnect the aftertreatment intake NOx sensor from the engine wiring harness.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3-pin service data link connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is not within the following specification: 108-132 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6.3 - OEM wiring harness has incorrect J1939 terminating resistance

Solution: S00000971

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if the resistance is not within the following specification: 108 - 132 Ω
  • Follow your technical escalation process if the resistance is within the following specification: 108 - 132 Ω

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Parent Solution

7 - OEM terminating resistor Ω check for the J1939 data link

Solution: S00000907

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM terminating resistor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the pins for the OEM terminating resistor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM terminating resistor has been detected if the resistance is not within the following specification: 108 - 132 Ω

Linked Solutions

  • None

Repair

  • For a malfunctioning OEM terminating resistor, replace the OEM terminating resistor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Incorrect terminating resistance in the J1939 data link by a J1939 data linked component

Solution: S00001002

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Reconnect the OEM terminating resistor if previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the resistance is not within the following specification: 108 - 132 Ω

Linked Solutions

  • J1939 wire resistance check at the crossover connector for each component

Refer to S00001003

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

8.1 - J1939 wire resistance check at the crossover connector for each component

Solution: S00001003

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Reconnect the OEM terminating resistor if previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

Inspect the following components if applicable:

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector for each component while disconnecting them one at a time.
  • Disconnect the aftertreatment outlet NOx sensor
  • Disconnect the aftertreatment temperature sensor module
  • Disconnect the aftertreatment particulate sensor
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor
  • Disconnect the aftertreatment diesel exhaust fluid temperature sensor
  • Disconnect the aftertreatment diesel exhaust fluid quality sensor.
  • Disconnect the aftertreatment intermediate NH3 sensor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance was not within 108 Ω to 132 Ω and it becomes within the specification of 108 Ω to 132 Ω when the J1939 component was disconnected, then a malfunctioning J1939 component has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid tank level sensor.

Refer to OEM Service Manual

  • Replace the aftertreatment diesel exhaust fluid temperature sensor.

Refer to OEM Service Manual

  • Replace the aftertreatment diesel exhaust fluid quality sensor.

Refer to OEM Service Manual

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace aftertreatment DOC temperature sensor module.

Refer to Procedure 019-449

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

  • Replace aftertreatment intermediate NH3 sensor.

Refer to Procedure 019-479

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

9 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1896 | SPN: 2791 | FMI: 13
EGR Valve Controller - Out of Calibration

Troubleshooting Summary

  1. Leaks in the intake air system
  2. Charge air cooler system leak
  3. EGR valve is malfunctioning
  4. ECM calibration revision history check

1 - Leaks in the intake air system

Solution: S00008386

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.
  • Visually inspect the intake plumbing for possible air leaks.

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Charge air cooler system leak

Solution: S00008815

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the charge air cooler hoses for possible air leaks.
  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If a leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the charge air cooler.

Refer to Procedure 010-027

  • Repair or replace the charge air cooler hoses.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - EGR valve is malfunctioning

Solution: S00004051

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Keyswitch OFF 1 minute.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning EGR valve has been detected if a fault code from the following list is active or has more than one inactive count within the last 25 engine operating hours: 1896

Linked Solutions

  • None

Repair

If the EGR valve has been replaced within the last 90 days, follow your technical escalation process PRIOR to performing any of the repair actions listed below:

  • Clean or replace the EGR valve.

Refer to Procedure 011-022

  • Clean the EGR differential pressure ports.

Refer to Procedure 010-080

  • Perform the Snap Acceleration - Aftertreatment Connected Test.

Refer to Procedure 014-017

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1897 | SPN: 641 | FMI: 12
VGT Actuator Controller - Bad Intelligent Device or Component

Troubleshooting Summary

  1. Variable geometry turbocharger actuator is installed incorrectly
  2. ECM calibration revision history check
  3. Variable geometry turbocharger actuator is malfunctioning

1 - Variable geometry turbocharger actuator is installed incorrectly

Solution: S00003229

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If both fault codes 2449 and 2634 are active, then an incorrect installation of the variable geometry turbocharger actuator has been detected.

Linked Solutions

  • None

Repair

  • Remove the variable geometry turbocharger actuator and reinstall in the correct position.

Refer to Procedure 010-134

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Variable geometry turbocharger actuator is malfunctioning

Solution: S00000600

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning variable geometry turbocharger actuator has been detected.

Linked Solutions

  • None

Repair

  • Replace the variable geometry turbocharger actuator.

Refer to Procedure 010-134

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1898 | SPN: 641 | FMI: 13
VGT Actuator Controller - Out of Calibration

Troubleshooting Summary

  1. Check for primary fault codes

1 - Check for primary fault codes

Solution: S00000162

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Turbocharger: 1894, 2387, 2636
  • Voltage: 1938

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1921 | SPN: 3251 | FMI: 16
Aftertreatment 1 Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Restricted intake air filter
  3. Plugged EGR differential pressure sensor supply ports
  4. Aftertreatment DPF differential pressure sensor tubes plugged
  5. Aftertreatment DPF differential pressure sensor stuck in-range
  6. Aftertreatment temperature sensor stuck in-range
  7. Aftertreatment DPF partially obstructed or plugged
  8. Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test
  9. ECM calibration revision history check
  10. Stationary aftertreatment regeneration is needed

1 - Check for primary fault codes

Solution: S00001901

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment regeneration: 2777, 3375, 3376, 4213, 6416
  • Aftertreatment differential pressure: 1879, 1881, 1883, 1922
  • Aftertreatment DPF: 1981, 2754, 3133, 3134, 3135, 3316, 3317, 3318, 3319, 3321, 3322, 3396, 5383
  • Aftertreatment DOC: 3313, 3314, 3315
  • Fuel: 559, 1139, 1141, 1142, 1143, 1144, 1145, 4713
  • Engine misfire: 1654, 1655, 1656, 1657, 1658, 1659
  • EGR: 1228, 1896, 2272, 2349, 2353, 2357, 2359, 2962, 3136, 3137, 3138, 3342, 3382, 3383, 3389
  • EGR differential pressure: 1866, 2273, 2274
  • Turbocharger: 1894, 1898, 2198, 2387, 2449, 2634, 2635, 2636, 3616
  • Intake manifold: 125, 2973, 4616
  • Intake throttle: 175, 176, 177, 3539, 3541, 3542, 5879, 5881, 5882

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Restricted intake air filter

Solution: S00000025

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Specification

  • If the intake air filter is plugged, then a restricted intake air filter has been detected.

Linked Solutions

  • None

Repair

  • Replace the air filter.

Refer to OEM Service Manual

Refer to Procedure 010-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Plugged EGR differential pressure sensor supply ports

Solution: S00005073

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the EGR differential pressure sensor flow port cross-drillings for soot blockage.

Refer to Procedure 011-066

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Remove and clean the EGR mass measurement flow assembly.

Refer to Procedure 011-066

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment DPF differential pressure sensor tubes plugged

Solution: S00001183

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment DPF differential pressure sensor tubes for signs of damage, plugging, kinks, leakage or loose connections.

Refer to Procedure 011-047

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace DPF differential pressure sensor tubes.

Refer to Procedure 011-047

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment DPF differential pressure sensor stuck in-range

Solution: S00000793

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the aftertreatment DPF differential pressure sensor voltage.

Refer to Procedure 019-443

Specification

  • If the aftertreatment DPF differential pressure sensor voltage readings are not within specification, then a malfunctioning aftertreatment DPF differential pressure sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment temperature sensor stuck in-range

Solution: S00000338

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Start the engine.

Action

  • Run the engine at high idle for the following minutes: 10
  • Use the recommended Cummins® electronic service tool or equivalent.

Monitor the following parameters:

  • Aftertreatment diesel oxidation catalyst intake temperature
  • Aftertreatment diesel particulate filter intake temperature
  • Aftertreatment diesel particulate filter outlet temperature

Specification

  • A malfunctioning aftertreatment exhaust gas temperature sensor has been detected if each sensor is not within the following specification of the others: 24 C [43 F]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Aftertreatment DPF partially obstructed or plugged

Solution: S00004187

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • If the aftertreatment DPF has already been replaced during this repair, then proceed to the next solution.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Particulate Filter Automated Restriction Test.

Refer to Procedure 011-085

Specification

  • If the Aftertreatment Diesel Particulate Filter Automated Restriction Test exceeds the limits called out in procedure, then a plugged or restricted aftertreatment DPF has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF.

Refer to Procedure 011-041

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test

Solution: S00003823

Verification

Conditions

  • Reconnect previously disconnected components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test.

Refer to Procedure 014-027

  • Verify the recommended Cummins® electronic service tool or equivalent has a version that supports this test.

Refer to Procedure 014-027

Specification

  • If the Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test does not pass, then reset the search to Aftertreatment Diesel Particulate Filter Regeneration Analyzer Did Not Pass. Only select the solution title that matches the error messages in the recommend Cummins® electronic service tool or equivalent.
  • If the Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test will not start, then reset the search to Aftertreatment Diesel Particulate Filter Regeneration Analyzer Did Not Start.
  • If the Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test does not complete, then reset the search to Aftertreatment Diesel Particulate Filter Regeneration Analyzer Did Not Complete.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

9 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - Stationary aftertreatment regeneration is needed

Solution: S00001113

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the Aftertreatment Diesel Particulate Filter regeneration test.

Refer to Procedure 014-016

Specification

  • If the aftertreatment stationary regeneration does not complete, then reset the Search to stationary regeneration will not complete.
  • If the aftertreatment stationary regeneration does not activate, then reset the Search to stationary regeneration will not start.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1922 | SPN: 3251 | FMI: 0
Aftertreatment 1 Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Fault Code 1922 requires that ALL solutions be performed
  2. Check for primary fault codes
  3. Restricted intake air filter
  4. Plugged EGR differential pressure sensor supply ports
  5. Aftertreatment DPF differential pressure sensor tubes plugged
  6. Aftertreatment DPF differential pressure sensor stuck in-range
  7. Aftertreatment DPF is malfunctioning
  8. Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test
  9. ECM calibration revision history check

1 - Fault Code 1922 requires that ALL solutions be performed

Solution: S00000603

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • This solution is information only.
  • ALL solutions displayed for this fault code must be performed.
  • Continue to perform the verifications of ALL solution steps listed for this fault code regardless if a given solution is within specification or out of specification.

Specification

  • This solution is information only.

Linked Solutions

  • None

Repair

  • If a resolution is found in any solution for this fault code, continue performing ALL solutions listed for this fault code.

Validation

  • None
Next Solution

2 - Check for primary fault codes

Solution: S00000164

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment regeneration: 2777, 4213, 6416
  • Aftertreatment differential pressure: 1879, 1881, 1883
  • Aftertreatment DPF: 2754, 3133, 3134, 3135, 3316, 3317, 3318, 3319, 3321, 3322, 3396, 5383
  • Aftertreatment DOC: 3313, 3314, 3315
  • Fuel: 559, 1139, 1141, 1142, 1143, 1144, 1145, ,4713
  • Engine misfire: 1654, 1655, 1656, 1657, 1658, 1659
  • EGR: 1228, 1896, 2272, 2349, 2353, 2357, 2961, 2962, 3136, 3137, 3138, 3342, 3382, 3383, 3389
  • Turbocharger: 1898, 2198, 2387, 2449, 2634, 2635, 2636, 3616
  • Intake manifold: 125, 2973, 4616
  • Intake throttle: 175, 176, 177, 3539, 3541, 3542, 5879, 5881, 5882
  • EGR differential pressure: 1866, 2273, 2274

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

3 - Restricted intake air filter

Solution: S00000025

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Specification

  • If the intake air filter is plugged, then a restricted intake air filter has been detected.

Linked Solutions

  • None

Repair

  • Replace the air filter.

Refer to OEM Service Manual

Refer to Procedure 010-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Plugged EGR differential pressure sensor supply ports

Solution: S00005073

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the EGR differential pressure sensor flow port cross-drillings for soot blockage.

Refer to Procedure 011-066

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Remove and clean the EGR mass measurement flow assembly.

Refer to Procedure 011-066

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment DPF differential pressure sensor tubes plugged

Solution: S00001183

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment DPF differential pressure sensor tubes for signs of damage, plugging, kinks, leakage or loose connections.

Refer to Procedure 011-047

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace DPF differential pressure sensor tubes.

Refer to Procedure 011-047

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment DPF differential pressure sensor stuck in-range

Solution: S00000793

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the aftertreatment DPF differential pressure sensor voltage.

Refer to Procedure 019-443

Specification

  • If the aftertreatment DPF differential pressure sensor voltage readings are not within specification, then a malfunctioning aftertreatment DPF differential pressure sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Aftertreatment DPF is malfunctioning

Solution: S00004545

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • If the aftertreatment DPF has already been replaced during this repair, then proceed to the next solution.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive with more than one count within the last 25 engine operating hours and no other fault codes have been logged, then a plugged or restricted aftertreatment DPF has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF.

Refer to Procedure 011-041

Validation

  • None
Next Solution

8 - Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test

Solution: S00003823

Verification

Conditions

  • Reconnect previously disconnected components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test.

Refer to Procedure 014-027

  • Verify the recommended Cummins® electronic service tool or equivalent has a version that supports this test.

Refer to Procedure 014-027

Specification

  • If the Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test does not pass, then reset the search to Aftertreatment Diesel Particulate Filter Regeneration Analyzer Did Not Pass. Only select the solution title that matches the error messages in the recommend Cummins® electronic service tool or equivalent.
  • If the Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test will not start, then reset the search to Aftertreatment Diesel Particulate Filter Regeneration Analyzer Did Not Start.
  • If the Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test does not complete, then reset the search to Aftertreatment Diesel Particulate Filter Regeneration Analyzer Did Not Complete.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

9 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1923 | SPN: 3482 | FMI: 3
Aftertreatment Fuel Shutoff Valve Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Fuel shutoff valve has a short circuit
  2. Aftertreatment fuel shutoff valve short circuit to battery in the engine wiring harness
  3. Aftertreatment fuel shutoff valve circuit pin to pin short

1 - Fuel shutoff valve has a short circuit

Solution: S00003108

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel shutoff valve from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment fuel shutoff valve SIGNAL pin and the metal case of the aftertreatment fuel shutoff valve.
  • Measure the aftertreatment fuel shutoff valve resistance.

Specification

  • If the resistance is not within specification, then a malfunctioning aftertreatment fuel shutoff valve has been detected.

Linked Solutions

  • None

Repair

  • Replace the fuel shutoff valve.

Refer to Procedure 011-052

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment fuel shutoff valve short circuit to battery in the engine wiring harness

Solution: S00002226

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the aftertreatment fuel shutoff valve from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment fuel shutoff valve SIGNAL pin at the aftertreatement fuel shutoff valve connector of the engine wiring harness and battery SUPPLY pins of the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment fuel shutoff valve circuit pin to pin short

Solution: S00002737

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel shutoff valve from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment fuel shutoff valve SIGNAL pin at the aftertreatement fuel shutoff valve connector of the engine wiring harness and battery SUPPLY pins of the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1924 | SPN: 3482 | FMI: 4
Aftertreatment Fuel Shutoff Valve Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Fuel shutoff valve has a short circuit
  2. Aftertreatment fuel shutoff valve circuit pin to ground short
  3. Aftertreatment fuel shutoff valve open circuit check
  4. Aftertreatment fuel shutoff valve circuit pin to ground short
  5. Aftertreatment fuel shutoff valve circuit pin to pin short

1 - Fuel shutoff valve has a short circuit

Solution: S00003108

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel shutoff valve from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment fuel shutoff valve SIGNAL pin and the metal case of the aftertreatment fuel shutoff valve.
  • Measure the aftertreatment fuel shutoff valve resistance.

Specification

  • If the resistance is not within specification, then a malfunctioning aftertreatment fuel shutoff valve has been detected.

Linked Solutions

  • None

Repair

  • Replace the fuel shutoff valve.

Refer to Procedure 011-052

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment fuel shutoff valve circuit pin to ground short

Solution: S00002732

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel shutoff valve from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment fuel shutoff valve SIGNAL pin at the aftertreatement fuel shutoff valve and block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Replace aftertreatment fuel shutoff valve.

Refer to Procedure 011-052

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment fuel shutoff valve open circuit check

Solution: S00002739

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the aftertreatment fuel shutoff valve from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment fuel shutoff valve SIGNAL pin at the aftertreatment fuel shutoff valve engine wiring harness connector and the aftertreatment fuel shutoff valve SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the aftertreatment fuel shutoff valve RETURN pin at the aftertreatment fuel shutoff valve engine wiring harness connector and the aftertreatment fuel shutoff valve RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment fuel shutoff valve circuit pin to ground short

Solution: S00002740

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the aftertreatment fuel shutoff valve from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment purge air actuator SIGNAL pin at the aftertreatment purge air actuator engine wiring harness connector and block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment fuel shutoff valve circuit pin to pin short

Solution: S00002737

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel shutoff valve from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment fuel shutoff valve SIGNAL pin at the aftertreatement fuel shutoff valve connector of the engine wiring harness and battery SUPPLY pins of the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1925 | SPN: 3482 | FMI: 2
Aftertreatment Fuel Shutoff Valve - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment fuel pressure sensor stuck in-range
  3. Aftertreatment fuel injector flow test
  4. Stuck open or leaking aftertreatment fuel shutoff valve
  5. Aftertreatment purge air actuator is stuck open or leaking

1 - Check for primary fault codes

Solution: S00000165

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment fuel: 1926, 1927, 1928
  • Fuel: 2215

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment fuel pressure sensor stuck in-range

Solution: S00000606

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel supply line from the aftertreatment fuel injector.
  • Disconnect the air supply line from the aftertreatment fuel shutoff manifold.
  • Connect the fuel extension line.
  • Place the end of the line in an empty fuel container.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the aftertreatment fuel pressure.

Specification

  • A malfunctioning aftertreatment fuel pressure sensor has been detected If the recommended Cummins® electronic service tool or equivalent reading are not within the following specification: 0 +/- 77 mm-Hg [3 in-hg], 0 +/- 10 kPa [1.5 psi]

Linked Solutions

  • None

Repair

  • Replace aftertreatment fuel pressure sensor.

Refer to Procedure 011-052

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment fuel injector flow test

Solution: S00002774

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the Aftertreatment Fuel Injector Flow Test.

Refer to Procedure 011-054

Specification

  • If the Aftertreatment Fuel Injector Flow Test does not meet specification, then a malfunctioning aftertreatment fuel injector has been detected.

Linked Solutions

  • None

Repair

  • Clean or replace the aftertreatment fuel injector.

Refer to Procedure 011-042

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Stuck open or leaking aftertreatment fuel shutoff valve

Solution: S00003052

Verification

Conditions

  • Disconnect the aftertreatment fuel supply line from the aftertreatment fuel injector.
  • Connect the fuel extension line.
  • Turn keyswitch ON.
  • Engine running at idle.

Action

  • Check for a stuck open or leaking aftertreatment fuel shutoff valve.
  • Check for a leaking aftertreatment fuel injector supply line extension.

Specification

  • If fuel is leaking from the aftertreatment fuel shutoff valve or aftertreatment fuel injector supply line extension, then a malfunctioning aftertreatment fuel shutoff valve has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment fuel shutoff valve.

Refer to Procedure 011-052

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment purge air actuator is stuck open or leaking

Solution: S00000610

Verification

Conditions

  • Disconnect the aftertreatment fuel supply line from the aftertreatment fuel injector.
  • Connect the fuel extension line.
  • Place the end of the line in an empty fuel container.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Engine running at idle.

Action

  • Check for a stuck open or leaking aftertreatment purge air actuator.
  • Check for air flowing from the supply line.

Specification

  • If any air is flowing from the supply line, then a malfunctioning aftertreatment purge air actuator has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment purge air actuator.

Refer to Procedure 011-065

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1926 | SPN: 3480 | FMI: 2
Aftertreatment Fuel Pressure Sensor - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Fuel filter restriction

1 - Check for primary fault codes

Solution: S00000166

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment fuel: 1927, 1928
  • Fuel: 559, 2372

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Fuel filter restriction

Solution: S00000900

Verification

Conditions

  • Turn keyswitch ON.
  • Engine running.

Action

  • Perform the Fuel Filter Restriction Test.

Refer to Procedure 005-236

Specification

  • If the outlet pressure of the filter is within specification, then proceed to the next solution.
  • If pressure from the fuel pump gear pump is within specification and the differential pressure does not meet specification a plugged or blocked fuel filter has been detected.
  • If the pressure is not within specification at the fuel pressure filter inlet then a malfunction of the fuel pump gear pump has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace fuel filter.

Refer to Procedure 006-065

  • Replace the fuel pump gear pump.

Refer to Procedure 005-025

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1927 | SPN: 3480 | FMI: 3
Aftertreatment Fuel Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Aftertreatment fuel pressure sensor circuit response check at the ECM
  2. Aftertreatment fuel pressure sensor open circuit check

1 - Aftertreatment fuel pressure sensor circuit response check at the ECM

Solution: S00002978

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 1928
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 1928

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment fuel pressure sensor open circuit check

Solution: S00000613

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel pressure sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment fuel pressure sensor RETURN pin at the aftertreatment fuel pressure sensor wiring harness connector and the aftertreatment fuel pressure sensor RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1928 | SPN: 3480 | FMI: 4
Aftertreatment Fuel Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment fuel pressure sensor circuit response
  3. Aftertreatment fuel pressure sensor circuit response check at the ECM

1 - Check for primary fault codes

Solution: S00000062

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352
  • Sensor supply 2: 187

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment fuel pressure sensor circuit response

Solution: S00005391

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the aftertreatment fuel pressure sensor +5 volt SUPPLY pin and the aftertreatment fuel pressure sensor SIGNAL pin at the sensor connector of the engine wiring harness.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.

Specification

  • A malfunctioning aftertreatment fuel pressure sensor has been detected if the following fault code became active with the jumper wire in place: 1927

Linked Solutions

  • None

Repair

  • Replace aftertreatment fuel pressure sensor.

Refer to Procedure 019-444

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment fuel pressure sensor circuit response check at the ECM

Solution: S00002977

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the aftertreatment fuel pressure sensor SUPPLY pin and the aftertreatment fuel pressure sensor SIGNAL pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 1927
  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 1927

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1932 | SPN: 3556 | FMI: 2
Aftertreatment Doser - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment fuel system leak check
  3. Aftertreatment fuel injector is malfunctioning
  4. Internally leaking aftertreatment fuel shutoff manifold
  5. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000169

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment fuel: 1923, 1924, 1926, 1927, 1928, 1977, 3223, 3224, 3225

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment fuel system leak check

Solution: S00002823

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the aftertreatment fuel injector.

Refer to Procedure 011-042

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Start the engine.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Fuel Injector Leak Test.
  • Visually inspect the aftertreatment fuel system for external fuel leaks.

Specification

  • If there are any leaks found in the aftertreatment fuel system, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean or replace the aftertreatment fuel injector.

Refer to Procedure 011-042

  • Replace aftertreatment fuel shutoff valve.

Refer to Procedure 011-045

  • Replace aftertreatment fuel drain valve.

Refer to Procedure 011-045

  • Replace the aftertreatment fuel supply line.

Refer to Procedure 011-051

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment fuel injector is malfunctioning

Solution: S00003286

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the aftertreatment fuel injector.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Fuel Injector Leak Test.

Refer to Procedure 011-054

Specification

  • If the Aftertreatment Fuel Injector Leak Test does not meet specification, then a malfunctioning aftertreatment fuel injector has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment fuel injector.

Refer to Procedure 011-042

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Internally leaking aftertreatment fuel shutoff manifold

Solution: S00000634

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disconnect the air supply line from the aftertreatment fuel shutoff manifold.
  • Engine running at idle.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Fuel Injector Leak Test.

Specification

  • If fuel is leaking from the aftertreatment fuel shutoff manifold, then a malfunctioning aftertreatment fuel shutoff manifold has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment fuel manifold.

Refer to Procedure 011-052

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1938 | SPN: 3597 | FMI: 18
ECU Power Output Supply Voltage 1 - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Intermittent ground connection
  3. Low battery voltage
  4. J1939 data link engine wiring harness voltage check 3 pin service connector
  5. OEM sensor voltage check
  6. J1939 data link harness pin to ground short circuit
  7. OEM wiring harness pin to pin short circuit
  8. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000170

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Voltage: 441, 442, 596, 597, 598

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Intermittent ground connection

Solution: S00000690

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect all of the engine block, starter, alternator, chassis, and battery ground connections.

Refer to OEM Service Manual

  • Verify all of the grounds are present and properly grounded.
  • Inspect all connections for corrosion or loose connections.

Refer to OEM Service Manual

  • Visually inspect the batteries and the battery cable connections for corrosion.

Specification

  • All grounds must be present, properly grounded, free of corrosion, and tight.

Linked Solutions

  • None

Repair

  • Repair or replace damaged connections.

Refer to Procedure 019-008

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Low battery voltage

Solution: S00000536

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the battery voltage.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal while trying to start the engine.
  • Visually inspect the batteries and the battery cable connections for corrosion.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.

Linked Solutions

  • None

Repair

  • Charge or replace the batteries.

Refer to OEM Service Manual

  • Clean corrosion or tighten battery cable connections.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - J1939 data link engine wiring harness voltage check 3 pin service connector

Solution: S00000594

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect all SAE J1939 components.
  • Turn keyswitch ON.

Action

The service tool datalink adapter can NOT be connected to the 3-pin J1939 datalink connector during this check.

  • Measure the J1939 voltage of the J1939 (+) pin to ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

  • Measure the J1939 voltage of the J1939 (-) pin to ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

Specification

  • A malfunctioning wiring harness has been detected due to the J1939 data link circuit being shorted to a voltage source if the voltage is greater than the following specification: 4.5 VDC
  • Proceed to the Linked Solutions section if the voltage is less than the following specification: 1 VDC
  • Proceed to the next solution if the voltage is within the following specification for both the SAE J1939 data link (+) and SAE J1939 data link (-) circuit: 1 - 4.5 VDC

Linked Solutions

  • OEM J1939 data link component isolation

Refer to S00003176

  • Engine or OEM wiring harness shorted to ground

Refer to S00003331

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4.1 - OEM sensor voltage check

Solution: S00003176

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Reconnect the crossover connector.

Inspect the following components if applicable:

  • Turn keyswitch ON.
  • Measure the J1939 voltage of the SAE J1939 data link (+) and SAE data link J1939 (-) pins at the variable geometry turbocharger actuator engine wiring harness connector to battery ground while each component is disconnected one at a time.
  • Disconnect the aftertreatment outlet NOx sensor
  • Disconnect the aftertreatment DPF temperature sensor module.
  • Disconnect the aftertreatment SCR temperature sensor module.
  • Disconnect the aftertreatment intermediate NH3 sensor.
  • Disconnect the aftertreatment particulate sensor
  • Disconnect the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.
  • Disconnect the aftertreatment exhaust gas temperature sensor.
  • Disconnect the aftertreatment intake NOx sensor.

Specification

  • A malfunctioning SAE J1939 data link component has been detected if the voltage is within the following specification after the component has been disconnected: 1 - 4.5 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.

Refer to OEM Service Manual

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

  • Replace aftertreatment DPF temperature sensor module.

Refer to Procedure 019-449

  • Replace the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-449

  • Replace aftertreatment intermediate NH3 sensor.

Refer to Procedure 019-479

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.2 - J1939 data link harness pin to ground short circuit

Solution: S00003331

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Turn keyswitch ON.

Action

The service tool datalink adapter can NOT be connected to the 3-pin J1939 datalink connector during this check.

  • Measure the J1939 voltage of the J1939 (+) pin to battery ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

  • Measure the J1939 voltage of the J1939 (-) pin to battery ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

Specification

  • A malfunctioning OEM wiring harness has been detected if voltage is within the following specification with the crossover connector disconnected: 1 - 4.5 VDC
  • A malfunctioning engine wiring harness has been detected if voltage is not within the following specification with the crossover connector disconnected: 1 - 4.5 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - OEM wiring harness pin to pin short circuit

Solution: S00003134

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power supply wiring harness connector from the ECM.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from one of the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to all pins in the that connector.
  • Measure the resistance from the second ECM battery SUPPLY (+) pin in the OEM power harness ECM connector to all pins in the that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace OEM power supply wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1942 | SPN: 101 | FMI: 2
Crankcase Pressure - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Visual inspection of crankcase breather components
  3. Crankcase pressure sensor stuck in-range
  4. Crankcase breather restriction check
  5. Crankcase pressure sensor or breather element check
  6. ECM calibration revision history check
  7. Crankcase pressure sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000171

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Crankcase pressure: 1843, 1844

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Visual inspection of crankcase breather components

Solution: S00001004

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the oil fill cap for proper installation.
  • Inspect the crankcase breather hose between the engine and the crankcase breather assembly for proper installation.
  • Visually inspect the crankcase breather hose for damage.

Specification

  • If the crankcase breather hose is incorrectly installed or damaged, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • For an incorrectly installed crankcase breather hose, reinstall the crankcase breather hose correctly.
  • For a damaged crankcase breather hose, replace the crankcase breather hose.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Crankcase pressure sensor stuck in-range

Solution: S00000623

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the crankcase pressure sensor.

Specification

  • A malfunctioning crankcase pressure sensor has been detected if the crankcase pressure sensor is not within the following specification: 0 ± 0.28 kPa - G [0 ± 1.2 in H2O]

Linked Solutions

  • None

Repair

  • Replace crankcase pressure sensor.

Refer to Procedure 019-445

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Crankcase breather restriction check

Solution: S00000635

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the crankcase pressure with keyswitch ON and engine OFF.
  • Run engine at high idle.
  • Monitor the crankcase pressure at high idle.
  • Subtract the (key ON engine OFF) measured value from the (Engine running at high idle) measured value.

Specification

  • If the measured value for engine running at high idle minus the measured value for key ON engine OFF is less than <0.7 in H₂O, then proceed to the next solution.
  • If the measured value for engine running at high idle minus the measured value for key ON engine OFF is greater than >0.7 in H₂O, then proceed to the Linked Solutions section.

Linked Solutions

Click on the link below:

  • Crankcase pressure sensor or breather element check

Refer to S00000636

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Crankcase pressure sensor or breather element check

Solution: S00000636

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check that the crankcase breather element is correctly installed.
  • Check that the crankcase breather inlet hose for restriction or other damage.

Specification

  • If the crankcase breather element is correctly installed and the crankcase breather inlet hose (if equipped) is free of restriction or damage, then proceed to the next solution.
  • If the crankcase breather element is incorrectly installed or the crankcase breather inlet hose is restricted or damaged, then a malfunction of the crankcase breather element or restricted crankcase breather inlet hose has been detected.

Linked Solutions

  • None

Repair

  • For an incorrectly installed crankcase breather element, reinstall the crankcase breather element correctly.

Refer to Procedure 003-019

Refer to Procedure 003-001

  • For a damaged crankcase breather hose, replace the crankcase breather hose.

Refer to Procedure 003-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Crankcase pressure sensor is malfunctioning

Solution: S00006414

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace crankcase pressure sensor.

Refer to Procedure 019-445

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1943 | SPN: 3555 | FMI: 17
Ambient Air Density - Data Valid But Below Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Barometric air pressure sensor stuck in-range
  3. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000172

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Barometric pressure: 221
  • Ambient air temperature: 249

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Barometric air pressure sensor stuck in-range

Solution: S00000340

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the barometric air pressure sensor
  • Compare to the local ambient air pressure.

Refer to Procedure 019-004

Specification

  • A malfunctioning barometric air pressure sensor has been detected if the barometric air pressure sensor is not within the following specification of local ambient air pressure: 51 mm HG [2 in HG]

Linked Solutions

  • None

Repair

  • Replace barometric air pressure sensor.

Refer to Procedure 019-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1961 | SPN: 2791 | FMI: 15
EGR Valve Control Circuit Over Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. EGR actuator internal temperature exceeded the maximum limit
  2. ECM calibration revision history check

1 - EGR actuator internal temperature exceeded the maximum limit

Solution: S00001011

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If Fault Code 1961 is active or has more than 1 inactive count within the last 25 engine operating hours, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • The EGR actuator internal temperature has exceeded the maximum limit.
  • No repair is necessary.
  • This fault code is for information only.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1962 | SPN: 641 | FMI: 15
VGT Actuator Driver Over Temperature (Calculated) - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Blocked or restricted variable geometry turbocharger actuator coolant lines

1 - Check for primary fault codes

Solution: S00000173

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Engine coolant temperature: 146, 151, 2963

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Blocked or restricted variable geometry turbocharger actuator coolant lines

Solution: S00000638

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the variable geometry turbocharger actuator coolant lines for damage, kinks and blockages.
  • Blow shop air reverse through the variable geometry turbocharger actuator cooling plate and associated cooling lines to check blockages.
  • Visually inspect for exhaust leaks around the variable geometry turbocharger actuator.

Specification

  • If damage, kinks or blockages are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the variable geometry turbocharger actuator coolant lines.

Refer to Procedure 010-041

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1963 | SPN: 3482 | FMI: 7
Aftertreatment Fuel Shutoff Valve - Mechanical System Not Responding or Out of Adjustment

Troubleshooting Summary

  1. Check for primary fault codes
  2. Low pressure fuel system component is malfunctioning
  3. Air in fuel check
  4. Fuel Inlet Restriction check
  5. Fuel lift pump check
  6. OEM fuel system component check
  7. Aftertreatment fuel shutoff manifold is malfunctioning
  8. Fuel filter restriction

1 - Check for primary fault codes

Solution: S00000174

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment fuel: 1923, 1924, 1925, 1926, 1927, 1928
  • Fuel: 559, 2372

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Low pressure fuel system component is malfunctioning

Solution: S00000640

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Verify the fuel system is primed.

Refer to Procedure 005-234

  • Measure the fuel pump gear pump outlet pressure at idle and at high idle.

Refer to Procedure 005-236

  • If engine will not start, then perform the check during cranking.

Specification

  • If the fuel pump gear pump outlet pressure is not within specification, then proceed to Linked Solutions section.

Linked Solutions

  • Air in fuel check

Refer to S00001205

  • Fuel Inlet Restriction check

Refer to S00001206

  • Fuel lift pump check

Refer to S00001207

  • OEM fuel system component check

Refer to S00000756

  • If the above checks are all within specification, then a malfunctioning fuel gear pump has been detected

Repair

  • Replace the fuel pump gear pump.

Refer to Procedure 005-025

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Air in fuel check

Solution: S00001205

Verification

Conditions

  • Turn keyswitch ON.
  • Verify adequate fuel level in the tank

Action

  • Allow the engine to reach operating temperature.
  • If engine will not start, then perform the check during cranking.
  • Inspect for air being ingested into the fuel.

Refer to Procedure 006-003

Specification

  • If air is present in the fuel flow, then a damaged fuel supply line, loose or damaged fuel filter, or a loose connection has been detected.

Linked Solutions

  • None

Repair

  • Tighten the loose fitting or replace the damaged component that allows air to enter the fuel system.

Refer to Procedure 006-003

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Fuel Inlet Restriction check

Solution: S00001206

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Measure the fuel inlet restriction.

Refer to Procedure 006-020

Specification

  • If the engine will not start, then proceed to the next solution.

If the inlet restriction is excessive, look for the root cause:

Inspect the following components if applicable:

  • Suction side fuel filters plugged.
  • Fuel heater restricted.

Refer to OEM Service Manual

  • OEM fuel lines restricted.

Refer to OEM Service Manual

  • ECM cooling plate plugged.

Refer to Procedure 006-006

  • ECM cooling plate check valve restricted.

Refer to Procedure 006-006

  • Fuel tank stand pipes restricted.

Refer to OEM Service Manual

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace fuel filter.

Refer to OEM Service Manual

  • Repair or replace the fuel heater.

Refer to OEM Service Manual

  • Repair or replace the OEM fuel lines.

Refer to OEM Service Manual

  • Repair or replace the ECM cooling plate.

Refer to Procedure 006-006

  • Repair or replace the ECM cooling plate check valve.

Refer to Procedure 006-006

  • Repair or replace the fuel tank stand pipe.

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.3 - Fuel lift pump check

Solution: S00001207

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Listen for fuel lift pump operation.
  • If the fuel lift pump does not operate after turning the keyswitch ON, then measure the resistance in the fuel lift pump circuit.

Refer to Procedure 019-397

  • Measure the lift pump pressure.

Refer to Procedure 005-236

Specification

  • If the resistance is not within specification, then proceed to the Repair section.
  • If the fuel lift pump pressure is not within specification, then a malfunctioning fuel lift pump has been detected.

Refer to Procedure 005-236

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the electric fuel lift pump.

Refer to Procedure 005-045

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.4 - OEM fuel system component check

Solution: S00000756

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually check fuel tank for adequate fuel supply.

Refer to Procedure 006-024

  • Visually inspect the engine fuel supply lines for signs of kinks, damage or fuel leaks.

Refer to Procedure 006-024

  • Visually inspect all fuel system gasket locations for signs of leakage.

Refer to Procedure 006-024

Specification

  • If there is any damage or leaks found in the OEM fuel system, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning OEM component.

Refer to OEM Service Manual

Validation

  • None
Parent Solution

3 - Aftertreatment fuel shutoff manifold is malfunctioning

Solution: S00003042

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disconnect the aftertreatment fuel supply line from the aftertreatment fuel injector.

Refer to Procedure 011-042

  • Connect the fuel extension line.

Action

  • Run the engine at idle.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Fuel Injector Leak Test.

Refer to Procedure 011-054

Specification

  • If fuel does not flow continuously from the line during the 60 second aftertreatment fuel injector flow test, then a malfunctioning aftertreatment fuel shutoff valve has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment fuel shutoff valve.

Refer to Procedure 011-052

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel filter restriction

Solution: S00000900

Verification

Conditions

  • Turn keyswitch ON.
  • Engine running.

Action

  • Perform the Fuel Filter Restriction Test.

Refer to Procedure 005-236

Specification

  • If the outlet pressure of the filter is within specification, then proceed to the next solution.
  • If pressure from the fuel pump gear pump is within specification and the differential pressure does not meet specification a plugged or blocked fuel filter has been detected.
  • If the pressure is not within specification at the fuel pressure filter inlet then a malfunction of the fuel pump gear pump has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace fuel filter.

Refer to Procedure 006-065

  • Replace the fuel pump gear pump.

Refer to Procedure 005-025

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1974 | SPN: 101 | FMI: 15
Crankcase Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Lubricating oil level is incorrect
  2. Plugged external crankcase breather tube
  3. Crankcase pressure sensor stuck in-range
  4. Crankcase Blowby Check
  5. Plugged external crankcase breather tube
  6. Turbocharger leaking air into crankcase
  7. Air compressor leaking air into crankcase
  8. Worn or damaged power cylinder components
  9. ECM calibration revision history check

1 - Lubricating oil level is incorrect

Solution: S00003234

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Make sure the vehicle is on a level surface with the engine off.
  • Check that the lubricating oil level is correct.
  • Determine if the lubrication oil is contaminated with coolant or fuel.

Specification

  • If the oil level is high and coolant contamination has been detected, then reset the search to Coolant in the oil.
  • If the oil level is high and fuel contamination has been detected, then reset the search to Fuel in the oil.
  • If the oil level is high and no coolant or fuel contamination has been detected, then incorrect oil dipstick calibration has been detected.
  • If the oil level is normal, then proceed to the next solution.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Reset search for coolant in the lubricating oil.
  • Search for fuel in oil.
  • Calibrate the lubricating oil dipstick for the proper oil level.

Refer to Procedure 007-009

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Plugged external crankcase breather tube

Solution: S00000626

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the oil drain tubes, check valves, breather tubes, and oil separator for plugging.

Refer to Procedure 003-001

It is important to check for a frozen, plugged, or restricted crankcase breather tubes in extreme cold ambient temperatures. Ice can form in the crankcase breather tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Specification

  • If an obstruction is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the crankcase ventilation oil drain tubes, check valves, breather tube, or separator.

Refer to Procedure 003-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Crankcase pressure sensor stuck in-range

Solution: S00000623

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the crankcase pressure sensor.

Specification

  • A malfunctioning crankcase pressure sensor has been detected if the crankcase pressure sensor is not within the following specification: 0 ± 0.28 kPa - G [0 ± 1.2 in H2O]

Linked Solutions

  • None

Repair

  • Replace crankcase pressure sensor.

Refer to Procedure 019-445

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Crankcase Blowby Check

Solution: S00000621

Verification

Conditions

  • Turn keyswitch OFF.

Action

It is important to check for a frozen, plugged, or restricted crankcase breather tubes in extreme cold ambient temperatures. Ice can form in the crankcase breather tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

  • Check the crankcase breather element type.
  • If the element is not a maintenance free insert, then check the maintenance interval to determine if the maintenance interval has been exceeded.
  • Start the engine.
  • Perform the crankcase blowby measurement test.

Refer to Procedure 014-010

Specification

  • If the crankcase breather element exceeds the maintenance interval, then proceed to the Repair section.
  • If the blowby measurement is not within specification with the element bypassed, then proceed to the Linked Solutions section.

Linked Solutions

Click on the link below:

  • Plugged external crankcase breather tube

Refer to S00001375

  • Turbocharger leaking air into crankcase

Refer to S00001203

  • Air compressor leaking air into crankcase

Refer to S00001204

  • Worn or damaged power cylinder components

Refer to S00001381

Repair

  • Replace the crankcase breather element.

Refer to Procedure 003-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4.1 - Plugged external crankcase breather tube

Solution: S00001375

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the oil drain tubes, check valves, breather tubes, and oil separator for plugging.

Refer to Procedure 003-018

It is important to check for a frozen, plugged, or restricted crankcase breather tubes in extreme cold ambient temperatures. Ice can form in the crankcase breather tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Specification

  • If the crankcase breather element is incorrectly installed or the crankcase breather inlet hose is restricted or damaged, then a malfunction of the crankcase breather element or restricted crankcase breather inlet hose has been detected.

Linked Solutions

  • None

Repair

  • Clean or replace the crankcase ventilation oil drain tubes, check valves, breather tube, or separator.

Refer to Procedure 003-018

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.2 - Turbocharger leaking air into crankcase

Solution: S00001203

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the crankcase blowby measurement test with the turbocharger isolated.

Refer to Procedure 014-010

Specification

  • If the turbocharger blowby contribution is out of specification, then a malfunctioning turbocharger has been detected.

Linked Solutions

  • None

Repair

  • Replace the turbocharger.

Refer to Procedure 010-033

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.3 - Air compressor leaking air into crankcase

Solution: S00001204

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the crankcase blowby measurement test with the air compressor isolated.

Refer to Procedure 014-010

Specification

  • If the air compressor blowby contribution is out of specification, then a malfunctioning air compressor has been detected.

Linked Solutions

  • None

Repair

  • Replace the air compressor.

Refer to Procedure 012-014

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.4 - Worn or damaged power cylinder components

Solution: S00001381

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pistons.

Refer to Procedure 001-043

  • Inspect the piston rings.

Refer to Procedure 001-047

Refer to tsb150069

  • Inspect the cylinder liners.

Refer to Procedure 001-028

Refer to tsb140030

Specification

  • If damaged or worn power cylinder components are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the piston.

Refer to Procedure 001-043

  • Replace the piston ring.

Refer to Procedure 001-047

  • Repair or replace the cylinder liner.

Refer to Procedure 001-028

Validation

  • None
Parent Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1976 | SPN: 641 | FMI: 15
VGT Actuator Driver Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Low pressure fuel system component is malfunctioning
  3. Air in fuel check
  4. Fuel Inlet Restriction check
  5. Fuel lift pump check
  6. OEM fuel system component check
  7. Blocked or restricted variable geometry turbocharger actuator coolant lines
  8. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000176

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Engine coolant temperature: 146, 151, 2963

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Low pressure fuel system component is malfunctioning

Solution: S00000640

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Verify the fuel system is primed.

Refer to Procedure 005-234

  • Measure the fuel pump gear pump outlet pressure at idle and at high idle.

Refer to Procedure 005-236

  • If engine will not start, then perform the check during cranking.

Specification

  • If the fuel pump gear pump outlet pressure is not within specification, then proceed to Linked Solutions section.

Linked Solutions

  • Air in fuel check

Refer to S00001205

  • Fuel Inlet Restriction check

Refer to S00001206

  • Fuel lift pump check

Refer to S00001207

  • OEM fuel system component check

Refer to S00000756

  • If the above checks are all within specification, then a malfunctioning fuel gear pump has been detected

Repair

  • Replace the fuel pump gear pump.

Refer to Procedure 005-025

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Air in fuel check

Solution: S00001205

Verification

Conditions

  • Turn keyswitch ON.
  • Verify adequate fuel level in the tank

Action

  • Allow the engine to reach operating temperature.
  • If engine will not start, then perform the check during cranking.
  • Inspect for air being ingested into the fuel.

Refer to Procedure 006-003

Specification

  • If air is present in the fuel flow, then a damaged fuel supply line, loose or damaged fuel filter, or a loose connection has been detected.

Linked Solutions

  • None

Repair

  • Tighten the loose fitting or replace the damaged component that allows air to enter the fuel system.

Refer to Procedure 006-003

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Fuel Inlet Restriction check

Solution: S00001206

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Measure the fuel inlet restriction.

Refer to Procedure 006-020

Specification

  • If the engine will not start, then proceed to the next solution.

If the inlet restriction is excessive, look for the root cause:

Inspect the following components if applicable:

  • Suction side fuel filters plugged.
  • Fuel heater restricted.

Refer to OEM Service Manual

  • OEM fuel lines restricted.

Refer to OEM Service Manual

  • ECM cooling plate plugged.

Refer to Procedure 006-006

  • ECM cooling plate check valve restricted.

Refer to Procedure 006-006

  • Fuel tank stand pipes restricted.

Refer to OEM Service Manual

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace fuel filter.

Refer to OEM Service Manual

  • Repair or replace the fuel heater.

Refer to OEM Service Manual

  • Repair or replace the OEM fuel lines.

Refer to OEM Service Manual

  • Repair or replace the ECM cooling plate.

Refer to Procedure 006-006

  • Repair or replace the ECM cooling plate check valve.

Refer to Procedure 006-006

  • Repair or replace the fuel tank stand pipe.

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.3 - Fuel lift pump check

Solution: S00001207

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Listen for fuel lift pump operation.
  • If the fuel lift pump does not operate after turning the keyswitch ON, then measure the resistance in the fuel lift pump circuit.

Refer to Procedure 019-397

  • Measure the lift pump pressure.

Refer to Procedure 005-236

Specification

  • If the resistance is not within specification, then proceed to the Repair section.
  • If the fuel lift pump pressure is not within specification, then a malfunctioning fuel lift pump has been detected.

Refer to Procedure 005-236

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the electric fuel lift pump.

Refer to Procedure 005-045

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.4 - OEM fuel system component check

Solution: S00000756

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually check fuel tank for adequate fuel supply.

Refer to Procedure 006-024

  • Visually inspect the engine fuel supply lines for signs of kinks, damage or fuel leaks.

Refer to Procedure 006-024

  • Visually inspect all fuel system gasket locations for signs of leakage.

Refer to Procedure 006-024

Specification

  • If there is any damage or leaks found in the OEM fuel system, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning OEM component.

Refer to OEM Service Manual

Validation

  • None
Parent Solution

3 - Blocked or restricted variable geometry turbocharger actuator coolant lines

Solution: S00000638

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the variable geometry turbocharger actuator coolant lines for damage, kinks and blockages.
  • Blow shop air reverse through the variable geometry turbocharger actuator cooling plate and associated cooling lines to check blockages.
  • Visually inspect for exhaust leaks around the variable geometry turbocharger actuator.

Specification

  • If damage, kinks or blockages are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the variable geometry turbocharger actuator coolant lines.

Refer to Procedure 010-041

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1977 | SPN: 3556 | FMI: 5
Aftertreatment Doser Circuit - Current Below Normal or Open Circuit

Troubleshooting Summary

  1. Aftertreatment fuel injector resistance check
  2. Aftertreatment fuel injector is malfunctioning
  3. Aftertreatment fuel injector open circuit check
  4. Aftertreatment fuel injector circuit pin to ground short
  5. Aftertreatment fuel injector circuit pin to pin short

1 - Aftertreatment fuel injector resistance check

Solution: S00002869

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel injector from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment fuel injector SIGNAL pin and aftertreatment fuel injector RETURN at the aftertreatment fuel injector connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not between 0.5 and 2 Ω, then a malfunctioning aftertreatment fuel injector has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment fuel injector.

Refer to Procedure 011-042

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment fuel injector is malfunctioning

Solution: S00002936

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel injector from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment fuel injector SIGNAL pin and the metal case of the aftertreatment fuel injector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning aftertreatment fuel injector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Replace aftertreatment fuel injector.

Refer to Procedure 011-042

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment fuel injector open circuit check

Solution: S00003135

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment fuel injector from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment fuel injector SIGNAL pin at the aftertreatment fuel injector engine wiring harness connector and aftertreatment fuel injector SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the aftertreatment fuel injector RETURN pin at the aftertreatment fuel injector engine wiring harness connector and aftertreatment fuel injector RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-361

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment fuel injector circuit pin to ground short

Solution: S00003151

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the aftertreatment fuel injector from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment fuel injector SIGNAL pin at the engine wiring harness ECM connector and engine block ground.
  • Measure the resistance between the aftertreatment fuel injector RETURN pin at the engine wiring harness ECM connector and engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment fuel injector circuit pin to pin short

Solution: S00003149

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the aftertreatment fuel injector from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment fuel injector SIGNAL pin at the engine wiring harness ECM connector and all other pins in the connector.
  • Measure the resistance between the aftertreatment fuel injector RETURN pin at the engine wiring harness ECM connector and all other pins in the connector .
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 1981 | SPN: 3936 | FMI: 15
Aftertreatment 1 Diesel Particulate Filter System - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Fault Code 1981 requires that ALL solutions be performed
  2. Check for primary fault codes
  3. Restricted intake air filter
  4. Plugged EGR differential pressure sensor supply ports
  5. Aftertreatment DPF differential pressure sensor tubes plugged
  6. Aftertreatment DPF differential pressure sensor stuck in-range
  7. Aftertreatment temperature sensor stuck in-range
  8. Aftertreatment DPF partially obstructed or plugged
  9. Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test
  10. ECM calibration revision history check
  11. Stationary aftertreatment regeneration is needed

1 - Fault Code 1981 requires that ALL solutions be performed

Solution: S00000645

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • This solution is information only.
  • ALL solutions displayed for this fault code must be performed.
  • Continue to perform the verifications of ALL solution steps listed for this fault code regardless if a given solution is within specification or out of specification.

Specification

  • This solution is information only.

Linked Solutions

  • None

Repair

  • If a resolution is found in any solution for this fault code, continue performing ALL solutions listed for this fault code.

Validation

  • None
Next Solution

2 - Check for primary fault codes

Solution: S00001124

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment regeneration: 3375, 3376, 5383
  • Aftertreatment differential pressure: 1879, 1881, 1883
  • Aftertreatment DOC: 3313, 3314, 3315
  • Aftertreatment DPF: 3133, 3134, 3135, 3316, 3317, 3318, 3319, 3321, 3322

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

3 - Restricted intake air filter

Solution: S00000025

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Specification

  • If the intake air filter is plugged, then a restricted intake air filter has been detected.

Linked Solutions

  • None

Repair

  • Replace the air filter.

Refer to OEM Service Manual

Refer to Procedure 010-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Plugged EGR differential pressure sensor supply ports

Solution: S00005073

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the EGR differential pressure sensor flow port cross-drillings for soot blockage.

Refer to Procedure 011-066

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Remove and clean the EGR mass measurement flow assembly.

Refer to Procedure 011-066

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment DPF differential pressure sensor tubes plugged

Solution: S00001183

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment DPF differential pressure sensor tubes for signs of damage, plugging, kinks, leakage or loose connections.

Refer to Procedure 011-047

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace DPF differential pressure sensor tubes.

Refer to Procedure 011-047

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment DPF differential pressure sensor stuck in-range

Solution: S00000793

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the aftertreatment DPF differential pressure sensor voltage.

Refer to Procedure 019-443

Specification

  • If the aftertreatment DPF differential pressure sensor voltage readings are not within specification, then a malfunctioning aftertreatment DPF differential pressure sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Aftertreatment temperature sensor stuck in-range

Solution: S00000338

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Start the engine.

Action

  • Run the engine at high idle for the following minutes: 10
  • Use the recommended Cummins® electronic service tool or equivalent.

Monitor the following parameters:

  • Aftertreatment diesel oxidation catalyst intake temperature
  • Aftertreatment diesel particulate filter intake temperature
  • Aftertreatment diesel particulate filter outlet temperature

Specification

  • A malfunctioning aftertreatment exhaust gas temperature sensor has been detected if each sensor is not within the following specification of the others: 24 C [43 F]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Aftertreatment DPF partially obstructed or plugged

Solution: S00004187

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • If the aftertreatment DPF has already been replaced during this repair, then proceed to the next solution.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Particulate Filter Automated Restriction Test.

Refer to Procedure 011-085

Specification

  • If the Aftertreatment Diesel Particulate Filter Automated Restriction Test exceeds the limits called out in procedure, then a plugged or restricted aftertreatment DPF has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF.

Refer to Procedure 011-041

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test

Solution: S00003823

Verification

Conditions

  • Reconnect previously disconnected components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test.

Refer to Procedure 014-027

  • Verify the recommended Cummins® electronic service tool or equivalent has a version that supports this test.

Refer to Procedure 014-027

Specification

  • If the Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test does not pass, then reset the search to Aftertreatment Diesel Particulate Filter Regeneration Analyzer Did Not Pass. Only select the solution title that matches the error messages in the recommend Cummins® electronic service tool or equivalent.
  • If the Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test will not start, then reset the search to Aftertreatment Diesel Particulate Filter Regeneration Analyzer Did Not Start.
  • If the Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test does not complete, then reset the search to Aftertreatment Diesel Particulate Filter Regeneration Analyzer Did Not Complete.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

10 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

11 - Stationary aftertreatment regeneration is needed

Solution: S00001113

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the Aftertreatment Diesel Particulate Filter regeneration test.

Refer to Procedure 014-016

Specification

  • If the aftertreatment stationary regeneration does not complete, then reset the Search to stationary regeneration will not complete.
  • If the aftertreatment stationary regeneration does not activate, then reset the Search to stationary regeneration will not start.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2182 | SPN: 1072 | FMI: 3
Engine Brake Actuator Driver 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Engine brake solenoid valve resistance check
  2. Engine brake solenoid valve open circuit check
  3. Engine brake solenoid circuit pin to ground short
  4. Engine brake solenoid circuit pin to pin short

1 - Engine brake solenoid valve resistance check

Solution: S00000539

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover.
  • Disconnect the engine wiring harness from the engine brake connector.
  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the engine brake solenoid valve terminal pin to the body of the solenoid.

Refer to Procedure 020-012

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the engine brake solenoid valve is not within specification, then a malfunctioning engine brake solenoid valve has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine brake solenoid valve.

Refer to Procedure 020-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Engine brake solenoid valve open circuit check

Solution: S00000648

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Measure the resistance between the engine brake solenoid SIGNAL wire at the engine brake solenoid to the engine brake solenoid SIGNAL line at the ECM connector on solenoid being tested.
  • Measure the resistance between the engine brake solenoid RETURN line at the engine brake solenoid to the engine brake solenoid RETURN line at the ECM connector on solenoid being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the engine brake wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine brake solenoid circuit pin to ground short

Solution: S00000723

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate engine brake solenoid from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid SIGNAL pin in the engine wiring harness ECM connector and ground for the solenoid being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness, internal actuator wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the internal actuator wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Engine brake solenoid circuit pin to pin short

Solution: S00001027

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2183 | SPN: 1072 | FMI: 4
Engine Brake Actuator Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Engine brake solenoid valve resistance check
  2. Engine brake solenoid valve open circuit check
  3. Engine brake solenoid circuit pin to ground short
  4. Engine brake solenoid circuit pin to pin short

1 - Engine brake solenoid valve resistance check

Solution: S00000539

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover.
  • Disconnect the engine wiring harness from the engine brake connector.
  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the engine brake solenoid valve terminal pin to the body of the solenoid.

Refer to Procedure 020-012

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the engine brake solenoid valve is not within specification, then a malfunctioning engine brake solenoid valve has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine brake solenoid valve.

Refer to Procedure 020-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Engine brake solenoid valve open circuit check

Solution: S00000648

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Measure the resistance between the engine brake solenoid SIGNAL wire at the engine brake solenoid to the engine brake solenoid SIGNAL line at the ECM connector on solenoid being tested.
  • Measure the resistance between the engine brake solenoid RETURN line at the engine brake solenoid to the engine brake solenoid RETURN line at the ECM connector on solenoid being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the engine brake wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine brake solenoid circuit pin to ground short

Solution: S00000723

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate engine brake solenoid from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid SIGNAL pin in the engine wiring harness ECM connector and ground for the solenoid being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness, internal actuator wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the internal actuator wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Engine brake solenoid circuit pin to pin short

Solution: S00001027

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2185 | SPN: 3512 | FMI: 3
Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Sensor supply 4 circuit pin to pin short
  2. Sensor supply 4 voltage error due to ECM

1 - Sensor supply 4 circuit pin to pin short

Solution: S00000538

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SUPPLY pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Sensor supply 4 voltage error due to ECM

Solution: S00000488

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2186 | SPN: 3512 | FMI: 4
Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Accelerator pedal or lever position sensor circuit pin to ground short
  2. Sensor supply 4 circuit pin to pin short
  3. Sensor supply 4 voltage error due to ECM

1 - Accelerator pedal or lever position sensor circuit pin to ground short

Solution: S00000731

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the accelerator pedal or lever position sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal or lever position sensor +5 volt SUPPLY pin in the OEM wiring harness ECM connector and engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Sensor supply 4 circuit pin to pin short

Solution: S00000538

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SUPPLY pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Sensor supply 4 voltage error due to ECM

Solution: S00000488

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2191 | SPN: 102 | FMI: 31
Intake Manifold 1 Pressure Sensor - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. Intake manifold pressure sensor has carbon buildup
  3. Intake manifold pressure sensor stuck in-range

1 - Check for primary fault codes

Solution: S00000177

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold: 122, 123

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Intake manifold pressure sensor has carbon buildup

Solution: S00006329

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

  • Visually inspect the intake manifold pressure/temperature sensor tip for soot or carbon buildup.
  • Visually inspect the intake manifold pressure sensor for damage.
  • Visually inspect the intake manifold pressure sensor o-rings for damage.

Specification

  • If any carbon buildup is found, then proceed to the Repair section.
  • If nicks or cuts in or on the o-ring are identified, then a damaged intake manifold pressure/temperature sensor o-ring has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

  • Replace the intake manifold pressure/temperature sensor o-ring.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Intake manifold pressure sensor stuck in-range

Solution: S00002814

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the intake manifold pressure sensor.

Specification

  • A malfunctioning intake manifold air pressure sensor has been detected if the intake manifold air pressure is not reading within the following specification: 0 ± 6.8 Kpa [0 ± 1 psi], 0 ± 51 mm-Hg [0 ± 2 in- Hg]

Linked Solutions

  • None

Repair

  • Replace the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2198 | SPN: 641 | FMI: 11
VGT Actuator Driver Circuit - Root Cause Not Known

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Variable geometry turbocharger actuator is malfunctioning

1 - Check for primary fault codes

Solution: S00000178

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Turbocharger: 1894, 2636, 5177

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Variable geometry turbocharger actuator is malfunctioning

Solution: S00001062

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning variable geometry turbocharger actuator has been detected.

Linked Solutions

  • None

Repair

  • Replace the variable geometry turbocharger actuator.

Refer to Procedure 010-134

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2222 | SPN: 96 | FMI: 3
Fuel Level (Main Tank) Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Technical Service Bulletin is available
  3. Incorrect adjustable parameter setting
  4. Fuel level sensor voltage check
  5. Fuel level sensor open circuit check
  6. Fuel level sensor circuit response
  7. Fuel level sensor open circuit check
  8. Fuel level sensor wire has a pin to pin short

1 - Check for primary fault codes

Solution: S00000179

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1695, 1696

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Technical Service Bulletin is available

Solution: S00009676

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb130081

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Incorrect adjustable parameter setting

Solution: S00000887

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify the fuel tank level sensor parameter is correctly set.

Specification

  • If the adjustable parameter setting and application do not match, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Adjust the features and parameters to the correct settings.

Refer to Procedure 019-078

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel level sensor voltage check

Solution: S00001128

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the fuel level sensor SUPPLY pin to the fuel level sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Fuel level sensor open circuit check

Refer to S00000649

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Fuel level sensor open circuit check

Solution: S00000649

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the fuel level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel level sensor SUPPLY pin at the fuel level sensor connector of the OEM wiring harness and the fuel level sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the fuel level sensor RETURN pin at the fuel level sensor connector of the OEM wiring harness and the fuel level sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Fuel level sensor circuit response

Solution: S00000404

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the fuel level sensor SIGNAL pin and the fuel level sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning fuel level sensor has been detected if the following fault code became active with the jumper wire in place: 2223

Linked Solutions

  • None

Repair

  • Replace the fuel level sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Fuel level sensor open circuit check

Solution: S00000750

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel level sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel level sensor SIGNAL pin at the fuel level sensor wiring harness connector and the fuel level sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Fuel level sensor wire has a pin to pin short

Solution: S00000751

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the fuel level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel level sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins at ECM connector. (2 wire sensor)
  • Measure the resistance between the fuel level sensor SUPPLY pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector. (3 wire sensor)
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 17-Apr-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2223 | SPN: 96 | FMI: 4
Fuel Level (Main Tank) Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Fuel level sensor voltage check
  3. Fuel level sensor open circuit check
  4. Fuel level sensor circuit response
  5. Fuel level sensor open circuit check
  6. Fuel level sensor SIGNAL has a short-to-ground
  7. Fuel level sensor wire has a pin to pin short

1 - Check for primary fault codes

Solution: S00000180

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1695, 1696

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Fuel level sensor voltage check

Solution: S00001128

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the fuel level sensor SUPPLY pin to the fuel level sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Fuel level sensor open circuit check

Refer to S00000649

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Fuel level sensor open circuit check

Solution: S00000649

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the fuel level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel level sensor SUPPLY pin at the fuel level sensor connector of the OEM wiring harness and the fuel level sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the fuel level sensor RETURN pin at the fuel level sensor connector of the OEM wiring harness and the fuel level sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Fuel level sensor circuit response

Solution: S00000405

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning fuel level sensor has been detected if the following fault code became active with the sensor disconnected: 2222

Linked Solutions

  • None

Repair

  • Replace the fuel level sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel level sensor open circuit check

Solution: S00000750

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel level sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel level sensor SIGNAL pin at the fuel level sensor wiring harness connector and the fuel level sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Fuel level sensor SIGNAL has a short-to-ground

Solution: S00000752

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the fuel level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel level sensor SIGNAL pin at the OEM wiring harness ECM connector and engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification:

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Fuel level sensor wire has a pin to pin short

Solution: S00000751

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the fuel level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel level sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins at ECM connector. (2 wire sensor)
  • Measure the resistance between the fuel level sensor SUPPLY pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector. (3 wire sensor)
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 31-Jan-2021


NO TITLE

ISX15 CM2350 X101

Fault Code: 2265 | SPN: 1075 | FMI: 3
Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Electric fuel lift pump resistance check
  2. Electric fuel lift pump circuit response at the ECM
  3. Electric fuel lift pump open circuit check
  4. Electric fuel lift pump circuit pin to pin short

1 - Electric fuel lift pump resistance check

Solution: S00001649

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electric fuel lift pump from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the electric fuel lift pump.

Refer to Procedure 005-045

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the electric fuel lift pump resistance is not within specification, then a malfunctioning electric fuel lift pump has been detected.

Linked Solutions

  • None

Repair

  • Replace the electric fuel lift pump.

Refer to Procedure 005-045

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Electric fuel lift pump circuit response at the ECM

Solution: S00003050

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the fuel lift pump SUPPLY pin and the fuel lift pump RETURN pin at the ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 2266
  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 2266

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Electric fuel lift pump open circuit check

Solution: S00001054

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the electric fuel lift pump from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel lift pump SUPPLY pin at the fuel lift pump wiring harness connector and the fuel lift pump SUPPLY pin at the ECM connector.
  • Measure the resistance between the fuel lift pump RETURN pin at the fuel lift pump wiring harness connector and the fuel lift pump RETURN pin at the ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

4 - Electric fuel lift pump circuit pin to pin short

Solution: S00000321

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the electric fuel lift pump from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel lift pump SUPPLY pin in the engine wiring harness ECM connector and all other pins in the engine wiring harness ECM connector.

Pins 14 and 15 are tied together in the wiring harness. These pins do not have to meet the 100K Ω resistance specification.

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Troubleshoot the engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2266 | SPN: 1075 | FMI: 4
Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Electric fuel lift pump circuit response
  2. Electric fuel lift pump circuit response at the ECM
  3. Electric fuel lift pump open circuit check
  4. Electric fuel lift pump circuit pin to ground short
  5. Electric fuel lift pump circuit pin to pin short

1 - Electric fuel lift pump circuit response

Solution: S00002826

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electric fuel lift pump from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning fuel lift pump has been detected if the following fault code became active with the lift pump disconnected: 2265

Linked Solutions

  • None

Repair

  • Replace the electric fuel lift pump.

Refer to Procedure 005-045

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Electric fuel lift pump circuit response at the ECM

Solution: S00003049

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 2265
  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 2265

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Electric fuel lift pump open circuit check

Solution: S00001054

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the electric fuel lift pump from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel lift pump SUPPLY pin at the fuel lift pump wiring harness connector and the fuel lift pump SUPPLY pin at the ECM connector.
  • Measure the resistance between the fuel lift pump RETURN pin at the fuel lift pump wiring harness connector and the fuel lift pump RETURN pin at the ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

4 - Electric fuel lift pump circuit pin to ground short

Solution: S00001055

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the electric fuel lift pump from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel lift pump SUPPLY pin in the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

5 - Electric fuel lift pump circuit pin to pin short

Solution: S00000321

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the electric fuel lift pump from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel lift pump SUPPLY pin in the engine wiring harness ECM connector and all other pins in the engine wiring harness ECM connector.

Pins 14 and 15 are tied together in the wiring harness. These pins do not have to meet the 100K Ω resistance specification.

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Troubleshoot the engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2272 | SPN: 27 | FMI: 4
EGR Valve Position Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. EGR valve position sensor voltage check
  3. EGR valve position sensor voltage check at the ECM
  4. EGR valve position sensor open circuit check
  5. EGR valve position sensor circuit pin to ground short
  6. EGR valve position sensor circuit pin to pin short
  7. EGR valve is malfunctioning

1 - Check for primary fault codes

Solution: S00000183

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386
  • Sensor supply 2: 187, 227

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - EGR valve position sensor voltage check

Solution: S00000719

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the EGR valve SUPPLY pin and the EGR valve RETURN pin at the EGR valve connector of the engine wiring harness.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • EGR valve position sensor voltage check at the ECM

Refer to S00000720

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - EGR valve position sensor voltage check at the ECM

Solution: S00000720

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the EGR valve SUPPLY pin and the EGR valve RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - EGR valve position sensor open circuit check

Solution: S00000765

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the EGR valve position sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the EGR valve position sensor SIGNAL A pin at the EGR valve wiring harness connector and the EGR valve position sensor SIGNAL A pin at the engine wiring harness ECM connector.
  • Measure the resistance between the EGR valve position sensor SIGNAL B pin at the EGR valve wiring harness connector and the EGR valve position sensor SIGNAL B pin at the engine wiring harness ECM connector.
  • Measure the resistance between the EGR valve position sensor SIGNAL C pin at the EGR valve wiring harness connector and the EGR valve position sensor SIGNAL C pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - EGR valve position sensor circuit pin to ground short

Solution: S00001063

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve motor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the EGR valve position SIGNAL A pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the EGR valve position SIGNAL B pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the EGR valve position SIGNAL C pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - EGR valve position sensor circuit pin to pin short

Solution: S00000766

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the EGR valve from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the EGR valve position SIGNAL A pin at the engine wiring harness ECM connector and all other pins in the ECM connector.
  • Measure the resistance between the EGR valve position SIGNAL B pin at the engine wiring harness ECM connector and all other pins in the ECM connector.
  • Measure the resistance between the EGR valve position SIGNAL C pin at the engine wiring harness ECM connector and all other pins in the ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - EGR valve is malfunctioning

Solution: S00003101

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Reconnect the engine wiring harness connector from the ECM.
  • Reconnect the EGR valve motor to the engine wiring harness.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait for 60 seconds.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the EGR valve.

Refer to Procedure 011-022

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 15-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2273 | SPN: 411 | FMI: 3
Exhaust Gas Recirculation Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. EGR differential pressure sensor voltage supply check
  3. EGR differential pressure sensor voltage check at the ECM
  4. EGR differential pressure sensor circuit response
  5. EGR differential pressure sensor circuit response at the ECM
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000183

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386
  • Sensor supply 2: 187, 227

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - EGR differential pressure sensor voltage supply check

Solution: S00000767

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the EGR differential pressure sensor SUPPLY pin and the EGR differential pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • EGR differential pressure sensor voltage check at the ECM.

Refer to S00000768

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - EGR differential pressure sensor voltage check at the ECM

Solution: S00000768

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the EGR differential pressure sensor SUPPLY pin and the EGR differential pressure sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - EGR differential pressure sensor circuit response

Solution: S00000366

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning EGR differential pressure sensor has been detected if the following fault code became active with the sensor disconnected: 2274

Linked Solutions

  • None

Repair

  • Replace the EGR differential pressure sensor.

Refer to Procedure 019-370

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - EGR differential pressure sensor circuit response at the ECM

Solution: S00001239

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 2274
  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 2274

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2274 | SPN: 411 | FMI: 4
Exhaust Gas Recirculation Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. EGR differential pressure sensor voltage supply check
  3. EGR differential pressure sensor voltage check at the ECM
  4. EGR differential pressure sensor circuit response
  5. EGR differential pressure sensor circuit response at the ECM
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000183

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386
  • Sensor supply 2: 187, 227

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - EGR differential pressure sensor voltage supply check

Solution: S00000767

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the EGR differential pressure sensor SUPPLY pin and the EGR differential pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • EGR differential pressure sensor voltage check at the ECM.

Refer to S00000768

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - EGR differential pressure sensor voltage check at the ECM

Solution: S00000768

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the EGR differential pressure sensor SUPPLY pin and the EGR differential pressure sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - EGR differential pressure sensor circuit response

Solution: S00001121

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the EGR differential pressure sensor SUPPLY pin and the EGR differential pressure SIGNAL pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning EGR differential pressure sensor has been detected if the following fault code became active with the jumper wire in place: 2273

Linked Solutions

  • None

Repair

  • Replace the EGR differential pressure sensor.

Refer to Procedure 019-370

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - EGR differential pressure sensor circuit response at the ECM

Solution: S00000592

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the EGR differential pressure sensor SUPPLY pin and the EGR differential pressure sensor SIGNAL pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 2273
  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 2273

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2288 | SPN: 103 | FMI: 15
Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Turbocharger speed sensor is malfunctioning
  3. Turbocharger speed sensor resistance check
  4. Turbocharger speed sensor open circuit check
  5. Turbocharger speed sensor circuit pin to ground short
  6. Turbocharger speed sensor circuit pin to pin short
  7. ECM calibration revision history check
  8. Turbocharger speed sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00002018

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Turbocharger: 1894, 1897, 1898, 1962, 1976, 2198, 2387, 2449, 2634, 2635, 2636, 2973, 6432

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Turbocharger speed sensor is malfunctioning

Solution: S00002831

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the turbocharger speed sensor from the turbocharger housing.

Refer to Procedure 019-390

  • Visually inspect the turbocharger speed sensor tip for damage.

Refer to Procedure 019-390

Specification

  • If the turbocharger speed sensor tip is damaged, then a malfunctioning turbocharger speed sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace turbocharger speed sensor.

Refer to Procedure 019-390

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Turbocharger speed sensor resistance check

Solution: S00002828

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the turbocharger speed sensor SUPPLY pin and the turbocharger speed sensor RETURN pin at the sensor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Repair section if the resistance is not within the following specification: 600 - 1600 Ω

Linked Solutions

  • None

Repair

  • Replace turbocharger speed sensor.

Refer to Procedure 019-390

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Turbocharger speed sensor open circuit check

Solution: S00000653

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the turbocharger speed sensor SIGNAL pin at the turbocharger speed sensor wiring harness connector and the turbocharger speed sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the turbocharger speed sensor RETURN pin at the turbocharger speed sensor wiring harness connector and the turbocharger speed sensor RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Turbocharger speed sensor circuit pin to ground short

Solution: S00000673

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the turbocharger speed SIGNAL pin at the engine wiring harness ECM connector to engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Turbocharger speed sensor circuit pin to pin short

Solution: S00000652

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the turbocharger speed sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the turbocharger speed sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Turbocharger speed sensor is malfunctioning

Solution: S00000651

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace turbocharger speed sensor.

Refer to Procedure 019-390

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2311 | SPN: 633 | FMI: 31
Electronic Fuel Injection Control Valve Circuit - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. Fuel pump actuator resistance check
  3. Fuel pump actuator open circuit check
  4. Fuel pump actuator circuit pin to ground short
  5. ECM calibration revision history check
  6. Fuel pump actuator is malfunctioning

1 - Check for primary fault codes

Solution: S00000184

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 271, 272

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Fuel pump actuator resistance check

Solution: S00002009

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the fuel pump actuator resistance.

Refer to Procedure 019-117

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not within specification, then a malfunctioning fuel pump actuator has been detected.

Linked Solutions

  • None

Repair

  • Replace the fuel pump actuator.

Refer to Procedure 019-117

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Fuel pump actuator open circuit check

Solution: S00000771

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel pump actuator SIGNAL pin at the fuel pump actuator engine wiring harness connector and the fuel pump actuator SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the fuel pump actuator RETURN pin at the fuel pump actuator engine wiring harness connector and the fuel pump actuator RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel pump actuator circuit pin to ground short

Solution: S00000507

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel pump actuator SIGNAL pin of the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Fuel pump actuator is malfunctioning

Solution: S00002783

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning fuel pump actuator have been detected.

Linked Solutions

  • None

Repair

  • Replace the fuel pump actuator.

Refer to Procedure 019-117

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2321 | SPN: 190 | FMI: 2
Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Engine crankshaft speed/position sensor check
  3. Crankshaft position sensor open circuit check
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000185

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Crankshaft speed/position sensor: 689

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Engine crankshaft speed/position sensor check

Solution: S00000684

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the crankshaft position sensor.
  • Inspect the crankshaft position sensor for signs of damage, oil leak, and metal debris on the end of the sensor.
  • Verify the crankshaft position sensor is connected properly.
  • Use the ratchet drive side of the socket tool that was used to removed the sensor from the engine, place it flush on the sensor so that the edge of the socket is on the edge of the sensor.
  • Monitor the crankshaft engine speed sensor state using the recommended Cummins® electronic service tool or equivalent and monitor (Engine Speed Main Sensor State) to check if the sensor state transitions.
  • Slowly slide the socket in a perpendicular direction to the marked line on the sensor or in a perpendicular direction to the mounting bracket of the sensor.

Specification

  • If any damage is found to the sensor, then proceed to the Repair section.
  • If the crankshaft position sensor is not connected properly, then proceed to the Repair section.
  • If the crankshaft position sensor state does NOT transition from high to low or low to high, or the state does NOT show triggered, then a malfunctioning crankshaft engine position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine crankshaft speed/position sensor.

Refer to Procedure 019-365

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Crankshaft position sensor open circuit check

Solution: S00000676

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the crankshaft position sensor SIGNAL pin at the crankshaft position sensor engine wiring harness connector to the crankshaft position sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2322 | SPN: 723 | FMI: 2
Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Camshaft position sensor is damaged
  3. Camshaft position sensor voltage check
  4. Camshaft position sensor voltage check at the ECM
  5. Camshaft position sensor open circuit check
  6. Camshaft position sensor circuit pin to pin short
  7. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000186

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Camshaft speed/position sensor: 778

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Camshaft position sensor is damaged

Solution: S00001226

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the camshaft position sensor.

Refer to Procedure 019-363

  • Inspect the camshaft position sensor for signs of damage, oil leak, and metal debris on the end of the sensor.

Specification

  • If the camshaft position sensor shows any signs of damage, then a malfunctioning camshaft position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace camshaft position sensor.

Refer to Procedure 019-363

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Camshaft position sensor voltage check

Solution: S00000693

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the camshaft position sensor SUPPLY pin and the camshaft position sensor RETURN pin at the sensor connector of the engine wiring harness.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Camshaft position sensor voltage check at the ECM

Refer to S00000694

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Camshaft position sensor voltage check at the ECM

Solution: S00000694

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the camshaft position sensor SUPPLY pin and the camshaft position sensor RETURN pin at the ECM connector.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Camshaft position sensor open circuit check

Solution: S00000691

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the camshaft position sensor SIGNAL pin at the camshaft position sensor engine wiring harness connector to the camshaft position sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Camshaft position sensor circuit pin to pin short

Solution: S00000692

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the camshaft position sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the camshaft position sensor SIGNAL pin of the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2343 | SPN: 95 | FMI: 15
Fuel Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Engine will not start
  2. Low pressure fuel system component is malfunctioning
  3. Fuel Inlet Restriction check
  4. Air in fuel check
  5. Fuel filter differential and gear pump pressure check
  6. Fuel injector return flow check
  7. Fuel injector isolation test
  8. Fuel pressure relief valve return flow excessive
  9. Air in fuel check
  10. Damaged fuel supply lines

1 - Engine will not start

Solution: S00000629

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Attempt to start the engine.

Specification

  • If the engine starts, then proceed to the next Solution.
  • If the engine will not start, then reset the search to crank no start.

Linked Solutions

  • None

Repair

  • Reset the search to crank no start.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Low pressure fuel system component is malfunctioning

Solution: S00005122

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually check fuel tank for adequate fuel supply.

Refer to OEM Service Manual

  • Visually inspect the engine fuel supply lines for signs of kinks, damage or fuel leaks.

Refer to Procedure 006-024

Specification

  • If no damage or leaks are observed, then proceed to the Linked Solutions section.
  • If there is any damage or leaks found in the OEM fuel system, then proceed to the Repair section.

Linked Solutions

  • Fuel Inlet Restriction check

Refer to S00001206

  • Air in fuel check

Refer to S00001205

  • Fuel filter differential and gear pump pressure check

Refer to S00005034

Repair

  • Repair or replace the OEM fuel lines.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Fuel Inlet Restriction check

Solution: S00001206

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Measure the fuel inlet restriction.

Refer to Procedure 006-020

Specification

  • If the engine will not start, then proceed to the next solution.

If the inlet restriction is excessive, look for the root cause:

Inspect the following components if applicable:

  • Suction side fuel filters plugged.
  • Fuel heater restricted.

Refer to OEM Service Manual

  • OEM fuel lines restricted.

Refer to OEM Service Manual

  • ECM cooling plate plugged.

Refer to Procedure 006-006

  • ECM cooling plate check valve restricted.

Refer to Procedure 006-006

  • Fuel tank stand pipes restricted.

Refer to OEM Service Manual

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace fuel filter.

Refer to OEM Service Manual

  • Repair or replace the fuel heater.

Refer to OEM Service Manual

  • Repair or replace the OEM fuel lines.

Refer to OEM Service Manual

  • Repair or replace the ECM cooling plate.

Refer to Procedure 006-006

  • Repair or replace the ECM cooling plate check valve.

Refer to Procedure 006-006

  • Repair or replace the fuel tank stand pipe.

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Air in fuel check

Solution: S00001205

Verification

Conditions

  • Turn keyswitch ON.
  • Verify adequate fuel level in the tank

Action

  • Allow the engine to reach operating temperature.
  • If engine will not start, then perform the check during cranking.
  • Inspect for air being ingested into the fuel.

Refer to Procedure 006-003

Specification

  • If air is present in the fuel flow, then a damaged fuel supply line, loose or damaged fuel filter, or a loose connection has been detected.

Linked Solutions

  • None

Repair

  • Tighten the loose fitting or replace the damaged component that allows air to enter the fuel system.

Refer to Procedure 006-003

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.3 - Fuel filter differential and gear pump pressure check

Solution: S00005034

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Perform the Fuel Filter Restriction Test.

Refer to Procedure 005-236

Specification

  • If the pressure is not within specification at the fuel pressure filter inlet, then a malfunction of the fuel pump gear pump has been detected.
  • If pressure from the fuel pump gear pump is within specification and the differential pressure does not meet specification a plugged or blocked fuel filter has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace fuel filter.

Refer to Procedure 006-065

  • Replace the fuel pump gear pump.

Refer to Procedure 005-025

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Fuel injector return flow check

Solution: S00000631

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the High-Pressure Injector Return Flow Test.

Refer to Procedure 005-236

Specification

  • If the High-Pressure Injector Return Flow Test is out of specification, then tighten the fuel injector connector nuts and perform the High-Pressure Injector Return Flow Test again.
  • If the High-Pressure Injector Return Flow Test is still out of specification, then proceed to the Linked Solutions section.

Linked Solutions

  • Fuel injector isolation test

Refer to S00001280

Repair

  • Check the torque on the fuel connector retaining nuts and tighten if necessary.

Refer to Procedure 006-052

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3.1 - Fuel injector isolation test

Solution: S00001280

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the High-Pressure Injector Return Flow Isolation Test.

Refer to Procedure 005-236

Specification

  • If the Fuel Injector Return Flow Isolation Test identifies a fuel injector that does not meet specification, then a malfunctioning fuel injector has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Fuel pressure relief valve return flow excessive

Solution: S00000632

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the Fuel Pressure Relief Valve Return Flow Test.

Refer to Procedure 005-236

Specification

  • If the fuel rail return flow does not meet the specification at the fuel rail pressure relief valve, then a malfunctioning fuel rail relief valve has been detected.

Linked Solutions

  • None

Repair

  • Replace the fuel pressure relief valve.

Refer to Procedure 006-061

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Air in fuel check

Solution: S00004548

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify adequate fuel level in the tank.

Refer to OEM Service Manual

  • Inspect for air being ingested into the fuel.

Refer to Procedure 006-003

Specification

  • If air is present in the fuel flow, then a damaged fuel supply line, loose or damaged fuel filter, or a loose connection has been detected.

Linked Solutions

  • None

Repair

Repair or replace the following components if they are found out of specification:

  • Tighten the loose fitting or replace the damaged component that allows air to enter the fuel system.

Refer to Procedure 006-003

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Damaged fuel supply lines

Solution: S00003353

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the pump head fuel inlet banjo bolt.

Refer to Procedure 005-016

  • Inspect the filter inside the banjo bolt for debris.

Refer to Procedure 005-016

Specification

  • If debris is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the banjo bolt.

Refer to Procedure 005-016

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2346 | SPN: 2789 | FMI: 15
Turbocharger Turbine Intake Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Leaks in the intake air system
  2. Charge air cooler system leak
  3. ECM calibration revision history check

1 - Leaks in the intake air system

Solution: S00008386

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.
  • Visually inspect the intake plumbing for possible air leaks.

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Charge air cooler system leak

Solution: S00008815

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the charge air cooler hoses for possible air leaks.
  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If a leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the charge air cooler.

Refer to Procedure 010-027

  • Repair or replace the charge air cooler hoses.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2347 | SPN: 2629 | FMI: 15
Turbocharger Compressor Outlet Temperature (Calculated) - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Intake manifold pressure sensor has carbon buildup
  3. Intake manifold pressure sensor stuck in-range
  4. Barometric air pressure sensor stuck in-range
  5. Leaks in the intake air system
  6. Charge air cooler system leak

1 - Check for primary fault codes

Solution: S00000189

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Turbocharger: 595, 1898, 2277, 2355, 2387, 2449, 2634, 3616
  • Intake manifold: 123, 433, 2973
  • Barometric pressure: 295

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Intake manifold pressure sensor has carbon buildup

Solution: S00006329

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

  • Visually inspect the intake manifold pressure/temperature sensor tip for soot or carbon buildup.
  • Visually inspect the intake manifold pressure sensor for damage.
  • Visually inspect the intake manifold pressure sensor o-rings for damage.

Specification

  • If any carbon buildup is found, then proceed to the Repair section.
  • If nicks or cuts in or on the o-ring are identified, then a damaged intake manifold pressure/temperature sensor o-ring has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

  • Replace the intake manifold pressure/temperature sensor o-ring.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Intake manifold pressure sensor stuck in-range

Solution: S00002814

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the intake manifold pressure sensor.

Specification

  • A malfunctioning intake manifold air pressure sensor has been detected if the intake manifold air pressure is not reading within the following specification: 0 ± 6.8 Kpa [0 ± 1 psi], 0 ± 51 mm-Hg [0 ± 2 in- Hg]

Linked Solutions

  • None

Repair

  • Replace the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Barometric air pressure sensor stuck in-range

Solution: S00000340

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the barometric air pressure sensor
  • Compare to the local ambient air pressure.

Refer to Procedure 019-004

Specification

  • A malfunctioning barometric air pressure sensor has been detected if the barometric air pressure sensor is not within the following specification of local ambient air pressure: 51 mm HG [2 in HG]

Linked Solutions

  • None

Repair

  • Replace barometric air pressure sensor.

Refer to Procedure 019-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Leaks in the intake air system

Solution: S00008386

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.
  • Visually inspect the intake plumbing for possible air leaks.

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Charge air cooler system leak

Solution: S00008815

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the charge air cooler hoses for possible air leaks.
  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If a leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the charge air cooler.

Refer to Procedure 010-027

  • Repair or replace the charge air cooler hoses.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2349 | SPN: 2791 | FMI: 5
EGR Valve Control Circuit - Current Below Normal or Open Circuit

Troubleshooting Summary

  1. EGR valve motor resistance check
  2. EGR valve motor open circuit check
  3. EGR valve is malfunctioning

1 - EGR valve motor resistance check

Solution: S00000773

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve motor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the EGR valve motor wire A pin, to the EGR valve motor wire B pin in the EGR valve motor connector.
  • Measure the resistance between the EGR valve motor wire A pin, to the EGR valve motor wire C pin in the EGR valve motor connector.
  • Measure the resistance between the EGR valve motor wire C pin, to the EGR valve motor wire B pin in the EGR valve motor connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning EGR valve motor has been detected if the resistance is greater than the following specification: 5 Ω

Linked Solutions

  • None

Repair

  • Replace the EGR valve.

Refer to Procedure 011-022

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - EGR valve motor open circuit check

Solution: S00001075

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the EGR valve from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the EGR valve motor A SIGNAL pin at the EGR valve engine wiring harness connector and the EGR valve motor A SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the EGR valve motor B SIGNAL pin at the EGR valve engine wiring harness connector and the EGR valve motor B SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the EGR valve motor C SIGNAL pin at the EGR valve engine wiring harness connector and the EGR valve motor C SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the EGR valve motor RETURN pin at the EGR valve engine wiring harness connector and the EGR valve motor RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - EGR valve is malfunctioning

Solution: S00004389

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

If the EGR valve has been replaced within the last 90 days, follow your technical escalation process PRIOR to performing any of the repair actions listed below:

  • Replace the EGR valve.

Refer to Procedure 011-022

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 15-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2353 | SPN: 2791 | FMI: 6
EGR Valve Control Circuit - Current Above Normal or Grounded Circuit

Troubleshooting Summary

  1. EGR valve motor resistance check
  2. EGR valve position sensor open circuit check
  3. EGR valve motor circuit pin to ground short

1 - EGR valve motor resistance check

Solution: S00000773

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve motor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the EGR valve motor wire A pin, to the EGR valve motor wire B pin in the EGR valve motor connector.
  • Measure the resistance between the EGR valve motor wire A pin, to the EGR valve motor wire C pin in the EGR valve motor connector.
  • Measure the resistance between the EGR valve motor wire C pin, to the EGR valve motor wire B pin in the EGR valve motor connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning EGR valve motor has been detected if the resistance is greater than the following specification: 5 Ω

Linked Solutions

  • None

Repair

  • Replace the EGR valve.

Refer to Procedure 011-022

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - EGR valve position sensor open circuit check

Solution: S00001084

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the EGR valve position sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the EGR valve position sensor SIGNAL A pin at the EGR valve wiring harness connector and the EGR valve position sensor SIGNAL A pin at the engine wiring harness ECM connector.
  • Measure the resistance between the EGR valve position sensor SIGNAL B pin at the EGR valve wiring harness connector and the EGR valve position sensor SIGNAL B pin at the engine wiring harness ECM connector.
  • Measure the resistance between the EGR valve position sensor SIGNAL C pin at the EGR valve wiring harness connector and the EGR valve position sensor SIGNAL C pin at the engine wiring harness ECM connector.
  • Measure the resistance connector between the EGR valve RETURN pin at the EGR valve wiring harness connector and the EGR valve RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - EGR valve motor circuit pin to ground short

Solution: S00001181

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the EGR valve motor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the EGR valve motor SIGNAL A pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the EGR valve motor SIGNAL B pin at the engine wiring harness ECM connector and ground.
  • Measure the resistance between the EGR valve motor SIGNAL C pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 15-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2363 | SPN: 1073 | FMI: 4
Engine Brake Actuator Driver Output 2 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Engine brake solenoid valve resistance check
  2. Engine brake solenoid valve resistance check
  3. Engine brake solenoid circuit pin to ground short
  4. Engine brake solenoid 2 harness pin to ground short
  5. Engine brake solenoid circuit pin to pin short
  6. Engine wiring harness has a pin to pin short

1 - Engine brake solenoid valve resistance check

Solution: S00000539

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover.
  • Disconnect the engine wiring harness from the engine brake connector.
  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the engine brake solenoid valve terminal pin to the body of the solenoid.

Refer to Procedure 020-012

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the engine brake solenoid valve is not within specification, then a malfunctioning engine brake solenoid valve has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine brake solenoid valve.

Refer to Procedure 020-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Engine brake solenoid valve resistance check

Solution: S00001031

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.
  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid valve SIGNAL pin and engine brake solenoid RETURN at the engine brake solenoid valve.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the engine brake solenoid valve is not within specification, then a malfunctioning engine brake solenoid valve has been detected.

Refer to Procedure 020-012

Linked Solutions

  • None

Repair

  • Replace the engine brake solenoid valve.

Refer to Procedure 020-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine brake solenoid circuit pin to ground short

Solution: S00000723

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate engine brake solenoid from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid SIGNAL pin in the engine wiring harness ECM connector and ground for the solenoid being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness, internal actuator wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the internal actuator wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Engine brake solenoid 2 harness pin to ground short

Solution: S00001030

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake solenoid number 2 from the engine brake pass through connector.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid number 2 SIGNAL pin in the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness, internal actuator wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the internal actuator wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Engine brake solenoid circuit pin to pin short

Solution: S00001027

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Engine wiring harness has a pin to pin short

Solution: S00000774

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake solenoid number 2 from the engine brake pass through connector.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid number 2 SIGNAL pin in the engine wiring harness ECM connector and all other pins in the ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness, internal actuator wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the internal actuator wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2367 | SPN: 1073 | FMI: 3
Engine Brake Actuator Driver Output 2 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Engine brake solenoid valve resistance check
  2. Engine brake solenoid valve open circuit check
  3. Engine brake solenoid circuit pin to ground short
  4. Engine brake solenoid circuit pin to pin short
  5. Engine brake solenoid circuit pin to pin short

1 - Engine brake solenoid valve resistance check

Solution: S00001031

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.
  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid valve SIGNAL pin and engine brake solenoid RETURN at the engine brake solenoid valve.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the engine brake solenoid valve is not within specification, then a malfunctioning engine brake solenoid valve has been detected.

Refer to Procedure 020-012

Linked Solutions

  • None

Repair

  • Replace the engine brake solenoid valve.

Refer to Procedure 020-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Engine brake solenoid valve open circuit check

Solution: S00000648

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Measure the resistance between the engine brake solenoid SIGNAL wire at the engine brake solenoid to the engine brake solenoid SIGNAL line at the ECM connector on solenoid being tested.
  • Measure the resistance between the engine brake solenoid RETURN line at the engine brake solenoid to the engine brake solenoid RETURN line at the ECM connector on solenoid being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the engine brake wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine brake solenoid circuit pin to ground short

Solution: S00000723

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate engine brake solenoid from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid SIGNAL pin in the engine wiring harness ECM connector and ground for the solenoid being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness, internal actuator wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the internal actuator wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Engine brake solenoid circuit pin to pin short

Solution: S00001027

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Engine brake solenoid circuit pin to pin short

Solution: S00001028

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine wiring harness from the engine brake connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid number 1 SIGNAL pin in the engine wiring harness ECM connector and all other pins in the ECM connector.
  • Measure the resistance between the engine brake solenoid number 2 SIGNAL pin in the engine wiring harness ECM connector and all other pins in the ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2372 | SPN: 95 | FMI: 16
Fuel Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Engine will not start
  2. Low pressure fuel system component is malfunctioning
  3. Fuel Inlet Restriction check
  4. Air in fuel check
  5. Fuel filter differential and gear pump pressure check
  6. Fuel injector return flow check
  7. Fuel injector isolation test
  8. Fuel pressure relief valve return flow excessive
  9. Air in fuel check
  10. Damaged fuel supply lines

1 - Engine will not start

Solution: S00000629

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Attempt to start the engine.

Specification

  • If the engine starts, then proceed to the next Solution.
  • If the engine will not start, then reset the search to crank no start.

Linked Solutions

  • None

Repair

  • Reset the search to crank no start.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Low pressure fuel system component is malfunctioning

Solution: S00005122

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually check fuel tank for adequate fuel supply.

Refer to OEM Service Manual

  • Visually inspect the engine fuel supply lines for signs of kinks, damage or fuel leaks.

Refer to Procedure 006-024

Specification

  • If no damage or leaks are observed, then proceed to the Linked Solutions section.
  • If there is any damage or leaks found in the OEM fuel system, then proceed to the Repair section.

Linked Solutions

  • Fuel Inlet Restriction check

Refer to S00001206

  • Air in fuel check

Refer to S00001205

  • Fuel filter differential and gear pump pressure check

Refer to S00005034

Repair

  • Repair or replace the OEM fuel lines.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Fuel Inlet Restriction check

Solution: S00001206

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Measure the fuel inlet restriction.

Refer to Procedure 006-020

Specification

  • If the engine will not start, then proceed to the next solution.

If the inlet restriction is excessive, look for the root cause:

Inspect the following components if applicable:

  • Suction side fuel filters plugged.
  • Fuel heater restricted.

Refer to OEM Service Manual

  • OEM fuel lines restricted.

Refer to OEM Service Manual

  • ECM cooling plate plugged.

Refer to Procedure 006-006

  • ECM cooling plate check valve restricted.

Refer to Procedure 006-006

  • Fuel tank stand pipes restricted.

Refer to OEM Service Manual

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace fuel filter.

Refer to OEM Service Manual

  • Repair or replace the fuel heater.

Refer to OEM Service Manual

  • Repair or replace the OEM fuel lines.

Refer to OEM Service Manual

  • Repair or replace the ECM cooling plate.

Refer to Procedure 006-006

  • Repair or replace the ECM cooling plate check valve.

Refer to Procedure 006-006

  • Repair or replace the fuel tank stand pipe.

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Air in fuel check

Solution: S00001205

Verification

Conditions

  • Turn keyswitch ON.
  • Verify adequate fuel level in the tank

Action

  • Allow the engine to reach operating temperature.
  • If engine will not start, then perform the check during cranking.
  • Inspect for air being ingested into the fuel.

Refer to Procedure 006-003

Specification

  • If air is present in the fuel flow, then a damaged fuel supply line, loose or damaged fuel filter, or a loose connection has been detected.

Linked Solutions

  • None

Repair

  • Tighten the loose fitting or replace the damaged component that allows air to enter the fuel system.

Refer to Procedure 006-003

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.3 - Fuel filter differential and gear pump pressure check

Solution: S00005034

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Perform the Fuel Filter Restriction Test.

Refer to Procedure 005-236

Specification

  • If the pressure is not within specification at the fuel pressure filter inlet, then a malfunction of the fuel pump gear pump has been detected.
  • If pressure from the fuel pump gear pump is within specification and the differential pressure does not meet specification a plugged or blocked fuel filter has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace fuel filter.

Refer to Procedure 006-065

  • Replace the fuel pump gear pump.

Refer to Procedure 005-025

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Fuel injector return flow check

Solution: S00000631

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the High-Pressure Injector Return Flow Test.

Refer to Procedure 005-236

Specification

  • If the High-Pressure Injector Return Flow Test is out of specification, then tighten the fuel injector connector nuts and perform the High-Pressure Injector Return Flow Test again.
  • If the High-Pressure Injector Return Flow Test is still out of specification, then proceed to the Linked Solutions section.

Linked Solutions

  • Fuel injector isolation test

Refer to S00001280

Repair

  • Check the torque on the fuel connector retaining nuts and tighten if necessary.

Refer to Procedure 006-052

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3.1 - Fuel injector isolation test

Solution: S00001280

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the High-Pressure Injector Return Flow Isolation Test.

Refer to Procedure 005-236

Specification

  • If the Fuel Injector Return Flow Isolation Test identifies a fuel injector that does not meet specification, then a malfunctioning fuel injector has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Fuel pressure relief valve return flow excessive

Solution: S00000632

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the Fuel Pressure Relief Valve Return Flow Test.

Refer to Procedure 005-236

Specification

  • If the fuel rail return flow does not meet the specification at the fuel rail pressure relief valve, then a malfunctioning fuel rail relief valve has been detected.

Linked Solutions

  • None

Repair

  • Replace the fuel pressure relief valve.

Refer to Procedure 006-061

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Air in fuel check

Solution: S00004548

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify adequate fuel level in the tank.

Refer to OEM Service Manual

  • Inspect for air being ingested into the fuel.

Refer to Procedure 006-003

Specification

  • If air is present in the fuel flow, then a damaged fuel supply line, loose or damaged fuel filter, or a loose connection has been detected.

Linked Solutions

  • None

Repair

Repair or replace the following components if they are found out of specification:

  • Tighten the loose fitting or replace the damaged component that allows air to enter the fuel system.

Refer to Procedure 006-003

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Damaged fuel supply lines

Solution: S00003353

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the pump head fuel inlet banjo bolt.

Refer to Procedure 005-016

  • Inspect the filter inside the banjo bolt for debris.

Refer to Procedure 005-016

Specification

  • If debris is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the banjo bolt.

Refer to Procedure 005-016

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2373 | SPN: 1209 | FMI: 3
Exhaust Gas Bank 1 Pressure Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Exhaust gas pressure sensor voltage check
  3. Exhaust gas pressure sensor voltage check at the ECM
  4. Exhaust gas pressure sensor circuit response
  5. Plugged or damaged exhaust gas pressure sensor tube
  6. Exhaust gas pressure sensor circuit response at the ECM
  7. Exhaust gas pressure sensor circuit pin to pin short
  8. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001088

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386
  • Sensor supply 2: 187, 227

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Exhaust gas pressure sensor voltage check

Solution: S00000776

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the exhaust gas pressure sensor SUPPLY pin and the exhaust gas pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Exhaust gas pressure sensor voltage check at the ECM

Refer to S00000777

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Exhaust gas pressure sensor voltage check at the ECM

Solution: S00000777

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the exhaust gas pressure sensor SUPPLY pin and the exhaust gas pressure sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Exhaust gas pressure sensor circuit response

Solution: S00000399

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning exhaust gas pressure sensor has been detected if the following fault code became active with the sensor disconnected: 2374

Linked Solutions

  • None

Repair

  • Replace exhaust gas pressure sensor.

Refer to Procedure 019-376

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Plugged or damaged exhaust gas pressure sensor tube

Solution: S00000703

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

  • Inspect the exhaust gas pressure sensor tube for cracks and thread damage.

Refer to Procedure 011-027

  • Inspect the inside of the tube and sensor adapter for debris or soot buildup.

Refer to Procedure 011-027

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Exhaust gas pressure sensor circuit response at the ECM

Solution: S00001228

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 2374
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 2374

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Exhaust gas pressure sensor circuit pin to pin short

Solution: S00000775

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the exhaust gas pressure sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2374 | SPN: 1209 | FMI: 4
Exhaust Gas Bank 1 Pressure Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Exhaust gas pressure sensor voltage check
  3. Exhaust gas pressure sensor voltage check at the ECM
  4. Exhaust gas pressure sensor circuit response
  5. Exhaust gas pressure sensor circuit response at the ECM
  6. Exhaust gas pressure sensor circuit pin to pin short
  7. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001088

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386
  • Sensor supply 2: 187, 227

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Exhaust gas pressure sensor voltage check

Solution: S00000776

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the exhaust gas pressure sensor SUPPLY pin and the exhaust gas pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Exhaust gas pressure sensor voltage check at the ECM

Refer to S00000777

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Exhaust gas pressure sensor voltage check at the ECM

Solution: S00000777

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the exhaust gas pressure sensor SUPPLY pin and the exhaust gas pressure sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Exhaust gas pressure sensor circuit response

Solution: S00000400

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the exhaust gas pressure sensor SUPPLY pin and the exhaust gas pressure sensor SIGNAL pin at the sensor connector of the engine wiring harness.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning exhaust gas pressure sensor has been detected if the following fault code became active with the jumper wire in place: 2373

Linked Solutions

  • None

Repair

  • Replace exhaust gas pressure sensor.

Refer to Procedure 019-376

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Exhaust gas pressure sensor circuit response at the ECM

Solution: S00001126

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the exhaust gas pressure sensor SUPPLY pin and the exhaust gas pressure sensor SIGNAL pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 2373
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 2373

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • None
Next Solution

5 - Exhaust gas pressure sensor circuit pin to pin short

Solution: S00000775

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the exhaust gas pressure sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2375 | SPN: 412 | FMI: 3
Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. EGR temperature sensor circuit response
  2. EGR temperature sensor circuit response at the ECM
  3. ECM calibration revision history check

1 - EGR temperature sensor circuit response

Solution: S00000391

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the EGR temperature sensor SIGNAL pin and the EGR temperature sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning EGR temperature sensor has been detected if the following fault code became active with the jumper wire in place: 2376

Linked Solutions

  • None

Repair

  • Replace EGR temperature sensor.

Refer to Procedure 019-378

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - EGR temperature sensor circuit response at the ECM

Solution: S00000575

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the EGR temperature sensor SIGNAL pin and the EGR temperature sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 2376
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 2376

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2376 | SPN: 412 | FMI: 4
Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. EGR temperature sensor circuit response
  2. EGR temperature sensor circuit response at the ECM
  3. ECM calibration revision history check

1 - EGR temperature sensor circuit response

Solution: S00000769

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning EGR temperature sensor has been detected if the following fault code became active with the sensor disconnected: 2375

Linked Solutions

  • None

Repair

  • Replace EGR temperature sensor.

Refer to Procedure 019-378

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - EGR temperature sensor circuit response at the ECM

Solution: S00001089

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 2375
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 2375

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2377 | SPN: 647 | FMI: 3
Fan Control Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Fan control solenoid open circuit check
  2. Fan control solenoid circuit pin to pin short
  3. Fan control solenoid is malfunctioning

1 - Fan control solenoid open circuit check

Solution: S00001057

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the fan control connector from the OEM wiring harness connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM wiring harness engine control module fan control SIGNAL pin and the OEM wiring harness fan control connector SIGNAL pin.
  • Measure the resistance between the OEM wiring harness engine control module fan control RETURN pin and the OEM wiring harness fan control connector RETURN pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

2 - Fan control solenoid circuit pin to pin short

Solution: S00004897

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the fan control connector from the OEM wiring harness connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fan control SIGNAL pin of the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Fan control solenoid is malfunctioning

Solution: S00005653

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the fan control solenoid.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 15-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2387 | SPN: 641 | FMI: 7
VGT Actuator Driver Circuit (Motor) - Mechanical System Not Responding or Out of Adjustment

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test
  3. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000192

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • EGR: 1896, 2353, 2357, 2359, 2961, 2962
  • Turbocharger: 1894, 2636

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test

Solution: S00003823

Verification

Conditions

  • Reconnect previously disconnected components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test.

Refer to Procedure 014-027

  • Verify the recommended Cummins® electronic service tool or equivalent has a version that supports this test.

Refer to Procedure 014-027

Specification

  • If the Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test does not pass, then reset the search to Aftertreatment Diesel Particulate Filter Regeneration Analyzer Did Not Pass. Only select the solution title that matches the error messages in the recommend Cummins® electronic service tool or equivalent.
  • If the Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test will not start, then reset the search to Aftertreatment Diesel Particulate Filter Regeneration Analyzer Did Not Start.
  • If the Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test does not complete, then reset the search to Aftertreatment Diesel Particulate Filter Regeneration Analyzer Did Not Complete.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2398 | SPN: 171 | FMI: 2
Ambient Air Temperature - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Intake manifold temperature sensor stuck in-range
  3. OEM ambient air temperature sensor stuck in-range
  4. Ambient air temperature sensor open circuit check
  5. Ambient air temperature sensor circuit pin to pin short
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000195

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Ambient air temperature: 249, 256

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Intake manifold temperature sensor stuck in-range

Solution: S00000334

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the intake manifold temperature sensor reading to an infrared thermometer or a known value.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the known value must be within: +/- 10C [18F]

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - OEM ambient air temperature sensor stuck in-range

Solution: S00000339

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the OEM ambient air temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the temperature sensor is not within the following specification of local ambient air temperature: 5°F [2.8°C]

Linked Solutions

  • None

Repair

  • Replace the ambient air temperature sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Ambient air temperature sensor open circuit check

Solution: S00000833

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the ambient air temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM wiring harness ECM connector ambient air temperature sensor RETURN pin and OEM wiring harness ambient air temperature sensor connector RETURN pin
  • Measure the resistance between the OEM wiring harness ECM connector ambient air temperature sensor SIGNAL pin and OEM wiring harness ambient air temperature sensor connector SIGNAL pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Ambient air temperature sensor circuit pin to pin short

Solution: S00001091

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ambient air temperature sensor SIGNAL pin in the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2416 | SPN: 1634 | FMI: 13
Engine Control Module Calibration Memory Checksum - Out of Calibration

Troubleshooting Summary

  1. ECM calibration revision history check

1 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2448 | SPN: 111 | FMI: 17
Coolant Level - Data Valid But Below Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Check for primary fault codes
  3. Coolant level check
  4. Coolant level sensor open circuit check
  5. Coolant level sensor circuit pin to ground short
  6. Coolant level sensor circuit pin to pin short
  7. ECM calibration revision history check
  8. Coolant level sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00001388

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Engine coolant level: 197

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Check for primary fault codes

Solution: S00010587

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 operating hours from the following list:

  • Coolant level: 195, 196

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

3 - Coolant level check

Solution: S00003142

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the coolant level.
  • Perform the Coolant System Pressure Test.

Refer to Procedure 008-018

  • Visually inspect for external coolant leaks.

Specification

  • If the coolant level is low and there are signs of external coolant leaks, then reset the search to external coolant leak.
  • If the coolant level is low and there are no signs of external coolant leaks, then reset the search to internal coolant leak.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4 - Coolant level sensor open circuit check

Solution: S00007920

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Coolant level sensor circuit pin to ground short

Solution: S00007921

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Coolant level sensor circuit pin to pin short

Solution: S00007922

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor SUPPLY pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Coolant level sensor is malfunctioning

Solution: S00007923

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning coolant level sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace engine coolant level sensor.

Refer to Procedure 019-017

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2449 | SPN: 641 | FMI: 13
VGT Actuator Controller - Out of Calibration

Troubleshooting Summary

  1. Check for primary fault codes
  2. Incorrect variable geometry turbocharger actuator installation
  3. Variable geometry turbocharger actuator calibration incorrect
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000196

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Turbocharger: 1894, 2636
  • Voltage: 1938

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Incorrect variable geometry turbocharger actuator installation

Solution: S00009051

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the variable geometry turbocharger actuator installation.

Refer to Procedure 010-134

Specification

  • If the variable geometry turbocharger actuator installation does complete, then proceed to the Linked Solutions section.
  • If the variable geometry turbocharger actuator installation does not complete, then a malfunctioning variable geometry turbocharger actuator has been detected.

Linked Solutions

  • Variable geometry turbocharger actuator calibration incorrect

Refer to S00008994

Repair

  • Replace the variable geometry turbocharger actuator.

Refer to Procedure 010-134

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Variable geometry turbocharger actuator calibration incorrect

Solution: S00008994

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the variable geometry turbocharger actuator calibration.

Refer to Procedure 010-134

Specification

  • If the variable geometry turbocharger actuator calibration does not complete, then a malfunctioning variable geometry turbocharger has been detected.

Linked Solutions

  • None

Repair

  • Replace the variable geometry turbocharger.

Refer to Procedure 010-134

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2451 | SPN: 2789 | FMI: 16
Turbocharger Turbine Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Restricted intake air filter
  3. Exhaust gas pressure sensor stuck in-range
  4. Plugged or damaged exhaust gas pressure sensor tube
  5. Exhaust gas pressure sensor stuck in-range
  6. Leaks in the intake air system
  7. Charge air cooler system leak
  8. Plugged or damaged exhaust gas pressure sensor tube
  9. Air leaks at the hood air plenum
  10. Turbocharger is malfunctioning
  11. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000197

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Turbocharger: 2387, 2449, 2634
  • Intake manifold: 2973

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Restricted intake air filter

Solution: S00000025

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Specification

  • If the intake air filter is plugged, then a restricted intake air filter has been detected.

Linked Solutions

  • None

Repair

  • Replace the air filter.

Refer to OEM Service Manual

Refer to Procedure 010-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Exhaust gas pressure sensor stuck in-range

Solution: S00000733

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Refer to Procedure 019-361

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the exhaust gas pressure sensor reading to the barometric pressure.

Specification

  • Proceed to the Linked Solution section if the exhaust gas pressure is not within the following specification of the barometric pressure: 76 mm Hg [3 in Hg]

Linked Solutions

  • Plugged or damaged exhaust gas pressure sensor tube

Refer to S00001370

  • Exhaust gas pressure sensor stuck in-range

Refer to S00000734

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Plugged or damaged exhaust gas pressure sensor tube

Solution: S00001370

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

  • Inspect the exhaust gas pressure sensor tube for cracks and thread damage.

Refer to Procedure 011-027

  • Inspect the inside of the tube and sensor adapter for debris or soot buildup.

Refer to Procedure 011-027

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.2 - Exhaust gas pressure sensor stuck in-range

Solution: S00000734

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Reconnect the sensor.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the exhaust gas pressure sensor reading to the barometric pressure.

Specification

  • A malfunctioning exhaust gas pressure sensor has been detected if the exhaust gas pressure is not within the following specification of the barometric pressure sensor: 76 mm Hg [3 in Hg]

Linked Solutions

  • None

Repair

  • Replace exhaust gas pressure sensor.

Refer to Procedure 019-376

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Leaks in the intake air system

Solution: S00008386

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.
  • Visually inspect the intake plumbing for possible air leaks.

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Charge air cooler system leak

Solution: S00008815

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the charge air cooler hoses for possible air leaks.
  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If a leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the charge air cooler.

Refer to Procedure 010-027

  • Repair or replace the charge air cooler hoses.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Plugged or damaged exhaust gas pressure sensor tube

Solution: S00000703

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

  • Inspect the exhaust gas pressure sensor tube for cracks and thread damage.

Refer to Procedure 011-027

  • Inspect the inside of the tube and sensor adapter for debris or soot buildup.

Refer to Procedure 011-027

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Air leaks at the hood air plenum

Solution: S00003677

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the sealing surface between the air filter and the hood plenum for damage.

Specification

  • None

Linked Solutions

  • None

Repair

  • Repair or replace the component that is the source of the leak.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Turbocharger is malfunctioning

Solution: S00005253

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the intake and exhaust connections from the turbocharger.

Action

  • Inspect the turbocharger compressor and turbine blades for damage or wear.

Refer to Procedure 010-033

Specification

  • If any of the checks are not within specification, then a malfunctioning turbocharger has been detected.

Linked Solutions

  • None

Repair

  • Replace the turbocharger.

Refer to Procedure 010-033

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2468 | SPN: 190 | FMI: 16
Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Engine speed sensor is malfunctioning

1 - Engine speed sensor is malfunctioning

Solution: S00000483

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Interview the customer and check for the following:
  • Engine has not been motoring downhill
  • Use the recommended Cummins® electronic service tool or equivalent.
  • RPM reading is correct

Specification

  • If all of these conditions are true, then a malfunctioning camshaft position sensor or crankshaft position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace camshaft position sensor.

Refer to Procedure 019-363

  • Replace crankshaft position sensor.

Refer to Procedure 019-365

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2554 | SPN: 1209 | FMI: 2
Exhaust Gas Pressure 1 - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Exhaust gas pressure sensor stuck in-range
  3. Plugged or damaged exhaust gas pressure sensor tube
  4. Exhaust gas pressure sensor stuck in-range
  5. Exhaust gas pressure sensor voltage check
  6. Exhaust gas pressure sensor voltage check at the ECM
  7. Plugged or damaged exhaust gas pressure sensor tube
  8. Exhaust gas pressure sensor open circuit check
  9. Exhaust gas pressure sensor circuit pin to pin short
  10. ECM calibration revision history check
  11. Exhaust gas pressure sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000199

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Exhaust gas pressure: 2373, 2374

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Exhaust gas pressure sensor stuck in-range

Solution: S00000733

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Refer to Procedure 019-361

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the exhaust gas pressure sensor reading to the barometric pressure.

Specification

  • Proceed to the Linked Solution section if the exhaust gas pressure is not within the following specification of the barometric pressure: 76 mm Hg [3 in Hg]

Linked Solutions

  • Plugged or damaged exhaust gas pressure sensor tube

Refer to S00001370

  • Exhaust gas pressure sensor stuck in-range

Refer to S00000734

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Plugged or damaged exhaust gas pressure sensor tube

Solution: S00001370

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

  • Inspect the exhaust gas pressure sensor tube for cracks and thread damage.

Refer to Procedure 011-027

  • Inspect the inside of the tube and sensor adapter for debris or soot buildup.

Refer to Procedure 011-027

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Exhaust gas pressure sensor stuck in-range

Solution: S00000734

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Reconnect the sensor.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the exhaust gas pressure sensor reading to the barometric pressure.

Specification

  • A malfunctioning exhaust gas pressure sensor has been detected if the exhaust gas pressure is not within the following specification of the barometric pressure sensor: 76 mm Hg [3 in Hg]

Linked Solutions

  • None

Repair

  • Replace exhaust gas pressure sensor.

Refer to Procedure 019-376

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Exhaust gas pressure sensor voltage check

Solution: S00000776

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the exhaust gas pressure sensor SUPPLY pin and the exhaust gas pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Exhaust gas pressure sensor voltage check at the ECM

Refer to S00000777

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Exhaust gas pressure sensor voltage check at the ECM

Solution: S00000777

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the exhaust gas pressure sensor SUPPLY pin and the exhaust gas pressure sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Plugged or damaged exhaust gas pressure sensor tube

Solution: S00000703

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

  • Inspect the exhaust gas pressure sensor tube for cracks and thread damage.

Refer to Procedure 011-027

  • Inspect the inside of the tube and sensor adapter for debris or soot buildup.

Refer to Procedure 011-027

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Exhaust gas pressure sensor open circuit check

Solution: S00000778

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the exhaust gas pressure sensor SIGNAL pin at the exhaust gas pressure sensor engine wiring harness connector and the exhaust gas pressure sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the exhaust gas pressure sensor SUPPLY pin at the exhaust gas pressure sensor engine wiring harness connector and the exhaust gas pressure sensor SUPPLY pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Exhaust gas pressure sensor circuit pin to pin short

Solution: S00000775

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the exhaust gas pressure sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Exhaust gas pressure sensor is malfunctioning

Solution: S00003039

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning exhaust gas pressure sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the Exhaust gas pressure sensor.

Refer to Procedure 019-376

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2634 | SPN: 641 | FMI: 12
VGT Actuator Controller - Bad Intelligent Device or Component

Troubleshooting Summary

  1. Variable geometry turbocharger actuator is installed incorrectly
  2. Variable geometry turbocharger actuator is malfunctioning

1 - Variable geometry turbocharger actuator is installed incorrectly

Solution: S00003229

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If both fault codes 2449 and 2634 are active, then an incorrect installation of the variable geometry turbocharger actuator has been detected.

Linked Solutions

  • None

Repair

  • Remove the variable geometry turbocharger actuator and reinstall in the correct position.

Refer to Procedure 010-134

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Variable geometry turbocharger actuator is malfunctioning

Solution: S00000600

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning variable geometry turbocharger actuator has been detected.

Linked Solutions

  • None

Repair

  • Replace the variable geometry turbocharger actuator.

Refer to Procedure 010-134

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2636 | SPN: 641 | FMI: 9
VGT Actuator Driver Circuit - Abnormal Update Rate

Troubleshooting Summary

  1. Check for primary fault codes
  2. Low battery voltage
  3. Battery load test
  4. Ground inspection
  5. Variable geometry turbocharger actuator voltage check
  6. Wiring harness load test
  7. Variable geometry turbocharger actuator voltage check at the ECM
  8. Fault Code 2636 triggered by a malfunction in the J1939 data link with multiple OEM fault code
  9. Variable geometry turbocharger actuator has incorrect J1939 terminating resistance
  10. J1939 data link engine wiring harness voltage check 3 pin service connector
  11. OEM sensor voltage check
  12. J1939 data link harness pin to ground short circuit
  13. J1939 data link terminating resistance is incorrect
  14. Variable geometry turbocharger actuator has incorrect J1939 terminating resistance
  15. Engine wiring harness has incorrect J1939 terminating resistance
  16. OEM wiring harness has incorrect J1939 terminating resistance
  17. OEM terminating resistor Ω check for the J1939 data link
  18. Incorrect terminating resistance in the J1939 data link by a J1939 data linked component
  19. J1939 wire resistance check at the crossover connector for each component
  20. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000200

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Turbocharger: 1962, 1976

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Low battery voltage

Solution: S00001110

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.
  • If this vehicle has been repaired within the last 30 days for the same fault code, then proceed to the Linked Solutions section.

Specification

  • If the battery voltage is at least 10.8 VDC (12 volt systems) or 21.6 VDC (24 volt systems), then proceed to the Linked Solutions section.
  • If the battery or battery cables show signs of corrosion or damage, then proceed to the Repair Section.

Linked Solutions

  • Battery load test

Refer to S00001379

  • Ground inspection

Refer to S00000754

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean corrosion or tighten battery cable connections.

Refer to OEM Service Manual

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Battery load test

Solution: S00001379

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Disconnect the batteries from each other.
  • Connect a load tester separately to each battery.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.

Specification

  • For a 12 volt system, proceed to the Repair section if the battery voltage is below the following specification: 11 VDC
  • For a 24 volt system, proceed to the Repair section if the battery voltage is below the following specification: 22 VDC

Linked Solutions

  • None

Repair

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Ground inspection

Solution: S00000754

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the ECM ground for damage, corrosion and loose connections.
  • Visually inspect the aftertreatment interface wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the OEM wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the grounds for proper routing.

Specification

  • If damage, corrosion or incorrect routing of grounds are found, then proceed to the Repair section

Linked Solutions

  • None

Repair

  • Clean or replace connections.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Variable geometry turbocharger actuator voltage check

Solution: S00000597

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the variable geometry turbocharger actuator from the engine wiring harness.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the variable geometry turbocharger actuator battery SUPPLY pin and the variable geometry turbocharger actuator battery RETURN pin at the variable geometry turbocharger actuator engine wiring harness connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section and perform the Wiring Harness Load Test if the voltage is within the following specification of battery voltage: 1 VDC
  • Proceed to the Linked Solutions section and perform the voltage check at the ECM if voltage is not within the following specification: 1 VDC

Linked Solutions

  • Wiring harness load test

Refer to S00000877

  • Variable geometry turbocharger actuator voltage check at the ECM

Refer to S00001244

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Wiring harness load test

Solution: S00000877

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect all components on the wiring circuit being tested.

Action

This test is NOT for checking the J1939 data link (+) and (-) pins since it may cause damage to the J1939 smart devices or sensors.

  • Perform the wiring harness load test for the circuit being tested.

Refer to Procedure 019-359

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the voltage drop is not within specification, then a malfunctioning wiring harness has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.2 - Variable geometry turbocharger actuator voltage check at the ECM

Solution: S00001244

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the variable geometry turbocharger actuator battery SUPPLY pin and the variable geometry turbocharger actuator battery RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the voltage is within the following specification of battery voltage: 1 VDC
  • A malfunctioning ECM has been detected if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Fault Code 2636 triggered by a malfunction in the J1939 data link with multiple OEM fault code

Solution: S00003143

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution, if any fault code is active or has more than one inactive count within the last 25 engine operating hours from the following list: 2771, 3232, 3868, 3911, 4151, 4152, 4572, 4677, 6688
  • Proceed to the Linked Solutions section if a fault code from the following list is not active or does not have more than one inactive count within the last 25 engine operating hours: 2771, 3232, 3868, 3911, 4151, 4152, 4572, 4677, 6688

Linked Solutions

  • Variable geometry turbocharger actuator has incorrect J1939 terminating resistance

Refer to S00001242

  • If the above checks are all within specification, then a malfunctioning variable geometry turbocharger actuator has been detected

Repair

  • Replace the variable geometry turbocharger actuator.

Refer to Procedure 010-134

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4.1 - Variable geometry turbocharger actuator has incorrect J1939 terminating resistance

Solution: S00001242

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the variable geometry turbocharger actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the variable geometry turbocharger actuator SAE J1939 data link (+) pin and the variable geometry turbocharger actuator SAE J1939 data link (-) pin at the variable geometry turbocharger actuator.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning variable geometry turbocharger actuator has been detected if the resistance is not within the following specification: 108 Ω - 132 Ω

Linked Solutions

  • None

Repair

  • Replace the variable geometry turbocharger actuator.

Refer to Procedure 010-134

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - J1939 data link engine wiring harness voltage check 3 pin service connector

Solution: S00000594

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect all SAE J1939 components.
  • Turn keyswitch ON.

Action

The service tool datalink adapter can NOT be connected to the 3-pin J1939 datalink connector during this check.

  • Measure the J1939 voltage of the J1939 (+) pin to ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

  • Measure the J1939 voltage of the J1939 (-) pin to ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

Specification

  • A malfunctioning wiring harness has been detected due to the J1939 data link circuit being shorted to a voltage source if the voltage is greater than the following specification: 4.5 VDC
  • Proceed to the Linked Solutions section if the voltage is less than the following specification: 1 VDC
  • Proceed to the next solution if the voltage is within the following specification for both the SAE J1939 data link (+) and SAE J1939 data link (-) circuit: 1 - 4.5 VDC

Linked Solutions

  • OEM J1939 data link component isolation

Refer to S00003176

  • Engine or OEM wiring harness shorted to ground

Refer to S00003331

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5.1 - OEM sensor voltage check

Solution: S00003176

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Reconnect the crossover connector.

Inspect the following components if applicable:

  • Turn keyswitch ON.
  • Measure the J1939 voltage of the SAE J1939 data link (+) and SAE data link J1939 (-) pins at the variable geometry turbocharger actuator engine wiring harness connector to battery ground while each component is disconnected one at a time.
  • Disconnect the aftertreatment outlet NOx sensor
  • Disconnect the aftertreatment DPF temperature sensor module.
  • Disconnect the aftertreatment SCR temperature sensor module.
  • Disconnect the aftertreatment intermediate NH3 sensor.
  • Disconnect the aftertreatment particulate sensor
  • Disconnect the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.
  • Disconnect the aftertreatment exhaust gas temperature sensor.
  • Disconnect the aftertreatment intake NOx sensor.

Specification

  • A malfunctioning SAE J1939 data link component has been detected if the voltage is within the following specification after the component has been disconnected: 1 - 4.5 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.

Refer to OEM Service Manual

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

  • Replace aftertreatment DPF temperature sensor module.

Refer to Procedure 019-449

  • Replace the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-449

  • Replace aftertreatment intermediate NH3 sensor.

Refer to Procedure 019-479

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.2 - J1939 data link harness pin to ground short circuit

Solution: S00003331

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Turn keyswitch ON.

Action

The service tool datalink adapter can NOT be connected to the 3-pin J1939 datalink connector during this check.

  • Measure the J1939 voltage of the J1939 (+) pin to battery ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

  • Measure the J1939 voltage of the J1939 (-) pin to battery ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

Specification

  • A malfunctioning OEM wiring harness has been detected if voltage is within the following specification with the crossover connector disconnected: 1 - 4.5 VDC
  • A malfunctioning engine wiring harness has been detected if voltage is not within the following specification with the crossover connector disconnected: 1 - 4.5 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - J1939 data link terminating resistance is incorrect

Solution: S00000593

Verification

Conditions

  • Turn keyswitch OFF.
  • Wait for 90 seconds.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.
  • Reconnect the variable geometry turbocharger actuator if it has been previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3-pin service data link connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Follow your technical escalation process if the resistance is within the following specification: 54 - 66 Ω
  • Proceed to the Linked Solutions section if the resistance is not within the following specification: 54 - 66 Ω

Linked Solutions

  • Variable geometry turbocharger actuator has incorrect J1939 terminating resistance

Refer to S00001242

  • Engine wiring harness has incorrect J1939 terminating resistance

Refer to S00000972

  • OEM wiring harness has incorrect J1939 terminating resistance

Refer to S00000971

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

6.1 - Variable geometry turbocharger actuator has incorrect J1939 terminating resistance

Solution: S00001242

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the variable geometry turbocharger actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the variable geometry turbocharger actuator SAE J1939 data link (+) pin and the variable geometry turbocharger actuator SAE J1939 data link (-) pin at the variable geometry turbocharger actuator.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning variable geometry turbocharger actuator has been detected if the resistance is not within the following specification: 108 Ω - 132 Ω

Linked Solutions

  • None

Repair

  • Replace the variable geometry turbocharger actuator.

Refer to Procedure 010-134

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6.2 - Engine wiring harness has incorrect J1939 terminating resistance

Solution: S00000972

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect previously disconnected components.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.
  • Disconnect the aftertreatment intake NOx sensor from the engine wiring harness.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3-pin service data link connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is not within the following specification: 108-132 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6.3 - OEM wiring harness has incorrect J1939 terminating resistance

Solution: S00000971

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if the resistance is not within the following specification: 108 - 132 Ω
  • Follow your technical escalation process if the resistance is within the following specification: 108 - 132 Ω

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Parent Solution

7 - OEM terminating resistor Ω check for the J1939 data link

Solution: S00000907

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM terminating resistor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the pins for the OEM terminating resistor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM terminating resistor has been detected if the resistance is not within the following specification: 108 - 132 Ω

Linked Solutions

  • None

Repair

  • For a malfunctioning OEM terminating resistor, replace the OEM terminating resistor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Incorrect terminating resistance in the J1939 data link by a J1939 data linked component

Solution: S00001002

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Reconnect the OEM terminating resistor if previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the resistance is not within the following specification: 108 - 132 Ω

Linked Solutions

  • J1939 wire resistance check at the crossover connector for each component

Refer to S00001003

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

8.1 - J1939 wire resistance check at the crossover connector for each component

Solution: S00001003

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Reconnect the OEM terminating resistor if previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

Inspect the following components if applicable:

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector for each component while disconnecting them one at a time.
  • Disconnect the aftertreatment outlet NOx sensor
  • Disconnect the aftertreatment temperature sensor module
  • Disconnect the aftertreatment particulate sensor
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor
  • Disconnect the aftertreatment diesel exhaust fluid temperature sensor
  • Disconnect the aftertreatment diesel exhaust fluid quality sensor.
  • Disconnect the aftertreatment intermediate NH3 sensor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance was not within 108 Ω to 132 Ω and it becomes within the specification of 108 Ω to 132 Ω when the J1939 component was disconnected, then a malfunctioning J1939 component has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid tank level sensor.

Refer to OEM Service Manual

  • Replace the aftertreatment diesel exhaust fluid temperature sensor.

Refer to OEM Service Manual

  • Replace the aftertreatment diesel exhaust fluid quality sensor.

Refer to OEM Service Manual

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace aftertreatment DOC temperature sensor module.

Refer to Procedure 019-449

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

  • Replace aftertreatment intermediate NH3 sensor.

Refer to Procedure 019-479

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

9 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2637 | SPN: 5018 | FMI: 11
Aftertreatment 1 Diesel Oxidation Catalyst Face Plugged - Root Cause Not Known

Troubleshooting Summary

  1. Leaks in the intake air system
  2. Aftertreatment exhaust system leaks
  3. Charge air cooler system leak
  4. Aftertreatment DOC is malfunctioning

1 - Leaks in the intake air system

Solution: S00008386

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.
  • Visually inspect the intake plumbing for possible air leaks.

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment exhaust system leaks

Solution: S00001008

Verification

Conditions

  • Engine running.

Action

  • Visually inspect for leaks in the exhaust manifold to head.

Refer to Procedure 010-024

  • Visually inspect for leaks from the turbocharger to exhaust manifold.

Refer to Procedure 010-024

  • Visually inspect for leaks in the exhaust plumbing between the turbocharger outlet and the Aftertreatment DOC intake connection.

Refer to Procedure 010-024

  • Visually inspect the exhaust piping for leaks, cracks, and loose connections.

Refer to Procedure 010-024

  • Inspect for leaks at the aftertreatment DOC housing, sensor ports and connection points.

Refer to Procedure 010-024

  • Visually inspect the aftertreatment and SCR components for exhaust leaks.

Refer to Procedure 010-024

Specification

  • If there is any damage or leaks found in the exhaust system, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the exhaust manifold.

Refer to Procedure 011-007

  • Repair or replace the exhaust plumbing.

Refer to Procedure 011-007

Refer to OEM Service Manual

  • Replace aftertreatment DOC.

Refer to Procedure 011-049

  • Replace the aftertreatment diesel particulate filter.

Refer to Procedure 011-041

  • Replace the aftertreatment SCR Catalyst.

Refer to Procedure 011-036

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Charge air cooler system leak

Solution: S00008815

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the charge air cooler hoses for possible air leaks.
  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If a leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the charge air cooler.

Refer to Procedure 010-027

  • Repair or replace the charge air cooler hoses.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment DOC is malfunctioning

Solution: S00005082

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect for the presence of the aftertreatment DOC.

Refer to Procedure 011-049

  • Inspect the inlet face of the aftertreatment DOC for reuse.

Refer to Procedure 011-049

Refer to Service Bulletin 4021600

  • Inspect for cracks in the aftertreatment DOC cell walls.

Refer to Service Bulletin 4021600

  • Inspect for soot or oil plugging the front face of the catalyst

Refer to Service Bulletin 4021600

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • If the face of the aftertreatment DOC is plugged, then clean the aftertreatment DOC.

Refer to Procedure 011-049

  • If the face of the aftertreatment DOC is cracked or damaged, then replace the aftertreatment DOC.

Refer to Procedure 011-049

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2638 | SPN: 5298 | FMI: 17
Aftertreatment 1 Diesel Oxidation Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment DPF Permit Switch Status is in the OFF position
  3. Aftertreatment exhaust system leaks
  4. Aftertreatment temperature sensor stuck in-range
  5. Turbocharger exhaust is leaking oil into the aftertreatment system
  6. Aftertreatment fuel injector is malfunctioning
  7. Aftertreatment DOC is malfunctioning
  8. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002466

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment DOC: 3251, 3313, 3314, 3315
  • Aftertreatment DPF: 1879, 1881, 1883, 1921, 1922, 1981, 1993, 2639, 3133, 3134, 3135, 3168, 3253, 3254, 3255, 3256, 3311, 3312, 3316, 3317, 3318, 3319, 3321, 3322, 3375, 3376, 3396, 4151, 4158, 4161, 4162, 4163, 4259, 5616, 5716
  • Turbocharger: 595, 687, 691, 692, 693, 1898, 1962, 2198, 2288, 2387, 2449, 2634, 2636, 3616, 4956, 4957, 5177
  • EGR: 1228, 1866, 1867, 1896, 1961, 2272, 2273, 2274, 2349, 2353, 2375, 2376, 2961, 2962, 3342, 3382, 3383, 4485
  • Fuel: 271, 272, 451, 452, 553, 559, 2311, 2372, 3727, 3741, 5384, 5385
  • Aftertreatment diesel exhaust fluid dosing unit: 3167

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment DPF Permit Switch Status is in the OFF position

Solution: S00001026

Verification

Conditions

  • None

Action

  • Visually verify the Aftertreatment DPF Permit Switch is in the ON position.

Specification

  • If the Aftertreatment DPF Permit Switch is in the ON position, then proceed to the next solution.
  • If the Aftertreatment DPF Permit Switch is not in the ON position, then proceed to the Repair section.
  • If there is not an Aftertreatment DPF Permit Switch on the dash, then an incorrect parameter setting has been determined. Proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Turn the Aftertreatment DPF Permit Switch Status to the ON position.
  • Adjust the features and parameters to the correct settings.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Perform the aftertreatment stationary regeneration.
Next Solution

3 - Aftertreatment exhaust system leaks

Solution: S00001008

Verification

Conditions

  • Engine running.

Action

  • Visually inspect for leaks in the exhaust manifold to head.

Refer to Procedure 010-024

  • Visually inspect for leaks from the turbocharger to exhaust manifold.

Refer to Procedure 010-024

  • Visually inspect for leaks in the exhaust plumbing between the turbocharger outlet and the Aftertreatment DOC intake connection.

Refer to Procedure 010-024

  • Visually inspect the exhaust piping for leaks, cracks, and loose connections.

Refer to Procedure 010-024

  • Inspect for leaks at the aftertreatment DOC housing, sensor ports and connection points.

Refer to Procedure 010-024

  • Visually inspect the aftertreatment and SCR components for exhaust leaks.

Refer to Procedure 010-024

Specification

  • If there is any damage or leaks found in the exhaust system, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the exhaust manifold.

Refer to Procedure 011-007

  • Repair or replace the exhaust plumbing.

Refer to Procedure 011-007

Refer to OEM Service Manual

  • Replace aftertreatment DOC.

Refer to Procedure 011-049

  • Replace the aftertreatment diesel particulate filter.

Refer to Procedure 011-041

  • Replace the aftertreatment SCR Catalyst.

Refer to Procedure 011-036

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment temperature sensor stuck in-range

Solution: S00000338

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Start the engine.

Action

  • Run the engine at high idle for the following minutes: 10
  • Use the recommended Cummins® electronic service tool or equivalent.

Monitor the following parameters:

  • Aftertreatment diesel oxidation catalyst intake temperature
  • Aftertreatment diesel particulate filter intake temperature
  • Aftertreatment diesel particulate filter outlet temperature

Specification

  • A malfunctioning aftertreatment exhaust gas temperature sensor has been detected if each sensor is not within the following specification of the others: 24 C [43 F]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Turbocharger exhaust is leaking oil into the aftertreatment system

Solution: S00000655

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the exhaust piping from the turbocharger outlet.

Action

  • Inspect for any fluids.
  • Visually inspect the turbocharger exhaust outlet for signs of oil or fuel.
  • Perform the Snap Acceleration Test - Aftertreatment Disconnected.

Refer to Procedure 014-017

Specification

  • If lubricating engine oil contamination is found in the turbocharger exhaust outlet, then reset the search to oil consumption internal.
  • If excessive black smoke is detected, then reset the search to black smoke.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

6 - Aftertreatment fuel injector is malfunctioning

Solution: S00003043

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the Aftertreatment Maintenance Reset All procedure found under the Aftertreatment Maintenance Section of Advanced ECM Data.

Performing the Aftertreatment Maintenance Reset All may cause the fault code to go inactive. This does not mean that the issue was resolved, only that the efficiencies were reset. Troubleshooting must be continued.

  • Visually inspect for a missing poppet in the aftertreatment fuel injector.

Refer to TSB130159

  • Perform the Aftertreatment Fuel Injector Flow Test.

Refer to Procedure 011-054

Specification

  • If the Aftertreatment Fuel Injector Flow Test does not meet specification, then a malfunctioning aftertreatment fuel injector has been detected.

Linked Solutions

  • None

Repair

  • Replace the fuel injector.

Refer to Procedure 011-042

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Aftertreatment DOC is malfunctioning

Solution: S00005082

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect for the presence of the aftertreatment DOC.

Refer to Procedure 011-049

  • Inspect the inlet face of the aftertreatment DOC for reuse.

Refer to Procedure 011-049

Refer to Service Bulletin 4021600

  • Inspect for cracks in the aftertreatment DOC cell walls.

Refer to Service Bulletin 4021600

  • Inspect for soot or oil plugging the front face of the catalyst

Refer to Service Bulletin 4021600

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • If the face of the aftertreatment DOC is plugged, then clean the aftertreatment DOC.

Refer to Procedure 011-049

  • If the face of the aftertreatment DOC is cracked or damaged, then replace the aftertreatment DOC.

Refer to Procedure 011-049

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2639 | SPN: 3251 | FMI: 15
Aftertreatment 1 Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Restricted intake air filter
  3. Aftertreatment DPF differential pressure sensor tubes plugged
  4. Aftertreatment DPF differential pressure sensor stuck in-range
  5. ECM calibration revision history check
  6. Stationary aftertreatment regeneration is needed

1 - Check for primary fault codes

Solution: S00000204

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment regeneration: 2777, 3375, 3376, 4213, 6416
  • Aftertreatment differential pressure: 1879, 1881, 1883, 1921, 1922
  • Aftertreatment DPF: 1981, 2754, 3133, 3134, 3135, 3316, 3317, 3318,, 3319, 3321, 3322, 3396, 5383
  • Aftertreatment DOC: 3313, 3314, 3315
  • Fuel: 559, 1139, 1141, 1142, 1143, 1144, 1145, 4713
  • Engine misfire: 1654, 1655, 1656, 1657, 1658, 1659
  • EGR: 1228, 1896, 2272, 2349, 2353, 2357, 2961, 2962, 3136, 3137, 3138, 3342, 3382, 3383, 3389
  • EGR differential pressure: 1866, 2273, 2274
  • Turbocharger: 1898, 2198, 2387, 2449, 2634, 2635, 2636, 3616
  • Intake manifold: 125, 2973, 4616
  • Intake throttle: 175, 176, 177, 3539, 3541, 3542, 5879, 5881, 5882

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Restricted intake air filter

Solution: S00000025

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Specification

  • If the intake air filter is plugged, then a restricted intake air filter has been detected.

Linked Solutions

  • None

Repair

  • Replace the air filter.

Refer to OEM Service Manual

Refer to Procedure 010-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment DPF differential pressure sensor tubes plugged

Solution: S00001183

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment DPF differential pressure sensor tubes for signs of damage, plugging, kinks, leakage or loose connections.

Refer to Procedure 011-047

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace DPF differential pressure sensor tubes.

Refer to Procedure 011-047

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment DPF differential pressure sensor stuck in-range

Solution: S00000793

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the aftertreatment DPF differential pressure sensor voltage.

Refer to Procedure 019-443

Specification

  • If the aftertreatment DPF differential pressure sensor voltage readings are not within specification, then a malfunctioning aftertreatment DPF differential pressure sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Stationary aftertreatment regeneration is needed

Solution: S00001113

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the Aftertreatment Diesel Particulate Filter regeneration test.

Refer to Procedure 014-016

Specification

  • If the aftertreatment stationary regeneration does not complete, then reset the Search to stationary regeneration will not complete.
  • If the aftertreatment stationary regeneration does not activate, then reset the Search to stationary regeneration will not start.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2646 | SPN: 110 | FMI: 31
Engine Coolant Temperature - Condition Exists

Troubleshooting Summary

  1. Fault code is for information only
  2. ECM calibration revision history check

1 - Fault code is for information only

Solution: S00010599

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • This solution is for information only stating that the EGR valve was closed to reduce engine coolant temperature.

Specification

  • This solution is information only.

Linked Solutions

  • None

Repair

  • This fault code is for information only.
  • No repair is necessary.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2692 | SPN: 3936 | FMI: 2
Aftertreatment 1 Diesel Particulate Filter System - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Aftertreatment DPF is malfunctioning

1 - Check for primary fault codes

Solution: S00000205

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment Particulate sensor: 4143, 4144, 4153, 4154, 5577, 5578, 5579, 5581, 5582, 5583, 5584, 5792, 5793, 5837, 6642, 6643, 6644, 6645, 6646, 6647, 6648, 6649, 6651, 6652, 6653, 6688
  • Aftertreatment differential pressure: 1922
  • Aftertreatment DPF: 1981, 1993
  • Aftertreatment regeneration: 3375, 3376

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment DPF is malfunctioning

Solution: S00007816

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • If the aftertreatment DPF has already been replaced during this repair, then disregard this solution.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive with more than one count within the last 25 engine operating hours and no other fault codes have been logged, then a plugged or restricted aftertreatment DPF has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF.

Refer to Procedure 011-041

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

Validation

  • None
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2718 | SPN: 6304 | FMI: 31
Brake Switch and Accelerator Pedal Position Incompatible - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002298

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Anti-Lock Braking: 3488, 4215
  • Accelerator Pedal or Lever Position: 131, 132, 1239, 1241, 1242, 1515, 3539, 3541, 3542, 5879, 5881

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2738 | SPN: 626 | FMI: 3
Engine Start Enable Device 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Ether injection solenoid resistance check
  2. Ether injection solenoid voltage check
  3. Ether injection solenoid open circuit check
  4. Ether injection solenoid open circuit check
  5. Ether injection solenoid pin to pin short in the OEM wiring harness

1 - Ether injection solenoid resistance check

Solution: S00000406

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ether injection solenoid from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ether injection solenoid SIGNAL pin and the ether injection solenoid RETURN pin of the ether injection solenoid connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Repair section if the resistance is greater than the following specification: 10k Ω

Linked Solutions

  • None

Repair

  • Replace the ether injection solenoid.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Ether injection solenoid voltage check

Solution: S00001093

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ether injection solenoid from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the ether injection solenoid SIGNAL pin and the ether injection solenoid RETURN pin at the ether injection solenoid connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Ether injection solenoid open circuit check

Refer to S00001094

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Ether injection solenoid open circuit check

Solution: S00001094

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the ether injection solenoid from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ether injection solenoid SIGNAL pin at the ether injection solenoid connector of the OEM wiring harness and the ether injection solenoid SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the ether injection solenoid RETURN pin at the ether injection solenoid connector of the OEM wiring harness and the ether injection solenoid RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Ether injection solenoid open circuit check

Solution: S00000407

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ether injection solenoid from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ether injection solenoid SIGNAL pin at the ether injection solenoid connector of the OEM wiring harness and the ether injection solenoid SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the ether injection solenoid RETURN pin at the ether injection solenoid connector of the OEM wiring harness and the ether injection solenoid RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Ether injection solenoid pin to pin short in the OEM wiring harness

Solution: S00001095

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ether injection solenoid from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the control solenoid SIGNAL pin in the OEM wiring harness ECM connector and all other pins in the connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 03-Apr-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2739 | SPN: 626 | FMI: 4
Engine Start Enable Device 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Ether injection solenoid resistance check
  2. Ether injection solenoid voltage check
  3. Ether injection solenoid open circuit check
  4. Ether injection solenoid circuit OEM wiring harness short-to ground
  5. Ether injection solenoid pin to pin short in the OEM wiring harness

1 - Ether injection solenoid resistance check

Solution: S00001096

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ether injection solenoid from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ether injection solenoid SIGNAL pin and the ether injection solenoid RETURN pin of the ether injection solenoid connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Repair section if the resistance is less than the following specification: 3 Ω

Linked Solutions

  • None

Repair

  • Replace the ether injection solenoid.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Ether injection solenoid voltage check

Solution: S00001093

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ether injection solenoid from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the ether injection solenoid SIGNAL pin and the ether injection solenoid RETURN pin at the ether injection solenoid connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Ether injection solenoid open circuit check

Refer to S00001094

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Ether injection solenoid open circuit check

Solution: S00001094

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the ether injection solenoid from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ether injection solenoid SIGNAL pin at the ether injection solenoid connector of the OEM wiring harness and the ether injection solenoid SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the ether injection solenoid RETURN pin at the ether injection solenoid connector of the OEM wiring harness and the ether injection solenoid RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Ether injection solenoid circuit OEM wiring harness short-to ground

Solution: S00001098

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the ether injection solenoid from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ether injection SIGNAL pin of the OEM wiring harness ECM connector and engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification:

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Ether injection solenoid pin to pin short in the OEM wiring harness

Solution: S00001095

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ether injection solenoid from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the control solenoid SIGNAL pin in the OEM wiring harness ECM connector and all other pins in the connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 03-Apr-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2754 | SPN: 81 | FMI: 16
Engine Diesel Particulate Filter Intake Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Fault Code 2754 requires that ALL solutions be performed
  2. Check for primary fault codes
  3. Restricted intake air filter
  4. Plugged EGR differential pressure sensor supply ports
  5. Damaged or missing aftertreatment DPF differential pressure sensor tubes
  6. Aftertreatment DPF differential pressure sensor stuck in-range
  7. Leaks in the intake air system
  8. Charge air cooler system leak
  9. Aftertreatment temperature sensor stuck in-range
  10. Aftertreatment DPF partially obstructed or plugged
  11. Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test

1 - Fault Code 2754 requires that ALL solutions be performed

Solution: S00001099

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • This solution is information only.
  • ALL solutions displayed for this fault code must be performed.
  • Continue to perform the verifications of ALL solution steps listed for this fault code regardless if a given solution is within specification or out of specification.

Specification

  • This solution is information only.

Linked Solutions

  • None

Repair

  • If a resolution is found in any solution for this fault code, continue performing ALL solutions listed for this fault code.

Validation

  • None
Next Solution

2 - Check for primary fault codes

Solution: S00000207

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment differential pressure: 5383
  • Aftertreatment DPF: 1879, 1881, 1883, 3133, 3134, 3135
  • Fuel: 559, 1139, 1141, 1142, 1143, 1144, 1145
  • Intake manifold: 125, 2973, 4612, 4616
  • EGR: 1228, 1866, 1867, 1961, 2272, 2273, 2274, 2349, 2353, 2375, 2376, 2961, 2962, 3136, 3137, 3138, 3342, 3382, 3383
  • Turbocharger: 1894, 1897, 1898, 1962, 1976, 2198, 2288, 2346, 2347, 2387, 2449, 2451, 2634, 2635, 2636, 3348, 6432
  • Aftertreatment DOC: 1691, 2638, 3168, 3315, 3318, 3322, 3396

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

3 - Restricted intake air filter

Solution: S00000025

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Specification

  • If the intake air filter is plugged, then a restricted intake air filter has been detected.

Linked Solutions

  • None

Repair

  • Replace the air filter.

Refer to OEM Service Manual

Refer to Procedure 010-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Plugged EGR differential pressure sensor supply ports

Solution: S00005073

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the EGR differential pressure sensor flow port cross-drillings for soot blockage.

Refer to Procedure 011-066

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Remove and clean the EGR mass measurement flow assembly.

Refer to Procedure 011-066

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Damaged or missing aftertreatment DPF differential pressure sensor tubes

Solution: S00001010

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the aftertreatment differential pressure tubes for proper installation.
  • Inspect the aftertreatment DPF differential pressure sensor tubes for signs of damage, plugging, kinks, leakage or loose connections.

Refer to Procedure 011-047

In extreme cold ambient temperatures it is important to check for a frozen, plugged, or restricted aftertreatment DPF differential pressure sensor tubes. Ice can form in the aftertreatment DPF differential pressure sensor tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Specification

  • If damage, kinks or blockages are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace DPF differential pressure sensor tubes.

Refer to Procedure 011-047

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

6 - Aftertreatment DPF differential pressure sensor stuck in-range

Solution: S00000793

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the aftertreatment DPF differential pressure sensor voltage.

Refer to Procedure 019-443

Specification

  • If the aftertreatment DPF differential pressure sensor voltage readings are not within specification, then a malfunctioning aftertreatment DPF differential pressure sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Leaks in the intake air system

Solution: S00008386

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.
  • Visually inspect the intake plumbing for possible air leaks.

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Charge air cooler system leak

Solution: S00008815

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the charge air cooler hoses for possible air leaks.
  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If a leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the charge air cooler.

Refer to Procedure 010-027

  • Repair or replace the charge air cooler hoses.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Aftertreatment temperature sensor stuck in-range

Solution: S00000338

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Start the engine.

Action

  • Run the engine at high idle for the following minutes: 10
  • Use the recommended Cummins® electronic service tool or equivalent.

Monitor the following parameters:

  • Aftertreatment diesel oxidation catalyst intake temperature
  • Aftertreatment diesel particulate filter intake temperature
  • Aftertreatment diesel particulate filter outlet temperature

Specification

  • A malfunctioning aftertreatment exhaust gas temperature sensor has been detected if each sensor is not within the following specification of the others: 24 C [43 F]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - Aftertreatment DPF partially obstructed or plugged

Solution: S00004187

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • If the aftertreatment DPF has already been replaced during this repair, then proceed to the next solution.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Particulate Filter Automated Restriction Test.

Refer to Procedure 011-085

Specification

  • If the Aftertreatment Diesel Particulate Filter Automated Restriction Test exceeds the limits called out in procedure, then a plugged or restricted aftertreatment DPF has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF.

Refer to Procedure 011-041

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

11 - Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test

Solution: S00003823

Verification

Conditions

  • Reconnect previously disconnected components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test.

Refer to Procedure 014-027

  • Verify the recommended Cummins® electronic service tool or equivalent has a version that supports this test.

Refer to Procedure 014-027

Specification

  • If the Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test does not pass, then reset the search to Aftertreatment Diesel Particulate Filter Regeneration Analyzer Did Not Pass. Only select the solution title that matches the error messages in the recommend Cummins® electronic service tool or equivalent.
  • If the Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test will not start, then reset the search to Aftertreatment Diesel Particulate Filter Regeneration Analyzer Did Not Start.
  • If the Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test does not complete, then reset the search to Aftertreatment Diesel Particulate Filter Regeneration Analyzer Did Not Complete.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 08-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2764 | SPN: 1209 | FMI: 16
Exhaust Gas Pressure 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Exhaust gas pressure sensor stuck in-range
  3. Plugged or damaged exhaust gas pressure sensor tube
  4. Exhaust gas pressure sensor stuck in-range
  5. Plugged or damaged exhaust gas pressure sensor tube
  6. High exhaust restriction
  7. Aftertreatment DPF partially obstructed or plugged
  8. Exhaust gas pressure sensor open circuit check
  9. Exhaust gas pressure sensor circuit pin to pin short
  10. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001100

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Exhaust gas pressure: 2373, 2374, 2554
  • EGR differential pressure: 1866, 2273, 2274
  • EGR: 1228, 1896, 1897, 1961, 2272, 2349, 2353, 3382, 3389, 4728
  • Turbocharger: 595, 687, 1894, 1897, 1976, 2198, 2387, 2449, 2635, 2636, 6432
  • Intake manifold: 122, 123, 124, 125, 2973, 3361, 4612, 5989, 5991

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Exhaust gas pressure sensor stuck in-range

Solution: S00000733

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Refer to Procedure 019-361

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the exhaust gas pressure sensor reading to the barometric pressure.

Specification

  • Proceed to the Linked Solution section if the exhaust gas pressure is not within the following specification of the barometric pressure: 76 mm Hg [3 in Hg]

Linked Solutions

  • Plugged or damaged exhaust gas pressure sensor tube

Refer to S00001370

  • Exhaust gas pressure sensor stuck in-range

Refer to S00000734

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Plugged or damaged exhaust gas pressure sensor tube

Solution: S00001370

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

  • Inspect the exhaust gas pressure sensor tube for cracks and thread damage.

Refer to Procedure 011-027

  • Inspect the inside of the tube and sensor adapter for debris or soot buildup.

Refer to Procedure 011-027

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Exhaust gas pressure sensor stuck in-range

Solution: S00000734

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Reconnect the sensor.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the exhaust gas pressure sensor reading to the barometric pressure.

Specification

  • A malfunctioning exhaust gas pressure sensor has been detected if the exhaust gas pressure is not within the following specification of the barometric pressure sensor: 76 mm Hg [3 in Hg]

Linked Solutions

  • None

Repair

  • Replace exhaust gas pressure sensor.

Refer to Procedure 019-376

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Plugged or damaged exhaust gas pressure sensor tube

Solution: S00000703

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

  • Inspect the exhaust gas pressure sensor tube for cracks and thread damage.

Refer to Procedure 011-027

  • Inspect the inside of the tube and sensor adapter for debris or soot buildup.

Refer to Procedure 011-027

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - High exhaust restriction

Solution: S00002897

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Install a mechanical gauge on the engine.

Refer to Procedure 011-009

  • Turn keyswitch ON.
  • Start the engine.
  • Check the exhaust restriction.

Refer to Procedure 011-009

Specification

  • If the exhaust restriction is not within specification, then a restriction in the exhaust has been detected.

Refer to Procedure 018-020

Linked Solutions

  • None

Repair

  • Check the face of the aftertreatment diesel oxidation catalyst for plugging.

Refer to Procedure 011-049

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment DPF partially obstructed or plugged

Solution: S00004187

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • If the aftertreatment DPF has already been replaced during this repair, then proceed to the next solution.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Particulate Filter Automated Restriction Test.

Refer to Procedure 011-085

Specification

  • If the Aftertreatment Diesel Particulate Filter Automated Restriction Test exceeds the limits called out in procedure, then a plugged or restricted aftertreatment DPF has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF.

Refer to Procedure 011-041

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Exhaust gas pressure sensor open circuit check

Solution: S00000778

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the exhaust gas pressure sensor SIGNAL pin at the exhaust gas pressure sensor engine wiring harness connector and the exhaust gas pressure sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the exhaust gas pressure sensor SUPPLY pin at the exhaust gas pressure sensor engine wiring harness connector and the exhaust gas pressure sensor SUPPLY pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Exhaust gas pressure sensor circuit pin to pin short

Solution: S00000775

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the exhaust gas pressure sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2771 | SPN: 3226 | FMI: 9
Aftertreatment 1 Outlet NOx Sensor - Abnormal Update Rate

Troubleshooting Summary

  1. Check for primary fault codes
  2. Low battery voltage
  3. Battery load test
  4. Ground inspection
  5. Aftertreatment outlet NOx sensor voltage check
  6. Aftertreatment power relay voltage check
  7. Aftertreatment power relay resistance check
  8. Aftertreatment outlet NOx sensor circuit check
  9. Aftertreatment power relay circuit check
  10. Fault Code 2771 triggered by a malfunction in the J1939 data link with multiple OEM fault code
  11. J1939 data link terminating resistance is incorrect
  12. Variable geometry turbocharger actuator has incorrect J1939 terminating resistance
  13. Engine wiring harness has incorrect J1939 terminating resistance
  14. OEM wiring harness has incorrect J1939 terminating resistance
  15. J1939 data link harness open circuit check
  16. OEM terminating resistor Ω check for the J1939 data link
  17. Incorrect terminating resistance in the J1939 data link by a J1939 data linked component
  18. J1939 wire resistance check at the crossover connector for each component
  19. ECM calibration revision history check
  20. Aftertreatment outlet NOx sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000210

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Turbocharger: 1894, 2636

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Low battery voltage

Solution: S00001110

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.
  • If this vehicle has been repaired within the last 30 days for the same fault code, then proceed to the Linked Solutions section.

Specification

  • If the battery voltage is at least 10.8 VDC (12 volt systems) or 21.6 VDC (24 volt systems), then proceed to the Linked Solutions section.
  • If the battery or battery cables show signs of corrosion or damage, then proceed to the Repair Section.

Linked Solutions

  • Battery load test

Refer to S00001379

  • Ground inspection

Refer to S00000754

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean corrosion or tighten battery cable connections.

Refer to OEM Service Manual

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Battery load test

Solution: S00001379

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Disconnect the batteries from each other.
  • Connect a load tester separately to each battery.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.

Specification

  • For a 12 volt system, proceed to the Repair section if the battery voltage is below the following specification: 11 VDC
  • For a 24 volt system, proceed to the Repair section if the battery voltage is below the following specification: 22 VDC

Linked Solutions

  • None

Repair

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Ground inspection

Solution: S00000754

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the ECM ground for damage, corrosion and loose connections.
  • Visually inspect the aftertreatment interface wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the OEM wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the grounds for proper routing.

Specification

  • If damage, corrosion or incorrect routing of grounds are found, then proceed to the Repair section

Linked Solutions

  • None

Repair

  • Clean or replace connections.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Aftertreatment outlet NOx sensor voltage check

Solution: S00010306

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment outlet NOx sensor battery voltage SUPPLY pin and the aftertreatment outlet NOx sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 1 VDC

Linked Solutions

  • Aftertreatment power relay voltage check

Refer to S00010303

  • Aftertreatment power relay resistance check

Refer to S00010305

  • Aftertreatment outlet NOx sensor circuit check

Refer to S00010333

  • Aftertreatment power relay circuit check

Refer to S00010368

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Aftertreatment power relay voltage check

Solution: S00010303

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment power relay battery voltage SUPPLY pin in the aftertreatment power relay connector of the OEM wiring harness and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.2 - Aftertreatment power relay resistance check

Solution: S00010305

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment power relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.3 - Aftertreatment outlet NOx sensor circuit check

Solution: S00010333

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.
  • Disconnect the aftertreatment outlet NOx sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment power relay SUPPLY pin at the aftertreatment power relay connector of the OEM wiring harness and the aftertreatment power relay SUPPLY pin at the aftertreatment interface wiring harness aftertreatment outlet NOx sensor connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.4 - Aftertreatment power relay circuit check

Solution: S00010368

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment power relay CONTROL pin at the aftertreatment power relay connector of the OEM wiring harness and the aftertreatment power relay CONTROL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Fault Code 2771 triggered by a malfunction in the J1939 data link with multiple OEM fault code

Solution: S00000823

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution, if any fault code is active or has more than one inactive count within the last 25 engine operating hours from the following list: 3232, 3868, 3911, 4151, 4152, 4572, 4677, 6688
  • A malfunctioning aftertreatment outlet NOx sensor has been detected if a fault code from the following list is not active, or does not have more than one inactive count within the last 25 engine operating hours: 3232, 3868, 3911, 4151, 4152, 4572, 4677, 6688

Linked Solutions

  • None

Repair

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - J1939 data link terminating resistance is incorrect

Solution: S00000593

Verification

Conditions

  • Turn keyswitch OFF.
  • Wait for 90 seconds.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.
  • Reconnect the variable geometry turbocharger actuator if it has been previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3-pin service data link connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Follow your technical escalation process if the resistance is within the following specification: 54 - 66 Ω
  • Proceed to the Linked Solutions section if the resistance is not within the following specification: 54 - 66 Ω

Linked Solutions

  • Variable geometry turbocharger actuator has incorrect J1939 terminating resistance

Refer to S00001242

  • Engine wiring harness has incorrect J1939 terminating resistance

Refer to S00000972

  • OEM wiring harness has incorrect J1939 terminating resistance

Refer to S00000971

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

5.1 - Variable geometry turbocharger actuator has incorrect J1939 terminating resistance

Solution: S00001242

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the variable geometry turbocharger actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the variable geometry turbocharger actuator SAE J1939 data link (+) pin and the variable geometry turbocharger actuator SAE J1939 data link (-) pin at the variable geometry turbocharger actuator.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning variable geometry turbocharger actuator has been detected if the resistance is not within the following specification: 108 Ω - 132 Ω

Linked Solutions

  • None

Repair

  • Replace the variable geometry turbocharger actuator.

Refer to Procedure 010-134

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.2 - Engine wiring harness has incorrect J1939 terminating resistance

Solution: S00000972

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect previously disconnected components.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.
  • Disconnect the aftertreatment intake NOx sensor from the engine wiring harness.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3-pin service data link connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is not within the following specification: 108-132 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.3 - OEM wiring harness has incorrect J1939 terminating resistance

Solution: S00000971

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if the resistance is not within the following specification: 108 - 132 Ω
  • Follow your technical escalation process if the resistance is within the following specification: 108 - 132 Ω

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Parent Solution

6 - J1939 data link harness open circuit check

Solution: S00004534

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the appropriate data link component from the data link wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the J1939 (+) pin at the appropriate component data link wiring harness connector and the appropriate data link component J1939 (+) pin at the data link wiring harness ECM connector.
  • Measure the resistance between the J1939 (-) pin at the appropriate component data link wiring harness connector and the appropriate data link component J1939 (-) pin at the data link wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning J1939 data link wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - OEM terminating resistor Ω check for the J1939 data link

Solution: S00000907

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM terminating resistor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the pins for the OEM terminating resistor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM terminating resistor has been detected if the resistance is not within the following specification: 108 - 132 Ω

Linked Solutions

  • None

Repair

  • For a malfunctioning OEM terminating resistor, replace the OEM terminating resistor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Incorrect terminating resistance in the J1939 data link by a J1939 data linked component

Solution: S00001002

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Reconnect the OEM terminating resistor if previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the resistance is not within the following specification: 108 - 132 Ω

Linked Solutions

  • J1939 wire resistance check at the crossover connector for each component

Refer to S00001003

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

8.1 - J1939 wire resistance check at the crossover connector for each component

Solution: S00001003

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Reconnect the OEM terminating resistor if previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

Inspect the following components if applicable:

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector for each component while disconnecting them one at a time.
  • Disconnect the aftertreatment outlet NOx sensor
  • Disconnect the aftertreatment temperature sensor module
  • Disconnect the aftertreatment particulate sensor
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor
  • Disconnect the aftertreatment diesel exhaust fluid temperature sensor
  • Disconnect the aftertreatment diesel exhaust fluid quality sensor.
  • Disconnect the aftertreatment intermediate NH3 sensor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance was not within 108 Ω to 132 Ω and it becomes within the specification of 108 Ω to 132 Ω when the J1939 component was disconnected, then a malfunctioning J1939 component has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid tank level sensor.

Refer to OEM Service Manual

  • Replace the aftertreatment diesel exhaust fluid temperature sensor.

Refer to OEM Service Manual

  • Replace the aftertreatment diesel exhaust fluid quality sensor.

Refer to OEM Service Manual

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace aftertreatment DOC temperature sensor module.

Refer to Procedure 019-449

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

  • Replace aftertreatment intermediate NH3 sensor.

Refer to Procedure 019-479

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

9 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - Aftertreatment outlet NOx sensor is malfunctioning

Solution: S00000994

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2777 | SPN: 3703 | FMI: 31
Aftertreatment Regeneration Inhibited Due to Inhibit Switch - Condition Exists

Troubleshooting Summary

  1. Aftertreatment DPF Permit Switch Status is in the OFF position
  2. ECM calibration revision history check

1 - Aftertreatment DPF Permit Switch Status is in the OFF position

Solution: S00001026

Verification

Conditions

  • None

Action

  • Visually verify the Aftertreatment DPF Permit Switch is in the ON position.

Specification

  • If the Aftertreatment DPF Permit Switch is in the ON position, then proceed to the next solution.
  • If the Aftertreatment DPF Permit Switch is not in the ON position, then proceed to the Repair section.
  • If there is not an Aftertreatment DPF Permit Switch on the dash, then an incorrect parameter setting has been determined. Proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Turn the Aftertreatment DPF Permit Switch Status to the ON position.
  • Adjust the features and parameters to the correct settings.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Perform the aftertreatment stationary regeneration.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2789 | SPN: 110 | FMI: 18
Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Coolant temperature sensor resistance check
  2. Fan clutch operates incorrectly
  3. Thermostat is malfunctioning
  4. Out-of-chassis opening temperature test
  5. Radiator shutters malfunctioning (if equipped)
  6. Excessive coolant flow through OEM plumbing and heater cores
  7. ECM calibration revision history check

1 - Coolant temperature sensor resistance check

Solution: S00000127

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and engine coolant temperature sensor RETURN pin at the engine coolant temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the resistance is not within the following specification: 180 - 160k Ω

Linked Solutions

  • None

Repair

  • Replace the coolant temperature sensor.

Refer to Procedure 019-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Fan clutch operates incorrectly

Solution: S00006090

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the adjustable parameters settings.

Ensure the following adjustable parameters are set correctly for the application:

  • Fan Control Logic.
  • Fan Control Switch.
  • Air Conditioner Pressure Switch Input.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Fan Override Test.
  • Verify that the fan operates correctly.
  • Verify the fan is engaging at the correct engine temperature.

Refer to Procedure 008-027

Refer to OEM Service Manual

Specification

  • If the fan does not engage at the correct engine temperature, then a malfunctioning fan clutch has been detected.

Linked Solutions

  • None

Repair

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to Procedure 008-027

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Thermostat is malfunctioning

Solution: S00000785

Verification

Conditions

  • Engine running.

Action

  • Allow the engine to reach operating temperature.
  • Check the thermostat opening temperature with an infrared temperature gun.
  • Check the coolant thermostat for proper operation.

Refer to Procedure 008-013

  • Check for a damaged or leaking thermostat seal.

Refer to Procedure 008-013

  • If a temperature gun is not available or if the temperature gun reading is above the correct thermostat opening temperature, then proceed to Linked Solutions section.

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • Out-of-chassis opening temperature test

Refer to S00001359

Repair

  • Replace the engine coolant thermostat.

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3.1 - Out-of-chassis opening temperature test

Solution: S00001359

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the out-of-chassis opening temperature test.

Refer to Procedure 008-013

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine coolant thermostat.

Refer to Procedure 008-013

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Radiator shutters malfunctioning (if equipped)

Solution: S00003116

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check for closed cold weather radiator cover or winterfront.

Refer to Procedure 008-049

Specification

  • If the radiator shutters do not operate according to the specification, then a malfunctioning radiator shutter assembly has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace cold weather radiator cover or winterfront.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Excessive coolant flow through OEM plumbing and heater cores

Solution: S00002161

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the OEM installed cooling system components.

Specification

  • If OEM installed cooling system components do not meet specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2881 | SPN: 3480 | FMI: 17
Aftertreatment Fuel Pressure Sensor - Data Valid But Below Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment fuel system leak check
  3. Debris in the aftertreatment fuel shutoff manifold or supply lines

1 - Check for primary fault codes

Solution: S00000221

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment fuel: 1923, 1924, 1925, 1926, 1927, 1928, 1932, 1963, 1977, 3223, 3224, 3225.
  • Fuel: 559, 2372

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment fuel system leak check

Solution: S00002823

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the aftertreatment fuel injector.

Refer to Procedure 011-042

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Start the engine.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Fuel Injector Leak Test.
  • Visually inspect the aftertreatment fuel system for external fuel leaks.

Specification

  • If there are any leaks found in the aftertreatment fuel system, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean or replace the aftertreatment fuel injector.

Refer to Procedure 011-042

  • Replace aftertreatment fuel shutoff valve.

Refer to Procedure 011-045

  • Replace aftertreatment fuel drain valve.

Refer to Procedure 011-045

  • Replace the aftertreatment fuel supply line.

Refer to Procedure 011-051

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Debris in the aftertreatment fuel shutoff manifold or supply lines

Solution: S00002871

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the aftertreatment fuel shutoff manifold.

Refer to Procedure 011-052

  • Remove the aftertreatment fuel supply line between the fuel rifle and the aftertreatment fuel shutoff manifold.

Refer to Procedure 011-051

  • Visually inspect the aftertreatment fuel shutoff manifold inlet, outlet and fuel drain ports for debris.
  • Visually inspect the aftertreatment fuel supply line for plugging or restrictions.
  • Visually inspect the fuel rifle port for plugging or restrictions.

Specification

  • If debris is found in the aftertreatment fuel shutoff manifold, then proceed to the Repair section.
  • If debris is found in the aftertreatment fuel supply line, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean or replace the aftertreatment fuel shutoff manifold.

Refer to Procedure 011-052

  • Replace the aftertreatment fuel supply line.

Refer to Procedure 011-051

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2961 | SPN: 412 | FMI: 15
Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. EGR temperature sensor stuck in-range
  3. Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test
  4. EGR valve is leaking internally
  5. ECM calibration revision history check
  6. EGR cooler plugged or restricted

1 - Check for primary fault codes

Solution: S00000223

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • EGR: 1899
  • EGR differential pressure: 2359

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - EGR temperature sensor stuck in-range

Solution: S00000341

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the EGR temperature sensor.
  • Compare to the local ambient air temperature.

Specification

  • A malfunctioning EGR temperature sensor has been detected if the reading is not within the following specification of the local ambient temperature reading: 10C [18F]

Linked Solutions

  • None

Repair

  • Replace EGR temperature sensor.

Refer to Procedure 019-378

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test

Solution: S00003823

Verification

Conditions

  • Reconnect previously disconnected components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test.

Refer to Procedure 014-027

  • Verify the recommended Cummins® electronic service tool or equivalent has a version that supports this test.

Refer to Procedure 014-027

Specification

  • If the Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test does not pass, then reset the search to Aftertreatment Diesel Particulate Filter Regeneration Analyzer Did Not Pass. Only select the solution title that matches the error messages in the recommend Cummins® electronic service tool or equivalent.
  • If the Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test will not start, then reset the search to Aftertreatment Diesel Particulate Filter Regeneration Analyzer Did Not Start.
  • If the Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test does not complete, then reset the search to Aftertreatment Diesel Particulate Filter Regeneration Analyzer Did Not Complete.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4 - EGR valve is leaking internally

Solution: S00000348

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the Aftertreatment Diesel Particulate Filter regeneration test.
  • Allow the stationary regeneration test to run a minimum of 5 minutes.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the EGR Differential Pressure.

Specification

  • A malfunctioning EGR valve has been detected if the EGR Differential Pressure is greater than the follwing: 1.7 kPa [0.5 inHg]

Linked Solutions

  • None

Repair

  • Replace the EGR valve.

Refer to Procedure 011-022

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - EGR cooler plugged or restricted

Solution: S00001029

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning EGR cooler has been detected.

Linked Solutions

  • None

Repair

  • Replace the EGR cooler.

Refer to Procedure 011-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2962 | SPN: 412 | FMI: 16
Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. EGR temperature sensor stuck in-range
  2. Damaged or missing aftertreatment DPF differential pressure sensor tubes
  3. Leaks in the intake air system
  4. Charge air cooler system leak
  5. EGR valve is leaking internally
  6. ECM calibration revision history check
  7. EGR cooler plugged or restricted

1 - EGR temperature sensor stuck in-range

Solution: S00000341

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the EGR temperature sensor.
  • Compare to the local ambient air temperature.

Specification

  • A malfunctioning EGR temperature sensor has been detected if the reading is not within the following specification of the local ambient temperature reading: 10C [18F]

Linked Solutions

  • None

Repair

  • Replace EGR temperature sensor.

Refer to Procedure 019-378

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Damaged or missing aftertreatment DPF differential pressure sensor tubes

Solution: S00001010

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the aftertreatment differential pressure tubes for proper installation.
  • Inspect the aftertreatment DPF differential pressure sensor tubes for signs of damage, plugging, kinks, leakage or loose connections.

Refer to Procedure 011-047

In extreme cold ambient temperatures it is important to check for a frozen, plugged, or restricted aftertreatment DPF differential pressure sensor tubes. Ice can form in the aftertreatment DPF differential pressure sensor tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Specification

  • If damage, kinks or blockages are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace DPF differential pressure sensor tubes.

Refer to Procedure 011-047

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

3 - Leaks in the intake air system

Solution: S00008386

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.
  • Visually inspect the intake plumbing for possible air leaks.

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Charge air cooler system leak

Solution: S00008815

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the charge air cooler hoses for possible air leaks.
  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If a leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the charge air cooler.

Refer to Procedure 010-027

  • Repair or replace the charge air cooler hoses.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - EGR valve is leaking internally

Solution: S00000348

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the Aftertreatment Diesel Particulate Filter regeneration test.
  • Allow the stationary regeneration test to run a minimum of 5 minutes.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the EGR Differential Pressure.

Specification

  • A malfunctioning EGR valve has been detected if the EGR Differential Pressure is greater than the follwing: 1.7 kPa [0.5 inHg]

Linked Solutions

  • None

Repair

  • Replace the EGR valve.

Refer to Procedure 011-022

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - EGR cooler plugged or restricted

Solution: S00001029

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning EGR cooler has been detected.

Linked Solutions

  • None

Repair

  • Replace the EGR cooler.

Refer to Procedure 011-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2963 | SPN: 110 | FMI: 15
Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Coolant level check
  2. Cooling fan component inspection
  3. Radiator is externally obstructed
  4. Radiator shutters malfunctioning (if equipped)
  5. Coolant temperature sensor resistance check
  6. Fan clutch operates incorrectly
  7. Thermostat is malfunctioning
  8. Out-of-chassis opening temperature test
  9. Combustion gases entering the cooling system
  10. ECM calibration revision history check

1 - Coolant level check

Solution: S00003142

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the coolant level.
  • Perform the Coolant System Pressure Test.

Refer to Procedure 008-018

  • Visually inspect for external coolant leaks.

Specification

  • If the coolant level is low and there are signs of external coolant leaks, then reset the search to external coolant leak.
  • If the coolant level is low and there are no signs of external coolant leaks, then reset the search to internal coolant leak.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2 - Cooling fan component inspection

Solution: S00001686

Verification

Conditions

  • Turn keyswitch OFF.

Action

Inspect the following components if applicable:

  • Visually inspect the cooling fan and cooling fan blades.
  • Visually inspect the cooling fan shroud.
  • Visually inspect the recirculation baffles.
  • Inspect the cooling fan belt.

Refer to Procedure 008-002

  • Visually inspect the cooling fan hub assembly.
  • Visually inspect the automatic cooling fan belt tensioner.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Radiator is externally obstructed

Solution: S00000485

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the radiator for damage.
  • Visually inspect the radiator for any type of external obstruction.
  • Check for closed cold weather radiator cover or winterfront.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the restricted radiator.

Refer to OEM Service Manual

  • Remove the obstruction.

Refer to OEM Service Manual

  • Repair or replace cold weather radiator cover or winterfront.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Radiator shutters malfunctioning (if equipped)

Solution: S00000484

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Manually operate the radiator shutters.

Refer to OEM Service Manual

  • Check the shutterstat setting.

Refer to OEM Service Manual

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning radiator shutters or shutterstat.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Coolant temperature sensor resistance check

Solution: S00000127

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and engine coolant temperature sensor RETURN pin at the engine coolant temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the resistance is not within the following specification: 180 - 160k Ω

Linked Solutions

  • None

Repair

  • Replace the coolant temperature sensor.

Refer to Procedure 019-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Fan clutch operates incorrectly

Solution: S00006090

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the adjustable parameters settings.

Ensure the following adjustable parameters are set correctly for the application:

  • Fan Control Logic.
  • Fan Control Switch.
  • Air Conditioner Pressure Switch Input.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Fan Override Test.
  • Verify that the fan operates correctly.
  • Verify the fan is engaging at the correct engine temperature.

Refer to Procedure 008-027

Refer to OEM Service Manual

Specification

  • If the fan does not engage at the correct engine temperature, then a malfunctioning fan clutch has been detected.

Linked Solutions

  • None

Repair

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to Procedure 008-027

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Thermostat is malfunctioning

Solution: S00000785

Verification

Conditions

  • Engine running.

Action

  • Allow the engine to reach operating temperature.
  • Check the thermostat opening temperature with an infrared temperature gun.
  • Check the coolant thermostat for proper operation.

Refer to Procedure 008-013

  • Check for a damaged or leaking thermostat seal.

Refer to Procedure 008-013

  • If a temperature gun is not available or if the temperature gun reading is above the correct thermostat opening temperature, then proceed to Linked Solutions section.

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • Out-of-chassis opening temperature test

Refer to S00001359

Repair

  • Replace the engine coolant thermostat.

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7.1 - Out-of-chassis opening temperature test

Solution: S00001359

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the out-of-chassis opening temperature test.

Refer to Procedure 008-013

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine coolant thermostat.

Refer to Procedure 008-013

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

8 - Combustion gases entering the cooling system

Solution: S00000470

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check for air or combustion gases in the cooling system.

Refer to Procedure 008-019

Specification

  • If air bubbles are found during the combustion gas test and did not change colors (Blue to Yellow or Green), then a malfunctioning air compressor has been determined.
  • If the combustion gas test changed colors (Blue to Yellow or Green), then a malfunctioning engine cylinder head gasket has been determined.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the air compressor cylinder head.

Refer to Procedure 012-007

  • Replace the cylinder head gasket.

Refer to Procedure 002-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2964 | SPN: 105 | FMI: 15
Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. High intake manifold temperature basic checks
  2. Fan clutch operates incorrectly
  3. Intake manifold temperature sensor stuck in-range
  4. EGR cooler plugged or restricted
  5. Malfunctioning cooling fan drive or cooling fan controls
  6. Overhead component damaged or out of adjustment

1 - High intake manifold temperature basic checks

Solution: S00000459

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Refer to Procedure 010-031

  • Visually inspect the charge-air cooler for damage or debris blocking the air flow.

Refer to Procedure 010-027

  • Visually inspect the air conditioner condenser.

Refer to OEM Service Manual

  • Visually inspect the radiator fins for damage or debris blocking the air flow.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Fan clutch operates incorrectly

Solution: S00006090

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the adjustable parameters settings.

Ensure the following adjustable parameters are set correctly for the application:

  • Fan Control Logic.
  • Fan Control Switch.
  • Air Conditioner Pressure Switch Input.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Fan Override Test.
  • Verify that the fan operates correctly.
  • Verify the fan is engaging at the correct engine temperature.

Refer to Procedure 008-027

Refer to OEM Service Manual

Specification

  • If the fan does not engage at the correct engine temperature, then a malfunctioning fan clutch has been detected.

Linked Solutions

  • None

Repair

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to Procedure 008-027

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Intake manifold temperature sensor stuck in-range

Solution: S00000334

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the intake manifold temperature sensor reading to an infrared thermometer or a known value.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the known value must be within: +/- 10C [18F]

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - EGR cooler plugged or restricted

Solution: S00001116

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the EGR cooler.

Refer to Procedure 011-019

  • Service Bulletin is available.

Refer to Service Bulletin 2883594

Specification

  • If the EGR cooler is restricted, then clear the restriction from the EGR cooler.
  • If the EGR cooler restriction cannot be cleared, then a malfunctioning EGR cooler has been detected.

Linked Solutions

  • None

Repair

  • Clean and reinstall or replace the EGR Cooler.

Refer to Procedure 011-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Malfunctioning cooling fan drive or cooling fan controls

Solution: S00000490

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Monitor the cooling fan operation.

Refer to Procedure 008-027

Specification

  • If the cooling fan operation is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.
  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Overhead component damaged or out of adjustment

Solution: S00005074

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.
  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Adjust the overhead.

Refer to Procedure 003-004

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 08-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2973 | SPN: 102 | FMI: 2
Intake Manifold 1 Pressure - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Restricted intake air filter
  3. Barometric air pressure sensor stuck in-range
  4. Exhaust gas pressure sensor stuck in-range
  5. Plugged or damaged exhaust gas pressure sensor tube
  6. Exhaust gas pressure sensor stuck in-range
  7. Intake manifold pressure sensor has carbon buildup
  8. Intake manifold pressure sensor stuck in-range
  9. Turbocharger speed sensor resistance check
  10. Leaks in the intake air system
  11. Charge air cooler system leak
  12. Turbocharger is malfunctioning
  13. ECM calibration revision history check
  14. Intake manifold pressure sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000228

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold: 122, 123
  • Intake throttle: 175, 176, 3539, 3541
  • Barometric pressure: 221, 222, 295
  • Turbocharger: 595, 687, 691, 692, 693

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Restricted intake air filter

Solution: S00000025

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Specification

  • If the intake air filter is plugged, then a restricted intake air filter has been detected.

Linked Solutions

  • None

Repair

  • Replace the air filter.

Refer to OEM Service Manual

Refer to Procedure 010-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Barometric air pressure sensor stuck in-range

Solution: S00005632

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the barometric air pressure sensor

Specification

  • A malfunctioning barometric air pressure sensor has been detected if the barometric air pressure sensor is not within the following specification of local ambient air pressure: 51 mm HG [2 in HG]

Linked Solutions

  • None

Repair

  • Replace barometric air pressure sensor.

Refer to Procedure 019-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Exhaust gas pressure sensor stuck in-range

Solution: S00000733

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Refer to Procedure 019-361

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the exhaust gas pressure sensor reading to the barometric pressure.

Specification

  • Proceed to the Linked Solution section if the exhaust gas pressure is not within the following specification of the barometric pressure: 76 mm Hg [3 in Hg]

Linked Solutions

  • Plugged or damaged exhaust gas pressure sensor tube

Refer to S00001370

  • Exhaust gas pressure sensor stuck in-range

Refer to S00000734

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Plugged or damaged exhaust gas pressure sensor tube

Solution: S00001370

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

  • Inspect the exhaust gas pressure sensor tube for cracks and thread damage.

Refer to Procedure 011-027

  • Inspect the inside of the tube and sensor adapter for debris or soot buildup.

Refer to Procedure 011-027

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.2 - Exhaust gas pressure sensor stuck in-range

Solution: S00000734

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Reconnect the sensor.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the exhaust gas pressure sensor reading to the barometric pressure.

Specification

  • A malfunctioning exhaust gas pressure sensor has been detected if the exhaust gas pressure is not within the following specification of the barometric pressure sensor: 76 mm Hg [3 in Hg]

Linked Solutions

  • None

Repair

  • Replace exhaust gas pressure sensor.

Refer to Procedure 019-376

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Intake manifold pressure sensor has carbon buildup

Solution: S00006329

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

  • Visually inspect the intake manifold pressure/temperature sensor tip for soot or carbon buildup.
  • Visually inspect the intake manifold pressure sensor for damage.
  • Visually inspect the intake manifold pressure sensor o-rings for damage.

Specification

  • If any carbon buildup is found, then proceed to the Repair section.
  • If nicks or cuts in or on the o-ring are identified, then a damaged intake manifold pressure/temperature sensor o-ring has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

  • Replace the intake manifold pressure/temperature sensor o-ring.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Intake manifold pressure sensor stuck in-range

Solution: S00002814

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the intake manifold pressure sensor.

Specification

  • A malfunctioning intake manifold air pressure sensor has been detected if the intake manifold air pressure is not reading within the following specification: 0 ± 6.8 Kpa [0 ± 1 psi], 0 ± 51 mm-Hg [0 ± 2 in- Hg]

Linked Solutions

  • None

Repair

  • Replace the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Turbocharger speed sensor resistance check

Solution: S00002828

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the turbocharger speed sensor SUPPLY pin and the turbocharger speed sensor RETURN pin at the sensor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Repair section if the resistance is not within the following specification: 600 - 1600 Ω

Linked Solutions

  • None

Repair

  • Replace turbocharger speed sensor.

Refer to Procedure 019-390

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Leaks in the intake air system

Solution: S00008386

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.
  • Visually inspect the intake plumbing for possible air leaks.

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Charge air cooler system leak

Solution: S00008815

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the charge air cooler hoses for possible air leaks.
  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If a leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the charge air cooler.

Refer to Procedure 010-027

  • Repair or replace the charge air cooler hoses.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - Turbocharger is malfunctioning

Solution: S00005253

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the intake and exhaust connections from the turbocharger.

Action

  • Inspect the turbocharger compressor and turbine blades for damage or wear.

Refer to Procedure 010-033

Specification

  • If any of the checks are not within specification, then a malfunctioning turbocharger has been detected.

Linked Solutions

  • None

Repair

  • Replace the turbocharger.

Refer to Procedure 010-033

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

11 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

12 - Intake manifold pressure sensor is malfunctioning

Solution: S00001048

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning intake manifold pressure/temperature sensor has been detected.

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 2976 | SPN: 3361 | FMI: 2
Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Temperature - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid dosing unit connector is malfunctioning
  2. Aftertreatment diesel exhaust fluid dosing unit harness open circuit check
  3. Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

1 - Aftertreatment diesel exhaust fluid dosing unit connector is malfunctioning

Solution: S00003209

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.
  • Inspect all connections for corrosion or loose connections.

Specification

  • If the aftertreatment diesel exhaust fluid dosing unit connector or the aftertreatment diesel exhaust fluid dosing unit wiring harness connector show signs of diesel exhaust fluid, then a malfunctioning aftertreatment diesel exhaust fluid dosing unit connector has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

  • Repair or replace the OEM wiring harness.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid dosing unit harness open circuit check

Solution: S00002911

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit temperature SIGNAL pin at the aftertreatment diesel exhaust fluid dosing unit wiring harness connector and the aftertreatment diesel exhaust fluid dosing unit temperature SIGNAL pin in the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit RETURN pin at the aftertreatment diesel exhaust fluid dosing unit wiring harness connector and the aftertreatment diesel exhaust fluid dosing unit RETURN pin in the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

Solution: S00001431

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid dosing unit has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3133 | SPN: 3610 | FMI: 3
Aftertreatment 1 Diesel Particulate Filter Outlet Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment DPF outlet pressure sensor voltage check
  3. Aftertreatment DPF outlet pressure sensor circuit check
  4. Aftertreatment DPF outlet pressure sensor circuit response
  5. Aftertreatment DPF differential pressure sensor open circuit check
  6. Aftertreatment DPF outlet pressure sensor open circuit check
  7. Aftertreatment DPF differential pressure sensor wire pin to pin short circuit check
  8. Aftertreatment diesel particulate filter outlet pressure sensor pin shorted to another pin
  9. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000229

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1695, 1696

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment DPF outlet pressure sensor voltage check

Solution: S00001104

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF outlet pressure sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment DPF differential/outlet pressure sensor SUPPLY pin and the aftertreatment DPF differential/outlet pressure sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 VDC - 5.25 VDC

Linked Solutions

  • Aftertreatment DPF outlet pressure sensor circuit check

Refer to S00001103

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Aftertreatment DPF outlet pressure sensor circuit check

Solution: S00001103

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF outlet pressure sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment DPF outlet pressure sensor SUPPLY pin and the OEM wiring harness aftertreatment DPF outlet pressure sensor connector SUPPLY pin.
  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment DPF outlet pressure sensor RETURN pin and the OEM wiring harness aftertreatment DPF outlet pressure sensor connector RETURN pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Aftertreatment DPF outlet pressure sensor circuit response

Solution: S00000349

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential/outlet pressure sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning aftertreatment DPF outlet pressure sensor has been detected if the following fault code became active with the sensor disconnected: 3134

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF differential/outlet pressure sensor.

Refer to Procedure 019-443

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment DPF differential pressure sensor open circuit check

Solution: S00000984

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment DPF differential pressure sensor RETURN pin and the OEM wiring harness aftertreatment DPF differential pressure sensor connector RETURN pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment DPF outlet pressure sensor open circuit check

Solution: S00001555

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment DPF outlet pressure sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment DPF outlet pressure sensor SUPPLY pin and the OEM wiring harness aftertreatment DPF outlet pressure sensor connector SUPPLY pin.
  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment DPF outlet pressure sensor SIGNAL pin and the OEM wiring harness aftertreatment DPF outlet pressure sensor connector SIGNAL pin.
  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment DPF outlet pressure sensor RETURN pin and the OEM wiring harness aftertreatment DPF outlet pressure sensor connector RETURN pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment DPF differential pressure sensor wire pin to pin short circuit check

Solution: S00007439

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the remote accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the fuel level sensor from the OEM wiring harness.
  • Disconnect the fan speed sensor from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM wiring harness.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SIGNAL pin in the OEM wiring harness ECM connector and all other pins in the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment DPF differential pressure sensor SUPPLY pin in the OEM wiring harness ECM connector and all other pins in the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Aftertreatment diesel particulate filter outlet pressure sensor pin shorted to another pin

Solution: S00001585

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment DPF outlet pressure sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF outlet pressure sensor SIGNAL pin in the OEM wiring harness ECM connector and all other pins in the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification:

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3134 | SPN: 3610 | FMI: 4
Aftertreatment 1 Diesel Particulate Filter Outlet Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment DPF outlet pressure sensor voltage check
  3. Aftertreatment DPF outlet pressure sensor circuit check
  4. Aftertreatment DPF outlet pressure sensor circuit response
  5. Aftertreatment DPF outlet pressure sensor open circuit check
  6. Aftertreatment DPF outlet pressure circuit pin to ground short

1 - Check for primary fault codes

Solution: S00000231

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1695, 1696

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment DPF outlet pressure sensor voltage check

Solution: S00001104

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF outlet pressure sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment DPF differential/outlet pressure sensor SUPPLY pin and the aftertreatment DPF differential/outlet pressure sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 VDC - 5.25 VDC

Linked Solutions

  • Aftertreatment DPF outlet pressure sensor circuit check

Refer to S00001103

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Aftertreatment DPF outlet pressure sensor circuit check

Solution: S00001103

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF outlet pressure sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment DPF outlet pressure sensor SUPPLY pin and the OEM wiring harness aftertreatment DPF outlet pressure sensor connector SUPPLY pin.
  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment DPF outlet pressure sensor RETURN pin and the OEM wiring harness aftertreatment DPF outlet pressure sensor connector RETURN pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Aftertreatment DPF outlet pressure sensor circuit response

Solution: S00000347

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF outlet pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the aftertreatment DPF outlet pressure sensor SUPPLY pin and the aftertreatment DPF outlet pressure sensor SIGNAL pin at the aftertreatment DPF outlet pressure sensor connector of the OEM wiring harness.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning aftertreatment DPF outlet pressure sensor has been detected if the following fault code became active with the jumper wire in place: 3133

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF differential/outlet pressure sensor.

Refer to Procedure 019-443

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment DPF outlet pressure sensor open circuit check

Solution: S00001555

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment DPF outlet pressure sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment DPF outlet pressure sensor SUPPLY pin and the OEM wiring harness aftertreatment DPF outlet pressure sensor connector SUPPLY pin.
  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment DPF outlet pressure sensor SIGNAL pin and the OEM wiring harness aftertreatment DPF outlet pressure sensor connector SIGNAL pin.
  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment DPF outlet pressure sensor RETURN pin and the OEM wiring harness aftertreatment DPF outlet pressure sensor connector RETURN pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment DPF outlet pressure circuit pin to ground short

Solution: S00002790

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential/outlet pressure sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF outlet pressure sensor SIGNAL pin in the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3135 | SPN: 3610 | FMI: 2
Aftertreatment 1 Diesel Particulate Filter Outlet Pressure - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Damaged or missing aftertreatment DPF differential pressure sensor tubes
  3. Aftertreatment DPF outlet pressure sensor voltage check
  4. Aftertreatment DPF outlet pressure sensor circuit check
  5. Aftertreatment DPF differential pressure sensor tubes plugged
  6. Aftertreatment DPF differential pressure sensor stuck in-range
  7. Aftertreatment DPF outlet pressure sensor open circuit check
  8. Deposits in the SCR decomposition tube
  9. Leaks in the aftertreatment diesel exhaust fluid dosing system
  10. Aftertreatment DPF outlet pressure circuit pin to ground short
  11. High exhaust restriction
  12. ECM calibration revision history check
  13. Aftertreatment DPF differential pressure sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000232

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment DPF: 3133, 3134

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Damaged or missing aftertreatment DPF differential pressure sensor tubes

Solution: S00001010

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the aftertreatment differential pressure tubes for proper installation.
  • Inspect the aftertreatment DPF differential pressure sensor tubes for signs of damage, plugging, kinks, leakage or loose connections.

Refer to Procedure 011-047

In extreme cold ambient temperatures it is important to check for a frozen, plugged, or restricted aftertreatment DPF differential pressure sensor tubes. Ice can form in the aftertreatment DPF differential pressure sensor tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Specification

  • If damage, kinks or blockages are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace DPF differential pressure sensor tubes.

Refer to Procedure 011-047

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

3 - Aftertreatment DPF outlet pressure sensor voltage check

Solution: S00001104

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF outlet pressure sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment DPF differential/outlet pressure sensor SUPPLY pin and the aftertreatment DPF differential/outlet pressure sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 VDC - 5.25 VDC

Linked Solutions

  • Aftertreatment DPF outlet pressure sensor circuit check

Refer to S00001103

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3.1 - Aftertreatment DPF outlet pressure sensor circuit check

Solution: S00001103

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF outlet pressure sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment DPF outlet pressure sensor SUPPLY pin and the OEM wiring harness aftertreatment DPF outlet pressure sensor connector SUPPLY pin.
  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment DPF outlet pressure sensor RETURN pin and the OEM wiring harness aftertreatment DPF outlet pressure sensor connector RETURN pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Aftertreatment DPF differential pressure sensor tubes plugged

Solution: S00001183

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment DPF differential pressure sensor tubes for signs of damage, plugging, kinks, leakage or loose connections.

Refer to Procedure 011-047

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace DPF differential pressure sensor tubes.

Refer to Procedure 011-047

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment DPF differential pressure sensor stuck in-range

Solution: S00000793

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the aftertreatment DPF differential pressure sensor voltage.

Refer to Procedure 019-443

Specification

  • If the aftertreatment DPF differential pressure sensor voltage readings are not within specification, then a malfunctioning aftertreatment DPF differential pressure sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment DPF outlet pressure sensor open circuit check

Solution: S00003179

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment DPF differential/outlet pressure sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment DPF outlet pressure sensor SIGNAL pin and the OEM wiring harness aftertreatment DPF outlet pressure sensor connector SIGNAL pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Troubleshoot each harness connected in series to determine which contains the open circuit.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Deposits in the SCR decomposition tube

Solution: S00000564

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the aftertreatment decomposition tube from the vehicle.

Refer to Procedure 011-062

  • Visually inspect the decomposition tube for deposits.

Refer to Procedure 011-062

Specification

  • If any excessive aftertreatment diesel exhaust fluid deposits were found inside the decomposition tube, then a plugged or restricted aftertreatment decomposition tube has been detected.
  • Proceed to Linked Solutions section for additional checks.

Linked Solutions

  • Leaks in the aftertreatment diesel exhaust fluid dosing system

Refer to S00000735

Repair

  • Clean and install the decomposition tube.

Refer to Procedure 011-062

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7.1 - Leaks in the aftertreatment diesel exhaust fluid dosing system

Solution: S00000735

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank if they have been previously disconnected during troubleshooting.

Action

  • Remove the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-080

Specification

  • If a line, fitting, connection, or dosing unit is leaking, then a malfunction has been detected in the aftertreatment diesel exhaust fluid system or dosing unit.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to Procedure 011-059

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

8 - Aftertreatment DPF outlet pressure circuit pin to ground short

Solution: S00002790

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential/outlet pressure sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF outlet pressure sensor SIGNAL pin in the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - High exhaust restriction

Solution: S00002649

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the exhaust restriction.

Refer to Procedure 011-009

Specification

  • If the exhaust restriction is not within specification, then a restriction in the exhaust has been detected.

Refer to Procedure 018-020

Linked Solutions

  • None

Repair

  • Repair the source of the exhaust restriction.

Repair or replace only the components that were found to be out of specification.

  • Check the face of the aftertreatment diesel oxidation catalyst for plugging.

Refer to Procedure 011-049

  • Check the face of the aftertreatment diesel particulate filter for plugging.

Refer to Procedure 011-041

  • Check for deposits in the decomposition tube.

Refer to Procedure 011-062

  • Check the face of the aftertreatment SCR catalyst for plugging.

Refer to Procedure 011-036

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

11 - Aftertreatment DPF differential pressure sensor is malfunctioning

Solution: S00002710

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all preceding solution verifications have been performed, then a malfunctioning aftertreatment DPF differential pressure sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3136 | SPN: 5019 | FMI: 3
Engine Exhaust Gas Recirculation Outlet Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. EGR outlet pressure sensor voltage check
  2. EGR outlet pressure sensor voltage check at the ECM
  3. EGR orifice pressure sensor circuit response
  4. EGR orifice pressure sensor circuit response at the ECM

1 - EGR outlet pressure sensor voltage check

Solution: S00003033

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR outlet pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the EGR outlet pressure sensor SUPPLY pin and the EGR outlet pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • EGR outlet pressure sensor voltage check at ECM

Refer to S00003034

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

1.1 - EGR outlet pressure sensor voltage check at the ECM

Solution: S00003034

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Disconnect the engine wiring harness from the ECM.
  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the EGR outlet pressure sensor SUPPLY pin and the EGR outlet pressure sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning OEM wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • None
Parent Solution

2 - EGR orifice pressure sensor circuit response

Solution: S00000363

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR orifice pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning EGR orifice pressure sensor has been detected if the following fault code became active with the sensor disconnected: 3137

Linked Solutions

  • None

Repair

  • Replace EGR orifice pressure sensor.

Refer to Procedure 019-461

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - EGR orifice pressure sensor circuit response at the ECM

Solution: S00000390

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If Fault Code 3137 became active with the engine wiring harness disconnected from ECM, then a malfunctioning engine wiring harness has been detected.
  • If Fault Code 3137 does not become active with the engine wiring harness disconnected from ECM, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3137 | SPN: 5019 | FMI: 4
Engine Exhaust Gas Recirculation Outlet Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. EGR outlet pressure sensor voltage check
  3. EGR outlet pressure sensor voltage check at the ECM

1 - Check for primary fault codes

Solution: S00000062

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352
  • Sensor supply 2: 187

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - EGR outlet pressure sensor voltage check

Solution: S00003033

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR outlet pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the EGR outlet pressure sensor SUPPLY pin and the EGR outlet pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • EGR outlet pressure sensor voltage check at ECM

Refer to S00003034

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - EGR outlet pressure sensor voltage check at the ECM

Solution: S00003034

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Disconnect the engine wiring harness from the ECM.
  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the EGR outlet pressure sensor SUPPLY pin and the EGR outlet pressure sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning OEM wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • None
Parent Solution

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3138 | SPN: 5019 | FMI: 2
Engine Exhaust Gas Recirculation Outlet Pressure - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. EGR mass measurement flow assembly is leaking

1 - Check for primary fault codes

Solution: S00000235

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • EGR: 3136, 3137

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - EGR mass measurement flow assembly is leaking

Solution: S00003269

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the EGR mass measurement flow assembly.

Refer to Procedure 011-066

  • Inspect the EGR mass measurement flow assembly for damage or debris.

Refer to Procedure 011-066

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Remove and clean the EGR mass measurement flow assembly.

Refer to Procedure 011-066

  • Replace the EGR mass measurement flow assembly.

Refer to Procedure 011-066

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3139 | SPN: 3667 | FMI: 3
Engine Air Shutoff Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Engine air shutoff solenoid resistance check

1 - Engine air shutoff solenoid resistance check

Solution: S00003395

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine air shutoff solenoid from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine air shutoff valve solenoid SIGNAL pin and engine air shutoff valve solenoid RETURN pin at the engine air shutoff valve solenoid.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Repair section if the resistance is greater than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Replace the air shutoff valve solenoid.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 09-Jan-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3141 | SPN: 3667 | FMI: 4
Engine Air Shutoff Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Engine air shutoff solenoid resistance check

1 - Engine air shutoff solenoid resistance check

Solution: S00003419

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine air shutoff solenoid from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine air shutoff valve solenoid SIGNAL pin and engine air shutoff valve solenoid RETURN pin at the engine air shutoff valve solenoid.

Refer to OEM Service Manual

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the air shutoff valve solenoid.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 09-Jan-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3142 | SPN: 4360 | FMI: 3
Aftertreatment 1 SCR Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000236

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment SCR: 4152, 4164, 4165, 4166, 4261

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00009782

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 08-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3146 | SPN: 4363 | FMI: 3
Aftertreatment 1 SCR Outlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Technical Service Bulletin is available
  3. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000237

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment SCR: 4152, 4164, 4165, 4166, 4261

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Technical Service Bulletin is available

Solution: S00009791

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb150153

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00004310

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3147 | SPN: 4363 | FMI: 4
Aftertreatment 1 SCR Outlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000238

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment SCR: 4152, 4164, 4165, 4166, 4261

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00004310

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3148 | SPN: 4363 | FMI: 2
Aftertreatment 1 SCR Outlet Temperature Sensor - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000239

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment SCR: 4152, 4164, 4165, 4166, 4261

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00009782

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3151 | SPN: 4794 | FMI: 31
Aftertreatment 1 SCR Catalyst System Missing - Condition Exists

Troubleshooting Summary

  1. Fault Code 3151 requires that ALL solutions be performed
  2. Check for primary fault codes
  3. Aftertreatment diesel exhaust fluid is contaminated
  4. Aftertreatment exhaust system leaks
  5. Leaks in the aftertreatment diesel exhaust fluid dosing system
  6. Aftertreatment Diesel Exhaust Fluid Doser Pump Override test
  7. Aftertreatment diesel exhaust fluid dosing valve is malfunctioning
  8. Aftertreatment SCR System Test
  9. Aftertreatment diesel exhaust fluid dosing system test failed
  10. Aftertreatment intake NOx sensor failed
  11. Aftertreatment outlet NOx sensor - Inspection
  12. Inspect both aftertreatment NOx sensors
  13. Aftertreatment SCR Catalyst Test Failed
  14. ECM calibration revision history check

1 - Fault Code 3151 requires that ALL solutions be performed

Solution: S00001372

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • This solution is information only.
  • ALL solutions displayed for this fault code must be performed.
  • Continue to perform the verifications of ALL solution steps listed for this fault code regardless if a given solution is within specification or out of specification.

Specification

  • This solution is information only.

Linked Solutions

  • None

Repair

  • If a resolution is found in any solution for this fault code, continue performing ALL solutions listed for this fault code.

Validation

  • None
Next Solution

2 - Check for primary fault codes

Solution: S00000779

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment NOx: 1694, 3228, 3748, 3749
  • Aftertreatment intake oxygen: 4747, 4748
  • Aftertreatment outlet oxygen: 4749, 4751
  • Aftertreatment SCR: 3142, 3146, 3147, 3148, 3165, 4164, 4165, 4166, 4518, 4519, 4521, 4524, 4525, 5655, 6266, 6267, 6268
  • Aftertreatment diesel exhaust fluid system: 1668, 1669, 1673, 1682, 1685, 1686, 1715, 3497, 3498, 3568, 3571, 3572, 3574, 3575, 3867, 3868, 3878, 4277, 4677, 4732, 4739, 4768, 4842, 5278
  • Aftertreatment diesel exhaust fluid dosing unit: 3558, 3559
  • Ambient air temperature: 249, 256, 2398

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

3 - Aftertreatment diesel exhaust fluid is contaminated

Solution: S00000563

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Use a diesel exhaust fluid refractometer to measure the concentration of the diesel exhaust fluid in the tank.

Refer to Service Bulletin 4021566

Specification

  • If there are signs of contaminates in the aftertreatment diesel exhaust fluid, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to Procedure 011-056

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment exhaust system leaks

Solution: S00001008

Verification

Conditions

  • Engine running.

Action

  • Visually inspect for leaks in the exhaust manifold to head.

Refer to Procedure 010-024

  • Visually inspect for leaks from the turbocharger to exhaust manifold.

Refer to Procedure 010-024

  • Visually inspect for leaks in the exhaust plumbing between the turbocharger outlet and the Aftertreatment DOC intake connection.

Refer to Procedure 010-024

  • Visually inspect the exhaust piping for leaks, cracks, and loose connections.

Refer to Procedure 010-024

  • Inspect for leaks at the aftertreatment DOC housing, sensor ports and connection points.

Refer to Procedure 010-024

  • Visually inspect the aftertreatment and SCR components for exhaust leaks.

Refer to Procedure 010-024

Specification

  • If there is any damage or leaks found in the exhaust system, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the exhaust manifold.

Refer to Procedure 011-007

  • Repair or replace the exhaust plumbing.

Refer to Procedure 011-007

Refer to OEM Service Manual

  • Replace aftertreatment DOC.

Refer to Procedure 011-049

  • Replace the aftertreatment diesel particulate filter.

Refer to Procedure 011-041

  • Replace the aftertreatment SCR Catalyst.

Refer to Procedure 011-036

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Leaks in the aftertreatment diesel exhaust fluid dosing system

Solution: S00002840

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-080

  • While the test is running, inspect the diesel exhaust fluid tank connectors, diesel exhaust fluid dosing unit and dosing unit connectors, diesel exhaust fluid lines, and diesel exhaust fluid dosing valve for signs of external leaks.

Specification

  • If a line, fitting, connection, or dosing unit is leaking, then a malfunction has been detected in the aftertreatment diesel exhaust fluid system or dosing unit.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Repair or replace the leaking diesel exhaust fluid line, connector or fitting.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment Diesel Exhaust Fluid Doser Pump Override test

Solution: S00002761

Verification

Conditions

  • Reconnect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank if they have been previously disconnected during troubleshooting.

Action

  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.

Refer to Procedure 011-059

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

The Aftertreatment Diesel Exhaust Fluid Doser Pump Override test can only be ran twice before a key cycle needs to be performed.

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test meets the specification, then proceed to the next solution.
  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test does not meet the specification, then proceed to the Linked Solutions section.

Linked Solutions

Click on the link below:

  • Aftertreatment diesel exhaust fluid dosing valve is malfunctioning

Refer to S00002764

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6.1 - Aftertreatment diesel exhaust fluid dosing valve is malfunctioning

Solution: S00002764

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Clean the aftertreatment diesel exhaust fluid dosing valve.
  • Turn keyswitch ON.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

7 - Aftertreatment SCR System Test

Solution: S00000541

Verification

Conditions

  • Connect all components.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment SCR System Test.

Refer to Procedure 014-025

If the Aftertreatment SCR System Test is not available on the recommended Cummins® electronic service tool or equivalent, update to the latest ECM Calibration Revision and then perform the Aftertreatment SCR System Test.

Specification

  • If the Aftertreatment SCR System Test does not pass, then proceed to the Linked Solutions section.

If the Aftertreatment SCR System Test does not activate, then reset the Search to Aftertreatment SCR System Test does not activate.

If the Aftertreatment SCR System Test does not complete, then reset the Search to Aftertreatment SCR System Test does not complete.

If the Aftertreatment SCR System Test displays "Deposit Burn Failed", the test should keep running and no repair action is required unless a Aftertreatment Intake or Outlet NOx sensor failure is detected.

Linked Solutions

  • Aftertreatment diesel exhaust fluid dosing system test failed

Refer to S00000552

  • Aftertreatment intake NOx sensor failed

Refer to S00000867

  • Aftertreatment outlet NOx sensor - Inspection

Refer to S00000567

  • Inspect both aftertreatment NOx sensors

Refer to S00000566

  • Aftertreatment SCR catalyst test failed

Refer to S00000565

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

7.1 - Aftertreatment diesel exhaust fluid dosing system test failed

Solution: S00000552

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If there are signs of contaminates in the diesel exhaust fluid, then proceed to the Repair section.
  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump override test displays FAILED, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to OEM Service Manual

  • For a Aftertreatment Diesel Exhaust Fluid Doser Pump override test displaying FAILED, then follow the repair instructions in the procedure.

Refer to Procedure 011-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

7.2 - Aftertreatment intake NOx sensor failed

Solution: S00000867

Verification

Conditions

  • None

Action

  • Verify that the aftertreatment intake NOx sensor is displayed as FAILED.

Specification

  • If the SCR System test displays that the intake NOx sensor has FAILED, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

7.3 - Aftertreatment outlet NOx sensor - Inspection

Solution: S00000567

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the decomposition tube for deposits.

Refer to Procedure 011-062

  • Visually inspect the aftertreatment diesel exhaust fluid tank connections for cracks or pitting.

Refer to OEM Service Manual

  • Connect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank.
  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-080

  • While the test is running, inspect the diesel exhaust fluid tank connectors, diesel exhaust fluid dosing unit and dosing unit connectors, diesel exhaust fluid lines, and diesel exhaust fluid dosing valve for signs of external leaks.

Specification

  • If the aftertreatment diesel exhaust fluid dosing valve is not leaking and there are no deposits in the decomposition tube, then a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Clean and install the decomposition tube.

Refer to Procedure 011-062

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

7.4 - Inspect both aftertreatment NOx sensors

Solution: S00000566

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the decomposition tube for deposits.

Refer to Procedure 011-062

  • Visually inspect the aftertreatment diesel exhaust fluid tank connections for cracks or pitting.

Refer to OEM Service Manual

  • Connect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank.
  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-080

  • Verify proper sealing at all connection points, including diesel exhaust fluid tank, dosing unit, and dosing valve.

Specification

  • If the aftertreatment diesel exhaust fluid dosing valve is not leaking and there are no deposits in the decomposition tube, then a malfunctioning aftertreatment intake NOx sensor and a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Clean and install the decomposition tube.

Refer to Procedure 011-062

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

7.5 - Aftertreatment SCR Catalyst Test Failed

Solution: S00000565

Verification

Conditions

  • Reconnect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank if they have been previously disconnected during troubleshooting.

Action

The aftertreatment diesel exhaust fluid dosing valve must be removed and placed in a measuring container greater then 1.5 liter [50 oz] capacity to perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override test.

The Aftertreatment Diesel Exhaust Fluid Doser Pump Override test can only be ran twice before a key cycle needs to be performed.

  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is not within specification, then proceed to the Repair section.
  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is within specification, then a malfunctioning aftertreatment SCR Catalyst has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Replace the aftertreatment SCR Catalyst.

Refer to Procedure 011-036

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

8 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3165 | SPN: 4363 | FMI: 0
Aftertreatment 1 SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment fuel injector is malfunctioning
  3. Aftertreatment diesel exhaust fluid is contaminated
  4. Turbocharger exhaust is leaking oil into the aftertreatment system
  5. Aftertreatment DOC is malfunctioning
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000240

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment SCR: 4152, 4159, 4164, 4165, 4261

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment fuel injector is malfunctioning

Solution: S00003286

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the aftertreatment fuel injector.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Fuel Injector Leak Test.

Refer to Procedure 011-054

Specification

  • If the Aftertreatment Fuel Injector Leak Test does not meet specification, then a malfunctioning aftertreatment fuel injector has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment fuel injector.

Refer to Procedure 011-042

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid is contaminated

Solution: S00000563

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Use a diesel exhaust fluid refractometer to measure the concentration of the diesel exhaust fluid in the tank.

Refer to Service Bulletin 4021566

Specification

  • If there are signs of contaminates in the aftertreatment diesel exhaust fluid, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to Procedure 011-056

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Turbocharger exhaust is leaking oil into the aftertreatment system

Solution: S00000655

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the exhaust piping from the turbocharger outlet.

Action

  • Inspect for any fluids.
  • Visually inspect the turbocharger exhaust outlet for signs of oil or fuel.
  • Perform the Snap Acceleration Test - Aftertreatment Disconnected.

Refer to Procedure 014-017

Specification

  • If lubricating engine oil contamination is found in the turbocharger exhaust outlet, then reset the search to oil consumption internal.
  • If excessive black smoke is detected, then reset the search to black smoke.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

5 - Aftertreatment DOC is malfunctioning

Solution: S00005082

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect for the presence of the aftertreatment DOC.

Refer to Procedure 011-049

  • Inspect the inlet face of the aftertreatment DOC for reuse.

Refer to Procedure 011-049

Refer to Service Bulletin 4021600

  • Inspect for cracks in the aftertreatment DOC cell walls.

Refer to Service Bulletin 4021600

  • Inspect for soot or oil plugging the front face of the catalyst

Refer to Service Bulletin 4021600

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • If the face of the aftertreatment DOC is plugged, then clean the aftertreatment DOC.

Refer to Procedure 011-049

  • If the face of the aftertreatment DOC is cracked or damaged, then replace the aftertreatment DOC.

Refer to Procedure 011-049

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3167 | SPN: 3556 | FMI: 18
Aftertreatment Doser - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Technical Service Bulletin is available
  3. Aftertreatment fuel injector is malfunctioning

1 - Check for primary fault codes

Solution: S00000241

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment fuel: 1923, 1924, 1925, 1926, 1927, 1928, 1963, 2881, 3223, 3224, 3225
  • Fuel: 1932, 1977

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Technical Service Bulletin is available

Solution: S00009715

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb130159

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment fuel injector is malfunctioning

Solution: S00003043

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the Aftertreatment Maintenance Reset All procedure found under the Aftertreatment Maintenance Section of Advanced ECM Data.

Performing the Aftertreatment Maintenance Reset All may cause the fault code to go inactive. This does not mean that the issue was resolved, only that the efficiencies were reset. Troubleshooting must be continued.

  • Visually inspect for a missing poppet in the aftertreatment fuel injector.

Refer to TSB130159

  • Perform the Aftertreatment Fuel Injector Flow Test.

Refer to Procedure 011-054

Specification

  • If the Aftertreatment Fuel Injector Flow Test does not meet specification, then a malfunctioning aftertreatment fuel injector has been detected.

Linked Solutions

  • None

Repair

  • Replace the fuel injector.

Refer to Procedure 011-042

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3168 | SPN: 3936 | FMI: 16
Aftertreatment 1 Diesel Particulate Filter System - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Damaged or missing aftertreatment DPF differential pressure sensor tubes
  3. Aftertreatment DPF differential pressure sensor stuck in-range
  4. Aftertreatment DPF damaged or missing
  5. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000243

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment differential pressure: 1879, 1881, 1883, 5715

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Damaged or missing aftertreatment DPF differential pressure sensor tubes

Solution: S00001010

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the aftertreatment differential pressure tubes for proper installation.
  • Inspect the aftertreatment DPF differential pressure sensor tubes for signs of damage, plugging, kinks, leakage or loose connections.

Refer to Procedure 011-047

In extreme cold ambient temperatures it is important to check for a frozen, plugged, or restricted aftertreatment DPF differential pressure sensor tubes. Ice can form in the aftertreatment DPF differential pressure sensor tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Specification

  • If damage, kinks or blockages are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace DPF differential pressure sensor tubes.

Refer to Procedure 011-047

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

3 - Aftertreatment DPF differential pressure sensor stuck in-range

Solution: S00000793

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the aftertreatment DPF differential pressure sensor voltage.

Refer to Procedure 019-443

Specification

  • If the aftertreatment DPF differential pressure sensor voltage readings are not within specification, then a malfunctioning aftertreatment DPF differential pressure sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment DPF damaged or missing

Solution: S00001215

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the aftertreatment system to determine if the aftertreatment DPF has been tampered with or has been removed from the exhaust system.

Refer to Procedure 011-041

  • Inspect the aftertreatment DPF for cracks or other damage.

Refer to Service Bulletin 4021600

Specification

  • If the aftertreatment DPF does not meet inspection criteria, then a plugged or damaged aftertreatment DPF has been detected.

Refer to Procedure 011-041

Refer to Service Bulletin 4021600

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel particulate filter.

Refer to Procedure 011-041

  • Perform the Aftertreatment maintenance filter installation procedure.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3223 | SPN: 3490 | FMI: 4
Aftertreatment Purge Air Actuator Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Aftertreatment purge air actuator open circuit check
  2. Aftertreatment purge air actuator resistance check
  3. Aftertreatment purge air actuator circuit pin to ground short
  4. Aftertreatment purge air actuator circuit pin to ground short
  5. Aftertreatment purge air actuator pin to pin short

1 - Aftertreatment purge air actuator open circuit check

Solution: S00003193

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment purge air actuator from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment purge air actuator SIGNAL pin at the aftertreatment purge air actuator engine wiring harness connector and aftertreatment purge air actuator SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the aftertreatment purge air actuator RETURN pin at the aftertreatment purge air actuator engine wiring harness connector and aftertreatment purge air actuator RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable Fault Code
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment purge air actuator resistance check

Solution: S00000781

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment purge air actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment purge air actuator SIGNAL pin and the aftertreatment purge air actuator RETURN pin at the sensor connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360

Specification

  • If the aftertreatment purge air actuator resistance is not between 7 and 10 ohms, then a malfunctioning aftertreatment purge air actuator has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment purge air actuator.

Refer to Procedure 011-065

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable Fault Code
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment purge air actuator circuit pin to ground short

Solution: S00003191

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment purge air actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment purge air actuator SIGNAL pin at the aftertreatment purge air actuator connector and block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning purge air actuator has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Replace aftertreatment purge air actuator.

Refer to Procedure 011-065

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable Fault Code
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment purge air actuator circuit pin to ground short

Solution: S00000782

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment purge air actuator from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment purge air actuator SIGNAL pin at the aftertreatment purge air actuator engine wiring harness connector and block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable Fault Code
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment purge air actuator pin to pin short

Solution: S00003190

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment purge air actuator from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment purge air actuator SIGNAL pin at the engine wiring harness ECM connector and all other pins in the connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable Fault Code
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 12-Jul-2020


NO TITLE

ISX15 CM2350 X101

Fault Code: 3224 | SPN: 3490 | FMI: 3
Aftertreatment Purge Air Actuator Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Aftertreatment purge air actuator resistance check
  2. Aftertreatment purge air actuator circuit pin to ground short
  3. Aftertreatment purge air actuator circuit pin to ground short
  4. Aftertreatment purge air actuator pin to pin short

1 - Aftertreatment purge air actuator resistance check

Solution: S00000781

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment purge air actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment purge air actuator SIGNAL pin and the aftertreatment purge air actuator RETURN pin at the sensor connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360

Specification

  • If the aftertreatment purge air actuator resistance is not between 7 and 10 ohms, then a malfunctioning aftertreatment purge air actuator has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment purge air actuator.

Refer to Procedure 011-065

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable Fault Code
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment purge air actuator circuit pin to ground short

Solution: S00003191

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment purge air actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment purge air actuator SIGNAL pin at the aftertreatment purge air actuator connector and block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning purge air actuator has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Replace aftertreatment purge air actuator.

Refer to Procedure 011-065

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable Fault Code
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment purge air actuator circuit pin to ground short

Solution: S00000782

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment purge air actuator from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment purge air actuator SIGNAL pin at the aftertreatment purge air actuator engine wiring harness connector and block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable Fault Code
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment purge air actuator pin to pin short

Solution: S00003190

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment purge air actuator from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment purge air actuator SIGNAL pin at the engine wiring harness ECM connector and all other pins in the connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable Fault Code
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 12-Jul-2020


NO TITLE

ISX15 CM2350 X101

Fault Code: 3225 | SPN: 3490 | FMI: 7
Aftertreatment Purge Air Actuator - Mechanical System Not Responding or Out of Adjustment

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment purge air actuator is stuck open or leaking
  3. Aftertreatment purge air actuator check
  4. Aftertreatment fuel shut off valve manifold check
  5. Aftertreatment fuel shutoff manifold is malfunctioning

1 - Check for primary fault codes

Solution: S00000244

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment fuel: 1926, 1927, 1928, 3223, 3224

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment purge air actuator is stuck open or leaking

Solution: S00003178

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Drain the air supply tank.
  • Disconnect the OEM air supply line to the aftertreatment purge air actuator.

Refer to Procedure 011-065

  • Run the engine at idle for the following minutes: 5
  • Confirm air flow from OEM air supply to the aftertreatment purge air actuator.

Specification

  • If air is weak or not present, then a malfunction of the OEM air plumbing has been detected.
  • If air is present, then proceed to the Linked Solutions section.

Linked Solutions

  • Aftertreatment purge air actuator check

Refer to S00002841

  • Aftertreatment fuel shut off valve manifold check

Refer to S00002984

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM air plumbing.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable Fault Code
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Aftertreatment purge air actuator check

Solution: S00002841

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect previously disconnected components.

Refer to Procedure 011-065

  • Disconnect the air supply line from the aftertreatment fuel shutoff manifold.

Refer to Procedure 011-067

Action

  • Turn keyswitch ON.
  • Run the engine at idle for the following minutes: 5
  • Allow the air pressure to stabilize for one minute.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Select the Aftertreatment Shutoff Valve and Injector Override Test found under ECM Diagnostic Tests.
  • Perform the Aftertreatment Fuel Injector Leak Test.
  • Turn keyswitch OFF.

After turning the keyswitch OFF the aftertreatment fuel system purge cycle will begin, and air will flow from the air supply line to the aftertreatment fuel shutoff valve manifold.

Specification

  • If air is weak or not present at the air supply line to the aftertreatment fuel shutoff manifold, then a stuck closed aftertreatment purge air actuator has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment purge air actuator.

Refer to Procedure 011-065

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable Fault Code
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Aftertreatment fuel shut off valve manifold check

Solution: S00002984

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Reconnect the air supply line to the aftertreatment fuel shutoff manifold.

Refer to Procedure 011-067

  • Remove the aftertreatment fuel injector.

Refer to Procedure 011-042

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Run the engine at idle for the following minutes: 5
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Select the Aftertreatment Shutoff Valve and Injector Override Test found under ECM Diagnostic Tests.
  • Perform the Aftertreatment Fuel Injector Leak Test.
  • Turn keyswitch OFF.

After turning the keyswitch OFF the aftertreatment fuel system purge cycle will begin, and air will flow from the air supply line to the aftertreatment fuel shutoff valve manifold.

Specification

  • If air is weak or not present at the aftertreatment fuel injector, then a malfunctioning aftertreatment fuel shutoff valve manifold has been detected.

Linked Solutions

  • None

Repair

  • Clean or replace the aftertreatment fuel shutoff manifold.

Refer to Procedure 011-052

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable Fault Code
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Aftertreatment fuel shutoff manifold is malfunctioning

Solution: S00001427

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment fuel shutoff manifold has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment fuel manifold.

Refer to Procedure 011-052

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable Fault Code
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 18-Jan-2020


NO TITLE

ISX15 CM2350 X101

Fault Code: 3228 | SPN: 3216 | FMI: 2
Aftertreatment 1 Intake NOx Sensor - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Technical Service Bulletin is available
  2. Check for primary fault codes
  3. Leaks in the intake air system
  4. Charge air cooler system leak
  5. ECM calibration revision history check
  6. Aftertreatment intake NOx sensor is malfunctioning

1 - Technical Service Bulletin is available

Solution: S00008721

Verification

Conditions

  • Turn keyswitch OFF.
  • Verify OEM is Kenworth™.

Action

  • If this engine is not in a Kenworth™ application, then proceed to the next solution.
  • Technical Service Bulletin is available.

Refer to tsb160065

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Check for primary fault codes

Solution: S00000245

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment NOx: 1885, 3232, 3649, 3682, 3748

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

3 - Leaks in the intake air system

Solution: S00008386

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.
  • Visually inspect the intake plumbing for possible air leaks.

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Charge air cooler system leak

Solution: S00008815

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the charge air cooler hoses for possible air leaks.
  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If a leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the charge air cooler.

Refer to Procedure 010-027

  • Repair or replace the charge air cooler hoses.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment intake NOx sensor is malfunctioning

Solution: S00000016

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment intake NOx sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3232 | SPN: 3216 | FMI: 9
Aftertreatment 1 Intake NOx Sensor - Abnormal Update Rate

Troubleshooting Summary

  1. Check for primary fault codes
  2. Low battery voltage
  3. Battery load test
  4. Ground inspection
  5. J1939 data link engine wiring harness voltage check 3 pin service connector
  6. OEM sensor voltage check
  7. J1939 data link harness pin to ground short circuit
  8. Aftertreatment intake NOx sensor voltage check
  9. Aftertreatment intake NOx sensor circuit pin to ground short
  10. Fault Code 3232 triggered by a malfunction in the J1939 data link with multiple OEM fault codes
  11. J1939 data link terminating resistance is incorrect
  12. Variable geometry turbocharger actuator has incorrect J1939 terminating resistance
  13. Engine wiring harness has incorrect J1939 terminating resistance
  14. OEM wiring harness has incorrect J1939 terminating resistance
  15. J1939 data link harness open circuit check
  16. OEM terminating resistor Ω check for the J1939 data link
  17. Incorrect terminating resistance in the J1939 data link by a J1939 data linked component
  18. J1939 wire resistance check at the crossover connector for each component
  19. ECM calibration revision history check
  20. Aftertreatment intake NOx sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000256

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Turbocharger: 1894, 2636

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Low battery voltage

Solution: S00001110

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.
  • If this vehicle has been repaired within the last 30 days for the same fault code, then proceed to the Linked Solutions section.

Specification

  • If the battery voltage is at least 10.8 VDC (12 volt systems) or 21.6 VDC (24 volt systems), then proceed to the Linked Solutions section.
  • If the battery or battery cables show signs of corrosion or damage, then proceed to the Repair Section.

Linked Solutions

  • Battery load test

Refer to S00001379

  • Ground inspection

Refer to S00000754

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean corrosion or tighten battery cable connections.

Refer to OEM Service Manual

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Battery load test

Solution: S00001379

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Disconnect the batteries from each other.
  • Connect a load tester separately to each battery.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.

Specification

  • For a 12 volt system, proceed to the Repair section if the battery voltage is below the following specification: 11 VDC
  • For a 24 volt system, proceed to the Repair section if the battery voltage is below the following specification: 22 VDC

Linked Solutions

  • None

Repair

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Ground inspection

Solution: S00000754

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the ECM ground for damage, corrosion and loose connections.
  • Visually inspect the aftertreatment interface wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the OEM wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the grounds for proper routing.

Specification

  • If damage, corrosion or incorrect routing of grounds are found, then proceed to the Repair section

Linked Solutions

  • None

Repair

  • Clean or replace connections.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - J1939 data link engine wiring harness voltage check 3 pin service connector

Solution: S00000594

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect all SAE J1939 components.
  • Turn keyswitch ON.

Action

The service tool datalink adapter can NOT be connected to the 3-pin J1939 datalink connector during this check.

  • Measure the J1939 voltage of the J1939 (+) pin to ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

  • Measure the J1939 voltage of the J1939 (-) pin to ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

Specification

  • A malfunctioning wiring harness has been detected due to the J1939 data link circuit being shorted to a voltage source if the voltage is greater than the following specification: 4.5 VDC
  • Proceed to the Linked Solutions section if the voltage is less than the following specification: 1 VDC
  • Proceed to the next solution if the voltage is within the following specification for both the SAE J1939 data link (+) and SAE J1939 data link (-) circuit: 1 - 4.5 VDC

Linked Solutions

  • OEM J1939 data link component isolation

Refer to S00003176

  • Engine or OEM wiring harness shorted to ground

Refer to S00003331

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3.1 - OEM sensor voltage check

Solution: S00003176

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Reconnect the crossover connector.

Inspect the following components if applicable:

  • Turn keyswitch ON.
  • Measure the J1939 voltage of the SAE J1939 data link (+) and SAE data link J1939 (-) pins at the variable geometry turbocharger actuator engine wiring harness connector to battery ground while each component is disconnected one at a time.
  • Disconnect the aftertreatment outlet NOx sensor
  • Disconnect the aftertreatment DPF temperature sensor module.
  • Disconnect the aftertreatment SCR temperature sensor module.
  • Disconnect the aftertreatment intermediate NH3 sensor.
  • Disconnect the aftertreatment particulate sensor
  • Disconnect the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.
  • Disconnect the aftertreatment exhaust gas temperature sensor.
  • Disconnect the aftertreatment intake NOx sensor.

Specification

  • A malfunctioning SAE J1939 data link component has been detected if the voltage is within the following specification after the component has been disconnected: 1 - 4.5 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.

Refer to OEM Service Manual

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

  • Replace aftertreatment DPF temperature sensor module.

Refer to Procedure 019-449

  • Replace the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-449

  • Replace aftertreatment intermediate NH3 sensor.

Refer to Procedure 019-479

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.2 - J1939 data link harness pin to ground short circuit

Solution: S00003331

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Turn keyswitch ON.

Action

The service tool datalink adapter can NOT be connected to the 3-pin J1939 datalink connector during this check.

  • Measure the J1939 voltage of the J1939 (+) pin to battery ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

  • Measure the J1939 voltage of the J1939 (-) pin to battery ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

Specification

  • A malfunctioning OEM wiring harness has been detected if voltage is within the following specification with the crossover connector disconnected: 1 - 4.5 VDC
  • A malfunctioning engine wiring harness has been detected if voltage is not within the following specification with the crossover connector disconnected: 1 - 4.5 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Aftertreatment intake NOx sensor voltage check

Solution: S00000880

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake NOx sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment intake NOx sensor battery SUPPLY pin and the aftertreatment intake NOx sensor battery RETURN pin at the aftertreatment intake NOx sensor engine wiring harness connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the voltage is not within the following specification of battery voltage: 1 VDC
  • Proceed to the next solution if voltage is within the following specification of battery voltage: 1 VDC

Linked Solutions

Click on the link below:

  • Aftertreatment intake NOx sensor circuit pin to ground short

Refer to S00000881

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Aftertreatment intake NOx sensor circuit pin to ground short

Solution: S00000881

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake NOx sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.
  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment intake NOx sensor SUPPLY pin at the sensor connector of the engine wiring harness and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A short circuit has been detected if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Fault Code 3232 triggered by a malfunction in the J1939 data link with multiple OEM fault codes

Solution: S00000622

Verification

Conditions

  • Connect all components.

Action

  • Reconnect the crossover connector.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning aftertreatment intake NOx sensor has been detected, if any fault code is not active or does not have more than one inactive count within the last 25 engine hours from the following list: 1894, 2636, 2771, 3868, 3911, 4151, 4152, 4572, 4677, 6688

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - J1939 data link terminating resistance is incorrect

Solution: S00000593

Verification

Conditions

  • Turn keyswitch OFF.
  • Wait for 90 seconds.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.
  • Reconnect the variable geometry turbocharger actuator if it has been previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3-pin service data link connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Follow your technical escalation process if the resistance is within the following specification: 54 - 66 Ω
  • Proceed to the Linked Solutions section if the resistance is not within the following specification: 54 - 66 Ω

Linked Solutions

  • Variable geometry turbocharger actuator has incorrect J1939 terminating resistance

Refer to S00001242

  • Engine wiring harness has incorrect J1939 terminating resistance

Refer to S00000972

  • OEM wiring harness has incorrect J1939 terminating resistance

Refer to S00000971

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

6.1 - Variable geometry turbocharger actuator has incorrect J1939 terminating resistance

Solution: S00001242

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the variable geometry turbocharger actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the variable geometry turbocharger actuator SAE J1939 data link (+) pin and the variable geometry turbocharger actuator SAE J1939 data link (-) pin at the variable geometry turbocharger actuator.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning variable geometry turbocharger actuator has been detected if the resistance is not within the following specification: 108 Ω - 132 Ω

Linked Solutions

  • None

Repair

  • Replace the variable geometry turbocharger actuator.

Refer to Procedure 010-134

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6.2 - Engine wiring harness has incorrect J1939 terminating resistance

Solution: S00000972

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect previously disconnected components.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.
  • Disconnect the aftertreatment intake NOx sensor from the engine wiring harness.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3-pin service data link connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is not within the following specification: 108-132 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6.3 - OEM wiring harness has incorrect J1939 terminating resistance

Solution: S00000971

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if the resistance is not within the following specification: 108 - 132 Ω
  • Follow your technical escalation process if the resistance is within the following specification: 108 - 132 Ω

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Parent Solution

7 - J1939 data link harness open circuit check

Solution: S00004534

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the appropriate data link component from the data link wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the J1939 (+) pin at the appropriate component data link wiring harness connector and the appropriate data link component J1939 (+) pin at the data link wiring harness ECM connector.
  • Measure the resistance between the J1939 (-) pin at the appropriate component data link wiring harness connector and the appropriate data link component J1939 (-) pin at the data link wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning J1939 data link wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - OEM terminating resistor Ω check for the J1939 data link

Solution: S00000907

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM terminating resistor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the pins for the OEM terminating resistor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM terminating resistor has been detected if the resistance is not within the following specification: 108 - 132 Ω

Linked Solutions

  • None

Repair

  • For a malfunctioning OEM terminating resistor, replace the OEM terminating resistor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Incorrect terminating resistance in the J1939 data link by a J1939 data linked component

Solution: S00001002

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Reconnect the OEM terminating resistor if previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the resistance is not within the following specification: 108 - 132 Ω

Linked Solutions

  • J1939 wire resistance check at the crossover connector for each component

Refer to S00001003

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

9.1 - J1939 wire resistance check at the crossover connector for each component

Solution: S00001003

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Reconnect the OEM terminating resistor if previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

Inspect the following components if applicable:

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector for each component while disconnecting them one at a time.
  • Disconnect the aftertreatment outlet NOx sensor
  • Disconnect the aftertreatment temperature sensor module
  • Disconnect the aftertreatment particulate sensor
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor
  • Disconnect the aftertreatment diesel exhaust fluid temperature sensor
  • Disconnect the aftertreatment diesel exhaust fluid quality sensor.
  • Disconnect the aftertreatment intermediate NH3 sensor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance was not within 108 Ω to 132 Ω and it becomes within the specification of 108 Ω to 132 Ω when the J1939 component was disconnected, then a malfunctioning J1939 component has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid tank level sensor.

Refer to OEM Service Manual

  • Replace the aftertreatment diesel exhaust fluid temperature sensor.

Refer to OEM Service Manual

  • Replace the aftertreatment diesel exhaust fluid quality sensor.

Refer to OEM Service Manual

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace aftertreatment DOC temperature sensor module.

Refer to Procedure 019-449

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

  • Replace aftertreatment intermediate NH3 sensor.

Refer to Procedure 019-479

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

10 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

11 - Aftertreatment intake NOx sensor is malfunctioning

Solution: S00000016

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment intake NOx sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3235 | SPN: 4363 | FMI: 16
Aftertreatment 1 SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment fuel injector is malfunctioning
  3. Aftertreatment diesel exhaust fluid is contaminated
  4. Turbocharger exhaust is leaking oil into the aftertreatment system
  5. Aftertreatment DOC is malfunctioning
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000257

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment SCR: 4152, 4159, 4164, 4165, 4261

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment fuel injector is malfunctioning

Solution: S00003286

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the aftertreatment fuel injector.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Fuel Injector Leak Test.

Refer to Procedure 011-054

Specification

  • If the Aftertreatment Fuel Injector Leak Test does not meet specification, then a malfunctioning aftertreatment fuel injector has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment fuel injector.

Refer to Procedure 011-042

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid is contaminated

Solution: S00000563

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Use a diesel exhaust fluid refractometer to measure the concentration of the diesel exhaust fluid in the tank.

Refer to Service Bulletin 4021566

Specification

  • If there are signs of contaminates in the aftertreatment diesel exhaust fluid, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to Procedure 011-056

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Turbocharger exhaust is leaking oil into the aftertreatment system

Solution: S00000655

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the exhaust piping from the turbocharger outlet.

Action

  • Inspect for any fluids.
  • Visually inspect the turbocharger exhaust outlet for signs of oil or fuel.
  • Perform the Snap Acceleration Test - Aftertreatment Disconnected.

Refer to Procedure 014-017

Specification

  • If lubricating engine oil contamination is found in the turbocharger exhaust outlet, then reset the search to oil consumption internal.
  • If excessive black smoke is detected, then reset the search to black smoke.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

5 - Aftertreatment DOC is malfunctioning

Solution: S00005082

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect for the presence of the aftertreatment DOC.

Refer to Procedure 011-049

  • Inspect the inlet face of the aftertreatment DOC for reuse.

Refer to Procedure 011-049

Refer to Service Bulletin 4021600

  • Inspect for cracks in the aftertreatment DOC cell walls.

Refer to Service Bulletin 4021600

  • Inspect for soot or oil plugging the front face of the catalyst

Refer to Service Bulletin 4021600

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • If the face of the aftertreatment DOC is plugged, then clean the aftertreatment DOC.

Refer to Procedure 011-049

  • If the face of the aftertreatment DOC is cracked or damaged, then replace the aftertreatment DOC.

Refer to Procedure 011-049

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3237 | SPN: 4340 | FMI: 3
Aftertreatment 1 Diesel Exhaust Fluid Line Heater 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid line heater relay is malfunctioning
  2. OEM wiring harness has a short to battery
  3. Aftertreatment diesel exhaust fluid line heater is malfunctioning
  4. Aftertreatment diesel exhaust fluid line heater resistance check
  5. Aftertreatment diesel exhaust fluid line heater pin shorted to another pin
  6. Aftertreatment diesel exhaust fluid line heater is malfunctioning

1 - Aftertreatment diesel exhaust fluid line heater relay is malfunctioning

Solution: S00000796

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid line heater relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - OEM wiring harness has a short to battery

Solution: S00001131

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the OEM wiring harness.
  • Connect the OEM wiring harness to the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment diesel exhaust fluid line heater SIGNAL pin and the aftertreatment diesel exhaust fluid line heater RETURN pin at the aftertreatment diesel exhaust fluid line heater connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the voltage is within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid line heater is malfunctioning

Solution: S00003290

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the Linked Solutions section if a fault code from the following list is active or has more than one inactive count within the last 25 engine operating hours: 3237, 3239, 3422

Linked Solutions

  • Aftertreatment diesel exhaust fluid line heater resistance check

Refer to S00003291

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Aftertreatment diesel exhaust fluid line heater resistance check

Solution: S00003291

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the appropriate aftertreatment diesel exhaust fluid line heater SIGNAL pin and the appropriate aftertreatment diesel exhaust fluid line heater RETURN pin at the appropriate aftertreatment diesel exhaust fluid line heater connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not between 2 Ω and 100 Ω, then a malfunctioning aftertreatment diesel exhaust fluid line heater has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid line heater.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Aftertreatment diesel exhaust fluid line heater pin shorted to another pin

Solution: S00000783

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater SIGNAL pin at the OEM wiring harness ECM connector and all other pins in the OEM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment diesel exhaust fluid line heater is malfunctioning

Solution: S00003985

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid line heater.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3238 | SPN: 4340 | FMI: 4
Aftertreatment 1 Diesel Exhaust Fluid Line Heater 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid line heater relay resistance check
  3. Aftertreatment diesel exhaust fluid line heater relay SUPPLY voltage check
  4. Aftertreatment diesel exhaust fluid line heater circuit pin to ground short
  5. Aftertreatment diesel exhaust fluid line heater pin shorted to another pin

1 - Check for primary fault codes

Solution: S00000258

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 3562, 3563, 3564

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid line heater relay resistance check

Solution: S00000802

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the OEM wiring harness.

Action

  • Check the relay.

Refer to Procedure 019-642

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid line heater relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid line heater relay SUPPLY voltage check

Solution: S00001001

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment diesel exhaust fluid line heater relay SUPPLY pin at the aftertreatment diesel exhaust fluid line heater relay OEM wiring harness connector and chassis ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuse.

Refer to OEM Service Manual

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid line heater circuit pin to ground short

Solution: S00001162

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater SIGNAL pin at the aftertreatment diesel exhaust fluid line heater connector and chassis ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment diesel exhaust fluid line heater pin shorted to another pin

Solution: S00000783

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater SIGNAL pin at the OEM wiring harness ECM connector and all other pins in the OEM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3239 | SPN: 4342 | FMI: 3
Aftertreatment 1 Diesel Exhaust Fluid Line Heater 2 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid line heater relay is malfunctioning
  2. OEM wiring harness has a short to battery
  3. Aftertreatment diesel exhaust fluid line heater is malfunctioning
  4. Aftertreatment diesel exhaust fluid line heater resistance check
  5. Aftertreatment diesel exhaust fluid line heater pin shorted to another pin

1 - Aftertreatment diesel exhaust fluid line heater relay is malfunctioning

Solution: S00000796

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid line heater relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - OEM wiring harness has a short to battery

Solution: S00001131

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the OEM wiring harness.
  • Connect the OEM wiring harness to the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment diesel exhaust fluid line heater SIGNAL pin and the aftertreatment diesel exhaust fluid line heater RETURN pin at the aftertreatment diesel exhaust fluid line heater connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the voltage is within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid line heater is malfunctioning

Solution: S00003290

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the Linked Solutions section if a fault code from the following list is active or has more than one inactive count within the last 25 engine operating hours: 3237, 3239, 3422

Linked Solutions

  • Aftertreatment diesel exhaust fluid line heater resistance check

Refer to S00003291

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Aftertreatment diesel exhaust fluid line heater resistance check

Solution: S00003291

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the appropriate aftertreatment diesel exhaust fluid line heater SIGNAL pin and the appropriate aftertreatment diesel exhaust fluid line heater RETURN pin at the appropriate aftertreatment diesel exhaust fluid line heater connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not between 2 Ω and 100 Ω, then a malfunctioning aftertreatment diesel exhaust fluid line heater has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid line heater.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Aftertreatment diesel exhaust fluid line heater pin shorted to another pin

Solution: S00000783

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater SIGNAL pin at the OEM wiring harness ECM connector and all other pins in the OEM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3241 | SPN: 4342 | FMI: 4
Aftertreatment 1 Diesel Exhaust Fluid Line Heater 2 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid line heater relay resistance check
  3. Aftertreatment diesel exhaust fluid line heater relay SUPPLY voltage check
  4. Aftertreatment diesel exhaust fluid line heater circuit pin to ground short
  5. Aftertreatment diesel exhaust fluid line heater pin shorted to another pin

1 - Check for primary fault codes

Solution: S00000259

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 3562, 3563, 3564

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid line heater relay resistance check

Solution: S00000802

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the OEM wiring harness.

Action

  • Check the relay.

Refer to Procedure 019-642

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid line heater relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid line heater relay SUPPLY voltage check

Solution: S00001001

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment diesel exhaust fluid line heater relay SUPPLY pin at the aftertreatment diesel exhaust fluid line heater relay OEM wiring harness connector and chassis ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuse.

Refer to OEM Service Manual

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid line heater circuit pin to ground short

Solution: S00001162

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater SIGNAL pin at the aftertreatment diesel exhaust fluid line heater connector and chassis ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment diesel exhaust fluid line heater pin shorted to another pin

Solution: S00000783

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater SIGNAL pin at the OEM wiring harness ECM connector and all other pins in the OEM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3242 | SPN: 3363 | FMI: 7
Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Mechanical System Not Responding or Out of Adjustment

Troubleshooting Summary

  1. Check for primary fault codes
  2. Restricted or leaking aftertreatment diesel exhaust fluid tank heater control valve coolant lines
  3. Aftertreatment diesel exhaust fluid tank heater control valve is installed incorrectly
  4. ECM calibration revision history check
  5. Aftertreatment diesel exhaust fluid tank heater control valve malfunctioning

1 - Check for primary fault codes

Solution: S00001396

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 1677, 1678, 1679, 1683, 1684, 3237, 3258, 3261, 3422, 3425, 3426, 3429, 3576, 4168, 4169
  • Engine coolant level: 195, 196, 197

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Restricted or leaking aftertreatment diesel exhaust fluid tank heater control valve coolant lines

Solution: S00000784

Verification

Conditions

  • Turn keyswitch OFF.
  • Verify that the engine coolant level is within normal operating range.

Action

  • Visually inspect the aftertreatment diesel exhaust fluid tank heater coolant lines for signs of damage, leaking lines, leaking gaskets, leaking seals, or loose connections.

Refer to OEM Service Manual

  • Visually inspect the aftertreatment diesel exhaust fluid tank heater coolant lines for kinks, or restrictions including the OEM in-line shutoff valve.

Refer to OEM Service Manual

Specification

  • If there are any leaks or restrictions in the aftertreatment diesel exhaust fluid tank heater coolant lines, then a malfunctioning aftertreatment diesel exhaust fluid tank heater coolant line or connection has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid tank heater control valve is installed incorrectly

Solution: S00000547

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the aftertreatment diesel exhaust fluid tank heater control valve is installed correctly, and not reversed.

Specification

  • If the aftertreatment diesel exhaust fluid tank heater control valve is reversed, then the incorrect installation of the aftertreatment diesel exhaust fluid tank heater control valve has been detected.
  • If the aftertreatment diesel exhaust fluid tank heater control valve is not reversed, then a malfunctioning aftertreatment diesel exhaust fluid tank heater control valve has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the aftertreatment diesel exhaust fluid tank heater control valve.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment diesel exhaust fluid tank heater control valve malfunctioning

Solution: S00001428

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid tank heater control valve has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the aftertreatment diesel exhaust fluid tank heater control valve.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3243 | SPN: 3060 | FMI: 18
Engine Cooling System Monitor - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Coolant temperature sensor resistance check
  3. Fan clutch operates incorrectly
  4. Thermostat is malfunctioning
  5. Out-of-chassis opening temperature test
  6. ECM calibration revision history check
  7. Coolant temperature sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000261

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Engine coolant temperature: 144, 145, 334

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Coolant temperature sensor resistance check

Solution: S00000127

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and engine coolant temperature sensor RETURN pin at the engine coolant temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the resistance is not within the following specification: 180 - 160k Ω

Linked Solutions

  • None

Repair

  • Replace the coolant temperature sensor.

Refer to Procedure 019-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Fan clutch operates incorrectly

Solution: S00006090

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the adjustable parameters settings.

Ensure the following adjustable parameters are set correctly for the application:

  • Fan Control Logic.
  • Fan Control Switch.
  • Air Conditioner Pressure Switch Input.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Fan Override Test.
  • Verify that the fan operates correctly.
  • Verify the fan is engaging at the correct engine temperature.

Refer to Procedure 008-027

Refer to OEM Service Manual

Specification

  • If the fan does not engage at the correct engine temperature, then a malfunctioning fan clutch has been detected.

Linked Solutions

  • None

Repair

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to Procedure 008-027

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Thermostat is malfunctioning

Solution: S00000785

Verification

Conditions

  • Engine running.

Action

  • Allow the engine to reach operating temperature.
  • Check the thermostat opening temperature with an infrared temperature gun.
  • Check the coolant thermostat for proper operation.

Refer to Procedure 008-013

  • Check for a damaged or leaking thermostat seal.

Refer to Procedure 008-013

  • If a temperature gun is not available or if the temperature gun reading is above the correct thermostat opening temperature, then proceed to Linked Solutions section.

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • Out-of-chassis opening temperature test

Refer to S00001359

Repair

  • Replace the engine coolant thermostat.

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4.1 - Out-of-chassis opening temperature test

Solution: S00001359

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the out-of-chassis opening temperature test.

Refer to Procedure 008-013

Specification

  • If any damage is noted or if the thermostat does not open at the correct temperature, then a malfunctioning coolant thermostat has been detected.
  • If any damage or if the thermostat seal is found leaking, then a malfunctioning thermostat seal has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine coolant thermostat.

Refer to Procedure 008-013

A new thermostat seal should be used when replacing the engine coolant thermostat.

If the thermostat seal is damaged, the engine coolant thermostat will still need to be replaced since the thermostat seal is not a separately serviceable item.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Coolant temperature sensor is malfunctioning

Solution: S00001238

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the engine coolant temperature sensor.

Refer to Procedure 019-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3245 | SPN: 3936 | FMI: 7
Aftertreatment 1 Diesel Particulate Filter System - Mechanical System Not Responding or Out of Adjustment

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment fuel injector is malfunctioning
  3. Aftertreatment temperature sensor stuck in-range
  4. Turbocharger exhaust is leaking oil into the aftertreatment system
  5. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000262

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment DPF: 4151, 4158, 4161, 4162, 4259

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment fuel injector is malfunctioning

Solution: S00003286

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the aftertreatment fuel injector.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Fuel Injector Leak Test.

Refer to Procedure 011-054

Specification

  • If the Aftertreatment Fuel Injector Leak Test does not meet specification, then a malfunctioning aftertreatment fuel injector has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment fuel injector.

Refer to Procedure 011-042

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment temperature sensor stuck in-range

Solution: S00000338

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Start the engine.

Action

  • Run the engine at high idle for the following minutes: 10
  • Use the recommended Cummins® electronic service tool or equivalent.

Monitor the following parameters:

  • Aftertreatment diesel oxidation catalyst intake temperature
  • Aftertreatment diesel particulate filter intake temperature
  • Aftertreatment diesel particulate filter outlet temperature

Specification

  • A malfunctioning aftertreatment exhaust gas temperature sensor has been detected if each sensor is not within the following specification of the others: 24 C [43 F]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Turbocharger exhaust is leaking oil into the aftertreatment system

Solution: S00000655

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the exhaust piping from the turbocharger outlet.

Action

  • Inspect for any fluids.
  • Visually inspect the turbocharger exhaust outlet for signs of oil or fuel.
  • Perform the Snap Acceleration Test - Aftertreatment Disconnected.

Refer to Procedure 014-017

Specification

  • If lubricating engine oil contamination is found in the turbocharger exhaust outlet, then reset the search to oil consumption internal.
  • If excessive black smoke is detected, then reset the search to black smoke.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3251 | SPN: 4765 | FMI: 16
Aftertreatment 1 Diesel Oxidation Catalyst Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment fuel injector is malfunctioning
  3. Leaks in the intake air system
  4. Charge air cooler system leak
  5. Aftertreatment temperature sensor stuck in-range
  6. Turbocharger exhaust is leaking oil into the aftertreatment system
  7. Aftertreatment DOC is malfunctioning
  8. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000280

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment fuel: 1932
  • Aftertreatment DPF: 4151, 4158, 4161, 4162, 4163, 4259

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment fuel injector is malfunctioning

Solution: S00003286

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the aftertreatment fuel injector.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Fuel Injector Leak Test.

Refer to Procedure 011-054

Specification

  • If the Aftertreatment Fuel Injector Leak Test does not meet specification, then a malfunctioning aftertreatment fuel injector has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment fuel injector.

Refer to Procedure 011-042

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Leaks in the intake air system

Solution: S00008386

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.
  • Visually inspect the intake plumbing for possible air leaks.

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Charge air cooler system leak

Solution: S00008815

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the charge air cooler hoses for possible air leaks.
  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If a leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the charge air cooler.

Refer to Procedure 010-027

  • Repair or replace the charge air cooler hoses.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment temperature sensor stuck in-range

Solution: S00000338

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Start the engine.

Action

  • Run the engine at high idle for the following minutes: 10
  • Use the recommended Cummins® electronic service tool or equivalent.

Monitor the following parameters:

  • Aftertreatment diesel oxidation catalyst intake temperature
  • Aftertreatment diesel particulate filter intake temperature
  • Aftertreatment diesel particulate filter outlet temperature

Specification

  • A malfunctioning aftertreatment exhaust gas temperature sensor has been detected if each sensor is not within the following specification of the others: 24 C [43 F]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Turbocharger exhaust is leaking oil into the aftertreatment system

Solution: S00000655

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the exhaust piping from the turbocharger outlet.

Action

  • Inspect for any fluids.
  • Visually inspect the turbocharger exhaust outlet for signs of oil or fuel.
  • Perform the Snap Acceleration Test - Aftertreatment Disconnected.

Refer to Procedure 014-017

Specification

  • If lubricating engine oil contamination is found in the turbocharger exhaust outlet, then reset the search to oil consumption internal.
  • If excessive black smoke is detected, then reset the search to black smoke.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

7 - Aftertreatment DOC is malfunctioning

Solution: S00005082

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect for the presence of the aftertreatment DOC.

Refer to Procedure 011-049

  • Inspect the inlet face of the aftertreatment DOC for reuse.

Refer to Procedure 011-049

Refer to Service Bulletin 4021600

  • Inspect for cracks in the aftertreatment DOC cell walls.

Refer to Service Bulletin 4021600

  • Inspect for soot or oil plugging the front face of the catalyst

Refer to Service Bulletin 4021600

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • If the face of the aftertreatment DOC is plugged, then clean the aftertreatment DOC.

Refer to Procedure 011-049

  • If the face of the aftertreatment DOC is cracked or damaged, then replace the aftertreatment DOC.

Refer to Procedure 011-049

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3253 | SPN: 3242 | FMI: 16
Aftertreatment 1 Diesel Particulate Filter Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment fuel injector is malfunctioning
  3. Aftertreatment temperature sensor stuck in-range
  4. Turbocharger exhaust is leaking oil into the aftertreatment system
  5. Aftertreatment DOC is malfunctioning
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000280

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment fuel: 1932
  • Aftertreatment DPF: 4151, 4158, 4161, 4162, 4163, 4259

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment fuel injector is malfunctioning

Solution: S00003286

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the aftertreatment fuel injector.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Fuel Injector Leak Test.

Refer to Procedure 011-054

Specification

  • If the Aftertreatment Fuel Injector Leak Test does not meet specification, then a malfunctioning aftertreatment fuel injector has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment fuel injector.

Refer to Procedure 011-042

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment temperature sensor stuck in-range

Solution: S00000338

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Start the engine.

Action

  • Run the engine at high idle for the following minutes: 10
  • Use the recommended Cummins® electronic service tool or equivalent.

Monitor the following parameters:

  • Aftertreatment diesel oxidation catalyst intake temperature
  • Aftertreatment diesel particulate filter intake temperature
  • Aftertreatment diesel particulate filter outlet temperature

Specification

  • A malfunctioning aftertreatment exhaust gas temperature sensor has been detected if each sensor is not within the following specification of the others: 24 C [43 F]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Turbocharger exhaust is leaking oil into the aftertreatment system

Solution: S00000655

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the exhaust piping from the turbocharger outlet.

Action

  • Inspect for any fluids.
  • Visually inspect the turbocharger exhaust outlet for signs of oil or fuel.
  • Perform the Snap Acceleration Test - Aftertreatment Disconnected.

Refer to Procedure 014-017

Specification

  • If lubricating engine oil contamination is found in the turbocharger exhaust outlet, then reset the search to oil consumption internal.
  • If excessive black smoke is detected, then reset the search to black smoke.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

5 - Aftertreatment DOC is malfunctioning

Solution: S00005082

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect for the presence of the aftertreatment DOC.

Refer to Procedure 011-049

  • Inspect the inlet face of the aftertreatment DOC for reuse.

Refer to Procedure 011-049

Refer to Service Bulletin 4021600

  • Inspect for cracks in the aftertreatment DOC cell walls.

Refer to Service Bulletin 4021600

  • Inspect for soot or oil plugging the front face of the catalyst

Refer to Service Bulletin 4021600

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • If the face of the aftertreatment DOC is plugged, then clean the aftertreatment DOC.

Refer to Procedure 011-049

  • If the face of the aftertreatment DOC is cracked or damaged, then replace the aftertreatment DOC.

Refer to Procedure 011-049

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3254 | SPN: 3242 | FMI: 15
Aftertreatment 1 Diesel Particulate Filter Intake Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Check for primary fault codes
  3. Aftertreatment temperature sensor stuck in-range
  4. Aftertreatment fuel injector flow test
  5. Overhead component damaged or out of adjustment
  6. Turbocharger exhaust is leaking oil into the aftertreatment system
  7. Aftertreatment DOC is malfunctioning
  8. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000280

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment fuel: 1932
  • Aftertreatment DPF: 4151, 4158, 4161, 4162, 4163, 4259

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Check for primary fault codes

Solution: S00000265

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment fuel: 1932
  • Aftertreatment DPF: 4151, 4158, 4161, 4162, 4259

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

3 - Aftertreatment temperature sensor stuck in-range

Solution: S00000338

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Start the engine.

Action

  • Run the engine at high idle for the following minutes: 10
  • Use the recommended Cummins® electronic service tool or equivalent.

Monitor the following parameters:

  • Aftertreatment diesel oxidation catalyst intake temperature
  • Aftertreatment diesel particulate filter intake temperature
  • Aftertreatment diesel particulate filter outlet temperature

Specification

  • A malfunctioning aftertreatment exhaust gas temperature sensor has been detected if each sensor is not within the following specification of the others: 24 C [43 F]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment fuel injector flow test

Solution: S00002774

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the Aftertreatment Fuel Injector Flow Test.

Refer to Procedure 011-054

Specification

  • If the Aftertreatment Fuel Injector Flow Test does not meet specification, then a malfunctioning aftertreatment fuel injector has been detected.

Linked Solutions

  • None

Repair

  • Clean or replace the aftertreatment fuel injector.

Refer to Procedure 011-042

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Overhead component damaged or out of adjustment

Solution: S00005074

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Visually inspect the rocker levers.
  • Visually inspect crossheads for correct positioning.
  • Visually inspect valve springs for damage.
  • Check the overhead valve lash settings and adjustment.

Refer to Procedure 003-004

Specification

  • If any of the inspections are not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Adjust the overhead.

Refer to Procedure 003-004

  • Replace the damaged or worn overhead component.

Refer to Procedure 003-004

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Turbocharger exhaust is leaking oil into the aftertreatment system

Solution: S00000655

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the exhaust piping from the turbocharger outlet.

Action

  • Inspect for any fluids.
  • Visually inspect the turbocharger exhaust outlet for signs of oil or fuel.
  • Perform the Snap Acceleration Test - Aftertreatment Disconnected.

Refer to Procedure 014-017

Specification

  • If lubricating engine oil contamination is found in the turbocharger exhaust outlet, then reset the search to oil consumption internal.
  • If excessive black smoke is detected, then reset the search to black smoke.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

7 - Aftertreatment DOC is malfunctioning

Solution: S00005082

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect for the presence of the aftertreatment DOC.

Refer to Procedure 011-049

  • Inspect the inlet face of the aftertreatment DOC for reuse.

Refer to Procedure 011-049

Refer to Service Bulletin 4021600

  • Inspect for cracks in the aftertreatment DOC cell walls.

Refer to Service Bulletin 4021600

  • Inspect for soot or oil plugging the front face of the catalyst

Refer to Service Bulletin 4021600

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • If the face of the aftertreatment DOC is plugged, then clean the aftertreatment DOC.

Refer to Procedure 011-049

  • If the face of the aftertreatment DOC is cracked or damaged, then replace the aftertreatment DOC.

Refer to Procedure 011-049

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3255 | SPN: 3246 | FMI: 16
Aftertreatment 1 Diesel Particulate Filter Outlet Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment fuel injector is malfunctioning
  3. Aftertreatment temperature sensor stuck in-range
  4. Turbocharger exhaust is leaking oil into the aftertreatment system
  5. Aftertreatment DOC is malfunctioning
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000280

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment fuel: 1932
  • Aftertreatment DPF: 4151, 4158, 4161, 4162, 4163, 4259

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment fuel injector is malfunctioning

Solution: S00003286

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the aftertreatment fuel injector.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Fuel Injector Leak Test.

Refer to Procedure 011-054

Specification

  • If the Aftertreatment Fuel Injector Leak Test does not meet specification, then a malfunctioning aftertreatment fuel injector has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment fuel injector.

Refer to Procedure 011-042

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment temperature sensor stuck in-range

Solution: S00000338

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Start the engine.

Action

  • Run the engine at high idle for the following minutes: 10
  • Use the recommended Cummins® electronic service tool or equivalent.

Monitor the following parameters:

  • Aftertreatment diesel oxidation catalyst intake temperature
  • Aftertreatment diesel particulate filter intake temperature
  • Aftertreatment diesel particulate filter outlet temperature

Specification

  • A malfunctioning aftertreatment exhaust gas temperature sensor has been detected if each sensor is not within the following specification of the others: 24 C [43 F]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Turbocharger exhaust is leaking oil into the aftertreatment system

Solution: S00000655

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the exhaust piping from the turbocharger outlet.

Action

  • Inspect for any fluids.
  • Visually inspect the turbocharger exhaust outlet for signs of oil or fuel.
  • Perform the Snap Acceleration Test - Aftertreatment Disconnected.

Refer to Procedure 014-017

Specification

  • If lubricating engine oil contamination is found in the turbocharger exhaust outlet, then reset the search to oil consumption internal.
  • If excessive black smoke is detected, then reset the search to black smoke.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

5 - Aftertreatment DOC is malfunctioning

Solution: S00005082

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect for the presence of the aftertreatment DOC.

Refer to Procedure 011-049

  • Inspect the inlet face of the aftertreatment DOC for reuse.

Refer to Procedure 011-049

Refer to Service Bulletin 4021600

  • Inspect for cracks in the aftertreatment DOC cell walls.

Refer to Service Bulletin 4021600

  • Inspect for soot or oil plugging the front face of the catalyst

Refer to Service Bulletin 4021600

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • If the face of the aftertreatment DOC is plugged, then clean the aftertreatment DOC.

Refer to Procedure 011-049

  • If the face of the aftertreatment DOC is cracked or damaged, then replace the aftertreatment DOC.

Refer to Procedure 011-049

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3256 | SPN: 3246 | FMI: 15
Aftertreatment 1 Diesel Particulate Filter Outlet Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment fuel injector is malfunctioning
  3. Aftertreatment temperature sensor stuck in-range
  4. Turbocharger exhaust is leaking oil into the aftertreatment system
  5. Aftertreatment DOC is malfunctioning
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000267

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid dosing unit: 1932
  • Aftertreatment DPF: 4151, 4158, 4162, 4259

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment fuel injector is malfunctioning

Solution: S00003286

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the aftertreatment fuel injector.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Fuel Injector Leak Test.

Refer to Procedure 011-054

Specification

  • If the Aftertreatment Fuel Injector Leak Test does not meet specification, then a malfunctioning aftertreatment fuel injector has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment fuel injector.

Refer to Procedure 011-042

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment temperature sensor stuck in-range

Solution: S00000338

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Start the engine.

Action

  • Run the engine at high idle for the following minutes: 10
  • Use the recommended Cummins® electronic service tool or equivalent.

Monitor the following parameters:

  • Aftertreatment diesel oxidation catalyst intake temperature
  • Aftertreatment diesel particulate filter intake temperature
  • Aftertreatment diesel particulate filter outlet temperature

Specification

  • A malfunctioning aftertreatment exhaust gas temperature sensor has been detected if each sensor is not within the following specification of the others: 24 C [43 F]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Turbocharger exhaust is leaking oil into the aftertreatment system

Solution: S00000655

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the exhaust piping from the turbocharger outlet.

Action

  • Inspect for any fluids.
  • Visually inspect the turbocharger exhaust outlet for signs of oil or fuel.
  • Perform the Snap Acceleration Test - Aftertreatment Disconnected.

Refer to Procedure 014-017

Specification

  • If lubricating engine oil contamination is found in the turbocharger exhaust outlet, then reset the search to oil consumption internal.
  • If excessive black smoke is detected, then reset the search to black smoke.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

5 - Aftertreatment DOC is malfunctioning

Solution: S00005082

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect for the presence of the aftertreatment DOC.

Refer to Procedure 011-049

  • Inspect the inlet face of the aftertreatment DOC for reuse.

Refer to Procedure 011-049

Refer to Service Bulletin 4021600

  • Inspect for cracks in the aftertreatment DOC cell walls.

Refer to Service Bulletin 4021600

  • Inspect for soot or oil plugging the front face of the catalyst

Refer to Service Bulletin 4021600

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • If the face of the aftertreatment DOC is plugged, then clean the aftertreatment DOC.

Refer to Procedure 011-049

  • If the face of the aftertreatment DOC is cracked or damaged, then replace the aftertreatment DOC.

Refer to Procedure 011-049

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3258 | SPN: 4340 | FMI: 5
Aftertreatment 1 Diesel Exhaust Fluid Line Heater 1 Circuit - Current Below Normal or Open Circuit

Troubleshooting Summary

  1. Check for primary fault codes
  2. Technical Service Bulletin is available
  3. Aftertreatment diesel exhaust fluid line heater relay voltage check
  4. Aftertreatment diesel exhaust fluid line heater voltage check
  5. Wiring harness load test
  6. Aftertreatment diesel exhaust fluid line heater open circuit check
  7. Aftertreatment diesel exhaust fluid line heater wire shorted to ground
  8. Aftertreatment diesel exhaust fluid line heater is malfunctioning

1 - Check for primary fault codes

Solution: S00000268

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 3562, 3563, 3564

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Technical Service Bulletin is available

Solution: S00009712

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb130017

  • If this engine is not in a PACCAR™ application, then proceed to the next solution.

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid line heater relay voltage check

Solution: S00000367

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid line heater from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment diesel exhaust fluid line heater SIGNAL pin and the aftertreatment diesel exhaust fluid line heater RETURN pin at the aftertreatment diesel exhaust fluid line heater connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is within the following specification: 4 - 6 VDC

Linked Solutions

  • Aftertreatment diesel exhaust fluid line heater voltage check

Refer to S00002909

  • Wiring harness load test

Refer to S00000877

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Aftertreatment diesel exhaust fluid line heater voltage check

Solution: S00002909

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid line heater from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment diesel exhaust fluid line heater SIGNAL pin and the aftertreatment diesel exhaust fluid line heater RETURN pin at the aftertreatment diesel exhaust fluid line heater connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the voltage is not within the following specification: 4 - 6 VDC

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.2 - Wiring harness load test

Solution: S00000877

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect all components on the wiring circuit being tested.

Action

This test is NOT for checking the J1939 data link (+) and (-) pins since it may cause damage to the J1939 smart devices or sensors.

  • Perform the wiring harness load test for the circuit being tested.

Refer to Procedure 019-359

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the voltage drop is not within specification, then a malfunctioning wiring harness has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Aftertreatment diesel exhaust fluid line heater open circuit check

Solution: S00000808

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater SIGNAL pin at the aftertreatment diesel exhaust fluid line heater connector and the aftertreatment diesel exhaust fluid line heater SIGNAL pin at the OEM wiring harness connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater SIGNAL pin at the aftertreatment diesel exhaust fluid line heater OEM wiring harness connector and the aftertreatment diesel exhaust fluid line heater relay SIGNAL pin at the aftertreatment diesel exhaust fluid line heater relay OEM wiring harness connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater RETURN pin at the aftertreatment diesel exhaust fluid line heater connector and the aftertreatment diesel exhaust fluid line heater RETURN pin at the OEM wiring harness connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment diesel exhaust fluid line heater wire shorted to ground

Solution: S00000812

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater RETURN pin at the aftertreatment diesel exhaust fluid line heater connector and chassis ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment diesel exhaust fluid line heater is malfunctioning

Solution: S00003985

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid line heater.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3261 | SPN: 4342 | FMI: 5
Aftertreatment 1 Diesel Exhaust Fluid Line Heater 2 Circuit - Current Below Normal or Open Circuit

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid line heater relay voltage check
  3. Aftertreatment diesel exhaust fluid line heater voltage check
  4. Wiring harness load test
  5. Aftertreatment diesel exhaust fluid line heater open circuit check
  6. Aftertreatment diesel exhaust fluid line heater wire shorted to ground
  7. Aftertreatment diesel exhaust fluid line heater pin shorted to another pin
  8. Aftertreatment diesel exhaust fluid line heater is malfunctioning

1 - Check for primary fault codes

Solution: S00000269

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 3562, 3563, 3564

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid line heater relay voltage check

Solution: S00000367

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid line heater from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment diesel exhaust fluid line heater SIGNAL pin and the aftertreatment diesel exhaust fluid line heater RETURN pin at the aftertreatment diesel exhaust fluid line heater connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is within the following specification: 4 - 6 VDC

Linked Solutions

  • Aftertreatment diesel exhaust fluid line heater voltage check

Refer to S00002909

  • Wiring harness load test

Refer to S00000877

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Aftertreatment diesel exhaust fluid line heater voltage check

Solution: S00002909

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid line heater from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment diesel exhaust fluid line heater SIGNAL pin and the aftertreatment diesel exhaust fluid line heater RETURN pin at the aftertreatment diesel exhaust fluid line heater connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the voltage is not within the following specification: 4 - 6 VDC

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Wiring harness load test

Solution: S00000877

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect all components on the wiring circuit being tested.

Action

This test is NOT for checking the J1939 data link (+) and (-) pins since it may cause damage to the J1939 smart devices or sensors.

  • Perform the wiring harness load test for the circuit being tested.

Refer to Procedure 019-359

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the voltage drop is not within specification, then a malfunctioning wiring harness has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Aftertreatment diesel exhaust fluid line heater open circuit check

Solution: S00000808

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater SIGNAL pin at the aftertreatment diesel exhaust fluid line heater connector and the aftertreatment diesel exhaust fluid line heater SIGNAL pin at the OEM wiring harness connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater SIGNAL pin at the aftertreatment diesel exhaust fluid line heater OEM wiring harness connector and the aftertreatment diesel exhaust fluid line heater relay SIGNAL pin at the aftertreatment diesel exhaust fluid line heater relay OEM wiring harness connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater RETURN pin at the aftertreatment diesel exhaust fluid line heater connector and the aftertreatment diesel exhaust fluid line heater RETURN pin at the OEM wiring harness connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid line heater wire shorted to ground

Solution: S00000812

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater RETURN pin at the aftertreatment diesel exhaust fluid line heater connector and chassis ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment diesel exhaust fluid line heater pin shorted to another pin

Solution: S00000783

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater SIGNAL pin at the OEM wiring harness ECM connector and all other pins in the OEM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment diesel exhaust fluid line heater is malfunctioning

Solution: S00003985

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid line heater.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3311 | SPN: 3242 | FMI: 0
Aftertreatment 1 Diesel Particulate Filter Intake Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment fuel injector is malfunctioning
  3. Aftertreatment temperature sensor stuck in-range
  4. Turbocharger exhaust is leaking oil into the aftertreatment system
  5. Aftertreatment DOC is malfunctioning
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000280

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment fuel: 1932
  • Aftertreatment DPF: 4151, 4158, 4161, 4162, 4163, 4259

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment fuel injector is malfunctioning

Solution: S00003286

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the aftertreatment fuel injector.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Fuel Injector Leak Test.

Refer to Procedure 011-054

Specification

  • If the Aftertreatment Fuel Injector Leak Test does not meet specification, then a malfunctioning aftertreatment fuel injector has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment fuel injector.

Refer to Procedure 011-042

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment temperature sensor stuck in-range

Solution: S00000338

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Start the engine.

Action

  • Run the engine at high idle for the following minutes: 10
  • Use the recommended Cummins® electronic service tool or equivalent.

Monitor the following parameters:

  • Aftertreatment diesel oxidation catalyst intake temperature
  • Aftertreatment diesel particulate filter intake temperature
  • Aftertreatment diesel particulate filter outlet temperature

Specification

  • A malfunctioning aftertreatment exhaust gas temperature sensor has been detected if each sensor is not within the following specification of the others: 24 C [43 F]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Turbocharger exhaust is leaking oil into the aftertreatment system

Solution: S00000655

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the exhaust piping from the turbocharger outlet.

Action

  • Inspect for any fluids.
  • Visually inspect the turbocharger exhaust outlet for signs of oil or fuel.
  • Perform the Snap Acceleration Test - Aftertreatment Disconnected.

Refer to Procedure 014-017

Specification

  • If lubricating engine oil contamination is found in the turbocharger exhaust outlet, then reset the search to oil consumption internal.
  • If excessive black smoke is detected, then reset the search to black smoke.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

5 - Aftertreatment DOC is malfunctioning

Solution: S00005082

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect for the presence of the aftertreatment DOC.

Refer to Procedure 011-049

  • Inspect the inlet face of the aftertreatment DOC for reuse.

Refer to Procedure 011-049

Refer to Service Bulletin 4021600

  • Inspect for cracks in the aftertreatment DOC cell walls.

Refer to Service Bulletin 4021600

  • Inspect for soot or oil plugging the front face of the catalyst

Refer to Service Bulletin 4021600

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • If the face of the aftertreatment DOC is plugged, then clean the aftertreatment DOC.

Refer to Procedure 011-049

  • If the face of the aftertreatment DOC is cracked or damaged, then replace the aftertreatment DOC.

Refer to Procedure 011-049

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3312 | SPN: 3246 | FMI: 0
Aftertreatment 1 Diesel Particulate Filter Outlet Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment fuel injector is malfunctioning
  3. Aftertreatment temperature sensor stuck in-range
  4. Turbocharger exhaust is leaking oil into the aftertreatment system
  5. Aftertreatment DOC is malfunctioning
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000280

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment fuel: 1932
  • Aftertreatment DPF: 4151, 4158, 4161, 4162, 4163, 4259

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment fuel injector is malfunctioning

Solution: S00003286

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the aftertreatment fuel injector.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Fuel Injector Leak Test.

Refer to Procedure 011-054

Specification

  • If the Aftertreatment Fuel Injector Leak Test does not meet specification, then a malfunctioning aftertreatment fuel injector has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment fuel injector.

Refer to Procedure 011-042

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment temperature sensor stuck in-range

Solution: S00000338

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Start the engine.

Action

  • Run the engine at high idle for the following minutes: 10
  • Use the recommended Cummins® electronic service tool or equivalent.

Monitor the following parameters:

  • Aftertreatment diesel oxidation catalyst intake temperature
  • Aftertreatment diesel particulate filter intake temperature
  • Aftertreatment diesel particulate filter outlet temperature

Specification

  • A malfunctioning aftertreatment exhaust gas temperature sensor has been detected if each sensor is not within the following specification of the others: 24 C [43 F]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Turbocharger exhaust is leaking oil into the aftertreatment system

Solution: S00000655

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the exhaust piping from the turbocharger outlet.

Action

  • Inspect for any fluids.
  • Visually inspect the turbocharger exhaust outlet for signs of oil or fuel.
  • Perform the Snap Acceleration Test - Aftertreatment Disconnected.

Refer to Procedure 014-017

Specification

  • If lubricating engine oil contamination is found in the turbocharger exhaust outlet, then reset the search to oil consumption internal.
  • If excessive black smoke is detected, then reset the search to black smoke.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

5 - Aftertreatment DOC is malfunctioning

Solution: S00005082

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect for the presence of the aftertreatment DOC.

Refer to Procedure 011-049

  • Inspect the inlet face of the aftertreatment DOC for reuse.

Refer to Procedure 011-049

Refer to Service Bulletin 4021600

  • Inspect for cracks in the aftertreatment DOC cell walls.

Refer to Service Bulletin 4021600

  • Inspect for soot or oil plugging the front face of the catalyst

Refer to Service Bulletin 4021600

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • If the face of the aftertreatment DOC is plugged, then clean the aftertreatment DOC.

Refer to Procedure 011-049

  • If the face of the aftertreatment DOC is cracked or damaged, then replace the aftertreatment DOC.

Refer to Procedure 011-049

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3313 | SPN: 4765 | FMI: 4
Aftertreatment 1 Diesel Oxidation Catalyst Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000280

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment fuel: 1932
  • Aftertreatment DPF: 4151, 4158, 4161, 4162, 4163, 4259

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00004310

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3314 | SPN: 4765 | FMI: 3
Aftertreatment 1 Diesel Oxidation Catalyst Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Technical Service Bulletin is available
  3. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000280

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment fuel: 1932
  • Aftertreatment DPF: 4151, 4158, 4161, 4162, 4163, 4259

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Technical Service Bulletin is available

Solution: S00009791

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb150153

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00009782

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 08-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3315 | SPN: 4765 | FMI: 2
Aftertreatment 1 Diesel Oxidation Catalyst Intake Temperature - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment temperature sensor stuck in-range
  3. Aftertreatment DOC is malfunctioning
  4. ECM calibration revision history check
  5. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000280

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment fuel: 1932
  • Aftertreatment DPF: 4151, 4158, 4161, 4162, 4163, 4259

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment temperature sensor stuck in-range

Solution: S00000338

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Start the engine.

Action

  • Run the engine at high idle for the following minutes: 10
  • Use the recommended Cummins® electronic service tool or equivalent.

Monitor the following parameters:

  • Aftertreatment diesel oxidation catalyst intake temperature
  • Aftertreatment diesel particulate filter intake temperature
  • Aftertreatment diesel particulate filter outlet temperature

Specification

  • A malfunctioning aftertreatment exhaust gas temperature sensor has been detected if each sensor is not within the following specification of the others: 24 C [43 F]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment DOC is malfunctioning

Solution: S00005082

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect for the presence of the aftertreatment DOC.

Refer to Procedure 011-049

  • Inspect the inlet face of the aftertreatment DOC for reuse.

Refer to Procedure 011-049

Refer to Service Bulletin 4021600

  • Inspect for cracks in the aftertreatment DOC cell walls.

Refer to Service Bulletin 4021600

  • Inspect for soot or oil plugging the front face of the catalyst

Refer to Service Bulletin 4021600

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • If the face of the aftertreatment DOC is plugged, then clean the aftertreatment DOC.

Refer to Procedure 011-049

  • If the face of the aftertreatment DOC is cracked or damaged, then replace the aftertreatment DOC.

Refer to Procedure 011-049

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00009782

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3316 | SPN: 3242 | FMI: 4
Aftertreatment 1 Diesel Particulate Filter Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment DPF temperature sensor circuit pin to ground short
  3. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000280

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment fuel: 1932
  • Aftertreatment DPF: 4151, 4158, 4161, 4162, 4163, 4259

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment DPF temperature sensor circuit pin to ground short

Solution: S00000787

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment DPF temperature sensor module from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF intake temperature sensor SUPPLY pin in the OEM wiring harness and battery ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00009782

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 08-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3317 | SPN: 3242 | FMI: 3
Aftertreatment 1 Diesel Particulate Filter Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Technical Service Bulletin is available
  3. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000280

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment fuel: 1932
  • Aftertreatment DPF: 4151, 4158, 4161, 4162, 4163, 4259

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Technical Service Bulletin is available

Solution: S00009791

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb150153

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00009782

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 08-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3318 | SPN: 3242 | FMI: 2
Aftertreatment 1 Diesel Particulate Filter Intake Temperature - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment temperature sensor stuck in-range
  3. ECM calibration revision history check
  4. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000280

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment fuel: 1932
  • Aftertreatment DPF: 4151, 4158, 4161, 4162, 4163, 4259

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment temperature sensor stuck in-range

Solution: S00000338

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Start the engine.

Action

  • Run the engine at high idle for the following minutes: 10
  • Use the recommended Cummins® electronic service tool or equivalent.

Monitor the following parameters:

  • Aftertreatment diesel oxidation catalyst intake temperature
  • Aftertreatment diesel particulate filter intake temperature
  • Aftertreatment diesel particulate filter outlet temperature

Specification

  • A malfunctioning aftertreatment exhaust gas temperature sensor has been detected if each sensor is not within the following specification of the others: 24 C [43 F]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00009782

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3319 | SPN: 3246 | FMI: 3
Aftertreatment 1 Diesel Particulate Filter Outlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Technical Service Bulletin is available
  3. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000280

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment fuel: 1932
  • Aftertreatment DPF: 4151, 4158, 4161, 4162, 4163, 4259

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Technical Service Bulletin is available

Solution: S00009791

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb150153

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00004310

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3321 | SPN: 3246 | FMI: 4
Aftertreatment 1 Diesel Particulate Filter Outlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000280

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment fuel: 1932
  • Aftertreatment DPF: 4151, 4158, 4161, 4162, 4163, 4259

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00009782

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 08-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3322 | SPN: 3246 | FMI: 2
Aftertreatment 1 Diesel Particulate Filter Outlet Temperature - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment temperature sensor stuck in-range
  3. ECM calibration revision history check
  4. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000280

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment fuel: 1932
  • Aftertreatment DPF: 4151, 4158, 4161, 4162, 4163, 4259

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment temperature sensor stuck in-range

Solution: S00000338

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Start the engine.

Action

  • Run the engine at high idle for the following minutes: 10
  • Use the recommended Cummins® electronic service tool or equivalent.

Monitor the following parameters:

  • Aftertreatment diesel oxidation catalyst intake temperature
  • Aftertreatment diesel particulate filter intake temperature
  • Aftertreatment diesel particulate filter outlet temperature

Specification

  • A malfunctioning aftertreatment exhaust gas temperature sensor has been detected if each sensor is not within the following specification of the others: 24 C [43 F]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00009782

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3326 | SPN: 91 | FMI: 9
Accelerator Pedal Position 1 - Abnormal Update Rate

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3328 | SPN: 191 | FMI: 9
Transmission Output Shaft Speed - Abnormal Update Rate

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3338 | SPN: 5395 | FMI: 18
Engine Idle Fuel Quantity - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes

1 - Check for primary fault codes

Solution: S00000281

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Accelerator Pedal or Lever Position: 131, 132, 1239, 1241, 1242
  • Wheel based vehicle speed: 241, 242, 3525, 3526
  • Fuel: 322, 323, 324, 325, 331, 332, 559, 1139, 1141, 1142, 1143, 1144, 1145

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 24-May-2020


NO TITLE

ISX15 CM2350 X101

Fault Code: 3342 | SPN: 4752 | FMI: 18
Engine Exhaust Gas Recirculation Cooler Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Plugged EGR differential pressure sensor supply ports
  3. EGR cooler plugged or restricted
  4. EGR temperature sensor stuck in-range
  5. EGR temperature sensor open circuit check
  6. EGR valve is leaking internally
  7. EGR temperature sensor circuit pin to ground short
  8. EGR temperature sensor circuit pin to pin short
  9. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002497

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • EGR: 1867, 2961, 3382, 3383
  • Aftertreatment DPF: 1922, 3375

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Plugged EGR differential pressure sensor supply ports

Solution: S00005073

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the EGR differential pressure sensor flow port cross-drillings for soot blockage.

Refer to Procedure 011-066

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Remove and clean the EGR mass measurement flow assembly.

Refer to Procedure 011-066

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - EGR cooler plugged or restricted

Solution: S00001116

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the EGR cooler.

Refer to Procedure 011-019

  • Service Bulletin is available.

Refer to Service Bulletin 2883594

Specification

  • If the EGR cooler is restricted, then clear the restriction from the EGR cooler.
  • If the EGR cooler restriction cannot be cleared, then a malfunctioning EGR cooler has been detected.

Linked Solutions

  • None

Repair

  • Clean and reinstall or replace the EGR Cooler.

Refer to Procedure 011-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - EGR temperature sensor stuck in-range

Solution: S00003137

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Monitor the intake manifold temperature
  • Monitor the EGR temperature sensor.

Specification

  • A malfunctioning EGR temperature sensor has been detected if the reading is not within the following specification of the intake manifold temperature sensor reading: +/- 5.5C [10F]

Linked Solutions

  • None

Repair

  • Replace EGR temperature sensor.

Refer to Procedure 019-378

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - EGR temperature sensor open circuit check

Solution: S00005089

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the EGR temperature sensor SIGNAL pin at the EGR temperature sensor engine wiring harness connector and the EGR temperature sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the EGR temperature sensor RETURN pin at the EGR temperature sensor engine wiring harness connector and the EGR temperature sensor RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - EGR valve is leaking internally

Solution: S00000348

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the Aftertreatment Diesel Particulate Filter regeneration test.
  • Allow the stationary regeneration test to run a minimum of 5 minutes.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the EGR Differential Pressure.

Specification

  • A malfunctioning EGR valve has been detected if the EGR Differential Pressure is greater than the follwing: 1.7 kPa [0.5 inHg]

Linked Solutions

  • None

Repair

  • Replace the EGR valve.

Refer to Procedure 011-022

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - EGR temperature sensor circuit pin to ground short

Solution: S00005090

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the EGR temperature sensor SIGNAL pin at the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - EGR temperature sensor circuit pin to pin short

Solution: S00005079

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR temperature sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the EGR temperature sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the EGR temperature sensor RETURN pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3343 | SPN: 5285 | FMI: 18
Engine Charge Air Cooler Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. High intake manifold temperature basic checks
  3. Fan clutch operates incorrectly
  4. Intake manifold temperature sensor stuck in-range
  5. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000282

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold temperature: 153, 154, 436

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - High intake manifold temperature basic checks

Solution: S00000459

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Refer to Procedure 010-031

  • Visually inspect the charge-air cooler for damage or debris blocking the air flow.

Refer to Procedure 010-027

  • Visually inspect the air conditioner condenser.

Refer to OEM Service Manual

  • Visually inspect the radiator fins for damage or debris blocking the air flow.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Fan clutch operates incorrectly

Solution: S00006090

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the adjustable parameters settings.

Ensure the following adjustable parameters are set correctly for the application:

  • Fan Control Logic.
  • Fan Control Switch.
  • Air Conditioner Pressure Switch Input.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Fan Override Test.
  • Verify that the fan operates correctly.
  • Verify the fan is engaging at the correct engine temperature.

Refer to Procedure 008-027

Refer to OEM Service Manual

Specification

  • If the fan does not engage at the correct engine temperature, then a malfunctioning fan clutch has been detected.

Linked Solutions

  • None

Repair

  • Adjust, repair, or replace the component preventing correct cooling fan operation.

Refer to Procedure 008-027

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Intake manifold temperature sensor stuck in-range

Solution: S00000334

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the intake manifold temperature sensor reading to an infrared thermometer or a known value.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the known value must be within: +/- 10C [18F]

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3348 | SPN: 1176 | FMI: 1
Turbocharger 1 Compressor Intake Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Restricted intake air filter
  3. Intake manifold pressure sensor has carbon buildup
  4. Intake manifold pressure sensor stuck in-range
  5. Oil discharge from turbocharger compressor

1 - Check for primary fault codes

Solution: S00000283

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Crankcase pressure: 555, 556

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Restricted intake air filter

Solution: S00000025

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Specification

  • If the intake air filter is plugged, then a restricted intake air filter has been detected.

Linked Solutions

  • None

Repair

  • Replace the air filter.

Refer to OEM Service Manual

Refer to Procedure 010-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Intake manifold pressure sensor has carbon buildup

Solution: S00006329

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

  • Visually inspect the intake manifold pressure/temperature sensor tip for soot or carbon buildup.
  • Visually inspect the intake manifold pressure sensor for damage.
  • Visually inspect the intake manifold pressure sensor o-rings for damage.

Specification

  • If any carbon buildup is found, then proceed to the Repair section.
  • If nicks or cuts in or on the o-ring are identified, then a damaged intake manifold pressure/temperature sensor o-ring has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

  • Replace the intake manifold pressure/temperature sensor o-ring.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Intake manifold pressure sensor stuck in-range

Solution: S00002814

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the intake manifold pressure sensor.

Specification

  • A malfunctioning intake manifold air pressure sensor has been detected if the intake manifold air pressure is not reading within the following specification: 0 ± 6.8 Kpa [0 ± 1 psi], 0 ± 51 mm-Hg [0 ± 2 in- Hg]

Linked Solutions

  • None

Repair

  • Replace the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Oil discharge from turbocharger compressor

Solution: S00000670

Verification

Conditions

  • Connect all components.

Action

  • Run the engine for 5 minutes at 1000 rpm.
  • Remove the discharge pipe from the turbocharger compressor.
  • Inspect the discharge line for oil.

Specification

  • If oil residue is found in the discharge pipe, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean the turbocharger compressor outlet and discharge pipe.
  • Assemble the discharge pipe and repeat the Verification procedure up to 5 times.
  • After 5 cleaning cycles, if oil is in the discharge pipe, replace the turbocharger.

Refer to Procedure 010-033

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3361 | SPN: 102 | FMI: 10
Intake Manifold 1 Pressure - Abnormal Rate of Change

Troubleshooting Summary

  1. Check for primary fault codes
  2. Intake manifold pressure sensor has carbon buildup
  3. Intake manifold pressure sensor stuck in-range
  4. Leaks in the intake air system
  5. Charge air cooler system leak
  6. Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test

1 - Check for primary fault codes

Solution: S00000284

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • EGR: 1228, 1896, 2272, 2349, 2351, 2352, 2353, 3382, 3383, 3389
  • EGR differential pressure: 1866, 2273, 2274
  • Turbocharger: 1894, 1898, 1938, 2387, 2636
  • Intake throttle: 175, 176, 177, 3539, 3541, 3542
  • Intake manifold: 124, 125

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Intake manifold pressure sensor has carbon buildup

Solution: S00006329

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

  • Visually inspect the intake manifold pressure/temperature sensor tip for soot or carbon buildup.
  • Visually inspect the intake manifold pressure sensor for damage.
  • Visually inspect the intake manifold pressure sensor o-rings for damage.

Specification

  • If any carbon buildup is found, then proceed to the Repair section.
  • If nicks or cuts in or on the o-ring are identified, then a damaged intake manifold pressure/temperature sensor o-ring has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

  • Replace the intake manifold pressure/temperature sensor o-ring.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Intake manifold pressure sensor stuck in-range

Solution: S00002814

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the intake manifold pressure sensor.

Specification

  • A malfunctioning intake manifold air pressure sensor has been detected if the intake manifold air pressure is not reading within the following specification: 0 ± 6.8 Kpa [0 ± 1 psi], 0 ± 51 mm-Hg [0 ± 2 in- Hg]

Linked Solutions

  • None

Repair

  • Replace the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Leaks in the intake air system

Solution: S00008386

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.
  • Visually inspect the intake plumbing for possible air leaks.

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Charge air cooler system leak

Solution: S00008815

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the charge air cooler hoses for possible air leaks.
  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If a leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the charge air cooler.

Refer to Procedure 010-027

  • Repair or replace the charge air cooler hoses.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test

Solution: S00003823

Verification

Conditions

  • Reconnect previously disconnected components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test.

Refer to Procedure 014-027

  • Verify the recommended Cummins® electronic service tool or equivalent has a version that supports this test.

Refer to Procedure 014-027

Specification

  • If the Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test does not pass, then reset the search to Aftertreatment Diesel Particulate Filter Regeneration Analyzer Did Not Pass. Only select the solution title that matches the error messages in the recommend Cummins® electronic service tool or equivalent.
  • If the Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test will not start, then reset the search to Aftertreatment Diesel Particulate Filter Regeneration Analyzer Did Not Start.
  • If the Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test does not complete, then reset the search to Aftertreatment Diesel Particulate Filter Regeneration Analyzer Did Not Complete.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3366 | SPN: 111 | FMI: 18
Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Coolant level check
  3. Coolant level sensor open circuit check
  4. Coolant level sensor circuit pin to ground short
  5. Coolant level sensor circuit pin to pin short
  6. Coolant level sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00010587

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 operating hours from the following list:

  • Coolant level: 195, 196

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Coolant level check

Solution: S00003142

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the coolant level.
  • Perform the Coolant System Pressure Test.

Refer to Procedure 008-018

  • Visually inspect for external coolant leaks.

Specification

  • If the coolant level is low and there are signs of external coolant leaks, then reset the search to external coolant leak.
  • If the coolant level is low and there are no signs of external coolant leaks, then reset the search to internal coolant leak.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3 - Coolant level sensor open circuit check

Solution: S00007920

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the coolant level sensor OEM wiring harness connector and the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Coolant level sensor circuit pin to ground short

Solution: S00007921

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Coolant level sensor circuit pin to pin short

Solution: S00007922

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the coolant level sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Measure the resistance between the coolant level sensor SUPPLY pin at the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Coolant level sensor is malfunctioning

Solution: S00007923

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning coolant level sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace engine coolant level sensor.

Refer to Procedure 019-017

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 15-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3374 | SPN: 1818 | FMI: 31
Roll Over Protection Brake Control Active - Condition Exists

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. Cruise control temporarily inhibited by the anti-lock braking system (ABS) controller
  3. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00003166

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify engine is equipped with a crankcase breather heater.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Verify the Crankcase Breather Heater setting is correct with the recommended Cummins® electronic service tool or equivalent.

Specification

  • If the adjustable parameter setting and application do not match, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Adjust the features and parameters to the correct settings.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Cruise control temporarily inhibited by the anti-lock braking system (ABS) controller

Solution: S00001654

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or has more than one inactive count within the last 25 engine operating hours, then the cruise control was inhibited temporarily by the anti-lock braking system (ABS) controller due to certain driving conditions.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3375 | SPN: 5397 | FMI: 31
Aftertreatment 1 Diesel Particulate Filter Regeneration too Frequent - Condition Exists

Troubleshooting Summary

  1. Fault Code 3375 requires that ALL solutions be performed
  2. Check for primary fault codes
  3. Restricted intake air filter
  4. Plugged EGR differential pressure sensor supply ports
  5. Damaged or missing aftertreatment DPF differential pressure sensor tubes
  6. Aftertreatment DPF differential pressure sensor stuck in-range
  7. Leaks in the intake air system
  8. Charge air cooler system leak
  9. Aftertreatment temperature sensor stuck in-range
  10. Aftertreatment DPF partially obstructed or plugged
  11. Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test
  12. ECM calibration revision history check

1 - Fault Code 3375 requires that ALL solutions be performed

Solution: S00000792

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • This solution is information only.
  • ALL solutions displayed for this fault code must be performed.
  • Continue to perform the verifications of ALL solution steps listed for this fault code regardless if a given solution is within specification or out of specification.

Specification

  • This solution is information only.

Linked Solutions

  • None

Repair

  • If a resolution is found in any solution for this fault code, continue performing ALL solutions listed for this fault code.

Validation

  • None
Next Solution

2 - Check for primary fault codes

Solution: S00000285

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment DPF: 5383
  • Aftertreatment differential pressure: 1879, 1881, 1883, 3133, 3134, 3135.
  • Fuel: 559, 1139, 1141, 1142, 1143, 1144, 1145.
  • Intake manifold: 125, 2973.
  • EGR: 1228, 1866, 1896, 1898, 2272, 2273, 2274, 2349, 2353, 2357, 2961, 2962, 3136, 3137, 3138, 3342, 3382, 3383
  • Aftertreatment DOC: 1925, 1926, 1932, 1963, 1964, 3167
  • Turbocharger: 2198, 2387, 2449, 2634, 2635, 2636, 3616
  • Exhaust gas pressure: 2373,2374,2554

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

3 - Restricted intake air filter

Solution: S00000025

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Specification

  • If the intake air filter is plugged, then a restricted intake air filter has been detected.

Linked Solutions

  • None

Repair

  • Replace the air filter.

Refer to OEM Service Manual

Refer to Procedure 010-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Plugged EGR differential pressure sensor supply ports

Solution: S00005073

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the EGR differential pressure sensor flow port cross-drillings for soot blockage.

Refer to Procedure 011-066

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Remove and clean the EGR mass measurement flow assembly.

Refer to Procedure 011-066

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Damaged or missing aftertreatment DPF differential pressure sensor tubes

Solution: S00001010

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the aftertreatment differential pressure tubes for proper installation.
  • Inspect the aftertreatment DPF differential pressure sensor tubes for signs of damage, plugging, kinks, leakage or loose connections.

Refer to Procedure 011-047

In extreme cold ambient temperatures it is important to check for a frozen, plugged, or restricted aftertreatment DPF differential pressure sensor tubes. Ice can form in the aftertreatment DPF differential pressure sensor tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Specification

  • If damage, kinks or blockages are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace DPF differential pressure sensor tubes.

Refer to Procedure 011-047

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

6 - Aftertreatment DPF differential pressure sensor stuck in-range

Solution: S00000793

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the aftertreatment DPF differential pressure sensor voltage.

Refer to Procedure 019-443

Specification

  • If the aftertreatment DPF differential pressure sensor voltage readings are not within specification, then a malfunctioning aftertreatment DPF differential pressure sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Leaks in the intake air system

Solution: S00008386

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.
  • Visually inspect the intake plumbing for possible air leaks.

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Charge air cooler system leak

Solution: S00008815

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the charge air cooler hoses for possible air leaks.
  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If a leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the charge air cooler.

Refer to Procedure 010-027

  • Repair or replace the charge air cooler hoses.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Aftertreatment temperature sensor stuck in-range

Solution: S00000338

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Start the engine.

Action

  • Run the engine at high idle for the following minutes: 10
  • Use the recommended Cummins® electronic service tool or equivalent.

Monitor the following parameters:

  • Aftertreatment diesel oxidation catalyst intake temperature
  • Aftertreatment diesel particulate filter intake temperature
  • Aftertreatment diesel particulate filter outlet temperature

Specification

  • A malfunctioning aftertreatment exhaust gas temperature sensor has been detected if each sensor is not within the following specification of the others: 24 C [43 F]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - Aftertreatment DPF partially obstructed or plugged

Solution: S00004187

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • If the aftertreatment DPF has already been replaced during this repair, then proceed to the next solution.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Particulate Filter Automated Restriction Test.

Refer to Procedure 011-085

Specification

  • If the Aftertreatment Diesel Particulate Filter Automated Restriction Test exceeds the limits called out in procedure, then a plugged or restricted aftertreatment DPF has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF.

Refer to Procedure 011-041

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

11 - Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test

Solution: S00003823

Verification

Conditions

  • Reconnect previously disconnected components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test.

Refer to Procedure 014-027

  • Verify the recommended Cummins® electronic service tool or equivalent has a version that supports this test.

Refer to Procedure 014-027

Specification

  • If the Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test does not pass, then reset the search to Aftertreatment Diesel Particulate Filter Regeneration Analyzer Did Not Pass. Only select the solution title that matches the error messages in the recommend Cummins® electronic service tool or equivalent.
  • If the Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test will not start, then reset the search to Aftertreatment Diesel Particulate Filter Regeneration Analyzer Did Not Start.
  • If the Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test does not complete, then reset the search to Aftertreatment Diesel Particulate Filter Regeneration Analyzer Did Not Complete.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

12 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3376 | SPN: 5319 | FMI: 31
Aftertreatment 1 Diesel Particulate Filter Incomplete Regeneration - Condition Exists

Troubleshooting Summary

  1. Fault Code 3376 requires that ALL solutions be performed
  2. Check for primary fault codes
  3. Restricted intake air filter
  4. Plugged EGR differential pressure sensor supply ports
  5. Damaged or missing aftertreatment DPF differential pressure sensor tubes
  6. Aftertreatment DPF differential pressure sensor stuck in-range
  7. Leaks in the intake air system
  8. Charge air cooler system leak
  9. Aftertreatment temperature sensor stuck in-range
  10. Aftertreatment DPF partially obstructed or plugged
  11. Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test
  12. ECM calibration revision history check

1 - Fault Code 3376 requires that ALL solutions be performed

Solution: S00003165

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • This solution is information only.
  • ALL solutions displayed for this fault code must be performed.
  • Continue to perform the verifications of ALL solution steps listed for this fault code regardless if a given solution is within specification or out of specification.

Specification

  • This solution is information only.

Linked Solutions

  • None

Repair

  • If a resolution is found in any solution for this fault code, continue performing ALL solutions listed for this fault code.

Validation

  • None
Next Solution

2 - Check for primary fault codes

Solution: S00000288

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment DPF: 1879, 1881, 1883, 3133, 3134, 3135, 5383
  • Fuel: 559, 1139, 1141, 1142, 1143, 1144, 1145
  • Intake manifold: 125, 2973
  • Aftertreatment DOC: 1664
  • Aftertreatment fuel: 1925, 1926, 1932, 1963, 1964, 3167
  • EGR: 1228, 1896, 2349, 2353, 2961, 2962, 3136, 3137, 3138, 3342, 3382, 3383
  • EGR differential pressure: 1866, 1867, 2273, 2274
  • Turbocharger: 1898, 2198, 2387, 2449, 2634, 2635, 2636, 3616

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

3 - Restricted intake air filter

Solution: S00000025

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Specification

  • If the intake air filter is plugged, then a restricted intake air filter has been detected.

Linked Solutions

  • None

Repair

  • Replace the air filter.

Refer to OEM Service Manual

Refer to Procedure 010-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Plugged EGR differential pressure sensor supply ports

Solution: S00005073

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the EGR differential pressure sensor flow port cross-drillings for soot blockage.

Refer to Procedure 011-066

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Remove and clean the EGR mass measurement flow assembly.

Refer to Procedure 011-066

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Damaged or missing aftertreatment DPF differential pressure sensor tubes

Solution: S00001010

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the aftertreatment differential pressure tubes for proper installation.
  • Inspect the aftertreatment DPF differential pressure sensor tubes for signs of damage, plugging, kinks, leakage or loose connections.

Refer to Procedure 011-047

In extreme cold ambient temperatures it is important to check for a frozen, plugged, or restricted aftertreatment DPF differential pressure sensor tubes. Ice can form in the aftertreatment DPF differential pressure sensor tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Specification

  • If damage, kinks or blockages are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace DPF differential pressure sensor tubes.

Refer to Procedure 011-047

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

6 - Aftertreatment DPF differential pressure sensor stuck in-range

Solution: S00000793

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the aftertreatment DPF differential pressure sensor voltage.

Refer to Procedure 019-443

Specification

  • If the aftertreatment DPF differential pressure sensor voltage readings are not within specification, then a malfunctioning aftertreatment DPF differential pressure sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Leaks in the intake air system

Solution: S00008386

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.
  • Visually inspect the intake plumbing for possible air leaks.

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Charge air cooler system leak

Solution: S00008815

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the charge air cooler hoses for possible air leaks.
  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If a leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the charge air cooler.

Refer to Procedure 010-027

  • Repair or replace the charge air cooler hoses.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Aftertreatment temperature sensor stuck in-range

Solution: S00000338

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Start the engine.

Action

  • Run the engine at high idle for the following minutes: 10
  • Use the recommended Cummins® electronic service tool or equivalent.

Monitor the following parameters:

  • Aftertreatment diesel oxidation catalyst intake temperature
  • Aftertreatment diesel particulate filter intake temperature
  • Aftertreatment diesel particulate filter outlet temperature

Specification

  • A malfunctioning aftertreatment exhaust gas temperature sensor has been detected if each sensor is not within the following specification of the others: 24 C [43 F]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - Aftertreatment DPF partially obstructed or plugged

Solution: S00004187

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • If the aftertreatment DPF has already been replaced during this repair, then proceed to the next solution.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Particulate Filter Automated Restriction Test.

Refer to Procedure 011-085

Specification

  • If the Aftertreatment Diesel Particulate Filter Automated Restriction Test exceeds the limits called out in procedure, then a plugged or restricted aftertreatment DPF has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF.

Refer to Procedure 011-041

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

11 - Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test

Solution: S00003823

Verification

Conditions

  • Reconnect previously disconnected components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test.

Refer to Procedure 014-027

  • Verify the recommended Cummins® electronic service tool or equivalent has a version that supports this test.

Refer to Procedure 014-027

Specification

  • If the Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test does not pass, then reset the search to Aftertreatment Diesel Particulate Filter Regeneration Analyzer Did Not Pass. Only select the solution title that matches the error messages in the recommend Cummins® electronic service tool or equivalent.
  • If the Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test will not start, then reset the search to Aftertreatment Diesel Particulate Filter Regeneration Analyzer Did Not Start.
  • If the Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test does not complete, then reset the search to Aftertreatment Diesel Particulate Filter Regeneration Analyzer Did Not Complete.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

12 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3382 | SPN: 3058 | FMI: 18
Engine Exhaust Gas Recirculation (EGR) System - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Restricted intake air filter
  3. Leaking EGR differential pressure sensor mounting surface
  4. Plugged EGR differential pressure sensor supply ports
  5. Leaks in the intake air system
  6. EGR cooler plugged or restricted
  7. Charge air cooler system leak
  8. EGR valve restricted
  9. Plugged or damaged exhaust gas pressure sensor tube
  10. ECM calibration revision history check
  11. EGR differential pressure sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000291

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • EGR: 1228, 1896, 2272, 2349, 2351, 2352, 2353
  • EGR differential pressure: 1866, 2273, 2274
  • Turbocharger: 1898, 2387
  • Intake throttle: 175, 176, 177, 3539, 3541, 3542
  • Intake manifold: 125
  • Exhaust gas pressure: 2554

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Restricted intake air filter

Solution: S00000025

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Specification

  • If the intake air filter is plugged, then a restricted intake air filter has been detected.

Linked Solutions

  • None

Repair

  • Replace the air filter.

Refer to OEM Service Manual

Refer to Procedure 010-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Leaking EGR differential pressure sensor mounting surface

Solution: S00001114

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Inspect the o-rings between the EGR differential pressure sensor and the mounting surface.

Refer to Procedure 019-370

  • Inspect the EGR differential pressure sensor.

Refer to Procedure 019-370

Leaks can be easily noted by traces of soot, however, the sensor will need to be removed to inspect the o-rings between the EGR differential pressure sensor and the mounting surface.

Specification

  • If leaks are detected at the EGR differential pressure sensor mounting surface, then proceed to the Repair section.
  • If any carbon buildup is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean or replace the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Clean the EGR differential pressure sensor mounting surface.

Refer to Procedure 011-066

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Plugged EGR differential pressure sensor supply ports

Solution: S00000795

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the EGR mass measurement flow assembly.

Refer to Procedure 011-066

  • Visually inspect the EGR differential pressure sensor flow port cross-drillings for soot blockage.

Refer to Procedure 011-066

  • Visually inspect the exhaust gas entrance ports for soot blockage.

Refer to Procedure 011-066

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Remove and clean the EGR mass measurement flow assembly.

Refer to Procedure 011-066

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Leaks in the intake air system

Solution: S00008386

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.
  • Visually inspect the intake plumbing for possible air leaks.

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - EGR cooler plugged or restricted

Solution: S00001116

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the EGR cooler.

Refer to Procedure 011-019

  • Service Bulletin is available.

Refer to Service Bulletin 2883594

Specification

  • If the EGR cooler is restricted, then clear the restriction from the EGR cooler.
  • If the EGR cooler restriction cannot be cleared, then a malfunctioning EGR cooler has been detected.

Linked Solutions

  • None

Repair

  • Clean and reinstall or replace the EGR Cooler.

Refer to Procedure 011-019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Charge air cooler system leak

Solution: S00008815

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the charge air cooler hoses for possible air leaks.
  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If a leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the charge air cooler.

Refer to Procedure 010-027

  • Repair or replace the charge air cooler hoses.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - EGR valve restricted

Solution: S00000681

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the EGR valve.

Refer to Procedure 011-022

  • Visually inspect the EGR valve.

Refer to Procedure 011-022

Specification

  • If debris is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean the EGR valve.

Refer to Procedure 011-022

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Plugged or damaged exhaust gas pressure sensor tube

Solution: S00000703

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

  • Inspect the exhaust gas pressure sensor tube for cracks and thread damage.

Refer to Procedure 011-027

  • Inspect the inside of the tube and sensor adapter for debris or soot buildup.

Refer to Procedure 011-027

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the exhaust gas pressure sensor tube.

Refer to Procedure 011-027

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

11 - EGR differential pressure sensor is malfunctioning

Solution: S00003480

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the EGR differential pressure sensor.

Refer to Procedure 019-370

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3383 | SPN: 3058 | FMI: 16
Engine Exhaust Gas Recirculation (EGR) System - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Technical Service Bulletin is available
  2. Check for primary fault codes
  3. Leaking EGR differential pressure sensor mounting surface
  4. Plugged EGR differential pressure sensor supply ports
  5. EGR valve restricted
  6. High exhaust restriction
  7. ECM calibration revision history check
  8. EGR differential pressure sensor is malfunctioning

1 - Technical Service Bulletin is available

Solution: S00008721

Verification

Conditions

  • Turn keyswitch OFF.
  • Verify OEM is Kenworth™.

Action

  • If this engine is not in a Kenworth™ application, then proceed to the next solution.
  • Technical Service Bulletin is available.

Refer to tsb160065

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Check for primary fault codes

Solution: S00000295

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • EGR: 1228, 1896, 2272, 2349, 2351, 2352, 2353
  • EGR differential pressure: 1866, 2273, 2274
  • Turbocharger: 1898, 2387, 3616
  • Intake manifold: 124, 125
  • Intake throttle: 175, 176, 177, 3539, 3541, 3542

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

3 - Leaking EGR differential pressure sensor mounting surface

Solution: S00001114

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Inspect the o-rings between the EGR differential pressure sensor and the mounting surface.

Refer to Procedure 019-370

  • Inspect the EGR differential pressure sensor.

Refer to Procedure 019-370

Leaks can be easily noted by traces of soot, however, the sensor will need to be removed to inspect the o-rings between the EGR differential pressure sensor and the mounting surface.

Specification

  • If leaks are detected at the EGR differential pressure sensor mounting surface, then proceed to the Repair section.
  • If any carbon buildup is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean or replace the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Clean the EGR differential pressure sensor mounting surface.

Refer to Procedure 011-066

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Plugged EGR differential pressure sensor supply ports

Solution: S00000795

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the EGR mass measurement flow assembly.

Refer to Procedure 011-066

  • Visually inspect the EGR differential pressure sensor flow port cross-drillings for soot blockage.

Refer to Procedure 011-066

  • Visually inspect the exhaust gas entrance ports for soot blockage.

Refer to Procedure 011-066

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Remove and clean the EGR mass measurement flow assembly.

Refer to Procedure 011-066

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - EGR valve restricted

Solution: S00000681

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the EGR valve.

Refer to Procedure 011-022

  • Visually inspect the EGR valve.

Refer to Procedure 011-022

Specification

  • If debris is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean the EGR valve.

Refer to Procedure 011-022

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - High exhaust restriction

Solution: S00000324

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the exhaust restriction.

Refer to Procedure 011-009

Specification

  • If the exhaust restriction is not within specification, then a restriction in the exhaust has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Check the face of the aftertreatment diesel oxidation catalyst for plugging.

Refer to Procedure 011-049

  • Check the face of the aftertreatment diesel particulate filter for plugging.

Refer to Procedure 011-041

  • Check for deposits in the decomposition tube.

Refer to Procedure 011-062

  • Check the face of the aftertreatment SCR catalyst for plugging.

Refer to Procedure 011-036

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - EGR differential pressure sensor is malfunctioning

Solution: S00003480

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the EGR differential pressure sensor.

Refer to Procedure 019-370

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3385 | SPN: 105 | FMI: 18
Intake Manifold 1 Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Intake manifold temperature sensor stuck in-range
  2. OEM ambient air temperature sensor stuck in-range
  3. ECM calibration revision history check

1 - Intake manifold temperature sensor stuck in-range

Solution: S00000334

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the intake manifold temperature sensor reading to an infrared thermometer or a known value.

Specification

  • The sensor reading between the recommended Cummins® electronic service tool or equivalent and the known value must be within: +/- 10C [18F]

Linked Solutions

  • None

Repair

  • Clean or replace intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - OEM ambient air temperature sensor stuck in-range

Solution: S00000339

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the OEM ambient air temperature sensor.

Specification

  • A malfunctioning temperature sensor has been detected if the temperature sensor is not within the following specification of local ambient air temperature: 5°F [2.8°C]

Linked Solutions

  • None

Repair

  • Replace the ambient air temperature sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3396 | SPN: 3750 | FMI: 31
Aftertreatment Diesel Particulate Filter 1 Conditions Not Met for Active Regeneration - Condition Exists

Troubleshooting Summary

  1. Turbocharger is malfunctioning
  2. ECM calibration revision history check
  3. Stationary aftertreatment regeneration is needed

1 - Turbocharger is malfunctioning

Solution: S00005253

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the intake and exhaust connections from the turbocharger.

Action

  • Inspect the turbocharger compressor and turbine blades for damage or wear.

Refer to Procedure 010-033

Specification

  • If any of the checks are not within specification, then a malfunctioning turbocharger has been detected.

Linked Solutions

  • None

Repair

  • Replace the turbocharger.

Refer to Procedure 010-033

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Stationary aftertreatment regeneration is needed

Solution: S00001113

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the Aftertreatment Diesel Particulate Filter regeneration test.

Refer to Procedure 014-016

Specification

  • If the aftertreatment stationary regeneration does not complete, then reset the Search to stationary regeneration will not complete.
  • If the aftertreatment stationary regeneration does not activate, then reset the Search to stationary regeneration will not start.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3418 | SPN: 191 | FMI: 19
Transmission Output Shaft Speed - Received Network Data in Error

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3422 | SPN: 4344 | FMI: 3
Aftertreatment 1 Diesel Exhaust Fluid Line Heater 3 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid line heater 3 short circuit
  2. Aftertreatment diesel exhaust fluid line heater relay is malfunctioning
  3. OEM wiring harness has a short to battery
  4. Aftertreatment diesel exhaust fluid line heater is malfunctioning
  5. Aftertreatment diesel exhaust fluid line heater resistance check
  6. Aftertreatment diesel exhaust fluid line heater pin shorted to another pin

1 - Aftertreatment diesel exhaust fluid line heater 3 short circuit

Solution: S00001373

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater 3 SIGNAL pin and the aftertreatment diesel exhaust fluid line heater 3 SUPPLY pin at the aftertreatment diesel exhaust fluid line heater 3 connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not between 2 Ω and 100 Ω, a short circuit has been detected in the aftertreatment diesel exhaust fluid line heater 3.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid line heater.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid line heater relay is malfunctioning

Solution: S00000796

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid line heater relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - OEM wiring harness has a short to battery

Solution: S00001131

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the OEM wiring harness.
  • Connect the OEM wiring harness to the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment diesel exhaust fluid line heater SIGNAL pin and the aftertreatment diesel exhaust fluid line heater RETURN pin at the aftertreatment diesel exhaust fluid line heater connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the voltage is within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid line heater is malfunctioning

Solution: S00003290

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the Linked Solutions section if a fault code from the following list is active or has more than one inactive count within the last 25 engine operating hours: 3237, 3239, 3422

Linked Solutions

  • Aftertreatment diesel exhaust fluid line heater resistance check

Refer to S00003291

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Aftertreatment diesel exhaust fluid line heater resistance check

Solution: S00003291

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the appropriate aftertreatment diesel exhaust fluid line heater SIGNAL pin and the appropriate aftertreatment diesel exhaust fluid line heater RETURN pin at the appropriate aftertreatment diesel exhaust fluid line heater connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not between 2 Ω and 100 Ω, then a malfunctioning aftertreatment diesel exhaust fluid line heater has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid line heater.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Aftertreatment diesel exhaust fluid line heater pin shorted to another pin

Solution: S00000783

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater SIGNAL pin at the OEM wiring harness ECM connector and all other pins in the OEM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3423 | SPN: 4344 | FMI: 4
Aftertreatment 1 Diesel Exhaust Fluid Line Heater 3 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid line heater relay resistance check
  3. Aftertreatment diesel exhaust fluid line heater relay SUPPLY voltage check
  4. Aftertreatment diesel exhaust fluid line heater circuit pin to ground short
  5. Aftertreatment diesel exhaust fluid line heater pin shorted to another pin

1 - Check for primary fault codes

Solution: S00000297

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 3562, 3563, 3564

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid line heater relay resistance check

Solution: S00000802

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the OEM wiring harness.

Action

  • Check the relay.

Refer to Procedure 019-642

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid line heater relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid line heater relay SUPPLY voltage check

Solution: S00001001

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment diesel exhaust fluid line heater relay SUPPLY pin at the aftertreatment diesel exhaust fluid line heater relay OEM wiring harness connector and chassis ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuse.

Refer to OEM Service Manual

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid line heater circuit pin to ground short

Solution: S00001162

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater SIGNAL pin at the aftertreatment diesel exhaust fluid line heater connector and chassis ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment diesel exhaust fluid line heater pin shorted to another pin

Solution: S00000783

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater SIGNAL pin at the OEM wiring harness ECM connector and all other pins in the OEM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3425 | SPN: 4344 | FMI: 5
Aftertreatment 1 Diesel Exhaust Fluid Line Heater 3 Circuit - Current Below Normal or Open Circuit

Troubleshooting Summary

  1. Check for primary fault codes
  2. Check for multiple active diesel exhaust fluid line heater fault codes
  3. Aftertreatment diesel exhaust fluid line heater relay voltage check
  4. Aftertreatment diesel exhaust fluid line heater relay voltage check
  5. Aftertreatment diesel exhaust fluid line heater voltage check
  6. Wiring harness load test
  7. Aftertreatment diesel exhaust fluid line heater open circuit check
  8. Aftertreatment diesel exhaust fluid line heater wire shorted to ground
  9. Aftertreatment diesel exhaust fluid line heater is malfunctioning

1 - Check for primary fault codes

Solution: S00000298

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 3562, 3563, 3564

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Check for multiple active diesel exhaust fluid line heater fault codes

Solution: S00000806

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the Linked Solutions section if all fault codes from the following list are active: 3258, 3261, 3425

Linked Solutions

Click on the link below:

  • Aftertreatment diesel exhaust fluid line heater relay voltage check

Refer to S00000807

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Aftertreatment diesel exhaust fluid line heater relay voltage check

Solution: S00000807

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the aftertreatment diesel exhaust fluid line heater relay SUPPLY pin at the aftertreatment diesel exhaust fluid line heater relay OEM wiring harness connector and chassis ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A short circuit has been detected if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Aftertreatment diesel exhaust fluid line heater relay voltage check

Solution: S00000367

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid line heater from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment diesel exhaust fluid line heater SIGNAL pin and the aftertreatment diesel exhaust fluid line heater RETURN pin at the aftertreatment diesel exhaust fluid line heater connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is within the following specification: 4 - 6 VDC

Linked Solutions

  • Aftertreatment diesel exhaust fluid line heater voltage check

Refer to S00002909

  • Wiring harness load test

Refer to S00000877

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Aftertreatment diesel exhaust fluid line heater voltage check

Solution: S00002909

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid line heater from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment diesel exhaust fluid line heater SIGNAL pin and the aftertreatment diesel exhaust fluid line heater RETURN pin at the aftertreatment diesel exhaust fluid line heater connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the voltage is not within the following specification: 4 - 6 VDC

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.2 - Wiring harness load test

Solution: S00000877

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect all components on the wiring circuit being tested.

Action

This test is NOT for checking the J1939 data link (+) and (-) pins since it may cause damage to the J1939 smart devices or sensors.

  • Perform the wiring harness load test for the circuit being tested.

Refer to Procedure 019-359

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the voltage drop is not within specification, then a malfunctioning wiring harness has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Aftertreatment diesel exhaust fluid line heater open circuit check

Solution: S00000808

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater SIGNAL pin at the aftertreatment diesel exhaust fluid line heater connector and the aftertreatment diesel exhaust fluid line heater SIGNAL pin at the OEM wiring harness connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater SIGNAL pin at the aftertreatment diesel exhaust fluid line heater OEM wiring harness connector and the aftertreatment diesel exhaust fluid line heater relay SIGNAL pin at the aftertreatment diesel exhaust fluid line heater relay OEM wiring harness connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater RETURN pin at the aftertreatment diesel exhaust fluid line heater connector and the aftertreatment diesel exhaust fluid line heater RETURN pin at the OEM wiring harness connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment diesel exhaust fluid line heater wire shorted to ground

Solution: S00000812

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater RETURN pin at the aftertreatment diesel exhaust fluid line heater connector and chassis ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment diesel exhaust fluid line heater is malfunctioning

Solution: S00003985

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid line heater.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3446 | SPN: 3222 | FMI: 5
Aftertreatment Intake Gas Sensor Heater - Current Below Normal or Open Circuit

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Aftertreatment intake NOx sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000299

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment NOx: 3232, 3682

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment intake NOx sensor is malfunctioning

Solution: S00007913

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment intake NOx sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3488 | SPN: 563 | FMI: 9
Anti-Lock Braking (ABS) Controller - Abnormal Update Rate

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3492 | SPN: 251 | FMI: 10
Real Time Clock - Abnormal Rate of Change

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM Malfunction
  3. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000300

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • ECM: 111

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM Malfunction

Solution: S00002899

Verification

Conditions

  • Engine not running.

Action

  • Keyswitch OFF 1 minute.
  • Keyswitch ON 15 minutes.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3497 | SPN: 1761 | FMI: 17
Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid level is low
  2. Aftertreatment diesel exhaust fluid tank level sensor circuit is malfunctioning
  3. ECM calibration revision history check

1 - Aftertreatment diesel exhaust fluid level is low

Solution: S00000798

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Fill the aftertreatment diesel exhaust fluid tank.

Refer to OEM Service Manual

Specification

  • If the fault code goes inactive, proceed to Repair section.

Linked Solutions

  • None

Repair

  • Fill the aftertreatment diesel exhaust fluid tank completely full.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid tank level sensor circuit is malfunctioning

Solution: S00000546

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually check the level of the aftertreatment diesel exhaust fluid in the aftertreatment diesel exhaust fluid tank.
  • Monitor the position of the aftertreatment diesel exhaust fluid level with the recommended Cummins® electronic service tool or equivalent.
  • Compare the reading from the recommended Cummins® electronic service tool or equivalent to the actual level of the aftertreatment diesel exhaust fluid.

Specification

  • If the actual aftertreatment diesel exhaust fluid level is within specification and the recommended Cummins® electronic service tool or equivalent reading is not the same as the actual level, then a malfunctioning aftertreatment diesel exhaust fluid level sensor have been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid tank level sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3498 | SPN: 1761 | FMI: 18
Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid level is low
  2. Aftertreatment diesel exhaust fluid tank level sensor circuit is malfunctioning
  3. ECM calibration revision history check

1 - Aftertreatment diesel exhaust fluid level is low

Solution: S00000798

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Fill the aftertreatment diesel exhaust fluid tank.

Refer to OEM Service Manual

Specification

  • If the fault code goes inactive, proceed to Repair section.

Linked Solutions

  • None

Repair

  • Fill the aftertreatment diesel exhaust fluid tank completely full.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid tank level sensor circuit is malfunctioning

Solution: S00000546

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually check the level of the aftertreatment diesel exhaust fluid in the aftertreatment diesel exhaust fluid tank.
  • Monitor the position of the aftertreatment diesel exhaust fluid level with the recommended Cummins® electronic service tool or equivalent.
  • Compare the reading from the recommended Cummins® electronic service tool or equivalent to the actual level of the aftertreatment diesel exhaust fluid.

Specification

  • If the actual aftertreatment diesel exhaust fluid level is within specification and the recommended Cummins® electronic service tool or equivalent reading is not the same as the actual level, then a malfunctioning aftertreatment diesel exhaust fluid level sensor have been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid tank level sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3525 | SPN: 84 | FMI: 19
Wheel-Based Vehicle Speed - Received Network Data in Error

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3526 | SPN: 84 | FMI: 9
Wheel-Based Vehicle Speed - Abnormal Update Rate

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3527 | SPN: 558 | FMI: 19
Accelerator Pedal or Lever Idle Validation Switch - Received Network Data in Error

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check
  3. Accelerator pedal is malfunctioning

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Accelerator pedal is malfunctioning

Solution: S00001185

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning accelerator pedal has been detected.

Linked Solutions

  • None

Repair

  • Replace the accelerator pedal.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3528 | SPN: 558 | FMI: 9
Accelerator Pedal or Lever Idle Validation Switch - Abnormal Update Rate

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3539 | SPN: 51 | FMI: 3
Engine Intake Throttle Actuator Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Engine intake throttle actuator voltage check
  3. Engine intake throttle actuator voltage check at the ECM
  4. Engine intake throttle actuator circuit response
  5. Engine intake throttle actuator circuit response at the ECM

1 - Check for primary fault codes

Solution: S00000183

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386
  • Sensor supply 2: 187, 227

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Engine intake throttle actuator voltage check

Solution: S00000818

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the engine intake throttle actuator position +5-VDC SUPPLY pin and the engine intake throttle actuator position RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Engine intake throttle actuator voltage check at the ECM

Refer to S00008140

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Engine intake throttle actuator voltage check at the ECM

Solution: S00008140

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the engine intake throttle actuator position sensor SUPPLY pin and the engine intake throttle actuator position sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75-5.25VDC
  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75-5.25VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Engine intake throttle actuator circuit response

Solution: S00000394

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the engine intake throttle actuator position sensor RETURN pin and the engine intake throttle actuator position sensor SIGNAL pin at the engine intake throttle actuator connector of the engine wiring harness.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

The SIGNAL pin is pin 5 and the RETURN pin is pin 4 at the engine intake throttle actuator on the ISX engines.

The SIGNAL pin is pin 2 and the RETURN pin is pin 3 at the engine intake throttle actuator on the ISB/ISL engines.

Specification

  • A malfunctioning engine intake throttle actuator has been detected if the following fault code became active with the jumper wire in place: 3541

Linked Solutions

  • None

Repair

  • Replace the engine intake throttle actuator.

Refer to Procedure 010-140

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Engine intake throttle actuator circuit response at the ECM

Solution: S00000395

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the engine intake throttle actuator position sensor SIGNAL pin and the engine intake throttle actuator position sensor RETURN pin at the ECM connector.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the jumper wire in place: 3541
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the jumper wire in place: 3541

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3541 | SPN: 51 | FMI: 4
Engine Intake Throttle Actuator Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Engine intake throttle actuator voltage check
  3. Engine intake throttle actuator voltage check at the ECM
  4. Engine intake throttle actuator circuit response
  5. Engine intake throttle actuator circuit response at the ECM

1 - Check for primary fault codes

Solution: S00000183

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386
  • Sensor supply 2: 187, 227

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Engine intake throttle actuator voltage check

Solution: S00000818

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the engine intake throttle actuator position +5-VDC SUPPLY pin and the engine intake throttle actuator position RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Engine intake throttle actuator voltage check at the ECM

Refer to S00008140

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Engine intake throttle actuator voltage check at the ECM

Solution: S00008140

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the engine intake throttle actuator position sensor SUPPLY pin and the engine intake throttle actuator position sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75-5.25VDC
  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75-5.25VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Engine intake throttle actuator circuit response

Solution: S00001369

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

The SIGNAL pin is pin 5 and the RETURN pin is pin 4 at the engine intake throttle actuator on the ISX engines.

The SIGNAL pin is pin 2 and the RETURN pin is pin 3 at the engine intake throttle actuator on the ISB/ISL engines.

Specification

  • A malfunctioning engine intake throttle actuator has been detected if the following fault code became active with the actuator disconnected: 3539

Linked Solutions

  • None

Repair

  • Replace the engine intake throttle actuator.

Refer to Procedure 010-140

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Engine intake throttle actuator circuit response at the ECM

Solution: S00001368

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if the following fault code does not become active with the engine wiring harness disconnected: 3539
  • A malfunctioning engine wiring harness has been detected if the following fault code became active with the engine wiring harness disconnected: 3539

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3542 | SPN: 51 | FMI: 2
Engine Intake Throttle Actuator Position Sensor - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Ice buildup in the air system components
  3. EGR valve plugged or restricted with ice
  4. Incorrect air compressor discharge line routing
  5. Air compressor discharge line plugged or restricted with ice
  6. Restricted engine intake throttle
  7. Engine intake throttle actuator voltage check
  8. Engine intake throttle actuator voltage check at the ECM
  9. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000303

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 1: 352, 386
  • Sensor supply 2: 187, 227
  • Intake throttle: 3539, 3541

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Ice buildup in the air system components

Solution: S00006422

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the engine was operating in temperatures at or below: 5° C [41° F]

Ice can form causing obstruction/sticking and may not be present at the time of troubleshooting.

Specification

  • Proceed to the Linked Solutions section if the engine was operating in temperatures at or below the following specification: 5° C [41° F]

Linked Solutions

  • EGR valve plugged or restricted with ice

Refer to S00007344

  • Incorrect air compressor discharge line routing

Refer to S00001254

  • Air compressor discharge line plugged or restricted with ice

Refer to S00001255

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - EGR valve plugged or restricted with ice

Solution: S00007344

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the EGR valve.
  • Visually inspect the EGR valve for ice plugging.

Refer to Procedure 011-022

Specification

  • If the EGR valve is plugged with ice, then an EGR valve restriction has been detected.

Linked Solutions

  • None

Repair

  • Clean or replace the EGR valve.

Refer to Procedure 011-022

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Incorrect air compressor discharge line routing

Solution: S00001254

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually verify the air compressor discharge line maintains a constant downward slope from the air compressor to the air dryer inlet fitting.

Refer to OEM Service Manual

Specification

  • If the air compressor discharge line does not have a continuous downward slope from the air compressor to the air dryer inlet fitting, then an incorrect air compressor discharge line routing has been detected.

Linked Solutions

  • None

Repair

  • Route the air compressor discharge line so it maintains a constant downward slope.

Refer to OEM Service Manual

Validation

  • None
Parent Solution

2.3 - Air compressor discharge line plugged or restricted with ice

Solution: S00001255

Verification

Conditions

  • Turn keyswitch OFF.
  • Air compressor discharge line removed.

Action

  • Visually inspect the air discharge line for ice plugging.
  • Visually inspect the air discharge line at the air dryer connection for moisture that could freeze and plug the air discharge line or fittings.

Specification

  • If the air compressor discharge line is plugged with ice, then an air compressor discharge line restriction has been detected.
  • If the air compressor discharge line has a lot of moisture in it, then excessive moisture has been detected in the air compressor discharge line.

Linked Solutions

  • None

Repair

  • Clear the moisture or ice from the air compressor discharge line.

Refer to OEM Service Manual

Validation

  • None
Parent Solution

3 - Restricted engine intake throttle

Solution: S00000495

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the engine intake throttle for restriction, stuck or debris blocking the throttle plate.

Refer to Procedure 010-140

Specification

  • If the throttle plate does not operate freely with no restriction, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Remove the obstruction.

Refer to Procedure 010-140

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Engine intake throttle actuator voltage check

Solution: S00000818

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the engine intake throttle actuator position +5-VDC SUPPLY pin and the engine intake throttle actuator position RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Engine intake throttle actuator voltage check at the ECM

Refer to S00008140

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Engine intake throttle actuator voltage check at the ECM

Solution: S00008140

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the engine intake throttle actuator position sensor SUPPLY pin and the engine intake throttle actuator position sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75-5.25VDC
  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75-5.25VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3543 | SPN: 4094 | FMI: 31
NOx Limits Exceeded Due to Insufficient Reagent Quality - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid is contaminated
  3. Leaks in the intake air system
  4. Aftertreatment exhaust system leaks
  5. Charge air cooler system leak
  6. Aftertreatment Diesel Exhaust Fluid Doser Pump Override test
  7. Aftertreatment diesel exhaust fluid dosing valve is malfunctioning
  8. Aftertreatment SCR System Test
  9. Aftertreatment diesel exhaust fluid dosing system test failed
  10. Aftertreatment intake NOx sensor failed
  11. Aftertreatment outlet NOx sensor - Inspection
  12. Inspect both aftertreatment NOx sensors
  13. Aftertreatment SCR Catalyst Test Failed
  14. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000304

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment NOx: 1885, 1887, 2771, 3232, 3545, 3583, 3649, 3681, 3682, 3717, 3718, 3725, 3726, 3748, 3749
  • Aftertreatment diesel exhaust fluid system: 1681, 1682, 3547, 3568, 3569, 3574, 3575, 3596

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid is contaminated

Solution: S00000563

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Use a diesel exhaust fluid refractometer to measure the concentration of the diesel exhaust fluid in the tank.

Refer to Service Bulletin 4021566

Specification

  • If there are signs of contaminates in the aftertreatment diesel exhaust fluid, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to Procedure 011-056

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Leaks in the intake air system

Solution: S00008386

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.
  • Visually inspect the intake plumbing for possible air leaks.

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment exhaust system leaks

Solution: S00001008

Verification

Conditions

  • Engine running.

Action

  • Visually inspect for leaks in the exhaust manifold to head.

Refer to Procedure 010-024

  • Visually inspect for leaks from the turbocharger to exhaust manifold.

Refer to Procedure 010-024

  • Visually inspect for leaks in the exhaust plumbing between the turbocharger outlet and the Aftertreatment DOC intake connection.

Refer to Procedure 010-024

  • Visually inspect the exhaust piping for leaks, cracks, and loose connections.

Refer to Procedure 010-024

  • Inspect for leaks at the aftertreatment DOC housing, sensor ports and connection points.

Refer to Procedure 010-024

  • Visually inspect the aftertreatment and SCR components for exhaust leaks.

Refer to Procedure 010-024

Specification

  • If there is any damage or leaks found in the exhaust system, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the exhaust manifold.

Refer to Procedure 011-007

  • Repair or replace the exhaust plumbing.

Refer to Procedure 011-007

Refer to OEM Service Manual

  • Replace aftertreatment DOC.

Refer to Procedure 011-049

  • Replace the aftertreatment diesel particulate filter.

Refer to Procedure 011-041

  • Replace the aftertreatment SCR Catalyst.

Refer to Procedure 011-036

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Charge air cooler system leak

Solution: S00008815

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the charge air cooler hoses for possible air leaks.
  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If a leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the charge air cooler.

Refer to Procedure 010-027

  • Repair or replace the charge air cooler hoses.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment Diesel Exhaust Fluid Doser Pump Override test

Solution: S00002761

Verification

Conditions

  • Reconnect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank if they have been previously disconnected during troubleshooting.

Action

  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.

Refer to Procedure 011-059

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

The Aftertreatment Diesel Exhaust Fluid Doser Pump Override test can only be ran twice before a key cycle needs to be performed.

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test meets the specification, then proceed to the next solution.
  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test does not meet the specification, then proceed to the Linked Solutions section.

Linked Solutions

Click on the link below:

  • Aftertreatment diesel exhaust fluid dosing valve is malfunctioning

Refer to S00002764

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6.1 - Aftertreatment diesel exhaust fluid dosing valve is malfunctioning

Solution: S00002764

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Clean the aftertreatment diesel exhaust fluid dosing valve.
  • Turn keyswitch ON.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

7 - Aftertreatment SCR System Test

Solution: S00000541

Verification

Conditions

  • Connect all components.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment SCR System Test.

Refer to Procedure 014-025

If the Aftertreatment SCR System Test is not available on the recommended Cummins® electronic service tool or equivalent, update to the latest ECM Calibration Revision and then perform the Aftertreatment SCR System Test.

Specification

  • If the Aftertreatment SCR System Test does not pass, then proceed to the Linked Solutions section.

If the Aftertreatment SCR System Test does not activate, then reset the Search to Aftertreatment SCR System Test does not activate.

If the Aftertreatment SCR System Test does not complete, then reset the Search to Aftertreatment SCR System Test does not complete.

If the Aftertreatment SCR System Test displays "Deposit Burn Failed", the test should keep running and no repair action is required unless a Aftertreatment Intake or Outlet NOx sensor failure is detected.

Linked Solutions

  • Aftertreatment diesel exhaust fluid dosing system test failed

Refer to S00000552

  • Aftertreatment intake NOx sensor failed

Refer to S00000867

  • Aftertreatment outlet NOx sensor - Inspection

Refer to S00000567

  • Inspect both aftertreatment NOx sensors

Refer to S00000566

  • Aftertreatment SCR catalyst test failed

Refer to S00000565

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

7.1 - Aftertreatment diesel exhaust fluid dosing system test failed

Solution: S00000552

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If there are signs of contaminates in the diesel exhaust fluid, then proceed to the Repair section.
  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump override test displays FAILED, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to OEM Service Manual

  • For a Aftertreatment Diesel Exhaust Fluid Doser Pump override test displaying FAILED, then follow the repair instructions in the procedure.

Refer to Procedure 011-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

7.2 - Aftertreatment intake NOx sensor failed

Solution: S00000867

Verification

Conditions

  • None

Action

  • Verify that the aftertreatment intake NOx sensor is displayed as FAILED.

Specification

  • If the SCR System test displays that the intake NOx sensor has FAILED, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

7.3 - Aftertreatment outlet NOx sensor - Inspection

Solution: S00000567

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the decomposition tube for deposits.

Refer to Procedure 011-062

  • Visually inspect the aftertreatment diesel exhaust fluid tank connections for cracks or pitting.

Refer to OEM Service Manual

  • Connect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank.
  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-080

  • While the test is running, inspect the diesel exhaust fluid tank connectors, diesel exhaust fluid dosing unit and dosing unit connectors, diesel exhaust fluid lines, and diesel exhaust fluid dosing valve for signs of external leaks.

Specification

  • If the aftertreatment diesel exhaust fluid dosing valve is not leaking and there are no deposits in the decomposition tube, then a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Clean and install the decomposition tube.

Refer to Procedure 011-062

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

7.4 - Inspect both aftertreatment NOx sensors

Solution: S00000566

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the decomposition tube for deposits.

Refer to Procedure 011-062

  • Visually inspect the aftertreatment diesel exhaust fluid tank connections for cracks or pitting.

Refer to OEM Service Manual

  • Connect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank.
  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-080

  • Verify proper sealing at all connection points, including diesel exhaust fluid tank, dosing unit, and dosing valve.

Specification

  • If the aftertreatment diesel exhaust fluid dosing valve is not leaking and there are no deposits in the decomposition tube, then a malfunctioning aftertreatment intake NOx sensor and a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Clean and install the decomposition tube.

Refer to Procedure 011-062

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

7.5 - Aftertreatment SCR Catalyst Test Failed

Solution: S00000565

Verification

Conditions

  • Reconnect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank if they have been previously disconnected during troubleshooting.

Action

The aftertreatment diesel exhaust fluid dosing valve must be removed and placed in a measuring container greater then 1.5 liter [50 oz] capacity to perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override test.

The Aftertreatment Diesel Exhaust Fluid Doser Pump Override test can only be ran twice before a key cycle needs to be performed.

  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is not within specification, then proceed to the Repair section.
  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is within specification, then a malfunctioning aftertreatment SCR Catalyst has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Replace the aftertreatment SCR Catalyst.

Refer to Procedure 011-036

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

8 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3545 | SPN: 3226 | FMI: 10
Aftertreatment 1 Outlet NOx Sensor - Abnormal Rate of Change

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Aftertreatment outlet NOx sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000305

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment NOx: 1887, 2771, 3681

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment outlet NOx sensor is malfunctioning

Solution: S00000587

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is active or inactive with more than one count within the last 25 engine hours, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3547 | SPN: 4096 | FMI: 31
Aftertreatment Diesel Exhaust Fluid Tank Empty - Condition Exists

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid level is low
  2. Aftertreatment diesel exhaust fluid tank level sensor circuit is malfunctioning
  3. ECM calibration revision history check

1 - Aftertreatment diesel exhaust fluid level is low

Solution: S00000798

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Fill the aftertreatment diesel exhaust fluid tank.

Refer to OEM Service Manual

Specification

  • If the fault code goes inactive, proceed to Repair section.

Linked Solutions

  • None

Repair

  • Fill the aftertreatment diesel exhaust fluid tank completely full.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid tank level sensor circuit is malfunctioning

Solution: S00000546

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually check the level of the aftertreatment diesel exhaust fluid in the aftertreatment diesel exhaust fluid tank.
  • Monitor the position of the aftertreatment diesel exhaust fluid level with the recommended Cummins® electronic service tool or equivalent.
  • Compare the reading from the recommended Cummins® electronic service tool or equivalent to the actual level of the aftertreatment diesel exhaust fluid.

Specification

  • If the actual aftertreatment diesel exhaust fluid level is within specification and the recommended Cummins® electronic service tool or equivalent reading is not the same as the actual level, then a malfunctioning aftertreatment diesel exhaust fluid level sensor have been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid tank level sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3558 | SPN: 3361 | FMI: 3
Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid dosing unit connector is malfunctioning
  2. Aftertreatment diesel exhaust fluid dosing unit open circuit check
  3. Aftertreatment diesel exhaust fluid dosing unit circuit pin to pin short
  4. Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

1 - Aftertreatment diesel exhaust fluid dosing unit connector is malfunctioning

Solution: S00003209

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.
  • Inspect all connections for corrosion or loose connections.

Specification

  • If the aftertreatment diesel exhaust fluid dosing unit connector or the aftertreatment diesel exhaust fluid dosing unit wiring harness connector show signs of diesel exhaust fluid, then a malfunctioning aftertreatment diesel exhaust fluid dosing unit connector has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

  • Repair or replace the OEM wiring harness.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid dosing unit open circuit check

Solution: S00001988

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit SUPPLY pin at the aftertreatment diesel exhaust fluid dosing unit connector of the OEM wiring harness and the aftertreatment diesel exhaust fluid dosing unit SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit RETURN pin at the aftertreatment diesel exhaust fluid dosing unit connector of the OEM wiring harness and the aftertreatment diesel exhaust fluid dosing unit RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid dosing unit circuit pin to pin short

Solution: S00001986

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit SUPPLY pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

Solution: S00001431

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid dosing unit has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3559 | SPN: 3361 | FMI: 4
Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid dosing unit connector is malfunctioning
  2. Aftertreatment diesel exhaust fluid dosing unit open circuit check
  3. Aftertreatment diesel exhaust fluid dosing unit circuit pin to ground short
  4. Aftertreatment diesel exhaust fluid dosing unit circuit pin to pin short
  5. ECM calibration revision history check
  6. Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

1 - Aftertreatment diesel exhaust fluid dosing unit connector is malfunctioning

Solution: S00003209

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.
  • Inspect all connections for corrosion or loose connections.

Specification

  • If the aftertreatment diesel exhaust fluid dosing unit connector or the aftertreatment diesel exhaust fluid dosing unit wiring harness connector show signs of diesel exhaust fluid, then a malfunctioning aftertreatment diesel exhaust fluid dosing unit connector has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

  • Repair or replace the OEM wiring harness.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid dosing unit open circuit check

Solution: S00001887

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Visually inspect the aftertreatment diesel exhaust fluid dosing unit connector for signs of contamination.
  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit temperature SIGNAL pin at the aftertreatment diesel exhaust fluid dosing unit wiring harness connector and the aftertreatment diesel exhaust fluid dosing unit temperature SIGNAL pin in the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit SUPPLY pin at the aftertreatment diesel exhaust fluid dosing unit wiring harness connector and the aftertreatment diesel exhaust fluid dosing unit SUPPLY pin in the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit RETURN pin at the aftertreatment diesel exhaust fluid dosing unit wiring harness connector and the aftertreatment diesel exhaust fluid dosing unit RETURN pin in the OEM wiring harness ECM connector.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the leaking diesel exhaust fluid line, connector or fitting.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid dosing unit circuit pin to ground short

Solution: S00004684

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit SIGNAL pin at the OEM wiring harness ECM connector and ground.
  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit SUPPLY pin at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid dosing unit circuit pin to pin short

Solution: S00001986

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit SUPPLY pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

Solution: S00001431

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid dosing unit has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3562 | SPN: 5491 | FMI: 3
Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid line heater relay is malfunctioning
  2. Aftertreatment diesel exhaust fluid line heater relay open circuit check
  3. Aftertreatment diesel exhaust fluid line heater relay circuit pin to pin short
  4. Aftertreatment diesel exhaust fluid line heater is malfunctioning

1 - Aftertreatment diesel exhaust fluid line heater relay is malfunctioning

Solution: S00000796

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid line heater relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid line heater relay open circuit check

Solution: S00000844

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relays 1,2, and 3 from the OEM wiring harness connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater relay CONTROL pin at the appropriate aftertreatment diesel exhaust fluid line heater relay OEM wiring harness connector and the appropriate aftertreatment diesel exhaust fluid line heater relay CONTROL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater relay feedback SIGNAL pin at the appropriate aftertreatment diesel exhaust fluid line heater relay OEM wiring harness connector and the appropriate aftertreatment diesel exhaust fluid line heater relay feedback SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater relay SUPPLY pin at the aftertreatment diesel exhaust fluid line heater relay OEM wiring harness connector and the aftertreatment diesel exhaust fluid line heater relay SUPPLY pin at the OEM wiring harness battery connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid line heater relay circuit pin to pin short

Solution: S00000841

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relays 1,2, and 3 from the OEM wiring harness connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater 1 relay CONTROL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater 2 relay CONTROL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater 3 relay CONTROL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid line heater is malfunctioning

Solution: S00000843

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid line heater relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid line heater relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3563 | SPN: 5491 | FMI: 4
Aftertreatment Diesel Exhaust Fluid Line Heater Relay - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid line heater relay voltage check
  2. Aftertreatment diesel exhaust fluid line heater relay open circuit check
  3. Aftertreatment diesel exhaust fluid line heater relay circuit pin to pin short
  4. Aftertreatment diesel exhaust fluid line heater is malfunctioning

1 - Aftertreatment diesel exhaust fluid line heater relay voltage check

Solution: S00001127

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relays 1,2, and 3 from the OEM wiring harness connector.

Action

  • Visually verify that the OEM fuses are not damaged or malfunctioning.

Refer to Procedure 019-198

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment diesel exhaust fluid line heater relay 1 SUPPLY at the aftertreatment diesel exhaust fluid line heater relay connector and chassis ground.
  • Measure the voltage between the aftertreatment diesel exhaust fluid line heater relay 2 SUPPLY at the aftertreatment diesel exhaust fluid line heater relay connector and chassis ground.
  • Measure the voltage between the aftertreatment diesel exhaust fluid line heater relay 3 SUPPLY at the aftertreatment diesel exhaust fluid line heater relay connector and chassis ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • An open or short circuit to ground has been detected in the aftertreatment diesel exhaust fluid line heater SUPPLY circuit if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to OEM Service Manual

  • Replace the fuse.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid line heater relay open circuit check

Solution: S00000844

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relays 1,2, and 3 from the OEM wiring harness connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater relay CONTROL pin at the appropriate aftertreatment diesel exhaust fluid line heater relay OEM wiring harness connector and the appropriate aftertreatment diesel exhaust fluid line heater relay CONTROL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater relay feedback SIGNAL pin at the appropriate aftertreatment diesel exhaust fluid line heater relay OEM wiring harness connector and the appropriate aftertreatment diesel exhaust fluid line heater relay feedback SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater relay SUPPLY pin at the aftertreatment diesel exhaust fluid line heater relay OEM wiring harness connector and the aftertreatment diesel exhaust fluid line heater relay SUPPLY pin at the OEM wiring harness battery connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid line heater relay circuit pin to pin short

Solution: S00000841

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relays 1,2, and 3 from the OEM wiring harness connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater 1 relay CONTROL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater 2 relay CONTROL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater 3 relay CONTROL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid line heater is malfunctioning

Solution: S00000843

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid line heater relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid line heater relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3567 | SPN: 5394 | FMI: 5
Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 1 Circuit - Current Below Normal or Open Circuit

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid dosing valve resistance check
  2. Aftertreatment diesel exhaust fluid dosing valve shorted to ground
  3. Aftertreatment diesel exhaust fluid dosing valve open circuit check
  4. Wiring harness load test
  5. Aftertreatment diesel exhaust fluid dosing valve circuit pin to ground short
  6. Aftertreatment diesel exhaust fluid dosing valve circuit pin to pin short

1 - Aftertreatment diesel exhaust fluid dosing valve resistance check

Solution: S00002015

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not within specification, then a malfunctioning aftertreatment diesel exhaust fluid dosing valve has been detected.

Refer to Procedure 011-059

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid dosing valve shorted to ground

Solution: S00002013

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing valve SIGNAL pin and the metal case of the aftertreatment diesel exhaust fluid dosing valve.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning aftertreatment diesel exhaust fluid dosing valve has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid dosing valve open circuit check

Solution: S00002019

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure resistance between the aftertreatment diesel exhaust fluid dosing valve RETURN pin at the OEM wiring harness ECM connector and the aftertreatment diesel exhaust fluid dosing valve RETURN pin at the OEM wiring harness aftertreatment diesel exhaust fluid dosing valve connector.
  • Measure resistance between the aftertreatment diesel exhaust fluid dosing valve SIGNAL pin at the OEM wiring harness ECM connector and the aftertreatment diesel exhaust fluid dosing valve SIGNAL pin at the OEM wiring harness aftertreatment diesel exhaust fluid dosing valve connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • Proceed to the Linked Solutions section if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • Wiring harness load test

Refer to S00000877

Repair

  • Repair or replace the OEM wiring harness.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3.1 - Wiring harness load test

Solution: S00000877

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect all components on the wiring circuit being tested.

Action

This test is NOT for checking the J1939 data link (+) and (-) pins since it may cause damage to the J1939 smart devices or sensors.

  • Perform the wiring harness load test for the circuit being tested.

Refer to Procedure 019-359

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the voltage drop is not within specification, then a malfunctioning wiring harness has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Aftertreatment diesel exhaust fluid dosing valve circuit pin to ground short

Solution: S00000846

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing valve SIGNAL pin in the OEM wiring harness ECM connector and ground.
  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing valve RETURN pin in the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment diesel exhaust fluid dosing valve circuit pin to pin short

Solution: S00001154

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment 1 diesel exhaust fluid dosing valve from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing valve SIGNAL pin in the OEM wiring harness ECM connector and all other pins in the connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3568 | SPN: 5394 | FMI: 7
Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 1 - Mechanical System Not Responding or Out of Adjustment

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid dosing valve resistance check
  3. Aftertreatment diesel exhaust fluid dosing valve shorted to ground
  4. Aftertreatment diesel exhaust fluid dosing valve circuit pin to ground short
  5. Wiring harness load test
  6. Aftertreatment diesel exhaust fluid dosing valve is malfunctioning
  7. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000306

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 3565, 3566, 3567, 3575
  • Aftertreatment differential pressure: 3571, 3572

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid dosing valve resistance check

Solution: S00002781

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning aftertreatment diesel exhaust fluid dosing valve has been detected if the resistance is not within the following specification: 11 - 18 Ω
  • Proceed to the Linked Solutions section if the resistance is within the following specification: 11 - 18 Ω

Linked Solutions

Click on the link below:

  • Aftertreatment diesel exhaust fluid dosing valve shorted to ground

Refer to S00002782

Repair

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Aftertreatment diesel exhaust fluid dosing valve shorted to ground

Solution: S00002782

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing valve SIGNAL pin and the metal case of the aftertreatment diesel exhaust fluid dosing valve.
  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing valve RETURN pin and the metal case of the aftertreatment diesel exhaust fluid dosing valve.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning aftertreatment diesel exhaust fluid dosing valve has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Aftertreatment diesel exhaust fluid dosing valve circuit pin to ground short

Solution: S00000851

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing valve SIGNAL pin in the OEM wiring harness ECM connector and the aftertreatment diesel exhaust fluid dosing valve RETURN pin in the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω
  • Proceed to the Linked Solutions section if the resistance is greater than the following specification: 100k Ω

Linked Solutions

  • Wiring harness load test

Refer to S00000877

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3.1 - Wiring harness load test

Solution: S00000877

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect all components on the wiring circuit being tested.

Action

This test is NOT for checking the J1939 data link (+) and (-) pins since it may cause damage to the J1939 smart devices or sensors.

  • Perform the wiring harness load test for the circuit being tested.

Refer to Procedure 019-359

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the voltage drop is not within specification, then a malfunctioning wiring harness has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Aftertreatment diesel exhaust fluid dosing valve is malfunctioning

Solution: S00000967

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3571 | SPN: 4334 | FMI: 3
Aftertreatment 1 Diesel Exhaust Fluid Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid pressure sensor voltage check
  3. Aftertreatment diesel exhaust fluid pressure sensor circuit check
  4. Aftertreatment diesel exhaust fluid dosing unit circuit response
  5. Aftertreatment diesel exhaust fluid pressure sensor open circuit check
  6. Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

1 - Check for primary fault codes

Solution: S00000854

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1695, 1696

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid pressure sensor voltage check

Solution: S00009257

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the aftertreatment diesel exhaust fluid pressure sensor SUPPLY pin and the aftertreatment diesel exhaust fluid pressure sensor RETURN pin at the aftertreatment diesel exhaust fluid dosing unit connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Aftertreatment diesel exhaust fluid pressure sensor circuit check

Refer to S00009258

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Aftertreatment diesel exhaust fluid pressure sensor circuit check

Solution: S00009258

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid pressure sensor SUPPLY pin in the OEM wiring harness ECM connector and the aftertreatment diesel exhaust fluid pressure sensor SUPPLY pin in the OEM wiring harness aftertreatment diesel exhaust fluid dosing unit connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid pressure sensor RETURN pin in the OEM wiring harness ECM connector and the aftertreatment diesel exhaust fluid pressure sensor RETURN pin in the OEM wiring harness aftertreatment diesel exhaust fluid dosing unit connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Aftertreatment diesel exhaust fluid dosing unit circuit response

Solution: S00002901

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning aftertreatment diesel exhaust fluid dosing unit has been detected if the following fault code became active with the aftertreatment diesel exhaust fluid dosing unit disconnected: 3572

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid pressure sensor open circuit check

Solution: S00001906

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.
  • Measure the resistance between the aftertreatment diesel exhaust fluid pressure sensor SUPPLY pin in the OEM wiring harness ECM connector and the aftertreatment diesel exhaust fluid pressure sensor SUPPLY pin in the OEM wiring harness aftertreatment diesel exhaust fluid dosing unit connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid pressure sensor SIGNAL pin in the OEM wiring harness ECM connector and the aftertreatment diesel exhaust fluid pressure sensor SIGNAL pin in the OEM wiring harness aftertreatment diesel exhaust fluid dosing unit connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid pressure sensor RETURN pin in the OEM wiring harness ECM connector and the aftertreatment diesel exhaust fluid pressure sensor RETURN pin in the OEM wiring harness aftertreatment diesel exhaust fluid dosing unit connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

Solution: S00001431

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid dosing unit has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3572 | SPN: 4334 | FMI: 4
Aftertreatment 1 Diesel Exhaust Fluid Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid dosing unit connector is malfunctioning
  3. Aftertreatment diesel exhaust fluid pressure sensor voltage check
  4. Aftertreatment diesel exhaust fluid pressure sensor circuit check
  5. Aftertreatment diesel exhaust fluid pressure sensor circuit response
  6. Aftertreatment diesel exhaust fluid pressure sensor open circuit check
  7. Aftertreatment diesel exhaust fluid pressure sensor circuit pin to ground short
  8. Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

1 - Check for primary fault codes

Solution: S00000855

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1695, 1696

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid dosing unit connector is malfunctioning

Solution: S00003209

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.
  • Inspect all connections for corrosion or loose connections.

Specification

  • If the aftertreatment diesel exhaust fluid dosing unit connector or the aftertreatment diesel exhaust fluid dosing unit wiring harness connector show signs of diesel exhaust fluid, then a malfunctioning aftertreatment diesel exhaust fluid dosing unit connector has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

  • Repair or replace the OEM wiring harness.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid pressure sensor voltage check

Solution: S00009257

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the aftertreatment diesel exhaust fluid pressure sensor SUPPLY pin and the aftertreatment diesel exhaust fluid pressure sensor RETURN pin at the aftertreatment diesel exhaust fluid dosing unit connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Aftertreatment diesel exhaust fluid pressure sensor circuit check

Refer to S00009258

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Aftertreatment diesel exhaust fluid pressure sensor circuit check

Solution: S00009258

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid pressure sensor SUPPLY pin in the OEM wiring harness ECM connector and the aftertreatment diesel exhaust fluid pressure sensor SUPPLY pin in the OEM wiring harness aftertreatment diesel exhaust fluid dosing unit connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid pressure sensor RETURN pin in the OEM wiring harness ECM connector and the aftertreatment diesel exhaust fluid pressure sensor RETURN pin in the OEM wiring harness aftertreatment diesel exhaust fluid dosing unit connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Aftertreatment diesel exhaust fluid pressure sensor circuit response

Solution: S00002920

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Place a jumper wire between the aftertreatment diesel exhaust fluid pressure sensor SIGNAL pin and aftertreatment diesel exhaust fluid pressure sensor SUPPLY pin of the dosing unit OEM wiring harness connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait 30 seconds before checking the circuit response.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning aftertreatment diesel exhaust fluid dosing unit has been detected if the following fault code became active with the jumper wire in place: 3571

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment diesel exhaust fluid pressure sensor open circuit check

Solution: S00001906

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.
  • Measure the resistance between the aftertreatment diesel exhaust fluid pressure sensor SUPPLY pin in the OEM wiring harness ECM connector and the aftertreatment diesel exhaust fluid pressure sensor SUPPLY pin in the OEM wiring harness aftertreatment diesel exhaust fluid dosing unit connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid pressure sensor SIGNAL pin in the OEM wiring harness ECM connector and the aftertreatment diesel exhaust fluid pressure sensor SIGNAL pin in the OEM wiring harness aftertreatment diesel exhaust fluid dosing unit connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid pressure sensor RETURN pin in the OEM wiring harness ECM connector and the aftertreatment diesel exhaust fluid pressure sensor RETURN pin in the OEM wiring harness aftertreatment diesel exhaust fluid dosing unit connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment diesel exhaust fluid pressure sensor circuit pin to ground short

Solution: S00001935

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid pressure sensor SIGNAL pin at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

Solution: S00001431

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid dosing unit has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3574 | SPN: 4334 | FMI: 18
Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid dosing unit connector is malfunctioning
  3. Aftertreatment diesel exhaust fluid dosing unit line or fittings are cracked, plugged or restricted
  4. Aftertreatment diesel exhaust fluid is contaminated
  5. Aftertreatment diesel exhaust fluid dosing unit suction test
  6. Aftertreatment diesel exhaust fluid dosing unit is malfunctioning
  7. Aftertreatment diesel exhaust fluid dosing unit intake restriction
  8. Air in the aftertreatment diesel exhaust fluid
  9. Aftertreatment Diesel Exhaust Fluid Doser Pump Override test
  10. Aftertreatment diesel exhaust fluid dosing valve is malfunctioning
  11. ECM calibration revision history check
  12. Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

1 - Check for primary fault codes

Solution: S00001990

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid temperature: 1712
  • Aftertreatment diesel exhaust fluid system: 1682, 1713, 1932, 1977, 3167, 3567, 3568, 4155, 4156, 4168, 4169, 4171, 4244, 4245, 4249, 4251, 4658, 5278
  • Aftertreatment diesel exhaust fluid dosing unit: 2976, 3558, 3559

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid dosing unit connector is malfunctioning

Solution: S00003209

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.
  • Inspect all connections for corrosion or loose connections.

Specification

  • If the aftertreatment diesel exhaust fluid dosing unit connector or the aftertreatment diesel exhaust fluid dosing unit wiring harness connector show signs of diesel exhaust fluid, then a malfunctioning aftertreatment diesel exhaust fluid dosing unit connector has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

  • Repair or replace the OEM wiring harness.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid dosing unit line or fittings are cracked, plugged or restricted

Solution: S00000664

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the lines are not swapped at the dosing unit, dosing valve or diesel exhaust fluid tank connections.

Refer to Procedure 011-058

  • Visually inspect the aftertreatment diesel exhaust fluid tank connections for cracks or pitting.
  • Visually inspect the aftertreatment diesel exhaust fluid tank vent line for restrictions.
  • Visually inspect the aftertreatment diesel exhaust fluid line for damage.
  • Visually inspect both dosing unit connections and fittings for loose, leaking, or damaged connections.
  • Disconnect the suction line and pressure line dosing unit connectors and look for signs of build-up or blockage.

Refer to Procedure 011-058

  • Visually inspect the suction line for signs of leakage or openings which will allow the dosing unit to suck in air with the diesel exhaust fluid.
  • Visually inspect the pressure line for signs of leakage or rupture.
  • Verify proper sealing at all connection points, including diesel exhaust fluid tank, dosing unit, and dosing valve.

Refer to Procedure 011-058

Specification

  • If there are aftertreament diesel exhaust fluid lines reversed, damaged, leaking or restricted connections found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace damaged components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid is contaminated

Solution: S00000563

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Use a diesel exhaust fluid refractometer to measure the concentration of the diesel exhaust fluid in the tank.

Refer to Service Bulletin 4021566

Specification

  • If there are signs of contaminates in the aftertreatment diesel exhaust fluid, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to Procedure 011-056

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment diesel exhaust fluid dosing unit suction test

Solution: S00000360

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the Aftertreatment Diesel Exhaust Fluid Dosing Unit Suction Test.

Refer to Procedure 011-121

Specification

  • If the vacuum in diagnostic line does not meet specification, then proceed to the Linked Solutions section.

Linked Solutions

Click on the link below:

  • Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

Refer to S00000522

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5.1 - Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

Solution: S00000522

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the Aftertreatment Diesel Exhaust Fluid Dosing Unit Non Air Flush.

Refer to Procedure 011-058

  • Perform the Aftertreatment Diesel Exhaust Fluid Dosing Unit Suction Test.

Refer to Procedure 011-121

Specification

  • A malfunctioning aftertreatment diesel exhaust fluid dosing unit has been detected if vacuum is less than the following specification: -216 mm-hg [-8.0 in-hg]
  • Excessive blockage or buildup has been detected in the aftertreatment diesel exhaust fluid dosing system and the aftertreatment diesel exhaust fluid dosing unit can be reused if the vacuum is greater than the following specification: -216 mm-hg [-8.0 in-hg]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Cleaning of the aftertreatment diesel exhaust fluid dosing system resolved the issue.
  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - Aftertreatment diesel exhaust fluid dosing unit intake restriction

Solution: S00000732

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the aftertreatment diesel exhaust fluid dosing unit intake restriction.

Refer to Procedure 011-086

Specification

  • If the vacuum in diagnostic line is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the diesel exhaust fluid tank filter.

Refer to OEM Service Manual

  • Clean or replace the aftertreatment diesel exhaust fluid intake line.

Refer to OEM Service Manual

  • Clean or replace the aftertreatment diesel exhaust fluid tank header.

Refer to OEM Service Manual

  • Clean or replace the aftertreatment diesel exhaust fluid tank vent.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Air in the aftertreatment diesel exhaust fluid

Solution: S00000730

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Check for air in the diesel exhaust fluid.

Refer to Procedure 011-075

Specification

  • If a line, fitting, connection, or dosing unit is leaking, then a malfunction has been detected in the aftertreatment diesel exhaust fluid system or dosing unit.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to Procedure 011-075

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Aftertreatment Diesel Exhaust Fluid Doser Pump Override test

Solution: S00002761

Verification

Conditions

  • Reconnect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank if they have been previously disconnected during troubleshooting.

Action

  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.

Refer to Procedure 011-059

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

The Aftertreatment Diesel Exhaust Fluid Doser Pump Override test can only be ran twice before a key cycle needs to be performed.

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test meets the specification, then proceed to the next solution.
  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test does not meet the specification, then proceed to the Linked Solutions section.

Linked Solutions

Click on the link below:

  • Aftertreatment diesel exhaust fluid dosing valve is malfunctioning

Refer to S00002764

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8.1 - Aftertreatment diesel exhaust fluid dosing valve is malfunctioning

Solution: S00002764

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Clean the aftertreatment diesel exhaust fluid dosing valve.
  • Turn keyswitch ON.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

9 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

10 - Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

Solution: S00001431

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid dosing unit has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3575 | SPN: 4334 | FMI: 16
Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid dosing unit line or fittings are cracked, plugged or restricted
  3. Aftertreatment diesel exhaust fluid dosing valve is malfunctioning
  4. ECM calibration revision history check
  5. Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

1 - Check for primary fault codes

Solution: S00001520

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid dosing unit: 3558, 3559
  • Aftertreatment diesel exhaust fluid system: 3571, 3572, 3596, 3713, 4167, 5278

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid dosing unit line or fittings are cracked, plugged or restricted

Solution: S00000664

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the lines are not swapped at the dosing unit, dosing valve or diesel exhaust fluid tank connections.

Refer to Procedure 011-058

  • Visually inspect the aftertreatment diesel exhaust fluid tank connections for cracks or pitting.
  • Visually inspect the aftertreatment diesel exhaust fluid tank vent line for restrictions.
  • Visually inspect the aftertreatment diesel exhaust fluid line for damage.
  • Visually inspect both dosing unit connections and fittings for loose, leaking, or damaged connections.
  • Disconnect the suction line and pressure line dosing unit connectors and look for signs of build-up or blockage.

Refer to Procedure 011-058

  • Visually inspect the suction line for signs of leakage or openings which will allow the dosing unit to suck in air with the diesel exhaust fluid.
  • Visually inspect the pressure line for signs of leakage or rupture.
  • Verify proper sealing at all connection points, including diesel exhaust fluid tank, dosing unit, and dosing valve.

Refer to Procedure 011-058

Specification

  • If there are aftertreament diesel exhaust fluid lines reversed, damaged, leaking or restricted connections found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace damaged components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid dosing valve is malfunctioning

Solution: S00000967

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

Solution: S00001431

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid dosing unit has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3577 | SPN: 4376 | FMI: 3
Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid dosing unit connector is malfunctioning
  2. Aftertreatment diesel exhaust fluid dosing unit has a malfunctioning return valve
  3. Aftertreatment diesel exhaust fluid return valve open circuit check
  4. Aftertreatment diesel exhaust fluid return valve circuit has a pin to pin short
  5. ECM Malfunction

1 - Aftertreatment diesel exhaust fluid dosing unit connector is malfunctioning

Solution: S00003209

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.
  • Inspect all connections for corrosion or loose connections.

Specification

  • If the aftertreatment diesel exhaust fluid dosing unit connector or the aftertreatment diesel exhaust fluid dosing unit wiring harness connector show signs of diesel exhaust fluid, then a malfunctioning aftertreatment diesel exhaust fluid dosing unit connector has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

  • Repair or replace the OEM wiring harness.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid dosing unit has a malfunctioning return valve

Solution: S00000863

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid return valve SIGNAL pin and the aftertreatment diesel exhaust fluid return valve RETURN pin at the aftertreatment diesel exhaust fluid dosing unit.

Specification

  • For 12 Volt systems, the resistance should be between 4.5 and 9 Ω.
  • For 24 Volt systems, the resistance should be between 17 and 25 Ω.

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid return valve open circuit check

Solution: S00002029

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure resistance between the aftertreatment diesel exhaust fluid return valve SIGNAL pin at the OEM wiring harness ECM connector and the aftertreatment diesel exhaust fluid return valve SIGNAL pin at the OEM wiring harness aftertreatment diesel exhaust fluid dosing unit connector.
  • Measure resistance between the aftertreatment diesel exhaust fluid return valve RETURN pin at the OEM wiring harness ECM connector and the aftertreatment diesel exhaust fluid return valve RETURN pin at the OEM wiring harness aftertreatment diesel exhaust fluid dosing unit connector.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid return valve circuit has a pin to pin short

Solution: S00000864

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid return valve SIGNAL pin at the OEM wiring harness ECM connector and all other pins in the OEM wiring harness ECM connector.
  • Perform a drag test on the diesel exhaust fluid return valve SIGNAL pin on the OEM wiring harness dosing unit connector. Refer to the Drag Test section.

Refer to Procedure 019-361

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM Malfunction

Solution: S00001622

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3578 | SPN: 4376 | FMI: 4
Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid dosing unit has a malfunctioning return valve
  2. Aftertreatment diesel exhaust fluid return valve circuit short-to-ground
  3. Aftertreatment diesel exhaust fluid return valve circuit has a pin to pin short
  4. ECM Malfunction

1 - Aftertreatment diesel exhaust fluid dosing unit has a malfunctioning return valve

Solution: S00000863

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid return valve SIGNAL pin and the aftertreatment diesel exhaust fluid return valve RETURN pin at the aftertreatment diesel exhaust fluid dosing unit.

Specification

  • For 12 Volt systems, the resistance should be between 4.5 and 9 Ω.
  • For 24 Volt systems, the resistance should be between 17 and 25 Ω.

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid return valve circuit short-to-ground

Solution: S00000865

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid return valve RETURN pin at the aftertreatment diesel exhaust fluid dosing unit harness connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid return valve circuit has a pin to pin short

Solution: S00000864

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid return valve SIGNAL pin at the OEM wiring harness ECM connector and all other pins in the OEM wiring harness ECM connector.
  • Perform a drag test on the diesel exhaust fluid return valve SIGNAL pin on the OEM wiring harness dosing unit connector. Refer to the Drag Test section.

Refer to Procedure 019-361

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM Malfunction

Solution: S00001622

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3582 | SPN: 4364 | FMI: 18
Aftertreatment SCR Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Fault Code 3582 requires that ALL solutions be performed
  2. Check for primary fault codes
  3. Aftertreatment diesel exhaust fluid is contaminated
  4. Aftertreatment exhaust system leaks
  5. Aftertreatment SCR System Test
  6. Aftertreatment diesel exhaust fluid dosing system test failed
  7. Aftertreatment intake NOx sensor failed
  8. Aftertreatment outlet NOx sensor - Inspection
  9. Inspect both aftertreatment NOx sensors
  10. Aftertreatment SCR Catalyst Test Failed
  11. ECM calibration revision history check

1 - Fault Code 3582 requires that ALL solutions be performed

Solution: S00000868

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • This solution is information only.
  • ALL solutions displayed for this fault code must be performed.
  • Continue to perform the verifications of ALL solution steps listed for this fault code regardless if a given solution is within specification or out of specification.

Specification

  • This solution is information only.

Linked Solutions

  • None

Repair

  • If a resolution is found in any solution for this fault code, continue performing ALL solutions listed for this fault code.

Validation

  • None
Next Solution

2 - Check for primary fault codes

Solution: S00000308

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold: 125
  • Intake throttle: 3542
  • Fuel: 559, 1654, 1655, 1656, 1657, 1658, 1659, 2372, 4713
  • EGR: 1896, 3382, 3383
  • EGR differential pressure: 1866
  • Turbocharger: 1894, 2636, 5177
  • Aftertreatment NOx: 1885, 1887, 2771, 3228, 3232, 3545, 3583, 3649, 3681, 3682, 3717, 3718, 3725, 3748, 3749, 4452
  • Aftertreatment SCR: 3142, 3146, 3147, 3148, 3165, 3899, 3911, 3912, 3932, 3933, 3934, 3935, 3936, 3937, 4164, 4165, 4166, 4518, 4519, 4521, 4524, 4525, 6266, 6267, 6268
  • Aftertreatment diesel exhaust fluid system: 1668, 1669, 1673, 1682, 2976, 3497, 3498, 3567, 3568, 3571, 3572, 3574, 3575, 3596, 4677, 4732, 4739, 5278
  • Aftertreatment diesel exhaust fluid dosing unit: 3558, 3559,

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

3 - Aftertreatment diesel exhaust fluid is contaminated

Solution: S00000563

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Use a diesel exhaust fluid refractometer to measure the concentration of the diesel exhaust fluid in the tank.

Refer to Service Bulletin 4021566

Specification

  • If there are signs of contaminates in the aftertreatment diesel exhaust fluid, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to Procedure 011-056

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment exhaust system leaks

Solution: S00001008

Verification

Conditions

  • Engine running.

Action

  • Visually inspect for leaks in the exhaust manifold to head.

Refer to Procedure 010-024

  • Visually inspect for leaks from the turbocharger to exhaust manifold.

Refer to Procedure 010-024

  • Visually inspect for leaks in the exhaust plumbing between the turbocharger outlet and the Aftertreatment DOC intake connection.

Refer to Procedure 010-024

  • Visually inspect the exhaust piping for leaks, cracks, and loose connections.

Refer to Procedure 010-024

  • Inspect for leaks at the aftertreatment DOC housing, sensor ports and connection points.

Refer to Procedure 010-024

  • Visually inspect the aftertreatment and SCR components for exhaust leaks.

Refer to Procedure 010-024

Specification

  • If there is any damage or leaks found in the exhaust system, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the exhaust manifold.

Refer to Procedure 011-007

  • Repair or replace the exhaust plumbing.

Refer to Procedure 011-007

Refer to OEM Service Manual

  • Replace aftertreatment DOC.

Refer to Procedure 011-049

  • Replace the aftertreatment diesel particulate filter.

Refer to Procedure 011-041

  • Replace the aftertreatment SCR Catalyst.

Refer to Procedure 011-036

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment SCR System Test

Solution: S00000541

Verification

Conditions

  • Connect all components.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment SCR System Test.

Refer to Procedure 014-025

If the Aftertreatment SCR System Test is not available on the recommended Cummins® electronic service tool or equivalent, update to the latest ECM Calibration Revision and then perform the Aftertreatment SCR System Test.

Specification

  • If the Aftertreatment SCR System Test does not pass, then proceed to the Linked Solutions section.

If the Aftertreatment SCR System Test does not activate, then reset the Search to Aftertreatment SCR System Test does not activate.

If the Aftertreatment SCR System Test does not complete, then reset the Search to Aftertreatment SCR System Test does not complete.

If the Aftertreatment SCR System Test displays "Deposit Burn Failed", the test should keep running and no repair action is required unless a Aftertreatment Intake or Outlet NOx sensor failure is detected.

Linked Solutions

  • Aftertreatment diesel exhaust fluid dosing system test failed

Refer to S00000552

  • Aftertreatment intake NOx sensor failed

Refer to S00000867

  • Aftertreatment outlet NOx sensor - Inspection

Refer to S00000567

  • Inspect both aftertreatment NOx sensors

Refer to S00000566

  • Aftertreatment SCR catalyst test failed

Refer to S00000565

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

5.1 - Aftertreatment diesel exhaust fluid dosing system test failed

Solution: S00000552

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If there are signs of contaminates in the diesel exhaust fluid, then proceed to the Repair section.
  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump override test displays FAILED, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to OEM Service Manual

  • For a Aftertreatment Diesel Exhaust Fluid Doser Pump override test displaying FAILED, then follow the repair instructions in the procedure.

Refer to Procedure 011-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.2 - Aftertreatment intake NOx sensor failed

Solution: S00000867

Verification

Conditions

  • None

Action

  • Verify that the aftertreatment intake NOx sensor is displayed as FAILED.

Specification

  • If the SCR System test displays that the intake NOx sensor has FAILED, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.3 - Aftertreatment outlet NOx sensor - Inspection

Solution: S00000567

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the decomposition tube for deposits.

Refer to Procedure 011-062

  • Visually inspect the aftertreatment diesel exhaust fluid tank connections for cracks or pitting.

Refer to OEM Service Manual

  • Connect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank.
  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-080

  • While the test is running, inspect the diesel exhaust fluid tank connectors, diesel exhaust fluid dosing unit and dosing unit connectors, diesel exhaust fluid lines, and diesel exhaust fluid dosing valve for signs of external leaks.

Specification

  • If the aftertreatment diesel exhaust fluid dosing valve is not leaking and there are no deposits in the decomposition tube, then a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Clean and install the decomposition tube.

Refer to Procedure 011-062

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.4 - Inspect both aftertreatment NOx sensors

Solution: S00000566

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the decomposition tube for deposits.

Refer to Procedure 011-062

  • Visually inspect the aftertreatment diesel exhaust fluid tank connections for cracks or pitting.

Refer to OEM Service Manual

  • Connect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank.
  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-080

  • Verify proper sealing at all connection points, including diesel exhaust fluid tank, dosing unit, and dosing valve.

Specification

  • If the aftertreatment diesel exhaust fluid dosing valve is not leaking and there are no deposits in the decomposition tube, then a malfunctioning aftertreatment intake NOx sensor and a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Clean and install the decomposition tube.

Refer to Procedure 011-062

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.5 - Aftertreatment SCR Catalyst Test Failed

Solution: S00000565

Verification

Conditions

  • Reconnect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank if they have been previously disconnected during troubleshooting.

Action

The aftertreatment diesel exhaust fluid dosing valve must be removed and placed in a measuring container greater then 1.5 liter [50 oz] capacity to perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override test.

The Aftertreatment Diesel Exhaust Fluid Doser Pump Override test can only be ran twice before a key cycle needs to be performed.

  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is not within specification, then proceed to the Repair section.
  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is within specification, then a malfunctioning aftertreatment SCR Catalyst has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Replace the aftertreatment SCR Catalyst.

Refer to Procedure 011-036

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3583 | SPN: 5031 | FMI: 10
Aftertreatment 1 Outlet NOx Sensor Heater - Abnormal Rate of Change

Troubleshooting Summary

  1. Check for primary fault codes
  2. Low battery voltage
  3. Battery load test
  4. Ground inspection
  5. Aftertreatment outlet NOx sensor voltage check
  6. Aftertreatment power relay voltage check
  7. Aftertreatment power relay resistance check
  8. Aftertreatment outlet NOx sensor circuit check
  9. Aftertreatment power relay circuit check
  10. Aftertreatment outlet NOx sensor open circuit
  11. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000309

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment NOx: 1887, 2771, 3681
  • Aftertreatment SCR: 3144, 3146, 3147, 3148

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Low battery voltage

Solution: S00001110

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.
  • If this vehicle has been repaired within the last 30 days for the same fault code, then proceed to the Linked Solutions section.

Specification

  • If the battery voltage is at least 10.8 VDC (12 volt systems) or 21.6 VDC (24 volt systems), then proceed to the Linked Solutions section.
  • If the battery or battery cables show signs of corrosion or damage, then proceed to the Repair Section.

Linked Solutions

  • Battery load test

Refer to S00001379

  • Ground inspection

Refer to S00000754

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean corrosion or tighten battery cable connections.

Refer to OEM Service Manual

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Battery load test

Solution: S00001379

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Disconnect the batteries from each other.
  • Connect a load tester separately to each battery.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.

Specification

  • For a 12 volt system, proceed to the Repair section if the battery voltage is below the following specification: 11 VDC
  • For a 24 volt system, proceed to the Repair section if the battery voltage is below the following specification: 22 VDC

Linked Solutions

  • None

Repair

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Ground inspection

Solution: S00000754

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the ECM ground for damage, corrosion and loose connections.
  • Visually inspect the aftertreatment interface wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the OEM wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the grounds for proper routing.

Specification

  • If damage, corrosion or incorrect routing of grounds are found, then proceed to the Repair section

Linked Solutions

  • None

Repair

  • Clean or replace connections.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Aftertreatment outlet NOx sensor voltage check

Solution: S00010306

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment outlet NOx sensor battery voltage SUPPLY pin and the aftertreatment outlet NOx sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 1 VDC

Linked Solutions

  • Aftertreatment power relay voltage check

Refer to S00010303

  • Aftertreatment power relay resistance check

Refer to S00010305

  • Aftertreatment outlet NOx sensor circuit check

Refer to S00010333

  • Aftertreatment power relay circuit check

Refer to S00010368

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Aftertreatment power relay voltage check

Solution: S00010303

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment power relay battery voltage SUPPLY pin in the aftertreatment power relay connector of the OEM wiring harness and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.2 - Aftertreatment power relay resistance check

Solution: S00010305

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment power relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.3 - Aftertreatment outlet NOx sensor circuit check

Solution: S00010333

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.
  • Disconnect the aftertreatment outlet NOx sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment power relay SUPPLY pin at the aftertreatment power relay connector of the OEM wiring harness and the aftertreatment power relay SUPPLY pin at the aftertreatment interface wiring harness aftertreatment outlet NOx sensor connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.4 - Aftertreatment power relay circuit check

Solution: S00010368

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment power relay CONTROL pin at the aftertreatment power relay connector of the OEM wiring harness and the aftertreatment power relay CONTROL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Aftertreatment outlet NOx sensor open circuit

Solution: S00000872

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage from the aftertreatment outlet NOx sensor battery voltage SUPPLY pin of the OEM wiring harness to the engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A short circuit has been detected if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3596 | SPN: 4334 | FMI: 2
Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid dosing unit is malfunctioning
  3. Aftertreatment OEM wiring harness connector check
  4. Aftertreatment diesel exhaust fluid dosing unit pressure sensor is malfunctioning
  5. Aftertreatment diesel exhaust fluid dosing unit open circuit check
  6. Aftertreatment diesel exhaust fluid dosing unit connector is malfunctioning
  7. Aftertreatment diesel exhaust fluid dosing unit line or fittings are cracked, plugged or restricted
  8. Aftertreatment diesel exhaust fluid is contaminated
  9. Aftertreatment diesel exhaust fluid dosing unit intake restriction
  10. Air in the aftertreatment diesel exhaust fluid
  11. Aftertreatment Diesel Exhaust Fluid Doser Pump Override test
  12. Aftertreatment diesel exhaust fluid dosing valve is malfunctioning
  13. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001402

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 5: 1695, 1696
  • Aftertreatment diesel exhaust fluid system: 3571, 3572

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

Solution: S00003271

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the snapshot data for the fault code.

Monitor the following parameters:

  • Aftertreatment diesel exhaust fluid dosing unit state.

Specification

  • If the aftertreatment diesel exhaust fluid dosing unit state parameter displays "Dosing" or "Purging" in the fault code snapshot data, then proceed to the next solution.
  • If the aftertreatment diesel exhaust fluid dosing unit state parameter does not display "Dosing" or "Purging" in the fault code snapshot data, then proceed to the Linked Solutions section.

Linked Solutions

  • Aftertreatment OEM wiring harness connector check

Refer to S00003272

  • Aftertreatment diesel exhaust fluid dosing unit pressure sensor is malfunctioning

Refer to S00003265

  • Aftertreatment diesel exhaust fluid dosing unit open circuit check

Refer to S00003276

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Aftertreatment OEM wiring harness connector check

Solution: S00003272

Verification

Conditions

  • Turn keyswitch OFF.
  • Verify OEM is Peterbilt™.

Action

  • If this engine is not in a Peterbilt™ application, then proceed to the next solution.
  • Visually inspect the aftertreatment diesel exhaust fluid dosing unit connector for proper pinning.

Refer to tsb130154

Specification

  • If loose, damaged, or corroded pins are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the aftertreatment diesel exhaust fluid dosing uint OEM wiring harness connector.

Refer to tsb130154

Validation

  • None
Parent Solution

2.2 - Aftertreatment diesel exhaust fluid dosing unit pressure sensor is malfunctioning

Solution: S00003265

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing valve supply line from the aftertreatment diesel exhaust fluid dosing valve and secure it appropriately.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the aftertreatment diesel exhaust fluid pressure.

Specification

  • A malfunctioning aftertreatment diesel exhaust fluid pressure sensor has been detected if the reading is not within the following specification: 0 ± 69 kpa [0 ± 10 psi]

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.3 - Aftertreatment diesel exhaust fluid dosing unit open circuit check

Solution: S00003276

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit RETURN pin at the aftertreatment diesel exhaust fluid dosing unit connector of the OEM wiring harness and the aftertreatment diesel exhaust fluid dosing unit RETURN pin at the OEM wiring harness ECM connector.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • None
Parent Solution

3 - Aftertreatment diesel exhaust fluid dosing unit connector is malfunctioning

Solution: S00003209

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.
  • Inspect all connections for corrosion or loose connections.

Specification

  • If the aftertreatment diesel exhaust fluid dosing unit connector or the aftertreatment diesel exhaust fluid dosing unit wiring harness connector show signs of diesel exhaust fluid, then a malfunctioning aftertreatment diesel exhaust fluid dosing unit connector has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

  • Repair or replace the OEM wiring harness.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid dosing unit line or fittings are cracked, plugged or restricted

Solution: S00000664

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the lines are not swapped at the dosing unit, dosing valve or diesel exhaust fluid tank connections.

Refer to Procedure 011-058

  • Visually inspect the aftertreatment diesel exhaust fluid tank connections for cracks or pitting.
  • Visually inspect the aftertreatment diesel exhaust fluid tank vent line for restrictions.
  • Visually inspect the aftertreatment diesel exhaust fluid line for damage.
  • Visually inspect both dosing unit connections and fittings for loose, leaking, or damaged connections.
  • Disconnect the suction line and pressure line dosing unit connectors and look for signs of build-up or blockage.

Refer to Procedure 011-058

  • Visually inspect the suction line for signs of leakage or openings which will allow the dosing unit to suck in air with the diesel exhaust fluid.
  • Visually inspect the pressure line for signs of leakage or rupture.
  • Verify proper sealing at all connection points, including diesel exhaust fluid tank, dosing unit, and dosing valve.

Refer to Procedure 011-058

Specification

  • If there are aftertreament diesel exhaust fluid lines reversed, damaged, leaking or restricted connections found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace damaged components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment diesel exhaust fluid is contaminated

Solution: S00000563

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Use a diesel exhaust fluid refractometer to measure the concentration of the diesel exhaust fluid in the tank.

Refer to Service Bulletin 4021566

Specification

  • If there are signs of contaminates in the aftertreatment diesel exhaust fluid, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to Procedure 011-056

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment diesel exhaust fluid dosing unit intake restriction

Solution: S00000732

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the aftertreatment diesel exhaust fluid dosing unit intake restriction.

Refer to Procedure 011-086

Specification

  • If the vacuum in diagnostic line is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the diesel exhaust fluid tank filter.

Refer to OEM Service Manual

  • Clean or replace the aftertreatment diesel exhaust fluid intake line.

Refer to OEM Service Manual

  • Clean or replace the aftertreatment diesel exhaust fluid tank header.

Refer to OEM Service Manual

  • Clean or replace the aftertreatment diesel exhaust fluid tank vent.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Air in the aftertreatment diesel exhaust fluid

Solution: S00000730

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Check for air in the diesel exhaust fluid.

Refer to Procedure 011-075

Specification

  • If a line, fitting, connection, or dosing unit is leaking, then a malfunction has been detected in the aftertreatment diesel exhaust fluid system or dosing unit.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to Procedure 011-075

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Aftertreatment Diesel Exhaust Fluid Doser Pump Override test

Solution: S00002761

Verification

Conditions

  • Reconnect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank if they have been previously disconnected during troubleshooting.

Action

  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.

Refer to Procedure 011-059

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

The Aftertreatment Diesel Exhaust Fluid Doser Pump Override test can only be ran twice before a key cycle needs to be performed.

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test meets the specification, then proceed to the next solution.
  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test does not meet the specification, then proceed to the Linked Solutions section.

Linked Solutions

Click on the link below:

  • Aftertreatment diesel exhaust fluid dosing valve is malfunctioning

Refer to S00002764

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8.1 - Aftertreatment diesel exhaust fluid dosing valve is malfunctioning

Solution: S00002764

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Clean the aftertreatment diesel exhaust fluid dosing valve.
  • Turn keyswitch ON.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

9 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3649 | SPN: 5024 | FMI: 10
Aftertreatment 1 Intake NOx Sensor Heater - Abnormal Rate of Change

Troubleshooting Summary

  1. Check for primary fault codes
  2. Low battery voltage
  3. Battery load test
  4. Ground inspection
  5. Aftertreatment intake NOx sensor voltage check
  6. Aftertreatment intake NOx sensor circuit pin to ground short
  7. ECM calibration revision history check
  8. Aftertreatment intake NOx sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000293

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment NOx: 1885, 3232, 3682
  • Aftertreatment DOC: 3313, 3314, 3315

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Low battery voltage

Solution: S00001110

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.
  • If this vehicle has been repaired within the last 30 days for the same fault code, then proceed to the Linked Solutions section.

Specification

  • If the battery voltage is at least 10.8 VDC (12 volt systems) or 21.6 VDC (24 volt systems), then proceed to the Linked Solutions section.
  • If the battery or battery cables show signs of corrosion or damage, then proceed to the Repair Section.

Linked Solutions

  • Battery load test

Refer to S00001379

  • Ground inspection

Refer to S00000754

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean corrosion or tighten battery cable connections.

Refer to OEM Service Manual

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Battery load test

Solution: S00001379

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Disconnect the batteries from each other.
  • Connect a load tester separately to each battery.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.

Specification

  • For a 12 volt system, proceed to the Repair section if the battery voltage is below the following specification: 11 VDC
  • For a 24 volt system, proceed to the Repair section if the battery voltage is below the following specification: 22 VDC

Linked Solutions

  • None

Repair

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Ground inspection

Solution: S00000754

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the ECM ground for damage, corrosion and loose connections.
  • Visually inspect the aftertreatment interface wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the OEM wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the grounds for proper routing.

Specification

  • If damage, corrosion or incorrect routing of grounds are found, then proceed to the Repair section

Linked Solutions

  • None

Repair

  • Clean or replace connections.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Aftertreatment intake NOx sensor voltage check

Solution: S00000880

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake NOx sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment intake NOx sensor battery SUPPLY pin and the aftertreatment intake NOx sensor battery RETURN pin at the aftertreatment intake NOx sensor engine wiring harness connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the voltage is not within the following specification of battery voltage: 1 VDC
  • Proceed to the next solution if voltage is within the following specification of battery voltage: 1 VDC

Linked Solutions

Click on the link below:

  • Aftertreatment intake NOx sensor circuit pin to ground short

Refer to S00000881

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Aftertreatment intake NOx sensor circuit pin to ground short

Solution: S00000881

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake NOx sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.
  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment intake NOx sensor SUPPLY pin at the sensor connector of the engine wiring harness and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A short circuit has been detected if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment intake NOx sensor is malfunctioning

Solution: S00007913

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment intake NOx sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3681 | SPN: 3228 | FMI: 2
Aftertreatment 1 Outlet NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Low battery voltage
  3. Battery load test
  4. Ground inspection
  5. Incorrect adjustable parameter setting
  6. Aftertreatment outlet NOx sensor voltage check
  7. Aftertreatment power relay voltage check
  8. Aftertreatment power relay resistance check
  9. Aftertreatment outlet NOx sensor circuit check
  10. Aftertreatment power relay circuit check
  11. Aftertreatment outlet NOx sensor has carbon buildup
  12. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000292

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Voltage: 441, 442, 596, 597, 598

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Low battery voltage

Solution: S00001110

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.
  • If this vehicle has been repaired within the last 30 days for the same fault code, then proceed to the Linked Solutions section.

Specification

  • If the battery voltage is at least 10.8 VDC (12 volt systems) or 21.6 VDC (24 volt systems), then proceed to the Linked Solutions section.
  • If the battery or battery cables show signs of corrosion or damage, then proceed to the Repair Section.

Linked Solutions

  • Battery load test

Refer to S00001379

  • Ground inspection

Refer to S00000754

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean corrosion or tighten battery cable connections.

Refer to OEM Service Manual

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Battery load test

Solution: S00001379

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Disconnect the batteries from each other.
  • Connect a load tester separately to each battery.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.

Specification

  • For a 12 volt system, proceed to the Repair section if the battery voltage is below the following specification: 11 VDC
  • For a 24 volt system, proceed to the Repair section if the battery voltage is below the following specification: 22 VDC

Linked Solutions

  • None

Repair

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Ground inspection

Solution: S00000754

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the ECM ground for damage, corrosion and loose connections.
  • Visually inspect the aftertreatment interface wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the OEM wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the grounds for proper routing.

Specification

  • If damage, corrosion or incorrect routing of grounds are found, then proceed to the Repair section

Linked Solutions

  • None

Repair

  • Clean or replace connections.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Incorrect adjustable parameter setting

Solution: S00000886

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify the Electrical System Voltage setting is correct for the engine configuration with the recommended Cummins® electronic service tool or equivalent.

Specification

  • If the Electrical System Voltage setting does not match the measured voltage, then the incorrect adjustable parameter is configured.

Linked Solutions

  • None

Repair

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Configure the electrical system voltage to match the engine configuration.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment outlet NOx sensor voltage check

Solution: S00010306

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment outlet NOx sensor battery voltage SUPPLY pin and the aftertreatment outlet NOx sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 1 VDC

Linked Solutions

  • Aftertreatment power relay voltage check

Refer to S00010303

  • Aftertreatment power relay resistance check

Refer to S00010305

  • Aftertreatment outlet NOx sensor circuit check

Refer to S00010333

  • Aftertreatment power relay circuit check

Refer to S00010368

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Aftertreatment power relay voltage check

Solution: S00010303

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment power relay battery voltage SUPPLY pin in the aftertreatment power relay connector of the OEM wiring harness and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.2 - Aftertreatment power relay resistance check

Solution: S00010305

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment power relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.3 - Aftertreatment outlet NOx sensor circuit check

Solution: S00010333

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.
  • Disconnect the aftertreatment outlet NOx sensor from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment power relay SUPPLY pin at the aftertreatment power relay connector of the OEM wiring harness and the aftertreatment power relay SUPPLY pin at the aftertreatment interface wiring harness aftertreatment outlet NOx sensor connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.4 - Aftertreatment power relay circuit check

Solution: S00010368

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment power relay CONTROL pin at the aftertreatment power relay connector of the OEM wiring harness and the aftertreatment power relay CONTROL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Aftertreatment outlet NOx sensor has carbon buildup

Solution: S00000540

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the correct aftertreatment outlet NOx sensor is installed for engine configuration (12 or 24 volt).
  • Remove the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Inspect the sensor tip for damage or carbon buildup.

Refer to Procedure 019-451

Specification

  • If the aftertreatment outlet NOx sensor is damaged or has carbon buildup, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3682 | SPN: 3218 | FMI: 2
Aftertreatment 1 Intake NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Low battery voltage
  3. Battery load test
  4. Ground inspection
  5. Incorrect aftertreatment intake NOx sensor installed
  6. Incorrect adjustable parameter setting
  7. Aftertreatment intake NOx sensor voltage check
  8. Aftertreatment intake NOx sensor circuit pin to ground short
  9. ECM calibration revision history check
  10. Aftertreatment intake NOx sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000290

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Voltage: 441, 442, 596, 597, 598

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Low battery voltage

Solution: S00001110

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.
  • If this vehicle has been repaired within the last 30 days for the same fault code, then proceed to the Linked Solutions section.

Specification

  • If the battery voltage is at least 10.8 VDC (12 volt systems) or 21.6 VDC (24 volt systems), then proceed to the Linked Solutions section.
  • If the battery or battery cables show signs of corrosion or damage, then proceed to the Repair Section.

Linked Solutions

  • Battery load test

Refer to S00001379

  • Ground inspection

Refer to S00000754

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean corrosion or tighten battery cable connections.

Refer to OEM Service Manual

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Battery load test

Solution: S00001379

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Disconnect the batteries from each other.
  • Connect a load tester separately to each battery.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.

Specification

  • For a 12 volt system, proceed to the Repair section if the battery voltage is below the following specification: 11 VDC
  • For a 24 volt system, proceed to the Repair section if the battery voltage is below the following specification: 22 VDC

Linked Solutions

  • None

Repair

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Ground inspection

Solution: S00000754

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the ECM ground for damage, corrosion and loose connections.
  • Visually inspect the aftertreatment interface wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the OEM wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the grounds for proper routing.

Specification

  • If damage, corrosion or incorrect routing of grounds are found, then proceed to the Repair section

Linked Solutions

  • None

Repair

  • Clean or replace connections.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Incorrect aftertreatment intake NOx sensor installed

Solution: S00000885

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake NOx sensor from the engine wiring harness.

Action

  • Verify the aftertreatment intake NOx sensor is correct for the engine configuration.

The aftertreatment intake NOx sensor is available in 12 volt or 24 volt versions.

Specification

  • If the aftertreatment intake NOx sensor is not the correct sensor part number for the engine configuration, then the incorrect sensor has been installed.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Incorrect adjustable parameter setting

Solution: S00000886

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify the Electrical System Voltage setting is correct for the engine configuration with the recommended Cummins® electronic service tool or equivalent.

Specification

  • If the Electrical System Voltage setting does not match the measured voltage, then the incorrect adjustable parameter is configured.

Linked Solutions

  • None

Repair

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Configure the electrical system voltage to match the engine configuration.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment intake NOx sensor voltage check

Solution: S00000880

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake NOx sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment intake NOx sensor battery SUPPLY pin and the aftertreatment intake NOx sensor battery RETURN pin at the aftertreatment intake NOx sensor engine wiring harness connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the voltage is not within the following specification of battery voltage: 1 VDC
  • Proceed to the next solution if voltage is within the following specification of battery voltage: 1 VDC

Linked Solutions

Click on the link below:

  • Aftertreatment intake NOx sensor circuit pin to ground short

Refer to S00000881

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

5.1 - Aftertreatment intake NOx sensor circuit pin to ground short

Solution: S00000881

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake NOx sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.
  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment intake NOx sensor SUPPLY pin at the sensor connector of the engine wiring harness and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A short circuit has been detected if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Aftertreatment intake NOx sensor is malfunctioning

Solution: S00000016

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment intake NOx sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3697 | SPN: 630 | FMI: 12
Engine Control Module Calibration Memory - Bad Intelligent Device or Component

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Internal ECM Error

1 - Check for primary fault codes

Solution: S00000289

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • ECM: 111

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Internal ECM Error

Solution: S00008078

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect all components.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait for 90 seconds.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • A malfunctioning ECM has been detected if a fault code from the following list is active or has greater than 3 inactive counts: 111, 335, 342, 343, 1597, 3697, 3724, 5874, 6155, 7155

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3712 | SPN: 5246 | FMI: 0
Aftertreatment SCR Operator Inducement - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Technical Service Bulletin is available

1 - Check for primary fault codes

Solution: S00001420

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 1682, 1683, 1685, 1713, 2976, 3238, 3241, 3258, 3261, 3423, 3425, 3563, 3572, 3574, 3575, 3596, 4156, 4169, 4769
  • Aftertreatment diesel exhaust fluid dosing unit: 3558, 3559
  • Aftertreatment diesel exhaust fluid dosing valve: 3567, 3568
  • Aftertreatment NOx: 3232, 3682, 3748
  • Aftertreatment SCR: 3151

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Technical Service Bulletin is available

Solution: S00003080

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb120309

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 05-Dec-2021


NO TITLE

ISX15 CM2350 X101

Fault Code: 3714 | SPN: 1569 | FMI: 31
Engine Protection Torque Derate - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. Technical Service Bulletin is available
  3. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002715

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment SCR: 3151, 3582
  • Aftertreatment diesel exhaust fluid dosing unit: 1682, 3558, 3559
  • Aftertreatment diesel exhaust fluid dosing valve: 3567, 3568
  • Aftertreatment diesel exhaust fluid system: 4156, 4169
  • Aftertreatment diesel exhaust fluid temperature: 1683, 1713, 3238, 3241, 3258, 3261, 3423, 3425, 3563, 4769
  • Aftertreatment diesel exhaust fluid pressure: 3572, 3574, 3575, 3596

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Technical Service Bulletin is available

Solution: S00003080

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb120309

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3715 | SPN: 188 | FMI: 16
Engine Speed At Idle - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Camshaft position sensor is damaged
  3. Engine crankshaft speed/position sensor check
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000287

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Wheel based vehicle speed: 241, 242, 3525, 3526
  • Fuel: 271, 272, 451, 452, 483, 484, 553, 559, 755, 2311, 3332, 3338, 3727, 3741, 4691, 4726, 4727, 6258, 6259
  • Crankshaft speed/position sensor: 234, 689, 2321, 2468
  • Camshaft speed/position sensor: 778, 731, 2322

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Camshaft position sensor is damaged

Solution: S00001226

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the camshaft position sensor.

Refer to Procedure 019-363

  • Inspect the camshaft position sensor for signs of damage, oil leak, and metal debris on the end of the sensor.

Specification

  • If the camshaft position sensor shows any signs of damage, then a malfunctioning camshaft position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace camshaft position sensor.

Refer to Procedure 019-363

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine crankshaft speed/position sensor check

Solution: S00000684

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the crankshaft position sensor.
  • Inspect the crankshaft position sensor for signs of damage, oil leak, and metal debris on the end of the sensor.
  • Verify the crankshaft position sensor is connected properly.
  • Use the ratchet drive side of the socket tool that was used to removed the sensor from the engine, place it flush on the sensor so that the edge of the socket is on the edge of the sensor.
  • Monitor the crankshaft engine speed sensor state using the recommended Cummins® electronic service tool or equivalent and monitor (Engine Speed Main Sensor State) to check if the sensor state transitions.
  • Slowly slide the socket in a perpendicular direction to the marked line on the sensor or in a perpendicular direction to the mounting bracket of the sensor.

Specification

  • If any damage is found to the sensor, then proceed to the Repair section.
  • If the crankshaft position sensor is not connected properly, then proceed to the Repair section.
  • If the crankshaft position sensor state does NOT transition from high to low or low to high, or the state does NOT show triggered, then a malfunctioning crankshaft engine position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine crankshaft speed/position sensor.

Refer to Procedure 019-365

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3716 | SPN: 188 | FMI: 18
Engine Speed At Idle - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Camshaft position sensor is damaged
  3. Engine crankshaft speed/position sensor check
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000286

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake throttle: 175, 176, 177, 3539, 3541, 3542, 5879, 5881, 5882
  • Wheel based vehicle speed: 241, 242, 3525, 3526
  • Fuel: 271, 272, 451, 452, 483, 484, 553, 559, 755, 2311, 3332, 3338, 3727, 3741, 4691, 4726, 4727, 6258, 6259
  • Crankshaft speed/position sensor: 234, 689, 2321, 2468
  • Camshaft speed/position sensor: 731, 778, 2322

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Camshaft position sensor is damaged

Solution: S00001226

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the camshaft position sensor.

Refer to Procedure 019-363

  • Inspect the camshaft position sensor for signs of damage, oil leak, and metal debris on the end of the sensor.

Specification

  • If the camshaft position sensor shows any signs of damage, then a malfunctioning camshaft position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace camshaft position sensor.

Refer to Procedure 019-363

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine crankshaft speed/position sensor check

Solution: S00000684

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the crankshaft position sensor.
  • Inspect the crankshaft position sensor for signs of damage, oil leak, and metal debris on the end of the sensor.
  • Verify the crankshaft position sensor is connected properly.
  • Use the ratchet drive side of the socket tool that was used to removed the sensor from the engine, place it flush on the sensor so that the edge of the socket is on the edge of the sensor.
  • Monitor the crankshaft engine speed sensor state using the recommended Cummins® electronic service tool or equivalent and monitor (Engine Speed Main Sensor State) to check if the sensor state transitions.
  • Slowly slide the socket in a perpendicular direction to the marked line on the sensor or in a perpendicular direction to the mounting bracket of the sensor.

Specification

  • If any damage is found to the sensor, then proceed to the Repair section.
  • If the crankshaft position sensor is not connected properly, then proceed to the Repair section.
  • If the crankshaft position sensor state does NOT transition from high to low or low to high, or the state does NOT show triggered, then a malfunctioning crankshaft engine position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine crankshaft speed/position sensor.

Refer to Procedure 019-365

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3724 | SPN: 2791 | FMI: 31
Engine Exhaust Gas Recirculation 1 Valve 1 Control 1 - Condition Exists

Troubleshooting Summary

  1. Battery or battery cables are malfunctioning

1 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 08-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3725 | SPN: 3216 | FMI: 10
Aftertreatment 1 Intake NOx Sensor - Abnormal Rate of Change

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Aftertreatment intake NOx sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000255

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment NOx: 1885, 3232, 3682

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment intake NOx sensor is malfunctioning

Solution: S00007913

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment intake NOx sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3727 | SPN: 5571 | FMI: 7
High Pressure Common Rail Fuel Pressure Relief Valve - Mechanical System Not Responding or Out of Adjustment

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Fuel pressure relief valve is malfunctioning

1 - Check for primary fault codes

Solution: S00000889

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 451, 452

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Fuel pressure relief valve is malfunctioning

Solution: S00008682

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is still active after all preceding solution verifications have been preformed, then a malfunctioning fuel pressure relief valve has been detected.

Linked Solutions

  • None

Repair

  • Replace the fuel pressure relief valve.

Refer to Procedure 006-061

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3733 | SPN: 862 | FMI: 3
Crankcase Breather Filter Heater Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. Crankcase breather filter heater has open or short circuit
  3. Crankcase breather heater circuit pin to pin short
  4. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000892

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify the Crankcase Breather Heater setting is correct with the recommended Cummins® electronic service tool or equivalent.

Specification

  • If the Crankcase Heater setting does not match the application, then the incorrect Crankcase Heater setting has been detected.

Linked Solutions

  • None

Repair

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Configure the crankcase heater setting to match the engine CPL.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Crankcase breather filter heater has open or short circuit

Solution: S00000891

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase breather heater from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the crankcase breather heater SUPPLY pin to the crankcase breather heater RETURN pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A short circuit in the crankcase breather filter heater has been detected if the resistance is less than the following specification: 5 Ω
  • An open circuit in the crankcase breather filter heater has been detected if the resistance is greater than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Replace the crankcase breather filter heater.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Crankcase breather heater circuit pin to pin short

Solution: S00000893

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase breather heater from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the crankcase breather heater SUPPLY pin in the engine wiring harness ECM connector and all other pins in the ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3734 | SPN: 862 | FMI: 4
Crankcase Breather Filter Heater Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Crankcase breather heater open circuit check
  2. Crankcase breather filter heater has open or short circuit
  3. Crankcase breather heater circuit pin to ground short
  4. Crankcase breather heater circuit pin to pin short

1 - Crankcase breather heater open circuit check

Solution: S00000894

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase breather heater from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the crankcase breather heater SUPPLY pin in the engine wiring harness ECM connector and the crankcase breather heater SUPPLY pin at the crankcase breather heater wiring harness connector.
  • Measure the resistance between the crankcase breather heater RETURN pin in the engine wiring harness ECM connector and the crankcase breather heater RETURN pin at the crankcase breather heater wiring harness connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Crankcase breather filter heater has open or short circuit

Solution: S00000891

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase breather heater from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the crankcase breather heater SUPPLY pin to the crankcase breather heater RETURN pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A short circuit in the crankcase breather filter heater has been detected if the resistance is less than the following specification: 5 Ω
  • An open circuit in the crankcase breather filter heater has been detected if the resistance is greater than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Replace the crankcase breather filter heater.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Crankcase breather heater circuit pin to ground short

Solution: S00000895

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase breather heater from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the crankcase breather heater SIGNAL pin in the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Crankcase breather heater circuit pin to pin short

Solution: S00000893

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase breather heater from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the crankcase breather heater SUPPLY pin in the engine wiring harness ECM connector and all other pins in the ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3737 | SPN: 1675 | FMI: 31
Engine Starter Mode Overcrank Protection - Condition Exists

Troubleshooting Summary

  1. Engine will not start
  2. ECM calibration revision history check

1 - Engine will not start

Solution: S00002969

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Attempt to start the engine.

Specification

  • If the engine will not start, then reset the search to crank no start.
  • If the engine is difficult to start, then reset the search to hard start / long crank time.

Linked Solutions

  • None

Repair

Only search the appropriate symptom.

  • Reset the search to crank no start.
  • Reset the search to hard start / long crank time.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3741 | SPN: 5571 | FMI: 0
High Pressure Common Rail Fuel Pressure Relief Valve - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Air in fuel check
  3. High fuel drain line restriction
  4. Fuel pump actuator has high resistance
  5. Fuel pump actuator o-ring is malfunctioning
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000254

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Voltage: 1117
  • Fuel: 271, 272, 449, 451, 452, 483, 484, 553, 2311, 2372

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Air in fuel check

Solution: S00004548

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify adequate fuel level in the tank.

Refer to OEM Service Manual

  • Inspect for air being ingested into the fuel.

Refer to Procedure 006-003

Specification

  • If air is present in the fuel flow, then a damaged fuel supply line, loose or damaged fuel filter, or a loose connection has been detected.

Linked Solutions

  • None

Repair

Repair or replace the following components if they are found out of specification:

  • Tighten the loose fitting or replace the damaged component that allows air to enter the fuel system.

Refer to Procedure 006-003

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - High fuel drain line restriction

Solution: S00000537

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect fuel drain line for signs of kinks or damage.
  • Measure the fuel drain line restriction.

Refer to Procedure 006-012

Specification

  • If the fuel drain line restriction is not within the specification, then high fuel drain line restriction has been detected.

Linked Solutions

  • None

Repair

  • Replace fuel drain line.

Refer to Procedure 006-013

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fuel pump actuator has high resistance

Solution: S00000859

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the fuel pump actuator resistance.

Refer to Procedure 019-117

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the fuel pump actuator.

Refer to Procedure 019-117

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Fuel pump actuator o-ring is malfunctioning

Solution: S00000620

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the fuel pump actuator.

Action

  • Visually inspect fuel pump actuator for a cut or damaged o-ring.
  • Visually inspect the wiring or body of the actuator for damage.

Specification

  • If any damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the o-ring.

Refer to Procedure 019-117

  • Replace the fuel pump actuator.

Refer to Procedure 019-117

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3748 | SPN: 3216 | FMI: 20
Aftertreatment 1 Intake NOx Sensor - Data Not Rational - Drifted High

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Aftertreatment intake NOx sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000253

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment NOx: 1885, 3232, 3649, 3682

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment intake NOx sensor is malfunctioning

Solution: S00007913

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment intake NOx sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3749 | SPN: 3226 | FMI: 20
Aftertreatment 1 Outlet NOx Sensor - Data Not Rational - Drifted High

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment outlet NOx sensor has carbon buildup
  3. Aftertreatment diesel exhaust fluid dosing valve is malfunctioning
  4. Deposits in the SCR decomposition tube
  5. Leaks in the aftertreatment diesel exhaust fluid dosing system
  6. ECM calibration revision history check
  7. Aftertreatment outlet NOx sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00006244

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment NOx: 1885, 1887, 2771, 3232, 3446, 3583, 3649, 3681, 3682, 3725
  • Aftertreatment diesel exhaust fluid system: 1681, 1682, 3574, 6485, 6486
  • Ambient air temperature: 249, 256, 2398

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment outlet NOx sensor has carbon buildup

Solution: S00000540

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the correct aftertreatment outlet NOx sensor is installed for engine configuration (12 or 24 volt).
  • Remove the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Inspect the sensor tip for damage or carbon buildup.

Refer to Procedure 019-451

Specification

  • If the aftertreatment outlet NOx sensor is damaged or has carbon buildup, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid dosing valve is malfunctioning

Solution: S00000967

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Clean or replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

4 - Deposits in the SCR decomposition tube

Solution: S00000564

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the aftertreatment decomposition tube from the vehicle.

Refer to Procedure 011-062

  • Visually inspect the decomposition tube for deposits.

Refer to Procedure 011-062

Specification

  • If any excessive aftertreatment diesel exhaust fluid deposits were found inside the decomposition tube, then a plugged or restricted aftertreatment decomposition tube has been detected.
  • Proceed to Linked Solutions section for additional checks.

Linked Solutions

  • Leaks in the aftertreatment diesel exhaust fluid dosing system

Refer to S00000735

Repair

  • Clean and install the decomposition tube.

Refer to Procedure 011-062

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4.1 - Leaks in the aftertreatment diesel exhaust fluid dosing system

Solution: S00000735

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank if they have been previously disconnected during troubleshooting.

Action

  • Remove the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-080

Specification

  • If a line, fitting, connection, or dosing unit is leaking, then a malfunction has been detected in the aftertreatment diesel exhaust fluid system or dosing unit.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to Procedure 011-059

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment outlet NOx sensor is malfunctioning

Solution: S00000994

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3843 | SPN: 5603 | FMI: 9
Cruise Control Disable Command - Abnormal Update Rate

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3844 | SPN: 5605 | FMI: 31
Cruise Control Pause Command - Condition Exists

Troubleshooting Summary

  1. Fault code is for information only
  2. ECM calibration revision history check

1 - Fault code is for information only

Solution: S00004413

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • This solution is for information only stating that the adaptive cruise control has paused.

Specification

  • This solution is information only.

Linked Solutions

  • None

Repair

  • This fault code is for information only.
  • No repair is necessary.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3845 | SPN: 5603 | FMI: 31
Cruise Control Disable Command - Condition Exists

Troubleshooting Summary

  1. Fault code is for information only
  2. ECM calibration revision history check

1 - Fault code is for information only

Solution: S00003669

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • This solution is for information only stating that the adaptive cruise control has been disabled.

Specification

  • This solution is information only.

Linked Solutions

  • None

Repair

  • This fault code is for information only.
  • No repair is necessary.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3867 | SPN: 3364 | FMI: 18
Aftertreatment Diesel Exhaust Fluid Quality - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Multiple Technical Service Bulletins are available
  2. Aftertreatment diesel exhaust fluid is contaminated
  3. ECM calibration revision history check
  4. Aftertreatment diesel exhaust fluid quality sensor is malfunctioning

1 - Multiple Technical Service Bulletins are available

Solution: S00005092

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb170054

  • If this engine is not in a Navistar application, then proceed to the next solution.
  • Technical Service Bulletin is available.

Refer to tsb160031

  • If this engine is not in a PACCAR™ application, then proceed to the next solution.
  • Technical Service Bulletin is available.

Refer to tsb200189

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid is contaminated

Solution: S00000563

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Use a diesel exhaust fluid refractometer to measure the concentration of the diesel exhaust fluid in the tank.

Refer to Service Bulletin 4021566

Specification

  • If there are signs of contaminates in the aftertreatment diesel exhaust fluid, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to Procedure 011-056

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid quality sensor is malfunctioning

Solution: S00000933

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than once count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid quality sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid quality sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3868 | SPN: 3364 | FMI: 9
Aftertreatment 1 Diesel Exhaust Fluid Quality - Abnormal Update Rate

Troubleshooting Summary

  1. Check for primary fault codes
  2. Technical Service Bulletin is available
  3. Low battery voltage
  4. Battery load test
  5. Ground inspection
  6. Aftertreatment diesel exhaust fluid quality sensor voltage check
  7. Aftertreatment power relay voltage check
  8. Aftertreatment power relay resistance check
  9. Aftertreatment diesel exhaust fluid quality sensor circuit check
  10. Fault Code 3868 triggered by a malfunction in the J1939 data link with multiple OEM fault code
  11. J1939 data link terminating resistance is incorrect
  12. Variable geometry turbocharger actuator has incorrect J1939 terminating resistance
  13. Engine wiring harness has incorrect J1939 terminating resistance
  14. OEM wiring harness has incorrect J1939 terminating resistance
  15. J1939 data link harness open circuit check
  16. OEM terminating resistor Ω check for the J1939 data link
  17. Incorrect terminating resistance in the J1939 data link by a J1939 data linked component
  18. J1939 wire resistance check at the crossover connector for each component
  19. ECM calibration revision history check
  20. Aftertreatment diesel exhaust fluid quality sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000251

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Turbocharger: 1894, 2636
  • Aftertreatment diesel exhaust fluid system: 1713

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Technical Service Bulletin is available

Solution: S00009162

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb170054

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Low battery voltage

Solution: S00001110

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.
  • If this vehicle has been repaired within the last 30 days for the same fault code, then proceed to the Linked Solutions section.

Specification

  • If the battery voltage is at least 10.8 VDC (12 volt systems) or 21.6 VDC (24 volt systems), then proceed to the Linked Solutions section.
  • If the battery or battery cables show signs of corrosion or damage, then proceed to the Repair Section.

Linked Solutions

  • Battery load test

Refer to S00001379

  • Ground inspection

Refer to S00000754

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean corrosion or tighten battery cable connections.

Refer to OEM Service Manual

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3.1 - Battery load test

Solution: S00001379

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Disconnect the batteries from each other.
  • Connect a load tester separately to each battery.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.

Specification

  • For a 12 volt system, proceed to the Repair section if the battery voltage is below the following specification: 11 VDC
  • For a 24 volt system, proceed to the Repair section if the battery voltage is below the following specification: 22 VDC

Linked Solutions

  • None

Repair

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.2 - Ground inspection

Solution: S00000754

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the ECM ground for damage, corrosion and loose connections.
  • Visually inspect the aftertreatment interface wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the OEM wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the grounds for proper routing.

Specification

  • If damage, corrosion or incorrect routing of grounds are found, then proceed to the Repair section

Linked Solutions

  • None

Repair

  • Clean or replace connections.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Aftertreatment diesel exhaust fluid quality sensor voltage check

Solution: S00010298

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage from the aftertreatment diesel exhaust fluid quality sensor battery voltage SUPPLY pin and the aftertreatment diesel exhaust fluid quality sensor battery voltage RETURN pin at the aftertreatment diesel exhaust fluid quality sensor wiring harness connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • Aftertreatment power relay voltage check

Refer to S00010303

  • Aftertreatment power relay resistance check

Refer to S00010305

  • Aftertreatment diesel exhaust fluid quality sensor circuit check

Refer to S00010304

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Aftertreatment power relay voltage check

Solution: S00010303

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment power relay battery voltage SUPPLY pin in the aftertreatment power relay connector of the OEM wiring harness and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.2 - Aftertreatment power relay resistance check

Solution: S00010305

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment power relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.3 - Aftertreatment diesel exhaust fluid quality sensor circuit check

Solution: S00010304

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid quality sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment power relay SUPPLY pin at the aftertreatment power relay connector of the OEM wiring harness and the aftertreatment power heater relay SUPPLY pin at the OEM wiring harness aftertreatment diesel exhaust fluid quality sensor connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Fault Code 3868 triggered by a malfunction in the J1939 data link with multiple OEM fault code

Solution: S00005738

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution, if any fault code is active or has more than one inactive count within the last 25 engine operating hours from the following list: 1894, 2636, 2771, 3232, 3911, 4151, 4152, 6688
  • A malfunctioning aftertreatment diesel exhaust fluid tank level/temperature/quality sensor has been detected if a fault code from the following list is not active, or does not have more than one inactive count within the last 25 engine operating hours: 1894, 2636, 2771, 3232, 3911, 4151, 4152, 6688

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.

Refer to Procedure 019-475

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - J1939 data link terminating resistance is incorrect

Solution: S00000593

Verification

Conditions

  • Turn keyswitch OFF.
  • Wait for 90 seconds.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.
  • Reconnect the variable geometry turbocharger actuator if it has been previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3-pin service data link connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Follow your technical escalation process if the resistance is within the following specification: 54 - 66 Ω
  • Proceed to the Linked Solutions section if the resistance is not within the following specification: 54 - 66 Ω

Linked Solutions

  • Variable geometry turbocharger actuator has incorrect J1939 terminating resistance

Refer to S00001242

  • Engine wiring harness has incorrect J1939 terminating resistance

Refer to S00000972

  • OEM wiring harness has incorrect J1939 terminating resistance

Refer to S00000971

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

6.1 - Variable geometry turbocharger actuator has incorrect J1939 terminating resistance

Solution: S00001242

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the variable geometry turbocharger actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the variable geometry turbocharger actuator SAE J1939 data link (+) pin and the variable geometry turbocharger actuator SAE J1939 data link (-) pin at the variable geometry turbocharger actuator.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning variable geometry turbocharger actuator has been detected if the resistance is not within the following specification: 108 Ω - 132 Ω

Linked Solutions

  • None

Repair

  • Replace the variable geometry turbocharger actuator.

Refer to Procedure 010-134

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6.2 - Engine wiring harness has incorrect J1939 terminating resistance

Solution: S00000972

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect previously disconnected components.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.
  • Disconnect the aftertreatment intake NOx sensor from the engine wiring harness.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3-pin service data link connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is not within the following specification: 108-132 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6.3 - OEM wiring harness has incorrect J1939 terminating resistance

Solution: S00000971

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if the resistance is not within the following specification: 108 - 132 Ω
  • Follow your technical escalation process if the resistance is within the following specification: 108 - 132 Ω

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Parent Solution

7 - J1939 data link harness open circuit check

Solution: S00004534

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the appropriate data link component from the data link wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the J1939 (+) pin at the appropriate component data link wiring harness connector and the appropriate data link component J1939 (+) pin at the data link wiring harness ECM connector.
  • Measure the resistance between the J1939 (-) pin at the appropriate component data link wiring harness connector and the appropriate data link component J1939 (-) pin at the data link wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning J1939 data link wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - OEM terminating resistor Ω check for the J1939 data link

Solution: S00000907

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM terminating resistor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the pins for the OEM terminating resistor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM terminating resistor has been detected if the resistance is not within the following specification: 108 - 132 Ω

Linked Solutions

  • None

Repair

  • For a malfunctioning OEM terminating resistor, replace the OEM terminating resistor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Incorrect terminating resistance in the J1939 data link by a J1939 data linked component

Solution: S00001002

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Reconnect the OEM terminating resistor if previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the resistance is not within the following specification: 108 - 132 Ω

Linked Solutions

  • J1939 wire resistance check at the crossover connector for each component

Refer to S00001003

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

9.1 - J1939 wire resistance check at the crossover connector for each component

Solution: S00001003

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Reconnect the OEM terminating resistor if previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

Inspect the following components if applicable:

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector for each component while disconnecting them one at a time.
  • Disconnect the aftertreatment outlet NOx sensor
  • Disconnect the aftertreatment temperature sensor module
  • Disconnect the aftertreatment particulate sensor
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor
  • Disconnect the aftertreatment diesel exhaust fluid temperature sensor
  • Disconnect the aftertreatment diesel exhaust fluid quality sensor.
  • Disconnect the aftertreatment intermediate NH3 sensor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance was not within 108 Ω to 132 Ω and it becomes within the specification of 108 Ω to 132 Ω when the J1939 component was disconnected, then a malfunctioning J1939 component has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid tank level sensor.

Refer to OEM Service Manual

  • Replace the aftertreatment diesel exhaust fluid temperature sensor.

Refer to OEM Service Manual

  • Replace the aftertreatment diesel exhaust fluid quality sensor.

Refer to OEM Service Manual

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace aftertreatment DOC temperature sensor module.

Refer to Procedure 019-449

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

  • Replace aftertreatment intermediate NH3 sensor.

Refer to Procedure 019-479

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

10 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

11 - Aftertreatment diesel exhaust fluid quality sensor is malfunctioning

Solution: S00000933

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than once count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid quality sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid quality sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3878 | SPN: 3364 | FMI: 2
Aftertreatment 1 Diesel Exhaust Fluid Quality - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid is contaminated
  2. ECM calibration revision history check

1 - Aftertreatment diesel exhaust fluid is contaminated

Solution: S00000563

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Use a diesel exhaust fluid refractometer to measure the concentration of the diesel exhaust fluid in the tank.

Refer to Service Bulletin 4021566

Specification

  • If there are signs of contaminates in the aftertreatment diesel exhaust fluid, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to Procedure 011-056

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3899 | SPN: 5848 | FMI: 4
Aftertreatment 1 SCR Intermediate NH3 Sensor - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Campaign or Temporary Repair Practice may be available

1 - Check for primary fault codes

Solution: S00000250

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment SCR: 3911, 3933, 3934

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Campaign or Temporary Repair Practice may be available

Solution: S00003003

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Campaign or Temporary Repair Practice may be available.

Specification

  • Proceed to the Repair section if a Campaign or Temporary Repair Practice is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Campaign or Temporary Repair Practice.

Validation

  • None

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 26-Jul-2020


NO TITLE

ISX15 CM2350 X101

Fault Code: 3911 | SPN: 5848 | FMI: 9
Aftertreatment 1 SCR Intermediate NH3 Sensor - Abnormal Update Rate

Troubleshooting Summary

  1. Check for primary fault codes
  2. Low battery voltage
  3. Battery load test
  4. Ground inspection
  5. Aftertreatment intermediate NH3 sensor module voltage check
  6. Aftertreatment intermediate NH3 sensor open circuit check
  7. J1939 data link engine wiring harness voltage check 3 pin service connector
  8. OEM sensor voltage check
  9. J1939 data link harness pin to ground short circuit
  10. Fault Code 3911 triggered by a malfunction in the J1939 data link with multiple OEM fault code
  11. J1939 data link terminating resistance is incorrect
  12. Variable geometry turbocharger actuator has incorrect J1939 terminating resistance
  13. Engine wiring harness has incorrect J1939 terminating resistance
  14. OEM wiring harness has incorrect J1939 terminating resistance
  15. J1939 data link harness open circuit check
  16. OEM terminating resistor Ω check for the J1939 data link
  17. Incorrect terminating resistance in the J1939 data link by a J1939 data linked component
  18. J1939 wire resistance check at the crossover connector for each component
  19. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000911

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Turbocharger: 1894, 2636

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Low battery voltage

Solution: S00001110

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.
  • If this vehicle has been repaired within the last 30 days for the same fault code, then proceed to the Linked Solutions section.

Specification

  • If the battery voltage is at least 10.8 VDC (12 volt systems) or 21.6 VDC (24 volt systems), then proceed to the Linked Solutions section.
  • If the battery or battery cables show signs of corrosion or damage, then proceed to the Repair Section.

Linked Solutions

  • Battery load test

Refer to S00001379

  • Ground inspection

Refer to S00000754

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean corrosion or tighten battery cable connections.

Refer to OEM Service Manual

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Battery load test

Solution: S00001379

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Disconnect the batteries from each other.
  • Connect a load tester separately to each battery.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.

Specification

  • For a 12 volt system, proceed to the Repair section if the battery voltage is below the following specification: 11 VDC
  • For a 24 volt system, proceed to the Repair section if the battery voltage is below the following specification: 22 VDC

Linked Solutions

  • None

Repair

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Ground inspection

Solution: S00000754

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the ECM ground for damage, corrosion and loose connections.
  • Visually inspect the aftertreatment interface wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the OEM wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the grounds for proper routing.

Specification

  • If damage, corrosion or incorrect routing of grounds are found, then proceed to the Repair section

Linked Solutions

  • None

Repair

  • Clean or replace connections.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Aftertreatment intermediate NH3 sensor module voltage check

Solution: S00000909

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR intermediate NH3 sensor module from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage from the aftertreatment intermediate NH3 sensor module battery voltage SUPPLY circuit and the aftertreatment intermediate NH3 sensor module battery voltage RETURN circuit at the aftertreatment intermediate NH3 sensor module wiring harness connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification of battery voltage: 1 VDC
  • Proceed to the Linked Solutions section if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

Click on the link below:

  • Aftertreatment intermediate NH3 sensor open circuit check

Refer to S00001065

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Aftertreatment intermediate NH3 sensor open circuit check

Solution: S00001065

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR intermediate NH3 sensor module from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment intermediate NH3 sensor module battery voltage SUPPLY pin of the OEM wiring harness to engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness RETURN circuit has been detected if the voltage is within the following specification of battery voltage: 1 VDC
  • A malfunctioning OEM wiring harness SUPPLY circuit has been detected if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Replace the fuse.

Refer to OEM Service Manual

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - J1939 data link engine wiring harness voltage check 3 pin service connector

Solution: S00000594

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect all SAE J1939 components.
  • Turn keyswitch ON.

Action

The service tool datalink adapter can NOT be connected to the 3-pin J1939 datalink connector during this check.

  • Measure the J1939 voltage of the J1939 (+) pin to ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

  • Measure the J1939 voltage of the J1939 (-) pin to ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

Specification

  • A malfunctioning wiring harness has been detected due to the J1939 data link circuit being shorted to a voltage source if the voltage is greater than the following specification: 4.5 VDC
  • Proceed to the Linked Solutions section if the voltage is less than the following specification: 1 VDC
  • Proceed to the next solution if the voltage is within the following specification for both the SAE J1939 data link (+) and SAE J1939 data link (-) circuit: 1 - 4.5 VDC

Linked Solutions

  • OEM J1939 data link component isolation

Refer to S00003176

  • Engine or OEM wiring harness shorted to ground

Refer to S00003331

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4.1 - OEM sensor voltage check

Solution: S00003176

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Reconnect the crossover connector.

Inspect the following components if applicable:

  • Turn keyswitch ON.
  • Measure the J1939 voltage of the SAE J1939 data link (+) and SAE data link J1939 (-) pins at the variable geometry turbocharger actuator engine wiring harness connector to battery ground while each component is disconnected one at a time.
  • Disconnect the aftertreatment outlet NOx sensor
  • Disconnect the aftertreatment DPF temperature sensor module.
  • Disconnect the aftertreatment SCR temperature sensor module.
  • Disconnect the aftertreatment intermediate NH3 sensor.
  • Disconnect the aftertreatment particulate sensor
  • Disconnect the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.
  • Disconnect the aftertreatment exhaust gas temperature sensor.
  • Disconnect the aftertreatment intake NOx sensor.

Specification

  • A malfunctioning SAE J1939 data link component has been detected if the voltage is within the following specification after the component has been disconnected: 1 - 4.5 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.

Refer to OEM Service Manual

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

  • Replace aftertreatment DPF temperature sensor module.

Refer to Procedure 019-449

  • Replace the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-449

  • Replace aftertreatment intermediate NH3 sensor.

Refer to Procedure 019-479

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.2 - J1939 data link harness pin to ground short circuit

Solution: S00003331

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Turn keyswitch ON.

Action

The service tool datalink adapter can NOT be connected to the 3-pin J1939 datalink connector during this check.

  • Measure the J1939 voltage of the J1939 (+) pin to battery ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

  • Measure the J1939 voltage of the J1939 (-) pin to battery ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

Specification

  • A malfunctioning OEM wiring harness has been detected if voltage is within the following specification with the crossover connector disconnected: 1 - 4.5 VDC
  • A malfunctioning engine wiring harness has been detected if voltage is not within the following specification with the crossover connector disconnected: 1 - 4.5 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Fault Code 3911 triggered by a malfunction in the J1939 data link with multiple OEM fault code

Solution: S00000912

Verification

Conditions

  • None

Action

  • Reconnect the variable geometry turbocharger actuator to the engine wiring harness.
  • Reconnect the aftertreatment intake NOx sensor to the engine wiring harness.
  • Reconnect the crossover connector.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution, if any fault code is active or has more than one inactive count within the last 25 engine operating hours from the following list: 1894, 2636, 2771, 3232, 3868, 4151, 4152, 4572, 4677, 6688
  • A malfunctioning aftertreatment SCR intermediate NH3 sensor has been detected if a fault code from the following list is not active, or does not have more than one inactive count within the last 25 engine operating hours: 1894, 2636, 2771, 3232, 3868, 4151, 4152, 4572, 4677, 668

Linked Solutions

  • None

Repair

  • Replace aftertreatment SCR intermediate NH3 sensor module.

Refer to Procedure 019-479

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

6 - J1939 data link terminating resistance is incorrect

Solution: S00000593

Verification

Conditions

  • Turn keyswitch OFF.
  • Wait for 90 seconds.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.
  • Reconnect the variable geometry turbocharger actuator if it has been previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3-pin service data link connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Follow your technical escalation process if the resistance is within the following specification: 54 - 66 Ω
  • Proceed to the Linked Solutions section if the resistance is not within the following specification: 54 - 66 Ω

Linked Solutions

  • Variable geometry turbocharger actuator has incorrect J1939 terminating resistance

Refer to S00001242

  • Engine wiring harness has incorrect J1939 terminating resistance

Refer to S00000972

  • OEM wiring harness has incorrect J1939 terminating resistance

Refer to S00000971

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

6.1 - Variable geometry turbocharger actuator has incorrect J1939 terminating resistance

Solution: S00001242

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the variable geometry turbocharger actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the variable geometry turbocharger actuator SAE J1939 data link (+) pin and the variable geometry turbocharger actuator SAE J1939 data link (-) pin at the variable geometry turbocharger actuator.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning variable geometry turbocharger actuator has been detected if the resistance is not within the following specification: 108 Ω - 132 Ω

Linked Solutions

  • None

Repair

  • Replace the variable geometry turbocharger actuator.

Refer to Procedure 010-134

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6.2 - Engine wiring harness has incorrect J1939 terminating resistance

Solution: S00000972

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect previously disconnected components.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.
  • Disconnect the aftertreatment intake NOx sensor from the engine wiring harness.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3-pin service data link connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is not within the following specification: 108-132 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6.3 - OEM wiring harness has incorrect J1939 terminating resistance

Solution: S00000971

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if the resistance is not within the following specification: 108 - 132 Ω
  • Follow your technical escalation process if the resistance is within the following specification: 108 - 132 Ω

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Parent Solution

7 - J1939 data link harness open circuit check

Solution: S00004534

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the appropriate data link component from the data link wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the J1939 (+) pin at the appropriate component data link wiring harness connector and the appropriate data link component J1939 (+) pin at the data link wiring harness ECM connector.
  • Measure the resistance between the J1939 (-) pin at the appropriate component data link wiring harness connector and the appropriate data link component J1939 (-) pin at the data link wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning J1939 data link wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - OEM terminating resistor Ω check for the J1939 data link

Solution: S00000907

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM terminating resistor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the pins for the OEM terminating resistor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM terminating resistor has been detected if the resistance is not within the following specification: 108 - 132 Ω

Linked Solutions

  • None

Repair

  • For a malfunctioning OEM terminating resistor, replace the OEM terminating resistor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Incorrect terminating resistance in the J1939 data link by a J1939 data linked component

Solution: S00001002

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Reconnect the OEM terminating resistor if previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the resistance is not within the following specification: 108 - 132 Ω

Linked Solutions

  • J1939 wire resistance check at the crossover connector for each component

Refer to S00001003

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

9.1 - J1939 wire resistance check at the crossover connector for each component

Solution: S00001003

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Reconnect the OEM terminating resistor if previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

Inspect the following components if applicable:

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector for each component while disconnecting them one at a time.
  • Disconnect the aftertreatment outlet NOx sensor
  • Disconnect the aftertreatment temperature sensor module
  • Disconnect the aftertreatment particulate sensor
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor
  • Disconnect the aftertreatment diesel exhaust fluid temperature sensor
  • Disconnect the aftertreatment diesel exhaust fluid quality sensor.
  • Disconnect the aftertreatment intermediate NH3 sensor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance was not within 108 Ω to 132 Ω and it becomes within the specification of 108 Ω to 132 Ω when the J1939 component was disconnected, then a malfunctioning J1939 component has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid tank level sensor.

Refer to OEM Service Manual

  • Replace the aftertreatment diesel exhaust fluid temperature sensor.

Refer to OEM Service Manual

  • Replace the aftertreatment diesel exhaust fluid quality sensor.

Refer to OEM Service Manual

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace aftertreatment DOC temperature sensor module.

Refer to Procedure 019-449

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

  • Replace aftertreatment intermediate NH3 sensor.

Refer to Procedure 019-479

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

10 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3912 | SPN: 5853 | FMI: 10
Aftertreatment 1 Outlet NH3 Gas Sensor Heater - Abnormal Rate of Change

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment intermediate NH3 sensor module and probe are malfunctioning

1 - Check for primary fault codes

Solution: S00000249

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment SCR: 3899, 3911, 3933, 3934

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment intermediate NH3 sensor module and probe are malfunctioning

Solution: S00005407

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment SCR intermediate NH3 sensor probe has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment SCR intermediate NH3 sensor probe.

Refer to Procedure 019-479

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 15-Aug-2021


NO TITLE

ISX15 CM2350 X101

Fault Code: 3932 | SPN: 5851 | FMI: 16
Aftertreatment 1 SCR Intermediate NH3 Gas Sensor Power Supply - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes

1 - Check for primary fault codes

Solution: S00000248

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins electronic service tool or equivalent.

Action

  • Use the recommended Cummins electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment SCR: 3899, 3911, 3934

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 20-May-2019


NO TITLE

ISX15 CM2350 X101

Fault Code: 3933 | SPN: 5851 | FMI: 18
Aftertreatment 1 SCR Intermediate NH3 Gas Sensor Power Supply - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes

1 - Check for primary fault codes

Solution: S00000247

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment SCR: 3911, 3934

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 15-Feb-2020


NO TITLE

ISX15 CM2350 X101

Fault Code: 3934 | SPN: 5851 | FMI: 2
Aftertreatment 1 SCR Intermediate NH3 Gas Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes

1 - Check for primary fault codes

Solution: S00000246

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins electronic service tool or equivalent.

Action

  • Use the recommended Cummins electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Voltage: 441, 442, 596, 597, 598

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 20-May-2019


NO TITLE

ISX15 CM2350 X101

Fault Code: 3935 | SPN: 5848 | FMI: 13
Aftertreatment 1 SCR Intermediate NH3 Sensor - Out of Calibration

Troubleshooting Summary

  1. Aftertreatment SCR intermediate NH3 sensor probe resistance check

1 - Aftertreatment SCR intermediate NH3 sensor probe resistance check

Solution: S00002989

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR intermediate NH3 sensor probe from the aftertreatment SCR intermediate NH3 sensor module.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the aftertreatment SCR intermediate NH3 sensor probe resistance.

Refer to Procedure 019-479

Specification

  • If the resistance is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace aftertreatment SCR intermediate NH3 sensor probe.

Refer to Procedure 019-479

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 17-Oct-2021


NO TITLE

ISX15 CM2350 X101

Fault Code: 3936 | SPN: 5848 | FMI: 12
Aftertreatment 1 SCR Intermediate NH3 Sensor - Bad Intelligent Device or Component

Troubleshooting Summary

  1. Campaign or Temporary Repair Practice may be available
  2. ECM calibration revision history check

1 - Campaign or Temporary Repair Practice may be available

Solution: S00003003

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Campaign or Temporary Repair Practice may be available.

Specification

  • Proceed to the Repair section if a Campaign or Temporary Repair Practice is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Campaign or Temporary Repair Practice.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 3937 | SPN: 5848 | FMI: 10
Aftertreatment 1 SCR Intermediate NH3 Sensor - Abnormal Rate of Change

Troubleshooting Summary

  1. Check for primary fault codes
  2. Campaign or Temporary Repair Practice may be available
  3. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000242

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment SCR: 3899, 3911, 3934

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Campaign or Temporary Repair Practice may be available

Solution: S00003003

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Campaign or Temporary Repair Practice may be available.

Specification

  • Proceed to the Repair section if a Campaign or Temporary Repair Practice is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Campaign or Temporary Repair Practice.

Validation

  • None
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4143 | SPN: 5835 | FMI: 3
Aftertreatment 1 Particulate Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment particulate matter sensor is damaged

1 - Check for primary fault codes

Solution: S00000230

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment Particulate sensor: 5582, 5583, 6651, 6652, 6653, 6688

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment particulate matter sensor is damaged

Solution: S00007912

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 05-Dec-2021


NO TITLE

ISX15 CM2350 X101

Fault Code: 4144 | SPN: 5835 | FMI: 4
Aftertreatment 1 Particulate Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment particulate matter sensor is damaged

1 - Check for primary fault codes

Solution: S00000227

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment Particulate sensor: 5582, 5583, 6651, 6652, 6653, 6688

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment particulate matter sensor is damaged

Solution: S00007912

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 05-Dec-2021


NO TITLE

ISX15 CM2350 X101

Fault Code: 4149 | SPN: 2623 | FMI: 8
Accelerator Pedal or Lever Position Sensor 2 Circuit Frequency - Abnormal Frequency or Pulse Width or Period

Troubleshooting Summary

  1. Check for primary fault codes
  2. Accelerator pedal position sensor open circuit check
  3. Accelerator pedal position sensor circuit short to ground
  4. Accelerator pedal position sensor circuit pin to pin short
  5. Accelerator pedal position sensor circuit pin to pin short
  6. ECM calibration revision history check
  7. Accelerator pedal sensor malfunctioning

1 - Check for primary fault codes

Solution: S00000914

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 4: 2185, 2186
  • Sensor supply 5: 1695, 1696

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Accelerator pedal position sensor open circuit check

Solution: S00000702

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Accelerator pedal position sensor circuit short to ground

Solution: S00000700

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100K Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Accelerator pedal position sensor circuit pin to pin short

Solution: S00000468

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Accelerator pedal position sensor circuit pin to pin short

Solution: S00000721

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect all components on the wiring circuit being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal 1 SIGNAL pin in the OEM wiring harness ECM connector and all other pins in that connector.
  • Measure the resistance between the accelerator pedal 2 SIGNAL pin in the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Accelerator pedal sensor malfunctioning

Solution: S00000915

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning accelerator pedal position sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the accelerator pedal position sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4151 | SPN: 5742 | FMI: 9
Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Abnormal Update Rate

Troubleshooting Summary

  1. Check for primary fault codes
  2. Low battery voltage
  3. Battery load test
  4. Ground inspection
  5. Fault Code 4151 triggered by a malfunction in the J1939 data link with multiple OEM fault code
  6. Aftertreatment DPF temperature sensor module voltage check
  7. Aftertreatment power relay voltage check
  8. Aftertreatment power relay resistance check
  9. Aftertreatment DPF temperature sensor module circuit check
  10. Aftertreatment power relay circuit check
  11. J1939 data link engine wiring harness voltage check 3 pin service connector
  12. OEM sensor voltage check
  13. J1939 data link harness pin to ground short circuit
  14. J1939 data link terminating resistance is incorrect
  15. Variable geometry turbocharger actuator has incorrect J1939 terminating resistance
  16. Engine wiring harness has incorrect J1939 terminating resistance
  17. OEM wiring harness has incorrect J1939 terminating resistance
  18. J1939 data link harness open circuit check
  19. OEM terminating resistor Ω check for the J1939 data link
  20. Incorrect terminating resistance in the J1939 data link by a J1939 data linked component
  21. J1939 wire resistance check at the crossover connector for each component
  22. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000226

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Turbocharger: 1894, 2636

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Low battery voltage

Solution: S00001110

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.
  • If this vehicle has been repaired within the last 30 days for the same fault code, then proceed to the Linked Solutions section.

Specification

  • If the battery voltage is at least 10.8 VDC (12 volt systems) or 21.6 VDC (24 volt systems), then proceed to the Linked Solutions section.
  • If the battery or battery cables show signs of corrosion or damage, then proceed to the Repair Section.

Linked Solutions

  • Battery load test

Refer to S00001379

  • Ground inspection

Refer to S00000754

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean corrosion or tighten battery cable connections.

Refer to OEM Service Manual

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Battery load test

Solution: S00001379

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Disconnect the batteries from each other.
  • Connect a load tester separately to each battery.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.

Specification

  • For a 12 volt system, proceed to the Repair section if the battery voltage is below the following specification: 11 VDC
  • For a 24 volt system, proceed to the Repair section if the battery voltage is below the following specification: 22 VDC

Linked Solutions

  • None

Repair

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Ground inspection

Solution: S00000754

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the ECM ground for damage, corrosion and loose connections.
  • Visually inspect the aftertreatment interface wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the OEM wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the grounds for proper routing.

Specification

  • If damage, corrosion or incorrect routing of grounds are found, then proceed to the Repair section

Linked Solutions

  • None

Repair

  • Clean or replace connections.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Fault Code 4151 triggered by a malfunction in the J1939 data link with multiple OEM fault code

Solution: S00000918

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution, if any fault code is active or has more than one inactive count within the last 25 engine operating hours from the following list: 1894, 2636, 2771, 3232, 3868, 3911, 4151, 4152, 4572, 4677, 6688
  • A malfunctioning aftertreatment DPF temperature sensor module has been detected if a fault code from the following list is not active, or does not have more than one inactive count within the last 25 engine operating hours: 1894, 2636, 2771, 3232, 3868, 3911, 4151, 4152, 4572, 4677, 6688

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment DPF temperature sensor module voltage check

Solution: S00010338

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF temperature sensor module from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the aftertreatment DPF temperature sensor module battery voltage SUPPLY circuit and the aftertreatment DPF temperature sensor module RETURN circuit at the aftertreatment DPF temperature sensor module wiring harness connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 1 VDC

Linked Solutions

  • Aftertreatment power relay voltage check

Refer to S00010303

  • Aftertreatment power relay resistance check

Refer to S00010305

  • Aftertreatment DPF temperature sensor module circuit check

Refer to S00010339

  • Aftertreatment power relay circuit check

Refer to S00010368

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Aftertreatment power relay voltage check

Solution: S00010303

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment power relay battery voltage SUPPLY pin in the aftertreatment power relay connector of the OEM wiring harness and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.2 - Aftertreatment power relay resistance check

Solution: S00010305

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment power relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.3 - Aftertreatment DPF temperature sensor module circuit check

Solution: S00010339

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.
  • Disconnect the aftertreatment DPF temperature sensor module from the aftertreatment interface wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment power relay SUPPLY pin at the aftertreatment power relay connector of the OEM wiring harness and the aftertreatment power relay SUPPLY pin at the aftertreatment interface wiring harness aftertreatment outlet NOx sensor connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or aftertreatment interface wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, aftertreatment interface wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the aftertreatment interface wiring harness.

Refer to Procedure 019-477

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.4 - Aftertreatment power relay circuit check

Solution: S00010368

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment power relay from the OEM wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment power relay CONTROL pin at the aftertreatment power relay connector of the OEM wiring harness and the aftertreatment power relay CONTROL pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness or engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - J1939 data link engine wiring harness voltage check 3 pin service connector

Solution: S00000594

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect all SAE J1939 components.
  • Turn keyswitch ON.

Action

The service tool datalink adapter can NOT be connected to the 3-pin J1939 datalink connector during this check.

  • Measure the J1939 voltage of the J1939 (+) pin to ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

  • Measure the J1939 voltage of the J1939 (-) pin to ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

Specification

  • A malfunctioning wiring harness has been detected due to the J1939 data link circuit being shorted to a voltage source if the voltage is greater than the following specification: 4.5 VDC
  • Proceed to the Linked Solutions section if the voltage is less than the following specification: 1 VDC
  • Proceed to the next solution if the voltage is within the following specification for both the SAE J1939 data link (+) and SAE J1939 data link (-) circuit: 1 - 4.5 VDC

Linked Solutions

  • OEM J1939 data link component isolation

Refer to S00003176

  • Engine or OEM wiring harness shorted to ground

Refer to S00003331

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5.1 - OEM sensor voltage check

Solution: S00003176

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Reconnect the crossover connector.

Inspect the following components if applicable:

  • Turn keyswitch ON.
  • Measure the J1939 voltage of the SAE J1939 data link (+) and SAE data link J1939 (-) pins at the variable geometry turbocharger actuator engine wiring harness connector to battery ground while each component is disconnected one at a time.
  • Disconnect the aftertreatment outlet NOx sensor
  • Disconnect the aftertreatment DPF temperature sensor module.
  • Disconnect the aftertreatment SCR temperature sensor module.
  • Disconnect the aftertreatment intermediate NH3 sensor.
  • Disconnect the aftertreatment particulate sensor
  • Disconnect the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.
  • Disconnect the aftertreatment exhaust gas temperature sensor.
  • Disconnect the aftertreatment intake NOx sensor.

Specification

  • A malfunctioning SAE J1939 data link component has been detected if the voltage is within the following specification after the component has been disconnected: 1 - 4.5 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.

Refer to OEM Service Manual

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

  • Replace aftertreatment DPF temperature sensor module.

Refer to Procedure 019-449

  • Replace the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-449

  • Replace aftertreatment intermediate NH3 sensor.

Refer to Procedure 019-479

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.2 - J1939 data link harness pin to ground short circuit

Solution: S00003331

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Turn keyswitch ON.

Action

The service tool datalink adapter can NOT be connected to the 3-pin J1939 datalink connector during this check.

  • Measure the J1939 voltage of the J1939 (+) pin to battery ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

  • Measure the J1939 voltage of the J1939 (-) pin to battery ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

Specification

  • A malfunctioning OEM wiring harness has been detected if voltage is within the following specification with the crossover connector disconnected: 1 - 4.5 VDC
  • A malfunctioning engine wiring harness has been detected if voltage is not within the following specification with the crossover connector disconnected: 1 - 4.5 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - J1939 data link terminating resistance is incorrect

Solution: S00000593

Verification

Conditions

  • Turn keyswitch OFF.
  • Wait for 90 seconds.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.
  • Reconnect the variable geometry turbocharger actuator if it has been previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3-pin service data link connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Follow your technical escalation process if the resistance is within the following specification: 54 - 66 Ω
  • Proceed to the Linked Solutions section if the resistance is not within the following specification: 54 - 66 Ω

Linked Solutions

  • Variable geometry turbocharger actuator has incorrect J1939 terminating resistance

Refer to S00001242

  • Engine wiring harness has incorrect J1939 terminating resistance

Refer to S00000972

  • OEM wiring harness has incorrect J1939 terminating resistance

Refer to S00000971

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

6.1 - Variable geometry turbocharger actuator has incorrect J1939 terminating resistance

Solution: S00001242

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the variable geometry turbocharger actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the variable geometry turbocharger actuator SAE J1939 data link (+) pin and the variable geometry turbocharger actuator SAE J1939 data link (-) pin at the variable geometry turbocharger actuator.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning variable geometry turbocharger actuator has been detected if the resistance is not within the following specification: 108 Ω - 132 Ω

Linked Solutions

  • None

Repair

  • Replace the variable geometry turbocharger actuator.

Refer to Procedure 010-134

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6.2 - Engine wiring harness has incorrect J1939 terminating resistance

Solution: S00000972

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect previously disconnected components.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.
  • Disconnect the aftertreatment intake NOx sensor from the engine wiring harness.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3-pin service data link connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is not within the following specification: 108-132 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6.3 - OEM wiring harness has incorrect J1939 terminating resistance

Solution: S00000971

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if the resistance is not within the following specification: 108 - 132 Ω
  • Follow your technical escalation process if the resistance is within the following specification: 108 - 132 Ω

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Parent Solution

7 - J1939 data link harness open circuit check

Solution: S00004534

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the appropriate data link component from the data link wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the J1939 (+) pin at the appropriate component data link wiring harness connector and the appropriate data link component J1939 (+) pin at the data link wiring harness ECM connector.
  • Measure the resistance between the J1939 (-) pin at the appropriate component data link wiring harness connector and the appropriate data link component J1939 (-) pin at the data link wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning J1939 data link wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - OEM terminating resistor Ω check for the J1939 data link

Solution: S00000907

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM terminating resistor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the pins for the OEM terminating resistor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM terminating resistor has been detected if the resistance is not within the following specification: 108 - 132 Ω

Linked Solutions

  • None

Repair

  • For a malfunctioning OEM terminating resistor, replace the OEM terminating resistor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Incorrect terminating resistance in the J1939 data link by a J1939 data linked component

Solution: S00001002

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Reconnect the OEM terminating resistor if previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the resistance is not within the following specification: 108 - 132 Ω

Linked Solutions

  • J1939 wire resistance check at the crossover connector for each component

Refer to S00001003

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

9.1 - J1939 wire resistance check at the crossover connector for each component

Solution: S00001003

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Reconnect the OEM terminating resistor if previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

Inspect the following components if applicable:

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector for each component while disconnecting them one at a time.
  • Disconnect the aftertreatment outlet NOx sensor
  • Disconnect the aftertreatment temperature sensor module
  • Disconnect the aftertreatment particulate sensor
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor
  • Disconnect the aftertreatment diesel exhaust fluid temperature sensor
  • Disconnect the aftertreatment diesel exhaust fluid quality sensor.
  • Disconnect the aftertreatment intermediate NH3 sensor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance was not within 108 Ω to 132 Ω and it becomes within the specification of 108 Ω to 132 Ω when the J1939 component was disconnected, then a malfunctioning J1939 component has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid tank level sensor.

Refer to OEM Service Manual

  • Replace the aftertreatment diesel exhaust fluid temperature sensor.

Refer to OEM Service Manual

  • Replace the aftertreatment diesel exhaust fluid quality sensor.

Refer to OEM Service Manual

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace aftertreatment DOC temperature sensor module.

Refer to Procedure 019-449

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

  • Replace aftertreatment intermediate NH3 sensor.

Refer to Procedure 019-479

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

10 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4152 | SPN: 5743 | FMI: 9
Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Abnormal Update Rate

Troubleshooting Summary

  1. Check for primary fault codes
  2. Low battery voltage
  3. Battery load test
  4. Ground inspection
  5. Fault Code 4152 triggered by a malfunction in the J1939 data link with multiple OEM fault codes
  6. Aftertreatment SCR temperature sensor module voltage check
  7. Fuse check
  8. Aftertreatment SCR temperature sensor module voltage check
  9. J1939 data link engine wiring harness voltage check 3 pin service connector
  10. OEM sensor voltage check
  11. J1939 data link harness pin to ground short circuit
  12. J1939 data link terminating resistance is incorrect
  13. Variable geometry turbocharger actuator has incorrect J1939 terminating resistance
  14. Engine wiring harness has incorrect J1939 terminating resistance
  15. OEM wiring harness has incorrect J1939 terminating resistance
  16. J1939 data link harness open circuit check
  17. OEM terminating resistor Ω check for the J1939 data link
  18. Incorrect terminating resistance in the J1939 data link by a J1939 data linked component
  19. J1939 wire resistance check at the crossover connector for each component
  20. ECM calibration revision history check
  21. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000225

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Turbocharger: 1894, 2636

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Low battery voltage

Solution: S00001110

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.
  • If this vehicle has been repaired within the last 30 days for the same fault code, then proceed to the Linked Solutions section.

Specification

  • If the battery voltage is at least 10.8 VDC (12 volt systems) or 21.6 VDC (24 volt systems), then proceed to the Linked Solutions section.
  • If the battery or battery cables show signs of corrosion or damage, then proceed to the Repair Section.

Linked Solutions

  • Battery load test

Refer to S00001379

  • Ground inspection

Refer to S00000754

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean corrosion or tighten battery cable connections.

Refer to OEM Service Manual

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Battery load test

Solution: S00001379

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Disconnect the batteries from each other.
  • Connect a load tester separately to each battery.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.

Specification

  • For a 12 volt system, proceed to the Repair section if the battery voltage is below the following specification: 11 VDC
  • For a 24 volt system, proceed to the Repair section if the battery voltage is below the following specification: 22 VDC

Linked Solutions

  • None

Repair

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Ground inspection

Solution: S00000754

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the ECM ground for damage, corrosion and loose connections.
  • Visually inspect the aftertreatment interface wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the OEM wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the grounds for proper routing.

Specification

  • If damage, corrosion or incorrect routing of grounds are found, then proceed to the Repair section

Linked Solutions

  • None

Repair

  • Clean or replace connections.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Fault Code 4152 triggered by a malfunction in the J1939 data link with multiple OEM fault codes

Solution: S00000921

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution, if any fault code is active or has more than one inactive count within the last 25 engine operating hours from the following list: 1894, 2636, 2771, 3232, 3868, 3911, 4151, 4152, 4572, 4677, 6688
  • A malfunctioning aftertreatment SCR temperature sensor module has been detected if a fault code from the following list is not active, or does not have more than one inactive count within the last 25 engine operating hours: 1894, 2636, 2771, 3232, 3868, 3911, 4151, 4152, 4572, 4677, 6688

Linked Solutions

  • None

Repair

  • Replace the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment SCR temperature sensor module voltage check

Solution: S00000919

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment SCR temperature sensor module battery voltage SUPPLY pin and the aftertreatment SCR temperature sensor module battery voltage RETURN pin at the aftertreatment SCR temperature sensor module OEM wiring harness connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Check the voltage at key ON, while cranking the engine, and with the engine at idle.

Specification

  • Proceed to the Linked Solutions section if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • Fuse check

Refer to S00001852

  • Aftertreatment SCR temperature sensor module voltage check.

Refer to S00000920

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Fuse check

Solution: S00001852

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the fuse.

Refer to Procedure 019-198

Specification

  • If the fuse is found to be blown or damaged, then proceed to Repair section.

Linked Solutions

  • None

Repair

  • Replace the fuse.

Refer to Procedure 019-198

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.2 - Aftertreatment SCR temperature sensor module voltage check

Solution: S00000920

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage from the aftertreatment SCR temperature sensor module battery voltage SUPPLY pin of the OEM wiring harness to engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • An open circuit or high resistance has been detected in the aftertreatment SCR temperature sensor module battery voltage RETURN circuit if the voltage is within the following specification of battery voltage: 1 VDC
  • An open circuit or high resistance has been detected in the aftertreatment SCR temperature sensor module battery voltage SUPPLY circuit if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Replace SCR aftertreatment interface harness.

Refer to Procedure 019-477

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the fuse.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - J1939 data link engine wiring harness voltage check 3 pin service connector

Solution: S00000594

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect all SAE J1939 components.
  • Turn keyswitch ON.

Action

The service tool datalink adapter can NOT be connected to the 3-pin J1939 datalink connector during this check.

  • Measure the J1939 voltage of the J1939 (+) pin to ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

  • Measure the J1939 voltage of the J1939 (-) pin to ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

Specification

  • A malfunctioning wiring harness has been detected due to the J1939 data link circuit being shorted to a voltage source if the voltage is greater than the following specification: 4.5 VDC
  • Proceed to the Linked Solutions section if the voltage is less than the following specification: 1 VDC
  • Proceed to the next solution if the voltage is within the following specification for both the SAE J1939 data link (+) and SAE J1939 data link (-) circuit: 1 - 4.5 VDC

Linked Solutions

  • OEM J1939 data link component isolation

Refer to S00003176

  • Engine or OEM wiring harness shorted to ground

Refer to S00003331

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5.1 - OEM sensor voltage check

Solution: S00003176

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Reconnect the crossover connector.

Inspect the following components if applicable:

  • Turn keyswitch ON.
  • Measure the J1939 voltage of the SAE J1939 data link (+) and SAE data link J1939 (-) pins at the variable geometry turbocharger actuator engine wiring harness connector to battery ground while each component is disconnected one at a time.
  • Disconnect the aftertreatment outlet NOx sensor
  • Disconnect the aftertreatment DPF temperature sensor module.
  • Disconnect the aftertreatment SCR temperature sensor module.
  • Disconnect the aftertreatment intermediate NH3 sensor.
  • Disconnect the aftertreatment particulate sensor
  • Disconnect the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.
  • Disconnect the aftertreatment exhaust gas temperature sensor.
  • Disconnect the aftertreatment intake NOx sensor.

Specification

  • A malfunctioning SAE J1939 data link component has been detected if the voltage is within the following specification after the component has been disconnected: 1 - 4.5 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.

Refer to OEM Service Manual

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

  • Replace aftertreatment DPF temperature sensor module.

Refer to Procedure 019-449

  • Replace the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-449

  • Replace aftertreatment intermediate NH3 sensor.

Refer to Procedure 019-479

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.2 - J1939 data link harness pin to ground short circuit

Solution: S00003331

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Turn keyswitch ON.

Action

The service tool datalink adapter can NOT be connected to the 3-pin J1939 datalink connector during this check.

  • Measure the J1939 voltage of the J1939 (+) pin to battery ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

  • Measure the J1939 voltage of the J1939 (-) pin to battery ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

Specification

  • A malfunctioning OEM wiring harness has been detected if voltage is within the following specification with the crossover connector disconnected: 1 - 4.5 VDC
  • A malfunctioning engine wiring harness has been detected if voltage is not within the following specification with the crossover connector disconnected: 1 - 4.5 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - J1939 data link terminating resistance is incorrect

Solution: S00000593

Verification

Conditions

  • Turn keyswitch OFF.
  • Wait for 90 seconds.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.
  • Reconnect the variable geometry turbocharger actuator if it has been previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3-pin service data link connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Follow your technical escalation process if the resistance is within the following specification: 54 - 66 Ω
  • Proceed to the Linked Solutions section if the resistance is not within the following specification: 54 - 66 Ω

Linked Solutions

  • Variable geometry turbocharger actuator has incorrect J1939 terminating resistance

Refer to S00001242

  • Engine wiring harness has incorrect J1939 terminating resistance

Refer to S00000972

  • OEM wiring harness has incorrect J1939 terminating resistance

Refer to S00000971

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

6.1 - Variable geometry turbocharger actuator has incorrect J1939 terminating resistance

Solution: S00001242

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the variable geometry turbocharger actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the variable geometry turbocharger actuator SAE J1939 data link (+) pin and the variable geometry turbocharger actuator SAE J1939 data link (-) pin at the variable geometry turbocharger actuator.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning variable geometry turbocharger actuator has been detected if the resistance is not within the following specification: 108 Ω - 132 Ω

Linked Solutions

  • None

Repair

  • Replace the variable geometry turbocharger actuator.

Refer to Procedure 010-134

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6.2 - Engine wiring harness has incorrect J1939 terminating resistance

Solution: S00000972

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect previously disconnected components.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.
  • Disconnect the aftertreatment intake NOx sensor from the engine wiring harness.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3-pin service data link connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is not within the following specification: 108-132 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6.3 - OEM wiring harness has incorrect J1939 terminating resistance

Solution: S00000971

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if the resistance is not within the following specification: 108 - 132 Ω
  • Follow your technical escalation process if the resistance is within the following specification: 108 - 132 Ω

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Parent Solution

7 - J1939 data link harness open circuit check

Solution: S00004534

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the appropriate data link component from the data link wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the J1939 (+) pin at the appropriate component data link wiring harness connector and the appropriate data link component J1939 (+) pin at the data link wiring harness ECM connector.
  • Measure the resistance between the J1939 (-) pin at the appropriate component data link wiring harness connector and the appropriate data link component J1939 (-) pin at the data link wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning J1939 data link wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - OEM terminating resistor Ω check for the J1939 data link

Solution: S00000907

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM terminating resistor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the pins for the OEM terminating resistor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM terminating resistor has been detected if the resistance is not within the following specification: 108 - 132 Ω

Linked Solutions

  • None

Repair

  • For a malfunctioning OEM terminating resistor, replace the OEM terminating resistor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Incorrect terminating resistance in the J1939 data link by a J1939 data linked component

Solution: S00001002

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Reconnect the OEM terminating resistor if previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the resistance is not within the following specification: 108 - 132 Ω

Linked Solutions

  • J1939 wire resistance check at the crossover connector for each component

Refer to S00001003

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

9.1 - J1939 wire resistance check at the crossover connector for each component

Solution: S00001003

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Reconnect the OEM terminating resistor if previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

Inspect the following components if applicable:

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector for each component while disconnecting them one at a time.
  • Disconnect the aftertreatment outlet NOx sensor
  • Disconnect the aftertreatment temperature sensor module
  • Disconnect the aftertreatment particulate sensor
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor
  • Disconnect the aftertreatment diesel exhaust fluid temperature sensor
  • Disconnect the aftertreatment diesel exhaust fluid quality sensor.
  • Disconnect the aftertreatment intermediate NH3 sensor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance was not within 108 Ω to 132 Ω and it becomes within the specification of 108 Ω to 132 Ω when the J1939 component was disconnected, then a malfunctioning J1939 component has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid tank level sensor.

Refer to OEM Service Manual

  • Replace the aftertreatment diesel exhaust fluid temperature sensor.

Refer to OEM Service Manual

  • Replace the aftertreatment diesel exhaust fluid quality sensor.

Refer to OEM Service Manual

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace aftertreatment DOC temperature sensor module.

Refer to Procedure 019-449

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

  • Replace aftertreatment intermediate NH3 sensor.

Refer to Procedure 019-479

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

10 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

11 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00009782

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4153 | SPN: 7321 | FMI: 3
Aftertreatment 1 Particulate Sensor Heater High Side Driver Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment particulate matter sensor is damaged

1 - Check for primary fault codes

Solution: S00000224

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment Particulate sensor: 5582, 5583, 6651, 6652, 6653, 6688

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment particulate matter sensor is damaged

Solution: S00007912

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 05-Dec-2021


NO TITLE

ISX15 CM2350 X101

Fault Code: 4154 | SPN: 7323 | FMI: 4
Aftertreatment 1 Particulate Sensor Heater Low Side Driver Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment particulate matter sensor is damaged

1 - Check for primary fault codes

Solution: S00000222

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment Particulate sensor: 5582, 5583, 6651, 6652, 6653, 6688

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment particulate matter sensor is damaged

Solution: S00007912

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 05-Dec-2021


NO TITLE

ISX15 CM2350 X101

Fault Code: 4155 | SPN: 5746 | FMI: 3
Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Heater Relay Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid dosing unit heater relay is malfunctioning
  2. Aftertreatment diesel exhaust fluid dosing unit heater relay circuit pin to pin short

1 - Aftertreatment diesel exhaust fluid dosing unit heater relay is malfunctioning

Solution: S00002253

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit heater relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid dosing unit heater relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid dosing unit heater relay circuit pin to pin short

Solution: S00002254

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit heater relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit heater relay RETURN pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4156 | SPN: 5746 | FMI: 4
Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Heater Relay Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid line heater relay voltage check
  2. Aftertreatment diesel exhaust fluid dosing unit heater relay is malfunctioning
  3. Aftertreatment diesel exhaust fluid dosing unit heater relay open circuit check
  4. Aftertreatment diesel exhaust fluid dosing unit heater relay circuit pin to ground short
  5. Aftertreatment diesel exhaust fluid dosing unit heater relay circuit pin to pin short

1 - Aftertreatment diesel exhaust fluid line heater relay voltage check

Solution: S00001127

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relays 1,2, and 3 from the OEM wiring harness connector.

Action

  • Visually verify that the OEM fuses are not damaged or malfunctioning.

Refer to Procedure 019-198

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment diesel exhaust fluid line heater relay 1 SUPPLY at the aftertreatment diesel exhaust fluid line heater relay connector and chassis ground.
  • Measure the voltage between the aftertreatment diesel exhaust fluid line heater relay 2 SUPPLY at the aftertreatment diesel exhaust fluid line heater relay connector and chassis ground.
  • Measure the voltage between the aftertreatment diesel exhaust fluid line heater relay 3 SUPPLY at the aftertreatment diesel exhaust fluid line heater relay connector and chassis ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • An open or short circuit to ground has been detected in the aftertreatment diesel exhaust fluid line heater SUPPLY circuit if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to OEM Service Manual

  • Replace the fuse.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid dosing unit heater relay is malfunctioning

Solution: S00002253

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit heater relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid dosing unit heater relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid dosing unit heater relay open circuit check

Solution: S00002268

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit heater relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit heater relay RETURN pin at the aftertreatment diesel exhaust fluid dosing unit heater relay connector of the OEM wiring harness and the aftertreatment diesel exhaust fluid dosing unit heater relay RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • None
Next Solution

4 - Aftertreatment diesel exhaust fluid dosing unit heater relay circuit pin to ground short

Solution: S00002275

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit heater relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit heater relay RETURN pin at the OEM wiring harness ECM connector and engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment diesel exhaust fluid dosing unit heater relay circuit pin to pin short

Solution: S00002254

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit heater relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit heater relay RETURN pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4157 | SPN: 4376 | FMI: 7
Aftertreatment Diesel Exhaust Fluid Return Valve - Mechanical System Not Responding or Out of Adjustment

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid dosing unit line or fittings are cracked, plugged or restricted
  3. Air in the aftertreatment diesel exhaust fluid
  4. Aftertreatment diesel exhaust fluid dosing unit purge cycle

1 - Check for primary fault codes

Solution: S00000220

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 3571, 3572, 3574, 3575, 3577, 3578, 3596
  • Sensor supply 5: 1695, 1696

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid dosing unit line or fittings are cracked, plugged or restricted

Solution: S00000664

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the lines are not swapped at the dosing unit, dosing valve or diesel exhaust fluid tank connections.

Refer to Procedure 011-058

  • Visually inspect the aftertreatment diesel exhaust fluid tank connections for cracks or pitting.
  • Visually inspect the aftertreatment diesel exhaust fluid tank vent line for restrictions.
  • Visually inspect the aftertreatment diesel exhaust fluid line for damage.
  • Visually inspect both dosing unit connections and fittings for loose, leaking, or damaged connections.
  • Disconnect the suction line and pressure line dosing unit connectors and look for signs of build-up or blockage.

Refer to Procedure 011-058

  • Visually inspect the suction line for signs of leakage or openings which will allow the dosing unit to suck in air with the diesel exhaust fluid.
  • Visually inspect the pressure line for signs of leakage or rupture.
  • Verify proper sealing at all connection points, including diesel exhaust fluid tank, dosing unit, and dosing valve.

Refer to Procedure 011-058

Specification

  • If there are aftertreament diesel exhaust fluid lines reversed, damaged, leaking or restricted connections found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace damaged components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Air in the aftertreatment diesel exhaust fluid

Solution: S00000730

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Check for air in the diesel exhaust fluid.

Refer to Procedure 011-075

Specification

  • If a line, fitting, connection, or dosing unit is leaking, then a malfunction has been detected in the aftertreatment diesel exhaust fluid system or dosing unit.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to Procedure 011-075

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid dosing unit purge cycle

Solution: S00002305

Verification

Conditions

  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Turn keyswitch ON.

Action

  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-080

  • Turn keyswitch OFF.
  • Wait for 90 seconds.
  • Turn keyswitch ON.

Specification

  • Proceed to the Repair section if the fault code is still active after the purge cycle.

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 15-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4158 | SPN: 5742 | FMI: 12
Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Bad Intelligent Device or Component

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000219

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment DPF: 4151, 4161, 4162, 4163, 4259

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00004310

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4159 | SPN: 5743 | FMI: 12
Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Bad Intelligent Device or Component

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000218

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment SCR: 4152, 4164, 4165, 4166, 4261

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00004310

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4161 | SPN: 5742 | FMI: 3
Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment DPF temperature sensor module voltage check
  3. Aftertreatment DPF temperature sensor module configuration is incorrect
  4. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000217

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Voltage: 441, 442, 596, 597, 598

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment DPF temperature sensor module voltage check

Solution: S00000923

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF temperature sensor module from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment DPF temperature sensor module battery voltage SUPPLY circuit and the aftertreatment DPF temperature sensor module RETURN circuit at the aftertreatment DPF temperature sensor module wiring harness connector.
  • Measure the voltage from the aftertreatment DPF temperature sensor module battery voltage SUPPLY pin of the OEM wiring harness to engine block ground.

Check the voltage at key ON, while cranking the engine, and with the engine at idle.

Specification

  • If the voltage is greater than 18 volts (12 volt system) or 30 volts (24 volt system), a short circuit to battery has been detected in the aftertreatment DPF temperature sensor module battery voltage supply circuit, and an overcharging condition has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment DPF temperature sensor module configuration is incorrect

Solution: S00000924

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the aftertreatment DPF temperature sensor module is correct for the engine configuration.

Specification

  • If the aftertreatment DPF temperature sensor module is not the correct part number for the engine configuration, then the incorrect aftertreatment DPF temperature sensor module has been installed.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00009782

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 08-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4162 | SPN: 5742 | FMI: 4
Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment DPF temperature sensor module voltage check
  3. Aftertreatment DPF temperature sensor module configuration is incorrect
  4. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000216

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Voltage: 441, 442, 596, 597, 598

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment DPF temperature sensor module voltage check

Solution: S00000925

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF temperature sensor module from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment DPF temperature sensor module battery voltage SUPPLY circuit and the aftertreatment DPF temperature sensor module RETURN circuit at the aftertreatment DPF temperature sensor module wiring harness connector.
  • Measure the voltage from the aftertreatment DPF temperature sensor module battery voltage SUPPLY pin of the OEM wiring harness to engine block ground.

Check the voltage at key ON, while cranking the engine, and with the engine at idle.

Specification

  • If the voltage is less than 10 volts (12 volt system) or 20 volts (24 volt system), an open circuit or high resistance has been detected in the aftertreatment DPF temperature sensor module battery voltage SUPPLY circuit.
  • If the voltage is less than 10 volts (12 volt system) or 20 volts (24 volt system), an open circuit or high resistance has been detected in the aftertreatment DPF temperature sensor module battery voltage RETURN circuit.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.

Refer to Procedure 019-071

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

3 - Aftertreatment DPF temperature sensor module configuration is incorrect

Solution: S00000924

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the aftertreatment DPF temperature sensor module is correct for the engine configuration.

Specification

  • If the aftertreatment DPF temperature sensor module is not the correct part number for the engine configuration, then the incorrect aftertreatment DPF temperature sensor module has been installed.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00009782

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 08-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4163 | SPN: 5742 | FMI: 16
Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Aftertreatment DPF temperature sensor module is above normal operating range
  2. ECM calibration revision history check

1 - Aftertreatment DPF temperature sensor module is above normal operating range

Solution: S00000926

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the aftertreatment DPF temperature sensor module is properly mounted.
  • Verify the proper heat shield is mounted over the aftertreatment temperature sensor module.
  • Visually inspect for debris on or around the aftertreatment temperature sensor module.
  • Visually check that no aftermarket shields, flaps, or brackets are mounted too close to the aftertreatment temperature sensor module.
  • Visually inspect for any exhaust leaks which would allow the aftertreatment temperature sensor module to overheat.

Specification

  • If signs of tampering or incorrect installation has been found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Relocate and/or secure the aftertreatment DPF temperature sensor module.

Refer to Procedure 019-449

  • Install the proper heat shield (if equipped).

Refer to Procedure 011-032

  • Remove any obstruction in or around the aftertreatment DPF temperature sensor module.

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4164 | SPN: 5743 | FMI: 3
Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment SCR temperature sensor module voltage check
  3. Aftertreatment SCR temperature sensor module incorrect configuration
  4. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000215

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Voltage: 441, 442, 596, 597, 598

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment SCR temperature sensor module voltage check

Solution: S00000927

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment SCR temperature sensor module battery voltage SUPPLY pin and the aftertreatment SCR temperature sensor module battery voltage RETURN pin at the aftertreatment SCR temperature sensor module OEM wiring harness connector.
  • Measure the voltage from the aftertreatment SCR temperature sensor module battery voltage SUPPLY pin of the OEM wiring harness to engine block ground.

Check the voltage at key ON, while cranking the engine, and with the engine at idle.

Specification

  • If the voltage is greater than 18 volts (12 volt system) or 30 volts (24 volt system), a short circuit to battery has been detected in the aftertreatment SCR temperature sensor module battery voltage supply circuit and an overcharging condition has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning components.
  • Troubleshoot the OEM wiring harness, and all interconnects.

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

3 - Aftertreatment SCR temperature sensor module incorrect configuration

Solution: S00000928

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the aftertreatment SCR temperature sensor module is correct for the engine configuration.

Specification

  • If the aftertreatment SCR temperature sensor module is not the correct part number for the engine configuration, then the incorrect aftertreatment SCR temperature sensor module has been installed.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00009782

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 08-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4165 | SPN: 5743 | FMI: 4
Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment SCR temperature sensor module voltage check
  3. Aftertreatment SCR temperature sensor module circuit check
  4. Aftertreatment SCR temperature sensor module incorrect configuration
  5. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000214

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Voltage: 441, 442, 596, 597, 598

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment SCR temperature sensor module voltage check

Solution: S00000929

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment SCR temperature sensor module battery voltage SUPPLY pin and the aftertreatment SCR temperature sensor module battery voltage RETURN pin at the aftertreatment SCR temperature sensor module OEM wiring harness connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Check the voltage at key ON, while cranking the engine, and with the engine at idle.

Specification

  • If the voltage is greater than 10 volts (12 volt system) or 20 volts (24 volt system), proceed to the next solution.
  • If the voltage is less than 10 volts (12 volt system) or 20 volts (24 volt system), then proceed to the Linked Solutions section.

Linked Solutions

  • Aftertreatment SCR temperature sensor module circuit check

Refer to S00001067

Repair

  • No additional action is required for this solution.

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

2.1 - Aftertreatment SCR temperature sensor module circuit check

Solution: S00001067

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Measure the resistance between the aftertreatment SCR temperature sensor module battery voltage SUPPLY pin at the aftertreatment SCR temperature sensor module connector of the OEM wiring harness and the aftertreatment SCR temperature sensor module battery voltage SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment SCR temperature sensor module RETURN pin at the aftertreatment SCR temperature sensor module connector of the OEM wiring harness to battery (-).
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Aftertreatment SCR temperature sensor module incorrect configuration

Solution: S00000928

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the aftertreatment SCR temperature sensor module is correct for the engine configuration.

Specification

  • If the aftertreatment SCR temperature sensor module is not the correct part number for the engine configuration, then the incorrect aftertreatment SCR temperature sensor module has been installed.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00009782

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 08-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4166 | SPN: 5743 | FMI: 16
Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Aftertreatment SCR temperature sensor module is above normal operating range
  2. ECM calibration revision history check
  3. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Aftertreatment SCR temperature sensor module is above normal operating range

Solution: S00000930

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the aftertreatment SCR temperature sensor module is properly mounted.

Refer to Procedure 019-449

  • Verify the proper heat shield is mounted over the aftertreatment temperature sensor module.

Refer to Procedure 011-032

  • Visually inspect for debris on or around the aftertreatment temperature sensor module.
  • Visually check that no aftermarket shields, flaps, or brackets are mounted too close to the aftertreatment temperature sensor module.
  • Visually inspect for any exhaust leaks which would allow the aftertreatment temperature sensor module to overheat.

Specification

  • If signs of tampering or incorrect installation has been found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Relocate and/or secure the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-449

  • Install the proper heat shield (if equipped).

Refer to Procedure 011-032

  • Remove any obstruction in or around the aftertreatment SCR temperature sensor module.

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00004310

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4168 | SPN: 5745 | FMI: 3
Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 1 Heater Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Check for primary fault codes
  3. Aftertreatment diesel exhaust fluid dosing unit heater relay short circuit
  4. Aftertreatment diesel exhaust fluid dosing unit heater relay circuit pin to ground short
  5. Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

1 - Check for primary fault codes

Solution: S00000213

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 2976, 4155, 4156

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Check for primary fault codes

Solution: S00006653

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 2976, 4155, 4156

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

3 - Aftertreatment diesel exhaust fluid dosing unit heater relay short circuit

Solution: S00003188

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit heater relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid dosing unit heater relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid dosing unit heater relay circuit pin to ground short

Solution: S00002519

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid dosing unit heater relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

Solution: S00001431

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid dosing unit has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4169 | SPN: 5745 | FMI: 4
Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 1 Heater Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid dosing unit connector is malfunctioning
  3. Aftertreatment diesel exhaust fluid dosing unit heater relay resistance check
  4. Aftertreatment diesel exhaust fluid dosing unit heater resistance check
  5. Aftertreatment diesel exhaust fluid heater relay SUPPLY wire has an open circuit
  6. Aftertreatment diesel exhaust fluid line heater relay open circuit check
  7. Aftertreatment diesel exhaust fluid dosing unit heater relay open circuit check
  8. Aftertreatment diesel exhaust fluid dosing unit heater SUPPLY short-to-ground
  9. Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

1 - Check for primary fault codes

Solution: S00000212

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 2976, 4155, 4156

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid dosing unit connector is malfunctioning

Solution: S00003209

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.
  • Inspect all connections for corrosion or loose connections.

Specification

  • If the aftertreatment diesel exhaust fluid dosing unit connector or the aftertreatment diesel exhaust fluid dosing unit wiring harness connector show signs of diesel exhaust fluid, then a malfunctioning aftertreatment diesel exhaust fluid dosing unit connector has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

  • Repair or replace the OEM wiring harness.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid dosing unit heater relay resistance check

Solution: S00002523

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit heater relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid dosing unit heater relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid dosing unit heater resistance check

Solution: S00003261

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the aftertreatment diesel exhaust fluid dosing unit heater.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning aftertreatment diesel exhaust fluid dosing unit has been detected if the resistance is not within the following specification: 1 - 7 Ω

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment diesel exhaust fluid heater relay SUPPLY wire has an open circuit

Solution: S00002545

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit heater relay from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater relay pin 87 and the aftertreatment diesel exhaust fluid dosing unit heater SUPPLY pin 5 at the aftertreatment diesel exhaust fluid dosing unit connector.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment diesel exhaust fluid line heater relay open circuit check

Solution: S00000844

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment diesel exhaust fluid line heater relays 1,2, and 3 from the OEM wiring harness connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater relay CONTROL pin at the appropriate aftertreatment diesel exhaust fluid line heater relay OEM wiring harness connector and the appropriate aftertreatment diesel exhaust fluid line heater relay CONTROL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater relay feedback SIGNAL pin at the appropriate aftertreatment diesel exhaust fluid line heater relay OEM wiring harness connector and the appropriate aftertreatment diesel exhaust fluid line heater relay feedback SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid line heater relay SUPPLY pin at the aftertreatment diesel exhaust fluid line heater relay OEM wiring harness connector and the aftertreatment diesel exhaust fluid line heater relay SUPPLY pin at the OEM wiring harness battery connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Aftertreatment diesel exhaust fluid dosing unit heater relay open circuit check

Solution: S00002564

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit heater relay from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit heater RETURN pin at the OEM wiring harness connector and chassis ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Aftertreatment diesel exhaust fluid dosing unit heater SUPPLY short-to-ground

Solution: S00002547

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit heater relay from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit heater SUPPLY pin at the OEM wiring harness connector and chassis ground.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

Solution: S00001431

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid dosing unit has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4171 | SPN: 5745 | FMI: 18
Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 1 Heater - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid dosing unit heater is malfunctioning

1 - Check for primary fault codes

Solution: S00000211

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold temperature: 153, 154
  • Ambient air temperature: 249, 256, 2398
  • Aftertreatment diesel exhaust fluid system: 2976, 4155, 4156, 4168, 4169, 4244

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid dosing unit heater is malfunctioning

Solution: S00002566

Verification

Conditions

  • None

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active and no other fault codes have been logged, then a malfunctioning aftertreatment diesel exhaust fluid dosing unit heater has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid dosing unit.

The aftertreatment diesel exhaust fluid dosing unit heater is a non-serviceable component of the aftertreatment diesel exhaust fluid dosing unit.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4213 | SPN: 3695 | FMI: 2
Aftertreatment Regeneration Inhibit Switch - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Aftertreatment DPF inhibit switch is malfunctioning
  2. ECM calibration revision history check

1 - Aftertreatment DPF inhibit switch is malfunctioning

Solution: S00000931

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Verify that the permit switch (inhibit switch) has been set up properly for the OEM application.

Refer to Procedure 011-056

Specification

  • This fault code indicates that the aftertreatment regeneration permit switch was disabled and the soot load of the diesel particulate filter is above a calibrated threshold.

Linked Solutions

  • None

Repair

  • Perform the Aftertreatment Stationary Regeneration procedure.

Refer to Procedure 014-016

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4215 | SPN: 563 | FMI: 31
Anti-Lock Braking (ABS) Active - Condition Exists

Troubleshooting Summary

  1. Fault code is for information only
  2. ECM calibration revision history check

1 - Fault code is for information only

Solution: S00002745

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to clear the fault codes.

Specification

  • Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours.

Linked Solutions

  • None

Repair

  • This fault code is for information only.
  • No repair is necessary.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4233 | SPN: 3515 | FMI: 3
Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid quality sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000209

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 3868

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid quality sensor is malfunctioning

Solution: S00000933

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than once count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid quality sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid quality sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4234 | SPN: 3515 | FMI: 4
Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid quality sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00004390

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 3868

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid quality sensor is malfunctioning

Solution: S00000933

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than once count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid quality sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid quality sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4243 | SPN: 3515 | FMI: 10
Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 - Abnormal Rate of Change

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid tank temperature sensor is malfunctioning
  3. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000206

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 4233, 4234
  • Engine coolant temperature: 334
  • Intake manifold temperature: 436

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid tank temperature sensor is malfunctioning

Solution: S00003127

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the reading from the recommended Cummins® electronic service tool or equivalent for the aftertreatment diesel exhaust fluid tank temperature sensor to the infrared thermometer reading.

Specification

  • A malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor has been detected if the reading is not within the following specification: 10 C [18 F]

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid tank temperature sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4244 | SPN: 4337 | FMI: 2
Aftertreatment 1 Diesel Exhaust Fluid Dosing Temperature - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid tank temperature sensor is malfunctioning
  2. Aftertreatment diesel exhaust fluid dosing unit open circuit check
  3. Aftertreatment diesel exhaust fluid harness pin-to-ground short circuit
  4. ECM calibration revision history check

1 - Aftertreatment diesel exhaust fluid tank temperature sensor is malfunctioning

Solution: S00003127

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the reading from the recommended Cummins® electronic service tool or equivalent for the aftertreatment diesel exhaust fluid tank temperature sensor to the infrared thermometer reading.

Specification

  • A malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor has been detected if the reading is not within the following specification: 10 C [18 F]

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid tank temperature sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid dosing unit open circuit check

Solution: S00002328

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit temperature SIGNAL pin at the aftertreatment diesel exhaust fluid dosing unit wiring harness connector and the aftertreatment diesel exhaust fluid dosing unit temperature SIGNAL pin in the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit RETURN pin at the aftertreatment diesel exhaust fluid dosing unit wiring harness connector and the aftertreatment diesel exhaust fluid dosing unit RETURN pin in the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid harness pin-to-ground short circuit

Solution: S00002364

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit temperature SIGNAL pin at the OEM wiring harness ECM connector and engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4245 | SPN: 5798 | FMI: 2
Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Heater Temperature - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid dosing unit open circuit check
  2. Aftertreatment diesel exhaust fluid harness pin-to-ground short circuit
  3. Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

1 - Aftertreatment diesel exhaust fluid dosing unit open circuit check

Solution: S00002328

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit temperature SIGNAL pin at the aftertreatment diesel exhaust fluid dosing unit wiring harness connector and the aftertreatment diesel exhaust fluid dosing unit temperature SIGNAL pin in the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit RETURN pin at the aftertreatment diesel exhaust fluid dosing unit wiring harness connector and the aftertreatment diesel exhaust fluid dosing unit RETURN pin in the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid harness pin-to-ground short circuit

Solution: S00002364

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit temperature SIGNAL pin at the OEM wiring harness ECM connector and engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid dosing unit is malfunctioning

Solution: S00000677

Verification

Conditions

  • Connect the aftertreatment diesel exhaust fluid dosing unit to the OEM wiring harness.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Specification

  • If the fault code is still active after the Aftertreatment Diesel Exhaust Fluid System Leak Test is completed, then a malfunctioning aftertreatment diesel exhaust fluid dosing unit has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4249 | SPN: 4337 | FMI: 10
Aftertreatment 1 Diesel Exhaust Fluid Dosing Temperature - Abnormal Rate of Change

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid dosing unit open circuit check
  3. Aftertreatment diesel exhaust fluid harness pin-to-ground short circuit
  4. Aftertreatment diesel exhaust fluid dosing unit circuit pin to pin short

1 - Check for primary fault codes

Solution: S00000203

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold temperature: 153, 154
  • Ambient air temperature: 249, 256, 2398, 3531, 3532

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid dosing unit open circuit check

Solution: S00002328

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit temperature SIGNAL pin at the aftertreatment diesel exhaust fluid dosing unit wiring harness connector and the aftertreatment diesel exhaust fluid dosing unit temperature SIGNAL pin in the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit RETURN pin at the aftertreatment diesel exhaust fluid dosing unit wiring harness connector and the aftertreatment diesel exhaust fluid dosing unit RETURN pin in the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid harness pin-to-ground short circuit

Solution: S00002364

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit temperature SIGNAL pin at the OEM wiring harness ECM connector and engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid dosing unit circuit pin to pin short

Solution: S00002363

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit temperature SIGNAL pin at the OEM wiring harness ECM connector and all other pins in the connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4251 | SPN: 5798 | FMI: 10
Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Heater Temperature - Abnormal Rate of Change

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid dosing unit connector is malfunctioning
  3. Aftertreatment diesel exhaust fluid dosing unit open circuit check
  4. Aftertreatment diesel exhaust fluid harness pin-to-ground short circuit
  5. Aftertreatment diesel exhaust fluid dosing unit circuit pin to pin short

1 - Check for primary fault codes

Solution: S00005272

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Ambient air temperature: 249, 256, 2398, 3531, 3532, 7863

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid dosing unit connector is malfunctioning

Solution: S00003209

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.
  • Inspect all connections for corrosion or loose connections.

Specification

  • If the aftertreatment diesel exhaust fluid dosing unit connector or the aftertreatment diesel exhaust fluid dosing unit wiring harness connector show signs of diesel exhaust fluid, then a malfunctioning aftertreatment diesel exhaust fluid dosing unit connector has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

  • Repair or replace the OEM wiring harness.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid dosing unit open circuit check

Solution: S00002328

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit temperature SIGNAL pin at the aftertreatment diesel exhaust fluid dosing unit wiring harness connector and the aftertreatment diesel exhaust fluid dosing unit temperature SIGNAL pin in the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit RETURN pin at the aftertreatment diesel exhaust fluid dosing unit wiring harness connector and the aftertreatment diesel exhaust fluid dosing unit RETURN pin in the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment diesel exhaust fluid harness pin-to-ground short circuit

Solution: S00002364

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit temperature SIGNAL pin at the OEM wiring harness ECM connector and engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment diesel exhaust fluid dosing unit circuit pin to pin short

Solution: S00002363

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing unit temperature SIGNAL pin at the OEM wiring harness ECM connector and all other pins in the connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4259 | SPN: 5742 | FMI: 11
Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Root Cause Not Known

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment DPF temperature sensor module voltage check
  3. Aftertreatment DPF temperature sensor module SUPPLY circuit malfunction
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000201

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Voltage: 441, 442, 596, 597, 598
  • Aftertreatment DPF: 4151, 4162

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment DPF temperature sensor module voltage check

Solution: S00000941

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF temperature sensor module from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment DPF temperature sensor module battery voltage SUPPLY circuit and the aftertreatment DPF temperature sensor module RETURN circuit at the aftertreatment DPF temperature sensor module wiring harness connector.

Check the voltage at key ON, while cranking the engine, and with the engine at idle.

For general voltage measurement techniques.

Refer to Procedure 019-359

Specification

  • If voltage is greater than 10-VDC (For 12 volt systems) or voltage is greater than 20-VDC (For 24 volt systems) an intermittent connection has been detected at the aftertreatment DPF temperature sensor module.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

3 - Aftertreatment DPF temperature sensor module SUPPLY circuit malfunction

Solution: S00001068

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF temperature sensor module from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage from the aftertreatment DPF temperature sensor module battery voltage SUPPLY pin of the OEM wiring harness to engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

For general voltage measurement techniques.

Refer to Procedure 019-359

Specification

  • If voltage is less than 10-VDC (For 12 volt systems) or voltage is less than 20-VDC (For 24 volt systems) an open circuit has been detected in the aftertreatment DPF temperature sensor module battery voltage SUPPLY circuit.
  • If voltage is greater than 10-VDC (For 12 volt systems) or voltage is greater than 20-VDC (For 24 volt systems) an open circuit has been detected in the aftertreatment DPF temperature sensor module battery voltage RETURN circuit.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4261 | SPN: 5743 | FMI: 11
Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Root Cause Not Known

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment SCR temperature sensor module voltage check
  3. Aftertreatment SCR temperature sensor module circuit check
  4. Aftertreatment SCR temperature sensor module open circuit check
  5. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000198

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Voltage: 441, 442, 596, 597, 598, 6257
  • Aftertreatment SCR: 4152, 4165

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment SCR temperature sensor module voltage check

Solution: S00000929

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment SCR temperature sensor module battery voltage SUPPLY pin and the aftertreatment SCR temperature sensor module battery voltage RETURN pin at the aftertreatment SCR temperature sensor module OEM wiring harness connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Check the voltage at key ON, while cranking the engine, and with the engine at idle.

Specification

  • If the voltage is greater than 10 volts (12 volt system) or 20 volts (24 volt system), proceed to the next solution.
  • If the voltage is less than 10 volts (12 volt system) or 20 volts (24 volt system), then proceed to the Linked Solutions section.

Linked Solutions

  • Aftertreatment SCR temperature sensor module circuit check

Refer to S00001067

Repair

  • No additional action is required for this solution.

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

2.1 - Aftertreatment SCR temperature sensor module circuit check

Solution: S00001067

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Measure the resistance between the aftertreatment SCR temperature sensor module battery voltage SUPPLY pin at the aftertreatment SCR temperature sensor module connector of the OEM wiring harness and the aftertreatment SCR temperature sensor module battery voltage SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment SCR temperature sensor module RETURN pin at the aftertreatment SCR temperature sensor module connector of the OEM wiring harness to battery (-).
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Aftertreatment SCR temperature sensor module open circuit check

Solution: S00000944

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage from the aftertreatment SCR temperature sensor module battery voltage SUPPLY pin of the OEM wiring harness to engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

For general voltage measurement techniques.

Refer to Procedure 019-359

Specification

  • If the voltage is greater than 10 volts (12 volt system) or 20 volts (24 volt system) a malfunction of the OEM wiring harness, engine wiring harness or interconnects has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4277 | SPN: 3364 | FMI: 10
Aftertreatment 1 Diesel Exhaust Fluid Quality - Abnormal Rate of Change

Troubleshooting Summary

  1. Multiple Technical Service Bulletins are available
  2. Aftertreatment diesel exhaust fluid level is low
  3. Aftertreatment diesel exhaust fluid is contaminated
  4. ECM calibration revision history check
  5. Aftertreatment diesel exhaust fluid quality sensor is malfunctioning

1 - Multiple Technical Service Bulletins are available

Solution: S00005092

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb170054

  • If this engine is not in a Navistar application, then proceed to the next solution.
  • Technical Service Bulletin is available.

Refer to tsb160031

  • If this engine is not in a PACCAR™ application, then proceed to the next solution.
  • Technical Service Bulletin is available.

Refer to tsb200189

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid level is low

Solution: S00000798

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Fill the aftertreatment diesel exhaust fluid tank.

Refer to OEM Service Manual

Specification

  • If the fault code goes inactive, proceed to Repair section.

Linked Solutions

  • None

Repair

  • Fill the aftertreatment diesel exhaust fluid tank completely full.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid is contaminated

Solution: S00000563

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Use a diesel exhaust fluid refractometer to measure the concentration of the diesel exhaust fluid in the tank.

Refer to Service Bulletin 4021566

Specification

  • If there are signs of contaminates in the aftertreatment diesel exhaust fluid, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to Procedure 011-056

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment diesel exhaust fluid quality sensor is malfunctioning

Solution: S00000933

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than once count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid quality sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid quality sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4281 | SPN: 5848 | FMI: 2
Aftertreatment 1 SCR Intermediate NH3 - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment Diesel Exhaust Fluid Doser Pump Override test
  3. Aftertreatment diesel exhaust fluid dosing valve is malfunctioning

1 - Check for primary fault codes

Solution: S00000194

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment SCR: 3899, 3911, 3937

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment Diesel Exhaust Fluid Doser Pump Override test

Solution: S00002761

Verification

Conditions

  • Reconnect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank if they have been previously disconnected during troubleshooting.

Action

  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.

Refer to Procedure 011-059

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

The Aftertreatment Diesel Exhaust Fluid Doser Pump Override test can only be ran twice before a key cycle needs to be performed.

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test meets the specification, then proceed to the next solution.
  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test does not meet the specification, then proceed to the Linked Solutions section.

Linked Solutions

Click on the link below:

  • Aftertreatment diesel exhaust fluid dosing valve is malfunctioning

Refer to S00002764

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Aftertreatment diesel exhaust fluid dosing valve is malfunctioning

Solution: S00002764

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Clean the aftertreatment diesel exhaust fluid dosing valve.
  • Turn keyswitch ON.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4289 | SPN: 91 | FMI: 8
Accelerator Pedal or Lever Position Sensor 1 Circuit Frequency - Abnormal Frequency or Pulse Width or Period

Troubleshooting Summary

  1. Check for primary fault codes
  2. Accelerator pedal voltage check
  3. Accelerator pedal circuit check
  4. Accelerator pedal position sensor open circuit check
  5. Accelerator pedal position sensor circuit short to ground
  6. Accelerator pedal position sensor circuit pin to pin short
  7. ECM calibration revision history check
  8. Accelerator pedal is malfunctioning

1 - Check for primary fault codes

Solution: S00000193

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Sensor supply 4: 2185, 2186

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Accelerator pedal voltage check

Solution: S00000948

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the accelerator pedal position 1 sensor SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Measure the voltage between the accelerator pedal position 2 sensor SUPPLY pin to the accelerator pedal position 2 sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Accelerator pedal circuit check

Refer to S00000949

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Accelerator pedal circuit check

Solution: S00000949

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position 1 sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 1 sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 1 sensor RETURN pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 2 sensor SUPPLY pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 2 sensor SUPPLY pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position 2 sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position 2 sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Accelerator pedal position sensor open circuit check

Solution: S00000702

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the accelerator pedal position sensor RETURN pin at the accelerator pedal position sensor OEM wiring harness connector and the accelerator pedal position sensor RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Accelerator pedal position sensor circuit short to ground

Solution: S00000700

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100K Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Accelerator pedal position sensor circuit pin to pin short

Solution: S00000468

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the accelerator pedal position sensor SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Accelerator pedal is malfunctioning

Solution: S00001185

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning accelerator pedal has been detected.

Linked Solutions

  • None

Repair

  • Replace the accelerator pedal.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4293 | SPN: 5097 | FMI: 3
Engine Brake Active Lamp - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Engine brake lamp relay resistance check
  2. Engine brake lamp relay open circuit check
  3. Engine brake lamp circuit pin to pin short

1 - Engine brake lamp relay resistance check

Solution: S00005556

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the engine brake lamp relay from the OEM wiring harness connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine brake lamp relay.

Refer to OEM Service Manual

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

2 - Engine brake lamp relay open circuit check

Solution: S00000951

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the engine brake lamp relay from the OEM wiring harness connector.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake lamp relay SIGNAL pin at the engine brake lamp relay OEM wiring harness connector and the engine brake lamp relay SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the engine brake lamp relay RETURN pin at the engine brake lamp relay OEM wiring harness connector and the engine brake lamp relay RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine brake lamp circuit pin to pin short

Solution: S00000952

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the engine brake lamp relay from the OEM wiring harness connector.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake lamp relay SIGNAL pin at the OEM wiring harness ECM connector and all other pins in the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 12-Dec-2021


NO TITLE

ISX15 CM2350 X101

Fault Code: 4294 | SPN: 5097 | FMI: 4
Engine Brake Active Lamp - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Engine brake lamp relay resistance check
  2. Engine brake lamp circuit pin to ground short
  3. Engine brake lamp circuit pin to pin short

1 - Engine brake lamp relay resistance check

Solution: S00005556

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the engine brake lamp relay from the OEM wiring harness connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine brake lamp relay.

Refer to OEM Service Manual

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

2 - Engine brake lamp circuit pin to ground short

Solution: S00000953

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the engine brake lamp relay from the OEM wiring harness connector.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake lamp relay SIGNAL pin at the engine brake lamp relay and chassis ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine brake lamp circuit pin to pin short

Solution: S00000952

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the engine brake lamp relay from the OEM wiring harness connector.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake lamp relay SIGNAL pin at the OEM wiring harness ECM connector and all other pins in the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 12-Dec-2021


NO TITLE

ISX15 CM2350 X101

Fault Code: 4449 | SPN: 6773 | FMI: 16
Aftertreatment 1 Particulate Sensor Regeneration Status - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Aftertreatment particulate matter sensor is damaged

1 - Check for primary fault codes

Solution: S00000190

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment regeneration: 3375, 3376
  • Aftertreatment differential pressure: 1879, 1881, 1883, 1921, 1922, 2639
  • Aftertreatment DPF: 1981, 1993
  • Aftertreatment Particulate sensor: 4143, 4144, 4153, 4154, 5577, 5578, 5579, 5581, 5582, 5583, 5584, 5792, 5793, 5837, 6642, 6643, 6644, 6645, 6646, 6647, 6648, 6649, 6651, 6652, 6653, 6688

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment particulate matter sensor is damaged

Solution: S00007912

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4453 | SPN: 5848 | FMI: 7
Aftertreatment 1 SCR Intermediate NH3 - Mechanical System Not Responding or Out of Adjustment

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid is contaminated
  3. Campaign or Temporary Repair Practice may be available
  4. Aftertreatment Diesel Exhaust Fluid Doser Pump Override test
  5. Aftertreatment diesel exhaust fluid dosing valve is malfunctioning
  6. Aftertreatment SCR System Test
  7. Aftertreatment diesel exhaust fluid dosing system test failed
  8. Aftertreatment intake NOx sensor failed
  9. Aftertreatment outlet NOx sensor - Inspection
  10. Inspect both aftertreatment NOx sensors
  11. Aftertreatment SCR Catalyst Test Failed

1 - Check for primary fault codes

Solution: S00000954

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 1668, 1669, 1673, 1677, 1678, 1679, 1682, 1683, 1685, 1686, 1715, 3237, 3238, 3239, 3241, 3242, 3422, 3423, 3425, 3547, 3562, 3563, 3567, 3568, 3571, 3572, 3574, 3575, 3677, 3578, 3596, 3867, 3868, 3878, 4155, 4156, 4157, 4168, 4169, 4171, 4233, 4234, 4244, 4245, 4249, 4251, 4277, 4732, 4739, 4745, 4768, 4769
  • Aftertreatment diesel exhaust fluid dosing unit: 3558, 3559, 5866, 5867

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid is contaminated

Solution: S00000563

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Use a diesel exhaust fluid refractometer to measure the concentration of the diesel exhaust fluid in the tank.

Refer to Service Bulletin 4021566

Specification

  • If there are signs of contaminates in the aftertreatment diesel exhaust fluid, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to Procedure 011-056

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Campaign or Temporary Repair Practice may be available

Solution: S00003003

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Campaign or Temporary Repair Practice may be available.

Specification

  • Proceed to the Repair section if a Campaign or Temporary Repair Practice is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Campaign or Temporary Repair Practice.

Validation

  • None
Next Solution

4 - Aftertreatment Diesel Exhaust Fluid Doser Pump Override test

Solution: S00002761

Verification

Conditions

  • Reconnect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank if they have been previously disconnected during troubleshooting.

Action

  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.

Refer to Procedure 011-059

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

The Aftertreatment Diesel Exhaust Fluid Doser Pump Override test can only be ran twice before a key cycle needs to be performed.

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test meets the specification, then proceed to the next solution.
  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test does not meet the specification, then proceed to the Linked Solutions section.

Linked Solutions

Click on the link below:

  • Aftertreatment diesel exhaust fluid dosing valve is malfunctioning

Refer to S00002764

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4.1 - Aftertreatment diesel exhaust fluid dosing valve is malfunctioning

Solution: S00002764

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Clean the aftertreatment diesel exhaust fluid dosing valve.
  • Turn keyswitch ON.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Aftertreatment SCR System Test

Solution: S00000541

Verification

Conditions

  • Connect all components.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment SCR System Test.

Refer to Procedure 014-025

If the Aftertreatment SCR System Test is not available on the recommended Cummins® electronic service tool or equivalent, update to the latest ECM Calibration Revision and then perform the Aftertreatment SCR System Test.

Specification

  • If the Aftertreatment SCR System Test does not pass, then proceed to the Linked Solutions section.

If the Aftertreatment SCR System Test does not activate, then reset the Search to Aftertreatment SCR System Test does not activate.

If the Aftertreatment SCR System Test does not complete, then reset the Search to Aftertreatment SCR System Test does not complete.

If the Aftertreatment SCR System Test displays "Deposit Burn Failed", the test should keep running and no repair action is required unless a Aftertreatment Intake or Outlet NOx sensor failure is detected.

Linked Solutions

  • Aftertreatment diesel exhaust fluid dosing system test failed

Refer to S00000552

  • Aftertreatment intake NOx sensor failed

Refer to S00000867

  • Aftertreatment outlet NOx sensor - Inspection

Refer to S00000567

  • Inspect both aftertreatment NOx sensors

Refer to S00000566

  • Aftertreatment SCR catalyst test failed

Refer to S00000565

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

5.1 - Aftertreatment diesel exhaust fluid dosing system test failed

Solution: S00000552

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If there are signs of contaminates in the diesel exhaust fluid, then proceed to the Repair section.
  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump override test displays FAILED, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to OEM Service Manual

  • For a Aftertreatment Diesel Exhaust Fluid Doser Pump override test displaying FAILED, then follow the repair instructions in the procedure.

Refer to Procedure 011-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.2 - Aftertreatment intake NOx sensor failed

Solution: S00000867

Verification

Conditions

  • None

Action

  • Verify that the aftertreatment intake NOx sensor is displayed as FAILED.

Specification

  • If the SCR System test displays that the intake NOx sensor has FAILED, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.3 - Aftertreatment outlet NOx sensor - Inspection

Solution: S00000567

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the decomposition tube for deposits.

Refer to Procedure 011-062

  • Visually inspect the aftertreatment diesel exhaust fluid tank connections for cracks or pitting.

Refer to OEM Service Manual

  • Connect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank.
  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-080

  • While the test is running, inspect the diesel exhaust fluid tank connectors, diesel exhaust fluid dosing unit and dosing unit connectors, diesel exhaust fluid lines, and diesel exhaust fluid dosing valve for signs of external leaks.

Specification

  • If the aftertreatment diesel exhaust fluid dosing valve is not leaking and there are no deposits in the decomposition tube, then a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Clean and install the decomposition tube.

Refer to Procedure 011-062

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.4 - Inspect both aftertreatment NOx sensors

Solution: S00000566

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the decomposition tube for deposits.

Refer to Procedure 011-062

  • Visually inspect the aftertreatment diesel exhaust fluid tank connections for cracks or pitting.

Refer to OEM Service Manual

  • Connect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank.
  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-080

  • Verify proper sealing at all connection points, including diesel exhaust fluid tank, dosing unit, and dosing valve.

Specification

  • If the aftertreatment diesel exhaust fluid dosing valve is not leaking and there are no deposits in the decomposition tube, then a malfunctioning aftertreatment intake NOx sensor and a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Clean and install the decomposition tube.

Refer to Procedure 011-062

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.5 - Aftertreatment SCR Catalyst Test Failed

Solution: S00000565

Verification

Conditions

  • Reconnect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank if they have been previously disconnected during troubleshooting.

Action

The aftertreatment diesel exhaust fluid dosing valve must be removed and placed in a measuring container greater then 1.5 liter [50 oz] capacity to perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override test.

The Aftertreatment Diesel Exhaust Fluid Doser Pump Override test can only be ran twice before a key cycle needs to be performed.

  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is not within specification, then proceed to the Repair section.
  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is within specification, then a malfunctioning aftertreatment SCR Catalyst has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Replace the aftertreatment SCR Catalyst.

Refer to Procedure 011-036

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4484 | SPN: 3667 | FMI: 7
Engine Air Shutoff - Mechanical System Not Responding or Out of Adjustment

Troubleshooting Summary

  1. Check for primary fault codes
  2. Engine air shutoff position switch voltage check
  3. Engine air shutoff position switch open circuit check
  4. Engine air shutoff position switch circuit pin to pin short
  5. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000187

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Engine air shutoff: 3139, 3141

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Engine air shutoff position switch voltage check

Solution: S00000957

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine air shutoff position switch from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the engine air shutoff position switch SIGNAL pin and the engine air shutoff position switch RETURN pin at the engine air shutoff position switch connector of the OEM wiring harness.

Specification

  • A malfunctioning engine air shutoff valve has been detected if the voltage is greater than the following specification: 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Engine air shutoff position switch open circuit check

Refer to S00000959

Repair

  • Replace the engine air shut off valve.

Refer to Procedure 010-143

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Engine air shutoff position switch open circuit check

Solution: S00000959

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine air shutoff position switch from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine air shutoff position switch RETURN pin in the OEM wiring harness and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Engine air shutoff position switch circuit pin to pin short

Solution: S00000962

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine air shutoff position switch from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine air shutoff position switch SIGNAL pin in the OEM wiring harness ECM connector and all other pins at the ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4517 | SPN: 237 | FMI: 13
Vehicle Identification Number - Out of Calibration

Troubleshooting Summary

  1. Vehicle identification number out of calibration
  2. ECM calibration revision history check

1 - Vehicle identification number out of calibration

Solution: S00000964

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify the vehicle identification number under the vehicle/OEM information in the system ID and Dataplate section of Features and Parameters matches the vehicle.

Specification

  • If the vehicle identification number is not present it will need to be added.

Linked Solutions

  • None

Repair

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Enter the appropriate information under the vehicle/OEM information in the System ID and Dataplate section of Features and Parameters.

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4518 | SPN: 5862 | FMI: 3
Aftertreatment 1 SCR Intermediate Gas Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Technical Service Bulletin is available
  3. ECM calibration revision history check
  4. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000125

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment SCR: 4152, 4164, 4165, 4166, 4261

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Technical Service Bulletin is available

Solution: S00009791

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb150153

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00004310

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4519 | SPN: 5862 | FMI: 4
Aftertreatment 1 SCR Intermediate Gas Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000124

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment SCR: 4152, 4164, 4165, 4166, 4261

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00004310

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4521 | SPN: 5862 | FMI: 2
Aftertreatment 1 SCR Intermediate Gas Temperature Sensor - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000121

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment SCR: 4152, 4164, 4165, 4166, 4261

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00009782

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4524 | SPN: 5862 | FMI: 0
Aftertreatment 1 SCR Intermediate Gas Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid is contaminated
  3. Turbocharger exhaust is leaking oil into the aftertreatment system
  4. Aftertreatment DOC is malfunctioning
  5. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000120

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment SCR: 4152, 4159, 4164, 4165, 4261

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid is contaminated

Solution: S00000563

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Use a diesel exhaust fluid refractometer to measure the concentration of the diesel exhaust fluid in the tank.

Refer to Service Bulletin 4021566

Specification

  • If there are signs of contaminates in the aftertreatment diesel exhaust fluid, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to Procedure 011-056

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Turbocharger exhaust is leaking oil into the aftertreatment system

Solution: S00000655

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the exhaust piping from the turbocharger outlet.

Action

  • Inspect for any fluids.
  • Visually inspect the turbocharger exhaust outlet for signs of oil or fuel.
  • Perform the Snap Acceleration Test - Aftertreatment Disconnected.

Refer to Procedure 014-017

Specification

  • If lubricating engine oil contamination is found in the turbocharger exhaust outlet, then reset the search to oil consumption internal.
  • If excessive black smoke is detected, then reset the search to black smoke.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4 - Aftertreatment DOC is malfunctioning

Solution: S00005082

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect for the presence of the aftertreatment DOC.

Refer to Procedure 011-049

  • Inspect the inlet face of the aftertreatment DOC for reuse.

Refer to Procedure 011-049

Refer to Service Bulletin 4021600

  • Inspect for cracks in the aftertreatment DOC cell walls.

Refer to Service Bulletin 4021600

  • Inspect for soot or oil plugging the front face of the catalyst

Refer to Service Bulletin 4021600

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • If the face of the aftertreatment DOC is plugged, then clean the aftertreatment DOC.

Refer to Procedure 011-049

  • If the face of the aftertreatment DOC is cracked or damaged, then replace the aftertreatment DOC.

Refer to Procedure 011-049

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4525 | SPN: 5862 | FMI: 16
Aftertreatment 1 SCR Intermediate Gas Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid is contaminated
  3. Turbocharger exhaust is leaking oil into the aftertreatment system
  4. Aftertreatment DOC is malfunctioning
  5. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000119

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment SCR: 4152, 4159, 4164, 4165, 4261

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid is contaminated

Solution: S00000563

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Use a diesel exhaust fluid refractometer to measure the concentration of the diesel exhaust fluid in the tank.

Refer to Service Bulletin 4021566

Specification

  • If there are signs of contaminates in the aftertreatment diesel exhaust fluid, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to Procedure 011-056

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Turbocharger exhaust is leaking oil into the aftertreatment system

Solution: S00000655

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the exhaust piping from the turbocharger outlet.

Action

  • Inspect for any fluids.
  • Visually inspect the turbocharger exhaust outlet for signs of oil or fuel.
  • Perform the Snap Acceleration Test - Aftertreatment Disconnected.

Refer to Procedure 014-017

Specification

  • If lubricating engine oil contamination is found in the turbocharger exhaust outlet, then reset the search to oil consumption internal.
  • If excessive black smoke is detected, then reset the search to black smoke.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4 - Aftertreatment DOC is malfunctioning

Solution: S00005082

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect for the presence of the aftertreatment DOC.

Refer to Procedure 011-049

  • Inspect the inlet face of the aftertreatment DOC for reuse.

Refer to Procedure 011-049

Refer to Service Bulletin 4021600

  • Inspect for cracks in the aftertreatment DOC cell walls.

Refer to Service Bulletin 4021600

  • Inspect for soot or oil plugging the front face of the catalyst

Refer to Service Bulletin 4021600

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • If the face of the aftertreatment DOC is plugged, then clean the aftertreatment DOC.

Refer to Procedure 011-049

  • If the face of the aftertreatment DOC is cracked or damaged, then replace the aftertreatment DOC.

Refer to Procedure 011-049

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4526 | SPN: 521 | FMI: 2
Brake Pedal Position - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Brake pedal position switch open circuit check
  2. Brake pedal position switch pin to pin short
  3. ECM calibration revision history check
  4. Brake pedal is malfunctioning

1 - Brake pedal position switch open circuit check

Solution: S00001070

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the brake pedal from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the brake pedal position 1 switch SIGNAL pin at the brake pedal OEM wiring harness connector to the brake pedal position 1 switch SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the brake pedal position 2 switch SIGNAL pin at the brake pedal OEM wiring harness connector to the brake pedal position 2 switch SIGNAL pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

2 - Brake pedal position switch pin to pin short

Solution: S00001071

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the brake pedal from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the brake pedal position 1 switch SIGNAL pin in the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Measure the resistance between the brake pedal position 2 switch SIGNAL pin in the OEM wiring harness ECM connector and all other pins at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Brake pedal is malfunctioning

Solution: S00000966

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunction with the brake pedal has been detected.

Linked Solutions

  • None

Repair

  • Replace brake pedal position switch.

Refer to OEM Service Manual

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4568 | SPN: 3482 | FMI: 16
Aftertreatment Fuel Shutoff Valve - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Low pressure fuel system component is malfunctioning
  3. Air in fuel check
  4. Fuel Inlet Restriction check
  5. Fuel lift pump check
  6. OEM fuel system component check

1 - Check for primary fault codes

Solution: S00000115

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment fuel: 1923, 1924, 1926, 1927, 1928
  • Fuel: 559, 2372

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Low pressure fuel system component is malfunctioning

Solution: S00000640

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Verify the fuel system is primed.

Refer to Procedure 005-234

  • Measure the fuel pump gear pump outlet pressure at idle and at high idle.

Refer to Procedure 005-236

  • If engine will not start, then perform the check during cranking.

Specification

  • If the fuel pump gear pump outlet pressure is not within specification, then proceed to Linked Solutions section.

Linked Solutions

  • Air in fuel check

Refer to S00001205

  • Fuel Inlet Restriction check

Refer to S00001206

  • Fuel lift pump check

Refer to S00001207

  • OEM fuel system component check

Refer to S00000756

  • If the above checks are all within specification, then a malfunctioning fuel gear pump has been detected

Repair

  • Replace the fuel pump gear pump.

Refer to Procedure 005-025

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Air in fuel check

Solution: S00001205

Verification

Conditions

  • Turn keyswitch ON.
  • Verify adequate fuel level in the tank

Action

  • Allow the engine to reach operating temperature.
  • If engine will not start, then perform the check during cranking.
  • Inspect for air being ingested into the fuel.

Refer to Procedure 006-003

Specification

  • If air is present in the fuel flow, then a damaged fuel supply line, loose or damaged fuel filter, or a loose connection has been detected.

Linked Solutions

  • None

Repair

  • Tighten the loose fitting or replace the damaged component that allows air to enter the fuel system.

Refer to Procedure 006-003

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Fuel Inlet Restriction check

Solution: S00001206

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Measure the fuel inlet restriction.

Refer to Procedure 006-020

Specification

  • If the engine will not start, then proceed to the next solution.

If the inlet restriction is excessive, look for the root cause:

Inspect the following components if applicable:

  • Suction side fuel filters plugged.
  • Fuel heater restricted.

Refer to OEM Service Manual

  • OEM fuel lines restricted.

Refer to OEM Service Manual

  • ECM cooling plate plugged.

Refer to Procedure 006-006

  • ECM cooling plate check valve restricted.

Refer to Procedure 006-006

  • Fuel tank stand pipes restricted.

Refer to OEM Service Manual

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace fuel filter.

Refer to OEM Service Manual

  • Repair or replace the fuel heater.

Refer to OEM Service Manual

  • Repair or replace the OEM fuel lines.

Refer to OEM Service Manual

  • Repair or replace the ECM cooling plate.

Refer to Procedure 006-006

  • Repair or replace the ECM cooling plate check valve.

Refer to Procedure 006-006

  • Repair or replace the fuel tank stand pipe.

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.3 - Fuel lift pump check

Solution: S00001207

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Listen for fuel lift pump operation.
  • If the fuel lift pump does not operate after turning the keyswitch ON, then measure the resistance in the fuel lift pump circuit.

Refer to Procedure 019-397

  • Measure the lift pump pressure.

Refer to Procedure 005-236

Specification

  • If the resistance is not within specification, then proceed to the Repair section.
  • If the fuel lift pump pressure is not within specification, then a malfunctioning fuel lift pump has been detected.

Refer to Procedure 005-236

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the electric fuel lift pump.

Refer to Procedure 005-045

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.4 - OEM fuel system component check

Solution: S00000756

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually check fuel tank for adequate fuel supply.

Refer to Procedure 006-024

  • Visually inspect the engine fuel supply lines for signs of kinks, damage or fuel leaks.

Refer to Procedure 006-024

  • Visually inspect all fuel system gasket locations for signs of leakage.

Refer to Procedure 006-024

Specification

  • If there is any damage or leaks found in the OEM fuel system, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace the malfunctioning OEM component.

Refer to OEM Service Manual

Validation

  • None
Parent Solution

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4572 | SPN: 3031 | FMI: 9
Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Abnormal Update Rate

Troubleshooting Summary

  1. Check for primary fault codes
  2. Technical Service Bulletin is available
  3. Low battery voltage
  4. Battery load test
  5. Ground inspection
  6. Fault Code 4572 triggered by a malfunction in the J1939 data link with multiple OEM fault code
  7. Aftertreatment diesel exhaust fluid tank level/temperature/quality sensor voltage check
  8. Aftertreatment diesel exhaust fluid tank temperature sensor voltage check
  9. Aftertreatment diesel exhaust fluid tank temperature sensor open circuit check
  10. Fuse check
  11. J1939 data link terminating resistance is incorrect
  12. Variable geometry turbocharger actuator has incorrect J1939 terminating resistance
  13. Engine wiring harness has incorrect J1939 terminating resistance
  14. OEM wiring harness has incorrect J1939 terminating resistance
  15. OEM terminating resistor Ω check for the J1939 data link
  16. Incorrect terminating resistance in the J1939 data link by a J1939 data linked component
  17. J1939 wire resistance check at the crossover connector for each component
  18. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000251

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Turbocharger: 1894, 2636
  • Aftertreatment diesel exhaust fluid system: 1713

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Technical Service Bulletin is available

Solution: S00009162

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb170054

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Low battery voltage

Solution: S00001110

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.
  • If this vehicle has been repaired within the last 30 days for the same fault code, then proceed to the Linked Solutions section.

Specification

  • If the battery voltage is at least 10.8 VDC (12 volt systems) or 21.6 VDC (24 volt systems), then proceed to the Linked Solutions section.
  • If the battery or battery cables show signs of corrosion or damage, then proceed to the Repair Section.

Linked Solutions

  • Battery load test

Refer to S00001379

  • Ground inspection

Refer to S00000754

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean corrosion or tighten battery cable connections.

Refer to OEM Service Manual

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3.1 - Battery load test

Solution: S00001379

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Disconnect the batteries from each other.
  • Connect a load tester separately to each battery.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.

Specification

  • For a 12 volt system, proceed to the Repair section if the battery voltage is below the following specification: 11 VDC
  • For a 24 volt system, proceed to the Repair section if the battery voltage is below the following specification: 22 VDC

Linked Solutions

  • None

Repair

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.2 - Ground inspection

Solution: S00000754

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the ECM ground for damage, corrosion and loose connections.
  • Visually inspect the aftertreatment interface wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the OEM wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the grounds for proper routing.

Specification

  • If damage, corrosion or incorrect routing of grounds are found, then proceed to the Repair section

Linked Solutions

  • None

Repair

  • Clean or replace connections.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Fault Code 4572 triggered by a malfunction in the J1939 data link with multiple OEM fault code

Solution: S00005739

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

If there is a previously saved job image, then that fault code list should be used in place of retrieving the fault codes again with the recommended Cummins® electronic service tool or equivalent. This will eliminate the need to reconnect and then disconnect component(s). Retrieving fault codes without reconnecting these components will result in multiple fault codes to be logged.

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution, if any fault code is active or has more than one inactive count within the last 25 engine operating hours from the following list: 1894, 2636, 2771, 3232, 3911, 4151, 4152, 6688
  • Proceed to the next solution if any fault code from the following list is not active: 3868, 4572, 4677
  • Proceed to the Linked Solutions section if all fault codes from the following list are active: 3868, 4572, 4677

Linked Solutions

  • Aftertreatment diesel exhaust fluid tank level/temperature/quality sensor voltage check

Refer to S00005705

Repair

Refer to OEM Service Manual

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Aftertreatment diesel exhaust fluid tank level/temperature/quality sensor voltage check

Solution: S00005705

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage from the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor SUPPLY pin and the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor RETURN pin at the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness, OEM wiring harness or interconnect has been detected if the voltage is not within the following specification of battery voltage: 1 VDC
  • A malfunctioning aftertreatment diesel exhaust fluid tank level/temperature/quality sensor has been detected if the voltage is within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, aftertreatment interface harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.

Refer to Procedure 019-475

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Aftertreatment diesel exhaust fluid tank temperature sensor voltage check

Solution: S00000969

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment diesel exhaust fluid tank temperature sensor battery voltage SUPPLY circuit and the aftertreatment diesel exhaust fluid tank temperature sensor battery voltage RETURN circuit at the aftertreatment diesel exhaust fluid tank temperature sensor wiring harness connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Check the voltage at key ON, while cranking the engine, and with the engine at idle.

Specification

  • If the voltage is less than 10 volts (12 volt system) or 20 volts (24 volt system), then proceed to the Linked Solutions section.

Linked Solutions

  • Aftertreatment diesel exhaust fluid tank temperature sensor open circuit check

Refer to S00001233

  • Fuse check

Refer to S00001852

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

5.1 - Aftertreatment diesel exhaust fluid tank temperature sensor open circuit check

Solution: S00001233

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank temperature sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage from the aftertreatment diesel exhaust fluid tank temperature sensor battery voltage SUPPLY pin of the OEM wiring harness to engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the voltage is greater than 10 volts (12 volt system) or 20 volts (24 volt system), an open circuit or high resistance has been detected in the aftertreatment diesel exhaust fluid tank temperature sensor battery voltage RETURN circuit.
  • If the voltage is less than 10 volts (12 volt system) or 20 volts (24 volt system), an open circuit or high resistance has been detected in the aftertreatment diesel exhaust fluid tank temperature sensor battery voltage SUPPLY circuit.

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.2 - Fuse check

Solution: S00001852

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the fuse.

Refer to Procedure 019-198

Specification

  • If the fuse is found to be blown or damaged, then proceed to Repair section.

Linked Solutions

  • None

Repair

  • Replace the fuse.

Refer to Procedure 019-198

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - J1939 data link terminating resistance is incorrect

Solution: S00000593

Verification

Conditions

  • Turn keyswitch OFF.
  • Wait for 90 seconds.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.
  • Reconnect the variable geometry turbocharger actuator if it has been previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3-pin service data link connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Follow your technical escalation process if the resistance is within the following specification: 54 - 66 Ω
  • Proceed to the Linked Solutions section if the resistance is not within the following specification: 54 - 66 Ω

Linked Solutions

  • Variable geometry turbocharger actuator has incorrect J1939 terminating resistance

Refer to S00001242

  • Engine wiring harness has incorrect J1939 terminating resistance

Refer to S00000972

  • OEM wiring harness has incorrect J1939 terminating resistance

Refer to S00000971

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

6.1 - Variable geometry turbocharger actuator has incorrect J1939 terminating resistance

Solution: S00001242

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the variable geometry turbocharger actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the variable geometry turbocharger actuator SAE J1939 data link (+) pin and the variable geometry turbocharger actuator SAE J1939 data link (-) pin at the variable geometry turbocharger actuator.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning variable geometry turbocharger actuator has been detected if the resistance is not within the following specification: 108 Ω - 132 Ω

Linked Solutions

  • None

Repair

  • Replace the variable geometry turbocharger actuator.

Refer to Procedure 010-134

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6.2 - Engine wiring harness has incorrect J1939 terminating resistance

Solution: S00000972

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect previously disconnected components.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.
  • Disconnect the aftertreatment intake NOx sensor from the engine wiring harness.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3-pin service data link connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is not within the following specification: 108-132 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6.3 - OEM wiring harness has incorrect J1939 terminating resistance

Solution: S00000971

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if the resistance is not within the following specification: 108 - 132 Ω
  • Follow your technical escalation process if the resistance is within the following specification: 108 - 132 Ω

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Parent Solution

7 - OEM terminating resistor Ω check for the J1939 data link

Solution: S00000907

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM terminating resistor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the pins for the OEM terminating resistor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM terminating resistor has been detected if the resistance is not within the following specification: 108 - 132 Ω

Linked Solutions

  • None

Repair

  • For a malfunctioning OEM terminating resistor, replace the OEM terminating resistor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - Incorrect terminating resistance in the J1939 data link by a J1939 data linked component

Solution: S00001002

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Reconnect the OEM terminating resistor if previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the resistance is not within the following specification: 108 - 132 Ω

Linked Solutions

  • J1939 wire resistance check at the crossover connector for each component

Refer to S00001003

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

8.1 - J1939 wire resistance check at the crossover connector for each component

Solution: S00001003

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Reconnect the OEM terminating resistor if previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

Inspect the following components if applicable:

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector for each component while disconnecting them one at a time.
  • Disconnect the aftertreatment outlet NOx sensor
  • Disconnect the aftertreatment temperature sensor module
  • Disconnect the aftertreatment particulate sensor
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor
  • Disconnect the aftertreatment diesel exhaust fluid temperature sensor
  • Disconnect the aftertreatment diesel exhaust fluid quality sensor.
  • Disconnect the aftertreatment intermediate NH3 sensor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance was not within 108 Ω to 132 Ω and it becomes within the specification of 108 Ω to 132 Ω when the J1939 component was disconnected, then a malfunctioning J1939 component has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid tank level sensor.

Refer to OEM Service Manual

  • Replace the aftertreatment diesel exhaust fluid temperature sensor.

Refer to OEM Service Manual

  • Replace the aftertreatment diesel exhaust fluid quality sensor.

Refer to OEM Service Manual

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace aftertreatment DOC temperature sensor module.

Refer to Procedure 019-449

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

  • Replace aftertreatment intermediate NH3 sensor.

Refer to Procedure 019-479

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

9 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4584 | SPN: 3936 | FMI: 14
Aftertreatment Diesel Particulate Filter System - Special Instructions

Troubleshooting Summary

  1. Restricted intake air filter
  2. Aftertreatment DPF system incorrect for this engine application
  3. Aftertreatment DPF differential pressure sensor tubes plugged
  4. Aftertreatment DPF differential pressure sensor stuck in-range
  5. Aftertreatment temperature sensor stuck in-range
  6. ECM calibration revision history check
  7. Stationary aftertreatment regeneration is needed

1 - Restricted intake air filter

Solution: S00000025

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Specification

  • If the intake air filter is plugged, then a restricted intake air filter has been detected.

Linked Solutions

  • None

Repair

  • Replace the air filter.

Refer to OEM Service Manual

Refer to Procedure 010-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment DPF system incorrect for this engine application

Solution: S00001141

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.

Specification

  • This fault code indicates that the incorrect aftertreatment diesel particulate filter system has been installed with the engine. Verify the correct aftertreatment diesel particulate filter system has been installed with the engine.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF.

Refer to Procedure 011-041

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment DPF differential pressure sensor tubes plugged

Solution: S00001183

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment DPF differential pressure sensor tubes for signs of damage, plugging, kinks, leakage or loose connections.

Refer to Procedure 011-047

Specification

  • If plugging or damage is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace DPF differential pressure sensor tubes.

Refer to Procedure 011-047

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment DPF differential pressure sensor stuck in-range

Solution: S00000793

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the aftertreatment DPF differential pressure sensor voltage.

Refer to Procedure 019-443

Specification

  • If the aftertreatment DPF differential pressure sensor voltage readings are not within specification, then a malfunctioning aftertreatment DPF differential pressure sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment temperature sensor stuck in-range

Solution: S00000338

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Start the engine.

Action

  • Run the engine at high idle for the following minutes: 10
  • Use the recommended Cummins® electronic service tool or equivalent.

Monitor the following parameters:

  • Aftertreatment diesel oxidation catalyst intake temperature
  • Aftertreatment diesel particulate filter intake temperature
  • Aftertreatment diesel particulate filter outlet temperature

Specification

  • A malfunctioning aftertreatment exhaust gas temperature sensor has been detected if each sensor is not within the following specification of the others: 24 C [43 F]

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Stationary aftertreatment regeneration is needed

Solution: S00001113

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the Aftertreatment Diesel Particulate Filter regeneration test.

Refer to Procedure 014-016

Specification

  • If the aftertreatment stationary regeneration does not complete, then reset the Search to stationary regeneration will not complete.
  • If the aftertreatment stationary regeneration does not activate, then reset the Search to stationary regeneration will not start.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4585 | SPN: 4792 | FMI: 14
Aftertreatment 1 SCR Catalyst System - Special Instructions

Troubleshooting Summary

  1. Technical Service Bulletin is available
  2. Aftertreatment SCR system is incorrect for this engine application

1 - Technical Service Bulletin is available

Solution: S00007333

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb130113

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment SCR system is incorrect for this engine application

Solution: S00001149

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Fault code 4585 active indicates the incorrect aftertreatment SCR system installed with this engine.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment SCR Catalyst.

Refer to Procedure 011-036

Validation

  • None

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 08-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4612 | SPN: 5321 | FMI: 31
Engine Intake Manifold Pressure System Monitor - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. Restricted intake air filter
  3. Leaks in the intake air system
  4. Charge air cooler system leak
  5. High exhaust restriction
  6. Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test
  7. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000107

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold: 122, 123, 124, 125, 2973, 3361
  • Intake manifold temperature: 153, 154, 436
  • Barometric pressure: 221, 222, 295
  • Ambient air temperature: 249, 256, 2398
  • Exhaust gas pressure: 2373, 2374, 2554
  • EGR: 1228, 1867, 1896, 1961, 2272, 2349, 2353, 3382, 3383
  • EGR differential pressure: 1866, 2273, 2274
  • Voltage: 3724
  • Turbocharger: 1898, 2198, 2387, 2449, 2634, 2635, 2636
  • Intake throttle: 175, 176, 177, 3539, 3541, 3542

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Restricted intake air filter

Solution: S00000025

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Specification

  • If the intake air filter is plugged, then a restricted intake air filter has been detected.

Linked Solutions

  • None

Repair

  • Replace the air filter.

Refer to OEM Service Manual

Refer to Procedure 010-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Leaks in the intake air system

Solution: S00008386

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.
  • Visually inspect the intake plumbing for possible air leaks.

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Charge air cooler system leak

Solution: S00008815

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the charge air cooler hoses for possible air leaks.
  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If a leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the charge air cooler.

Refer to Procedure 010-027

  • Repair or replace the charge air cooler hoses.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - High exhaust restriction

Solution: S00000324

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the exhaust restriction.

Refer to Procedure 011-009

Specification

  • If the exhaust restriction is not within specification, then a restriction in the exhaust has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Check the face of the aftertreatment diesel oxidation catalyst for plugging.

Refer to Procedure 011-049

  • Check the face of the aftertreatment diesel particulate filter for plugging.

Refer to Procedure 011-041

  • Check for deposits in the decomposition tube.

Refer to Procedure 011-062

  • Check the face of the aftertreatment SCR catalyst for plugging.

Refer to Procedure 011-036

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test

Solution: S00003823

Verification

Conditions

  • Reconnect previously disconnected components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test.

Refer to Procedure 014-027

  • Verify the recommended Cummins® electronic service tool or equivalent has a version that supports this test.

Refer to Procedure 014-027

Specification

  • If the Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test does not pass, then reset the search to Aftertreatment Diesel Particulate Filter Regeneration Analyzer Did Not Pass. Only select the solution title that matches the error messages in the recommend Cummins® electronic service tool or equivalent.
  • If the Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test will not start, then reset the search to Aftertreatment Diesel Particulate Filter Regeneration Analyzer Did Not Start.
  • If the Aftertreatment Diesel Particulate Filter Regeneration Analyzer Test does not complete, then reset the search to Aftertreatment Diesel Particulate Filter Regeneration Analyzer Did Not Complete.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4616 | SPN: 102 | FMI: 17
Intake Manifold 1 Pressure - Data Valid But Below Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Restricted intake air filter
  3. Intake manifold pressure sensor has carbon buildup
  4. Intake manifold pressure sensor stuck in-range
  5. Leaks in the intake air system
  6. Charge air cooler system leak
  7. Turbocharger is malfunctioning
  8. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002333

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold: 122, 123
  • Barometric pressure: 221, 222, 295
  • Turbocharger: 595, 629, 686, 687, 691, 692, 693, 2288, 2346, 2347, 2375, 2376, 2451, 3348
  • EGR: 1228, 1867, 1896, 1961, 2272, 2349, 2353, 2357, 2961, 2962, 3136, 3137, 3138, 3382, 3383, 3389
  • EGR differential pressure: 1866, 2273, 2274
  • Exhaust gas pressure: 2373, 2374, 2554, 2764

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Restricted intake air filter

Solution: S00000025

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Specification

  • If the intake air filter is plugged, then a restricted intake air filter has been detected.

Linked Solutions

  • None

Repair

  • Replace the air filter.

Refer to OEM Service Manual

Refer to Procedure 010-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Intake manifold pressure sensor has carbon buildup

Solution: S00006329

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

  • Visually inspect the intake manifold pressure/temperature sensor tip for soot or carbon buildup.
  • Visually inspect the intake manifold pressure sensor for damage.
  • Visually inspect the intake manifold pressure sensor o-rings for damage.

Specification

  • If any carbon buildup is found, then proceed to the Repair section.
  • If nicks or cuts in or on the o-ring are identified, then a damaged intake manifold pressure/temperature sensor o-ring has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

  • Replace the intake manifold pressure/temperature sensor o-ring.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Intake manifold pressure sensor stuck in-range

Solution: S00002814

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the intake manifold pressure sensor.

Specification

  • A malfunctioning intake manifold air pressure sensor has been detected if the intake manifold air pressure is not reading within the following specification: 0 ± 6.8 Kpa [0 ± 1 psi], 0 ± 51 mm-Hg [0 ± 2 in- Hg]

Linked Solutions

  • None

Repair

  • Replace the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Leaks in the intake air system

Solution: S00008386

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.
  • Visually inspect the intake plumbing for possible air leaks.

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Charge air cooler system leak

Solution: S00008815

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the charge air cooler hoses for possible air leaks.
  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If a leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the charge air cooler.

Refer to Procedure 010-027

  • Repair or replace the charge air cooler hoses.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Turbocharger is malfunctioning

Solution: S00005253

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the intake and exhaust connections from the turbocharger.

Action

  • Inspect the turbocharger compressor and turbine blades for damage or wear.

Refer to Procedure 010-033

Specification

  • If any of the checks are not within specification, then a malfunctioning turbocharger has been detected.

Linked Solutions

  • None

Repair

  • Replace the turbocharger.

Refer to Procedure 010-033

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4658 | SPN: 4331 | FMI: 18
Aftertreatment 1 Diesel Exhaust Fluid Actual Dosing Quantity - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid dosing unit line or fittings are cracked, plugged or restricted
  2. Aftertreatment diesel exhaust fluid is contaminated
  3. Aftertreatment diesel exhaust fluid dosing unit intake restriction
  4. Aftertreatment Diesel Exhaust Fluid Doser Pump Override test
  5. Aftertreatment diesel exhaust fluid dosing valve is malfunctioning
  6. ECM calibration revision history check

1 - Aftertreatment diesel exhaust fluid dosing unit line or fittings are cracked, plugged or restricted

Solution: S00000664

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the lines are not swapped at the dosing unit, dosing valve or diesel exhaust fluid tank connections.

Refer to Procedure 011-058

  • Visually inspect the aftertreatment diesel exhaust fluid tank connections for cracks or pitting.
  • Visually inspect the aftertreatment diesel exhaust fluid tank vent line for restrictions.
  • Visually inspect the aftertreatment diesel exhaust fluid line for damage.
  • Visually inspect both dosing unit connections and fittings for loose, leaking, or damaged connections.
  • Disconnect the suction line and pressure line dosing unit connectors and look for signs of build-up or blockage.

Refer to Procedure 011-058

  • Visually inspect the suction line for signs of leakage or openings which will allow the dosing unit to suck in air with the diesel exhaust fluid.
  • Visually inspect the pressure line for signs of leakage or rupture.
  • Verify proper sealing at all connection points, including diesel exhaust fluid tank, dosing unit, and dosing valve.

Refer to Procedure 011-058

Specification

  • If there are aftertreament diesel exhaust fluid lines reversed, damaged, leaking or restricted connections found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace damaged components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid is contaminated

Solution: S00000563

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Use a diesel exhaust fluid refractometer to measure the concentration of the diesel exhaust fluid in the tank.

Refer to Service Bulletin 4021566

Specification

  • If there are signs of contaminates in the aftertreatment diesel exhaust fluid, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to Procedure 011-056

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid dosing unit intake restriction

Solution: S00000732

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the aftertreatment diesel exhaust fluid dosing unit intake restriction.

Refer to Procedure 011-086

Specification

  • If the vacuum in diagnostic line is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the diesel exhaust fluid tank filter.

Refer to OEM Service Manual

  • Clean or replace the aftertreatment diesel exhaust fluid intake line.

Refer to OEM Service Manual

  • Clean or replace the aftertreatment diesel exhaust fluid tank header.

Refer to OEM Service Manual

  • Clean or replace the aftertreatment diesel exhaust fluid tank vent.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment Diesel Exhaust Fluid Doser Pump Override test

Solution: S00002761

Verification

Conditions

  • Reconnect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank if they have been previously disconnected during troubleshooting.

Action

  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.

Refer to Procedure 011-059

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

The Aftertreatment Diesel Exhaust Fluid Doser Pump Override test can only be ran twice before a key cycle needs to be performed.

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test meets the specification, then proceed to the next solution.
  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test does not meet the specification, then proceed to the Linked Solutions section.

Linked Solutions

Click on the link below:

  • Aftertreatment diesel exhaust fluid dosing valve is malfunctioning

Refer to S00002764

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4.1 - Aftertreatment diesel exhaust fluid dosing valve is malfunctioning

Solution: S00002764

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Clean the aftertreatment diesel exhaust fluid dosing valve.
  • Turn keyswitch ON.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4677 | SPN: 1761 | FMI: 9
Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Abnormal Update Rate

Troubleshooting Summary

  1. Check for primary fault codes
  2. Technical Service Bulletin is available
  3. Low battery voltage
  4. Battery load test
  5. Ground inspection
  6. Fault Code 4677 triggered by a malfunction in the J1939 data link with multiple OEM fault code
  7. Aftertreatment diesel exhaust fluid tank level/temperature/quality sensor voltage check
  8. Aftertreatment diesel exhaust fluid tank level sensor voltage check
  9. Aftertreatment diesel exhaust fluid tank level sensor open circuit check
  10. J1939 data link terminating resistance is incorrect
  11. Variable geometry turbocharger actuator has incorrect J1939 terminating resistance
  12. Engine wiring harness has incorrect J1939 terminating resistance
  13. OEM wiring harness has incorrect J1939 terminating resistance
  14. J1939 data link harness open circuit check
  15. OEM terminating resistor Ω check for the J1939 data link
  16. Incorrect terminating resistance in the J1939 data link by a J1939 data linked component
  17. J1939 wire resistance check at the crossover connector for each component
  18. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000251

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Turbocharger: 1894, 2636
  • Aftertreatment diesel exhaust fluid system: 1713

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Technical Service Bulletin is available

Solution: S00009162

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb170054

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Low battery voltage

Solution: S00001110

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.
  • If this vehicle has been repaired within the last 30 days for the same fault code, then proceed to the Linked Solutions section.

Specification

  • If the battery voltage is at least 10.8 VDC (12 volt systems) or 21.6 VDC (24 volt systems), then proceed to the Linked Solutions section.
  • If the battery or battery cables show signs of corrosion or damage, then proceed to the Repair Section.

Linked Solutions

  • Battery load test

Refer to S00001379

  • Ground inspection

Refer to S00000754

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean corrosion or tighten battery cable connections.

Refer to OEM Service Manual

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3.1 - Battery load test

Solution: S00001379

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Disconnect the batteries from each other.
  • Connect a load tester separately to each battery.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.

Specification

  • For a 12 volt system, proceed to the Repair section if the battery voltage is below the following specification: 11 VDC
  • For a 24 volt system, proceed to the Repair section if the battery voltage is below the following specification: 22 VDC

Linked Solutions

  • None

Repair

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3.2 - Ground inspection

Solution: S00000754

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the ECM ground for damage, corrosion and loose connections.
  • Visually inspect the aftertreatment interface wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the OEM wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the grounds for proper routing.

Specification

  • If damage, corrosion or incorrect routing of grounds are found, then proceed to the Repair section

Linked Solutions

  • None

Repair

  • Clean or replace connections.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Fault Code 4677 triggered by a malfunction in the J1939 data link with multiple OEM fault code

Solution: S00005690

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

If there is a previously saved job image, then that fault code list should be used in place of retrieving the fault codes again with the recommended Cummins® electronic service tool or equivalent. This will eliminate the need to reconnect and then disconnect component(s). Retrieving fault codes without reconnecting these components will result in multiple fault codes to be logged.

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution, if any fault code is active or has more than one inactive count within the last 25 engine operating hours from the following list: 1894, 2636, 2771, 3232, 3911, 4151, 4152, 6688
  • Proceed to the next solution if any fault code from the following list is not active: 3868, 4572, 4677
  • Proceed to the Linked Solutions section if all fault codes from the following list are active: 3868, 4572, 4677

Linked Solutions

  • Aftertreatment diesel exhaust fluid tank level/temperature/quality sensor voltage check

Refer to S00005705

Repair

Refer to OEM Service Manual

  • No additional action is required for this solution.

Validation

  • None
Next Solution

4.1 - Aftertreatment diesel exhaust fluid tank level/temperature/quality sensor voltage check

Solution: S00005705

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage from the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor SUPPLY pin and the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor RETURN pin at the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness, OEM wiring harness or interconnect has been detected if the voltage is not within the following specification of battery voltage: 1 VDC
  • A malfunctioning aftertreatment diesel exhaust fluid tank level/temperature/quality sensor has been detected if the voltage is within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, aftertreatment interface harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Replace the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.

Refer to Procedure 019-475

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Aftertreatment diesel exhaust fluid tank level sensor voltage check

Solution: S00000988

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment diesel exhaust fluid tank level sensor voltage SUPPLY pin and the aftertreatment diesel exhaust fluid tank level sensor voltage RETURN pin at the OEM wiring harness connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification of ECM power supply voltage: 1 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification of ECM power supply voltage: 1 VDC

Linked Solutions

Click on the link below:

  • Aftertreatment diesel exhaust fluid tank level sensor open circuit

Refer to S00000989

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

5.1 - Aftertreatment diesel exhaust fluid tank level sensor open circuit check

Solution: S00000989

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage from the aftertreatment diesel exhaust fluid tank level sensor ECM power supply voltage SUPPLY pin of the wiring harness connector to engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • An open circuit has been detected in the aftertreatment diesel exhaust fluid tank level sensor ECM power supply voltage RETURN circuit in the OEM wiring harness if the voltage is within the following specification of the ECM power supply: 1 VDC
  • An open circuit has been detected in the aftertreatment diesel exhaust fluid tank level sensor ECM power supply voltage SUPPLY circuit in the OEM wiring harness if the voltage is not within the following specification of the ECM power supply: 1 VDC

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - J1939 data link terminating resistance is incorrect

Solution: S00000593

Verification

Conditions

  • Turn keyswitch OFF.
  • Wait for 90 seconds.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.
  • Reconnect the variable geometry turbocharger actuator if it has been previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3-pin service data link connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Follow your technical escalation process if the resistance is within the following specification: 54 - 66 Ω
  • Proceed to the Linked Solutions section if the resistance is not within the following specification: 54 - 66 Ω

Linked Solutions

  • Variable geometry turbocharger actuator has incorrect J1939 terminating resistance

Refer to S00001242

  • Engine wiring harness has incorrect J1939 terminating resistance

Refer to S00000972

  • OEM wiring harness has incorrect J1939 terminating resistance

Refer to S00000971

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

6.1 - Variable geometry turbocharger actuator has incorrect J1939 terminating resistance

Solution: S00001242

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the variable geometry turbocharger actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the variable geometry turbocharger actuator SAE J1939 data link (+) pin and the variable geometry turbocharger actuator SAE J1939 data link (-) pin at the variable geometry turbocharger actuator.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning variable geometry turbocharger actuator has been detected if the resistance is not within the following specification: 108 Ω - 132 Ω

Linked Solutions

  • None

Repair

  • Replace the variable geometry turbocharger actuator.

Refer to Procedure 010-134

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6.2 - Engine wiring harness has incorrect J1939 terminating resistance

Solution: S00000972

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect previously disconnected components.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.
  • Disconnect the aftertreatment intake NOx sensor from the engine wiring harness.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3-pin service data link connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is not within the following specification: 108-132 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6.3 - OEM wiring harness has incorrect J1939 terminating resistance

Solution: S00000971

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if the resistance is not within the following specification: 108 - 132 Ω
  • Follow your technical escalation process if the resistance is within the following specification: 108 - 132 Ω

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Parent Solution

7 - J1939 data link harness open circuit check

Solution: S00004534

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the appropriate data link component from the data link wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the J1939 (+) pin at the appropriate component data link wiring harness connector and the appropriate data link component J1939 (+) pin at the data link wiring harness ECM connector.
  • Measure the resistance between the J1939 (-) pin at the appropriate component data link wiring harness connector and the appropriate data link component J1939 (-) pin at the data link wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning J1939 data link wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - OEM terminating resistor Ω check for the J1939 data link

Solution: S00000907

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM terminating resistor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the pins for the OEM terminating resistor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM terminating resistor has been detected if the resistance is not within the following specification: 108 - 132 Ω

Linked Solutions

  • None

Repair

  • For a malfunctioning OEM terminating resistor, replace the OEM terminating resistor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Incorrect terminating resistance in the J1939 data link by a J1939 data linked component

Solution: S00001002

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Reconnect the OEM terminating resistor if previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the resistance is not within the following specification: 108 - 132 Ω

Linked Solutions

  • J1939 wire resistance check at the crossover connector for each component

Refer to S00001003

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

9.1 - J1939 wire resistance check at the crossover connector for each component

Solution: S00001003

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Reconnect the OEM terminating resistor if previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

Inspect the following components if applicable:

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector for each component while disconnecting them one at a time.
  • Disconnect the aftertreatment outlet NOx sensor
  • Disconnect the aftertreatment temperature sensor module
  • Disconnect the aftertreatment particulate sensor
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor
  • Disconnect the aftertreatment diesel exhaust fluid temperature sensor
  • Disconnect the aftertreatment diesel exhaust fluid quality sensor.
  • Disconnect the aftertreatment intermediate NH3 sensor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance was not within 108 Ω to 132 Ω and it becomes within the specification of 108 Ω to 132 Ω when the J1939 component was disconnected, then a malfunctioning J1939 component has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid tank level sensor.

Refer to OEM Service Manual

  • Replace the aftertreatment diesel exhaust fluid temperature sensor.

Refer to OEM Service Manual

  • Replace the aftertreatment diesel exhaust fluid quality sensor.

Refer to OEM Service Manual

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace aftertreatment DOC temperature sensor module.

Refer to Procedure 019-449

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

  • Replace aftertreatment intermediate NH3 sensor.

Refer to Procedure 019-479

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

10 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4691 | SPN: 5585 | FMI: 18
Engine Injector Metering Rail 1 Cranking Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Technical Service Bulletin is available
  3. Engine will not start
  4. Low pressure fuel system component is malfunctioning
  5. Fuel Inlet Restriction check
  6. Air in fuel check
  7. Fuel filter differential and gear pump pressure check
  8. Fuel injector return flow check
  9. Fuel injector isolation test
  10. Fuel pressure relief valve return flow excessive
  11. High-Pressure Fuel Pump Performance Test
  12. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000104

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Voltage: 1117
  • Sensor supply 1: 352, 386
  • Fuel: 271, 272, 322, 323, 324, 325, 331, 332, 449, 451, 452, 1911, 2311, 2372

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Technical Service Bulletin is available

Solution: S00009733

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb140002

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine will not start

Solution: S00000629

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Attempt to start the engine.

Specification

  • If the engine starts, then proceed to the next Solution.
  • If the engine will not start, then reset the search to crank no start.

Linked Solutions

  • None

Repair

  • Reset the search to crank no start.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Low pressure fuel system component is malfunctioning

Solution: S00005122

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually check fuel tank for adequate fuel supply.

Refer to OEM Service Manual

  • Visually inspect the engine fuel supply lines for signs of kinks, damage or fuel leaks.

Refer to Procedure 006-024

Specification

  • If no damage or leaks are observed, then proceed to the Linked Solutions section.
  • If there is any damage or leaks found in the OEM fuel system, then proceed to the Repair section.

Linked Solutions

  • Fuel Inlet Restriction check

Refer to S00001206

  • Air in fuel check

Refer to S00001205

  • Fuel filter differential and gear pump pressure check

Refer to S00005034

Repair

  • Repair or replace the OEM fuel lines.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4.1 - Fuel Inlet Restriction check

Solution: S00001206

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Measure the fuel inlet restriction.

Refer to Procedure 006-020

Specification

  • If the engine will not start, then proceed to the next solution.

If the inlet restriction is excessive, look for the root cause:

Inspect the following components if applicable:

  • Suction side fuel filters plugged.
  • Fuel heater restricted.

Refer to OEM Service Manual

  • OEM fuel lines restricted.

Refer to OEM Service Manual

  • ECM cooling plate plugged.

Refer to Procedure 006-006

  • ECM cooling plate check valve restricted.

Refer to Procedure 006-006

  • Fuel tank stand pipes restricted.

Refer to OEM Service Manual

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace fuel filter.

Refer to OEM Service Manual

  • Repair or replace the fuel heater.

Refer to OEM Service Manual

  • Repair or replace the OEM fuel lines.

Refer to OEM Service Manual

  • Repair or replace the ECM cooling plate.

Refer to Procedure 006-006

  • Repair or replace the ECM cooling plate check valve.

Refer to Procedure 006-006

  • Repair or replace the fuel tank stand pipe.

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.2 - Air in fuel check

Solution: S00001205

Verification

Conditions

  • Turn keyswitch ON.
  • Verify adequate fuel level in the tank

Action

  • Allow the engine to reach operating temperature.
  • If engine will not start, then perform the check during cranking.
  • Inspect for air being ingested into the fuel.

Refer to Procedure 006-003

Specification

  • If air is present in the fuel flow, then a damaged fuel supply line, loose or damaged fuel filter, or a loose connection has been detected.

Linked Solutions

  • None

Repair

  • Tighten the loose fitting or replace the damaged component that allows air to enter the fuel system.

Refer to Procedure 006-003

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4.3 - Fuel filter differential and gear pump pressure check

Solution: S00005034

Verification

Conditions

  • Turn keyswitch ON.

Action

  • Perform the Fuel Filter Restriction Test.

Refer to Procedure 005-236

Specification

  • If the pressure is not within specification at the fuel pressure filter inlet, then a malfunction of the fuel pump gear pump has been detected.
  • If pressure from the fuel pump gear pump is within specification and the differential pressure does not meet specification a plugged or blocked fuel filter has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace fuel filter.

Refer to Procedure 006-065

  • Replace the fuel pump gear pump.

Refer to Procedure 005-025

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5 - Fuel injector return flow check

Solution: S00000631

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the High-Pressure Injector Return Flow Test.

Refer to Procedure 005-236

Specification

  • If the High-Pressure Injector Return Flow Test is out of specification, then tighten the fuel injector connector nuts and perform the High-Pressure Injector Return Flow Test again.
  • If the High-Pressure Injector Return Flow Test is still out of specification, then proceed to the Linked Solutions section.

Linked Solutions

  • Fuel injector isolation test

Refer to S00001280

Repair

  • Check the torque on the fuel connector retaining nuts and tighten if necessary.

Refer to Procedure 006-052

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5.1 - Fuel injector isolation test

Solution: S00001280

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the High-Pressure Injector Return Flow Isolation Test.

Refer to Procedure 005-236

Specification

  • If the Fuel Injector Return Flow Isolation Test identifies a fuel injector that does not meet specification, then a malfunctioning fuel injector has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - Fuel pressure relief valve return flow excessive

Solution: S00000632

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the Fuel Pressure Relief Valve Return Flow Test.

Refer to Procedure 005-236

Specification

  • If the fuel rail return flow does not meet the specification at the fuel rail pressure relief valve, then a malfunctioning fuel rail relief valve has been detected.

Linked Solutions

  • None

Repair

  • Replace the fuel pressure relief valve.

Refer to Procedure 006-061

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - High-Pressure Fuel Pump Performance Test

Solution: S00005120

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the High-Pressure Fuel Pump Performance Test.

Refer to Procedure 005-236

Specification

  • If the measured fuel flow from the high-pressure fuel pump service tool at the recorded engine speed is in the upper region of the graph, the fuel pump is functioning properly.

Refer to Procedure 005-236

  • If the measured fuel flow from the high-pressure fuel pump service tool at the recorded engine speed is in the lower region of the graph, then a malfunctioning fuel pump has been detected.

Refer to Procedure 005-236

  • If the test readings are in the gray area, the fuel pump head must be removed and the fuel pump camshaft and fuel pump camshaft tappet rollers must be inspected.

Refer to Procedure 005-236

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace fuel pump head.

Refer to Procedure 005-227

  • Replace high pressure fuel pump.

Refer to Procedure 005-227

Refer to tsb140019

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4726 | SPN: 1239 | FMI: 16
Engine Fuel Leakage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Fuel injector return flow check
  3. Fuel injector isolation test
  4. Fuel pressure relief valve return flow excessive
  5. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000103

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 322, 323, 324, 325, 331, 332, 451, 452, 2343, 2372

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Fuel injector return flow check

Solution: S00000631

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the High-Pressure Injector Return Flow Test.

Refer to Procedure 005-236

Specification

  • If the High-Pressure Injector Return Flow Test is out of specification, then tighten the fuel injector connector nuts and perform the High-Pressure Injector Return Flow Test again.
  • If the High-Pressure Injector Return Flow Test is still out of specification, then proceed to the Linked Solutions section.

Linked Solutions

  • Fuel injector isolation test

Refer to S00001280

Repair

  • Check the torque on the fuel connector retaining nuts and tighten if necessary.

Refer to Procedure 006-052

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Fuel injector isolation test

Solution: S00001280

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the High-Pressure Injector Return Flow Isolation Test.

Refer to Procedure 005-236

Specification

  • If the Fuel Injector Return Flow Isolation Test identifies a fuel injector that does not meet specification, then a malfunctioning fuel injector has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the fuel injector.

Refer to Procedure 006-026

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Fuel pressure relief valve return flow excessive

Solution: S00000632

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the Fuel Pressure Relief Valve Return Flow Test.

Refer to Procedure 005-236

Specification

  • If the fuel rail return flow does not meet the specification at the fuel rail pressure relief valve, then a malfunctioning fuel rail relief valve has been detected.

Linked Solutions

  • None

Repair

  • Replace the fuel pressure relief valve.

Refer to Procedure 006-061

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4727 | SPN: 157 | FMI: 15
Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Air in fuel check
  3. High fuel drain line restriction
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000102

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Fuel: 322, 323, 324, 325, 331, 332, 451, 452

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Air in fuel check

Solution: S00004548

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify adequate fuel level in the tank.

Refer to OEM Service Manual

  • Inspect for air being ingested into the fuel.

Refer to Procedure 006-003

Specification

  • If air is present in the fuel flow, then a damaged fuel supply line, loose or damaged fuel filter, or a loose connection has been detected.

Linked Solutions

  • None

Repair

Repair or replace the following components if they are found out of specification:

  • Tighten the loose fitting or replace the damaged component that allows air to enter the fuel system.

Refer to Procedure 006-003

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - High fuel drain line restriction

Solution: S00000537

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect fuel drain line for signs of kinks or damage.
  • Measure the fuel drain line restriction.

Refer to Procedure 006-012

Specification

  • If the fuel drain line restriction is not within the specification, then high fuel drain line restriction has been detected.

Linked Solutions

  • None

Repair

  • Replace fuel drain line.

Refer to Procedure 006-013

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4728 | SPN: 1209 | FMI: 18
Exhaust Gas Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Leaks in the intake air system
  3. Charge air cooler system leak
  4. High exhaust restriction
  5. Exhaust gas pressure sensor open circuit check
  6. Exhaust gas pressure sensor circuit pin to pin short
  7. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00004969

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Voltage: 3724
  • Intake manifold: 122, 123, 124, 125, 2973, 3361
  • Exhaust gas pressure: 2373, 2374, 2554
  • EGR: 1228, 1867, 1896, 2272, 2349, 2353, 3382, 3383, 3724
  • EGR differential pressure: 1866, 2273, 2274
  • Turbocharger: 1894, 1898, 2198, 2387, 2449, 2634, 2635, 2636, 5177
  • Intake throttle: 175, 176, 177, 3539, 3541, 3542

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Leaks in the intake air system

Solution: S00008386

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.
  • Visually inspect the intake plumbing for possible air leaks.

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Charge air cooler system leak

Solution: S00008815

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the charge air cooler hoses for possible air leaks.
  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If a leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the charge air cooler.

Refer to Procedure 010-027

  • Repair or replace the charge air cooler hoses.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - High exhaust restriction

Solution: S00000324

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the exhaust restriction.

Refer to Procedure 011-009

Specification

  • If the exhaust restriction is not within specification, then a restriction in the exhaust has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Check the face of the aftertreatment diesel oxidation catalyst for plugging.

Refer to Procedure 011-049

  • Check the face of the aftertreatment diesel particulate filter for plugging.

Refer to Procedure 011-041

  • Check for deposits in the decomposition tube.

Refer to Procedure 011-062

  • Check the face of the aftertreatment SCR catalyst for plugging.

Refer to Procedure 011-036

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Exhaust gas pressure sensor open circuit check

Solution: S00000778

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the exhaust gas pressure sensor SIGNAL pin at the exhaust gas pressure sensor engine wiring harness connector and the exhaust gas pressure sensor SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the exhaust gas pressure sensor SUPPLY pin at the exhaust gas pressure sensor engine wiring harness connector and the exhaust gas pressure sensor SUPPLY pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Exhaust gas pressure sensor circuit pin to pin short

Solution: S00000775

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the exhaust gas pressure sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the exhaust gas pressure sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4731 | SPN: 3031 | FMI: 13
Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Out of Calibration

Troubleshooting Summary

  1. ECM calibration revision history check
  2. Aftertreatment diesel exhaust fluid tank temperature sensor is malfunctioning

1 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid tank temperature sensor is malfunctioning

Solution: S00004854

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor has been detected.

Linked Solutions

  • None

Repair

If an aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit has been replaced within the last 90 days, follow your technical escalation process PRIOR to performing any of the repair actions listed below:

The aftertreatment diesel exhaust fluid tank level sensor is a integrated part of the aftertreatment diesel exhaust fluid tank level, temperature, quality sensor unit and is not a servicable part.

  • Replace the aftertreatment diesel exhaust fluid tank temperature sensor .

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4732 | SPN: 1761 | FMI: 13
Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Out of Calibration

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid tank level sensor is malfunctioning
  2. ECM calibration revision history check

1 - Aftertreatment diesel exhaust fluid tank level sensor is malfunctioning

Solution: S00000982

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active and no other fault codes have been logged, then a malfunctioning aftertreatment diesel exhaust fluid tank level, temperature, quality sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid tank level sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4739 | SPN: 1761 | FMI: 11
Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Root Cause Not Known

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid tank level sensor is malfunctioning
  3. Aftertreatment diesel exhaust fluid tank level sensor is malfunctioning
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00001187

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 3868, 4572

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid tank level sensor is malfunctioning

Solution: S00000983

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive with more than one count within the last 25 engine operating hours and no other fault codes have been logged, then a malfunctioning aftertreatment diesel exhaust fluid tank level sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid tank level sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid tank level sensor is malfunctioning

Solution: S00000982

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active and no other fault codes have been logged, then a malfunctioning aftertreatment diesel exhaust fluid tank level, temperature, quality sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid tank level sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4745 | SPN: 3515 | FMI: 11
Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 - Root Cause Not Known

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Aftertreatment diesel exhaust fluid quality sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000100

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 3868, 4572, 4677

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid quality sensor is malfunctioning

Solution: S00000933

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than once count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid quality sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid quality sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4747 | SPN: 3217 | FMI: 20
Aftertreatment 1 Intake Oxygen Sensor - Data Not Rational - Drifted High

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment intake and outlet NOx sensors malfunctioning
  3. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000099

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment NOx: 1885, 3232, 3649, 3682, 3748
  • Intake manifold: 122, 123, 124, 125, 2973, 4612
  • Intake manifold temperature: 155, 488, 2964
  • Barometric pressure: 221, 222, 295
  • Turbocharger: 595, 687, 1962, 1976, 2198, 2288, 2387, 2449, 2634, 2636, 4956, 4957, 5177
  • EGR: 1228, 1896, 1961, 2272, 2349, 2353, 2961, 2962
  • EGR differential pressure: 2273, 2274
  • Aftertreatment outlet oxygen: 4749, 4751

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment intake and outlet NOx sensors malfunctioning

Solution: S00000991

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Verify proper installation of the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

Specification

  • If Fault Code 4749 or 4751 is not active or inactive with more than one count logged within the last 25 engine hours, then a malfunctioning aftertreatment intake NOx sensor has been detected.
  • If Fault Code 4749 or 4751 is active or inactive with more than one count logged within the last 25 engine hours, then a malfunctioning aftertreatment intake NOx sensor and a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4748 | SPN: 3217 | FMI: 21
Aftertreatment 1 Intake Oxygen Sensor - Data Not Rational - Drifted Low

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment intake and outlet NOx sensors malfunctioning
  3. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000098

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Voltage: 1938
  • Aftertreatment NOx: 1885, 3232, 3649, 3682, 3748
  • Intake manifold: 122, 123, 124, 125, 4612
  • Intake manifold temperature: 155, 488, 2973
  • Barometric pressure: 221, 222, 295
  • Turbocharger: 595, 687, 1962, 1976, 2198, 2288, 2387, 2449, 2634, 2635, 2636, 4956, 4957, 5177
  • EGR: 1228, 1896, 1961, 2272, 2349, 2353, 2961, 2962
  • EGR differential pressure: 2273, 2274

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment intake and outlet NOx sensors malfunctioning

Solution: S00000991

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Verify proper installation of the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

Specification

  • If Fault Code 4749 or 4751 is not active or inactive with more than one count logged within the last 25 engine hours, then a malfunctioning aftertreatment intake NOx sensor has been detected.
  • If Fault Code 4749 or 4751 is active or inactive with more than one count logged within the last 25 engine hours, then a malfunctioning aftertreatment intake NOx sensor and a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4749 | SPN: 3227 | FMI: 20
Aftertreatment 1 Outlet Oxygen - Data Not Rational - Drifted High

Troubleshooting Summary

  1. Check for primary fault codes
  2. Leaking EGR differential pressure sensor mounting surface
  3. Aftertreatment outlet NOx sensor has carbon buildup
  4. Charge air cooler is restricted
  5. ECM calibration revision history check
  6. Aftertreatment outlet NOx sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000097

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment NOx: 1887, 2771, 3583, 3681, 3749
  • Intake manifold temperature: 155, 488, 2964
  • Intake manifold: 122, 123, 124, 125, 2973, 4612
  • Barometric pressure: 221, 222, 295
  • Turbocharger: 595, 687, 1962, 1976, 2198, ,2288, 2387, 2449, 2634, 2636, 4956, 4957, 5177
  • EGR: 1228, 1896, 1961, 2272, 2349, 2353, 2961, 2962
  • EGR differential pressure: 2273, 2274
  • Voltage: 1938

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Leaking EGR differential pressure sensor mounting surface

Solution: S00001114

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Inspect the o-rings between the EGR differential pressure sensor and the mounting surface.

Refer to Procedure 019-370

  • Inspect the EGR differential pressure sensor.

Refer to Procedure 019-370

Leaks can be easily noted by traces of soot, however, the sensor will need to be removed to inspect the o-rings between the EGR differential pressure sensor and the mounting surface.

Specification

  • If leaks are detected at the EGR differential pressure sensor mounting surface, then proceed to the Repair section.
  • If any carbon buildup is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean or replace the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Clean the EGR differential pressure sensor mounting surface.

Refer to Procedure 011-066

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment outlet NOx sensor has carbon buildup

Solution: S00000540

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the correct aftertreatment outlet NOx sensor is installed for engine configuration (12 or 24 volt).
  • Remove the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Inspect the sensor tip for damage or carbon buildup.

Refer to Procedure 019-451

Specification

  • If the aftertreatment outlet NOx sensor is damaged or has carbon buildup, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Charge air cooler is restricted

Solution: S00001005

Verification

Conditions

  • Turn keyswitch ON.
  • Engine running.

Action

  • Check the pressure differential across the charge air cooler.

Refer to Procedure 010-027

Specification

  • If the charge air cooler does not meet specification, then a malfunctioning charge air cooler has been detected.

Refer to Procedure 010-027

Linked Solutions

  • None

Repair

  • Repair or replace the charge air cooler.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment outlet NOx sensor is malfunctioning

Solution: S00000994

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4751 | SPN: 3227 | FMI: 21
Aftertreatment 1 Outlet Oxygen - Data Not Rational - Drifted Low

Troubleshooting Summary

  1. Check for primary fault codes
  2. Leaking EGR differential pressure sensor mounting surface
  3. Aftertreatment outlet NOx sensor has carbon buildup
  4. Charge air cooler is restricted
  5. ECM calibration revision history check
  6. Aftertreatment outlet NOx sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000096

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment NOx: 1887, 2771, 3583, 3681, 3749
  • Intake manifold: 122, 123, 124, 125, 2973, 4612
  • Barometric pressure: 221, 222, 295
  • Intake manifold temperature: 488
  • Turbocharger: 687, 1962, 1976, 2198, 2288, 2387, 2449, 2634, 2636, 4956, 4957, 5177
  • EGR: 1228, 1896, 1961, 2272, 2349, 22353, 2961, 2962
  • EGR differential pressure: 2273, 2274
  • Voltage: 1938

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Leaking EGR differential pressure sensor mounting surface

Solution: S00001114

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Inspect the o-rings between the EGR differential pressure sensor and the mounting surface.

Refer to Procedure 019-370

  • Inspect the EGR differential pressure sensor.

Refer to Procedure 019-370

Leaks can be easily noted by traces of soot, however, the sensor will need to be removed to inspect the o-rings between the EGR differential pressure sensor and the mounting surface.

Specification

  • If leaks are detected at the EGR differential pressure sensor mounting surface, then proceed to the Repair section.
  • If any carbon buildup is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean or replace the EGR differential pressure sensor.

Refer to Procedure 019-370

  • Clean the EGR differential pressure sensor mounting surface.

Refer to Procedure 011-066

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment outlet NOx sensor has carbon buildup

Solution: S00000540

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the correct aftertreatment outlet NOx sensor is installed for engine configuration (12 or 24 volt).
  • Remove the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Inspect the sensor tip for damage or carbon buildup.

Refer to Procedure 019-451

Specification

  • If the aftertreatment outlet NOx sensor is damaged or has carbon buildup, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Charge air cooler is restricted

Solution: S00001005

Verification

Conditions

  • Turn keyswitch ON.
  • Engine running.

Action

  • Check the pressure differential across the charge air cooler.

Refer to Procedure 010-027

Specification

  • If the charge air cooler does not meet specification, then a malfunctioning charge air cooler has been detected.

Refer to Procedure 010-027

Linked Solutions

  • None

Repair

  • Repair or replace the charge air cooler.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment outlet NOx sensor is malfunctioning

Solution: S00000994

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4768 | SPN: 3521 | FMI: 11
Aftertreatment 1 Diesel Exhaust Fluid Property - Root Cause Not Known

Troubleshooting Summary

  1. Aftertreatment diesel exhaust fluid is contaminated
  2. ECM calibration revision history check
  3. Aftertreatment diesel exhaust fluid quality sensor is malfunctioning

1 - Aftertreatment diesel exhaust fluid is contaminated

Solution: S00000563

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Use a diesel exhaust fluid refractometer to measure the concentration of the diesel exhaust fluid in the tank.

Refer to Service Bulletin 4021566

Specification

  • If there are signs of contaminates in the aftertreatment diesel exhaust fluid, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to Procedure 011-056

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid quality sensor is malfunctioning

Solution: S00000933

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than once count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment diesel exhaust fluid quality sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid quality sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4769 | SPN: 1761 | FMI: 10
Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Abnormal Rate of Change

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment diesel exhaust fluid level is low
  3. Aftertreatment diesel exhaust fluid tank level sensor is malfunctioning
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000093

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 1668, 1669, 3242, 3497, 3868, 4679, 4732, 4738, 4739

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment diesel exhaust fluid level is low

Solution: S00000798

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Fill the aftertreatment diesel exhaust fluid tank.

Refer to OEM Service Manual

Specification

  • If the fault code goes inactive, proceed to Repair section.

Linked Solutions

  • None

Repair

  • Fill the aftertreatment diesel exhaust fluid tank completely full.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment diesel exhaust fluid tank level sensor is malfunctioning

Solution: S00002687

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Fill the aftertreatment diesel exhaust fluid tank.
  • Wait for 120 seconds.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Wait for 120 seconds.
  • Check the aftertreatment diesel exhaust fluid gauge on the dash.

Specification

  • A malfunctioning aftertreatment diesel exhaust fluid tank level, temperature, quality sensor has been detected if the fault code is active and the aftertreatment diesel exhaust fluid gauge on the dash indicates the tank is full.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment diesel exhaust fluid tank level sensor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4839 | SPN: 3667 | FMI: 31
Engine Air Shutoff - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000998

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake throttle: 175, 176, 177, 3539, 3541, 3542, 5879, 5881, 5882

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4842 | SPN: 3364 | FMI: 15
Aftertreatment 1 Diesel Exhaust Fluid Quality - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Multiple Technical Service Bulletins are available
  2. Aftertreatment diesel exhaust fluid is contaminated
  3. ECM calibration revision history check

1 - Multiple Technical Service Bulletins are available

Solution: S00005092

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb170054

  • If this engine is not in a Navistar application, then proceed to the next solution.
  • Technical Service Bulletin is available.

Refer to tsb160031

  • If this engine is not in a PACCAR™ application, then proceed to the next solution.
  • Technical Service Bulletin is available.

Refer to tsb200189

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Aftertreatment diesel exhaust fluid is contaminated

Solution: S00000563

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Use a diesel exhaust fluid refractometer to measure the concentration of the diesel exhaust fluid in the tank.

Refer to Service Bulletin 4021566

Specification

  • If there are signs of contaminates in the aftertreatment diesel exhaust fluid, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to Procedure 011-056

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4951 | SPN: 6655 | FMI: 3
Maintain ECU Power Lamp Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Engine control unit power lamp resistance check
  2. Voltage check at engine control unit power lamp
  3. Voltage check at the engine control unit power lamp to block ground
  4. ECM calibration revision history check

1 - Engine control unit power lamp resistance check

Solution: S00004218

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness from the engine control unit power lamp.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the engine control unit power lamp.

Refer to OEM Service Manual

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not within specification, then a malfunctioning engine control unit power lamp has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine control unit power lamp.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Voltage check at engine control unit power lamp

Solution: S00000999

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness from the engine control unit power lamp.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the OEM wiring harness connector engine control unit power lamp SUPPLY pin and the OEM wiring harness engine control unit power lamp connector RETURN pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

For general voltage measurement techniques.

Refer to Procedure 019-359

Specification

  • If the voltage is not between 10 to 15 VDC on 12 volt systems and 21 to 27 VDC on 24 volt systems, then a failed OEM wiring harness has been detected.
  • If the voltage is between 10 to 15 VDC on 12 volt systems and 21 to 27 VDC for 24 volt systems, then proceed to the Linked Solutions section.

Linked Solutions

Click on the link below:

  • Voltage check at the engine control unit power lamp to block ground

Refer to S00001000

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • None
Next Solution

2.1 - Voltage check at the engine control unit power lamp to block ground

Solution: S00001000

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness from the engine control unit power lamp.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the OEM wiring harness connector engine control unit power lamp SUPPLY pin and the engine block, or a good clean ground surface on the chassis.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

For general voltage measurement techniques.

Refer to Procedure 019-359

Specification

  • If the voltage is not between 10 to 15 VDC on 12 volt systems and 21 to 27 VDC on 24 volt systems, then a failed OEM wiring harness has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the fuse.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 4952 | SPN: 6655 | FMI: 4
Maintain ECU Power Lamp Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Engine control unit power lamp resistance check
  2. Voltage check at engine control unit power lamp
  3. Voltage check at the engine control unit power lamp to block ground
  4. ECM calibration revision history check

1 - Engine control unit power lamp resistance check

Solution: S00004218

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness from the engine control unit power lamp.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the engine control unit power lamp.

Refer to OEM Service Manual

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance is not within specification, then a malfunctioning engine control unit power lamp has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine control unit power lamp.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Voltage check at engine control unit power lamp

Solution: S00000999

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness from the engine control unit power lamp.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the OEM wiring harness connector engine control unit power lamp SUPPLY pin and the OEM wiring harness engine control unit power lamp connector RETURN pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

For general voltage measurement techniques.

Refer to Procedure 019-359

Specification

  • If the voltage is not between 10 to 15 VDC on 12 volt systems and 21 to 27 VDC on 24 volt systems, then a failed OEM wiring harness has been detected.
  • If the voltage is between 10 to 15 VDC on 12 volt systems and 21 to 27 VDC for 24 volt systems, then proceed to the Linked Solutions section.

Linked Solutions

Click on the link below:

  • Voltage check at the engine control unit power lamp to block ground

Refer to S00001000

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • None
Next Solution

2.1 - Voltage check at the engine control unit power lamp to block ground

Solution: S00001000

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness from the engine control unit power lamp.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the OEM wiring harness connector engine control unit power lamp SUPPLY pin and the engine block, or a good clean ground surface on the chassis.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

For general voltage measurement techniques.

Refer to Procedure 019-359

Specification

  • If the voltage is not between 10 to 15 VDC on 12 volt systems and 21 to 27 VDC on 24 volt systems, then a failed OEM wiring harness has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the fuse.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 5259 | SPN: 3667 | FMI: 14
Engine Air Shutoff Status - Special Instructions

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000091

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake throttle: 175, 176, 177, 3539, 3541, 3542

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 5278 | SPN: 6802 | FMI: 31
Aftertreatment 1 Diesel Exhaust Fluid Dosing System Frozen - Condition Exists

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000090

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 1683, 1684, 1712, 1713, 3237, 3239, 3242, 3258, 3261, 3422, 3425, 3426, 3429, 3562, 3563, 3564, 3576, 3713, 4167

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 5297 | SPN: 747 | FMI: 13
Engine/Transmission Match - Out of Calibration

Troubleshooting Summary

  1. Technical Service Bulletin is available
  2. ECM calibration revision history check

1 - Technical Service Bulletin is available

Solution: S00006176

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify the present Transmission Control Module software phase.

Refer to tsb150099

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Verify the predictive engine braking parameter is correctly set.

Refer to Procedure 019-665

  • Verify the predictive gear shifting parameter is correctly set.

Refer to Procedure 019-665

  • Verify the smart coast parameter is correctly set.

Refer to Procedure 019-665

  • Verify the smart torque 2 parameter is correctly set.

Refer to Procedure 019-665

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 5298 | SPN: 747 | FMI: 19
Engine/Transmission Match - Received Network Data in Error

Troubleshooting Summary

  1. Incorrect adjustable parameter setting

1 - Incorrect adjustable parameter setting

Solution: S00008945

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Go to Features and Parameters.
  • Check that the ECM features and parameters enables match the Transmission Control Module feature and parameter enables.

Specification

  • If the Smart Coast feature is disabled in the ECM and enabled in the Transmission Control Module, then the incorrect adjustable parameter is configured.
  • If the Smart Torque feature is disabled in the ECM and enabled in the Transmission Control Module, then the incorrect adjustable parameter is configured.
  • If the Predictive Gear Shifting feature is disabled in the ECM and enabled in the Transmission Control Module, then the incorrect adjustable parameter is configured.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Disable the Smart Coast feature in the ECM if it is not supported in the transmission using the recommended Cummins® electronic service tool or equivalent.
  • Enable the Smart Coast feature in the Transmission Control Module if it is supported in the transmission.
  • Disable the Smart Torque feature in the ECM if it is not supported in the transmission using the recommended Cummins® electronic service tool or equivalent.
  • Enable the Smart Torque feature in the Transmission Control Module if it is supported in the transmission.
  • Disable the Predictive Gear Shifting feature in the ECM if it is not supported in the transmission using the recommended Cummins® electronic service tool or equivalent.
  • Enable the Predictive Gear Shifting feature in the Transmission Control Module if it is supported in the transmission.

Validation

  • None

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 15-Mar-2021


NO TITLE

ISX15 CM2350 X101

Fault Code: 5383 | SPN: 3720 | FMI: 15
Aftertreatment 1 Diesel Particulate Filter Ash Load Percent - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Aftertreatment DPF is malfunctioning

1 - Check for primary fault codes

Solution: S00000085

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment differential pressure: 1879, 1881, 1883
  • Aftertreatment DPF: 1922

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment DPF is malfunctioning

Solution: S00005270

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • If the aftertreatment DPF has already been replaced during this repair, then disregard this solution.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive with more than one count within the last 25 engine operating hours and no other fault codes have been logged, then a plugged or restricted aftertreatment DPF has been detected.

Linked Solutions

  • None

Repair

  • Clean the aftertreatment DPF.

Refer to Procedure 011-041

Validation

  • None
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 5577 | SPN: 6778 | FMI: 3
Aftertreatment 1 Particulate Sensor Power Supply - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment particulate matter sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000084

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment Particulate sensor: 6651, 6652, 6653, 6688

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment particulate matter sensor is malfunctioning

Solution: S00000913

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 17-Apr-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 5578 | SPN: 6778 | FMI: 4
Aftertreatment 1 Particulate Sensor Power Supply - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment particulate matter sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000083

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment Particulate sensor: 6651, 6652, 6653, 6688

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment particulate matter sensor is malfunctioning

Solution: S00000913

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 17-Apr-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 5579 | SPN: 6778 | FMI: 16
Aftertreatment 1 Particulate Sensor Power Supply - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Aftertreatment particulate matter sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000081

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment Particulate sensor: 6651, 6652, 6653, 6688

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment particulate matter sensor is malfunctioning

Solution: S00000913

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 5581 | SPN: 7329 | FMI: 2
Aftertreatment 1 Particulate Sensor Heater Power Supply - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Aftertreatment particulate matter sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000076

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment Particulate sensor: 6651, 6652, 6653, 6688

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment particulate matter sensor is malfunctioning

Solution: S00000913

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 5582 | SPN: 7854 | FMI: 2
Aftertreatment 1 Particulate Sensor Module Battery Voltage Supply - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment particulate matter sensor voltage check
  3. Aftertreatment particulate matter sensor battery SUPPLY to block ground check
  4. ECM calibration revision history check
  5. Aftertreatment particulate matter sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000075

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Voltage: 441, 442, 596, 597, 598, 1939, 1941, 6256, 6257, 6499
  • Aftertreatment Particulate sensor: 6688

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment particulate matter sensor voltage check

Solution: S00001006

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment particulate matter sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment particulate matter sensor battery voltage SUPPLY pin and the aftertreatment particulate matter sensor RETURN pin at the particulate matter sensor OEM wiring harness connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

For general voltage measurement techniques.

Refer to Procedure 019-359

Check the voltage at key ON, while cranking the engine, and with the engine at idle.

Specification

  • Proceed to the next solution if voltage is within the following specification of battery voltage: 1 VDC
  • Proceed to the Linked Solutions section if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

Click on the link below:

  • Aftertreatment particulate matter sensor battery SUPPLY to block ground check

Refer to S00001007

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Aftertreatment particulate matter sensor battery SUPPLY to block ground check

Solution: S00001007

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment particulate matter sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Turn keyswitch ON.
  • Measure the voltage from the aftertreatment particulate matter sensor battery voltage SUPPLY pin of the OEM wiring harness to engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

For general voltage measurement techniques.

Refer to Procedure 019-359

Specification

  • An open circuit or high resistance has been detected in the aftertreatment particulate matter sensor battery voltage RETURN circuit if the voltage is within the following specification of battery voltage: 1 VDC
  • An open circuit or high resistance has been detected in the aftertreatment particulate matter sensor battery voltage SUPPLY circuit if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment particulate matter sensor is malfunctioning

Solution: S00000913

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 5583 | SPN: 6777 | FMI: 10
Aftertreatment 1 Particulate Sensor Detection Status - Abnormal Rate of Change

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Aftertreatment particulate matter sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000073

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment Particulate sensor: 6688

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment particulate matter sensor is malfunctioning

Solution: S00000913

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 5584 | SPN: 6773 | FMI: 7
Aftertreatment 1 Particulate Sensor Regeneration Status - Mechanical System Not Responding or Out of Adjustment

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Aftertreatment particulate matter sensor is damaged

1 - Check for primary fault codes

Solution: S00000072

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment Particulate sensor: 5582, 5583, 6651, 6652, 6653, 6688

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment particulate matter sensor is damaged

Solution: S00007912

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 5655 | SPN: 4364 | FMI: 31
Aftertreatment 1 SCR Conversion Efficiency - Condition Exists

Troubleshooting Summary

  1. Fault Code 5655 requires that ALL solutions be performed
  2. Check for primary fault codes
  3. Aftertreatment diesel exhaust fluid is contaminated
  4. Aftertreatment exhaust system leaks
  5. Leaks in the aftertreatment diesel exhaust fluid dosing system
  6. Aftertreatment Diesel Exhaust Fluid Doser Pump Override test
  7. Aftertreatment diesel exhaust fluid dosing valve is malfunctioning
  8. Aftertreatment SCR System Test
  9. Aftertreatment diesel exhaust fluid dosing system test failed
  10. Aftertreatment intake NOx sensor failed
  11. Aftertreatment outlet NOx sensor - Inspection
  12. Inspect both aftertreatment NOx sensors
  13. Aftertreatment SCR Catalyst Test Failed
  14. ECM calibration revision history check

1 - Fault Code 5655 requires that ALL solutions be performed

Solution: S00007691

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • This solution is information only.
  • ALL solutions displayed for this fault code must be performed.
  • Continue to perform the verifications of ALL solution steps listed for this fault code regardless if a given solution is within specification or out of specification.

Specification

  • This solution is information only.

Linked Solutions

  • None

Repair

  • If a resolution is found in any solution for this fault code, continue performing ALL solutions listed for this fault code.

Validation

  • None
Next Solution

2 - Check for primary fault codes

Solution: S00000071

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment NOx: 1885, 1887, 2771, 3228, 3232, 3545, 3583, 3649, 3681, 3682, 3717, 3718, 3725, 3748, 3749, 4452
  • Aftertreatment outlet oxygen: 4749, 4751, 5656
  • Aftertreatment intake oxygen: 4747, 4748
  • Aftertreatment SCR: 3142, 3146, 3147, 3148, 3165, 4164, 4166, 4518, 4519, 4521, 4524, 4525, 6266, 6267, 6268, 8363
  • Aftertreatment diesel exhaust fluid system: 1668, 1669, 1673, 1682, 3497, 3498, 3571, 3572, 3574, 3575, 4677, 4732, 4739, 5278
  • Aftertreatment diesel exhaust fluid dosing unit: 3558, 3559
  • Ambient air temperature: 249, 256, 2398

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

3 - Aftertreatment diesel exhaust fluid is contaminated

Solution: S00000563

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Use a diesel exhaust fluid refractometer to measure the concentration of the diesel exhaust fluid in the tank.

Refer to Service Bulletin 4021566

Specification

  • If there are signs of contaminates in the aftertreatment diesel exhaust fluid, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to Procedure 011-056

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment exhaust system leaks

Solution: S00001008

Verification

Conditions

  • Engine running.

Action

  • Visually inspect for leaks in the exhaust manifold to head.

Refer to Procedure 010-024

  • Visually inspect for leaks from the turbocharger to exhaust manifold.

Refer to Procedure 010-024

  • Visually inspect for leaks in the exhaust plumbing between the turbocharger outlet and the Aftertreatment DOC intake connection.

Refer to Procedure 010-024

  • Visually inspect the exhaust piping for leaks, cracks, and loose connections.

Refer to Procedure 010-024

  • Inspect for leaks at the aftertreatment DOC housing, sensor ports and connection points.

Refer to Procedure 010-024

  • Visually inspect the aftertreatment and SCR components for exhaust leaks.

Refer to Procedure 010-024

Specification

  • If there is any damage or leaks found in the exhaust system, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the exhaust manifold.

Refer to Procedure 011-007

  • Repair or replace the exhaust plumbing.

Refer to Procedure 011-007

Refer to OEM Service Manual

  • Replace aftertreatment DOC.

Refer to Procedure 011-049

  • Replace the aftertreatment diesel particulate filter.

Refer to Procedure 011-041

  • Replace the aftertreatment SCR Catalyst.

Refer to Procedure 011-036

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Leaks in the aftertreatment diesel exhaust fluid dosing system

Solution: S00002840

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-080

  • While the test is running, inspect the diesel exhaust fluid tank connectors, diesel exhaust fluid dosing unit and dosing unit connectors, diesel exhaust fluid lines, and diesel exhaust fluid dosing valve for signs of external leaks.

Specification

  • If a line, fitting, connection, or dosing unit is leaking, then a malfunction has been detected in the aftertreatment diesel exhaust fluid system or dosing unit.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Repair or replace the leaking diesel exhaust fluid line, connector or fitting.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment Diesel Exhaust Fluid Doser Pump Override test

Solution: S00002761

Verification

Conditions

  • Reconnect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank if they have been previously disconnected during troubleshooting.

Action

  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.

Refer to Procedure 011-059

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

The Aftertreatment Diesel Exhaust Fluid Doser Pump Override test can only be ran twice before a key cycle needs to be performed.

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test meets the specification, then proceed to the next solution.
  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test does not meet the specification, then proceed to the Linked Solutions section.

Linked Solutions

Click on the link below:

  • Aftertreatment diesel exhaust fluid dosing valve is malfunctioning

Refer to S00002764

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6.1 - Aftertreatment diesel exhaust fluid dosing valve is malfunctioning

Solution: S00002764

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Clean the aftertreatment diesel exhaust fluid dosing valve.
  • Turn keyswitch ON.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

7 - Aftertreatment SCR System Test

Solution: S00000541

Verification

Conditions

  • Connect all components.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment SCR System Test.

Refer to Procedure 014-025

If the Aftertreatment SCR System Test is not available on the recommended Cummins® electronic service tool or equivalent, update to the latest ECM Calibration Revision and then perform the Aftertreatment SCR System Test.

Specification

  • If the Aftertreatment SCR System Test does not pass, then proceed to the Linked Solutions section.

If the Aftertreatment SCR System Test does not activate, then reset the Search to Aftertreatment SCR System Test does not activate.

If the Aftertreatment SCR System Test does not complete, then reset the Search to Aftertreatment SCR System Test does not complete.

If the Aftertreatment SCR System Test displays "Deposit Burn Failed", the test should keep running and no repair action is required unless a Aftertreatment Intake or Outlet NOx sensor failure is detected.

Linked Solutions

  • Aftertreatment diesel exhaust fluid dosing system test failed

Refer to S00000552

  • Aftertreatment intake NOx sensor failed

Refer to S00000867

  • Aftertreatment outlet NOx sensor - Inspection

Refer to S00000567

  • Inspect both aftertreatment NOx sensors

Refer to S00000566

  • Aftertreatment SCR catalyst test failed

Refer to S00000565

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

7.1 - Aftertreatment diesel exhaust fluid dosing system test failed

Solution: S00000552

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If there are signs of contaminates in the diesel exhaust fluid, then proceed to the Repair section.
  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump override test displays FAILED, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to OEM Service Manual

  • For a Aftertreatment Diesel Exhaust Fluid Doser Pump override test displaying FAILED, then follow the repair instructions in the procedure.

Refer to Procedure 011-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

7.2 - Aftertreatment intake NOx sensor failed

Solution: S00000867

Verification

Conditions

  • None

Action

  • Verify that the aftertreatment intake NOx sensor is displayed as FAILED.

Specification

  • If the SCR System test displays that the intake NOx sensor has FAILED, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

7.3 - Aftertreatment outlet NOx sensor - Inspection

Solution: S00000567

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the decomposition tube for deposits.

Refer to Procedure 011-062

  • Visually inspect the aftertreatment diesel exhaust fluid tank connections for cracks or pitting.

Refer to OEM Service Manual

  • Connect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank.
  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-080

  • While the test is running, inspect the diesel exhaust fluid tank connectors, diesel exhaust fluid dosing unit and dosing unit connectors, diesel exhaust fluid lines, and diesel exhaust fluid dosing valve for signs of external leaks.

Specification

  • If the aftertreatment diesel exhaust fluid dosing valve is not leaking and there are no deposits in the decomposition tube, then a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Clean and install the decomposition tube.

Refer to Procedure 011-062

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

7.4 - Inspect both aftertreatment NOx sensors

Solution: S00000566

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the decomposition tube for deposits.

Refer to Procedure 011-062

  • Visually inspect the aftertreatment diesel exhaust fluid tank connections for cracks or pitting.

Refer to OEM Service Manual

  • Connect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank.
  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-080

  • Verify proper sealing at all connection points, including diesel exhaust fluid tank, dosing unit, and dosing valve.

Specification

  • If the aftertreatment diesel exhaust fluid dosing valve is not leaking and there are no deposits in the decomposition tube, then a malfunctioning aftertreatment intake NOx sensor and a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Clean and install the decomposition tube.

Refer to Procedure 011-062

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

7.5 - Aftertreatment SCR Catalyst Test Failed

Solution: S00000565

Verification

Conditions

  • Reconnect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank if they have been previously disconnected during troubleshooting.

Action

The aftertreatment diesel exhaust fluid dosing valve must be removed and placed in a measuring container greater then 1.5 liter [50 oz] capacity to perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override test.

The Aftertreatment Diesel Exhaust Fluid Doser Pump Override test can only be ran twice before a key cycle needs to be performed.

  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is not within specification, then proceed to the Repair section.
  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is within specification, then a malfunctioning aftertreatment SCR Catalyst has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Replace the aftertreatment SCR Catalyst.

Refer to Procedure 011-036

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

8 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 5689 | SPN: 3226 | FMI: 11
Aftertreatment 1 Outlet NOx Sensor - Root Cause Not Known

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment exhaust system leaks
  3. ECM calibration revision history check
  4. Aftertreatment outlet NOx sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000069

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Voltage: 1941
  • Aftertreatment NOx: 1887, 2771, 3583, 3681, 3682, 3749, 4528, 4529, 6582
  • Aftertreatment outlet oxygen: 4749

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment exhaust system leaks

Solution: S00001008

Verification

Conditions

  • Engine running.

Action

  • Visually inspect for leaks in the exhaust manifold to head.

Refer to Procedure 010-024

  • Visually inspect for leaks from the turbocharger to exhaust manifold.

Refer to Procedure 010-024

  • Visually inspect for leaks in the exhaust plumbing between the turbocharger outlet and the Aftertreatment DOC intake connection.

Refer to Procedure 010-024

  • Visually inspect the exhaust piping for leaks, cracks, and loose connections.

Refer to Procedure 010-024

  • Inspect for leaks at the aftertreatment DOC housing, sensor ports and connection points.

Refer to Procedure 010-024

  • Visually inspect the aftertreatment and SCR components for exhaust leaks.

Refer to Procedure 010-024

Specification

  • If there is any damage or leaks found in the exhaust system, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the exhaust manifold.

Refer to Procedure 011-007

  • Repair or replace the exhaust plumbing.

Refer to Procedure 011-007

Refer to OEM Service Manual

  • Replace aftertreatment DOC.

Refer to Procedure 011-049

  • Replace the aftertreatment diesel particulate filter.

Refer to Procedure 011-041

  • Replace the aftertreatment SCR Catalyst.

Refer to Procedure 011-036

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment outlet NOx sensor is malfunctioning

Solution: S00000994

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 5715 | SPN: 3251 | FMI: 10
Aftertreatment 1 Diesel Particulate Filter Differential Pressure - Abnormal Rate of Change

Troubleshooting Summary

  1. Check for primary fault codes
  2. Damaged or missing aftertreatment DPF differential pressure sensor tubes
  3. Aftertreatment DPF differential pressure sensor voltage check
  4. Aftertreatment DPF differential pressure sensor circuit check
  5. Aftertreatment DPF differential pressure sensor stuck in-range
  6. Aftertreatment DPF differential pressure sensor open circuit check
  7. Aftertreatment DPF differential pressure sensor circuit pin to ground short
  8. Aftertreatment DPF differential pressure sensor wire pin to pin short circuit check
  9. ECM calibration revision history check
  10. Aftertreatment DPF differential pressure sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000068

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment differential pressure: 1879, 1881

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Damaged or missing aftertreatment DPF differential pressure sensor tubes

Solution: S00001010

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the aftertreatment differential pressure tubes for proper installation.
  • Inspect the aftertreatment DPF differential pressure sensor tubes for signs of damage, plugging, kinks, leakage or loose connections.

Refer to Procedure 011-047

In extreme cold ambient temperatures it is important to check for a frozen, plugged, or restricted aftertreatment DPF differential pressure sensor tubes. Ice can form in the aftertreatment DPF differential pressure sensor tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Specification

  • If damage, kinks or blockages are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace DPF differential pressure sensor tubes.

Refer to Procedure 011-047

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

3 - Aftertreatment DPF differential pressure sensor voltage check

Solution: S00001246

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment DPF differential/outlet pressure sensor SUPPLY pin and the aftertreatment DPF differential/outlet pressure sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section and perform the open circuit check if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Aftertreatment DPF differential pressure sensor circuit check

Refer to S00001247

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Aftertreatment DPF differential pressure sensor circuit check

Solution: S00001247

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment DPF differential pressure sensor SUPPLY pin and the OEM wiring harness aftertreatment DPF differential pressure sensor connector SUPPLY pin.
  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment DPF differential pressure sensor RETURN pin and the OEM wiring harness aftertreatment DPF differential pressure sensor connector RETURN pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω
  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Aftertreatment DPF differential pressure sensor stuck in-range

Solution: S00000793

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the aftertreatment DPF differential pressure sensor voltage.

Refer to Procedure 019-443

Specification

  • If the aftertreatment DPF differential pressure sensor voltage readings are not within specification, then a malfunctioning aftertreatment DPF differential pressure sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment DPF differential pressure sensor open circuit check

Solution: S00000996

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment diesel particulate filter differential pressure sensor SIGNAL pin and the OEM wiring harness aftertreatment diesel particulate filter differential pressure sensor connector SIGNAL pin.
  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment diesel particulate filter differential pressure sensor SUPPLY pin and the OEM wiring harness aftertreatment diesel particulate filter differential pressure sensor connector SUPPLY pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment DPF differential pressure sensor circuit pin to ground short

Solution: S00001539

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF outlet pressure sensor SIGNAL pin in the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Aftertreatment DPF differential pressure sensor wire pin to pin short circuit check

Solution: S00007439

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the remote accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the fuel level sensor from the OEM wiring harness.
  • Disconnect the fan speed sensor from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM wiring harness.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SIGNAL pin in the OEM wiring harness ECM connector and all other pins in the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment DPF differential pressure sensor SUPPLY pin in the OEM wiring harness ECM connector and all other pins in the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Aftertreatment DPF differential pressure sensor is malfunctioning

Solution: S00002710

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all preceding solution verifications have been performed, then a malfunctioning aftertreatment DPF differential pressure sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 5716 | SPN: 3610 | FMI: 10
Aftertreatment 1 Diesel Particulate Filter Outlet Pressure - Abnormal Rate of Change

Troubleshooting Summary

  1. Check for primary fault codes
  2. Damaged or missing aftertreatment DPF differential pressure sensor tubes
  3. Aftertreatment DPF outlet pressure sensor voltage check
  4. Aftertreatment DPF outlet pressure sensor circuit check
  5. Aftertreatment DPF differential pressure sensor stuck in-range
  6. Aftertreatment DPF differential pressure sensor open circuit check
  7. Aftertreatment DPF outlet pressure circuit pin to ground short
  8. Aftertreatment DPF differential pressure sensor wire pin to pin short circuit check
  9. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000066

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment DPF: 3133, 3134

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Damaged or missing aftertreatment DPF differential pressure sensor tubes

Solution: S00001010

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the aftertreatment differential pressure tubes for proper installation.
  • Inspect the aftertreatment DPF differential pressure sensor tubes for signs of damage, plugging, kinks, leakage or loose connections.

Refer to Procedure 011-047

In extreme cold ambient temperatures it is important to check for a frozen, plugged, or restricted aftertreatment DPF differential pressure sensor tubes. Ice can form in the aftertreatment DPF differential pressure sensor tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Specification

  • If damage, kinks or blockages are found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Repair or replace DPF differential pressure sensor tubes.

Refer to Procedure 011-047

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

3 - Aftertreatment DPF outlet pressure sensor voltage check

Solution: S00001104

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF outlet pressure sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment DPF differential/outlet pressure sensor SUPPLY pin and the aftertreatment DPF differential/outlet pressure sensor RETURN pin at the sensor connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 VDC - 5.25 VDC

Linked Solutions

  • Aftertreatment DPF outlet pressure sensor circuit check

Refer to S00001103

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3.1 - Aftertreatment DPF outlet pressure sensor circuit check

Solution: S00001103

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF outlet pressure sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment DPF outlet pressure sensor SUPPLY pin and the OEM wiring harness aftertreatment DPF outlet pressure sensor connector SUPPLY pin.
  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment DPF outlet pressure sensor RETURN pin and the OEM wiring harness aftertreatment DPF outlet pressure sensor connector RETURN pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Aftertreatment DPF differential pressure sensor stuck in-range

Solution: S00000793

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the aftertreatment DPF differential pressure sensor voltage.

Refer to Procedure 019-443

Specification

  • If the aftertreatment DPF differential pressure sensor voltage readings are not within specification, then a malfunctioning aftertreatment DPF differential pressure sensor has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Aftertreatment DPF differential pressure sensor open circuit check

Solution: S00000996

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment diesel particulate filter differential pressure sensor SIGNAL pin and the OEM wiring harness aftertreatment diesel particulate filter differential pressure sensor connector SIGNAL pin.
  • Measure the resistance between the OEM wiring harness ECM connector aftertreatment diesel particulate filter differential pressure sensor SUPPLY pin and the OEM wiring harness aftertreatment diesel particulate filter differential pressure sensor connector SUPPLY pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment DPF outlet pressure circuit pin to ground short

Solution: S00002790

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential/outlet pressure sensor from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF outlet pressure sensor SIGNAL pin in the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Aftertreatment DPF differential pressure sensor wire pin to pin short circuit check

Solution: S00007439

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the remote accelerator pedal or lever from the OEM wiring harness.
  • Disconnect the engine coolant level sensor from the OEM wiring harness.
  • Disconnect the fuel level sensor from the OEM wiring harness.
  • Disconnect the fan speed sensor from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor from the OEM wiring harness.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM wiring harness.
  • Disconnect the aftertreatment diesel exhaust fluid dosing unit from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SIGNAL pin in the OEM wiring harness ECM connector and all other pins in the OEM wiring harness ECM connector.
  • Measure the resistance between the aftertreatment DPF differential pressure sensor SUPPLY pin in the OEM wiring harness ECM connector and all other pins in the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 5792 | SPN: 7321 | FMI: 4
Aftertreatment 1 Particulate Sensor Heater High Side Driver Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Low battery voltage
  3. Aftertreatment particulate matter sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000065

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment Particulate sensor: 5582, 5583, 6651, 6652, 6653, 6688

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Low battery voltage

Solution: S00000536

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the battery voltage.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal while trying to start the engine.
  • Visually inspect the batteries and the battery cable connections for corrosion.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.

Linked Solutions

  • None

Repair

  • Charge or replace the batteries.

Refer to OEM Service Manual

  • Clean corrosion or tighten battery cable connections.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment particulate matter sensor is malfunctioning

Solution: S00000913

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 5793 | SPN: 7323 | FMI: 3
Aftertreatment 1 Particulate Sensor Heater Low Side Driver Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment particulate matter sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000064

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment Particulate sensor: 5582, 5583, 6651, 6652, 6653, 6688

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment particulate matter sensor is malfunctioning

Solution: S00000913

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 17-Apr-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 5837 | SPN: 5835 | FMI: 21
Aftertreatment 1 Particulate Sensor - Data Not Rational - Drifted Low

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Aftertreatment particulate matter sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000063

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment Particulate sensor: 5582, 5583, 6688
  • Aftertreatment DPF: 6651, 6652, 6653

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment particulate matter sensor is malfunctioning

Solution: S00000913

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 5868 | SPN: 4339 | FMI: 7
Aftertreatment 1 SCR Feedback Control Status - Mechanical System Not Responding or Out of Adjustment

Troubleshooting Summary

  1. Fault Code 5868 requires that ALL solutions be performed
  2. Check for primary fault codes
  3. Aftertreatment diesel exhaust fluid is contaminated
  4. Aftertreatment exhaust system leaks
  5. Leaks in the aftertreatment diesel exhaust fluid dosing system
  6. Aftertreatment Diesel Exhaust Fluid Doser Pump Override test
  7. Aftertreatment diesel exhaust fluid dosing valve is malfunctioning
  8. Aftertreatment SCR System Test
  9. Aftertreatment diesel exhaust fluid dosing system test failed
  10. Aftertreatment intake NOx sensor failed
  11. Aftertreatment outlet NOx sensor - Inspection
  12. Inspect both aftertreatment NOx sensors
  13. Aftertreatment SCR Catalyst Test Failed
  14. ECM calibration revision history check

1 - Fault Code 5868 requires that ALL solutions be performed

Solution: S00002767

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • This solution is information only.
  • ALL solutions displayed for this fault code must be performed.
  • Continue to perform the verifications of ALL solution steps listed for this fault code regardless if a given solution is within specification or out of specification.

Specification

  • This solution is information only.

Linked Solutions

  • None

Repair

  • If a resolution is found in any solution for this fault code, continue performing ALL solutions listed for this fault code.

Validation

  • None
Next Solution

2 - Check for primary fault codes

Solution: S00001421

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment NOx: 1694, 1885, 1887, 2771, 3228, 3232, 3545, 3717, 3718, 3725, 3748, 3749, 4452, 5689, 6245
  • Aftertreatment SCR: 3899, 3911, 3912, 3932, 3933, 3934, 3935, 3936, 3937, 4279, 4281, 4453
  • Aftertreatment diesel exhaust fluid system: 1682, 3567, 3568, 3571, 3572, 3574, 3575, 3577, 3578, 4157, 4658
  • Aftertreatment diesel exhaust fluid dosing unit: 2976, 3558, 3559
  • EGR: 3382, 3383
  • Ambient air temperature: 249, 256, 2398

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

3 - Aftertreatment diesel exhaust fluid is contaminated

Solution: S00000563

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Use a diesel exhaust fluid refractometer to measure the concentration of the diesel exhaust fluid in the tank.

Refer to Service Bulletin 4021566

Specification

  • If there are signs of contaminates in the aftertreatment diesel exhaust fluid, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to Procedure 011-056

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Aftertreatment exhaust system leaks

Solution: S00001008

Verification

Conditions

  • Engine running.

Action

  • Visually inspect for leaks in the exhaust manifold to head.

Refer to Procedure 010-024

  • Visually inspect for leaks from the turbocharger to exhaust manifold.

Refer to Procedure 010-024

  • Visually inspect for leaks in the exhaust plumbing between the turbocharger outlet and the Aftertreatment DOC intake connection.

Refer to Procedure 010-024

  • Visually inspect the exhaust piping for leaks, cracks, and loose connections.

Refer to Procedure 010-024

  • Inspect for leaks at the aftertreatment DOC housing, sensor ports and connection points.

Refer to Procedure 010-024

  • Visually inspect the aftertreatment and SCR components for exhaust leaks.

Refer to Procedure 010-024

Specification

  • If there is any damage or leaks found in the exhaust system, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the exhaust manifold.

Refer to Procedure 011-007

  • Repair or replace the exhaust plumbing.

Refer to Procedure 011-007

Refer to OEM Service Manual

  • Replace aftertreatment DOC.

Refer to Procedure 011-049

  • Replace the aftertreatment diesel particulate filter.

Refer to Procedure 011-041

  • Replace the aftertreatment SCR Catalyst.

Refer to Procedure 011-036

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Leaks in the aftertreatment diesel exhaust fluid dosing system

Solution: S00002840

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-080

  • While the test is running, inspect the diesel exhaust fluid tank connectors, diesel exhaust fluid dosing unit and dosing unit connectors, diesel exhaust fluid lines, and diesel exhaust fluid dosing valve for signs of external leaks.

Specification

  • If a line, fitting, connection, or dosing unit is leaking, then a malfunction has been detected in the aftertreatment diesel exhaust fluid system or dosing unit.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Repair or replace the leaking diesel exhaust fluid line, connector or fitting.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Aftertreatment Diesel Exhaust Fluid Doser Pump Override test

Solution: S00002761

Verification

Conditions

  • Reconnect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank if they have been previously disconnected during troubleshooting.

Action

  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.

Refer to Procedure 011-059

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

The Aftertreatment Diesel Exhaust Fluid Doser Pump Override test can only be ran twice before a key cycle needs to be performed.

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test meets the specification, then proceed to the next solution.
  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test does not meet the specification, then proceed to the Linked Solutions section.

Linked Solutions

Click on the link below:

  • Aftertreatment diesel exhaust fluid dosing valve is malfunctioning

Refer to S00002764

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6.1 - Aftertreatment diesel exhaust fluid dosing valve is malfunctioning

Solution: S00002764

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Clean the aftertreatment diesel exhaust fluid dosing valve.
  • Turn keyswitch ON.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is not within specification, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Replace aftertreatment diesel exhaust fluid dosing unit.

Refer to Procedure 011-058

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

7 - Aftertreatment SCR System Test

Solution: S00000541

Verification

Conditions

  • Connect all components.

Action

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment SCR System Test.

Refer to Procedure 014-025

If the Aftertreatment SCR System Test is not available on the recommended Cummins® electronic service tool or equivalent, update to the latest ECM Calibration Revision and then perform the Aftertreatment SCR System Test.

Specification

  • If the Aftertreatment SCR System Test does not pass, then proceed to the Linked Solutions section.

If the Aftertreatment SCR System Test does not activate, then reset the Search to Aftertreatment SCR System Test does not activate.

If the Aftertreatment SCR System Test does not complete, then reset the Search to Aftertreatment SCR System Test does not complete.

If the Aftertreatment SCR System Test displays "Deposit Burn Failed", the test should keep running and no repair action is required unless a Aftertreatment Intake or Outlet NOx sensor failure is detected.

Linked Solutions

  • Aftertreatment diesel exhaust fluid dosing system test failed

Refer to S00000552

  • Aftertreatment intake NOx sensor failed

Refer to S00000867

  • Aftertreatment outlet NOx sensor - Inspection

Refer to S00000567

  • Inspect both aftertreatment NOx sensors

Refer to S00000566

  • Aftertreatment SCR catalyst test failed

Refer to S00000565

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

7.1 - Aftertreatment diesel exhaust fluid dosing system test failed

Solution: S00000552

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the aftertreatment diesel exhaust fluid in the tank for signs of debris or contamination.

Refer to Procedure 011-056

  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If there are signs of contaminates in the diesel exhaust fluid, then proceed to the Repair section.
  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump override test displays FAILED, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Drain the diesel exhaust fluid tank, clean thoroughly and refill with pure diesel exhaust fluid.

Refer to OEM Service Manual

  • For a Aftertreatment Diesel Exhaust Fluid Doser Pump override test displaying FAILED, then follow the repair instructions in the procedure.

Refer to Procedure 011-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

7.2 - Aftertreatment intake NOx sensor failed

Solution: S00000867

Verification

Conditions

  • None

Action

  • Verify that the aftertreatment intake NOx sensor is displayed as FAILED.

Specification

  • If the SCR System test displays that the intake NOx sensor has FAILED, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

7.3 - Aftertreatment outlet NOx sensor - Inspection

Solution: S00000567

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the decomposition tube for deposits.

Refer to Procedure 011-062

  • Visually inspect the aftertreatment diesel exhaust fluid tank connections for cracks or pitting.

Refer to OEM Service Manual

  • Connect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank.
  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-080

  • While the test is running, inspect the diesel exhaust fluid tank connectors, diesel exhaust fluid dosing unit and dosing unit connectors, diesel exhaust fluid lines, and diesel exhaust fluid dosing valve for signs of external leaks.

Specification

  • If the aftertreatment diesel exhaust fluid dosing valve is not leaking and there are no deposits in the decomposition tube, then a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Clean and install the decomposition tube.

Refer to Procedure 011-062

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

7.4 - Inspect both aftertreatment NOx sensors

Solution: S00000566

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the decomposition tube for deposits.

Refer to Procedure 011-062

  • Visually inspect the aftertreatment diesel exhaust fluid tank connections for cracks or pitting.

Refer to OEM Service Manual

  • Connect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank.
  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid System Leak Test found under ECM Diagnostic Tests.

Refer to Procedure 011-080

  • Verify proper sealing at all connection points, including diesel exhaust fluid tank, dosing unit, and dosing valve.

Specification

  • If the aftertreatment diesel exhaust fluid dosing valve is not leaking and there are no deposits in the decomposition tube, then a malfunctioning aftertreatment intake NOx sensor and a malfunctioning aftertreatment outlet NOx sensor has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Clean and install the decomposition tube.

Refer to Procedure 011-062

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

7.5 - Aftertreatment SCR Catalyst Test Failed

Solution: S00000565

Verification

Conditions

  • Reconnect all aftertreatment diesel exhaust fluid lines and electrical connectors to the dosing unit and aftertreatment diesel exhaust fluid tank if they have been previously disconnected during troubleshooting.

Action

The aftertreatment diesel exhaust fluid dosing valve must be removed and placed in a measuring container greater then 1.5 liter [50 oz] capacity to perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override test.

The Aftertreatment Diesel Exhaust Fluid Doser Pump Override test can only be ran twice before a key cycle needs to be performed.

  • Remove the aftertreatment diesel exhaust fluid dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test.

Refer to Procedure 011-063

Specification

  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is not within specification, then proceed to the Repair section.
  • If the Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test is within specification, then a malfunctioning aftertreatment SCR Catalyst has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid dosing valve.

Refer to Procedure 011-059

  • Replace the aftertreatment SCR Catalyst.

Refer to Procedure 011-036

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

8 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 5879 | SPN: 3464 | FMI: 3
Electronic Throttle Control Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Technical Service Bulletin is available
  2. Open circuit in the engine intake throttle actuator motor
  3. Engine intake throttle actuator motor resistance check
  4. Engine intake throttle actuator motor open circuit check
  5. Intake throttle control actuator motor circuit pin to pin short

1 - Technical Service Bulletin is available

Solution: S00008863

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb190003

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Open circuit in the engine intake throttle actuator motor

Solution: S00000804

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine intake throttle actuator motor SIGNAL pin and the engine intake throttle actuator motor connector RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the resistance is greater than the following specification: 15 Ω

Linked Solutions

Click on the link below:

  • Engine intake throttle actuator motor resistance check

Refer to S00000805

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Engine intake throttle actuator motor resistance check

Solution: S00000805

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine intake throttle actuator motor SIGNAL pin and the engine intake throttle actuator motor RETURN pin at the engine intake throttle actuator motor connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine intake throttle actuator motor has been detected if the resistance is greater than the following specification: 15 Ω
  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 15 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the engine intake throttle actuator.

Refer to Procedure 010-140

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Engine intake throttle actuator motor open circuit check

Solution: S00000494

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine intake throttle actuator motor SUPPLY pin at the engine intake throttle actuator engine wiring harness connector and the engine intake throttle actuator SUPPLY pin at the engine wiring harness ECM connector.
  • Measure the resistance between the engine intake throttle actuator motor SIGNAL pin at the engine intake throttle actuator engine wiring harness connector and the engine intake throttle actuator SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the engine intake throttle actuator motor RETURN pin at the engine intake throttle actuator engine wiring harness connector and the engine intake throttle actuator RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Intake throttle control actuator motor circuit pin to pin short

Solution: S00000800

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the intake throttle actuator motor SIGNAL pin at the ECM connector of the engine wiring harness and all other pins at that connector.
  • Measure the resistance between the intake throttle actuator motor RETURN pin at the ECM connector of the engine wiring harness and all other pins at that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 17-Apr-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 5881 | SPN: 3464 | FMI: 4
Electronic Throttle Control Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Technical Service Bulletin is available
  2. Engine intake throttle actuator motor shorted to ground
  3. Engine intake throttle actuator circuit pin to ground short
  4. Intake throttle control actuator motor circuit pin to pin short

1 - Technical Service Bulletin is available

Solution: S00008863

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Technical Service Bulletin is available.

Refer to tsb190003

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Engine intake throttle actuator motor shorted to ground

Solution: S00000493

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine intake throttle actuator motor SIGNAL pin and ground.
  • Measure the resistance between the engine intake throttle actuator motor RETURN pin and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine intake throttle actuator motor has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Replace the engine intake throttle actuator.

Refer to Procedure 010-140

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine intake throttle actuator circuit pin to ground short

Solution: S00000492

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine intake throttle actuator motor SUPPLY pin at the ECM connector of the engine wiring harness and engine block ground.
  • Measure the resistance between the engine intake throttle actuator motor RETURN pin at the ECM connector of the engine wiring harness and engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Intake throttle control actuator motor circuit pin to pin short

Solution: S00000800

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the intake throttle actuator motor SIGNAL pin at the ECM connector of the engine wiring harness and all other pins at that connector.
  • Measure the resistance between the intake throttle actuator motor RETURN pin at the ECM connector of the engine wiring harness and all other pins at that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 17-Apr-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 5882 | SPN: 3464 | FMI: 7
Electronic Throttle Control Actuator - Mechanical System Not Responding or Out of Adjustment

Troubleshooting Summary

  1. Restricted engine intake throttle
  2. Engine intake throttle actuator motor open circuit check
  3. ECM calibration revision history check
  4. Engine intake throttle actuator not responding or out of adjustment

1 - Restricted engine intake throttle

Solution: S00000495

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the engine intake throttle for restriction, stuck or debris blocking the throttle plate.

Refer to Procedure 010-140

Specification

  • If the throttle plate does not operate freely with no restriction, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Remove the obstruction.

Refer to Procedure 010-140

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Engine intake throttle actuator motor open circuit check

Solution: S00000494

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine intake throttle actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine intake throttle actuator motor SUPPLY pin at the engine intake throttle actuator engine wiring harness connector and the engine intake throttle actuator SUPPLY pin at the engine wiring harness ECM connector.
  • Measure the resistance between the engine intake throttle actuator motor SIGNAL pin at the engine intake throttle actuator engine wiring harness connector and the engine intake throttle actuator SIGNAL pin at the engine wiring harness ECM connector.
  • Measure the resistance between the engine intake throttle actuator motor RETURN pin at the engine intake throttle actuator engine wiring harness connector and the engine intake throttle actuator RETURN pin at the engine wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Engine intake throttle actuator not responding or out of adjustment

Solution: S00001034

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then a malfunctioning engine intake throttle actuator assembly has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine intake throttle actuator.

Refer to Procedure 010-140

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6244 | SPN: 5400 | FMI: 31
SCR Thermal Management - Condition Exists

Troubleshooting Summary

  1. ECM calibration update

1 - ECM calibration update

Solution: S00004914

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or has more than one inactive count within the last 25 engine operating hours, then the incorrect ECM calibration code has been detected.

Linked Solutions

  • None

Repair

  • Download the updated ECM calibration code.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 24-May-2020


NO TITLE

ISX15 CM2350 X101

Fault Code: 6254 | SPN: 5246 | FMI: 16
Aftertreatment SCR Operator Inducement Severity - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002630

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Voltage: 1117
  • Aftertreatment diesel exhaust fluid pressure: 3574, 3596
  • Aftertreatment diesel exhaust fluid dosing unit: 1682
  • Fuel: 4691
  • Aftertreatment SCR: 3582, 3712, 5655

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6255 | SPN: 1569 | FMI: 15
Engine Protection Torque Derate - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00002776

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid dosing unit: 1682, 4277, 6767
  • Aftertreatment SCR: 3712, 6254
  • Intake manifold: 5989

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6256 | SPN: 168 | FMI: 15
Battery 1 Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Battery or battery cables are malfunctioning
  2. Charging system alternator is malfunctioning
  3. ECM calibration revision history check

1 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Charging system alternator is malfunctioning

Solution: S00000532

Verification

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the charging system alternator and the battery.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Test the charging system alternator output.

Refer to Procedure 013-001

Specification

  • If the charging system alternator output does not meet specification, then a malfunctioning alternator has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the alternator.

Refer to Procedure 013-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6257 | SPN: 168 | FMI: 17
Battery 1 Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Battery or battery cables are malfunctioning
  2. Incorrect variable geometry turbocharger actuator for engine application
  3. Charging system alternator is malfunctioning
  4. Unswitched battery open circuit check
  5. Unswitched battery circuit pin to pin short
  6. OEM wiring harness pin to pin short circuit
  7. ECM calibration revision history check

1 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Incorrect variable geometry turbocharger actuator for engine application

Solution: S00001148

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the ECM calibration and make sure it is correct for the engine CPL.
  • Go to Features and Parameters.
  • Check the ECM code calibration voltage and make sure it is correct for the application.

Specification

  • If the ECM code matches the engine CPL, then an incorrect variable geometry turbocharger actuator has been installed.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the variable geometry turbocharger actuator.

Refer to Procedure 010-134

  • Adjust the features and parameters to the correct settings.

Refer to Procedure 019-078

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Charging system alternator is malfunctioning

Solution: S00000532

Verification

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the charging system alternator and the battery.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Test the charging system alternator output.

Refer to Procedure 013-001

Specification

  • If the charging system alternator output does not meet specification, then a malfunctioning alternator has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the alternator.

Refer to Procedure 013-001

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Unswitched battery open circuit check

Solution: S00005285

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the ECM battery SUPPLY (+) circuit between the OEM wiring harness ECM connector and the positive (+) terminal of the battery.
  • Measure the resistance of the ECM battery SUPPLY (-) circuit between the OEM wiring harness ECM connector and the positive (-) terminal of the battery.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Unswitched battery circuit pin to pin short

Solution: S00002997

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the ECM battery SUPPLY (+) pin of the OEM wiring harness ECM connector to all other pins in that connector.
  • Measure the resistance between the ECM battery SUPPLY (-) pin of the OEM wiring harness ECM connector to all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - OEM wiring harness pin to pin short circuit

Solution: S00003134

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power supply wiring harness connector from the ECM.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from one of the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to all pins in the that connector.
  • Measure the resistance from the second ECM battery SUPPLY (+) pin in the OEM power harness ECM connector to all pins in the that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace OEM power supply wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6258 | SPN: 1075 | FMI: 3
Electric Lift Pump for Engine Fuel Supply - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Electric fuel lift pump resistance check
  2. Electric fuel lift pump open circuit check
  3. Electric fuel lift pump circuit pin to pin short

1 - Electric fuel lift pump resistance check

Solution: S00001649

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electric fuel lift pump from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the electric fuel lift pump.

Refer to Procedure 005-045

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the electric fuel lift pump resistance is not within specification, then a malfunctioning electric fuel lift pump has been detected.

Linked Solutions

  • None

Repair

  • Replace the electric fuel lift pump.

Refer to Procedure 005-045

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Electric fuel lift pump open circuit check

Solution: S00001054

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the electric fuel lift pump from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel lift pump SUPPLY pin at the fuel lift pump wiring harness connector and the fuel lift pump SUPPLY pin at the ECM connector.
  • Measure the resistance between the fuel lift pump RETURN pin at the fuel lift pump wiring harness connector and the fuel lift pump RETURN pin at the ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

3 - Electric fuel lift pump circuit pin to pin short

Solution: S00000321

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the electric fuel lift pump from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel lift pump SUPPLY pin in the engine wiring harness ECM connector and all other pins in the engine wiring harness ECM connector.

Pins 14 and 15 are tied together in the wiring harness. These pins do not have to meet the 100K Ω resistance specification.

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Troubleshoot the engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6259 | SPN: 1075 | FMI: 4
Electric Lift Pump for Engine Fuel Supply - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Electric fuel lift pump open circuit check
  2. Electric fuel lift pump circuit pin to ground short
  3. Electric fuel lift pump circuit pin to pin short

1 - Electric fuel lift pump open circuit check

Solution: S00001054

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the electric fuel lift pump from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel lift pump SUPPLY pin at the fuel lift pump wiring harness connector and the fuel lift pump SUPPLY pin at the ECM connector.
  • Measure the resistance between the fuel lift pump RETURN pin at the fuel lift pump wiring harness connector and the fuel lift pump RETURN pin at the ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

2 - Electric fuel lift pump circuit pin to ground short

Solution: S00001055

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the electric fuel lift pump from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel lift pump SUPPLY pin in the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

3 - Electric fuel lift pump circuit pin to pin short

Solution: S00000321

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the electric fuel lift pump from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fuel lift pump SUPPLY pin in the engine wiring harness ECM connector and all other pins in the engine wiring harness ECM connector.

Pins 14 and 15 are tied together in the wiring harness. These pins do not have to meet the 100K Ω resistance specification.

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Troubleshoot the engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6261 | SPN: 677 | FMI: 3
Engine Starter Motor Relay Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Starter lockout relay is malfunctioning
  2. Starter lockout relay not enabled
  3. Starter lockout relay voltage circuit check
  4. Starter lockout relay circuit check at the ECM
  5. Starter lockout relay open circuit check
  6. Starter lockout relay circuit pin to pin short

1 - Starter lockout relay is malfunctioning

Solution: S00000637

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the starter lockout relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Starter lockout relay not enabled

Solution: S00000639

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify a starter lockout relay is installed.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Verify the starter lockout relay parameter is set correctly for the application.

Specification

  • If a starter lockout relay is installed and the parameter is not set to "Enable", then the incorrect adjustable parameter is configured.
  • If a starter lockout relay is not installed and the parameter is not set to "Disable", then the incorrect adjustable parameter is configured.

Linked Solutions

  • None

Repair

  • Adjust the features and parameters to the correct settings.

Refer to Procedure 019-078

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Starter lockout relay voltage circuit check

Solution: S00000644

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the starter lockout relay SIGNAL pin and the starter lockout relay RETURN pin at the starter lockout relay connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Starter lockout relay circuit check at the ECM

Refer to S00000646

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Starter lockout relay circuit check at the ECM

Solution: S00000646

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the starter lockout relay SIGNAL pin at the starter lockout relay connector and the starter lockout relay SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the starter lockout relay RETURN pin at the starter lockout relay connector and the starter lockout relay RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω
  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Starter lockout relay open circuit check

Solution: S00000642

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.
  • Measure the resistance between the starter lockout relay SIGNAL pin at the starter lockout relay connector of the OEM wiring harness and the starter lockout relay SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the starter lockout relay RETURN pin at the starter lockout relay connector of the OEM wiring harness and the starter lockout relay RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Starter lockout relay circuit pin to pin short

Solution: S00000643

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the starter lockout relay SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6262 | SPN: 677 | FMI: 4
Engine Starter Motor Relay Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Starter lockout relay is malfunctioning
  2. Starter lockout relay not enabled
  3. Starter lockout relay voltage circuit check
  4. Starter lockout relay circuit check at the ECM
  5. Starter lockout relay circuit pin to ground short
  6. Starter lockout relay circuit pin to pin short

1 - Starter lockout relay is malfunctioning

Solution: S00000637

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Check the relay.

Refer to Procedure 019-642

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the relay does not meet specification, then a malfunctioning relay has been detected.

Linked Solutions

  • None

Repair

  • Replace the starter lockout relay.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Starter lockout relay not enabled

Solution: S00000639

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify a starter lockout relay is installed.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Verify the starter lockout relay parameter is set correctly for the application.

Specification

  • If a starter lockout relay is installed and the parameter is not set to "Enable", then the incorrect adjustable parameter is configured.
  • If a starter lockout relay is not installed and the parameter is not set to "Disable", then the incorrect adjustable parameter is configured.

Linked Solutions

  • None

Repair

  • Adjust the features and parameters to the correct settings.

Refer to Procedure 019-078

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Starter lockout relay voltage circuit check

Solution: S00000644

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the starter lockout relay SIGNAL pin and the starter lockout relay RETURN pin at the starter lockout relay connector of the OEM wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if voltage is within the following specification: 4.75 - 5.25 VDC
  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

Click on the link below:

  • Starter lockout relay circuit check at the ECM

Refer to S00000646

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

3.1 - Starter lockout relay circuit check at the ECM

Solution: S00000646

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the starter lockout relay SIGNAL pin at the starter lockout relay connector and the starter lockout relay SIGNAL pin at the OEM wiring harness ECM connector.
  • Measure the resistance between the starter lockout relay RETURN pin at the starter lockout relay connector and the starter lockout relay RETURN pin at the OEM wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if the resistance is less than the following specification: 10 Ω
  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Starter lockout relay circuit pin to ground short

Solution: S00000650

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the starter lockout relay SIGNAL pin in the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Starter lockout relay circuit pin to pin short

Solution: S00000643

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM wiring harness.
  • Disconnect the OEM wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the starter lockout relay SIGNAL pin at the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6263 | SPN: 647 | FMI: 3
Fan Control Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Fan control solenoid open circuit check
  2. Fan control solenoid circuit pin to pin short
  3. Fan control solenoid is malfunctioning

1 - Fan control solenoid open circuit check

Solution: S00001057

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the fan control connector from the OEM wiring harness connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the OEM wiring harness engine control module fan control SIGNAL pin and the OEM wiring harness fan control connector SIGNAL pin.
  • Measure the resistance between the OEM wiring harness engine control module fan control RETURN pin and the OEM wiring harness fan control connector RETURN pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

2 - Fan control solenoid circuit pin to pin short

Solution: S00004897

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the fan control connector from the OEM wiring harness connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fan control SIGNAL pin of the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Fan control solenoid is malfunctioning

Solution: S00005653

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the fan control solenoid.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 15-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6264 | SPN: 647 | FMI: 4
Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Fan control solenoid resistance check
  2. Fan control solenoid circuit pin to ground short
  3. Fan control solenoid circuit pin to pin short
  4. Fan control solenoid is malfunctioning

1 - Fan control solenoid resistance check

Solution: S00001059

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance of the fan control solenoid.

Refer to OEM Service Manual

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the fan control solenoid resistance does not meet specification, then a malfunctioning fan control solenoid has been detected.

Refer to OEM Service Manual

Linked Solutions

  • None

Repair

  • Replace the fan control solenoid.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Fan control solenoid circuit pin to ground short

Solution: S00001060

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the fan control solenoid from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fan control SIGNAL pin of the OEM wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

3 - Fan control solenoid circuit pin to pin short

Solution: S00004897

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness connector from the ECM.
  • Disconnect the fan control connector from the OEM wiring harness connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the fan control SIGNAL pin of the OEM wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Fan control solenoid is malfunctioning

Solution: S00005653

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the fan control solenoid.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 15-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6265 | SPN: 3936 | FMI: 7
Aftertreatment 1 Diesel Particulate Filter System - Mechanical System Not Responding or Out of Adjustment

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment fuel injector is malfunctioning
  3. Turbocharger exhaust is leaking oil into the aftertreatment system

1 - Check for primary fault codes

Solution: S00000061

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment DPF: 4151, 4158, 4161, 4162, 4259

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment fuel injector is malfunctioning

Solution: S00003286

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the aftertreatment fuel injector.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Perform the Aftertreatment Fuel Injector Leak Test.

Refer to Procedure 011-054

Specification

  • If the Aftertreatment Fuel Injector Leak Test does not meet specification, then a malfunctioning aftertreatment fuel injector has been detected.

Linked Solutions

  • None

Repair

  • Replace aftertreatment fuel injector.

Refer to Procedure 011-042

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Turbocharger exhaust is leaking oil into the aftertreatment system

Solution: S00000655

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the exhaust piping from the turbocharger outlet.

Action

  • Inspect for any fluids.
  • Visually inspect the turbocharger exhaust outlet for signs of oil or fuel.
  • Perform the Snap Acceleration Test - Aftertreatment Disconnected.

Refer to Procedure 014-017

Specification

  • If lubricating engine oil contamination is found in the turbocharger exhaust outlet, then reset the search to oil consumption internal.
  • If excessive black smoke is detected, then reset the search to black smoke.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6266 | SPN: 5862 | FMI: 14
Aftertreatment 1 SCR Intermediate Gas Temperature - Special Instructions

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000058

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment SCR: 4152, 4164, 4165, 4166, 4261

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00009782

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6267 | SPN: 4360 | FMI: 14
Aftertreatment 1 SCR Intake Temperature - Special Instructions

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment exhaust gas temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000056

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment SCR: 4152, 4164, 4165, 4166, 4261

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment exhaust gas temperature sensor module is malfunctioning

Solution: S00009782

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or inactive and has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment exhaust gas temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 08-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6268 | SPN: 4363 | FMI: 12
Aftertreatment 1 SCR Outlet Temperature Sensor - Bad Intelligent Device or Component

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment SCR temperature sensor module is malfunctioning

1 - Check for primary fault codes

Solution: S00000024

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins electronic service tool or equivalent.

Action

  • Use the recommended Cummins electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment SCR: 4152, 4164, 4165, 4166, 4261

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment SCR temperature sensor module is malfunctioning

Solution: S00002741

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins electronic service tool or equivalent.

Action

  • Use the recommended Cummins electronic service tool or equivalent to read the fault codes.

Specification

  • If the fault code is active or has more than one inactive count within the last 25 engine operating hours, then a malfunctioning aftertreatment SCR temperature sensor module has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-449

Validation

  • Connect all components
  • Connect the recommended Cummins electronic service tool or equivalent.
  • Disable Fault Code
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 20-May-2019


NO TITLE

ISX15 CM2350 X101

Fault Code: 6336 | SPN: 862 | FMI: 3
Crankcase Breather Filter Heater Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. Crankcase breather filter heater has open or short circuit
  3. Crankcase breather heater circuit pin to pin short

1 - Incorrect adjustable parameter setting

Solution: S00000892

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify the Crankcase Breather Heater setting is correct with the recommended Cummins® electronic service tool or equivalent.

Specification

  • If the Crankcase Heater setting does not match the application, then the incorrect Crankcase Heater setting has been detected.

Linked Solutions

  • None

Repair

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Configure the crankcase heater setting to match the engine CPL.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Crankcase breather filter heater has open or short circuit

Solution: S00000891

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase breather heater from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the crankcase breather heater SUPPLY pin to the crankcase breather heater RETURN pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A short circuit in the crankcase breather filter heater has been detected if the resistance is less than the following specification: 5 Ω
  • An open circuit in the crankcase breather filter heater has been detected if the resistance is greater than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Replace the crankcase breather filter heater.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Crankcase breather heater circuit pin to pin short

Solution: S00000893

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase breather heater from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the crankcase breather heater SUPPLY pin in the engine wiring harness ECM connector and all other pins in the ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6337 | SPN: 862 | FMI: 4
Crankcase Breather Filter Heater Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. Crankcase breather heater open circuit check
  3. Crankcase breather filter heater has open or short circuit
  4. Crankcase breather heater circuit pin to ground short
  5. Crankcase breather heater circuit pin to pin short

1 - Incorrect adjustable parameter setting

Solution: S00003166

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify engine is equipped with a crankcase breather heater.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Verify the Crankcase Breather Heater setting is correct with the recommended Cummins® electronic service tool or equivalent.

Specification

  • If the adjustable parameter setting and application do not match, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Adjust the features and parameters to the correct settings.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Crankcase breather heater open circuit check

Solution: S00000894

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase breather heater from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the crankcase breather heater SUPPLY pin in the engine wiring harness ECM connector and the crankcase breather heater SUPPLY pin at the crankcase breather heater wiring harness connector.
  • Measure the resistance between the crankcase breather heater RETURN pin in the engine wiring harness ECM connector and the crankcase breather heater RETURN pin at the crankcase breather heater wiring harness connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Crankcase breather filter heater has open or short circuit

Solution: S00000891

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase breather heater from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the crankcase breather heater SUPPLY pin to the crankcase breather heater RETURN pin.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A short circuit in the crankcase breather filter heater has been detected if the resistance is less than the following specification: 5 Ω
  • An open circuit in the crankcase breather filter heater has been detected if the resistance is greater than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Replace the crankcase breather filter heater.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Crankcase breather heater circuit pin to ground short

Solution: S00000895

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase breather heater from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the crankcase breather heater SIGNAL pin in the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Crankcase breather heater circuit pin to pin short

Solution: S00000893

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase breather heater from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the crankcase breather heater SUPPLY pin in the engine wiring harness ECM connector and all other pins in the ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6339 | SPN: 96 | FMI: 9
Fuel Level 1 - Abnormal Update Rate

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6341 | SPN: 96 | FMI: 13
Fuel Level 1 - Out of Calibration

Troubleshooting Summary

  1. Battery or battery cables are malfunctioning
  2. Incorrect adjustable parameter setting
  3. ECM calibration revision history check

1 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6342 | SPN: 38 | FMI: 9
Fuel Level 2 - Abnormal Update Rate

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6343 | SPN: 38 | FMI: 13
Fuel Level 2 - Out of Calibration

Troubleshooting Summary

  1. Battery or battery cables are malfunctioning
  2. Incorrect adjustable parameter setting
  3. ECM calibration revision history check

1 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6416 | SPN: 3703 | FMI: 31
Aftertreatment Regeneration Inhibited Due to Inhibit Switch - Condition Exists

Troubleshooting Summary

  1. Aftertreatment DPF Permit Switch Status is in the OFF position
  2. ECM calibration revision history check

1 - Aftertreatment DPF Permit Switch Status is in the OFF position

Solution: S00001026

Verification

Conditions

  • None

Action

  • Visually verify the Aftertreatment DPF Permit Switch is in the ON position.

Specification

  • If the Aftertreatment DPF Permit Switch is in the ON position, then proceed to the next solution.
  • If the Aftertreatment DPF Permit Switch is not in the ON position, then proceed to the Repair section.
  • If there is not an Aftertreatment DPF Permit Switch on the dash, then an incorrect parameter setting has been determined. Proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Turn the Aftertreatment DPF Permit Switch Status to the ON position.
  • Adjust the features and parameters to the correct settings.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Perform the aftertreatment stationary regeneration.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6417 | SPN: 974 | FMI: 19
SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Sensor System - Received Network Data in Error

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6418 | SPN: 1072 | FMI: 3
Engine Brake Actuator Driver 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Engine brake solenoid valve resistance check
  2. Engine brake solenoid valve open circuit check
  3. Engine brake solenoid circuit pin to pin short

1 - Engine brake solenoid valve resistance check

Solution: S00000539

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover.
  • Disconnect the engine wiring harness from the engine brake connector.
  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the engine brake solenoid valve terminal pin to the body of the solenoid.

Refer to Procedure 020-012

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the engine brake solenoid valve is not within specification, then a malfunctioning engine brake solenoid valve has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine brake solenoid valve.

Refer to Procedure 020-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Engine brake solenoid valve open circuit check

Solution: S00000648

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Measure the resistance between the engine brake solenoid SIGNAL wire at the engine brake solenoid to the engine brake solenoid SIGNAL line at the ECM connector on solenoid being tested.
  • Measure the resistance between the engine brake solenoid RETURN line at the engine brake solenoid to the engine brake solenoid RETURN line at the ECM connector on solenoid being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the engine brake wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine brake solenoid circuit pin to pin short

Solution: S00001027

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6419 | SPN: 1072 | FMI: 4
Engine Brake Actuator Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Engine brake solenoid valve resistance check
  2. Engine brake solenoid valve open circuit check
  3. Engine brake solenoid circuit pin to ground short
  4. Engine brake solenoid circuit pin to pin short
  5. ECM Malfunction

1 - Engine brake solenoid valve resistance check

Solution: S00000539

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover.
  • Disconnect the engine wiring harness from the engine brake connector.
  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the engine brake solenoid valve terminal pin to the body of the solenoid.

Refer to Procedure 020-012

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the engine brake solenoid valve is not within specification, then a malfunctioning engine brake solenoid valve has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine brake solenoid valve.

Refer to Procedure 020-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Engine brake solenoid valve open circuit check

Solution: S00000648

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Measure the resistance between the engine brake solenoid SIGNAL wire at the engine brake solenoid to the engine brake solenoid SIGNAL line at the ECM connector on solenoid being tested.
  • Measure the resistance between the engine brake solenoid RETURN line at the engine brake solenoid to the engine brake solenoid RETURN line at the ECM connector on solenoid being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the engine brake wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine brake solenoid circuit pin to ground short

Solution: S00000723

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the appropriate engine brake solenoid from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid SIGNAL pin in the engine wiring harness ECM connector and ground for the solenoid being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness, internal actuator wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the internal actuator wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Engine brake solenoid circuit pin to pin short

Solution: S00001027

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid SIGNAL pin at the engine wiring harness ECM connector and all other pins in that connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM Malfunction

Solution: S00001622

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after all the preceding solution verifications have been performed, then a malfunctioning ECM has been detected.

Linked Solutions

  • None

Repair

  • Replace the ECM.

Refer to Procedure 019-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6421 | SPN: 1073 | FMI: 3
Engine Brake Actuator Driver Output 2 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Engine brake solenoid valve resistance check
  2. Engine brake solenoid valve open circuit check
  3. Engine brake solenoid circuit pin to pin short

1 - Engine brake solenoid valve resistance check

Solution: S00001031

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.
  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid valve SIGNAL pin and engine brake solenoid RETURN at the engine brake solenoid valve.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the engine brake solenoid valve is not within specification, then a malfunctioning engine brake solenoid valve has been detected.

Refer to Procedure 020-012

Linked Solutions

  • None

Repair

  • Replace the engine brake solenoid valve.

Refer to Procedure 020-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Engine brake solenoid valve open circuit check

Solution: S00000648

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Measure the resistance between the engine brake solenoid SIGNAL wire at the engine brake solenoid to the engine brake solenoid SIGNAL line at the ECM connector on solenoid being tested.
  • Measure the resistance between the engine brake solenoid RETURN line at the engine brake solenoid to the engine brake solenoid RETURN line at the ECM connector on solenoid being tested.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the engine brake wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine brake solenoid circuit pin to pin short

Solution: S00001028

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the engine wiring harness from the engine brake connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid number 1 SIGNAL pin in the engine wiring harness ECM connector and all other pins in the ECM connector.
  • Measure the resistance between the engine brake solenoid number 2 SIGNAL pin in the engine wiring harness ECM connector and all other pins in the ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6422 | SPN: 1073 | FMI: 4
Engine Brake Actuator Driver Output 2 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Engine brake solenoid valve resistance check
  2. Engine brake solenoid valve resistance check
  3. Engine brake solenoid 2 harness pin to ground short
  4. Engine wiring harness has a pin to pin short

1 - Engine brake solenoid valve resistance check

Solution: S00000539

Verification

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover.
  • Disconnect the engine wiring harness from the engine brake connector.
  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance from the engine brake solenoid valve terminal pin to the body of the solenoid.

Refer to Procedure 020-012

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the engine brake solenoid valve is not within specification, then a malfunctioning engine brake solenoid valve has been detected.

Linked Solutions

  • None

Repair

  • Replace the engine brake solenoid valve.

Refer to Procedure 020-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Engine brake solenoid valve resistance check

Solution: S00001031

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the rocker lever cover.

Refer to Procedure 003-011

  • Disconnect the engine brake wiring harness from the engine brake solenoid valve being tested.
  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid valve SIGNAL pin and engine brake solenoid RETURN at the engine brake solenoid valve.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the engine brake solenoid valve is not within specification, then a malfunctioning engine brake solenoid valve has been detected.

Refer to Procedure 020-012

Linked Solutions

  • None

Repair

  • Replace the engine brake solenoid valve.

Refer to Procedure 020-012

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Engine brake solenoid 2 harness pin to ground short

Solution: S00001030

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake solenoid number 2 from the engine brake pass through connector.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid number 2 SIGNAL pin in the engine wiring harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness, internal actuator wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the internal actuator wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Engine wiring harness has a pin to pin short

Solution: S00000774

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake solenoid number 2 from the engine brake pass through connector.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the engine brake solenoid number 2 SIGNAL pin in the engine wiring harness ECM connector and all other pins in the ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness, internal actuator wiring harness or pass through connector has been detected if the resistance is less than the following specification: 100k Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the internal actuator wiring harness.

Refer to Procedure 019-063

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 01-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6432 | SPN: 641 | FMI: 14
VGT Actuator Controller - Special Instructions

Troubleshooting Summary

  1. Check for primary fault codes
  2. Incorrect variable geometry turbocharger actuator installation
  3. Variable geometry turbocharger actuator calibration incorrect
  4. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000055

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Turbocharger: 1894, 2636
  • Voltage: 1938

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Incorrect variable geometry turbocharger actuator installation

Solution: S00009051

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the variable geometry turbocharger actuator installation.

Refer to Procedure 010-134

Specification

  • If the variable geometry turbocharger actuator installation does complete, then proceed to the Linked Solutions section.
  • If the variable geometry turbocharger actuator installation does not complete, then a malfunctioning variable geometry turbocharger actuator has been detected.

Linked Solutions

  • Variable geometry turbocharger actuator calibration incorrect

Refer to S00008994

Repair

  • Replace the variable geometry turbocharger actuator.

Refer to Procedure 010-134

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Variable geometry turbocharger actuator calibration incorrect

Solution: S00008994

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Perform the variable geometry turbocharger actuator calibration.

Refer to Procedure 010-134

Specification

  • If the variable geometry turbocharger actuator calibration does not complete, then a malfunctioning variable geometry turbocharger has been detected.

Linked Solutions

  • None

Repair

  • Replace the variable geometry turbocharger.

Refer to Procedure 010-134

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6575 | SPN: 7317 | FMI: 9
Predictive Cruise Control State - Abnormal Update Rate

Troubleshooting Summary

  1. Navigation control module check
  2. Predictive cruise control is malfunctioning
  3. Predictive cruise control is malfunctioning
  4. ECM calibration revision history check

1 - Navigation control module check

Solution: S00006503

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify if the navigation control module is a Cummins® Route Parameter Manager module.

Refer to Procedure 019-665

Specification

  • If the navigation control module is a OEM module, then contact the OEM for further troubleshooting direction.
  • If the navigation control module is a Cummins® Route Parameter Manager module, then proceed with the troubleshooting.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.

Validation

  • None
Next Solution

2 - Predictive cruise control is malfunctioning

Solution: S00000725

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the vehicle for installed predictive cruise control hardware.

Specification

  • If predictive cruise control hardware is not installed on the vehicle, then use the recommended Cummins® electronic service tool or equivalent to disable the Predictive Cruise feature.
  • If predictive cruise control hardware has been installed on the vehicle, then proceed to the Linked Solutions section.

Linked Solutions

  • Predictive cruise control is malfunctioning.

Refer to S00000726

Repair

  • Disable the Predictive Cruise feature.

Refer to Procedure 019-078

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Predictive cruise control is malfunctioning

Solution: S00000726

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Connect the INLINE™ data link adapter to the vehicle SAE J1939 data link diagnostic connector.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Attempt to communicate with the ECM.
  • Select INLINE™ J1939 ECM connection.
  • Verify the J1939 communications between the recommended Cummins® electronic service tool or equivalent and the ECM.

Specification

  • If communication between the ECM and the recommended Cummins® electronic service tool or equivalent cannot be established, then reset the search to No Communication with the Cummins® Electronic Service Tool or Equivalent to ECM.

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Parent Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6595 | SPN: 190 | FMI: 11
Engine Speed - Root Cause Not Known

Troubleshooting Summary

  1. Battery or battery cables are malfunctioning
  2. Reversed engine position sensors
  3. ECM calibration revision history check

1 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Reversed engine position sensors

Solution: S00000318

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine wiring harness.
  • Disconnect the crankshaft position sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually verify the camshaft engine position and crankshaft engine position sensor are connected properly.

Specification

  • If the sensors are not properly connected, then proceed to the repair section.

Linked Solutions

  • None

Repair

  • Connect the camshaft and crankshaft position sensors in the correct position.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6613 | SPN: 5842 | FMI: 14
SCR Monitoring System Malfunction - Special Instructions

Troubleshooting Summary

  1. Check for primary fault codes

1 - Check for primary fault codes

Solution: S00001414

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 1669, 3572, 4677
  • Aftertreatment diesel exhaust fluid dosing unit: 3559
  • Aftertreatment NOx: 2771
  • Aftertreatment SCR: 3146, 3911, 4152

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 24-May-2020


NO TITLE

ISX15 CM2350 X101

Fault Code: 6637 | SPN: 2978 | FMI: 2
Estimated Engine Parasitic Losses - Percent Torque - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Incorrect adjustable parameter setting
  2. ECM calibration revision history check

1 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6642 | SPN: 5569 | FMI: 4
Aftertreatment 1 Diesel Particulate Filter 1 Soot Sensor ECU Internal Temperature 1 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment particulate matter sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000053

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment Particulate sensor: 5582, 5583, 6651, 6652, 6653, 6688

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment particulate matter sensor is malfunctioning

Solution: S00000913

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 17-Apr-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6643 | SPN: 5569 | FMI: 3
Aftertreatment 1 Diesel Particulate Filter 1 Soot Sensor ECU Internal Temperature 1 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment particulate matter sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000052

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment Particulate sensor: 5582, 5583, 6651, 6652, 6653, 6688

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment particulate matter sensor is malfunctioning

Solution: S00000913

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 17-Apr-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6644 | SPN: 5569 | FMI: 4
Aftertreatment 1 Diesel Particulate Filter 1 Soot Sensor ECU Internal Temperature 2 Circuit - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment particulate matter sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000042

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment Particulate sensor: 5582, 5583, 6651, 6652, 6653, 6688

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment particulate matter sensor is malfunctioning

Solution: S00000913

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 17-Apr-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6645 | SPN: 5569 | FMI: 3
Aftertreatment 1 Diesel Particulate Filter 1 Soot Sensor ECU Internal Temperature 2 Circuit - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment particulate matter sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000041

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment Particulate sensor: 5582, 5583, 6651, 6652, 6653, 6688

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment particulate matter sensor is malfunctioning

Solution: S00000913

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 17-Apr-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6646 | SPN: 5569 | FMI: 2
Aftertreatment 1 Diesel Particulate Filter 1 Soot Sensor ECU Internal Temperature - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Aftertreatment particulate matter sensor is damaged

1 - Check for primary fault codes

Solution: S00000040

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment Particulate sensor: 5582, 5583, 6651, 6652, 6653, 6688

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment particulate matter sensor is damaged

Solution: S00007912

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6647 | SPN: 6780 | FMI: 3
Aftertreatment 1 Diesel Particulate Filter Soot Temperature Sensor - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment particulate matter sensor is damaged

1 - Check for primary fault codes

Solution: S00000039

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment Particulate sensor: 5582, 5583, 6651, 6652, 6653, 6688

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment particulate matter sensor is damaged

Solution: S00007912

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 05-Dec-2021


NO TITLE

ISX15 CM2350 X101

Fault Code: 6648 | SPN: 6780 | FMI: 4
Aftertreatment 1 Diesel Particulate Filter Soot Temperature Sensor - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment particulate matter sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000038

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment Particulate sensor: 5582, 5583, 6651, 6652, 6653, 6688

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment particulate matter sensor is malfunctioning

Solution: S00000913

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 17-Apr-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6649 | SPN: 6780 | FMI: 2
Aftertreatment 1 Diesel Particulate Filter Soot Temperature Sensor - Data Erratic, Intermittent, or Incorrect

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check
  3. Aftertreatment particulate matter sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000037

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment Particulate sensor: 5582, 5583, 6688
  • Aftertreatment SCR: 3148, 6268

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Aftertreatment particulate matter sensor is malfunctioning

Solution: S00000913

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6651 | SPN: 7854 | FMI: 3
Aftertreatment 1 Diesel Particulate Filter Soot Sensor Module - Voltage Above Normal or Shorted to High Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment particulate matter sensor voltage check
  3. Aftertreatment particulate matter sensor battery SUPPLY to block ground check
  4. Incorrect aftertreatment particulate matter sensor installed

1 - Check for primary fault codes

Solution: S00000036

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Voltage: 441, 442, 596, 597, 598, 1939, 1941, 6256, 6257
  • Aftertreatment Particulate sensor: 6688

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment particulate matter sensor voltage check

Solution: S00001006

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment particulate matter sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment particulate matter sensor battery voltage SUPPLY pin and the aftertreatment particulate matter sensor RETURN pin at the particulate matter sensor OEM wiring harness connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

For general voltage measurement techniques.

Refer to Procedure 019-359

Check the voltage at key ON, while cranking the engine, and with the engine at idle.

Specification

  • Proceed to the next solution if voltage is within the following specification of battery voltage: 1 VDC
  • Proceed to the Linked Solutions section if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

Click on the link below:

  • Aftertreatment particulate matter sensor battery SUPPLY to block ground check

Refer to S00001007

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Aftertreatment particulate matter sensor battery SUPPLY to block ground check

Solution: S00001007

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment particulate matter sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Turn keyswitch ON.
  • Measure the voltage from the aftertreatment particulate matter sensor battery voltage SUPPLY pin of the OEM wiring harness to engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

For general voltage measurement techniques.

Refer to Procedure 019-359

Specification

  • An open circuit or high resistance has been detected in the aftertreatment particulate matter sensor battery voltage RETURN circuit if the voltage is within the following specification of battery voltage: 1 VDC
  • An open circuit or high resistance has been detected in the aftertreatment particulate matter sensor battery voltage SUPPLY circuit if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Incorrect aftertreatment particulate matter sensor installed

Solution: S00000722

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the aftertreatment particulate matter sensor.
  • Verify aftertreatment particulate matter sensor is the correct sensor for the engine configuration.

Specification

  • If the aftertreatment particulate matter sensor is not correct, then an incorrect sensor configuration has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 05-Dec-2021


NO TITLE

ISX15 CM2350 X101

Fault Code: 6652 | SPN: 7854 | FMI: 4
Aftertreatment 1 Diesel Particulate Filter Soot Sensor Module - Voltage Below Normal or Shorted to Low Source

Troubleshooting Summary

  1. Check for primary fault codes
  2. Low battery voltage
  3. Battery load test
  4. Ground inspection
  5. Aftertreatment particulate matter sensor voltage check
  6. Aftertreatment particulate matter sensor battery SUPPLY to block ground check
  7. Incorrect aftertreatment particulate matter sensor installed

1 - Check for primary fault codes

Solution: S00000035

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Voltage: 441, 442, 596, 597, 598, 1939, 1941, 6256, 6257
  • Aftertreatment Particulate sensor: 6688

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Low battery voltage

Solution: S00001110

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.
  • If this vehicle has been repaired within the last 30 days for the same fault code, then proceed to the Linked Solutions section.

Specification

  • If the battery voltage is at least 10.8 VDC (12 volt systems) or 21.6 VDC (24 volt systems), then proceed to the Linked Solutions section.
  • If the battery or battery cables show signs of corrosion or damage, then proceed to the Repair Section.

Linked Solutions

  • Battery load test

Refer to S00001379

  • Ground inspection

Refer to S00000754

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean corrosion or tighten battery cable connections.

Refer to OEM Service Manual

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Battery load test

Solution: S00001379

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Disconnect the batteries from each other.
  • Connect a load tester separately to each battery.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.

Specification

  • For a 12 volt system, proceed to the Repair section if the battery voltage is below the following specification: 11 VDC
  • For a 24 volt system, proceed to the Repair section if the battery voltage is below the following specification: 22 VDC

Linked Solutions

  • None

Repair

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Ground inspection

Solution: S00000754

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the ECM ground for damage, corrosion and loose connections.
  • Visually inspect the aftertreatment interface wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the OEM wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the grounds for proper routing.

Specification

  • If damage, corrosion or incorrect routing of grounds are found, then proceed to the Repair section

Linked Solutions

  • None

Repair

  • Clean or replace connections.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Aftertreatment particulate matter sensor voltage check

Solution: S00001006

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment particulate matter sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment particulate matter sensor battery voltage SUPPLY pin and the aftertreatment particulate matter sensor RETURN pin at the particulate matter sensor OEM wiring harness connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

For general voltage measurement techniques.

Refer to Procedure 019-359

Check the voltage at key ON, while cranking the engine, and with the engine at idle.

Specification

  • Proceed to the next solution if voltage is within the following specification of battery voltage: 1 VDC
  • Proceed to the Linked Solutions section if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

Click on the link below:

  • Aftertreatment particulate matter sensor battery SUPPLY to block ground check

Refer to S00001007

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3.1 - Aftertreatment particulate matter sensor battery SUPPLY to block ground check

Solution: S00001007

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment particulate matter sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Turn keyswitch ON.
  • Measure the voltage from the aftertreatment particulate matter sensor battery voltage SUPPLY pin of the OEM wiring harness to engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

For general voltage measurement techniques.

Refer to Procedure 019-359

Specification

  • An open circuit or high resistance has been detected in the aftertreatment particulate matter sensor battery voltage RETURN circuit if the voltage is within the following specification of battery voltage: 1 VDC
  • An open circuit or high resistance has been detected in the aftertreatment particulate matter sensor battery voltage SUPPLY circuit if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Incorrect aftertreatment particulate matter sensor installed

Solution: S00000722

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the aftertreatment particulate matter sensor.
  • Verify aftertreatment particulate matter sensor is the correct sensor for the engine configuration.

Specification

  • If the aftertreatment particulate matter sensor is not correct, then an incorrect sensor configuration has been detected.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6653 | SPN: 7854 | FMI: 6
Aftertreatment 1 Diesel Particulate Filter Soot Sensor Module - Current Above Normal or Grounded Circuit

Troubleshooting Summary

  1. Check for primary fault codes
  2. Aftertreatment particulate matter sensor voltage check
  3. Aftertreatment particulate matter sensor battery SUPPLY to block ground check
  4. Aftertreatment particulate matter sensor is malfunctioning

1 - Check for primary fault codes

Solution: S00000034

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Voltage: 441, 442, 596, 597, 598, 1939, 1941, 6256, 6257
  • Aftertreatment Particulate sensor: 6688

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Aftertreatment particulate matter sensor voltage check

Solution: S00001006

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment particulate matter sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment particulate matter sensor battery voltage SUPPLY pin and the aftertreatment particulate matter sensor RETURN pin at the particulate matter sensor OEM wiring harness connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

For general voltage measurement techniques.

Refer to Procedure 019-359

Check the voltage at key ON, while cranking the engine, and with the engine at idle.

Specification

  • Proceed to the next solution if voltage is within the following specification of battery voltage: 1 VDC
  • Proceed to the Linked Solutions section if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

Click on the link below:

  • Aftertreatment particulate matter sensor battery SUPPLY to block ground check

Refer to S00001007

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Aftertreatment particulate matter sensor battery SUPPLY to block ground check

Solution: S00001007

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment particulate matter sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Turn keyswitch ON.
  • Measure the voltage from the aftertreatment particulate matter sensor battery voltage SUPPLY pin of the OEM wiring harness to engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

For general voltage measurement techniques.

Refer to Procedure 019-359

Specification

  • An open circuit or high resistance has been detected in the aftertreatment particulate matter sensor battery voltage RETURN circuit if the voltage is within the following specification of battery voltage: 1 VDC
  • An open circuit or high resistance has been detected in the aftertreatment particulate matter sensor battery voltage SUPPLY circuit if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Aftertreatment particulate matter sensor is malfunctioning

Solution: S00000913

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active or inactive with more than one count within the last 25 engine hours and all the preceding solution verifications have been performed, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 17-Apr-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6656 | SPN: 5842 | FMI: 14
SCR Monitoring System Malfunction - Special Instructions

Troubleshooting Summary

  1. Check for primary fault codes
  2. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000033

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Aftertreatment diesel exhaust fluid system: 1669, 4572, 4677
  • Aftertreatment NOx: 2771
  • Aftertreatment diesel exhaust fluid dosing unit: 3559, 4156
  • Aftertreatment diesel exhaust fluid pressure: 3572
  • Aftertreatment SCR: 3146, 3911, 4152, 4518

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6688 | SPN: 5835 | FMI: 9
Aftertreatment 1 Particulate Sensor - Abnormal Update Rate

Troubleshooting Summary

  1. Check for primary fault codes
  2. Low battery voltage
  3. Battery load test
  4. Ground inspection
  5. Aftertreatment particulate matter sensor voltage check
  6. Aftertreatment particulate matter sensor battery SUPPLY to block ground check
  7. Fault Code 6688 triggered by a malfunction in the J1939 data link with multiple OEM fault code
  8. J1939 data link engine wiring harness voltage check 3 pin service connector
  9. OEM sensor voltage check
  10. J1939 data link harness pin to ground short circuit
  11. J1939 data link terminating resistance is incorrect
  12. Variable geometry turbocharger actuator has incorrect J1939 terminating resistance
  13. Engine wiring harness has incorrect J1939 terminating resistance
  14. OEM wiring harness has incorrect J1939 terminating resistance
  15. J1939 data link harness open circuit check
  16. OEM terminating resistor Ω check for the J1939 data link
  17. Incorrect terminating resistance in the J1939 data link by a J1939 data linked component
  18. J1939 wire resistance check at the crossover connector for each component
  19. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000031

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Turbocharger: 1894, 2636

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Low battery voltage

Solution: S00001110

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.
  • If this vehicle has been repaired within the last 30 days for the same fault code, then proceed to the Linked Solutions section.

Specification

  • If the battery voltage is at least 10.8 VDC (12 volt systems) or 21.6 VDC (24 volt systems), then proceed to the Linked Solutions section.
  • If the battery or battery cables show signs of corrosion or damage, then proceed to the Repair Section.

Linked Solutions

  • Battery load test

Refer to S00001379

  • Ground inspection

Refer to S00000754

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean corrosion or tighten battery cable connections.

Refer to OEM Service Manual

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2.1 - Battery load test

Solution: S00001379

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Disconnect the batteries from each other.
  • Connect a load tester separately to each battery.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.

Specification

  • For a 12 volt system, proceed to the Repair section if the battery voltage is below the following specification: 11 VDC
  • For a 24 volt system, proceed to the Repair section if the battery voltage is below the following specification: 22 VDC

Linked Solutions

  • None

Repair

  • Charge or replace the batteries.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

2.2 - Ground inspection

Solution: S00000754

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the ECM ground for damage, corrosion and loose connections.
  • Visually inspect the aftertreatment interface wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the OEM wiring harness ground for damage, corrosion and loose connections.
  • Visually inspect the grounds for proper routing.

Specification

  • If damage, corrosion or incorrect routing of grounds are found, then proceed to the Repair section

Linked Solutions

  • None

Repair

  • Clean or replace connections.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Aftertreatment particulate matter sensor voltage check

Solution: S00000717

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment particulate matter sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the aftertreatment particulate matter sensor battery voltage SUPPLY pin and the aftertreatment particulate matter sensor RETURN pin at the particulate matter sensor OEM wiring harness connector.

Check the voltage at key ON, while cranking the engine, and with the engine at idle.

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • Aftertreatment particulate matter sensor battery SUPPLY to block ground check

Refer to S00000718

Repair

  • No additional action is required for this solution.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3.1 - Aftertreatment particulate matter sensor battery SUPPLY to block ground check

Solution: S00000718

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment particulate matter sensor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage from the aftertreatment particulate matter sensor battery voltage SUPPLY pin of the OEM wiring harness to engine block ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • An open circuit or high resistance has been detected in the aftertreatment particulate matter sensor battery voltage RETURN circuit if the voltage is within the following specification of battery voltage: 1 VDC
  • An open circuit or high resistance has been detected in the aftertreatment particulate matter sensor battery voltage SUPPLY circuit if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the fuse.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

4 - Fault Code 6688 triggered by a malfunction in the J1939 data link with multiple OEM fault code

Solution: S00000716

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

  • Proceed to the next solution, if any fault code is active or has more than one inactive count within the last 25 engine operating hours from the following list: 1894, 2636, 2771, 3232, 3868, 3911, 4151, 4152, 4572, 4677
  • A malfunctioning aftertreatment particulate matter sensor has been detected if a fault code from the following list is not active, or does not have more than one inactive count within the last 25 engine operating hours: 1894, 2636, 2771, 3232, 3868, 3911, 4151, 4152, 4572, 4677

Linked Solutions

  • None

Repair

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - J1939 data link engine wiring harness voltage check 3 pin service connector

Solution: S00000594

Verification

Conditions

  • Turn keyswitch OFF.
  • Connect all SAE J1939 components.
  • Turn keyswitch ON.

Action

The service tool datalink adapter can NOT be connected to the 3-pin J1939 datalink connector during this check.

  • Measure the J1939 voltage of the J1939 (+) pin to ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

  • Measure the J1939 voltage of the J1939 (-) pin to ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

Specification

  • A malfunctioning wiring harness has been detected due to the J1939 data link circuit being shorted to a voltage source if the voltage is greater than the following specification: 4.5 VDC
  • Proceed to the Linked Solutions section if the voltage is less than the following specification: 1 VDC
  • Proceed to the next solution if the voltage is within the following specification for both the SAE J1939 data link (+) and SAE J1939 data link (-) circuit: 1 - 4.5 VDC

Linked Solutions

  • OEM J1939 data link component isolation

Refer to S00003176

  • Engine or OEM wiring harness shorted to ground

Refer to S00003331

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, engine wiring harness, and all interconnects.
  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5.1 - OEM sensor voltage check

Solution: S00003176

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Reconnect the crossover connector.

Inspect the following components if applicable:

  • Turn keyswitch ON.
  • Measure the J1939 voltage of the SAE J1939 data link (+) and SAE data link J1939 (-) pins at the variable geometry turbocharger actuator engine wiring harness connector to battery ground while each component is disconnected one at a time.
  • Disconnect the aftertreatment outlet NOx sensor
  • Disconnect the aftertreatment DPF temperature sensor module.
  • Disconnect the aftertreatment SCR temperature sensor module.
  • Disconnect the aftertreatment intermediate NH3 sensor.
  • Disconnect the aftertreatment particulate sensor
  • Disconnect the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.
  • Disconnect the aftertreatment exhaust gas temperature sensor.
  • Disconnect the aftertreatment intake NOx sensor.

Specification

  • A malfunctioning SAE J1939 data link component has been detected if the voltage is within the following specification after the component has been disconnected: 1 - 4.5 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.

Refer to OEM Service Manual

  • Replace the aftertreatment exhaust gas temperature sensor module.

Refer to Procedure 019-449

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463

  • Replace aftertreatment DPF temperature sensor module.

Refer to Procedure 019-449

  • Replace the aftertreatment SCR temperature sensor module.

Refer to Procedure 019-449

  • Replace aftertreatment intermediate NH3 sensor.

Refer to Procedure 019-479

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

5.2 - J1939 data link harness pin to ground short circuit

Solution: S00003331

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Turn keyswitch ON.

Action

The service tool datalink adapter can NOT be connected to the 3-pin J1939 datalink connector during this check.

  • Measure the J1939 voltage of the J1939 (+) pin to battery ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

  • Measure the J1939 voltage of the J1939 (-) pin to battery ground at the 3 pin connector for the J1939 data link.

Refer to Procedure 019-417

Specification

  • A malfunctioning OEM wiring harness has been detected if voltage is within the following specification with the crossover connector disconnected: 1 - 4.5 VDC
  • A malfunctioning engine wiring harness has been detected if voltage is not within the following specification with the crossover connector disconnected: 1 - 4.5 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - J1939 data link terminating resistance is incorrect

Solution: S00000593

Verification

Conditions

  • Turn keyswitch OFF.
  • Wait for 90 seconds.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.
  • Reconnect the variable geometry turbocharger actuator if it has been previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3-pin service data link connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Follow your technical escalation process if the resistance is within the following specification: 54 - 66 Ω
  • Proceed to the Linked Solutions section if the resistance is not within the following specification: 54 - 66 Ω

Linked Solutions

  • Variable geometry turbocharger actuator has incorrect J1939 terminating resistance

Refer to S00001242

  • Engine wiring harness has incorrect J1939 terminating resistance

Refer to S00000972

  • OEM wiring harness has incorrect J1939 terminating resistance

Refer to S00000971

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

6.1 - Variable geometry turbocharger actuator has incorrect J1939 terminating resistance

Solution: S00001242

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the variable geometry turbocharger actuator from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the variable geometry turbocharger actuator SAE J1939 data link (+) pin and the variable geometry turbocharger actuator SAE J1939 data link (-) pin at the variable geometry turbocharger actuator.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning variable geometry turbocharger actuator has been detected if the resistance is not within the following specification: 108 Ω - 132 Ω

Linked Solutions

  • None

Repair

  • Replace the variable geometry turbocharger actuator.

Refer to Procedure 010-134

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6.2 - Engine wiring harness has incorrect J1939 terminating resistance

Solution: S00000972

Verification

Conditions

  • Turn keyswitch OFF.
  • Reconnect previously disconnected components.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.
  • Disconnect the aftertreatment intake NOx sensor from the engine wiring harness.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3-pin service data link connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning engine wiring harness has been detected if the resistance is not within the following specification: 108-132 Ω

Linked Solutions

  • None

Repair

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6.3 - OEM wiring harness has incorrect J1939 terminating resistance

Solution: S00000971

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the next solution if the resistance is not within the following specification: 108 - 132 Ω
  • Follow your technical escalation process if the resistance is within the following specification: 108 - 132 Ω

Linked Solutions

  • None

Repair

  • No additional action is required for this solution.

Validation

  • None
Parent Solution

7 - J1939 data link harness open circuit check

Solution: S00004534

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the appropriate data link component from the data link wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the J1939 (+) pin at the appropriate component data link wiring harness connector and the appropriate data link component J1939 (+) pin at the data link wiring harness ECM connector.
  • Measure the resistance between the J1939 (-) pin at the appropriate component data link wiring harness connector and the appropriate data link component J1939 (-) pin at the data link wiring harness ECM connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning J1939 data link wiring harness has been detected if the resistance is greater than the following specification: 10 Ω

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - OEM terminating resistor Ω check for the J1939 data link

Solution: S00000907

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM terminating resistor from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the pins for the OEM terminating resistor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM terminating resistor has been detected if the resistance is not within the following specification: 108 - 132 Ω

Linked Solutions

  • None

Repair

  • For a malfunctioning OEM terminating resistor, replace the OEM terminating resistor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Incorrect terminating resistance in the J1939 data link by a J1939 data linked component

Solution: S00001002

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Reconnect the OEM terminating resistor if previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if the resistance is not within the following specification: 108 - 132 Ω

Linked Solutions

  • J1939 wire resistance check at the crossover connector for each component

Refer to S00001003

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

9.1 - J1939 wire resistance check at the crossover connector for each component

Solution: S00001003

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the OEM wiring harness crossover connector.
  • Reconnect the OEM terminating resistor if previously disconnected.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

Inspect the following components if applicable:

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the crossover of the OEM wiring harness connector for each component while disconnecting them one at a time.
  • Disconnect the aftertreatment outlet NOx sensor
  • Disconnect the aftertreatment temperature sensor module
  • Disconnect the aftertreatment particulate sensor
  • Disconnect the aftertreatment diesel exhaust fluid tank level sensor
  • Disconnect the aftertreatment diesel exhaust fluid temperature sensor
  • Disconnect the aftertreatment diesel exhaust fluid quality sensor.
  • Disconnect the aftertreatment intermediate NH3 sensor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • If the resistance was not within 108 Ω to 132 Ω and it becomes within the specification of 108 Ω to 132 Ω when the J1939 component was disconnected, then a malfunctioning J1939 component has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the aftertreatment diesel exhaust fluid tank level sensor.

Refer to OEM Service Manual

  • Replace the aftertreatment diesel exhaust fluid temperature sensor.

Refer to OEM Service Manual

  • Replace the aftertreatment diesel exhaust fluid quality sensor.

Refer to OEM Service Manual

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

  • Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451

  • Replace aftertreatment DOC temperature sensor module.

Refer to Procedure 019-449

  • Replace the aftertreatment particulate sensor

Refer to Procedure 019-478

  • Replace aftertreatment intermediate NH3 sensor.

Refer to Procedure 019-479

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

10 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6725 | SPN: 102 | FMI: 15
Intake Manifold 1 Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Intake manifold pressure sensor voltage check
  3. Intake manifold pressure sensor voltage check at the ECM
  4. Intake manifold pressure sensor has carbon buildup
  5. Intake manifold pressure sensor stuck in-range
  6. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000386

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold: 122, 123, 2191
  • Barometric pressure: 221, 222, 295
  • Turbocharger: 595, 687, 1894, 2288, 2636
  • Voltage: 1938

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Intake manifold pressure sensor voltage check

Solution: S00007820

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure/temperature sensor from the engine wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage between the intake manifold pressure sensor SUPPLY pin and the intake manifold pressure sensor RETURN pin at the sensor connector of the engine wiring harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • Proceed to the Linked Solutions section if voltage is not within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • Intake manifold pressure sensor voltage check at the ECM

Refer to S00000758

Repair

  • No additional action is required for this solution.

Validation

  • None
Next Solution

2.1 - Intake manifold pressure sensor voltage check at the ECM

Solution: S00000758

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Turn keyswitch ON.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the voltage between the intake manifold pressure/temperature sensor SUPPLY pin and the intake manifold pressure/temperature sensor RETURN pin at the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning ECM has been detected if voltage at the ECM connector is not within the following specification: 4.75 - 5.25 VDC
  • A malfunctioning engine wiring harness has been detected if voltage at the ECM connector is within the following specification: 4.75 - 5.25 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the ECM.

Refer to Procedure 019-031

  • Repair or replace the engine wiring harness.

Refer to Procedure 019-043

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

3 - Intake manifold pressure sensor has carbon buildup

Solution: S00006329

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

  • Visually inspect the intake manifold pressure/temperature sensor tip for soot or carbon buildup.
  • Visually inspect the intake manifold pressure sensor for damage.
  • Visually inspect the intake manifold pressure sensor o-rings for damage.

Specification

  • If any carbon buildup is found, then proceed to the Repair section.
  • If nicks or cuts in or on the o-ring are identified, then a damaged intake manifold pressure/temperature sensor o-ring has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

  • Replace the intake manifold pressure/temperature sensor o-ring.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Intake manifold pressure sensor stuck in-range

Solution: S00002814

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the intake manifold pressure sensor.

Specification

  • A malfunctioning intake manifold air pressure sensor has been detected if the intake manifold air pressure is not reading within the following specification: 0 ± 6.8 Kpa [0 ± 1 psi], 0 ± 51 mm-Hg [0 ± 2 in- Hg]

Linked Solutions

  • None

Repair

  • Replace the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6735 | SPN: 5569 | FMI: 16
Aftertreatment 1 Diesel Particulate Filter 1 Soot Sensor ECU Internal Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Troubleshooting Summary

  1. Aftertreatment particulate matter sensor has incorrect mounting or debris
  2. ECM calibration revision history check

1 - Aftertreatment particulate matter sensor has incorrect mounting or debris

Solution: S00000713

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the aftertreatment particulate matter sensor is properly mounted.

Refer to Procedure 019-478

  • Verify the proper heat shield is mounted over the particulate matter sensor.

Refer to Procedure 011-032

  • Visually check that no aftermarket shields, flaps, or brackets are mounted too close to the aftertreatment particulate matter sensor.
  • Visually inspect for any exhaust leaks which would allow the aftertreatment particulate matter sensor to overheat.
  • Visually inspect for any obstruction or blockage in or around the aftertreatment particulate matter sensor.

Specification

  • If the aftertreatment particulate matter sensor is incorrectly mounted, heat shield missing (if equipped), obstruction or debris around the sensor, then proceed to the Repair section.

Linked Solutions

  • None

Repair

  • Relocate and/or secure the aftertreatment particulate matter sensor.

Refer to Procedure 019-478

  • Install the proper heat shield (if equipped).

Refer to Procedure 011-032

  • Remove any obstruction or blockage in or around the aftertreatment particulate matter sensor.
  • Repair exhaust leaks that are causing the aftertreatment particulate matter sensor to overheat.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6753 | SPN: 7936 | FMI: 9
Navigation Control Module - Abnormal Update Rate

Troubleshooting Summary

  1. ECM will not communicate
  2. Incorrect adjustable parameter setting
  3. Navigation control module check
  4. Check for primary fault codes
  5. Route Parameter Manager Module voltage check
  6. Route Parameter Manager Module is malfunctioning
  7. Incorrect terminating resistor in the J1939 data link
  8. Route Parameter Manager Module Calibration Revision History check
  9. ECM calibration revision history check
  10. Route Parameter Manager Module is malfunctioning

1 - ECM will not communicate

Solution: S00001146

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify recommended Cummins® electronic service tool or equivalent communication with the ECM.

Specification

  • If communication between the ECM and the recommended Cummins® electronic service tool or equivalent cannot be established, then reset the search to No Communication with the Cummins® Electronic Service Tool or Equivalent to ECM.

Linked Solutions

  • None

Repair

  • Reset the search to No Communication with the Cummins® Electronic Service Tool or Equivalent to ECM.

Validation

  • None
Next Solution

2 - Incorrect adjustable parameter setting

Solution: S00007719

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify if the vehicle has a Cummins® Route Parameter module or OEM navigation control module installed.
  • Use the recommended Cummins® electronic service tool or equivalent.

Verify the following parameters:

  • Predictive gear shifting.
  • Predictive engine braking.
  • On-ramp boost.
  • Predictive cruise control.
  • Predictive road speed governor.

Specification

  • If the vehicle does not have a Cummins® Route Parameter module or OEM navigation control module installed and the parameters are not set to "Disable", then the incorrect adjustable parameters are configured.

Linked Solutions

  • None

Repair

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Adjust the features and parameters to the correct settings.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Navigation control module check

Solution: S00006503

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify if the navigation control module is a Cummins® Route Parameter Manager module.

Refer to Procedure 019-665

Specification

  • If the navigation control module is a OEM module, then contact the OEM for further troubleshooting direction.
  • If the navigation control module is a Cummins® Route Parameter Manager module, then proceed with the troubleshooting.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.

Validation

  • None
Next Solution

4 - Check for primary fault codes

Solution: S00001136

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Route parameter manager module: 6737, 6743, 6744, 6745, 6746, 6748, 6749

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

5 - Route Parameter Manager Module voltage check

Solution: S00000704

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Route Parameter Manager Module from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage from the Route Parameter Manager Module battery voltage SUPPLY pin and the Route Parameter Manager Module battery voltage RETURN pin at the Route Parameter Manager Module wiring harness connector.

Specification

  • Proceed to the next solution if voltage is within the following specification of battery voltage: 1 VDC
  • Proceed to the Linked Solutions section if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

Click on the link below:

  • Route Parameter Manager Module is malfunctioning

Refer to S00000705

Repair

  • No additional action is required for this solution.

Validation

  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
Next Solution

5.1 - Route Parameter Manager Module is malfunctioning

Solution: S00000705

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Route Parameter Manager Module from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Turn keyswitch ON.
  • Measure the voltage from the Route Parameter Manager Module battery voltage SUPPLY pin and battery ground.

Specification

  • An open circuit has been detected if the voltage is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

  • Troubleshoot the OEM wiring harness, and all interconnects.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Parent Solution

6 - Incorrect terminating resistor in the J1939 data link

Solution: S00001138

Verification

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Route Parameter Manager Module from the OEM wiring harness.

Action

  • Inspect the pins and connectors for damage.

Refer to Procedure 019-361

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the Route Parameter Manager Module wiring harness connector.

Refer to Procedure 019-417

  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Specification

  • A malfunctioning OEM wiring harness has been detected if the resistance is not within the following specification: 54 - 66 Ω

Linked Solutions

  • None

Repair

  • For a malfunctioning OEM terminating resistor, replace the OEM terminating resistor.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - Route Parameter Manager Module Calibration Revision History check

Solution: S00000712

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Find the present Route Parameter Manager Module code and revision number in the Route Parameter Manager Module.

Refer to Procedure 019-647

Specification

  • If a calibration update for this fault code is available, the Route Parameter Manager Module calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Download the updated Route Parameter Manager Module calibration code.

Refer to Procedure 019-647

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

9 - Route Parameter Manager Module is malfunctioning

Solution: S00001160

Verification

Conditions

  • None

Action

  • Verify all preceding solution verifications for this fault code have been performed.

Specification

  • If the fault code is still active after the preceding solution verifications have been performed, then a malfunctioning Route Parameter Manager Module has been detected.

Linked Solutions

  • None

Repair

  • Replace the Route Parameter Manager Module.

Refer to Procedure 019-645

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6864 | SPN: 102 | FMI: 17
Intake Manifold 1 Pressure - Data Valid But Below Normal Operating Range - Least Severe Level

Troubleshooting Summary

  1. Check for primary fault codes
  2. Restricted intake air filter
  3. Intake manifold pressure sensor has carbon buildup
  4. Intake manifold pressure sensor stuck in-range
  5. Leaks in the intake air system
  6. Charge air cooler system leak
  7. High exhaust restriction
  8. ECM calibration revision history check

1 - Check for primary fault codes

Solution: S00000020

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Intake manifold: 122, 123
  • Barometric pressure: 221, 222, 295
  • Turbocharger: 595, 687, 691, 692, 693, 1894, 1897, 1898, 1962, 1976, 2198, 2288, 2346, 2347, 2387, 2449, 2451, 2634, 2635, 2636, 3348, 6432
  • EGR: 1228, 1867, 1896, 1961, 2272, 2349, 2353, 2375, 2376, 2961, 2962, 3136, 3137, 3138, 3342,, 3382, 3383
  • EGR differential pressure: 1866, 2273, 2274

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Restricted intake air filter

Solution: S00000025

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air filter to make sure it is not plugged.

Specification

  • If the intake air filter is plugged, then a restricted intake air filter has been detected.

Linked Solutions

  • None

Repair

  • Replace the air filter.

Refer to OEM Service Manual

Refer to Procedure 010-031

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - Intake manifold pressure sensor has carbon buildup

Solution: S00006329

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Remove the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

  • Visually inspect the intake manifold pressure/temperature sensor tip for soot or carbon buildup.
  • Visually inspect the intake manifold pressure sensor for damage.
  • Visually inspect the intake manifold pressure sensor o-rings for damage.

Specification

  • If any carbon buildup is found, then proceed to the Repair section.
  • If nicks or cuts in or on the o-ring are identified, then a damaged intake manifold pressure/temperature sensor o-ring has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Clean the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

  • Replace the intake manifold pressure/temperature sensor o-ring.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

4 - Intake manifold pressure sensor stuck in-range

Solution: S00002814

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Monitor the intake manifold pressure sensor.

Specification

  • A malfunctioning intake manifold air pressure sensor has been detected if the intake manifold air pressure is not reading within the following specification: 0 ± 6.8 Kpa [0 ± 1 psi], 0 ± 51 mm-Hg [0 ± 2 in- Hg]

Linked Solutions

  • None

Repair

  • Replace the intake manifold pressure/temperature sensor.

Refer to Procedure 019-159

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

5 - Leaks in the intake air system

Solution: S00008386

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.
  • Visually inspect the intake plumbing for possible air leaks.

Specification

  • If any of the components have leaks observed, then a leaking air handling component has been detected.

Linked Solutions

  • None

Repair

  • Repair or replace the leaking components.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

6 - Charge air cooler system leak

Solution: S00008815

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the charge air cooler hoses for possible air leaks.
  • Pressure test the charge air cooler to check for leaks.

Refer to Procedure 010-027

Specification

  • If a leak is found, then proceed to the Repair section.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the charge air cooler.

Refer to Procedure 010-027

  • Repair or replace the charge air cooler hoses.

Refer to OEM Service Manual

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

7 - High exhaust restriction

Solution: S00000324

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Check the exhaust restriction.

Refer to Procedure 011-009

Specification

  • If the exhaust restriction is not within specification, then a restriction in the exhaust has been detected.

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Check the face of the aftertreatment diesel oxidation catalyst for plugging.

Refer to Procedure 011-049

  • Check the face of the aftertreatment diesel particulate filter for plugging.

Refer to Procedure 011-041

  • Check for deposits in the decomposition tube.

Refer to Procedure 011-062

  • Check the face of the aftertreatment SCR catalyst for plugging.

Refer to Procedure 011-036

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

8 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 6919 | SPN: 91 | FMI: 13
Accelerator Pedal Position 1 - Out of Calibration

Troubleshooting Summary

  1. Battery or battery cables are malfunctioning
  2. Incorrect adjustable parameter setting
  3. ECM calibration revision history check

1 - Battery or battery cables are malfunctioning

Solution: S00000451

Verification

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the batteries and the battery cable connections for corrosion.
  • Check add-on components or the accessory wiring at the (+) battery terminal.

Refer to Procedure 013-009

  • Measure the battery voltage during keyswitch ON and then during cranking conditions.

Refer to Procedure 013-007

  • If the engine cranks, but will not start then disconnect the battery supply connector from the ECM.
  • Measure the voltage from the battery voltage SUPPLY to the battery voltage RETURN on the OEM side of the ECM battery supply connector.

Specification

  • If the voltage at the battery is less than 10 VDC (20 VDC for 24 Volt systems), then a malfunctioning battery has been detected.
  • A malfunctioning fuse or OEM wiring harness has been detected if the voltage at the OEM side of the battery supply connector is not within the following specification of battery voltage: 1 VDC

Linked Solutions

  • None

Repair

Repair or replace only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness, and all interconnects.
  • Charge or replace the battery.

Refer to Procedure 013-007

  • Replace the fuse.

Refer to Procedure 019-198

  • Repair or replace the OEM wiring harness.

Refer to Procedure 019-071

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

2 - Incorrect adjustable parameter setting

Solution: S00000902

Verification

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Service Bulletin 4021378

Specification

  • If the ECM multiplexing configuration does match the OEM VECU multiplexing configuration, then an OEM issue has been detected.
  • If the ECM multiplexing configuration does not match the OEM VECU multiplexing configuration, then an incorrect setup has been detected in the Cummins® engine ECM.

Linked Solutions

  • None

Repair

  • For an OEM issue: Contact the OEM for further repair instructions.
  • For an incorrect setup in the Cummins® engine ECM, enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.
Next Solution

3 - ECM calibration revision history check

Solution: S00000443

Verification

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM calibration revision history for applicable changes.

Specification

  • If a calibration update for this fault code is available, the ECM calibration revision must be that revision or higher.

Linked Solutions

  • None

Repair

  • Prior to downloading the ECM calibration, check to see that all job images and all other troubleshooting has been documented as downloading an ECM calibration will remove the fault codes on the ECM.
  • Download the updated ECM calibration code.

Refer to Procedure 019-032

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 22-May-2022


NO TITLE

ISX15 CM2350 X101

Fault Code: 7286 | SPN: 8613 | FMI: 9
Source Address of Active or Pending Transmission Requested Gear - Abnormal Update Rate

Troubleshooting Summary

  1. Check for primary fault codes
  2. Technical Service Bulletin is available

1 - Check for primary fault codes

Solution: S00004932

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Specification

Before troubleshooting this fault code, troubleshoot any fault code that is active or has more than one inactive count within the last 25 engine operating hours from the following list:

  • Transmission: 5297

Linked Solutions

  • None

Repair

  • Perform a search on the appropriate fault codes.

Validation

  • None
Next Solution

2 - Technical Service Bulletin is available

Solution: S00006267

Verification

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify the present Transmission Control Module software phase.

Refer to tsb150099

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Verify the predictive gear shifting parameter is correctly set.

Refer to Procedure 019-665

  • Verify the predictive engine braking parameter is correctly set.

Refer to Procedure 019-665

Specification

  • Proceed to the Repair section if the Technical Service Bulletin is applicable.

Linked Solutions

  • None

Repair

  • Complete the action outlined in the Technical Service Bulletin.

Validation

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent.
  • Disable the fault code.
  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.
  • Verify that the fault code is no longer active.
  • Check ECM Calibration Revision History
  • Use the recommended Cummins® electronic service tool or equivalent to find the current ECM code and revision number in the ECM.
  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History Database for applicable changes related to this fault code.
  • Refer to ECM Calibration Revision History Database.

If all steps have been completed and no root cause has been identified, then follow the technical escalation process.

Table Of Contents

Last Modified: 28-Nov-2021


INDEX
189-fc111.htm

189-t06-111.htm

189-fc115.htm

189-t06-115.htm

189-fc122.htm

189-t06-122.htm

189-fc123.htm

189-t06-123.htm

189-fc124.htm

189-t06-124.htm

189-fc125.htm

189-t06-125.htm

189-fc131.htm

189-t06-131.htm

189-fc132.htm

189-t06-132.htm

189-fc133.htm

189-t06-133.htm

189-fc134.htm

189-t06-134.htm

189-fc135.htm

189-t06-135.htm

189-fc141.htm

189-t06-141.htm

189-fc143.htm

189-t06-143.htm

189-fc144.htm

189-t06-144.htm

189-fc145.htm

189-t06-145.htm

189-fc146.htm

189-t06-146.htm

189-fc151.htm

189-t06-151.htm

189-fc153.htm

189-t06-153.htm

189-fc154.htm

189-t06-154.htm

189-fc155.htm

189-t06-155.htm

189-fc175.htm

189-t06-175.htm

189-fc176.htm

189-t06-176.htm

189-fc177.htm

189-t06-177.htm

189-fc187.htm

189-t06-187.htm

189-fc195.htm

189-t06-195.htm

189-fc196.htm

189-t06-196.htm

189-fc197.htm

189-t06-197.htm

189-fc212.htm

189-t06-212.htm

189-fc213.htm

189-t06-213.htm

189-fc214.htm

189-t06-214.htm

189-fc221.htm

189-t06-221.htm

189-fc222.htm

189-t06-222.htm

189-fc227.htm

189-t06-227.htm

189-fc234.htm

189-t06-234.htm

189-fc235.htm

189-t06-235.htm

189-fc238.htm

189-t06-238.htm

189-fc239.htm

189-t06-239.htm

189-fc241.htm

189-t06-241.htm

189-fc242.htm

189-t06-242.htm

189-fc245.htm

189-t06-245.htm

189-fc249.htm

189-t06-249.htm

189-fc256.htm

189-t06-256.htm

189-fc271.htm

189-t06-271.htm

189-fc272.htm

189-t06-272.htm

189-fc285.htm

189-t06-285.htm

189-fc286.htm

189-t06-286.htm

189-fc288.htm

189-t06-288.htm

189-fc295.htm

189-t06-295.htm

189-fc322.htm

189-t06-322.htm

189-fc323.htm

189-t06-323.htm

189-fc324.htm

189-t06-324.htm

189-fc325.htm

189-t06-325.htm

189-fc331.htm

189-t06-331.htm

189-fc332.htm

189-t06-332.htm

189-fc334.htm

189-t06-334.htm

189-fc338.htm

189-t06-338.htm

189-fc339.htm

189-t06-339.htm

189-fc343.htm

189-t06-343.htm

189-fc346.htm

189-t06-346.htm

189-fc351.htm

189-t06-351.htm

189-fc352.htm

189-t06-352.htm

189-fc386.htm

189-t06-386.htm

189-fc415.htm

189-t06-415.htm

189-fc418.htm

189-t06-418.htm

189-fc421.htm

189-t06-421.htm

189-fc425.htm

189-t06-425.htm

189-fc427.htm

189-t06-427.htm

189-fc428.htm

189-t06-428.htm

189-fc429.htm

189-t06-429.htm

189-fc435.htm

189-t06-435.htm

189-fc436.htm

189-t06-436.htm

189-fc441.htm

189-t06-441.htm

189-fc442.htm

189-t06-442.htm

189-fc451.htm

189-t06-451.htm

189-fc452.htm

189-t06-452.htm

189-fc483.htm

189-t06-483.htm

189-fc484.htm

189-t06-484.htm

189-fc488.htm

189-t06-488.htm

189-fc515.htm

189-t06-515.htm

189-fc516.htm

189-t06-516.htm

189-fc553.htm

189-t06-553.htm

189-fc555.htm

189-t06-555.htm

189-fc556.htm

189-t06-556.htm

189-fc559.htm

189-t06-559.htm

189-fc584.htm

189-t06-584.htm

189-fc585.htm

189-t06-585.htm

189-fc595.htm

189-t06-595.htm

189-fc596.htm

189-t06-596.htm

189-fc597.htm

189-t06-597.htm

189-fc629.htm

189-t06-629.htm

189-fc649.htm

189-t06-649.htm

189-fc687.htm

189-t06-687.htm

189-fc689.htm

189-t06-689.htm

189-fc691.htm

189-t06-691.htm

189-fc692.htm

189-t06-692.htm

189-fc693.htm

189-t06-693.htm

189-fc731.htm

189-t06-731.htm

189-fc755.htm

189-t06-755.htm

189-fc778.htm

189-t06-778.htm

189-fc779.htm

189-t06-779.htm

189-fc784.htm

189-t06-784.htm

189-fc1117.htm

189-t06-1117.htm

189-fc1139.htm

189-t06-1139.htm

189-fc1141.htm

189-t06-1141.htm

189-fc1142.htm

189-t06-1142.htm

189-fc1143.htm

189-t06-1143.htm

189-fc1144.htm

189-t06-1144.htm

189-fc1145.htm

189-t06-1145.htm

189-fc1228.htm

189-t06-1228.htm

189-fc1239.htm

189-t06-1239.htm

189-fc1241.htm

189-t06-1241.htm

189-fc1242.htm

189-t06-1242.htm

189-fc1361.htm

189-t06-1361.htm

189-fc1515.htm

189-t06-1515.htm

189-fc1595.htm

189-t06-1595.htm

189-fc1654.htm

189-t06-1654.htm

189-fc1655.htm

189-t06-1655.htm

189-fc1656.htm

189-t06-1656.htm

189-fc1657.htm

189-t06-1657.htm

189-fc1658.htm

189-t06-1658.htm

189-fc1659.htm

189-t06-1659.htm

189-fc1664.htm

189-t06-1664.htm

189-fc1668.htm

189-t06-1668.htm

189-fc1669.htm

189-t06-1669.htm

189-fc1673.htm

189-t06-1673.htm

189-fc1677.htm

189-t06-1677.htm

189-fc1678.htm

189-t06-1678.htm

189-fc1679.htm

189-t06-1679.htm

189-fc1682.htm

189-t06-1682.htm

189-fc1683.htm

189-t06-1683.htm

189-fc1684.htm

189-t06-1684.htm

189-fc1685.htm

189-t06-1685.htm

189-fc1686.htm

189-t06-1686.htm

189-fc1691.htm

189-t06-1691.htm

189-fc1694.htm

189-t06-1694.htm

189-fc1695.htm

189-t06-1695.htm

189-fc1696.htm

189-t06-1696.htm

189-fc1712.htm

189-t06-1712.htm

189-fc1713.htm

189-t06-1713.htm

189-fc1714.htm

189-t06-1714.htm

189-fc1715.htm

189-t06-1715.htm

189-fc1718.htm

189-t06-1718.htm

189-fc1843.htm

189-t06-1843.htm

189-fc1844.htm

189-t06-1844.htm

189-fc1845.htm

189-t06-1845.htm

189-fc1846.htm

189-t06-1846.htm

189-fc1852.htm

189-t06-1852.htm

189-fc1866.htm

189-t06-1866.htm

189-fc1867.htm

189-t06-1867.htm

189-fc1879.htm

189-t06-1879.htm

189-fc1881.htm

189-t06-1881.htm

189-fc1883.htm

189-t06-1883.htm

189-fc1885.htm

189-t06-1885.htm

189-fc1887.htm

189-t06-1887.htm

189-fc1894.htm

189-t06-1894.htm

189-fc1896.htm

189-t06-1896.htm

189-fc1897.htm

189-t06-1897.htm

189-fc1898.htm

189-t06-1898.htm

189-fc1921.htm

189-t06-1921.htm

189-fc1922.htm

189-t06-1922.htm

189-fc1923.htm

189-t06-1923.htm

189-fc1924.htm

189-t06-1924.htm

189-fc1925.htm

189-t06-1925.htm

189-fc1926.htm

189-t06-1926.htm

189-fc1927.htm

189-t06-1927.htm

189-fc1928.htm

189-t06-1928.htm

189-fc1932.htm

189-t06-1932.htm

189-fc1938.htm

189-t06-1938.htm

189-fc1942.htm

189-t06-1942.htm

189-fc1943.htm

189-t06-1943.htm

189-fc1961.htm

189-t06-1961.htm

189-fc1962.htm

189-t06-1962.htm

189-fc1963.htm

189-t06-1963.htm

189-fc1974.htm

189-t06-1974.htm

189-fc1976.htm

189-t06-1976.htm

189-fc1977.htm

189-t06-1977.htm

189-fc1981.htm

189-t06-1981.htm

189-fc2182.htm

189-t06-2182.htm

189-fc2183.htm

189-t06-2183.htm

189-fc2185.htm

189-t06-2185.htm

189-fc2186.htm

189-t06-2186.htm

189-fc2191.htm

189-t06-2191.htm

189-fc2198.htm

189-t06-2198.htm

189-fc2222.htm

189-t06-2222.htm

189-fc2223.htm

189-t06-2223.htm

189-fc2265.htm

189-t06-2265.htm

189-fc2266.htm

189-t06-2266.htm

189-fc2272.htm

189-t06-2272.htm

189-fc2273.htm

189-t06-2273.htm

189-fc2274.htm

189-t06-2274.htm

189-fc2288.htm

189-t06-2288.htm

189-fc2311.htm

189-t06-2311.htm

189-fc2321.htm

189-t06-2321.htm

189-fc2322.htm

189-t06-2322.htm

189-fc2343.htm

189-t06-2343.htm

189-fc2346.htm

189-t06-2346.htm

189-fc2347.htm

189-t06-2347.htm

189-fc2349.htm

189-t06-2349.htm

189-fc2353.htm

189-t06-2353.htm

189-fc2363.htm

189-t06-2363.htm

189-fc2367.htm

189-t06-2367.htm

189-fc2372.htm

189-t06-2372.htm

189-fc2373.htm

189-t06-2373.htm

189-fc2374.htm

189-t06-2374.htm

189-fc2375.htm

189-t06-2375.htm

189-fc2376.htm

189-t06-2376.htm

189-fc2377.htm

189-t06-2377.htm

189-fc2387.htm

189-t06-2387.htm

189-fc2398.htm

189-t06-2398.htm

189-fc2416.htm

189-t06-2416.htm

189-fc2448.htm

189-t06-2448.htm

189-fc2449.htm

189-t06-2449.htm

189-fc2451.htm

189-t06-2451.htm

189-fc2468.htm

189-t06-2468.htm

189-fc2554.htm

189-t06-2554.htm

189-fc2634.htm

189-t06-2634.htm

189-fc2636.htm

189-t06-2636.htm

189-fc2637.htm

189-t06-2637.htm

189-fc2638.htm

189-t06-2638.htm

189-fc2639.htm

189-t06-2639.htm

189-fc2646.htm

189-t06-2646.htm

189-fc2692.htm

189-t06-2692.htm

189-fc2718.htm

189-t06-2718.htm

189-fc2738.htm

189-t06-2738.htm

189-fc2739.htm

189-t06-2739.htm

189-fc2754.htm

189-t06-2754.htm

189-fc2764.htm

189-t06-2764.htm

189-fc2771.htm

189-t06-2771.htm

189-fc2777.htm

189-t06-2777.htm

189-fc2789.htm

189-t06-2789.htm

189-fc2881.htm

189-t06-2881.htm

189-fc2961.htm

189-t06-2961.htm

189-fc2962.htm

189-t06-2962.htm

189-fc2963.htm

189-t06-2963.htm

189-fc2964.htm

189-t06-2964.htm

189-fc2973.htm

189-t06-2973.htm

189-fc2976.htm

189-t06-2976.htm

189-fc3133.htm

189-t06-3133.htm

189-fc3134.htm

189-t06-3134.htm

189-fc3135.htm

189-t06-3135.htm

189-fc3136.htm

189-t06-3136.htm

189-fc3137.htm

189-t06-3137.htm

189-fc3138.htm

189-t06-3138.htm

189-fc3139.htm

189-t06-3139.htm

189-fc3141.htm

189-t06-3141.htm

189-fc3142.htm

189-t06-3142.htm

189-fc3146.htm

189-t06-3146.htm

189-fc3147.htm

189-t06-3147.htm

189-fc3148.htm

189-t06-3148.htm

189-fc3151.htm

189-t06-3151.htm

189-fc3165.htm

189-t06-3165.htm

189-fc3167.htm

189-t06-3167.htm

189-fc3168.htm

189-t06-3168.htm

189-fc3223.htm

189-t06-3223.htm

189-fc3224.htm

189-t06-3224.htm

189-fc3225.htm

189-t06-3225.htm

189-fc3228.htm

189-t06-3228.htm

189-fc3232.htm

189-t06-3232.htm

189-fc3235.htm

189-t06-3235.htm

189-fc3237.htm

189-t06-3237.htm

189-fc3238.htm

189-t06-3238.htm

189-fc3239.htm

189-t06-3239.htm

189-fc3241.htm

189-t06-3241.htm

189-fc3242.htm

189-t06-3242.htm

189-fc3243.htm

189-t06-3243.htm

189-fc3245.htm

189-t06-3245.htm

189-fc3251.htm

189-t06-3251.htm

189-fc3253.htm

189-t06-3253.htm

189-fc3254.htm

189-t06-3254.htm

189-fc3255.htm

189-t06-3255.htm

189-fc3256.htm

189-t06-3256.htm

189-fc3258.htm

189-t06-3258.htm

189-fc3261.htm

189-t06-3261.htm

189-fc3311.htm

189-t06-3311.htm

189-fc3312.htm

189-t06-3312.htm

189-fc3313.htm

189-t06-3313.htm

189-fc3314.htm

189-t06-3314.htm

189-fc3315.htm

189-t06-3315.htm

189-fc3316.htm

189-t06-3316.htm

189-fc3317.htm

189-t06-3317.htm

189-fc3318.htm

189-t06-3318.htm

189-fc3319.htm

189-t06-3319.htm

189-fc3321.htm

189-t06-3321.htm

189-fc3322.htm

189-t06-3322.htm

189-fc3326.htm

189-t06-3326.htm

189-fc3328.htm

189-t06-3328.htm

189-fc3338.htm

189-t06-3338.htm

189-fc3342.htm

189-t06-3342.htm

189-fc3343.htm

189-t06-3343.htm

189-fc3348.htm

189-t06-3348.htm

189-fc3361.htm

189-t06-3361.htm

189-fc3366.htm

189-t06-3366.htm

189-fc3374.htm

189-t06-3374.htm

189-fc3375.htm

189-t06-3375.htm

189-fc3376.htm

189-t06-3376.htm

189-fc3382.htm

189-t06-3382.htm

189-fc3383.htm

189-t06-3383.htm

189-fc3385.htm

189-t06-3385.htm

189-fc3396.htm

189-t06-3396.htm

189-fc3418.htm

189-t06-3418.htm

189-fc3422.htm

189-t06-3422.htm

189-fc3423.htm

189-t06-3423.htm

189-fc3425.htm

189-t06-3425.htm

189-fc3446.htm

189-t06-3446.htm

189-fc3488.htm

189-t06-3488.htm

189-fc3492.htm

189-t06-3492.htm

189-fc3497.htm

189-t06-3497.htm

189-fc3498.htm

189-t06-3498.htm

189-fc3525.htm

189-t06-3525.htm

189-fc3526.htm

189-t06-3526.htm

189-fc3527.htm

189-t06-3527.htm

189-fc3528.htm

189-t06-3528.htm

189-fc3539.htm

189-t06-3539.htm

189-fc3541.htm

189-t06-3541.htm

189-fc3542.htm

189-t06-3542.htm

189-fc3543.htm

189-t06-3543.htm

189-fc3545.htm

189-t06-3545.htm

189-fc3547.htm

189-t06-3547.htm

189-fc3558.htm

189-t06-3558.htm

189-fc3559.htm

189-t06-3559.htm

189-fc3562.htm

189-t06-3562.htm

189-fc3563.htm

189-t06-3563.htm

189-fc3567.htm

189-t06-3567.htm

189-fc3568.htm

189-t06-3568.htm

189-fc3571.htm

189-t06-3571.htm

189-fc3572.htm

189-t06-3572.htm

189-fc3574.htm

189-t06-3574.htm

189-fc3575.htm

189-t06-3575.htm

189-fc3577.htm

189-t06-3577.htm

189-fc3578.htm

189-t06-3578.htm

189-fc3582.htm

189-t06-3582.htm

189-fc3583.htm

189-t06-3583.htm

189-fc3596.htm

189-t06-3596.htm

189-fc3649.htm

189-t06-3649.htm

189-fc3681.htm

189-t06-3681.htm

189-fc3682.htm

189-t06-3682.htm

189-fc3697.htm

189-t06-3697.htm

189-fc3712.htm

189-t06-3712.htm

189-fc3714.htm

189-t06-3714.htm

189-fc3715.htm

189-t06-3715.htm

189-fc3716.htm

189-t06-3716.htm

189-fc3724.htm

189-t06-3724.htm

189-fc3725.htm

189-t06-3725.htm

189-fc3727.htm

189-t06-3727.htm

189-fc3733.htm

189-t06-3733.htm

189-fc3734.htm

189-t06-3734.htm

189-fc3737.htm

189-t06-3737.htm

189-fc3741.htm

189-t06-3741.htm

189-fc3748.htm

189-t06-3748.htm

189-fc3749.htm

189-t06-3749.htm

189-fc3843.htm

189-t06-3843.htm

189-fc3844.htm

189-t06-3844.htm

189-fc3845.htm

189-t06-3845.htm

189-fc3867.htm

189-t06-3867.htm

189-fc3868.htm

189-t06-3868.htm

189-fc3878.htm

189-t06-3878.htm

189-fc3899.htm

189-t06-3899.htm

189-fc3911.htm

189-t06-3911.htm

189-fc3912.htm

189-t06-3912.htm

189-fc3932.htm

189-t06-3932.htm

189-fc3933.htm

189-t06-3933.htm

189-fc3934.htm

189-t06-3934.htm

189-fc3935.htm

189-t06-3935.htm

189-fc3936.htm

189-t06-3936.htm

189-fc3937.htm

189-t06-3937.htm

189-fc4143.htm

189-t06-4143.htm

189-fc4144.htm

189-t06-4144.htm

189-fc4149.htm

189-t06-4149.htm

189-fc4151.htm

189-t06-4151.htm

189-fc4152.htm

189-t06-4152.htm

189-fc4153.htm

189-t06-4153.htm

189-fc4154.htm

189-t06-4154.htm

189-fc4155.htm

189-t06-4155.htm

189-fc4156.htm

189-t06-4156.htm

189-fc4157.htm

189-t06-4157.htm

189-fc4158.htm

189-t06-4158.htm

189-fc4159.htm

189-t06-4159.htm

189-fc4161.htm

189-t06-4161.htm

189-fc4162.htm

189-t06-4162.htm

189-fc4163.htm

189-t06-4163.htm

189-fc4164.htm

189-t06-4164.htm

189-fc4165.htm

189-t06-4165.htm

189-fc4166.htm

189-t06-4166.htm

189-fc4168.htm

189-t06-4168.htm

189-fc4169.htm

189-t06-4169.htm

189-fc4171.htm

189-t06-4171.htm

189-fc4213.htm

189-t06-4213.htm

189-fc4215.htm

189-t06-4215.htm

189-fc4233.htm

189-t06-4233.htm

189-fc4234.htm

189-t06-4234.htm

189-fc4243.htm

189-t06-4243.htm

189-fc4244.htm

189-t06-4244.htm

189-fc4245.htm

189-t06-4245.htm

189-fc4249.htm

189-t06-4249.htm

189-fc4251.htm

189-t06-4251.htm

189-fc4259.htm

189-t06-4259.htm

189-fc4261.htm

189-t06-4261.htm

189-fc4277.htm

189-t06-4277.htm

189-fc4281.htm

189-t06-4281.htm

189-fc4289.htm

189-t06-4289.htm

189-fc4293.htm

189-t06-4293.htm

189-fc4294.htm

189-t06-4294.htm

189-fc4449.htm

189-t06-4449.htm

189-fc4453.htm

189-t06-4453.htm

189-fc4484.htm

189-t06-4484.htm

189-fc4517.htm

189-t06-4517.htm

189-fc4518.htm

189-t06-4518.htm

189-fc4519.htm

189-t06-4519.htm

189-fc4521.htm

189-t06-4521.htm

189-fc4524.htm

189-t06-4524.htm

189-fc4525.htm

189-t06-4525.htm

189-fc4526.htm

189-t06-4526.htm

189-fc4568.htm

189-t06-4568.htm

189-fc4572.htm

189-t06-4572.htm

189-fc4584.htm

189-t06-4584.htm

189-fc4585.htm

189-t06-4585.htm

189-fc4612.htm

189-t06-4612.htm

189-fc4616.htm

189-t06-4616.htm

189-fc4658.htm

189-t06-4658.htm

189-fc4677.htm

189-t06-4677.htm

189-fc4691.htm

189-t06-4691.htm

189-fc4726.htm

189-t06-4726.htm

189-fc4727.htm

189-t06-4727.htm

189-fc4728.htm

189-t06-4728.htm

189-fc4731.htm

189-t06-4731.htm

189-fc4732.htm

189-t06-4732.htm

189-fc4739.htm

189-t06-4739.htm

189-fc4745.htm

189-t06-4745.htm

189-fc4747.htm

189-t06-4747.htm

189-fc4748.htm

189-t06-4748.htm

189-fc4749.htm

189-t06-4749.htm

189-fc4751.htm

189-t06-4751.htm

189-fc4768.htm

189-t06-4768.htm

189-fc4769.htm

189-t06-4769.htm

189-fc4839.htm

189-t06-4839.htm

189-fc4842.htm

189-t06-4842.htm

189-fc4951.htm

189-t06-4951.htm

189-fc4952.htm

189-t06-4952.htm

189-fc5259.htm

189-t06-5259.htm

189-fc5278.htm

189-t06-5278.htm

189-fc5297.htm

189-t06-5297.htm

189-fc5298.htm

189-t06-5298.htm

189-fc5383.htm

189-t06-5383.htm

189-fc5577.htm

189-t06-5577.htm

189-fc5578.htm

189-t06-5578.htm

189-fc5579.htm

189-t06-5579.htm

189-fc5581.htm

189-t06-5581.htm

189-fc5582.htm

189-t06-5582.htm

189-fc5583.htm

189-t06-5583.htm

189-fc5584.htm

189-t06-5584.htm

189-fc5655.htm

189-t06-5655.htm

189-fc5689.htm

189-t06-5689.htm

189-fc5715.htm

189-t06-5715.htm

189-fc5716.htm

189-t06-5716.htm

189-fc5792.htm

189-t06-5792.htm

189-fc5793.htm

189-t06-5793.htm

189-fc5837.htm

189-t06-5837.htm

189-fc5868.htm

189-t06-5868.htm

189-fc5879.htm

189-t06-5879.htm

189-fc5881.htm

189-t06-5881.htm

189-fc5882.htm

189-t06-5882.htm

189-fc6244.htm

189-t06-6244.htm

189-fc6254.htm

189-t06-6254.htm

189-fc6255.htm

189-t06-6255.htm

189-fc6256.htm

189-t06-6256.htm

189-fc6257.htm

189-t06-6257.htm

189-fc6258.htm

189-t06-6258.htm

189-fc6259.htm

189-t06-6259.htm

189-fc6261.htm

189-t06-6261.htm

189-fc6262.htm

189-t06-6262.htm

189-fc6263.htm

189-t06-6263.htm

189-fc6264.htm

189-t06-6264.htm

189-fc6265.htm

189-t06-6265.htm

189-fc6266.htm

189-t06-6266.htm

189-fc6267.htm

189-t06-6267.htm

189-fc6268.htm

189-t06-6268.htm

189-fc6336.htm

189-t06-6336.htm

189-fc6337.htm

189-t06-6337.htm

189-fc6339.htm

189-t06-6339.htm

189-fc6341.htm

189-t06-6341.htm

189-fc6342.htm

189-t06-6342.htm

189-fc6343.htm

189-t06-6343.htm

189-fc6416.htm

189-t06-6416.htm

189-fc6417.htm

189-t06-6417.htm

189-fc6418.htm

189-t06-6418.htm

189-fc6419.htm

189-t06-6419.htm

189-fc6421.htm

189-t06-6421.htm

189-fc6422.htm

189-t06-6422.htm

189-fc6432.htm

189-t06-6432.htm

189-fc6575.htm

189-t06-6575.htm

189-fc6595.htm

189-t06-6595.htm

189-fc6613.htm

189-t06-6613.htm

189-fc6637.htm

189-t06-6637.htm

189-fc6642.htm

189-t06-6642.htm

189-fc6643.htm

189-t06-6643.htm

189-fc6644.htm

189-t06-6644.htm

189-fc6645.htm

189-t06-6645.htm

189-fc6646.htm

189-t06-6646.htm

189-fc6647.htm

189-t06-6647.htm

189-fc6648.htm

189-t06-6648.htm

189-fc6649.htm

189-t06-6649.htm

189-fc6651.htm

189-t06-6651.htm

189-fc6652.htm

189-t06-6652.htm

189-fc6653.htm

189-t06-6653.htm

189-fc6656.htm

189-t06-6656.htm

189-fc6688.htm

189-t06-6688.htm

189-fc6725.htm

189-t06-6725.htm

189-fc6735.htm

189-t06-6735.htm

189-fc6753.htm

189-t06-6753.htm

189-fc6864.htm

189-t06-6864.htm

189-fc6919.htm

189-t06-6919.htm

189-fc7286.htm

189-t06-7286.htm